Crazy Eddies GUI System: File Index

  • Main Page
  • Namespaces
  • Classes
  • Files
  • Directories
  • Related Pages

Crazy Eddies GUI System File List

Here is a list of all documented files with brief descriptions:
CEGUI.h [code]
CEGUIBase.h [code]
CEGUIButtonBase.h [code]
CEGUIButtonBaseProperties.h [code]
CEGUICheckbox.h [code]
CEGUICheckboxProperties.h [code]
CEGUIcolour.h [code]
CEGUIColourRect.h [code]
CEGUICombobox.h [code]
CEGUIComboboxProperties.h [code]
CEGUIComboDropList.h [code]
CEGUIConfig.h [code]
CEGUIConfig_xmlHandler.h [code]
CEGUIDataContainer.h [code]
CEGUIDefaultResourceProvider.h [code]
CEGUIDragContainer.h [code]
CEGUIDragContainerProperties.h [code]
CEGUIEditbox.h [code]
CEGUIEditboxProperties.h [code]
CEGUIEvent.h [code]
CEGUIEventArgs.h [code]
CEGUIEventSet.h [code]
CEGUIExceptions.h [code]
CEGUIFactoryModule.h [code]
CEGUIFalagard_xmlHandler.h [code]
CEGUIFalComponentBase.h [code]
CEGUIFalDimensions.h [code]
CEGUIFalEnums.h [code]
CEGUIFalFrameComponent.h [code]
CEGUIFalImageryComponent.h [code]
CEGUIFalImagerySection.h [code]
CEGUIFalLayerSpecification.h [code]
CEGUIFalNamedArea.h [code]
CEGUIFalPropertyDefinition.h [code]
CEGUIFalPropertyInitialiser.h [code]
CEGUIFalSectionSpecification.h [code]
CEGUIFalStateImagery.h [code]
CEGUIFalTextComponent.h [code]
CEGUIFalWidgetComponent.h [code]
CEGUIFalWidgetLookFeel.h [code]
CEGUIFalWidgetLookManager.h [code]
CEGUIFalXMLEnumHelper.h [code]
CEGUIFont.h [code]
CEGUIFont_implData.h [code]
CEGUIFont_xmlHandler.h [code]
CEGUIFontManager.h [code]
CEGUIFontManager_implData.h [code]
CEGUIForwardRefs.h [code]
CEGUIFrameWindow.h [code]
CEGUIFrameWindowProperties.h [code]
CEGUIGlobalEventSet.h [code]
CEGUIGUILayout_xmlHandler.h [code]
CEGUIGUISheet.h [code]
CEGUIImage.h [code]
CEGUIImageset.h [code]
CEGUIImageset_xmlHandler.h [code]
CEGUIImagesetManager.h [code]
CEGUIInputEvent.h [code]
CEGUIItemEntry.h [code]
CEGUIItemListBase.h [code]
CEGUIItemListBaseProperties.h [code]
CEGUIIteratorBase.h [code]
CEGUIListbox.h [code]
CEGUIListboxItem.h [code]
CEGUIListboxProperties.h [code]
CEGUIListboxTextItem.h [code]
CEGUIListHeader.h [code]
CEGUIListHeaderProperties.h [code]
CEGUIListHeaderSegment.h [code]
CEGUIListHeaderSegmentProperties.h [code]
CEGUILogger.h [code]
CEGUIMenubar.h [code]
CEGUIMenuBase.h [code]
CEGUIMenuBaseProperties.h [code]
CEGUIMenuItem.h [code]
CEGUIMenuItemProperties.h [code]
CEGUIMouseCursor.h [code]
CEGUIMultiColumnList.h [code]
CEGUIMultiColumnListProperties.h [code]
CEGUIMultiLineEditbox.h [code]
CEGUIMultiLineEditboxProperties.h [code]
CEGUIPopupMenu.h [code]
CEGUIPopupMenuProperties.h [code]
CEGUIProgressBar.h [code]
CEGUIProgressBarProperties.h [code]
CEGUIProperty.h [code]
CEGUIPropertyHelper.h [code]
CEGUIPropertySet.h [code]
CEGUIPushButton.h [code]
CEGUIPushButtonProperties.h [code]
CEGUIRadioButton.h [code]
CEGUIRadioButtonProperties.h [code]
CEGUIRect.h [code]
CEGUIRefPtr.h [code]
CEGUIRenderableElement.h [code]
CEGUIRenderableFrame.h [code]
CEGUIRenderableImage.h [code]
CEGUIRenderCache.h [code]
CEGUIRenderer.h [code]
CEGUIResourceProvider.h [code]
CEGUIScheme.h [code]
CEGUIScheme_xmlHandler.h [code]
CEGUISchemeManager.h [code]
CEGUIScriptModule.h [code]
CEGUIScrollablePane.h [code]
CEGUIScrollablePaneProperties.h [code]
CEGUIScrollbar.h [code]
CEGUIScrollbarProperties.h [code]
CEGUIScrolledContainer.h [code]
CEGUIScrolledContainerProperties.h [code]
CEGUISingleton.h [code]
CEGUISize.h [code]
CEGUISlider.h [code]
CEGUISliderProperties.h [code]
CEGUISpinner.h [code]
CEGUISpinnerProperties.h [code]
CEGUIStatic.h [code]
CEGUIStaticImage.h [code]
CEGUIStaticImageProperties.h [code]
CEGUIStaticProperties.h [code]
CEGUIStaticText.h [code]
CEGUIStaticTextProperties.h [code]
CEGUIString.h [code]
CEGUISystem.h [code]
CEGUITabButton.h [code]
CEGUITabControl.h [code]
CEGUITabControlProperties.h [code]
CEGUITabPane.h [code]
CEGUITextItem.h [code]
CEGUITextItemProperties.h [code]
CEGUITexture.h [code]
CEGUITextUtils.h [code]
CEGUIThumb.h [code]
CEGUIThumbProperties.h [code]
CEGUITinyXMLParser.h [code]
CEGUITitlebar.h [code]
CEGUITitlebarProperties.h [code]
CEGUITooltip.h [code]
CEGUITooltipProperties.h [code]
CEGUIUDim.h [code]
CEGUIVector.h [code]
CEGUIVersion.h [code]
CEGUIWindow.h [code]
CEGUIWindowFactory.h [code]
CEGUIWindowFactoryManager.h [code]
CEGUIWindowManager.h [code]
CEGUIWindowProperties.h [code]
CEGUIXercesParser.h [code]
CEGUIXMLAttributes.h [code]
CEGUIXMLHandler.h [code]
CEGUIXMLParser.h [code]
d3d9renderer.h [code]
d3d9texture.h [code]
internal.h [code]
IrrlichtEventPusher.h [code]
irrlichtrenderer.h [code]
IrrlichtRendererDef.h [code]
IrrlichtResourceProvider.h [code]
irrlichttexture.h [code]
macPlugins.h [code]
openglrenderer.h [code]
opengltexture.h [code]
pcre.h [code]
pcreconfig.h [code]
pcreposix.h [code]
renderer.h [code]
texture.h [code]
tinystr.h [code]
tinyxml.h [code]
ucp.h [code]
ucpinternal.h [code]
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class List

  • Files
  • Directories
  • Related Pages
  • Class List
  • Alphabetical List
  • Class Hierarchy
  • Class Members

Crazy Eddies GUI System Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
CEGUI::_freeBinder< Ret, Args > | This class binds a free function
CEGUI::_functorBinder< Functor, Ret, Args > | This class binds a copy of a functor
CEGUI::_memberBinder< T, Ret, Args > | This class binds a member function along with a target object
CEGUI::_refBinder< Functor, Ret, Args > | This class binds a const reference to a generalized functor. Sometimes it may not be appropriate for the functor to be cloned. In which case, use SubscriberRef() (which uses this)
CEGUI::AbsoluteDim | Dimension type that represents an absolute pixel value. Implements BaseDim interface
CEGUI::WindowProperties::AbsoluteHeight | Property to access window height
CEGUI::WindowProperties::AbsoluteMaxSize | Property to access maximum window size
CEGUI::WindowProperties::AbsoluteMinSize | Property to access minimum window size
CEGUI::WindowProperties::AbsolutePosition | Property to access window position
CEGUI::WindowProperties::AbsoluteRect | Property to access window area rectangle
CEGUI::WindowProperties::AbsoluteSize | Property to access the window size
CEGUI::TabControlProperties::AbsoluteTabHeight | Property to access the absolute tab height setting of the tab control
CEGUI::TabControlProperties::AbsoluteTabTextPadding | Property to access the absolute tab text padding setting of the tab control
CEGUI::WindowProperties::AbsoluteWidth | Property to access window width
CEGUI::WindowProperties::AbsoluteXPosition | Property to access window X position
CEGUI::WindowProperties::AbsoluteYPosition | Property to access window Y position
CEGUI::ActivationEventArgs | EventArgs based class that is used for Activated and Deactivated window events
CEGUI::ComboboxProperties::ActiveEditSelectionColour | Property to access the colour used for rendering the selection highlight when the edit box is active
CEGUI::MultiLineEditboxProperties::ActiveSelectionColour | Property to access the colour used for rendering the selection highlight when the edit box is active
CEGUI::EditboxProperties::ActiveSelectionColour | Property to access the colour used for rendering the selection highlight when the edit box is active
CEGUI::MenuBaseProperties::AllowMultiplePopups | Property to access the state of the allow multiple popups setting
CEGUI::WindowProperties::Alpha | Property to access window alpha setting
CEGUI::AlreadyExistsException | Exception class used when an attempt is made to use an object name that is already in use within the system
CEGUI::WindowProperties::AlwaysOnTop | Property to access window "Always-On-Top" setting
CEGUI::WindowProperties::AutoRepeatDelay | Property to access window autorepeat delay value
CEGUI::WindowProperties::AutoRepeatRate | Property to access window autorepeat rate value
CEGUI::ItemListBaseProperties::AutoResizeEnabled | Property to access the state of the auto resize enabled setting
CEGUI::StaticProperties::BackgroundColours | Property to access the background colours for the Static widget
CEGUI::MenuBaseProperties::BackgroundColours | Property to access the background colours of the menu
CEGUI::StaticProperties::BackgroundEnabled | Property to access the state of the frame background setting for the Static widget
CEGUI::StaticProperties::BackgroundImage | Property to access the background image for the Static widget
CEGUI::BaseDim | Abstract interface for a generic 'dimension' class
CEGUI::MenuBaseProperties::BorderWidth | Property to access the border width of the menu
CEGUI::StaticProperties::BottomFrameImage | Property to access the bottom edge image for the frame of the Static widget
CEGUI::StaticProperties::BottomLeftFrameImage | Property to access the bottom-left image for the frame of the Static widget
CEGUI::StaticProperties::BottomRightFrameImage | Property to access the bottom-right image for the frame of the Static widget
CEGUI::ButtonBase | Base class for all the 'button' type widgets (push button, radio button, check-box, etc)
CEGUI::TitlebarProperties::CaptionColour | Property to colour used for rendering the caption text
CEGUI::FrameWindowProperties::CaptionColour | Property to colour used for rendering the caption text
CEGUI::MultiLineEditboxProperties::CaratIndex | Property to access the current carat index
CEGUI::ComboboxProperties::CaratIndex | Property to access the current carat index
CEGUI::EditboxProperties::CaratIndex | Property to access the current carat index
CEGUI::Checkbox | Base class providing logic for Check-box widgets
CEGUI::ScrolledContainerProperties::ChildExtentsArea | Property offering read-only access to the current content extents rectangle (as window relative pixels)
CEGUI::ListHeaderSegmentProperties::Clickable | Property to access the click-able setting of the header segment
CEGUI::SliderProperties::ClickStepSize | Property to access the click-step size for the slider
CEGUI::WindowProperties::ClippedByParent | Property to access window "clipped by parent" setting
CEGUI::FrameWindowProperties::CloseButtonEnabled | Property to access the setting for whether the window close button will be enabled (or displayed depending upon choice of final widget type)
CEGUI::colour | Class representing colour values within the system
CEGUI::ColourRect | Class that holds details of colours for the four corners of a rectangle
CEGUI::MultiColumnListProperties::ColumnHeader | Property to access a column
CEGUI::MultiColumnListProperties::ColumnsMovable | Property to access the setting for user moving of the column headers
CEGUI::ListHeaderProperties::ColumnsMovable | Property to access the setting for user moving of the column headers
CEGUI::MultiColumnListProperties::ColumnsSizable | Property to access the setting for user sizing of the column headers
CEGUI::ListHeaderProperties::ColumnsSizable | Property to access the setting for user sizing of the column headers
CEGUI::Combobox | Base class for the Combobox widget
CEGUI::ComboDropList | Base class for the combo box drop down list. This is a specialisation of the Listbox class
CEGUI::ComponentArea | Class that represents a target area for a widget or imagery component
CEGUI::Config_xmlHandler | Handler class used to parse the Configuration XML file
CEGUI::ConstBaseIterator< T > | Base class constant iterator used to offer iteration over various collections within the system
CEGUI::ScrollablePaneProperties::ContentArea | Property to access the current content pane area rectangle (as window relative pixels)
CEGUI::ScrolledContainerProperties::ContentArea | Property to access the current content pane area rectangle (as window relative pixels)
CEGUI::ScrollablePaneProperties::ContentPaneAutoSized | Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content
CEGUI::ScrolledContainerProperties::ContentPaneAutoSized | Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content
CEGUI::ProgressBarProperties::CurrentProgress | Property to access the current progress of the progress bar
CEGUI::SliderProperties::CurrentValue | Property to access the current value of the slider
CEGUI::SpinnerProperties::CurrentValue | Property to access the current value of the spinner
CEGUI::WindowProperties::CustomTooltipType | Property to access the custom tooltip for this Window
CEGUI::WindowProperties::DestroyedByParent | Property to access window Destroyed by Parent setting
CEGUI::Dimension | Class representing some kind of dimension
CEGUI::DirectX81Renderer | Renderer class to interface with Microsoft DirectX 8.1
CEGUI::DirectX81Texture | Texture class that is created by DirectX81Renderer objects
CEGUI::DirectX9Renderer | Renderer class to interface with Microsoft DirectX 9.0
CEGUI::DirectX9Texture | Texture class that is created by DirectX9Renderer objects
CEGUI::WindowProperties::Disabled | Property to access window Disabled setting
CEGUI::PushButtonProperties::DisabledImage | Property to access the disabled image of the button
CEGUI::MenuItemProperties::DisabledTextColour | Property to access the disabled text colour of the item
CEGUI::ButtonBaseProperties::DisabledTextColour | Property to access the disabled text colour
CEGUI::TooltipProperties::DisplayTime | Property to access the time after which the tooltip automatically de-activates itself
CEGUI::WindowProperties::DistributeCapturedInputs | Property to access whether inputs are passed to child windows when input is captured to this window
CEGUI::ScrollbarProperties::DocumentSize | Property to access the document size for the Scrollbar
CEGUI::ListHeaderSegmentProperties::Dragable | Property to access the drag-able setting of the header segment
CEGUI::DragContainerProperties::DragAlpha | Property to access the dragging alpha value
CEGUI::DragContainer | Generic drag & drop enabled window class
CEGUI::DragContainerFactory | Factory class for producing DragContainer windows
CEGUI::DragContainerProperties::DragCursorImage | Property to access the dragging mouse cursor setting
CEGUI::DragDropEventArgs | EventArgs based class used for certain drag/drop notifications
CEGUI::DragContainerProperties::DraggingEnabled | Property to access the state of the dragging enabled setting
CEGUI::TitlebarProperties::DraggingEnabled | Property to access the state of the dragging enabled setting for the Titlebar
CEGUI::FrameWindowProperties::DragMovingEnabled | Property to access the setting for whether the user may drag the window around by its title bar
CEGUI::DragContainerProperties::DragThreshold | Property to access the dragging threshold value
CEGUI::Editbox | Base class for an Editbox widget
CEGUI::ComboboxProperties::EditSelectionLength | Property to access the current selection length
CEGUI::ComboboxProperties::EditSelectionStart | Property to access the current selection start index
CEGUI::Event | Defines an 'event' which can be subscribed to by interested parties
CEGUI::Event::ConnectionInterface | Interface to be implemented by connection objects
CEGUI::Event::ScopedConnection | A Connection object that automatically disconnects from the event when the ScropedConnection object goes out of scope (and is deleted)
CEGUI::EventArgs | Base class used as the argument to all subscribers Event object
CEGUI::EventSet | Class that collects together a set of Event objects
CEGUI::FrameWindowProperties::EWSizingCursorImage | Property to access the E-W (left/right) sizing cursor image
CEGUI::Exception | Root exception class used within the GUI system
CEGUI::FactoryModule | Class that encapsulates access to a dynamic loadable module containing implementations of Windows, Widgets, and their factories
CEGUI::PopupMenuProperties::FadeInTime | Property to access the fade in time in seconds of the menu bar
CEGUI::PopupMenuProperties::FadeOutTime | Property to access the fade out time in seconds of the menu bar
CEGUI::TooltipProperties::FadeTime | Property to access the duration of the fade effect for the tooltip
CEGUI::Falagard_xmlHandler | Handler class used to parse look & feel XML files used by the Falagard system
CEGUI::FalagardComponentBase | Common base class used for renderable components within an ImagerySection
CEGUI::FalagardXMLHelper | Utility helper class primarily intended for use by the falagard xml parser
CEGUI::FileIOException | Exception class used when a file handling problem occurs
CEGUI::WindowProperties::Font | Property to access window Font setting
CEGUI::Font | Class that encapsulates text rendering functionality for a typeface
CEGUI::Font_xmlHandler | Handler class used to parse the Font XML files using SAX2
CEGUI::FontDim | Dimension type that represents some metric of a Font. Implements BaseDim interface
CEGUI::FontManager | Class providing a shared library of Font objects to the system
CEGUI::MultiColumnListProperties::ForceHorzScrollbar | Property to access the 'always show' setting for the horizontal scroll bar of the list box
CEGUI::ScrollablePaneProperties::ForceHorzScrollbar | Property to access the setting which controls whether the horizontal scroll bar will always be displayed, or only displayed when it is required
CEGUI::ComboboxProperties::ForceHorzScrollbar | Property to access the 'always show' setting for the horizontal scroll bar of the list box
CEGUI::ListboxProperties::ForceHorzScrollbar | Property to access the 'always show' setting for the horizontal scroll bar of the list box
CEGUI::MultiColumnListProperties::ForceVertScrollbar | Property to access the 'always show' setting for the vertical scroll bar of the list box
CEGUI::ScrollablePaneProperties::ForceVertScrollbar | Property to access the setting which controls whether the vertical scroll bar will always be displayed, or only displayed when it is required
CEGUI::ComboboxProperties::ForceVertScrollbar | Property to access the 'always show' setting for the vertical scroll bar of the list box
CEGUI::ListboxProperties::ForceVertScrollbar | Property to access the 'always show' setting for the vertical scroll bar of the list box
CEGUI::StaticProperties::FrameColours | Property to access the frame colours for the Static widget
CEGUI::FrameComponent | Class that encapsulates information for a frame with background (9 images in total)
CEGUI::StaticProperties::FrameEnabled | Property to access the state of the frame enabled setting for the Static widget
CEGUI::FrameWindowProperties::FrameEnabled | Property to access the setting for whether the window frame will be displayed
CEGUI::FrameWindow | Abstract base class for a movable, sizable, window with a title-bar and a frame
CEGUI::GenericException | Exception class used when none of the other classes are applicable
CEGUI::GlobalEventSet | The GlobalEventSet singleton allows you to subscribe to an event for all instances of a class. The GlobalEventSet effectively supports "late binding" to events; which means you can subscribe to some event that does not actually exist (yet)
CEGUI::RadioButtonProperties::GroupID | Property to access the radio button group ID
CEGUI::GUILayout_xmlHandler | Handler class used to parse the GUILayout XML files using SAX2
CEGUI::GUISheet | Window class intended to be used as a simple, generic Window
CEGUI::GUISheetFactory | Factory class for producing default windows
CEGUI::HeaderSequenceEventArgs | EventArgs class used for segment move (sequence changed) events
CEGUI::WindowProperties::Height | Property to access window height
CEGUI::WindowProperties::HorizontalAlignment | Property to access the horizontal alignment setting for the window
CEGUI::StaticImageProperties::HorzFormatting | Property to access the horizontal formatting mode setting
CEGUI::StaticTextProperties::HorzFormatting | Property to access the horizontal formatting mode setting
CEGUI::ThumbProperties::HorzFree | Property to access the state the setting to free the thumb horizontally
CEGUI::ScrollablePaneProperties::HorzOverlapSize | Property to access the overlap size for the horizontal Scrollbar
CEGUI::MenuBaseProperties::HorzPadding | Property to access the horz padding value of the menu
CEGUI::ThumbProperties::HorzRange | Property to access the horizontal movement range for the thumb
CEGUI::StaticTextProperties::HorzScrollbar | Property to access the setting for enabling the horizontal scroll bar
CEGUI::ScrollablePaneProperties::HorzScrollPosition | Property to access the scroll position of the horizontal Scrollbar
CEGUI::ScrollablePaneProperties::HorzStepSize | Property to access the step size for the horizontal Scrollbar
CEGUI::ThumbProperties::HotTracked | Property to access the state of the "hot-tracked" setting for the thumb
CEGUI::MenuItemProperties::HoverColour | Property to access the hover colour of the item
CEGUI::PushButtonProperties::HoverImage | Property to access the hover image of the button
CEGUI::ButtonBaseProperties::HoverTextColour | Property to access the hover / highlight text colour
CEGUI::TooltipProperties::HoverTime | Property to access the timout that must expire before the tooltip gets activated
CEGUI::WindowProperties::ID | Property to access window ID field
CEGUI::Image | Class that represents a single Image of an Imageset
CEGUI::StaticImageProperties::Image | Property to access the image for the StaticImage widget
CEGUI::StaticImageProperties::ImageColours | Property to access the image colours for the StaticImage widget
CEGUI::ImageDim | Dimension type that represents some dimension of a named Image. Implements BaseDim interface
CEGUI::ImageryComponent | Class that encapsulates information for a single image component
CEGUI::ImagerySection | Class that encapsulates a re-usable collection of imagery specifications
CEGUI::Imageset | Offers functions to define, access, and draw, a set of image components on a single graphical surface or Texture
CEGUI::Imageset_xmlHandler | Handler class used to parse the Imageset XML files using SAX2
CEGUI::ImagesetManager | Class providing a shared library of Imageset objects to the system
CEGUI::ComboboxProperties::InactiveEditSelectionColour | Property to access the colour used for rendering the selection highlight when the edit box is inactive
CEGUI::MultiLineEditboxProperties::InactiveSelectionColour | Property to access the colour used for rendering the selection highlight when the edit box is inactive
CEGUI::EditboxProperties::InactiveSelectionColour | Property to access the colour used for rendering the selection highlight when the edit box is inactive
CEGUI::WindowProperties::InheritsAlpha | Property to access window "Inherits Alpha" setting
CEGUI::WindowProperties::InheritsTooltipText | Property to access whether the window inherits its tooltip text from its parent whn it has no tooltip text of its own
CEGUI::InvalidRequestException | Exception class used when some impossible request was made for the current system state
CEGUI::IrrlichtRenderer | Class implementing the interface for Renderer objects with the irrlicht graphics engine
CEGUI::ItemEntry | Base class for item type widgets
CEGUI::ItemListBase | Base class for item list widgets
CEGUI::MenuBaseProperties::ItemSpacing | Property to access the item spacing of the menu
CEGUI::ListboxProperties::ItemTooltips | Property to access the show item tooltips setting of the list box
CEGUI::Key | Struct to give scope to scan code enumeration
CEGUI::KeyEventArgs | EventArgs based class that is used for objects passed to input event handlers concerning keyboard input
CEGUI::LayerSpecification | Class that encapsulates a single layer of imagery
CEGUI::StaticProperties::LeftFrameImage | Property to access the left edge image for the frame of the Static widget
CEGUI::Listbox | Base class for standard Listbox widget
CEGUI::ListboxItem | Base class for list box items
CEGUI::ListboxTextItem | Class used for textual items in a list box
CEGUI::ListHeader | Base class for the multi column list header widget
CEGUI::ListHeaderSegment | Base class for list header segment window
CEGUI::Logger | Class that implements logging for the GUI system
CEGUI::EditboxProperties::MaskCodepoint | Property to access the mask text setting of the edit box
CEGUI::EditboxProperties::MaskText | Property to access the mask text setting of the edit box
CEGUI::ComboboxProperties::MaxEditTextLength | Property to access the maximum text length for the edit box
CEGUI::SliderProperties::MaximumValue | Property to access the maximum value of the slider
CEGUI::SpinnerProperties::MaximumValue | Property to access the maximum value setting of the spinner
CEGUI::MultiLineEditboxProperties::MaxTextLength | Property to access the maximum text length for the edit box
CEGUI::EditboxProperties::MaxTextLength | Property to access the maximum text length for the edit box
CEGUI::MCLGridRef | Simple grid index structure
CEGUI::MemoryException | Exception class used when a memory handling error is detected
CEGUI::Menubar | Base class for menu bars
CEGUI::MenuBase | Abstract base class for menus
CEGUI::MenuItem | Base class for menu items
CEGUI::WindowProperties::MetricsMode | Property to access the metrics mode setting
CEGUI::SpinnerProperties::MinimumValue | Property to access the minimum value setting of the spinner
CEGUI::WindowProperties::MouseButtonDownAutoRepeat | Property to control whether the window will receive autorepeat mouse button down events
CEGUI::MouseClickTracker | Implementation structure used in tracking up & down mouse button inputs in order to generate click, double-click, and triple-click events
CEGUI::MouseCursor | Class that allows access to the GUI system mouse cursor
CEGUI::MouseCursorEventArgs | EventArgs based class that is used for objects passed to input event handlers concerning mouse cursor events
CEGUI::WindowProperties::MouseCursorImage | Property to access window mouse cursor setting
CEGUI::MouseEventArgs | EventArgs based class that is used for objects passed to input event handlers concerning mouse input
CEGUI::MultiColumnList | Base class for the multi column list widget
CEGUI::MultiColumnList::ListRow | Struct used internally to represent a row in the list and also to ease sorting of the rows
CEGUI::MultiLineEditbox | Base class for the multi-line edit box widget
CEGUI::MultiLineEditbox::LineInfo | Struct used to store information about a formatted line within the paragraph
CEGUI::ListboxProperties::MultiSelect | Property to access the multi-select setting of the list box
CEGUI::NamedArea | NamedArea defines an area for a component which may later be obtained and referenced by a name unique to the WidgetLook holding the NamedArea
CEGUI::FrameWindowProperties::NESWSizingCursorImage | Property to access the NE-SW diagonal sizing cursor image
CEGUI::MultiColumnListProperties::NominatedSelectionColumnID | Property to access the nominated selection column (via ID)
CEGUI::MultiColumnListProperties::NominatedSelectionRow | Property to access the nominated selection row
CEGUI::ComboboxProperties::NormalEditTextColour | Property to access the normal, unselected, text colour used for rendering text
CEGUI::PushButtonProperties::NormalImage | Property to access the normal image of the button
CEGUI::MenuItemProperties::NormalTextColour | Property to access the normal text colour of the item
CEGUI::MultiLineEditboxProperties::NormalTextColour | Property to access the normal, unselected, text colour used for rendering text
CEGUI::ButtonBaseProperties::NormalTextColour | Property to access the normal text colour
CEGUI::EditboxProperties::NormalTextColour | Property to access the normal, unselected, text colour used for rendering text
CEGUI::FrameWindowProperties::NSSizingCursorImage | Property to access the N-S (up-down) sizing cursor image
CEGUI::NullObjectException | Exception class used when some required object or parameter is null
CEGUI::FrameWindowProperties::NWSESizingCursorImage | Property to access the NW-SE diagonal sizing cursor image
CEGUI::ObjectInUseException | Exception class used when some attempt to delete, remove, or otherwise invalidate some object that is still in use occurs
CEGUI::MenuItemProperties::OpenedColour | Property to access the opened colour of the item
CEGUI::OpenGLRenderer | Renderer class to interface with OpenGL
CEGUI::OpenGLTexture | Texture class that is created by OpenGLRenderer objects
CEGUI::ScrollbarProperties::OverlapSize | Property to access the overlap size for the Scrollbar
CEGUI::ScrollbarProperties::PageSize | Property to access the page size for the Scrollbar
CEGUI::PopupMenu | Base class for popup menus
CEGUI::WindowProperties::Position | Property to access window position
CEGUI::ProgressBar | Base class for progress bars
CEGUI::Property | An abstract class that defines the interface to access object properties by name
CEGUI::PropertyDefinition | Class representing a new property to be available on all widgets that use the WidgetLook that this PropertyDefinition is defiend for
CEGUI::PropertyDim | Dimension type that represents the value of a Window property. Implements BaseDim interface
CEGUI::PropertyHelper | Helper class used to convert various data types to and from the format expected in Propery strings
CEGUI::PropertyInitialiser | Class that holds information about a property and it's required initial value
CEGUI::PropertyReceiver | Dummy base class to ensure correct casting of receivers
CEGUI::PropertySet | Class that contains a collection of Property objects
CEGUI::PushButton | Base class to provide logic for push button type widgets
CEGUI::MenuItemProperties::PushedColour | Property to access the pushed colour of the item
CEGUI::PushButtonProperties::PushedImage | Property to access the pushed image of the button
CEGUI::ButtonBaseProperties::PushedTextColour | Property to access the pushed text colour
CEGUI::RadioButton | Base class to provide the logic for Radio Button widgets
CEGUI::ComboboxProperties::ReadOnly | Property to access the read-only setting of the edit box
CEGUI::MultiLineEditboxProperties::ReadOnly | Property to access the read-only setting of the edit box
CEGUI::EditboxProperties::ReadOnly | Property to access the read-only setting of the edit box
CEGUI::WindowProperties::Rect | Property to access window area rectangle
CEGUI::Rect | Class encapsulating operations on a Rectangle
CEGUI::RegexValidator | Internal struct to contain compiled regex string
CEGUI::WindowProperties::RelativeHeight | Property to access window height
CEGUI::WindowProperties::RelativeMaxSize | Property to access maximum window size
CEGUI::WindowProperties::RelativeMinSize | Property to access minimum window size
CEGUI::WindowProperties::RelativePosition | Property to access window position
CEGUI::WindowProperties::RelativeRect | Property to access window area rectangle
CEGUI::WindowProperties::RelativeSize | Property to access the window size
CEGUI::TabControlProperties::RelativeTabHeight | Property to access the relative tab height setting of the tab control
CEGUI::TabControlProperties::RelativeTabTextPadding | Property to access the relative tab text padding setting of the tab control
CEGUI::WindowProperties::RelativeWidth | Property to access window width
CEGUI::WindowProperties::RelativeXPosition | Property to access window X position
CEGUI::WindowProperties::RelativeYPosition | Property to access window Y position
CEGUI::RenderableFrame | A higher order GUI entity that represents a renderable frame
CEGUI::RenderableImage | A higher order GUI entity that represents a renderable image with formatting options
CEGUI::RenderCache | Class that acts as a cache for images that need to be rendered
CEGUI::Renderer | Abstract class defining the interface for Renderer objects
CEGUI::RendererException | Exception class used when an problem is detected within the Renderer or related objects
CEGUI::ResourceProvider | Abstract class that defines the required interface for all resource provider sub-classes
CEGUI::WindowProperties::RestoreOldCapture | Property to access window Restore Old Capture setting
CEGUI::StaticProperties::RightFrameImage | Property to access the right edge image for the frame of the Static widget
CEGUI::WindowProperties::RiseOnClick | Property to access whether the window rises to the top of the z order when clicked
CEGUI::FrameWindowProperties::RollUpEnabled | Property to access the setting for whether the user is able to roll-up / shade the window
CEGUI::FrameWindowProperties::RollUpState | Property to access the roll-up / shade state of the window
CEGUI::MultiColumnListProperties::RowCount | Property to access the number of rows in the list (read-only)
CEGUI::Scheme | A class that groups a set of GUI elements and initialises the system to access those elements
CEGUI::Scheme_xmlHandler | Handler class used to parse the Scheme XML files using SAX2
CEGUI::SchemeManager | A class that manages the creation of, access to, and destruction of GUI Scheme objects
CEGUI::ScriptFunctor | Functor class used for binding named script functions to events
CEGUI::ScriptModule | Abstract interface required for all scripting support modules to be used with the CEGUI system
CEGUI::ScrollablePane | Base class for the ScrollablePane widget
CEGUI::Scrollbar | Base scroll bar class
CEGUI::ScrolledContainer | Helper container window class which is used in the implementation of the ScrollablePane widget class
CEGUI::ScrolledContainerFactory | Factory class for producing ScrolledContainer windows
CEGUI::ScrollbarProperties::ScrollPosition | Property to access the scroll position of the Scrollbar
CEGUI::SectionSpecification | Class that represents a simple 'link' to an ImagerySection
CEGUI::RadioButtonProperties::Selected | Property to access the selected state of the RadioButton
CEGUI::CheckboxProperties::Selected | Property to access the selected state of the check box
CEGUI::ComboboxProperties::SelectedEditTextColour | Property to access the colour used for rendering text within the selection area
CEGUI::MultiLineEditboxProperties::SelectedTextColour | Property to access the colour used for rendering text within the selection area
CEGUI::EditboxProperties::SelectedTextColour | Property to access the colour used for rendering text within the selection area
CEGUI::MultiLineEditboxProperties::SelectionLength | Property to access the current selection length
CEGUI::EditboxProperties::SelectionLength | Property to access the current selection length
CEGUI::MultiColumnListProperties::SelectionMode | Property to access the selection mode setting of the list
CEGUI::EditboxProperties::SelectionStart | Property to access the current selection start index
CEGUI::MultiLineEditboxProperties::SelectionStart | Property to access the current selection start index
CEGUI::SimpleTimer | Simple timer class
CEGUI::ComboboxProperties::SingleClickMode | Property to access the 'single click mode' setting for the combo box
CEGUI::ListHeaderSegmentProperties::Sizable | Property to access the sizable setting of the header segment
CEGUI::Size | Class that holds the size (width & height) of something
CEGUI::WindowProperties::Size | Property to access the window size
CEGUI::FrameWindowProperties::SizingBorderThickness | Property to access the setting for the sizing border thickness
CEGUI::FrameWindowProperties::SizingEnabled | Property to access the state of the sizable setting for the FrameWindow
CEGUI::Slider | Base class for Slider widgets
CEGUI::ListboxProperties::Sort | Property to access the sort setting of the list box
CEGUI::ListHeaderProperties::SortColumnID | Property to access the current sort column (via ID code)
CEGUI::MultiColumnListProperties::SortColumnID | Property to access the current sort column (via ID code)
CEGUI::MultiColumnListProperties::SortDirection | Property to access the sort direction setting of the list
CEGUI::ListHeaderProperties::SortDirection | Property to access the sort direction setting of the list header
CEGUI::ListHeaderSegmentProperties::SortDirection | Property to access the sort direction setting of the header segment
CEGUI::ComboboxProperties::SortList | Property to access the sort setting of the list box
CEGUI::ListHeaderProperties::SortSettingEnabled | Property to access the setting for user modification of the sort column & direction
CEGUI::MultiColumnListProperties::SortSettingEnabled | Property to access the setting for user modification of the sort column & direction
CEGUI::Spinner | Base class for the Spinner widget
CEGUI::StateImagery | Class the encapsulates imagery for a given widget state
CEGUI::Static | Base class for static widgets
CEGUI::StaticImage | Static image widget class
CEGUI::StaticText | Base class for a static text widget
CEGUI::SpinnerProperties::StepSize | Property to access the step size of the spinner
CEGUI::ScrollbarProperties::StepSize | Property to access the step size for the Scrollbar
CEGUI::ProgressBarProperties::StepSize | Property to access the step size setting for the progress bar
CEGUI::String | String class used within the GUI system
CEGUI::String::const_iterator | Constant forward iterator class for String objects
CEGUI::String::iterator | Forward iterator class for String objects
CEGUI::SubscriberInterface< Ret, Args > | The base class for the various binders. This provides a consistent interface for firing functions bound to an event
CEGUI::SubscriberTemplate< Ret, Args > | This template describes the Subscriber class. It is a wrapper for a pointer to a SubscriberInterface with various constructors that will by implicit conversion construct the various binders
CEGUI::System | The System class is the CEGUI class that provides access to all other elements in this system
CEGUI::TabButton | Base class for TabButtons. A TabButton based class is used internally as the button that appears at the top of a TabControl widget to select the active tab pane
CEGUI::TabControl | Base class for standard Tab Control widget
CEGUI::TabControlProperties::TabHeight | Property to access the tab height setting of the tab control
CEGUI::TabPane | Base class for a tab pane
CEGUI::TabControlProperties::TabTextPadding | Property to access the tab text padding setting of the tab control
CEGUI::WindowProperties::Text | Property to access window text setting
CEGUI::TextItemProperties::TextColour | Property to access the text colour of the item
CEGUI::StaticTextProperties::TextColours | Property to access the text colours for the StaticText widget
CEGUI::TextComponent | Class that encapsulates information for a text component
CEGUI::TextItemProperties::TextFormatting | Property to access the horizontal formatting mode setting
CEGUI::SpinnerProperties::TextInputMode | Property to access the TextInputMode setting
CEGUI::TextItem | Base class for all the TextItem widgets
CEGUI::Texture | Abstract base class specifying the required interface for Texture objects
CEGUI::TextUtils | Text utility support class. This class is all static members. You do not create instances of this class
CEGUI::PushButtonProperties::TextXOffset | Property to access an offset that is used to shift the text in the x-direction
CEGUI::TextItemProperties::TextXOffset | Property to access the X offset of the text on the item
CEGUI::Thumb | Base class for Thumb widget
CEGUI::TinyXMLParser | Implementation of XMLParser using TinyXML
CEGUI::Titlebar | Class representing the title bar for Frame Windows
CEGUI::FrameWindowProperties::TitlebarEnabled | Property to access the setting for whether the window title-bar will be enabled (or displayed depending upon choice of final widget type)
CEGUI::FrameWindowProperties::TitlebarFont | Property to access the Font set for the windows title bar
TiXmlAttribute |
TiXmlBase |
TiXmlComment |
TiXmlDeclaration |
TiXmlDocument |
TiXmlElement |
TiXmlHandle |
TiXmlNode |
TiXmlText |
TiXmlUnknown |
CEGUI::WindowProperties::Tooltip | Property to access the tooltip text for this Window
CEGUI::Tooltip | Base class for Tooltip widgets
CEGUI::StaticProperties::TopFrameImage | Property to access the top edge image for the frame of the Static widget
CEGUI::StaticProperties::TopLeftFrameImage | Property to access the top-left image for the frame of the Static widget
CEGUI::StaticProperties::TopRightFrameImage | Property to access the top-right image for the frame of the Static widget
CEGUI::UDim | Class representing a unified dimension; that is a dimension that has both a relative 'scale' portion and and absolute 'offset' portion
CEGUI::UnifiedDim | Dimension type that represents an Unified dimension. Implements BaseDim interface
CEGUI::UnknownObjectException | Exception class used when a request was made using a name of an unknown object
CEGUI::URect | Area rectangle class built using unified dimensions (UDims)
CEGUI::PushButtonProperties::UseStandardImagery | Property to access whether to use the standard images or the supplied custom ones
CEGUI::UVector2 | Two dimensional vector class built using unified dimensions (UDims). The UVector2 class is used for representing both positions and sizes
CEGUI::EditboxProperties::ValidationString | Property to access the string used for regular expression validation of the edit box text
CEGUI::ComboboxProperties::ValidationString | Property to access the string used for regular expression validation of the edit box text
CEGUI::Vector2 | Class used as a two dimensional vector (aka a Point)
CEGUI::Vector3 | Class used as a three dimensional vector
CEGUI::StaticImageProperties::VertFormatting | Property to access the vertical formatting mode setting
CEGUI::StaticTextProperties::VertFormatting | Property to access the vertical formatting mode setting
CEGUI::ThumbProperties::VertFree | Property to access the state the setting to free the thumb vertically
CEGUI::WindowProperties::VerticalAlignment | Property to access the vertical alignment setting for the window
CEGUI::ScrollablePaneProperties::VertOverlapSize | Property to access the overlap size for the vertical Scrollbar
CEGUI::MenuBaseProperties::VertPadding | Property to access the vert padding value of the menu
CEGUI::ThumbProperties::VertRange | Property to access the vertical movement range for the thumb
CEGUI::StaticTextProperties::VertScrollbar | Property to access the setting for enabling the vertical scroll bar
CEGUI::ScrollablePaneProperties::VertScrollPosition | Property to access the scroll position of the vertical Scrollbar
CEGUI::ScrollablePaneProperties::VertStepSize | Property to access the step size for the vertical Scrollbar
CEGUI::WindowProperties::Visible | Property to access window Visible setting
CEGUI::WindowProperties::WantsMultiClickEvents | Property to control whether the window will receive double/triple-click events
CEGUI::WidgetComponent | Class that encapsulates information regarding a sub-widget required for a widget
CEGUI::WidgetDim | Dimension type that represents some dimension of a Window/widget. Implements BaseDim interface
CEGUI::WidgetLookFeel | Class that encapsulates look & feel information for a particular widget type
CEGUI::WidgetLookManager | Manager class that gives top-level access to widget data based "look and feel" specifications loaded into the system
CEGUI::WindowProperties::Width | Property to access window width
CEGUI::Window | An abstract base class providing common functionality and specifying the required interface for derived classes
CEGUI::WindowEventArgs | EventArgs based class that is used for objects passed to handlers triggered for events concerning some Window object
CEGUI::WindowFactory | Abstract class that defines the required interface for all WindowFactory objects
CEGUI::WindowFactoryManager | Class that manages WindowFactory objects
CEGUI::WindowFactoryManager::AliasTargetStack | Class used to track active alias targets for Window factory types
CEGUI::WindowFactoryManager::FalagardWindowMapping | Struct used to hold mapping information required to create a falagard based window
CEGUI::WindowManager | The WindowManager class describes an object that manages creation and lifetime of Window objects
CEGUI::MultiLineEditboxProperties::WordWrap | Property to access the word-wrap setting of the edit box
CEGUI::XercesParser | Implementation of XMLParser using Xerces-C++
CEGUI::XMLAttributes | Class representing a block of attributes associated with an XML element
CEGUI::XMLParser | This is an abstract class that is used by CEGUI to interface with XML parser libraries
CEGUI::WindowProperties::XPosition | Property to access window X position
CEGUI::WindowProperties::YPosition | Property to access window Y position
CEGUI::WindowProperties::ZOrderChangeEnabled | Property to access window Z-Order changing enabled setting
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::_freeBinder< Ret, Args > Class Template Reference

  • Class List
  • Alphabetical List
  • Class Hierarchy
  • Class Members
CEGUI::_freeBinder

CEGUI::_freeBinder< Ret, Args > Class Template Reference

This class binds a free function. More...

Inheritance diagram for CEGUI::_freeBinder< Ret, Args >:

[legend]
Collaboration diagram for CEGUI::_freeBinder< Ret, Args >:

[legend]
List of all members.

Public Types

typedef Ret(* | SlotFunction )(Args)

Public Member Functions

virtual Ret | operator() (Args args) const
_freeBinder (SlotFunction f)

Protected Attributes

SlotFunction | d_f

Detailed Description

template<typename Ret, typename Args>
class CEGUI::_freeBinder< Ret, Args >

This class binds a free function.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::_functorBinder< Functor, Ret, Args > Class Template Reference

  • Class Members
CEGUI::_functorBinder

CEGUI::_functorBinder< Functor, Ret, Args > Class Template Reference

This class binds a copy of a functor. More...

Inheritance diagram for CEGUI::_functorBinder< Functor, Ret, Args >:

[legend]
Collaboration diagram for CEGUI::_functorBinder< Functor, Ret, Args >:

[legend]
List of all members.

Public Member Functions

virtual Ret | operator() (Args args) const
_functorBinder (const Functor &f)

Protected Attributes

Functor | d_f

Detailed Description

template<class Functor, typename Ret, typename Args>
class CEGUI::_functorBinder< Functor, Ret, Args >

This class binds a copy of a functor.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::_memberBinder< T, Ret, Args > Class Template Reference

CEGUI::_memberBinder

CEGUI::_memberBinder< T, Ret, Args > Class Template Reference

This class binds a member function along with a target object. More...

Inheritance diagram for CEGUI::_memberBinder< T, Ret, Args >:

[legend]
Collaboration diagram for CEGUI::_memberBinder< T, Ret, Args >:

[legend]
List of all members.

Public Member Functions

virtual Ret | operator() (Args args) const
_memberBinder (F f, T *t)

Protected Attributes

F | d_f
T * | d_t

Detailed Description

template<class T, typename Ret, typename Args>
class CEGUI::_memberBinder< T, Ret, Args >

This class binds a member function along with a target object.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::_refBinder< Functor, Ret, Args > Class Template Reference

CEGUI::_refBinder

CEGUI::_refBinder< Functor, Ret, Args > Class Template Reference

This class binds a const reference to a generalized functor. Sometimes it may not be appropriate for the functor to be cloned. In which case, use SubscriberRef() (which uses this). More...

Inheritance diagram for CEGUI::_refBinder< Functor, Ret, Args >:

[legend]
Collaboration diagram for CEGUI::_refBinder< Functor, Ret, Args >:

[legend]
List of all members.

Public Member Functions

virtual Ret | operator() (Args args) const
_refBinder (const Functor &f)

Protected Attributes

const Functor & | d_f

Detailed Description

template<class Functor, typename Ret, typename Args>
class CEGUI::_refBinder< Functor, Ret, Args >

This class binds a const reference to a generalized functor. Sometimes it may not be appropriate for the functor to be cloned. In which case, use SubscriberRef() (which uses this).

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::AbsoluteDim Class Reference

CEGUI::AbsoluteDim

CEGUI::AbsoluteDim Class Reference

Dimension type that represents an absolute pixel value. Implements BaseDim interface. More...

Inheritance diagram for CEGUI::AbsoluteDim:

[legend]
Collaboration diagram for CEGUI::AbsoluteDim:

[legend]
List of all members.

Public Member Functions

AbsoluteDim (float val)
Constructor.
void | setValue (float val)
Set the current value of the AbsoluteDim.

Protected Member Functions

float | getValue_impl (const Window &wnd) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
float | getValue_impl (const Window &wnd, const Rect &container) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
void | writeXMLElementName_impl (OutStream &out_stream) const
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
void | writeXMLElementAttributes_impl (OutStream &out_stream) const
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.
BaseDim * | clone_impl () const
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.

Detailed Description

Dimension type that represents an absolute pixel value. Implements BaseDim interface.

Constructor & Destructor Documentation

CEGUI::AbsoluteDim::AbsoluteDim ( float val )

Constructor.

Parameters:
val float value to be assigned to the AbsoluteDim.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteHeight Class Reference

CEGUI::WindowProperties::AbsoluteHeight

CEGUI::WindowProperties::AbsoluteHeight Class Reference

Property to access window height. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteHeight:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteHeight:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window height.

This property offers access to the Height setting for the window, using the absolute metrics mode.

Usage:
  • Name: AbsoluteHeight
  • Format: "[float]".
Where:
  • [float] specifies the height as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteHeight::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteHeight::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteMaxSize Class Reference

CEGUI::WindowProperties::AbsoluteMaxSize

CEGUI::WindowProperties::AbsoluteMaxSize Class Reference

Property to access maximum window size. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteMaxSize:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteMaxSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.
String | getDefault (const PropertyReceiver *receiver) const
Returns the default value of the Property as a String.

Detailed Description

Property to access maximum window size.

This property offers access to the maximum size setting for the window, using absolute screen pixel metrics.

Usage:
  • Name: AbsoluteMaxSize
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the maximum width as a floating point number.
  • h:[float] specifies the maximum height as a floating point number.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteMaxSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

String CEGUI::WindowProperties::AbsoluteMaxSize::getDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns the default value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the default value for this property.

Reimplemented from CEGUI::Property.

bool CEGUI::WindowProperties::AbsoluteMaxSize::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteMaxSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteMinSize Class Reference

CEGUI::WindowProperties::AbsoluteMinSize

CEGUI::WindowProperties::AbsoluteMinSize Class Reference

Property to access minimum window size. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteMinSize:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteMinSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access minimum window size.

This property offers access to the minimum size setting for the window, using absolute screen pixel metrics.

Usage:
  • Name: AbsoluteMinSize
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the minimum width as a floating point number.
  • h:[float] specifies the minimum height as a floating point number.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteMinSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteMinSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsolutePosition Class Reference

CEGUI::WindowProperties::AbsolutePosition

CEGUI::WindowProperties::AbsolutePosition Class Reference

Property to access window position. More...

Inheritance diagram for CEGUI::WindowProperties::AbsolutePosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsolutePosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window position.

This property offers access to the position for the window, using the absolute metrics system.

Usage:
  • Name: AbsolutePosition
  • Format: "x:[float] y:[float]".
Where:
  • x:[float] specifies the x position co-ordinate as a floating point number, using the absolute metrics system.
  • y:[float] specifies the y position co-ordinate as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsolutePosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsolutePosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteRect Class Reference

CEGUI::WindowProperties::AbsoluteRect

CEGUI::WindowProperties::AbsoluteRect Class Reference

Property to access window area rectangle. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteRect:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteRect:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window area rectangle.

This property offers access to the area rectangle (Rect) for the window, using the absolute metrics system.

Usage:
  • Name: AbsoluteRect
  • Format: "l:[float] t:[float] r:[float] b:[float]".
Where:
  • l:[float] specifies the position of the left edge of the area as a floating point number, using the absolute metrics system.
  • t:[float] specifies the position of the top edge of the area as a floating point number, using the absolute metrics system.
  • r:[float] specifies the position of the right edge of the area as a floating point number, using the absolute metrics system.
  • b:[float] specifies the position of the bottom edge of the area as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteRect::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteRect::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteSize Class Reference

CEGUI::WindowProperties::AbsoluteSize

CEGUI::WindowProperties::AbsoluteSize Class Reference

Property to access the window size. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteSize:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the window size.

This property offers access to the size setting for the window, using the absolute metrics system.

Usage:
  • Name: AbsoluteSize
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the minimum width as a floating point number, using the absolute metrics system.
  • h:[float] specifies the minimum height as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties::AbsoluteTabHeight Class Reference

CEGUI::TabControlProperties::AbsoluteTabHeight

CEGUI::TabControlProperties::AbsoluteTabHeight Class Reference

Property to access the absolute tab height setting of the tab control. More...

Inheritance diagram for CEGUI::TabControlProperties::AbsoluteTabHeight:

[legend]
Collaboration diagram for CEGUI::TabControlProperties::AbsoluteTabHeight:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.
String | getDefault (const PropertyReceiver *receiver) const
Returns the default value of the Property as a String.

Detailed Description

Property to access the absolute tab height setting of the tab control.

Usage:
  • Name: AbsoluteTabHeight
  • Format: "[float]"

Member Function Documentation

String CEGUI::TabControlProperties::AbsoluteTabHeight::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

String CEGUI::TabControlProperties::AbsoluteTabHeight::getDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns the default value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the default value for this property.

Reimplemented from CEGUI::Property.

bool CEGUI::TabControlProperties::AbsoluteTabHeight::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::TabControlProperties::AbsoluteTabHeight::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties::AbsoluteTabTextPadding Class Reference

CEGUI::TabControlProperties::AbsoluteTabTextPadding

CEGUI::TabControlProperties::AbsoluteTabTextPadding Class Reference

Property to access the absolute tab text padding setting of the tab control. More...

Inheritance diagram for CEGUI::TabControlProperties::AbsoluteTabTextPadding:

[legend]
Collaboration diagram for CEGUI::TabControlProperties::AbsoluteTabTextPadding:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the absolute tab text padding setting of the tab control.

Usage:
  • Name: AbsoluteTabTextPadding
  • Format: "[float]"

Member Function Documentation

String CEGUI::TabControlProperties::AbsoluteTabTextPadding::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TabControlProperties::AbsoluteTabTextPadding::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteWidth Class Reference

CEGUI::WindowProperties::AbsoluteWidth

CEGUI::WindowProperties::AbsoluteWidth Class Reference

Property to access window width. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteWidth:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteWidth:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window width.

This property offers access to the Width setting for the window, using the absolute metrics mode.

Usage:
  • Name: AbsoluteWidth
  • Format: "[float]".
Where:
  • [float] specifies the width as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteWidth::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteWidth::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteXPosition Class Reference

CEGUI::WindowProperties::AbsoluteXPosition

CEGUI::WindowProperties::AbsoluteXPosition Class Reference

Property to access window X position. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteXPosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteXPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window X position.

This property offers access to the X position for the window, using the absolute metrics system.

Usage:
  • Name: AbsoluteXPosition
  • Format: "[float]".
Where:
  • [float] specifies the x position co-ordinate as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteXPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteXPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AbsoluteYPosition Class Reference

CEGUI::WindowProperties::AbsoluteYPosition

CEGUI::WindowProperties::AbsoluteYPosition Class Reference

Property to access window Y position. More...

Inheritance diagram for CEGUI::WindowProperties::AbsoluteYPosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AbsoluteYPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window Y position.

This property offers access to the Y position for the window, using the absolute metrics system.

Usage:
  • Name: AbsoluteYPosition
  • Format: "[float]".
Where:
  • [float] specifies the y position co-ordinate as a floating point number, using the absolute metrics system.

Member Function Documentation

String CEGUI::WindowProperties::AbsoluteYPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AbsoluteYPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ActivationEventArgs Class Reference

CEGUI::ActivationEventArgs

CEGUI::ActivationEventArgs Class Reference

EventArgs based class that is used for Activated and Deactivated window events. More...

Inheritance diagram for CEGUI::ActivationEventArgs:

[legend]
Collaboration diagram for CEGUI::ActivationEventArgs:

[legend]
List of all members.

Public Member Functions

ActivationEventArgs (Window *wnd)

Public Attributes

Window * otherWindow
Pointer to the other window involved in the activation change.

Detailed Description

EventArgs based class that is used for Activated and Deactivated window events.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::ActiveEditSelectionColour Class Reference

CEGUI::ComboboxProperties::ActiveEditSelectionColour

CEGUI::ComboboxProperties::ActiveEditSelectionColour Class Reference

Property to access the colour used for rendering the selection highlight when the edit box is active. More...

Inheritance diagram for CEGUI::ComboboxProperties::ActiveEditSelectionColour:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::ActiveEditSelectionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering the selection highlight when the edit box is active.

Usage:
  • Name: ActiveEditSelectionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ComboboxProperties::ActiveEditSelectionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::ActiveEditSelectionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::ActiveSelectionColour Class Reference

CEGUI::MultiLineEditboxProperties::ActiveSelectionColour

CEGUI::MultiLineEditboxProperties::ActiveSelectionColour Class Reference

Property to access the colour used for rendering the selection highlight when the edit box is active. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::ActiveSelectionColour:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::ActiveSelectionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering the selection highlight when the edit box is active.

Usage:
  • Name: ActiveSelectionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::ActiveSelectionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::ActiveSelectionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::ActiveSelectionColour Class Reference

CEGUI::EditboxProperties::ActiveSelectionColour

CEGUI::EditboxProperties::ActiveSelectionColour Class Reference

Property to access the colour used for rendering the selection highlight when the edit box is active. More...

Inheritance diagram for CEGUI::EditboxProperties::ActiveSelectionColour:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::ActiveSelectionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering the selection highlight when the edit box is active.

Usage:
  • Name: ActiveSelectionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::EditboxProperties::ActiveSelectionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::ActiveSelectionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBaseProperties::AllowMultiplePopups Class Reference

CEGUI::MenuBaseProperties::AllowMultiplePopups

CEGUI::MenuBaseProperties::AllowMultiplePopups Class Reference

Property to access the state of the allow multiple popups setting. More...

Inheritance diagram for CEGUI::MenuBaseProperties::AllowMultiplePopups:

[legend]
Collaboration diagram for CEGUI::MenuBaseProperties::AllowMultiplePopups:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the allow multiple popups setting.

Usage:
  • Name: AllowMultiplePopups
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate that auto resizing is enabled.
  • "False" to indicate that auto resizing is disabled.

Member Function Documentation

String CEGUI::MenuBaseProperties::AllowMultiplePopups::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuBaseProperties::AllowMultiplePopups::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Alpha Class Reference

CEGUI::WindowProperties::Alpha

CEGUI::WindowProperties::Alpha Class Reference

Property to access window alpha setting. More...

Inheritance diagram for CEGUI::WindowProperties::Alpha:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Alpha:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window alpha setting.

This property offers access to the alpha-blend setting for the window.

Usage:
  • Name: Alpha
  • Format: "[float]".
Where:
  • [float] is a floating point number between 0.0 and 1.0.

Member Function Documentation

String CEGUI::WindowProperties::Alpha::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Alpha::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::AlreadyExistsException Class Reference

CEGUI::AlreadyExistsException

CEGUI::AlreadyExistsException Class Reference

Exception class used when an attempt is made to use an object name that is already in use within the system. More...

Inheritance diagram for CEGUI::AlreadyExistsException:

[legend]
Collaboration diagram for CEGUI::AlreadyExistsException:

[legend]
List of all members.

Public Member Functions

AlreadyExistsException (const String &message)

Detailed Description

Exception class used when an attempt is made to use an object name that is already in use within the system.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AlwaysOnTop Class Reference

CEGUI::WindowProperties::AlwaysOnTop

CEGUI::WindowProperties::AlwaysOnTop Class Reference

Property to access window "Always-On-Top" setting. More...

Inheritance diagram for CEGUI::WindowProperties::AlwaysOnTop:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AlwaysOnTop:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window "Always-On-Top" setting.

This property offers access to the always on top / topmost setting for the window.

Usage:
  • Name: AlwaysOnTop
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window is always on top, and appears above all other non-always on top Windows.
  • "False" to indicate the Window is not always on top, and will appear below all other always on top Windows.

Member Function Documentation

String CEGUI::WindowProperties::AlwaysOnTop::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AlwaysOnTop::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AutoRepeatDelay Class Reference

CEGUI::WindowProperties::AutoRepeatDelay

CEGUI::WindowProperties::AutoRepeatDelay Class Reference

Property to access window autorepeat delay value. More...

Inheritance diagram for CEGUI::WindowProperties::AutoRepeatDelay:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AutoRepeatDelay:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window autorepeat delay value.

This property offers access to the value that controls the initial delay for autorepeat mouse button down events.

Usage:
  • Name: AutoRepeatDelay
  • Format: "[float]".
Where:
  • [float] specifies the delay in seconds.

Member Function Documentation

String CEGUI::WindowProperties::AutoRepeatDelay::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AutoRepeatDelay::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::AutoRepeatRate Class Reference

CEGUI::WindowProperties::AutoRepeatRate

CEGUI::WindowProperties::AutoRepeatRate Class Reference

Property to access window autorepeat rate value. More...

Inheritance diagram for CEGUI::WindowProperties::AutoRepeatRate:

[legend]
Collaboration diagram for CEGUI::WindowProperties::AutoRepeatRate:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window autorepeat rate value.

This property offers access to the value that controls the generation rate for autorepeat mouse button down events.

Usage:
  • Name: AutoRepeatRate
  • Format: "[float]".
Where:
  • [float] specifies the rate at which autorepeat events will be generated in seconds.

Member Function Documentation

String CEGUI::WindowProperties::AutoRepeatRate::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::AutoRepeatRate::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ItemListBaseProperties::AutoResizeEnabled Class Reference

CEGUI::ItemListBaseProperties::AutoResizeEnabled

CEGUI::ItemListBaseProperties::AutoResizeEnabled Class Reference

Property to access the state of the auto resize enabled setting. More...

Inheritance diagram for CEGUI::ItemListBaseProperties::AutoResizeEnabled:

[legend]
Collaboration diagram for CEGUI::ItemListBaseProperties::AutoResizeEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the auto resize enabled setting.

Usage:
  • Name: AutoResizeEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate that auto resizing is enabled.
  • "False" to indicate that auto resizing is disabled.

Member Function Documentation

String CEGUI::ItemListBaseProperties::AutoResizeEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ItemListBaseProperties::AutoResizeEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::BackgroundColours Class Reference

CEGUI::StaticProperties::BackgroundColours

CEGUI::StaticProperties::BackgroundColours Class Reference

Property to access the background colours for the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::BackgroundColours:

[legend]
Collaboration diagram for CEGUI::StaticProperties::BackgroundColours:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the background colours for the Static widget.

Usage:
  • Name: BackgroundColours
  • Format: "tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]".
Where:
  • tl:[aarrggbb] is the top-left colour value specified as ARGB (hex).
  • tr:[aarrggbb] is the top-right colour value specified as ARGB (hex).
  • bl:[aarrggbb] is the bottom-left colour value specified as ARGB (hex).
  • br:[aarrggbb] is the bottom-right colour value specified as ARGB (hex).

Member Function Documentation

String CEGUI::StaticProperties::BackgroundColours::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::BackgroundColours::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBaseProperties::BackgroundColours Class Reference

CEGUI::MenuBaseProperties::BackgroundColours

CEGUI::MenuBaseProperties::BackgroundColours Class Reference

Property to access the background colours of the menu. More...

Inheritance diagram for CEGUI::MenuBaseProperties::BackgroundColours:

[legend]
Collaboration diagram for CEGUI::MenuBaseProperties::BackgroundColours:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the background colours of the menu.

Usage:
  • Name: BackgroundColours
  • Format: "tl:aarrggbb tr:aarrggbb bl:aarrggbb br:aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used for each corner of the ColourRect

Member Function Documentation

String CEGUI::MenuBaseProperties::BackgroundColours::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuBaseProperties::BackgroundColours::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::BackgroundEnabled Class Reference

CEGUI::StaticProperties::BackgroundEnabled

CEGUI::StaticProperties::BackgroundEnabled Class Reference

Property to access the state of the frame background setting for the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::BackgroundEnabled:

[legend]
Collaboration diagram for CEGUI::StaticProperties::BackgroundEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the frame background setting for the Static widget.

Usage:
  • Name: BackgroundEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate that the background is enabled.
  • "False" to indicate that the background is disabled.

Member Function Documentation

String CEGUI::StaticProperties::BackgroundEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::BackgroundEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::BackgroundImage Class Reference

CEGUI::StaticProperties::BackgroundImage

CEGUI::StaticProperties::BackgroundImage Class Reference

Property to access the background image for the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::BackgroundImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::BackgroundImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the background image for the Static widget.

Usage:
  • Name: BackgroundImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::BackgroundImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::BackgroundImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::BaseDim Class Reference

CEGUI::BaseDim

CEGUI::BaseDim Class Reference

Abstract interface for a generic 'dimension' class. More...

Inheritance diagram for CEGUI::BaseDim:

[legend]
Collaboration diagram for CEGUI::BaseDim:

[legend]
List of all members.

Public Member Functions

float | getValue (const Window &wnd) const
Return a value that represents this dimension as absolute pixels.
float | getValue (const Window &wnd, const Rect &container) const
Return a value that represents this dimension as absolute pixels.
BaseDim * | clone () const
Create an exact copy of the specialised class and return it as a pointer to a BaseDim object.
DimensionOperator | getDimensionOperator () const
Return the DimensionOperator set for this BaseDim based object.
void | setDimensionOperator (DimensionOperator op)
Set the DimensionOperator set for this BaseDim based object.
const BaseDim * | getOperand () const
Return a pointer to the BaseDim set to be used as the other operand.
void | setOperand (const BaseDim &operand)
Set the BaseDim set to be used as the other operand in calculations for this BaseDim.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this BaseDim to out_stream.

Protected Member Functions

virtual float | getValue_impl (const Window &wnd) const =0
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
virtual float | getValue_impl (const Window &wnd, const Rect &container) const =0
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
virtual BaseDim * | clone_impl () const =0
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.
virtual void | writeXMLElementName_impl (OutStream &out_stream) const =0
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
virtual void | writeXMLElementAttributes_impl (OutStream &out_stream) const =0
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.

Detailed Description

Abstract interface for a generic 'dimension' class.

Member Function Documentation

BaseDim * CEGUI::BaseDim::clone ( ) const

Create an exact copy of the specialised class and return it as a pointer to a BaseDim object.

Since the system needs to be able to copy objects derived from BaseDim, but only has knowledge of the BaseDim interface, this clone method is provided to prevent slicing issues.

Returns:
BaseDim object pointer

DimensionOperator CEGUI::BaseDim::getDimensionOperator ( ) const

Return the DimensionOperator set for this BaseDim based object.

Returns:
One of the DimensionOperator enumerated values representing a mathematical operation to be performed upon this BaseDim using the set operand.

const BaseDim * CEGUI::BaseDim::getOperand ( ) const

Return a pointer to the BaseDim set to be used as the other operand.

Returns:
Pointer to the BaseDim object.

float CEGUI::BaseDim::getValue | ( | const Window & | wnd,
 |  | const Rect & | container
 | ) | const

Return a value that represents this dimension as absolute pixels.

Parameters:
wnd | Window object that may be used by the specialised class to aid in calculating the final value (typically would be used to obtain window/widget dimensions).
container | Rect object which describes an area to be considered as the base area when calculating the final value. Basically this means that relative values are calculated from the dimensions of this Rect.
Returns:
float value which represents, in pixels, the same value as this BaseDim.

float CEGUI::BaseDim::getValue ( const Window & wnd ) const

Return a value that represents this dimension as absolute pixels.

Parameters:
wnd Window object that may be used by the specialised class to aid in calculating the final value.
Returns:
float value which represents, in pixels, the same value as this BaseDim.

void CEGUI::BaseDim::setDimensionOperator ( DimensionOperator op )

Set the DimensionOperator set for this BaseDim based object.

Parameters:
op One of the DimensionOperator enumerated values representing a mathematical operation to be performed upon this BaseDim using the set operand.
Returns:
Nothing.

void CEGUI::BaseDim::setOperand ( const BaseDim & operand )

Set the BaseDim set to be used as the other operand in calculations for this BaseDim.

Parameters:
operand sub-class of BaseDim representing the 'other' operand. The given object will be cloned; no transfer of ownership occurrs for the passed object.
Returns:
Nothing.

void CEGUI::BaseDim::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this BaseDim to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBaseProperties::BorderWidth Class Reference

CEGUI::MenuBaseProperties::BorderWidth

CEGUI::MenuBaseProperties::BorderWidth Class Reference

Property to access the border width of the menu. More...

Inheritance diagram for CEGUI::MenuBaseProperties::BorderWidth:

[legend]
Collaboration diagram for CEGUI::MenuBaseProperties::BorderWidth:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the border width of the menu.

Usage:
  • Name: BorderWidth
  • Format: "[float]".
Where:
  • [float] represents the border width of the slider.

Member Function Documentation

String CEGUI::MenuBaseProperties::BorderWidth::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuBaseProperties::BorderWidth::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::BottomFrameImage Class Reference

CEGUI::StaticProperties::BottomFrameImage

CEGUI::StaticProperties::BottomFrameImage Class Reference

Property to access the bottom edge image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::BottomFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::BottomFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the bottom edge image for the frame of the Static widget.

Usage:
  • Name: BottomFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::BottomFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::BottomFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::BottomLeftFrameImage Class Reference

CEGUI::StaticProperties::BottomLeftFrameImage

CEGUI::StaticProperties::BottomLeftFrameImage Class Reference

Property to access the bottom-left image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::BottomLeftFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::BottomLeftFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the bottom-left image for the frame of the Static widget.

Usage:
  • Name: BottomLeftFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::BottomLeftFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::BottomLeftFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::BottomRightFrameImage Class Reference

CEGUI::StaticProperties::BottomRightFrameImage

CEGUI::StaticProperties::BottomRightFrameImage Class Reference

Property to access the bottom-right image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::BottomRightFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::BottomRightFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the bottom-right image for the frame of the Static widget.

Usage:
  • Name: BottomRightFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::BottomRightFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::BottomRightFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ButtonBase Class Reference

CEGUI::ButtonBase

CEGUI::ButtonBase Class Reference

Base class for all the 'button' type widgets (push button, radio button, check-box, etc). More...

Inheritance diagram for CEGUI::ButtonBase:

[legend]
Collaboration diagram for CEGUI::ButtonBase:

[legend]
List of all members.

Public Member Functions

bool | isHovering (void) const
return true if user is hovering over this widget (or it's pushed and user is not over it for highlight)
bool | isPushed (void) const
Return true if the button widget is in the pushed state.
colour | getNormalTextColour (void) const
return text label colour used for normal rendering
colour | getHoverTextColour (void) const
return text label colour used for hover / highlight rendering
colour | getPushedTextColour (void) const
return text label colour used for pushed rendering
colour | getDisabledTextColour (void) const
return text label colour used for disabled rendering
void | setNormalTextColour (const colour &colour)
Set the colour to use for the label text when rendering in the normal state.
void | setHoverTextColour (const colour &colour)
Set the colour to use for the label text when rendering in the hover / highlighted states.
void | setPushedTextColour (const colour &colour)
Set the colour to use for the label text when rendering in the pushed state.
void | setDisabledTextColour (const colour &colour)
Set the colour to use for the label text when rendering in the disabled state.
ButtonBase (const String &type, const String &name)
Constructor for ButtonBase objects.
virtual | ~ButtonBase (void)
Destructor for ButtonBase objects.

Static Public Attributes

static const colour | DefaultNormalLabelColour = 0xFFFFFFFF
Default colour used when rendering label text in normal state.
static const colour | DefaultHoverLabelColour = 0xFFFFFFFF
Default colour used when rendering label text in hover / highlight state.
static const colour | DefaultPushedLabelColour = 0xFFFFFFFF
Default colour used when rendering label text in pushed state.
static const colour | DefaultDisabledLabelColour = 0xFF7F7F7F
Default colour used when rendering label text in disabled state.

Protected Member Functions

virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onMouseLeaves (MouseEventArgs &e)
Handler called when the mouse cursor has left this window's area.
void | updateInternalState (const Point &mouse_pos)
Update the internal state of the widget with the mouse at the given position.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | drawSelf (float z)
Perform the rendering for this widget.
virtual void | drawNormal (float z)=0
Render the button-type widget in it's 'normal' state.
virtual void | drawHover (float z)
Render the button-type widget in it's 'hover' (highlighted) state.
virtual void | drawPushed (float z)
Render the button-type widget in it's 'pushed' state.
virtual void | drawDisabled (float z)
Render the button-type widget in it's 'disabled' state.

Protected Attributes

bool | d_pushed
true when widget is pushed
bool | d_hovering
true when the button is in 'hover' state and requires the hover rendering.
colour d_normalColour
Colour used for label text when rendering in normal state.
colour d_hoverColour
Colour used for label text when rendering in highlighted state.
colour d_pushedColour
Colour used for label text when rendering in pushed state.
colour d_disabledColour
Colour used for label text when rendering in disabled state.

Detailed Description

Base class for all the 'button' type widgets (push button, radio button, check-box, etc).

Member Function Documentation

virtual void CEGUI::ButtonBase::drawDisabled ( float z ) [inline, protected, virtual]

Render the button-type widget in it's 'disabled' state.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

virtual void CEGUI::ButtonBase::drawHover ( float z ) [inline, protected, virtual]

Render the button-type widget in it's 'hover' (highlighted) state.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

virtual void CEGUI::ButtonBase::drawNormal ( float z ) [protected, pure virtual]

Render the button-type widget in it's 'normal' state.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

virtual void CEGUI::ButtonBase::drawPushed ( float z ) [inline, protected, virtual]

Render the button-type widget in it's 'pushed' state.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

void CEGUI::ButtonBase::drawSelf ( float z ) [protected, virtual]

Perform the rendering for this widget.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::TabButton.

colour CEGUI::ButtonBase::getDisabledTextColour ( void ) const [inline]

return text label colour used for disabled rendering

Returns:
colour value that is used for the label text when rendering in the disabled state.

colour CEGUI::ButtonBase::getHoverTextColour ( void ) const [inline]

return text label colour used for hover / highlight rendering

Returns:
colour value that is used for the label text when rendering in the hover / highlighted states.

colour CEGUI::ButtonBase::getNormalTextColour ( void ) const [inline]

return text label colour used for normal rendering

Returns:
colour value that is used for the label text when rendering in the normal state.

colour CEGUI::ButtonBase::getPushedTextColour ( void ) const [inline]

return text label colour used for pushed rendering

Returns:
colour value that is used for the label text when rendering in the pushed state.

bool CEGUI::ButtonBase::isHovering ( void ) const [inline]

return true if user is hovering over this widget (or it's pushed and user is not over it for highlight)

Returns:
true if the user is hovering or if the button is pushed and the mouse is not over the button. Otherwise return false.

bool CEGUI::ButtonBase::isPushed ( void ) const [inline]

Return true if the button widget is in the pushed state.

Returns:
true if the button-type widget is pushed, false if the widget is not pushed.

void CEGUI::ButtonBase::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::Thumb.

void CEGUI::ButtonBase::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::Thumb.

void CEGUI::ButtonBase::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::Checkbox, CEGUI::PushButton, CEGUI::RadioButton, and CEGUI::TabButton.

void CEGUI::ButtonBase::onMouseLeaves ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has left this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ButtonBase::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::Thumb.

void CEGUI::ButtonBase::setDisabledTextColour ( const colour & colour )

Set the colour to use for the label text when rendering in the disabled state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::ButtonBase::setHoverTextColour ( const colour & colour )

Set the colour to use for the label text when rendering in the hover / highlighted states.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::ButtonBase::setNormalTextColour ( const colour & colour )

Set the colour to use for the label text when rendering in the normal state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::ButtonBase::setPushedTextColour ( const colour & colour )

Set the colour to use for the label text when rendering in the pushed state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

virtual bool CEGUI::ButtonBase::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::Checkbox, CEGUI::PushButton, CEGUI::RadioButton, CEGUI::TabButton, and CEGUI::Thumb.

void CEGUI::ButtonBase::updateInternalState ( const Point & mouse_pos ) [protected]

Update the internal state of the widget with the mouse at the given position.

Parameters:
mouse_pos Point object describing, in screen pixel co-ordinates, the location of the mouse cursor.
Returns:
Nothing

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TitlebarProperties::CaptionColour Class Reference

CEGUI::TitlebarProperties::CaptionColour

CEGUI::TitlebarProperties::CaptionColour Class Reference

Property to colour used for rendering the caption text. More...

Inheritance diagram for CEGUI::TitlebarProperties::CaptionColour:

[legend]
Collaboration diagram for CEGUI::TitlebarProperties::CaptionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to colour used for rendering the caption text.

Usage:
  • Name: CaptionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::TitlebarProperties::CaptionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TitlebarProperties::CaptionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::CaptionColour Class Reference

CEGUI::FrameWindowProperties::CaptionColour

CEGUI::FrameWindowProperties::CaptionColour Class Reference

Property to colour used for rendering the caption text. More...

Inheritance diagram for CEGUI::FrameWindowProperties::CaptionColour:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::CaptionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to colour used for rendering the caption text.

Usage:
  • Name: CaptionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::FrameWindowProperties::CaptionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::CaptionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::CaratIndex Class Reference

CEGUI::MultiLineEditboxProperties::CaratIndex

CEGUI::MultiLineEditboxProperties::CaratIndex Class Reference

Property to access the current carat index. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::CaratIndex:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::CaratIndex:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current carat index.

Usage:
  • Name: CaratIndex
  • Format: "[uint]"
Where:
  • [uint] is the zero based index of the carat position within the text.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::CaratIndex::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::CaratIndex::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::CaratIndex Class Reference

CEGUI::ComboboxProperties::CaratIndex

CEGUI::ComboboxProperties::CaratIndex Class Reference

Property to access the current carat index. More...

Inheritance diagram for CEGUI::ComboboxProperties::CaratIndex:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::CaratIndex:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current carat index.

Usage:
  • Name: CaratIndex
  • Format: "[uint]"
Where:
  • [uint] is the zero based index of the carat position within the text.

Member Function Documentation

String CEGUI::ComboboxProperties::CaratIndex::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::CaratIndex::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::CaratIndex Class Reference

CEGUI::EditboxProperties::CaratIndex

CEGUI::EditboxProperties::CaratIndex Class Reference

Property to access the current carat index. More...

Inheritance diagram for CEGUI::EditboxProperties::CaratIndex:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::CaratIndex:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current carat index.

Usage:
  • Name: CaratIndex
  • Format: "[uint]"
Where:
  • [uint] is the zero based index of the carat position within the text.

Member Function Documentation

String CEGUI::EditboxProperties::CaratIndex::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::CaratIndex::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Checkbox Class Reference

CEGUI::Checkbox

CEGUI::Checkbox Class Reference

Base class providing logic for Check-box widgets. More...

Inheritance diagram for CEGUI::Checkbox:

[legend]
Collaboration diagram for CEGUI::Checkbox:

[legend]
List of all members.

Public Member Functions

bool | isSelected (void) const
return true if the check-box is selected (has the checkmark)
void | setSelected (bool select)
set whether the check-box is selected or not
Checkbox (const String &type, const String &name)
Constructor for Checkbox class.
virtual | ~Checkbox (void)
Destructor for Checkbox class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventCheckStateChanged
The check-state of the widget has changed.

Protected Member Functions

virtual void | onSelectStateChange (WindowEventArgs &e)
event triggered internally when state of check-box changes
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
void | addCheckboxEvents (void)
Add check-box specific events.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

bool | d_selected
true if check-box is selected (has checkmark)

Detailed Description

Base class providing logic for Check-box widgets.

Member Function Documentation

bool CEGUI::Checkbox::isSelected ( void ) const [inline]

return true if the check-box is selected (has the checkmark)

Returns:
true if the widget is selected and has the check-mark, false if the widget is not selected and does not have the check-mark.

void CEGUI::Checkbox::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::ButtonBase.

void CEGUI::Checkbox::setSelected ( bool select )

set whether the check-box is selected or not

Parameters:
select true to select the widget and give it the check-mark. false to de-select the widget and remove the check-mark.
Returns:
Nothing.

virtual bool CEGUI::Checkbox::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::ButtonBase.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrolledContainerProperties::ChildExtentsArea Class Reference

CEGUI::ScrolledContainerProperties::ChildExtentsArea

CEGUI::ScrolledContainerProperties::ChildExtentsArea Class Reference

Property offering read-only access to the current content extents rectangle (as window relative pixels). More...

Inheritance diagram for CEGUI::ScrolledContainerProperties::ChildExtentsArea:

[legend]
Collaboration diagram for CEGUI::ScrolledContainerProperties::ChildExtentsArea:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property offering read-only access to the current content extents rectangle (as window relative pixels).

Usage:
  • Name: ChildExtentsArea
  • Format: "l:[float] t:[float] r:[float] b:[float]".
Where:
  • l:[float] specifies the position of the left edge of the area as a floating point number.
  • t:[float] specifies the position of the top edge of the area as a floating point number.
  • r:[float] specifies the position of the right edge of the area as a floating point number.
  • b:[float] specifies the position of the bottom edge of the area as a floating point number.

Member Function Documentation

String CEGUI::ScrolledContainerProperties::ChildExtentsArea::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrolledContainerProperties::ChildExtentsArea::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderSegmentProperties::Clickable Class Reference

CEGUI::ListHeaderSegmentProperties::Clickable

CEGUI::ListHeaderSegmentProperties::Clickable Class Reference

Property to access the click-able setting of the header segment. More...

Inheritance diagram for CEGUI::ListHeaderSegmentProperties::Clickable:

[legend]
Collaboration diagram for CEGUI::ListHeaderSegmentProperties::Clickable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the click-able setting of the header segment.

Usage:
  • Name: Clickable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the segment can be clicked by the user.
  • "False" to indicate the segment can not be clicked by the user.

Member Function Documentation

String CEGUI::ListHeaderSegmentProperties::Clickable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderSegmentProperties::Clickable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SliderProperties::ClickStepSize Class Reference

CEGUI::SliderProperties::ClickStepSize

CEGUI::SliderProperties::ClickStepSize Class Reference

Property to access the click-step size for the slider. More...

Inheritance diagram for CEGUI::SliderProperties::ClickStepSize:

[legend]
Collaboration diagram for CEGUI::SliderProperties::ClickStepSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the click-step size for the slider.

Usage:
  • Name: ClickStepSize
  • Format: "[float]".
Where:
  • [float] represents the click-step size slider (this is how much the value changes when the slider container is clicked).

Member Function Documentation

String CEGUI::SliderProperties::ClickStepSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SliderProperties::ClickStepSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::ClippedByParent Class Reference

CEGUI::WindowProperties::ClippedByParent

CEGUI::WindowProperties::ClippedByParent Class Reference

Property to access window "clipped by parent" setting. More...

Inheritance diagram for CEGUI::WindowProperties::ClippedByParent:

[legend]
Collaboration diagram for CEGUI::WindowProperties::ClippedByParent:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window "clipped by parent" setting.

This property offers access to the clipped by parent setting for the window.

Usage:
  • Name: ClippedByParent
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window is clipped by it's parent.
  • "False" to indicate the Window is not clipped by it's parent.

Member Function Documentation

String CEGUI::WindowProperties::ClippedByParent::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::ClippedByParent::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::CloseButtonEnabled Class Reference

CEGUI::FrameWindowProperties::CloseButtonEnabled

CEGUI::FrameWindowProperties::CloseButtonEnabled Class Reference

Property to access the setting for whether the window close button will be enabled (or displayed depending upon choice of final widget type). More...

Inheritance diagram for CEGUI::FrameWindowProperties::CloseButtonEnabled:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::CloseButtonEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for whether the window close button will be enabled (or displayed depending upon choice of final widget type).

Usage:
  • Name: CloseButtonEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the windows close button should be enabled (and/or visible)
  • "False" to indicate the windows close button should be disabled (and/or hidden)

Member Function Documentation

String CEGUI::FrameWindowProperties::CloseButtonEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::CloseButtonEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::colour Class Reference

CEGUI::colour

CEGUI::colour Class Reference

Class representing colour values within the system. More...

List of all members.

Public Member Functions

colour (const colour &val)
colour (float red, float green, float blue, float alpha=1.0f)
colour (argb_t argb)
argb_t | getARGB (void) const
float | getAlpha (void) const
float | getRed (void) const
float | getGreen (void) const
float | getBlue (void) const
float | getHue (void) const
float | getSaturation (void) const
float | getLumination (void) const
void | setARGB (argb_t argb)
void | setAlpha (float alpha)
void | setRed (float red)
void | setGreen (float green)
void | setBlue (float blue)
void | set (float red, float green, float blue, float alpha=1.0f)
void | setRGB (float red, float green, float blue)
void | setRGB (const colour &val)
void | setHSL (float hue, float saturation, float luminance, float alpha=1.0f)
void | invertColour (void)
void | invertColourWithAlpha (void)
colour & | operator= (argb_t val)
colour & | operator= (const colour &val)
colour & | operator &= (argb_t val)
colour & | operator &= (const colour &val)
colour & | operator|= (argb_t val)
colour & | operator|= (const colour &val)
colour & | operator<<= (int val)
colour & | operator>>= (int val)
colour | operator+ (const colour &val) const
colour | operator- (const colour &val) const
colour | operator * (const float val) const
colour & | operator *= (const colour &val)
bool | operator== (const colour &rhs) const
bool | operator!= (const colour &rhs) const
operator argb_t () const

Detailed Description

Class representing colour values within the system.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ColourRect Class Reference

CEGUI::ColourRect

CEGUI::ColourRect Class Reference

Class that holds details of colours for the four corners of a rectangle. More...

Collaboration diagram for CEGUI::ColourRect:

[legend]
List of all members.

Public Member Functions

ColourRect (void)
Default constructor.
ColourRect (const colour &col)
Constructor for ColourRect objects (via single colour). Also handles default construction.
ColourRect (const colour &top_left, const colour &top_right, const colour &bottom_left, const colour &bottom_right)
Constructor for ColourRect objects.
void | setAlpha (float alpha)
Set the alpha value to use for all four corners of the ColourRect.
void | setTopAlpha (float alpha)
Set the alpha value to use for the top edge of the ColourRect.
void | setBottomAlpha (float alpha)
Set the alpha value to use for the bottom edge of the ColourRect.
void | setLeftAlpha (float alpha)
Set the alpha value to use for the left edge of the ColourRect.
void | setRightAlpha (float alpha)
Set the alpha value to use for the right edge of the ColourRect.
bool | isMonochromatic () const
Determinate the ColourRect is monochromatic or variegated.
ColourRect | getSubRectangle (float left, float right, float top, float bottom) const
Gets a portion of this ColourRect as a subset ColourRect.
colour | getColourAtPoint (float x, float y) const
Get the colour at a point in the rectangle.
void | setColours (const colour &col)
Set the colour of all four corners simultaneously.
void | modulateAlpha (float alpha)
Module the alpha components of each corner's colour by a constant.
ColourRect & | operator *= (const ColourRect &other)
Modulate all components of this colour rect with corresponding components from another colour rect.

Public Attributes

colour | d_top_left
colour | d_top_right
colour | d_bottom_left
colour | d_bottom_right

Detailed Description

Class that holds details of colours for the four corners of a rectangle.

Member Function Documentation

colour CEGUI::ColourRect::getColourAtPoint | ( | float | x,
 |  | float | y
 | ) | const

Get the colour at a point in the rectangle.

Parameters:
x | The x coordinate of the point
y | The y coordinate of the point
Returns:
The colour at the specified point.

ColourRect CEGUI::ColourRect::getSubRectangle | ( | float | left,
 |  | float | right,
 |  | float | top,
 |  | float | bottom
 | ) | const

Gets a portion of this ColourRect as a subset ColourRect.

Parameters:
left | The left side of this subrectangle (in the range of 0-1 float)
right | The right side of this subrectangle (in the range of 0-1 float)
top | The top side of this subrectangle (in the range of 0-1 float)
bottom | The bottom side of this subrectangle (in the range of 0-1 float)
Returns:
A ColourRect from the specified range

bool CEGUI::ColourRect::isMonochromatic ( ) const

Determinate the ColourRect is monochromatic or variegated.

Returns:
True if all four corners of the ColourRect has same colour, false otherwise.

void CEGUI::ColourRect::modulateAlpha ( float alpha )

Module the alpha components of each corner's colour by a constant.

Parameters:
alpha The constant factor to modulate all alpha colour components by.

void CEGUI::ColourRect::setAlpha ( float alpha )

Set the alpha value to use for all four corners of the ColourRect.

Parameters:
alpha Alpha value to use.
Returns:
Nothing.

void CEGUI::ColourRect::setBottomAlpha ( float alpha )

Set the alpha value to use for the bottom edge of the ColourRect.

Parameters:
alpha Alpha value to use.
Returns:
Nothing.

void CEGUI::ColourRect::setColours ( const colour & col )

Set the colour of all four corners simultaneously.

Parameters:
col colour that is to be set for all four corners of the ColourRect;

void CEGUI::ColourRect::setLeftAlpha ( float alpha )

Set the alpha value to use for the left edge of the ColourRect.

Parameters:
alpha Alpha value to use.
Returns:
Nothing.

void CEGUI::ColourRect::setRightAlpha ( float alpha )

Set the alpha value to use for the right edge of the ColourRect.

Parameters:
alpha Alpha value to use.
Returns:
Nothing.

void CEGUI::ColourRect::setTopAlpha ( float alpha )

Set the alpha value to use for the top edge of the ColourRect.

Parameters:
alpha Alpha value to use.
Returns:
Nothing.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::ColumnHeader Class Reference

CEGUI::MultiColumnListProperties::ColumnHeader

CEGUI::MultiColumnListProperties::ColumnHeader Class Reference

Property to access a column. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::ColumnHeader:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::ColumnHeader:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access a column.

Usage:
  • Name: ColumnHeader
  • Format: "text:[caption] width:[float] id:[uint]"
where:
  • [caption] is the column header caption text.
  • [float] is the width of the column.
  • [uint] is the unique ID for the column.

Member Function Documentation

String CEGUI::MultiColumnListProperties::ColumnHeader::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::ColumnHeader::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::ColumnsMovable Class Reference

CEGUI::MultiColumnListProperties::ColumnsMovable

CEGUI::MultiColumnListProperties::ColumnsMovable Class Reference

Property to access the setting for user moving of the column headers. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::ColumnsMovable:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::ColumnsMovable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for user moving of the column headers.

Usage:
  • Name: ColumnsMovable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the column headers can be moved by the user.
  • "False" to indicate the column headers can not be moved by the user.

Member Function Documentation

String CEGUI::MultiColumnListProperties::ColumnsMovable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::ColumnsMovable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderProperties::ColumnsMovable Class Reference

CEGUI::ListHeaderProperties::ColumnsMovable

CEGUI::ListHeaderProperties::ColumnsMovable Class Reference

Property to access the setting for user moving of the column headers. More...

Inheritance diagram for CEGUI::ListHeaderProperties::ColumnsMovable:

[legend]
Collaboration diagram for CEGUI::ListHeaderProperties::ColumnsMovable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for user moving of the column headers.

Usage:
  • Name: ColumnsMovable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the column headers can be moved by the user.
  • "False" to indicate the column headers can not be moved by the user.

Member Function Documentation

String CEGUI::ListHeaderProperties::ColumnsMovable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderProperties::ColumnsMovable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::ColumnsSizable Class Reference

CEGUI::MultiColumnListProperties::ColumnsSizable

CEGUI::MultiColumnListProperties::ColumnsSizable Class Reference

Property to access the setting for user sizing of the column headers. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::ColumnsSizable:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::ColumnsSizable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for user sizing of the column headers.

Usage:
  • Name: ColumnsSizable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the column headers can be sized by the user.
  • "False" to indicate the column headers can not be sized by the user.

Member Function Documentation

String CEGUI::MultiColumnListProperties::ColumnsSizable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::ColumnsSizable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderProperties::ColumnsSizable Class Reference

CEGUI::ListHeaderProperties::ColumnsSizable

CEGUI::ListHeaderProperties::ColumnsSizable Class Reference

Property to access the setting for user sizing of the column headers. More...

Inheritance diagram for CEGUI::ListHeaderProperties::ColumnsSizable:

[legend]
Collaboration diagram for CEGUI::ListHeaderProperties::ColumnsSizable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for user sizing of the column headers.

Usage:
  • Name: ColumnsSizable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the column headers can be sized by the user.
  • "False" to indicate the column headers can not be sized by the user.

Member Function Documentation

String CEGUI::ListHeaderProperties::ColumnsSizable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderProperties::ColumnsSizable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Combobox Class Reference

CEGUI::Combobox

CEGUI::Combobox Class Reference

Base class for the Combobox widget. More...

Inheritance diagram for CEGUI::Combobox:

[legend]
Collaboration diagram for CEGUI::Combobox:

[legend]
List of all members.

Public Member Functions

virtual bool | isHit (const Point &position) const
check if the given position would hit this window.
bool | getSingleClickEnabled (void) const
returns the mode of operation for the combo box.
bool | isDropDownListVisible (void) const
returns true if the drop down list is visible.
bool | hasInputFocus (void) const
return true if the Editbox has input focus.
bool | isReadOnly (void) const
return true if the Editbox is read-only.
bool | isTextValid (void) const
return true if the Editbox text is valid given the currently set validation string.
const String & | getValidationString (void) const
return the currently set validation string
size_t | getCaratIndex (void) const
return the current position of the carat.
size_t | getSelectionStartIndex (void) const
return the current selection start point.
size_t | getSelectionEndIndex (void) const
return the current selection end point.
size_t | getSelectionLength (void) const
return the length of the current selection (in code points / characters).
size_t | getMaxTextLength (void) const
return the maximum text length set for this Editbox.
colour | getNormalTextColour (void) const
return the currently set colour to be used for rendering Editbox text in the normal, unselected state.
colour | getSelectedTextColour (void) const
return the currently set colour to be used for rendering the Editbox text when within the selected region.
colour | getNormalSelectBrushColour (void) const
return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is active.
colour | getInactiveSelectBrushColour (void) const
return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.
size_t | getItemCount (void) const
Return number of items attached to the list box.
ListboxItem * | getSelectedItem (void) const
Return a pointer to the currently selected item.
ListboxItem * | getListboxItemFromIndex (size_t index) const
Return the item at index position index.
size_t | getItemIndex (const ListboxItem *item) const
Return the index of ListboxItem item.
bool | isSortEnabled (void) const
return whether list sorting is enabled
bool | isItemSelected (size_t index) const
return whether the string at index position index is selected
ListboxItem * | findItemWithText (const String &text, const ListboxItem *start_item)
Search the list for an item with the specified text.
bool | isListboxItemInList (const ListboxItem *item) const
Return whether the specified ListboxItem is in the List.
bool | isVertScrollbarAlwaysShown (void) const
Return whether the vertical scroll bar is always shown.
bool | isHorzScrollbarAlwaysShown (void) const
Return whether the horizontal scroll bar is always shown.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | showDropList (void)
Show the drop-down list.
void | hideDropList (void)
Hide the drop-down list.
void | setSingleClickEnabled (bool setting)
Set the mode of operation for the combo box.
void | setReadOnly (bool setting)
Specify whether the Editbox is read-only.
void | setValidationString (const String &validation_string)
Set the text validation string.
void | setCaratIndex (size_t carat_pos)
Set the current position of the carat.
void | setSelection (size_t start_pos, size_t end_pos)
Define the current selection for the Editbox.
void | setMaxTextLength (size_t max_len)
set the maximum text length for this Editbox.
void | setNormalTextColour (colour col)
Set the colour to be used for rendering Editbox text in the normal, unselected state.
void | setSelectedTextColour (colour col)
Set the colour to be used for rendering the Editbox text when within the selected region.
void | setNormalSelectBrushColour (colour col)
Set the colour to be used for rendering the Editbox selection highlight when the Editbox is active.
void | setInactiveSelectBrushColour (colour col)
Set the colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.
void | activateEditbox (void)
Activate the edit box component of the Combobox.
void | resetList (void)
Remove all items from the list.
void | addItem (ListboxItem *item)
Add the given ListboxItem to the list.
void | insertItem (ListboxItem *item, const ListboxItem *position)
Insert an item into the list box after a specified item already in the list.
void | removeItem (const ListboxItem *item)
Removes the given item from the list box.
void | clearAllSelections (void)
Clear the selected state for all items.
void | setSortingEnabled (bool setting)
Set whether the list should be sorted.
void | setShowVertScrollbar (bool setting)
Set whether the vertical scroll bar should always be shown.
void | setShowHorzScrollbar (bool setting)
Set whether the horizontal scroll bar should always be shown.
void | setItemSelectState (ListboxItem *item, bool state)
Set the select state of an attached ListboxItem.
void | setItemSelectState (size_t item_index, bool state)
Set the select state of an attached ListboxItem.
void | handleUpdatedListItemData (void)
Causes the list box to update it's internal state after changes have been made to one or more attached ListboxItem objects.
Combobox (const String &type, const String &name)
Constructor for Combobox base class.
virtual | ~Combobox (void)
Destructor for Combobox base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventReadOnlyModeChanged
The read-only mode for the edit box has been changed.
static const String | EventValidationStringChanged
The validation string has been changed.
static const String | EventMaximumTextLengthChanged
The maximum allowable string length has been changed.
static const String | EventTextInvalidated
Some operation has made the current text invalid with regards to the validation string.
static const String | EventInvalidEntryAttempted
The user attempted to modify the text in a way that would have made it invalid.
static const String | EventCaratMoved
The text carat (insert point) has changed.
static const String | EventTextSelectionChanged
The current text selection has changed.
static const String | EventEditboxFull
The number of characters in the edit box has reached the current maximum.
static const String | EventTextAccepted
The user has accepted the current text by pressing Return, Enter, or Tab.
static const String | EventListContentsChanged
Event triggered when the contents of the list is changed.
static const String | EventListSelectionChanged
Event triggered when there is a change to the currently selected item(s).
static const String | EventSortModeChanged
Event triggered when the sort mode setting changes.
static const String | EventVertScrollbarModeChanged
Event triggered when the vertical scroll bar 'force' setting changes.
static const String | EventHorzScrollbarModeChanged
Event triggered when the horizontal scroll bar 'force' setting changes.
static const String | EventDropListDisplayed
Event triggered when the drop-down list is displayed.
static const String | EventDropListRemoved
Event triggered when the drop-down list is removed / hidden.
static const String | EventListSelectionAccepted
Event triggered when the user accepts a selection from the drop-down list.

Protected Member Functions

void | addComboboxEvents (void)
Add combo box specific events.
virtual Editbox * | createEditbox (const String &name) const =0
Create, initialise, and return a pointer to an Editbox widget to be used as part of this Combobox.
virtual PushButton * | createPushButton (const String &name) const =0
Create, initialise, and return a pointer to a PushButton widget to be used as part of this Combobox.
virtual ComboDropList * | createDropList (const String &name) const =0
Create, initialise, and return a pointer to a ComboDropList widget to be used as part of this Combobox.
bool | button_PressHandler (const EventArgs &e)
Handler function for button clicks.
bool | droplist_SelectionAcceptedHandler (const EventArgs &e)
Handler for selections made in the drop-list.
bool | droplist_HiddenHandler (const EventArgs &e)
Handler for when drop-list hides itself.
bool | editbox_MouseDownHandler (const EventArgs &e)
Mouse button down handler attached to edit box.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
bool | editbox_ReadOnlyChangedHandler (const EventArgs &e)
bool | editbox_ValidationStringChangedHandler (const EventArgs &e)
bool | editbox_MaximumTextLengthChangedHandler (const EventArgs &e)
bool | editbox_TextInvalidatedEventHandler (const EventArgs &e)
bool | editbox_InvalidEntryAttemptedHandler (const EventArgs &e)
bool | editbox_CaratMovedHandler (const EventArgs &e)
bool | editbox_TextSelectionChangedHandler (const EventArgs &e)
bool | editbox_EditboxFullEventHandler (const EventArgs &e)
bool | editbox_TextAcceptedEventHandler (const EventArgs &e)
bool | editbox_TextChangedEventHandler (const EventArgs &e)
bool | listbox_ListContentsChangedHandler (const EventArgs &e)
bool | listbox_ListSelectionChangedHandler (const EventArgs &e)
bool | listbox_SortModeChangedHandler (const EventArgs &e)
bool | listbox_VertScrollModeChangedHandler (const EventArgs &e)
bool | listbox_HorzScrollModeChangedHandler (const EventArgs &e)
virtual void | onReadOnlyChanged (WindowEventArgs &e)
Handler called internally when the read only state of the Combobox's Editbox has been changed.
virtual void | onValidationStringChanged (WindowEventArgs &e)
Handler called internally when the Combobox's Editbox validation string has been changed.
virtual void | onMaximumTextLengthChanged (WindowEventArgs &e)
Handler called internally when the Combobox's Editbox maximum text length is changed.
virtual void | onTextInvalidatedEvent (WindowEventArgs &e)
Handler called internally when the Combobox's Editbox text has been invalidated.
virtual void | onInvalidEntryAttempted (WindowEventArgs &e)
Handler called internally when an invalid entry was attempted in the Combobox's Editbox.
virtual void | onCaratMoved (WindowEventArgs &e)
Handler called internally when the carat in the Comboxbox's Editbox moves.
virtual void | onTextSelectionChanged (WindowEventArgs &e)
Handler called internally when the selection within the Combobox's Editbox changes.
virtual void | onEditboxFullEvent (WindowEventArgs &e)
Handler called internally when the maximum length is reached for text in the Combobox's Editbox.
virtual void | onTextAcceptedEvent (WindowEventArgs &e)
Handler called internally when the text in the Combobox's Editbox is accepted (by various means).
virtual void | onListContentsChanged (WindowEventArgs &e)
Handler called internally when the Combobox's Drop-down list contents are changed.
virtual void | onListSelectionChanged (WindowEventArgs &e)
Handler called internally when the selection within the Combobox's drop-down list changes (this is not the 'final' accepted selection, just the currently highlighted item).
virtual void | onSortModeChanged (WindowEventArgs &e)
Handler called fired internally when the sort mode for the Combobox's drop-down list is changed.
virtual void | onVertScrollbarModeChanged (WindowEventArgs &e)
Handler called internally when the 'force' setting for the vertical scrollbar within the Combobox's drop-down list is changed.
virtual void | onHorzScrollbarModeChanged (WindowEventArgs &e)
Handler called internally when the 'force' setting for the horizontal scrollbar within the Combobox's drop-down list is changed.
virtual void | onDropListDisplayed (WindowEventArgs &e)
Handler called internally when the Combobox's drop-down list has been displayed.
virtual void | onDroplistRemoved (WindowEventArgs &e)
Handler called internally when the Combobox's drop-down list has been hidden.
virtual void | onListSelectionAccepted (WindowEventArgs &e)
Handler called internally when the user has confirmed a selection within the Combobox's drop-down list.
virtual void | onFontChanged (WindowEventArgs &e)
Handler called when the window's font is changed.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | onActivated (ActivationEventArgs &e)
Handler called when this window has become the active window.

Protected Attributes

Editbox * d_editbox
Editbox widget sub-component.
ComboDropList * d_droplist
ComboDropList widget sub-component.
PushButton * d_button
PushButton widget sub-component.
bool | d_singleClickOperation
true if user can show and select from list in a single click.

Detailed Description

Base class for the Combobox widget.

Member Function Documentation

void CEGUI::Combobox::activateEditbox ( void )

Activate the edit box component of the Combobox.

Returns:
Nothing.

void CEGUI::Combobox::addItem ( ListboxItem * item )

Add the given ListboxItem to the list.

Parameters:
item Pointer to the ListboxItem to be added to the list. Note that it is the passed object that is added to the list, a copy is not made. If this parameter is NULL, nothing happens.
Returns:
Nothing.

void CEGUI::Combobox::clearAllSelections ( void )

Clear the selected state for all items.

Returns:
Nothing.

virtual ComboDropList* CEGUI::Combobox::createDropList ( const String & name ) const [protected, pure virtual]

Create, initialise, and return a pointer to a ComboDropList widget to be used as part of this Combobox.

Returns:
Pointer to a ComboDropList derived class.

virtual Editbox* CEGUI::Combobox::createEditbox ( const String & name ) const [protected, pure virtual]

Create, initialise, and return a pointer to an Editbox widget to be used as part of this Combobox.

Returns:
Pointer to an Editbox derived class.

virtual PushButton* CEGUI::Combobox::createPushButton ( const String & name ) const [protected, pure virtual]

Create, initialise, and return a pointer to a PushButton widget to be used as part of this Combobox.

Returns:
Pointer to a PushButton derived class.

ListboxItem * CEGUI::Combobox::findItemWithText | ( | const String & | text,
 |  | const ListboxItem * | start_item
 | ) |

Search the list for an item with the specified text.

Parameters:
text | String object containing the text to be searched for.
start_item | ListboxItem where the search is to begin, the search will not include item. If item is NULL, the search will begin from the first item in the list.
Returns:
Pointer to the first ListboxItem in the list after item that has text matching text. If no item matches the criteria NULL is returned.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

size_t CEGUI::Combobox::getCaratIndex ( void ) const

return the current position of the carat.

Returns:
Index of the insert carat relative to the start of the text.

colour CEGUI::Combobox::getInactiveSelectBrushColour ( void ) const

return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.

Returns:
colour value describing the ARGB colour that is currently set.

size_t CEGUI::Combobox::getItemCount ( void ) const

Return number of items attached to the list box.

Returns:
the number of items currently attached to this list box.

size_t CEGUI::Combobox::getItemIndex ( const ListboxItem * item ) const

Return the index of ListboxItem item.

Parameters:
item Pointer to a ListboxItem whos zero based index is to be returned.
Returns:
Zero based index indicating the position of ListboxItem item in the list box.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

ListboxItem * CEGUI::Combobox::getListboxItemFromIndex ( size_t index ) const

Return the item at index position index.

Parameters:
index Zero based index of the item to be returned.
Returns:
Pointer to the ListboxItem at index position index in the list box.
Exceptions:
InvalidRequestException thrown if index is out of range.

size_t CEGUI::Combobox::getMaxTextLength ( void ) const

return the maximum text length set for this Editbox.

Returns:
The maximum number of code points (characters) that can be entered into this Editbox.
Note:
Depending on the validation string set, the actual length of text that can be entered may be less than the value returned here (it will never be more).

colour CEGUI::Combobox::getNormalSelectBrushColour ( void ) const

return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is active.

Returns:
colour value describing the ARGB colour that is currently set.

colour CEGUI::Combobox::getNormalTextColour ( void ) const

return the currently set colour to be used for rendering Editbox text in the normal, unselected state.

Returns:
colour value describing the ARGB colour that is currently set.

ListboxItem * CEGUI::Combobox::getSelectedItem ( void ) const

Return a pointer to the currently selected item.

Returns:
Pointer to a ListboxItem based object that is the selected item in the list. will return NULL if no item is selected.

colour CEGUI::Combobox::getSelectedTextColour ( void ) const

return the currently set colour to be used for rendering the Editbox text when within the selected region.

Returns:
colour value describing the ARGB colour that is currently set.

size_t CEGUI::Combobox::getSelectionEndIndex ( void ) const

return the current selection end point.

Returns:
Index of the selection end point relative to the start of the text. If no selection is defined this function returns the position of the carat.

size_t CEGUI::Combobox::getSelectionLength ( void ) const

return the length of the current selection (in code points / characters).

Returns:
Number of code points (or characters) contained within the currently defined selection.

size_t CEGUI::Combobox::getSelectionStartIndex ( void ) const

return the current selection start point.

Returns:
Index of the selection start point relative to the start of the text. If no selection is defined this function returns the position of the carat.

bool CEGUI::Combobox::getSingleClickEnabled ( void ) const

returns the mode of operation for the combo box.

Returns:
  • true if the user can show the list and select an item with a single mouse click.
  • false if the user must click to show the list and then click again to select an item.

const String & CEGUI::Combobox::getValidationString ( void ) const

return the currently set validation string

Note:
Validation is performed by means of a regular expression. If the text matches the regex, the text is said to have passed validation. If the text does not match with the regex then the text fails validation.
Returns:
String object containing the current validation regex data

void CEGUI::Combobox::handleUpdatedListItemData ( void )

Causes the list box to update it's internal state after changes have been made to one or more attached ListboxItem objects.

Client code must call this whenever it has made any changes to ListboxItem objects already attached to the list box. If you are just adding items, or removed items to update them prior to re-adding them, there is no need to call this method.

Returns:
Nothing.

bool CEGUI::Combobox::hasInputFocus ( void ) const

return true if the Editbox has input focus.

Returns:
true if the Editbox has keyboard input focus, false if the Editbox does not have keyboard input focus.

void CEGUI::Combobox::hideDropList ( void )

Hide the drop-down list.

Returns:
Nothing.

void CEGUI::Combobox::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::Combobox::insertItem | ( | ListboxItem * | item,
 |  | const ListboxItem * | position
 | ) |

Insert an item into the list box after a specified item already in the list.

Note that if the list is sorted, the item may not end up in the requested position.

Parameters:
item | Pointer to the ListboxItem to be inserted. Note that it is the passed object that is added to the list, a copy is not made. If this parameter is NULL, nothing happens.
position | Pointer to a ListboxItem that item is to be inserted after. If this parameter is NULL, the item is inserted at the start of the list.
Returns:
Nothing.

bool CEGUI::Combobox::isDropDownListVisible ( void ) const

returns true if the drop down list is visible.

Returns:
true if the drop down list is visible, false otherwise.

virtual bool CEGUI::Combobox::isHit ( const Point & position ) const [inline, virtual]

check if the given position would hit this window.

Parameters:
position Point object describing the position to check in screen pixels
Returns:
true if position 'hits' this Window, else false.

Reimplemented from CEGUI::Window.

bool CEGUI::Combobox::isHorzScrollbarAlwaysShown ( void ) const

Return whether the horizontal scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

bool CEGUI::Combobox::isItemSelected ( size_t index ) const

return whether the string at index position index is selected

Parameters:
index Zero based index of the item to be examined.
Returns:
true if the item at index is selected, false if the item at index is not selected.
Exceptions:
InvalidRequestException thrown if index is out of range.

bool CEGUI::Combobox::isListboxItemInList ( const ListboxItem * item ) const

Return whether the specified ListboxItem is in the List.

Returns:
true if ListboxItem item is in the list, false if ListboxItem item is not in the list.

bool CEGUI::Combobox::isReadOnly ( void ) const

return true if the Editbox is read-only.

Returns:
true if the Editbox is read only and can't be edited by the user, false if the Editbox is not read only and may be edited by the user.

bool CEGUI::Combobox::isSortEnabled ( void ) const

return whether list sorting is enabled

Returns:
true if the list is sorted, false if the list is not sorted

bool CEGUI::Combobox::isTextValid ( void ) const

return true if the Editbox text is valid given the currently set validation string.

Note:
It is possible to programmatically set 'invalid' text for the Editbox by calling setText. This has certain implications since if invalid text is set, whatever the user types into the box will be rejected when the input is validated.

Validation is performed by means of a regular expression. If the text matches the regex, the text is said to have passed validation. If the text does not match with the regex then the text fails validation.

Returns:
true if the current Editbox text passes validation, false if the text does not pass validation.

bool CEGUI::Combobox::isVertScrollbarAlwaysShown ( void ) const

Return whether the vertical scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

void CEGUI::Combobox::onActivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has become the active window.

Parameters:
e ActivationEventArgs class whose 'otherWindow' field is set to the window that previously was active, or NULL for none.

Reimplemented from CEGUI::Window.

void CEGUI::Combobox::onFontChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's font is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Combobox::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Combobox::removeItem ( const ListboxItem * item )

Removes the given item from the list box.

Parameters:
item Pointer to the ListboxItem that is to be removed. If item is not attached to this list box then nothing will happen.
Returns:
Nothing.

void CEGUI::Combobox::resetList ( void )

Remove all items from the list.

Note that this will cause 'AutoDelete' items to be deleted.

void CEGUI::Combobox::setCaratIndex ( size_t carat_pos )

Set the current position of the carat.

Parameters:
carat_pos New index for the insert carat relative to the start of the text. If the value specified is greater than the number of characters in the Editbox, the carat is positioned at the end of the text.
Returns:
Nothing.

void CEGUI::Combobox::setInactiveSelectBrushColour ( colour col )

Set the colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::Combobox::setItemSelectState | ( | size_t | item_index,
 |  | bool | state
 | ) |

Set the select state of an attached ListboxItem.

This is the recommended way of selecting and deselecting items attached to a list box as it respects the multi-select mode setting. It is possible to modify the setting on ListboxItems directly, but that approach does not respect the settings of the list box.

Parameters:
item_index | The zero based index of the ListboxItem to be affected. This must be a valid index (0 <= index < getItemCount())
state | true to select the item, false to de-select the item.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if item_index is out of range for the list box

void CEGUI::Combobox::setItemSelectState | ( | ListboxItem * | item,
 |  | bool | state
 | ) |

Set the select state of an attached ListboxItem.

This is the recommended way of selecting and deselecting items attached to a list box as it respects the multi-select mode setting. It is possible to modify the setting on ListboxItems directly, but that approach does not respect the settings of the list box.

Parameters:
item | The ListboxItem to be affected. This item must be attached to the list box.
state | true to select the item, false to de-select the item.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

void CEGUI::Combobox::setMaxTextLength ( size_t max_len )

set the maximum text length for this Editbox.

Parameters:
max_len The maximum number of code points (characters) that can be entered into this Editbox.
Note:
Depending on the validation string set, the actual length of text that can be entered may be less than the value set here (it will never be more).
Returns:
Nothing.

void CEGUI::Combobox::setNormalSelectBrushColour ( colour col )

Set the colour to be used for rendering the Editbox selection highlight when the Editbox is active.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::Combobox::setNormalTextColour ( colour col )

Set the colour to be used for rendering Editbox text in the normal, unselected state.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::Combobox::setReadOnly ( bool setting )

Specify whether the Editbox is read-only.

Parameters:
setting true if the Editbox is read only and can't be edited by the user, false if the Editbox is not read only and may be edited by the user.
Returns:
Nothing.

void CEGUI::Combobox::setSelectedTextColour ( colour col )

Set the colour to be used for rendering the Editbox text when within the selected region.

Returns:
colour value describing the ARGB colour that is currently set.

void CEGUI::Combobox::setSelection | ( | size_t | start_pos,
 |  | size_t | end_pos
 | ) |

Define the current selection for the Editbox.

Parameters:
start_pos | Index of the starting point for the selection. If this value is greater than the number of characters in the Editbox, the selection start will be set to the end of the text.
end_pos | Index of the ending point for the selection. If this value is greater than the number of characters in the Editbox, the selection start will be set to the end of the text.
Returns:
Nothing.

void CEGUI::Combobox::setShowHorzScrollbar ( bool setting )

Set whether the horizontal scroll bar should always be shown.

Parameters:
setting true if the horizontal scroll bar should be shown even when it is not required. false if the horizontal scroll bar should only be shown when it is required.
Returns:
Nothing.

void CEGUI::Combobox::setShowVertScrollbar ( bool setting )

Set whether the vertical scroll bar should always be shown.

Parameters:
setting true if the vertical scroll bar should be shown even when it is not required. false if the vertical scroll bar should only be shown when it is required.
Returns:
Nothing.

void CEGUI::Combobox::setSingleClickEnabled ( bool setting )

Set the mode of operation for the combo box.

Parameters:
setting
  • true if the user should be able to show the list and select an item with a single mouse click.
  • false if the user must click to show the list and then click again to select an item.
Returns:
Nothing.

void CEGUI::Combobox::setSortingEnabled ( bool setting )

Set whether the list should be sorted.

Parameters:
setting true if the list should be sorted, false if the list should not be sorted.
Returns:
Nothing.

void CEGUI::Combobox::setValidationString ( const String & validation_string )

Set the text validation string.

Note:
Validation is performed by means of a regular expression. If the text matches the regex, the text is said to have passed validation. If the text does not match with the regex then the text fails validation.
Parameters:
validation_string String object containing the validation regex data to be used.
Returns:
Nothing.

void CEGUI::Combobox::showDropList ( void )

Show the drop-down list.

Returns:
Nothing

virtual bool CEGUI::Combobox::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboDropList Class Reference

CEGUI::ComboDropList

CEGUI::ComboDropList Class Reference

Base class for the combo box drop down list. This is a specialisation of the Listbox class. More...

Inheritance diagram for CEGUI::ComboDropList:

[legend]
Collaboration diagram for CEGUI::ComboDropList:

[legend]
List of all members.

Public Member Functions

virtual void | initialise (void)
Initialise the Window based object ready for use.
void | setArmed (bool setting)
Set whether the drop-list is 'armed' for selection.
bool | isArmed (void) const
Return the 'armed' state of the ComboDropList.
void | setAutoArmEnabled (bool setting)
Set the mode of operation for the ComboDropList.
bool | isAutoArmEnabled (void) const
returns the mode of operation for the drop-list
ComboDropList (const String &type, const String &name)
Constructor for ComboDropList base class.
virtual | ~ComboDropList (void)
Destructor for ComboDropList base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventListSelectionAccepted
Event fired when the user confirms the selection by clicking the mouse.

Protected Member Functions

void | addComboDropListEvents (void)
Add drop-list specific events.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
void | onListSelectionAccepted (WindowEventArgs &e)
Handler for when list selection is confirmed.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onActivated (ActivationEventArgs &e)
Handler called when this window has become the active window.

Protected Attributes

bool | d_autoArm
true if the box auto-arms when the mouse enters it.
bool | d_armed
true when item selection has been armed.

Detailed Description

Base class for the combo box drop down list. This is a specialisation of the Listbox class.

Member Function Documentation

void CEGUI::ComboDropList::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Listbox.

bool CEGUI::ComboDropList::isArmed ( void ) const [inline]

Return the 'armed' state of the ComboDropList.

Returns:
  • true if the box is armed; items will be highlighted and the next left button up event will cause dismissal and possible item selection.
  • false if the box is not armed; items will not be highlighted or selected until the box is armed.

bool CEGUI::ComboDropList::isAutoArmEnabled ( void ) const [inline]

returns the mode of operation for the drop-list

Returns:
  • true if the ComboDropList auto-arms when the mouse enters the box.
  • false if the user must click to arm the box.

void CEGUI::ComboDropList::onActivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has become the active window.

Parameters:
e ActivationEventArgs class whose 'otherWindow' field is set to the window that previously was active, or NULL for none.

Reimplemented from CEGUI::Window.

void CEGUI::ComboDropList::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::ComboDropList::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Listbox.

void CEGUI::ComboDropList::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ComboDropList::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Listbox.

void CEGUI::ComboDropList::setArmed ( bool setting ) [inline]

Set whether the drop-list is 'armed' for selection.

Note:
This setting is not exclusively under client control; the ComboDropList will auto-arm in response to certain left mouse button events. This is also dependant upon the autoArm setting of the ComboDropList.
Parameters:
setting
  • true to arm the box; items will be highlighted and the next left button up event will cause dismissal and possible item selection.
  • false to disarm the box; items will not be highlighted or selected until the box is armed.

Returns:
Nothing.

void CEGUI::ComboDropList::setAutoArmEnabled ( bool setting ) [inline]

Set the mode of operation for the ComboDropList.

Parameters:
setting
  • true if the ComboDropList auto-arms when the mouse enters the box.
  • false if the user must click to arm the box.
Returns:
Nothing.

virtual bool CEGUI::ComboDropList::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Listbox.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComponentArea Class Reference

CEGUI::ComponentArea

CEGUI::ComponentArea Class Reference

Class that represents a target area for a widget or imagery component. More...

Collaboration diagram for CEGUI::ComponentArea:

[legend]
List of all members.

Public Member Functions

Rect | getPixelRect (const Window &wnd) const
Return a Rect describing the absolute pixel area represented by this ComponentArea.
Rect | getPixelRect (const Window &wnd, const Rect &container) const
Return a Rect describing the absolute pixel area represented by this ComponentArea.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this ComponentArea to out_stream.
bool | isAreaFetchedFromProperty () const
Return whether this ComponentArea fetches it's area via a property on the target window.
const String & | getAreaPropertySource () const
Return the name of the property that will be used to determine the pixel area for this ComponentArea.
void | setAreaPropertySource (const String &property)
Set the name of the property that will be used to determine the pixel area for this ComponentArea.

Public Attributes

Dimension d_left
Left edge of the area.
Dimension d_top
Top edge of the area.
Dimension d_right_or_width
Either the right edge or the width of the area.
Dimension d_bottom_or_height
Either the bototm edge or the height of the area.

Detailed Description

Class that represents a target area for a widget or imagery component.

This is essentially a Rect built out of Dimension objects. Of note is that what would normally be the 'right' and 'bottom' edges may alternatively represent width and height depending upon what the assigned Dimension(s) represent.

Member Function Documentation

const String & CEGUI::ComponentArea::getAreaPropertySource ( ) const

Return the name of the property that will be used to determine the pixel area for this ComponentArea.

Returns:
String object holding the name of a Propery.

Rect CEGUI::ComponentArea::getPixelRect | ( | const Window & | wnd,
 |  | const Rect & | container
 | ) | const

Return a Rect describing the absolute pixel area represented by this ComponentArea.

Parameters:
wnd | Window object to be used when calculating final pixel area.
container | Rect object to be used as a base or container when converting relative dimensions.
Returns:
Rect object describing the pixels area represented by this ComponentArea when using wnd and container as a reference for calculating the final pixel dimensions.

Rect CEGUI::ComponentArea::getPixelRect ( const Window & wnd ) const

Return a Rect describing the absolute pixel area represented by this ComponentArea.

Parameters:
wnd Window object to be used when calculating final pixel area.
Returns:
Rect object describing the pixels area represented by this ComponentArea when using wnd as a reference for calculating the final pixel dimensions.

bool CEGUI::ComponentArea::isAreaFetchedFromProperty ( ) const

Return whether this ComponentArea fetches it's area via a property on the target window.

Returns:
  • true if the area comes via a Propery.
  • false if the area is defined explicitly via the Dimension fields.

void CEGUI::ComponentArea::setAreaPropertySource ( const String & property )

Set the name of the property that will be used to determine the pixel area for this ComponentArea.

Parameters:
property String object holding the name of a Propery. The property should access a URect type property.
Returns:
Nothing.

void CEGUI::ComponentArea::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this ComponentArea to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Config_xmlHandler Class Reference

CEGUI::Config_xmlHandler

CEGUI::Config_xmlHandler Class Reference

Handler class used to parse the Configuration XML file. More...

Collaboration diagram for CEGUI::Config_xmlHandler:

[legend]
List of all members.

Public Member Functions

Config_xmlHandler (void)
Constructor for GUILayout_xmlHandler objects.
virtual | ~Config_xmlHandler (void)
Destructor for GUILayout_xmlHandler objects.
virtual void | elementStart (const String &element, const XMLAttributes &attributes)
document processing (only care about elements, schema validates format)
const String & | getLogFilename (void) const
Return log filename.
const String & | getSchemeFilename (void) const
Return initial scheme filename to load.
const String & | getLayoutFilename (void) const
Return initial layout filename to load and set as the GUI sheet.
const String & | getInitScriptFilename (void) const
Return the name of the initialisation script to run.
const String & | getTermScriptFilename (void) const
Return the name of the termination script to run.
const String & | getDefaultFontName (void) const
Return name of font to use as default.
const String & | getDefaultResourceGroup (void) const
Return name of default resource group.
LoggingLevel | getLoggingLevel (void) const
Return logging level which was read from the config file.

Detailed Description

Handler class used to parse the Configuration XML file.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ConstBaseIterator< T > Class Template Reference

CEGUI::ConstBaseIterator

CEGUI::ConstBaseIterator< T > Class Template Reference

Base class constant iterator used to offer iteration over various collections within the system. More...

List of all members.

Public Types

typedef T::mapped_type | mapped_type

Public Member Functions

ConstBaseIterator (typename T::const_iterator start_iter, typename T::const_iterator end_iter)
ConstBaseIterator constructor.
~ConstBaseIterator (void)
ConstBaseIterator destructor.
ConstBaseIterator (const ConstBaseIterator< T > &org)
ConstBaseIterator copy constructor.
ConstBaseIterator< T > & | operator= (const ConstBaseIterator< T > &rhs)
ConstBaseIterator assignment operator.
T::key_type | getCurrentKey (void) const
Return the key for the item at the current iterator position.
mapped_type | getCurrentValue (void) const
Return the value for the item at the current iterator position.
bool | isAtEnd (void) const
Return whether the current iterator position is at the end of the iterators range.
bool | isAtStart (void) const
Return whether the current iterator position is at the start of the iterators range.
ConstBaseIterator< T > & | operator++ ()
Increase the iterator position (prefix increment).
ConstBaseIterator< T > | operator++ (int)
Increase the iterator position (postfix increment).
ConstBaseIterator< T > & | operator-- ()
Decrease the iterator position (prefix decrement).
ConstBaseIterator< T > | operator-- (int)
Decrease the iterator position (postfix decrement).
bool | operator== (const ConstBaseIterator< T > &rhs) const
Compares two iterators. Return true if the current position of both iterators are equivalent.
bool | operator!= (const ConstBaseIterator< T > &rhs) const
Compares two iterators. Return true if the current position of the iterators are different.
mapped_type | operator * () const
Return the value for the current iterator position.
void | toStart (void)
Set the iterator current position to the start position.
void | toEnd (void)
Set the iterator current position to the end position.

Detailed Description

template<class T>
class CEGUI::ConstBaseIterator< T >

Base class constant iterator used to offer iteration over various collections within the system.

Constructor & Destructor Documentation

template<class T>
CEGUI::ConstBaseIterator< T >::ConstBaseIterator | ( | typename T::const_iterator | start_iter,
 |  | typename T::const_iterator | end_iter
 | ) | [inline]

ConstBaseIterator constructor.

Parameters:
start_iter | 'real' iterator that will be the start of the range to be iterated over by this iterator.
end_iter | 'real' iterator that will be the end of the range to be iterated over by this iterator.

Member Function Documentation

template<class T>
ConstBaseIterator<T> CEGUI::ConstBaseIterator< T >::operator++ ( int ) [inline]

Increase the iterator position (postfix increment).

Note:
The iterator is checked, and this call will always succeed, so do not rely on some exception to exit a loop.

template<class T>
ConstBaseIterator<T>& CEGUI::ConstBaseIterator< T >::operator++ ( ) [inline]

Increase the iterator position (prefix increment).

Note:
The iterator is checked, and this call will always succeed, so do not rely on some exception to exit a loop.

template<class T>
ConstBaseIterator<T> CEGUI::ConstBaseIterator< T >::operator-- ( int ) [inline]

Decrease the iterator position (postfix decrement).

Note:
The iterator is checked, and this call will always succeed, so do not rely on some exception to exit a loop.

template<class T>
ConstBaseIterator<T>& CEGUI::ConstBaseIterator< T >::operator-- ( ) [inline]

Decrease the iterator position (prefix decrement).

Note:
The iterator is checked, and this call will always succeed, so do not rely on some exception to exit a loop.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::ContentArea Class Reference

CEGUI::ScrollablePaneProperties::ContentArea

CEGUI::ScrollablePaneProperties::ContentArea Class Reference

Property to access the current content pane area rectangle (as window relative pixels). More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::ContentArea:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::ContentArea:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current content pane area rectangle (as window relative pixels).

Usage:
  • Name: ContentArea
  • Format: "l:[float] t:[float] r:[float] b:[float]".
Where:
  • l:[float] specifies the position of the left edge of the area as a floating point number.
  • t:[float] specifies the position of the top edge of the area as a floating point number.
  • r:[float] specifies the position of the right edge of the area as a floating point number.
  • b:[float] specifies the position of the bottom edge of the area as a floating point number.

Member Function Documentation

String CEGUI::ScrollablePaneProperties::ContentArea::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::ContentArea::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrolledContainerProperties::ContentArea Class Reference

CEGUI::ScrolledContainerProperties::ContentArea

CEGUI::ScrolledContainerProperties::ContentArea Class Reference

Property to access the current content pane area rectangle (as window relative pixels). More...

Inheritance diagram for CEGUI::ScrolledContainerProperties::ContentArea:

[legend]
Collaboration diagram for CEGUI::ScrolledContainerProperties::ContentArea:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current content pane area rectangle (as window relative pixels).

Usage:
  • Name: ContentArea
  • Format: "l:[float] t:[float] r:[float] b:[float]".
Where:
  • l:[float] specifies the position of the left edge of the area as a floating point number.
  • t:[float] specifies the position of the top edge of the area as a floating point number.
  • r:[float] specifies the position of the right edge of the area as a floating point number.
  • b:[float] specifies the position of the bottom edge of the area as a floating point number.

Member Function Documentation

String CEGUI::ScrolledContainerProperties::ContentArea::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrolledContainerProperties::ContentArea::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::ContentPaneAutoSized Class Reference

CEGUI::ScrollablePaneProperties::ContentPaneAutoSized

CEGUI::ScrollablePaneProperties::ContentPaneAutoSized Class Reference

Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::ContentPaneAutoSized:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::ContentPaneAutoSized:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content.

Usage:
  • Name: ContentPaneAutoSized
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the pane should automatically resize itself.
  • "False" to indicate the pane should not automatically resize itself.

Member Function Documentation

String CEGUI::ScrollablePaneProperties::ContentPaneAutoSized::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::ContentPaneAutoSized::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrolledContainerProperties::ContentPaneAutoSized Class Reference

CEGUI::ScrolledContainerProperties::ContentPaneAutoSized

CEGUI::ScrolledContainerProperties::ContentPaneAutoSized Class Reference

Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content. More...

Inheritance diagram for CEGUI::ScrolledContainerProperties::ContentPaneAutoSized:

[legend]
Collaboration diagram for CEGUI::ScrolledContainerProperties::ContentPaneAutoSized:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content.

Usage:
  • Name: ContentPaneAutoSized
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the pane should automatically resize itself.
  • "False" to indicate the pane should not automatically resize itself.

Member Function Documentation

String CEGUI::ScrolledContainerProperties::ContentPaneAutoSized::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrolledContainerProperties::ContentPaneAutoSized::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ProgressBarProperties::CurrentProgress Class Reference

CEGUI::ProgressBarProperties::CurrentProgress

CEGUI::ProgressBarProperties::CurrentProgress Class Reference

Property to access the current progress of the progress bar. More...

Inheritance diagram for CEGUI::ProgressBarProperties::CurrentProgress:

[legend]
Collaboration diagram for CEGUI::ProgressBarProperties::CurrentProgress:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current progress of the progress bar.

Usage:
  • Name: CurrentProgress
  • Format: "[float]".
Where:
  • [float] is the current progress of the bar expressed as a value between 0 and 1.

Member Function Documentation

String CEGUI::ProgressBarProperties::CurrentProgress::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ProgressBarProperties::CurrentProgress::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SliderProperties::CurrentValue Class Reference

CEGUI::SliderProperties::CurrentValue

CEGUI::SliderProperties::CurrentValue Class Reference

Property to access the current value of the slider. More...

Inheritance diagram for CEGUI::SliderProperties::CurrentValue:

[legend]
Collaboration diagram for CEGUI::SliderProperties::CurrentValue:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current value of the slider.

Usage:
  • Name: CurrentValue
  • Format: "[float]".
Where:
  • [float] represents the current value of the slider.

Member Function Documentation

String CEGUI::SliderProperties::CurrentValue::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SliderProperties::CurrentValue::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SpinnerProperties::CurrentValue Class Reference

CEGUI::SpinnerProperties::CurrentValue

CEGUI::SpinnerProperties::CurrentValue Class Reference

Property to access the current value of the spinner. More...

Inheritance diagram for CEGUI::SpinnerProperties::CurrentValue:

[legend]
Collaboration diagram for CEGUI::SpinnerProperties::CurrentValue:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current value of the spinner.

Usage:
  • Name: CurrentValue
  • Format: "[float]".
Where:
  • [float] represents the current value of the Spinner widget.

Member Function Documentation

String CEGUI::SpinnerProperties::CurrentValue::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SpinnerProperties::CurrentValue::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::CustomTooltipType Class Reference

CEGUI::WindowProperties::CustomTooltipType

CEGUI::WindowProperties::CustomTooltipType Class Reference

Property to access the custom tooltip for this Window. More...

Inheritance diagram for CEGUI::WindowProperties::CustomTooltipType:

[legend]
Collaboration diagram for CEGUI::WindowProperties::CustomTooltipType:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the custom tooltip for this Window.

Usage:
  • Name: CustomTooltipType
  • Format: "[text]".
Where:
  • [Text] is the typename of the custom tooltip for the Window.

Member Function Documentation

String CEGUI::WindowProperties::CustomTooltipType::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::CustomTooltipType::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::DestroyedByParent Class Reference

CEGUI::WindowProperties::DestroyedByParent

CEGUI::WindowProperties::DestroyedByParent Class Reference

Property to access window Destroyed by Parent setting. More...

Inheritance diagram for CEGUI::WindowProperties::DestroyedByParent:

[legend]
Collaboration diagram for CEGUI::WindowProperties::DestroyedByParent:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window Destroyed by Parent setting.

This property offers access to the destryed by parent setting for the window.

Usage:
  • Name: DestroyedByParent
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window should be automatically destroyed when it's parent Window is destroyed.
  • "False" to indicate the Window should not be destroyed when it's parent Window is destroyed.

Member Function Documentation

String CEGUI::WindowProperties::DestroyedByParent::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::DestroyedByParent::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Dimension Class Reference

CEGUI::Dimension

CEGUI::Dimension Class Reference

Class representing some kind of dimension. More...

Collaboration diagram for CEGUI::Dimension:

[legend]
List of all members.

Public Member Functions

Dimension ()
Constructor.
~Dimension ()
Destructor.
Dimension (const BaseDim &dim, DimensionType type)
Constructor.
Dimension (const Dimension &other)
Copy constructor.
Dimension & | operator= (const Dimension &other)
Assignment operator.
const BaseDim & | getBaseDimension () const
return the BaseDim object currently used as the value for this Dimension.
void | setBaseDimension (const BaseDim &dim)
set the current value for this Dimension.
DimensionType | getDimensionType () const
Return a DimensionType value indicating what this Dimension represents.
void | setDimensionType (DimensionType type)
Sets what this Dimension represents.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this Dimension to out_stream.

Detailed Description

Class representing some kind of dimension.

The key thing to understand about Dimension is that it contains not just a dimensional value, but also a record of what the dimension value is supposed to represent. (e.g. a co-ordinate on the x axis, or the height of something).

Constructor & Destructor Documentation

CEGUI::Dimension::Dimension | ( | const BaseDim & | dim,
 |  | DimensionType | type
 | ) |

Constructor.

Parameters:
dim | object based on subclass of BaseDim which holds the dimensional value.
type | DimensionType value indicating what dimension this object is to represent.

Member Function Documentation

const BaseDim & CEGUI::Dimension::getBaseDimension ( ) const

return the BaseDim object currently used as the value for this Dimension.

Returns:
const reference to the BaseDim sub-class object which contains the value for this Dimension.

DimensionType CEGUI::Dimension::getDimensionType ( ) const

Return a DimensionType value indicating what this Dimension represents.

Returns:
one of the DimensionType enumerated values.

void CEGUI::Dimension::setBaseDimension ( const BaseDim & dim )

set the current value for this Dimension.

Parameters:
dim object based on a subclass of BaseDim which holds the dimensional value.
Returns:
Nothing.

void CEGUI::Dimension::setDimensionType ( DimensionType type )

Sets what this Dimension represents.

Parameters:
type one of the DimensionType enumerated values.
Returns:
Nothing.

void CEGUI::Dimension::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this Dimension to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DirectX81Renderer Class Reference

CEGUI::DirectX81Renderer

CEGUI::DirectX81Renderer Class Reference

Renderer class to interface with Microsoft DirectX 8.1. More...

Inheritance diagram for CEGUI::DirectX81Renderer:

[legend]
Collaboration diagram for CEGUI::DirectX81Renderer:

[legend]
List of all members.

Public Member Functions

DirectX81Renderer (LPDIRECT3DDEVICE8 device, uint max_quads=0)
Constructor for Direct3D 8.1 Renderer object.
DirectX81Renderer (LPDIRECT3DDEVICE8 device, const Size &sz)
Constructor for Direct3D 8.1 Renderer object.
virtual | ~DirectX81Renderer (void)
Destructor for DirectX81Renderer objects.
virtual void | addQuad (const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode)
Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.
virtual void | doRender (void)
Perform final rendering for all quads that have been queued for rendering.
virtual void | clearRenderList (void)
Clears all queued quads from the render queue.
virtual void | setQueueingEnabled (bool setting)
Enable or disable the queueing of quads from this point on.
virtual Texture * | createTexture (void)
Creates a 'null' Texture object.
virtual Texture * | createTexture (const String &filename, const String &resourceGroup)
Create a Texture object using the given image file.
virtual Texture * | createTexture (float size)
Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.
virtual void | destroyTexture (Texture *texture)
Destroy the given Texture object.
virtual void | destroyAllTextures (void)
Destroy all Texture objects.
LPDIRECT3DDEVICE8 | getDevice (void) const
virtual bool | isQueueingEnabled (void) const
Return whether queueing is enabled.
virtual float | getWidth (void) const
Return the current width of the display in pixels.
virtual float | getHeight (void) const
Return the current height of the display in pixels.
virtual Size | getSize (void) const
Return the size of the display in pixels.
virtual Rect | getRect (void) const
Return a Rect describing the screen.
virtual uint | getMaxTextureSize (void) const
Return the maximum texture size available.
virtual uint | getHorzScreenDPI (void) const
Return the horizontal display resolution dpi.
virtual uint | getVertScreenDPI (void) const
Return the vertical display resolution dpi.
virtual void | preD3DReset (void)
Direct3D support method that must be called prior to a Reset call on the Direct3DDevice; this is required so that the GUI renderer can release any unmanaged D3D resources as needed for the device reset to succeed.
virtual void | postD3DReset (void)
Direct3D support method that must be called after a Reset call on the Direct3DDevice; this is required so that the GUI renderer can rebuild any unmanaged D3D resources after the device has been reset.
void | setDisplaySize (const Size &sz)
Set the size of the display in pixels.

Classes

struct | QuadInfo
structure holding details about a quad to be drawn
struct | QuadVertex
FVF structure used for all vertices.

Detailed Description

Renderer class to interface with Microsoft DirectX 8.1.

Constructor & Destructor Documentation

CEGUI::DirectX81Renderer::DirectX81Renderer | ( | LPDIRECT3DDEVICE8 | device,
 |  | uint | max_quads = 0
 | ) |

Constructor for Direct3D 8.1 Renderer object.

Parameters:
device | Pointer to the IDirect3DDevice8 interface object that will be used for all rendering
max_quads | Obsolete. Set to 0.

CEGUI::DirectX81Renderer::DirectX81Renderer | ( | LPDIRECT3DDEVICE8 | device,
 |  | const Size & | sz
 | ) |

Constructor for Direct3D 8.1 Renderer object.

Parameters:
device | Pointer to the IDirect3DDevice8 interface object that will be used for all rendering
sz | Size object describing the initial size of the display (the dimensions should be >0)

Member Function Documentation

void CEGUI::DirectX81Renderer::addQuad | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Texture * | tex,
 |  | const Rect & | texture_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode
 | ) | [virtual]

Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.

Parameters:
dest_rect | Rect object describing the destination area (values are in pixels)
z | float value specifying the z co-ordinate / z order of the quad
tex | pointer to the Texture object that holds the imagery to be rendered
texture_rect | Rect object holding the area of tex that is to be rendered (values are in texture co-ordinates).
colours | ColourRect object describing the colour values that are to be applied when rendering.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::DirectX81Renderer::clearRenderList ( void ) [virtual]

Clears all queued quads from the render queue.

Returns:
Nothing

Implements CEGUI::Renderer.

Texture * CEGUI::DirectX81Renderer::createTexture ( float size ) [virtual]

Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.

Parameters:
size float value that specifies the size to use for the width and height when creating the new texture.
Returns:
a newly created Texture object. The initial contents of the texture memory is undefined / random.
Note:
Textures are always created with a size that is a power of 2. If you specify a size that is not a power of two, the final size will be rounded up. So if you specify a size of 1024, the texture will be (1024 x 1024), however, if you specify a size of 1025, the texture will be (2048 x 2048). You can check the ultimate size by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::DirectX81Renderer::createTexture | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Create a Texture object using the given image file.

Parameters:
filename | String object that specifies the path and filename of the image file to use when creating the texture.
resourceGroup | Resource group identifier to be passed to the resource provider when loading the texture file.
Returns:
a newly created Texture object. The initial contents of the texture memory is the requested image file.
Note:
Textures are always created with a size that is a power of 2. If the file you specify is of a size that is not a power of two, the final size will be rounded up. Additionally, textures are always square, so the ultimate size is governed by the larger of the width and height of the specified file. You can check the ultimate sizes by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::DirectX81Renderer::createTexture ( void ) [virtual]

Creates a 'null' Texture object.

Returns:
a newly created Texture object. The returned Texture object has no size or imagery associated with it, and is generally of little or no use.

Implements CEGUI::Renderer.

void CEGUI::DirectX81Renderer::destroyAllTextures ( void ) [virtual]

Destroy all Texture objects.

Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::DirectX81Renderer::destroyTexture ( Texture * texture ) [virtual]

Destroy the given Texture object.

Parameters:
texture pointer to the Texture object to be destroyed
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::DirectX81Renderer::doRender ( void ) [virtual]

Perform final rendering for all quads that have been queued for rendering.

The contents of the rendering queue is retained and can be rendered again as required. If the contents is not required call clearRenderList().

Returns:
Nothing

Implements CEGUI::Renderer.

virtual float CEGUI::DirectX81Renderer::getHeight ( void ) const [inline, virtual]

Return the current height of the display in pixels.

Returns:
float value equal to the current height of the display in pixels.

Implements CEGUI::Renderer.

virtual uint CEGUI::DirectX81Renderer::getHorzScreenDPI ( void ) const [inline, virtual]

Return the horizontal display resolution dpi.

Returns:
horizontal resolution of the display in dpi.

Implements CEGUI::Renderer.

virtual uint CEGUI::DirectX81Renderer::getMaxTextureSize ( void ) const [inline, virtual]

Return the maximum texture size available.

Returns:
Size of the maximum supported texture in pixels (textures are always assumed to be square)

Implements CEGUI::Renderer.

virtual Rect CEGUI::DirectX81Renderer::getRect ( void ) const [inline, virtual]

Return a Rect describing the screen.

Returns:
A Rect object that describes the screen area. Typically, the top-left values are always 0, and the size of the area described is equal to the screen resolution.

Implements CEGUI::Renderer.

virtual Size CEGUI::DirectX81Renderer::getSize ( void ) const [inline, virtual]

Return the size of the display in pixels.

Returns:
Size object describing the dimensions of the current display.

Implements CEGUI::Renderer.

virtual uint CEGUI::DirectX81Renderer::getVertScreenDPI ( void ) const [inline, virtual]

Return the vertical display resolution dpi.

Returns:
vertical resolution of the display in dpi.

Implements CEGUI::Renderer.

virtual float CEGUI::DirectX81Renderer::getWidth ( void ) const [inline, virtual]

Return the current width of the display in pixels.

Returns:
float value equal to the current width of the display in pixels.

Implements CEGUI::Renderer.

virtual bool CEGUI::DirectX81Renderer::isQueueingEnabled ( void ) const [inline, virtual]

Return whether queueing is enabled.

Returns:
true if queueing is enabled, false if queueing is disabled.

Implements CEGUI::Renderer.

void CEGUI::DirectX81Renderer::setDisplaySize ( const Size & sz )

Set the size of the display in pixels.

This method is important if your D3D 8 device is a pure device; since with a pure device the system is unable to determine the size of the view port, so you must manually tell it the size by using this method.

Note:
This method will cause the EventDisplaySizeChanged event to fire if the display size has changed.
Parameters:
sz Size object describing the size of the display.
Returns:
Nothing.

virtual void CEGUI::DirectX81Renderer::setQueueingEnabled ( bool setting ) [inline, virtual]

Enable or disable the queueing of quads from this point on.

This only affects queueing. If queueing is turned off, any calls to addQuad will cause the quad to be rendered directly. Note that disabling queueing will not cause currently queued quads to be rendered, nor is the queue cleared - at any time the queue can still be drawn by calling doRender, and the list can be cleared by calling clearRenderList. Re-enabling the queue causes subsequent quads to be added as if queueing had never been disabled.

Parameters:
setting true to enable queueing, or false to disable queueing (see notes above).
Returns:
Nothing

Implements CEGUI::Renderer.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DirectX81Texture Class Reference

CEGUI::DirectX81Texture

CEGUI::DirectX81Texture Class Reference

Texture class that is created by DirectX81Renderer objects. More...

Inheritance diagram for CEGUI::DirectX81Texture:

[legend]
Collaboration diagram for CEGUI::DirectX81Texture:

[legend]
List of all members.

Public Member Functions

virtual ushort | getWidth (void) const
Returns the current pixel width of the texture.
virtual ushort | getHeight (void) const
Returns the current pixel height of the texture.
virtual void | loadFromFile (const String &filename, const String &resourceGroup)
Loads the specified image file into the texture. The texture is resized as required to hold the image.
virtual void | loadFromMemory (const void *buffPtr, uint buffWidth, uint buffHeight)
Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.
LPDIRECT3DTEXTURE8 | getD3DTexture (void) const
Return a pointer to the internal Direct3DTexture8 object.
void | setD3DTextureSize (uint size)
set the size of the internal D3D texture. Previous D3D texture is lost.
virtual void | preD3DReset (void)
Direct3D support method that must be called prior to a Reset call on the Direct3DDevice; this is required so that the GUI renderer can release any unmanaged D3D resources as needed for the device reset to succeed.
virtual void | postD3DReset (void)
Direct3D support method that must be called after a Reset call on the Direct3DDevice; this is required so that the GUI renderer can rebuild any unmanaged D3D resources after the device has been reset.

Friends

Texture * | DirectX81Renderer::createTexture (void)
Texture * | DirectX81Renderer::createTexture (const String &filename, const String &resourceGroup)
Texture * | DirectX81Renderer::createTexture (float size)
void | DirectX81Renderer::destroyTexture (Texture *texture)

Detailed Description

Texture class that is created by DirectX81Renderer objects.

Member Function Documentation

LPDIRECT3DTEXTURE8 CEGUI::DirectX81Texture::getD3DTexture ( void ) const [inline]

Return a pointer to the internal Direct3DTexture8 object.

Returns:
Pointer to the IDirect3DTexture8 interface currently being used by this Texture object

virtual ushort CEGUI::DirectX81Texture::getHeight ( void ) const [inline, virtual]

Returns the current pixel height of the texture.

Returns:
ushort value that is the current height of the texture in pixels

Implements CEGUI::Texture.

virtual ushort CEGUI::DirectX81Texture::getWidth ( void ) const [inline, virtual]

Returns the current pixel width of the texture.

Returns:
ushort value that is the current width of the texture in pixels

Implements CEGUI::Texture.

void CEGUI::DirectX81Texture::loadFromFile | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Loads the specified image file into the texture. The texture is resized as required to hold the image.

Parameters:
filename | The filename of the image file that is to be loaded into the texture
resourceGroup | Resource group identifier passed to the resource provider.
Returns:
Nothing.

Implements CEGUI::Texture.

void CEGUI::DirectX81Texture::loadFromMemory | ( | const void * | buffPtr,
 |  | uint | buffWidth,
 |  | uint | buffHeight
 | ) | [virtual]

Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.

Parameters:
buffPtr | Pointer to the buffer containing the image data
buffWidth | Width of the buffer (in 0xAARRGGBB pixels)
buffHeight | Height of the buffer (in 0xAARRGGBB pixels)
Returns:
Nothing.

Implements CEGUI::Texture.

void CEGUI::DirectX81Texture::postD3DReset ( void ) [virtual]

Direct3D support method that must be called after a Reset call on the Direct3DDevice; this is required so that the GUI renderer can rebuild any unmanaged D3D resources after the device has been reset.

Note:
You do not need to call this on DirectX81Texture objects created via the DirectX81Renderer object; for such textures the method is called by the system when you call the DirectX81Renderer::postD3DReset method.

void CEGUI::DirectX81Texture::preD3DReset ( void ) [virtual]

Direct3D support method that must be called prior to a Reset call on the Direct3DDevice; this is required so that the GUI renderer can release any unmanaged D3D resources as needed for the device reset to succeed.

Note:
You do not need to call this on DirectX81Texture objects created via the DirectX81Renderer object; for such textures the method is called by the system when you call the DirectX81Renderer::preD3DReset method.

void CEGUI::DirectX81Texture::setD3DTextureSize ( uint size )

set the size of the internal D3D texture. Previous D3D texture is lost.

Parameters:
size pixel size of the new internal texture. This will be rounded up to a power of 2.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DirectX9Renderer Class Reference

CEGUI::DirectX9Renderer

CEGUI::DirectX9Renderer Class Reference

Renderer class to interface with Microsoft DirectX 9.0. More...

Inheritance diagram for CEGUI::DirectX9Renderer:

[legend]
Collaboration diagram for CEGUI::DirectX9Renderer:

[legend]
List of all members.

Public Member Functions

DirectX9Renderer (LPDIRECT3DDEVICE9 device, uint max_quads)
Constructor for Direct3D 9.0 Renderer object.
virtual | ~DirectX9Renderer (void)
Destructor for DirectX9Renderer objects.
virtual void | addQuad (const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode)
Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.
virtual void | doRender (void)
Perform final rendering for all quads that have been queued for rendering.
virtual void | clearRenderList (void)
Clears all queued quads from the render queue.
virtual void | setQueueingEnabled (bool setting)
Enable or disable the queueing of quads from this point on.
virtual Texture * | createTexture (void)
Creates a 'null' Texture object.
virtual Texture * | createTexture (const String &filename, const String &resourceGroup)
Create a Texture object using the given image file.
virtual Texture * | createTexture (float size)
Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.
virtual void | destroyTexture (Texture *texture)
Destroy the given Texture object.
virtual void | destroyAllTextures (void)
Destroy all Texture objects.
LPDIRECT3DDEVICE9 | getDevice (void) const
virtual bool | isQueueingEnabled (void) const
Return whether queueing is enabled.
virtual float | getWidth (void) const
Return the current width of the display in pixels.
virtual float | getHeight (void) const
Return the current height of the display in pixels.
virtual Size | getSize (void) const
Return the size of the display in pixels.
virtual Rect | getRect (void) const
Return a Rect describing the screen.
virtual uint | getMaxTextureSize (void) const
Return the maximum texture size available.
virtual uint | getHorzScreenDPI (void) const
Return the horizontal display resolution dpi.
virtual uint | getVertScreenDPI (void) const
Return the vertical display resolution dpi.
virtual void | preD3DReset (void)
Direct3D support method that must be called prior to a Reset call on the Direct3DDevice; this is required so that the GUI renderer can release any unmanaged D3D resources as needed for the device reset to succeed.
virtual void | postD3DReset (void)
Direct3D support method that must be called after a Reset call on the Direct3DDevice; this is required so that the GUI renderer can rebuild any unmanaged D3D resources after the device has been reset.
void | setDisplaySize (const Size &sz)
Set the size of the display in pixels.

Classes

struct | QuadInfo
structure holding details about a quad to be drawn
struct | QuadVertex
FVF structure used for all vertices.

Detailed Description

Renderer class to interface with Microsoft DirectX 9.0.

Constructor & Destructor Documentation

CEGUI::DirectX9Renderer::DirectX9Renderer | ( | LPDIRECT3DDEVICE9 | device,
 |  | uint | max_quads
 | ) |

Constructor for Direct3D 9.0 Renderer object.

Parameters:
device | Pointer to the IDirect3DDevice9 interface object that will be used for all rendering
max_quads | Obsolete. Set to 0.

Member Function Documentation

void CEGUI::DirectX9Renderer::addQuad | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Texture * | tex,
 |  | const Rect & | texture_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode
 | ) | [virtual]

Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.

Parameters:
dest_rect | Rect object describing the destination area (values are in pixels)
z | float value specifying the z co-ordinate / z order of the quad
tex | pointer to the Texture object that holds the imagery to be rendered
texture_rect | Rect object holding the area of tex that is to be rendered (values are in texture co-ordinates).
colours | ColourRect object describing the colour values that are to be applied when rendering.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::DirectX9Renderer::clearRenderList ( void ) [virtual]

Clears all queued quads from the render queue.

Returns:
Nothing

Implements CEGUI::Renderer.

Texture * CEGUI::DirectX9Renderer::createTexture ( float size ) [virtual]

Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.

Parameters:
size float value that specifies the size to use for the width and height when creating the new texture.
Returns:
a newly created Texture object. The initial contents of the texture memory is undefined / random.
Note:
Textures are always created with a size that is a power of 2. If you specify a size that is not a power of two, the final size will be rounded up. So if you specify a size of 1024, the texture will be (1024 x 1024), however, if you specify a size of 1025, the texture will be (2048 x 2048). You can check the ultimate size by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::DirectX9Renderer::createTexture | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Create a Texture object using the given image file.

Parameters:
filename | String object that specifies the path and filename of the image file to use when creating the texture.
resourceGroup | Resource group identifier to be passed to the resource provider when loading the texture file.
Returns:
a newly created Texture object. The initial contents of the texture memory is the requested image file.
Note:
Textures are always created with a size that is a power of 2. If the file you specify is of a size that is not a power of two, the final size will be rounded up. Additionally, textures are always square, so the ultimate size is governed by the larger of the width and height of the specified file. You can check the ultimate sizes by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::DirectX9Renderer::createTexture ( void ) [virtual]

Creates a 'null' Texture object.

Returns:
a newly created Texture object. The returned Texture object has no size or imagery associated with it, and is generally of little or no use.

Implements CEGUI::Renderer.

void CEGUI::DirectX9Renderer::destroyAllTextures ( void ) [virtual]

Destroy all Texture objects.

Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::DirectX9Renderer::destroyTexture ( Texture * texture ) [virtual]

Destroy the given Texture object.

Parameters:
texture pointer to the Texture object to be destroyed
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::DirectX9Renderer::doRender ( void ) [virtual]

Perform final rendering for all quads that have been queued for rendering.

The contents of the rendering queue is retained and can be rendered again as required. If the contents is not required call clearRenderList().

Returns:
Nothing

Implements CEGUI::Renderer.

virtual float CEGUI::DirectX9Renderer::getHeight ( void ) const [inline, virtual]

Return the current height of the display in pixels.

Returns:
float value equal to the current height of the display in pixels.

Implements CEGUI::Renderer.

virtual uint CEGUI::DirectX9Renderer::getHorzScreenDPI ( void ) const [inline, virtual]

Return the horizontal display resolution dpi.

Returns:
horizontal resolution of the display in dpi.

Implements CEGUI::Renderer.

virtual uint CEGUI::DirectX9Renderer::getMaxTextureSize ( void ) const [inline, virtual]

Return the maximum texture size available.

Returns:
Size of the maximum supported texture in pixels (textures are always assumed to be square)

Implements CEGUI::Renderer.

virtual Rect CEGUI::DirectX9Renderer::getRect ( void ) const [inline, virtual]

Return a Rect describing the screen.

Returns:
A Rect object that describes the screen area. Typically, the top-left values are always 0, and the size of the area described is equal to the screen resolution.

Implements CEGUI::Renderer.

virtual Size CEGUI::DirectX9Renderer::getSize ( void ) const [inline, virtual]

Return the size of the display in pixels.

Returns:
Size object describing the dimensions of the current display.

Implements CEGUI::Renderer.

virtual uint CEGUI::DirectX9Renderer::getVertScreenDPI ( void ) const [inline, virtual]

Return the vertical display resolution dpi.

Returns:
vertical resolution of the display in dpi.

Implements CEGUI::Renderer.

virtual float CEGUI::DirectX9Renderer::getWidth ( void ) const [inline, virtual]

Return the current width of the display in pixels.

Returns:
float value equal to the current width of the display in pixels.

Implements CEGUI::Renderer.

virtual bool CEGUI::DirectX9Renderer::isQueueingEnabled ( void ) const [inline, virtual]

Return whether queueing is enabled.

Returns:
true if queueing is enabled, false if queueing is disabled.

Implements CEGUI::Renderer.

void CEGUI::DirectX9Renderer::setDisplaySize ( const Size & sz )

Set the size of the display in pixels.

You do not have to call this method under normal operation as the system will automatically extract the size from the current view port.

Note:
This method will cause the EventDisplaySizeChanged event to fire if the display size has changed.
Parameters:
sz Size object describing the size of the display.
Returns:
Nothing.

virtual void CEGUI::DirectX9Renderer::setQueueingEnabled ( bool setting ) [inline, virtual]

Enable or disable the queueing of quads from this point on.

This only affects queueing. If queueing is turned off, any calls to addQuad will cause the quad to be rendered directly. Note that disabling queueing will not cause currently queued quads to be rendered, nor is the queue cleared - at any time the queue can still be drawn by calling doRender, and the list can be cleared by calling clearRenderList. Re-enabling the queue causes subsequent quads to be added as if queueing had never been disabled.

Parameters:
setting true to enable queueing, or false to disable queueing (see notes above).
Returns:
Nothing

Implements CEGUI::Renderer.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DirectX9Texture Class Reference

CEGUI::DirectX9Texture

CEGUI::DirectX9Texture Class Reference

Texture class that is created by DirectX9Renderer objects. More...

Inheritance diagram for CEGUI::DirectX9Texture:

[legend]
Collaboration diagram for CEGUI::DirectX9Texture:

[legend]
List of all members.

Public Member Functions

virtual ushort | getWidth (void) const
Returns the current pixel width of the texture.
virtual ushort | getHeight (void) const
Returns the current pixel height of the texture.
virtual void | loadFromFile (const String &filename, const String &resourceGroup)
Loads the specified image file into the texture. The texture is resized as required to hold the image.
virtual void | loadFromMemory (const void *buffPtr, uint buffWidth, uint buffHeight)
Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.
LPDIRECT3DTEXTURE9 | getD3DTexture (void) const
Return a pointer to the internal Direct3DTexture9 object.
void | setD3DTextureSize (uint size)
set the size of the internal D3D texture. Previous D3D texture is lost.
virtual void | preD3DReset (void)
Direct3D support method that must be called prior to a Reset call on the Direct3DDevice; this is required so that the GUI renderer can release any unmanaged D3D resources as needed for the device reset to succeed.
virtual void | postD3DReset (void)
Direct3D support method that must be called after a Reset call on the Direct3DDevice; this is required so that the GUI renderer can rebuild any unmanaged D3D resources after the device has been reset.

Friends

Texture * | DirectX9Renderer::createTexture (void)
Texture * | DirectX9Renderer::createTexture (const String &filename, const String &resourceGroup)
Texture * | DirectX9Renderer::createTexture (float size)
void | DirectX9Renderer::destroyTexture (Texture *texture)

Detailed Description

Texture class that is created by DirectX9Renderer objects.

Member Function Documentation

LPDIRECT3DTEXTURE9 CEGUI::DirectX9Texture::getD3DTexture ( void ) const [inline]

Return a pointer to the internal Direct3DTexture9 object.

Returns:
Pointer to the IDirect3DTexture9 interface currently being used by this Texture object

virtual ushort CEGUI::DirectX9Texture::getHeight ( void ) const [inline, virtual]

Returns the current pixel height of the texture.

Returns:
ushort value that is the current height of the texture in pixels

Implements CEGUI::Texture.

virtual ushort CEGUI::DirectX9Texture::getWidth ( void ) const [inline, virtual]

Returns the current pixel width of the texture.

Returns:
ushort value that is the current width of the texture in pixels

Implements CEGUI::Texture.

void CEGUI::DirectX9Texture::loadFromFile | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Loads the specified image file into the texture. The texture is resized as required to hold the image.

Parameters:
filename | The filename of the image file that is to be loaded into the texture
resourceGroup | Resource group identifier passed to the resource provider.
Returns:
Nothing.

Implements CEGUI::Texture.

void CEGUI::DirectX9Texture::loadFromMemory | ( | const void * | buffPtr,
 |  | uint | buffWidth,
 |  | uint | buffHeight
 | ) | [virtual]

Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.

Parameters:
buffPtr | Pointer to the buffer containing the image data
buffWidth | Width of the buffer (in 0xAARRGGBB pixels)
buffHeight | Height of the buffer (in 0xAARRGGBB pixels)
Returns:
Nothing.

Implements CEGUI::Texture.

void CEGUI::DirectX9Texture::postD3DReset ( void ) [virtual]

Direct3D support method that must be called after a Reset call on the Direct3DDevice; this is required so that the GUI renderer can rebuild any unmanaged D3D resources after the device has been reset.

Note:
You do not need to call this on DirectX9Texture objects created via the DirectX9Renderer object; for such textures the method is called by the system when you call the DirectX9Renderer::postD3DReset method.

void CEGUI::DirectX9Texture::preD3DReset ( void ) [virtual]

Direct3D support method that must be called prior to a Reset call on the Direct3DDevice; this is required so that the GUI renderer can release any unmanaged D3D resources as needed for the device reset to succeed.

Note:
You do not need to call this on DirectX9Texture objects created via the DirectX9Renderer object; for such textures the method is called by the system when you call the DirectX9Renderer::preD3DReset method.

void CEGUI::DirectX9Texture::setD3DTextureSize ( uint size )

set the size of the internal D3D texture. Previous D3D texture is lost.

Parameters:
size pixel size of the new internal texture. This will be rounded up to a power of 2.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Disabled Class Reference

CEGUI::WindowProperties::Disabled

CEGUI::WindowProperties::Disabled Class Reference

Property to access window Disabled setting. More...

Inheritance diagram for CEGUI::WindowProperties::Disabled:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Disabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.

Detailed Description

Property to access window Disabled setting.

This property offers access to the enabled / disabled setting for the window.

Usage:
  • Name: Disabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window is disabled, and will normally receive no inputs from the user.
  • "False" to indicate the Window is not disabled and will receive inputs from the user as normal.

Member Function Documentation

String CEGUI::WindowProperties::Disabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

bool CEGUI::WindowProperties::Disabled::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::WindowProperties::Disabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties::DisabledImage Class Reference

CEGUI::PushButtonProperties::DisabledImage

CEGUI::PushButtonProperties::DisabledImage Class Reference

Property to access the disabled image of the button. More...

Inheritance diagram for CEGUI::PushButtonProperties::DisabledImage:

[legend]
Collaboration diagram for CEGUI::PushButtonProperties::DisabledImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the disabled image of the button.

Usage:
  • Name: DisabledImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::PushButtonProperties::DisabledImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PushButtonProperties::DisabledImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuItemProperties::DisabledTextColour Class Reference

CEGUI::MenuItemProperties::DisabledTextColour

CEGUI::MenuItemProperties::DisabledTextColour Class Reference

Property to access the disabled text colour of the item. More...

Inheritance diagram for CEGUI::MenuItemProperties::DisabledTextColour:

[legend]
Collaboration diagram for CEGUI::MenuItemProperties::DisabledTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the disabled text colour of the item.

Usage:
  • Name: DisabledTextColour
  • Format: "[aarrggbb]".
Where:
  • [aarrggbb] represents the disabled text colour of the item.

Member Function Documentation

String CEGUI::MenuItemProperties::DisabledTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuItemProperties::DisabledTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ButtonBaseProperties::DisabledTextColour Class Reference

CEGUI::ButtonBaseProperties::DisabledTextColour

CEGUI::ButtonBaseProperties::DisabledTextColour Class Reference

Property to access the disabled text colour. More...

Inheritance diagram for CEGUI::ButtonBaseProperties::DisabledTextColour:

[legend]
Collaboration diagram for CEGUI::ButtonBaseProperties::DisabledTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the disabled text colour.

This property offers access to the colour value to be used for rendering the button caption text for the disabled state.

Usage:
  • Name: DisabledTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ButtonBaseProperties::DisabledTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ButtonBaseProperties::DisabledTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TooltipProperties::DisplayTime Class Reference

CEGUI::TooltipProperties::DisplayTime

CEGUI::TooltipProperties::DisplayTime Class Reference

Property to access the time after which the tooltip automatically de-activates itself. More...

Inheritance diagram for CEGUI::TooltipProperties::DisplayTime:

[legend]
Collaboration diagram for CEGUI::TooltipProperties::DisplayTime:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the time after which the tooltip automatically de-activates itself.

Usage:
  • Name: DisplayTime
  • Format: "[float]".
Where:
  • [float] specifies the number of seconds after which the tooltip will deactivate itself if the mouse has remained stationary.

Member Function Documentation

String CEGUI::TooltipProperties::DisplayTime::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TooltipProperties::DisplayTime::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::DistributeCapturedInputs Class Reference

CEGUI::WindowProperties::DistributeCapturedInputs

CEGUI::WindowProperties::DistributeCapturedInputs Class Reference

Property to access whether inputs are passed to child windows when input is captured to this window. More...

Inheritance diagram for CEGUI::WindowProperties::DistributeCapturedInputs:

[legend]
Collaboration diagram for CEGUI::WindowProperties::DistributeCapturedInputs:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access whether inputs are passed to child windows when input is captured to this window.

Usage:
  • Name: DistributeCapturedInputs
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate 'captured' inputs should be passed to attached child windows.
  • "False" to indicate 'captured' inputs should be passed to this window only.

Member Function Documentation

String CEGUI::WindowProperties::DistributeCapturedInputs::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::DistributeCapturedInputs::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollbarProperties::DocumentSize Class Reference

CEGUI::ScrollbarProperties::DocumentSize

CEGUI::ScrollbarProperties::DocumentSize Class Reference

Property to access the document size for the Scrollbar. More...

Inheritance diagram for CEGUI::ScrollbarProperties::DocumentSize:

[legend]
Collaboration diagram for CEGUI::ScrollbarProperties::DocumentSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the document size for the Scrollbar.

Usage:
  • Name: DocumentSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the document being scrolled (as defined by the client code).

Member Function Documentation

String CEGUI::ScrollbarProperties::DocumentSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollbarProperties::DocumentSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderSegmentProperties::Dragable Class Reference

CEGUI::ListHeaderSegmentProperties::Dragable

CEGUI::ListHeaderSegmentProperties::Dragable Class Reference

Property to access the drag-able setting of the header segment. More...

Inheritance diagram for CEGUI::ListHeaderSegmentProperties::Dragable:

[legend]
Collaboration diagram for CEGUI::ListHeaderSegmentProperties::Dragable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the drag-able setting of the header segment.

Usage:
  • Name: Dragable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the segment can be dragged by the user.
  • "False" to indicate the segment can not be dragged by the user.

Member Function Documentation

String CEGUI::ListHeaderSegmentProperties::Dragable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderSegmentProperties::Dragable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragContainerProperties::DragAlpha Class Reference

CEGUI::DragContainerProperties::DragAlpha

CEGUI::DragContainerProperties::DragAlpha Class Reference

Property to access the dragging alpha value. More...

Inheritance diagram for CEGUI::DragContainerProperties::DragAlpha:

[legend]
Collaboration diagram for CEGUI::DragContainerProperties::DragAlpha:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the dragging alpha value.

Usage:
  • Name: DragAlpha
  • Format: "[float]".
Where:
  • [float] represents the alpha value to set when dragging.

Member Function Documentation

String CEGUI::DragContainerProperties::DragAlpha::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::DragContainerProperties::DragAlpha::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragContainer Class Reference

CEGUI::DragContainer

CEGUI::DragContainer Class Reference

Generic drag & drop enabled window class. More...

Inheritance diagram for CEGUI::DragContainer:

[legend]
Collaboration diagram for CEGUI::DragContainer:

[legend]
List of all members.

Public Member Functions

DragContainer (const String &type, const String &name)
Constructor for DragContainer objects.
virtual | ~DragContainer (void)
Destructor for DragContainer objects.
bool | isDraggingEnabled (void) const
Return whether dragging is currently enabled for this DragContainer.
void | setDraggingEnabled (bool setting)
Set whether dragging is currently enabled for this DragContainer.
bool | isBeingDragged (void) const
Return whether the DragContainer is currently being dragged.
float | getPixelDragThreshold (void) const
Return the current drag threshold in pixels.
void | setPixelDragThreshold (float pixels)
Set the current drag threshold in pixels.
float | getDragAlpha (void) const
Return the alpha value that will be set on the DragContainer while a drag operation is in progress.
void | setDragAlpha (float alpha)
Set the alpha value to be set on the DragContainer when a drag operation is in progress.
const Image * | getDragCursorImage (void) const
Return the Image currently set to be used for the mouse cursor when a drag operation is in progress.
void | setDragCursorImage (const Image *image)
Set the Image to be used for the mouse cursor when a drag operation is in progress.
void | setDragCursorImage (MouseCursorImage image)
Set the Image to be used for the mouse cursor when a drag operation is in progress.
void | setDragCursorImage (const String &imageset, const String &image)
Set the Image to be used for the mouse cursor when a drag operation is in progress.
Window * | getCurrentDropTarget (void) const
Return the Window object that is the current drop target for the DragContainer.

Static Public Attributes

static const String | WidgetTypeName
Type name for DragContainer.
static const String | EventNamespace
Namespace for global events.
static const String | EventDragStarted
Name of the event fired when the user begins dragging the thumb.
static const String | EventDragEnded
Name of the event fired when the user releases the thumb.
static const String | EventDragPositionChanged
Event fired when the drag position has changed.
static const String | EventDragEnabledChanged
Event fired when dragging is enabled or disabled.
static const String | EventDragAlphaChanged
Event fired when the alpha value used when dragging is changed.
static const String | EventDragMouseCursorChanged
Event fired when the mouse cursor used when dragging is changed.
static const String | EventDragThresholdChanged
Event fired when the drag pixel threshold is changed.
static const String | EventDragDropTargetChanged
Event fired when the drop target changes.

Protected Member Functions

void | addDragContainerEvents (void)
Adds events specific to the DragContainer base class.
bool | isDraggingThresholdExceeded (const Point &local_mouse)
Return whether the required minimum movement threshold before initiating dragging has been exceeded.
void | initialiseDragging (void)
Initialise the required states to put the window into dragging mode.
void | doDragging (const Point &local_mouse)
Update state for window dragging.
void | updateActiveMouseCursor (void) const
Method to update mouse cursor image.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
void | drawSelf (float z)
Perform the actual rendering for this Window.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onAlphaChanged (WindowEventArgs &e)
Handler called when the window's alpha blend value is changed.
virtual void | onClippingChanged (WindowEventArgs &e)
Handler called when the window's setting for being clipped by it's parent is changed.
virtual void | onDragStarted (WindowEventArgs &e)
Method called when dragging commences.
virtual void | onDragEnded (WindowEventArgs &e)
Method called when dragging ends.
virtual void | onDragPositionChanged (WindowEventArgs &e)
Method called when the dragged object position is changed.
virtual void | onDragEnabledChanged (WindowEventArgs &e)
Method called when the dragging state is enabled or disabled.
virtual void | onDragAlphaChanged (WindowEventArgs &e)
Method called when the alpha value to use when dragging is changed.
virtual void | onDragMouseCursorChanged (WindowEventArgs &e)
Method called when the mouse cursor to use when dragging is changed.
virtual void | onDragThresholdChanged (WindowEventArgs &e)
Method called when the movement threshold required to trigger dragging is changed.
virtual void | onDragDropTargetChanged (DragDropEventArgs &e)
Method called when the current drop target of this DragContainer changes.

Protected Attributes

bool | d_draggingEnabled
True when dragging is enabled.
bool | d_leftMouseDown
True when left mouse button is down.
bool | d_dragging
true when being dragged.
Point d_dragPoint
point we are being dragged at.
Point d_startPosition
position prior to dragging.
float | d_dragThreshold
Pixels mouse must move before dragging commences.
float | d_dragAlpha
Alpha value to set when dragging.
float | d_storedAlpha
Alpha value to re-set when dragging ends.
bool | d_storedClipState
Parent clip state to re-set.
Window * d_dropTarget
Target window for possible drop operation.
const Image * | d_dragCursorImage
Image to use for mouse cursor when dragging.

Detailed Description

Generic drag & drop enabled window class.

Member Function Documentation

void CEGUI::DragContainer::addDragContainerEvents ( void ) [protected]

Adds events specific to the DragContainer base class.

Returns:
Nothing.

void CEGUI::DragContainer::doDragging ( const Point & local_mouse ) [protected]

Update state for window dragging.

Parameters:
local_mouse Mouse position as a pixel offset from the top-left corner of this window.
Returns:
Nothing.

void CEGUI::DragContainer::drawSelf ( float z ) [protected, virtual]

Perform the actual rendering for this Window.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented from CEGUI::Window.

Window * CEGUI::DragContainer::getCurrentDropTarget ( void ) const

Return the Window object that is the current drop target for the DragContainer.

The drop target for a DragContainer is basically the Window that the DragContainer is within while being dragged. The drop target may be 0 to indicate no target.

Returns:
Pointer to a Window object that contains the DragContainer whilst being dragged, or 0 to indicate no current target.

float CEGUI::DragContainer::getDragAlpha ( void ) const

Return the alpha value that will be set on the DragContainer while a drag operation is in progress.

Returns:
Current alpha value to use whilst dragging.

const Image * CEGUI::DragContainer::getDragCursorImage ( void ) const

Return the Image currently set to be used for the mouse cursor when a drag operation is in progress.

Returns:
Image object currently set to be used as the mouse cursor when dragging.

float CEGUI::DragContainer::getPixelDragThreshold ( void ) const

Return the current drag threshold in pixels.

The drag threshold is the number of pixels that the mouse must be moved with the left button held down in order to commence a drag operation.

Returns:
float value indicating the current drag threshold value.

void CEGUI::DragContainer::initialiseDragging ( void ) [protected]

Initialise the required states to put the window into dragging mode.

Returns:
Nothing.

bool CEGUI::DragContainer::isBeingDragged ( void ) const

Return whether the DragContainer is currently being dragged.

Returns:
  • true if the DragContainer is being dragged.
  • false if te DragContainer is not being dragged.

bool CEGUI::DragContainer::isDraggingEnabled ( void ) const

Return whether dragging is currently enabled for this DragContainer.

Returns:
  • true if dragging is enabled and the DragContainer may be dragged.
  • false if dragging is disabled and the DragContainer may not be dragged.

bool CEGUI::DragContainer::isDraggingThresholdExceeded ( const Point & local_mouse ) [protected]

Return whether the required minimum movement threshold before initiating dragging has been exceeded.

Parameters:
local_mouse Mouse position as a pixel offset from the top-left corner of this window.
Returns:
  • true if the threshold has been exceeded and dragging should be initiated.
  • false if the threshold has not been exceeded.

void CEGUI::DragContainer::onAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's alpha blend value is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::DragContainer::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::DragContainer::onClippingChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's setting for being clipped by it's parent is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::DragContainer::onDragAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the alpha value to use when dragging is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::DragContainer::onDragDropTargetChanged ( DragDropEventArgs & e ) [protected, virtual]

Method called when the current drop target of this DragContainer changes.

Note:
This event fires just prior to the target field being changed. The default implementation changes the drop target, you can examine the old and new targets before calling the default implementation to make the actual change (and fire appropriate events for the Window objects involved).
Parameters:
e DragDropEventArgs object initialised as follows:
  • dragDropItem is initialised to the DragContainer triggering the event (typically 'this').
  • window is initialised to point to the Window which will be the new drop target.
Returns:
Nothing.

void CEGUI::DragContainer::onDragEnabledChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the dragging state is enabled or disabled.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::DragContainer::onDragEnded ( WindowEventArgs & e ) [protected, virtual]

Method called when dragging ends.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::DragContainer::onDragMouseCursorChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the mouse cursor to use when dragging is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::DragContainer::onDragPositionChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the dragged object position is changed.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::DragContainer::onDragStarted ( WindowEventArgs & e ) [protected, virtual]

Method called when dragging commences.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::DragContainer::onDragThresholdChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the movement threshold required to trigger dragging is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::DragContainer::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::DragContainer::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::DragContainer::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::DragContainer::setDragAlpha ( float alpha )

Set the alpha value to be set on the DragContainer when a drag operation is in progress.

This method can be used while a drag is in progress to update the alpha. Note that the normal setAlpha method does not affect alpha while a drag is in progress, but once the drag operation has ended, any value set via setAlpha will be restored.

Parameters:
alpha Alpha value to use whilst dragging.
Returns:
Nothing.

void CEGUI::DragContainer::setDragCursorImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the Image to be used for the mouse cursor when a drag operation is in progress.

This method may be used during a drag operation to update the current mouse cursor image.

Parameters:
imageset | String holding the name of the Imageset that contains the Image to be used.
image | Image defined for the Imageset imageset to be used as the mouse cursor when dragging.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if either imageset or image are unknown.

void CEGUI::DragContainer::setDragCursorImage ( MouseCursorImage image )

Set the Image to be used for the mouse cursor when a drag operation is in progress.

This method may be used during a drag operation to update the current mouse cursor image.

Parameters:
image One of the MouseCursorImage enumerated values.
Returns:
Nothing.

void CEGUI::DragContainer::setDragCursorImage ( const Image * image )

Set the Image to be used for the mouse cursor when a drag operation is in progress.

This method may be used during a drag operation to update the current mouse cursor image.

Parameters:
image Image object to be used as the mouse cursor while dragging.
Returns:
Nothing.

void CEGUI::DragContainer::setDraggingEnabled ( bool setting )

Set whether dragging is currently enabled for this DragContainer.

Parameters:
setting
  • true to enable dragging so that the DragContainer may be dragged.
  • false to disabled dragging so that the DragContainer may not be dragged.
Returns:
Nothing.

void CEGUI::DragContainer::setPixelDragThreshold ( float pixels )

Set the current drag threshold in pixels.

The drag threshold is the number of pixels that the mouse must be moved with the left button held down in order to commence a drag operation.

Parameters:
pixels float value indicating the new drag threshold value.
Returns:
Nothing.

virtual bool CEGUI::DragContainer::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragContainerFactory Class Reference

CEGUI::DragContainerFactory

CEGUI::DragContainerFactory Class Reference

Factory class for producing DragContainer windows. More...

Inheritance diagram for CEGUI::DragContainerFactory:

[legend]
Collaboration diagram for CEGUI::DragContainerFactory:

[legend]
List of all members.

Public Member Functions

Window * | createWindow (const String &name)
Create a new Window object of whatever type this WindowFactory produces.
void | destroyWindow (Window *window)
Destroys the given Window object.

Detailed Description

Factory class for producing DragContainer windows.

Member Function Documentation

Window* CEGUI::DragContainerFactory::createWindow ( const String & name ) [inline, virtual]

Create a new Window object of whatever type this WindowFactory produces.

Parameters:
name A unique name that is to be assigned to the newly created Window object
Returns:
Pointer to the new Window object.

Implements CEGUI::WindowFactory.

void CEGUI::DragContainerFactory::destroyWindow ( Window * window ) [inline, virtual]

Destroys the given Window object.

Parameters:
window Pointer to the Window object to be destroyed.
Returns:
Nothing.

Implements CEGUI::WindowFactory.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragContainerProperties::DragCursorImage Class Reference

CEGUI::DragContainerProperties::DragCursorImage

CEGUI::DragContainerProperties::DragCursorImage Class Reference

Property to access the dragging mouse cursor setting. More...

Inheritance diagram for CEGUI::DragContainerProperties::DragCursorImage:

[legend]
Collaboration diagram for CEGUI::DragContainerProperties::DragCursorImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the dragging mouse cursor setting.

This property offers access to the mouse cursor image used when dragging the DragContainer.

Usage:
  • Name: DragCursorImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::DragContainerProperties::DragCursorImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::DragContainerProperties::DragCursorImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragDropEventArgs Class Reference

CEGUI::DragDropEventArgs

CEGUI::DragDropEventArgs Class Reference

EventArgs based class used for certain drag/drop notifications. More...

Inheritance diagram for CEGUI::DragDropEventArgs:

[legend]
Collaboration diagram for CEGUI::DragDropEventArgs:

[legend]
List of all members.

Public Member Functions

DragDropEventArgs (Window *wnd)

Public Attributes

DragContainer * dragDropItem

Detailed Description

EventArgs based class used for certain drag/drop notifications.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragContainerProperties::DraggingEnabled Class Reference

CEGUI::DragContainerProperties::DraggingEnabled

CEGUI::DragContainerProperties::DraggingEnabled Class Reference

Property to access the state of the dragging enabled setting. More...

Inheritance diagram for CEGUI::DragContainerProperties::DraggingEnabled:

[legend]
Collaboration diagram for CEGUI::DragContainerProperties::DraggingEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the dragging enabled setting.

Usage:
  • Name: DraggingEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate that dragging is enabled.
  • "False" to indicate that dragging is disabled.

Member Function Documentation

String CEGUI::DragContainerProperties::DraggingEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::DragContainerProperties::DraggingEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TitlebarProperties::DraggingEnabled Class Reference

CEGUI::TitlebarProperties::DraggingEnabled

CEGUI::TitlebarProperties::DraggingEnabled Class Reference

Property to access the state of the dragging enabled setting for the Titlebar. More...

Inheritance diagram for CEGUI::TitlebarProperties::DraggingEnabled:

[legend]
Collaboration diagram for CEGUI::TitlebarProperties::DraggingEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the dragging enabled setting for the Titlebar.

Usage:
  • Name: DraggingEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate that drag moving is enabled.
  • "False" to indicate that drag moving is disabled.

Member Function Documentation

String CEGUI::TitlebarProperties::DraggingEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TitlebarProperties::DraggingEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::DragMovingEnabled Class Reference

CEGUI::FrameWindowProperties::DragMovingEnabled

CEGUI::FrameWindowProperties::DragMovingEnabled Class Reference

Property to access the setting for whether the user may drag the window around by its title bar. More...

Inheritance diagram for CEGUI::FrameWindowProperties::DragMovingEnabled:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::DragMovingEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for whether the user may drag the window around by its title bar.

Usage:
  • Name: DragMovingEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the window may be repositioned by the user via dragging.
  • "False" to indicate the window may not be repositioned by the user.

Member Function Documentation

String CEGUI::FrameWindowProperties::DragMovingEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::DragMovingEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::DragContainerProperties::DragThreshold Class Reference

CEGUI::DragContainerProperties::DragThreshold

CEGUI::DragContainerProperties::DragThreshold Class Reference

Property to access the dragging threshold value. More...

Inheritance diagram for CEGUI::DragContainerProperties::DragThreshold:

[legend]
Collaboration diagram for CEGUI::DragContainerProperties::DragThreshold:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the dragging threshold value.

Usage:
  • Name: DragThreshold
  • Format: "[float]".
Where:
  • [float] represents the movement threshold (in pixels) which must be exceeded to commence dragging.

Member Function Documentation

String CEGUI::DragContainerProperties::DragThreshold::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::DragContainerProperties::DragThreshold::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Editbox Class Reference

CEGUI::Editbox

CEGUI::Editbox Class Reference

Base class for an Editbox widget. More...

Inheritance diagram for CEGUI::Editbox:

[legend]
Collaboration diagram for CEGUI::Editbox:

[legend]
List of all members.

Public Member Functions

bool | hasInputFocus (void) const
return true if the Editbox has input focus.
bool | isReadOnly (void) const
return true if the Editbox is read-only.
bool | isTextMasked (void) const
return true if the text for the Editbox will be rendered masked.
bool | isTextValid (void) const
return true if the Editbox text is valid given the currently set validation string.
const String & | getValidationString (void) const
return the currently set validation string
size_t | getCaratIndex (void) const
return the current position of the carat.
size_t | getSelectionStartIndex (void) const
return the current selection start point.
size_t | getSelectionEndIndex (void) const
return the current selection end point.
size_t | getSelectionLength (void) const
return the length of the current selection (in code points / characters).
utf32 | getMaskCodePoint (void) const
return the utf32 code point used when rendering masked text.
size_t | getMaxTextLength (void) const
return the maximum text length set for this Editbox.
colour | getNormalTextColour (void) const
return the currently set colour to be used for rendering Editbox text in the normal, unselected state.
colour | getSelectedTextColour (void) const
return the currently set colour to be used for rendering the Editbox text when within the selected region.
colour | getNormalSelectBrushColour (void) const
return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is active.
colour | getInactiveSelectBrushColour (void) const
return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.
void | setReadOnly (bool setting)
Specify whether the Editbox is read-only.
void | setTextMasked (bool setting)
Specify whether the text for the Editbox will be rendered masked.
void | setValidationString (const String &validation_string)
Set the text validation string.
void | setCaratIndex (size_t carat_pos)
Set the current position of the carat.
void | setSelection (size_t start_pos, size_t end_pos)
Define the current selection for the Editbox.
void | setMaskCodePoint (utf32 code_point)
set the utf32 code point used when rendering masked text.
void | setMaxTextLength (size_t max_len)
set the maximum text length for this Editbox.
void | setNormalTextColour (const colour &col)
Set the colour to be used for rendering Editbox text in the normal, unselected state.
void | setSelectedTextColour (const colour &col)
Set the colour to be used for rendering the Editbox text when within the selected region.
void | setNormalSelectBrushColour (const colour &col)
Set the colour to be used for rendering the Editbox selection highlight when the Editbox is active.
void | setInactiveSelectBrushColour (const colour &col)
Set the colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.
Editbox (const String &type, const String &name)
Constructor for Editbox class.
virtual | ~Editbox (void)
Destructor for Editbox class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const argb_t | DefaultNormalTextColour = 0xFFFFFFFF
Colour applied to normal unselected text.
static const argb_t | DefaultSelectedTextColour = 0xFF000000
Colour applied to selected text.
static const argb_t | DefaultNormalSelectionColour = 0xFF6060FF
Colour applied to normal selection brush.
static const argb_t | DefaultInactiveSelectionColour = 0xFF808080
Colour applied to selection brush when widget is inactive.
static const String | EventReadOnlyModeChanged
The read-only mode for the edit box has been changed.
static const String | EventMaskedRenderingModeChanged
The masked rendering mode (password mode) has been changed.
static const String | EventMaskCodePointChanged
The code point (character) to use for masked text has been changed.
static const String | EventValidationStringChanged
The validation string has been changed.
static const String | EventMaximumTextLengthChanged
The maximum allowable string length has been changed.
static const String | EventTextInvalidated
Some operation has made the current text invalid with regards to the validation string.
static const String | EventInvalidEntryAttempted
The user attempted to modify the text in a way that would have made it invalid.
static const String | EventCaratMoved
The text carat (insert point) has changed.
static const String | EventTextSelectionChanged
The current text selection has changed.
static const String | EventEditboxFull
The number of characters in the edit box has reached the current maximum.
static const String | EventTextAccepted
The user has accepted the current text by pressing Return, Enter, or Tab.

Protected Member Functions

void | addEditboxEvents (void)
Add edit box specific events.
virtual size_t | getTextIndexFromPosition (const Point &pt) const =0
Return the text code point index that is rendered closest to screen position pt.
void | clearSelection (void)
Clear the current selection setting.
void | eraseSelectedText (bool modify_text=true)
Erase the currently selected text.
bool | isStringValid (const String &str) const
return true if the given string matches the validation regular expression.
void | handleBackspace (void)
Processing for backspace key.
void | handleDelete (void)
Processing for Delete key.
void | handleCharLeft (uint sysKeys)
Processing to move carat one character left.
void | handleWordLeft (uint sysKeys)
Processing to move carat one word left.
void | handleCharRight (uint sysKeys)
Processing to move carat one character right.
void | handleWordRight (uint sysKeys)
Processing to move carat one word right.
void | handleHome (uint sysKeys)
Processing to move carat to the start of the text.
void | handleEnd (uint sysKeys)
Processing to move carat to the end of the text.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onReadOnlyChanged (WindowEventArgs &e)
Event fired internally when the read only state of the Editbox has been changed.
virtual void | onMaskedRenderingModeChanged (WindowEventArgs &e)
Event fired internally when the masked rendering mode (password mode) has been changed.
virtual void | onMaskCodePointChanged (WindowEventArgs &e)
Event fired internally when the code point to use for masked rendering has been changed.
virtual void | onValidationStringChanged (WindowEventArgs &e)
Event fired internally when the validation string is changed.
virtual void | onMaximumTextLengthChanged (WindowEventArgs &e)
Event fired internally when the maximum text length for the edit box is changed.
virtual void | onTextInvalidatedEvent (WindowEventArgs &e)
Event fired internally when something has caused the current text to now fail validation.
virtual void | onInvalidEntryAttempted (WindowEventArgs &e)
Event fired internally when the user attempted to make a change to the edit box that would have caused it to fail validation.
virtual void | onCaratMoved (WindowEventArgs &e)
Event fired internally when the carat (insert point) position changes.
virtual void | onTextSelectionChanged (WindowEventArgs &e)
Event fired internally when the current text selection changes.
virtual void | onEditboxFullEvent (WindowEventArgs &e)
Event fired internally when the edit box text has reached the set maximum length.
virtual void | onTextAcceptedEvent (WindowEventArgs &e)
Event fired internally when the user accepts the edit box text by pressing Return, Enter, or Tab.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onMouseDoubleClicked (MouseEventArgs &e)
Handler called when a mouse button has been double-clicked within this window's area.
virtual void | onMouseTripleClicked (MouseEventArgs &e)
Handler called when a mouse button has been triple-clicked within this window's area.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onCharacter (KeyEventArgs &e)
Handler called when a character-key has been pressed while this window has input focus.
virtual void | onKeyDown (KeyEventArgs &e)
Handler called when a key as been depressed while this window has input focus.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.

Protected Attributes

bool | d_readOnly
True if the editbox is in read-only mode.
bool | d_maskText
True if the editbox text should be rendered masked.
utf32 | d_maskCodePoint
Code point to use when rendering masked text.
size_t | d_maxTextLen
Maximum number of characters for this Editbox.
size_t | d_caratPos
Position of the carat / insert-point.
size_t | d_selectionStart
Start of selection area.
size_t | d_selectionEnd
End of selection area.
String d_validationString
Copy of validation reg-ex string.
RegexValidator * d_validator
RegEx String used for validation of text.
bool | d_dragging
true when a selection is being dragged.
size_t | d_dragAnchorIdx
Selection index for drag selection anchor point.
colour d_normalTextColour
Text colour used normally.
colour d_selectTextColour
Text colour used when text is highlighted.
colour d_selectBrushColour
Colour to apply to the selection brush.
colour d_inactiveSelectBrushColour
Colour to apply to the selection brush when widget is inactive / read-only.

Detailed Description

Base class for an Editbox widget.

Member Function Documentation

void CEGUI::Editbox::eraseSelectedText ( bool modify_text = true ) [protected]

Erase the currently selected text.

Parameters:
modify_text when true, the actual text will be modified. When false, everything is done except erasing the characters.

size_t CEGUI::Editbox::getCaratIndex ( void ) const [inline]

return the current position of the carat.

Returns:
Index of the insert carat relative to the start of the text.

colour CEGUI::Editbox::getInactiveSelectBrushColour ( void ) const [inline]

return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.

Returns:
colour value describing the ARGB colour that is currently set.

utf32 CEGUI::Editbox::getMaskCodePoint ( void ) const [inline]

return the utf32 code point used when rendering masked text.

Returns:
utf32 code point value representing the Unicode code point that will be rendered instead of the Editbox text when rendering in masked mode.

size_t CEGUI::Editbox::getMaxTextLength ( void ) const [inline]

return the maximum text length set for this Editbox.

Returns:
The maximum number of code points (characters) that can be entered into this Editbox.
Note:
Depending on the validation string set, the actual length of text that can be entered may be less than the value returned here (it will never be more).

colour CEGUI::Editbox::getNormalSelectBrushColour ( void ) const [inline]

return the currently set colour to be used for rendering the Editbox selection highlight when the Editbox is active.

Returns:
colour value describing the ARGB colour that is currently set.

colour CEGUI::Editbox::getNormalTextColour ( void ) const [inline]

return the currently set colour to be used for rendering Editbox text in the normal, unselected state.

Returns:
colour value describing the ARGB colour that is currently set.

colour CEGUI::Editbox::getSelectedTextColour ( void ) const [inline]

return the currently set colour to be used for rendering the Editbox text when within the selected region.

Returns:
colour value describing the ARGB colour that is currently set.

size_t CEGUI::Editbox::getSelectionEndIndex ( void ) const

return the current selection end point.

Returns:
Index of the selection end point relative to the start of the text. If no selection is defined this function returns the position of the carat.

size_t CEGUI::Editbox::getSelectionLength ( void ) const

return the length of the current selection (in code points / characters).

Returns:
Number of code points (or characters) contained within the currently defined selection.

size_t CEGUI::Editbox::getSelectionStartIndex ( void ) const

return the current selection start point.

Returns:
Index of the selection start point relative to the start of the text. If no selection is defined this function returns the position of the carat.

virtual size_t CEGUI::Editbox::getTextIndexFromPosition ( const Point & pt ) const [protected, pure virtual]

Return the text code point index that is rendered closest to screen position pt.

Parameters:
pt Point object describing a position on the screen in pixels.
Returns:
Code point index into the text that is rendered closest to screen position pt.

const String& CEGUI::Editbox::getValidationString ( void ) const [inline]

return the currently set validation string

Note:
Validation is performed by means of a regular expression. If the text matches the regex, the text is said to have passed validation. If the text does not match with the regex then the text fails validation.
Returns:
String object containing the current validation regex data

bool CEGUI::Editbox::hasInputFocus ( void ) const

return true if the Editbox has input focus.

Returns:
true if the Editbox has keyboard input focus, false if the Editbox does not have keyboard input focus.

bool CEGUI::Editbox::isReadOnly ( void ) const [inline]

return true if the Editbox is read-only.

Returns:
true if the Editbox is read only and can't be edited by the user, false if the Editbox is not read only and may be edited by the user.

bool CEGUI::Editbox::isTextMasked ( void ) const [inline]

return true if the text for the Editbox will be rendered masked.

Returns:
true if the Editbox text will be rendered masked using the currently set mask code point, false if the Editbox text will be rendered as plain text.

bool CEGUI::Editbox::isTextValid ( void ) const

return true if the Editbox text is valid given the currently set validation string.

Note:
It is possible to programmatically set 'invalid' text for the Editbox by calling setText. This has certain implications since if invalid text is set, whatever the user types into the box will be rejected when the input is validated.

Validation is performed by means of a regular expression. If the text matches the regex, the text is said to have passed validation. If the text does not match with the regex then the text fails validation.

Returns:
true if the current Editbox text passes validation, false if the text does not pass validation.

void CEGUI::Editbox::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onCharacter ( KeyEventArgs & e ) [protected, virtual]

Handler called when a character-key has been pressed while this window has input focus.

Parameters:
e KeyEventArgs object whose 'codepoint' field is set to the Unicode code point (encoded as utf32) for the character typed, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated. All other fields should be considered as 'junk'.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onKeyDown ( KeyEventArgs & e ) [protected, virtual]

Handler called when a key as been depressed while this window has input focus.

Parameters:
e KeyEventArgs object whose 'scancode' field is set to the Key::Scan value representing the key that was pressed, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onMouseDoubleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been double-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onMouseTripleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been triple-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Editbox::onTextInvalidatedEvent ( WindowEventArgs & e ) [protected, virtual]

Event fired internally when something has caused the current text to now fail validation.

This can be caused by changing the validation string or setting a maximum length that causes the current text to be truncated.

void CEGUI::Editbox::setCaratIndex ( size_t carat_pos )

Set the current position of the carat.

Parameters:
carat_pos New index for the insert carat relative to the start of the text. If the value specified is greater than the number of characters in the Editbox, the carat is positioned at the end of the text.
Returns:
Nothing.

void CEGUI::Editbox::setInactiveSelectBrushColour ( const colour & col )

Set the colour to be used for rendering the Editbox selection highlight when the Editbox is inactive.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::Editbox::setMaskCodePoint ( utf32 code_point )

set the utf32 code point used when rendering masked text.

Parameters:
code_point utf32 code point value representing the Unicode code point that should be rendered instead of the Editbox text when rendering in masked mode.
Returns:
Nothing.

void CEGUI::Editbox::setMaxTextLength ( size_t max_len )

set the maximum text length for this Editbox.

Parameters:
max_len The maximum number of code points (characters) that can be entered into this Editbox.
Note:
Depending on the validation string set, the actual length of text that can be entered may be less than the value set here (it will never be more).
Returns:
Nothing.

void CEGUI::Editbox::setNormalSelectBrushColour ( const colour & col )

Set the colour to be used for rendering the Editbox selection highlight when the Editbox is active.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::Editbox::setNormalTextColour ( const colour & col )

Set the colour to be used for rendering Editbox text in the normal, unselected state.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::Editbox::setReadOnly ( bool setting )

Specify whether the Editbox is read-only.

Parameters:
setting true if the Editbox is read only and can't be edited by the user, false if the Editbox is not read only and may be edited by the user.
Returns:
Nothing.

void CEGUI::Editbox::setSelectedTextColour ( const colour & col )

Set the colour to be used for rendering the Editbox text when within the selected region.

Returns:
colour value describing the ARGB colour that is currently set.

void CEGUI::Editbox::setSelection | ( | size_t | start_pos,
 |  | size_t | end_pos
 | ) |

Define the current selection for the Editbox.

Parameters:
start_pos | Index of the starting point for the selection. If this value is greater than the number of characters in the Editbox, the selection start will be set to the end of the text.
end_pos | Index of the ending point for the selection. If this value is greater than the number of characters in the Editbox, the selection end will be set to the end of the text.
Returns:
Nothing.

void CEGUI::Editbox::setTextMasked ( bool setting )

Specify whether the text for the Editbox will be rendered masked.

Parameters:
setting true if the Editbox text should be rendered masked using the currently set mask code point, false if the Editbox text should be rendered as plain text.
Returns:
Nothing.

void CEGUI::Editbox::setValidationString ( const String & validation_string )

Set the text validation string.

Note:
Validation is performed by means of a regular expression. If the text matches the regex, the text is said to have passed validation. If the text does not match with the regex then the text fails validation.
Parameters:
validation_string String object containing the validation regex data to be used.
Returns:
Nothing.

virtual bool CEGUI::Editbox::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::EditSelectionLength Class Reference

CEGUI::ComboboxProperties::EditSelectionLength

CEGUI::ComboboxProperties::EditSelectionLength Class Reference

Property to access the current selection length. More...

Inheritance diagram for CEGUI::ComboboxProperties::EditSelectionLength:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::EditSelectionLength:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current selection length.

Usage:
  • Name: EditSelectionLength
  • Format: "[uint]"
Where:
  • [uint] is the length of the selection (as a count of the number of code points selected).

Member Function Documentation

String CEGUI::ComboboxProperties::EditSelectionLength::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::EditSelectionLength::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::EditSelectionStart Class Reference

CEGUI::ComboboxProperties::EditSelectionStart

CEGUI::ComboboxProperties::EditSelectionStart Class Reference

Property to access the current selection start index. More...

Inheritance diagram for CEGUI::ComboboxProperties::EditSelectionStart:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::EditSelectionStart:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current selection start index.

Usage:
  • Name: EditSelectionStart
  • Format: "[uint]"
Where:
  • [uint] is the zero based index of the selection start position within the text.

Member Function Documentation

String CEGUI::ComboboxProperties::EditSelectionStart::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::EditSelectionStart::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Event Class Reference

CEGUI::Event

CEGUI::Event Class Reference

Defines an 'event' which can be subscribed to by interested parties. More...

Collaboration diagram for CEGUI::Event:

[legend]
List of all members.

Public Types

typedef RefPtr< ConnectionInterface > | Connection
typedef SubscriberTemplate<
bool, const EventArgs & > 		Subscriber
typedef int | Group

Public Member Functions

Event (const String &name)
Constructs a new Event object with the specified name.
virtual | ~Event (void)
Destructor for Event objects.
const String & | getName (void) const
Return the name given to this Event object when it was created.
Connection | subscribe (Subscriber subscriber)
Subscribes some function / object to the Event.
Connection | subscribe (Group group, Subscriber subscriber)
Subscribes some function / object to the Event.
void | operator() (EventArgs &args)

Friends

class | ConnectionImpl

Classes

class | ConnectionInterface
Interface to be implemented by connection objects. More...
class | GroupSubscriber
struct | ltGroupSubscriber
class | ScopedConnection
A Connection object that automatically disconnects from the event when the ScropedConnection object goes out of scope (and is deleted). More...

Detailed Description

Defines an 'event' which can be subscribed to by interested parties.

An Event can be subscribed by a function, a member function, or a function object. Whichever option is taken, the function signature needs to be as follows

bool function_name(const EventArgs& args);
Note:
An Event object may not be copied.

Member Function Documentation

const String& CEGUI::Event::getName ( void ) const [inline]

Return the name given to this Event object when it was created.

Returns:
String object containing the name of the Event object.

Event::Connection CEGUI::Event::subscribe | ( | Group | group,
 |  | Subscriber | subscriber
 | ) |

Subscribes some function / object to the Event.

Parameters:
group | The Event group to subscribe to, subscription groups are called in ascending order, followed by subscriptions with no group. connections to the same group may be called in any order.
subscriber | A function, static member function, or function object, with the signature void function_name(const EventArgs& args)
Returns:
A Connection which can be used to disconnect (unsubscribe) from the Event, and to check the connection state.

Connection CEGUI::Event::subscribe ( Subscriber subscriber ) [inline]

Subscribes some function / object to the Event.

Parameters:
subscriber A function, static member function, or function object, with the signature void function_name(const EventArgs& args)
Returns:
A Connection pointer which can be used to disconnect (unsubscribe) from the Event, and to check the connection state.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Event::ConnectionInterface Class Reference

CEGUI::Event::ConnectionInterface

CEGUI::Event::ConnectionInterface Class Reference

Interface to be implemented by connection objects. More...

Inheritance diagram for CEGUI::Event::ConnectionInterface:

[legend]
List of all members.

Public Member Functions

virtual bool | connected ()
virtual void | disconnect ()

Detailed Description

Interface to be implemented by connection objects.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Event::ScopedConnection Class Reference

CEGUI::Event::ScopedConnection

CEGUI::Event::ScopedConnection Class Reference

A Connection object that automatically disconnects from the event when the ScropedConnection object goes out of scope (and is deleted). More...

List of all members.

Public Member Functions

ScopedConnection (Connection conn_)

Public Attributes

Connection conn

Detailed Description

A Connection object that automatically disconnects from the event when the ScropedConnection object goes out of scope (and is deleted).

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EventArgs Class Reference

CEGUI::EventArgs

CEGUI::EventArgs Class Reference

Base class used as the argument to all subscribers Event object. More...

Inheritance diagram for CEGUI::EventArgs:

[legend]
List of all members.

Public Attributes

bool handled
handlers should set this to true if they handled the event, or false otherwise.

Detailed Description

Base class used as the argument to all subscribers Event object.

The base EventArgs class does not contain any useful information, it is intended to be specialised for each type of event that can be generated by objects within the system. The use of this base class allows all event subscribers to have the same function signature.

The handled field is used to signal whether an event was actually handled or not. While the event system does not look at this value, code at a higher level can use it to determine how far to propagate an event.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EventSet Class Reference

CEGUI::EventSet

CEGUI::EventSet Class Reference

Class that collects together a set of Event objects. More...

Inheritance diagram for CEGUI::EventSet:

[legend]
List of all members.

Public Types

typedef ConstBaseIterator<
EventMap > 		EventIterator

Public Member Functions

EventSet ()
Constructor for EventSet objects.
virtual | ~EventSet (void)
Destructor for EventSet objects.
void | addEvent (const String &name)
Add a new Event to the EventSet with the given name.
void | removeEvent (const String &name)
Removes the Event with the given name. All connections to the event are disconnected.
void | removeAllEvents (void)
Remove all Event objects from the EventSet.
bool | isEventPresent (const String &name)
Checks to see if an Event with the given name is present in the EventSet.
virtual Event::Connection | subscribeEvent (const String &name, Event::Subscriber subscriber)
Subscribes the named Event.
virtual Event::Connection | subscribeEvent (const String &name, Event::Group group, Event::Subscriber subscriber)
Subscribes the specified group of the named Event.
virtual Event::Connection | subscribeScriptedEvent (const String &name, const String &subscriber_name)
Subscribes the named Event to a scripted funtion.
virtual Event::Connection | subscribeScriptedEvent (const String &name, Event::Group group, const String &subscriber_name)
Subscribes the specified group of the named Event to a scripted funtion.
virtual void | fireEvent (const String &name, EventArgs &args, const String &eventNamespace="")
Fires the named event passing the given EventArgs object.
bool | isMuted (void) const
Return whether the EventSet is muted or not.
void | setMutedState (bool setting)
Set the mute state for this EventSet.
EventIterator | getIterator (void) const
Return a EventSet::EventIterator object to iterate over the available events.

Protected Types

typedef std::map< String,
Event * > 		EventMap

Protected Member Functions

EventSet (EventSet &e)
EventSet & | operator= (EventSet &e)

Protected Attributes

EventMap | d_events
bool | d_muted
true if events for this EventSet have been muted.

Detailed Description

Class that collects together a set of Event objects.

The EventSet used to collect Event objects together, and allow access to them by a unique name

Member Function Documentation

void CEGUI::EventSet::addEvent ( const String & name )

Add a new Event to the EventSet with the given name.

Parameters:
name String object containing the name to give the new Event. The name must be unique for the EventSet.
Returns:
Nothing
Exceptions:
AlreadyExistsException Thrown if an Event already exists named name.

void CEGUI::EventSet::fireEvent | ( | const String & | name,
 |  | EventArgs & | args,
 |  | const String & | eventNamespace = ""
 | ) | [virtual]

Fires the named event passing the given EventArgs object.

Parameters:
name | String object holding the name of the Event that is to be fired (triggered)
args | The EventArgs (or derived) object that is to be bassed to each subscriber of the Event. Once all subscribers have been called the 'handled' field of the event is updated appropriately.
eventNamespace | String object describing the global event namespace prefix for this event.
Returns:
Nothing.
Exceptions:
UnknownObjectException Thrown if no Event named name was found in the EventSet.

Reimplemented in CEGUI::GlobalEventSet.

bool CEGUI::EventSet::isEventPresent ( const String & name )

Checks to see if an Event with the given name is present in the EventSet.

Returns:
true if an Event named name was found, or false if the Event was not found

bool CEGUI::EventSet::isMuted ( void ) const

Return whether the EventSet is muted or not.

Returns:
  • true if the EventSet is muted. All requests to fire events will be ignored.
  • false if the EventSet is not muted. All requests to fire events are processed as normal.

void CEGUI::EventSet::removeAllEvents ( void )

Remove all Event objects from the EventSet.

Returns:
Nothing

void CEGUI::EventSet::removeEvent ( const String & name )

Removes the Event with the given name. All connections to the event are disconnected.

Parameters:
name String object containing the name of the Event to remove. If no such Event exists, nothing happens.
Returns:
Nothing.

void CEGUI::EventSet::setMutedState ( bool setting )

Set the mute state for this EventSet.

Parameters:
setting
  • true if the EventSet is to be muted (no further event firing requests will be honoured until EventSet is unmuted).
  • false if the EventSet is not to be muted and all events should fired as requested.
Returns:
Nothing.

Event::Connection CEGUI::EventSet::subscribeEvent | ( | const String & | name,
 |  | Event::Group | group,
 |  | Event::Subscriber | subscriber
 | ) | [virtual]

Subscribes the specified group of the named Event.

Parameters:
name | String object containing the name of the Event to subscribe to.
group | Group which is to be subscribed to. Subscription groups are called in ascending order.
subscriber | Function or object that is to be subscribed to the Event.
Returns:
Connection object that can be used to check the status of the Event connection and to disconnect (unsubscribe) from the Event.
Exceptions:
UnknownObjectException Thrown if an Event named name is not in the EventSet

Reimplemented in CEGUI::GlobalEventSet.

Event::Connection CEGUI::EventSet::subscribeEvent | ( | const String & | name,
 |  | Event::Subscriber | subscriber
 | ) | [virtual]

Subscribes the named Event.

Parameters:
name | String object containing the name of the Event to subscribe to.
subscriber | Function or object that is to be subscribed to the Event.
Returns:
Connection object that can be used to check the status of the Event connection and to disconnect (unsubscribe) from the Event.
Exceptions:
UnknownObjectException Thrown if an Event named name is not in the EventSet

Reimplemented in CEGUI::GlobalEventSet.

Event::Connection CEGUI::EventSet::subscribeScriptedEvent | ( | const String & | name,
 |  | Event::Group | group,
 |  | const String & | subscriber_name
 | ) | [virtual]

Subscribes the specified group of the named Event to a scripted funtion.

Parameters:
name | String object containing the name of the Event to subscribe to.
group | Group which is to be subscribed to. Subscription groups are called in ascending order.
subscriber_name | String object containing the name of the script funtion that is to be subscribed to the Event.
Returns:
Connection object that can be used to check the status of the Event connection and to disconnect (unsubscribe) from the Event.
Exceptions:
UnknownObjectException Thrown if an Event named name is not in the EventSet

Event::Connection CEGUI::EventSet::subscribeScriptedEvent | ( | const String & | name,
 |  | const String & | subscriber_name
 | ) | [virtual]

Subscribes the named Event to a scripted funtion.

Parameters:
name | String object containing the name of the Event to subscribe to.
subscriber_name | String object containing the name of the script funtion that is to be subscribed to the Event.
Returns:
Connection object that can be used to check the status of the Event connection and to disconnect (unsubscribe) from the Event.
Exceptions:
UnknownObjectException Thrown if an Event named name is not in the EventSet

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::EWSizingCursorImage Class Reference

CEGUI::FrameWindowProperties::EWSizingCursorImage

CEGUI::FrameWindowProperties::EWSizingCursorImage Class Reference

Property to access the E-W (left/right) sizing cursor image. More...

Inheritance diagram for CEGUI::FrameWindowProperties::EWSizingCursorImage:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::EWSizingCursorImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the E-W (left/right) sizing cursor image.

Usage:
  • Name: EWSizingCursorImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::FrameWindowProperties::EWSizingCursorImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::EWSizingCursorImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Exception Class Reference

CEGUI::Exception

CEGUI::Exception Class Reference

Root exception class used within the GUI system. More...

Inheritance diagram for CEGUI::Exception:

[legend]
Collaboration diagram for CEGUI::Exception:

[legend]
List of all members.

Public Member Functions

Exception (const String &message)
const String & | getMessage (void) const
Return a reference to the String object describing the reason for the exception being thrown.

Protected Attributes

String | d_message

Detailed Description

Root exception class used within the GUI system.

Member Function Documentation

const String& CEGUI::Exception::getMessage ( void ) const [inline]

Return a reference to the String object describing the reason for the exception being thrown.

Returns:
String object containing a message describing the reason for the exception.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FactoryModule Class Reference

CEGUI::FactoryModule

CEGUI::FactoryModule Class Reference

Class that encapsulates access to a dynamic loadable module containing implementations of Windows, Widgets, and their factories. More...

Collaboration diagram for CEGUI::FactoryModule:

[legend]
List of all members.

Public Member Functions

FactoryModule (const String &filename)
Construct the FactoryModule object by loading the dynamic loadable module specified.
virtual | ~FactoryModule (void)
Destroys the FactoryModule object and unloads any loadable module.
void | registerFactory (const String &type) const
Register a WindowFactory for type Windows.
uint | registerAllFactories () const
Register all factories available in this module.

Detailed Description

Class that encapsulates access to a dynamic loadable module containing implementations of Windows, Widgets, and their factories.

Constructor & Destructor Documentation

CEGUI::FactoryModule::FactoryModule ( const String & filename )

Construct the FactoryModule object by loading the dynamic loadable module specified.

Parameters:
filename String object holding the filename of a loadable module.
Returns:
Nothing

CEGUI::FactoryModule::~FactoryModule ( void ) [virtual]

Destroys the FactoryModule object and unloads any loadable module.

Returns:
Nothing

Member Function Documentation

uint CEGUI::FactoryModule::registerAllFactories ( ) const

Register all factories available in this module.

Returns:
uint value indicating the number of factories registered.

void CEGUI::FactoryModule::registerFactory ( const String & type ) const

Register a WindowFactory for type Windows.

Parameters:
type String object holding the name of the Window type a factory is to be registered for.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PopupMenuProperties::FadeInTime Class Reference

CEGUI::PopupMenuProperties::FadeInTime

CEGUI::PopupMenuProperties::FadeInTime Class Reference

Property to access the fade in time in seconds of the menu bar. More...

Inheritance diagram for CEGUI::PopupMenuProperties::FadeInTime:

[legend]
Collaboration diagram for CEGUI::PopupMenuProperties::FadeInTime:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the fade in time in seconds of the menu bar.

Usage:
  • Name: FadeInTime
  • Format: "[float]".
Where:
  • [float] represents the fade in time in seconds of the menu bar.

Member Function Documentation

String CEGUI::PopupMenuProperties::FadeInTime::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PopupMenuProperties::FadeInTime::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PopupMenuProperties::FadeOutTime Class Reference

CEGUI::PopupMenuProperties::FadeOutTime

CEGUI::PopupMenuProperties::FadeOutTime Class Reference

Property to access the fade out time in seconds of the menu bar. More...

Inheritance diagram for CEGUI::PopupMenuProperties::FadeOutTime:

[legend]
Collaboration diagram for CEGUI::PopupMenuProperties::FadeOutTime:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the fade out time in seconds of the menu bar.

Usage:
  • Name: FadeOutTime
  • Format: "[float]".
Where:
  • [float] represents the fade out time in seconds of the menu bar.

Member Function Documentation

String CEGUI::PopupMenuProperties::FadeOutTime::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PopupMenuProperties::FadeOutTime::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TooltipProperties::FadeTime Class Reference

CEGUI::TooltipProperties::FadeTime

CEGUI::TooltipProperties::FadeTime Class Reference

Property to access the duration of the fade effect for the tooltip. More...

Inheritance diagram for CEGUI::TooltipProperties::FadeTime:

[legend]
Collaboration diagram for CEGUI::TooltipProperties::FadeTime:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the duration of the fade effect for the tooltip.

Usage:
  • Name: FadeTime
  • Format: "[float]".
Where:
  • [float] specifies the number of seconds over which the fade in / fade out effect will happen.

Member Function Documentation

String CEGUI::TooltipProperties::FadeTime::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TooltipProperties::FadeTime::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Falagard_xmlHandler Class Reference

CEGUI::Falagard_xmlHandler

CEGUI::Falagard_xmlHandler Class Reference

Handler class used to parse look & feel XML files used by the Falagard system. More...

Collaboration diagram for CEGUI::Falagard_xmlHandler:

[legend]
List of all members.

Public Member Functions

Falagard_xmlHandler (WidgetLookManager *mgr)
Constructor for Falagard_xmlHandler objects.
~Falagard_xmlHandler ()
Destructor for Falagard_xmlHandler objects.
void | elementStart (const String &element, const XMLAttributes &attributes)
void | elementEnd (const String &element)

Detailed Description

Handler class used to parse look & feel XML files used by the Falagard system.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FalagardComponentBase Class Reference

CEGUI::FalagardComponentBase

CEGUI::FalagardComponentBase Class Reference

Common base class used for renderable components within an ImagerySection. More...

Inheritance diagram for CEGUI::FalagardComponentBase:

[legend]
Collaboration diagram for CEGUI::FalagardComponentBase:

[legend]
List of all members.

Public Member Functions

FalagardComponentBase ()
Constructor.
virtual | ~FalagardComponentBase ()
Destructor.
void | render (Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render this component. More correctly, the component is cached for rendering.
void | render (Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render this component. More correctly, the component is cached for rendering.
const ComponentArea & | getComponentArea () const
Return the ComponentArea of this ImageryComponent.
void | setComponentArea (const ComponentArea &area)
Set the ImageryComponent's ComponentArea.
const ColourRect & | getColours () const
Return the ColourRect set for use by this ImageryComponent.
void | setColours (const ColourRect &cols)
Set the colours to be used by this ImageryComponent.
void | setColoursPropertySource (const String &property)
Set the name of the property where colour values can be obtained.
void | setColoursPropertyIsColourRect (bool setting=true)
Set whether the colours property source represents a full ColourRect.
void | setVertFormattingPropertySource (const String &property)
Set the name of the property where vertical formatting option can be obtained.
void | setHorzFormattingPropertySource (const String &property)
Set the name of the property where horizontal formatting option can be obtained.

Protected Member Functions

void | initColoursRect (const Window &wnd, const ColourRect *modCols, ColourRect &cr) const
Helper method to initialise a ColourRect with appropriate values according to the way the ImageryComponent is set up.
virtual void | render_impl (Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const =0
Method to do main render caching work.
bool | writeColoursXML (OutStream &out_stream) const
Writes xml for the colours to a OutStream. Will prefer property colours before explicit.
bool | writeVertFormatXML (OutStream &out_stream) const
Writes xml for the vertical formatting to a OutStream if such a property is defined.
bool | writeHorzFormatXML (OutStream &out_stream) const
Writes xml for the horizontal formatting to a OutStream if such a property is defined.

Protected Attributes

ComponentArea d_area
Destination area for this component.
ColourRect d_colours
base colours to be applied when rendering the image component.
String d_colourPropertyName
name of property to fetch colours from.
bool | d_colourProperyIsRect
true if the colour property will fetch a full ColourRect.
String d_vertFormatPropertyName
name of property to fetch vertical formatting setting from.
String d_horzFormatPropertyName
name of property to fetch horizontal formatting setting from.

Detailed Description

Common base class used for renderable components within an ImagerySection.

Member Function Documentation

const ColourRect & CEGUI::FalagardComponentBase::getColours ( ) const

Return the ColourRect set for use by this ImageryComponent.

Returns:
ColourRect object holding the colours currently in use by this ImageryComponent.

const ComponentArea & CEGUI::FalagardComponentBase::getComponentArea ( ) const

Return the ComponentArea of this ImageryComponent.

Returns:
ComponentArea object describing the ImageryComponent's current target area.

void CEGUI::FalagardComponentBase::initColoursRect | ( | const Window & | wnd,
 |  | const ColourRect * | modCols,
 |  | ColourRect & | cr
 | ) | const [protected]

Helper method to initialise a ColourRect with appropriate values according to the way the ImageryComponent is set up.

This will try and get values from multiple places:

  • a property attached to wnd
  • or the integral d_colours value.

void CEGUI::FalagardComponentBase::render | ( | Window & | srcWindow,
 |  | const Rect & | baseRect,
 |  | float | base_z,
 |  | const CEGUI::ColourRect * | modColours = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render this component. More correctly, the component is cached for rendering.

Parameters:
srcWindow | Window to use as the base for translating the component's ComponentArea into pixel values.
baseRect | Rect to use as the base for translating the component's ComponentArea into pixel values.
base_z | The z value to use for rendering the component. Note that this is not the final z value to use, but some z offset from a currently unknown starting value.
modColours | ColourRect describing colours that are to be modulated with the component's stored colour values to calculate a set of 'final' colour values to be used. May be 0.
Returns:
Nothing.

void CEGUI::FalagardComponentBase::render | ( | Window & | srcWindow,
 |  | float | base_z,
 |  | const CEGUI::ColourRect * | modColours = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render this component. More correctly, the component is cached for rendering.

Parameters:
srcWindow | Window to use as the base for translating the component's ComponentArea into pixel values.
base_z | The z value to use for rendering the component. Note that this is not the final z value to use, but some z offset from a currently unknown starting value.
modColours | ColourRect describing colours that are to be modulated with the component's stored colour values to calculate a set of 'final' colour values to be used. May be 0.
Returns:
Nothing.

void CEGUI::FalagardComponentBase::setColours ( const ColourRect & cols )

Set the colours to be used by this ImageryComponent.

Parameters:
cols ColourRect object describing the colours to be used by this ImageryComponent.

void CEGUI::FalagardComponentBase::setColoursPropertyIsColourRect ( bool setting = true )

Set whether the colours property source represents a full ColourRect.

Parameters:
setting
  • true if the colours property will access a ColourRect object.
  • false if the colours property will access a colour object.
Returns:
Nothing.

void CEGUI::FalagardComponentBase::setColoursPropertySource ( const String & property )

Set the name of the property where colour values can be obtained.

Parameters:
property String containing the name of the property.
Returns:
Nothing.

void CEGUI::FalagardComponentBase::setComponentArea ( const ComponentArea & area )

Set the ImageryComponent's ComponentArea.

Parameters:
area ComponentArea object describing a new target area for the ImageryComponent.
Returns:
Nothing.

void CEGUI::FalagardComponentBase::setHorzFormattingPropertySource ( const String & property )

Set the name of the property where horizontal formatting option can be obtained.

Parameters:
property String containing the name of the property.
Returns:
Nothing.

void CEGUI::FalagardComponentBase::setVertFormattingPropertySource ( const String & property )

Set the name of the property where vertical formatting option can be obtained.

Parameters:
property String containing the name of the property.
Returns:
Nothing.

bool CEGUI::FalagardComponentBase::writeColoursXML ( OutStream & out_stream ) const [protected]

Writes xml for the colours to a OutStream. Will prefer property colours before explicit.

Note:
This is intended as a helper method for sub-classes when outputting xml to a stream.
Returns:
  • true if xml element was written.
  • false if nothing was output due to the formatting not being set (sub-class may then choose to do something else.)

bool CEGUI::FalagardComponentBase::writeHorzFormatXML ( OutStream & out_stream ) const [protected]

Writes xml for the horizontal formatting to a OutStream if such a property is defined.

Note:
This is intended as a helper method for sub-classes when outputting xml to a stream.
Returns:
  • true if xml element was written.
  • false if nothing was output due to the formatting not being set (sub-class may then choose to do something else.)

bool CEGUI::FalagardComponentBase::writeVertFormatXML ( OutStream & out_stream ) const [protected]

Writes xml for the vertical formatting to a OutStream if such a property is defined.

Note:
This is intended as a helper method for sub-classes when outputting xml to a stream.
Returns:
  • true if xml element was written.
  • false if nothing was output due to the formatting not being set (sub-class may then choose to do something else.)

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FalagardXMLHelper Class Reference

CEGUI::FalagardXMLHelper

CEGUI::FalagardXMLHelper Class Reference

Utility helper class primarily intended for use by the falagard xml parser. More...

List of all members.

Static Public Member Functions

static VerticalFormatting | stringToVertFormat (const String &str)
static HorizontalFormatting | stringToHorzFormat (const String &str)
static VerticalAlignment | stringToVertAlignment (const String &str)
static HorizontalAlignment | stringToHorzAlignment (const String &str)
static DimensionType | stringToDimensionType (const String &str)
static VerticalTextFormatting | stringToVertTextFormat (const String &str)
static HorizontalTextFormatting | stringToHorzTextFormat (const String &str)
static FontMetricType | stringToFontMetricType (const String &str)
static DimensionOperator | stringToDimensionOperator (const String &str)
static FrameImageComponent | stringToFrameImageComponent (const String &str)
static String | vertFormatToString (VerticalFormatting format)
static String | horzFormatToString (HorizontalFormatting format)
static String | vertAlignmentToString (VerticalAlignment alignment)
static String | horzAlignmentToString (HorizontalAlignment alignment)
static String | dimensionTypeToString (DimensionType dim)
static String | vertTextFormatToString (VerticalTextFormatting format)
static String | horzTextFormatToString (HorizontalTextFormatting format)
static String | fontMetricTypeToString (FontMetricType metric)
static String | dimensionOperatorToString (DimensionOperator op)
static String | frameImageComponentToString (FrameImageComponent imageComp)

Detailed Description

Utility helper class primarily intended for use by the falagard xml parser.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FileIOException Class Reference

CEGUI::FileIOException

CEGUI::FileIOException Class Reference

Exception class used when a file handling problem occurs. More...

Inheritance diagram for CEGUI::FileIOException:

[legend]
Collaboration diagram for CEGUI::FileIOException:

[legend]
List of all members.

Public Member Functions

FileIOException (const String &message)

Detailed Description

Exception class used when a file handling problem occurs.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Font Class Reference

CEGUI::WindowProperties::Font

CEGUI::WindowProperties::Font Class Reference

Property to access window Font setting. More...

Inheritance diagram for CEGUI::WindowProperties::Font:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Font:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.

Detailed Description

Property to access window Font setting.

This property offers access to the current Font setting for the window.

Usage:
  • Name: Font
  • Format: "[text]".
Where:
  • [text] is the name of the Font to assign for this window. The Font specified must already be loaded.

Member Function Documentation

String CEGUI::WindowProperties::Font::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

bool CEGUI::WindowProperties::Font::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::WindowProperties::Font::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Font Class Reference

CEGUI::Font

CEGUI::Font Class Reference

Class that encapsulates text rendering functionality for a typeface. More...

Collaboration diagram for CEGUI::Font:

[legend]
List of all members.

Public Member Functions

size_t | drawText (const String &text, const Rect &draw_area, float z, const Rect &clip_rect, TextFormatting fmt, const ColourRect &colours, float x_scale=1.0f, float y_scale=1.0f) const
Draw text into a specified area of the display.
size_t | drawText (const String &text, const Rect &draw_area, float z, const Rect &clip_rect, TextFormatting fmt, float x_scale=1.0f, float y_scale=1.0f) const
Draw text into a specified area of the display using default colours.
void | drawText (const String &text, const Rect &draw_area, float z, const Rect &clip_rect, float x_scale=1.0f, float y_scale=1.0f) const
Draw text into a specified area of the display with default colours and default formatting (LeftAligned).
size_t | drawText (const String &text, const Rect &draw_area, float z, TextFormatting fmt, const ColourRect &colours, float x_scale=1.0f, float y_scale=1.0f) const
Draw text into a specified area of the display.
size_t | drawText (const String &text, const Rect &draw_area, float z, TextFormatting fmt, float x_scale=1.0f, float y_scale=1.0f) const
Draw text into a specified area of the display with default colours.
void | drawText (const String &text, const Rect &draw_area, float z, float x_scale=1.0f, float y_scale=1.0f) const
Draw text into a specified area of the display with default colours and default formatting (LeftAligned).
void | drawText (const String &text, const Vector3 &position, const Rect &clip_rect, const ColourRect &colours, float x_scale=1.0f, float y_scale=1.0f) const
Draw text at the specified location.
void | drawText (const String &text, const Vector3 &position, const Rect &clip_rect, float x_scale=1.0f, float y_scale=1.0f) const
Draw text at the specified location with default colours.
void | defineFontGlyphs (const String &glyph_set)
Define the set of code points to be renderable by the font.
void | defineFontGlyphs (utf32 first_code_point, utf32 last_code_point)
Define the range of code points to be renderable by the font.
void | setNativeResolution (const Size &size)
Set the native resolution for this Font.
void | notifyScreenResolution (const Size &size)
Notify the Font of the current (usually new) display resolution.
void | setAutoScalingEnabled (bool setting)
Enable or disable auto-scaling for this Font.
void | setAntiAliased (bool setting)
Set whether the font is anti-aliased or not. Only relevant for dynamic fonts, this setting is ignored for bitmapped fonts.
float | getTextExtent (const String &text, float x_scale=1.0f) const
Return the pixel width of the specified text if rendered with this Font.
float | getLineSpacing (float y_scale=1.0f) const
Return the pixel line spacing value for.
float | getFontHeight (float y_scale=1.0f) const
return the exact pixel height of the font.
float | getBaseline (float y_scale=1.0f) const
Return the number of pixels from the top of the highest glyph to the baseline.
size_t | getCharAtPixel (const String &text, float pixel, float x_scale=1.0f) const
Return the index of the closest text character in String text that corresponds to pixel location pixel if the text were rendered.
size_t | getCharAtPixel (const String &text, size_t start_char, float pixel, float x_scale=1.0f) const
Return the index of the closest text character in String text, starting at character index start_char, that corresponds to pixel location pixel if the text were to be rendered.
const String & | getName (void) const
Return the name of this font.
Size | getNativeResolution (void) const
Return the native display size for this Font. This is only relevant if the Font is being auto-scaled.
bool | isAutoScaled (void) const
Return whether this Font is auto-scaled.
bool | isCodepointAvailable (utf32 cp) const
Return whether this Font can currently draw the specified code-point.
size_t | getFormattedLineCount (const String &text, const Rect &format_area, TextFormatting fmt, float x_scale=1.0f) const
Return the number of lines the given text would be formatted to.
float | getFormattedTextExtent (const String &text, const Rect &format_area, TextFormatting fmt, float x_scale=1.0f) const
Return the horizontal pixel extent given text would be formatted to.
bool | isAntiAliased (void) const
Return whether this font is anti-aliased or not. This is only relevant for dynamic fonts created from a TrueType font file.
const String & | getAvailableGlyphs (void) const
Return a String object that contains the code-points that the font is currently configured to render.
uint | getPointSize (void) const
Return the point size of a dynamic (ttf based) font.
~Font (void)
Destroys a Font object.

Static Public Attributes

static const argb_t | DefaultColour = 0xFFFFFFFF
Colour value used whenever a colour is not specified.

Friends

class | Font_xmlHandler
class | FontManager

Classes

struct | FontImplData
struct | glyphDat
struct to hold extra details about a glyph (required for proper rendering)

Detailed Description

Class that encapsulates text rendering functionality for a typeface.

A Font object is created for each unique typeface required. The Font class provides methods for loading typefaces from various sources, and then for outputting text via the Renderer object.

Member Function Documentation

void CEGUI::Font::defineFontGlyphs | ( | utf32 | first_code_point,
 |  | utf32 | last_code_point
 | ) |

Define the range of code points to be renderable by the font.

Note:
This function can take some time to execute depending upon the size of the code point set, and the size of the font being operated upon.

The code point arguments must satisfy the following: first_code_point <= last_code_point, otherwise results are undefined

Parameters:
first_code_point | utf32 value describing the first code point that will be renderable by this font.
last_code_point | utf32 value describing the last code point that will be renderable by this font.
Returns:
Nothing
Exceptions:
InvalidRequestException | thrown if the font is based on a bitmap rather than a true-type font.
RendererException | thrown if the Renderer can't support a texture large enough to hold the glyph imagery.
MemoryException | thrown if allocation of imagery construction buffer fails.

void CEGUI::Font::defineFontGlyphs ( const String & glyph_set )

Define the set of code points to be renderable by the font.

Note:
This function can take some time to execute depending upon the size of the code point set, and the size of the font being operated upon.
Parameters:
glyph_set String object describing all the code points that will be renderable by this font
Returns:
Nothing
Exceptions:
InvalidRequestException | thrown if the font is based on a bitmap rather than a true-type font.
RendererException | thrown if the Renderer can't support a texture large enough to hold the glyph imagery.
MemoryException | thrown if allocation of imagery construction buffer fails.

void CEGUI::Font::drawText | ( | const String & | text,
 |  | const Vector3 & | position,
 |  | const Rect & | clip_rect,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text at the specified location with default colours.

Parameters:
text | String object containing the text to be drawn.
position | Vector3 object describing the location for the text. NB: The position specified here corresponds to the text baseline and not the top of any glyph. The baseline spacing required can be retrieved by calling getBaseline().
clip_rect | Rect object describing the clipping area for the drawing. No drawing will occur outside this Rect.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
Nothing.

void CEGUI::Font::drawText | ( | const String & | text,
 |  | const Vector3 & | position,
 |  | const Rect & | clip_rect,
 |  | const ColourRect & | colours,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text at the specified location.

Parameters:
text | String object containing the text to be drawn.
position | Vector3 object describing the location for the text. NB: The position specified here corresponds to the text baseline and not the top of any glyph. The baseline spacing required can be retrieved by calling getBaseline().
clip_rect | Rect object describing the clipping area for the drawing. No drawing will occur outside this Rect.
colours | ColourRect object describing the colours to be applied when drawing the text. NB: The colours specified in here are applied to each glyph, rather than the text as a whole.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
Nothing.

void CEGUI::Font::drawText | ( | const String & | text,
 |  | const Rect & | draw_area,
 |  | float | z,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text into a specified area of the display with default colours and default formatting (LeftAligned).

Parameters:
text | String object containing the text to be drawn.
draw_area | Rect object describing the area of the display where the text is to be rendered. The text is formatted using this Rect depending upon the option specified in fmt. Additionally, the drawn text is clipped to be within this Rect (applies to non-word wrapped formatting where the text may otherwise have fallen outside this Rect).
z | flat value specifying the z co-ordinate for the drawn text.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
Nothing.

size_t CEGUI::Font::drawText | ( | const String & | text,
 |  | const Rect & | draw_area,
 |  | float | z,
 |  | TextFormatting | fmt,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text into a specified area of the display with default colours.

Parameters:
text | String object containing the text to be drawn.
draw_area | Rect object describing the area of the display where the text is to be rendered. The text is formatted using this Rect depending upon the option specified in fmt. Additionally, the drawn text is clipped to be within this Rect (applies to non-word wrapped formatting where the text may otherwise have fallen outside this Rect).
z | flat value specifying the z co-ordinate for the drawn text.
fmt | One of the TextFormatting values specifying the text formatting required.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
The number of lines output. NB: This does not consider clipping, so if all text was clipped, this would still return >=1.

size_t CEGUI::Font::drawText | ( | const String & | text,
 |  | const Rect & | draw_area,
 |  | float | z,
 |  | TextFormatting | fmt,
 |  | const ColourRect & | colours,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text into a specified area of the display.

Parameters:
text | String object containing the text to be drawn.
draw_area | Rect object describing the area of the display where the text is to be rendered. The text is formatted using this Rect depending upon the option specified in fmt. Additionally, the drawn text is clipped to be within this Rect (applies to non-word wrapped formatting where the text may otherwise have fallen outside this Rect).
z | flat value specifying the z co-ordinate for the drawn text.
fmt | One of the TextFormatting values specifying the text formatting required.
colours | ColourRect object describing the colours to be applied when drawing the text. NB: The colours specified in here are applied to each glyph, rather than the text as a whole.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
The number of lines output. NB: This does not consider clipping, so if all text was clipped, this would still return >=1.

void CEGUI::Font::drawText | ( | const String & | text,
 |  | const Rect & | draw_area,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text into a specified area of the display with default colours and default formatting (LeftAligned).

Parameters:
text | String object containing the text to be drawn.
draw_area | Rect object describing the area of the display where the text is to be rendered. The text is not clipped to this Rect, but is formatted using this Rect depending upon the option specified in fmt.
z | flat value specifying the z co-ordinate for the drawn text.
clip_rect | Rect object describing the clipping area for the drawing. No drawing will occur outside this Rect.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
Nothing.

size_t CEGUI::Font::drawText | ( | const String & | text,
 |  | const Rect & | draw_area,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | TextFormatting | fmt,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const [inline]

Draw text into a specified area of the display using default colours.

Parameters:
text | String object containing the text to be drawn.
draw_area | Rect object describing the area of the display where the text is to be rendered. The text is not clipped to this Rect, but is formatted using this Rect depending upon the option specified in fmt.
z | flat value specifying the z co-ordinate for the drawn text.
clip_rect | Rect object describing the clipping area for the drawing. No drawing will occur outside this Rect.
fmt | One of the TextFormatting values specifying the text formatting required.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
The number of lines output. NB: This does not consider clipping, so if all text was clipped, this would still return >=1.

size_t CEGUI::Font::drawText | ( | const String & | text,
 |  | const Rect & | draw_area,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | TextFormatting | fmt,
 |  | const ColourRect & | colours,
 |  | float | x_scale = 1.0f,
 |  | float | y_scale = 1.0f
 | ) | const

Draw text into a specified area of the display.

Parameters:
text | String object containing the text to be drawn.
draw_area | Rect object describing the area of the display where the text is to be rendered. The text is not clipped to this Rect, but is formatted using this Rect depending upon the option specified in fmt.
z | flat value specifying the z co-ordinate for the drawn text.
clip_rect | Rect object describing the clipping area for the drawing. No drawing will occur outside this Rect.
fmt | One of the TextFormatting values specifying the text formatting required.
colours | ColourRect object describing the colours to be applied when drawing the text. NB: The colours specified in here are applied to each glyph, rather than the text as a whole.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
y_scale | Scaling factor to be applied to each glyph's y axis, where 1.0f is considered to be 'normal'.
Returns:
The number of lines output. NB: This does not consider clipping, so if all text was clipped, this would still return >=1.

const String & CEGUI::Font::getAvailableGlyphs ( void ) const

Return a String object that contains the code-points that the font is currently configured to render.

Returns:
Reference to a String object.

float CEGUI::Font::getBaseline ( float y_scale = 1.0f ) const [inline]

Return the number of pixels from the top of the highest glyph to the baseline.

Parameters:
y_scale Scaling factor to be applied to the baseline distance, where 1.0f is considered to be 'normal'.
Returns:
pixel spacing from top of front glyphs to baseline

size_t CEGUI::Font::getCharAtPixel | ( | const String & | text,
 |  | size_t | start_char,
 |  | float | pixel,
 |  | float | x_scale = 1.0f
 | ) | const

Return the index of the closest text character in String text, starting at character index start_char, that corresponds to pixel location pixel if the text were to be rendered.

Parameters:
text | String object containing the text.
start_char | index of the first character to consider. This is the lowest value that will be returned from the call.
pixel | Specifies the (horizontal) pixel offset to return the character index for.
x_scale | Scaling factor to be applied to each glyph's x axis when measuring the text extent, where 1.0f is considered to be 'normal'.
Returns:
Returns a character index into String text for the character that would be rendered closest to horizontal pixel offset pixel if the text were to be rendered via this Font. Range of the return is from 0 to text.length(), so may actually return an index past the end of the string, which indicates pixel was beyond the last character.

size_t CEGUI::Font::getCharAtPixel | ( | const String & | text,
 |  | float | pixel,
 |  | float | x_scale = 1.0f
 | ) | const [inline]

Return the index of the closest text character in String text that corresponds to pixel location pixel if the text were rendered.

Parameters:
text | String object containing the text.
pixel | Specifies the (horizontal) pixel offset to return the character index for.
x_scale | Scaling factor to be applied to each glyph's x axis when measuring the text extent, where 1.0f is considered to be 'normal'.
Returns:
Returns a character index into String text for the character that would be rendered closest to horizontal pixel offset pixel if the text were to be rendered via this Font. Range of the return is from 0 to text.length(), so may actually return an index past the end of the string, which indicates pixel was beyond the last character.

float CEGUI::Font::getFontHeight ( float y_scale = 1.0f ) const [inline]

return the exact pixel height of the font.

Parameters:
y_scale Scaling factor to be applied to the height, where 1.0f is considered to be 'normal'.
Returns:
float value describing the pixel height of the font without any additional padding.

size_t CEGUI::Font::getFormattedLineCount | ( | const String & | text,
 |  | const Rect & | format_area,
 |  | TextFormatting | fmt,
 |  | float | x_scale = 1.0f
 | ) | const

Return the number of lines the given text would be formatted to.

Since text formatting can result in multiple lines of text being output, it can be useful to know how many lines would be output without actually rendering the text.

Parameters:
text | String object containing the text to be measured.
format_area | Rect object describing the area to be used when formatting the text depending upon the option specified in fmt.
fmt | One of the TextFormatting values specifying the text formatting required.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
Returns:
The number of lines produced from the specified formatting

float CEGUI::Font::getFormattedTextExtent | ( | const String & | text,
 |  | const Rect & | format_area,
 |  | TextFormatting | fmt,
 |  | float | x_scale = 1.0f
 | ) | const

Return the horizontal pixel extent given text would be formatted to.

The value return by this method is basically the extent of the widest line within the formatted text.

Parameters:
text | String object containing the text to be measured.
format_area | Rect object describing the area to be used when formatting the text depending upon the option specified in fmt.
fmt | One of the TextFormatting values specifying the text formatting required.
x_scale | Scaling factor to be applied to each glyph's x axis, where 1.0f is considered to be 'normal'.
Returns:
The widest pixel extent of the lines produced from the specified formatting.

float CEGUI::Font::getLineSpacing ( float y_scale = 1.0f ) const [inline]

Return the pixel line spacing value for.

Parameters:
y_scale Scaling factor to be applied to the line spacing, where 1.0f is considered to be 'normal'.
Returns:
Number of pixels between vertical base lines, i.e. The minimum pixel space between two lines of text.

const String& CEGUI::Font::getName ( void ) const [inline]

Return the name of this font.

Returns:
String object holding the name of this font.

Size CEGUI::Font::getNativeResolution ( void ) const [inline]

Return the native display size for this Font. This is only relevant if the Font is being auto-scaled.

Returns:
Size object describing the native display size for this Font.

uint CEGUI::Font::getPointSize ( void ) const

Return the point size of a dynamic (ttf based) font.

Returns:
uint value indicating the point size specified when the dynamic font was created.
Exceptions:
InvalidRequestException thrown if the font is a static (bitmap based) font which do not support point sizes.

float CEGUI::Font::getTextExtent | ( | const String & | text,
 |  | float | x_scale = 1.0f
 | ) | const

Return the pixel width of the specified text if rendered with this Font.

Parameters:
text | String object containing the text to return the rendered pixel width for.
x_scale | Scaling factor to be applied to each glyph's x axis when measuring the extent, where 1.0f is considered to be 'normal'.
Returns:
Number of pixels that text will occupy when rendered with this Font.

bool CEGUI::Font::isAntiAliased ( void ) const

Return whether this font is anti-aliased or not. This is only relevant for dynamic fonts created from a TrueType font file.

Returns:
  • true if the font is anti-aliased.
  • false if the font is not anti-aliased.

bool CEGUI::Font::isAutoScaled ( void ) const [inline]

Return whether this Font is auto-scaled.

Returns:
true if the Font is auto-scaled, false if not.

bool CEGUI::Font::isCodepointAvailable ( utf32 cp ) const [inline]

Return whether this Font can currently draw the specified code-point.

Parameters:
cp utf32 code point that is the subject of the query.
Returns:
true if the font contains a mapping for code point cp, false if it does not contain a mapping for cp.

void CEGUI::Font::notifyScreenResolution ( const Size & size )

Notify the Font of the current (usually new) display resolution.

Parameters:
size Size object describing the display resolution
Returns:
Nothing

void CEGUI::Font::setAntiAliased ( bool setting )

Set whether the font is anti-aliased or not. Only relevant for dynamic fonts, this setting is ignored for bitmapped fonts.

Parameters:
setting
  • true if the font should be anti-aliased.
  • false if the font should not be anti-aliased.
Returns:
Nothing.

void CEGUI::Font::setAutoScalingEnabled ( bool setting )

Enable or disable auto-scaling for this Font.

Parameters:
setting true to enable auto-scaling, false to disable auto-scaling.
Returns:
Nothing.

void CEGUI::Font::setNativeResolution ( const Size & size )

Set the native resolution for this Font.

Parameters:
size Size object describing the new native screen resolution for this Font.
Returns:
Nothing

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Font_xmlHandler Class Reference

CEGUI::Font_xmlHandler

CEGUI::Font_xmlHandler Class Reference

Handler class used to parse the Font XML files using SAX2. More...

Collaboration diagram for CEGUI::Font_xmlHandler:

[legend]
List of all members.

Public Member Functions

Font_xmlHandler (Font *font)
Constructor for Font::xmlHandler objects.
virtual | ~Font_xmlHandler (void)
Destructor for Font::xmlHandler objects.
virtual void | elementStart (const String &element, const XMLAttributes &attributes)
document processing (only care about elements, schema validates format)
virtual void | elementEnd (const String &element)

Detailed Description

Handler class used to parse the Font XML files using SAX2.

Constructor & Destructor Documentation

CEGUI::Font_xmlHandler::Font_xmlHandler ( Font * font ) [inline]

Constructor for Font::xmlHandler objects.

Parameters:
font Pointer to the Font object creating this xmlHandler object

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FontDim Class Reference

CEGUI::FontDim

CEGUI::FontDim Class Reference

Dimension type that represents some metric of a Font. Implements BaseDim interface. More...

Inheritance diagram for CEGUI::FontDim:

[legend]
Collaboration diagram for CEGUI::FontDim:

[legend]
List of all members.

Public Member Functions

FontDim (const String &name, const String &font, const String &text, FontMetricType metric, float padding=0)
Constructor.

Protected Member Functions

float | getValue_impl (const Window &wnd) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
float | getValue_impl (const Window &wnd, const Rect &container) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
void | writeXMLElementName_impl (OutStream &out_stream) const
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
void | writeXMLElementAttributes_impl (OutStream &out_stream) const
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.
BaseDim * | clone_impl () const
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.

Detailed Description

Dimension type that represents some metric of a Font. Implements BaseDim interface.

Constructor & Destructor Documentation

CEGUI::FontDim::FontDim | ( | const String & | name,
 |  | const String & | font,
 |  | const String & | text,
 |  | FontMetricType | metric,
 |  | float | padding = 0
 | ) |

Constructor.

Parameters:
name | String holding the name suffix of the window to be accessed to obtain the font and / or text strings to be used when these items are not explicitly given.
font | String holding the name of the font to use for this dimension. If the string is empty, the font assigned to the window passed to getValue will be used.
text | String holding the text to be measured for horizontal extent. If this is empty, the text from the window passed to getValue will be used.
metric | One of the FontMetricType values indicating what we should represent.
padding | constant pixel padding value to be added.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FontManager Class Reference

CEGUI::FontManager

CEGUI::FontManager Class Reference

Class providing a shared library of Font objects to the system. More...

List of all members.

Public Types

typedef ConstBaseIterator<
FontRegistry > 		FontIterator

Public Member Functions

FontManager (void)
Constructor for FontManager objects.
~FontManager (void)
Destructor for FontManager objects.
Font * | createFont (const String &filename, const String &resourceGroup="")
Creates a new font from a font definition file, and returns a pointer to the new Font object.
Font * | createFont (const String &name, const String &fontname, uint size, uint flags, const String &resourceGroup="")
Creates a new Font based on a true-type font, and returns a pointer to the new Font object.
void | destroyFont (const String &name)
Destroy's the font with the given name.
void | destroyFont (Font *font)
Destroys the given Font object.
void | destroyAllFonts (void)
Destroys all Font objects registered in the system.
bool | isFontPresent (const String &name) const
Checks the existence of a given font.
Font * | getFont (const String &name) const
Returns a pointer to the font object with the specified name.
void | notifyScreenResolution (const Size &size)
Notify the FontManager of the current (usually new) display resolution.
void | writeFontToStream (const String &name, OutStream &out_stream) const
Writes a full XML font file for the specified Font to the given OutStream.
FontIterator | getIterator (void) const
Return a FontManager::FontIterator object to iterate over the available Font objects.

Static Public Member Functions

static FontManager & | getSingleton (void)
Return singleton FontManager object.
static FontManager * | getSingletonPtr (void)
Return pointer to singleton FontManager object.

Classes

struct | FontManagerImplData

Detailed Description

Class providing a shared library of Font objects to the system.

The FontManager is used to create, access, and destroy Font objects. The idea is that the FontManager will function as a central repository for Font objects used within the GUI system, and that those Font objects can be accessed, via a unique name, by any interested party within the system.

Member Function Documentation

Font * CEGUI::FontManager::createFont | ( | const String & | name,
 |  | const String & | fontname,
 |  | uint | size,
 |  | uint | flags,
 |  | const String & | resourceGroup = ""
 | ) |

Creates a new Font based on a true-type font, and returns a pointer to the new Font object.

Parameters:
name | String object containing a unique name for the new font.
fontname | String object containing the name and path of the true-type font to access.
size | Specifies the glyph size (point-size) for the new font.
flags | Some combination of FontFlag values to be used for the creation of this font.
resourceGroup | Resource group identifier to be passed to the resource provider when loading the font definition file.
Returns:
Pointer to the newly created Font object.
Exceptions:
AlreadyExistsException | thrown if a Font already exists with the name specified, or if a font Imageset clashes with one already defined in the system.
GenericException | thrown if something goes wrong while accessing a true-type font referenced in file fontname.
RendererException | thrown if the Renderer can't support a texture large enough to hold the requested glyph imagery.
MemoryException | thrown if allocation of imagery construction buffer fails.

Font * CEGUI::FontManager::createFont | ( | const String & | filename,
 |  | const String & | resourceGroup = ""
 | ) |

Creates a new font from a font definition file, and returns a pointer to the new Font object.

Parameters:
filename | String object containing the filename of a 'font definition file' what will be used to create the new font
resourceGroup | Resource group identifier to pass to the resource provider when loading the font definition file.
Returns:
Pointer the the newly created Font object
Exceptions:
FileIOException | thrown if there was some problem accessing or parsing the file filename
InvalidRequestException | thrown if an invalid filename was provided.
AlreadyExistsException | thrown if a Font already exists with the name specified, or if a font Imageset clashes with one already defined in the system.
GenericException | thrown if something goes wrong while accessing a true-type font referenced in file filename.
RendererException | thrown if the Renderer can't support a texture large enough to hold the requested glyph imagery.
MemoryException | thrown if allocation of imagery construction buffer fails.

void CEGUI::FontManager::destroyAllFonts ( void )

Destroys all Font objects registered in the system.

Returns:
Nothing

void CEGUI::FontManager::destroyFont ( Font * font )

Destroys the given Font object.

Parameters:
font Pointer to the Font to be destroyed. If no such Font exists, nothing happens.
Returns:
Nothing.

void CEGUI::FontManager::destroyFont ( const String & name )

Destroy's the font with the given name.

Parameters:
name String object containing the name of the font to be destroyed. If the specified font does not exist, nothing happens.
Returns:
Nothing

Font * CEGUI::FontManager::getFont ( const String & name ) const

Returns a pointer to the font object with the specified name.

Parameters:
name String object containing the name of the Font object to be returned
Returns:
Pointer to the requested Font object
Exceptions:
UnknownObjectException Thrown if no font with the given name exists.

FontManager & CEGUI::FontManager::getSingleton ( void ) [static]

Return singleton FontManager object.

Returns:
Singleton FontManager object

FontManager * CEGUI::FontManager::getSingletonPtr ( void ) [static]

Return pointer to singleton FontManager object.

Returns:
Pointer to singleton FontManager object

bool CEGUI::FontManager::isFontPresent ( const String & name ) const

Checks the existence of a given font.

Parameters:
name String object holding the name of the Font object to look for.
Returns:
true if a Font object named name exists in the system, false if no such font exists.

void CEGUI::FontManager::notifyScreenResolution ( const Size & size )

Notify the FontManager of the current (usually new) display resolution.

Parameters:
size Size object describing the display resolution
Returns:
Nothing

void CEGUI::FontManager::writeFontToStream | ( | const String & | name,
 |  | OutStream & | out_stream
 | ) | const

Writes a full XML font file for the specified Font to the given OutStream.

Parameters:
name | String holding the name of the Font to be written to the stream.
out_stream | OutStream (std::ostream based) object where data is to be sent.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::ForceHorzScrollbar Class Reference

CEGUI::MultiColumnListProperties::ForceHorzScrollbar

CEGUI::MultiColumnListProperties::ForceHorzScrollbar Class Reference

Property to access the 'always show' setting for the horizontal scroll bar of the list box. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::ForceHorzScrollbar:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::ForceHorzScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'always show' setting for the horizontal scroll bar of the list box.

Usage:
  • Name: ForceHorzScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the horizontal scroll bar will always be shown.
  • "False" to indicate that the horizontal scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::MultiColumnListProperties::ForceHorzScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::ForceHorzScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::ForceHorzScrollbar Class Reference

CEGUI::ScrollablePaneProperties::ForceHorzScrollbar

CEGUI::ScrollablePaneProperties::ForceHorzScrollbar Class Reference

Property to access the setting which controls whether the horizontal scroll bar will always be displayed, or only displayed when it is required. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::ForceHorzScrollbar:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::ForceHorzScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting which controls whether the horizontal scroll bar will always be displayed, or only displayed when it is required.

Usage:
  • Name: ForceHorzScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the horizontal scroll bar will always be shown.
  • "False" to indicate that the horizontal scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::ScrollablePaneProperties::ForceHorzScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::ForceHorzScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::ForceHorzScrollbar Class Reference

CEGUI::ComboboxProperties::ForceHorzScrollbar

CEGUI::ComboboxProperties::ForceHorzScrollbar Class Reference

Property to access the 'always show' setting for the horizontal scroll bar of the list box. More...

Inheritance diagram for CEGUI::ComboboxProperties::ForceHorzScrollbar:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::ForceHorzScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'always show' setting for the horizontal scroll bar of the list box.

Usage:
  • Name: ForceHorzScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the horizontal scroll bar will always be shown.
  • "False" to indicate that the horizontal scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::ComboboxProperties::ForceHorzScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::ForceHorzScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxProperties::ForceHorzScrollbar Class Reference

CEGUI::ListboxProperties::ForceHorzScrollbar

CEGUI::ListboxProperties::ForceHorzScrollbar Class Reference

Property to access the 'always show' setting for the horizontal scroll bar of the list box. More...

Inheritance diagram for CEGUI::ListboxProperties::ForceHorzScrollbar:

[legend]
Collaboration diagram for CEGUI::ListboxProperties::ForceHorzScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'always show' setting for the horizontal scroll bar of the list box.

Usage:
  • Name: ForceHorzScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the horizontal scroll bar will always be shown.
  • "False" to indicate that the horizontal scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::ListboxProperties::ForceHorzScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListboxProperties::ForceHorzScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::ForceVertScrollbar Class Reference

CEGUI::MultiColumnListProperties::ForceVertScrollbar

CEGUI::MultiColumnListProperties::ForceVertScrollbar Class Reference

Property to access the 'always show' setting for the vertical scroll bar of the list box. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::ForceVertScrollbar:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::ForceVertScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'always show' setting for the vertical scroll bar of the list box.

Usage:
  • Name: ForceVertScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the vertical scroll bar will always be shown.
  • "False" to indicate that the vertical scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::MultiColumnListProperties::ForceVertScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::ForceVertScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::ForceVertScrollbar Class Reference

CEGUI::ScrollablePaneProperties::ForceVertScrollbar

CEGUI::ScrollablePaneProperties::ForceVertScrollbar Class Reference

Property to access the setting which controls whether the vertical scroll bar will always be displayed, or only displayed when it is required. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::ForceVertScrollbar:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::ForceVertScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting which controls whether the vertical scroll bar will always be displayed, or only displayed when it is required.

Usage:
  • Name: ForceVertScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the vertical scroll bar will always be shown.
  • "False" to indicate that the vertical scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::ScrollablePaneProperties::ForceVertScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::ForceVertScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::ForceVertScrollbar Class Reference

CEGUI::ComboboxProperties::ForceVertScrollbar

CEGUI::ComboboxProperties::ForceVertScrollbar Class Reference

Property to access the 'always show' setting for the vertical scroll bar of the list box. More...

Inheritance diagram for CEGUI::ComboboxProperties::ForceVertScrollbar:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::ForceVertScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'always show' setting for the vertical scroll bar of the list box.

Usage:
  • Name: ForceVertScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the vertical scroll bar will always be shown.
  • "False" to indicate that the vertical scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::ComboboxProperties::ForceVertScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::ForceVertScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxProperties::ForceVertScrollbar Class Reference

CEGUI::ListboxProperties::ForceVertScrollbar

CEGUI::ListboxProperties::ForceVertScrollbar Class Reference

Property to access the 'always show' setting for the vertical scroll bar of the list box. More...

Inheritance diagram for CEGUI::ListboxProperties::ForceVertScrollbar:

[legend]
Collaboration diagram for CEGUI::ListboxProperties::ForceVertScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'always show' setting for the vertical scroll bar of the list box.

Usage:
  • Name: ForceVertScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the vertical scroll bar will always be shown.
  • "False" to indicate that the vertical scroll bar will only be shown when it is needed.

Member Function Documentation

String CEGUI::ListboxProperties::ForceVertScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListboxProperties::ForceVertScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::FrameColours Class Reference

CEGUI::StaticProperties::FrameColours

CEGUI::StaticProperties::FrameColours Class Reference

Property to access the frame colours for the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::FrameColours:

[legend]
Collaboration diagram for CEGUI::StaticProperties::FrameColours:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the frame colours for the Static widget.

Usage:
  • Name: FrameColours
  • Format: "tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]".
Where:
  • tl:[aarrggbb] is the top-left colour value specified as ARGB (hex).
  • tr:[aarrggbb] is the top-right colour value specified as ARGB (hex).
  • bl:[aarrggbb] is the bottom-left colour value specified as ARGB (hex).
  • br:[aarrggbb] is the bottom-right colour value specified as ARGB (hex).

Member Function Documentation

String CEGUI::StaticProperties::FrameColours::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::FrameColours::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameComponent Class Reference

CEGUI::FrameComponent

CEGUI::FrameComponent Class Reference

Class that encapsulates information for a frame with background (9 images in total). More...

Inheritance diagram for CEGUI::FrameComponent:

[legend]
Collaboration diagram for CEGUI::FrameComponent:

[legend]
List of all members.

Public Member Functions

FrameComponent ()
Constructor.
VerticalFormatting | getBackgroundVerticalFormatting () const
Return the current vertical formatting setting for this FrameComponent.
void | setBackgroundVerticalFormatting (VerticalFormatting fmt)
Set the vertical formatting setting for this FrameComponent.
HorizontalFormatting | getBackgroundHorizontalFormatting () const
Return the current horizontal formatting setting for this FrameComponent.
void | setBackgroundHorizontalFormatting (HorizontalFormatting fmt)
Set the horizontal formatting setting for this FrameComponent.
const Image * | getImage (FrameImageComponent part) const
Return the Image object that will be drawn by this FrameComponent for a specified frame part.
void | setImage (FrameImageComponent part, const Image *image)
Set the Image that will be drawn by this ImageryComponent.
void | setImage (FrameImageComponent part, const String &imageset, const String &image)
Set the Image that will be drawn by this FrameComponent.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this FrameComponent to out_stream.

Protected Member Functions

void | render_impl (Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const
Method to do main render caching work.
void | doBackgroundRender (Window &srcWindow, Rect &destRect, float base_z, const ColourRect &colours, const Rect *clipper, bool clipToDisplay) const

Protected Attributes

VerticalFormatting d_vertFormatting
Vertical formatting to be applied when rendering the background for the component.
HorizontalFormatting d_horzFormatting
Horizontal formatting to be applied when rendering the background for the component.
const Image * | d_frameImages [FIC_FRAME_IMAGE_COUNT]
Array that holds the assigned images.

Detailed Description

Class that encapsulates information for a frame with background (9 images in total).

Corner images are always drawn at their natural size, edges are stretched between the corner pieces for a particular edge, the background image will cover the inner rectangle formed by the edge images and can be stretched or tiled in either dimension.

Member Function Documentation

HorizontalFormatting CEGUI::FrameComponent::getBackgroundHorizontalFormatting ( ) const

Return the current horizontal formatting setting for this FrameComponent.

Returns:
One of the HorizontalFormatting enumerated values.

VerticalFormatting CEGUI::FrameComponent::getBackgroundVerticalFormatting ( ) const

Return the current vertical formatting setting for this FrameComponent.

Returns:
One of the VerticalFormatting enumerated values.

const Image * CEGUI::FrameComponent::getImage ( FrameImageComponent part ) const

Return the Image object that will be drawn by this FrameComponent for a specified frame part.

Parameters:
part One of the FrameImageComponent enumerated values specifying the component image to be accessed.
Returns:
Image object.

void CEGUI::FrameComponent::setBackgroundHorizontalFormatting ( HorizontalFormatting fmt )

Set the horizontal formatting setting for this FrameComponent.

Parameters:
fmt One of the HorizontalFormatting enumerated values.
Returns:
Nothing.

void CEGUI::FrameComponent::setBackgroundVerticalFormatting ( VerticalFormatting fmt )

Set the vertical formatting setting for this FrameComponent.

Parameters:
fmt One of the VerticalFormatting enumerated values.
Returns:
Nothing.

void CEGUI::FrameComponent::setImage | ( | FrameImageComponent | part,
 |  | const String & | imageset,
 |  | const String & | image
 | ) |

Set the Image that will be drawn by this FrameComponent.

Parameters:
part | One of the FrameImageComponent enumerated values specifying the component image to be accessed.
imageset | String holding the name of the Imagset that contains the Image to be rendered.
image | String holding the name of the Image to be rendered.
Returns:
Nothing.

void CEGUI::FrameComponent::setImage | ( | FrameImageComponent | part,
 |  | const Image * | image
 | ) |

Set the Image that will be drawn by this ImageryComponent.

Parameters:
part | One of the FrameImageComponent enumerated values specifying the component image to be accessed.
image | Pointer to the Image object to be drawn by this FrameComponent.
Returns:
Nothing.

void CEGUI::FrameComponent::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this FrameComponent to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::FrameEnabled Class Reference

CEGUI::StaticProperties::FrameEnabled

CEGUI::StaticProperties::FrameEnabled Class Reference

Property to access the state of the frame enabled setting for the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::FrameEnabled:

[legend]
Collaboration diagram for CEGUI::StaticProperties::FrameEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the frame enabled setting for the Static widget.

Usage:
  • Name: FrameEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate that the frame is enabled.
  • "False" to indicate that the frame is disabled.

Member Function Documentation

String CEGUI::StaticProperties::FrameEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::FrameEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::FrameEnabled Class Reference

CEGUI::FrameWindowProperties::FrameEnabled

CEGUI::FrameWindowProperties::FrameEnabled Class Reference

Property to access the setting for whether the window frame will be displayed. More...

Inheritance diagram for CEGUI::FrameWindowProperties::FrameEnabled:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::FrameEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for whether the window frame will be displayed.

Usage:
  • Name: FrameEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the windows frame should be displayed.
  • "False" to indicate the windows frame should not be displayed.

Member Function Documentation

String CEGUI::FrameWindowProperties::FrameEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::FrameEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindow Class Reference

CEGUI::FrameWindow

CEGUI::FrameWindow Class Reference

Abstract base class for a movable, sizable, window with a title-bar and a frame. More...

Inheritance diagram for CEGUI::FrameWindow:

[legend]
Collaboration diagram for CEGUI::FrameWindow:

[legend]
List of all members.

Public Types

enum SizingLocation {
SizingNone, SizingTopLeft, SizingTopRight, SizingBottomLeft,
SizingBottomRight, SizingTop, SizingLeft, SizingBottom,
SizingRight
}
Enumeration that defines the set of possible locations for the mouse on a frame windows sizing border. More...

Public Member Functions

virtual void | initialise (void)
Initialises the Window based object ready for use.
bool | isSizingEnabled (void) const
Return whether this window is sizable. Note that this requires that the window have an enabled frame and that sizing itself is enabled.
bool | isFrameEnabled (void) const
Return whether the frame for this window is enabled.
bool | isTitleBarEnabled (void) const
Return whether the title bar for this window is enabled.
bool | isCloseButtonEnabled (void) const
Return whether this close button for this window is enabled.
bool | isRollupEnabled (void) const
Return whether roll up (a.k.a shading) is enabled for this window.
bool | isRolledup (void) const
Return whether the window is currently rolled up (a.k.a shaded).
float | getSizingBorderThickness (void) const
Return the thickness of the sizing border.
void | setSizingEnabled (bool setting)
Enables or disables sizing for this window.
void | setFrameEnabled (bool setting)
Enables or disables the frame for this window.
void | setTitleBarEnabled (bool setting)
Enables or disables the title bar for the frame window.
void | setCloseButtonEnabled (bool setting)
Enables or disables the close button for the frame window.
void | setRollupEnabled (bool setting)
Enables or disables roll-up (shading) for this window.
void | toggleRollup (void)
Toggles the state of the window between rolled-up (shaded) and normal sizes. This requires roll-up to be enabled.
void | setSizingBorderThickness (float pixels)
Set the size of the sizing border for this window.
void | setTitlebarFont (const String &name)
Set the font to use for the title bar text.
void | setTitlebarFont (Font *font)
Set the font to use for the title bar text.
void | offsetPixelPosition (const Vector2 &offset)
Move the window by the pixel offsets specified in offset.
bool | isDragMovingEnabled (void) const
Return whether this FrameWindow can be moved by dragging the title bar.
void | setDragMovingEnabled (bool setting)
Set whether this FrameWindow can be moved by dragging the title bar.
const Font * | getTitlebarFont (void) const
Return the font being used for the title bar text.
colour | getCaptionColour (void) const
Return the current colour used for rendering the caption text.
void | setCaptionColour (colour col)
Sets the colour to be used for rendering the caption text.
const Image * | getNSSizingCursorImage () const
Return a pointer to the currently set Image to be used for the north-south sizing mouse cursor.
const Image * | getEWSizingCursorImage () const
Return a pointer to the currently set Image to be used for the east-west sizing mouse cursor.
const Image * | getNWSESizingCursorImage () const
Return a pointer to the currently set Image to be used for the northwest-southeast sizing mouse cursor.
const Image * | getNESWSizingCursorImage () const
Return a pointer to the currently set Image to be used for the northeast-southwest sizing mouse cursor.
void | setNSSizingCursorImage (const Image *image)
Set the Image to be used for the north-south sizing mouse cursor.
void | setEWSizingCursorImage (const Image *image)
Set the Image to be used for the east-west sizing mouse cursor.
void | setNWSESizingCursorImage (const Image *image)
Set the Image to be used for the northwest-southeast sizing mouse cursor.
void | setNESWSizingCursorImage (const Image *image)
Set the Image to be used for the northeast-southwest sizing mouse cursor.
void | setNSSizingCursorImage (const String &imageset, const String &image)
Set the image to be used for the north-south sizing mouse cursor.
void | setEWSizingCursorImage (const String &imageset, const String &image)
Set the image to be used for the east-west sizing mouse cursor.
void | setNWSESizingCursorImage (const String &imageset, const String &image)
Set the image to be used for the northwest-southeast sizing mouse cursor.
void | setNESWSizingCursorImage (const String &imageset, const String &image)
Set the image to be used for the northeast-southwest sizing mouse cursor.
bool | isHit (const Point &position) const
check if the given position would hit this window.
FrameWindow (const String &name, const String &type)
Constructor for FrameWindow objects.
virtual | ~FrameWindow (void)
Destructor for FramwWindow objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventRollupToggled
Fired when the rollup (shade) state of the window changes.
static const String | EventCloseClicked
Fired when the close button for the window is clicked.
static const float | DefaultSizingBorderSize = 8.0f
Default size for the sizing border (in pixels).

Protected Member Functions

virtual Titlebar * | createTitlebar (const String &name) const =0
Create a control based upon the Titlebar base class to be used as the title bar for this window.
virtual PushButton * | createCloseButton (const String &name) const =0
Create a control based upon the PushButton base class, to be used at the close button for the window.
void | moveLeftEdge (float delta)
move the window's left edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.
void | moveRightEdge (float delta)
move the window's right edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.
void | moveTopEdge (float delta)
move the window's top edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.
void | moveBottomEdge (float delta)
move the window's bottom edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.
SizingLocation | getSizingBorderAtPoint (const Point &pt) const
check local pixel co-ordinate point 'pt' and return one of the SizingLocation enumerated values depending where the point falls on the sizing border.
bool | isLeftSizingLocation (SizingLocation loc) const
return true if given SizingLocation is on left edge.
bool | isRightSizingLocation (SizingLocation loc) const
return true if given SizingLocation is on right edge.
bool | isTopSizingLocation (SizingLocation loc) const
return true if given SizingLocation is on top edge.
bool | isBottomSizingLocation (SizingLocation loc) const
return true if given SizingLocation is on bottom edge.
void | addFrameWindowEvents (void)
Add frame window specific events.
bool | closeClickHandler (const EventArgs &e)
Method to respond to close button click events and fire our close event.
void | setCursorForPoint (const Point &pt) const
Set the appropriate mouse cursor for the given window-relative pixel point.
virtual Rect | getSizingRect (void) const
Return a Rect that describes, in window relative pixel co-ordinates, the outer edge of the sizing area for this window.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onRollupToggled (WindowEventArgs &e)
Event generated internally whenever the roll-up / shade state of the window changes.
virtual void | onCloseClicked (WindowEventArgs &e)
Event generated internally whenever the close button is clicked.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | onActivated (ActivationEventArgs &e)
Handler called when this window has become the active window.
virtual void | onDeactivated (ActivationEventArgs &e)
Handler called when this window has lost input focus and has been deactivated.

Protected Attributes

bool | d_frameEnabled
true if window frame should be drawn.
bool | d_rollupEnabled
true if roll-up of window is allowed.
bool | d_rolledup
true if window is rolled up.
bool | d_sizingEnabled
true if sizing is enabled for this window.
bool | d_beingSized
true if window is being sized.
float | d_borderSize
thickness of the sizing border around this window
Point d_dragPoint
point window is being dragged at.
Titlebar * d_titlebar
points to the title bar widget.
PushButton * d_closeButton
points to close button widget.
const Image * | d_nsSizingCursor
North/South sizing cursor image.
const Image * | d_ewSizingCursor
East/West sizing cursor image.
const Image * | d_nwseSizingCursor
North-West/South-East cursor image.
const Image * | d_neswSizingCursor
North-East/South-West cursor image.
bool | d_dragMovable
true if the window will move when dragged by the title bar.

Detailed Description

Abstract base class for a movable, sizable, window with a title-bar and a frame.

Member Enumeration Documentation

enum CEGUI::FrameWindow::SizingLocation

Enumeration that defines the set of possible locations for the mouse on a frame windows sizing border.

Enumerator:
SizingNone | Position is not a sizing location.
SizingTopLeft | Position will size from the top-left.
SizingTopRight | Position will size from the top-right.
SizingBottomLeft | Position will size from the bottom left.
SizingBottomRight | Position will size from the bottom right.
SizingTop | Position will size from the top.
SizingLeft | Position will size from the left.
SizingBottom | Position will size from the bottom.
SizingRight | Position will size from the right.

Member Function Documentation

virtual PushButton* CEGUI::FrameWindow::createCloseButton ( const String & name ) const [protected, pure virtual]

Create a control based upon the PushButton base class, to be used at the close button for the window.

Parameters:
name String object holding the name that must be used when creating the close button.
Returns:
Pointer to an object who's class derives from PushButton.

virtual Titlebar* CEGUI::FrameWindow::createTitlebar ( const String & name ) const [protected, pure virtual]

Create a control based upon the Titlebar base class to be used as the title bar for this window.

Parameters:
name String object holding the name that must be used when creating the titlebar.
Returns:
Pointer to an object who's class derives from Titlebar

colour CEGUI::FrameWindow::getCaptionColour ( void ) const

Return the current colour used for rendering the caption text.

Returns:
colour value that specifies the colour used when rendering the title bar caption text.

const Image * CEGUI::FrameWindow::getEWSizingCursorImage ( ) const

Return a pointer to the currently set Image to be used for the east-west sizing mouse cursor.

Returns:
Pointer to an Image object, or 0 for none.

const Image * CEGUI::FrameWindow::getNESWSizingCursorImage ( ) const

Return a pointer to the currently set Image to be used for the northeast-southwest sizing mouse cursor.

Returns:
Pointer to an Image object, or 0 for none.

const Image * CEGUI::FrameWindow::getNSSizingCursorImage ( ) const

Return a pointer to the currently set Image to be used for the north-south sizing mouse cursor.

Returns:
Pointer to an Image object, or 0 for none.

const Image * CEGUI::FrameWindow::getNWSESizingCursorImage ( ) const

Return a pointer to the currently set Image to be used for the northwest-southeast sizing mouse cursor.

Returns:
Pointer to an Image object, or 0 for none.

FrameWindow::SizingLocation CEGUI::FrameWindow::getSizingBorderAtPoint ( const Point & pt ) const [protected]

check local pixel co-ordinate point 'pt' and return one of the SizingLocation enumerated values depending where the point falls on the sizing border.

Parameters:
pt Point object describing, in pixels, the window relative offset to check.
Returns:
One of the SizingLocation enumerated values that describe which part of the sizing border that pt corresponded to, if any.

float CEGUI::FrameWindow::getSizingBorderThickness ( void ) const [inline]

Return the thickness of the sizing border.

Returns:
float value describing the thickness of the sizing border in screen pixels.

const Font * CEGUI::FrameWindow::getTitlebarFont ( void ) const

Return the font being used for the title bar text.

Returns:
Pointer to the Font being used for the TitleBar on this FrameWindow.

void CEGUI::FrameWindow::initialise ( void ) [virtual]

Initialises the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

bool CEGUI::FrameWindow::isBottomSizingLocation ( SizingLocation loc ) const [inline, protected]

return true if given SizingLocation is on bottom edge.

Parameters:
loc SizingLocation value to be checked.
Returns:
true if loc is on the bottom edge. false if loc is not on the bottom edge.

bool CEGUI::FrameWindow::isCloseButtonEnabled ( void ) const [inline]

Return whether this close button for this window is enabled.

Returns:
true if the window has a close button and it is enabled, false if the window either has no close button or if the close button is disabled.

bool CEGUI::FrameWindow::isDragMovingEnabled ( void ) const [inline]

Return whether this FrameWindow can be moved by dragging the title bar.

Returns:
true if the Window will move when the user drags the title bar, false if the window will not move.

bool CEGUI::FrameWindow::isFrameEnabled ( void ) const [inline]

Return whether the frame for this window is enabled.

Returns:
true if the frame for this window is enabled, false if the frame for this window is disabled.

bool CEGUI::FrameWindow::isHit ( const Point & position ) const [inline, virtual]

check if the given position would hit this window.

Parameters:
position Point object describing the position to check in screen pixels
Returns:
true if position 'hits' this Window, else false.

Reimplemented from CEGUI::Window.

bool CEGUI::FrameWindow::isLeftSizingLocation ( SizingLocation loc ) const [inline, protected]

return true if given SizingLocation is on left edge.

Parameters:
loc SizingLocation value to be checked.
Returns:
true if loc is on the left edge. false if loc is not on the left edge.

bool CEGUI::FrameWindow::isRightSizingLocation ( SizingLocation loc ) const [inline, protected]

return true if given SizingLocation is on right edge.

Parameters:
loc SizingLocation value to be checked.
Returns:
true if loc is on the right edge. false if loc is not on the right edge.

bool CEGUI::FrameWindow::isRolledup ( void ) const [inline]

Return whether the window is currently rolled up (a.k.a shaded).

Returns:
true if the window is rolled up, false if the window is not rolled up.

bool CEGUI::FrameWindow::isRollupEnabled ( void ) const [inline]

Return whether roll up (a.k.a shading) is enabled for this window.

Returns:
true if roll up is enabled, false if roll up is disabled.

bool CEGUI::FrameWindow::isSizingEnabled ( void ) const [inline]

Return whether this window is sizable. Note that this requires that the window have an enabled frame and that sizing itself is enabled.

Returns:
true if the window can be sized, false if the window can not be sized

bool CEGUI::FrameWindow::isTitleBarEnabled ( void ) const [inline]

Return whether the title bar for this window is enabled.

Returns:
true if the window has a title bar and it is enabled, false if the window has no title bar or if the title bar is disabled.

bool CEGUI::FrameWindow::isTopSizingLocation ( SizingLocation loc ) const [inline, protected]

return true if given SizingLocation is on top edge.

Parameters:
loc SizingLocation value to be checked.
Returns:
true if loc is on the top edge. false if loc is not on the top edge.

void CEGUI::FrameWindow::moveBottomEdge ( float delta ) [protected]

move the window's bottom edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.

Parameters:
delta float value that specifies the amount to move the window edge, and in which direction. Positive values make window larger.

void CEGUI::FrameWindow::moveLeftEdge ( float delta ) [protected]

move the window's left edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.

Parameters:
delta float value that specifies the amount to move the window edge, and in which direction. Positive values make window smaller.

void CEGUI::FrameWindow::moveRightEdge ( float delta ) [protected]

move the window's right edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.

Parameters:
delta float value that specifies the amount to move the window edge, and in which direction. Positive values make window larger.

void CEGUI::FrameWindow::moveTopEdge ( float delta ) [protected]

move the window's top edge by 'delta'. The rest of the window does not move, thus this changes the size of the Window.

Parameters:
delta float value that specifies the amount to move the window edge, and in which direction. Positive values make window smaller.

void CEGUI::FrameWindow::offsetPixelPosition ( const Vector2 & offset )

Move the window by the pixel offsets specified in offset.

This is intended for internal system use - it is the method by which the title bar moves the frame window.

Parameters:
offset Vector2 object containing the offsets to apply (offsets are in screen pixels).
Returns:
Nothing.

void CEGUI::FrameWindow::onActivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has become the active window.

Parameters:
e ActivationEventArgs class whose 'otherWindow' field is set to the window that previously was active, or NULL for none.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::onDeactivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has lost input focus and has been deactivated.

Parameters:
e ActivationEventArgs object whose 'otherWindow' field is set to the window that has now become active, or NULL for none.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::setCaptionColour ( colour col )

Sets the colour to be used for rendering the caption text.

Parameters:
col colour value that specifies the colour to be used when rendering the title bar caption text.
Returns:
Nothing.

void CEGUI::FrameWindow::setCloseButtonEnabled ( bool setting )

Enables or disables the close button for the frame window.

Parameters:
setting Set to true to enable the close button (if one is attached), or false to disable the close button.
Returns:
Nothing.

void CEGUI::FrameWindow::setDragMovingEnabled ( bool setting )

Set whether this FrameWindow can be moved by dragging the title bar.

Parameters:
setting true if the Window should move when the user drags the title bar, false if the window should not move.
Returns:
Nothing.

void CEGUI::FrameWindow::setEWSizingCursorImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the image to be used for the east-west sizing mouse cursor.

Parameters:
imageset | String holding the name of the Imageset containing the Image to be used.
image | String holding the name of the Image to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if either imageset or image refer to non-existant entities.

void CEGUI::FrameWindow::setEWSizingCursorImage ( const Image * image )

Set the Image to be used for the east-west sizing mouse cursor.

Parameters:
image Pointer to an Image object, or 0 for none.
Returns:
Nothing.

void CEGUI::FrameWindow::setFrameEnabled ( bool setting )

Enables or disables the frame for this window.

Parameters:
setting set to true to enable the frame for this window, or false to disable the frame for this window.
Returns:
Nothing.

void CEGUI::FrameWindow::setNESWSizingCursorImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the image to be used for the northeast-southwest sizing mouse cursor.

Parameters:
imageset | String holding the name of the Imageset containing the Image to be used.
image | String holding the name of the Image to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if either imageset or image refer to non-existant entities.

void CEGUI::FrameWindow::setNESWSizingCursorImage ( const Image * image )

Set the Image to be used for the northeast-southwest sizing mouse cursor.

Parameters:
image Pointer to an Image object, or 0 for none.
Returns:
Nothing.

void CEGUI::FrameWindow::setNSSizingCursorImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the image to be used for the north-south sizing mouse cursor.

Parameters:
imageset | String holding the name of the Imageset containing the Image to be used.
image | String holding the name of the Image to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if either imageset or image refer to non-existant entities.

void CEGUI::FrameWindow::setNSSizingCursorImage ( const Image * image )

Set the Image to be used for the north-south sizing mouse cursor.

Parameters:
image Pointer to an Image object, or 0 for none.
Returns:
Nothing.

void CEGUI::FrameWindow::setNWSESizingCursorImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the image to be used for the northwest-southeast sizing mouse cursor.

Parameters:
imageset | String holding the name of the Imageset containing the Image to be used.
image | String holding the name of the Image to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if either imageset or image refer to non-existant entities.

void CEGUI::FrameWindow::setNWSESizingCursorImage ( const Image * image )

Set the Image to be used for the northwest-southeast sizing mouse cursor.

Parameters:
image Pointer to an Image object, or 0 for none.
Returns:
Nothing.

void CEGUI::FrameWindow::setRollupEnabled ( bool setting )

Enables or disables roll-up (shading) for this window.

Parameters:
setting Set to true to enable roll-up for the frame window, or false to disable roll-up.
Returns:
Nothing.

void CEGUI::FrameWindow::setSizingBorderThickness ( float pixels ) [inline]

Set the size of the sizing border for this window.

Parameters:
pixels float value specifying the thickness for the sizing border in screen pixels.
Returns:
Nothing.

void CEGUI::FrameWindow::setSizingEnabled ( bool setting )

Enables or disables sizing for this window.

Parameters:
setting set to true to enable sizing (also requires frame to be enabled), or false to disable sizing.
Returns:
nothing

void CEGUI::FrameWindow::setTitleBarEnabled ( bool setting )

Enables or disables the title bar for the frame window.

Parameters:
setting set to true to enable the title bar (if one is attached), or false to disable the title bar.
Returns:
Nothing.

void CEGUI::FrameWindow::setTitlebarFont ( Font * font )

Set the font to use for the title bar text.

Parameters:
font Pointer to the font to use.
Returns:
Nothing.

void CEGUI::FrameWindow::setTitlebarFont ( const String & name )

Set the font to use for the title bar text.

Parameters:
name String object holding the name of the font to use.
Returns:
Nothing.

virtual bool CEGUI::FrameWindow::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

void CEGUI::FrameWindow::toggleRollup ( void )

Toggles the state of the window between rolled-up (shaded) and normal sizes. This requires roll-up to be enabled.

Returns:
Nothing

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::GenericException Class Reference

CEGUI::GenericException

CEGUI::GenericException Class Reference

Exception class used when none of the other classes are applicable. More...

Inheritance diagram for CEGUI::GenericException:

[legend]
Collaboration diagram for CEGUI::GenericException:

[legend]
List of all members.

Public Member Functions

GenericException (const String &message)

Detailed Description

Exception class used when none of the other classes are applicable.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::GlobalEventSet Class Reference

CEGUI::GlobalEventSet

CEGUI::GlobalEventSet Class Reference

The GlobalEventSet singleton allows you to subscribe to an event for all instances of a class. The GlobalEventSet effectively supports "late binding" to events; which means you can subscribe to some event that does not actually exist (yet). More...

Inheritance diagram for CEGUI::GlobalEventSet:

[legend]
Collaboration diagram for CEGUI::GlobalEventSet:

[legend]
List of all members.

Public Member Functions

virtual Event::Connection | subscribeEvent (const String &name, Event::Subscriber subscriber)
Subscribes the the named Event.
virtual Event::Connection | subscribeEvent (const String &name, Event::Group group, Event::Subscriber subscriber)
Subscribes the the specified group of the named Event.
virtual void | fireEvent (const String &name, EventArgs &args, const String &eventNamespace="")
Fires the named event passing the given EventArgs object.

Static Public Member Functions

static GlobalEventSet & | getSingleton (void)
Return singleton System object.
static GlobalEventSet * | getSingletonPtr (void)
Return pointer to singleton System object.

Detailed Description

The GlobalEventSet singleton allows you to subscribe to an event for all instances of a class. The GlobalEventSet effectively supports "late binding" to events; which means you can subscribe to some event that does not actually exist (yet).

Member Function Documentation

void CEGUI::GlobalEventSet::fireEvent | ( | const String & | name,
 |  | EventArgs & | args,
 |  | const String & | eventNamespace = ""
 | ) | [virtual]

Fires the named event passing the given EventArgs object.

Parameters:
name | String object holding the name of the Event that is to be fired (triggered)
args | The EventArgs (or derived) object that is to be bassed to each subscriber of the Event. Once all subscribers have been called the 'handled' field of the event is updated appropriately.
eventNamespace | String object describing the namespace prefix to use when firing the global event.
Returns:
Nothing.

Reimplemented from CEGUI::EventSet.

GlobalEventSet & CEGUI::GlobalEventSet::getSingleton ( void ) [static]

Return singleton System object.

Returns:
Singleton System object

GlobalEventSet * CEGUI::GlobalEventSet::getSingletonPtr ( void ) [static]

Return pointer to singleton System object.

Returns:
Pointer to singleton System object

Event::Connection CEGUI::GlobalEventSet::subscribeEvent | ( | const String & | name,
 |  | Event::Group | group,
 |  | Event::Subscriber | subscriber
 | ) | [virtual]

Subscribes the the specified group of the named Event.

/note If the named event does not exist it is added.

Parameters:
name | String object containing the name of the Event to subscribe to.
group | Group which is to be subscribed to. Subscription groups are called in ascending order.
subscriber | Function or object that is to be subscribed to the Event.
Returns:
Connection object that can be used to check the status of the Event connection and to disconnect (unsubscribe) from the Event.

Reimplemented from CEGUI::EventSet.

Event::Connection CEGUI::GlobalEventSet::subscribeEvent | ( | const String & | name,
 |  | Event::Subscriber | subscriber
 | ) | [virtual]

Subscribes the the named Event.

Note:
If the named event does not exist it is added.
Parameters:
name | String object containing the name of the Event to subscribe to.
subscriber | Function or object that is to be subscribed to the Event.
Returns:
Connection object that can be used to check the status of the Event connection and to disconnect (unsubscribe) from the Event.

Reimplemented from CEGUI::EventSet.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RadioButtonProperties::GroupID Class Reference

CEGUI::RadioButtonProperties::GroupID

CEGUI::RadioButtonProperties::GroupID Class Reference

Property to access the radio button group ID. More...

Inheritance diagram for CEGUI::RadioButtonProperties::GroupID:

[legend]
Collaboration diagram for CEGUI::RadioButtonProperties::GroupID:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the radio button group ID.

Usage:
  • Name: GroupID
  • Format: "[uint]".
Where:
  • [uint] is any unsigned integer value.

Member Function Documentation

String CEGUI::RadioButtonProperties::GroupID::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::RadioButtonProperties::GroupID::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::GUILayout_xmlHandler Class Reference

CEGUI::GUILayout_xmlHandler

CEGUI::GUILayout_xmlHandler Class Reference

Handler class used to parse the GUILayout XML files using SAX2. More...

Collaboration diagram for CEGUI::GUILayout_xmlHandler:

[legend]
List of all members.

Public Member Functions

GUILayout_xmlHandler (const String &name_prefix, PropertyCallback *callback=NULL, void *userdata=NULL)
Constructor for GUILayout_xmlHandler objects.
virtual | ~GUILayout_xmlHandler (void)
Destructor for GUILayout_xmlHandler objects.
virtual void | elementStart (const String &element, const XMLAttributes &attributes)
document processing (only care about elements, schema validates format)
virtual void | elementEnd (const String &element)
void | cleanupLoadedWindows (void)
Destroy all windows created so far.
Window * | getLayoutRootWindow (void) const
Return a pointer to the 'root' window created.

Detailed Description

Handler class used to parse the GUILayout XML files using SAX2.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::GUISheet Class Reference

CEGUI::GUISheet

CEGUI::GUISheet Class Reference

Window class intended to be used as a simple, generic Window. More...

Inheritance diagram for CEGUI::GUISheet:

[legend]
Collaboration diagram for CEGUI::GUISheet:

[legend]
List of all members.

Public Member Functions

GUISheet (const String &type, const String &name)
Constructor for GUISheet windows.
virtual | ~GUISheet (void)
Destructor for GUISheet windows.

Static Public Attributes

static const String | WidgetTypeName
The unique typename of this widget.

Protected Member Functions

virtual void | drawSelf (float z)
Perform the actual rendering for this Window.
void | initialise (void)
overridden initialise member to set-up our default state.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Detailed Description

Window class intended to be used as a simple, generic Window.

This class does no rendering and so appears totally transparent. This window defaults to position 0.0f, 0.0f with a size of 1.0f x 1.0f.

/note The C++ name of this class has been retained for backward compatibility reasons. The intended usage of this window type has now been extended beyond that of a gui-sheet or root window.

Member Function Documentation

virtual void CEGUI::GUISheet::drawSelf ( float z ) [inline, protected, virtual]

Perform the actual rendering for this Window.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented from CEGUI::Window.

virtual bool CEGUI::GUISheet::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::GUISheetFactory Class Reference

CEGUI::GUISheetFactory

CEGUI::GUISheetFactory Class Reference

Factory class for producing default windows. More...

Inheritance diagram for CEGUI::GUISheetFactory:

[legend]
Collaboration diagram for CEGUI::GUISheetFactory:

[legend]
List of all members.

Public Member Functions

Window * | createWindow (const String &name)
Create a new Window object of whatever type this WindowFactory produces.
virtual void | destroyWindow (Window *window)
Destroys the given Window object.

Detailed Description

Factory class for producing default windows.

Member Function Documentation

Window* CEGUI::GUISheetFactory::createWindow ( const String & name ) [inline, virtual]

Create a new Window object of whatever type this WindowFactory produces.

Parameters:
name A unique name that is to be assigned to the newly created Window object
Returns:
Pointer to the new Window object.

Implements CEGUI::WindowFactory.

virtual void CEGUI::GUISheetFactory::destroyWindow ( Window * window ) [inline, virtual]

Destroys the given Window object.

Parameters:
window Pointer to the Window object to be destroyed.
Returns:
Nothing.

Implements CEGUI::WindowFactory.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::HeaderSequenceEventArgs Class Reference

CEGUI::HeaderSequenceEventArgs

CEGUI::HeaderSequenceEventArgs Class Reference

EventArgs class used for segment move (sequence changed) events. More...

Inheritance diagram for CEGUI::HeaderSequenceEventArgs:

[legend]
Collaboration diagram for CEGUI::HeaderSequenceEventArgs:

[legend]
List of all members.

Public Member Functions

HeaderSequenceEventArgs (Window *wnd, uint old_idx, uint new_idx)

Public Attributes

uint | d_oldIdx
The original column index of the segment that has moved.
uint | d_newIdx
The new column index of the segment that has moved.

Detailed Description

EventArgs class used for segment move (sequence changed) events.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Height Class Reference

CEGUI::WindowProperties::Height

CEGUI::WindowProperties::Height Class Reference

Property to access window height. More...

Inheritance diagram for CEGUI::WindowProperties::Height:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Height:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window height.

This property offers access to the Height setting for the window, using the Windows active metrics mode.

Usage:
  • Name: Height
  • Format: "[float]".
Where:
  • [float] specifies the height as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::Height::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Height::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::HorizontalAlignment Class Reference

CEGUI::WindowProperties::HorizontalAlignment

CEGUI::WindowProperties::HorizontalAlignment Class Reference

Property to access the horizontal alignment setting for the window. More...

Inheritance diagram for CEGUI::WindowProperties::HorizontalAlignment:

[legend]
Collaboration diagram for CEGUI::WindowProperties::HorizontalAlignment:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the horizontal alignment setting for the window.

Usage:
  • Name: HorizontalAlignment
  • Format: "[text]".
Where [Text] is:
  • "Left" to indicate the windows position is an offset of its left edge from its parents left edge.
  • "Centre" to indicate the windows position is an offset of its centre point from its parents centre point.
  • "Right" to indicate the windows position is an offset of its right edge from its parents right edge.

Member Function Documentation

String CEGUI::WindowProperties::HorizontalAlignment::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::HorizontalAlignment::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticImageProperties::HorzFormatting Class Reference

CEGUI::StaticImageProperties::HorzFormatting

CEGUI::StaticImageProperties::HorzFormatting Class Reference

Property to access the horizontal formatting mode setting. More...

Inheritance diagram for CEGUI::StaticImageProperties::HorzFormatting:

[legend]
Collaboration diagram for CEGUI::StaticImageProperties::HorzFormatting:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the horizontal formatting mode setting.

Usage:
  • Name: HorzFormatting
  • Format: "[text]".
Where [text] is one of:
  • "LeftAligned"
  • "RightAligned"
  • "HorzCentred"
  • "HorzStretched"
  • "HorzTiled"

Member Function Documentation

String CEGUI::StaticImageProperties::HorzFormatting::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticImageProperties::HorzFormatting::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticTextProperties::HorzFormatting Class Reference

CEGUI::StaticTextProperties::HorzFormatting

CEGUI::StaticTextProperties::HorzFormatting Class Reference

Property to access the horizontal formatting mode setting. More...

Inheritance diagram for CEGUI::StaticTextProperties::HorzFormatting:

[legend]
Collaboration diagram for CEGUI::StaticTextProperties::HorzFormatting:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the horizontal formatting mode setting.

Usage:
  • Name: HorzFormatting
  • Format: "[text]".
Where [text] is one of:
  • "LeftAligned"
  • "RightAligned"
  • "HorzCentred"
  • "HorzJustified"
  • "WordWrapLeftAligned"
  • "WordWrapRightAligned"
  • "WordWrapCentred"
  • "WordWrapJustified"

Member Function Documentation

String CEGUI::StaticTextProperties::HorzFormatting::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticTextProperties::HorzFormatting::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ThumbProperties::HorzFree Class Reference

CEGUI::ThumbProperties::HorzFree

CEGUI::ThumbProperties::HorzFree Class Reference

Property to access the state the setting to free the thumb horizontally. More...

Inheritance diagram for CEGUI::ThumbProperties::HorzFree:

[legend]
Collaboration diagram for CEGUI::ThumbProperties::HorzFree:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state the setting to free the thumb horizontally.

Usage:
  • Name: HorzFree
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the thumb will be free (movable) horizontally.
  • "False" to indicate the thumb will be fixed horizontally.

Member Function Documentation

String CEGUI::ThumbProperties::HorzFree::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ThumbProperties::HorzFree::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::HorzOverlapSize Class Reference

CEGUI::ScrollablePaneProperties::HorzOverlapSize

CEGUI::ScrollablePaneProperties::HorzOverlapSize Class Reference

Property to access the overlap size for the horizontal Scrollbar. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::HorzOverlapSize:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::HorzOverlapSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the overlap size for the horizontal Scrollbar.

Usage:
  • Name: HorzOverlapSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the per-page overlap (as a fraction of one page).

Member Function Documentation

String CEGUI::ScrollablePaneProperties::HorzOverlapSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::HorzOverlapSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBaseProperties::HorzPadding Class Reference

CEGUI::MenuBaseProperties::HorzPadding

CEGUI::MenuBaseProperties::HorzPadding Class Reference

Property to access the horz padding value of the menu. More...

Inheritance diagram for CEGUI::MenuBaseProperties::HorzPadding:

[legend]
Collaboration diagram for CEGUI::MenuBaseProperties::HorzPadding:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the horz padding value of the menu.

Usage:
  • Name: HorzPadding
  • Format: "[float]".
Where:
  • [float] represents the horz padding of the slider.

Member Function Documentation

String CEGUI::MenuBaseProperties::HorzPadding::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuBaseProperties::HorzPadding::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ThumbProperties::HorzRange Class Reference

CEGUI::ThumbProperties::HorzRange

CEGUI::ThumbProperties::HorzRange Class Reference

Property to access the horizontal movement range for the thumb. More...

Inheritance diagram for CEGUI::ThumbProperties::HorzRange:

[legend]
Collaboration diagram for CEGUI::ThumbProperties::HorzRange:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the horizontal movement range for the thumb.

Usage:
  • Name: HorzRange
  • Format: "min:[float] max:[float]".
Where:
  • min:[float] specifies the minimum horizontal setting (position) for the thumb, specified using the active metrics system for the window.
  • max:[float] specifies the maximum horizontal setting (position) for the thumb, specified using the active metrics system for the window.

Member Function Documentation

String CEGUI::ThumbProperties::HorzRange::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ThumbProperties::HorzRange::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticTextProperties::HorzScrollbar Class Reference

CEGUI::StaticTextProperties::HorzScrollbar

CEGUI::StaticTextProperties::HorzScrollbar Class Reference

Property to access the setting for enabling the horizontal scroll bar. More...

Inheritance diagram for CEGUI::StaticTextProperties::HorzScrollbar:

[legend]
Collaboration diagram for CEGUI::StaticTextProperties::HorzScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for enabling the horizontal scroll bar.

Usage:
  • Name: HorzScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the scroll bar is enabled and will be shown when needed.
  • "False" to indicate the scroll bar is disabled and will never be shown

Member Function Documentation

String CEGUI::StaticTextProperties::HorzScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticTextProperties::HorzScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::HorzScrollPosition Class Reference

CEGUI::ScrollablePaneProperties::HorzScrollPosition

CEGUI::ScrollablePaneProperties::HorzScrollPosition Class Reference

Property to access the scroll position of the horizontal Scrollbar. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::HorzScrollPosition:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::HorzScrollPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the scroll position of the horizontal Scrollbar.

Usage:
  • Name: HorzScrollPosition
  • Format: "[float]".
Where:
  • [float] specifies the current scroll position / value of the horizontal Scrollbar (as a fraction of the whole).

Member Function Documentation

String CEGUI::ScrollablePaneProperties::HorzScrollPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::HorzScrollPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::HorzStepSize Class Reference

CEGUI::ScrollablePaneProperties::HorzStepSize

CEGUI::ScrollablePaneProperties::HorzStepSize Class Reference

Property to access the step size for the horizontal Scrollbar. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::HorzStepSize:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::HorzStepSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the step size for the horizontal Scrollbar.

Usage:
  • Name: HorzStepSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the increase/decrease button step for the horizontal scrollbar (as a fraction of 1 page).

Member Function Documentation

String CEGUI::ScrollablePaneProperties::HorzStepSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::HorzStepSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ThumbProperties::HotTracked Class Reference

CEGUI::ThumbProperties::HotTracked

CEGUI::ThumbProperties::HotTracked Class Reference

Property to access the state of the "hot-tracked" setting for the thumb. More...

Inheritance diagram for CEGUI::ThumbProperties::HotTracked:

[legend]
Collaboration diagram for CEGUI::ThumbProperties::HotTracked:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the "hot-tracked" setting for the thumb.

Usage:
  • Name: HotTracked
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the thumb will send notifications as it is dragged.
  • "False" to indicate the thumb will only notify once, when it is released.

Member Function Documentation

String CEGUI::ThumbProperties::HotTracked::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ThumbProperties::HotTracked::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuItemProperties::HoverColour Class Reference

CEGUI::MenuItemProperties::HoverColour

CEGUI::MenuItemProperties::HoverColour Class Reference

Property to access the hover colour of the item. More...

Inheritance diagram for CEGUI::MenuItemProperties::HoverColour:

[legend]
Collaboration diagram for CEGUI::MenuItemProperties::HoverColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the hover colour of the item.

Usage:
  • Name: HoverColour
  • Format: "[aarrggbb]".
Where:
  • [aarrggbb] represents the hover colour of the item.

Member Function Documentation

String CEGUI::MenuItemProperties::HoverColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuItemProperties::HoverColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties::HoverImage Class Reference

CEGUI::PushButtonProperties::HoverImage

CEGUI::PushButtonProperties::HoverImage Class Reference

Property to access the hover image of the button. More...

Inheritance diagram for CEGUI::PushButtonProperties::HoverImage:

[legend]
Collaboration diagram for CEGUI::PushButtonProperties::HoverImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the hover image of the button.

Usage:
  • Name: HoverImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::PushButtonProperties::HoverImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PushButtonProperties::HoverImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ButtonBaseProperties::HoverTextColour Class Reference

CEGUI::ButtonBaseProperties::HoverTextColour

CEGUI::ButtonBaseProperties::HoverTextColour Class Reference

Property to access the hover / highlight text colour. More...

Inheritance diagram for CEGUI::ButtonBaseProperties::HoverTextColour:

[legend]
Collaboration diagram for CEGUI::ButtonBaseProperties::HoverTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the hover / highlight text colour.

This property offers access to the colour value to be used for rendering the button caption text for the hover or highlight state.

Usage:
  • Name: HoverTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ButtonBaseProperties::HoverTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ButtonBaseProperties::HoverTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TooltipProperties::HoverTime Class Reference

CEGUI::TooltipProperties::HoverTime

CEGUI::TooltipProperties::HoverTime Class Reference

Property to access the timout that must expire before the tooltip gets activated. More...

Inheritance diagram for CEGUI::TooltipProperties::HoverTime:

[legend]
Collaboration diagram for CEGUI::TooltipProperties::HoverTime:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the timout that must expire before the tooltip gets activated.

Usage:
  • Name: HoverTime
  • Format: "[float]".
Where:
  • [float] specifies the number of seconds the mouse must hover stationary on a widget before the tooltip gets activated.

Member Function Documentation

String CEGUI::TooltipProperties::HoverTime::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TooltipProperties::HoverTime::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::ID Class Reference

CEGUI::WindowProperties::ID

CEGUI::WindowProperties::ID Class Reference

Property to access window ID field. More...

Inheritance diagram for CEGUI::WindowProperties::ID:

[legend]
Collaboration diagram for CEGUI::WindowProperties::ID:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window ID field.

This property offers access to the client specified ID for the window.

Usage:
  • Name: ID
  • Format: "[uint]".
Where:
  • [uint] is any unsigned integer value.

Member Function Documentation

String CEGUI::WindowProperties::ID::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::ID::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Image Class Reference

CEGUI::Image

CEGUI::Image Class Reference

Class that represents a single Image of an Imageset. More...

Collaboration diagram for CEGUI::Image:

[legend]
List of all members.

Public Member Functions

Size | getSize (void) const
Return a Size object containing the dimensions of the Image.
float | getWidth (void) const
Return the pixel width of the image.
float | getHeight (void) const
Return the pixel height of the image.
Point | getOffsets (void) const
Return a Point object that contains the offset applied when rendering this Image.
float | getOffsetX (void) const
Return the X rendering offset.
float | getOffsetY (void) const
Return the Y rendering offset.
const String & | getName (void) const
Return the name of this Image object.
const String & | getImagesetName (void) const
Return the name of the Imageset that contains this Image.
const Rect & | getSourceTextureArea (void) const
Return Rect describing the source texture area used by this Image.
void | draw (const Vector3 &position, const Size &size, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queue the image to be drawn.
void | draw (const Rect &dest_rect, float z, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queue the image to be drawn.
void | draw (const Vector3 &position, const Size &size, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queue the image to be drawn.
void | draw (const Vector3 &position, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queue the image to be drawn.
void | draw (const Vector3 &position, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queue the image to be drawn.
void | draw (const Rect &dest_rect, float z, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queue the image to be drawn.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this Image object to out_stream.
Image (void)
Default constructor (only used by std::map).
Image (const Imageset *owner, const String &name, const Rect &area, const Point &render_offset, float horzScaling=1.0f, float vertScaling=1.0f)
Constructor for Image objects. This is not normally used directly by client code, use the Imageset interface instead.
Image (const Image &image)
Copy constructor.
~Image (void)
Destructor for Image objects.

Friends

class | std::map< String, Image >
struct | std::pair< const String, Image >
class | Imageset

Detailed Description

Class that represents a single Image of an Imageset.

Constructor & Destructor Documentation

CEGUI::Image::Image | ( | const Imageset * | owner,
 |  | const String & | name,
 |  | const Rect & | area,
 |  | const Point & | render_offset,
 |  | float | horzScaling = 1.0f,
 |  | float | vertScaling = 1.0f
 | ) |

Constructor for Image objects. This is not normally used directly by client code, use the Imageset interface instead.

Parameters:
owner | Pointer to a Imageset object that owns this Image. This must not be NULL.
name | String object describing the name of the image being created.
area | Rect object describing an area that will be associated with this image.
render_offset | Point object that describes the offset to be applied when rendering this image.
horzScaling | float value indicating the initial horizontal scaling to be applied to this image.
vertScaling | float value indicating the initial vertical scaling to be applied to this image.
Exceptions:
NullObjectException Thrown if owner was NULL.

Member Function Documentation

void CEGUI::Image::draw | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const

Queue the image to be drawn.

Note:
The final position of the Image will be adjusted by the offset values defined for this Image object. If absolute positioning is essential then these values should be taken into account prior to calling the draw() methods. However, by doing this you take away the ability of the Imageset designer to adjust the alignment and positioning of Images, therefore your component is far less useful since it requires code changes to modify image positioning that could have been handled from a data file.
Parameters:
dest_rect | Rect object defining the area on-screen where the Image is to be drawn. The Image will be scaled to fit the area as required.
z | Z-order position for the image. Positions increase "into the screen", so 0.0f is at the top of the z-order.
clip_rect | Rect object that defines an on-screen area that the Image will be clipped to when drawing.
colours | ColourRect object that describes the colour values to use for each corner of the Image.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

void CEGUI::Image::draw | ( | const Vector3 & | position,
 |  | const Rect & | clip_rect,
 |  | const colour & | top_left_colour = 0xFFFFFFFF,
 |  | const colour & | top_right_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_left_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_right_colour = 0xFFFFFFFF,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const [inline]

Queue the image to be drawn.

Note:
The final position of the Image will be adjusted by the offset values defined for this Image object. If absolute positioning is essential then these values should be taken into account prior to calling the draw() methods. However, by doing this you take away the ability of the Imageset designer to adjust the alignment and positioning of Images, therefore your component is far less useful since it requires code changes to modify image positioning that could have been handled from a data file.
Parameters:
position | Vector3 object containing the location where the Image is to be drawn
clip_rect | Rect object that defines an on-screen area that the Image will be clipped to when drawing.
top_left_colour | Colour (as 0xAARRGGBB value) to be applied to the top-left corner of the Image.
top_right_colour | Colour (as 0xAARRGGBB value) to be applied to the top-right corner of the Image.
bottom_left_colour | Colour (as 0xAARRGGBB value) to be applied to the bottom-left corner of the Image.
bottom_right_colour | Colour (as 0xAARRGGBB value) to be applied to the bottom-right corner of the Image.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

void CEGUI::Image::draw | ( | const Vector3 & | position,
 |  | const Rect & | clip_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const [inline]

Queue the image to be drawn.

Note:
The final position of the Image will be adjusted by the offset values defined for this Image object. If absolute positioning is essential then these values should be taken into account prior to calling the draw() methods. However, by doing this you take away the ability of the Imageset designer to adjust the alignment and positioning of Images, therefore your component is far less useful since it requires code changes to modify image positioning that could have been handled from a data file.
Parameters:
position Vector3 object containing the location where the Image is to be drawn
Note:
The image will be drawn at it's internally defined size.
Parameters:
clip_rect | Rect object that defines an on-screen area that the Image will be clipped to when drawing.
colours | ColourRect object that describes the colour values to use for each corner of the Image.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

void CEGUI::Image::draw | ( | const Vector3 & | position,
 |  | const Size & | size,
 |  | const Rect & | clip_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const [inline]

Queue the image to be drawn.

Note:
The final position of the Image will be adjusted by the offset values defined for this Image object. If absolute positioning is essential then these values should be taken into account prior to calling the draw() methods. However, by doing this you take away the ability of the Imageset designer to adjust the alignment and positioning of Images, therefore your component is far less useful since it requires code changes to modify image positioning that could have been handled from a data file.
Parameters:
position | Vector3 object containing the location where the Image is to be drawn
size | Size object describing the size that the Image is to be drawn at.
clip_rect | Rect object that defines an on-screen area that the Image will be clipped to when drawing.
colours | ColourRect object that describes the colour values to use for each corner of the Image.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

void CEGUI::Image::draw | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | const colour & | top_left_colour = 0xFFFFFFFF,
 |  | const colour & | top_right_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_left_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_right_colour = 0xFFFFFFFF,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const [inline]

Queue the image to be drawn.

Note:
The final position of the Image will be adjusted by the offset values defined for this Image object. If absolute positioning is essential then these values should be taken into account prior to calling the draw() methods. However, by doing this you take away the ability of the Imageset designer to adjust the alignment and positioning of Images, therefore your component is far less useful since it requires code changes to modify image positioning that could have been handled from a data file.
Parameters:
dest_rect | Rect object defining the area on-screen where the Image is to be drawn. The Image will be scaled to fit the area as required.
z | Z-order position for the image. Positions increase "into the screen", so 0.0f is at the top of the z-order.
clip_rect | Rect object that defines an on-screen area that the Image will be clipped to when drawing.
top_left_colour | Colour (as 0xAARRGGBB value) to be applied to the top-left corner of the Image.
top_right_colour | Colour (as 0xAARRGGBB value) to be applied to the top-right corner of the Image.
bottom_left_colour | Colour (as 0xAARRGGBB value) to be applied to the bottom-left corner of the Image.
bottom_right_colour | Colour (as 0xAARRGGBB value) to be applied to the bottom-right corner of the Image.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

void CEGUI::Image::draw | ( | const Vector3 & | position,
 |  | const Size & | size,
 |  | const Rect & | clip_rect,
 |  | const colour & | top_left_colour = 0xFFFFFFFF,
 |  | const colour & | top_right_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_left_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_right_colour = 0xFFFFFFFF,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const [inline]

Queue the image to be drawn.

Note:
The final position of the Image will be adjusted by the offset values defined for this Image object. If absolute positioning is essential then these values should be taken into account prior to calling the draw() methods. However, by doing this you take away the ability of the Imageset designer to adjust the alignment and positioning of Images, therefore your component is far less useful since it requires code changes to modify image positioning that could have been handled from a data file.
Parameters:
position | Vector3 object containing the location where the Image is to be drawn
size | Size object describing the size that the Image is to be drawn at.
clip_rect | Rect object that defines an on-screen area that the Image will be clipped to when drawing.
top_left_colour | Colour (as 0xAARRGGBB value) to be applied to the top-left corner of the Image.
top_right_colour | Colour (as 0xAARRGGBB value) to be applied to the top-right corner of the Image.
bottom_left_colour | Colour (as 0xAARRGGBB value) to be applied to the bottom-left corner of the Image.
bottom_right_colour | Colour (as 0xAARRGGBB value) to be applied to the bottom-right corner of the Image.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

float CEGUI::Image::getHeight ( void ) const [inline]

Return the pixel height of the image.

Returns:
Height of this Image in pixels

const String & CEGUI::Image::getImagesetName ( void ) const

Return the name of the Imageset that contains this Image.

Returns:
String object containing the name of the Imageset which this Image is a part of.

const String & CEGUI::Image::getName ( void ) const

Return the name of this Image object.

Returns:
String object containing the name of this Image

Point CEGUI::Image::getOffsets ( void ) const [inline]

Return a Point object that contains the offset applied when rendering this Image.

Returns:
Point object containing the offsets applied when rendering this Image

float CEGUI::Image::getOffsetX ( void ) const [inline]

Return the X rendering offset.

Returns:
X rendering offset. This is the number of pixels that the image is offset by when rendering at any given location.

float CEGUI::Image::getOffsetY ( void ) const [inline]

Return the Y rendering offset.

Returns:
Y rendering offset. This is the number of pixels that the image is offset by when rendering at any given location.

Size CEGUI::Image::getSize ( void ) const [inline]

Return a Size object containing the dimensions of the Image.

Returns:
Size object holding the width and height of the Image.

const Rect & CEGUI::Image::getSourceTextureArea ( void ) const

Return Rect describing the source texture area used by this Image.

Returns:
Rect object that describes, in pixels, the area upon the source texture which is used when rendering this Image.

float CEGUI::Image::getWidth ( void ) const [inline]

Return the pixel width of the image.

Returns:
Width of this Image in pixels.

void CEGUI::Image::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this Image object to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticImageProperties::Image Class Reference

CEGUI::StaticImageProperties::Image

CEGUI::StaticImageProperties::Image Class Reference

Property to access the image for the StaticImage widget. More...

Inheritance diagram for CEGUI::StaticImageProperties::Image:

[legend]
Collaboration diagram for CEGUI::StaticImageProperties::Image:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the image for the StaticImage widget.

Usage:
  • Name: Image
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticImageProperties::Image::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticImageProperties::Image::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticImageProperties::ImageColours Class Reference

CEGUI::StaticImageProperties::ImageColours

CEGUI::StaticImageProperties::ImageColours Class Reference

Property to access the image colours for the StaticImage widget. More...

Inheritance diagram for CEGUI::StaticImageProperties::ImageColours:

[legend]
Collaboration diagram for CEGUI::StaticImageProperties::ImageColours:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the image colours for the StaticImage widget.

Usage:
  • Name: ImageColours
  • Format: "tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]".
Where:
  • tl:[aarrggbb] is the top-left colour value specified as ARGB (hex).
  • tr:[aarrggbb] is the top-right colour value specified as ARGB (hex).
  • bl:[aarrggbb] is the bottom-left colour value specified as ARGB (hex).
  • br:[aarrggbb] is the bottom-right colour value specified as ARGB (hex).

Member Function Documentation

String CEGUI::StaticImageProperties::ImageColours::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticImageProperties::ImageColours::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ImageDim Class Reference

CEGUI::ImageDim

CEGUI::ImageDim Class Reference

Dimension type that represents some dimension of a named Image. Implements BaseDim interface. More...

Inheritance diagram for CEGUI::ImageDim:

[legend]
Collaboration diagram for CEGUI::ImageDim:

[legend]
List of all members.

Public Member Functions

ImageDim (const String &imageset, const String &image, DimensionType dim)
Constructor.
void | setSourceImage (const String &imageset, const String &image)
Sets the source image information for this ImageDim.
void | setSourceDimension (DimensionType dim)
Sets the source dimension type for this ImageDim.

Protected Member Functions

float | getValue_impl (const Window &wnd) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
float | getValue_impl (const Window &wnd, const Rect &container) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
void | writeXMLElementName_impl (OutStream &out_stream) const
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
void | writeXMLElementAttributes_impl (OutStream &out_stream) const
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.
BaseDim * | clone_impl () const
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.

Detailed Description

Dimension type that represents some dimension of a named Image. Implements BaseDim interface.

Constructor & Destructor Documentation

CEGUI::ImageDim::ImageDim | ( | const String & | imageset,
 |  | const String & | image,
 |  | DimensionType | dim
 | ) |

Constructor.

Parameters:
imageset | String object holding the name of the imagseset which contains the image.
image | String object holding the name of the image.
dim | DimensionType value indicating which dimension of the described image that this ImageDim is to represent.

Member Function Documentation

void CEGUI::ImageDim::setSourceDimension ( DimensionType dim )

Sets the source dimension type for this ImageDim.

Parameters:
dim DimensionType value indicating which dimension of the described image that this ImageDim is to represent.
Returns:
Nothing.

void CEGUI::ImageDim::setSourceImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Sets the source image information for this ImageDim.

Parameters:
imageset | String object holding the name of the imagseset which contains the image.
image | String object holding the name of the image.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ImageryComponent Class Reference

CEGUI::ImageryComponent

CEGUI::ImageryComponent Class Reference

Class that encapsulates information for a single image component. More...

Inheritance diagram for CEGUI::ImageryComponent:

[legend]
Collaboration diagram for CEGUI::ImageryComponent:

[legend]
List of all members.

Public Member Functions

ImageryComponent ()
Constructor.
const Image * | getImage () const
Return the Image object that will be drawn by this ImageryComponent.
void | setImage (const Image *image)
Set the Image that will be drawn by this ImageryComponent.
void | setImage (const String &imageset, const String &image)
Set the Image that will be drawn by this ImageryComponent.
VerticalFormatting | getVerticalFormatting () const
Return the current vertical formatting setting for this ImageryComponent.
void | setVerticalFormatting (VerticalFormatting fmt)
Set the vertical formatting setting for this ImageryComponent.
HorizontalFormatting | getHorizontalFormatting () const
Return the current horizontal formatting setting for this ImageryComponent.
void | setHorizontalFormatting (HorizontalFormatting fmt)
Set the horizontal formatting setting for this ImageryComponent.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this ImageryComponent to out_stream.
bool | isImageFetchedFromProperty () const
Return whether this ImageryComponent fetches it's image via a property on the target window.
const String & | getImagePropertySource () const
Return the name of the property that will be used to determine the image for this ImageryComponent.
void | setImagePropertySource (const String &property)
Set the name of the property that will be used to determine the image for this ImageryComponent.

Protected Member Functions

void | render_impl (Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const
Method to do main render caching work.

Protected Attributes

const Image * | d_image
CEGUI::Image to be drawn by this image component.
VerticalFormatting d_vertFormatting
Vertical formatting to be applied when rendering the image component.
HorizontalFormatting d_horzFormatting
Horizontal formatting to be applied when rendering the image component.
String d_imagePropertyName
Name of the property to access to obtain the image to be used.

Detailed Description

Class that encapsulates information for a single image component.

Member Function Documentation

HorizontalFormatting CEGUI::ImageryComponent::getHorizontalFormatting ( ) const

Return the current horizontal formatting setting for this ImageryComponent.

Returns:
One of the HorizontalFormatting enumerated values.

const Image * CEGUI::ImageryComponent::getImage ( ) const

Return the Image object that will be drawn by this ImageryComponent.

Returns:
Image object.

const String & CEGUI::ImageryComponent::getImagePropertySource ( ) const

Return the name of the property that will be used to determine the image for this ImageryComponent.

Returns:
String object holding the name of a Propery.

VerticalFormatting CEGUI::ImageryComponent::getVerticalFormatting ( ) const

Return the current vertical formatting setting for this ImageryComponent.

Returns:
One of the VerticalFormatting enumerated values.

bool CEGUI::ImageryComponent::isImageFetchedFromProperty ( ) const

Return whether this ImageryComponent fetches it's image via a property on the target window.

Returns:
  • true if the image comes via a Propery.
  • false if the image is defined explicitly.

void CEGUI::ImageryComponent::setHorizontalFormatting ( HorizontalFormatting fmt )

Set the horizontal formatting setting for this ImageryComponent.

Parameters:
fmt One of the HorizontalFormatting enumerated values.
Returns:
Nothing.

void CEGUI::ImageryComponent::setImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the Image that will be drawn by this ImageryComponent.

Parameters:
imageset | String holding the name of the Imagset that contains the Image to be rendered.
image | String holding the name of the Image to be rendered.
Returns:
Nothing.

void CEGUI::ImageryComponent::setImage ( const Image * image )

Set the Image that will be drawn by this ImageryComponent.

Parameters:
Pointer to the Image object to be drawn by this ImageryComponent.
Returns:
Nothing.

void CEGUI::ImageryComponent::setImagePropertySource ( const String & property )

Set the name of the property that will be used to determine the image for this ImageryComponent.

Parameters:
property String object holding the name of a Propery. The property should access a imageset & image specification.
Returns:
Nothing.

void CEGUI::ImageryComponent::setVerticalFormatting ( VerticalFormatting fmt )

Set the vertical formatting setting for this ImageryComponent.

Parameters:
fmt One of the VerticalFormatting enumerated values.
Returns:
Nothing.

void CEGUI::ImageryComponent::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this ImageryComponent to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ImagerySection Class Reference

CEGUI::ImagerySection

CEGUI::ImagerySection Class Reference

Class that encapsulates a re-usable collection of imagery specifications. More...

Collaboration diagram for CEGUI::ImagerySection:

[legend]
List of all members.

Public Member Functions

ImagerySection ()
Constructor.
ImagerySection (const String &name)
ImagerySection constructor. Name must be supplied, masterColours are set to 0xFFFFFFFF by default.
void | render (Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render the ImagerySection.
void | render (Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render the ImagerySection.
void | addImageryComponent (const ImageryComponent &img)
Add an ImageryComponent to this ImagerySection.
void | clearImageryComponents ()
Clear all ImageryComponents from this ImagerySection.
void | addTextComponent (const TextComponent &text)
Add a TextComponent to this ImagerySection.
void | clearTextComponents ()
Clear all TextComponents from this ImagerySection.
void | clearFrameComponents ()
Clear all FrameComponents from this ImagerySection.
void | addFrameComponent (const FrameComponent &frame)
Add a FrameComponent to this ImagerySection.
const ColourRect & | getMasterColours () const
Return the current master colours set for this ImagerySection.
void | setMasterColours (const ColourRect &cols)
Set the master colours to be used for this ImagerySection.
const String & | getName () const
Return the name of this ImagerySection.
void | setMasterColoursPropertySource (const String &property)
Set the name of the property where master colour values can be obtained.
void | setMasterColoursPropertyIsColourRect (bool setting=true)
Set whether the master colours property source represents a full ColourRect.
Rect | getBoundingRect (const Window &wnd) const
Return smallest Rect that could contain all imagery within this section.
Rect | getBoundingRect (const Window &wnd, const Rect &rect) const
Return smallest Rect that could contain all imagery within this section.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this ImagerySection to out_stream.

Protected Member Functions

void | initMasterColourRect (const Window &wnd, ColourRect &cr) const
Helper method to initialise a ColourRect with appropriate values according to the way the ImagerySection is set up.

Detailed Description

Class that encapsulates a re-usable collection of imagery specifications.

Constructor & Destructor Documentation

CEGUI::ImagerySection::ImagerySection ( const String & name )

ImagerySection constructor. Name must be supplied, masterColours are set to 0xFFFFFFFF by default.

Parameters:
name Name of the new ImagerySection.

Member Function Documentation

void CEGUI::ImagerySection::addFrameComponent ( const FrameComponent & frame )

Add a FrameComponent to this ImagerySection.

Parameters:
frame FrameComponent to be added to the section (a copy is made)
Returns:
Nothing

void CEGUI::ImagerySection::addImageryComponent ( const ImageryComponent & img )

Add an ImageryComponent to this ImagerySection.

Parameters:
img ImageryComponent to be added to the section (a copy is made)
Returns:
Nothing

void CEGUI::ImagerySection::addTextComponent ( const TextComponent & text )

Add a TextComponent to this ImagerySection.

Parameters:
text TextComponent to be added to the section (a copy is made)
Returns:
Nothing

void CEGUI::ImagerySection::clearFrameComponents ( )

Clear all FrameComponents from this ImagerySection.

Returns:
Nothing

void CEGUI::ImagerySection::clearImageryComponents ( )

Clear all ImageryComponents from this ImagerySection.

Returns:
Nothing

void CEGUI::ImagerySection::clearTextComponents ( )

Clear all TextComponents from this ImagerySection.

Returns:
Nothing

const ColourRect & CEGUI::ImagerySection::getMasterColours ( ) const

Return the current master colours set for this ImagerySection.

Returns:
ColourRect describing the master colour values in use for this ImagerySection.

const String & CEGUI::ImagerySection::getName ( ) const

Return the name of this ImagerySection.

Returns:
String object holding the name of the ImagerySection.

void CEGUI::ImagerySection::initMasterColourRect | ( | const Window & | wnd,
 |  | ColourRect & | cr
 | ) | const [protected]

Helper method to initialise a ColourRect with appropriate values according to the way the ImagerySection is set up.

This will try and get values from multiple places:

  • a property attached to wnd
  • or the integral d_masterColours value.

void CEGUI::ImagerySection::render | ( | Window & | srcWindow,
 |  | const Rect & | baseRect,
 |  | float | base_z,
 |  | const CEGUI::ColourRect * | modColours = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render the ImagerySection.

Parameters:
srcWindow | Window object to be used when calculating pixel values from BaseDim values.
baseRect | Rect object to be used when calculating pixel values from BaseDim values.
base_z | base z value to be used for all imagery in the section.
modColours | ColourRect specifying colours to be modulated with the ImagerySection's master colours. May be 0.
Returns:
Nothing.

void CEGUI::ImagerySection::render | ( | Window & | srcWindow,
 |  | float | base_z,
 |  | const CEGUI::ColourRect * | modColours = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render the ImagerySection.

Parameters:
srcWindow | Window object to be used when calculating pixel values from BaseDim values.
base_z | base z value to be used for all imagery in the section.
modColours | ColourRect specifying colours to be modulated with the ImagerySection's master colours. May be 0.
Returns:
Nothing.

void CEGUI::ImagerySection::setMasterColours ( const ColourRect & cols )

Set the master colours to be used for this ImagerySection.

Parameters:
cols ColourRect describing the colours to be set as the master colours for this ImagerySection.
Returns:
Nothing.

void CEGUI::ImagerySection::setMasterColoursPropertyIsColourRect ( bool setting = true )

Set whether the master colours property source represents a full ColourRect.

Parameters:
setting
  • true if the master colours property will access a ColourRect object.
  • false if the master colours property will access a colour object.
Returns:
Nothing.

void CEGUI::ImagerySection::setMasterColoursPropertySource ( const String & property )

Set the name of the property where master colour values can be obtained.

Parameters:
property String containing the name of the property.
Returns:
Nothing.

void CEGUI::ImagerySection::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this ImagerySection to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Imageset Class Reference

CEGUI::Imageset

CEGUI::Imageset Class Reference

Offers functions to define, access, and draw, a set of image components on a single graphical surface or Texture. More...

Collaboration diagram for CEGUI::Imageset:

[legend]
List of all members.

Public Types

typedef ConstBaseIterator<
ImageRegistry > 		ImageIterator
Iterator type for this collection.

Public Member Functions

~Imageset (void)
Destroys Imageset objects.
Texture * | getTexture (void) const
return Texture object for this Imageset
const String & | getName (void) const
return String object holding the name of the Imageset
uint | getImageCount (void) const
return number of images defined for this Imageset
bool | isImageDefined (const String &name) const
return true if an Image with the specified name exists.
const Image & | getImage (const String &name) const
return a copy of the Image object for the named image
void | undefineImage (const String &name)
remove the definition for the Image with the specified name. If no such Image exists, nothing happens.
void | undefineAllImages (void)
Removes the definitions for all Image objects currently defined in the Imageset.
Size | getImageSize (const String &name) const
return a Size object describing the dimensions of the named image.
float | getImageWidth (const String &name) const
return the width of the named image.
float | getImageHeight (const String &name) const
return the height of the named image.
Point | getImageOffset (const String &name) const
return the rendering offsets applied to the named image.
float | getImageOffsetX (const String &name) const
return the x rendering offset for the named image.
float | getImageOffsetY (const String &name) const
return the y rendering offset for the named image.
void | defineImage (const String &name, const Point &position, const Size &size, const Point &render_offset)
Define a new Image for this Imageset.
void | defineImage (const String &name, const Rect &image_rect, const Point &render_offset)
Define a new Image for this Imageset.
void | draw (const Rect &source_rect, const Rect &dest_rect, float z, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode) const
Queues an area of the associated Texture the be drawn on the screen. Low-level routine to be used carefully!
void | draw (const Rect &source_rect, const Rect &dest_rect, float z, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const
Queues an area of the associated Texture the be drawn on the screen. Low-level routine to be used carefully!
bool | isAutoScaled (void) const
Return whether this Imageset is auto-scaled.
Size | getNativeResolution (void) const
Return the native display size for this Imageset. This is only relevant if the Imageset is being auto-scaled.
void | setAutoScalingEnabled (bool setting)
Enable or disable auto-scaling for this Imageset.
void | setNativeResolution (const Size &size)
Set the native resolution for this Imageset.
void | notifyScreenResolution (const Size &size)
Notify the Imageset of the current (usually new) display resolution.
ImageIterator | getIterator (void) const
Return an Imageset::ImageIterator object that can be used to iterate over the Image objects in the Imageset.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this Imageset to out_stream.

Protected Member Functions

void | load (const String &filename, const String &resourceGroup)
Initialise the Imageset with information taken from the specified file.
void | unload (void)
Unloads all loaded data and leaves the Imageset in a clean (but un-usable) state. This should be called for cleanup purposes only.
void | setTexture (Texture *texture)
set the Texture object to be used by this Imageset. Changing textures on an Imageset that is in use is not a good idea!
void | updateImageScalingFactors (void)
Sets the scaling factor for all Images that are a part of this Imageset.

Protected Attributes

String d_name
Holds the name of this imageset.
ImageRegistry | d_images
Registry of Image objects for the images defined for this Imageset.
Texture * d_texture
Texture object that handles imagery for this Imageset.
String d_textureFilename
String holding the name of the texture filename (if any).
bool | d_autoScale
true when auto-scaling is enabled.
float | d_horzScaling
current horizontal scaling factor.
float | d_vertScaling
current vertical scaling factor.
float | d_nativeHorzRes
native horizontal resolution for this Imageset.
float | d_nativeVertRes
native vertical resolution for this Imageset.

Static Protected Attributes

static const char | ImagesetSchemaName [] = "Imageset.xsd"
Filename of the XML schema used for validating Imageset files.

Friends

class | Imageset_xmlHandler
Imageset * | ImagesetManager::createImageset (const String &name, Texture *texture)
Imageset * | ImagesetManager::createImageset (const String &filename, const String &resourceGroup)
Imageset * | ImagesetManager::createImagesetFromImageFile (const String &name, const String &filename, const String &resourceGroup)
void | ImagesetManager::destroyImageset (const String &name)

Detailed Description

Offers functions to define, access, and draw, a set of image components on a single graphical surface or Texture.

Imageset objects are a means by which a single graphical image (file, Texture, etc), can be split into a number of 'components' which can later be accessed via name. The components of an Imageset can queried for various details, and sent to the Renderer object for drawing.

Member Function Documentation

void CEGUI::Imageset::defineImage | ( | const String & | name,
 |  | const Rect & | image_rect,
 |  | const Point & | render_offset
 | ) |

Define a new Image for this Imageset.

Parameters:
name | String object holding the name that will be assigned to the new Image, which must be unique within the Imageset.
image_rect | Rect object describing the area on the image file / texture associated with this Imageset that will be used for the Image.
render_offset | Point object describing the offsets, in pixels, that are to be applied to the Image when it is drawn.
Returns:
Nothing
Exceptions:
AlreadyExistsException thrown if an Image named name is already defined for this Imageset

void CEGUI::Imageset::defineImage | ( | const String & | name,
 |  | const Point & | position,
 |  | const Size & | size,
 |  | const Point & | render_offset
 | ) | [inline]

Define a new Image for this Imageset.

Parameters:
name | String object holding the name that will be assigned to the new Image, which must be unique within the Imageset.
position | Point object describing the pixel location of the Image on the image file / texture associated with this Imageset.
size | Size object describing the dimensions of the Image, in pixels.
render_offset | Point object describing the offsets, in pixels, that are to be applied to the Image when it is drawn.
Returns:
Nothing
Exceptions:
AlreadyExistsException thrown if an Image named name is already defined for this Imageset

void CEGUI::Imageset::draw | ( | const Rect & | source_rect,
 |  | const Rect & | dest_rect,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | const colour & | top_left_colour = 0xFFFFFFFF,
 |  | const colour & | top_right_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_left_colour = 0xFFFFFFFF,
 |  | const colour & | bottom_right_colour = 0xFFFFFFFF,
 |  | QuadSplitMode | quad_split_mode = TopLeftToBottomRight
 | ) | const [inline]

Queues an area of the associated Texture the be drawn on the screen. Low-level routine to be used carefully!

Parameters:
source_rect | Rect object describing the area of the image file / texture that is to be queued for drawing
dest_rect | Rect describing the area of the screen that will be filled with the imagery from source_rect.
z | float value specifying 'z' order. 0 is topmost with increasing values moving back into the screen.
clip_rect | Rect object describing a 'clipping rectangle' that will be applied when drawing the requested imagery
top_left_colour | colour to be applied to the top left corner of the rendered imagery.
top_right_colour | colour to be applied to the top right corner of the rendered imagery.
bottom_left_colour | colour to be applied to the bottom left corner of the rendered imagery.
bottom_right_colour | colour to be applied to the bottom right corner of the rendered imagery.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

void CEGUI::Imageset::draw | ( | const Rect & | source_rect,
 |  | const Rect & | dest_rect,
 |  | float | z,
 |  | const Rect & | clip_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode
 | ) | const

Queues an area of the associated Texture the be drawn on the screen. Low-level routine to be used carefully!

Parameters:
source_rect | Rect object describing the area of the image file / texture that is to be queued for drawing
dest_rect | Rect describing the area of the screen that will be filled with the imagery from source_rect.
z | float value specifying 'z' order. 0 is topmost with increasing values moving back into the screen.
clip_rect | Rect object describing a 'clipping rectangle' that will be applied when drawing the requested imagery
colours | ColourRect object holding the ARGB colours to be applied to the four corners of the rendered imagery.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

const Image & CEGUI::Imageset::getImage ( const String & name ) const

return a copy of the Image object for the named image

Parameters:
name String object holding the name of the Image object to be returned
Returns:
constant Image object that has the requested name.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

uint CEGUI::Imageset::getImageCount ( void ) const [inline]

return number of images defined for this Imageset

Returns:
uint value equal to the number of Image objects defined for the Imageset

float CEGUI::Imageset::getImageHeight ( const String & name ) const [inline]

return the height of the named image.

Parameters:
name String object holding the name of the Image.
Returns:
float value equalling the height of the requested Image.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

Point CEGUI::Imageset::getImageOffset ( const String & name ) const [inline]

return the rendering offsets applied to the named image.

Parameters:
name String object holding the name of the Image.
Returns:
Point object that holds the rendering offsets for the requested Image.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

float CEGUI::Imageset::getImageOffsetX ( const String & name ) const [inline]

return the x rendering offset for the named image.

Parameters:
name String object holding the name of the Image.
Returns:
float value equal to the x rendering offset applied when drawing the requested Image.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

float CEGUI::Imageset::getImageOffsetY ( const String & name ) const [inline]

return the y rendering offset for the named image.

Parameters:
name String object holding the name of the Image.
Returns:
float value equal to the y rendering offset applied when drawing the requested Image.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

Size CEGUI::Imageset::getImageSize ( const String & name ) const [inline]

return a Size object describing the dimensions of the named image.

Parameters:
name String object holding the name of the Image.
Returns:
Size object holding the dimensions of the requested Image.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

float CEGUI::Imageset::getImageWidth ( const String & name ) const [inline]

return the width of the named image.

Parameters:
name String object holding the name of the Image.
Returns:
float value equalling the width of the requested Image.
Exceptions:
UnknownObjectException thrown if no Image named name is defined for the Imageset

const String& CEGUI::Imageset::getName ( void ) const [inline]

return String object holding the name of the Imageset

Returns:
String object that holds the name of the Imageset.

Size CEGUI::Imageset::getNativeResolution ( void ) const [inline]

Return the native display size for this Imageset. This is only relevant if the Imageset is being auto-scaled.

Returns:
Size object describing the native display size for this Imageset.

Texture* CEGUI::Imageset::getTexture ( void ) const [inline]

return Texture object for this Imageset

Returns:
Texture object that holds the imagery for this Imageset

bool CEGUI::Imageset::isAutoScaled ( void ) const [inline]

Return whether this Imageset is auto-scaled.

Returns:
true if Imageset is auto-scaled, false if not.

bool CEGUI::Imageset::isImageDefined ( const String & name ) const [inline]

return true if an Image with the specified name exists.

Parameters:
name String object holding the name of the Image to look for.
Returns:
true if an Image object named name is defined for this Imageset, else false.

void CEGUI::Imageset::load | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [protected]

Initialise the Imageset with information taken from the specified file.

Parameters:
filename | String object that holds the name of the Imageset data file that is to be processed.
resourceGroup | Resource group identifier to be passed to the resource manager. NB: This affects the imageset xml file only, the texture loaded may have its own group specified in the XML file.
Returns:
Nothing
Exceptions:
FileIOException thrown if something goes wrong while processing the file filename.

void CEGUI::Imageset::notifyScreenResolution ( const Size & size )

Notify the Imageset of the current (usually new) display resolution.

Parameters:
size Size object describing the display resolution
Returns:
Nothing

void CEGUI::Imageset::setAutoScalingEnabled ( bool setting )

Enable or disable auto-scaling for this Imageset.

Parameters:
setting true to enable auto-scaling, false to disable auto-scaling.
Returns:
Nothing.

void CEGUI::Imageset::setNativeResolution ( const Size & size )

Set the native resolution for this Imageset.

Parameters:
size Size object describing the new native screen resolution for this Imageset.
Returns:
Nothing

void CEGUI::Imageset::setTexture ( Texture * texture ) [protected]

set the Texture object to be used by this Imageset. Changing textures on an Imageset that is in use is not a good idea!

Parameters:
texture Texture object to be used by the Imageset. The old texture is NOT disposed of, that is the clients responsibility.
Returns:
Nothing
Exceptions:
NullObjectException thrown if texture is NULL

void CEGUI::Imageset::undefineAllImages ( void )

Removes the definitions for all Image objects currently defined in the Imageset.

Returns:
Nothing

void CEGUI::Imageset::undefineImage ( const String & name )

remove the definition for the Image with the specified name. If no such Image exists, nothing happens.

Parameters:
name String object holding the name of the Image object to be removed from the Imageset,
Returns:
Nothing.

void CEGUI::Imageset::updateImageScalingFactors ( void ) [protected]

Sets the scaling factor for all Images that are a part of this Imageset.

Returns:
Nothing.

void CEGUI::Imageset::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this Imageset to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Imageset_xmlHandler Class Reference

CEGUI::Imageset_xmlHandler

CEGUI::Imageset_xmlHandler Class Reference

Handler class used to parse the Imageset XML files using SAX2. More...

Collaboration diagram for CEGUI::Imageset_xmlHandler:

[legend]
List of all members.

Public Member Functions

Imageset_xmlHandler (Imageset *imageset)
Constructor for Imageset::xmlHandler objects.
virtual | ~Imageset_xmlHandler (void)
Destructor for Imageset::xmlHandler objects.
virtual void | elementStart (const String &element, const XMLAttributes &attributes)
document processing (only care about elements, schema validates format)
virtual void | elementEnd (const String &element)
Imageset * | getImageset (void) const

Detailed Description

Handler class used to parse the Imageset XML files using SAX2.

Constructor & Destructor Documentation

CEGUI::Imageset_xmlHandler::Imageset_xmlHandler ( Imageset * imageset ) [inline]

Constructor for Imageset::xmlHandler objects.

Parameters:
imageset Pointer to the Imageset object creating this xmlHandler object

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ImagesetManager Class Reference

CEGUI::ImagesetManager

CEGUI::ImagesetManager Class Reference

Class providing a shared library of Imageset objects to the system. More...

List of all members.

Public Types

typedef ConstBaseIterator<
ImagesetRegistry > 		ImagesetIterator

Public Member Functions

ImagesetManager (void)
Constructor for ImagesetManager objects.
~ImagesetManager (void)
Destructor for ImagesetManager objects.
Imageset * | createImageset (const String &name, Texture *texture)
Create a Imageset object with the given name and Texture.
Imageset * | createImageset (const String &filename, const String &resourceGroup="")
Create an Imageset object from the specified file.
Imageset * | createImagesetFromImageFile (const String &name, const String &filename, const String &resourceGroup="")
Create an Imageset object from the specified image file. The Imageset will initially have a single image defined named "full_image" which is an image that represents the entire area of the loaded image.
void | destroyImageset (const String &name)
Destroys the Imageset with the specified name.
void | destroyImageset (Imageset *imageset)
Destroys the given Imageset object.
void | destroyAllImagesets (void)
Destroys all Imageset objects registered in the system.
Imageset * | getImageset (const String &name) const
Returns a pointer to the Imageset object with the specified name.
bool | isImagesetPresent (const String &name) const
Check for the existence of a named Imageset.
void | notifyScreenResolution (const Size &size)
Notify the ImagesetManager of the current (usually new) display resolution.
void | writeImagesetToStream (const String &imageset, OutStream &out_stream) const
Writes a full XML imageset for the specified Imageset to the given OutStream.
ImagesetIterator | getIterator (void) const
Return a ImagesetManager::ImagesetIterator object to iterate over the available Imageset objects.

Static Public Member Functions

static ImagesetManager & | getSingleton (void)
Return singleton ImagesetManager object.
static ImagesetManager * | getSingletonPtr (void)
Return pointer to singleton ImagesetManager object.

Detailed Description

Class providing a shared library of Imageset objects to the system.

The ImagesetManager is used to create, access, and destroy Imageset objects. The idea is that the ImagesetManager will function as a central repository for imagery used within the GUI system, and that such imagery can be accessed, via a unique name, by any interested party within the system.

Member Function Documentation

Imageset * CEGUI::ImagesetManager::createImageset | ( | const String & | filename,
 |  | const String & | resourceGroup = ""
 | ) |

Create an Imageset object from the specified file.

Parameters:
filename | String object holding the name of the Imageset definition file which should be used to create the Imageset
resourceGroup | Resource group identifier to be passed to the resource manager. NB: This affects the imageset xml file only, the texture loaded may have its own group specified in the XML file.
Returns:
Pointer to the newly created Imageset object
Exceptions:
AlreadyExistsException | Thrown if an Imageset named name is already present in the system.
FileIOException | Thrown if something goes wrong while processing the file filename.

Imageset * CEGUI::ImagesetManager::createImageset | ( | const String & | name,
 |  | Texture * | texture
 | ) |

Create a Imageset object with the given name and Texture.

The created Imageset will be of limited use, and will require one or more images to be defined for the set.

Parameters:
name | String object containing the unique name for the Imageset being created.
texture | Texture object to be associated with the Imageset
Returns:
Pointer to the newly created Imageset object
Exceptions:
AlreadyExistsException Thrown if an Imageset named name is already present in the system.

Imageset * CEGUI::ImagesetManager::createImagesetFromImageFile | ( | const String & | name,
 |  | const String & | filename,
 |  | const String & | resourceGroup = ""
 | ) |

Create an Imageset object from the specified image file. The Imageset will initially have a single image defined named "full_image" which is an image that represents the entire area of the loaded image.

Parameters:
name | String object containing the unique name for the Imageset being created.
filename | String object holding the name of the image file to be loaded.
resourceGroup | Resource group identifier to be passed to the resource manager when loading the image file.
Returns:
Pointer to the newly created Imageset object
Exceptions:
AlreadyExistsException | Thrown if an Imageset named name is already present in the system.
FileIOException | Thrown if something goes wrong while reading the image file filename.

void CEGUI::ImagesetManager::destroyAllImagesets ( void )

Destroys all Imageset objects registered in the system.

Returns:
Nothing

void CEGUI::ImagesetManager::destroyImageset ( Imageset * imageset )

Destroys the given Imageset object.

Parameters:
imageset Pointer to the Imageset to be destroyed. If no such Imageset exists, nothing happens.
Returns:
Nothing.

void CEGUI::ImagesetManager::destroyImageset ( const String & name )

Destroys the Imageset with the specified name.

Parameters:
name String object containing the name of the Imageset to be destroyed. If no such Imageset exists, nothing happens.
Returns:
Nothing.

Imageset * CEGUI::ImagesetManager::getImageset ( const String & name ) const

Returns a pointer to the Imageset object with the specified name.

Parameters:
name String object containing the name of the Imageset to return a pointer to
Returns:
Pointer to the requested Imageset object
Exceptions:
UnknownObjectException Thrown if no Imageset named name is present in within the system

ImagesetManager & CEGUI::ImagesetManager::getSingleton ( void ) [static]

Return singleton ImagesetManager object.

Returns:
Singleton ImagesetManager object

ImagesetManager * CEGUI::ImagesetManager::getSingletonPtr ( void ) [static]

Return pointer to singleton ImagesetManager object.

Returns:
Pointer to singleton ImagesetManager object

bool CEGUI::ImagesetManager::isImagesetPresent ( const String & name ) const [inline]

Check for the existence of a named Imageset.

Parameters:
name String object containing the name of the Imageset to look for
Returns:
true if an Imageset named name is presently loaded in the system, else false.

void CEGUI::ImagesetManager::notifyScreenResolution ( const Size & size )

Notify the ImagesetManager of the current (usually new) display resolution.

Parameters:
size Size object describing the display resolution
Returns:
Nothing

void CEGUI::ImagesetManager::writeImagesetToStream | ( | const String & | imageset,
 |  | OutStream & | out_stream
 | ) | const

Writes a full XML imageset for the specified Imageset to the given OutStream.

Parameters:
imageset | String holding the name of the Imageset to be written to the stream.
out_stream | OutStream (std::ostream based) object where data is to be sent.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::InactiveEditSelectionColour Class Reference

CEGUI::ComboboxProperties::InactiveEditSelectionColour

CEGUI::ComboboxProperties::InactiveEditSelectionColour Class Reference

Property to access the colour used for rendering the selection highlight when the edit box is inactive. More...

Inheritance diagram for CEGUI::ComboboxProperties::InactiveEditSelectionColour:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::InactiveEditSelectionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering the selection highlight when the edit box is inactive.

Usage:
  • Name: InactiveEditSelectionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ComboboxProperties::InactiveEditSelectionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::InactiveEditSelectionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::InactiveSelectionColour Class Reference

CEGUI::MultiLineEditboxProperties::InactiveSelectionColour

CEGUI::MultiLineEditboxProperties::InactiveSelectionColour Class Reference

Property to access the colour used for rendering the selection highlight when the edit box is inactive. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::InactiveSelectionColour:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::InactiveSelectionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering the selection highlight when the edit box is inactive.

Usage:
  • Name: InactiveSelectionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::InactiveSelectionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::InactiveSelectionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::InactiveSelectionColour Class Reference

CEGUI::EditboxProperties::InactiveSelectionColour

CEGUI::EditboxProperties::InactiveSelectionColour Class Reference

Property to access the colour used for rendering the selection highlight when the edit box is inactive. More...

Inheritance diagram for CEGUI::EditboxProperties::InactiveSelectionColour:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::InactiveSelectionColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering the selection highlight when the edit box is inactive.

Usage:
  • Name: InactiveSelectionColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::EditboxProperties::InactiveSelectionColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::InactiveSelectionColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::InheritsAlpha Class Reference

CEGUI::WindowProperties::InheritsAlpha

CEGUI::WindowProperties::InheritsAlpha Class Reference

Property to access window "Inherits Alpha" setting. More...

Inheritance diagram for CEGUI::WindowProperties::InheritsAlpha:

[legend]
Collaboration diagram for CEGUI::WindowProperties::InheritsAlpha:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window "Inherits Alpha" setting.

This property offers access to the inherits alpha setting for the window.

Usage:
  • Name: InheritsAlpha
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window inherits alpha blend values from it's ancestors.
  • "False" to indicate the Window does not inherit alpha blend values from it's ancestors.

Member Function Documentation

String CEGUI::WindowProperties::InheritsAlpha::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::InheritsAlpha::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::InheritsTooltipText Class Reference

CEGUI::WindowProperties::InheritsTooltipText

CEGUI::WindowProperties::InheritsTooltipText Class Reference

Property to access whether the window inherits its tooltip text from its parent whn it has no tooltip text of its own. More...

Inheritance diagram for CEGUI::WindowProperties::InheritsTooltipText:

[legend]
Collaboration diagram for CEGUI::WindowProperties::InheritsTooltipText:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access whether the window inherits its tooltip text from its parent whn it has no tooltip text of its own.

Usage:
  • Name: InheritsTooltipText
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window inherits its tooltip text from its parent.
  • "False" to indicate the Window does not inherit its tooltip text.

Member Function Documentation

String CEGUI::WindowProperties::InheritsTooltipText::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::InheritsTooltipText::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::InvalidRequestException Class Reference

CEGUI::InvalidRequestException

CEGUI::InvalidRequestException Class Reference

Exception class used when some impossible request was made for the current system state. More...

Inheritance diagram for CEGUI::InvalidRequestException:

[legend]
Collaboration diagram for CEGUI::InvalidRequestException:

[legend]
List of all members.

Public Member Functions

InvalidRequestException (const String &message)

Detailed Description

Exception class used when some impossible request was made for the current system state.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::IrrlichtRenderer Class Reference

CEGUI::IrrlichtRenderer

CEGUI::IrrlichtRenderer Class Reference

class implementing the interface for Renderer objects with the irrlicht graphics engine. More...

Inheritance diagram for CEGUI::IrrlichtRenderer:

[legend]
Collaboration diagram for CEGUI::IrrlichtRenderer:

[legend]
List of all members.

Public Member Functions

IrrlichtRenderer (irr::IrrlichtDevice *dev, bool bWithIrrlichtResourceProvicer=false)
create the irrlicht renderer
virtual | ~IrrlichtRenderer ()
virtual ResourceProvider * | createResourceProvider (void)
bool | OnEvent (irr::SEvent &event)
virtual void | addQuad (const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode)
Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.
virtual void | doRender (void)
Perform final rendering for all quads that have been queued for rendering.
virtual void | clearRenderList (void)
Clears all queued quads from the render queue.
virtual void | setQueueingEnabled (bool setting)
Enable or disable the queueing of quads from this point on.
virtual Texture * | createTexture (void)
Creates a 'null' Texture object.
virtual Texture * | createTexture (const String &filename, const String &resourceGroup)
Create a Texture object using the given image file.
virtual Texture * | createTexture (float size)
Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.
virtual void | destroyTexture (Texture *texture)
Destroy the given Texture object.
virtual void | destroyAllTextures (void)
Destroy all Texture objects.
virtual bool | isQueueingEnabled (void) const
Return whether queueing is enabled.
virtual float | getWidth (void) const
Return the current width of the display in pixels.
virtual float | getHeight (void) const
Return the current height of the display in pixels.
virtual Size | getSize (void) const
Return the size of the display in pixels.
virtual Rect | getRect (void) const
Return a Rect describing the screen.
virtual uint | getMaxTextureSize (void) const
Return the maximum texture size available.
virtual uint | getHorzScreenDPI (void) const
Return the horizontal display resolution dpi.
virtual uint | getVertScreenDPI (void) const
Return the vertical display resolution dpi.

Classes

struct | quadsorter
struct | RenderQuad

Detailed Description

class implementing the interface for Renderer objects with the irrlicht graphics engine.

Constructor & Destructor Documentation

CEGUI::IrrlichtRenderer::IrrlichtRenderer | ( | irr::IrrlichtDevice * | dev,
 |  | bool | bWithIrrlichtResourceProvicer = false
 | ) |

create the irrlicht renderer

constructor

Parameters:
dev | pointer to irr::IrrlichtDevice value specifying the irrlicht device
bWithIrrlichtResourceProvicer | bool specifying wether to use an irrlicht- or defautresourceprovider (default)

CEGUI::IrrlichtRenderer::~IrrlichtRenderer ( ) [virtual]

destructor

Member Function Documentation

void CEGUI::IrrlichtRenderer::addQuad | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Texture * | tex,
 |  | const Rect & | texture_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode
 | ) | [virtual]

Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.

Parameters:
dest_rect | Rect object describing the destination area (values are in pixels)
z | float value specifying the z co-ordinate / z order of the quad
tex | pointer to the Texture object that holds the imagery to be rendered
texture_rect | Rect object holding the area of tex that is to be rendered (values are in texture co-ordinates).
colours | ColourRect object describing the colour values that are to be applied when rendering.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::IrrlichtRenderer::clearRenderList ( void ) [virtual]

Clears all queued quads from the render queue.

Returns:
Nothing

Implements CEGUI::Renderer.

ResourceProvider * CEGUI::IrrlichtRenderer::createResourceProvider ( void ) [virtual]

get an irrlicht resource provider

Returns:
irrlicht resourceprovider

Reimplemented from CEGUI::Renderer.

Texture * CEGUI::IrrlichtRenderer::createTexture ( float size ) [virtual]

Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.

Parameters:
size float value that specifies the size to use for the width and height when creating the new texture.
Returns:
a newly created Texture object. The initial contents of the texture memory is undefined / random.
Note:
Textures are always created with a size that is a power of 2. If you specify a size that is not a power of two, the final size will be rounded up. So if you specify a size of 1024, the texture will be (1024 x 1024), however, if you specify a size of 1025, the texture will be (2048 x 2048). You can check the ultimate size by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::IrrlichtRenderer::createTexture | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Create a Texture object using the given image file.

Parameters:
filename | String object that specifies the path and filename of the image file to use when creating the texture.
resourceGroup | Resource group identifier passed to the resource provider.
Returns:
a newly created Texture object. The initial contents of the texture memory is the requested image file.
Note:
Textures are always created with a size that is a power of 2. If the file you specify is of a size that is not a power of two, the final size will be rounded up. Additionally, textures are always square, so the ultimate size is governed by the larger of the width and height of the specified file. You can check the ultimate sizes by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::IrrlichtRenderer::createTexture ( void ) [virtual]

Creates a 'null' Texture object.

Returns:
a newly created Texture object. The returned Texture object has no size or imagery associated with it, and is generally of little or no use.

Implements CEGUI::Renderer.

void CEGUI::IrrlichtRenderer::destroyAllTextures ( void ) [virtual]

Destroy all Texture objects.

Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::IrrlichtRenderer::destroyTexture ( Texture * texture ) [virtual]

Destroy the given Texture object.

Parameters:
texture pointer to the Texture object to be destroyed
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::IrrlichtRenderer::doRender ( void ) [virtual]

Perform final rendering for all quads that have been queued for rendering.

The contents of the rendering queue is retained and can be rendered again as required. If the contents is not required call clearRenderList().

Returns:
Nothing

Implements CEGUI::Renderer.

float CEGUI::IrrlichtRenderer::getHeight ( void ) const [virtual]

Return the current height of the display in pixels.

Returns:
float value equal to the current height of the display in pixels.

Implements CEGUI::Renderer.

uint CEGUI::IrrlichtRenderer::getHorzScreenDPI ( void ) const [virtual]

Return the horizontal display resolution dpi.

Returns:
horizontal resolution of the display in dpi.

Implements CEGUI::Renderer.

uint CEGUI::IrrlichtRenderer::getMaxTextureSize ( void ) const [virtual]

Return the maximum texture size available.

Returns:
Size of the maximum supported texture in pixels (textures are always assumed to be square)

Implements CEGUI::Renderer.

Rect CEGUI::IrrlichtRenderer::getRect ( void ) const [virtual]

Return a Rect describing the screen.

Returns:
A Rect object that describes the screen area. Typically, the top-left values are always 0, and the size of the area described is equal to the screen resolution.

Implements CEGUI::Renderer.

Size CEGUI::IrrlichtRenderer::getSize ( void ) const [virtual]

Return the size of the display in pixels.

Returns:
Size object describing the dimensions of the current display.

Implements CEGUI::Renderer.

uint CEGUI::IrrlichtRenderer::getVertScreenDPI ( void ) const [virtual]

Return the vertical display resolution dpi.

Returns:
vertical resolution of the display in dpi.

Implements CEGUI::Renderer.

float CEGUI::IrrlichtRenderer::getWidth ( void ) const [virtual]

Return the current width of the display in pixels.

Returns:
float value equal to the current width of the display in pixels.

Implements CEGUI::Renderer.

bool CEGUI::IrrlichtRenderer::isQueueingEnabled ( void ) const [virtual]

Return whether queueing is enabled.

Returns:
true if queueing is enabled, false if queueing is disabled.

Implements CEGUI::Renderer.

bool CEGUI::IrrlichtRenderer::OnEvent ( irr::SEvent & event )

forward event to CEGUI system

void CEGUI::IrrlichtRenderer::setQueueingEnabled ( bool setting ) [virtual]

Enable or disable the queueing of quads from this point on.

This only affects queueing. If queueing is turned off, any calls to addQuad will cause the quad to be rendered directly. Note that disabling queueing will not cause currently queued quads to be rendered, nor is the queue cleared - at any time the queue can still be drawn by calling doRender, and the list can be cleared by calling clearRenderList. Re-enabling the queue causes subsequent quads to be added as if queueing had never been disabled.

Parameters:
setting true to enable queueing, or false to disable queueing (see notes above).
Returns:
Nothing

Implements CEGUI::Renderer.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ItemEntry Class Reference

CEGUI::ItemEntry

CEGUI::ItemEntry Class Reference

Base class for item type widgets. More...

Inheritance diagram for CEGUI::ItemEntry:

[legend]
Collaboration diagram for CEGUI::ItemEntry:

[legend]
List of all members.

Public Member Functions

virtual Size | getItemPixelSize (void)=0
Return the "optimal" size for the item.
ItemEntry (const String &type, const String &name)
Constructor for ItemEntry objects.
virtual | ~ItemEntry (void)
Destructor for ItemEntry objects.

Protected Member Functions

void | addItemEntryEvents (void)
Add itementry specific events.
virtual void | populateRenderCahce ()
Perform the actual rendering for this Window.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Detailed Description

Base class for item type widgets.

Member Function Documentation

virtual Size CEGUI::ItemEntry::getItemPixelSize ( void ) [pure virtual]

Return the "optimal" size for the item.

Returns:
Size describing the size in pixel that this ItemEntry's content requires for non-clipped rendering

Implemented in CEGUI::TextItem.

virtual void CEGUI::ItemEntry::populateRenderCahce ( ) [inline, protected, virtual]

Perform the actual rendering for this Window.

Returns:
Nothing

virtual bool CEGUI::ItemEntry::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::MenuItem, and CEGUI::TextItem.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ItemListBase Class Reference

CEGUI::ItemListBase

CEGUI::ItemListBase Class Reference

Base class for item list widgets. More...

Inheritance diagram for CEGUI::ItemListBase:

[legend]
Collaboration diagram for CEGUI::ItemListBase:

[legend]
List of all members.

Public Member Functions

size_t | getItemCount (void) const
Return number of items attached to the list.
ItemEntry * | getItemFromIndex (size_t index) const
Return the item at index position index.
size_t | getItemIndex (const ItemEntry *item) const
Return the index of ItemEntry item.
ItemEntry * | findItemWithText (const String &text, const ItemEntry *start_item)
Search the list for an item with the specified text.
bool | isItemInList (const ItemEntry *item) const
Return whether the specified ItemEntry is in the List.
bool | isAutoResizeEnabled () const
Return wheter this window is automatically resized to fit its content.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | resetList (void)
Remove all items from the list.
void | addItem (ItemEntry *item)
Add the given ItemEntry to the list.
void | insertItem (ItemEntry *item, const ItemEntry *position)
Insert an item into the list after a specified item already in the list.
void | removeItem (ItemEntry *item)
Removes the given item from the list. If the item is has the auto delete state set, the item will be deleted.
void | handleUpdatedItemData (void)
Causes the list to update it's internal state after changes have been made to one or more attached ItemEntry objects.
void | setAutoResizeEnabled (bool setting)
Set whether or not this ItemListBase widget should automatically resize to fit its content.
virtual void | sizeToContent (void)
Resize the ItemListBase to exactly fit the content that is attached to it. Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering items.
ItemListBase (const String &type, const String &name)
Constructor for ItemListBase base class.
virtual | ~ItemListBase (void)
Destructor for ItemListBase base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventListContentsChanged
Event triggered when the contents of the list is changed.

Protected Types

typedef std::vector< ItemEntry * > | ItemEntryList

Protected Member Functions

virtual void | sizeToContent_impl (void)=0
Resize the ItemListBase to exactly fit the content that is attached to it. Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering items.
virtual Size | getContentSize ()=0
Returns the Size in unclipped pixels of the content attached to this ItemListBase that is attached to it.
virtual Rect | getItemRenderArea (void) const =0
Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering list items.
virtual void | layoutItemWidgets ()=0
Setup size and position for the item widgets attached to this ItemListBase.
virtual void | populateRenderCache ()=0
Perform the actual rendering for this Window.
void | addItemListBaseEvents (void)
Add list box specific events.
bool | resetList_impl (void)
Remove all items from the list.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onListContentsChanged (WindowEventArgs &e)
Handler called internally when the list contents are changed.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.

Protected Attributes

ItemEntryList | d_listItems
list of items in the list.
bool | d_autoResize

Detailed Description

Base class for item list widgets.

Member Function Documentation

void CEGUI::ItemListBase::addItem ( ItemEntry * item )

Add the given ItemEntry to the list.

Parameters:
item Pointer to the ItemEntry to be added to the list. Note that it is the passed object that is added to the list, a copy is not made. If this parameter is NULL, nothing happens.
Returns:
Nothing.

ItemEntry * CEGUI::ItemListBase::findItemWithText | ( | const String & | text,
 |  | const ItemEntry * | start_item
 | ) |

Search the list for an item with the specified text.

Parameters:
text | String object containing the text to be searched for.
start_item | ItemEntry where the search is to begin, the search will not include item. If item is NULL, the search will begin from the first item in the list.
Returns:
Pointer to the first ItemEntry in the list after item that has text matching text. If no item matches the criteria NULL is returned.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

virtual Size CEGUI::ItemListBase::getContentSize ( ) [protected, pure virtual]

Returns the Size in unclipped pixels of the content attached to this ItemListBase that is attached to it.

Returns:
Nothing.

Implemented in CEGUI::Menubar, and CEGUI::PopupMenu.

size_t CEGUI::ItemListBase::getItemCount ( void ) const [inline]

Return number of items attached to the list.

Returns:
the number of items currently attached to this list.

ItemEntry * CEGUI::ItemListBase::getItemFromIndex ( size_t index ) const

Return the item at index position index.

Parameters:
index Zero based index of the item to be returned.
Returns:
Pointer to the ItemEntry at index position index in the list.
Exceptions:
InvalidRequestException thrown if index is out of range.

size_t CEGUI::ItemListBase::getItemIndex ( const ItemEntry * item ) const

Return the index of ItemEntry item.

Parameters:
item Pointer to a ItemEntry whos zero based index is to be returned.
Returns:
Zero based index indicating the position of ItemEntry item in the list.
Exceptions:
InvalidRequestException thrown if item is not attached to this list.

virtual Rect CEGUI::ItemListBase::getItemRenderArea ( void ) const [protected, pure virtual]

Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering list items.

Returns:
Rect object describing the window relative area of the that is to be used for rendering the items.

void CEGUI::ItemListBase::handleUpdatedItemData ( void )

Causes the list to update it's internal state after changes have been made to one or more attached ItemEntry objects.

Client code must call this whenever it has made any changes to ItemEntry objects already attached to the list. If you are just adding items, or removed items to update them prior to re-adding them, there is no need to call this method.

Returns:
Nothing.

void CEGUI::ItemListBase::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::ItemListBase::insertItem | ( | ItemEntry * | item,
 |  | const ItemEntry * | position
 | ) |

Insert an item into the list after a specified item already in the list.

Note that if the list is sorted, the item may not end up in the requested position.

Parameters:
item | Pointer to the ItemEntry to be inserted. Note that it is the passed object that is added to the list, a copy is not made. If this parameter is NULL, nothing happens.
position | Pointer to a ItemEntry that item is to be inserted after. If this parameter is NULL, the item is inserted at the start of the list.
Returns:
Nothing.

bool CEGUI::ItemListBase::isAutoResizeEnabled ( ) const [inline]

Return wheter this window is automatically resized to fit its content.

Returns:
true if automatic resizing is enabled, false if it is disabled.

bool CEGUI::ItemListBase::isItemInList ( const ItemEntry * item ) const

Return whether the specified ItemEntry is in the List.

Returns:
true if ItemEntry item is in the list, false if ItemEntry item is not in the list.

virtual void CEGUI::ItemListBase::layoutItemWidgets ( ) [protected, pure virtual]

Setup size and position for the item widgets attached to this ItemListBase.

Returns:
Nothing.

Implemented in CEGUI::Menubar, and CEGUI::PopupMenu.

void CEGUI::ItemListBase::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

virtual void CEGUI::ItemListBase::populateRenderCache ( ) [protected, pure virtual]

Perform the actual rendering for this Window.

Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::ItemListBase::removeItem ( ItemEntry * item )

Removes the given item from the list. If the item is has the auto delete state set, the item will be deleted.

Parameters:
item Pointer to the ItemEntry that is to be removed. If item is not attached to this list then nothing will happen.
Returns:
Nothing.

void CEGUI::ItemListBase::resetList ( void )

Remove all items from the list.

Note that this will cause 'AutoDelete' items to be deleted.

bool CEGUI::ItemListBase::resetList_impl ( void ) [protected]

Remove all items from the list.

Note:
Note that this will cause 'AutoDelete' items to be deleted.
Returns:
  • true if the list contents were changed.
  • false if the list contents were not changed (list already empty).

void CEGUI::ItemListBase::setAutoResizeEnabled ( bool setting )

Set whether or not this ItemListBase widget should automatically resize to fit its content.

Parameters:
setting Boolean value that if true enables automatic resizing, if false disables automatic resizing.
Returns:
Nothing.

virtual void CEGUI::ItemListBase::sizeToContent ( void ) [inline, virtual]

Resize the ItemListBase to exactly fit the content that is attached to it. Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering items.

Returns:
Nothing

virtual void CEGUI::ItemListBase::sizeToContent_impl ( void ) [protected, pure virtual]

Resize the ItemListBase to exactly fit the content that is attached to it. Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering items.

Returns:
Nothing

virtual bool CEGUI::ItemListBase::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::Menubar, CEGUI::MenuBase, and CEGUI::PopupMenu.

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBaseProperties::ItemSpacing Class Reference

CEGUI::MenuBaseProperties::ItemSpacing

CEGUI::MenuBaseProperties::ItemSpacing Class Reference

Property to access the item spacing of the menu. More...

Inheritance diagram for CEGUI::MenuBaseProperties::ItemSpacing:

[legend]
Collaboration diagram for CEGUI::MenuBaseProperties::ItemSpacing:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the item spacing of the menu.

Usage:
  • Name: ItemSpacing
  • Format: "[float]".
Where:
  • [float] represents the item spacing of the menu.

Member Function Documentation

String CEGUI::MenuBaseProperties::ItemSpacing::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuBaseProperties::ItemSpacing::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxProperties::ItemTooltips Class Reference

CEGUI::ListboxProperties::ItemTooltips

CEGUI::ListboxProperties::ItemTooltips Class Reference

Property to access the show item tooltips setting of the list box. More...

Inheritance diagram for CEGUI::ListboxProperties::ItemTooltips:

[legend]
Collaboration diagram for CEGUI::ListboxProperties::ItemTooltips:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the show item tooltips setting of the list box.

Usage:
  • Name: ItemTooltips
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the tooltip of the list box will be set by the item below the mouse pointer
  • "False" to indicate that the list box has a static tooltip.

Member Function Documentation

String CEGUI::ListboxProperties::ItemTooltips::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListboxProperties::ItemTooltips::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Key Struct Reference

CEGUI::Key

CEGUI::Key Struct Reference

struct to give scope to scan code enumeration. More...

List of all members.

Public Types

enum Scan {
Escape = 0x01, One = 0x02, Two = 0x03, Three = 0x04,
Four = 0x05, Five = 0x06, Six = 0x07, Seven = 0x08,
Eight = 0x09, Nine = 0x0A, Zero = 0x0B, Minus = 0x0C,
Equals = 0x0D, Backspace = 0x0E, Tab = 0x0F, Q = 0x10,
W = 0x11, E = 0x12, R = 0x13, T = 0x14,
Y = 0x15, U = 0x16, I = 0x17, O = 0x18,
P = 0x19, LeftBracket = 0x1A, RightBracket = 0x1B, Return = 0x1C,
LeftControl = 0x1D, A = 0x1E, S = 0x1F, D = 0x20,
F = 0x21, G = 0x22, H = 0x23, J = 0x24,
K = 0x25, L = 0x26, Semicolon = 0x27, Apostrophe = 0x28,
Grave = 0x29, LeftShift = 0x2A, Backslash = 0x2B, Z = 0x2C,
X = 0x2D, C = 0x2E, V = 0x2F, B = 0x30,
N = 0x31, M = 0x32, Comma = 0x33, Period = 0x34,
Slash = 0x35, RightShift = 0x36, Multiply = 0x37, LeftAlt = 0x38,
Space = 0x39, Capital = 0x3A, F1 = 0x3B, F2 = 0x3C,
F3 = 0x3D, F4 = 0x3E, F5 = 0x3F, F6 = 0x40,
F7 = 0x41, F8 = 0x42, F9 = 0x43, F10 = 0x44,
NumLock = 0x45, ScrollLock = 0x46, Numpad7 = 0x47, Numpad8 = 0x48,
Numpad9 = 0x49, Subtract = 0x4A, Numpad4 = 0x4B, Numpad5 = 0x4C,
Numpad6 = 0x4D, Add = 0x4E, Numpad1 = 0x4F, Numpad2 = 0x50,
Numpad3 = 0x51, Numpad0 = 0x52, Decimal = 0x53, OEM_102 = 0x56,
F11 = 0x57, F12 = 0x58, F13 = 0x64, F14 = 0x65,
F15 = 0x66, Kana = 0x70, ABNT_C1 = 0x73, Convert = 0x79,
NoConvert = 0x7B, Yen = 0x7D, ABNT_C2 = 0x7E, NumpadEquals = 0x8D,
PrevTrack = 0x90, At = 0x91, Colon = 0x92, Underline = 0x93,
Kanji = 0x94, Stop = 0x95, AX = 0x96, Unlabeled = 0x97,
NextTrack = 0x99, NumpadEnter = 0x9C, RightControl = 0x9D, Mute = 0xA0,
Calculator = 0xA1, PlayPause = 0xA2, MediaStop = 0xA4, VolumeDown = 0xAE,
VolumeUp = 0xB0, WebHome = 0xB2, NumpadComma = 0xB3, Divide = 0xB5,
SysRq = 0xB7, RightAlt = 0xB8, Pause = 0xC5, Home = 0xC7,
ArrowUp = 0xC8, PageUp = 0xC9, ArrowLeft = 0xCB, ArrowRight = 0xCD,
End = 0xCF, ArrowDown = 0xD0, PageDown = 0xD1, Insert = 0xD2,
Delete = 0xD3, LeftWindows = 0xDB, RightWindow = 0xDC, RightWindows = 0xDC,
AppMenu = 0xDD, Power = 0xDE, Sleep = 0xDF, Wake = 0xE3,
WebSearch = 0xE5, WebFavorites = 0xE6, WebRefresh = 0xE7, WebStop = 0xE8,
WebForward = 0xE9, WebBack = 0xEA, MyComputer = 0xEB, Mail = 0xEC,
MediaSelect = 0xED
}

Detailed Description

struct to give scope to scan code enumeration.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::KeyEventArgs Class Reference

CEGUI::KeyEventArgs

CEGUI::KeyEventArgs Class Reference

EventArgs based class that is used for objects passed to input event handlers concerning keyboard input. More...

Inheritance diagram for CEGUI::KeyEventArgs:

[legend]
Collaboration diagram for CEGUI::KeyEventArgs:

[legend]
List of all members.

Public Member Functions

KeyEventArgs (Window *wnd)

Public Attributes

utf32 | codepoint
utf32 codepoint for the key (only used for Character inputs).
Key::Scan | scancode
Scan code of key that caused event (only used for key up & down inputs.
uint | sysKeys
current state of the system keys and mouse buttons.

Detailed Description

EventArgs based class that is used for objects passed to input event handlers concerning keyboard input.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::LayerSpecification Class Reference

CEGUI::LayerSpecification

CEGUI::LayerSpecification Class Reference

Class that encapsulates a single layer of imagery. More...

List of all members.

Public Member Functions

LayerSpecification (uint priority)
Constructor.
void | render (Window &srcWindow, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render this layer.
void | render (Window &srcWindow, const Rect &baseRect, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render this layer.
void | addSectionSpecification (const SectionSpecification &section)
Add a section specification to the layer.
void | clearSectionSpecifications ()
Clear all section specifications from this layer,.
uint | getLayerPriority () const
Return the priority of this layer.
bool | operator< (const LayerSpecification &other) const
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this Layer to out_stream.

Detailed Description

Class that encapsulates a single layer of imagery.

Constructor & Destructor Documentation

CEGUI::LayerSpecification::LayerSpecification ( uint priority )

Constructor.

Parameters:
priority Specifies the priority of the layer. Layers with higher priorities will be drawn on top of layers with lower priorities.

Member Function Documentation

void CEGUI::LayerSpecification::addSectionSpecification ( const SectionSpecification & section )

Add a section specification to the layer.

A section specification is a reference to a named ImagerySection within the WidgetLook.

Parameters:
section SectionSpecification object descibing the section that should be added to this layer.
Returns:
Nothing,

void CEGUI::LayerSpecification::clearSectionSpecifications ( )

Clear all section specifications from this layer,.

Returns:
Nothing.

uint CEGUI::LayerSpecification::getLayerPriority ( ) const

Return the priority of this layer.

Returns:
uint value descibing the priority of this LayerSpecification.

void CEGUI::LayerSpecification::render | ( | Window & | srcWindow,
 |  | const Rect & | baseRect,
 |  | float | base_z,
 |  | const ColourRect * | modcols = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render this layer.

Parameters:
srcWindow | Window to use when calculating pixel values from BaseDim values.
baseRect | Rect to use when calculating pixel values from BaseDim values.
base_z | base level z value to use for all imagery in the layer.
Returns:
Nothing.

void CEGUI::LayerSpecification::render | ( | Window & | srcWindow,
 |  | float | base_z,
 |  | const ColourRect * | modcols = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render this layer.

Parameters:
srcWindow | Window to use when calculating pixel values from BaseDim values.
base_z | base level z value to use for all imagery in the layer.
Returns:
Nothing.

void CEGUI::LayerSpecification::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this Layer to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::LeftFrameImage Class Reference

CEGUI::StaticProperties::LeftFrameImage

CEGUI::StaticProperties::LeftFrameImage Class Reference

Property to access the left edge image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::LeftFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::LeftFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the left edge image for the frame of the Static widget.

Usage:
  • Name: LeftFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::LeftFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::LeftFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Listbox Class Reference

CEGUI::Listbox

CEGUI::Listbox Class Reference

Base class for standard Listbox widget. More...

Inheritance diagram for CEGUI::Listbox:

[legend]
Collaboration diagram for CEGUI::Listbox:

[legend]
List of all members.

Public Member Functions

size_t | getItemCount (void) const
Return number of items attached to the list box.
size_t | getSelectedCount (void) const
Return the number of selected items in the list box.
ListboxItem * | getFirstSelectedItem (void) const
Return a pointer to the first selected item.
ListboxItem * | getNextSelected (const ListboxItem *start_item) const
Return a pointer to the next selected item after item start_item.
ListboxItem * | getListboxItemFromIndex (size_t index) const
Return the item at index position index.
size_t | getItemIndex (const ListboxItem *item) const
Return the index of ListboxItem item.
bool | isSortEnabled (void) const
return whether list sorting is enabled
bool | isMultiselectEnabled (void) const
return whether multi-select is enabled
bool | isItemTooltipsEnabled (void) const
bool | isItemSelected (size_t index) const
return whether the string at index position index is selected
ListboxItem * | findItemWithText (const String &text, const ListboxItem *start_item)
Search the list for an item with the specified text.
bool | isListboxItemInList (const ListboxItem *item) const
Return whether the specified ListboxItem is in the List.
bool | isVertScrollbarAlwaysShown (void) const
Return whether the vertical scroll bar is always shown.
bool | isHorzScrollbarAlwaysShown (void) const
Return whether the horizontal scroll bar is always shown.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | resetList (void)
Remove all items from the list.
void | addItem (ListboxItem *item)
Add the given ListboxItem to the list.
void | insertItem (ListboxItem *item, const ListboxItem *position)
Insert an item into the list box after a specified item already in the list.
void | removeItem (const ListboxItem *item)
Removes the given item from the list box. If the item is has the auto delete state set, the item will be deleted.
void | clearAllSelections (void)
Clear the selected state for all items.
void | setSortingEnabled (bool setting)
Set whether the list should be sorted.
void | setMultiselectEnabled (bool setting)
Set whether the list should allow multiple selections or just a single selection.
void | setShowVertScrollbar (bool setting)
Set whether the vertical scroll bar should always be shown.
void | setShowHorzScrollbar (bool setting)
Set whether the horizontal scroll bar should always be shown.
void | setItemTooltipsEnabled (bool setting)
void | setItemSelectState (ListboxItem *item, bool state)
Set the select state of an attached ListboxItem.
void | setItemSelectState (size_t item_index, bool state)
Set the select state of an attached ListboxItem.
void | handleUpdatedItemData (void)
Causes the list box to update it's internal state after changes have been made to one or more attached ListboxItem objects.
void | ensureItemIsVisible (size_t item_index)
Ensure the item at the specified index is visible within the list box.
void | ensureItemIsVisible (const ListboxItem *item)
Ensure the item at the specified index is visible within the list box.
Listbox (const String &type, const String &name)
Constructor for Listbox base class.
virtual | ~Listbox (void)
Destructor for Listbox base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventListContentsChanged
Event triggered when the contents of the list is changed.
static const String | EventSelectionChanged
Event triggered when there is a change to the currently selected item(s).
static const String | EventSortModeChanged
Event triggered when the sort mode setting changes.
static const String | EventMultiselectModeChanged
Event triggered when the multi-select mode setting changes.
static const String | EventVertScrollbarModeChanged
Event triggered when the vertical scroll bar 'force' setting changes.
static const String | EventHorzScrollbarModeChanged
Event triggered when the horizontal scroll bar 'force' setting changes.

Protected Types

typedef std::vector< ListboxItem * > | LBItemList

Protected Member Functions

virtual Rect | getListRenderArea (void) const =0
Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering list items.
virtual Scrollbar * | createVertScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as vertical scroll bar
virtual Scrollbar * | createHorzScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as horizontal scroll bar
virtual void | cacheListboxBaseImagery ()=0
Perform caching of the widget control frame and other 'static' areas. This method should not render the actual items. Note that the items are typically rendered to layer 3, other layers can be used for rendering imagery behind and infront of the items.
void | addListboxEvents (void)
Add list box specific events.
void | configureScrollbars (void)
display required integrated scroll bars according to current state of the list box and update their values.
void | selectRange (size_t start, size_t end)
select all strings between positions start and end. (inclusive) including end.
float | getTotalItemsHeight (void) const
Return the sum of all item heights.
float | getWidestItemWidth (void) const
Return the width of the widest item.
bool | clearAllSelections_impl (void)
Clear the selected state for all items (implementation).
ListboxItem * | getItemAtPoint (const Point &pt) const
Return the ListboxItem under the given window local pixel co-ordinate.
bool | resetList_impl (void)
Remove all items from the list.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
bool | handle_scrollChange (const EventArgs &args)
Internal handler that is triggered when the user interacts with the scrollbars.
void | populateRenderCache ()
Update the rendering cache.
virtual void | onListContentsChanged (WindowEventArgs &e)
Handler called internally when the list contents are changed.
virtual void | onSelectionChanged (WindowEventArgs &e)
Handler called internally when the currently selected item or items changes.
virtual void | onSortModeChanged (WindowEventArgs &e)
Handler called internally when the sort mode setting changes.
virtual void | onMultiselectModeChanged (WindowEventArgs &e)
Handler called internally when the multi-select mode setting changes.
virtual void | onVertScrollbarModeChanged (WindowEventArgs &e)
Handler called internally when the forced display of the vertical scroll bar setting changes.
virtual void | onHorzScrollbarModeChanged (WindowEventArgs &e)
Handler called internally when the forced display of the horizontal scroll bar setting changes.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.

Protected Attributes

bool | d_sorted
true if list is sorted
bool | d_multiselect
true if multi-select is enabled
bool | d_forceVertScroll
true if vertical scrollbar should always be displayed
bool | d_forceHorzScroll
true if horizontal scrollbar should always be displayed
bool | d_itemTooltips
true if each item should have an individual tooltip
Scrollbar * d_vertScrollbar
vertical scroll-bar widget
Scrollbar * d_horzScrollbar
horizontal scroll-bar widget
LBItemList | d_listItems
list of items in the list box.
ListboxItem * d_lastSelected
holds pointer to the last selected item (used in range selections)

Detailed Description

Base class for standard Listbox widget.

Member Function Documentation

void CEGUI::Listbox::addItem ( ListboxItem * item )

Add the given ListboxItem to the list.

Parameters:
item Pointer to the ListboxItem to be added to the list. Note that it is the passed object that is added to the list, a copy is not made. If this parameter is NULL, nothing happens.
Returns:
Nothing.

virtual void CEGUI::Listbox::cacheListboxBaseImagery ( ) [protected, pure virtual]

Perform caching of the widget control frame and other 'static' areas. This method should not render the actual items. Note that the items are typically rendered to layer 3, other layers can be used for rendering imagery behind and infront of the items.

Returns:
Nothing.

void CEGUI::Listbox::clearAllSelections ( void )

Clear the selected state for all items.

Returns:
Nothing.

bool CEGUI::Listbox::clearAllSelections_impl ( void ) [protected]

Clear the selected state for all items (implementation).

Returns:
true if some selections were cleared, false nothing was changed.

virtual Scrollbar* CEGUI::Listbox::createHorzScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as horizontal scroll bar

Parameters:
name String holding the name to be given to the created widget component.
Returns:
Pointer to a Scrollbar to be used for scrolling the list horizontally.

virtual Scrollbar* CEGUI::Listbox::createVertScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as vertical scroll bar

Parameters:
name String holding the name to be given to the created widget component.
Returns:
Pointer to a Scrollbar to be used for scrolling the list vertically.

void CEGUI::Listbox::ensureItemIsVisible ( const ListboxItem * item )

Ensure the item at the specified index is visible within the list box.

Parameters:
item Pointer to the ListboxItem to be made visible in the list box.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

void CEGUI::Listbox::ensureItemIsVisible ( size_t item_index )

Ensure the item at the specified index is visible within the list box.

Parameters:
item_index Zero based index of the item to be made visible in the list box. If this value is out of range, the list is always scrolled to the bottom.
Returns:
Nothing.

ListboxItem * CEGUI::Listbox::findItemWithText | ( | const String & | text,
 |  | const ListboxItem * | start_item
 | ) |

Search the list for an item with the specified text.

Parameters:
text | String object containing the text to be searched for.
start_item | ListboxItem where the search is to begin, the search will not include item. If item is NULL, the search will begin from the first item in the list.
Returns:
Pointer to the first ListboxItem in the list after item that has text matching text. If no item matches the criteria NULL is returned.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

ListboxItem * CEGUI::Listbox::getFirstSelectedItem ( void ) const

Return a pointer to the first selected item.

Returns:
Pointer to a ListboxItem based object that is the first selected item in the list. will return NULL if no item is selected.

ListboxItem * CEGUI::Listbox::getItemAtPoint ( const Point & pt ) const [protected]

Return the ListboxItem under the given window local pixel co-ordinate.

Returns:
ListboxItem that is under window pixel co-ordinate pt, or NULL if no item is under that position.

size_t CEGUI::Listbox::getItemCount ( void ) const [inline]

Return number of items attached to the list box.

Returns:
the number of items currently attached to this list box.

size_t CEGUI::Listbox::getItemIndex ( const ListboxItem * item ) const

Return the index of ListboxItem item.

Parameters:
item Pointer to a ListboxItem whos zero based index is to be returned.
Returns:
Zero based index indicating the position of ListboxItem item in the list box.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

ListboxItem * CEGUI::Listbox::getListboxItemFromIndex ( size_t index ) const

Return the item at index position index.

Parameters:
index Zero based index of the item to be returned.
Returns:
Pointer to the ListboxItem at index position index in the list box.
Exceptions:
InvalidRequestException thrown if index is out of range.

virtual Rect CEGUI::Listbox::getListRenderArea ( void ) const [protected, pure virtual]

Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering list items.

Returns:
Rect object describing the area of the Window to be used for rendering list box items.

ListboxItem * CEGUI::Listbox::getNextSelected ( const ListboxItem * start_item ) const

Return a pointer to the next selected item after item start_item.

Parameters:
start_item Pointer to the ListboxItem where the search for the next selected item is to begin. If this parameter is NULL, the search will begin with the first item in the list box.
Returns:
Pointer to a ListboxItem based object that is the next selected item in the list after the item specified by start_item. Will return NULL if no further items were selected.
Exceptions:
InvalidRequestException thrown if start_item is not attached to this list box.

size_t CEGUI::Listbox::getSelectedCount ( void ) const

Return the number of selected items in the list box.

Returns:
Total number of attached items that are in the selected state.

void CEGUI::Listbox::handleUpdatedItemData ( void )

Causes the list box to update it's internal state after changes have been made to one or more attached ListboxItem objects.

Client code must call this whenever it has made any changes to ListboxItem objects already attached to the list box. If you are just adding items, or removed items to update them prior to re-adding them, there is no need to call this method.

Returns:
Nothing.

void CEGUI::Listbox::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::ComboDropList.

void CEGUI::Listbox::insertItem | ( | ListboxItem * | item,
 |  | const ListboxItem * | position
 | ) |

Insert an item into the list box after a specified item already in the list.

Note that if the list is sorted, the item may not end up in the requested position.

Parameters:
item | Pointer to the ListboxItem to be inserted. Note that it is the passed object that is added to the list, a copy is not made. If this parameter is NULL, nothing happens.
position | Pointer to a ListboxItem that item is to be inserted after. If this parameter is NULL, the item is inserted at the start of the list.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if no ListboxItem position is attached to this list box.

bool CEGUI::Listbox::isHorzScrollbarAlwaysShown ( void ) const

Return whether the horizontal scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

bool CEGUI::Listbox::isItemSelected ( size_t index ) const

return whether the string at index position index is selected

Parameters:
index Zero based index of the item to be examined.
Returns:
true if the item at index is selected, false if the item at index is not selected.
Exceptions:
InvalidRequestException thrown if index is out of range.

bool CEGUI::Listbox::isListboxItemInList ( const ListboxItem * item ) const

Return whether the specified ListboxItem is in the List.

Returns:
true if ListboxItem item is in the list, false if ListboxItem item is not in the list.

bool CEGUI::Listbox::isMultiselectEnabled ( void ) const [inline]

return whether multi-select is enabled

Returns:
true if multi-select is enabled, false if multi-select is not enabled.

bool CEGUI::Listbox::isSortEnabled ( void ) const [inline]

return whether list sorting is enabled

Returns:
true if the list is sorted, false if the list is not sorted

bool CEGUI::Listbox::isVertScrollbarAlwaysShown ( void ) const

Return whether the vertical scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

void CEGUI::Listbox::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::ComboDropList.

void CEGUI::Listbox::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::ComboDropList.

void CEGUI::Listbox::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Listbox::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Listbox::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Window.

void CEGUI::Listbox::removeItem ( const ListboxItem * item )

Removes the given item from the list box. If the item is has the auto delete state set, the item will be deleted.

Parameters:
item Pointer to the ListboxItem that is to be removed. If item is not attached to this list box then nothing will happen.
Returns:
Nothing.

void CEGUI::Listbox::resetList ( void )

Remove all items from the list.

Note that this will cause 'AutoDelete' items to be deleted.

bool CEGUI::Listbox::resetList_impl ( void ) [protected]

Remove all items from the list.

Note:
Note that this will cause 'AutoDelete' items to be deleted.
Returns:
  • true if the list contents were changed.
  • false if the list contents were not changed (list already empty).

void CEGUI::Listbox::setItemSelectState | ( | size_t | item_index,
 |  | bool | state
 | ) |

Set the select state of an attached ListboxItem.

This is the recommended way of selecting and deselecting items attached to a list box as it respects the multi-select mode setting. It is possible to modify the setting on ListboxItems directly, but that approach does not respect the settings of the list box.

Parameters:
item_index | The zero based index of the ListboxItem to be affected. This must be a valid index (0 <= index < getItemCount())
state | true to select the item, false to de-select the item.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if item_index is out of range for the list box

void CEGUI::Listbox::setItemSelectState | ( | ListboxItem * | item,
 |  | bool | state
 | ) |

Set the select state of an attached ListboxItem.

This is the recommended way of selecting and deselecting items attached to a list box as it respects the multi-select mode setting. It is possible to modify the setting on ListboxItems directly, but that approach does not respect the settings of the list box.

Parameters:
item | The ListboxItem to be affected. This item must be attached to the list box.
state | true to select the item, false to de-select the item.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if item is not attached to this list box.

void CEGUI::Listbox::setMultiselectEnabled ( bool setting )

Set whether the list should allow multiple selections or just a single selection.

Parameters:
setting true if the widget should allow multiple items to be selected, false if the widget should only allow a single selection.
Returns:
Nothing.

void CEGUI::Listbox::setShowHorzScrollbar ( bool setting )

Set whether the horizontal scroll bar should always be shown.

Parameters:
setting true if the horizontal scroll bar should be shown even when it is not required. false if the horizontal scroll bar should only be shown when it is required.
Returns:
Nothing.

void CEGUI::Listbox::setShowVertScrollbar ( bool setting )

Set whether the vertical scroll bar should always be shown.

Parameters:
setting true if the vertical scroll bar should be shown even when it is not required. false if the vertical scroll bar should only be shown when it is required.
Returns:
Nothing.

void CEGUI::Listbox::setSortingEnabled ( bool setting )

Set whether the list should be sorted.

Parameters:
setting true if the list should be sorted, false if the list should not be sorted.
Returns:
Nothing.

virtual bool CEGUI::Listbox::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::ComboDropList.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxItem Class Reference

CEGUI::ListboxItem

CEGUI::ListboxItem Class Reference

Base class for list box items. More...

Inheritance diagram for CEGUI::ListboxItem:

[legend]
Collaboration diagram for CEGUI::ListboxItem:

[legend]
List of all members.

Public Member Functions

ListboxItem (const String &text, uint item_id=0, void *item_data=NULL, bool disabled=false, bool auto_delete=true)
base class constructor
virtual | ~ListboxItem (void)
base class destructor
const String & | getText (void) const
return the text string set for this list box item.
const String & | getTooltipText (void) const
uint | getID (void) const
Return the current ID assigned to this list box item.
void * | getUserData (void) const
Return the pointer to any client assigned user data attached to this lis box item.
bool | isSelected (void) const
return whether this item is selected.
bool | isDisabled (void) const
return whether this item is disabled.
bool | isAutoDeleted (void) const
return whether this item will be automatically deleted when the list box it is attached to is destroyed, or when the item is removed from the list box.
const Window * | getOwnerWindow (const Window *owner)
Get the owner window for this ListboxItem.
ColourRect | getSelectionColours (void) const
Return the current colours used for selection highlighting.
const Image * | getSelectionBrushImage (void) const
Return the current selection highlighting brush.
void | setText (const String &text)
set the text string for this list box item.
void | setTooltipText (const String &text)
void | setID (uint item_id)
Set the ID assigned to this list box item.
void | setUserData (void *item_data)
Set the client assigned user data attached to this lis box item.
void | setSelected (bool setting)
set whether this item is selected.
void | setDisabled (bool setting)
set whether this item is disabled.
void | setAutoDeleted (bool setting)
Set whether this item will be automatically deleted when the list box it is attached to is destroyed, or when the item is removed from the list box.
void | setOwnerWindow (const Window *owner)
Set the owner window for this ListboxItem. This is called by all the list box widgets when an item is added or inserted.
void | setSelectionColours (const ColourRect &cols)
Set the colours used for selection highlighting.
void | setSelectionColours (colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour)
Set the colours used for selection highlighting.
void | setSelectionColours (colour col)
Set the colours used for selection highlighting.
void | setSelectionBrushImage (const Image *image)
Set the selection highlighting brush image.
void | setSelectionBrushImage (const String &imageset, const String &image)
Set the selection highlighting brush image.
virtual Size | getPixelSize (void) const =0
Return the rendered pixel size of this list box item.
virtual void | draw (const Vector3 &position, float alpha, const Rect &clipper) const =0
Draw the list box item in its current state.
virtual void | draw (RenderCache &cache, const Rect &targetRect, float zBase, float alpha, const Rect *clipper) const =0
virtual bool | operator< (const ListboxItem &rhs) const
Less-than operator, compares item texts.
virtual bool | operator> (const ListboxItem &rhs) const
Greater-than operator, compares item texts.

Static Public Attributes

static const colour | DefaultSelectionColour = 0xFF4444AA
Default selection brush colour.

Protected Member Functions

ColourRect | getModulateAlphaColourRect (const ColourRect &cols, float alpha) const
Return a ColourRect object describing the colours in cols after having their alpha component modulated by the value alpha.
colour | calculateModulatedAlphaColour (colour col, float alpha) const
Return a colour value describing the colour specified by col after having its alpha component modulated by the value alpha.

Protected Attributes

String d_itemText
Text for this list box item. If not rendered, this is still used for list sorting.
String d_tooltipText
Text for the individual tooltip of this item.
uint | d_itemID
ID code assigned by client code. This has no meaning within the GUI system.
void * | d_itemData
Pointer to some client code data. This has no meaning within the GUI system.
bool | d_selected
true if this item is selected. false if the item is not selected.
bool | d_disabled
true if this item is disabled. false if the item is not disabled.
bool | d_autoDelete
true if the system should destroy this item, false if client code will destroy the item.
const Window * | d_owner
Pointer to the window that owns this item.
ColourRect d_selectCols
Colours used for selection highlighting.
const Image * | d_selectBrush
Image used for rendering selection.

Detailed Description

Base class for list box items.

Member Function Documentation

virtual void CEGUI::ListboxItem::draw | ( | const Vector3 & | position,
 |  | float | alpha,
 |  | const Rect & | clipper
 | ) | const [pure virtual]

Draw the list box item in its current state.

Parameters:
position | Vecor3 object describing the upper-left corner of area that should be rendered in to for the draw operation.
alpha | Alpha value to be used when rendering the item (between 0.0f and 1.0f).
clipper | Rect object describing the clipping rectangle for the draw operation.
Returns:
Nothing.

Implemented in CEGUI::ListboxTextItem.

uint CEGUI::ListboxItem::getID ( void ) const [inline]

Return the current ID assigned to this list box item.

Note that the system does not make use of this value, client code can assign any meaning it wishes to the ID.

Returns:
ID code currently assigned to this list box item

const Window* CEGUI::ListboxItem::getOwnerWindow ( const Window * owner ) [inline]

Get the owner window for this ListboxItem.

The owner of a ListboxItem is typically set by the list box widgets when an item is added or inserted.

Returns:
Ponter to the window that is considered the owner of this ListboxItem.

virtual Size CEGUI::ListboxItem::getPixelSize ( void ) const [pure virtual]

Return the rendered pixel size of this list box item.

Returns:
Size object describing the size of the list box item in pixels.

Implemented in CEGUI::ListboxTextItem.

const Image* CEGUI::ListboxItem::getSelectionBrushImage ( void ) const [inline]

Return the current selection highlighting brush.

Returns:
Pointer to the Image object currently used for selection highlighting.

ColourRect CEGUI::ListboxItem::getSelectionColours ( void ) const [inline]

Return the current colours used for selection highlighting.

Returns:
ColourRect object describing the currently set colours

const String& CEGUI::ListboxItem::getText ( void ) const [inline]

return the text string set for this list box item.

Note that even if the item does not render text, the text string can still be useful, since it is used for sorting list box items.

Returns:
String object containing the current text for the list box item.

void* CEGUI::ListboxItem::getUserData ( void ) const [inline]

Return the pointer to any client assigned user data attached to this lis box item.

Note that the system does not make use of this data, client code can assign any meaning it wishes to the attached data.

Returns:
Pointer to the currently assigned user data.

bool CEGUI::ListboxItem::isAutoDeleted ( void ) const [inline]

return whether this item will be automatically deleted when the list box it is attached to is destroyed, or when the item is removed from the list box.

Returns:
true if the item object will be deleted by the system when the list box it is attached to is destroyed, or when the item is removed from the list. false if client code must destroy the item after it is removed from the list.

bool CEGUI::ListboxItem::isDisabled ( void ) const [inline]

return whether this item is disabled.

Returns:
true if the item is disabled, false if the item is enabled.

bool CEGUI::ListboxItem::isSelected ( void ) const [inline]

return whether this item is selected.

Returns:
true if the item is selected, false if the item is not selected.

void CEGUI::ListboxItem::setAutoDeleted ( bool setting ) [inline]

Set whether this item will be automatically deleted when the list box it is attached to is destroyed, or when the item is removed from the list box.

Parameters:
setting true if the item object should be deleted by the system when the list box it is attached to is destroyed, or when the item is removed from the list. false if client code will destroy the item after it is removed from the list.
Returns:
Nothing.

void CEGUI::ListboxItem::setDisabled ( bool setting ) [inline]

set whether this item is disabled.

Parameters:
setting true if the item is disabled, false if the item is enabled.
Returns:
Nothing.

void CEGUI::ListboxItem::setID ( uint item_id ) [inline]

Set the ID assigned to this list box item.

Note that the system does not make use of this value, client code can assign any meaning it wishes to the ID.

Parameters:
item_id ID code to be assigned to this list box item
Returns:
Nothing.

void CEGUI::ListboxItem::setOwnerWindow ( const Window * owner ) [inline]

Set the owner window for this ListboxItem. This is called by all the list box widgets when an item is added or inserted.

Parameters:
owner Ponter to the window that should be considered the owner of this ListboxItem.
Returns:
Nothing

void CEGUI::ListboxItem::setSelected ( bool setting ) [inline]

set whether this item is selected.

Parameters:
setting true if the item is selected, false if the item is not selected.
Returns:
Nothing.

void CEGUI::ListboxItem::setSelectionBrushImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the selection highlighting brush image.

Parameters:
imageset | Name of the imagest containing the image to be used.
image | Name of the image to be used
Returns:
Nothing.

void CEGUI::ListboxItem::setSelectionBrushImage ( const Image * image ) [inline]

Set the selection highlighting brush image.

Parameters:
image Pointer to the Image object to be used for selection highlighting.
Returns:
Nothing.

void CEGUI::ListboxItem::setSelectionColours ( colour col ) [inline]

Set the colours used for selection highlighting.

Parameters:
col colour value to be used when rendering.
Returns:
Nothing.

void CEGUI::ListboxItem::setSelectionColours | ( | colour | top_left_colour,
 |  | colour | top_right_colour,
 |  | colour | bottom_left_colour,
 |  | colour | bottom_right_colour
 | ) |

Set the colours used for selection highlighting.

Parameters:
top_left_colour | Colour (as ARGB value) to be applied to the top-left corner of the selection area.
top_right_colour | Colour (as ARGB value) to be applied to the top-right corner of the selection area.
bottom_left_colour | Colour (as ARGB value) to be applied to the bottom-left corner of the selection area.
bottom_right_colour | Colour (as ARGB value) to be applied to the bottom-right corner of the selection area.
Returns:
Nothing.

void CEGUI::ListboxItem::setSelectionColours ( const ColourRect & cols ) [inline]

Set the colours used for selection highlighting.

Parameters:
cols ColourRect object describing the colours to be used.
Returns:
Nothing.

void CEGUI::ListboxItem::setText ( const String & text ) [inline]

set the text string for this list box item.

Note that even if the item does not render text, the text string can still be useful, since it is used for sorting list box items.

Parameters:
text String object containing the text to set for the list box item.
Returns:
Nothing.

void CEGUI::ListboxItem::setUserData ( void * item_data ) [inline]

Set the client assigned user data attached to this lis box item.

Note that the system does not make use of this data, client code can assign any meaning it wishes to the attached data.

Parameters:
item_data Pointer to the user data to attach to this list item.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxTextItem Class Reference

CEGUI::ListboxTextItem

CEGUI::ListboxTextItem Class Reference

Class used for textual items in a list box. More...

Inheritance diagram for CEGUI::ListboxTextItem:

[legend]
Collaboration diagram for CEGUI::ListboxTextItem:

[legend]
List of all members.

Public Member Functions

ListboxTextItem (const String &text, uint item_id=0, void *item_data=NULL, bool disabled=false, bool auto_delete=true)
base class constructor
virtual | ~ListboxTextItem (void)
base class destructor
const Font * | getFont (void) const
Return a pointer to the font being used by this ListboxTextItem.
ColourRect | getTextColours (void) const
Return the current colours used for text rendering.
void | setFont (const Font *font)
Set the font to be used by this ListboxTextItem.
void | setFont (const String &font_name)
Set the font to be used by this ListboxTextItem.
void | setTextColours (const ColourRect &cols)
Set the colours used for text rendering.
void | setTextColours (colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour)
Set the colours used for text rendering.
void | setTextColours (colour col)
Set the colours used for text rendering.
Size | getPixelSize (void) const
Return the rendered pixel size of this list box item.
void | draw (const Vector3 &position, float alpha, const Rect &clipper) const
Draw the list box item in its current state.
void | draw (RenderCache &cache, const Rect &targetRect, float zBase, float alpha, const Rect *clipper) const

Static Public Attributes

static const colour | DefaultTextColour = 0xFFFFFFFF
Default text colour.

Protected Attributes

ColourRect d_textCols
Colours used for rendering the text.
const Font * | d_font
Font used for rendering text.

Detailed Description

Class used for textual items in a list box.

Member Function Documentation

void CEGUI::ListboxTextItem::draw | ( | const Vector3 & | position,
 |  | float | alpha,
 |  | const Rect & | clipper
 | ) | const [virtual]

Draw the list box item in its current state.

Parameters:
position | Vecor3 object describing the upper-left corner of area that should be rendered in to for the draw operation.
alpha | Alpha value to be used when rendering the item (between 0.0f and 1.0f).
clipper | Rect object describing the clipping rectangle for the draw operation.
Returns:
Nothing.

Implements CEGUI::ListboxItem.

const Font * CEGUI::ListboxTextItem::getFont ( void ) const

Return a pointer to the font being used by this ListboxTextItem.

This method will try a number of places to find a font to be used. If no font can be found, NULL is returned.

Returns:
Font to be used for rendering this item

Size CEGUI::ListboxTextItem::getPixelSize ( void ) const [virtual]

Return the rendered pixel size of this list box item.

Returns:
Size object describing the size of the list box item in pixels.

Implements CEGUI::ListboxItem.

ColourRect CEGUI::ListboxTextItem::getTextColours ( void ) const [inline]

Return the current colours used for text rendering.

Returns:
ColourRect object describing the currently set colours

void CEGUI::ListboxTextItem::setFont ( const String & font_name )

Set the font to be used by this ListboxTextItem.

Parameters:
font_name String object containing the name of the Font to be used for rendering this item
Returns:
Nothing

void CEGUI::ListboxTextItem::setFont ( const Font * font ) [inline]

Set the font to be used by this ListboxTextItem.

Parameters:
font Font to be used for rendering this item
Returns:
Nothing

void CEGUI::ListboxTextItem::setTextColours ( colour col ) [inline]

Set the colours used for text rendering.

Parameters:
col colour value to be used when rendering.
Returns:
Nothing.

void CEGUI::ListboxTextItem::setTextColours | ( | colour | top_left_colour,
 |  | colour | top_right_colour,
 |  | colour | bottom_left_colour,
 |  | colour | bottom_right_colour
 | ) |

Set the colours used for text rendering.

Parameters:
top_left_colour | Colour (as ARGB value) to be applied to the top-left corner of each text glyph rendered.
top_right_colour | Colour (as ARGB value) to be applied to the top-right corner of each text glyph rendered.
bottom_left_colour | Colour (as ARGB value) to be applied to the bottom-left corner of each text glyph rendered.
bottom_right_colour | Colour (as ARGB value) to be applied to the bottom-right corner of each text glyph rendered.
Returns:
Nothing.

void CEGUI::ListboxTextItem::setTextColours ( const ColourRect & cols ) [inline]

Set the colours used for text rendering.

Parameters:
cols ColourRect object describing the colours to be used.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeader Class Reference

CEGUI::ListHeader

CEGUI::ListHeader Class Reference

Base class for the multi column list header widget. More...

Inheritance diagram for CEGUI::ListHeader:

[legend]
Collaboration diagram for CEGUI::ListHeader:

[legend]
List of all members.

Public Member Functions

uint | getColumnCount (void) const
Return the number of columns or segments attached to the header.
ListHeaderSegment & | getSegmentFromColumn (uint column) const
Return the ListHeaderSegment object for the specified column.
ListHeaderSegment & | getSegmentFromID (uint id) const
Return the ListHeaderSegment object with the specified ID.
ListHeaderSegment & | getSortSegment (void) const
Return the ListHeaderSegment that is marked as being the 'sort key' segment. There must be at least one segment to successfully call this method.
uint | getColumnFromSegment (const ListHeaderSegment &segment) const
Return the zero based column index of the specified segment.
uint | getColumnFromID (uint id) const
Return the zero based column index of the segment with the specified ID.
uint | getSortColumn (void) const
Return the zero based index of the current sort column. There must be at least one segment/column to successfully call this method.
uint | getColumnWithText (const String &text) const
Return the zero based column index of the segment with the specified text.
float | getPixelOffsetToSegment (const ListHeaderSegment &segment) const
Return the pixel offset to the given ListHeaderSegment.
float | getPixelOffsetToColumn (uint column) const
Return the pixel offset to the ListHeaderSegment at the given zero based column index.
float | getTotalSegmentsPixelExtent (void) const
Return the total pixel width of all attached segments.
float | getColumnPixelWidth (uint column) const
Return the pixel width of the specified column.
ListHeaderSegment::SortDirection | getSortDirection (void) const
Return the currently set sort direction.
bool | isSortingEnabled (void) const
Return whether user manipulation of the sort column & direction are enabled.
bool | isColumnSizingEnabled (void) const
Return whether the user may size column segments.
bool | isColumnDraggingEnabled (void) const
Return whether the user may modify the order of the segments.
float | getSegmentOffset (void) const
Return the current segment offset value. This value is used to implement scrolling of the header segments within the ListHeader area.
void | setSortingEnabled (bool setting)
Set whether user manipulation of the sort column and direction is enabled.
void | setSortDirection (ListHeaderSegment::SortDirection direction)
Set the current sort direction.
void | setSortSegment (const ListHeaderSegment &segment)
Set the column segment to be used as the sort column.
void | setSortColumn (uint column)
Set the column to be used as the sort column.
void | setSortColumnFromID (uint id)
Set the column to to be used for sorting via its ID code.
void | setColumnSizingEnabled (bool setting)
Set whether columns may be sized by the user.
void | setColumnDraggingEnabled (bool setting)
Set whether columns may be reordered by the user via drag and drop.
void | addColumn (const String &text, uint id, float width)
Add a new column segment to the end of the header.
void | insertColumn (const String &text, uint id, float width, uint position)
Insert a new column segment at the specified position.
void | insertColumn (const String &text, uint id, float width, const ListHeaderSegment &position)
Insert a new column segment at the specified position.
void | removeColumn (uint column)
Removes a column segment from the ListHeader.
void | removeSegment (const ListHeaderSegment &segment)
Remove the specified segment from the ListHeader.
void | moveColumn (uint column, uint position)
Moves a column segment into a new position.
void | moveColumn (uint column, const ListHeaderSegment &position)
Move a column segment to a new position.
void | moveSegment (const ListHeaderSegment &segment, uint position)
Moves a segment into a new position.
void | moveSegment (const ListHeaderSegment &segment, const ListHeaderSegment &position)
Move a segment to a new position.
void | setSegmentOffset (float offset)
Set the current base segment offset. (This implements scrolling of the header segments within the header area).
void | setColumnPixelWidth (uint column, float width)
Set the pixel width of the specified column.
ListHeader (const String &type, const String &name)
Constructor for the list header base class.
virtual | ~ListHeader (void)
Destructor for the list header base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventSortColumnChanged
Event fired when the current sort column changes.
static const String | EventSortDirectionChanged
Event fired when the sort direction changes.
static const String | EventSegmentSized
Event fired when a segment has been sized by the user (e.window is the segment).
static const String | EventSegmentClicked
Event fired when a segment has been clicked by the user (e.window is the segment).
static const String | EventSplitterDoubleClicked
Event fired when a segment splitter has been double-clicked. (e.window is the segment).
static const String | EventSegmentSequenceChanged
Event fired when the order of the segments has changed. ('e' is a HeaderSequenceEventArgs&).
static const String | EventSegmentAdded
Event fired when a segment is added to the header.
static const String | EventSegmentRemoved
Event fired when a segment is removed from the header.
static const String | EventSortSettingChanged
Event fired when setting that controls user modification to sort configuration changes.
static const String | EventDragMoveSettingChanged
Event fired when setting that controls user drag & drop of segments changes.
static const String | EventDragSizeSettingChanged
Event fired when setting that controls user sizing of segments changes.
static const String | EventSegmentRenderOffsetChanged
Event fired when the rendering offset for the segments changes.
static const float | ScrollSpeed = 8.0f
Speed to scroll at when dragging outside header.
static const float | MinimumSegmentPixelWidth = 20.0f
Miniumum width of a segment in pixels.

Protected Types

typedef std::vector< ListHeaderSegment * > | SegmentList

Protected Member Functions

virtual ListHeaderSegment * | createNewSegment (const String &name) const =0
Create and return a pointer to a new ListHeaderSegment based object.
virtual void | destroyListSegment (ListHeaderSegment *segment) const =0
Cleanup and destroy the given ListHeaderSegment that was created via the createNewSegment method.
ListHeaderSegment * | createInitialisedSegment (const String &text, uint id, float width)
Create initialise and return a ListHeaderSegment object, with all events subscribed and ready to use.
void | layoutSegments (void)
Layout the attached segments.
void | addListHeaderEvents (void)
Add ListHeader specific events.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onSortColumnChanged (WindowEventArgs &e)
Handler called when the sort column is changed.
virtual void | onSortDirectionChanged (WindowEventArgs &e)
Handler called when the sort direction is changed.
virtual void | onSegmentSized (WindowEventArgs &e)
Handler called when a segment is sized by the user. e.window points to the segment.
virtual void | onSegmentClicked (WindowEventArgs &e)
Handler called when a segment is clicked by the user. e.window points to the segment.
virtual void | onSplitterDoubleClicked (WindowEventArgs &e)
Handler called when a segment splitter / sizer is double-clicked. e.window points to the segment.
virtual void | onSegmentSequenceChanged (WindowEventArgs &e)
Handler called when the segment / column order changes.
virtual void | onSegmentAdded (WindowEventArgs &e)
Handler called when a new segment is added to the header.
virtual void | onSegmentRemoved (WindowEventArgs &e)
Handler called when a segment is removed from the header.
virtual void | onSortSettingChanged (WindowEventArgs &e)
Handler called then setting that controls the users ability to modify the search column & direction changes.
virtual void | onDragMoveSettingChanged (WindowEventArgs &e)
Handler called when the setting that controls the users ability to drag and drop segments changes.
virtual void | onDragSizeSettingChanged (WindowEventArgs &e)
Handler called when the setting that controls the users ability to size segments changes.
virtual void | onSegmentOffsetChanged (WindowEventArgs &e)
Handler called when the base rendering offset for the segments (scroll position) changes.
bool | segmentSizedHandler (const EventArgs &e)
bool | segmentMovedHandler (const EventArgs &e)
bool | segmentClickedHandler (const EventArgs &e)
bool | segmentDoubleClickHandler (const EventArgs &e)
bool | segmentDragHandler (const EventArgs &e)

Protected Attributes

SegmentList | d_segments
Attached segment windows in header order.
ListHeaderSegment * d_sortSegment
Pointer to the segment that is currently set as the sork-key,.
bool | d_sizingEnabled
true if segments can be sized by the user.
bool | d_sortingEnabled
true if the sort criteria modifications by user are enabled (no sorting is actuall done)
bool | d_movingEnabled
true if drag & drop moving of columns / segments is enabled.
uint | d_uniqueIDNumber
field used to create unique names.
float | d_segmentOffset
Base offset used to layout the segments (allows scrolling within the window area).
ListHeaderSegment::SortDirection d_sortDir
Brief copy of the current sort direction.

Detailed Description

Base class for the multi column list header widget.

Member Function Documentation

void CEGUI::ListHeader::addColumn | ( | const String & | text,
 |  | uint | id,
 |  | float | width
 | ) |

Add a new column segment to the end of the header.

Parameters:
text | String object holding the initial text for the new segment
id | Client specified ID code to be assigned to the new segment.
width | Initial width of the new segment using the relative metrics system
Returns:
Nothing.

virtual ListHeaderSegment* CEGUI::ListHeader::createNewSegment ( const String & name ) const [protected, pure virtual]

Create and return a pointer to a new ListHeaderSegment based object.

Parameters:
name String object holding the name that should be given to the new Window.
Returns:
Pointer to an ListHeaderSegment based object of whatever type is appropriate for this ListHeader.

virtual void CEGUI::ListHeader::destroyListSegment ( ListHeaderSegment * segment ) const [protected, pure virtual]

Cleanup and destroy the given ListHeaderSegment that was created via the createNewSegment method.

Parameters:
segment Pointer to a ListHeaderSegment based object to be destroyed.
Returns:
Nothing.

uint CEGUI::ListHeader::getColumnCount ( void ) const

Return the number of columns or segments attached to the header.

Returns:
uint value equal to the number of columns / segments currently in the header.

uint CEGUI::ListHeader::getColumnFromID ( uint id ) const

Return the zero based column index of the segment with the specified ID.

Parameters:
id ID code of the segment whos column index is to be returned.
Returns:
Zero based column index of the first ListHeaderSegment whos ID matches id.
Exceptions:
InvalidRequestException thrown if no attached segment has the requested ID.

uint CEGUI::ListHeader::getColumnFromSegment ( const ListHeaderSegment & segment ) const

Return the zero based column index of the specified segment.

Parameters:
segment ListHeaderSegment whos zero based index is to be returned.
Returns:
Zero based column index of the ListHeaderSegment segment.
Exceptions:
InvalidRequestException thrown if segment is not attached to this ListHeader.

float CEGUI::ListHeader::getColumnPixelWidth ( uint column ) const

Return the pixel width of the specified column.

Parameters:
column Zero based column index of the segment whos pixel width is to be returned.
Returns:
Pixel width of the ListHeaderSegment at the zero based column index specified by column.
Exceptions:
InvalidRequestException thrown if column is out of range.

uint CEGUI::ListHeader::getColumnWithText ( const String & text ) const

Return the zero based column index of the segment with the specified text.

Parameters:
text String object containing the text to be searched for.
Returns:
Zero based column index of the segment with the specified text.
Exceptions:
InvalidRequestException thrown if no attached segments have the requested text.

float CEGUI::ListHeader::getPixelOffsetToColumn ( uint column ) const

Return the pixel offset to the ListHeaderSegment at the given zero based column index.

Parameters:
column Zero based column index of the ListHeaderSegment whos pixel offset it to be returned.
Returns:
The number of pixels up-to the begining of the ListHeaderSegment located at zero based column index column.
Exceptions:
InvalidRequestException thrown if column is out of range.

float CEGUI::ListHeader::getPixelOffsetToSegment ( const ListHeaderSegment & segment ) const

Return the pixel offset to the given ListHeaderSegment.

Parameters:
segment ListHeaderSegment object that the offset to is to be returned.
Returns:
The number of pixels up-to the begining of the ListHeaderSegment described by segment.
Exceptions:
InvalidRequestException thrown if segment is not attached to the ListHeader.

ListHeaderSegment & CEGUI::ListHeader::getSegmentFromColumn ( uint column ) const

Return the ListHeaderSegment object for the specified column.

Parameters:
column zero based column index of the ListHeaderSegment to be returned.
Returns:
ListHeaderSegment object at the requested index.
Exceptions:
InvalidRequestException thrown if column is out of range.

ListHeaderSegment & CEGUI::ListHeader::getSegmentFromID ( uint id ) const

Return the ListHeaderSegment object with the specified ID.

Parameters:
id id code of the ListHeaderSegment to be returned.
Returns:
ListHeaderSegment object with the ID id. If more than one segment has the same ID, only the first one will ever be returned.
Exceptions:
InvalidRequestException thrown if no segment with the requested ID is attached.

float CEGUI::ListHeader::getSegmentOffset ( void ) const [inline]

Return the current segment offset value. This value is used to implement scrolling of the header segments within the ListHeader area.

Returns:
float value specifying the current segment offset value in whatever metrics system is active for the ListHeader.

uint CEGUI::ListHeader::getSortColumn ( void ) const

Return the zero based index of the current sort column. There must be at least one segment/column to successfully call this method.

Returns:
Zero based column index that is the current sort column.
Exceptions:
InvalidRequestException thrown if there are no segments / columns in this ListHeader.

ListHeaderSegment::SortDirection CEGUI::ListHeader::getSortDirection ( void ) const

Return the currently set sort direction.

Returns:
One of the ListHeaderSegment::SortDirection enumerated values specifying the current sort direction.

ListHeaderSegment & CEGUI::ListHeader::getSortSegment ( void ) const

Return the ListHeaderSegment that is marked as being the 'sort key' segment. There must be at least one segment to successfully call this method.

Returns:
ListHeaderSegment object which is the sort-key segment.
Exceptions:
InvalidRequestException thrown if no segments are attached to the ListHeader.

float CEGUI::ListHeader::getTotalSegmentsPixelExtent ( void ) const

Return the total pixel width of all attached segments.

Returns:
Sum of the pixel widths of all attached ListHeaderSegment objects.

void CEGUI::ListHeader::insertColumn | ( | const String & | text,
 |  | uint | id,
 |  | float | width,
 |  | const ListHeaderSegment & | position
 | ) |

Insert a new column segment at the specified position.

Parameters:
text | String object holding the initial text for the new segment
id | Client specified ID code to be assigned to the new segment.
width | Initial width of the new segment using the relative metrics system
position | ListHeaderSegment object indicating the insert position for the new segment. The new segment will be inserted before the segment indicated by position.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if ListHeaderSegment position is not attached to the ListHeader.

void CEGUI::ListHeader::insertColumn | ( | const String & | text,
 |  | uint | id,
 |  | float | width,
 |  | uint | position
 | ) |

Insert a new column segment at the specified position.

Parameters:
text | String object holding the initial text for the new segment
id | Client specified ID code to be assigned to the new segment.
width | Initial width of the new segment using the relative metrics system
position | Zero based column index indicating the desired position for the new column. If this is greater than the current number of columns, the new segment is added to the end if the header.
Returns:
Nothing.

bool CEGUI::ListHeader::isColumnDraggingEnabled ( void ) const

Return whether the user may modify the order of the segments.

Returns:
true if the user may interactively modify the order of the column segments, false if they may not.

bool CEGUI::ListHeader::isColumnSizingEnabled ( void ) const

Return whether the user may size column segments.

Returns:
true if the user may interactively modify the width of column segments, false if they may not.

bool CEGUI::ListHeader::isSortingEnabled ( void ) const

Return whether user manipulation of the sort column & direction are enabled.

Returns:
true if the user may interactively modify the sort column and direction. false if the user may not modify the sort column and direction (these can still be set programmatically).

void CEGUI::ListHeader::moveColumn | ( | uint | column,
 |  | const ListHeaderSegment & | position
 | ) |

Move a column segment to a new position.

Parameters:
column | Zero based column index indicating the column segment to be moved.
position | ListHeaderSegment object indicating the new position for the segment. The segment at column will be moved behind segment position (that is, segment column will appear to the right of segment position).
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if column is out of range for this ListHeader, or if position is not attached to this ListHeader.

void CEGUI::ListHeader::moveColumn | ( | uint | column,
 |  | uint | position
 | ) |

Moves a column segment into a new position.

Parameters:
column | Zero based column index indicating the column segment to be moved.
position | Zero based column index indicating the new position for the segment. If this is greater than the current number of segments, the segment is moved to the end of the header.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if column is out of range for this ListHeader.

void CEGUI::ListHeader::moveSegment | ( | const ListHeaderSegment & | segment,
 |  | const ListHeaderSegment & | position
 | ) |

Move a segment to a new position.

Parameters:
segment | ListHeaderSegment object that is to be moved.
position | ListHeaderSegment object indicating the new position for the segment. The segment segment will be moved behind segment position (that is, segment segment will appear to the right of segment position).
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if either segment or position are not attached to this ListHeader.

void CEGUI::ListHeader::moveSegment | ( | const ListHeaderSegment & | segment,
 |  | uint | position
 | ) |

Moves a segment into a new position.

Parameters:
segment | ListHeaderSegment object that is to be moved.
position | Zero based column index indicating the new position for the segment. If this is greater than the current number of segments, the segment is moved to the end of the header.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if segment is not attached to this ListHeader.

void CEGUI::ListHeader::removeColumn ( uint column )

Removes a column segment from the ListHeader.

Parameters:
column Zero based column index indicating the segment to be removed.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if column is out of range.

void CEGUI::ListHeader::removeSegment ( const ListHeaderSegment & segment )

Remove the specified segment from the ListHeader.

Parameters:
segment ListHeaderSegment object that is to be removed from the ListHeader.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if segment is not attached to this ListHeader.

void CEGUI::ListHeader::setColumnDraggingEnabled ( bool setting )

Set whether columns may be reordered by the user via drag and drop.

Parameters:
setting
  • true to indicate the user may change the order of the column segments via drag and drop.
  • false to indicate the user may not change the column segment order.
Returns:
Nothing.

void CEGUI::ListHeader::setColumnPixelWidth | ( | uint | column,
 |  | float | width
 | ) |

Set the pixel width of the specified column.

Parameters:
column | Zero based column index of the segment whos pixel width is to be set.
width | float value specifying the new pixel width to set for the ListHeaderSegment at the zero based column index specified by column.
Returns:
Nothing
Exceptions:
InvalidRequestException thrown if column is out of range.

void CEGUI::ListHeader::setColumnSizingEnabled ( bool setting )

Set whether columns may be sized by the user.

Parameters:
setting
  • true to indicate that the user may interactively size segments.
  • false to indicate that the user may not interactively size segments.
Returns:
Nothing.

void CEGUI::ListHeader::setSegmentOffset ( float offset )

Set the current base segment offset. (This implements scrolling of the header segments within the header area).

Parameters:
offset New base offset for the first segment. The segments will of offset to the left by the amount specified. offset should be specified using the active metrics system for the ListHeader.
Returns:
Nothing.

void CEGUI::ListHeader::setSortColumn ( uint column )

Set the column to be used as the sort column.

Parameters:
column Zero based column index indicating the column to be sorted.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if column is out of range for this ListHeader.

void CEGUI::ListHeader::setSortColumnFromID ( uint id )

Set the column to to be used for sorting via its ID code.

Parameters:
id ID code of the column segment that is to be used as the sort column.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if no segment with ID id is attached to the ListHeader.

void CEGUI::ListHeader::setSortDirection ( ListHeaderSegment::SortDirection direction )

Set the current sort direction.

Parameters:
direction One of the ListHeaderSegment::SortDirection enumerated values indicating the sort direction to be used.
Returns:
Nothing.

void CEGUI::ListHeader::setSortingEnabled ( bool setting )

Set whether user manipulation of the sort column and direction is enabled.

Parameters:
setting
  • true to allow interactive user manipulation of the sort column and direction.
  • false to disallow interactive user manipulation of the sort column and direction.
Returns:
Nothing.

void CEGUI::ListHeader::setSortSegment ( const ListHeaderSegment & segment )

Set the column segment to be used as the sort column.

Parameters:
segment ListHeaderSegment object indicating the column to be sorted.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if segment is not attached to this ListHeader.

virtual bool CEGUI::ListHeader::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderSegment Class Reference

CEGUI::ListHeaderSegment

CEGUI::ListHeaderSegment Class Reference

Base class for list header segment window. More...

Inheritance diagram for CEGUI::ListHeaderSegment:

[legend]
Collaboration diagram for CEGUI::ListHeaderSegment:

[legend]
List of all members.

Public Types

enum | SortDirection { None, Ascending, Descending }
Enumeration of possible values for sorting direction used with ListHeaderSegment classes. More...

Public Member Functions

bool | isSizingEnabled (void) const
Return whether this segment can be sized.
SortDirection | getSortDirection (void) const
Return the current sort direction set for this segment.
bool | isDragMovingEnabled (void) const
Return whether drag moving is enabled for this segment.
const Point & | getDragMoveOffset (void) const
Return the current drag move position offset (in pixels relative to the top-left corner of the segment).
bool | isClickable (void) const
Return whether the segment is clickable.
void | setSizingEnabled (bool setting)
Set whether this segment can be sized.
void | setSortDirection (SortDirection sort_dir)
Set the current sort direction set for this segment.
void | setDragMovingEnabled (bool setting)
Set whether drag moving is allowed for this segment.
void | setClickable (bool setting)
Set whether the segment is clickable.
ListHeaderSegment (const String &type, const String &name)
Constructor for list header segment base class.
virtual | ~ListHeaderSegment (void)
Destructor for list header segment base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventSegmentClicked
Event fired when the segment is clicked.
static const String | EventSplitterDoubleClicked
Event fired when the sizer/splitter is double-clicked.
static const String | EventSizingSettingChanged
Event fired when the sizing setting changes.
static const String | EventSortDirectionChanged
Event fired when the sort direction value changes.
static const String | EventMovableSettingChanged
Event fired when the movable setting changes.
static const String | EventSegmentDragStart
Event fired when the segment has started to be dragged.
static const String | EventSegmentDragStop
Event fired when segment dragging has stopped (via mouse release).
static const String | EventSegmentDragPositionChanged
Event fired when the segment drag position has changed.
static const String | EventSegmentSized
Event fired when the segment is sized.
static const String | EventClickableSettingChanged
Event fired when the clickable state of the segment changes.
static const float | DefaultSizingArea = 8.0f
Default size of the sizing area.
static const float | SegmentMoveThreshold = 12.0f
Amount the mouse must be dragged before drag-moving is initiated.

Protected Member Functions

void | addHeaderSegmentEvents (void)
Add list header segment specific events.
void | doDragSizing (const Point &local_mouse)
Update state for drag sizing.
void | doDragMoving (const Point &local_mouse)
Update state for drag moving.
void | initDragMoving (void)
Initialise the required states to put the widget into drag-moving mode.
void | initSizingHoverState (void)
Initialise the required states when we are hovering over the sizing area.
void | initSegmentHoverState (void)
Initialise the required states when we are hovering over the main segment area.
bool | isDragMoveThresholdExceeded (const Point &local_mouse)
Return whether the required minimum movement threshold before initiating drag-moving has been exceeded.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onSegmentClicked (WindowEventArgs &e)
Handler called when segment is clicked.
virtual void | onSplitterDoubleClicked (WindowEventArgs &e)
Handler called when the sizer/splitter is double-clicked.
virtual void | onSizingSettingChanged (WindowEventArgs &e)
Handler called when sizing setting changes.
virtual void | onSortDirectionChanged (WindowEventArgs &e)
Handler called when the sort direction value changes.
virtual void | onMovableSettingChanged (WindowEventArgs &e)
Handler called when the drag-movable setting is changed.
virtual void | onSegmentDragStart (WindowEventArgs &e)
Handler called when the user starts dragging the segment.
virtual void | onSegmentDragStop (WindowEventArgs &e)
Handler called when the user stops dragging the segment (releases mouse button).
virtual void | onSegmentDragPositionChanged (WindowEventArgs &e)
Handler called when the drag position changes.
virtual void | onSegmentSized (WindowEventArgs &e)
Handler called when the segment is sized.
virtual void | onClickableSettingChanged (WindowEventArgs &e)
Handler called when the clickable setting for the segment changes.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onMouseDoubleClicked (MouseEventArgs &e)
Handler called when a mouse button has been double-clicked within this window's area.
virtual void | onMouseLeaves (MouseEventArgs &e)
Handler called when the mouse cursor has left this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.

Protected Attributes

const Image * | d_sizingMouseCursor
Image to use for mouse when sizing (typically set by derived class).
const Image * | d_movingMouseCursor
Image to use for mouse when moving (typically set by derived class).
float | d_splitterSize
pixel width of the sizing area.
bool | d_splitterHover
True if the mouse is over the splitter.
bool | d_dragSizing
true when we are being sized.
Point d_dragPoint
point we are being dragged at when sizing or moving.
SortDirection d_sortDir
Direction for sorting (used for deciding what icon to display).
bool | d_segmentHover
true when the mouse is within the segment area (and not in sizing area).
bool | d_segmentPushed
true when the left mouse button has been pressed within the confines of the segment.
bool | d_sizingEnabled
true when sizing is enabled for this segment.
bool | d_movingEnabled
True when drag-moving is enabled for this segment;.
bool | d_dragMoving
true when segment is being drag moved.
Point d_dragPosition
position of dragged segment.
bool | d_allowClicks
true if the segment can be clicked.

Detailed Description

Base class for list header segment window.

Member Enumeration Documentation

enum CEGUI::ListHeaderSegment::SortDirection

Enumeration of possible values for sorting direction used with ListHeaderSegment classes.

Enumerator:
None | Items under this segment should not be sorted.
Ascending | Items under this segment should be sorted in ascending order.
Descending | Items under this segment should be sorted in descending order.

Member Function Documentation

void CEGUI::ListHeaderSegment::doDragMoving ( const Point & local_mouse ) [protected]

Update state for drag moving.

Parameters:
local_mouse Mouse position as a pixel offset from the top-left corner of this window.
Returns:
Nothing.

void CEGUI::ListHeaderSegment::doDragSizing ( const Point & local_mouse ) [protected]

Update state for drag sizing.

Parameters:
local_mouse Mouse position as a pixel offset from the top-left corner of this window.
Returns:
Nothing.

const Point& CEGUI::ListHeaderSegment::getDragMoveOffset ( void ) const [inline]

Return the current drag move position offset (in pixels relative to the top-left corner of the segment).

Returns:
Point object describing the drag move offset position.

SortDirection CEGUI::ListHeaderSegment::getSortDirection ( void ) const [inline]

Return the current sort direction set for this segment.

Note that this has no impact on the way the segment functions (aside from the possibility of varied rendering). This is intended as a 'helper setting' to classes that make use of the ListHeaderSegment objects.

Returns:
One of the SortDirection enumerated values indicating the current sort direction set for this segment.

bool CEGUI::ListHeaderSegment::isClickable ( void ) const [inline]

Return whether the segment is clickable.

Returns:
true if the segment can be clicked, false of the segment can not be clicked (so no highlighting or events will happen).

bool CEGUI::ListHeaderSegment::isDragMoveThresholdExceeded ( const Point & local_mouse ) [protected]

Return whether the required minimum movement threshold before initiating drag-moving has been exceeded.

Parameters:
local_mouse Mouse position as a pixel offset from the top-left corner of this window.
Returns:
true if the threshold has been exceeded and drag-moving should be initiated, or false if the threshold has not been exceeded.

bool CEGUI::ListHeaderSegment::isDragMovingEnabled ( void ) const [inline]

Return whether drag moving is enabled for this segment.

Returns:
true if the segment can be drag moved, false if the segment can not be drag moved.

bool CEGUI::ListHeaderSegment::isSizingEnabled ( void ) const [inline]

Return whether this segment can be sized.

Returns:
true if the segment can be horizontally sized, false if the segment can not be horizontally sized.

void CEGUI::ListHeaderSegment::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::ListHeaderSegment::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ListHeaderSegment::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ListHeaderSegment::onMouseDoubleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been double-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ListHeaderSegment::onMouseLeaves ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has left this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ListHeaderSegment::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ListHeaderSegment::setClickable ( bool setting )

Set whether the segment is clickable.

Parameters:
setting true if the segment may be clicked, false of the segment may not be clicked (so no highlighting or events will happen).
Returns:
Nothing.

void CEGUI::ListHeaderSegment::setDragMovingEnabled ( bool setting )

Set whether drag moving is allowed for this segment.

Parameters:
setting true if the segment may be drag moved, false if the segment may not be drag moved.
Returns:
Nothing.

void CEGUI::ListHeaderSegment::setSizingEnabled ( bool setting )

Set whether this segment can be sized.

Parameters:
setting true if the segment may be horizontally sized, false if the segment may not be horizontally sized.
Returns:
Nothing.

void CEGUI::ListHeaderSegment::setSortDirection ( SortDirection sort_dir )

Set the current sort direction set for this segment.

Note that this has no impact on the way the segment functions (aside from the possibility of varied rendering). This is intended as a 'helper setting' to classes that make use of the ListHeaderSegment objects.

Parameters:
sort_dir One of the SortDirection enumerated values indicating the current sort direction set for this segment.
Returns:
Nothing

virtual bool CEGUI::ListHeaderSegment::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Logger Class Reference

CEGUI::Logger

CEGUI::Logger Class Reference

Class that implements logging for the GUI system. More...

List of all members.

Public Member Functions

Logger (void)
Constructor for Logger object.
~Logger (void)
Destructor for Logger object.
void | setLoggingLevel (LoggingLevel level)
Set the level of logging information that will get out to the log file.
LoggingLevel | getLoggingLevel (void) const
return the current logging level setting
void | logEvent (const String &message, LoggingLevel level=Standard)
Add an event to the log.
void | setLogFilename (const String &filename, bool append=false)
Set the name of the log file where all subsequent log entries should be written.

Static Public Member Functions

static Logger & | getSingleton (void)
Return the singleton Logger object.

Protected Attributes

LoggingLevel d_level
Holds current logging level.
std::ofstream | d_ostream
Stream used to implement the logger.
std::vector< std::pair< String,
LoggingLevel > > 		d_cache
Used to cache log entries before log file is created.
std::ostringstream | d_workstream
Used to build log entry strings.
bool | d_caching
true while log entries are beign cached (prior to logfile creation)

Detailed Description

Class that implements logging for the GUI system.

Member Function Documentation

LoggingLevel CEGUI::Logger::getLoggingLevel ( void ) const [inline]

return the current logging level setting

Returns:
One of the LoggingLevel enumerated values specifying the current level of logging

Logger & CEGUI::Logger::getSingleton ( void ) [static]

Return the singleton Logger object.

Returns:
Reference to the one and only Logger object

void CEGUI::Logger::logEvent | ( | const String & | message,
 |  | LoggingLevel | level = Standard
 | ) |

Add an event to the log.

Parameters:
message | String object containing the message to be added to the event log.
level | LoggingLevel for this message. If level is greater than the current set logging level, the message is not logged.
Returns:
Nothing

void CEGUI::Logger::setLogFilename | ( | const String & | filename,
 |  | bool | append = false
 | ) |

Set the name of the log file where all subsequent log entries should be written.

Note:
When this is called, and the log file is created, any cached log entries are flushed to the log file.
Parameters:
filename Name of the file to put log messages.
append
  • true if events should be added to the end of the current file.
  • false if the current contents of the file should be discarded.

void CEGUI::Logger::setLoggingLevel ( LoggingLevel level ) [inline]

Set the level of logging information that will get out to the log file.

Parameters:
level One of the LoggingLevel enumerated values that specified the level of logging information required.
Returns:
Nothing

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::MaskCodepoint Class Reference

CEGUI::EditboxProperties::MaskCodepoint

CEGUI::EditboxProperties::MaskCodepoint Class Reference

Property to access the mask text setting of the edit box. More...

Inheritance diagram for CEGUI::EditboxProperties::MaskCodepoint:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::MaskCodepoint:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the mask text setting of the edit box.

This property offers access to the mask text setting for the Editbox object.

Usage:
  • Name: MaskCodepoint
  • Format: "[uint]"
Where:
  • [uint] is the Unicode utf32 value of the codepoint used for masking text.

Member Function Documentation

String CEGUI::EditboxProperties::MaskCodepoint::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::MaskCodepoint::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::MaskText Class Reference

CEGUI::EditboxProperties::MaskText

CEGUI::EditboxProperties::MaskText Class Reference

Property to access the mask text setting of the edit box. More...

Inheritance diagram for CEGUI::EditboxProperties::MaskText:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::MaskText:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the mask text setting of the edit box.

This property offers access to the mask text setting for the Editbox object.

Usage:
  • Name: MaskText
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the text should be masked.
  • "False" to indicate the text should not be masked.

Member Function Documentation

String CEGUI::EditboxProperties::MaskText::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::MaskText::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::MaxEditTextLength Class Reference

CEGUI::ComboboxProperties::MaxEditTextLength

CEGUI::ComboboxProperties::MaxEditTextLength Class Reference

Property to access the maximum text length for the edit box. More...

Inheritance diagram for CEGUI::ComboboxProperties::MaxEditTextLength:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::MaxEditTextLength:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the maximum text length for the edit box.

Usage:
  • Name: MaxEditTextLength
  • Format: "[uint]"
Where:
  • [uint] is the maximum allowed text length (as a count of code points).

Member Function Documentation

String CEGUI::ComboboxProperties::MaxEditTextLength::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::MaxEditTextLength::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SliderProperties::MaximumValue Class Reference

CEGUI::SliderProperties::MaximumValue

CEGUI::SliderProperties::MaximumValue Class Reference

Property to access the maximum value of the slider. More...

Inheritance diagram for CEGUI::SliderProperties::MaximumValue:

[legend]
Collaboration diagram for CEGUI::SliderProperties::MaximumValue:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the maximum value of the slider.

Usage:
  • Name: MaximumValue
  • Format: "[float]".
Where:
  • [float] represents the maximum value of the slider.

Member Function Documentation

String CEGUI::SliderProperties::MaximumValue::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SliderProperties::MaximumValue::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SpinnerProperties::MaximumValue Class Reference

CEGUI::SpinnerProperties::MaximumValue

CEGUI::SpinnerProperties::MaximumValue Class Reference

Property to access the maximum value setting of the spinner. More...

Inheritance diagram for CEGUI::SpinnerProperties::MaximumValue:

[legend]
Collaboration diagram for CEGUI::SpinnerProperties::MaximumValue:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the maximum value setting of the spinner.

Usage:
  • Name: MaximumValue
  • Format: "[float]".
Where:
  • [float] represents the current maximum value of the Spinner widget.

Member Function Documentation

String CEGUI::SpinnerProperties::MaximumValue::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SpinnerProperties::MaximumValue::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::MaxTextLength Class Reference

CEGUI::MultiLineEditboxProperties::MaxTextLength

CEGUI::MultiLineEditboxProperties::MaxTextLength Class Reference

Property to access the maximum text length for the edit box. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::MaxTextLength:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::MaxTextLength:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the maximum text length for the edit box.

Usage:
  • Name: MaxTextLength
  • Format: "[uint]"
Where:
  • [uint] is the maximum allowed text length (as a count of code points).

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::MaxTextLength::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::MaxTextLength::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::MaxTextLength Class Reference

CEGUI::EditboxProperties::MaxTextLength

CEGUI::EditboxProperties::MaxTextLength Class Reference

Property to access the maximum text length for the edit box. More...

Inheritance diagram for CEGUI::EditboxProperties::MaxTextLength:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::MaxTextLength:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the maximum text length for the edit box.

Usage:
  • Name: MaxTextLength
  • Format: "[uint]"
Where:
  • [uint] is the maximum allowed text length (as a count of code points).

Member Function Documentation

String CEGUI::EditboxProperties::MaxTextLength::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::MaxTextLength::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MCLGridRef Struct Reference

CEGUI::MCLGridRef

CEGUI::MCLGridRef Struct Reference

Simple grid index structure. More...

List of all members.

Public Member Functions

MCLGridRef (uint r, uint c)
MCLGridRef & | operator= (const MCLGridRef &rhs)
bool | operator< (const MCLGridRef &rhs) const
bool | operator<= (const MCLGridRef &rhs) const
bool | operator> (const MCLGridRef &rhs) const
bool | operator>= (const MCLGridRef &rhs) const
bool | operator== (const MCLGridRef &rhs) const
bool | operator!= (const MCLGridRef &rhs) const

Public Attributes

uint | row
Zero based row index.
uint | column
Zero based column index.

Detailed Description

Simple grid index structure.

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MemoryException Class Reference

CEGUI::MemoryException

CEGUI::MemoryException Class Reference

Exception class used when a memory handling error is detected. More...

Inheritance diagram for CEGUI::MemoryException:

[legend]
Collaboration diagram for CEGUI::MemoryException:

[legend]
List of all members.

Public Member Functions

MemoryException (const String &message)

Detailed Description

Exception class used when a memory handling error is detected.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Menubar Class Reference

CEGUI::Menubar

CEGUI::Menubar Class Reference

Base class for menu bars. More...

Inheritance diagram for CEGUI::Menubar:

[legend]
Collaboration diagram for CEGUI::Menubar:

[legend]
List of all members.

Public Member Functions

Menubar (const String &type, const String &name)
Constructor for Menubar objects.
virtual | ~Menubar (void)
Destructor for Menubar objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.

Protected Member Functions

virtual void | layoutItemWidgets ()
Setup size and position for the item widgets attached to this Menubar.
virtual Size | getContentSize ()
Resizes the menubar to exactly fit the content that is attached to it.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Detailed Description

Base class for menu bars.

Member Function Documentation

Size CEGUI::Menubar::getContentSize ( ) [protected, virtual]

Resizes the menubar to exactly fit the content that is attached to it.

Returns:
Nothing.

Implements CEGUI::ItemListBase.

void CEGUI::Menubar::layoutItemWidgets ( ) [protected, virtual]

Setup size and position for the item widgets attached to this Menubar.

Returns:
Nothing.

Implements CEGUI::ItemListBase.

virtual bool CEGUI::Menubar::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::MenuBase.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBase Class Reference

CEGUI::MenuBase

CEGUI::MenuBase Class Reference

Abstract base class for menus. More...

Inheritance diagram for CEGUI::MenuBase:

[legend]
Collaboration diagram for CEGUI::MenuBase:

[legend]
List of all members.

Public Member Functions

float | getItemSpacing (void) const
Get the item spacing for this menu.
float | getHorzPadding (void) const
Get the horizontal padding for this menu's items.
float | getVertPadding (void) const
Get the vertical padding for this menu's items.
float | getBorderWidth (void) const
Get the border width for this menu.
const ColourRect & | getBackgroundColours (void) const
Get the ColourRect with the colours used for rendering the background of this menu.
bool | isMultiplePopupsAllowed (void) const
Return whether this menu allows multiple popup menus to open at the same time.
MenuItem * | getPopupMenuItem (void) const
Get currently opened MenuItem in this menu. Returns NULL if menu item is open.
void | setItemSpacing (float spacing)
Set the item spacing for this menu.
void | setHorzPadding (float padding)
Set the horizontal padding for this menu's items.
void | setVertPadding (float padding)
Set the vertical padding for this menu's items.
void | setBorderWidth (float border)
Set the border width for this menu.
void | setBackgroundColours (const ColourRect &cr)
Set the background colours to used when rendereing this menu.
void | changePopupMenuItem (MenuItem *item)
Change the currently open MenuItem in this menu.
void | setAllowMultiplePopups (bool setting)
Set whether this menu allows multiple popup menus to opened simultaneously.
MenuBase (const String &type, const String &name)
Constructor for MenuBase objects.
virtual | ~MenuBase (void)
Destructor for MenuBase objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const colour | DefaultBackgroundColour = 0xFFFFFFFF
Default background colour.
static const String | EventPopupOpened
A MenuItem attached to this menu opened a PopupMenu.
static const String | EventPopupClosed
A MenuItem attached to this menu opened a PopupMenu.

Protected Member Functions

virtual void | onPopupOpened (WindowEventArgs &e)
handler invoked internally when the a MenuItem attached to this menu opens its popup.
virtual void | onPopupClosed (WindowEventArgs &e)
handler invoked internally when the a MenuItem attached to this menu closes its popup.
void | addMenuBaseEvents (void)
Add MenuBase specific events.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

float | d_itemSpacing
The spacing in pixels between items.
float | d_horzPadding
The width in pixels that is added to the left and right of each item.
float | d_vertPadding
The height in pixels that is added to the top and bottom of each item.
float | d_borderWidth
The width in pixels of the border around the entire content of this menu.
ColourRect d_backgroundColours
The colours used when rendering the background of this menu.
MenuItem * d_popup
The currently open MenuItem. NULL if no item is open. If multiple popups are allowed, this means nothing.
bool | d_allowMultiplePopups
true if multiple popup menus are allowed smultaneously. false if not.

Detailed Description

Abstract base class for menus.

Member Function Documentation

void CEGUI::MenuBase::changePopupMenuItem ( MenuItem * item )

Change the currently open MenuItem in this menu.

Parameters:
item Pointer to a MenuItem to open or NULL to close any opened.

const ColourRect& CEGUI::MenuBase::getBackgroundColours ( void ) const [inline]

Get the ColourRect with the colours used for rendering the background of this menu.

Returns:
A ColourRect with the colours used for rendering the background of this menu.

float CEGUI::MenuBase::getBorderWidth ( void ) const [inline]

Get the border width for this menu.

Returns:
A float value with the current border width for this menu.

float CEGUI::MenuBase::getHorzPadding ( void ) const [inline]

Get the horizontal padding for this menu's items.

Returns:
A float value with the current horizontal padding for this menu's items.

float CEGUI::MenuBase::getItemSpacing ( void ) const [inline]

Get the item spacing for this menu.

Returns:
A float value with the current item spacing for this menu

MenuItem* CEGUI::MenuBase::getPopupMenuItem ( void ) const [inline]

Get currently opened MenuItem in this menu. Returns NULL if menu item is open.

Returns:
Pointer to the MenuItem currently open.

float CEGUI::MenuBase::getVertPadding ( void ) const [inline]

Get the vertical padding for this menu's items.

Returns:
A float value with the current vertical padding for this menu's items.

bool CEGUI::MenuBase::isMultiplePopupsAllowed ( void ) const [inline]

Return whether this menu allows multiple popup menus to open at the same time.

Returns:
true if this menu allows multiple popup menus to be opened simultaneously. false if not

virtual bool CEGUI::MenuBase::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::ItemListBase.

Reimplemented in CEGUI::Menubar, and CEGUI::PopupMenu.

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuItem Class Reference

CEGUI::MenuItem

CEGUI::MenuItem Class Reference

Base class for menu items. More...

Inheritance diagram for CEGUI::MenuItem:

[legend]
Collaboration diagram for CEGUI::MenuItem:

[legend]
List of all members.

Public Member Functions

bool | isHovering (void) const
return true if user is hovering over this widget (or it's pushed and user is not over it for highlight)
bool | isPushed (void) const
Return true if the button widget is in the pushed state.
colour | getHoverColour (void) const
return text label colour used for hover / highlight rendering
colour | getPushedColour (void) const
return text label colour used for pushed rendering
colour | getOpenedColour (void) const
return text label colour used for opened rendering
colour | getNormalTextColour (void) const
return text label colour used for normal rendering
colour | getDisabledTextColour (void) const
return text label colour used for disabled rendering
PopupMenu * | getPopupMenu (void) const
Get the PopupMenu that is currently attached to this MenuItem.
void | setHoverColour (const colour &colour)
Set the colour to use when rendering in the hover / highlighted states.
void | setPushedColour (const colour &colour)
Set the colour to use when rendering in the pushed state.
void | setOpenedColour (const colour &colour)
Set the colour to use when rendering in the opened state.
void | setNormalTextColour (const colour &colour)
Set the colour to use for the label text when rendering in the normal state.
void | setDisabledTextColour (const colour &colour)
Set the colour to use for the label text when rendering in the disabled state.
void | setPopupMenu (PopupMenu *popup)
Set the popup menu for this item.
void | openPopupMenu (void)
Opens the PopupMenu.
void | closePopupMenu (bool notify=true)
Closes the PopupMenu.
bool | togglePopupMenu (void)
Toggles the PopupMenu.
MenuItem (const String &type, const String &name)
Constructor for MenuItem objects.
virtual | ~MenuItem (void)
Destructor for MenuItem objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const colour | DefaultHoverColour = 0xFFFFFFFF
Default colour used when rendering in hover / highlight state.
static const colour | DefaultPushedColour = 0xFFFFFFFF
Default colour used when rendering in pushed state.
static const colour | DefaultOpenedColour = 0xFFEFEFEF
Default colour used when rendering in opended state.
static const colour | DefaultNormalTextColour = 0xFFFFFFFF
Default colour used when rendering the text in normal state.
static const colour | DefaultDisabledTextColour = 0xFF7F7F7F
Default colour used when rendering the text in disabled state.
static const String | EventClicked
The menuitem was clicked.

Protected Member Functions

virtual void | onClicked (WindowEventArgs &e)
handler invoked internally when the MenuItem is clicked.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onMouseLeaves (MouseEventArgs &e)
Handler called when the mouse cursor has left this window's area.
void | updateInternalState (const Point &mouse_pos)
Update the internal state of the widget with the mouse at the given position.
void | addMenuItemEvents (void)
Add menuitem specific events.
void | closeAllMenuItemPopups ()
Recursive function that closes all popups down the hierarcy starting with this one.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

bool | d_pushed
true when widget is pushed
bool | d_hovering
true when the button is in 'hover' state and requires the hover rendering.
bool | d_opened
true when the menu item's popup menu is opened.
colour d_hoverColour
Colour used when rendering in highlighted state.
colour d_pushedColour
Colour used when rendering in pushed state.
colour d_openedColour
Colour used when rendering in opened state.
colour d_normalTextColour
Colour used for the text when rendering in normal state.
colour d_disabledTextColour
Colour used for the text when rendering in disabled state.
PopupMenu * d_popup
PopupMenu that this item displays when activated.
bool | d_popupWasClosed
Used internally to determine if a popup was just closed on a Clicked event.

Detailed Description

Base class for menu items.

Member Function Documentation

void CEGUI::MenuItem::closeAllMenuItemPopups ( ) [protected]

Recursive function that closes all popups down the hierarcy starting with this one.

Returns:
Nothing.

void CEGUI::MenuItem::closePopupMenu ( bool notify = true )

Closes the PopupMenu.

Parameters:
notify true if the parent menubar is to be notified of the close.
Returns:
Nothing.

colour CEGUI::MenuItem::getDisabledTextColour ( void ) const [inline]

return text label colour used for disabled rendering

Returns:
colour value that is used for the label text when rendering in the disabled state.

colour CEGUI::MenuItem::getHoverColour ( void ) const [inline]

return text label colour used for hover / highlight rendering

Returns:
colour value that is used for the label text when rendering in the hover / highlighted states.

colour CEGUI::MenuItem::getNormalTextColour ( void ) const [inline]

return text label colour used for normal rendering

Returns:
colour value that is used for the label text when rendering in the normal state.

colour CEGUI::MenuItem::getOpenedColour ( void ) const [inline]

return text label colour used for opened rendering

Returns:
colour value that is used for the label text when rendering in the opened state.

PopupMenu* CEGUI::MenuItem::getPopupMenu ( void ) const [inline]

Get the PopupMenu that is currently attached to this MenuItem.

Returns:
A pointer to the currently attached PopupMenu. Null is there is no PopupMenu attached.

colour CEGUI::MenuItem::getPushedColour ( void ) const [inline]

return text label colour used for pushed rendering

Returns:
colour value that is used for the label text when rendering in the pushed state.

bool CEGUI::MenuItem::isHovering ( void ) const [inline]

return true if user is hovering over this widget (or it's pushed and user is not over it for highlight)

Returns:
true if the user is hovering or if the button is pushed and the mouse is not over the button. Otherwise return false.

bool CEGUI::MenuItem::isPushed ( void ) const [inline]

Return true if the button widget is in the pushed state.

Returns:
true if the button-type widget is pushed, false if the widget is not pushed.

void CEGUI::MenuItem::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::MenuItem::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MenuItem::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MenuItem::onMouseLeaves ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has left this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MenuItem::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MenuItem::setDisabledTextColour ( const colour & colour )

Set the colour to use for the label text when rendering in the disabled state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::MenuItem::setHoverColour ( const colour & colour )

Set the colour to use when rendering in the hover / highlighted states.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::MenuItem::setNormalTextColour ( const colour & colour )

Set the colour to use for the label text when rendering in the normal state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::MenuItem::setOpenedColour ( const colour & colour )

Set the colour to use when rendering in the opened state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

void CEGUI::MenuItem::setPopupMenu ( PopupMenu * popup )

Set the popup menu for this item.

Parameters:
popup popupmenu window to attach to this item
Returns:
Nothing.

void CEGUI::MenuItem::setPushedColour ( const colour & colour )

Set the colour to use when rendering in the pushed state.

Parameters:
colour colour value specifying the colour to be used.
Returns:
Nothing.

virtual bool CEGUI::MenuItem::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::TextItem.

bool CEGUI::MenuItem::togglePopupMenu ( void )

Toggles the PopupMenu.

Returns:
true if the popup was opened. false if it was closed.

void CEGUI::MenuItem::updateInternalState ( const Point & mouse_pos ) [protected]

Update the internal state of the widget with the mouse at the given position.

Parameters:
mouse_pos Point object describing, in screen pixel co-ordinates, the location of the mouse cursor.
Returns:
Nothing

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::MetricsMode Class Reference

CEGUI::WindowProperties::MetricsMode

CEGUI::WindowProperties::MetricsMode Class Reference

Property to access the metrics mode setting. More...

Inheritance diagram for CEGUI::WindowProperties::MetricsMode:

[legend]
Collaboration diagram for CEGUI::WindowProperties::MetricsMode:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the metrics mode setting.

This property offers access to the metrics mode setting for the window.

Usage:
  • Name: MetricsMode
  • Format: "[text]".
Where [text] is:
  • "Relative" for the relative metrics mode.
  • "Absolute" for the absolute metrics mode.
  • "Inherited" if metrics should be inherited from the parent (only used with set method).

Member Function Documentation

String CEGUI::WindowProperties::MetricsMode::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::MetricsMode::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SpinnerProperties::MinimumValue Class Reference

CEGUI::SpinnerProperties::MinimumValue

CEGUI::SpinnerProperties::MinimumValue Class Reference

Property to access the minimum value setting of the spinner. More...

Inheritance diagram for CEGUI::SpinnerProperties::MinimumValue:

[legend]
Collaboration diagram for CEGUI::SpinnerProperties::MinimumValue:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the minimum value setting of the spinner.

Usage:
  • Name: MinimumValue
  • Format: "[float]".
Where:
  • [float] represents the current minimum value of the Spinner widget.

Member Function Documentation

String CEGUI::SpinnerProperties::MinimumValue::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SpinnerProperties::MinimumValue::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::MouseButtonDownAutoRepeat Class Reference

CEGUI::WindowProperties::MouseButtonDownAutoRepeat

CEGUI::WindowProperties::MouseButtonDownAutoRepeat Class Reference

Property to control whether the window will receive autorepeat mouse button down events. More...

Inheritance diagram for CEGUI::WindowProperties::MouseButtonDownAutoRepeat:

[legend]
Collaboration diagram for CEGUI::WindowProperties::MouseButtonDownAutoRepeat:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to control whether the window will receive autorepeat mouse button down events.

This property offers access to the setting that controls whether a window will receive autorepeat mouse button down events.

Usage:
  • Name: MouseButtonDownAutoRepeat
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window will receive autorepeat mouse button down events.
  • "False" to indicate the Window will not receive autorepeat mouse button down events.

Member Function Documentation

String CEGUI::WindowProperties::MouseButtonDownAutoRepeat::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::MouseButtonDownAutoRepeat::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MouseClickTracker Struct Reference

CEGUI::MouseClickTracker

CEGUI::MouseClickTracker Struct Reference

Implementation structure used in tracking up & down mouse button inputs in order to generate click, double-click, and triple-click events. More...

Collaboration diagram for CEGUI::MouseClickTracker:

[legend]
List of all members.

Public Attributes

SimpleTimer d_timer
Timer used to track clicks for this button.
int d_click_count
count of clicks made so far.
Rect d_click_area
area used to detect multi-clicks
Window * d_target_window
target window for any events generated.

Detailed Description

Implementation structure used in tracking up & down mouse button inputs in order to generate click, double-click, and triple-click events.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MouseCursor Class Reference

CEGUI::MouseCursor

CEGUI::MouseCursor Class Reference

Class that allows access to the GUI system mouse cursor. More...

Inheritance diagram for CEGUI::MouseCursor:

[legend]
Collaboration diagram for CEGUI::MouseCursor:

[legend]
List of all members.

Public Member Functions

MouseCursor (void)
Constructor for MouseCursor objects.
~MouseCursor (void)
Destructor for MouseCursor objects.
void | setImage (const String &imageset, const String &image_name)
Set the current mouse cursor image.
void | setImage (const Image *image)
Set the current mouse cursor image.
const Image * | getImage (void) const
Get the current mouse cursor image.
void | draw (void) const
Makes the cursor draw itself.
void | setPosition (const Point &position)
Set the current mouse cursor position.
void | offsetPosition (const Point &offset)
Offset the mouse cursor position by the deltas specified in offset.
void | setConstraintArea (const Rect *area)
Set the area that the mouse cursor is constrained to.
void | setUnifiedConstraintArea (const URect *area)
Set the area that the mouse cursor is constrained to.
void | hide (void)
Hides the mouse cursor.
void | show (void)
Shows the mouse cursor.
bool | isVisible (void) const
return whether the mouse cursor is visible.
Point | getPosition (void) const
Return the current mouse cursor position as a pixel offset from the top-left corner of the display.
Rect | getConstraintArea (void) const
return the current constraint area of the mouse cursor.
const URect & | getUnifiedConstraintArea (void) const
return the current constraint area of the mouse cursor.
Point | getDisplayIndependantPosition (void) const
Return the current mouse cursor position as display resolution independant values.

Static Public Member Functions

static MouseCursor & | getSingleton (void)
Return singleton MouseCursor object.
static MouseCursor * | getSingletonPtr (void)
Return pointer to singleton MouseCursor object.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventImageChanged
The cursor image of the widget has changed.

Protected Member Functions

virtual void | onImageChanged (MouseCursorEventArgs &e)
event triggered internally when image of mouse cursor changes
void | addMouseCursorEvents (void)
Add mouse cursor specific events.

Detailed Description

Class that allows access to the GUI system mouse cursor.

The MouseCursor provides functionality to access the position and imagery of the mouse cursor / pointer

Member Function Documentation

void CEGUI::MouseCursor::draw ( void ) const

Makes the cursor draw itself.

Returns:
Nothing

Rect CEGUI::MouseCursor::getConstraintArea ( void ) const

return the current constraint area of the mouse cursor.

Returns:
Rect object describing the active area that the mouse cursor is constrained to.

Point CEGUI::MouseCursor::getDisplayIndependantPosition ( void ) const

Return the current mouse cursor position as display resolution independant values.

Returns:
Point object describing the current mouse cursor position as resolution independant values that range from 0.0f to 1.0f, where 0.0f represents the left-most and top-most positions, and 1.0f represents the right-most and bottom-most positions.

const Image* CEGUI::MouseCursor::getImage ( void ) const [inline]

Get the current mouse cursor image.

Returns:
The current image used to draw mouse cursor.

Point CEGUI::MouseCursor::getPosition ( void ) const [inline]

Return the current mouse cursor position as a pixel offset from the top-left corner of the display.

Returns:
Point object describing the mouse cursor position in screen pixels.

MouseCursor & CEGUI::MouseCursor::getSingleton ( void ) [static]

Return singleton MouseCursor object.

Returns:
Singleton MouseCursor object

MouseCursor * CEGUI::MouseCursor::getSingletonPtr ( void ) [static]

Return pointer to singleton MouseCursor object.

Returns:
Pointer to singleton MouseCursor object

const URect & CEGUI::MouseCursor::getUnifiedConstraintArea ( void ) const

return the current constraint area of the mouse cursor.

Returns:
URect object describing the active area that the mouse cursor is constrained to.

void CEGUI::MouseCursor::hide ( void ) [inline]

Hides the mouse cursor.

Returns:
Nothing.

bool CEGUI::MouseCursor::isVisible ( void ) const [inline]

return whether the mouse cursor is visible.

Returns:
true if the mouse cursor is visible, false if the mouse cursor is hidden.

void CEGUI::MouseCursor::offsetPosition ( const Point & offset )

Offset the mouse cursor position by the deltas specified in offset.

Parameters:
offset Point object which describes the amount to move the cursor in each axis.
Returns:
Nothing.

void CEGUI::MouseCursor::setConstraintArea ( const Rect * area )

Set the area that the mouse cursor is constrained to.

Parameters:
area Pointer to a Rect object that describes the area of the display that the mouse is allowed to occupy. The given area will be clipped to the current Renderer screen area - it is never possible for the mouse to leave this area. If this parameter is NULL, the constraint is set to the size of the current Renderer screen area.
Returns:
Nothing.

void CEGUI::MouseCursor::setImage | ( | const String & | imageset,
 |  | const String & | image_name
 | ) |

Set the current mouse cursor image.

Parameters:
imageset | String object holding the name of the Imageset that contains the desired Image.
image_name | String object holding the name of the desired Image on Imageset imageset.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if imageset is not known, or if imageset contains no Image named image_name.

void CEGUI::MouseCursor::setPosition ( const Point & position )

Set the current mouse cursor position.

Parameters:
position Point object describing the new location for the mouse. This will be clipped to within the renderer screen area.

void CEGUI::MouseCursor::setUnifiedConstraintArea ( const URect * area )

Set the area that the mouse cursor is constrained to.

Parameters:
area Pointer to a URect object that describes the area of the display that the mouse is allowed to occupy. The given area will be clipped to the current Renderer screen area - it is never possible for the mouse to leave this area. If this parameter is NULL, the constraint is set to the size of the current Renderer screen area.
Returns:
Nothing.

void CEGUI::MouseCursor::show ( void ) [inline]

Shows the mouse cursor.

Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MouseCursorEventArgs Class Reference

CEGUI::MouseCursorEventArgs

CEGUI::MouseCursorEventArgs Class Reference

EventArgs based class that is used for objects passed to input event handlers concerning mouse cursor events. More...

Inheritance diagram for CEGUI::MouseCursorEventArgs:

[legend]
Collaboration diagram for CEGUI::MouseCursorEventArgs:

[legend]
List of all members.

Public Member Functions

MouseCursorEventArgs (MouseCursor *cursor)

Public Attributes

MouseCursor * mouseCursor
pointer to a MouseCursor object of relevance to the event.
const Image * image
pointer to an Image object of relevance to the event.

Detailed Description

EventArgs based class that is used for objects passed to input event handlers concerning mouse cursor events.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::MouseCursorImage Class Reference

CEGUI::WindowProperties::MouseCursorImage

CEGUI::WindowProperties::MouseCursorImage Class Reference

Property to access window mouse cursor setting. More...

Inheritance diagram for CEGUI::WindowProperties::MouseCursorImage:

[legend]
Collaboration diagram for CEGUI::WindowProperties::MouseCursorImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.

Detailed Description

Property to access window mouse cursor setting.

This property offers access to the current mouse cursor image for the window.

Usage:
  • Name: MouseCursorImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::WindowProperties::MouseCursorImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

bool CEGUI::WindowProperties::MouseCursorImage::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::WindowProperties::MouseCursorImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MouseEventArgs Class Reference

CEGUI::MouseEventArgs

CEGUI::MouseEventArgs Class Reference

EventArgs based class that is used for objects passed to input event handlers concerning mouse input. More...

Inheritance diagram for CEGUI::MouseEventArgs:

[legend]
Collaboration diagram for CEGUI::MouseEventArgs:

[legend]
List of all members.

Public Member Functions

MouseEventArgs (Window *wnd)

Public Attributes

Point position
holds current mouse position.
Vector2 moveDelta
holds variation of mouse position from last mouse input
MouseButton button
one of the MouseButton enumerated values describing the mouse button causing the event (for button inputs only)
uint | sysKeys
current state of the system keys and mouse buttons.
float | wheelChange
Holds the amount the scroll wheel has changed.
uint | clickCount
Holds number of mouse button down events currently counted in a multi-click sequence (for button inputs only).

Detailed Description

EventArgs based class that is used for objects passed to input event handlers concerning mouse input.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnList Class Reference

CEGUI::MultiColumnList

CEGUI::MultiColumnList Class Reference

Base class for the multi column list widget. More...

Inheritance diagram for CEGUI::MultiColumnList:

[legend]
Collaboration diagram for CEGUI::MultiColumnList:

[legend]
List of all members.

Public Types

enum SelectionMode {
RowSingle, RowMultiple, CellSingle, CellMultiple,
NominatedColumnSingle, NominatedColumnMultiple, ColumnSingle, ColumnMultiple,
NominatedRowSingle, NominatedRowMultiple
}
Enumerated values for the selection modes possible with a Multi-column list.

Public Member Functions

bool | isUserSortControlEnabled (void) const
Return whether user manipulation of the sort column and direction are enabled.
bool | isUserColumnSizingEnabled (void) const
Return whether the user may size column segments.
bool | isUserColumnDraggingEnabled (void) const
Return whether the user may modify the order of the columns.
uint | getColumnCount (void) const
Return the number of columns in the multi-column list.
uint | getRowCount (void) const
Return the number of rows in the multi-column list.
uint | getSortColumn (void) const
Return the zero based index of the current sort column. There must be at least one column to successfully call this method.
uint | getColumnWithID (uint col_id) const
Return the zero based column index of the column with the specified ID.
uint | getColumnWithHeaderText (const String &text) const
Return the zero based index of the column whos header text matches the specified text.
float | getTotalColumnHeadersWidth (void) const
Return the total width of all column headers.
float | getColumnHeaderWidth (uint col_idx) const
Return the width of the specified column header (and therefore the column itself).
ListHeaderSegment::SortDirection | getSortDirection (void) const
Return the currently set sort direction.
ListHeaderSegment & | getHeaderSegmentForColumn (uint col_idx) const
Return the ListHeaderSegment object for the specified column.
uint | getItemRowIndex (const ListboxItem *item) const
Return the zero based index of the Row that contains item.
uint | getItemColumnIndex (const ListboxItem *item) const
Return the current zero based index of the column that contains item.
MCLGridRef | getItemGridReference (const ListboxItem *item) const
Return the grid reference for item.
ListboxItem * | getItemAtGridReference (const MCLGridRef &grid_ref) const
Return a pointer to the ListboxItem at the specified grid reference.
bool | isListboxItemInColumn (const ListboxItem *item, uint col_idx) const
return whether ListboxItem item is attached to the column at index col_idx.
bool | isListboxItemInRow (const ListboxItem *item, uint row_idx) const
return whether ListboxItem item is attached to the row at index row_idx.
bool | isListboxItemInList (const ListboxItem *item) const
return whether ListboxItem item is attached to the list box.
ListboxItem * | findColumnItemWithText (const String &text, uint col_idx, const ListboxItem *start_item) const
Return the ListboxItem in column col_idx that has the text string text.
ListboxItem * | findRowItemWithText (const String &text, uint row_idx, const ListboxItem *start_item) const
Return the ListboxItem in row row_idx that has the text string text.
ListboxItem * | findListItemWithText (const String &text, const ListboxItem *start_item) const
Return the ListboxItem that has the text string text.
ListboxItem * | getFirstSelectedItem (void) const
Return a pointer to the first selected ListboxItem attached to this list box.
ListboxItem * | getNextSelected (const ListboxItem *start_item) const
Return a pointer to the next selected ListboxItem after start_item.
uint | getSelectedCount (void) const
Return the number of selected ListboxItems attached to this list box.
bool | isItemSelected (const MCLGridRef &grid_ref) const
Return whether the ListboxItem at grid_ref is selected.
uint | getNominatedSelectionColumnID (void) const
Return the ID of the currently set nominated selection column to be used when in one of the NominatedColumn* selection modes.
uint | getNominatedSelectionColumn (void) const
Return the index of the currently set nominated selection column to be used when in one of the NominatedColumn* selection modes.
uint | getNominatedSelectionRow (void) const
Return the index of the currently set nominated selection row to be used when in one of the NominatedRow* selection modes.
MultiColumnList::SelectionMode | getSelectionMode (void) const
Return the currently set selection mode.
bool | isVertScrollbarAlwaysShown (void) const
Return whether the vertical scroll bar is always shown.
bool | isHorzScrollbarAlwaysShown (void) const
Return whether the horizontal scroll bar is always shown.
uint | getColumnID (uint col_idx) const
Return the ID code assigned to the requested column.
uint | getRowID (uint row_idx) const
Return the ID code assigned to the requested row.
uint | getRowWithID (uint row_id) const
Return the zero based row index of the row with the specified ID.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | resetList (void)
Remove all items from the list.
void | addColumn (const String &text, uint col_id, float width)
Add a column to the list box.
void | insertColumn (const String &text, uint col_id, float width, uint position)
Insert a new column in the list.
void | removeColumn (uint col_idx)
Removes a column from the list box. This will cause any ListboxItem using the autoDelete option in the column to be deleted.
void | removeColumnWithID (uint col_id)
Removes a column from the list box. This will cause any ListboxItem using the autoDelete option in the column to be deleted.
void | moveColumn (uint col_idx, uint position)
Move the column at index col_idx so it is at index position.
void | moveColumnWithID (uint col_id, uint position)
Move the column with ID col_id so it is at index position.
uint | addRow (uint row_id=0)
Add an empty row to the list box.
uint | addRow (ListboxItem *item, uint col_id, uint row_id=0)
Add a row to the list box, and set the item in the column with ID col_id to item.
uint | insertRow (uint row_idx, uint row_id=0)
Insert an empty row into the list box.
uint | insertRow (ListboxItem *item, uint col_id, uint row_idx, uint row_id=0)
Insert a row into the list box, and set the item in the column with ID col_id to item.
void | removeRow (uint row_idx)
Remove the list box row with index row_idx. Any ListboxItem in row row_idx using autoDelete mode will be deleted.
void | setItem (ListboxItem *item, const MCLGridRef &position)
Set the ListboxItem for grid reference position.
void | setItem (ListboxItem *item, uint col_id, uint row_idx)
Set the ListboxItem for the column with ID col_id in row row_idx.
void | setSelectionMode (MultiColumnList::SelectionMode sel_mode)
Set the selection mode for the list box.
void | setNominatedSelectionColumnID (uint col_id)
Set the column to be used for the NominatedColumn* selection modes.
void | setNominatedSelectionColumn (uint col_idx)
Set the column to be used for the NominatedColumn* selection modes.
void | setNominatedSelectionRow (uint row_idx)
Set the row to be used for the NominatedRow* selection modes.
void | setSortDirection (ListHeaderSegment::SortDirection direction)
Set the sort direction to be used.
void | setSortColumn (uint col_idx)
Set the column to be used as the sort key.
void | setSortColumnByID (uint col_id)
Set the column to be used as the sort key.
void | setShowVertScrollbar (bool setting)
Set whether the vertical scroll bar should always be shown, or just when needed.
void | setShowHorzScrollbar (bool setting)
Set whether the horizontal scroll bar should always be shown, or just when needed.
void | clearAllSelections (void)
Removed the selected state from any currently selected ListboxItem attached to the list.
void | setItemSelectState (ListboxItem *item, bool state)
Sets or clears the selected state of the given ListboxItem which must be attached to the list.
void | setItemSelectState (const MCLGridRef &grid_ref, bool state)
Sets or clears the selected state of the ListboxItem at the given grid reference.
void | handleUpdatedItemData (void)
Inform the list box that one or more attached ListboxItems have been externally modified, and the list should re-sync its internal state and refresh the display as needed.
void | setColumnHeaderWidth (uint col_idx, float width)
Set the width of the specified column header (and therefore the column itself).
void | setUserSortControlEnabled (bool setting)
Set whether user manipulation of the sort column and direction are enabled.
void | setUserColumnSizingEnabled (bool setting)
Set whether the user may size column segments.
void | setUserColumnDraggingEnabled (bool setting)
Set whether the user may modify the order of the columns.
void | autoSizeColumnHeader (uint col_idx)
Automatically determines the "best fit" size for the specified column and sets the column width to the same.
void | setRowID (uint row_idx, uint row_id)
Set the ID code assigned to a given row.
MultiColumnList (const String &type, const String &name)
Constructor for the Multi-column list base class.
virtual | ~MultiColumnList (void)
Destructor for the multi-column list base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventSelectionModeChanged
Event fired when the selection mode for the list box changes.
static const String | EventNominatedSelectColumnChanged
Event fired when the nominated select column changes.
static const String | EventNominatedSelectRowChanged
Event fired when the nominated select row changes.
static const String | EventVertScrollbarModeChanged
Event fired when the vertical scroll bar 'force' setting changes.
static const String | EventHorzScrollbarModeChanged
Event fired when the horizontal scroll bar 'force' setting changes.
static const String | EventSelectionChanged
Event fired when the current selection(s) within the list box changes.
static const String | EventListContentsChanged
Event fired when the contents of the list box changes.
static const String | EventSortColumnChanged
Event fired when the sort column changes.
static const String | EventSortDirectionChanged
Event fired when the sort direction changes.
static const String | EventListColumnSized
Event fired when the width of a column in the list changes.
static const String | EventListColumnMoved
Event fired when the column order changes.

Protected Types

typedef std::vector< ListRow > | ListItemGrid

Protected Member Functions

virtual Rect | getListRenderArea (void) const =0
Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering list items.
virtual ListHeader * | createListHeader (const String &name) const =0
create and return a pointer to a ListHeaer widget for use as the column headers.
virtual Scrollbar * | createVertScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as vertical scroll bar
virtual Scrollbar * | createHorzScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as horizontal scroll bar
virtual void | cacheListboxBaseImagery ()=0
Perform rendering of the widget control frame and other 'static' areas. This method should not render the actual items. Note that the items are typically rendered to layer 3, other layers can be used for rendering imagery behind and infront of the items.
void | addMultiColumnListboxEvents (void)
Add multi column list box specific events.
virtual void | populateRenderCache ()
Update the rendering cache.
void | configureScrollbars (void)
display required integrated scroll bars according to current state of the list box and update their values.
bool | selectRange (const MCLGridRef &start, const MCLGridRef &end)
select all strings between positions start and end. (inclusive). Returns true if something was modified.
float | getTotalRowsHeight (void) const
Return the sum of all row heights.
float | getWidestColumnItemWidth (uint col_idx) const
Return the width of the widest item in the given column.
float | getHighestRowItemHeight (uint row_idx) const
Return the height of the highest item in the given row.
bool | clearAllSelections_impl (void)
Clear the selected state for all items (implementation).
ListboxItem * | getItemAtPoint (const Point &pt) const
Return the ListboxItem under the given window local pixel co-ordinate.
bool | setItemSelectState_impl (const MCLGridRef grid_ref, bool state)
Set select state for the given item. This appropriately selects other items depending upon the select mode. Returns true if something is changed, else false.
void | setSelectForItemsInRow (uint row_idx, bool state)
Set select state for all items in the given row.
void | setSelectForItemsInColumn (uint col_idx, bool state)
Set select state for all items in the given column.
void | moveColumn_impl (uint col_idx, uint position)
Move the column at index col_idx so it is at index position. Implementation version which does not move the header segment (since that may have already happened).
bool | resetList_impl (void)
Remove all items from the list.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
int | writePropertiesXML (OutStream &out_stream) const
virtual void | onSelectionModeChanged (WindowEventArgs &e)
Handler called when the selection mode of the list box changes.
virtual void | onNominatedSelectColumnChanged (WindowEventArgs &e)
Handler called when the nominated selection column changes.
virtual void | onNominatedSelectRowChanged (WindowEventArgs &e)
Handler called when the nominated selection row changes.
virtual void | onVertScrollbarModeChanged (WindowEventArgs &e)
Handler called when the vertical scroll bar 'force' mode is changed.
virtual void | onHorzScrollbarModeChanged (WindowEventArgs &e)
Handler called when the horizontal scroll bar 'force' mode is changed.
virtual void | onSelectionChanged (WindowEventArgs &e)
Handler called when the current selection changes.
virtual void | onListContentsChanged (WindowEventArgs &e)
Handler called when the list contents is changed.
virtual void | onSortColumnChanged (WindowEventArgs &e)
Handler called when the sort column changes.
virtual void | onSortDirectionChanged (WindowEventArgs &e)
Handler called when the sort direction changes.
virtual void | onListColumnSized (WindowEventArgs &e)
Handler called when a column is sized.
virtual void | onListColumnMoved (WindowEventArgs &e)
Handler called when the column order is changed.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.
bool | handleHeaderScroll (const EventArgs &e)
bool | handleHeaderSegMove (const EventArgs &e)
bool | handleColumnSizeChange (const EventArgs &e)
bool | handleHorzScrollbar (const EventArgs &e)
bool | handleVertScrollbar (const EventArgs &e)
bool | handleSortColumnChange (const EventArgs &e)
bool | handleSortDirectionChange (const EventArgs &e)
bool | handleHeaderSegDblClick (const EventArgs &e)

Static Protected Member Functions

static bool | pred_descend (const ListRow &a, const ListRow &b)
std algorithm predicate used for sorting in descending order

Protected Attributes

Scrollbar * d_vertScrollbar
vertical scroll-bar widget
Scrollbar * d_horzScrollbar
horizontal scroll-bar widget
ListHeader * d_header
The ListHeader attached to this multi-column list.
bool | d_forceVertScroll
true if vertical scrollbar should always be displayed
bool | d_forceHorzScroll
true if horizontal scrollbar should always be displayed
SelectionMode d_selectMode
Holds selection mode (represented by settings below).
uint | d_nominatedSelectCol
Nominated column for single column selection.
uint | d_nominatedSelectRow
Nominated row for single row selection.
bool | d_multiSelect
Allow multiple selections.
bool | d_fullRowSelect
All items in a row are selected.
bool | d_fullColSelect
All items in a column are selected.
bool | d_useNominatedRow
true if we use a nominated row to select.
bool | d_useNominatedCol
true if we use a nominated col to select.
ListboxItem * d_lastSelected
holds pointer to the last selected item (used in range selections)
ListItemGrid | d_grid
Holds the list box data.

Classes

struct | ListRow
Struct used internally to represent a row in the list and also to ease sorting of the rows. More...

Detailed Description

Base class for the multi column list widget.

Member Function Documentation

void CEGUI::MultiColumnList::addColumn | ( | const String & | text,
 |  | uint | col_id,
 |  | float | width
 | ) |

Add a column to the list box.

Parameters:
text | String object containing the text label for the column header.
col_id | ID code to be assigned to the column header.
width | Initial width to be set for the column using the active metrics mode for this window.
Returns:
Nothing.

uint CEGUI::MultiColumnList::addRow | ( | ListboxItem * | item,
 |  | uint | col_id,
 |  | uint | row_id = 0
 | ) |

Add a row to the list box, and set the item in the column with ID col_id to item.

Note:
If the list is being sorted, the new row will appear at an appropriate position according to the sorting being applied. If no sorting is being done, the new row will appear at the bottom of the list.
Parameters:
item | Pointer to a ListboxItem to be used as the initial contents for the column with ID col_id.
col_id | ID code of the column whos initial item is to be set to item.
row_id | ID code to be assigned to the new row.
Returns:
Initial zero based index of the new row.
Exceptions:
InvalidRequestException thrown if no column with the specified ID is attached to the list box.

uint CEGUI::MultiColumnList::addRow ( uint row_id = 0 )

Add an empty row to the list box.

Parameters:
row_id ID code to be assigned to the new row.
Note:
If the list is being sorted, the new row will appear at an appropriate position according to the sorting being applied. If no sorting is being done, the new row will appear at the bottom of the list.
Returns:
Initial zero based index of the new row.

void CEGUI::MultiColumnList::autoSizeColumnHeader ( uint col_idx )

Automatically determines the "best fit" size for the specified column and sets the column width to the same.

Parameters:
col_idx Zero based index of the column to be sized.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if col_idx is out of range.

virtual void CEGUI::MultiColumnList::cacheListboxBaseImagery ( ) [protected, pure virtual]

Perform rendering of the widget control frame and other 'static' areas. This method should not render the actual items. Note that the items are typically rendered to layer 3, other layers can be used for rendering imagery behind and infront of the items.

Returns:
Nothing.

void CEGUI::MultiColumnList::clearAllSelections ( void )

Removed the selected state from any currently selected ListboxItem attached to the list.

Returns:
Nothing.

bool CEGUI::MultiColumnList::clearAllSelections_impl ( void ) [protected]

Clear the selected state for all items (implementation).

Returns:
true if some selections were cleared, false nothing was changed.

virtual Scrollbar* CEGUI::MultiColumnList::createHorzScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as horizontal scroll bar

Parameters:
name String holding the name to be assigned to the created component.
Returns:
Pointer to a Scrollbar to be used for scrolling the list horizontally.

virtual ListHeader* CEGUI::MultiColumnList::createListHeader ( const String & name ) const [protected, pure virtual]

create and return a pointer to a ListHeaer widget for use as the column headers.

Parameters:
name String holding the name to be assigned to the created component.
Returns:
Pointer to a ListHeader based object.

virtual Scrollbar* CEGUI::MultiColumnList::createVertScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as vertical scroll bar

Parameters:
name String holding the name to be assigned to the created component.
Returns:
Pointer to a Scrollbar to be used for scrolling the list vertically.

ListboxItem * CEGUI::MultiColumnList::findColumnItemWithText | ( | const String & | text,
 |  | uint | col_idx,
 |  | const ListboxItem * | start_item
 | ) | const

Return the ListboxItem in column col_idx that has the text string text.

Parameters:
text | String object containing the text to be searched for.
col_idx | Zero based index of the column to be searched.
start_item | Pointer to the ListboxItem where the exclusive search is to start, or NULL to search from the top of the column.
Returns:
Pointer to the first ListboxItem in column col_idx, after start_item, that has the string text.
Exceptions:
InvalidRequestException thrown if start_item is not attached to the list box, or if col_idx is out of range.

ListboxItem * CEGUI::MultiColumnList::findListItemWithText | ( | const String & | text,
 |  | const ListboxItem * | start_item
 | ) | const

Return the ListboxItem that has the text string text.

Note:
List box searching progresses across the columns in each row.
Parameters:
text | String object containing the text to be searched for.
start_item | Pointer to the ListboxItem where the exclusive search is to start, or NULL to search the whole list box.
Returns:
Pointer to the first ListboxItem, after start_item, that has the string text.
Exceptions:
InvalidRequestException thrown if start_item is not attached to the list box.

ListboxItem * CEGUI::MultiColumnList::findRowItemWithText | ( | const String & | text,
 |  | uint | row_idx,
 |  | const ListboxItem * | start_item
 | ) | const

Return the ListboxItem in row row_idx that has the text string text.

Parameters:
text | String object containing the text to be searched for.
row_idx | Zero based index of the row to be searched.
start_item | Pointer to the ListboxItem where the exclusive search is to start, or NULL to search from the start of the row.
Returns:
Pointer to the first ListboxItem in row row_idx, after start_item, that has the string text.
Exceptions:
InvalidRequestException thrown if start_item is not attached to the list box, or if row_idx is out of range.

uint CEGUI::MultiColumnList::getColumnCount ( void ) const

Return the number of columns in the multi-column list.

Returns:
uint value equal to the number of columns in the list.

float CEGUI::MultiColumnList::getColumnHeaderWidth ( uint col_idx ) const

Return the width of the specified column header (and therefore the column itself).

Parameters:
col_idx Zero based column index of the column whos width is to be returned.
Returns:
Width of the column header at the zero based column index specified by col_idx, in whichever is the active metrics system.
Exceptions:
InvalidRequestException thrown if column is out of range.

uint CEGUI::MultiColumnList::getColumnID ( uint col_idx ) const

Return the ID code assigned to the requested column.

Parameters:
col_idx Zero based index of the column whos ID code is to be returned.
Returns:
Current ID code assigned to the column at the requested index.
Exceptions:
InvalidRequestException thrown if col_idx is out of range

uint CEGUI::MultiColumnList::getColumnWithHeaderText ( const String & text ) const

Return the zero based index of the column whos header text matches the specified text.

Parameters:
text String object containing the text to be searched for.
Returns:
Zero based column index of the column whos header has the specified text.
Exceptions:
InvalidRequestException thrown if no columns header has the requested text.

uint CEGUI::MultiColumnList::getColumnWithID ( uint col_id ) const

Return the zero based column index of the column with the specified ID.

Parameters:
col_id ID code of the column whos index is to be returned.
Returns:
Zero based column index of the first column whos ID matches col_id.
Exceptions:
InvalidRequestException thrown if no attached column has the requested ID.

ListboxItem * CEGUI::MultiColumnList::getFirstSelectedItem ( void ) const

Return a pointer to the first selected ListboxItem attached to this list box.

Note:
List box searching progresses across the columns in each row.
Returns:
Pointer to the first ListboxItem attached to this list box that is selected, or NULL if no item is selected.

ListHeaderSegment & CEGUI::MultiColumnList::getHeaderSegmentForColumn ( uint col_idx ) const

Return the ListHeaderSegment object for the specified column.

Parameters:
col_idx zero based index of the column whos ListHeaderSegment is to be returned.
Returns:
ListHeaderSegment object for the column at the requested index.
Exceptions:
InvalidRequestException thrown if col_idx is out of range.

ListboxItem * CEGUI::MultiColumnList::getItemAtGridReference ( const MCLGridRef & grid_ref ) const

Return a pointer to the ListboxItem at the specified grid reference.

Parameters:
grid_ref MCLGridRef object that describes the position of the ListboxItem to be returned.
Returns:
Pointer to the ListboxItem at grid reference grid_ref.
Exceptions:
InvalidRequestException thrown if grid_ref is invalid for this list box.

ListboxItem * CEGUI::MultiColumnList::getItemAtPoint ( const Point & pt ) const [protected]

Return the ListboxItem under the given window local pixel co-ordinate.

Returns:
ListboxItem that is under window pixel co-ordinate pt, or NULL if no item is under that position.

uint CEGUI::MultiColumnList::getItemColumnIndex ( const ListboxItem * item ) const

Return the current zero based index of the column that contains item.

Parameters:
item Pointer to the ListboxItem that the column index is to returned for.
Returns:
Zero based index of the column that contains ListboxItem item.
Exceptions:
InvalidRequestException thrown if item is not attached to the list box.

MCLGridRef CEGUI::MultiColumnList::getItemGridReference ( const ListboxItem * item ) const

Return the grid reference for item.

Parameters:
item Pointer to the ListboxItem whos current grid reference is to be returned.
Returns:
MCLGridRef object describing the current grid reference of ListboxItem item.
Exceptions:
InvalidRequestException thrown if item is not attached to the list box.

uint CEGUI::MultiColumnList::getItemRowIndex ( const ListboxItem * item ) const

Return the zero based index of the Row that contains item.

Parameters:
item Pointer to the ListboxItem that the row index is to returned for.
Returns:
Zero based index of the row that contains ListboxItem item.
Exceptions:
InvalidRequestException thrown if item is not attached to the list box.

virtual Rect CEGUI::MultiColumnList::getListRenderArea ( void ) const [protected, pure virtual]

Return a Rect object describing, in un-clipped pixels, the window relative area that is to be used for rendering list items.

Returns:
Rect object describing the area of the Window to be used for rendering list box items.

ListboxItem * CEGUI::MultiColumnList::getNextSelected ( const ListboxItem * start_item ) const

Return a pointer to the next selected ListboxItem after start_item.

Note:
List box searching progresses across the columns in each row.
Parameters:
start_item Pointer to the ListboxItem where the exclusive search is to start, or NULL to search the whole list box.
Returns:
Pointer to the first selected ListboxItem attached to this list box, after start_item, or NULL if no item is selected.
Exceptions:
InvalidRequestException thrown if start_item is not attached to the list box.

uint CEGUI::MultiColumnList::getNominatedSelectionColumn ( void ) const

Return the index of the currently set nominated selection column to be used when in one of the NominatedColumn* selection modes.

Returns:
Zero based index of the nominated selection column.

uint CEGUI::MultiColumnList::getNominatedSelectionColumnID ( void ) const

Return the ID of the currently set nominated selection column to be used when in one of the NominatedColumn* selection modes.

Note:
You should only ever call this when getColumnCount() returns > 0.
Returns:
ID code of the nominated selection column.

uint CEGUI::MultiColumnList::getNominatedSelectionRow ( void ) const

Return the index of the currently set nominated selection row to be used when in one of the NominatedRow* selection modes.

Returns:
Zero based index of the nominated selection column.

uint CEGUI::MultiColumnList::getRowCount ( void ) const

Return the number of rows in the multi-column list.

Returns:
uint value equal to the number of rows currently in the list.

uint CEGUI::MultiColumnList::getRowID ( uint row_idx ) const

Return the ID code assigned to the requested row.

Parameters:
row_idx Zero based index of the row who's ID code is to be returned.
Returns:
Current ID code assigned to the row at the requested index.
Exceptions:
InvalidRequestException thrown if row_idx is out of range

uint CEGUI::MultiColumnList::getRowWithID ( uint row_id ) const

Return the zero based row index of the row with the specified ID.

Parameters:
row_id ID code of the row who's index is to be returned.
Returns:
Zero based row index of the first row who's ID matches row_id.
Exceptions:
InvalidRequestException thrown if no row has the requested ID.

uint CEGUI::MultiColumnList::getSelectedCount ( void ) const

Return the number of selected ListboxItems attached to this list box.

return uint value equal to the number of ListboxItems attached to this list box that are currently selected.

MultiColumnList::SelectionMode CEGUI::MultiColumnList::getSelectionMode ( void ) const

Return the currently set selection mode.

Returns:
One of the MultiColumnList::SelectionMode enumerated values specifying the current selection mode.

uint CEGUI::MultiColumnList::getSortColumn ( void ) const

Return the zero based index of the current sort column. There must be at least one column to successfully call this method.

Returns:
Zero based column index that is the current sort column.
Exceptions:
InvalidRequestException thrown if there are no columns in this multi column list.

ListHeaderSegment::SortDirection CEGUI::MultiColumnList::getSortDirection ( void ) const

Return the currently set sort direction.

Returns:
One of the ListHeaderSegment::SortDirection enumerated values specifying the current sort direction.

float CEGUI::MultiColumnList::getTotalColumnHeadersWidth ( void ) const

Return the total width of all column headers.

Returns:
Sum total of all the column header widths in whichever metrics system is active.

void CEGUI::MultiColumnList::handleUpdatedItemData ( void )

Inform the list box that one or more attached ListboxItems have been externally modified, and the list should re-sync its internal state and refresh the display as needed.

Returns:
Nothing.

void CEGUI::MultiColumnList::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::MultiColumnList::insertColumn | ( | const String & | text,
 |  | uint | col_id,
 |  | float | width,
 |  | uint | position
 | ) |

Insert a new column in the list.

Parameters:
text | String object containing the text label for the column header.
col_id | ID code to be assigned to the column header.
width | Initial width to be set for the column using the active metrics mode for this window.
position | Zero based index where the column is to be inserted. If this is greater than the current number of columns, the new column is inserted at the end.
Returns:
Nothing.

uint CEGUI::MultiColumnList::insertRow | ( | ListboxItem * | item,
 |  | uint | col_id,
 |  | uint | row_idx,
 |  | uint | row_id = 0
 | ) |

Insert a row into the list box, and set the item in the column with ID col_id to item.

Note:
If the list is being sorted, the new row will appear at an appropriate position according to the sorting being applied. If no sorting is being done, the new row will appear at the specified index.
Parameters:
item | Pointer to a ListboxItem to be used as the initial contents for the column with ID col_id.
col_id | ID code of the column whos initial item is to be set to item.
row_idx | Zero based index where the row should be inserted. If this is greater than the current number of rows, the row is appended to the list.
row_id | ID code to be assigned to the new row.
Returns:
Zero based index where the row was actually inserted.
Exceptions:
InvalidRequestException thrown if no column with the specified ID is attached to the list box.

uint CEGUI::MultiColumnList::insertRow | ( | uint | row_idx,
 |  | uint | row_id = 0
 | ) |

Insert an empty row into the list box.

Note:
If the list is being sorted, the new row will appear at an appropriate position according to the sorting being applied. If no sorting is being done, the new row will appear at the specified index.
Parameters:
row_idx | Zero based index where the row should be inserted. If this is greater than the current number of rows, the row is appended to the list.
row_id | ID code to be assigned to the new row.
Returns:
Zero based index where the row was actually inserted.

bool CEGUI::MultiColumnList::isHorzScrollbarAlwaysShown ( void ) const

Return whether the horizontal scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

bool CEGUI::MultiColumnList::isItemSelected ( const MCLGridRef & grid_ref ) const

Return whether the ListboxItem at grid_ref is selected.

Parameters:
grid_ref MCLGridRef object describing the grid reference that is to be examined.
Returns:
  • true if there is a ListboxItem at grid_ref and it is selected.
  • false if there is no ListboxItem at grid_ref, or if the item is not selected.
Exceptions:
InvalidRequestException thrown if grid_ref contains an invalid grid position.

bool CEGUI::MultiColumnList::isListboxItemInColumn | ( | const ListboxItem * | item,
 |  | uint | col_idx
 | ) | const

return whether ListboxItem item is attached to the column at index col_idx.

Parameters:
item | Pointer to the ListboxItem to look for.
col_idx | Zero based index of the column that is to be searched.
Returns:
  • true if item is attached to list box column col_idx.
  • false if item is not attached to list box column col_idx.
Exceptions:
InvalidRequestException thrown if col_idx is out of range.

bool CEGUI::MultiColumnList::isListboxItemInList ( const ListboxItem * item ) const

return whether ListboxItem item is attached to the list box.

Parameters:
item Pointer to the ListboxItem to look for.
Returns:
  • true if item is attached to list box.
  • false if item is not attached to list box.

bool CEGUI::MultiColumnList::isListboxItemInRow | ( | const ListboxItem * | item,
 |  | uint | row_idx
 | ) | const

return whether ListboxItem item is attached to the row at index row_idx.

Parameters:
item | Pointer to the ListboxItem to look for.
row_idx | Zero based index of the row that is to be searched.
Returns:
  • true if item is attached to list box row row_idx.
  • false if item is not attached to list box row row_idx.
Exceptions:
InvalidRequestException thrown if row_idx is out of range.

bool CEGUI::MultiColumnList::isUserColumnDraggingEnabled ( void ) const

Return whether the user may modify the order of the columns.

Returns:
true if the user may interactively modify the order of the columns, false if they may not.

bool CEGUI::MultiColumnList::isUserColumnSizingEnabled ( void ) const

Return whether the user may size column segments.

Returns:
true if the user may interactively modify the width of columns, false if they may not.

bool CEGUI::MultiColumnList::isUserSortControlEnabled ( void ) const

Return whether user manipulation of the sort column and direction are enabled.

Returns:
true if the user may interactively modify the sort column and direction. false if the user may not modify the sort column and direction (these can still be set programmatically).

bool CEGUI::MultiColumnList::isVertScrollbarAlwaysShown ( void ) const

Return whether the vertical scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

void CEGUI::MultiColumnList::moveColumn | ( | uint | col_idx,
 |  | uint | position
 | ) |

Move the column at index col_idx so it is at index position.

Parameters:
col_idx | Zero based index of the column to be moved.
position | Zero based index of the new position for the column.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if col_idx is invalid.

void CEGUI::MultiColumnList::moveColumn_impl | ( | uint | col_idx,
 |  | uint | position
 | ) | [protected]

Move the column at index col_idx so it is at index position. Implementation version which does not move the header segment (since that may have already happened).

Exceptions:
InvalidRequestException thrown if col_idx is invalid.

void CEGUI::MultiColumnList::moveColumnWithID | ( | uint | col_id,
 |  | uint | position
 | ) |

Move the column with ID col_id so it is at index position.

Parameters:
col_id | ID code of the column to be moved.
position | Zero based index of the new position for the column.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if no column with col_id is available on this list box.

void CEGUI::MultiColumnList::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiColumnList::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiColumnList::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::MultiColumnList::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Window.

void CEGUI::MultiColumnList::removeColumn ( uint col_idx )

Removes a column from the list box. This will cause any ListboxItem using the autoDelete option in the column to be deleted.

Parameters:
col_idx Zero based index of the column to be removed.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if col_idx is invalid.

void CEGUI::MultiColumnList::removeColumnWithID ( uint col_id )

Removes a column from the list box. This will cause any ListboxItem using the autoDelete option in the column to be deleted.

Parameters:
col_id ID code of the column to be deleted.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if no column with col_id is available on this list box.

void CEGUI::MultiColumnList::removeRow ( uint row_idx )

Remove the list box row with index row_idx. Any ListboxItem in row row_idx using autoDelete mode will be deleted.

Parameters:
row_idx Zero based index of the row to be removed.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if row_idx is invalid.

void CEGUI::MultiColumnList::resetList ( void )

Remove all items from the list.

Note that this will cause 'AutoDelete' items to be deleted.

bool CEGUI::MultiColumnList::resetList_impl ( void ) [protected]

Remove all items from the list.

Note:
Note that this will cause 'AutoDelete' items to be deleted.
Returns:
  • true if the list contents were changed.
  • false if the list contents were not changed (list already empty).

void CEGUI::MultiColumnList::setColumnHeaderWidth | ( | uint | col_idx,
 |  | float | width
 | ) |

Set the width of the specified column header (and therefore the column itself).

Parameters:
col_idx | Zero based column index of the column whos width is to be set.
width | float value specifying the new width for the column using the active metrics system.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if column is out of range.

void CEGUI::MultiColumnList::setItem | ( | ListboxItem * | item,
 |  | uint | col_id,
 |  | uint | row_idx
 | ) |

Set the ListboxItem for the column with ID col_id in row row_idx.

Parameters:
item | Pointer to the ListboxItem to be set into the list.
col_id | ID code of the column to receive item.
row_idx | Zero based index of the row to receive item.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if no column with ID col_id exists, or of row_idx is out of range.

void CEGUI::MultiColumnList::setItem | ( | ListboxItem * | item,
 |  | const MCLGridRef & | position
 | ) |

Set the ListboxItem for grid reference position.

Parameters:
item | Pointer to the ListboxItem to be set at position.
position | MCLGridRef describing the grid reference of the item to be set.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if position contains an invalid grid reference.

void CEGUI::MultiColumnList::setItemSelectState | ( | const MCLGridRef & | grid_ref,
 |  | bool | state
 | ) |

Sets or clears the selected state of the ListboxItem at the given grid reference.

Note:
Depending upon the current selection mode, this may cause other items to be selected, other items to be deselected, or for nothing to actually happen at all.
Parameters:
grid_ref MCLGridRef object describing the position of the item to be affected.
state
  • true to put the ListboxItem into the selected state.
  • false to put the ListboxItem into the de-selected state.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if grid_ref is invalid for this list box.

void CEGUI::MultiColumnList::setItemSelectState | ( | ListboxItem * | item,
 |  | bool | state
 | ) |

Sets or clears the selected state of the given ListboxItem which must be attached to the list.

Note:
Depending upon the current selection mode, this may cause other items to be selected, other items to be deselected, or for nothing to actually happen at all.
Parameters:
item Pointer to the attached ListboxItem to be affected.
state
  • true to put the ListboxItem into the selected state.
  • false to put the ListboxItem into the de-selected state.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if item is not attached to the list box.

void CEGUI::MultiColumnList::setNominatedSelectionColumn ( uint col_idx )

Set the column to be used for the NominatedColumn* selection modes.

Parameters:
col_idx zero based index of the column to be used in NominatedColumn* selection modes.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if col_idx is out of range.

void CEGUI::MultiColumnList::setNominatedSelectionColumnID ( uint col_id )

Set the column to be used for the NominatedColumn* selection modes.

Parameters:
col_id ID code of the column to be used in NominatedColumn* selection modes.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if no column has ID code col_id.

void CEGUI::MultiColumnList::setNominatedSelectionRow ( uint row_idx )

Set the row to be used for the NominatedRow* selection modes.

Parameters:
row_idx zero based index of the row to be used in NominatedRow* selection modes.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if row_idx is out of range.

void CEGUI::MultiColumnList::setRowID | ( | uint | row_idx,
 |  | uint | row_id
 | ) |

Set the ID code assigned to a given row.

Parameters:
row_idx | Zero based index of the row who's ID code is to be set.
row_id | ID code to be assigned to the row at the requested index.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if row_idx is out of range

void CEGUI::MultiColumnList::setSelectionMode ( MultiColumnList::SelectionMode sel_mode )

Set the selection mode for the list box.

Parameters:
sel_mode One of the MultiColumnList::SelectionMode enumerated values specifying the selection mode to be used.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if the value specified for sel_mode is invalid.

void CEGUI::MultiColumnList::setShowHorzScrollbar ( bool setting )

Set whether the horizontal scroll bar should always be shown, or just when needed.

Parameters:
setting
  • true to have the horizontal scroll bar shown at all times.
  • false to have the horizontal scroll bar appear only when needed.
Returns:
Nothing.

void CEGUI::MultiColumnList::setShowVertScrollbar ( bool setting )

Set whether the vertical scroll bar should always be shown, or just when needed.

Parameters:
setting
  • true to have the vertical scroll bar shown at all times.
  • false to have the vertical scroll bar appear only when needed.
Returns:
Nothing.

void CEGUI::MultiColumnList::setSortColumn ( uint col_idx )

Set the column to be used as the sort key.

Parameters:
col_idx Zero based index of the column to use as the key when sorting the list items.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if col_idx is out of range.

void CEGUI::MultiColumnList::setSortColumnByID ( uint col_id )

Set the column to be used as the sort key.

Parameters:
col_id ID code of the column to use as the key when sorting the list items.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if col_id is invalid for this list box.

void CEGUI::MultiColumnList::setSortDirection ( ListHeaderSegment::SortDirection direction )

Set the sort direction to be used.

Parameters:
direction One of the ListHeaderSegment::SortDirection enumerated values specifying the sort direction to be used.
Returns:
Nothing.

void CEGUI::MultiColumnList::setUserColumnDraggingEnabled ( bool setting )

Set whether the user may modify the order of the columns.

Parameters:
setting
  • true if the user may interactively modify the order of the columns.
  • false if the user may not modify the order of the columns.

void CEGUI::MultiColumnList::setUserColumnSizingEnabled ( bool setting )

Set whether the user may size column segments.

Parameters:
setting
  • true if the user may interactively modify the width of columns.
  • false if the user may not change the width of the columns.
Returns:
Nothing.

void CEGUI::MultiColumnList::setUserSortControlEnabled ( bool setting )

Set whether user manipulation of the sort column and direction are enabled.

Parameters:
setting
  • true if the user may interactively modify the sort column and direction.
  • false if the user may not modify the sort column and direction (these can still be set programmatically).
Returns:
Nothing.

virtual bool CEGUI::MultiColumnList::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnList::ListRow Struct Reference

CEGUI::MultiColumnList::ListRow

CEGUI::MultiColumnList::ListRow Struct Reference

Struct used internally to represent a row in the list and also to ease sorting of the rows. More...

List of all members.

Public Types

typedef std::vector< ListboxItem * > | RowItems

Public Member Functions

ListboxItem *const & | operator[] (uint idx) const
ListboxItem *& | operator[] (uint idx)
bool | operator< (const ListRow &rhs) const
bool | operator> (const ListRow &rhs) const

Public Attributes

RowItems | d_items
uint | d_sortColumn
uint | d_rowID

Detailed Description

Struct used internally to represent a row in the list and also to ease sorting of the rows.

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditbox Class Reference

CEGUI::MultiLineEditbox

CEGUI::MultiLineEditbox Class Reference

Base class for the multi-line edit box widget. More...

Inheritance diagram for CEGUI::MultiLineEditbox:

[legend]
Collaboration diagram for CEGUI::MultiLineEditbox:

[legend]
List of all members.

Public Member Functions

bool | hasInputFocus (void) const
return true if the edit box has input focus.
bool | isReadOnly (void) const
return true if the edit box is read-only.
size_t | getCaratIndex (void) const
return the current position of the carat.
size_t | getSelectionStartIndex (void) const
return the current selection start point.
size_t | getSelectionEndIndex (void) const
return the current selection end point.
size_t | getSelectionLength (void) const
return the length of the current selection (in code points / characters).
size_t | getMaxTextLength (void) const
return the maximum text length set for this edit box.
colour | getNormalTextColour (void) const
return the currently set colour to be used for rendering edit box text in the normal, unselected state.
colour | getSelectedTextColour (void) const
return the currently set colour to be used for rendering the edit box text when within the selected region.
colour | getNormalSelectBrushColour (void) const
return the currently set colour to be used for rendering the edit box selection highlight when the edit box is active.
colour | getInactiveSelectBrushColour (void) const
return the currently set colour to be used for rendering the edit box selection highlight when the edit box is inactive.
bool | isWordWrapped (void) const
Return whether the text in the edit box will be word-wrapped.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | setReadOnly (bool setting)
Specify whether the edit box is read-only.
void | setCaratIndex (size_t carat_pos)
Set the current position of the carat.
void | setSelection (size_t start_pos, size_t end_pos)
Define the current selection for the edit box.
void | setMaxTextLength (size_t max_len)
set the maximum text length for this edit box.
void | setNormalTextColour (const colour &col)
Set the colour to be used for rendering edit box text in the normal, unselected state.
void | setSelectedTextColour (const colour &col)
Set the colour to be used for rendering the edit box text when within the selected region.
void | setNormalSelectBrushColour (const colour &col)
Set the colour to be used for rendering the edit box selection highlight when the edit box is active.
void | setInactiveSelectBrushColour (const colour &col)
Set the colour to be used for rendering the edit box selection highlight when the edit box is inactive.
void | ensureCaratIsVisible (void)
Scroll the view so that the current carat position is visible.
void | setWordWrapping (bool setting)
Set whether the text will be word wrapped or not.
MultiLineEditbox (const String &type, const String &name)
Constructor for the MultiLineEditbox base class.
virtual | ~MultiLineEditbox (void)
Destructor for the MultiLineEditbox base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventReadOnlyModeChanged
The read-only mode for the edit box has been changed.
static const String | EventWordWrapModeChanged
The word wrap mode of the text box has been changed.
static const String | EventMaximumTextLengthChanged
The maximum allowable string length has been changed.
static const String | EventCaratMoved
The text carat (insert point) has changed.
static const String | EventTextSelectionChanged
The current text selection has changed.
static const String | EventEditboxFull
The number of characters in the edit box has reached the current maximum.
static const String | EventVertScrollbarModeChanged
Event triggered when the vertical scroll bar 'force' setting changes.
static const String | EventHorzScrollbarModeChanged
Event triggered when the horizontal scroll bar 'force' setting changes.
static const argb_t | DefaultNormalTextColour = 0xFFFFFFFF
Colour applied to normal unselected text.
static const argb_t | DefaultSelectedTextColour = 0xFF000000
Colour applied to selected text.
static const argb_t | DefaultNormalSelectionColour = 0xFF6060FF
Colour applied to normal selection brush.
static const argb_t | DefaultInactiveSelectionColour = 0xFF808080
Colour applied to selection brush when widget is inactive.

Protected Types

typedef std::vector< LineInfo > | LineList
Type for collection of LineInfos.

Protected Member Functions

virtual Rect | getTextRenderArea (void) const =0
Return a Rect object describing, in un-clipped pixels, the window relative area that the text should be rendered in to.
virtual Scrollbar * | createVertScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as vertical scroll bar
virtual Scrollbar * | createHorzScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as horizontal scroll bar
virtual void | cacheEditboxBaseImagery ()=0
Perform rendering of the widget control frame and other 'static' areas. This method should not render the actual text. Note that the text will be rendered to layer 4 and the selection brush to layer 3, other layers can be used for rendering imagery behind and infront of the text & selection..
virtual void | cacheCaratImagery (const Rect &textArea)=0
Render the carat.
void | addMultiLineEditboxEvents (void)
Add multi-line edit box specific events.
void | cacheTextLines (const Rect &dest_area)
Render text lines.
void | formatText (void)
Format the text into lines as needed by the current formatting options.
size_t | getNextTokenLength (const String &text, size_t start_idx) const
Return the length of the next token in String text starting at index start_idx.
virtual void | populateRenderCache ()
Update the rendering cache.
void | configureScrollbars (void)
display required integrated scroll bars according to current state of the edit box and update their values.
size_t | getTextIndexFromPosition (const Point &pt) const
Return the text code point index that is rendered closest to screen position pt.
size_t | getLineNumberFromIndex (size_t index) const
Return the line number a given index falls on with the current formatting. Will return last line if index is out of range.
void | clearSelection (void)
Clear the current selection setting.
void | eraseSelectedText (bool modify_text=true)
Erase the currently selected text.
void | handleBackspace (void)
Processing for backspace key.
void | handleDelete (void)
Processing for Delete key.
void | handleCharLeft (uint sysKeys)
Processing to move carat one character left.
void | handleWordLeft (uint sysKeys)
Processing to move carat one word left.
void | handleCharRight (uint sysKeys)
Processing to move carat one character right.
void | handleWordRight (uint sysKeys)
Processing to move carat one word right.
void | handleDocHome (uint sysKeys)
Processing to move carat to the start of the text.
void | handleDocEnd (uint sysKeys)
Processing to move carat to the end of the text.
void | handleLineHome (uint sysKeys)
Processing to move carat to the start of the current line.
void | handleLineEnd (uint sysKeys)
Processing to move carat to the end of the current line.
void | handleLineUp (uint sysKeys)
Processing to move carat up a line.
void | handleLineDown (uint sysKeys)
Processing to move carat down a line.
void | handleNewLine (uint sysKeys)
Processing to insert a new line / paragraph.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
bool | handle_scrollChange (const EventArgs &args)
Internal handler that is triggered when the user interacts with the scrollbars.
void | onReadOnlyChanged (WindowEventArgs &e)
Handler called when the read-only state of the edit box changes.
void | onWordWrapModeChanged (WindowEventArgs &e)
Handler called when the word wrap mode for the the edit box changes.
void | onMaximumTextLengthChanged (WindowEventArgs &e)
Handler called when the maximum text length for the edit box changes.
void | onCaratMoved (WindowEventArgs &e)
Handler called when the carat moves.
void | onTextSelectionChanged (WindowEventArgs &e)
Handler called when the text selection changes.
void | onEditboxFullEvent (WindowEventArgs &e)
Handler called when the edit box is full.
void | onVertScrollbarModeChanged (WindowEventArgs &e)
Handler called when the 'always show' setting for the vertical scroll bar changes.
void | onHorzScrollbarModeChanged (WindowEventArgs &e)
Handler called when 'always show' setting for the horizontal scroll bar changes.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onMouseDoubleClicked (MouseEventArgs &e)
Handler called when a mouse button has been double-clicked within this window's area.
virtual void | onMouseTripleClicked (MouseEventArgs &e)
Handler called when a mouse button has been triple-clicked within this window's area.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onCharacter (KeyEventArgs &e)
Handler called when a character-key has been pressed while this window has input focus.
virtual void | onKeyDown (KeyEventArgs &e)
Handler called when a key as been depressed while this window has input focus.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.

Protected Attributes

bool | d_readOnly
true if the edit box is in read-only mode
size_t | d_maxTextLen
Maximum number of characters for this Editbox.
size_t | d_caratPos
Position of the carat / insert-point.
size_t | d_selectionStart
Start of selection area.
size_t | d_selectionEnd
End of selection area.
bool | d_dragging
true when a selection is being dragged.
size_t | d_dragAnchorIdx
Selection index for drag selection anchor point.
bool | d_wordWrap
true when formatting uses word-wrapping.
LineList d_lines
Holds the lines for the current formatting.
float | d_widestExtent
Holds the extent of the widest line as calculated in the last formatting pass.
Scrollbar * d_vertScrollbar
Points to the vertical scroll bar widget.
Scrollbar * d_horzScrollbar
Points to the horizontal scroll bar widget.
bool | d_forceVertScroll
true if vertical scrollbar should always be displayed
bool | d_forceHorzScroll
true if horizontal scrollbar should always be displayed
const Image * | d_selectionBrush
Image to use as the selection brush (should be set by derived class).
colour d_normalTextColour
Text colour used normally.
colour d_selectTextColour
Text colour used when text is highlighted.
colour d_selectBrushColour
Colour to apply to the selection brush.
colour d_inactiveSelectBrushColour
Colour to apply to the selection brush when widget is inactive / read-only.

Static Protected Attributes

static String | d_lineBreakChars
Holds what we consider to be line break characters.

Classes

struct | LineInfo
struct used to store information about a formatted line within the paragraph. More...

Detailed Description

Base class for the multi-line edit box widget.

Member Function Documentation

virtual void CEGUI::MultiLineEditbox::cacheCaratImagery ( const Rect & textArea ) [protected, pure virtual]

Render the carat.

Returns:
Nothing

virtual void CEGUI::MultiLineEditbox::cacheEditboxBaseImagery ( ) [protected, pure virtual]

Perform rendering of the widget control frame and other 'static' areas. This method should not render the actual text. Note that the text will be rendered to layer 4 and the selection brush to layer 3, other layers can be used for rendering imagery behind and infront of the text & selection..

Returns:
Nothing.

virtual Scrollbar* CEGUI::MultiLineEditbox::createHorzScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as horizontal scroll bar

Parameters:
name String holding the name to be assigned to the component.
Returns:
Pointer to a Scrollbar to be used for scrolling horizontally.

virtual Scrollbar* CEGUI::MultiLineEditbox::createVertScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as vertical scroll bar

Parameters:
name String holding the name to be assigned to the component.
Returns:
Pointer to a Scrollbar to be used for scrolling vertically.

void CEGUI::MultiLineEditbox::eraseSelectedText ( bool modify_text = true ) [protected]

Erase the currently selected text.

Parameters:
modify_text when true, the actual text will be modified. When false, everything is done except erasing the characters.

size_t CEGUI::MultiLineEditbox::getCaratIndex ( void ) const [inline]

return the current position of the carat.

Returns:
Index of the insert carat relative to the start of the text.

colour CEGUI::MultiLineEditbox::getInactiveSelectBrushColour ( void ) const [inline]

return the currently set colour to be used for rendering the edit box selection highlight when the edit box is inactive.

Returns:
colour value describing the ARGB colour that is currently set.

size_t CEGUI::MultiLineEditbox::getMaxTextLength ( void ) const [inline]

return the maximum text length set for this edit box.

Returns:
The maximum number of code points (characters) that can be entered into this edit box.

size_t CEGUI::MultiLineEditbox::getNextTokenLength | ( | const String & | text,
 |  | size_t | start_idx
 | ) | const [protected]

Return the length of the next token in String text starting at index start_idx.

Note:
Any single whitespace character is one token, any group of other characters is a token.
Returns:
The code point length of the token.

colour CEGUI::MultiLineEditbox::getNormalSelectBrushColour ( void ) const [inline]

return the currently set colour to be used for rendering the edit box selection highlight when the edit box is active.

Returns:
colour value describing the ARGB colour that is currently set.

colour CEGUI::MultiLineEditbox::getNormalTextColour ( void ) const [inline]

return the currently set colour to be used for rendering edit box text in the normal, unselected state.

Returns:
colour value describing the ARGB colour that is currently set.

colour CEGUI::MultiLineEditbox::getSelectedTextColour ( void ) const [inline]

return the currently set colour to be used for rendering the edit box text when within the selected region.

Returns:
colour value describing the ARGB colour that is currently set.

size_t CEGUI::MultiLineEditbox::getSelectionEndIndex ( void ) const

return the current selection end point.

Returns:
Index of the selection end point relative to the start of the text. If no selection is defined this function returns the position of the carat.

size_t CEGUI::MultiLineEditbox::getSelectionLength ( void ) const

return the length of the current selection (in code points / characters).

Returns:
Number of code points (or characters) contained within the currently defined selection.

size_t CEGUI::MultiLineEditbox::getSelectionStartIndex ( void ) const

return the current selection start point.

Returns:
Index of the selection start point relative to the start of the text. If no selection is defined this function returns the position of the carat.

size_t CEGUI::MultiLineEditbox::getTextIndexFromPosition ( const Point & pt ) const [protected]

Return the text code point index that is rendered closest to screen position pt.

Parameters:
pt Point object describing a position on the screen in pixels.
Returns:
Code point index into the text that is rendered closest to screen position pt.

virtual Rect CEGUI::MultiLineEditbox::getTextRenderArea ( void ) const [protected, pure virtual]

Return a Rect object describing, in un-clipped pixels, the window relative area that the text should be rendered in to.

Returns:
Rect object describing the area of the Window to be used for rendering text.

bool CEGUI::MultiLineEditbox::hasInputFocus ( void ) const

return true if the edit box has input focus.

Returns:
  • true if the edit box has keyboard input focus.
  • false if the edit box does not have keyboard input focus.

void CEGUI::MultiLineEditbox::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

bool CEGUI::MultiLineEditbox::isReadOnly ( void ) const [inline]

return true if the edit box is read-only.

Returns:
  • true if the edit box is read only and can't be edited by the user.
  • false if the edit box is not read only and may be edited by the user.

bool CEGUI::MultiLineEditbox::isWordWrapped ( void ) const

Return whether the text in the edit box will be word-wrapped.

Returns:
  • true if the text will be word-wrapped at the edges of the widget frame.
  • false if text will not be word-wrapped (a scroll bar will be used to access long text lines).

void CEGUI::MultiLineEditbox::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onCharacter ( KeyEventArgs & e ) [protected, virtual]

Handler called when a character-key has been pressed while this window has input focus.

Parameters:
e KeyEventArgs object whose 'codepoint' field is set to the Unicode code point (encoded as utf32) for the character typed, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated. All other fields should be considered as 'junk'.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onKeyDown ( KeyEventArgs & e ) [protected, virtual]

Handler called when a key as been depressed while this window has input focus.

Parameters:
e KeyEventArgs object whose 'scancode' field is set to the Key::Scan value representing the key that was pressed, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onMouseDoubleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been double-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onMouseTripleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been triple-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Window.

void CEGUI::MultiLineEditbox::setCaratIndex ( size_t carat_pos )

Set the current position of the carat.

Parameters:
carat_pos New index for the insert carat relative to the start of the text. If the value specified is greater than the number of characters in the edit box, the carat is positioned at the end of the text.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setInactiveSelectBrushColour ( const colour & col )

Set the colour to be used for rendering the edit box selection highlight when the edit box is inactive.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setMaxTextLength ( size_t max_len )

set the maximum text length for this edit box.

Parameters:
max_len The maximum number of code points (characters) that can be entered into this Editbox.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setNormalSelectBrushColour ( const colour & col )

Set the colour to be used for rendering the edit box selection highlight when the edit box is active.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setNormalTextColour ( const colour & col )

Set the colour to be used for rendering edit box text in the normal, unselected state.

Parameters:
col colour value describing the ARGB colour that is to be used.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setReadOnly ( bool setting )

Specify whether the edit box is read-only.

Parameters:
setting
  • true if the edit box is read only and can't be edited by the user.
  • false if the edit box is not read only and may be edited by the user.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setSelectedTextColour ( const colour & col )

Set the colour to be used for rendering the edit box text when within the selected region.

Returns:
colour value describing the ARGB colour that is currently set.

void CEGUI::MultiLineEditbox::setSelection | ( | size_t | start_pos,
 |  | size_t | end_pos
 | ) |

Define the current selection for the edit box.

Parameters:
start_pos | Index of the starting point for the selection. If this value is greater than the number of characters in the edit box, the selection start will be set to the end of the text.
end_pos | Index of the ending point for the selection. If this value is greater than the number of characters in the edit box, the selection start will be set to the end of the text.
Returns:
Nothing.

void CEGUI::MultiLineEditbox::setWordWrapping ( bool setting )

Set whether the text will be word wrapped or not.

Parameters:
setting
  • true if the text should word-wrap at the edges of the text box.
  • false if the text should not wrap, but a scroll bar should be used.
Returns:
Nothing.

virtual bool CEGUI::MultiLineEditbox::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditbox::LineInfo Struct Reference

CEGUI::MultiLineEditbox::LineInfo

CEGUI::MultiLineEditbox::LineInfo Struct Reference

struct used to store information about a formatted line within the paragraph. More...

List of all members.

Public Attributes

size_t | d_startIdx
Starting index for this line.
size_t | d_length
Code point length of this line.
float | d_extent
Rendered extent of this line.

Detailed Description

struct used to store information about a formatted line within the paragraph.

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxProperties::MultiSelect Class Reference

CEGUI::ListboxProperties::MultiSelect

CEGUI::ListboxProperties::MultiSelect Class Reference

Property to access the multi-select setting of the list box. More...

Inheritance diagram for CEGUI::ListboxProperties::MultiSelect:

[legend]
Collaboration diagram for CEGUI::ListboxProperties::MultiSelect:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the multi-select setting of the list box.

Usage:
  • Name: MultiSelect
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that multiple items may be selected.
  • "False" to indicate that only a single item may be selected.

Member Function Documentation

String CEGUI::ListboxProperties::MultiSelect::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListboxProperties::MultiSelect::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::NamedArea Class Reference

CEGUI::NamedArea

CEGUI::NamedArea Class Reference

NamedArea defines an area for a component which may later be obtained and referenced by a name unique to the WidgetLook holding the NamedArea. More...

Collaboration diagram for CEGUI::NamedArea:

[legend]
List of all members.

Public Member Functions

NamedArea (const String &name)
const String & | getName () const
Return the name of this NamedArea.
const ComponentArea & | getArea () const
Return the ComponentArea of this NamedArea.
void | setArea (const ComponentArea &area)
Set the Area for this NamedArea.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this NamedArea to out_stream.

Detailed Description

NamedArea defines an area for a component which may later be obtained and referenced by a name unique to the WidgetLook holding the NamedArea.

Member Function Documentation

const ComponentArea & CEGUI::NamedArea::getArea ( ) const

Return the ComponentArea of this NamedArea.

Returns:
ComponentArea object describing the NamedArea's current target area.

const String & CEGUI::NamedArea::getName ( ) const

Return the name of this NamedArea.

Returns:
String object holding the name of this NamedArea.

void CEGUI::NamedArea::setArea ( const ComponentArea & area )

Set the Area for this NamedArea.

Parameters:
area ComponentArea object describing a new target area for the NamedArea..
Returns:
Nothing.

void CEGUI::NamedArea::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this NamedArea to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::NESWSizingCursorImage Class Reference

CEGUI::FrameWindowProperties::NESWSizingCursorImage

CEGUI::FrameWindowProperties::NESWSizingCursorImage Class Reference

Property to access the NE-SW diagonal sizing cursor image. More...

Inheritance diagram for CEGUI::FrameWindowProperties::NESWSizingCursorImage:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::NESWSizingCursorImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the NE-SW diagonal sizing cursor image.

Usage:
  • Name: NESWSizingCursorImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::FrameWindowProperties::NESWSizingCursorImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::NESWSizingCursorImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::NominatedSelectionColumnID Class Reference

CEGUI::MultiColumnListProperties::NominatedSelectionColumnID

CEGUI::MultiColumnListProperties::NominatedSelectionColumnID Class Reference

Property to access the nominated selection column (via ID). More...

Inheritance diagram for CEGUI::MultiColumnListProperties::NominatedSelectionColumnID:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::NominatedSelectionColumnID:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the nominated selection column (via ID).

Usage:
  • Name: NominatedSelectionColumnID
  • Format: "[uint]".
Where:
  • [uint] is any unsigned integer value representing the ID code of the column to be used.

Member Function Documentation

String CEGUI::MultiColumnListProperties::NominatedSelectionColumnID::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::NominatedSelectionColumnID::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::NominatedSelectionRow Class Reference

CEGUI::MultiColumnListProperties::NominatedSelectionRow

CEGUI::MultiColumnListProperties::NominatedSelectionRow Class Reference

Property to access the nominated selection row. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::NominatedSelectionRow:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::NominatedSelectionRow:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the nominated selection row.

Usage:
  • Name: NominatedSelectionRow
  • Format: "[uint]".
Where:
  • [uint] is any unsigned integer value representing the index of the row to be used.

Member Function Documentation

String CEGUI::MultiColumnListProperties::NominatedSelectionRow::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::NominatedSelectionRow::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::NormalEditTextColour Class Reference

CEGUI::ComboboxProperties::NormalEditTextColour

CEGUI::ComboboxProperties::NormalEditTextColour Class Reference

Property to access the normal, unselected, text colour used for rendering text. More...

Inheritance diagram for CEGUI::ComboboxProperties::NormalEditTextColour:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::NormalEditTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the normal, unselected, text colour used for rendering text.

Usage:
  • Name: NormalEditTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ComboboxProperties::NormalEditTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::NormalEditTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties::NormalImage Class Reference

CEGUI::PushButtonProperties::NormalImage

CEGUI::PushButtonProperties::NormalImage Class Reference

Property to access the normal image of the button. More...

Inheritance diagram for CEGUI::PushButtonProperties::NormalImage:

[legend]
Collaboration diagram for CEGUI::PushButtonProperties::NormalImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the normal image of the button.

Usage:
  • Name: NormalImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::PushButtonProperties::NormalImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PushButtonProperties::NormalImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuItemProperties::NormalTextColour Class Reference

CEGUI::MenuItemProperties::NormalTextColour

CEGUI::MenuItemProperties::NormalTextColour Class Reference

Property to access the normal text colour of the item. More...

Inheritance diagram for CEGUI::MenuItemProperties::NormalTextColour:

[legend]
Collaboration diagram for CEGUI::MenuItemProperties::NormalTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the normal text colour of the item.

Usage:
  • Name: NormalTextColour
  • Format: "[aarrggbb]".
Where:
  • [aarrggbb] represents the normal text colour of the item.

Member Function Documentation

String CEGUI::MenuItemProperties::NormalTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuItemProperties::NormalTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::NormalTextColour Class Reference

CEGUI::MultiLineEditboxProperties::NormalTextColour

CEGUI::MultiLineEditboxProperties::NormalTextColour Class Reference

Property to access the normal, unselected, text colour used for rendering text. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::NormalTextColour:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::NormalTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the normal, unselected, text colour used for rendering text.

Usage:
  • Name: NormalTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::NormalTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::NormalTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ButtonBaseProperties::NormalTextColour Class Reference

CEGUI::ButtonBaseProperties::NormalTextColour

CEGUI::ButtonBaseProperties::NormalTextColour Class Reference

Property to access the normal text colour. More...

Inheritance diagram for CEGUI::ButtonBaseProperties::NormalTextColour:

[legend]
Collaboration diagram for CEGUI::ButtonBaseProperties::NormalTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the normal text colour.

This property offers access to the colour value to be used for rendering the button caption text for the normal state.

Usage:
  • Name: NormalTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ButtonBaseProperties::NormalTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ButtonBaseProperties::NormalTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::NormalTextColour Class Reference

CEGUI::EditboxProperties::NormalTextColour

CEGUI::EditboxProperties::NormalTextColour Class Reference

Property to access the normal, unselected, text colour used for rendering text. More...

Inheritance diagram for CEGUI::EditboxProperties::NormalTextColour:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::NormalTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the normal, unselected, text colour used for rendering text.

Usage:
  • Name: NormalTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::EditboxProperties::NormalTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::NormalTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::NSSizingCursorImage Class Reference

CEGUI::FrameWindowProperties::NSSizingCursorImage

CEGUI::FrameWindowProperties::NSSizingCursorImage Class Reference

Property to access the N-S (up-down) sizing cursor image. More...

Inheritance diagram for CEGUI::FrameWindowProperties::NSSizingCursorImage:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::NSSizingCursorImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the N-S (up-down) sizing cursor image.

Usage:
  • Name: NSSizingCursorImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::FrameWindowProperties::NSSizingCursorImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::NSSizingCursorImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::NullObjectException Class Reference

CEGUI::NullObjectException

CEGUI::NullObjectException Class Reference

Exception class used when some required object or parameter is null. More...

Inheritance diagram for CEGUI::NullObjectException:

[legend]
Collaboration diagram for CEGUI::NullObjectException:

[legend]
List of all members.

Public Member Functions

NullObjectException (const String &message)

Detailed Description

Exception class used when some required object or parameter is null.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::NWSESizingCursorImage Class Reference

CEGUI::FrameWindowProperties::NWSESizingCursorImage

CEGUI::FrameWindowProperties::NWSESizingCursorImage Class Reference

Property to access the NW-SE diagonal sizing cursor image. More...

Inheritance diagram for CEGUI::FrameWindowProperties::NWSESizingCursorImage:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::NWSESizingCursorImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the NW-SE diagonal sizing cursor image.

Usage:
  • Name: NWSESizingCursorImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::FrameWindowProperties::NWSESizingCursorImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::NWSESizingCursorImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ObjectInUseException Class Reference

CEGUI::ObjectInUseException

CEGUI::ObjectInUseException Class Reference

Exception class used when some attempt to delete, remove, or otherwise invalidate some object that is still in use occurs. More...

Inheritance diagram for CEGUI::ObjectInUseException:

[legend]
Collaboration diagram for CEGUI::ObjectInUseException:

[legend]
List of all members.

Public Member Functions

ObjectInUseException (const String &message)

Detailed Description

Exception class used when some attempt to delete, remove, or otherwise invalidate some object that is still in use occurs.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuItemProperties::OpenedColour Class Reference

CEGUI::MenuItemProperties::OpenedColour

CEGUI::MenuItemProperties::OpenedColour Class Reference

Property to access the opened colour of the item. More...

Inheritance diagram for CEGUI::MenuItemProperties::OpenedColour:

[legend]
Collaboration diagram for CEGUI::MenuItemProperties::OpenedColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the opened colour of the item.

Usage:
  • Name: OpenedColour
  • Format: "[aarrggbb]".
Where:
  • [aarrggbb] represents the opened colour of the item.

Member Function Documentation

String CEGUI::MenuItemProperties::OpenedColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuItemProperties::OpenedColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::OpenGLRenderer Class Reference

CEGUI::OpenGLRenderer

CEGUI::OpenGLRenderer Class Reference

Renderer class to interface with OpenGL. More...

Inheritance diagram for CEGUI::OpenGLRenderer:

[legend]
Collaboration diagram for CEGUI::OpenGLRenderer:

[legend]
List of all members.

Public Member Functions

OpenGLRenderer (uint max_quads)
Constructor for OpenGL Renderer object.
OpenGLRenderer (uint max_quads, int width, int height)
virtual | ~OpenGLRenderer (void)
Destructor for OpenGLRenderer objects.
virtual void | addQuad (const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode)
Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.
virtual void | doRender (void)
Perform final rendering for all quads that have been queued for rendering.
virtual void | clearRenderList (void)
Clears all queued quads from the render queue.
virtual void | setQueueingEnabled (bool setting)
Enable or disable the queuing of quads from this point on.
virtual Texture * | createTexture (void)
Creates a 'null' Texture object.
virtual Texture * | createTexture (const String &filename, const String &resourceGroup)
Create a Texture object using the given image file.
virtual Texture * | createTexture (float size)
Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.
virtual void | destroyTexture (Texture *texture)
Destroy the given Texture object.
virtual void | destroyAllTextures (void)
Destroy all Texture objects.
virtual bool | isQueueingEnabled (void) const
Return whether queuing is enabled.
virtual float | getWidth (void) const
Return the current width of the display in pixels.
virtual float | getHeight (void) const
Return the current height of the display in pixels.
virtual Size | getSize (void) const
Return the size of the display in pixels.
virtual Rect | getRect (void) const
Return a Rect describing the screen.
virtual uint | getMaxTextureSize (void) const
Return the maximum texture size available.
virtual uint | getHorzScreenDPI (void) const
Return the horizontal display resolution dpi.
virtual uint | getVertScreenDPI (void) const
Return the vertical display resolution dpi.
void | setDisplaySize (const Size &sz)
Set the size of the display in pixels.
void | grabTextures (void)
Grabs all the loaded textures from Texture RAM and stores them in a local data buffer. This function invalidates all textures, and restoreTextures must be called before any CEGUI rendering is done for predictable results.
void | restoreTextures (void)
Restores all the loaded textures from the local data buffers previously created by 'grabTextures'.

Classes

struct | MyQuad
struct | QuadInfo
structure holding details about a quad to be drawn

Detailed Description

Renderer class to interface with OpenGL.

Constructor & Destructor Documentation

CEGUI::OpenGLRenderer::OpenGLRenderer ( uint max_quads )

Constructor for OpenGL Renderer object.

Parameters:
max_quads obsolete. Set to 0.

Member Function Documentation

void CEGUI::OpenGLRenderer::addQuad | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Texture * | tex,
 |  | const Rect & | texture_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode
 | ) | [virtual]

Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.

Parameters:
dest_rect | Rect object describing the destination area (values are in pixels)
z | float value specifying the z co-ordinate / z order of the quad
tex | pointer to the Texture object that holds the imagery to be rendered
texture_rect | Rect object holding the area of tex that is to be rendered (values are in texture co-ordinates).
colours | ColourRect object describing the colour values that are to be applied when rendering.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::OpenGLRenderer::clearRenderList ( void ) [virtual]

Clears all queued quads from the render queue.

Returns:
Nothing

Implements CEGUI::Renderer.

Texture * CEGUI::OpenGLRenderer::createTexture ( float size ) [virtual]

Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.

Parameters:
size float value that specifies the size to use for the width and height when creating the new texture.
Returns:
a newly created Texture object. The initial contents of the texture memory is undefined / random.
Note:
Textures are always created with a size that is a power of 2. If you specify a size that is not a power of two, the final size will be rounded up. So if you specify a size of 1024, the texture will be (1024 x 1024), however, if you specify a size of 1025, the texture will be (2048 x 2048). You can check the ultimate size by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::OpenGLRenderer::createTexture | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Create a Texture object using the given image file.

Parameters:
filename | String object that specifies the path and filename of the image file to use when creating the texture.
resourceGroup | Resource group identifier to be passed to the resource provider when loading the texture file.
Returns:
a newly created Texture object. The initial contents of the texture memory is the requested image file.
Note:
Textures are always created with a size that is a power of 2. If the file you specify is of a size that is not a power of two, the final size will be rounded up. Additionally, textures are always square, so the ultimate size is governed by the larger of the width and height of the specified file. You can check the ultimate sizes by querying the texture after creation.

Implements CEGUI::Renderer.

Texture * CEGUI::OpenGLRenderer::createTexture ( void ) [virtual]

Creates a 'null' Texture object.

Returns:
a newly created Texture object. The returned Texture object has no size or imagery associated with it, and is generally of little or no use.

Implements CEGUI::Renderer.

void CEGUI::OpenGLRenderer::destroyAllTextures ( void ) [virtual]

Destroy all Texture objects.

Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::OpenGLRenderer::destroyTexture ( Texture * texture ) [virtual]

Destroy the given Texture object.

Parameters:
texture pointer to the Texture object to be destroyed
Returns:
Nothing

Implements CEGUI::Renderer.

void CEGUI::OpenGLRenderer::doRender ( void ) [virtual]

Perform final rendering for all quads that have been queued for rendering.

The contents of the rendering queue is retained and can be rendered again as required. If the contents is not required call clearRenderList().

Returns:
Nothing

Implements CEGUI::Renderer.

virtual float CEGUI::OpenGLRenderer::getHeight ( void ) const [inline, virtual]

Return the current height of the display in pixels.

Returns:
float value equal to the current height of the display in pixels.

Implements CEGUI::Renderer.

virtual uint CEGUI::OpenGLRenderer::getHorzScreenDPI ( void ) const [inline, virtual]

Return the horizontal display resolution dpi.

Returns:
horizontal resolution of the display in dpi.

Implements CEGUI::Renderer.

virtual uint CEGUI::OpenGLRenderer::getMaxTextureSize ( void ) const [inline, virtual]

Return the maximum texture size available.

Returns:
Size of the maximum supported texture in pixels (textures are always assumed to be square)

Implements CEGUI::Renderer.

virtual Rect CEGUI::OpenGLRenderer::getRect ( void ) const [inline, virtual]

Return a Rect describing the screen.

Returns:
A Rect object that describes the screen area. Typically, the top-left values are always 0, and the size of the area described is equal to the screen resolution.

Implements CEGUI::Renderer.

virtual Size CEGUI::OpenGLRenderer::getSize ( void ) const [inline, virtual]

Return the size of the display in pixels.

Returns:
Size object describing the dimensions of the current display.

Implements CEGUI::Renderer.

virtual uint CEGUI::OpenGLRenderer::getVertScreenDPI ( void ) const [inline, virtual]

Return the vertical display resolution dpi.

Returns:
vertical resolution of the display in dpi.

Implements CEGUI::Renderer.

virtual float CEGUI::OpenGLRenderer::getWidth ( void ) const [inline, virtual]

Return the current width of the display in pixels.

Returns:
float value equal to the current width of the display in pixels.

Implements CEGUI::Renderer.

virtual bool CEGUI::OpenGLRenderer::isQueueingEnabled ( void ) const [inline, virtual]

Return whether queuing is enabled.

Returns:
true if queuing is enabled, false if queuing is disabled.

Implements CEGUI::Renderer.

void CEGUI::OpenGLRenderer::setDisplaySize ( const Size & sz )

Set the size of the display in pixels.

If your viewport size changes, you can call this function with the new size in pixels to update the rendering area.

Note:
This method will cause the EventDisplaySizeChanged event to fire if the display size has changed.
Parameters:
sz Size object describing the size of the display.
Returns:
Nothing.

virtual void CEGUI::OpenGLRenderer::setQueueingEnabled ( bool setting ) [inline, virtual]

Enable or disable the queuing of quads from this point on.

This only affects queuing. If queuing is turned off, any calls to addQuad will cause the quad to be rendered directly. Note that disabling queuing will not cause currently queued quads to be rendered, nor is the queue cleared - at any time the queue can still be drawn by calling doRender, and the list can be cleared by calling clearRenderList. Re-enabling the queue causes subsequent quads to be added as if queuing had never been disabled.

Parameters:
setting true to enable queuing, or false to disable queuing (see notes above).
Returns:
Nothing

Implements CEGUI::Renderer.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::OpenGLTexture Class Reference

CEGUI::OpenGLTexture

CEGUI::OpenGLTexture Class Reference

Texture class that is created by OpenGLRenderer objects. More...

Inheritance diagram for CEGUI::OpenGLTexture:

[legend]
Collaboration diagram for CEGUI::OpenGLTexture:

[legend]
List of all members.

Public Member Functions

virtual ushort | getWidth (void) const
Returns the current pixel width of the texture.
virtual ushort | getHeight (void) const
Returns the current pixel height of the texture.
virtual void | loadFromFile (const String &filename, const String &resourceGroup)
Loads the specified image file into the texture. The texture is resized as required to hold the image.
virtual void | loadFromMemory (const void *buffPtr, uint buffWidth, uint buffHeight)
Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.
GLuint | getOGLTexid (void) const
Return a pointer to the internal texture id.
void | setOGLTextureSize (uint size)
set the size of the internal texture.
void | grabTexture (void)
Grab the texture to a local buffer. This will destroy the OpenGL texture, and restoreTexture must be called before using it again.
void | restoreTexture (void)
Restore the texture from the locally buffered copy previously create by a call to grabTexture.

Friends

Texture * | OpenGLRenderer::createTexture (void)
Texture * | OpenGLRenderer::createTexture (const String &filename, const String &resourceGroup)
Texture * | OpenGLRenderer::createTexture (float size)
void | OpenGLRenderer::destroyTexture (Texture *texture)

Classes

struct | tImageTGA

Detailed Description

Texture class that is created by OpenGLRenderer objects.

Member Function Documentation

virtual ushort CEGUI::OpenGLTexture::getHeight ( void ) const [inline, virtual]

Returns the current pixel height of the texture.

Returns:
ushort value that is the current height of the texture in pixels

Implements CEGUI::Texture.

GLuint CEGUI::OpenGLTexture::getOGLTexid ( void ) const [inline]

Return a pointer to the internal texture id.

Returns:
Texture id that is loaded

virtual ushort CEGUI::OpenGLTexture::getWidth ( void ) const [inline, virtual]

Returns the current pixel width of the texture.

Returns:
ushort value that is the current width of the texture in pixels

Implements CEGUI::Texture.

void CEGUI::OpenGLTexture::loadFromFile | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [virtual]

Loads the specified image file into the texture. The texture is resized as required to hold the image.

Parameters:
filename | The filename of the image file that is to be loaded into the texture
resourceGroup | Resource group identifier passed to the resource provider.
Returns:
Nothing.

Implements CEGUI::Texture.

void CEGUI::OpenGLTexture::loadFromMemory | ( | const void * | buffPtr,
 |  | uint | buffWidth,
 |  | uint | buffHeight
 | ) | [virtual]

Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.

Parameters:
buffPtr | Pointer to the buffer containing the image data
buffWidth | Width of the buffer (in 0xAARRGGBB pixels)
buffHeight | Height of the buffer (in 0xAARRGGBB pixels)
Returns:
Nothing.

Implements CEGUI::Texture.

void CEGUI::OpenGLTexture::setOGLTextureSize ( uint size )

set the size of the internal texture.

Parameters:
size pixel size of the new internal texture. This will be rounded up to a power of 2.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollbarProperties::OverlapSize Class Reference

CEGUI::ScrollbarProperties::OverlapSize

CEGUI::ScrollbarProperties::OverlapSize Class Reference

Property to access the overlap size for the Scrollbar. More...

Inheritance diagram for CEGUI::ScrollbarProperties::OverlapSize:

[legend]
Collaboration diagram for CEGUI::ScrollbarProperties::OverlapSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the overlap size for the Scrollbar.

Usage:
  • Name: OverlapSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the per-page overlap (as defined by the client code).

Member Function Documentation

String CEGUI::ScrollbarProperties::OverlapSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollbarProperties::OverlapSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollbarProperties::PageSize Class Reference

CEGUI::ScrollbarProperties::PageSize

CEGUI::ScrollbarProperties::PageSize Class Reference

Property to access the page size for the Scrollbar. More...

Inheritance diagram for CEGUI::ScrollbarProperties::PageSize:

[legend]
Collaboration diagram for CEGUI::ScrollbarProperties::PageSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the page size for the Scrollbar.

Usage:
  • Name: PageSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the visible page (as defined by the client code).

Member Function Documentation

String CEGUI::ScrollbarProperties::PageSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollbarProperties::PageSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PopupMenu Class Reference

CEGUI::PopupMenu

CEGUI::PopupMenu Class Reference

Base class for popup menus. More...

Inheritance diagram for CEGUI::PopupMenu:

[legend]
Collaboration diagram for CEGUI::PopupMenu:

[legend]
List of all members.

Public Member Functions

float | getFadeInTime (void) const
Get the fade in time for this popup menu.
float | getFadeOutTime (void) const
Get the fade out time for this popup menu.
void | setFadeInTime (float fadetime)
Set the fade in time for this popup menu.
void | setFadeOutTime (float fadetime)
Set the fade out time for this popup menu.
void | openPopupMenu (void)
Tells the popup menu to open.
void | closePopupMenu (void)
Tells the popup menu to close.
PopupMenu (const String &type, const String &name)
Constructor for PopupMenu objects.
virtual | ~PopupMenu (void)
Destructor for PopupMenu objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.

Protected Member Functions

virtual void | updateSelf (float elapsed)
Perform actual update processing for this Window.
virtual void | layoutItemWidgets (void)
Setup size and position for the item widgets attached to this Listbox.
virtual Size | getContentSize (void)
Resizes the popup menu to exactly fit the content that is attached to it.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onAlphaChanged (WindowEventArgs &e)
Handler called when the window's alpha blend value is changed.

Protected Attributes

float | d_origAlpha
The original alpha of this window.
float | d_fadeElapsed
The time in seconds this popup menu has been fading.
float | d_fadeOutTime
The time in seconds it takes for this popup menu to fade out.
float | d_fadeInTime
The time in seconds it takes for this popup menu to fade in.
bool | d_fading
true if this popup menu is fading in/out. false if not
bool | d_fadingOut
true if this popup menu is fading out. false if fading in.

Detailed Description

Base class for popup menus.

Member Function Documentation

Size CEGUI::PopupMenu::getContentSize ( void ) [protected, virtual]

Resizes the popup menu to exactly fit the content that is attached to it.

Returns:
Nothing.

Implements CEGUI::ItemListBase.

float CEGUI::PopupMenu::getFadeInTime ( void ) const [inline]

Get the fade in time for this popup menu.

Returns:
The time in seconds that it takes for the popup to fade in. 0 if fading is disabled.

float CEGUI::PopupMenu::getFadeOutTime ( void ) const [inline]

Get the fade out time for this popup menu.

Returns:
The time in seconds that it takes for the popup to fade out. 0 if fading is disabled.

void CEGUI::PopupMenu::layoutItemWidgets ( void ) [protected, virtual]

Setup size and position for the item widgets attached to this Listbox.

Returns:
Nothing.

Implements CEGUI::ItemListBase.

void CEGUI::PopupMenu::onAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's alpha blend value is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::PopupMenu::setFadeInTime ( float fadetime ) [inline]

Set the fade in time for this popup menu.

Parameters:
fadetime The time in seconds that it takes for the popup to fade in. If this parameter is zero, fading is disabled.

void CEGUI::PopupMenu::setFadeOutTime ( float fadetime ) [inline]

Set the fade out time for this popup menu.

Parameters:
fadetime The time in seconds that it takes for the popup to fade out. If this parameter is zero, fading is disabled.

virtual bool CEGUI::PopupMenu::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::MenuBase.

void CEGUI::PopupMenu::updateSelf ( float elapsed ) [protected, virtual]

Perform actual update processing for this Window.

Parameters:
elapsed float value indicating the number of seconds elapsed since the last update call.
Returns:
Nothing.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Position Class Reference

CEGUI::WindowProperties::Position

CEGUI::WindowProperties::Position Class Reference

Property to access window position. More...

Inheritance diagram for CEGUI::WindowProperties::Position:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Position:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window position.

This property offers access to the position for the window, using the Windows active metrics mode.

Usage:
  • Name: Position
  • Format: "x:[float] y:[float]".
Where:
  • x:[float] specifies the x position co-ordinate as a floating point number, using the active metrics system for the Window.
  • y:[float] specifies the y position co-ordinate as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::Position::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Position::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ProgressBar Class Reference

CEGUI::ProgressBar

CEGUI::ProgressBar Class Reference

Base class for progress bars. More...

Inheritance diagram for CEGUI::ProgressBar:

[legend]
Collaboration diagram for CEGUI::ProgressBar:

[legend]
List of all members.

Public Member Functions

float | getProgress (void) const
return the current progress value
float | getStep (void) const
return the current step size
void | setProgress (float progress)
set the current progress.
void | setStepSize (float step_val)
set the size of the 'step' in percentage points (default is 0.01f or 1%).
void | step (void)
cause the progress to step
void | adjustProgress (float delta)
Modify the progress level by a specified delta.
ProgressBar (const String &type, const String &name)
Constructor for ProgressBar class.
virtual | ~ProgressBar (void)
Destructor for ProgressBar.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventProgressChanged
Event fired whenever the progress value changes.
static const String | EventProgressDone
Event fired when the progress bar reaches 100%.

Protected Member Functions

void | addProgressBarEvents (void)
Add progress bar specific events to the window.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onProgressChanged (WindowEventArgs &e)
event triggered when progress changes
virtual void | onProgressDone (WindowEventArgs &e)
event triggered when progress reaches 100%

Protected Attributes

float | d_progress
current progress (from 0.0f to 1.0f)
float | d_step
amount to 'step' progress by on a call to step()

Detailed Description

Base class for progress bars.

Member Function Documentation

void CEGUI::ProgressBar::adjustProgress ( float delta ) [inline]

Modify the progress level by a specified delta.

Parameters:
delta amount to adjust the progress by. Whatever this value is, the progress of the bar will be kept within the range: 0.0f <= progress <= 1.0f.
Returns:
Nothing.

void CEGUI::ProgressBar::setProgress ( float progress )

set the current progress.

Parameters:
progress The level of progress to set. If this value is >1.0f (100%) progress will be limited to 1.0f.
Returns:
Nothing.

void CEGUI::ProgressBar::setStepSize ( float step_val ) [inline]

set the size of the 'step' in percentage points (default is 0.01f or 1%).

Parameters:
step Amount to increase the progress by each time the step method is called.
Returns:
Nothing.

void CEGUI::ProgressBar::step ( void ) [inline]

cause the progress to step

The amount the progress bar will step can be changed by calling the setStepSize method. The default step size is 0.01f which is equal to 1%.

Returns:
Nothing.

virtual bool CEGUI::ProgressBar::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Property Class Reference

CEGUI::Property

CEGUI::Property Class Reference

An abstract class that defines the interface to access object properties by name. More...

Inheritance diagram for CEGUI::Property:

[legend]
Collaboration diagram for CEGUI::Property:

[legend]
List of all members.

Public Member Functions

Property (const String &name, const String &help, const String &defaultValue="", bool writesXML=true)
Creates a new Property object.
virtual | ~Property (void)
Destructor for Property objects.
const String & | getHelp (void) const
Return a String that describes the purpose and usage of this Property.
const String & | getName (void) const
Return a the name of this Property.
virtual String | get (const PropertyReceiver *receiver) const =0
Return the current value of the Property as a String.
virtual void | set (PropertyReceiver *receiver, const String &value)=0
Sets the value of the property.
virtual bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.
virtual String | getDefault (const PropertyReceiver *receiver) const
Returns the default value of the Property as a String.
void | writeXMLToStream (const PropertyReceiver *receiver, OutStream &out_stream) const
Writes out an XML representation of this class to the given stream.

Protected Attributes

String d_name
String that stores the Property name.
String d_help
String that stores the Property help text.
String d_default
String that stores the Property default value string.
bool | d_writeXML
Specifies whether writeXMLToStream should do anything for this property.

Detailed Description

An abstract class that defines the interface to access object properties by name.

Property objects allow (via a PropertySet) access to certain properties of objects by using simple get/set functions and the name of the property to be accessed.

Constructor & Destructor Documentation

CEGUI::Property::Property | ( | const String & | name,
 |  | const String & | help,
 |  | const String & | defaultValue = "",
 |  | bool | writesXML = true
 | ) | [inline]

Creates a new Property object.

Parameters:
name | String containing the name of the new Property.
help | String containing a description of the Property and it's usage.
defaultValue | String holding the textual representation of the default value for this Property
writesXML | Specifies whether the writeXMLToStream method should do anything for this Property. This enables selectivity in what properties within a PropertySet will get output as XML.

Member Function Documentation

virtual String CEGUI::Property::get ( const PropertyReceiver * receiver ) const [pure virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implemented in CEGUI::WindowProperties::RelativeMinSize, CEGUI::WindowProperties::RelativeMaxSize, CEGUI::WindowProperties::AbsoluteMinSize, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::MetricsMode, CEGUI::WindowProperties::ID, CEGUI::WindowProperties::Alpha, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::Text, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::ClippedByParent, CEGUI::WindowProperties::InheritsAlpha, CEGUI::WindowProperties::AlwaysOnTop, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::RestoreOldCapture, CEGUI::WindowProperties::DestroyedByParent, CEGUI::WindowProperties::Width, CEGUI::WindowProperties::RelativeWidth, CEGUI::WindowProperties::AbsoluteWidth, CEGUI::WindowProperties::Height, CEGUI::WindowProperties::RelativeHeight, CEGUI::WindowProperties::AbsoluteHeight, CEGUI::WindowProperties::Size, CEGUI::WindowProperties::RelativeSize, CEGUI::WindowProperties::AbsoluteSize, CEGUI::WindowProperties::XPosition, CEGUI::WindowProperties::RelativeXPosition, CEGUI::WindowProperties::AbsoluteXPosition, CEGUI::WindowProperties::YPosition, CEGUI::WindowProperties::RelativeYPosition, CEGUI::WindowProperties::AbsoluteYPosition, CEGUI::WindowProperties::Position, CEGUI::WindowProperties::RelativePosition, CEGUI::WindowProperties::AbsolutePosition, CEGUI::WindowProperties::Rect, CEGUI::WindowProperties::RelativeRect, CEGUI::WindowProperties::AbsoluteRect, CEGUI::WindowProperties::ZOrderChangeEnabled, CEGUI::WindowProperties::WantsMultiClickEvents, CEGUI::WindowProperties::MouseButtonDownAutoRepeat, CEGUI::WindowProperties::AutoRepeatDelay, CEGUI::WindowProperties::AutoRepeatRate, CEGUI::WindowProperties::DistributeCapturedInputs, CEGUI::WindowProperties::CustomTooltipType, CEGUI::WindowProperties::Tooltip, CEGUI::WindowProperties::InheritsTooltipText, CEGUI::WindowProperties::RiseOnClick, CEGUI::WindowProperties::VerticalAlignment, CEGUI::WindowProperties::HorizontalAlignment, CEGUI::ButtonBaseProperties::NormalTextColour, CEGUI::ButtonBaseProperties::HoverTextColour, CEGUI::ButtonBaseProperties::PushedTextColour, CEGUI::ButtonBaseProperties::DisabledTextColour, CEGUI::CheckboxProperties::Selected, CEGUI::ComboboxProperties::ReadOnly, CEGUI::ComboboxProperties::ValidationString, CEGUI::ComboboxProperties::CaratIndex, CEGUI::ComboboxProperties::EditSelectionStart, CEGUI::ComboboxProperties::EditSelectionLength, CEGUI::ComboboxProperties::MaxEditTextLength, CEGUI::ComboboxProperties::NormalEditTextColour, CEGUI::ComboboxProperties::SelectedEditTextColour, CEGUI::ComboboxProperties::ActiveEditSelectionColour, CEGUI::ComboboxProperties::InactiveEditSelectionColour, CEGUI::ComboboxProperties::SortList, CEGUI::ComboboxProperties::ForceVertScrollbar, CEGUI::ComboboxProperties::ForceHorzScrollbar, CEGUI::ComboboxProperties::SingleClickMode, CEGUI::DragContainerProperties::DraggingEnabled, CEGUI::DragContainerProperties::DragAlpha, CEGUI::DragContainerProperties::DragThreshold, CEGUI::DragContainerProperties::DragCursorImage, CEGUI::EditboxProperties::ReadOnly, CEGUI::EditboxProperties::MaskText, CEGUI::EditboxProperties::MaskCodepoint, CEGUI::EditboxProperties::ValidationString, CEGUI::EditboxProperties::CaratIndex, CEGUI::EditboxProperties::SelectionStart, CEGUI::EditboxProperties::SelectionLength, CEGUI::EditboxProperties::MaxTextLength, CEGUI::EditboxProperties::NormalTextColour, CEGUI::EditboxProperties::SelectedTextColour, CEGUI::EditboxProperties::ActiveSelectionColour, CEGUI::EditboxProperties::InactiveSelectionColour, CEGUI::FrameWindowProperties::SizingEnabled, CEGUI::FrameWindowProperties::FrameEnabled, CEGUI::FrameWindowProperties::TitlebarEnabled, CEGUI::FrameWindowProperties::CloseButtonEnabled, CEGUI::FrameWindowProperties::RollUpEnabled, CEGUI::FrameWindowProperties::RollUpState, CEGUI::FrameWindowProperties::DragMovingEnabled, CEGUI::FrameWindowProperties::SizingBorderThickness, CEGUI::FrameWindowProperties::TitlebarFont, CEGUI::FrameWindowProperties::CaptionColour, CEGUI::FrameWindowProperties::NSSizingCursorImage, CEGUI::FrameWindowProperties::EWSizingCursorImage, CEGUI::FrameWindowProperties::NWSESizingCursorImage, CEGUI::FrameWindowProperties::NESWSizingCursorImage, CEGUI::ItemListBaseProperties::AutoResizeEnabled, CEGUI::ListboxProperties::Sort, CEGUI::ListboxProperties::MultiSelect, CEGUI::ListboxProperties::ForceVertScrollbar, CEGUI::ListboxProperties::ForceHorzScrollbar, CEGUI::ListboxProperties::ItemTooltips, CEGUI::ListHeaderProperties::ColumnsSizable, CEGUI::ListHeaderProperties::ColumnsMovable, CEGUI::ListHeaderProperties::SortSettingEnabled, CEGUI::ListHeaderProperties::SortDirection, CEGUI::ListHeaderProperties::SortColumnID, CEGUI::ListHeaderSegmentProperties::Sizable, CEGUI::ListHeaderSegmentProperties::Clickable, CEGUI::ListHeaderSegmentProperties::Dragable, CEGUI::ListHeaderSegmentProperties::SortDirection, CEGUI::MenuBaseProperties::ItemSpacing, CEGUI::MenuBaseProperties::HorzPadding, CEGUI::MenuBaseProperties::VertPadding, CEGUI::MenuBaseProperties::BorderWidth, CEGUI::MenuBaseProperties::BackgroundColours, CEGUI::MenuBaseProperties::AllowMultiplePopups, CEGUI::MenuItemProperties::HoverColour, CEGUI::MenuItemProperties::PushedColour, CEGUI::MenuItemProperties::OpenedColour, CEGUI::MenuItemProperties::NormalTextColour, CEGUI::MenuItemProperties::DisabledTextColour, CEGUI::MultiColumnListProperties::ColumnsSizable, CEGUI::MultiColumnListProperties::ColumnsMovable, CEGUI::MultiColumnListProperties::SortSettingEnabled, CEGUI::MultiColumnListProperties::SortDirection, CEGUI::MultiColumnListProperties::SortColumnID, CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, CEGUI::MultiColumnListProperties::NominatedSelectionRow, CEGUI::MultiColumnListProperties::ForceVertScrollbar, CEGUI::MultiColumnListProperties::ForceHorzScrollbar, CEGUI::MultiColumnListProperties::SelectionMode, CEGUI::MultiColumnListProperties::ColumnHeader, CEGUI::MultiColumnListProperties::RowCount, CEGUI::MultiLineEditboxProperties::ReadOnly, CEGUI::MultiLineEditboxProperties::WordWrap, CEGUI::MultiLineEditboxProperties::CaratIndex, CEGUI::MultiLineEditboxProperties::SelectionStart, CEGUI::MultiLineEditboxProperties::SelectionLength, CEGUI::MultiLineEditboxProperties::MaxTextLength, CEGUI::MultiLineEditboxProperties::NormalTextColour, CEGUI::MultiLineEditboxProperties::SelectedTextColour, CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, CEGUI::PopupMenuProperties::FadeInTime, CEGUI::PopupMenuProperties::FadeOutTime, CEGUI::ProgressBarProperties::CurrentProgress, CEGUI::ProgressBarProperties::StepSize, CEGUI::PushButtonProperties::NormalImage, CEGUI::PushButtonProperties::PushedImage, CEGUI::PushButtonProperties::HoverImage, CEGUI::PushButtonProperties::DisabledImage, CEGUI::PushButtonProperties::UseStandardImagery, CEGUI::PushButtonProperties::TextXOffset, CEGUI::RadioButtonProperties::Selected, CEGUI::RadioButtonProperties::GroupID, CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, CEGUI::ScrollablePaneProperties::ContentArea, CEGUI::ScrollablePaneProperties::ForceVertScrollbar, CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, CEGUI::ScrollablePaneProperties::HorzStepSize, CEGUI::ScrollablePaneProperties::HorzOverlapSize, CEGUI::ScrollablePaneProperties::HorzScrollPosition, CEGUI::ScrollablePaneProperties::VertStepSize, CEGUI::ScrollablePaneProperties::VertOverlapSize, CEGUI::ScrollablePaneProperties::VertScrollPosition, CEGUI::ScrollbarProperties::DocumentSize, CEGUI::ScrollbarProperties::PageSize, CEGUI::ScrollbarProperties::StepSize, CEGUI::ScrollbarProperties::OverlapSize, CEGUI::ScrollbarProperties::ScrollPosition, CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, CEGUI::ScrolledContainerProperties::ContentArea, CEGUI::ScrolledContainerProperties::ChildExtentsArea, CEGUI::SliderProperties::CurrentValue, CEGUI::SliderProperties::MaximumValue, CEGUI::SliderProperties::ClickStepSize, CEGUI::SpinnerProperties::CurrentValue, CEGUI::SpinnerProperties::StepSize, CEGUI::SpinnerProperties::MinimumValue, CEGUI::SpinnerProperties::MaximumValue, CEGUI::SpinnerProperties::TextInputMode, CEGUI::StaticImageProperties::Image, CEGUI::StaticImageProperties::ImageColours, CEGUI::StaticImageProperties::HorzFormatting, CEGUI::StaticImageProperties::VertFormatting, CEGUI::StaticProperties::FrameEnabled, CEGUI::StaticProperties::BackgroundEnabled, CEGUI::StaticProperties::FrameColours, CEGUI::StaticProperties::BackgroundColours, CEGUI::StaticProperties::BackgroundImage, CEGUI::StaticProperties::TopLeftFrameImage, CEGUI::StaticProperties::TopRightFrameImage, CEGUI::StaticProperties::BottomLeftFrameImage, CEGUI::StaticProperties::BottomRightFrameImage, CEGUI::StaticProperties::LeftFrameImage, CEGUI::StaticProperties::RightFrameImage, CEGUI::StaticProperties::TopFrameImage, CEGUI::StaticProperties::BottomFrameImage, CEGUI::StaticTextProperties::TextColours, CEGUI::StaticTextProperties::HorzFormatting, CEGUI::StaticTextProperties::VertFormatting, CEGUI::StaticTextProperties::VertScrollbar, CEGUI::StaticTextProperties::HorzScrollbar, CEGUI::TabControlProperties::TabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::RelativeTabHeight, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::AbsoluteTabTextPadding, CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TextItemProperties::TextXOffset, CEGUI::TextItemProperties::TextColour, CEGUI::TextItemProperties::TextFormatting, CEGUI::ThumbProperties::HotTracked, CEGUI::ThumbProperties::VertFree, CEGUI::ThumbProperties::HorzFree, CEGUI::ThumbProperties::VertRange, CEGUI::ThumbProperties::HorzRange, CEGUI::TitlebarProperties::DraggingEnabled, CEGUI::TitlebarProperties::CaptionColour, CEGUI::TooltipProperties::HoverTime, CEGUI::TooltipProperties::DisplayTime, CEGUI::TooltipProperties::FadeTime, and CEGUI::PropertyDefinition.

String CEGUI::Property::getDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns the default value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the default value for this property.

Reimplemented in CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::TabControlProperties::TabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabTextPadding, and CEGUI::TabControlProperties::RelativeTabTextPadding.

const String& CEGUI::Property::getHelp ( void ) const [inline]

Return a String that describes the purpose and usage of this Property.

Returns:
String that contains the help text

const String& CEGUI::Property::getName ( void ) const [inline]

Return a the name of this Property.

Returns:
String containing the name of the Property

bool CEGUI::Property::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented in CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::Visible, CEGUI::TabControlProperties::TabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabTextPadding, and CEGUI::TabControlProperties::RelativeTabTextPadding.

virtual void CEGUI::Property::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [pure virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implemented in CEGUI::WindowProperties::RelativeMinSize, CEGUI::WindowProperties::RelativeMaxSize, CEGUI::WindowProperties::AbsoluteMinSize, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::MetricsMode, CEGUI::WindowProperties::ID, CEGUI::WindowProperties::Alpha, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::Text, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::ClippedByParent, CEGUI::WindowProperties::InheritsAlpha, CEGUI::WindowProperties::AlwaysOnTop, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::RestoreOldCapture, CEGUI::WindowProperties::DestroyedByParent, CEGUI::WindowProperties::Width, CEGUI::WindowProperties::RelativeWidth, CEGUI::WindowProperties::AbsoluteWidth, CEGUI::WindowProperties::Height, CEGUI::WindowProperties::RelativeHeight, CEGUI::WindowProperties::AbsoluteHeight, CEGUI::WindowProperties::Size, CEGUI::WindowProperties::RelativeSize, CEGUI::WindowProperties::AbsoluteSize, CEGUI::WindowProperties::XPosition, CEGUI::WindowProperties::RelativeXPosition, CEGUI::WindowProperties::AbsoluteXPosition, CEGUI::WindowProperties::YPosition, CEGUI::WindowProperties::RelativeYPosition, CEGUI::WindowProperties::AbsoluteYPosition, CEGUI::WindowProperties::Position, CEGUI::WindowProperties::RelativePosition, CEGUI::WindowProperties::AbsolutePosition, CEGUI::WindowProperties::Rect, CEGUI::WindowProperties::RelativeRect, CEGUI::WindowProperties::AbsoluteRect, CEGUI::WindowProperties::ZOrderChangeEnabled, CEGUI::WindowProperties::WantsMultiClickEvents, CEGUI::WindowProperties::MouseButtonDownAutoRepeat, CEGUI::WindowProperties::AutoRepeatDelay, CEGUI::WindowProperties::AutoRepeatRate, CEGUI::WindowProperties::DistributeCapturedInputs, CEGUI::WindowProperties::CustomTooltipType, CEGUI::WindowProperties::Tooltip, CEGUI::WindowProperties::InheritsTooltipText, CEGUI::WindowProperties::RiseOnClick, CEGUI::WindowProperties::VerticalAlignment, CEGUI::WindowProperties::HorizontalAlignment, CEGUI::ButtonBaseProperties::NormalTextColour, CEGUI::ButtonBaseProperties::HoverTextColour, CEGUI::ButtonBaseProperties::PushedTextColour, CEGUI::ButtonBaseProperties::DisabledTextColour, CEGUI::CheckboxProperties::Selected, CEGUI::ComboboxProperties::ReadOnly, CEGUI::ComboboxProperties::ValidationString, CEGUI::ComboboxProperties::CaratIndex, CEGUI::ComboboxProperties::EditSelectionStart, CEGUI::ComboboxProperties::EditSelectionLength, CEGUI::ComboboxProperties::MaxEditTextLength, CEGUI::ComboboxProperties::NormalEditTextColour, CEGUI::ComboboxProperties::SelectedEditTextColour, CEGUI::ComboboxProperties::ActiveEditSelectionColour, CEGUI::ComboboxProperties::InactiveEditSelectionColour, CEGUI::ComboboxProperties::SortList, CEGUI::ComboboxProperties::ForceVertScrollbar, CEGUI::ComboboxProperties::ForceHorzScrollbar, CEGUI::ComboboxProperties::SingleClickMode, CEGUI::DragContainerProperties::DraggingEnabled, CEGUI::DragContainerProperties::DragAlpha, CEGUI::DragContainerProperties::DragThreshold, CEGUI::DragContainerProperties::DragCursorImage, CEGUI::EditboxProperties::ReadOnly, CEGUI::EditboxProperties::MaskText, CEGUI::EditboxProperties::MaskCodepoint, CEGUI::EditboxProperties::ValidationString, CEGUI::EditboxProperties::CaratIndex, CEGUI::EditboxProperties::SelectionStart, CEGUI::EditboxProperties::SelectionLength, CEGUI::EditboxProperties::MaxTextLength, CEGUI::EditboxProperties::NormalTextColour, CEGUI::EditboxProperties::SelectedTextColour, CEGUI::EditboxProperties::ActiveSelectionColour, CEGUI::EditboxProperties::InactiveSelectionColour, CEGUI::FrameWindowProperties::SizingEnabled, CEGUI::FrameWindowProperties::FrameEnabled, CEGUI::FrameWindowProperties::TitlebarEnabled, CEGUI::FrameWindowProperties::CloseButtonEnabled, CEGUI::FrameWindowProperties::RollUpEnabled, CEGUI::FrameWindowProperties::RollUpState, CEGUI::FrameWindowProperties::DragMovingEnabled, CEGUI::FrameWindowProperties::SizingBorderThickness, CEGUI::FrameWindowProperties::TitlebarFont, CEGUI::FrameWindowProperties::CaptionColour, CEGUI::FrameWindowProperties::NSSizingCursorImage, CEGUI::FrameWindowProperties::EWSizingCursorImage, CEGUI::FrameWindowProperties::NWSESizingCursorImage, CEGUI::FrameWindowProperties::NESWSizingCursorImage, CEGUI::ItemListBaseProperties::AutoResizeEnabled, CEGUI::ListboxProperties::Sort, CEGUI::ListboxProperties::MultiSelect, CEGUI::ListboxProperties::ForceVertScrollbar, CEGUI::ListboxProperties::ForceHorzScrollbar, CEGUI::ListboxProperties::ItemTooltips, CEGUI::ListHeaderProperties::ColumnsSizable, CEGUI::ListHeaderProperties::ColumnsMovable, CEGUI::ListHeaderProperties::SortSettingEnabled, CEGUI::ListHeaderProperties::SortDirection, CEGUI::ListHeaderProperties::SortColumnID, CEGUI::ListHeaderSegmentProperties::Sizable, CEGUI::ListHeaderSegmentProperties::Clickable, CEGUI::ListHeaderSegmentProperties::Dragable, CEGUI::ListHeaderSegmentProperties::SortDirection, CEGUI::MenuBaseProperties::ItemSpacing, CEGUI::MenuBaseProperties::HorzPadding, CEGUI::MenuBaseProperties::VertPadding, CEGUI::MenuBaseProperties::BorderWidth, CEGUI::MenuBaseProperties::BackgroundColours, CEGUI::MenuBaseProperties::AllowMultiplePopups, CEGUI::MenuItemProperties::HoverColour, CEGUI::MenuItemProperties::PushedColour, CEGUI::MenuItemProperties::OpenedColour, CEGUI::MenuItemProperties::NormalTextColour, CEGUI::MenuItemProperties::DisabledTextColour, CEGUI::MultiColumnListProperties::ColumnsSizable, CEGUI::MultiColumnListProperties::ColumnsMovable, CEGUI::MultiColumnListProperties::SortSettingEnabled, CEGUI::MultiColumnListProperties::SortDirection, CEGUI::MultiColumnListProperties::SortColumnID, CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, CEGUI::MultiColumnListProperties::NominatedSelectionRow, CEGUI::MultiColumnListProperties::ForceVertScrollbar, CEGUI::MultiColumnListProperties::ForceHorzScrollbar, CEGUI::MultiColumnListProperties::SelectionMode, CEGUI::MultiColumnListProperties::ColumnHeader, CEGUI::MultiColumnListProperties::RowCount, CEGUI::MultiLineEditboxProperties::ReadOnly, CEGUI::MultiLineEditboxProperties::WordWrap, CEGUI::MultiLineEditboxProperties::CaratIndex, CEGUI::MultiLineEditboxProperties::SelectionStart, CEGUI::MultiLineEditboxProperties::SelectionLength, CEGUI::MultiLineEditboxProperties::MaxTextLength, CEGUI::MultiLineEditboxProperties::NormalTextColour, CEGUI::MultiLineEditboxProperties::SelectedTextColour, CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, CEGUI::PopupMenuProperties::FadeInTime, CEGUI::PopupMenuProperties::FadeOutTime, CEGUI::ProgressBarProperties::CurrentProgress, CEGUI::ProgressBarProperties::StepSize, CEGUI::PushButtonProperties::NormalImage, CEGUI::PushButtonProperties::PushedImage, CEGUI::PushButtonProperties::HoverImage, CEGUI::PushButtonProperties::DisabledImage, CEGUI::PushButtonProperties::UseStandardImagery, CEGUI::PushButtonProperties::TextXOffset, CEGUI::RadioButtonProperties::Selected, CEGUI::RadioButtonProperties::GroupID, CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, CEGUI::ScrollablePaneProperties::ContentArea, CEGUI::ScrollablePaneProperties::ForceVertScrollbar, CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, CEGUI::ScrollablePaneProperties::HorzStepSize, CEGUI::ScrollablePaneProperties::HorzOverlapSize, CEGUI::ScrollablePaneProperties::HorzScrollPosition, CEGUI::ScrollablePaneProperties::VertStepSize, CEGUI::ScrollablePaneProperties::VertOverlapSize, CEGUI::ScrollablePaneProperties::VertScrollPosition, CEGUI::ScrollbarProperties::DocumentSize, CEGUI::ScrollbarProperties::PageSize, CEGUI::ScrollbarProperties::StepSize, CEGUI::ScrollbarProperties::OverlapSize, CEGUI::ScrollbarProperties::ScrollPosition, CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, CEGUI::ScrolledContainerProperties::ContentArea, CEGUI::ScrolledContainerProperties::ChildExtentsArea, CEGUI::SliderProperties::CurrentValue, CEGUI::SliderProperties::MaximumValue, CEGUI::SliderProperties::ClickStepSize, CEGUI::SpinnerProperties::CurrentValue, CEGUI::SpinnerProperties::StepSize, CEGUI::SpinnerProperties::MinimumValue, CEGUI::SpinnerProperties::MaximumValue, CEGUI::SpinnerProperties::TextInputMode, CEGUI::StaticImageProperties::Image, CEGUI::StaticImageProperties::ImageColours, CEGUI::StaticImageProperties::HorzFormatting, CEGUI::StaticImageProperties::VertFormatting, CEGUI::StaticProperties::FrameEnabled, CEGUI::StaticProperties::BackgroundEnabled, CEGUI::StaticProperties::FrameColours, CEGUI::StaticProperties::BackgroundColours, CEGUI::StaticProperties::BackgroundImage, CEGUI::StaticProperties::TopLeftFrameImage, CEGUI::StaticProperties::TopRightFrameImage, CEGUI::StaticProperties::BottomLeftFrameImage, CEGUI::StaticProperties::BottomRightFrameImage, CEGUI::StaticProperties::LeftFrameImage, CEGUI::StaticProperties::RightFrameImage, CEGUI::StaticProperties::TopFrameImage, CEGUI::StaticProperties::BottomFrameImage, CEGUI::StaticTextProperties::TextColours, CEGUI::StaticTextProperties::HorzFormatting, CEGUI::StaticTextProperties::VertFormatting, CEGUI::StaticTextProperties::VertScrollbar, CEGUI::StaticTextProperties::HorzScrollbar, CEGUI::TabControlProperties::TabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::RelativeTabHeight, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::AbsoluteTabTextPadding, CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TextItemProperties::TextXOffset, CEGUI::TextItemProperties::TextColour, CEGUI::TextItemProperties::TextFormatting, CEGUI::ThumbProperties::HotTracked, CEGUI::ThumbProperties::VertFree, CEGUI::ThumbProperties::HorzFree, CEGUI::ThumbProperties::VertRange, CEGUI::ThumbProperties::HorzRange, CEGUI::TitlebarProperties::DraggingEnabled, CEGUI::TitlebarProperties::CaptionColour, CEGUI::TooltipProperties::HoverTime, CEGUI::TooltipProperties::DisplayTime, CEGUI::TooltipProperties::FadeTime, and CEGUI::PropertyDefinition.

void CEGUI::Property::writeXMLToStream | ( | const PropertyReceiver * | receiver,
 |  | OutStream & | out_stream
 | ) | const

Writes out an XML representation of this class to the given stream.

Note:
This would normally have been implemented via XMLGenerator base class, but in this case we require the target PropertyReceiver in order to obtain the property value.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PropertyDefinition Class Reference

CEGUI::PropertyDefinition

CEGUI::PropertyDefinition Class Reference

class representing a new property to be available on all widgets that use the WidgetLook that this PropertyDefinition is defiend for. More...

Inheritance diagram for CEGUI::PropertyDefinition:

[legend]
Collaboration diagram for CEGUI::PropertyDefinition:

[legend]
List of all members.

Public Member Functions

PropertyDefinition (const String &name, const String &initialValue, bool redrawOnWrite, bool layoutOnWrite)
String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this PropertyDefinition to out_stream.

Protected Attributes

String | d_userStringName
bool | d_writeCausesRedraw
bool | d_writeCausesLayout

Detailed Description

class representing a new property to be available on all widgets that use the WidgetLook that this PropertyDefinition is defiend for.

Member Function Documentation

String CEGUI::PropertyDefinition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PropertyDefinition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

void CEGUI::PropertyDefinition::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this PropertyDefinition to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PropertyDim Class Reference

CEGUI::PropertyDim

CEGUI::PropertyDim Class Reference

Dimension type that represents the value of a Window property. Implements BaseDim interface. More...

Inheritance diagram for CEGUI::PropertyDim:

[legend]
Collaboration diagram for CEGUI::PropertyDim:

[legend]
List of all members.

Public Member Functions

PropertyDim (const String &name, const String &property)
Constructor.

Protected Member Functions

float | getValue_impl (const Window &wnd) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
float | getValue_impl (const Window &wnd, const Rect &container) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
void | writeXMLElementName_impl (OutStream &out_stream) const
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
void | writeXMLElementAttributes_impl (OutStream &out_stream) const
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.
BaseDim * | clone_impl () const
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.

Detailed Description

Dimension type that represents the value of a Window property. Implements BaseDim interface.

Constructor & Destructor Documentation

CEGUI::PropertyDim::PropertyDim | ( | const String & | name,
 |  | const String & | property
 | ) |

Constructor.

Parameters:
name | String holding the name suffix of the window on which the property is to be accessed.
property | String object holding the name of the property this PropertyDim represents the value of. The property named should represent a simple float value.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PropertyHelper Class Reference

CEGUI::PropertyHelper

CEGUI::PropertyHelper Class Reference

Helper class used to convert various data types to and from the format expected in Propery strings. More...

List of all members.

Static Public Member Functions

static float | stringToFloat (const String &str)
static uint | stringToUint (const String &str)
static int | stringToInt (const String &str)
static bool | stringToBool (const String &str)
static Size | stringToSize (const String &str)
static Point | stringToPoint (const String &str)
static Rect | stringToRect (const String &str)
static MetricsMode | stringToMetricsMode (const String &str)
static const Image * | stringToImage (const String &str)
static colour | stringToColour (const String &str)
static ColourRect | stringToColourRect (const String &str)
static UDim | stringToUDim (const String &str)
static UVector2 | stringToUVector2 (const String &str)
static URect | stringToURect (const String &str)
static String | floatToString (float val)
static String | uintToString (uint val)
static String | intToString (int val)
static String | boolToString (bool val)
static String | sizeToString (const Size &val)
static String | pointToString (const Point &val)
static String | rectToString (const Rect &val)
static String | metricsModeToString (MetricsMode val)
static String | imageToString (const Image *const val)
static String | colourToString (const colour &val)
static String | colourRectToString (const ColourRect &val)
static String | udimToString (const UDim &val)
static String | uvector2ToString (const UVector2 &val)
static String | urectToString (const URect &val)

Detailed Description

Helper class used to convert various data types to and from the format expected in Propery strings.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PropertyInitialiser Class Reference

CEGUI::PropertyInitialiser

CEGUI::PropertyInitialiser Class Reference

Class that holds information about a property and it's required initial value. More...

Collaboration diagram for CEGUI::PropertyInitialiser:

[legend]
List of all members.

Public Member Functions

PropertyInitialiser (const String &property, const String &value)
Constructor.
void | apply (PropertySet &target) const
Apply this property initialiser to the specified target CEGUI::PropertySet object.
const String & | getTargetPropertyName () const
Return the name of the property targetted by this PropertyInitialiser.
const String & | getInitialiserValue () const
Return the value string to be set on the property targetted by this PropertyInitialiser.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this PropertyInitialiser to out_stream.

Detailed Description

Class that holds information about a property and it's required initial value.

Constructor & Destructor Documentation

CEGUI::PropertyInitialiser::PropertyInitialiser | ( | const String & | property,
 |  | const String & | value
 | ) |

Constructor.

Parameters:
property | String holding the name of the property targetted by this PropertyInitialiser.
value | String holding the value to be set by this PropertyInitialiser.

Member Function Documentation

void CEGUI::PropertyInitialiser::apply ( PropertySet & target ) const

Apply this property initialiser to the specified target CEGUI::PropertySet object.

Parameters:
target CEGUI::PropertySet object to be initialised by this PropertyInitialiser.
Returns:
Nothing.

const String & CEGUI::PropertyInitialiser::getInitialiserValue ( ) const

Return the value string to be set on the property targetted by this PropertyInitialiser.

Returns:
String object holding the value string.

const String & CEGUI::PropertyInitialiser::getTargetPropertyName ( ) const

Return the name of the property targetted by this PropertyInitialiser.

Returns:
String object holding the name of the target property.

void CEGUI::PropertyInitialiser::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this PropertyInitialiser to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PropertyReceiver Class Reference

CEGUI::PropertyReceiver

CEGUI::PropertyReceiver Class Reference

Dummy base class to ensure correct casting of receivers. More...

Inheritance diagram for CEGUI::PropertyReceiver:

[legend]
List of all members.

Detailed Description

Dummy base class to ensure correct casting of receivers.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PropertySet Class Reference

CEGUI::PropertySet

CEGUI::PropertySet Class Reference

Class that contains a collection of Property objects. More...

Inheritance diagram for CEGUI::PropertySet:

[legend]
Collaboration diagram for CEGUI::PropertySet:

[legend]
List of all members.

Public Types

typedef ConstBaseIterator<
PropertyRegistry > 		PropertyIterator

Public Member Functions

PropertySet (void)
Constructs a new PropertySet object.
virtual | ~PropertySet (void)
Destructor for PropertySet objects.
void | addProperty (Property *property)
Adds a new Property to the PropertySet.
void | removeProperty (const String &name)
Removes a Property from the PropertySet.
void | clearProperties (void)
Removes all Property objects from the PropertySet.
bool | isPropertyPresent (const String &name) const
Checks to see if a Property with the given name is in the PropertySet.
const String & | getPropertyHelp (const String &name) const
Return the help text for the specified Property.
String | getProperty (const String &name) const
Gets the current value of the specified Property.
void | setProperty (const String &name, const String &value)
Sets the current value of a Property.
bool | isPropertyDefault (const String &name) const
Returns whether a Property is at it's default value.
String | getPropertyDefault (const String &name) const
Returns the default value of a Property as a String.
PropertyIterator | getIterator (void) const
Return a PropertySet::PropertyIterator object to iterate over the available Properties.

Detailed Description

Class that contains a collection of Property objects.

Member Function Documentation

void CEGUI::PropertySet::addProperty ( Property * property )

Adds a new Property to the PropertySet.

Parameters:
property Pointer to the Property object to be added to the PropertySet.
Returns:
Nothing.
Exceptions:
NullObjectException | Thrown if property is NULL.
AlreadyExistsException | Thrown if a Property with the same name as property already exists in the PropertySet

void CEGUI::PropertySet::clearProperties ( void )

Removes all Property objects from the PropertySet.

Returns:
Nothing.

String CEGUI::PropertySet::getProperty ( const String & name ) const

Gets the current value of the specified Property.

Parameters:
name String containing the name of the Property who's value is to be returned.
Returns:
String object containing a textual representation of the requested Property.
Exceptions:
UnknownObjectException Thrown if no Property named name is in the PropertySet.

String CEGUI::PropertySet::getPropertyDefault ( const String & name ) const

Returns the default value of a Property as a String.

Parameters:
name String containing the name of the Property who's default string is to be returned.
Returns:
String object containing a textual representation of the default value for this property.

const String & CEGUI::PropertySet::getPropertyHelp ( const String & name ) const

Return the help text for the specified Property.

Parameters:
name String holding the name of the Property who's help text is to be returned.
Returns:
String object containing the help text for the Property name.
Exceptions:
UnknownObjectException Thrown if no Property named name is in the PropertySet.

bool CEGUI::PropertySet::isPropertyDefault ( const String & name ) const

Returns whether a Property is at it's default value.

Parameters:
name String containing the name of the Property who's default state is to be tested.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

bool CEGUI::PropertySet::isPropertyPresent ( const String & name ) const

Checks to see if a Property with the given name is in the PropertySet.

Parameters:
name String containing the name of the Property to check for.
Returns:
true if a Property named name is in the PropertySet. false if no Property named name is in the PropertySet.

void CEGUI::PropertySet::removeProperty ( const String & name )

Removes a Property from the PropertySet.

Parameters:
name String containing the name of the Property to be removed. If Property name is not in the set, nothing happens.
Returns:
Nothing.

void CEGUI::PropertySet::setProperty | ( | const String & | name,
 |  | const String & | value
 | ) |

Sets the current value of a Property.

Parameters:
name | String containing the name of the Property who's value is to be set.
value | String containing a textual representation of the new value for the Property
Returns:
Nothing
Exceptions:
UnknownObjectException | Thrown if no Property named name is in the PropertySet.
InvalidRequestException | Thrown when the Property was unable to interpret the content of value.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButton Class Reference

CEGUI::PushButton

CEGUI::PushButton Class Reference

Base class to provide logic for push button type widgets. More...

Inheritance diagram for CEGUI::PushButton:

[legend]
Collaboration diagram for CEGUI::PushButton:

[legend]
List of all members.

Public Member Functions

PushButton (const String &type, const String &name)
Constructor for base PushButton class.
virtual | ~PushButton (void)
Destructor for PushButton class.
bool | isStandardImageryEnabled (void) const
return whether or not rendering of the standard imagery is enabled.
bool | isCustomImageryAutoSized (void) const
Return whether of not custom button image areas are auto-scaled to the size of the button.
const RenderableImage * | getNormalImage (void) const
returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the normal state, or 0 if no image is currently set for this state.
const RenderableImage * | getHoverImage (void) const
returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the highlighted state, or 0 if no image is currently set for this state.
const RenderableImage * | getPushedImage (void) const
returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the pushed state, or 0 if no image is currently set for this state.
const RenderableImage * | getDisabledImage (void) const
returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the disabled state, or 0 if no image is currently set for this state.
float | getTextXOffset (void) const
get the offset that is used to shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered
void | setStandardImageryEnabled (bool setting)
set whether or not to render the standard imagery for the button
void | setCustomImageryAutoSized (bool setting)
Set whether to auto re-size custom image areas when the button is sized.
void | setNormalImage (const RenderableImage *image)
set the details of the image to render for the button in the normal state.
void | setHoverImage (const RenderableImage *image)
set the details of the image to render for the button in the highlighted state.
void | setPushedImage (const RenderableImage *image)
set the details of the image to render for the button in the pushed state.
void | setDisabledImage (const RenderableImage *image)
set the details of the image to render for the button in the disabled state.
void | setTextXOffset (float offset)
set the offset to use for a shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventClicked
The button was clicked.

Protected Member Functions

virtual void | onClicked (WindowEventArgs &e)
handler invoked internally when the button is clicked.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
void | addPushButtonEvents (void)
Add button specific events.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

bool | d_autoscaleImages
when true custom images will be scaled to the same size as the button
bool | d_useStandardImagery
true if button standard imagery should be drawn.
bool | d_useNormalImage
true if an image should be drawn for the normal state.
bool | d_useHoverImage
true if an image should be drawn for the highlighted state.
bool | d_usePushedImage
true if an image should be drawn for the pushed state.
bool | d_useDisabledImage
true if an image should be drawn for the disabled state.
RenderableImage d_normalImage
RenderableImage used when rendering an image in the normal state.
RenderableImage d_hoverImage
RenderableImage used when rendering an image in the highlighted state.
RenderableImage d_pushedImage
RenderableImage used when rendering an image in the pushed state.
RenderableImage d_disabledImage
RenderableImage used when rendering an image in the disabled state.
float | d_textXOffset
offset applied to the x co-ordinate of the text label.

Detailed Description

Base class to provide logic for push button type widgets.

Member Function Documentation

const RenderableImage * CEGUI::PushButton::getDisabledImage ( void ) const

returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the disabled state, or 0 if no image is currently set for this state.

Returns:
Pointer to a const RenderableImage object with all the details for the image.

const RenderableImage * CEGUI::PushButton::getHoverImage ( void ) const

returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the highlighted state, or 0 if no image is currently set for this state.

Returns:
Pointer to a const RenderableImage object with all the details for the image.

const RenderableImage * CEGUI::PushButton::getNormalImage ( void ) const

returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the normal state, or 0 if no image is currently set for this state.

Returns:
Pointer to a const RenderableImage object with all the details for the image.

const RenderableImage * CEGUI::PushButton::getPushedImage ( void ) const

returns a pointer to a read-only RenderableImage object holding the details of the image set to render for the button in the pushed state, or 0 if no image is currently set for this state.

Returns:
Pointer to a const RenderableImage object with all the details for the image.

float CEGUI::PushButton::getTextXOffset ( void ) const

get the offset that is used to shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered

Returns:
the offset relative to the button-size

bool CEGUI::PushButton::isCustomImageryAutoSized ( void ) const

Return whether of not custom button image areas are auto-scaled to the size of the button.

Returns:
true if client specified custom image areas are re-sized when the button size changes. false if image areas will remain unchanged when the button is sized.

bool CEGUI::PushButton::isStandardImageryEnabled ( void ) const

return whether or not rendering of the standard imagery is enabled.

Returns:
true if the standard button imagery will be rendered, false if no standard rendering will be performed.

void CEGUI::PushButton::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::ButtonBase.

void CEGUI::PushButton::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::PushButton::setCustomImageryAutoSized ( bool setting )

Set whether to auto re-size custom image areas when the button is sized.

Parameters:
setting true to have custom image areas auto-sized. false to have system leave image areas untouched.
Returns:
Nothing.

void CEGUI::PushButton::setDisabledImage ( const RenderableImage * image )

set the details of the image to render for the button in the disabled state.

Parameters:
image RenderableImage object with all the details for the image. Note that an internal copy of the Renderable image is made and ownership of image remains with client code. If this parameter is NULL, rendering of an image for this button state is disabled.
Returns:
Nothing.

void CEGUI::PushButton::setHoverImage ( const RenderableImage * image )

set the details of the image to render for the button in the highlighted state.

Parameters:
image RenderableImage object with all the details for the image. Note that an internal copy of the Renderable image is made and ownership of image remains with client code. If this parameter is NULL, rendering of an image for this button state is disabled.
Returns:
Nothing.

void CEGUI::PushButton::setNormalImage ( const RenderableImage * image )

set the details of the image to render for the button in the normal state.

Parameters:
image RenderableImage object with all the details for the image. Note that an internal copy of the Renderable image is made and ownership of image remains with client code. If this parameter is NULL, rendering of an image for this button state is disabled.
Returns:
Nothing.

void CEGUI::PushButton::setPushedImage ( const RenderableImage * image )

set the details of the image to render for the button in the pushed state.

Parameters:
image RenderableImage object with all the details for the image. Note that an internal copy of the Renderable image is made and ownership of image remains with client code. If this parameter is NULL, rendering of an image for this button state is disabled.
Returns:
Nothing.

void CEGUI::PushButton::setStandardImageryEnabled ( bool setting )

set whether or not to render the standard imagery for the button

Parameters:
setting true to have the standard button imagery drawn, false to have no standard imagery drawn.
Returns:
Nothing.

void CEGUI::PushButton::setTextXOffset ( float offset )

set the offset to use for a shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered

Parameters:
offset The offset to use. This is relative to the button-width
Returns:
Nothing.

virtual bool CEGUI::PushButton::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::ButtonBase.

Reimplemented in CEGUI::Thumb.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuItemProperties::PushedColour Class Reference

CEGUI::MenuItemProperties::PushedColour

CEGUI::MenuItemProperties::PushedColour Class Reference

Property to access the pushed colour of the item. More...

Inheritance diagram for CEGUI::MenuItemProperties::PushedColour:

[legend]
Collaboration diagram for CEGUI::MenuItemProperties::PushedColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the pushed colour of the item.

Usage:
  • Name: PushedColour
  • Format: "[aarrggbb]".
Where:
  • [aarrggbb] represents the pushed colour of the item.

Member Function Documentation

String CEGUI::MenuItemProperties::PushedColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuItemProperties::PushedColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties::PushedImage Class Reference

CEGUI::PushButtonProperties::PushedImage

CEGUI::PushButtonProperties::PushedImage Class Reference

Property to access the pushed image of the button. More...

Inheritance diagram for CEGUI::PushButtonProperties::PushedImage:

[legend]
Collaboration diagram for CEGUI::PushButtonProperties::PushedImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the pushed image of the button.

Usage:
  • Name: PushedImage
  • Format: "set:<imageset> image:<imagename>".

Member Function Documentation

String CEGUI::PushButtonProperties::PushedImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PushButtonProperties::PushedImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ButtonBaseProperties::PushedTextColour Class Reference

CEGUI::ButtonBaseProperties::PushedTextColour

CEGUI::ButtonBaseProperties::PushedTextColour Class Reference

Property to access the pushed text colour. More...

Inheritance diagram for CEGUI::ButtonBaseProperties::PushedTextColour:

[legend]
Collaboration diagram for CEGUI::ButtonBaseProperties::PushedTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the pushed text colour.

This property offers access to the colour value to be used for rendering the button caption text for the pushed state.

Usage:
  • Name: PushedTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ButtonBaseProperties::PushedTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ButtonBaseProperties::PushedTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RadioButton Class Reference

CEGUI::RadioButton

CEGUI::RadioButton Class Reference

Base class to provide the logic for Radio Button widgets. More...

Inheritance diagram for CEGUI::RadioButton:

[legend]
Collaboration diagram for CEGUI::RadioButton:

[legend]
List of all members.

Public Member Functions

bool | isSelected (void) const
return true if the radio button is selected (has the checkmark)
ulong | getGroupID (void) const
return the groupID assigned to this radio button
RadioButton * | getSelectedButtonInGroup (void) const
Return a pointer to the RadioButton object within the same group as this RadioButton, that is currently selected.
void | setSelected (bool select)
set whether the radio button is selected or not
void | setGroupID (ulong group)
set the groupID for this radio button
RadioButton (const String &type, const String &name)

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventSelectStateChanged
The selected state of the widget has changed.

Protected Member Functions

void | addRadioButtonEvents (void)
Add radio button specific events.
void | deselectOtherButtonsInGroup (void) const
Deselect any selected radio buttons attached to the same parent within the same group (but not do not deselect 'this').
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onSelectStateChanged (WindowEventArgs &e)
event triggered internally when the select state of the button changes.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.

Protected Attributes

bool | d_selected
ulong | d_groupID

Detailed Description

Base class to provide the logic for Radio Button widgets.

Member Function Documentation

ulong CEGUI::RadioButton::getGroupID ( void ) const [inline]

return the groupID assigned to this radio button

Returns:
ulong value that identifies the Radio Button group this widget belongs to.

RadioButton * CEGUI::RadioButton::getSelectedButtonInGroup ( void ) const

Return a pointer to the RadioButton object within the same group as this RadioButton, that is currently selected.

Returns:
Pointer to the RadioButton object that is the RadioButton within the same group as this RadioButton, and is attached to the same parent window as this RadioButton, that is currently selected. Returns NULL if no button within the group is selected, or if 'this' is not attached to a parent window.

bool CEGUI::RadioButton::isSelected ( void ) const [inline]

return true if the radio button is selected (has the checkmark)

Returns:
true if this widget is selected, false if the widget is not selected.

void CEGUI::RadioButton::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::ButtonBase.

void CEGUI::RadioButton::setGroupID ( ulong group )

set the groupID for this radio button

Parameters:
group ulong value specifying the radio button group that this widget belongs to.
Returns:
Nothing.

void CEGUI::RadioButton::setSelected ( bool select )

set whether the radio button is selected or not

Parameters:
select true to put the radio button in the selected state, false to put the radio button in the deselected state. If changing to the selected state, any previously selected radio button within the same group is automatically deselected.
Returns:
Nothing.

virtual bool CEGUI::RadioButton::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::ButtonBase.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::ReadOnly Class Reference

CEGUI::ComboboxProperties::ReadOnly

CEGUI::ComboboxProperties::ReadOnly Class Reference

Property to access the read-only setting of the edit box. More...

Inheritance diagram for CEGUI::ComboboxProperties::ReadOnly:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::ReadOnly:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the read-only setting of the edit box.

Usage:
  • Name: ReadOnly
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the edit box is read-only.
  • "False" to indicate the edit box is not read-only (text may be edited by user).

Member Function Documentation

String CEGUI::ComboboxProperties::ReadOnly::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::ReadOnly::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::ReadOnly Class Reference

CEGUI::MultiLineEditboxProperties::ReadOnly

CEGUI::MultiLineEditboxProperties::ReadOnly Class Reference

Property to access the read-only setting of the edit box. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::ReadOnly:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::ReadOnly:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the read-only setting of the edit box.

Usage:
  • Name: ReadOnly
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the edit box is read-only.
  • "False" to indicate the edit box is not read-only (text may be edited by user).

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::ReadOnly::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::ReadOnly::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::ReadOnly Class Reference

CEGUI::EditboxProperties::ReadOnly

CEGUI::EditboxProperties::ReadOnly Class Reference

Property to access the read-only setting of the edit box. More...

Inheritance diagram for CEGUI::EditboxProperties::ReadOnly:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::ReadOnly:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the read-only setting of the edit box.

This property offers access to the read-only setting for the Editbox object.

Usage:
  • Name: ReadOnly
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the edit box is read-only.
  • "False" to indicate the edit box is not read-only (text may be edited by user).

Member Function Documentation

String CEGUI::EditboxProperties::ReadOnly::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::ReadOnly::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Rect Class Reference

CEGUI::WindowProperties::Rect

CEGUI::WindowProperties::Rect Class Reference

Property to access window area rectangle. More...

Inheritance diagram for CEGUI::WindowProperties::Rect:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Rect:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window area rectangle.

This property offers access to the area rectangle (Rect) for the window, using the Windows active metrics mode.

Usage:
  • Name: Rect
  • Format: "l:[float] t:[float] r:[float] b:[float]".
Where:
  • l:[float] specifies the position of the left edge of the area as a floating point number, using the active metrics system for the Window.
  • t:[float] specifies the position of the top edge of the area as a floating point number, using the active metrics system for the Window.
  • r:[float] specifies the position of the right edge of the area as a floating point number, using the active metrics system for the Window.
  • b:[float] specifies the position of the bottom edge of the area as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::Rect::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Rect::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Rect Class Reference

CEGUI::Rect

CEGUI::Rect Class Reference

Class encapsulating operations on a Rectangle. More...

List of all members.

Public Member Functions

Rect (float left, float top, float right, float bottom)
Constructor for a Rect.
Rect (Point pos, Size sz)
Point | getPosition (void) const
Return top-left postion of Rect as a Point.
float | getWidth (void) const
return width of Rect area
float | getHeight (void) const
return height of Rect area
Size | getSize (void) const
return the size of the Rect area
void | setPosition (const Point &pt)
set the position of the Rect (leaves size in tact)
void | setWidth (float width)
set the width of the Rect object
void | setHeight (float height)
set the height of the Rect object
void | setSize (const Size &sze)
set the size of the Rect area
Rect | getIntersection (const Rect &rect) const
return a Rect that is the intersection of 'this' Rect with the Rect 'rect'
Rect & | offset (const Point &pt)
Applies an offset the Rect object.
bool | isPointInRect (const Point &pt) const
Return true if the given Point falls within this Rect.
Rect & | constrainSizeMax (const Size &sz)
check the size of the Rect object and if it is bigger than sz, resize it so it isn't.
Rect & | constrainSizeMin (const Size &sz)
check the size of the Rect object and if it is smaller than sz, resize it so it isn't.
Rect & | constrainSize (const Size &max_sz, const Size &min_sz)
check the size of the Rect object and if it is bigger than max_sz or smaller than min_sz, resize it so it isn't.
bool | operator== (const Rect &rhs) const
bool | operator!= (const Rect &rhs) const
Rect & | operator= (const Rect &rhs)
Rect | operator * (float scalar) const
const Rect & | operator *= (float scalar)

Public Attributes

float | d_top
float | d_bottom
float | d_left
float | d_right

Detailed Description

Class encapsulating operations on a Rectangle.

Member Function Documentation

Rect & CEGUI::Rect::constrainSize | ( | const Size & | max_sz,
 |  | const Size & | min_sz
 | ) |

check the size of the Rect object and if it is bigger than max_sz or smaller than min_sz, resize it so it isn't.

Parameters:
max_sz | Size object that describes the maximum dimensions that this Rect should be limited to.
min_sz | Size object that describes the minimum dimensions that this Rect should be limited to.
Returns:
'this' Rect object after the constrain operation

Rect & CEGUI::Rect::constrainSizeMax ( const Size & sz )

check the size of the Rect object and if it is bigger than sz, resize it so it isn't.

Parameters:
sz Size object that describes the maximum dimensions that this Rect should be limited to.
Returns:
'this' Rect object after the constrain operation

Rect & CEGUI::Rect::constrainSizeMin ( const Size & sz )

check the size of the Rect object and if it is smaller than sz, resize it so it isn't.

Parameters:
sz Size object that describes the minimum dimensions that this Rect should be limited to.
Returns:
'this' Rect object after the constrain operation

Rect CEGUI::Rect::getIntersection ( const Rect & rect ) const

return a Rect that is the intersection of 'this' Rect with the Rect 'rect'

Note:
It can be assumed that if d_left == d_right, or d_top == d_bottom, or getWidth() == 0, or getHeight() == 0, then 'this' rect was totally outside 'rect'.

bool CEGUI::Rect::isPointInRect ( const Point & pt ) const

Return true if the given Point falls within this Rect.

Parameters:
pt Point object describing the position to test.
Returns:
true if position pt is within this Rect's area, else false

Rect & CEGUI::Rect::offset ( const Point & pt )

Applies an offset the Rect object.

Parameters:
pt Point object containing the offsets to be applied to the Rect.
Returns:
this Rect after the offset is performed

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RegexValidator Struct Reference

CEGUI::RegexValidator

CEGUI::RegexValidator Struct Reference

Internal struct to contain compiled regex string. More...

List of all members.

Public Member Functions

void | release ()

Public Attributes

pcre * | d_regex

Detailed Description

Internal struct to contain compiled regex string.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeHeight Class Reference

CEGUI::WindowProperties::RelativeHeight

CEGUI::WindowProperties::RelativeHeight Class Reference

Property to access window height. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeHeight:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeHeight:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window height.

This property offers access to the Height setting for the window, using the relative metrics mode.

Usage:
  • Name: RelativeHeight
  • Format: "[float]".
Where:
  • [float] specifies the height as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativeHeight::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeHeight::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeMaxSize Class Reference

CEGUI::WindowProperties::RelativeMaxSize

CEGUI::WindowProperties::RelativeMaxSize Class Reference

Property to access maximum window size. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeMaxSize:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeMaxSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access maximum window size.

This property offers access to the maximum size setting for the window, using screen relative metrics.

Usage:
  • Name: RelativeMaxSize
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the maximum width as a floating point number.
  • h:[float] specifies the maximum height as a floating point number.

Member Function Documentation

String CEGUI::WindowProperties::RelativeMaxSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeMaxSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeMinSize Class Reference

CEGUI::WindowProperties::RelativeMinSize

CEGUI::WindowProperties::RelativeMinSize Class Reference

Property to access minimum window size. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeMinSize:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeMinSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access minimum window size.

This property offers access to the minimum size setting for the window, using screen relative metrics.

Usage:
  • Name: RelativeMinSize
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the minimum width as a floating point number.
  • h:[float] specifies the minimum height as a floating point number.

Member Function Documentation

String CEGUI::WindowProperties::RelativeMinSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeMinSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativePosition Class Reference

CEGUI::WindowProperties::RelativePosition

CEGUI::WindowProperties::RelativePosition Class Reference

Property to access window position. More...

Inheritance diagram for CEGUI::WindowProperties::RelativePosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativePosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window position.

This property offers access to the position for the window, using the relative metrics system.

Usage:
  • Name: RelativePosition
  • Format: "x:[float] y:[float]".
Where:
  • x:[float] specifies the x position co-ordinate as a floating point number, using the relative metrics system.
  • y:[float] specifies the y position co-ordinate as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativePosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativePosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeRect Class Reference

CEGUI::WindowProperties::RelativeRect

CEGUI::WindowProperties::RelativeRect Class Reference

Property to access window area rectangle. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeRect:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeRect:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window area rectangle.

This property offers access to the area rectangle (Rect) for the window, using the relative metrics system.

Usage:
  • Name: RelativeRect
  • Format: "l:[float] t:[float] r:[float] b:[float]".
Where:
  • l:[float] specifies the position of the left edge of the area as a floating point number, using the relative metrics system.
  • t:[float] specifies the position of the top edge of the area as a floating point number, using the relative metrics system.
  • r:[float] specifies the position of the right edge of the area as a floating point number, using the relative metrics system.
  • b:[float] specifies the position of the bottom edge of the area as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativeRect::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeRect::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeSize Class Reference

CEGUI::WindowProperties::RelativeSize

CEGUI::WindowProperties::RelativeSize Class Reference

Property to access the window size. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeSize:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the window size.

This property offers access to the size setting for the window, using the relative metrics system.

Usage:
  • Name: RelativeSize
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the minimum width as a floating point number, using the relative metrics system.
  • h:[float] specifies the minimum height as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativeSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties::RelativeTabHeight Class Reference

CEGUI::TabControlProperties::RelativeTabHeight

CEGUI::TabControlProperties::RelativeTabHeight Class Reference

Property to access the relative tab height setting of the tab control. More...

Inheritance diagram for CEGUI::TabControlProperties::RelativeTabHeight:

[legend]
Collaboration diagram for CEGUI::TabControlProperties::RelativeTabHeight:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the relative tab height setting of the tab control.

Usage:
  • Name: RelativeTabHeight
  • Format: "[float]"

Member Function Documentation

String CEGUI::TabControlProperties::RelativeTabHeight::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TabControlProperties::RelativeTabHeight::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties::RelativeTabTextPadding Class Reference

CEGUI::TabControlProperties::RelativeTabTextPadding

CEGUI::TabControlProperties::RelativeTabTextPadding Class Reference

Property to access the relative tab text padding setting of the tab control. More...

Inheritance diagram for CEGUI::TabControlProperties::RelativeTabTextPadding:

[legend]
Collaboration diagram for CEGUI::TabControlProperties::RelativeTabTextPadding:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.
String | getDefault (const PropertyReceiver *receiver) const
Returns the default value of the Property as a String.

Detailed Description

Property to access the relative tab text padding setting of the tab control.

Usage:
  • Name: RelativeTabTextPadding
  • Format: "[float]"

Member Function Documentation

String CEGUI::TabControlProperties::RelativeTabTextPadding::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

String CEGUI::TabControlProperties::RelativeTabTextPadding::getDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns the default value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the default value for this property.

Reimplemented from CEGUI::Property.

bool CEGUI::TabControlProperties::RelativeTabTextPadding::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::TabControlProperties::RelativeTabTextPadding::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeWidth Class Reference

CEGUI::WindowProperties::RelativeWidth

CEGUI::WindowProperties::RelativeWidth Class Reference

Property to access window width. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeWidth:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeWidth:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window width.

This property offers access to the Width setting for the window, using the relative metrics mode.

Usage:
  • Name: RelativeWidth
  • Format: "[float]".
Where:
  • [float] specifies the width as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativeWidth::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeWidth::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeXPosition Class Reference

CEGUI::WindowProperties::RelativeXPosition

CEGUI::WindowProperties::RelativeXPosition Class Reference

Property to access window X position. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeXPosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeXPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window X position.

This property offers access to the X position for the window, using the relative metrics system.

Usage:
  • Name: RelativeXPosition
  • Format: "[float]".
Where:
  • [float] specifies the x position co-ordinate as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativeXPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeXPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RelativeYPosition Class Reference

CEGUI::WindowProperties::RelativeYPosition

CEGUI::WindowProperties::RelativeYPosition Class Reference

Property to access window Y position. More...

Inheritance diagram for CEGUI::WindowProperties::RelativeYPosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RelativeYPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window Y position.

This property offers access to the Y position for the window, using the relative metrics system.

Usage:
  • Name: RelativeYPosition
  • Format: "[float]".
Where:
  • [float] specifies the y position co-ordinate as a floating point number, using the relative metrics system.

Member Function Documentation

String CEGUI::WindowProperties::RelativeYPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RelativeYPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RenderableFrame Class Reference

CEGUI::RenderableFrame

CEGUI::RenderableFrame Class Reference

A higher order GUI entity that represents a renderable frame. More...

Collaboration diagram for CEGUI::RenderableFrame:

[legend]
List of all members.

Public Member Functions

RenderableFrame (void)
Default constructor for RenderableFrame.
virtual | ~RenderableFrame (void)
Destructor for RenderableFrame.
void | setImages (const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom)
specify the Image objects to use for each part of the frame. A NULL may be used to omit any part.
void | setImageForLocation (FrameLocation location, const Image *image)
Set the Image to use for the specified location of the frame.
const Image * | getImageForLocation (FrameLocation location) const
Return the Image being used for the specified location of the frame.

Protected Member Functions

void | draw_impl (const Vector3 &position, const Rect &clip_rect) const
Renders the imagery for a RenderableFrame element.
void | draw_impl (RenderCache &renderCache) const

Protected Attributes

const Image * | d_topleft
Image to draw for the top-left corner.
const Image * | d_topright
Image to draw for the top-right corner.
const Image * | d_bottomleft
Image to draw for the bottom-left corner.
const Image * | d_bottomright
Image to draw for the bottom-right corner.
const Image * | d_left
Image to draw for the left edge.
const Image * | d_right
Image to draw for the right edge.
const Image * | d_top
Image to draw for the top edge.
const Image * | d_bottom
Image to draw for the bottom edge.

Detailed Description

A higher order GUI entity that represents a renderable frame.

This class is intended to be used where a (usually top-level) GUI element needs to draw a frame that is constructed from a collection of Images. It is possible to specify the image to use for each of the four corners, which are placed appropriately at their natural size, and the images for the four edges, which are stretched to cover the area between any corner images. Any of the Images may be omitted, in which case that part of the frame is not drawn. If the GUI element uses only one image for its frame (usually stretched over the entire area of the element) then a better choice would be to use a RenderableImage, or perform the rendering directly instead.

Member Function Documentation

void CEGUI::RenderableFrame::draw_impl | ( | const Vector3 & | position,
 |  | const Rect & | clip_rect
 | ) | const [protected]

Renders the imagery for a RenderableFrame element.

Parameters:
position | Vector3 object describing the final rendering position for the object.
clip_rect | Rect object describing the clipping area for the rendering. No rendering will be performed outside this area.
Returns:
Nothing.

const Image * CEGUI::RenderableFrame::getImageForLocation ( FrameLocation location ) const

Return the Image being used for the specified location of the frame.

Parameters:
location One of the FrameLocation enumerated values specifying the image to be returned.
Returns:
Pointer to the Image object currently set for the frame location specified in location. May return NULL if no Image is set for the requested position.

void CEGUI::RenderableFrame::setImageForLocation | ( | FrameLocation | location,
 |  | const Image * | image
 | ) |

Set the Image to use for the specified location of the frame.

Parameters:
location | One of the FrameLocation enumerated values specifying the image to be returned.
image | Pointer to the Image to use for the frame location specified in location. May be NULL to indicate the frame component is not required.
Returns:
Nothing.

void CEGUI::RenderableFrame::setImages | ( | const Image * | topleft,
 |  | const Image * | topright,
 |  | const Image * | bottomleft,
 |  | const Image * | bottomright,
 |  | const Image * | left,
 |  | const Image * | top,
 |  | const Image * | right,
 |  | const Image * | bottom
 | ) |

specify the Image objects to use for each part of the frame. A NULL may be used to omit any part.

Parameters:
topleft | Pointer to an Image object to render as the top-left corner of the frame. Specify NULL to omit this part of the frame.
topright | Pointer to an Image object to render as the top-right corner of the frame. Specify NULL to omit this part of the frame.
bottomleft | Pointer to an Image object to render as the bottom-left corner of the frame. Specify NULL to omit this part of the frame.
bottomright | Pointer to an Image object to render as the bottom-right corner of the frame. Specify NULL to omit this part of the frame.
left | Pointer to an Image object to render as the left edge of the frame. Specify NULL to omit this part of the frame.
top | Pointer to an Image object to render as the top edge of the frame. Specify NULL to omit this part of the frame.
right | Pointer to an Image object to render as the right edge of the frame. Specify NULL to omit this part of the frame.
bottom | Pointer to an Image object to render as the bottom edge of the frame. Specify NULL to omit this part of the frame.
Returns:
Nothing

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RenderableImage Class Reference

CEGUI::RenderableImage

CEGUI::RenderableImage Class Reference

A higher order GUI entity that represents a renderable image with formatting options. More...

Collaboration diagram for CEGUI::RenderableImage:

[legend]
List of all members.

Public Types

enum HorzFormatting {
LeftAligned, RightAligned, HorzCentred, HorzStretched,
HorzTiled
}
Enumeration of horizontal formatting options for a RenderableImage. More...
enum VertFormatting {
TopAligned, BottomAligned, VertCentred, VertStretched,
VertTiled
}
Enumeration of vertical formatting options for a RenderableImage. More...

Public Member Functions

RenderableImage (void)
Default constructor for RenderableImage objects.
virtual | ~RenderableImage (void)
Destructor for RenderableImage objects.
void | setImage (const Image *image)
Set the Image object to be drawn by this RenderableImage.
void | setHorzFormatting (HorzFormatting formatting)
Set the required horizontal formatting.
void | setVertFormatting (VertFormatting formatting)
Set the required vertical formatting.
void | setQuadSplitMode (QuadSplitMode split_mode)
Set the required quad split mode.
const Image * | getImage (void) const
Return the Image object currently set to be rendered.
HorzFormatting | getHorzFormatting (void) const
Return current horizontal formatting setting.
VertFormatting | getVertFormatting (void) const
Return current vertical formatting setting.
QuadSplitMode | getQuadSplitMode (void) const
Return current quad split mode setting.

Protected Member Functions

void | draw_impl (const Vector3 &position, const Rect &clip_rect) const
Renders the imagery for a RenderableImage element.
void | draw_impl (RenderCache &renderCache) const
uint | getHorzTileCount () const
return number of horizontal tiles required.
uint | getVertTileCount () const
return number of vertical tiles required.
float | getBaseXCoord (const Size &sz) const
Return base x co-ord for first tile.
float | getBaseYCoord (const Size &sz) const
Return base y co-ord for first tile.
Size | getDestinationSize () const
Return target size to be used for each tile.

Protected Attributes

HorzFormatting d_horzFormat
Currently set horizontal formatting option.
VertFormatting d_vertFormat
Currently set vertical formatting option.
QuadSplitMode d_quadSplitMode
Currently set quad split mode.
const Image * | d_image
Pointer to the actual Image to be displayed.

Detailed Description

A higher order GUI entity that represents a renderable image with formatting options.

This class is intended to be used where a (usually top-level) GUI element needs to draw an image that requires some additional formatting. It is possible to specify the Image that is to be rendered, as well as the horizontal and vertical formatting required.

Member Enumeration Documentation

enum CEGUI::RenderableImage::HorzFormatting

Enumeration of horizontal formatting options for a RenderableImage.

Enumerator:
LeftAligned | Image will be rendered at it's natural size and with it's left edge aligned with the left edge of the RenderableImage rect.
RightAligned | Image will be rendered at it's natural size and with it's right edge aligned with the right edge of the RenderableImage rect.
HorzCentred | Image will be rendered at it's natural size and horizontally centred within the RenderableImage rect.
HorzStretched | Image will be horizontally stretched to cover the entire width of the RenderableImage rect.
HorzTiled | Image will be tiled horizontally across the width of the RenderableImage rect. The rightmost tile will be clipped to remain within the rect.

enum CEGUI::RenderableImage::VertFormatting

Enumeration of vertical formatting options for a RenderableImage.

Enumerator:
TopAligned | Image will be rendered at it's natural size and with it's top edge aligned with the top edge of the RenderableImage rect.
BottomAligned | Image will be rendered at it's natural size and with it's bottom edge aligned with the bottom edge of the RenderableImage rect.
VertCentred | Image will be rendered at it's natural size and vertically centred within the RenderableImage rect.
VertStretched | Image will be vertically stretched to cover the entire height of the RenderableImage rect.
VertTiled | Image will be tiled vertically down the height of the RenderableImage rect. The bottommost tile will be clipped to remain within the rect.

Member Function Documentation

void CEGUI::RenderableImage::draw_impl | ( | const Vector3 & | position,
 |  | const Rect & | clip_rect
 | ) | const [protected]

Renders the imagery for a RenderableImage element.

Parameters:
position | Vector3 object describing the final rendering position for the object.
clip_rect | Rect object describing the clipping area for the rendering. No rendering will be performed outside this area.
Returns:
Nothing.

HorzFormatting CEGUI::RenderableImage::getHorzFormatting ( void ) const [inline]

Return current horizontal formatting setting.

Returns:
One of the HorzFormatting values specifying the formatting set.

const Image* CEGUI::RenderableImage::getImage ( void ) const [inline]

Return the Image object currently set to be rendered.

Returns:
Pointer to the current Image object set for this RenderableImage. May return NULL if no image is set.

QuadSplitMode CEGUI::RenderableImage::getQuadSplitMode ( void ) const [inline]

Return current quad split mode setting.

Returns:
One of the QuadSplitMode values specifying the way quads are split into triangles.

VertFormatting CEGUI::RenderableImage::getVertFormatting ( void ) const [inline]

Return current vertical formatting setting.

Returns:
One of the VertFormatting values specifying the formatting set.

void CEGUI::RenderableImage::setHorzFormatting ( HorzFormatting formatting ) [inline]

Set the required horizontal formatting.

Parameters:
formatting One of the HorzFormatting values specifying the formatting required.
Returns:
Nothing

void CEGUI::RenderableImage::setImage ( const Image * image ) [inline]

Set the Image object to be drawn by this RenderableImage.

Parameters:
image Pointer to the Image object to be rendered. Can be NULL to specify no image is to be rendered.
Returns:
Nothing.

void CEGUI::RenderableImage::setQuadSplitMode ( QuadSplitMode split_mode ) [inline]

Set the required quad split mode.

Parameters:
split_mode One of the QuadSplitMode values specifying the way quads are split into triangles.
Returns:
Nothing

void CEGUI::RenderableImage::setVertFormatting ( VertFormatting formatting ) [inline]

Set the required vertical formatting.

Parameters:
formatting One of the VertFormatting values specifying the formatting required.
Returns:
Nothing

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RenderCache Class Reference

CEGUI::RenderCache

CEGUI::RenderCache Class Reference

Class that acts as a cache for images that need to be rendered. More...

List of all members.

Public Member Functions

RenderCache ()
Constructor.
~RenderCache ()
Destructor.
bool | hasCachedImagery () const
Return whether the cache contains anything to draw.
void | render (const Point &basePos, float baseZ, const Rect &clipper) const
Send the contents of the cache to the Renderer.
void | clearCachedImagery ()
Erase any stored image information.
void | cacheImage (const Image &image, const Rect &destArea, float zOffset, const ColourRect &cols, const Rect *clipper=0, bool clipToDisplay=false)
Add an image to the cache.
void | cacheText (const String &text, const Font *font, TextFormatting format, const Rect &destArea, float zOffset, const ColourRect &cols, const Rect *clipper=0, bool clipToDisplay=false)
Add a text to the cache.

Classes

struct | ImageInfo
internal struct that holds info about a single image to be drawn.
struct | TextInfo
internal struct that holds info about text to be drawn.

Detailed Description

Class that acts as a cache for images that need to be rendered.

This is in many ways an optimisation cache, it allows a full image redraw to occur while limiting the amount of information that needs to be re-calculated.

Basically, unless the actual images (or their size) change, or the colours (or alpha) change then imagery cached in here will suffice for a full redraw. The reasoning behind this is that when some window underneath window 'X' changes, a full image redraw is required by the renderer, however, since window 'X' is unchanged, performing a total recalculation of all imagery is very wasteful, and so we use this cache to limit such waste.
As another example, when a window is simply moved, there is no need to perform a total imagery recalculation; we can still use the imagery cached here since it is position independant.

Member Function Documentation

void CEGUI::RenderCache::cacheImage | ( | const Image & | image,
 |  | const Rect & | destArea,
 |  | float | zOffset,
 |  | const ColourRect & | cols,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) |

Add an image to the cache.

Parameters:
image | Image object to be cached.
destArea | Destination area over which the Image object will be rendered. This area should be position independant; so position (0,0) will be to top-left corner of whatever it is you're rendering (like a Window for example).
zOffset | Zero based z offset for this image. Allows imagery to be layered.
cols | ColourRect object describing the colours to be applied when rendering this image.
Returns:
Nothing

void CEGUI::RenderCache::cacheText | ( | const String & | text,
 |  | const Font * | font,
 |  | TextFormatting | format,
 |  | const Rect & | destArea,
 |  | float | zOffset,
 |  | const ColourRect & | cols,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) |

Add a text to the cache.

Parameters:
text | String object to be cached.
font | Font to be used when rendering.
format | TextFormatting value specifying the formatting to use when rendering.
destArea | Destination area over which the Image object will be rendered. This area should be position independant; so position (0,0) will be to top-left corner of whatever it is you're rendering (like a Window for example).
zOffset | Zero based z offset for this image. Allows imagery to be layered.
cols | ColourRect object describing the colours to be applied when rendering this image.
Returns:
Nothing

bool CEGUI::RenderCache::hasCachedImagery ( ) const

Return whether the cache contains anything to draw.

Returns:
  • true if the cache contains information about images to be drawn.
  • false if the cache is empty.

void CEGUI::RenderCache::render | ( | const Point & | basePos,
 |  | float | baseZ,
 |  | const Rect & | clipper
 | ) | const

Send the contents of the cache to the Renderer.

Parameters:
basePos | Point that describes a screen offset that cached imagery will be rendered relative to.
baseZ | Z value that cached imagery will use as a base figure when calculating final z values.
clipper | Rect object describing a rect to which imagery will be clipped.
Returns:
Nothing

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Renderer Class Reference

CEGUI::Renderer

CEGUI::Renderer Class Reference

Abstract class defining the interface for Renderer objects. More...

Inheritance diagram for CEGUI::Renderer:

[legend]
Collaboration diagram for CEGUI::Renderer:

[legend]
List of all members.

Public Member Functions

virtual void | addQuad (const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode)=0
Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.
virtual void | doRender (void)=0
Perform final rendering for all quads that have been queued for rendering.
virtual void | clearRenderList (void)=0
Clears all queued quads from the render queue.
virtual void | setQueueingEnabled (bool setting)=0
Enable or disable the queueing of quads from this point on.
virtual Texture * | createTexture (void)=0
Creates a 'null' Texture object.
virtual Texture * | createTexture (const String &filename, const String &resourceGroup)=0
Create a Texture object using the given image file.
virtual Texture * | createTexture (float size)=0
Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.
virtual void | destroyTexture (Texture *texture)=0
Destroy the given Texture object.
virtual void | destroyAllTextures (void)=0
Destroy all Texture objects.
virtual bool | isQueueingEnabled (void) const =0
Return whether queueing is enabled.
virtual float | getWidth (void) const =0
Return the current width of the display in pixels.
virtual float | getHeight (void) const =0
Return the current height of the display in pixels.
virtual Size | getSize (void) const =0
Return the size of the display in pixels.
virtual Rect | getRect (void) const =0
Return a Rect describing the screen.
virtual uint | getMaxTextureSize (void) const =0
Return the maximum texture size available.
virtual uint | getHorzScreenDPI (void) const =0
Return the horizontal display resolution dpi.
virtual uint | getVertScreenDPI (void) const =0
Return the vertical display resolution dpi.
void | resetZValue (void)
Reset the z co-ordinate for rendering.
void | advanceZValue (void)
Update the z co-ordinate for the next major UI element (window).
float | getCurrentZ (void) const
return the current Z value to use (equates to layer 0 for this UI element).
float | getZLayer (uint layer) const
return the z co-ordinate to use for the requested layer on the current GUI element.
const String & | getIdentifierString () const
Return identification string for the renderer module. If the internal id string has not been set by the Renderer module creator, a generic string of "Unknown renderer" will be returned.
virtual ResourceProvider * | createResourceProvider (void)

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventDisplaySizeChanged

Protected Attributes

ResourceProvider * d_resourceProvider
Holds the pointer to the ResourceProvider object.
String d_identifierString
String that holds some id information about the renderer.

Detailed Description

Abstract class defining the interface for Renderer objects.

Objects derived from Renderer are the means by which the GUI system interfaces with specific rendering technologies. To use a rendering system or API to draw CEGUI imagery requires that an appropriate Renderer object be available.

Member Function Documentation

virtual void CEGUI::Renderer::addQuad | ( | const Rect & | dest_rect,
 |  | float | z,
 |  | const Texture * | tex,
 |  | const Rect & | texture_rect,
 |  | const ColourRect & | colours,
 |  | QuadSplitMode | quad_split_mode
 | ) | [pure virtual]

Add a quad to the rendering queue. All clipping and other adjustments should have been made prior to calling this.

Parameters:
dest_rect | Rect object describing the destination area (values are in pixels)
z | float value specifying the z co-ordinate / z order of the quad
tex | pointer to the Texture object that holds the imagery to be rendered
texture_rect | Rect object holding the area of tex that is to be rendered (values are in texture co-ordinates).
colours | ColourRect object describing the colour values that are to be applied when rendering.
quad_split_mode | One of the QuadSplitMode values specifying the way quads are split into triangles
Returns:
Nothing

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

void CEGUI::Renderer::advanceZValue ( void ) [inline]

Update the z co-ordinate for the next major UI element (window).

Returns:
Nothing

virtual void CEGUI::Renderer::clearRenderList ( void ) [pure virtual]

Clears all queued quads from the render queue.

Returns:
Nothing

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual Texture* CEGUI::Renderer::createTexture ( float size ) [pure virtual]

Create a Texture object with the given pixel dimensions as specified by size. NB: Textures are always square.

Parameters:
size float value that specifies the size to use for the width and height when creating the new texture.
Returns:
a newly created Texture object. The initial contents of the texture memory is undefined / random.
Note:
Textures are always created with a size that is a power of 2. If you specify a size that is not a power of two, the final size will be rounded up. So if you specify a size of 1024, the texture will be (1024 x 1024), however, if you specify a size of 1025, the texture will be (2048 x 2048). You can check the ultimate size by querying the texture after creation.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual Texture* CEGUI::Renderer::createTexture | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [pure virtual]

Create a Texture object using the given image file.

Parameters:
filename | String object that specifies the path and filename of the image file to use when creating the texture.
resourceGroup | Resource group identifier to be passed to the resource provider when loading the texture file.
Returns:
a newly created Texture object. The initial contents of the texture memory is the requested image file.
Note:
Textures are always created with a size that is a power of 2. If the file you specify is of a size that is not a power of two, the final size will be rounded up. Additionally, textures are always square, so the ultimate size is governed by the larger of the width and height of the specified file. You can check the ultimate sizes by querying the texture after creation.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual Texture* CEGUI::Renderer::createTexture ( void ) [pure virtual]

Creates a 'null' Texture object.

Returns:
a newly created Texture object. The returned Texture object has no size or imagery associated with it, and is generally of little or no use.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual void CEGUI::Renderer::destroyAllTextures ( void ) [pure virtual]

Destroy all Texture objects.

Returns:
Nothing

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual void CEGUI::Renderer::destroyTexture ( Texture * texture ) [pure virtual]

Destroy the given Texture object.

Parameters:
texture pointer to the Texture object to be destroyed
Returns:
Nothing

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual void CEGUI::Renderer::doRender ( void ) [pure virtual]

Perform final rendering for all quads that have been queued for rendering.

The contents of the rendering queue is retained and can be rendered again as required. If the contents is not required call clearRenderList().

Returns:
Nothing

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

float CEGUI::Renderer::getCurrentZ ( void ) const [inline]

return the current Z value to use (equates to layer 0 for this UI element).

Returns:
float value that specifies the z co-ordinate to be used for layer 0 on the current GUI element.

virtual float CEGUI::Renderer::getHeight ( void ) const [pure virtual]

Return the current height of the display in pixels.

Returns:
float value equal to the current height of the display in pixels.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual uint CEGUI::Renderer::getHorzScreenDPI ( void ) const [pure virtual]

Return the horizontal display resolution dpi.

Returns:
horizontal resolution of the display in dpi.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

const String & CEGUI::Renderer::getIdentifierString ( ) const

Return identification string for the renderer module. If the internal id string has not been set by the Renderer module creator, a generic string of "Unknown renderer" will be returned.

Returns:
String object holding a string that identifies the Renderer in use.

virtual uint CEGUI::Renderer::getMaxTextureSize ( void ) const [pure virtual]

Return the maximum texture size available.

Returns:
Size of the maximum supported texture in pixels (textures are always assumed to be square)

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual Rect CEGUI::Renderer::getRect ( void ) const [pure virtual]

Return a Rect describing the screen.

Returns:
A Rect object that describes the screen area. Typically, the top-left values are always 0, and the size of the area described is equal to the screen resolution.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual Size CEGUI::Renderer::getSize ( void ) const [pure virtual]

Return the size of the display in pixels.

Returns:
Size object describing the dimensions of the current display.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual uint CEGUI::Renderer::getVertScreenDPI ( void ) const [pure virtual]

Return the vertical display resolution dpi.

Returns:
vertical resolution of the display in dpi.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

virtual float CEGUI::Renderer::getWidth ( void ) const [pure virtual]

Return the current width of the display in pixels.

Returns:
float value equal to the current width of the display in pixels.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

float CEGUI::Renderer::getZLayer ( uint layer ) const [inline]

return the z co-ordinate to use for the requested layer on the current GUI element.

Parameters:
layer Specifies the layer to return the Z co-ordinate for. Each GUI element can use up to 10 layers, so valid inputs are 0 to 9 inclusive. If you specify an invalid value for layer, results are undefined.
Returns:
float value that specifies the Z co-ordinate for layer layer on the current GUI element.

virtual bool CEGUI::Renderer::isQueueingEnabled ( void ) const [pure virtual]

Return whether queueing is enabled.

Returns:
true if queueing is enabled, false if queueing is disabled.

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

void CEGUI::Renderer::resetZValue ( void ) [inline]

Reset the z co-ordinate for rendering.

Returns:
Nothing

virtual void CEGUI::Renderer::setQueueingEnabled ( bool setting ) [pure virtual]

Enable or disable the queueing of quads from this point on.

This only affects queueing. If queueing is turned off, any calls to addQuad will cause the quad to be rendered directly. Note that disabling queueing will not cause currently queued quads to be rendered, nor is the queue cleared - at any time the queue can still be drawn by calling doRender, and the list can be cleared by calling clearRenderList. Re-enabling the queue causes subsequent quads to be added as if queueing had never been disabled.

Parameters:
setting true to enable queueing, or false to disable queueing (see notes above).
Returns:
Nothing

Implemented in CEGUI::DirectX81Renderer, CEGUI::DirectX9Renderer, CEGUI::IrrlichtRenderer, and CEGUI::OpenGLRenderer.

Member Data Documentation

const String CEGUI::Renderer::EventDisplaySizeChanged [static]

event that fires when the underlying display size had changed.

It is important that all Renderer implementers fire this properly as the system itself subscribes to this event.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RendererException Class Reference

CEGUI::RendererException

CEGUI::RendererException Class Reference

Exception class used when an problem is detected within the Renderer or related objects. More...

Inheritance diagram for CEGUI::RendererException:

[legend]
Collaboration diagram for CEGUI::RendererException:

[legend]
List of all members.

Public Member Functions

RendererException (const String &message)

Detailed Description

Exception class used when an problem is detected within the Renderer or related objects.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ResourceProvider Class Reference

CEGUI::ResourceProvider

CEGUI::ResourceProvider Class Reference

Abstract class that defines the required interface for all resource provider sub-classes. More...

Inheritance diagram for CEGUI::ResourceProvider:

[legend]
Collaboration diagram for CEGUI::ResourceProvider:

[legend]
List of all members.

Public Member Functions

ResourceProvider ()
Constructor for the ResourceProvider class.
virtual | ~ResourceProvider (void)
Destructor for the ResourceProvider class.
virtual void | loadRawDataContainer (const String &filename, RawDataContainer &output, const String &resourceGroup)=0
Load XML data using InputSource objects. Load raw binary data.
virtual void | unloadRawDataContainer (RawDataContainer &data)
Unload raw binary data. This gives the resource provider a change to unload the data in its own way before the data container object is destroyed. If it does nothing, then the object will release its memory.
const String & | getDefaultResourceGroup (void) const
Return the current default resource group identifier.
void | setDefaultResourceGroup (const String &resourceGroup)
Set the default resource group identifier.

Protected Attributes

String d_defaultResourceGroup
Default resource group identifier.

Detailed Description

Abstract class that defines the required interface for all resource provider sub-classes.

A ResourceProvider is used to load both XML and binary data from an external source. This could be from a filesystem or the resource manager of a specific renderer.

Member Function Documentation

const String& CEGUI::ResourceProvider::getDefaultResourceGroup ( void ) const [inline]

Return the current default resource group identifier.

Returns:
String object containing the currently set default resource group identifier.

virtual void CEGUI::ResourceProvider::loadRawDataContainer | ( | const String & | filename,
 |  | RawDataContainer & | output,
 |  | const String & | resourceGroup
 | ) | [pure virtual]

Load XML data using InputSource objects. Load raw binary data.

Parameters:
filename | String containing a filename of the resource to be loaded.
output | Reference to a RawDataContainer object to load the data into.
resourceGroup | Optional String that may be used by implementations to identify the group from which the resource should be loaded.

void CEGUI::ResourceProvider::setDefaultResourceGroup ( const String & resourceGroup ) [inline]

Set the default resource group identifier.

Parameters:
resourceGroup String object containing the default resource group identifier to be used.
Returns:
Nothing.

virtual void CEGUI::ResourceProvider::unloadRawDataContainer ( RawDataContainer & data ) [inline, virtual]

Unload raw binary data. This gives the resource provider a change to unload the data in its own way before the data container object is destroyed. If it does nothing, then the object will release its memory.

Parameters:
data Reference to a RawDataContainer object that is about to be destroyed.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RestoreOldCapture Class Reference

CEGUI::WindowProperties::RestoreOldCapture

CEGUI::WindowProperties::RestoreOldCapture Class Reference

Property to access window Restore Old Capture setting. More...

Inheritance diagram for CEGUI::WindowProperties::RestoreOldCapture:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RestoreOldCapture:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window Restore Old Capture setting.

This property offers access to the restore old capture setting for the window. This setting is of generally limited use, it is primary purpose is for certain operations required for compound widgets.

Usage:
  • Name: RestoreOldCapture
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window should restore any previous capture Window when it loses input capture.
  • "False" to indicate the Window should not restore the old capture Window. This is the default behaviour.

Member Function Documentation

String CEGUI::WindowProperties::RestoreOldCapture::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RestoreOldCapture::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::RightFrameImage Class Reference

CEGUI::StaticProperties::RightFrameImage

CEGUI::StaticProperties::RightFrameImage Class Reference

Property to access the right edge image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::RightFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::RightFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the right edge image for the frame of the Static widget.

Usage:
  • Name: RightFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::RightFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::RightFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::RiseOnClick Class Reference

CEGUI::WindowProperties::RiseOnClick

CEGUI::WindowProperties::RiseOnClick Class Reference

Property to access whether the window rises to the top of the z order when clicked. More...

Inheritance diagram for CEGUI::WindowProperties::RiseOnClick:

[legend]
Collaboration diagram for CEGUI::WindowProperties::RiseOnClick:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access whether the window rises to the top of the z order when clicked.

Usage:
  • Name: RiseOnClick
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window will rise to the surface when clicked.
  • "False" to indicate the Window will not change z position when clicked.

Member Function Documentation

String CEGUI::WindowProperties::RiseOnClick::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::RiseOnClick::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::RollUpEnabled Class Reference

CEGUI::FrameWindowProperties::RollUpEnabled

CEGUI::FrameWindowProperties::RollUpEnabled Class Reference

Property to access the setting for whether the user is able to roll-up / shade the window. More...

Inheritance diagram for CEGUI::FrameWindowProperties::RollUpEnabled:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::RollUpEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for whether the user is able to roll-up / shade the window.

Usage:
  • Name: RollUpEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the user can roll-up / shade the window.
  • "False" to indicate the user can not roll-up / shade the window.

Member Function Documentation

String CEGUI::FrameWindowProperties::RollUpEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::RollUpEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::RollUpState Class Reference

CEGUI::FrameWindowProperties::RollUpState

CEGUI::FrameWindowProperties::RollUpState Class Reference

Property to access the roll-up / shade state of the window. More...

Inheritance diagram for CEGUI::FrameWindowProperties::RollUpState:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::RollUpState:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the roll-up / shade state of the window.

Usage:
  • Name: RollUpState
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the window is / should be rolled-up.
  • "False" to indicate the window is not / should not be rolled up

Member Function Documentation

String CEGUI::FrameWindowProperties::RollUpState::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::RollUpState::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::RowCount Class Reference

CEGUI::MultiColumnListProperties::RowCount

CEGUI::MultiColumnListProperties::RowCount Class Reference

Property to access the number of rows in the list (read-only). More...

Inheritance diagram for CEGUI::MultiColumnListProperties::RowCount:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::RowCount:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the number of rows in the list (read-only).

Usage:
  • Name: RowCount
  • Format: "" (property is read-only).

Member Function Documentation

String CEGUI::MultiColumnListProperties::RowCount::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::RowCount::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Scheme Class Reference

CEGUI::Scheme

CEGUI::Scheme Class Reference

A class that groups a set of GUI elements and initialises the system to access those elements. More...

Collaboration diagram for CEGUI::Scheme:

[legend]
List of all members.

Public Member Functions

void | loadResources (void)
Loads all resources for this scheme.
void | unloadResources (void)
Unloads all resources for this scheme. This should be used very carefully.
bool | resourcesLoaded (void) const
Return whether the resources for this Scheme are all loaded.
const String & | getName (void) const
Return the name of this Scheme.
~Scheme (void)
Destroys a Scheme object.

Friends

class | Scheme_xmlHandler
Scheme * | SchemeManager::loadScheme (const String &scheme_filename, const String &resourceGroup)
void | SchemeManager::unloadScheme (const String &scheme_name)

Classes

struct | AliasMapping
struct | FalagardMapping
struct | LoadableUIElement
struct | UIElementFactory
struct | UIModule

Detailed Description

A class that groups a set of GUI elements and initialises the system to access those elements.

A GUI Scheme is a high-level construct that loads and initialises various lower-level objects and registers them within the system for usage. So, for example, a Scheme might create some Imageset objects, some Font objects, and register a collection of WindowFactory objects within the system which would then be in a state to serve those elements to client code.

Constructor & Destructor Documentation

CEGUI::Scheme::~Scheme ( void )

Destroys a Scheme object.

Returns:
Nothing

Member Function Documentation

const String& CEGUI::Scheme::getName ( void ) const [inline]

Return the name of this Scheme.

Returns:
String object containing the name of this Scheme.

void CEGUI::Scheme::loadResources ( void )

Loads all resources for this scheme.

Returns:
Nothing.

bool CEGUI::Scheme::resourcesLoaded ( void ) const

Return whether the resources for this Scheme are all loaded.

Returns:
true if all resources for the Scheme are loaded and available, or false of one or more resource is not currently loaded.

void CEGUI::Scheme::unloadResources ( void )

Unloads all resources for this scheme. This should be used very carefully.

Returns:
Nothing.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Scheme_xmlHandler Class Reference

CEGUI::Scheme_xmlHandler

CEGUI::Scheme_xmlHandler Class Reference

Handler class used to parse the Scheme XML files using SAX2. More...

Collaboration diagram for CEGUI::Scheme_xmlHandler:

[legend]
List of all members.

Public Member Functions

Scheme_xmlHandler (Scheme *scheme)
Constructor for Scheme::xmlHandler objects.
virtual | ~Scheme_xmlHandler (void)
Destructor for Scheme::xmlHandler objects.
virtual void | elementStart (const String &element, const XMLAttributes &attributes)
document processing (only care about elements, schema validates format)
virtual void | elementEnd (const String &element)

Detailed Description

Handler class used to parse the Scheme XML files using SAX2.

Constructor & Destructor Documentation

CEGUI::Scheme_xmlHandler::Scheme_xmlHandler ( Scheme * scheme ) [inline]

Constructor for Scheme::xmlHandler objects.

Parameters:
scheme Pointer to the Scheme object creating this xmlHandler object

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SchemeManager Class Reference

CEGUI::SchemeManager

CEGUI::SchemeManager Class Reference

A class that manages the creation of, access to, and destruction of GUI Scheme objects. More...

List of all members.

Public Types

typedef ConstBaseIterator<
SchemeRegistry > 		SchemeIterator

Public Member Functions

SchemeManager (void)
Constructor for SchemeManager objects.
~SchemeManager (void)
Destructor for SchemeManager objects.
Scheme * | loadScheme (const String &scheme_filename, const String &resourceGroup="")
Loads a scheme.
void | unloadScheme (const String &scheme_name)
Unloads all data referenced in a scheme. If any object is using some resource which is listed in the scheme, this function will effectively pull the rug out from under those objects. This should be used with extreme caution, or not at all.
bool | isSchemePresent (const String &scheme_name) const
Returns true if the named Scheme is present in the system (though the resources for the scheme may or may not be loaded).
Scheme * | getScheme (const String &name) const
Returns a pointer to the Scheme object with the specified name.
void | unloadAllSchemes (void)
Unload all schemes currently defined within the system.
SchemeIterator | getIterator (void) const
Return a SchemeManager::SchemeIterator object to iterate over the available schemes.

Static Public Member Functions

static SchemeManager & | getSingleton (void)
Return singleton SchemeManager object.
static SchemeManager * | getSingletonPtr (void)
Return pointer to singleton SchemeManager object.

Detailed Description

A class that manages the creation of, access to, and destruction of GUI Scheme objects.

Member Function Documentation

Scheme * CEGUI::SchemeManager::getScheme ( const String & name ) const

Returns a pointer to the Scheme object with the specified name.

Parameters:
name String object holding the name of the Scheme to be returned.
Returns:
Pointer to the Scheme named name.
Exceptions:
UnknownObjectException thrown if no Scheme named name is present in the system

SchemeManager & CEGUI::SchemeManager::getSingleton ( void ) [static]

Return singleton SchemeManager object.

Returns:
Singleton SchemeManager object

SchemeManager * CEGUI::SchemeManager::getSingletonPtr ( void ) [static]

Return pointer to singleton SchemeManager object.

Returns:
Pointer to singleton SchemeManager object

bool CEGUI::SchemeManager::isSchemePresent ( const String & scheme_name ) const [inline]

Returns true if the named Scheme is present in the system (though the resources for the scheme may or may not be loaded).

Parameters:
scheme_name String object specifying the name of the Scheme to check for.
Returns:
true if the scheme is loaded, false if it is not.

Scheme * CEGUI::SchemeManager::loadScheme | ( | const String & | scheme_filename,
 |  | const String & | resourceGroup = ""
 | ) |

Loads a scheme.

Parameters:
scheme_filename | String object that holds the filename of the scheme to be loaded
resourceGroup | Resource group identifier to be passed to the resource manager. NB: This affects loading of the scheme xml file only, scheme resources may specify their own groups.
Returns:
Pointer to an object representing the loaded Scheme.

void CEGUI::SchemeManager::unloadAllSchemes ( void )

Unload all schemes currently defined within the system.

Note:
Calling this method has the potential to be very dangerous; if any of the data that forms part of the scheme is still in use, you can expect fireworks shortly after!
Returns:
Nothing.

void CEGUI::SchemeManager::unloadScheme ( const String & scheme_name )

Unloads all data referenced in a scheme. If any object is using some resource which is listed in the scheme, this function will effectively pull the rug out from under those objects. This should be used with extreme caution, or not at all.

Parameters:
scheme_name String object specifying the name of the Scheme to be unloaded.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScriptFunctor Class Reference

CEGUI::ScriptFunctor

CEGUI::ScriptFunctor Class Reference

Functor class used for binding named script functions to events. More...

Collaboration diagram for CEGUI::ScriptFunctor:

[legend]
List of all members.

Public Member Functions

ScriptFunctor (const String &functionName)
ScriptFunctor (const ScriptFunctor &obj)
bool operator() (const EventArgs &e) const

Detailed Description

Functor class used for binding named script functions to events.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScriptModule Class Reference

CEGUI::ScriptModule

CEGUI::ScriptModule Class Reference

Abstract interface required for all scripting support modules to be used with the CEGUI system. More...

Collaboration diagram for CEGUI::ScriptModule:

[legend]
List of all members.

Public Member Functions

ScriptModule (void)
Constructor for ScriptModule base class.
virtual | ~ScriptModule (void)
Destructor for ScriptModule base class.
virtual void | executeScriptFile (const String &filename, const String &resourceGroup="")=0
Execute a script file.
virtual int | executeScriptGlobal (const String &function_name)=0
Execute a scripted global function. The function should not take any parameters and should return an integer.
virtual bool | executeScriptedEventHandler (const String &handler_name, const EventArgs &e)=0
Execute a scripted global 'event handler' function. The function should take some kind of EventArgs like parameter that the concrete implementation of this function can create from the passed EventArgs based object. The function should not return anything.
virtual void | executeString (const String &str)=0
Execute script code contained in the given CEGUI::String object.
virtual void | createBindings (void)
Method called during system initialisation, prior to running any scripts via the ScriptModule, to enable the ScriptModule to perform any operations required to complete initialisation or binding of the script language to the gui system objects.
virtual void | destroyBindings (void)
Method called during system destruction, after all scripts have been run via the ScriptModule, to enable the ScriptModule to perform any operations required to cleanup bindings of the script language to the gui system objects, as set-up in the earlier createBindings call.
const String & | getIdentifierString () const
Return identification string for the ScriptModule. If the internal id string has not been set by the ScriptModule creator, a generic string of "Unknown scripting module" will be returned.

Protected Attributes

String d_identifierString
String that holds some id information about the module.

Detailed Description

Abstract interface required for all scripting support modules to be used with the CEGUI system.

Member Function Documentation

virtual void CEGUI::ScriptModule::createBindings ( void ) [inline, virtual]

Method called during system initialisation, prior to running any scripts via the ScriptModule, to enable the ScriptModule to perform any operations required to complete initialisation or binding of the script language to the gui system objects.

Returns:
Nothing.

virtual void CEGUI::ScriptModule::destroyBindings ( void ) [inline, virtual]

Method called during system destruction, after all scripts have been run via the ScriptModule, to enable the ScriptModule to perform any operations required to cleanup bindings of the script language to the gui system objects, as set-up in the earlier createBindings call.

Returns:
Nothing.

virtual bool CEGUI::ScriptModule::executeScriptedEventHandler | ( | const String & | handler_name,
 |  | const EventArgs & | e
 | ) | [pure virtual]

Execute a scripted global 'event handler' function. The function should take some kind of EventArgs like parameter that the concrete implementation of this function can create from the passed EventArgs based object. The function should not return anything.

Parameters:
handler_name | String object holding the name of the scripted handler function.
e | EventArgs based object that should be passed, by any appropriate means, to the scripted function.
Returns:
  • true if the event was handled.
  • false if the event was not handled.

virtual void CEGUI::ScriptModule::executeScriptFile | ( | const String & | filename,
 |  | const String & | resourceGroup = ""
 | ) | [pure virtual]

Execute a script file.

Parameters:
filename | String object holding the filename of the script file that is to be executed
resourceGroup | Resource group idendifier to be passed to the ResourceProvider when loading the script file.

virtual int CEGUI::ScriptModule::executeScriptGlobal ( const String & function_name ) [pure virtual]

Execute a scripted global function. The function should not take any parameters and should return an integer.

Parameters:
function_name String object holding the name of the function, in the global script environment, that is to be executed.
Returns:
The integer value returned from the script function.

virtual void CEGUI::ScriptModule::executeString ( const String & str ) [pure virtual]

Execute script code contained in the given CEGUI::String object.

Parameters:
str String object holding the valid script code that should be executed.
Returns:
Nothing.

const String & CEGUI::ScriptModule::getIdentifierString ( ) const

Return identification string for the ScriptModule. If the internal id string has not been set by the ScriptModule creator, a generic string of "Unknown scripting module" will be returned.

Returns:
String object holding a string that identifies the ScriptModule in use.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePane Class Reference

CEGUI::ScrollablePane

CEGUI::ScrollablePane Class Reference

Base class for the ScrollablePane widget. More...

Inheritance diagram for CEGUI::ScrollablePane:

[legend]
Collaboration diagram for CEGUI::ScrollablePane:

[legend]
List of all members.

Public Member Functions

ScrollablePane (const String &type, const String &name)
Constructor for the ScrollablePane base class.
~ScrollablePane (void)
Destructor for the ScrollablePane base class.
const ScrolledContainer * | getContentPane (void) const
Returns a pointer to the window holding the pane contents.
bool | isVertScrollbarAlwaysShown (void) const
Return whether the vertical scroll bar is always shown.
void | setShowVertScrollbar (bool setting)
Set whether the vertical scroll bar should always be shown.
bool | isHorzScrollbarAlwaysShown (void) const
Return whether the horizontal scroll bar is always shown.
void | setShowHorzScrollbar (bool setting)
Set whether the horizontal scroll bar should always be shown.
bool | isContentPaneAutoSized (void) const
Return whether the content pane is auto sized.
void | setContentPaneAutoSized (bool setting)
Set whether the content pane should be auto-sized.
const Rect & | getContentPaneArea (void) const
Return the current content pane area for the ScrollablePane.
void | setContentPaneArea (const Rect &area)
Set the current content pane area for the ScrollablePane.
float | getHorizontalStepSize (void) const
Returns the horizontal scrollbar step size as a fraction of one complete view page.
void | setHorizontalStepSize (float step)
Sets the horizontal scrollbar step size as a fraction of one complete view page.
float | getHorizontalOverlapSize (void) const
Returns the horizontal scrollbar overlap size as a fraction of one complete view page.
void | setHorizontalOverlapSize (float overlap)
Sets the horizontal scrollbar overlap size as a fraction of one complete view page.
float | getHorizontalScrollPosition (void) const
Returns the horizontal scroll position as a fraction of the complete scrollable width.
void | setHorizontalScrollPosition (float position)
Sets the horizontal scroll position as a fraction of the complete scrollable width.
float | getVerticalStepSize (void) const
Returns the vertical scrollbar step size as a fraction of one complete view page.
void | setVerticalStepSize (float step)
Sets the vertical scrollbar step size as a fraction of one complete view page.
float | getVerticalOverlapSize (void) const
Returns the vertical scrollbar overlap size as a fraction of one complete view page.
void | setVerticalOverlapSize (float overlap)
Sets the vertical scrollbar overlap size as a fraction of one complete view page.
float | getVerticalScrollPosition (void) const
Returns the vertical scroll position as a fraction of the complete scrollable height.
void | setVerticalScrollPosition (float position)
Sets the vertical scroll position as a fraction of the complete scrollable height.
void | initialise (void)
Initialises the Window based object ready for use.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventContentPaneChanged
Event fired when an area on the content pane has been updated.
static const String | EventVertScrollbarModeChanged
Event triggered when the vertical scroll bar 'force' setting changes.
static const String | EventHorzScrollbarModeChanged
Event triggered when the horizontal scroll bar 'force' setting changes.
static const String | EventAutoSizeSettingChanged
Event fired when the auto size setting changes.
static const String | EventContentPaneScrolled
Event fired when the pane gets scrolled.

Protected Member Functions

virtual Scrollbar * | createHorizontalScrollbar (const String &name) const =0
Create a Scrollbar based widget to be used as the horizontal scrollbar.
virtual Scrollbar * | createVerticalScrollbar (const String &name) const =0
Create a Scrollbar based widget to be used as the vertical scrollbar.
virtual Rect | getViewableArea (void) const =0
Return a Rect that described the pane's viewable area, relative to this Window, in pixels.
void | addScrollablePaneEvents (void)
Add ScrollablePane specific events.
void | configureScrollbars (void)
display required integrated scroll bars according to current size of the ScrollablePane view area and the size of the attached ScrolledContainer.
bool | isVertScrollbarNeeded (void) const
Return whether the vertical scrollbar is needed.
bool | isHorzScrollbarNeeded (void) const
Return whether the horizontal scrollbar is needed.
void | updateContainerPosition (void)
Update the content container position according to the current state of the widget (like scrollbar positions, etc).
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onContentPaneChanged (WindowEventArgs &e)
Event trigger method called when some pane content has changed size or location.
virtual void | onVertScrollbarModeChanged (WindowEventArgs &e)
Event trigger method called when the setting that controls whether the vertical scrollbar is always shown or not, is changed.
virtual void | onHorzScrollbarModeChanged (WindowEventArgs &e)
Event trigger method called when the setting that controls whether the horizontal scrollbar is always shown or not, is changed.
virtual void | onAutoSizeSettingChanged (WindowEventArgs &e)
Notification method called whenever the setting that controls whether the content pane is automatically sized is changed.
virtual void | onContentPaneScrolled (WindowEventArgs &e)
Notification method called whenever the content pane is scrolled via changes in the scrollbar positions.
bool | handleScrollChange (const EventArgs &e)
Handler method which gets subscribed to the scrollbar position change events.
bool | handleContentAreaChange (const EventArgs &e)
Handler method which gets subscribed to the ScrolledContainer content change events.
bool | handleAutoSizePaneChanged (const EventArgs &e)
Handler method which gets subscribed to the ScrolledContainer auto-size setting changes.
void | addChild_impl (Window *wnd)
Add given window to child list at an appropriate position.
void | removeChild_impl (Window *wnd)
Remove given window from child list.
void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.

Protected Attributes

bool | d_forceVertScroll
true if vertical scrollbar should always be displayed
bool | d_forceHorzScroll
true if horizontal scrollbar should always be displayed
Rect d_contentRect
holds content area so we can track changes.
float | d_vertStep
vertical scroll step fraction.
float | d_vertOverlap
vertical scroll overlap fraction.
float | d_horzStep
horizontal scroll step fraction.
float | d_horzOverlap
horizontal scroll overlap fraction.
Scrollbar * d_vertScrollbar
Scrollbar widget used for vertical scrolling.
Scrollbar * d_horzScrollbar
Scrollbar widget used for horizontal scrolling.
ScrolledContainer * d_container
ScrolledContainer widget holding the attached widgets.

Detailed Description

Base class for the ScrollablePane widget.

The ScrollablePane widget allows child windows to be attached which cover an area larger than the ScrollablePane itself and these child windows can be scrolled into view using the scrollbars of the scrollable pane.

Member Function Documentation

virtual Scrollbar* CEGUI::ScrollablePane::createHorizontalScrollbar ( const String & name ) const [protected, pure virtual]

Create a Scrollbar based widget to be used as the horizontal scrollbar.

Parameters:
name String object holding the name that must be used when creating the widget.
Returns:
Scrollbar based object.

virtual Scrollbar* CEGUI::ScrollablePane::createVerticalScrollbar ( const String & name ) const [protected, pure virtual]

Create a Scrollbar based widget to be used as the vertical scrollbar.

Parameters:
name String object holding the name that must be used when creating the widget.
Returns:
Scrollbar based object.

const ScrolledContainer * CEGUI::ScrollablePane::getContentPane ( void ) const

Returns a pointer to the window holding the pane contents.

The purpose of this is so that attached windows may be inspected, client code may not modify the returned window in any way.

Returns:
Pointer to the ScrolledContainer that is acting as the container for the scrollable pane content. The returned window is const, client code should not modify the ScrolledContainer settings directly.

const Rect & CEGUI::ScrollablePane::getContentPaneArea ( void ) const

Return the current content pane area for the ScrollablePane.

Returns:
Rect object that details the current pixel extents of the content pane attached to this ScrollablePane.

float CEGUI::ScrollablePane::getHorizontalOverlapSize ( void ) const

Returns the horizontal scrollbar overlap size as a fraction of one complete view page.

Returns:
float value specifying the overlap size where 1.0f would be the width of the viewing area.

float CEGUI::ScrollablePane::getHorizontalScrollPosition ( void ) const

Returns the horizontal scroll position as a fraction of the complete scrollable width.

Returns:
float value specifying the scroll position.

float CEGUI::ScrollablePane::getHorizontalStepSize ( void ) const

Returns the horizontal scrollbar step size as a fraction of one complete view page.

Returns:
float value specifying the step size where 1.0f would be the width of the viewing area.

float CEGUI::ScrollablePane::getVerticalOverlapSize ( void ) const

Returns the vertical scrollbar overlap size as a fraction of one complete view page.

Returns:
float value specifying the overlap size where 1.0f would be the height of the viewing area.

float CEGUI::ScrollablePane::getVerticalScrollPosition ( void ) const

Returns the vertical scroll position as a fraction of the complete scrollable height.

Returns:
float value specifying the scroll position.

float CEGUI::ScrollablePane::getVerticalStepSize ( void ) const

Returns the vertical scrollbar step size as a fraction of one complete view page.

Returns:
float value specifying the step size where 1.0f would be the height of the viewing area.

virtual Rect CEGUI::ScrollablePane::getViewableArea ( void ) const [protected, pure virtual]

Return a Rect that described the pane's viewable area, relative to this Window, in pixels.

Returns:
Rect object describing the ScrollablePane's viewable area.

void CEGUI::ScrollablePane::initialise ( void ) [virtual]

Initialises the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

bool CEGUI::ScrollablePane::isContentPaneAutoSized ( void ) const

Return whether the content pane is auto sized.

Returns:
  • true to indicate the content pane will automatically resize itself.
  • false to indicate the content pane will not automatically resize itself.

bool CEGUI::ScrollablePane::isHorzScrollbarAlwaysShown ( void ) const

Return whether the horizontal scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

bool CEGUI::ScrollablePane::isHorzScrollbarNeeded ( void ) const [protected]

Return whether the horizontal scrollbar is needed.

Returns:
  • true if the scrollbar is either needed or forced via setting.
  • false if the scrollbar should not be shown.

bool CEGUI::ScrollablePane::isVertScrollbarAlwaysShown ( void ) const

Return whether the vertical scroll bar is always shown.

Returns:
  • true if the scroll bar will always be shown even if it is not required.
  • false if the scroll bar will only be shown when it is required.

bool CEGUI::ScrollablePane::isVertScrollbarNeeded ( void ) const [protected]

Return whether the vertical scrollbar is needed.

Returns:
  • true if the scrollbar is either needed or forced via setting.
  • false if the scrollbar should not be shown.

void CEGUI::ScrollablePane::onAutoSizeSettingChanged ( WindowEventArgs & e ) [protected, virtual]

Notification method called whenever the setting that controls whether the content pane is automatically sized is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrollablePane::onContentPaneChanged ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called when some pane content has changed size or location.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrollablePane::onContentPaneScrolled ( WindowEventArgs & e ) [protected, virtual]

Notification method called whenever the content pane is scrolled via changes in the scrollbar positions.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrollablePane::onHorzScrollbarModeChanged ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called when the setting that controls whether the horizontal scrollbar is always shown or not, is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrollablePane::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::ScrollablePane::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::ScrollablePane::onVertScrollbarModeChanged ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called when the setting that controls whether the vertical scrollbar is always shown or not, is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrollablePane::setContentPaneArea ( const Rect & area )

Set the current content pane area for the ScrollablePane.

Note:
If the ScrollablePane is configured to auto-size the content pane this call will have no effect.
Parameters:
area Rect object that details the pixel extents to use for the content pane attached to this ScrollablePane.
Returns:
Nothing.

void CEGUI::ScrollablePane::setContentPaneAutoSized ( bool setting )

Set whether the content pane should be auto-sized.

Parameters:
setting
  • true to indicate the content pane should automatically resize itself.
  • false to indicate the content pane should not automatically resize itself.
Returns:
Nothing.

void CEGUI::ScrollablePane::setHorizontalOverlapSize ( float overlap )

Sets the horizontal scrollbar overlap size as a fraction of one complete view page.

Parameters:
overlap float value specifying the overlap size, where 1.0f would be the width of the viewing area.
Returns:
Nothing.

void CEGUI::ScrollablePane::setHorizontalScrollPosition ( float position )

Sets the horizontal scroll position as a fraction of the complete scrollable width.

Parameters:
position float value specifying the new scroll position.
Returns:
Nothing.

void CEGUI::ScrollablePane::setHorizontalStepSize ( float step )

Sets the horizontal scrollbar step size as a fraction of one complete view page.

Parameters:
step float value specifying the step size, where 1.0f would be the width of the viewing area.
Returns:
Nothing.

void CEGUI::ScrollablePane::setShowHorzScrollbar ( bool setting )

Set whether the horizontal scroll bar should always be shown.

Parameters:
setting
  • true if the horizontal scroll bar should be shown even when it is not required.
  • false if the horizontal scroll bar should only be shown when it is required.
Returns:
Nothing.

void CEGUI::ScrollablePane::setShowVertScrollbar ( bool setting )

Set whether the vertical scroll bar should always be shown.

Parameters:
setting
  • true if the vertical scroll bar should be shown even when it is not required.
  • false if the vertical scroll bar should only be shown when it is required.
Returns:
Nothing.

void CEGUI::ScrollablePane::setVerticalOverlapSize ( float overlap )

Sets the vertical scrollbar overlap size as a fraction of one complete view page.

Parameters:
overlap float value specifying the overlap size, where 1.0f would be the height of the viewing area.
Returns:
Nothing.

void CEGUI::ScrollablePane::setVerticalScrollPosition ( float position )

Sets the vertical scroll position as a fraction of the complete scrollable height.

Parameters:
position float value specifying the new scroll position.
Returns:
Nothing.

void CEGUI::ScrollablePane::setVerticalStepSize ( float step )

Sets the vertical scrollbar step size as a fraction of one complete view page.

Parameters:
step float value specifying the step size, where 1.0f would be the height of the viewing area.
Returns:
Nothing.

virtual bool CEGUI::ScrollablePane::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Scrollbar Class Reference

CEGUI::Scrollbar

CEGUI::Scrollbar Class Reference

Base scroll bar class. More...

Inheritance diagram for CEGUI::Scrollbar:

[legend]
Collaboration diagram for CEGUI::Scrollbar:

[legend]
List of all members.

Public Member Functions

float | getDocumentSize (void) const
Return the size of the document or data.
float | getPageSize (void) const
Return the page size for this scroll bar.
float | getStepSize (void) const
Return the step size for this scroll bar.
float | getOverlapSize (void) const
Return the overlap size for this scroll bar.
float | getScrollPosition (void) const
Return the current position of scroll bar within the document.
virtual void | initialise (void)
Initialises the Scrollbar object ready for use.
void | setDocumentSize (float document_size)
Set the size of the document or data.
void | setPageSize (float page_size)
Set the page size for this scroll bar.
void | setStepSize (float step_size)
Set the step size for this scroll bar.
void | setOverlapSize (float overlap_size)
Set the overlap size for this scroll bar.
void | setScrollPosition (float position)
Set the current position of scroll bar within the document.
Scrollbar (const String &type, const String &name)
Constructor for Scrollbar objects.
virtual | ~Scrollbar (void)
Destructor for Scrollbar objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventScrollPositionChanged
Name of the event fired when the scroll bar position value changes.
static const String | EventThumbTrackStarted
Name of the event fired when the user begins dragging the thumb.
static const String | EventThumbTrackEnded
Name of the event fired when the user releases the thumb.
static const String | EventScrollConfigChanged
Name of the event fired when the scroll bar configuration data changes.

Protected Member Functions

void | addScrollbarEvents (void)
Add scroll bar specific events.
virtual PushButton * | createIncreaseButton (const String &name) const =0
create a PushButton based widget to use as the increase button for this scroll bar.
virtual PushButton * | createDecreaseButton (const String &name) const =0
create a PushButton based widget to use as the decrease button for this scroll bar.
virtual Thumb * | createThumb (const String &name) const =0
create a Thumb based widget to use as the thumb for this scroll bar.
virtual void | updateThumb (void)=0
update the size and location of the thumb to properly represent the current state of the scroll bar
virtual float | getValueFromThumb (void) const =0
return value that best represents current scroll bar position given the current location of the thumb.
virtual float | getAdjustDirectionFromPoint (const Point &pt) const =0
Given window location pt, return a value indicating what change should be made to the scroll bar.
bool | handleThumbMoved (const EventArgs &e)
handler function for when thumb moves.
bool | handleIncreaseClicked (const EventArgs &e)
handler function for when the increase button is clicked.
bool | handleDecreaseClicked (const EventArgs &e)
handler function for when the decrease button is clicked.
bool | handleThumbTrackStarted (const EventArgs &e)
handler function for when thumb tracking begins
bool | handleThumbTrackEnded (const EventArgs &e)
handler function for when thumb tracking begins
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onScrollPositionChanged (WindowEventArgs &e)
Handler triggered when the scroll position changes.
virtual void | onThumbTrackStarted (WindowEventArgs &e)
Handler triggered when the user begins to drag the scroll bar thumb.
virtual void | onThumbTrackEnded (WindowEventArgs &e)
Handler triggered when the scroll bar thumb is released.
virtual void | onScrollConfigChanged (WindowEventArgs &e)
Handler triggered when the scroll bar data configuration changes.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.

Protected Attributes

float | d_documentSize
The size of the document / data being scrolled thorugh.
float | d_pageSize
The size of a single 'page' of data.
float | d_stepSize
Step size used for increase / decrease button clicks.
float | d_overlapSize
Amount of overlap when jumping by a page.
float | d_position
Current scroll position.
Thumb * d_thumb
widget used to represent the 'thumb' of the scroll bar.
PushButton * d_increase
Widget used for the increase button of the scroll bar.
PushButton * d_decrease
Widget used for the decrease button of the scroll bar.

Detailed Description

Base scroll bar class.

This base class for scroll bars does not have any idea of direction - a derived class would add whatever meaning is appropriate according to what that derived class represents to the user.

Member Function Documentation

virtual PushButton* CEGUI::Scrollbar::createDecreaseButton ( const String & name ) const [protected, pure virtual]

create a PushButton based widget to use as the decrease button for this scroll bar.

Parameters:
name String holding the name that must be passed when creating the component widget.

virtual PushButton* CEGUI::Scrollbar::createIncreaseButton ( const String & name ) const [protected, pure virtual]

create a PushButton based widget to use as the increase button for this scroll bar.

Parameters:
name String holding the name that must be passed when creating the component widget.

virtual Thumb* CEGUI::Scrollbar::createThumb ( const String & name ) const [protected, pure virtual]

create a Thumb based widget to use as the thumb for this scroll bar.

Parameters:
name String holding the name that must be passed when creating the component widget.

virtual float CEGUI::Scrollbar::getAdjustDirectionFromPoint ( const Point & pt ) const [protected, pure virtual]

Given window location pt, return a value indicating what change should be made to the scroll bar.

Parameters:
pt Point object describing a pixel position in window space.
Returns:
  • -1 to indicate scroll bar position should be moved to a lower value.
  • 0 to indicate scroll bar position should not be changed.
  • +1 to indicate scroll bar position should be moved to a higher value.

float CEGUI::Scrollbar::getDocumentSize ( void ) const [inline]

Return the size of the document or data.

The document size should be thought of as the total size of the data that is being scrolled through (the number of lines in a text file for example).

Note:
The returned value has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Returns:
float value specifying the currently set document size.

float CEGUI::Scrollbar::getOverlapSize ( void ) const [inline]

Return the overlap size for this scroll bar.

The overlap size is the amount of data from the end of a 'page' that will remain visible when the position is moved by a page. This is usually used so that the user keeps some context of where they were within the document's data when jumping a page at a time.

Note:
The returned value has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Returns:
float value specifying the currently set overlap size.

float CEGUI::Scrollbar::getPageSize ( void ) const [inline]

Return the page size for this scroll bar.

The page size is typically the amount of data that can be displayed at one time. This value is also used when calculating the amount the position will change when you click either side of the scroll bar thumb - the amount the position changes will is (pageSize - overlapSize).

Note:
The returned value has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Returns:
float value specifying the currently set page size.

float CEGUI::Scrollbar::getScrollPosition ( void ) const [inline]

Return the current position of scroll bar within the document.

The range of the scroll bar is from 0 to the size of the document minus the size of a page (0 <= position <= (documentSize - pageSize)).

Note:
The returned value has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Returns:
float value specifying the current position of the scroll bar within its document.

float CEGUI::Scrollbar::getStepSize ( void ) const [inline]

Return the step size for this scroll bar.

The step size is typically a single unit of data that can be displayed, this is the amount the position will change when you click either of the arrow buttons on the scroll bar. (this could be 1 for a single line of text, for example).

Note:
The returned value has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Returns:
float value specifying the currently set step size.

virtual float CEGUI::Scrollbar::getValueFromThumb ( void ) const [protected, pure virtual]

return value that best represents current scroll bar position given the current location of the thumb.

Returns:
float value that, given the thumb widget position, best represents the current position for the scroll bar.

void CEGUI::Scrollbar::initialise ( void ) [virtual]

Initialises the Scrollbar object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::Scrollbar::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Scrollbar::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Scrollbar::setDocumentSize ( float document_size )

Set the size of the document or data.

The document size should be thought of as the total size of the data that is being scrolled through (the number of lines in a text file for example).

Note:
The value set has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Parameters:
document_size float value specifying the document size.
Returns:
Nothing.

void CEGUI::Scrollbar::setOverlapSize ( float overlap_size )

Set the overlap size for this scroll bar.

The overlap size is the amount of data from the end of a 'page' that will remain visible when the position is moved by a page. This is usually used so that the user keeps some context of where they were within the document's data when jumping a page at a time.

Note:
The value set has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Parameters:
overlap_size float value specifying the overlap size.
Returns:
Nothing.

void CEGUI::Scrollbar::setPageSize ( float page_size )

Set the page size for this scroll bar.

The page size is typically the amount of data that can be displayed at one time. This value is also used when calculating the amount the position will change when you click either side of the scroll bar thumb - the amount the position changes will is (pageSize - overlapSize).

Note:
The value set has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Parameters:
page_size float value specifying the page size.
Returns:
Nothing.

void CEGUI::Scrollbar::setScrollPosition ( float position )

Set the current position of scroll bar within the document.

The range of the scroll bar is from 0 to the size of the document minus the size of a page (0 <= position <= (documentSize - pageSize)), any attempt to set the position outside this range will be adjusted so that it falls within the legal range.

Note:
The returned value has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Parameters:
position float value specifying the position of the scroll bar within its document.
Returns:
Nothing.

void CEGUI::Scrollbar::setStepSize ( float step_size )

Set the step size for this scroll bar.

The step size is typically a single unit of data that can be displayed, this is the amount the position will change when you click either of the arrow buttons on the scroll bar. (this could be 1 for a single line of text, for example).

Note:
The value set has no meaning within the Gui system, it is left up to the application to assign appropriate values for the application specific use of the scroll bar.
Parameters:
step_size float value specifying the step size.
Returns:
Nothing.

virtual bool CEGUI::Scrollbar::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrolledContainer Class Reference

CEGUI::ScrolledContainer

CEGUI::ScrolledContainer Class Reference

Helper container window class which is used in the implementation of the ScrollablePane widget class. More...

Inheritance diagram for CEGUI::ScrolledContainer:

[legend]
Collaboration diagram for CEGUI::ScrolledContainer:

[legend]
List of all members.

Public Member Functions

ScrolledContainer (const String &type, const String &name)
Constructor for ScrolledContainer objects.
~ScrolledContainer (void)
Destructor for ScrolledContainer objects.
bool | isContentPaneAutoSized (void) const
Return whether the content pane is auto sized.
void | setContentPaneAutoSized (bool setting)
Set whether the content pane should be auto-sized.
const Rect & | getContentArea (void) const
Return the current content pane area for the ScrolledContainer.
void | setContentArea (const Rect &area)
Set the current content pane area for the ScrolledContainer.
Rect | getChildExtentsArea (void) const
Return the current extents of the attached content.

Static Public Attributes

static const String | WidgetTypeName
Type name for ScrolledContainer.
static const String | EventNamespace
Namespace for global events.
static const String | EventContentChanged
Event fired whenever some child changes.
static const String | EventAutoSizeSettingChanged
Event fired when the autosize setting changes.

Protected Types

typedef std::multimap< Window *,
Event::Connection > 		ConnectionTracker

Protected Member Functions

void | addScrolledContainerEvents (void)
Adds events for this widget type.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
void | drawSelf (float z)
Perform the actual rendering for this Window.
virtual void | onContentChanged (WindowEventArgs &e)
Notification method called whenever the content size may have changed.
virtual void | onAutoSizeSettingChanged (WindowEventArgs &e)
Notification method called whenever the setting that controls whether the content pane is automatically sized is changed.
bool | handleChildSized (const EventArgs &e)
Method which receives notifications about child windows being moved.
bool | handleChildMoved (const EventArgs &e)
Method which receives notifications about child windows being sized.
Rect | getUnclippedInnerRect (void) const
Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.
void | onChildAdded (WindowEventArgs &e)
Handler called when a child window is added to this window.
void | onChildRemoved (WindowEventArgs &e)
Handler called when a child window is removed from this window.
void | onParentSized (WindowEventArgs &e)
Handler called when this window's parent window has been resized. If this window is the root / GUI Sheet window, this call will be made when the screen size changes.

Protected Attributes

ConnectionTracker | d_eventConnections
Tracks event connections we make.
Rect d_contentArea
Holds extents of the content pane.
bool | d_autosizePane
true if the pane auto-sizes itself.

Detailed Description

Helper container window class which is used in the implementation of the ScrollablePane widget class.

Member Function Documentation

void CEGUI::ScrolledContainer::drawSelf ( float z ) [inline, protected, virtual]

Perform the actual rendering for this Window.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented from CEGUI::Window.

Rect CEGUI::ScrolledContainer::getChildExtentsArea ( void ) const

Return the current extents of the attached content.

Returns:
Rect object that describes the pixel extents of the attached child windows. This is effectively the smallest bounding box that could contain all the attached windows.

const Rect & CEGUI::ScrolledContainer::getContentArea ( void ) const

Return the current content pane area for the ScrolledContainer.

Returns:
Rect object that details the current pixel extents of the content pane represented by this ScrolledContainer.

Rect CEGUI::ScrolledContainer::getUnclippedInnerRect ( void ) const [protected, virtual]

Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.

Returns:
Rect object that describes, in unclipped screen pixel co-ordinates, the window object's inner rect area.

Reimplemented from CEGUI::Window.

bool CEGUI::ScrolledContainer::isContentPaneAutoSized ( void ) const

Return whether the content pane is auto sized.

Returns:
  • true to indicate the content pane will automatically resize itself.
  • false to indicate the content pane will not automatically resize itself.

void CEGUI::ScrolledContainer::onAutoSizeSettingChanged ( WindowEventArgs & e ) [protected, virtual]

Notification method called whenever the setting that controls whether the content pane is automatically sized is changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrolledContainer::onChildAdded ( WindowEventArgs & e ) [protected, virtual]

Handler called when a child window is added to this window.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that has been added.

Reimplemented from CEGUI::Window.

void CEGUI::ScrolledContainer::onChildRemoved ( WindowEventArgs & e ) [protected, virtual]

Handler called when a child window is removed from this window.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set the window that has been removed.

Reimplemented from CEGUI::Window.

void CEGUI::ScrolledContainer::onContentChanged ( WindowEventArgs & e ) [protected, virtual]

Notification method called whenever the content size may have changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::ScrolledContainer::onParentSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window's parent window has been resized. If this window is the root / GUI Sheet window, this call will be made when the screen size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set the the window that caused the event; this is typically either this window's parent window, or NULL to indicate the screen size has changed.

Reimplemented from CEGUI::Window.

void CEGUI::ScrolledContainer::setContentArea ( const Rect & area )

Set the current content pane area for the ScrolledContainer.

Note:
If the ScrolledContainer is configured to auto-size the content pane this call will have no effect.
Parameters:
area Rect object that details the pixel extents to use for the content pane represented by this ScrolledContainer.
Returns:
Nothing.

void CEGUI::ScrolledContainer::setContentPaneAutoSized ( bool setting )

Set whether the content pane should be auto-sized.

Parameters:
setting
  • true to indicate the content pane should automatically resize itself.
  • false to indicate the content pane should not automatically resize itself.
Returns:
Nothing.

virtual bool CEGUI::ScrolledContainer::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrolledContainerFactory Class Reference

CEGUI::ScrolledContainerFactory

CEGUI::ScrolledContainerFactory Class Reference

Factory class for producing ScrolledContainer windows. More...

Inheritance diagram for CEGUI::ScrolledContainerFactory:

[legend]
Collaboration diagram for CEGUI::ScrolledContainerFactory:

[legend]
List of all members.

Public Member Functions

Window * | createWindow (const String &name)
Create a new Window object of whatever type this WindowFactory produces.
void | destroyWindow (Window *window)
Destroys the given Window object.

Detailed Description

Factory class for producing ScrolledContainer windows.

Member Function Documentation

Window* CEGUI::ScrolledContainerFactory::createWindow ( const String & name ) [inline, virtual]

Create a new Window object of whatever type this WindowFactory produces.

Parameters:
name A unique name that is to be assigned to the newly created Window object
Returns:
Pointer to the new Window object.

Implements CEGUI::WindowFactory.

void CEGUI::ScrolledContainerFactory::destroyWindow ( Window * window ) [inline, virtual]

Destroys the given Window object.

Parameters:
window Pointer to the Window object to be destroyed.
Returns:
Nothing.

Implements CEGUI::WindowFactory.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollbarProperties::ScrollPosition Class Reference

CEGUI::ScrollbarProperties::ScrollPosition

CEGUI::ScrollbarProperties::ScrollPosition Class Reference

Property to access the scroll position of the Scrollbar. More...

Inheritance diagram for CEGUI::ScrollbarProperties::ScrollPosition:

[legend]
Collaboration diagram for CEGUI::ScrollbarProperties::ScrollPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the scroll position of the Scrollbar.

Usage:
  • Name: ScrollPosition
  • Format: "[float]".
Where:
  • [float] specifies the current scroll position / value of the Scrollbar.

Member Function Documentation

String CEGUI::ScrollbarProperties::ScrollPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollbarProperties::ScrollPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SectionSpecification Class Reference

CEGUI::SectionSpecification

CEGUI::SectionSpecification Class Reference

Class that represents a simple 'link' to an ImagerySection. More...

Collaboration diagram for CEGUI::SectionSpecification:

[legend]
List of all members.

Public Member Functions

SectionSpecification (const String &owner, const String &sectionName)
Constructor.
SectionSpecification (const String &owner, const String &sectionName, const ColourRect &cols)
Constructor.
void | render (Window &srcWindow, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render the section specified by this SectionSpecification.
void | render (Window &srcWindow, const Rect &baseRect, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const
Render the section specified by this SectionSpecification.
const String & | getOwnerWidgetLookFeel () const
Return the name of the WidgetLookFeel object containing the target section.
const String & | getSectionName () const
Return the name of the target ImagerySection.
const ColourRect & | getOverrideColours () const
Return the current override colours.
void | setOverrideColours (const ColourRect &cols)
Set the override colours to be used by this SectionSpecification.
bool | isUsingOverrideColours () const
return whether the use of override colours is enabled on this SectionSpecification.
void | setUsingOverrideColours (bool setting=true)
Enable or disable the use of override colours for this section.
void | setOverrideColoursPropertySource (const String &property)
Set the name of the property where override colour values can be obtained.
void | setOverrideColoursPropertyIsColourRect (bool setting=true)
Set whether the override colours property source represents a full ColourRect.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this SectionSpecification to out_stream.

Protected Member Functions

void | initColourRectForOverride (const Window &wnd, ColourRect &cr) const
Helper method to initialise a ColourRect with appropriate values according to the way the section sepcification is set up.

Detailed Description

Class that represents a simple 'link' to an ImagerySection.

This class enables sections to be easily re-used, by different states and/or layers, by allowing sections to be specified by name rather than having mutiple copies of the same thing all over the place.

Constructor & Destructor Documentation

CEGUI::SectionSpecification::SectionSpecification | ( | const String & | owner,
 |  | const String & | sectionName
 | ) |

Constructor.

Parameters:
owner | String holding the name of the WidgetLookFeel object that contains the target section.
sectionName | String holding the name of the target section.

CEGUI::SectionSpecification::SectionSpecification | ( | const String & | owner,
 |  | const String & | sectionName,
 |  | const ColourRect & | cols
 | ) |

Constructor.

Parameters:
owner | String holding the name of the WidgetLookFeel object that contains the target section.
sectionName | String holding the name of the target section.
cols | Override colours to be used (modulates sections master colours).

Member Function Documentation

const ColourRect & CEGUI::SectionSpecification::getOverrideColours ( ) const

Return the current override colours.

Returns:
ColourRect holding the colours that will be modulated with the sections master colours if colour override is enabled on this SectionSpecification.

const String & CEGUI::SectionSpecification::getOwnerWidgetLookFeel ( ) const

Return the name of the WidgetLookFeel object containing the target section.

Returns:
String object holding the name of the WidgetLookFeel that contains the target ImagerySection.

const String & CEGUI::SectionSpecification::getSectionName ( ) const

Return the name of the target ImagerySection.

Returns:
String object holding the name of the target ImagerySection.

void CEGUI::SectionSpecification::initColourRectForOverride | ( | const Window & | wnd,
 |  | ColourRect & | cr
 | ) | const [protected]

Helper method to initialise a ColourRect with appropriate values according to the way the section sepcification is set up.

This will try and get values from multiple places:

  • a property attached to wnd
  • the integral d_coloursOverride values.
  • or default to colour(1,1,1,1);

bool CEGUI::SectionSpecification::isUsingOverrideColours ( ) const

return whether the use of override colours is enabled on this SectionSpecification.

Returns:
  • true if override colours will be used for this SectionSpecification.
  • false if override colours will not be used for this SectionSpecification.

void CEGUI::SectionSpecification::render | ( | Window & | srcWindow,
 |  | const Rect & | baseRect,
 |  | float | base_z,
 |  | const ColourRect * | modcols = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render the section specified by this SectionSpecification.

Parameters:
srcWindow | Window object to be used when calculating pixel values from BaseDim values.
baseRect | Rect object to be used when calculating pixel values from BaseDim values.
base_z | base z co-ordinate to use for all imagery in the linked section.
Returns:
Nothing.

void CEGUI::SectionSpecification::render | ( | Window & | srcWindow,
 |  | float | base_z,
 |  | const ColourRect * | modcols = 0,
 |  | const Rect * | clipper = 0,
 |  | bool | clipToDisplay = false
 | ) | const

Render the section specified by this SectionSpecification.

Parameters:
srcWindow | Window object to be used when calculating pixel values from BaseDim values.
base_z | base z co-ordinate to use for all imagery in the linked section.
Returns:
Nothing.

void CEGUI::SectionSpecification::setOverrideColours ( const ColourRect & cols )

Set the override colours to be used by this SectionSpecification.

Parameters:
cols ColourRect describing the override colours to set for this SectionSpecification.
Returns:
Nothing.

void CEGUI::SectionSpecification::setOverrideColoursPropertyIsColourRect ( bool setting = true )

Set whether the override colours property source represents a full ColourRect.

Parameters:
setting
  • true if the override colours property will access a ColourRect object.
  • false if the override colours property will access a colour object.
Returns:
Nothing.

void CEGUI::SectionSpecification::setOverrideColoursPropertySource ( const String & property )

Set the name of the property where override colour values can be obtained.

Parameters:
property String containing the name of the property.
Returns:
Nothing.

void CEGUI::SectionSpecification::setUsingOverrideColours ( bool setting = true )

Enable or disable the use of override colours for this section.

Parameters:
setting
  • true if override colours should be used for this SectionSpecification.
  • false if override colours should not be used for this SectionSpecification.
Returns:
Nothing.

void CEGUI::SectionSpecification::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this SectionSpecification to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RadioButtonProperties::Selected Class Reference

CEGUI::RadioButtonProperties::Selected

CEGUI::RadioButtonProperties::Selected Class Reference

Property to access the selected state of the RadioButton. More...

Inheritance diagram for CEGUI::RadioButtonProperties::Selected:

[legend]
Collaboration diagram for CEGUI::RadioButtonProperties::Selected:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the selected state of the RadioButton.

Usage:
  • Name: Selected
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the radio button is selected.
  • "False" to indicate the radio button is not selected.

Member Function Documentation

String CEGUI::RadioButtonProperties::Selected::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::RadioButtonProperties::Selected::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::CheckboxProperties::Selected Class Reference

CEGUI::CheckboxProperties::Selected

CEGUI::CheckboxProperties::Selected Class Reference

Property to access the selected state of the check box. More...

Inheritance diagram for CEGUI::CheckboxProperties::Selected:

[legend]
Collaboration diagram for CEGUI::CheckboxProperties::Selected:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the selected state of the check box.

This property offers access to the select state for the Checkbox object.

Usage:
  • Name: Selected
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the check box is selected (has check mark).
  • "False" to indicate the check box is not selected (does not have check mark).

Member Function Documentation

String CEGUI::CheckboxProperties::Selected::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::CheckboxProperties::Selected::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::SelectedEditTextColour Class Reference

CEGUI::ComboboxProperties::SelectedEditTextColour

CEGUI::ComboboxProperties::SelectedEditTextColour Class Reference

Property to access the colour used for rendering text within the selection area. More...

Inheritance diagram for CEGUI::ComboboxProperties::SelectedEditTextColour:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::SelectedEditTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering text within the selection area.

Usage:
  • Name: SelectedEditTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::ComboboxProperties::SelectedEditTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::SelectedEditTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::SelectedTextColour Class Reference

CEGUI::MultiLineEditboxProperties::SelectedTextColour

CEGUI::MultiLineEditboxProperties::SelectedTextColour Class Reference

Property to access the colour used for rendering text within the selection area. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::SelectedTextColour:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::SelectedTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering text within the selection area.

Usage:
  • Name: SelectedTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::SelectedTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::SelectedTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::SelectedTextColour Class Reference

CEGUI::EditboxProperties::SelectedTextColour

CEGUI::EditboxProperties::SelectedTextColour Class Reference

Property to access the colour used for rendering text within the selection area. More...

Inheritance diagram for CEGUI::EditboxProperties::SelectedTextColour:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::SelectedTextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the colour used for rendering text within the selection area.

Usage:
  • Name: SelectedTextColour
  • Format: "aarrggbb".
Where:
  • aarrggbb is the ARGB colour value to be used.

Member Function Documentation

String CEGUI::EditboxProperties::SelectedTextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::SelectedTextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::SelectionLength Class Reference

CEGUI::MultiLineEditboxProperties::SelectionLength

CEGUI::MultiLineEditboxProperties::SelectionLength Class Reference

Property to access the current selection length. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::SelectionLength:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::SelectionLength:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current selection length.

Usage:
  • Name: SelectionLength
  • Format: "[uint]"
Where:
  • [uint] is the length of the selection (as a count of the number of code points selected).

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::SelectionLength::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::SelectionLength::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::SelectionLength Class Reference

CEGUI::EditboxProperties::SelectionLength

CEGUI::EditboxProperties::SelectionLength Class Reference

Property to access the current selection length. More...

Inheritance diagram for CEGUI::EditboxProperties::SelectionLength:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::SelectionLength:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current selection length.

Usage:
  • Name: SelectionLength
  • Format: "[uint]"
Where:
  • [uint] is the length of the selection (as a count of the number of code points selected).

Member Function Documentation

String CEGUI::EditboxProperties::SelectionLength::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::SelectionLength::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::SelectionMode Class Reference

CEGUI::MultiColumnListProperties::SelectionMode

CEGUI::MultiColumnListProperties::SelectionMode Class Reference

Property to access the selection mode setting of the list. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::SelectionMode:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::SelectionMode:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the selection mode setting of the list.

Usage:
  • Name: SelectionMode
  • Format: "[text]"
Where [Text] is one of:
  • "RowSingle"
  • "RowMultiple"
  • "CellSingle"
  • "CellMultiple"
  • "NominatedColumnSingle"
  • "NominatedColumnMultiple"
  • "ColumnSingle"
  • "ColumnMultiple"
  • "NominatedRowSingle"
  • "NominatedRowMultiple"

Member Function Documentation

String CEGUI::MultiColumnListProperties::SelectionMode::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::SelectionMode::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::SelectionStart Class Reference

CEGUI::EditboxProperties::SelectionStart

CEGUI::EditboxProperties::SelectionStart Class Reference

Property to access the current selection start index. More...

Inheritance diagram for CEGUI::EditboxProperties::SelectionStart:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::SelectionStart:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current selection start index.

Usage:
  • Name: SelectionStart
  • Format: "[uint]"
Where:
  • [uint] is the zero based index of the selection start position within the text.

Member Function Documentation

String CEGUI::EditboxProperties::SelectionStart::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::SelectionStart::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::SelectionStart Class Reference

CEGUI::MultiLineEditboxProperties::SelectionStart

CEGUI::MultiLineEditboxProperties::SelectionStart Class Reference

Property to access the current selection start index. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::SelectionStart:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::SelectionStart:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current selection start index.

Usage:
  • Name: SelectionStart
  • Format: "[uint]"
Where:
  • [uint] is the zero based index of the selection start position within the text.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::SelectionStart::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::SelectionStart::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SimpleTimer Class Reference

CEGUI::SimpleTimer

CEGUI::SimpleTimer Class Reference

Simple timer class. More...

List of all members.

Public Member Functions

void | restart ()
double | elapsed ()

Detailed Description

Simple timer class.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::SingleClickMode Class Reference

CEGUI::ComboboxProperties::SingleClickMode

CEGUI::ComboboxProperties::SingleClickMode Class Reference

Property to access the 'single click mode' setting for the combo box. More...

Inheritance diagram for CEGUI::ComboboxProperties::SingleClickMode:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::SingleClickMode:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the 'single click mode' setting for the combo box.

Usage:
  • Name: SingleClickMode
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate that the box will operate in single click mode
  • "False" to indicate that the box will not operate in single click mode

Member Function Documentation

String CEGUI::ComboboxProperties::SingleClickMode::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::SingleClickMode::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderSegmentProperties::Sizable Class Reference

CEGUI::ListHeaderSegmentProperties::Sizable

CEGUI::ListHeaderSegmentProperties::Sizable Class Reference

Property to access the sizable setting of the header segment. More...

Inheritance diagram for CEGUI::ListHeaderSegmentProperties::Sizable:

[legend]
Collaboration diagram for CEGUI::ListHeaderSegmentProperties::Sizable:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the sizable setting of the header segment.

Usage:
  • Name: Sizable
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the segment can be sized by the user.
  • "False" to indicate the segment can not be sized by the user.

Member Function Documentation

String CEGUI::ListHeaderSegmentProperties::Sizable::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderSegmentProperties::Sizable::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Size Class Reference

CEGUI::Size

CEGUI::Size Class Reference

Class that holds the size (width & height) of something. More...

List of all members.

Public Member Functions

Size (float width, float height)
bool | operator== (const Size &other) const
bool | operator!= (const Size &other) const

Public Attributes

float | d_width
float | d_height

Detailed Description

Class that holds the size (width & height) of something.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Size Class Reference

CEGUI::WindowProperties::Size

CEGUI::WindowProperties::Size Class Reference

Property to access the window size. More...

Inheritance diagram for CEGUI::WindowProperties::Size:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Size:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the window size.

This property offers access to the size setting for the window, using the Windows active metrics mode.

Usage:
  • Name: Size
  • Format: "w:[float] h:[float]".
Where:
  • w:[float] specifies the minimum width as a floating point number, using the active metrics system for the Window.
  • h:[float] specifies the minimum height as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::Size::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Size::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::SizingBorderThickness Class Reference

CEGUI::FrameWindowProperties::SizingBorderThickness

CEGUI::FrameWindowProperties::SizingBorderThickness Class Reference

Property to access the setting for the sizing border thickness. More...

Inheritance diagram for CEGUI::FrameWindowProperties::SizingBorderThickness:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::SizingBorderThickness:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for the sizing border thickness.

Usage:
  • Name: SizingBorderThickness
  • Format: "[float]".
Where:
  • [float] is the size of the invisible sizing border in screen pixels.

Member Function Documentation

String CEGUI::FrameWindowProperties::SizingBorderThickness::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::SizingBorderThickness::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::SizingEnabled Class Reference

CEGUI::FrameWindowProperties::SizingEnabled

CEGUI::FrameWindowProperties::SizingEnabled Class Reference

Property to access the state of the sizable setting for the FrameWindow. More...

Inheritance diagram for CEGUI::FrameWindowProperties::SizingEnabled:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::SizingEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state of the sizable setting for the FrameWindow.

Usage:
  • Name: SizingEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the window will be user re-sizable.
  • "False" to indicate the window will not be re-sizable by the user.

Member Function Documentation

String CEGUI::FrameWindowProperties::SizingEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::SizingEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Slider Class Reference

CEGUI::Slider

CEGUI::Slider Class Reference

Base class for Slider widgets. More...

Inheritance diagram for CEGUI::Slider:

[legend]
Collaboration diagram for CEGUI::Slider:

[legend]
List of all members.

Public Member Functions

float | getCurrentValue (void) const
return the current slider value.
float | getMaxValue (void) const
return the maximum value set for this widget
float | getClickStep (void) const
return the current click step setting for the slider.
virtual void | initialise (void)
Initialises the Window based object ready for use.
void | setMaxValue (float maxVal)
set the maximum value for the slider. Note that the minimum value is fixed at 0.
void | setCurrentValue (float value)
set the current slider value.
void | setClickStep (float step)
set the current click step setting for the slider.
Slider (const String &type, const String &name)
Slider base class constructor.
virtual | ~Slider (void)
Slider base class destructor.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventValueChanged
Event fired when the slider value changes.
static const String | EventThumbTrackStarted
Name of the event fired when the user begins dragging the thumb.
static const String | EventThumbTrackEnded
Name of the event fired when the user releases the thumb.

Protected Member Functions

void | addSliderEvents (void)
Add slider specific events.
virtual Thumb * | createThumb (const String &name) const =0
create a Thumb based widget to use as the thumb for this slider.
virtual void | updateThumb (void)=0
update the size and location of the thumb to properly represent the current state of the slider
virtual float | getValueFromThumb (void) const =0
return value that best represents current slider value given the current location of the thumb.
virtual float | getAdjustDirectionFromPoint (const Point &pt) const =0
Given window location pt, return a value indicating what change should be made to the slider.
bool | handleThumbMoved (const EventArgs &e)
handler function for when thumb moves.
bool | handleThumbTrackStarted (const EventArgs &e)
handler function for when thumb tracking begins
bool | handleThumbTrackEnded (const EventArgs &e)
handler function for when thumb tracking begins
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onValueChanged (WindowEventArgs &e)
Handler triggered when the slider value changes.
virtual void | onThumbTrackStarted (WindowEventArgs &e)
Handler triggered when the user begins to drag the slider thumb.
virtual void | onThumbTrackEnded (WindowEventArgs &e)
Handler triggered when the slider thumb is released.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.

Protected Attributes

float | d_value
current slider value
float | d_maxValue
slider maximum value (minimum is fixed at 0)
float | d_step
amount to adjust slider by when clicked (and not dragged).
Thumb * d_thumb
widget used to represent the 'thumb' of the slider.

Detailed Description

Base class for Slider widgets.

The slider widget has a default range of 0.0f - 1.0f. This enables use of the slider value to scale any value needed by way of a simple multiplication.

Member Function Documentation

virtual Thumb* CEGUI::Slider::createThumb ( const String & name ) const [protected, pure virtual]

create a Thumb based widget to use as the thumb for this slider.

Parameters:
name String containing the name to be assigned to the thumb upon creation.

virtual float CEGUI::Slider::getAdjustDirectionFromPoint ( const Point & pt ) const [protected, pure virtual]

Given window location pt, return a value indicating what change should be made to the slider.

Parameters:
pt Point object describing a pixel position in window space.
Returns:
  • -1 to indicate slider should be moved to a lower setting.
  • 0 to indicate slider should not be moved.
  • +1 to indicate slider should be moved to a higher setting.

float CEGUI::Slider::getClickStep ( void ) const [inline]

return the current click step setting for the slider.

The click step size is the amount the slider value will be adjusted when the widget is clicked wither side of the slider thumb.

Returns:
float value representing the current click step setting.

float CEGUI::Slider::getCurrentValue ( void ) const [inline]

return the current slider value.

Returns:
float value equal to the sliders current value.

float CEGUI::Slider::getMaxValue ( void ) const [inline]

return the maximum value set for this widget

Returns:
float value equal to the currently set maximum value for this slider.

virtual float CEGUI::Slider::getValueFromThumb ( void ) const [protected, pure virtual]

return value that best represents current slider value given the current location of the thumb.

Returns:
float value that, given the thumb widget position, best represents the current value for the slider.

void CEGUI::Slider::initialise ( void ) [virtual]

Initialises the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::Slider::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Slider::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Slider::setClickStep ( float step ) [inline]

set the current click step setting for the slider.

The click step size is the amount the slider value will be adjusted when the widget is clicked wither side of the slider thumb.

Parameters:
step float value representing the click step setting to use.
Returns:
Nothing.

void CEGUI::Slider::setCurrentValue ( float value )

set the current slider value.

Parameters:
value float value specifying the new value for this slider widget.
Returns:
Nothing.

void CEGUI::Slider::setMaxValue ( float maxVal )

set the maximum value for the slider. Note that the minimum value is fixed at 0.

Parameters:
maxVal float value specifying the maximum value for this slider widget.
Returns:
Nothing.

virtual bool CEGUI::Slider::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxProperties::Sort Class Reference

CEGUI::ListboxProperties::Sort

CEGUI::ListboxProperties::Sort Class Reference

Property to access the sort setting of the list box. More...

Inheritance diagram for CEGUI::ListboxProperties::Sort:

[legend]
Collaboration diagram for CEGUI::ListboxProperties::Sort:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the sort setting of the list box.

Usage:
  • Name: Sort
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the list items should be sorted.
  • "False" to indicate the list items should not be sorted.

Member Function Documentation

String CEGUI::ListboxProperties::Sort::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListboxProperties::Sort::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderProperties::SortColumnID Class Reference

CEGUI::ListHeaderProperties::SortColumnID

CEGUI::ListHeaderProperties::SortColumnID Class Reference

Property to access the current sort column (via ID code). More...

Inheritance diagram for CEGUI::ListHeaderProperties::SortColumnID:

[legend]
Collaboration diagram for CEGUI::ListHeaderProperties::SortColumnID:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current sort column (via ID code).

Usage:
  • Name: SortColumnID
  • Format: "[uint]".
Where:
  • [uint] is any unsigned integer value.

Member Function Documentation

String CEGUI::ListHeaderProperties::SortColumnID::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderProperties::SortColumnID::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::SortColumnID Class Reference

CEGUI::MultiColumnListProperties::SortColumnID

CEGUI::MultiColumnListProperties::SortColumnID Class Reference

Property to access the current sort column (via ID code). More...

Inheritance diagram for CEGUI::MultiColumnListProperties::SortColumnID:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::SortColumnID:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the current sort column (via ID code).

Usage:
  • Name: SortColumnID
  • Format: "[uint]".
Where:
  • [uint] is any unsigned integer value.

Member Function Documentation

String CEGUI::MultiColumnListProperties::SortColumnID::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::SortColumnID::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::SortDirection Class Reference

CEGUI::MultiColumnListProperties::SortDirection

CEGUI::MultiColumnListProperties::SortDirection Class Reference

Property to access the sort direction setting of the list. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::SortDirection:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::SortDirection:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the sort direction setting of the list.

Usage:
  • Name: SortDirection
  • Format: "[text]"
Where [Text] is one of:
  • "Ascending"
  • "Descending"
  • "None"

Member Function Documentation

String CEGUI::MultiColumnListProperties::SortDirection::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::SortDirection::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderProperties::SortDirection Class Reference

CEGUI::ListHeaderProperties::SortDirection

CEGUI::ListHeaderProperties::SortDirection Class Reference

Property to access the sort direction setting of the list header. More...

Inheritance diagram for CEGUI::ListHeaderProperties::SortDirection:

[legend]
Collaboration diagram for CEGUI::ListHeaderProperties::SortDirection:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the sort direction setting of the list header.

Usage:
  • Name: SortDirection
  • Format: "[text]"
Where [Text] is one of:
  • "Ascending"
  • "Descending"
  • "None"

Member Function Documentation

String CEGUI::ListHeaderProperties::SortDirection::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderProperties::SortDirection::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderSegmentProperties::SortDirection Class Reference

CEGUI::ListHeaderSegmentProperties::SortDirection

CEGUI::ListHeaderSegmentProperties::SortDirection Class Reference

Property to access the sort direction setting of the header segment. More...

Inheritance diagram for CEGUI::ListHeaderSegmentProperties::SortDirection:

[legend]
Collaboration diagram for CEGUI::ListHeaderSegmentProperties::SortDirection:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the sort direction setting of the header segment.

Usage:
  • Name: SortDirection
  • Format: "[text]"
Where [Text] is one of:
  • "Ascending"
  • "Descending"
  • "None"

Member Function Documentation

String CEGUI::ListHeaderSegmentProperties::SortDirection::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderSegmentProperties::SortDirection::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::SortList Class Reference

CEGUI::ComboboxProperties::SortList

CEGUI::ComboboxProperties::SortList Class Reference

Property to access the sort setting of the list box. More...

Inheritance diagram for CEGUI::ComboboxProperties::SortList:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::SortList:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the sort setting of the list box.

Usage:
  • Name: SortList
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the list items should be sorted.
  • "False" to indicate the list items should not be sorted.

Member Function Documentation

String CEGUI::ComboboxProperties::SortList::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::SortList::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderProperties::SortSettingEnabled Class Reference

CEGUI::ListHeaderProperties::SortSettingEnabled

CEGUI::ListHeaderProperties::SortSettingEnabled Class Reference

Property to access the setting for user modification of the sort column & direction. More...

Inheritance diagram for CEGUI::ListHeaderProperties::SortSettingEnabled:

[legend]
Collaboration diagram for CEGUI::ListHeaderProperties::SortSettingEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for user modification of the sort column & direction.

Usage:
  • Name: SortSettingEnabled
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the user may modify the sort column and direction by clicking the header segments.
  • "False" to indicate the user may not modify the sort column or direction.

Member Function Documentation

String CEGUI::ListHeaderProperties::SortSettingEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ListHeaderProperties::SortSettingEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties::SortSettingEnabled Class Reference

CEGUI::MultiColumnListProperties::SortSettingEnabled

CEGUI::MultiColumnListProperties::SortSettingEnabled Class Reference

Property to access the setting for user modification of the sort column & direction. More...

Inheritance diagram for CEGUI::MultiColumnListProperties::SortSettingEnabled:

[legend]
Collaboration diagram for CEGUI::MultiColumnListProperties::SortSettingEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for user modification of the sort column & direction.

Usage:
  • Name: SortSettingEnabled
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the user may modify the sort column and direction by clicking the header segments.
  • "False" to indicate the user may not modify the sort column or direction.

Member Function Documentation

String CEGUI::MultiColumnListProperties::SortSettingEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiColumnListProperties::SortSettingEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Spinner Class Reference

CEGUI::Spinner

CEGUI::Spinner Class Reference

Base class for the Spinner widget. More...

Inheritance diagram for CEGUI::Spinner:

[legend]
Collaboration diagram for CEGUI::Spinner:

[legend]
List of all members.

Public Types

enum | TextInputMode { FloatingPoint, Integer, Hexadecimal, Octal }
Enumerated type specifying possible input and/or display modes for the spinner. More...

Public Member Functions

Spinner (const String &type, const String &name)
Constructor for Spinner objects.
virtual | ~Spinner (void)
Destructor for Spinner objects.
void | initialise (void)
Initialises the Window based object ready for use.
float | getCurrentValue (void) const
Return the current spinner value.
float | getStepSize (void) const
Return the current step value.
float | getMaximumValue (void) const
Return the current maximum limit value for the Spinner.
float | getMinimumValue (void) const
Return the current minimum limit value for the Spinner.
TextInputMode | getTextInputMode (void) const
Return the current text input / display mode setting.
void | setCurrentValue (float value)
Set the current spinner value.
void | setStepSize (float step)
Set the current step value.
void | setMaximumValue (float maxValue)
Set the spinner maximum value.
void | setMinimumValue (float minVaue)
Set the spinner minimum value.
void | setTextInputMode (TextInputMode mode)
Set the spinner input / display mode.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventValueChanged
Event fired when the spinner value changes.
static const String | EventStepChanged
Event fired when the step value changes.
static const String | EventMaximumValueChanged
Event fired when the maximum spinner value changes.
static const String | EventMinimumValueChanged
Event fired when the minimum spinner value changes.
static const String | EventTextInputModeChanged
Event fired when the input/display mode is changed.

Protected Member Functions

void | addSpinnerEvents (void)
Adds events specific to the Spinner base class.
virtual float | getValueFromText (void) const
Returns the numerical representation of the current editbox text.
virtual String | getTextFromValue (void) const
Returns the textual representation of the current spinner value.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual PushButton * | createIncreaseButton (const String &name) const =0
Creates a PushButton based widget that will be used for the increase button component of the Spinner widget.
virtual PushButton * | createDecreaseButton (const String &name) const =0
Creates a PushButton based widget that will be used for the decrease button component of the Spinner widget.
virtual Editbox * | createEditbox (const String &name) const =0
Creates an Editbox based widget that will be used for the text input area of the spinner widget.
virtual void | onFontChanged (WindowEventArgs &e)
Handler called when the window's font is changed.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | onActivated (ActivationEventArgs &e)
Handler called when this window has become the active window.
virtual void | onValueChanged (WindowEventArgs &e)
Method called when the spinner value changes.
virtual void | onStepChanged (WindowEventArgs &e)
Method called when the step value changes.
virtual void | onMaximumValueChanged (WindowEventArgs &e)
Method called when the maximum value setting changes.
virtual void | onMinimumValueChanged (WindowEventArgs &e)
Method called when the minimum value setting changes.
virtual void | onTextInputModeChanged (WindowEventArgs &e)
Method called when the text input/display mode is changed.
bool | handleIncreaseButton (const EventArgs &e)
bool | handleDecreaseButton (const EventArgs &e)
bool | handleEditTextChange (const EventArgs &e)

Protected Attributes

PushButton * d_increaseButton
Pointer to the increase button widget.
PushButton * d_decreaseButton
Pointer to the decrease button widget.
Editbox * d_editbox
Pointer to the editbox widget.
float | d_stepSize
Step size value used y the increase & decrease buttons.
float | d_currentValue
Numerical copy of the text in d_editbox.
float | d_maxValue
Maximum value for spinner.
float | d_minValue
Minimum value for spinner.
TextInputMode d_inputMode
Current text display/input mode.

Static Protected Attributes

static const String | FloatValidator
Validator regex used for floating point mode.
static const String | IntegerValidator
Validator regex used for decimal integer mode.
static const String | HexValidator
Validator regex used for hexadecimal mode.
static const String | OctalValidator
Validator regex used for octal mode.

Detailed Description

Base class for the Spinner widget.

The spinner widget has a text area where numbers may be entered and two buttons which may be used to increase or decrease the value in the text area by a user specified amount.

Member Enumeration Documentation

enum CEGUI::Spinner::TextInputMode

Enumerated type specifying possible input and/or display modes for the spinner.

Enumerator:
FloatingPoint | Floating point decimal.
Integer | Integer decimal.
Hexadecimal | Hexadecimal.
Octal | Octal.

Member Function Documentation

void CEGUI::Spinner::addSpinnerEvents ( void ) [protected]

Adds events specific to the Spinner base class.

Returns:
Nothing.

virtual PushButton* CEGUI::Spinner::createDecreaseButton ( const String & name ) const [protected, pure virtual]

Creates a PushButton based widget that will be used for the decrease button component of the Spinner widget.

Returns:
Pointer to a valid PushButton based object.

virtual Editbox* CEGUI::Spinner::createEditbox ( const String & name ) const [protected, pure virtual]

Creates an Editbox based widget that will be used for the text input area of the spinner widget.

Returns:
Pointer to a valid Editbox based object.

virtual PushButton* CEGUI::Spinner::createIncreaseButton ( const String & name ) const [protected, pure virtual]

Creates a PushButton based widget that will be used for the increase button component of the Spinner widget.

Returns:
Pointer to a valid PushButton based object.

float CEGUI::Spinner::getCurrentValue ( void ) const

Return the current spinner value.

Returns:
current float value of the Spinner.

float CEGUI::Spinner::getMaximumValue ( void ) const

Return the current maximum limit value for the Spinner.

Returns:
Maximum value that is allowed for the spinner.

float CEGUI::Spinner::getMinimumValue ( void ) const

Return the current minimum limit value for the Spinner.

Returns:
Minimum value that is allowed for the spinner.

float CEGUI::Spinner::getStepSize ( void ) const

Return the current step value.

Returns:
float step value. This is the value added to the spinner vaue when the up / down buttons are clicked.

String CEGUI::Spinner::getTextFromValue ( void ) const [protected, virtual]

Returns the textual representation of the current spinner value.

Returns:
String object that is equivalent to the the numerical value of the spinner.

Spinner::TextInputMode CEGUI::Spinner::getTextInputMode ( void ) const

Return the current text input / display mode setting.

Returns:
One of the TextInputMode enumerated values indicating the current text input and display mode.

float CEGUI::Spinner::getValueFromText ( void ) const [protected, virtual]

Returns the numerical representation of the current editbox text.

Returns:
float value that is the numerical equivalent of the editbox text.
Exceptions:
InvalidRequestException thrown if the text can not be converted.

void CEGUI::Spinner::initialise ( void ) [virtual]

Initialises the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

void CEGUI::Spinner::onActivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has become the active window.

Parameters:
e ActivationEventArgs class whose 'otherWindow' field is set to the window that previously was active, or NULL for none.

Reimplemented from CEGUI::Window.

void CEGUI::Spinner::onFontChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's font is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Spinner::onMaximumValueChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the maximum value setting changes.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::Spinner::onMinimumValueChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the minimum value setting changes.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::Spinner::onStepChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the step value changes.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::Spinner::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Spinner::onTextInputModeChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the text input/display mode is changed.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::Spinner::onValueChanged ( WindowEventArgs & e ) [protected, virtual]

Method called when the spinner value changes.

Parameters:
e WindowEventArgs object containing any relevant data.
Returns:
Nothing.

void CEGUI::Spinner::setCurrentValue ( float value )

Set the current spinner value.

Parameters:
value value to be assigned to the Spinner.
Returns:
Nothing.

void CEGUI::Spinner::setMaximumValue ( float maxValue )

Set the spinner maximum value.

Parameters:
maxValue The maximum value to be allowed by the spinner.
Returns:
Nothing.

void CEGUI::Spinner::setMinimumValue ( float minVaue )

Set the spinner minimum value.

Parameters:
minVaue The minimum value to be allowed by the spinner.
Returns:
Nothing.

void CEGUI::Spinner::setStepSize ( float step )

Set the current step value.

Parameters:
step The value added to be the spinner value when the up / down buttons are clicked.
Returns:
Nothing.

void CEGUI::Spinner::setTextInputMode ( TextInputMode mode )

Set the spinner input / display mode.

Parameters:
mode One of the TextInputMode enumerated values indicating the text input / display mode to be used by the spinner.
Returns:
Nothing.

virtual bool CEGUI::Spinner::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StateImagery Class Reference

CEGUI::StateImagery

CEGUI::StateImagery Class Reference

Class the encapsulates imagery for a given widget state. More...

Collaboration diagram for CEGUI::StateImagery:

[legend]
List of all members.

Public Member Functions

StateImagery ()
Constructor.
StateImagery (const String &name)
Constructor.
void | render (Window &srcWindow, const ColourRect *modcols=0, const Rect *clipper=0) const
Render imagery for this state.
void | render (Window &srcWindow, const Rect &baseRect, const ColourRect *modcols=0, const Rect *clipper=0) const
Render imagery for this state.
void | addLayer (const LayerSpecification &layer)
Add an imagery LayerSpecification to this state.
void | clearLayers ()
Removed all LayerSpecifications from this state.
const String & | getName () const
Return the name of this state.
bool | isClippedToDisplay () const
Return whether this state imagery should be clipped to the display rather than the target window.
void | setClippedToDisplay (bool setting)
Set whether this state imagery should be clipped to the display rather than the target window.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this StateImagery to out_stream.

Detailed Description

Class the encapsulates imagery for a given widget state.

Constructor & Destructor Documentation

CEGUI::StateImagery::StateImagery ( const String & name )

Constructor.

Parameters:
name Name of the state

Member Function Documentation

void CEGUI::StateImagery::addLayer ( const LayerSpecification & layer )

Add an imagery LayerSpecification to this state.

Parameters:
layer LayerSpecification to be added to this state (will be copied)
Returns:
Nothing.

void CEGUI::StateImagery::clearLayers ( )

Removed all LayerSpecifications from this state.

Returns:
Nothing.

const String & CEGUI::StateImagery::getName ( ) const

Return the name of this state.

Returns:
String object holding the name of the StateImagery object.

bool CEGUI::StateImagery::isClippedToDisplay ( ) const

Return whether this state imagery should be clipped to the display rather than the target window.

Clipping to the display effectively implies that the imagery should be rendered unclipped.

/return

  • true if the imagery will be clipped to the display area.
  • false if the imagery will be clipped to the target window area.

void CEGUI::StateImagery::render | ( | Window & | srcWindow,
 |  | const Rect & | baseRect,
 |  | const ColourRect * | modcols = 0,
 |  | const Rect * | clipper = 0
 | ) | const

Render imagery for this state.

Parameters:
srcWindow | Window to use when convering BaseDim values to pixels.
baseRect | Rect to use when convering BaseDim values to pixels.
Returns:
Nothing.

void CEGUI::StateImagery::render | ( | Window & | srcWindow,
 |  | const ColourRect * | modcols = 0,
 |  | const Rect * | clipper = 0
 | ) | const

Render imagery for this state.

Parameters:
srcWindow Window to use when convering BaseDim values to pixels.
Returns:
Nothing.

void CEGUI::StateImagery::setClippedToDisplay ( bool setting )

Set whether this state imagery should be clipped to the display rather than the target window.

Clipping to the display effectively implies that the imagery should be rendered unclipped.

Parameters:
setting
  • true if the imagery should be clipped to the display area.
  • false if the imagery should be clipped to the target window area.
Returns:
Nothing.

void CEGUI::StateImagery::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this StateImagery to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Static Class Reference

CEGUI::Static

CEGUI::Static Class Reference

Base class for static widgets. More...

Inheritance diagram for CEGUI::Static:

[legend]
Collaboration diagram for CEGUI::Static:

[legend]
List of all members.

Public Member Functions

bool | isFrameEnabled (void) const
Return whether the frame for this static widget is enabled or disabled.
bool | isBackgroundEnabled (void) const
Return whether the background for this static widget is enabled to disabled.
ColourRect | getFrameColours (void) const
Return a ColourRect object containing the colours used when rendering this widget.
ColourRect | getBackgroundColours (void) const
Return a ColourRect object containing the colours used when rendering this widget.
virtual Rect | getUnclippedInnerRect (void) const
Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.
const Image * | getImageForFrameLocation (FrameLocation location) const
Return the Image being used for the specified location of the frame.
const Image * | getBackgroundImage (void) const
Return the Image currently set as the background image for the widget.
void | setFrameEnabled (bool setting)
Enable or disable rendering of the frame for this static widget.
void | setFrameImages (const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom)
specify the Image objects to use for each part of the frame. A NULL may be used to omit any part.
void | setFrameColours (const ColourRect &colours)
Sets the colours to be applied when rendering the frame.
void | setFrameColours (const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour)
Sets the colours to be applied when rendering the frame.
void | setFrameColours (const colour &col)
Sets the colour to be applied when rendering the frame.
void | setBackgroundEnabled (bool setting)
Enable or disable rendering of the background for this static widget.
void | setBackgroundImage (const Image *image)
Set the image to use as the background for the static widget.
void | setBackgroundImage (const String &imageset, const String &image)
Set the image to use as the background for the static widget.
void | setBackgroundColours (const ColourRect &colours)
Sets the colours to be applied when rendering the background.
void | setBackgroundColours (const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour)
Sets the colours to be applied when rendering the background.
void | setBackgroundColours (const colour &col)
Sets the colour to be applied when rendering the background.
void | setImageForFrameLocation (FrameLocation location, const Image *image)
Set the Image to use for the specified location of the frame.
Static (const String &type, const String &name)
Constructor for static widget base class.
virtual | ~Static (void)
Destructor for static widget base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.

Protected Member Functions

virtual void | populateRenderCache ()
Update the rendering cache.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onAlphaChanged (WindowEventArgs &e)
Handler called when the window's alpha blend value is changed.
void | updateRenderableFrameColours (void)
update the internal RenderableFrame with currently set colours and alpha settings.
colour | calculateModulatedAlphaColour (const colour &col, float alpha) const
return ARGB colour value col, with its alpha component modulated by the value specified in float alpha.
virtual void | onStaticFrameChanged (WindowEventArgs &e)
This is used internally to indicate that the frame for the static widget has been modified, and as such derived classes may need to adjust their layouts or reconfigure their rendering somehow.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

bool | d_frameEnabled
True when the frame is enabled.
ColourRect d_frameCols
Used to store frame colours.
RenderableFrame d_frame
Frame object used for rendering a frame for the static element.
bool | d_backgroundEnabled
true when the background is enabled.
ColourRect d_backgroundCols
Colours to use when drawing background.
const Image * | d_background
Image to use for widget background.
float | d_left_width
Width of the left edge image for the current frame.
float | d_right_width
Width of the right edge image for the current frame.
float | d_top_height
Height of the top edge image for the current frame.
float | d_bottom_height
Height of the bottom edge image for the current frame.

Detailed Description

Base class for static widgets.

Member Function Documentation

ColourRect CEGUI::Static::getBackgroundColours ( void ) const [inline]

Return a ColourRect object containing the colours used when rendering this widget.

Returns:
ColourRect object initialised with the colours used when rendering the background for this widget.

const Image * CEGUI::Static::getBackgroundImage ( void ) const

Return the Image currently set as the background image for the widget.

Returns:
Pointer to the Image object currently set as the background for this StaticWidget. May return NULL if no Image is currently set.

ColourRect CEGUI::Static::getFrameColours ( void ) const [inline]

Return a ColourRect object containing the colours used when rendering this widget.

Returns:
ColourRect object initialised with the colours used when rendering the frame for this widget.

const Image * CEGUI::Static::getImageForFrameLocation ( FrameLocation location ) const

Return the Image being used for the specified location of the frame.

Parameters:
location One of the FrameLocation enumerated values specifying the image to be returned.
Returns:
Pointer to the Image object currently set for the frame location specified in location. May return NULL if no Image is set for the requested position.

Rect CEGUI::Static::getUnclippedInnerRect ( void ) const [virtual]

Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.

Returns:
Rect object that describes, in unclipped screen pixel co-ordinates, the window object's inner rect area.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::StaticText.

bool CEGUI::Static::isBackgroundEnabled ( void ) const [inline]

Return whether the background for this static widget is enabled to disabled.

Returns:
true if the background is enabled and will be rendered. false if the background is disabled and will not be rendered.

bool CEGUI::Static::isFrameEnabled ( void ) const [inline]

Return whether the frame for this static widget is enabled or disabled.

Returns:
true if the frame is enabled and will be rendered. false is the frame is disabled and will not be rendered.

void CEGUI::Static::onAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's alpha blend value is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::StaticImage.

void CEGUI::Static::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::StaticImage, and CEGUI::StaticText.

virtual void CEGUI::Static::onStaticFrameChanged ( WindowEventArgs & e ) [inline, protected, virtual]

This is used internally to indicate that the frame for the static widget has been modified, and as such derived classes may need to adjust their layouts or reconfigure their rendering somehow.

Note:
This does not currently fire an external event.

Reimplemented in CEGUI::StaticImage.

void CEGUI::Static::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::StaticImage, and CEGUI::StaticText.

void CEGUI::Static::setBackgroundColours ( const colour & col ) [inline]

Sets the colour to be applied when rendering the background.

Parameters:
col colour value to be used when rendering.
Returns:
Nothing.

void CEGUI::Static::setBackgroundColours | ( | const colour & | top_left_colour,
 |  | const colour & | top_right_colour,
 |  | const colour & | bottom_left_colour,
 |  | const colour & | bottom_right_colour
 | ) |

Sets the colours to be applied when rendering the background.

Parameters:
top_left_colour | Colour to be applied to the top-left corner of the background.
top_right_colour | Colour to be applied to the top-right corner of the background.
bottom_left_colour | Colour to be applied to the bottom-left corner of the background.
bottom_right_colour | Colour to be applied to the bottom-right corner of the background.
Returns:
Nothing.

void CEGUI::Static::setBackgroundColours ( const ColourRect & colours )

Sets the colours to be applied when rendering the background.

Parameters:
colours ColourRect object describing the colours to be used.
Returns:
Nothing.

void CEGUI::Static::setBackgroundEnabled ( bool setting )

Enable or disable rendering of the background for this static widget.

Parameters:
setting true to enable rendering of the background. false to disable rendering of the background.

void CEGUI::Static::setBackgroundImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the image to use as the background for the static widget.

Parameters:
imageset | String object specifying the name of the Imageset that holds the required image.
image | Name of the Image on the specified Imageset that is to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if Imageset imageset does not exist in the system or if imageset contains no Image named image.

void CEGUI::Static::setBackgroundImage ( const Image * image )

Set the image to use as the background for the static widget.

Parameters:
image Pointer to the Image object to be rendered. Can be NULL to specify no image is to be rendered.
Returns:
Nothing.

void CEGUI::Static::setFrameColours ( const colour & col ) [inline]

Sets the colour to be applied when rendering the frame.

Parameters:
col colour value to be used when rendering.
Returns:
Nothing.

void CEGUI::Static::setFrameColours | ( | const colour & | top_left_colour,
 |  | const colour & | top_right_colour,
 |  | const colour & | bottom_left_colour,
 |  | const colour & | bottom_right_colour
 | ) |

Sets the colours to be applied when rendering the frame.

Parameters:
top_left_colour | Colour to be applied to the top-left corner of each Image used in the frame.
top_right_colour | Colour to be applied to the top-right corner of each Image used in the frame.
bottom_left_colour | Colour to be applied to the bottom-left corner of each Image used in the frame.
bottom_right_colour | Colour to be applied to the bottom-right corner of each Image used in the frame.
Returns:
Nothing.

void CEGUI::Static::setFrameColours ( const ColourRect & colours )

Sets the colours to be applied when rendering the frame.

Parameters:
colours ColourRect object describing the colours to be used.
Returns:
Nothing.

void CEGUI::Static::setFrameEnabled ( bool setting )

Enable or disable rendering of the frame for this static widget.

Frame imagery can be customised via the setFrameImages method.

Parameters:
setting true to enable rendering of a frame. false to disable rendering of a frame.

void CEGUI::Static::setFrameImages | ( | const Image * | topleft,
 |  | const Image * | topright,
 |  | const Image * | bottomleft,
 |  | const Image * | bottomright,
 |  | const Image * | left,
 |  | const Image * | top,
 |  | const Image * | right,
 |  | const Image * | bottom
 | ) |

specify the Image objects to use for each part of the frame. A NULL may be used to omit any part.

Parameters:
topleft | Pointer to an Image object to render as the top-left corner of the frame. Specify NULL to omit this part of the frame.
topright | Pointer to an Image object to render as the top-right corner of the frame. Specify NULL to omit this part of the frame.
bottomleft | Pointer to an Image object to render as the bottom-left corner of the frame. Specify NULL to omit this part of the frame.
bottomright | Pointer to an Image object to render as the bottom-right corner of the frame. Specify NULL to omit this part of the frame.
left | Pointer to an Image object to render as the left edge of the frame. Specify NULL to omit this part of the frame.
top | Pointer to an Image object to render as the top edge of the frame. Specify NULL to omit this part of the frame.
right | Pointer to an Image object to render as the right edge of the frame. Specify NULL to omit this part of the frame.
bottom | Pointer to an Image object to render as the bottom edge of the frame. Specify NULL to omit this part of the frame.
Returns:
Nothing

void CEGUI::Static::setImageForFrameLocation | ( | FrameLocation | location,
 |  | const Image * | image
 | ) |

Set the Image to use for the specified location of the frame.

Parameters:
location | One of the FrameLocation enumerated values specifying the image to be returned.
image | Pointer to the Image to use for the frame location specified in location. May be NULL to indicate the frame component is not required.
Returns:
Nothing.

virtual bool CEGUI::Static::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Reimplemented in CEGUI::StaticImage, CEGUI::StaticText, and CEGUI::TabPane.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticImage Class Reference

CEGUI::StaticImage

CEGUI::StaticImage Class Reference

Static image widget class. More...

Inheritance diagram for CEGUI::StaticImage:

[legend]
Collaboration diagram for CEGUI::StaticImage:

[legend]
List of all members.

Public Types

enum HorzFormatting {
LeftAligned, RightAligned, HorzCentred, HorzStretched,
HorzTiled
}
Enumeration of horizontal formatting options for static image widgets. More...
enum VertFormatting {
TopAligned, BottomAligned, VertCentred, VertStretched,
VertTiled
}
Enumeration of vertical formatting options for a static image widgets. More...

Public Member Functions

StaticImage (const String &type, const String &name)
Constructor for StaticImage widgets.
virtual | ~StaticImage (void)
Destructor for StaticImage widgets.
const Image * | getImage (void) const
Return a pointer to the current image displayed by this static image widget.
ColourRect | getImageColours (void) const
Return a ColourRect object containing the colours used when rendering this widget.
HorzFormatting | getHorizontalFormatting (void) const
Return the current horizontal formatting option set for this widget.
VertFormatting | getVerticalFormatting (void) const
Return the current vertical formatting option set for this widget.
void | setImage (const Image *image)
Set the Image object to be drawn by this widget.
void | setImage (const String &imageset, const String &image)
Set the Image object to be drawn by this widget.
void | setImageColours (const ColourRect &colours)
Sets the colours to be applied when rendering the image.
void | setImageColours (const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour)
Sets the colours to be applied when rendering the image.
void | setImageColours (const colour &col)
Sets the colour to be applied when rendering the image.
void | setFormatting (HorzFormatting h_fmt, VertFormatting v_fmt)
Set the formatting required for the image.
void | setVerticalFormatting (VertFormatting v_fmt)
Set the formatting required for the image.
void | setHorizontalFormatting (HorzFormatting h_fmt)
Set the formatting required for the image.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.

Protected Member Functions

virtual void | populateRenderCache ()
Update the rendering cache.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onAlphaChanged (WindowEventArgs &e)
Handler called when the window's alpha blend value is changed.
virtual void | onStaticFrameChanged (WindowEventArgs &e)
This is used internally to indicate that the frame for the static widget has been modified, and as such derived classes may need to adjust their layouts or reconfigure their rendering somehow.
void | updateRenderableImageColours (void)
update the internal RenderableImage with currently set colours and alpha settings.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

RenderableImage d_image
RenderableImage that does most of the work for us.
ColourRect d_imageCols
Colours to use for the image.

Detailed Description

Static image widget class.

This base class performs it's own rendering. There is no need to override this widget to perform rendering of static images.

Member Enumeration Documentation

enum CEGUI::StaticImage::HorzFormatting

Enumeration of horizontal formatting options for static image widgets.

Enumerator:
LeftAligned | Image will be rendered at it's natural width, with it's left edge aligned with the left edge of the widget.
RightAligned | Image will be rendered at it's natural width, with it's right edge aligned with the right edge of the widget.
HorzCentred | Image will be rendered at it's natural width, horizontally centred within the widget.
HorzStretched | Image will be horizontally stretched to cover the entire width of the widget.
HorzTiled | Image will be tiled horizontally across the width of the widget. The rightmost tile may be clipped.

enum CEGUI::StaticImage::VertFormatting

Enumeration of vertical formatting options for a static image widgets.

Enumerator:
TopAligned | Image will be rendered at it's natural height, with it's top edge aligned with the top edge of the widget.
BottomAligned | Image will be rendered at it's natural height, with it's bottom edge aligned with the bottom edge of the widget.
VertCentred | Image will be rendered at it's natural height, vertically centred within the widget.
VertStretched | Image will be vertically stretched to cover the entire height of the widget.
VertTiled | Image will be tiled vertically down the height of the widget. The bottommost tile may be clipped.

Member Function Documentation

HorzFormatting CEGUI::StaticImage::getHorizontalFormatting ( void ) const [inline]

Return the current horizontal formatting option set for this widget.

Returns:
One of the StaticImage::HorzFormatting enumerated values specifying the horizontal formatting currently set.

const Image* CEGUI::StaticImage::getImage ( void ) const [inline]

Return a pointer to the current image displayed by this static image widget.

Returns:
Pointer to the Image object that is used to render this widget, or NULL for none.

ColourRect CEGUI::StaticImage::getImageColours ( void ) const [inline]

Return a ColourRect object containing the colours used when rendering this widget.

Returns:
ColourRect object initialised with the colours used when rendering the image for this widget.

VertFormatting CEGUI::StaticImage::getVerticalFormatting ( void ) const [inline]

Return the current vertical formatting option set for this widget.

Returns:
One of the StaticImage::VertFormatting enumerated values specifying the vertical formatting currently set.

void CEGUI::StaticImage::onAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's alpha blend value is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Static.

void CEGUI::StaticImage::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Static.

void CEGUI::StaticImage::onStaticFrameChanged ( WindowEventArgs & e ) [protected, virtual]

This is used internally to indicate that the frame for the static widget has been modified, and as such derived classes may need to adjust their layouts or reconfigure their rendering somehow.

Note:
This does not currently fire an external event.

Reimplemented from CEGUI::Static.

void CEGUI::StaticImage::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Static.

void CEGUI::StaticImage::setFormatting | ( | HorzFormatting | h_fmt,
 |  | VertFormatting | v_fmt
 | ) |

Set the formatting required for the image.

Parameters:
h_fmt | One of the HorzFormatting enumerated values specifying the formatting required.
v_fmt | One of the VertFormatting enumerated values specifying the formatting required.
Returns:
Nothing

void CEGUI::StaticImage::setHorizontalFormatting ( HorzFormatting h_fmt )

Set the formatting required for the image.

Parameters:
h_fmt One of the HorzFormatting enumerated values specifying the formatting required.
Returns:
Nothing

void CEGUI::StaticImage::setImage | ( | const String & | imageset,
 |  | const String & | image
 | ) |

Set the Image object to be drawn by this widget.

Parameters:
imageset | String object specifying the name of the Imageset that holds the required image.
image | Name of the Image on the specified Imageset that is to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if Imageset imageset does not exist in the system or if imageset contains no Image named image.

void CEGUI::StaticImage::setImage ( const Image * image )

Set the Image object to be drawn by this widget.

Parameters:
image Pointer to the Image object to be rendered. Can be NULL to specify no image is to be rendered.
Returns:
Nothing.

void CEGUI::StaticImage::setImageColours ( const colour & col ) [inline]

Sets the colour to be applied when rendering the image.

Parameters:
col colour value to be used when rendering.
Returns:
Nothing.

void CEGUI::StaticImage::setImageColours | ( | const colour & | top_left_colour,
 |  | const colour & | top_right_colour,
 |  | const colour & | bottom_left_colour,
 |  | const colour & | bottom_right_colour
 | ) |

Sets the colours to be applied when rendering the image.

Parameters:
top_left_colour | Colour to be applied to the top-left corner of each Image used in the image.
top_right_colour | Colour to be applied to the top-right corner of each Image used in the image.
bottom_left_colour | Colour to be applied to the bottom-left corner of each Image used in the image.
bottom_right_colour | Colour to be applied to the bottom-right corner of each Image used in the image.
Returns:
Nothing.

void CEGUI::StaticImage::setImageColours ( const ColourRect & colours )

Sets the colours to be applied when rendering the image.

Parameters:
colours ColourRect object describing the colours to be used.
Returns:
Nothing.

void CEGUI::StaticImage::setVerticalFormatting ( VertFormatting v_fmt )

Set the formatting required for the image.

Parameters:
v_fmt One of the VertFormatting enumerated values specifying the formatting required.
Returns:
Nothing

virtual bool CEGUI::StaticImage::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Static.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticText Class Reference

CEGUI::StaticText

CEGUI::StaticText Class Reference

Base class for a static text widget. More...

Inheritance diagram for CEGUI::StaticText:

[legend]
Collaboration diagram for CEGUI::StaticText:

[legend]
List of all members.

Public Types

enum HorzFormatting {
LeftAligned, RightAligned, HorzCentred, HorzJustified,
WordWrapLeftAligned, WordWrapRightAligned, WordWrapCentred, WordWrapJustified
}
Enumeration of horizontal formatting options for static text widgets. More...
enum | VertFormatting { TopAligned, BottomAligned, VertCentred }
Enumeration of vertical formatting options for a static text widgets. More...

Public Member Functions

StaticText (const String &type, const String &name)
Constructor for static text widgets.
virtual | ~StaticText (void)
Destructor for static text widgets.
ColourRect | getTextColours (void) const
Return a ColourRect object containing the colours used when rendering this widget.
HorzFormatting | getHorizontalFormatting (void) const
Return the current horizontal formatting option set for this widget.
VertFormatting | getVerticalFormatting (void) const
Return the current vertical formatting option set for this widget.
bool | isVerticalScrollbarEnabled (void) const
Return whether the vertical scroll bar is set to be shown if needed.
bool | isHorizontalScrollbarEnabled (void) const
Return whether the horizontal scroll bar is set to be shown if needed.
virtual Rect | getUnclippedInnerRect (void) const
Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | setTextColours (const ColourRect &colours)
Sets the colours to be applied when rendering the text.
void | setTextColours (const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour)
Sets the colours to be applied when rendering the text.
void | setTextColours (const colour &col)
Sets the colour to be applied when rendering the text.
void | setFormatting (HorzFormatting h_fmt, VertFormatting v_fmt)
Set the formatting required for the text.
void | setVerticalFormatting (VertFormatting v_fmt)
Set the formatting required for the text.
void | setHorizontalFormatting (HorzFormatting h_fmt)
Set the formatting required for the text.
void | setVerticalScrollbarEnabled (bool setting)
Set whether the vertical scroll bar will be shown if needed.
void | setHorizontalScrollbarEnabled (bool setting)
Set whether the horizontal scroll bar will be shown if needed.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.

Protected Member Functions

virtual void | populateRenderCache ()
Update the rendering cache.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onFontChanged (WindowEventArgs &e)
Handler called when the window's font is changed.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.
virtual Rect | getTextRenderArea (void) const
Return a Rect object describing, in un-clipped pixels, the window relative area that the text should be rendered in to.
void | configureScrollbars (void)
display required integrated scroll bars according to current state of the edit box and update their values.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual Scrollbar * | createVertScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as vertical scroll bar
virtual Scrollbar * | createHorzScrollbar (const String &name) const =0
create and return a pointer to a Scrollbar widget for use as horizontal scroll bar
bool | handleScrollbarChange (const EventArgs &e)

Protected Attributes

HorzFormatting d_horzFormatting
Horizontal formatting to be applied to the text.
VertFormatting d_vertFormatting
Vertical formatting to be applied to the text.
ColourRect d_textCols
Colours used when rendering the text.
Scrollbar * d_vertScrollbar
Widget used as vertical scrollbar;.
Scrollbar * d_horzScrollbar
Widget used as horizontal scrollbar;.
bool | d_enableVertScrollbar
true if vertical scroll bar is enabled.
bool | d_enableHorzScrollbar
true if horizontal scroll bar is enabled.

Detailed Description

Base class for a static text widget.

Member Enumeration Documentation

enum CEGUI::StaticText::HorzFormatting

Enumeration of horizontal formatting options for static text widgets.

Enumerator:
LeftAligned | Text is output as a single line of text with the first character aligned with the left edge of the widget.
RightAligned | Text is output as a single line of text with the last character aligned with the right edge of the widget.
HorzCentred | Text is output as a single line of text horizontally centred within the widget.
HorzJustified | Text is output as a single line of text with the first and last characters aligned with the edges of the widget.
WordWrapLeftAligned | Text is output as multiple word-wrapped lines of text with the first character of each line aligned with the left edge of the widget.
WordWrapRightAligned | Text is output as multiple word-wrapped lines of text with the last character of each line aligned with the right edge of the widget.
WordWrapCentred | Text is output as multiple word-wrapped lines of text with each line horizontally centered within the widget.
WordWrapJustified | Text is output as multiple word-wrapped lines of text with the first and last characters of each line aligned with the edges of the widget.

enum CEGUI::StaticText::VertFormatting

Enumeration of vertical formatting options for a static text widgets.

Enumerator:
TopAligned | Text is output with the top of first line of text aligned with the top edge of the widget.
BottomAligned | Text is output with the bottom of last line of text aligned with the bottom edge of the widget.
VertCentred | Text is output vertically centred within the widget.

Member Function Documentation

virtual Scrollbar* CEGUI::StaticText::createHorzScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as horizontal scroll bar

Parameters:
name String containing the name to be given to the created component.
Returns:
Pointer to a Scrollbar to be used for scrolling horizontally.

virtual Scrollbar* CEGUI::StaticText::createVertScrollbar ( const String & name ) const [protected, pure virtual]

create and return a pointer to a Scrollbar widget for use as vertical scroll bar

Parameters:
name String containing the name to be given to the created component.
Returns:
Pointer to a Scrollbar to be used for scrolling vertically.

HorzFormatting CEGUI::StaticText::getHorizontalFormatting ( void ) const [inline]

Return the current horizontal formatting option set for this widget.

Returns:
One of the StaticText::HorzFormatting enumerated values specifying the horizontal formatting currently set.

ColourRect CEGUI::StaticText::getTextColours ( void ) const [inline]

Return a ColourRect object containing the colours used when rendering this widget.

Returns:
ColourRect object initialised with the colours used when rendering the text for this widget.

Rect CEGUI::StaticText::getTextRenderArea ( void ) const [protected, virtual]

Return a Rect object describing, in un-clipped pixels, the window relative area that the text should be rendered in to.

Returns:
Rect object describing the area of the Window to be used for rendering text.

Rect CEGUI::StaticText::getUnclippedInnerRect ( void ) const [virtual]

Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.

Returns:
Rect object that describes, in unclipped screen pixel co-ordinates, the window object's inner rect area.

Reimplemented from CEGUI::Static.

VertFormatting CEGUI::StaticText::getVerticalFormatting ( void ) const [inline]

Return the current vertical formatting option set for this widget.

Returns:
One of the StaticText::VertFormatting enumerated values specifying the vertical formatting currently set.

void CEGUI::StaticText::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

bool CEGUI::StaticText::isHorizontalScrollbarEnabled ( void ) const

Return whether the horizontal scroll bar is set to be shown if needed.

Returns:
  • true if the horizontal scroll bar will be shown if needed (non-word wrapped, left or right aligned formatting only).
  • false if the horizontal scroll bar will never be shown (default behaviour).

bool CEGUI::StaticText::isVerticalScrollbarEnabled ( void ) const

Return whether the vertical scroll bar is set to be shown if needed.

Returns:
  • true if the vertical scroll bar will be shown if needed (top or bottom aligned formatting only).
  • false if the vertical scroll bar will never be shown (default behaviour).

void CEGUI::StaticText::onFontChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's font is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::StaticText::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::StaticText::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Static.

void CEGUI::StaticText::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::StaticText::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Static.

void CEGUI::StaticText::setFormatting | ( | HorzFormatting | h_fmt,
 |  | VertFormatting | v_fmt
 | ) |

Set the formatting required for the text.

Parameters:
h_fmt | One of the HorzFormatting enumerated values specifying the formatting required.
v_fmt | One of the VertFormatting enumerated values specifying the formatting required.
Returns:
Nothing

void CEGUI::StaticText::setHorizontalFormatting ( HorzFormatting h_fmt )

Set the formatting required for the text.

Parameters:
h_fmt One of the HorzFormatting enumerated values specifying the formatting required.
Returns:
Nothing

void CEGUI::StaticText::setHorizontalScrollbarEnabled ( bool setting )

Set whether the horizontal scroll bar will be shown if needed.

Parameters:
setting
  • true if the horizontal scroll bar should be shown if needed (non-word wrapped, left or right aligned formatting only).
  • false if the horizontal scroll bar should never be shown (default behaviour).

void CEGUI::StaticText::setTextColours ( const colour & col ) [inline]

Sets the colour to be applied when rendering the text.

Parameters:
col colour value to be used when rendering.
Returns:
Nothing.

void CEGUI::StaticText::setTextColours | ( | const colour & | top_left_colour,
 |  | const colour & | top_right_colour,
 |  | const colour & | bottom_left_colour,
 |  | const colour & | bottom_right_colour
 | ) |

Sets the colours to be applied when rendering the text.

Parameters:
top_left_colour | Colour to be applied to the top-left corner of each text glyph rendered.
top_right_colour | Colour to be applied to the top-right corner of each text glyph rendered.
bottom_left_colour | Colour to be applied to the bottom-left corner of each text glyph rendered.
bottom_right_colour | Colour to be applied to the bottom-right corner of each text glyph rendered.
Returns:
Nothing.

void CEGUI::StaticText::setTextColours ( const ColourRect & colours )

Sets the colours to be applied when rendering the text.

Parameters:
colours ColourRect object describing the colours to be used for each text glyph rendered.
Returns:
Nothing.

void CEGUI::StaticText::setVerticalFormatting ( VertFormatting v_fmt )

Set the formatting required for the text.

Parameters:
v_fmt One of the VertFormatting enumerated values specifying the formatting required.
Returns:
Nothing

void CEGUI::StaticText::setVerticalScrollbarEnabled ( bool setting )

Set whether the vertical scroll bar will be shown if needed.

Parameters:
setting
  • true if the vertical scroll bar should be shown if needed (top or bottom aligned formatting only).
  • false if the vertical scroll bar should never be shown (default behaviour).

virtual bool CEGUI::StaticText::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Static.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SpinnerProperties::StepSize Class Reference

CEGUI::SpinnerProperties::StepSize

CEGUI::SpinnerProperties::StepSize Class Reference

Property to access the step size of the spinner. More...

Inheritance diagram for CEGUI::SpinnerProperties::StepSize:

[legend]
Collaboration diagram for CEGUI::SpinnerProperties::StepSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the step size of the spinner.

Usage:
  • Name: StepSize
  • Format: "[float]".
Where:
  • [float] represents the current value of the Spinner widget.

Member Function Documentation

String CEGUI::SpinnerProperties::StepSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SpinnerProperties::StepSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollbarProperties::StepSize Class Reference

CEGUI::ScrollbarProperties::StepSize

CEGUI::ScrollbarProperties::StepSize Class Reference

Property to access the step size for the Scrollbar. More...

Inheritance diagram for CEGUI::ScrollbarProperties::StepSize:

[legend]
Collaboration diagram for CEGUI::ScrollbarProperties::StepSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the step size for the Scrollbar.

Usage:
  • Name: StepSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the increase/decrease button step (as defined by the client code).

Member Function Documentation

String CEGUI::ScrollbarProperties::StepSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollbarProperties::StepSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ProgressBarProperties::StepSize Class Reference

CEGUI::ProgressBarProperties::StepSize

CEGUI::ProgressBarProperties::StepSize Class Reference

Property to access the step size setting for the progress bar. More...

Inheritance diagram for CEGUI::ProgressBarProperties::StepSize:

[legend]
Collaboration diagram for CEGUI::ProgressBarProperties::StepSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the step size setting for the progress bar.

Usage:
  • Name: StepSize
  • Format: "[float]".
Where:
  • [float] is the size of the invisible sizing border in screen pixels.

Member Function Documentation

String CEGUI::ProgressBarProperties::StepSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ProgressBarProperties::StepSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::String Class Reference

CEGUI::String

CEGUI::String Class Reference

String class used within the GUI system. More...

List of all members.

Public Types

typedef utf32 | value_type
Basic 'code point' type used for String (utf32).
typedef size_t | size_type
Unsigned type used for size values and indices.
typedef ptrdiff_t | difference_type
Signed type used for differences.
typedef utf32 & | reference
Type used for utf32 code point references.
typedef const utf32 & | const_reference
Type used for constant utf32 code point references.
typedef utf32 * | pointer
Type used for utf32 code point pointers.
typedef const utf32 * | const_pointer
Type used for constant utf32 code point pointers.
typedef std::reverse_iterator<
const_iterator > 		const_reverse_iterator
Constant reverse iterator class for String objects.
typedef std::reverse_iterator<
iterator > 		reverse_iterator
Reverse iterator class for String objects.

Public Member Functions

String (void)
Constructs an empty string.
~String (void)
Destructor for String objects.
String (const String &str)
Copy constructor - Creates a new string with the same value as str.
String (const String &str, size_type str_idx, size_type str_num=npos)
Constructs a new string initialised with code points from another String object.
String (const std::string &std_str)
Constructs a new string and initialises it using the std::string std_str.
String (const std::string &std_str, size_type str_idx, size_type str_num=npos)
Constructs a new string initialised with characters from the given std::string object.
String (const utf8 *utf8_str)
Constructs a new String object and initialise it using the provided utf8 encoded string buffer.
String (const utf8 *utf8_str, size_type chars_len)
Constructs a new String object and initialise it using the provided utf8 encoded string buffer.
String (size_type num, utf32 code_point)
Constructs a new String that is initialised with the specified code point.
String (const_iterator iter_beg, const_iterator iter_end)
Construct a new string object and initialise it with code-points from the range [beg, end).
String (const char *cstr)
Constructs a new String object and initialise it using the provided c-string.
String (const char *chars, size_type chars_len)
Constructs a new String object and initialise it using characters from the provided char array.
size_type | size (void) const
Returns the size of the String in code points.
size_type | length (void) const
Returns the size of the String in code points.
bool | empty (void) const
Returns true if the String is empty.
size_type | capacity (void) const
Return the number of code points that the String could hold before a re-allocation would be required.
void | reserve (size_type num=0)
Specifies the amount of reserve capacity to allocate.
int | compare (const String &str) const
Compares this String with the String 'str'.
int | compare (size_type idx, size_type len, const String &str, size_type str_idx=0, size_type str_len=npos) const
Compares code points from this String with code points from the String 'str'.
int | compare (const std::string &std_str) const
Compares this String with the std::string 'std_str'.
int | compare (size_type idx, size_type len, const std::string &std_str, size_type str_idx=0, size_type str_len=npos) const
Compares code points from this String with code points from the std::string 'std_str'.
int | compare (const utf8 *utf8_str) const
Compares this String with the null-terminated utf8 encoded 'utf8_str'.
int | compare (size_type idx, size_type len, const utf8 *utf8_str) const
Compares code points from this String with the null-terminated utf8 encoded 'utf8_str'.
int | compare (size_type idx, size_type len, const utf8 *utf8_str, size_type str_cplen) const
Compares code points from this String with the utf8 encoded data in buffer 'utf8_str'.
int | compare (const char *cstr) const
Compares this String with the given c-string.
int | compare (size_type idx, size_type len, const char *cstr) const
Compares code points from this String with the given c-string.
int | compare (size_type idx, size_type len, const char *chars, size_type chars_len) const
Compares code points from this String with chars in the given char array.
reference | operator[] (size_type idx)
Returns the code point at the given index.
value_type | operator[] (size_type idx) const
Returns the code point at the given index.
reference | at (size_type idx)
Returns the code point at the given index.
const_reference | at (size_type idx) const
Returns the code point at the given index.
const char * | c_str (void) const
Returns contents of the String as a null terminated string of utf8 encoded data.
const utf8 * | data (void) const
Returns contents of the String as utf8 encoded data.
size_type | copy (utf8 *buf, size_type len=npos, size_type idx=0) const
Copies an area of the String into the provided buffer as encoded utf8 data.
size_type | utf8_stream_len (size_type num=npos, size_type idx=0)
Return the number of utf8 code units required to hold an area of the String when encoded as utf8 data.
String & | operator= (const String &str)
Assign the value of String str to this String.
String & | assign (const String &str, size_type str_idx=0, size_type str_num=npos)
Assign a sub-string of String str to this String.
String & | operator= (const std::string &std_str)
Assign the value of std::string std_str to this String.
String & | assign (const std::string &std_str, size_type str_idx=0, size_type str_num=npos)
Assign a sub-string of std::string std_str to this String.
String & | operator= (const utf8 *utf8_str)
Assign to this String the string value represented by the given null-terminated utf8 encoded data.
String & | assign (const utf8 *utf8_str)
Assign to this String the string value represented by the given null-terminated utf8 encoded data.
String & | assign (const utf8 *utf8_str, size_type str_num)
Assign to this String the string value represented by the given utf8 encoded data.
String & | operator= (utf32 code_point)
Assigns the specified utf32 code point to this String. Result is always a String 1 code point in length.
String & | assign (size_type num, utf32 code_point)
Assigns the specified code point repeatedly to the String.
String & | operator= (const char *cstr)
Assign to this String the given C-string.
String & | assign (const char *cstr)
Assign to this String the given C-string.
String & | assign (const char *chars, size_type chars_len)
Assign to this String a number of chars from a char array.
void | swap (String &str)
Swaps the value of this String with the given String str.
String & | operator+= (const String &str)
Appends the String str.
String & | append (const String &str, size_type str_idx=0, size_type str_num=npos)
Appends a sub-string of the String str.
String & | operator+= (const std::string &std_str)
Appends the std::string std_str.
String & | append (const std::string &std_str, size_type str_idx=0, size_type str_num=npos)
Appends a sub-string of the std::string std_str.
String & | operator+= (const utf8 *utf8_str)
Appends to the String the null-terminated utf8 encoded data in the buffer utf8_str.
String & | append (const utf8 *utf8_str)
Appends to the String the null-terminated utf8 encoded data in the buffer utf8_str.
String & | append (const utf8 *utf8_str, size_type len)
Appends to the String the utf8 encoded data in the buffer utf8_str.
String & | operator+= (utf32 code_point)
Appends a single code point to the string.
String & | append (size_type num, utf32 code_point)
Appends a single code point multiple times to the string.
void | push_back (utf32 code_point)
Appends a single code point to the string.
String & | append (const_iterator iter_beg, const_iterator iter_end)
Appends the code points in the reange [beg, end).
String & | operator+= (const char *cstr)
Appends to the String the given c-string.
String & | append (const char *cstr)
Appends to the String the given c-string.
String & | append (const char *chars, size_type chars_len)
Appends to the String chars from the given char array.
String & | insert (size_type idx, const String &str)
Inserts the given String object at the specified position.
String & | insert (size_type idx, const String &str, size_type str_idx, size_type str_num)
Inserts a sub-string of the given String object at the specified position.
String & | insert (size_type idx, const std::string &std_str)
Inserts the given std::string object at the specified position.
String & | insert (size_type idx, const std::string &std_str, size_type str_idx, size_type str_num)
Inserts a sub-string of the given std::string object at the specified position.
String & | insert (size_type idx, const utf8 *utf8_str)
Inserts the given null-terminated utf8 encoded data at the specified position.
String & | insert (size_type idx, const utf8 *utf8_str, size_type len)
Inserts the given utf8 encoded data at the specified position.
String & | insert (size_type idx, size_type num, utf32 code_point)
Inserts a code point multiple times into the String.
void | insert (iterator pos, size_type num, utf32 code_point)
Inserts a code point multiple times into the String.
iterator | insert (iterator pos, utf32 code_point)
Inserts a single code point into the String.
void | insert (iterator iter_pos, const_iterator iter_beg, const_iterator iter_end)
Inserts code points specified by the range [beg, end).
String & | insert (size_type idx, const char *cstr)
Inserts the given c-string at the specified position.
String & | insert (size_type idx, const char *chars, size_type chars_len)
Inserts chars from the given char array at the specified position.
void | clear (void)
Removes all data from the String.
String & | erase (void)
Removes all data from the String.
String & | erase (size_type idx)
Erase a single code point from the string.
String & | erase (size_type idx, size_type len=npos)
Erase a range of code points.
String & | erase (iterator pos)
Erase the code point described by the given iterator.
String & | erase (iterator iter_beg, iterator iter_end)
Erase a range of code points described by the iterators [beg, end).
void | resize (size_type num)
Resizes the String either by inserting default utf32 code points to make it larger, or by truncating to make it smaller.
void | resize (size_type num, utf32 code_point)
Resizes the String either by inserting the given utf32 code point to make it larger, or by truncating to make it smaller.
String & | replace (size_type idx, size_type len, const String &str)
Replace code points in the String with the specified String object.
String & | replace (iterator iter_beg, iterator iter_end, const String &str)
Replace the code points in the range [beg, end) with the specified String object.
String & | replace (size_type idx, size_type len, const String &str, size_type str_idx, size_type str_num)
Replace code points in the String with a specified sub-string of a given String object.
String & | replace (size_type idx, size_type len, const std::string &std_str)
Replace code points in the String with the specified std::string object.
String & | replace (iterator iter_beg, iterator iter_end, const std::string &std_str)
Replace the code points in the range [beg, end) with the specified std::string object.
String & | replace (size_type idx, size_type len, const std::string &std_str, size_type str_idx, size_type str_num)
Replace code points in the String with a specified sub-string of a given std::string object.
String & | replace (size_type idx, size_type len, const utf8 *utf8_str)
Replace code points in the String with the specified null-terminated utf8 encoded data.
String & | replace (iterator iter_beg, iterator iter_end, const utf8 *utf8_str)
Replace the code points in the range [beg, end) with the specified null-terminated utf8 encoded data.
String & | replace (size_type idx, size_type len, const utf8 *utf8_str, size_type str_len)
Replace code points in the String with the specified utf8 encoded data.
String & | replace (iterator iter_beg, iterator iter_end, const utf8 *utf8_str, size_type str_len)
Replace the code points in the range [beg, end) with the specified null-terminated utf8 encoded data.
String & | replace (size_type idx, size_type len, size_type num, utf32 code_point)
Replaces a specified range of code points with occurrences of a given code point.
String & | replace (iterator iter_beg, iterator iter_end, size_type num, utf32 code_point)
Replace the code points in the range [beg, end) with occurrences of a given code point.
String & | replace (iterator iter_beg, iterator iter_end, const_iterator iter_newBeg, const_iterator iter_newEnd)
Replace the code points in the range [beg, end) with code points from the range [newBeg, newEnd).
String & | replace (size_type idx, size_type len, const char *cstr)
Replace code points in the String with the specified c-string.
String & | replace (iterator iter_beg, iterator iter_end, const char *cstr)
Replace the code points in the range [beg, end) with the specified c-string.
String & | replace (size_type idx, size_type len, const char *chars, size_type chars_len)
Replace code points in the String with chars from the given char array.
String & | replace (iterator iter_beg, iterator iter_end, const char *chars, size_type chars_len)
Replace the code points in the range [beg, end) with chars from the given char array.
size_type | find (utf32 code_point, size_type idx=0) const
Search forwards for a given code point.
size_type | rfind (utf32 code_point, size_type idx=npos) const
Search backwards for a given code point.
size_type | find (const String &str, size_type idx=0) const
Search forwards for a sub-string.
size_type | rfind (const String &str, size_type idx=npos) const
Search backwards for a sub-string.
size_type | find (const std::string &std_str, size_type idx=0) const
Search forwards for a sub-string.
size_type | rfind (const std::string &std_str, size_type idx=npos) const
Search backwards for a sub-string.
size_type | find (const utf8 *utf8_str, size_type idx=0) const
Search forwards for a sub-string.
size_type | rfind (const utf8 *utf8_str, size_type idx=npos) const
Search backwards for a sub-string.
size_type | find (const utf8 *utf8_str, size_type idx, size_type str_len) const
Search forwards for a sub-string.
size_type | rfind (const utf8 *utf8_str, size_type idx, size_type str_len) const
Search backwards for a sub-string.
size_type | find (const char *cstr, size_type idx=0) const
Search forwards for a sub-string.
size_type | rfind (const char *cstr, size_type idx=npos) const
Search backwards for a sub-string.
size_type | find (const char *chars, size_type idx, size_type chars_len) const
Search forwards for a sub-string.
size_type | rfind (const char *chars, size_type idx, size_type chars_len) const
Search backwards for a sub-string.
size_type | find_first_of (const String &str, size_type idx=0) const
Find the first occurrence of one of a set of code points.
size_type | find_first_not_of (const String &str, size_type idx=0) const
Find the first code point that is not one of a set of code points.
size_type | find_first_of (const std::string &std_str, size_type idx=0) const
Find the first occurrence of one of a set of code points.
size_type | find_first_not_of (const std::string &std_str, size_type idx=0) const
Find the first code point that is not one of a set of code points.
size_type | find_first_of (const utf8 *utf8_str, size_type idx=0) const
Find the first occurrence of one of a set of code points.
size_type | find_first_not_of (const utf8 *utf8_str, size_type idx=0) const
Find the first code point that is not one of a set of code points.
size_type | find_first_of (const utf8 *utf8_str, size_type idx, size_type str_len) const
Find the first occurrence of one of a set of code points.
size_type | find_first_not_of (const utf8 *utf8_str, size_type idx, size_type str_len) const
Find the first code point that is not one of a set of code points.
size_type | find_first_of (utf32 code_point, size_type idx=0) const
Search forwards for a given code point.
size_type | find_first_not_of (utf32 code_point, size_type idx=0) const
Search forwards for the first code point that does not match a given code point.
size_type | find_first_of (const char *cstr, size_type idx=0) const
Find the first occurrence of one of a set of chars.
size_type | find_first_not_of (const char *cstr, size_type idx=0) const
Find the first code point that is not one of a set of chars.
size_type | find_first_of (const char *chars, size_type idx, size_type chars_len) const
Find the first occurrence of one of a set of chars.
size_type | find_first_not_of (const char *chars, size_type idx, size_type chars_len) const
Find the first code point that is not one of a set of chars.
size_type | find_last_of (const String &str, size_type idx=npos) const
Find the last occurrence of one of a set of code points.
size_type | find_last_not_of (const String &str, size_type idx=npos) const
Find the last code point that is not one of a set of code points.
size_type | find_last_of (const std::string &std_str, size_type idx=npos) const
Find the last occurrence of one of a set of code points.
size_type | find_last_not_of (const std::string &std_str, size_type idx=npos) const
Find the last code point that is not one of a set of code points.
size_type | find_last_of (const utf8 *utf8_str, size_type idx=npos) const
Find the last occurrence of one of a set of code points.
size_type | find_last_not_of (const utf8 *utf8_str, size_type idx=npos) const
Find the last code point that is not one of a set of code points.
size_type | find_last_of (const utf8 *utf8_str, size_type idx, size_type str_len) const
Find the last occurrence of one of a set of code points.
size_type | find_last_not_of (const utf8 *utf8_str, size_type idx, size_type str_len) const
Find the last code point that is not one of a set of code points.
size_type | find_last_of (utf32 code_point, size_type idx=npos) const
Search for last occurrence of a given code point.
size_type | find_last_not_of (utf32 code_point, size_type idx=npos) const
Search for the last code point that does not match a given code point.
size_type | find_last_of (const char *cstr, size_type idx=npos) const
Find the last occurrence of one of a set of chars.
size_type | find_last_not_of (const char *cstr, size_type idx=npos) const
Find the last code point that is not one of a set of chars.
size_type | find_last_of (const char *chars, size_type idx, size_type chars_len) const
Find the last occurrence of one of a set of chars.
size_type | find_last_not_of (const char *chars, size_type idx, size_type chars_len) const
Find the last code point that is not one of a set of chars.
String | substr (size_type idx=0, size_type len=npos) const
Returns a substring of this String.
iterator | begin (void)
Return a forwards iterator that describes the beginning of the String.
const_iterator | begin (void) const
Return a constant forwards iterator that describes the beginning of the String.
iterator | end (void)
Return a forwards iterator that describes the end of the String.
const_iterator | end (void) const
Return a constant forwards iterator that describes the end of the String.
reverse_iterator | rbegin (void)
Return a reverse iterator that describes the beginning of the String.
const_reverse_iterator | rbegin (void) const
Return a constant reverse iterator that describes the beginning of the String.
reverse_iterator | rend (void)
Return a reverse iterator that describes the end of the String.
const_reverse_iterator | rend (void) const
Return a constant reverse iterator that describes the end of the String.

Static Public Member Functions

static size_type | max_size (void)
Returns the maximum size of a String.

Static Public Attributes

static const size_type | npos = (String::size_type)(-1)
Value used to represent 'not found' conditions and 'all code points' etc.

Classes

class | const_iterator
Constant forward iterator class for String objects. More...
class | iterator
Forward iterator class for String objects. More...

Detailed Description

String class used within the GUI system.

For the most part, this class can replace std::string in basic usage. However, currently String does not use the current locale, and also comparisons do not take into account the Unicode data tables, so are not 'correct' as such.

Constructor & Destructor Documentation

CEGUI::String::String ( const String & str ) [inline]

Copy constructor - Creates a new string with the same value as str.

Parameters:
str String object used to initialise the newly created string
Returns:
Nothing

CEGUI::String::String | ( | const String & | str,
 |  | size_type | str_idx,
 |  | size_type | str_num = npos
 | ) | [inline]

Constructs a new string initialised with code points from another String object.

Parameters:
str | String object used to initialise the newly created string
str_idx | Starting code-point of str to be used when initialising the new String
str_num | Maximum number of code points from str that are to be assigned to the new String
Returns:
Nothing

CEGUI::String::String ( const std::string & std_str ) [inline]

Constructs a new string and initialises it using the std::string std_str.

Parameters:
std_str The std::string object that is to be used to initialise the new String object.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

CEGUI::String::String | ( | const std::string & | std_str,
 |  | size_type | str_idx,
 |  | size_type | str_num = npos
 | ) | [inline]

Constructs a new string initialised with characters from the given std::string object.

Parameters:
std_str | std::string object used to initialise the newly created string
str_idx | Starting character of std_str to be used when initialising the new String
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
str_num Maximum number of characters from std_str that are to be assigned to the new String
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

CEGUI::String::String ( const utf8 * utf8_str ) [inline]

Constructs a new String object and initialise it using the provided utf8 encoded string buffer.

Parameters:
utf8_str Pointer to a buffer containing a null-terminated Unicode string encoded as utf8 data.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

CEGUI::String::String | ( | const utf8 * | utf8_str,
 |  | size_type | chars_len
 | ) | [inline]

Constructs a new String object and initialise it using the provided utf8 encoded string buffer.

A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.

Parameters:
utf8_str Pointer to a buffer containing Unicode string data encoded as utf8.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
chars_len Length of the provided utf8 string in code units (not code-points).
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

CEGUI::String::String | ( | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Constructs a new String that is initialised with the specified code point.

Parameters:
num | The number of times code_point is to be put into new String object
code_point | The Unicode code point to be used when initialising the String object
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

CEGUI::String::String | ( | const_iterator | iter_beg,
 |  | const_iterator | iter_end
 | ) | [inline]

Construct a new string object and initialise it with code-points from the range [beg, end).

Parameters:
beg | Iterator describing the start of the data to be used when initialising the String object
end | Iterator describing the (exclusive) end of the data to be used when initialising the String object
Returns:
Nothing

CEGUI::String::String ( const char * cstr ) [inline]

Constructs a new String object and initialise it using the provided c-string.

Parameters:
c_str Pointer to a c-string.
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

CEGUI::String::String | ( | const char * | chars,
 |  | size_type | chars_len
 | ) | [inline]

Constructs a new String object and initialise it using characters from the provided char array.

Parameters:
chars | char array.
chars_len | Number of chars from the array to be used.
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

Member Function Documentation

String& CEGUI::String::append | ( | const char * | chars,
 |  | size_type | chars_len
 | ) | [inline]

Appends to the String chars from the given char array.

Parameters:
chars | char array holding the chars that are to be appended
chars_len | Number of chars to be appended
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large, or if chars_len was 'npos'

String& CEGUI::String::append ( const char * cstr ) [inline]

Appends to the String the given c-string.

Parameters:
c_str c-string that is to be appended.
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large.

String& CEGUI::String::append | ( | const_iterator | iter_beg,
 |  | const_iterator | iter_end
 | ) | [inline]

Appends the code points in the reange [beg, end).

Parameters:
beg | Iterator describing the start of the range to be appended
end | Iterator describing the (exclusive) end of the range to be appended.
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if the resulting string would be too large.

String& CEGUI::String::append | ( | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Appends a single code point multiple times to the string.

Parameters:
num | Number of copies of the code point to be appended
code_point | utf32 Unicode code point that is to be appended
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too long, or if num was 'npos'.

String& CEGUI::String::append | ( | const utf8 * | utf8_str,
 |  | size_type | len
 | ) | [inline]

Appends to the String the utf8 encoded data in the buffer utf8_str.

Parameters:
utf8_str Buffer holding the utf8 encoded data that is to be appended
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
len Number of code units (not code points) in the buffer to be appended
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large, or if len was 'npos'

String& CEGUI::String::append ( const utf8 * utf8_str ) [inline]

Appends to the String the null-terminated utf8 encoded data in the buffer utf8_str.

Parameters:
utf8_str Buffer holding the null-terminated utf8 encoded data that is to be appended
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large.

String& CEGUI::String::append | ( | const std::string & | std_str,
 |  | size_type | str_idx = 0,
 |  | size_type | str_num = npos
 | ) | [inline]

Appends a sub-string of the std::string std_str.

Parameters:
std_str std::string object containing data to be appended
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
str_idx | Index of the first character to be appended
str_num | Maximum number of characters to be appended
Returns:
This String after the append operation
Exceptions:
std::out_of_range | Thrown if str_idx is invalid for std_str.
std::length_error | Thrown if resulting String would be too large.

String& CEGUI::String::append | ( | const String & | str,
 |  | size_type | str_idx = 0,
 |  | size_type | str_num = npos
 | ) | [inline]

Appends a sub-string of the String str.

Parameters:
str | String object containing data to be appended
str_idx | Index of the first code point to be appended
str_num | Maximum number of code points to be appended
Returns:
This String after the append operation
Exceptions:
std::out_of_range | Thrown if str_idx is invalid for str.
std::length_error | Thrown if resulting String would be too large.

String& CEGUI::String::assign | ( | const char * | chars,
 |  | size_type | chars_len
 | ) | [inline]

Assign to this String a number of chars from a char array.

Parameters:
chars | char array.
chars_len | Number of chars to be assigned.
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large.

String& CEGUI::String::assign ( const char * cstr ) [inline]

Assign to this String the given C-string.

Parameters:
c_str Pointer to a valid C style string.
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large.

String& CEGUI::String::assign | ( | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Assigns the specified code point repeatedly to the String.

Parameters:
num | The number of times to assign the code point
code_point | Valid utf32 Unicode code point to be assigned to the string
Returns:
This String after assignment.
Exceptions:
std::length_error Thrown if num was 'npos'

String& CEGUI::String::assign | ( | const utf8 * | utf8_str,
 |  | size_type | str_num
 | ) | [inline]

Assign to this String the string value represented by the given utf8 encoded data.

Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
utf8_str | Buffer containing valid utf8 encoded data
str_num | Number of code units (not code points) in the buffer pointed to by utf8_str
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large, or if str_num is 'npos'.

String& CEGUI::String::assign ( const utf8 * utf8_str ) [inline]

Assign to this String the string value represented by the given null-terminated utf8 encoded data.

Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
utf8_str Buffer containing valid null-terminated utf8 encoded data
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large.

String& CEGUI::String::assign | ( | const std::string & | std_str,
 |  | size_type | str_idx = 0,
 |  | size_type | str_num = npos
 | ) | [inline]

Assign a sub-string of std::string std_str to this String.

Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
std_str | std::string object containing the string value to be assigned.
str_idx | Index of the first character of std_str to be assigned
str_num | Maximum number of characters from std_str to be assigned
Returns:
This String after the assignment has happened
Exceptions:
std::out_of_range | Thrown if str_idx is invalid for std_str
std::length_error | Thrown if the resulting String would have been too large.

String& CEGUI::String::assign | ( | const String & | str,
 |  | size_type | str_idx = 0,
 |  | size_type | str_num = npos
 | ) | [inline]

Assign a sub-string of String str to this String.

Parameters:
str | String object containing the string data to be assigned.
str_idx | Index of the first code point in str that is to be assigned
str_num | Maximum number of code points from str that are be be assigned
Returns:
This String after the assignment has happened
Exceptions:
std::out_of_range Thrown if str_idx is invalid for str

const_reference CEGUI::String::at ( size_type idx ) const [inline]

Returns the code point at the given index.

Parameters:
idx Zero based index of the code point to be returned.
Returns:
The utf32 code point at the given index within the String.
Exceptions:
std::out_of_range Thrown if idx is >= length().

reference CEGUI::String::at ( size_type idx ) [inline]

Returns the code point at the given index.

Parameters:
idx Zero based index of the code point to be returned.
Returns:
The utf32 code point at the given index within the String.
Exceptions:
std::out_of_range Thrown if idx is >= length().

const_iterator CEGUI::String::begin ( void ) const [inline]

Return a constant forwards iterator that describes the beginning of the String.

Returns:
const_iterator object that describes the beginning of the String.

iterator CEGUI::String::begin ( void ) [inline]

Return a forwards iterator that describes the beginning of the String.

Returns:
iterator object that describes the beginning of the String.

const char* CEGUI::String::c_str ( void ) const [inline]

Returns contents of the String as a null terminated string of utf8 encoded data.

Returns:
Pointer to a char buffer containing the contents of the String encoded as null-terminated utf8 data.
Note:
The buffer returned from this function is owned by the String object.

Any function that modifies the String data will invalidate the buffer returned by this call.

size_type CEGUI::String::capacity ( void ) const [inline]

Return the number of code points that the String could hold before a re-allocation would be required.

Returns:
Size of the current reserve buffer. This is the maximum number of code points the String could hold before a buffer re-allocation would be required

void CEGUI::String::clear ( void ) [inline]

Removes all data from the String.

Returns:
Nothing

int CEGUI::String::compare | ( | size_type | idx,
 |  | size_type | len,
 |  | const char * | chars,
 |  | size_type | chars_len
 | ) | const [inline]

Compares code points from this String with chars in the given char array.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
idx | Index of the first code point from this String to consider.
len | Maximum number of code points from this String to consider.
chars | The array containing the chars that are to compared with this String.
chars_len | The number of chars in the array.
Returns:
  • 0 if the specified sub-strings are equal
  • <0 if specified sub-strings are lexicographically smaller than chars
  • >0 if specified sub-strings are lexicographically greater than chars
Exceptions:
std::out_of_range | Thrown if idx is invalid.
std::length_error | Thrown if chars_len is set to npos.

int CEGUI::String::compare | ( | size_type | idx,
 |  | size_type | len,
 |  | const char * | cstr
 | ) | const [inline]

Compares code points from this String with the given c-string.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
idx | Index of the first code point from this String to consider.
len | Maximum number of code points from this String to consider.
c_str | The c-string that is to compared with this String.
Returns:
  • 0 if the specified sub-strings are equal
  • <0 if specified sub-strings are lexicographically smaller than c_str
  • >0 if specified sub-strings are lexicographically greater than c_str
Exceptions:
std::out_of_range Thrown if idx is invalid.

int CEGUI::String::compare ( const char * cstr ) const [inline]

Compares this String with the given c-string.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
c_str The c-string that is to compared with this String.
Returns:
  • 0 if the strings are equal
  • <0 if this string is lexicographically smaller than c_str
  • >0 if this string is lexicographically greater than c_str

int CEGUI::String::compare | ( | size_type | idx,
 |  | size_type | len,
 |  | const utf8 * | utf8_str,
 |  | size_type | str_cplen
 | ) | const [inline]

Compares code points from this String with the utf8 encoded data in buffer 'utf8_str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
idx | Index of the first code point from this String to consider.
len | Maximum number of code points from this String to consider.
utf8_str | The buffer containing valid Unicode data encoded as utf8 that is to compared with this String.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
str_cplen The number of encoded code points in the buffer utf8_str (this is not the same as the number of code units).
Returns:
  • 0 if the specified sub-strings are equal
  • <0 if specified sub-strings are lexicographically smaller than utf8_str
  • >0 if specified sub-strings are lexicographically greater than utf8_str
Exceptions:
std::out_of_range | Thrown if idx is invalid.
std::length_error | Thrown if str_cplen is set to npos.

int CEGUI::String::compare | ( | size_type | idx,
 |  | size_type | len,
 |  | const utf8 * | utf8_str
 | ) | const [inline]

Compares code points from this String with the null-terminated utf8 encoded 'utf8_str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
idx | Index of the first code point from this String to consider.
len | Maximum number of code points from this String to consider.
utf8_str | The buffer containing valid Unicode data encoded as utf8 that is to compared with this String.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
  • 0 if the specified sub-strings are equal
  • <0 if specified sub-strings are lexicographically smaller than utf8_str
  • >0 if specified sub-strings are lexicographically greater than utf8_str
Exceptions:
std::out_of_range Thrown if idx is invalid.

int CEGUI::String::compare ( const utf8 * utf8_str ) const [inline]

Compares this String with the null-terminated utf8 encoded 'utf8_str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
utf8_str The buffer containing valid Unicode data encoded as utf8 that is to compared with this String.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
  • 0 if the strings are equal
  • <0 if this string is lexicographically smaller than utf8_str
  • >0 if this string is lexicographically greater than utf8_str

int CEGUI::String::compare | ( | size_type | idx,
 |  | size_type | len,
 |  | const std::string & | std_str,
 |  | size_type | str_idx = 0,
 |  | size_type | str_len = npos
 | ) | const [inline]

Compares code points from this String with code points from the std::string 'std_str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
idx | Index of the first code point from this String to consider.
len | Maximum number of code points from this String to consider.
std_str | The std::string object that is to compared with this String.
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Parameters:
str_idx | Index of the first character from std::string std_str to consider.
str_len | Maximum number of characters from std::string std_str to consider
Returns:
  • 0 if the specified sub-strings are equal
  • <0 if specified sub-strings are lexicographically smaller than std_str
  • >0 if specified sub-strings are lexicographically greater than std_str
Exceptions:
std::out_of_range Thrown if either idx or str_idx are invalid.

int CEGUI::String::compare ( const std::string & std_str ) const [inline]

Compares this String with the std::string 'std_str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
std_str The std::string object that is to compared with this String.
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Returns:
  • 0 if the string objects are equal
  • <0 if this string is lexicographically smaller than std_str
  • >0 if this string is lexicographically greater than std_str

int CEGUI::String::compare | ( | size_type | idx,
 |  | size_type | len,
 |  | const String & | str,
 |  | size_type | str_idx = 0,
 |  | size_type | str_len = npos
 | ) | const [inline]

Compares code points from this String with code points from the String 'str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
idx | Index of the first code point from this String to consider.
len | Maximum number of code points from this String to consider.
str | The String object that is to compared with this String.
str_idx | Index of the first code point from String str to consider.
str_len | Maximum number of code points from String str to consider
Returns:
  • 0 if the specified sub-strings are equal
  • <0 if specified sub-strings are lexicographically smaller than str
  • >0 if specified sub-strings are lexicographically greater than str
Exceptions:
std::out_of_range Thrown if either idx or str_idx are invalid.

int CEGUI::String::compare ( const String & str ) const [inline]

Compares this String with the String 'str'.

Note:
This does currently not properly consider Unicode and / or the system locale.
Parameters:
str The String object that is to compared with this String.
Returns:
  • 0 if the String objects are equal
  • <0 if this String is lexicographically smaller than str
  • >0 if this String is lexicographically greater than str

size_type CEGUI::String::copy | ( | utf8 * | buf,
 |  | size_type | len = npos,
 |  | size_type | idx = 0
 | ) | const [inline]

Copies an area of the String into the provided buffer as encoded utf8 data.

Parameters:
buf | Pointer to a buffer that is to receive the encoded data (this must be big enough to hold the encoded data)
len | Maximum number of code points from the String that should be encoded into the buffer
idx | Index of the first code point to be encoded into the buffer
Returns:
The number of utf8 encoded code units transferred to the buffer.
Note:
A code unit does not equal a code point. A utf32 code point, when encoded as utf8, can occupy between 1 and 4 code units.
Exceptions:
std::out_of_range Thrown if idx was invalid for this String.

const utf8* CEGUI::String::data ( void ) const [inline]

Returns contents of the String as utf8 encoded data.

Returns:
Pointer to a buffer containing the contents of the String encoded utf8 data.
Note:
The buffer returned from this function is owned by the String object.

Any function that modifies the String data will invalidate the buffer returned by this call.

bool CEGUI::String::empty ( void ) const [inline]

Returns true if the String is empty.

Returns:
true if the String is empty, else false.

const_iterator CEGUI::String::end ( void ) const [inline]

Return a constant forwards iterator that describes the end of the String.

Returns:
const_iterator object that describes the end of the String.

iterator CEGUI::String::end ( void ) [inline]

Return a forwards iterator that describes the end of the String.

Returns:
iterator object that describes the end of the String.

String& CEGUI::String::erase | ( | iterator | iter_beg,
 |  | iterator | iter_end
 | ) | [inline]

Erase a range of code points described by the iterators [beg, end).

Parameters:
beg | Iterator describing the postion of the beginning of the range to erase
end | Iterator describing the postion of the (exclusive) end of the range to erase
Returns:
This String after the erase operation.

String& CEGUI::String::erase ( iterator pos ) [inline]

Erase the code point described by the given iterator.

Parameters:
pos Iterator describing the code point to be erased
Returns:
This String after the erase operation.

String& CEGUI::String::erase | ( | size_type | idx,
 |  | size_type | len = npos
 | ) | [inline]

Erase a range of code points.

Parameters:
idx | Index of the first code point to be removed.
len | Maximum number of code points to be removed.
Returns:
This String after the erase operation.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

String& CEGUI::String::erase ( size_type idx ) [inline]

Erase a single code point from the string.

Parameters:
idx The index of the code point to be removed.
Returns:
This String after the erase operation
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

String& CEGUI::String::erase ( void ) [inline]

Removes all data from the String.

Returns:
The empty String (*this)

size_type CEGUI::String::find | ( | const char * | chars,
 |  | size_type | idx,
 |  | size_type | chars_len
 | ) | const [inline]

Search forwards for a sub-string.

Parameters:
chars | char array describing the sub-string to search for
idx | Index of the code point where the search is to start
chars_len | Number of chars in the char array.
Returns:
  • Index of the first occurrence of sub-string chars travelling forwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::length_error Thrown if chars_len is 'npos'

size_type CEGUI::String::find | ( | const char * | cstr,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for a sub-string.

Parameters:
c_str | c-string describing the sub-string to search for
idx | Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string c_str travelling forwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find | ( | const utf8 * | utf8_str,
 |  | size_type | idx,
 |  | size_type | str_len
 | ) | const [inline]

Search forwards for a sub-string.

Parameters:
utf8_str Buffer containing utf8 encoded data describing the sub-string to search for
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx | Index of the code point where the search is to start
str_len | Length of the utf8 encoded sub-string in utf8 code units (not code points)
Returns:
  • Index of the first occurrence of sub-string utf8_str travelling forwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::length_error Thrown if str_len is 'npos'

size_type CEGUI::String::find | ( | const utf8 * | utf8_str,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for a sub-string.

Parameters:
utf8_str Buffer containing null-terminated utf8 encoded data describing the sub-string to search for
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string utf8_str travelling forwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find | ( | const std::string & | std_str,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for a sub-string.

Parameters:
std_str std::string object describing the sub-string to search for
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Parameters:
idx Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string std_str travelling forwards from idx.
  • npos if the sub-string could not be found

size_type CEGUI::String::find | ( | const String & | str,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for a sub-string.

Parameters:
str | String object describing the sub-string to search for
idx | Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string str travelling forwards from idx.
  • npos if the sub-string could not be found

size_type CEGUI::String::find | ( | utf32 | code_point,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for a given code point.

Parameters:
code_point | The utf32 code point to search for
idx | Index of the code point where the search is to start.
Returns:
  • Index of the first occurrence of code_point travelling forwards from idx.
  • npos if the code point could not be found

size_type CEGUI::String::find_first_not_of | ( | const char * | chars,
 |  | size_type | idx,
 |  | size_type | chars_len
 | ) | const [inline]

Find the first code point that is not one of a set of chars.

Parameters:
chars | char array containing the set of chars.
idx | Index of the start point for the search
chars_len | Number of chars in the car array.
Returns:
  • Index of the first code point that does not match any one of the chars in chars starting from from idx.
  • npos if all code points matched any of the chars in chars.
Exceptions:
std::length_error Thrown if chars_len was 'npos'.

size_type CEGUI::String::find_first_not_of | ( | const char * | cstr,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first code point that is not one of a set of chars.

Parameters:
c_str | c-string describing the set of chars.
idx | Index of the start point for the search
Returns:
  • Index of the first code point that does not match any one of the chars in c_str starting from from idx.
  • npos if all code points matched any of the chars in c_str.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_first_not_of | ( | utf32 | code_point,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for the first code point that does not match a given code point.

Parameters:
code_point | The utf32 code point to search for
idx | Index of the code point where the search is to start.
Returns:
  • Index of the first code point that does not match code_point starting from from idx.
  • npos if all code points matched code_point
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_first_not_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx,
 |  | size_type | str_len
 | ) | const [inline]

Find the first code point that is not one of a set of code points.

Parameters:
utf8_str Buffer containing utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx | Index of the start point for the search
str_len | Length of the utf8 encoded data in utf8 code units (not code points).
Returns:
  • Index of the first code point that does not match any one of the code points in utf8_str starting from from idx.
  • npos if all code points matched one of the code points in utf8_str.
Exceptions:
std::length_error Thrown if str_len was 'npos'.

size_type CEGUI::String::find_first_not_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first code point that is not one of a set of code points.

Parameters:
utf8_str Buffer containing null-terminated utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the first code point that does not match any one of the code points in utf8_str starting from from idx.
  • npos if all code points matched one of the code points in utf8_str.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_first_not_of | ( | const std::string & | std_str,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first code point that is not one of a set of code points.

Parameters:
std_str std::string object describing the set of code points.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the first code point that does not match any one of the code points in std_str starting from from idx.
  • npos if all code points matched one of the code points in std_str.

size_type CEGUI::String::find_first_not_of | ( | const String & | str,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first code point that is not one of a set of code points.

Parameters:
str | String object describing the set of code points.
idx | Index of the start point for the search
Returns:
  • Index of the first code point that does not match any one of the code points in str starting from from idx.
  • npos if all code points matched one of the code points in str.

size_type CEGUI::String::find_first_of | ( | const char * | chars,
 |  | size_type | idx,
 |  | size_type | chars_len
 | ) | const [inline]

Find the first occurrence of one of a set of chars.

Parameters:
chars | char array containing the set of chars.
idx | Index of the start point for the search
chars_len | Number of chars in the char array.
Returns:
  • Index of the first occurrence of any one of the chars in chars starting from from idx.
  • npos if none of the chars in chars were found.
Exceptions:
std::length_error Thrown if chars_len was 'npos'.

size_type CEGUI::String::find_first_of | ( | const char * | cstr,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first occurrence of one of a set of chars.

Parameters:
c_str | c-string describing the set of chars.
idx | Index of the start point for the search
Returns:
  • Index of the first occurrence of any one of the chars in c_str starting from from idx.
  • npos if none of the chars in c_str were found.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_first_of | ( | utf32 | code_point,
 |  | size_type | idx = 0
 | ) | const [inline]

Search forwards for a given code point.

Parameters:
code_point | The utf32 code point to search for
idx | Index of the code point where the search is to start.
Returns:
  • Index of the first occurrence of code_point starting from from idx.
  • npos if the code point could not be found

size_type CEGUI::String::find_first_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx,
 |  | size_type | str_len
 | ) | const [inline]

Find the first occurrence of one of a set of code points.

Parameters:
utf8_str Buffer containing utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx | Index of the start point for the search
str_len | Length of the utf8 encoded data in utf8 code units (not code points).
Returns:
  • Index of the first occurrence of any one of the code points in utf8_str starting from from idx.
  • npos if none of the code points in utf8_str were found.
Exceptions:
std::length_error Thrown if str_len was 'npos'.

size_type CEGUI::String::find_first_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first occurrence of one of a set of code points.

Parameters:
utf8_str Buffer containing null-terminated utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the first occurrence of any one of the code points in utf8_str starting from from idx.
  • npos if none of the code points in utf8_str were found.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_first_of | ( | const std::string & | std_str,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first occurrence of one of a set of code points.

Parameters:
std_str std::string object describing the set of code points.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the first occurrence of any one of the code points in std_str starting from from idx.
  • npos if none of the code points in std_str were found.

size_type CEGUI::String::find_first_of | ( | const String & | str,
 |  | size_type | idx = 0
 | ) | const [inline]

Find the first occurrence of one of a set of code points.

Parameters:
str | String object describing the set of code points.
idx | Index of the start point for the search
Returns:
  • Index of the first occurrence of any one of the code points in str starting from from idx.
  • npos if none of the code points in str were found.

size_type CEGUI::String::find_last_not_of | ( | const char * | chars,
 |  | size_type | idx,
 |  | size_type | chars_len
 | ) | const [inline]

Find the last code point that is not one of a set of chars.

Parameters:
chars | char array containing the set of chars.
idx | Index of the start point for the search
chars_len | Number of chars in the char array.
Returns:
  • Index of the last code point that does not match any one of the chars in chars, starting from from idx.
  • npos if all code points matched any of the chars in chars.
Exceptions:
std::length_error Thrown if chars_len was 'npos'.

size_type CEGUI::String::find_last_not_of | ( | const char * | cstr,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last code point that is not one of a set of chars.

Parameters:
c_str | c-string describing the set of chars.
idx | Index of the start point for the search
Returns:
  • Index of the last code point that does not match any one of the chars in c_str starting from idx.
  • npos if all code points matched any of the chars in c_str.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_last_not_of | ( | utf32 | code_point,
 |  | size_type | idx = npos
 | ) | const [inline]

Search for the last code point that does not match a given code point.

Parameters:
code_point | The utf32 code point to search for
idx | Index of the code point where the search is to start.
Returns:
  • Index of the last code point that does not match code_point starting from from idx.
  • npos if all code points matched code_point

size_type CEGUI::String::find_last_not_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx,
 |  | size_type | str_len
 | ) | const [inline]

Find the last code point that is not one of a set of code points.

Parameters:
utf8_str Buffer containing utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx | Index of the start point for the search
str_len | Length of the utf8 encoded data in utf8 code units (not code points).
Returns:
  • Index of the last code point that does not match any one of the code points in utf8_str starting from from idx.
  • npos if all code points matched one of the code points in utf8_str.
Exceptions:
std::length_error Thrown if str_len was 'npos'.

size_type CEGUI::String::find_last_not_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last code point that is not one of a set of code points.

Parameters:
utf8_str Buffer containing null-terminated utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the last code point that does not match any one of the code points in utf8_str starting from idx.
  • npos if all code points matched one of the code points in utf8_str.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_last_not_of | ( | const std::string & | std_str,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last code point that is not one of a set of code points.

Parameters:
std_str std::string object describing the set of code points.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the last code point that does not match any one of the code points in std_str starting from idx.
  • npos if all code points matched one of the code points in std_str.

size_type CEGUI::String::find_last_not_of | ( | const String & | str,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last code point that is not one of a set of code points.

Parameters:
str | String object describing the set of code points.
idx | Index of the start point for the search
Returns:
  • Index of the last code point that does not match any one of the code points in str starting from idx.
  • npos if all code points matched one of the code points in str.

size_type CEGUI::String::find_last_of | ( | const char * | chars,
 |  | size_type | idx,
 |  | size_type | chars_len
 | ) | const [inline]

Find the last occurrence of one of a set of chars.

Parameters:
chars | char array containing the set of chars.
idx | Index of the start point for the search
chars_len | Number of chars in the char array.
Returns:
  • Index of the last occurrence of any one of the chars in chars, starting from from idx.
  • npos if none of the chars in chars were found.
Exceptions:
std::length_error Thrown if chars_len was 'npos'.

size_type CEGUI::String::find_last_of | ( | const char * | cstr,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last occurrence of one of a set of chars.

Parameters:
c_str | c-string describing the set of chars.
idx | Index of the start point for the search
Returns:
  • Index of the last occurrence of any one of the chars in c_str starting from idx.
  • npos if none of the chars in c_str were found.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_last_of | ( | utf32 | code_point,
 |  | size_type | idx = npos
 | ) | const [inline]

Search for last occurrence of a given code point.

Parameters:
code_point | The utf32 code point to search for
idx | Index of the code point where the search is to start.
Returns:
  • Index of the last occurrence of code_point starting from idx.
  • npos if the code point could not be found

size_type CEGUI::String::find_last_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx,
 |  | size_type | str_len
 | ) | const [inline]

Find the last occurrence of one of a set of code points.

Parameters:
utf8_str Buffer containing utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx | Index of the start point for the search
str_len | Length of the utf8 encoded data in utf8 code units (not code points).
Returns:
  • Index of the last occurrence of any one of the code points in utf8_str starting from from idx.
  • npos if none of the code points in utf8_str were found.
Exceptions:
std::length_error Thrown if str_len was 'npos'.

size_type CEGUI::String::find_last_of | ( | const utf8 * | utf8_str,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last occurrence of one of a set of code points.

Parameters:
utf8_str Buffer containing null-terminated utf8 encoded data describing the set of code points.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the last occurrence of any one of the code points in utf8_str starting from idx.
  • npos if none of the code points in utf8_str were found.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::find_last_of | ( | const std::string & | std_str,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last occurrence of one of a set of code points.

Parameters:
std_str std::string object describing the set of code points.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
idx Index of the start point for the search
Returns:
  • Index of the last occurrence of any one of the code points in std_str starting from idx.
  • npos if none of the code points in std_str were found.

size_type CEGUI::String::find_last_of | ( | const String & | str,
 |  | size_type | idx = npos
 | ) | const [inline]

Find the last occurrence of one of a set of code points.

Parameters:
str | String object describing the set of code points.
idx | Index of the start point for the search
Returns:
  • Index of the last occurrence of any one of the code points in str starting from idx.
  • npos if none of the code points in str were found.

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const char * | chars,
 |  | size_type | chars_len
 | ) | [inline]

Inserts chars from the given char array at the specified position.

Parameters:
idx | Index where the data is to be inserted.
chars | char array containing the chars that are to be inserted.
chars_len | Length of the char array to be inserted.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large, or if chars_len is 'npos'

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const char * | cstr
 | ) | [inline]

Inserts the given c-string at the specified position.

Parameters:
idx | Index where the c-string is to be inserted.
c_str | c-string that is to be inserted.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large.

void CEGUI::String::insert | ( | iterator | iter_pos,
 |  | const_iterator | iter_beg,
 |  | const_iterator | iter_end
 | ) | [inline]

Inserts code points specified by the range [beg, end).

Parameters:
pos | Iterator describing the position where the data is to be inserted
beg | Iterator describing the begining of the range to be inserted
end | Iterator describing the (exclusive) end of the range to be inserted.
Returns:
Nothing.
Exceptions:
std::length_error Thrown if resulting String would be too large.

iterator CEGUI::String::insert | ( | iterator | pos,
 |  | utf32 | code_point
 | ) | [inline]

Inserts a single code point into the String.

Parameters:
pos | Iterator describing the position where the code point is to be inserted
code_point | The utf32 code point that is to be inserted
Returns:
This String after the insertion.
Exceptions:
std::length_error Thrown if resulting String would be too large.

void CEGUI::String::insert | ( | iterator | pos,
 |  | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Inserts a code point multiple times into the String.

Parameters:
pos | Iterator describing the position where the code point(s) are to be inserted
num | The number of times to insert the code point
code_point | The utf32 code point that is to be inserted
Returns:
This String after the insertion.
Exceptions:
std::length_error Thrown if resulting String would be too large, or if num is 'npos'

String& CEGUI::String::insert | ( | size_type | idx,
 |  | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Inserts a code point multiple times into the String.

Parameters:
idx | Index where the code point(s) are to be inserted
num | The number of times to insert the code point
code_point | The utf32 code point that is to be inserted
Returns:
This String after the insertion.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large, or if num is 'npos'

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const utf8 * | utf8_str,
 |  | size_type | len
 | ) | [inline]

Inserts the given utf8 encoded data at the specified position.

Parameters:
idx | Index where the data is to be inserted.
utf8_str | Buffer containing the utf8 encoded data that is to be inserted.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
len Length of the data to be inserted in uf8 code units (not code points)
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large, or if len is 'npos'

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const utf8 * | utf8_str
 | ) | [inline]

Inserts the given null-terminated utf8 encoded data at the specified position.

Parameters:
idx | Index where the data is to be inserted.
utf8_str | Buffer containing the null-terminated utf8 encoded data that is to be inserted.
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large.

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const std::string & | std_str,
 |  | size_type | str_idx,
 |  | size_type | str_num
 | ) | [inline]

Inserts a sub-string of the given std::string object at the specified position.

Parameters:
idx | Index where the string is to be inserted.
std_str | std::string object containing data to be inserted.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
str_idx | Index of the first character from std_str to be inserted.
str_num | Maximum number of characters from str to be inserted.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx or str_idx are out of range.
std::length_error | Thrown if resulting String would be too large.

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const std::string & | std_str
 | ) | [inline]

Inserts the given std::string object at the specified position.

Parameters:
idx | Index where the std::string is to be inserted.
std_str | std::string object that is to be inserted.
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large.

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const String & | str,
 |  | size_type | str_idx,
 |  | size_type | str_num
 | ) | [inline]

Inserts a sub-string of the given String object at the specified position.

Parameters:
idx | Index where the string is to be inserted.
str | String object containing data to be inserted.
str_idx | Index of the first code point from str to be inserted.
str_num | Maximum number of code points from str to be inserted.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx or str_idx are out of range.
std::length_error | Thrown if resulting String would be too large.

String& CEGUI::String::insert | ( | size_type | idx,
 |  | const String & | str
 | ) | [inline]

Inserts the given String object at the specified position.

Parameters:
idx | Index where the string is to be inserted.
str | String object that is to be inserted.
Returns:
This String after the insert.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String.
std::length_error | Thrown if resulting String would be too large.

size_type CEGUI::String::length ( void ) const [inline]

Returns the size of the String in code points.

Returns:
Number of code points currently in the String

static size_type CEGUI::String::max_size ( void ) [inline, static]

Returns the maximum size of a String.

Any operation that would result in a String that is larger than this value will throw the std::length_error exception.

Returns:
The maximum number of code points that a string can contain

String& CEGUI::String::operator+= ( const char * cstr ) [inline]

Appends to the String the given c-string.

Parameters:
c_str c-string that is to be appended.
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large.

String& CEGUI::String::operator+= ( utf32 code_point ) [inline]

Appends a single code point to the string.

Parameters:
code_point utf32 Unicode code point that is to be appended
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too long.

String& CEGUI::String::operator+= ( const utf8 * utf8_str ) [inline]

Appends to the String the null-terminated utf8 encoded data in the buffer utf8_str.

Parameters:
utf8_str buffer holding the null-terminated utf8 encoded data that is to be appended
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large.

String& CEGUI::String::operator+= ( const std::string & std_str ) [inline]

Appends the std::string std_str.

Parameters:
std_str std::string object that is to be appended
Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large.

String& CEGUI::String::operator+= ( const String & str ) [inline]

Appends the String str.

Parameters:
str String object that is to be appended
Returns:
This String after the append operation
Exceptions:
std::length_error Thrown if resulting String would be too large.

String& CEGUI::String::operator= ( const char * cstr ) [inline]

Assign to this String the given C-string.

Parameters:
c_str Pointer to a valid C style string.
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large.

String& CEGUI::String::operator= ( utf32 code_point ) [inline]

Assigns the specified utf32 code point to this String. Result is always a String 1 code point in length.

Parameters:
code_point Valid utf32 Unicode code point to be assigned to the string
Returns:
This String after assignment

String& CEGUI::String::operator= ( const utf8 * utf8_str ) [inline]

Assign to this String the string value represented by the given null-terminated utf8 encoded data.

Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
utf8_str Buffer containing valid null-terminated utf8 encoded data
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large.

String& CEGUI::String::operator= ( const std::string & std_str ) [inline]

Assign the value of std::string std_str to this String.

Note:
The characters of std_str are taken to be unencoded data which represent Unicode code points 0x00..0xFF. No translation of the provided data will occur.
Parameters:
std_str std::string object containing the string value to be assigned.
Returns:
This String after the assignment has happened
Exceptions:
std::length_error Thrown if the resulting String would have been too large.

String& CEGUI::String::operator= ( const String & str ) [inline]

Assign the value of String str to this String.

Parameters:
str String object containing the string value to be assigned.
Returns:
This String after the assignment has happened

value_type CEGUI::String::operator[] ( size_type idx ) const [inline]

Returns the code point at the given index.

Parameters:
idx Zero based index of the code point to be returned.
Note:
  • For constant strings length()/size() provide a valid index and will access the default utf32 value.
  • For non-constant strings length()/size() is an invalid index, and acceesing (especially writing) this index could cause string corruption.
Returns:
The utf32 code point at the given index within the String.

reference CEGUI::String::operator[] ( size_type idx ) [inline]

Returns the code point at the given index.

Parameters:
idx Zero based index of the code point to be returned.
Note:
  • For constant strings length()/size() provide a valid index and will access the default utf32 value.
  • For non-constant strings length()/size() is an invalid index, and acceesing (especially writing) this index could cause string corruption.
Returns:
The utf32 code point at the given index within the String.

void CEGUI::String::push_back ( utf32 code_point ) [inline]

Appends a single code point to the string.

Parameters:
code_point utf32 Unicode code point that is to be appended
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String would be too long.

const_reverse_iterator CEGUI::String::rbegin ( void ) const [inline]

Return a constant reverse iterator that describes the beginning of the String.

Returns:
const_reverse_iterator object that describes the beginning of the String (so is actually at the end)

reverse_iterator CEGUI::String::rbegin ( void ) [inline]

Return a reverse iterator that describes the beginning of the String.

Returns:
reverse_iterator object that describes the beginning of the String (so is actually at the end)

const_reverse_iterator CEGUI::String::rend ( void ) const [inline]

Return a constant reverse iterator that describes the end of the String.

Returns:
const_reverse_iterator object that describes the end of the String (so is actually at the beginning)

reverse_iterator CEGUI::String::rend ( void ) [inline]

Return a reverse iterator that describes the end of the String.

Returns:
reverse_iterator object that describes the end of the String (so is actually at the beginning)

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const char * | chars,
 |  | size_type | chars_len
 | ) | [inline]

Replace the code points in the range [beg, end) with chars from the given char array.

Note:
If beg == end, the operation is a insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
chars | char array containing the chars that are to replace the specified range of code points
chars_len | Number of chars in the char array.
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if the resulting String would be too large, or if chars_len was 'npos'.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const char * | chars,
 |  | size_type | chars_len
 | ) | [inline]

Replace code points in the String with chars from the given char array.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced (if this is 0, operation is an insert at position idx)
chars | char array containing the cars that are to replace the specified code points
chars_len | Number of chars in the char array.
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if the resulting String would be too large, or if chars_len was 'npos'.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const char * | cstr
 | ) | [inline]

Replace the code points in the range [beg, end) with the specified c-string.

Note:
If beg == end, the operation is a insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
c_str | c-string that is to replace the specified range of code points
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const char * | cstr
 | ) | [inline]

Replace code points in the String with the specified c-string.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced (if this is 0, operation is an insert at position idx)
c_str | c-string that is to replace the specified code points
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const_iterator | iter_newBeg,
 |  | const_iterator | iter_newEnd
 | ) | [inline]

Replace the code points in the range [beg, end) with code points from the range [newBeg, newEnd).

Note:
If beg == end, the operation is an insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
newBeg | Iterator describing the beginning of the range to insert.
newEnd | Iterator describing the (exclusive) end of the range to insert.
Returns:
This String after the insert operation.
Exceptions:
std::length_error Thrown if the resulting string would be too long.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Replace the code points in the range [beg, end) with occurrences of a given code point.

Note:
If beg == end, the operation is an insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
num | Number of occurrences of code_point that are to replace the specified range of code points
code_point | Code point that is to be used when replacing the specified range of code points
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if resulting String would have been too long, or if num was 'npos'.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Replaces a specified range of code points with occurrences of a given code point.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to replace. If this is 0 the operation is an insert
num | Number of occurrences of code_point that are to replace the specified range of code points
code_point | Code point that is to be used when replacing the specified range of code points
Returns:
This String after the replace operation.
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if resulting String would have been too long, or if num was 'npos'.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const utf8 * | utf8_str,
 |  | size_type | str_len
 | ) | [inline]

Replace the code points in the range [beg, end) with the specified null-terminated utf8 encoded data.

Note:
If beg == end, the operation is a insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
utf8_str | Buffer containing the null-terminated utf8 encoded data that is to replace the specified range of code points
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
str_len Length of the utf8 encoded data in utf8 code units (not code points).
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if the resulting String would be too large, or if str_len was 'npos'.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const utf8 * | utf8_str,
 |  | size_type | str_len
 | ) | [inline]

Replace code points in the String with the specified utf8 encoded data.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced (if this is 0, operation is an insert at position idx)
utf8_str | Buffer containing the null-terminated utf8 encoded data that is to replace the specified code points
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
str_len Length of the utf8 encoded data in utf8 code units (not code points).
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if the resulting String would be too large, or if str_len was 'npos'.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const utf8 * | utf8_str
 | ) | [inline]

Replace the code points in the range [beg, end) with the specified null-terminated utf8 encoded data.

Note:
If beg == end, the operation is a insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
utf8_str | Buffer containing the null-terminated utf8 encoded data that is to replace the specified range of code points
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const utf8 * | utf8_str
 | ) | [inline]

Replace code points in the String with the specified null-terminated utf8 encoded data.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced (if this is 0, operation is an insert at position idx)
utf8_str | Buffer containing the null-terminated utf8 encoded data that is to replace the specified code points
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const std::string & | std_str,
 |  | size_type | str_idx,
 |  | size_type | str_num
 | ) | [inline]

Replace code points in the String with a specified sub-string of a given std::string object.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced. If this is 0, the operation is an insert at position idx.
std_str | std::string object containing the data that will replace the specified range of code points
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Parameters:
str_idx | Index of the first code point of std_str that is to replace the specified code point range
str_num | Maximum number of code points of std_str that are to replace the specified code point range
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if either idx, or str_idx are invalid
std::length_error | Thrown if the resulting String would have been too large.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const std::string & | std_str
 | ) | [inline]

Replace the code points in the range [beg, end) with the specified std::string object.

Note:
If beg == end, the operation is a insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
std_str | The std::string object that is to replace the specified range of code points
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const std::string & | std_str
 | ) | [inline]

Replace code points in the String with the specified std::string object.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced (if this is 0, operation is an insert at position idx)
std_str | The std::string object that is to replace the specified code points
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const String & | str,
 |  | size_type | str_idx,
 |  | size_type | str_num
 | ) | [inline]

Replace code points in the String with a specified sub-string of a given String object.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced. If this is 0, the operation is an insert at position idx.
str | String object containing the data that will replace the specified range of code points
str_idx | Index of the first code point of str that is to replace the specified code point range
str_num | Maximum number of code points of str that are to replace the specified code point range
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if either idx, or str_idx are invalid
std::length_error | Thrown if the resulting String would have been too large.

String& CEGUI::String::replace | ( | iterator | iter_beg,
 |  | iterator | iter_end,
 |  | const String & | str
 | ) | [inline]

Replace the code points in the range [beg, end) with the specified String object.

Note:
If beg == end, the operation is a insert at iterator position beg
Parameters:
beg | Iterator describing the start of the range to be replaced
end | Iterator describing the (exclusive) end of the range to be replaced.
str | The String object that is to replace the specified range of code points
Returns:
This String after the replace operation
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String& CEGUI::String::replace | ( | size_type | idx,
 |  | size_type | len,
 |  | const String & | str
 | ) | [inline]

Replace code points in the String with the specified String object.

Parameters:
idx | Index of the first code point to be replaced
len | Maximum number of code points to be replaced (if this is 0, operation is an insert at position idx)
str | The String object that is to replace the specified code points
Returns:
This String after the replace operation
Exceptions:
std::out_of_range | Thrown if idx is invalid for this String
std::length_error | Thrown if the resulting String would be too large.

void CEGUI::String::reserve ( size_type num = 0 ) [inline]

Specifies the amount of reserve capacity to allocate.

Parameters:
num The number of code points to allocate space for. If num is larger that the current reserve, then a re-allocation will occur. If num is smaller than the current reserve (but not 0) the buffer may be shrunk to the larger of the specified number, or the current String size (operation is currently not implemented). If num is 0, then the buffer is re-allocated to fit the current String size.
Returns:
Nothing
Exceptions:
std::length_error Thrown if resulting String object would be too big.

void CEGUI::String::resize | ( | size_type | num,
 |  | utf32 | code_point
 | ) | [inline]

Resizes the String either by inserting the given utf32 code point to make it larger, or by truncating to make it smaller.

Parameters:
num | The length, in code points, that the String is to be made.
code_point | The utf32 code point that should be used when majing the String larger
Returns:
Nothing.
Exceptions:
std::length_error Thrown if the String would be too large.

void CEGUI::String::resize ( size_type num ) [inline]

Resizes the String either by inserting default utf32 code points to make it larger, or by truncating to make it smaller.

Parameters:
num The length, in code points, that the String is to be made.
Returns:
Nothing.
Exceptions:
std::length_error Thrown if the String would be too large.

size_type CEGUI::String::rfind | ( | const char * | chars,
 |  | size_type | idx,
 |  | size_type | chars_len
 | ) | const [inline]

Search backwards for a sub-string.

Parameters:
chars | char array describing the sub-string to search for
idx | Index of the code point where the search is to start
chars_len | Number of chars in the char array.
Returns:
  • Index of the first occurrence of sub-string chars travelling backwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::length_error Thrown if chars_len is 'npos'

size_type CEGUI::String::rfind | ( | const char * | cstr,
 |  | size_type | idx = npos
 | ) | const [inline]

Search backwards for a sub-string.

Parameters:
c_str | c-string describing the sub-string to search for
idx | Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string c_str travelling backwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::rfind | ( | const utf8 * | utf8_str,
 |  | size_type | idx,
 |  | size_type | str_len
 | ) | const [inline]

Search backwards for a sub-string.

Parameters:
utf8_str Buffer containing utf8 encoded data describing the sub-string to search for
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx | Index of the code point where the search is to start
str_len | Length of the utf8 encoded sub-string in utf8 code units (not code points)
Returns:
  • Index of the first occurrence of sub-string utf8_str travelling backwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::length_error Thrown if str_len is 'npos'

size_type CEGUI::String::rfind | ( | const utf8 * | utf8_str,
 |  | size_type | idx = npos
 | ) | const [inline]

Search backwards for a sub-string.

Parameters:
utf8_str Buffer containing null-terminated utf8 encoded data describing the sub-string to search for
Note:
A basic string literal (cast to utf8*) can be passed to this function, provided that the string is comprised only of code points 0x00..0x7f. The use of extended ASCII characters (with values >0x7f) would result in incorrect behaviour as the String will attempt to 'decode' the data, with unpredictable results.
Parameters:
idx Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string utf8_str travelling backwards from idx.
  • npos if the sub-string could not be found
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

size_type CEGUI::String::rfind | ( | const std::string & | std_str,
 |  | size_type | idx = npos
 | ) | const [inline]

Search backwards for a sub-string.

Parameters:
std_str std::string object describing the sub-string to search for
Note:
Characters from std_str are considered to represent Unicode code points in the range 0x00..0xFF. No translation of the encountered data is performed.
Parameters:
idx Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string std_str travelling backwards from idx.
  • npos if the sub-string could not be found

size_type CEGUI::String::rfind | ( | const String & | str,
 |  | size_type | idx = npos
 | ) | const [inline]

Search backwards for a sub-string.

Parameters:
str | String object describing the sub-string to search for
idx | Index of the code point where the search is to start
Returns:
  • Index of the first occurrence of sub-string str travelling backwards from idx.
  • npos if the sub-string could not be found

size_type CEGUI::String::rfind | ( | utf32 | code_point,
 |  | size_type | idx = npos
 | ) | const [inline]

Search backwards for a given code point.

Parameters:
code_point | The utf32 code point to search for
idx | Index of the code point where the search is to start.
Returns:
  • Index of the first occurrence of code_point travelling backwards from idx.
  • npos if the code point could not be found

size_type CEGUI::String::size ( void ) const [inline]

Returns the size of the String in code points.

Returns:
Number of code points currently in the String

String CEGUI::String::substr | ( | size_type | idx = 0,
 |  | size_type | len = npos
 | ) | const [inline]

Returns a substring of this String.

Parameters:
idx | Index of the first code point to use for the sub-string.
len | Maximum number of code points to use for the sub-string
Returns:
A String object containing the specified sub-string.
Exceptions:
std::out_of_range Thrown if idx is invalid for this String.

void CEGUI::String::swap ( String & str ) [inline]

Swaps the value of this String with the given String str.

Parameters:
str String object whos value is to be swapped with this String.
Returns:
Nothing

size_type CEGUI::String::utf8_stream_len | ( | size_type | num = npos,
 |  | size_type | idx = 0
 | ) | [inline]

Return the number of utf8 code units required to hold an area of the String when encoded as utf8 data.

Parameters:
num | Maximum number of code points to consider when calculating utf8 encoded size.
idx | Index of the first code point to consider when calculating the utf8 encoded size
Returns:
The number of utf8 code units (bytes) required to hold the specified sub-string when encoded as utf8 data.
Exceptions:
std::out_of_range Thrown if idx was invalid for this String.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::String::const_iterator Class Reference

CEGUI::String::const_iterator

CEGUI::String::const_iterator Class Reference

Constant forward iterator class for String objects. More...

Inheritance diagram for CEGUI::String::const_iterator:

[legend]
List of all members.

Public Member Functions

const_iterator (const_pointer ptr)
const_reference | operator * () const
const_pointer | operator-> () const
const_iterator & | operator++ ()
const_iterator | operator++ (int)
const_iterator & | operator-- ()
const_iterator | operator-- (int)
const_iterator & | operator+= (difference_type offset)
const_iterator | operator+ (difference_type offset) const
const_iterator & | operator-= (difference_type offset)
const_iterator | operator- (difference_type offset) const
difference_type | operator- (const const_iterator &iter) const
const_reference | operator[] (difference_type offset) const
bool | operator== (const const_iterator &iter) const
bool | operator!= (const const_iterator &iter) const
bool | operator< (const const_iterator &iter) const
bool | operator> (const const_iterator &iter) const
bool | operator<= (const const_iterator &iter) const
bool | operator>= (const const_iterator &iter) const

Public Attributes

const utf32 * | d_ptr

Friends

const_iterator | operator+ (difference_type offset, const const_iterator &iter)

Detailed Description

Constant forward iterator class for String objects.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::String::iterator Class Reference

CEGUI::String::iterator

CEGUI::String::iterator Class Reference

Forward iterator class for String objects. More...

Inheritance diagram for CEGUI::String::iterator:

[legend]
Collaboration diagram for CEGUI::String::iterator:

[legend]
List of all members.

Public Member Functions

iterator (pointer ptr)
reference | operator * () const
pointer | operator-> () const
iterator & | operator++ ()
iterator | operator++ (int)
iterator & | operator-- ()
iterator | operator-- (int)
iterator & | operator+= (difference_type offset)
iterator | operator+ (difference_type offset) const
iterator & | operator-= (difference_type offset)
iterator | operator- (difference_type offset) const
difference_type | operator- (const const_iterator &iter) const
reference | operator[] (difference_type offset) const

Friends

iterator | operator+ (difference_type offset, const iterator &iter)

Detailed Description

Forward iterator class for String objects.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SubscriberInterface< Ret, Args > Class Template Reference

CEGUI::SubscriberInterface

CEGUI::SubscriberInterface< Ret, Args > Class Template Reference

The base class for the various binders. This provides a consistent interface for firing functions bound to an event. More...

Inheritance diagram for CEGUI::SubscriberInterface< Ret, Args >:

[legend]
List of all members.

Public Member Functions

virtual Ret operator() (Args) const =0

Detailed Description

template<typename Ret, typename Args>
class CEGUI::SubscriberInterface< Ret, Args >

The base class for the various binders. This provides a consistent interface for firing functions bound to an event.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SubscriberTemplate< Ret, Args > Class Template Reference

CEGUI::SubscriberTemplate

CEGUI::SubscriberTemplate< Ret, Args > Class Template Reference

This template describes the Subscriber class. It is a wrapper for a pointer to a SubscriberInterface with various constructors that will by implicit conversion construct the various binders. More...

List of all members.

Public Types

typedef Ret(* | SlotFunction )(Args)

Public Member Functions

Ret | operator() (Args args) const
SubscriberTemplate (SlotFunction f)
construct from a free function
template<class T>
SubscriberTemplate (Ret(T::*f)(Args), T *target)
construct from a member function and a pointer to the target object.
template<typename Functor>
SubscriberTemplate (const Functor &f)
construct from a generalized functor by copying it
SubscriberTemplate (SubscriberInterface< Ret, Args > *si)
construct from a preconstructed SubscriberInterface. used for SubscriberRef().
SubscriberTemplate (const SubscriberTemplate< Ret, Args > &copy)
copy constructor
bool | operator< (const SubscriberTemplate< Ret, Args > &rhs) const
'less than' comparable for insertion in a map
void | release () const
release the binding -- called upon disconnection

Protected Attributes

SubscriberInterface< Ret,
Args > * 		d_si

Detailed Description

template<typename Ret, typename Args>
class CEGUI::SubscriberTemplate< Ret, Args >

This template describes the Subscriber class. It is a wrapper for a pointer to a SubscriberInterface with various constructors that will by implicit conversion construct the various binders.

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::System Class Reference

CEGUI::System

CEGUI::System Class Reference

The System class is the CEGUI class that provides access to all other elements in this system. More...

Inheritance diagram for CEGUI::System:

[legend]
Collaboration diagram for CEGUI::System:

[legend]
List of all members.

Public Member Functions

System (Renderer *renderer, const utf8 *logFile=(const utf8 *)"CEGUI.log")
Constructs a System object.
System (Renderer *renderer, ResourceProvider *resourceProvider, const utf8 *logFile=(const utf8 *)"CEGUI.log")
Construct a new System object.
System (Renderer *renderer, ScriptModule *scriptModule, const utf8 *configFile=(const utf8 *)"cegui.config")
Construct a new System object.
System (Renderer *renderer, ScriptModule *scriptModule, ResourceProvider *resourceProvider, const utf8 *configFile=(const utf8 *)"cegui.config")
Construct a new System object.
System (Renderer *renderer, XMLParser *xmlParser, const utf8 *logFile=(const utf8 *)"CEGUI.log")
Constructs a System object.
System (Renderer *renderer, ResourceProvider *resourceProvider, XMLParser *xmlParser, const utf8 *logFile=(const utf8 *)"CEGUI.log")
Constructs a System object.
System (Renderer *renderer, XMLParser *xmlParser, ScriptModule *scriptModule, const utf8 *configFile=(const utf8 *)"cegui.config")
Construct a new System object.
System (Renderer *renderer, ResourceProvider *resourceProvider, XMLParser *xmlParser, ScriptModule *scriptModule, const utf8 *configFile=(const utf8 *)"cegui.config")
Construct a new System object.
~System (void)
Destructor for System objects.
Renderer * | getRenderer (void) const
Return a pointer to the Renderer object being used by the system.
void | setDefaultFont (const String &name)
Set the default font to be used by the system.
void | setDefaultFont (Font *font)
Set the default font to be used by the system.
Font * | getDefaultFont (void) const
Return a pointer to the default Font for the GUI system.
void | signalRedraw ()
Causes a full re-draw next time renderGUI() is called.
bool | isRedrawRequested () const
Return a boolean value to indicate whether a full re-draw is requested next time renderGUI() is called.
void | renderGUI (void)
Render the GUI.
Window * | setGUISheet (Window *sheet)
Set the active GUI sheet (root) window.
Window * | getGUISheet (void) const
Return a pointer to the active GUI sheet (root) window.
double | getSingleClickTimeout (void) const
Return the current timeout for generation of single-click events.
double | getMultiClickTimeout (void) const
Return the current timeout for generation of multi-click events.
const Size & | getMultiClickToleranceAreaSize (void) const
Return the size of the allowable mouse movement tolerance used when generating multi-click events.
void | setSingleClickTimeout (double timeout)
Set the timeout used for generation of single-click events.
void | setMultiClickTimeout (double timeout)
Set the timeout to be used for the generation of multi-click events.
void | setMultiClickToleranceAreaSize (const Size &sz)
Set the size of the allowable mouse movement tolerance used when generating multi-click events.
const Image * | getDefaultMouseCursor (void) const
Return the currently set default mouse cursor image.
void | setDefaultMouseCursor (const Image *image)
Set the image to be used as the default mouse cursor.
void | setDefaultMouseCursor (MouseCursorImage image)
Set the image to be used as the default mouse cursor.
void | setDefaultMouseCursor (const String &imageset, const String &image_name)
Set the image to be used as the default mouse cursor.
Window * | getWindowContainingMouse (void) const
Return the Window object that the mouse is presently within.
ScriptModule * | getScriptingModule (void) const
Return a pointer to the ScriptModule being used for scripting within the GUI system.
ResourceProvider * | getResourceProvider (void) const
Return a pointer to the ResourceProvider being used within the GUI system.
void | executeScriptFile (const String &filename, const String &resourceGroup="") const
Execute a script file if possible.
int | executeScriptGlobal (const String &function_name) const
Execute a scripted global function if possible. The function should not take any parameters and should return an integer.
void | executeScriptString (const String &str) const
If possible, execute script code contained in the given CEGUI::String object.
float | getMouseMoveScaling (void) const
return the current mouse movement scaling factor.
void | setMouseMoveScaling (float scaling)
Set the current mouse movement scaling factor.
void | notifyWindowDestroyed (const Window *window)
Internal method used to inform the System object whenever a window is destroyed, so that System can perform any required housekeeping.
uint | getSystemKeys (void) const
Return the current system keys value.
XMLParser * | getXMLParser (void) const
Return the XMLParser object.
void | setTooltip (Tooltip *tooltip)
Set the system default Tooltip object. This value may be NULL to indicate that no default Tooltip will be available.
void | setTooltip (const String &tooltipType)
Set the system default Tooltip to be used by specifying a Window type.
Tooltip * | getDefaultTooltip (void) const
return a poiter to the system default tooltip. May return 0.
void | setModalTarget (Window *target)
Internal method to directly set the current modal target.
Window * | getModalTarget (void) const
Return a pointer to the Window that is currently the modal target.
bool | injectMouseMove (float delta_x, float delta_y)
Method that injects a mouse movement event into the system.
bool | injectMouseLeaves (void)
Method that injects that the mouse has left the application window.
bool | injectMouseButtonDown (MouseButton button)
Method that injects a mouse button down event into the system.
bool | injectMouseButtonUp (MouseButton button)
Method that injects a mouse button up event into the system.
bool | injectKeyDown (uint key_code)
Method that injects a key down event into the system.
bool | injectKeyUp (uint key_code)
Method that injects a key up event into the system.
bool | injectChar (utf32 code_point)
Method that injects a typed character event into the system.
bool | injectMouseWheelChange (float delta)
Method that injects a mouse-wheel / scroll-wheel event into the system.
bool | injectMousePosition (float x_pos, float y_pos)
Method that injects a new position for the mouse cursor.
bool | injectTimePulse (float timeElapsed)
Method to inject time pulses into the system.

Static Public Member Functions

static System & | getSingleton (void)
Return singleton System object.
static System * | getSingletonPtr (void)
Return pointer to singleton System object.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const double | DefaultSingleClickTimeout = 0.2
Default timeout for generation of single click events.
static const double | DefaultMultiClickTimeout = 0.33
Default timeout for generation of multi-click events.
static const Size | DefaultMultiClickAreaSize
Default allowable mouse movement for multi-click event generation.
static const String | EventGUISheetChanged
Name of event fired whenever the GUI sheet is changed.
static const String | EventSingleClickTimeoutChanged
Name of event fired when the single-click timeout is changed.
static const String | EventMultiClickTimeoutChanged
Name of event fired when the multi-click timeout is changed.
static const String | EventMultiClickAreaSizeChanged
Name of event fired when the size of the multi-click tolerance area is changed.
static const String | EventDefaultFontChanged
Name of event fired when the default font changes.
static const String | EventDefaultMouseCursorChanged
Name of event fired when the default mouse cursor changes.
static const String | EventMouseMoveScalingChanged
Name of event fired when the mouse move scaling factor changes.

Detailed Description

The System class is the CEGUI class that provides access to all other elements in this system.

This object must be created by the client application. The System object requires that you pass it an initialised Renderer object which it can use to interface to whatever rendering system will be used to display the GUI imagery.

Constructor & Destructor Documentation

CEGUI::System::System | ( | Renderer * | renderer,
 |  | const utf8 * | logFile = (const utf8 *)"CEGUI.log"
 | ) |

Constructs a System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
logFile | pointer to a utf8 encoded buffer containing the name to use for the log file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | ResourceProvider * | resourceProvider,
 |  | const utf8 * | logFile = (const utf8 *)"CEGUI.log"
 | ) |

Construct a new System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
resourceProvider | Pointer to a ResourceProvider object.
logFile | pointer to a utf8 encoded buffer containing the name to use for the log file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | ScriptModule * | scriptModule,
 |  | const utf8 * | configFile = (const utf8 *)"cegui.config"
 | ) |

Construct a new System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
scriptModule | Pointer to a ScriptModule object. may be NULL.
configFile | pointer to a utf8 encoded buffer containing the name to use for the configuration file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | ScriptModule * | scriptModule,
 |  | ResourceProvider * | resourceProvider,
 |  | const utf8 * | configFile = (const utf8 *)"cegui.config"
 | ) |

Construct a new System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
scriptModule | Pointer to a ScriptModule object. may be NULL.
resourceProvider | Pointer to a ResourceProvider object.
configFile | pointer to a utf8 encoded buffer containing the name to use for the configuration file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | XMLParser * | xmlParser,
 |  | const utf8 * | logFile = (const utf8 *)"CEGUI.log"
 | ) |

Constructs a System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
xmlParser | Pointer to a valid XMLParser object to be used when parsing XML files, or NULL to use a default parser.
logFile | pointer to a utf8 encoded buffer containing the name to use for the log file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | ResourceProvider * | resourceProvider,
 |  | XMLParser * | xmlParser,
 |  | const utf8 * | logFile = (const utf8 *)"CEGUI.log"
 | ) |

Constructs a System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
resourceProvider | Pointer to a ResourceProvider object.
xmlParser | Pointer to a valid XMLParser object to be used when parsing XML files, or NULL to use a default parser.
logFile | pointer to a utf8 encoded buffer containing the name to use for the log file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | XMLParser * | xmlParser,
 |  | ScriptModule * | scriptModule,
 |  | const utf8 * | configFile = (const utf8 *)"cegui.config"
 | ) |

Construct a new System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
xmlParser | Pointer to a valid XMLParser object to be used when parsing XML files, or NULL to use a default parser.
scriptModule | Pointer to a ScriptModule object. may be NULL.
configFile | pointer to a utf8 encoded buffer containing the name to use for the configuration file.

CEGUI::System::System | ( | Renderer * | renderer,
 |  | ResourceProvider * | resourceProvider,
 |  | XMLParser * | xmlParser,
 |  | ScriptModule * | scriptModule,
 |  | const utf8 * | configFile = (const utf8 *)"cegui.config"
 | ) |

Construct a new System object.

Parameters:
renderer | Pointer to the valid Renderer object that will be used to render GUI imagery
resourceProvider | Pointer to a ResourceProvider object.
xmlParser | Pointer to a valid XMLParser object to be used when parsing XML files, or NULL to use a default parser.
scriptModule | Pointer to a ScriptModule object. may be NULL.
configFile | pointer to a utf8 encoded buffer containing the name to use for the configuration file.

Member Function Documentation

void CEGUI::System::executeScriptFile | ( | const String & | filename,
 |  | const String & | resourceGroup = ""
 | ) | const

Execute a script file if possible.

Parameters:
filename | String object holding the filename of the script file that is to be executed
resourceGroup | Resource group identifier to be passed to the ResourceProvider when loading the script file.

int CEGUI::System::executeScriptGlobal ( const String & function_name ) const

Execute a scripted global function if possible. The function should not take any parameters and should return an integer.

Parameters:
function_name String object holding the name of the function, in the global script environment, that is to be executed.
Returns:
The integer value returned from the script function.

void CEGUI::System::executeScriptString ( const String & str ) const

If possible, execute script code contained in the given CEGUI::String object.

Parameters:
str String object holding the valid script code that should be executed.
Returns:
Nothing.

Font* CEGUI::System::getDefaultFont ( void ) const [inline]

Return a pointer to the default Font for the GUI system.

Returns:
Pointer to a Font object that is the default font in the system.

const Image* CEGUI::System::getDefaultMouseCursor ( void ) const [inline]

Return the currently set default mouse cursor image.

Returns:
Pointer to the current default image used for the mouse cursor. May return NULL if default cursor has not been set, or has intentionally been set to NULL - which results in a blank default cursor.

Tooltip* CEGUI::System::getDefaultTooltip ( void ) const [inline]

return a poiter to the system default tooltip. May return 0.

Returns:
Pointer to the current system default tooltip. May return 0 if no system default tooltip is available.

Window* CEGUI::System::getGUISheet ( void ) const [inline]

Return a pointer to the active GUI sheet (root) window.

Returns:
Pointer to the window object that has been set as the GUI root element.

Window* CEGUI::System::getModalTarget ( void ) const [inline]

Return a pointer to the Window that is currently the modal target.

Returns:
Pointer to the current modal target. NULL if there is no modal target.

float CEGUI::System::getMouseMoveScaling ( void ) const

return the current mouse movement scaling factor.

Returns:
float value that is equal to the currently set mouse movement scaling factor. Defaults to 1.0f.

double CEGUI::System::getMultiClickTimeout ( void ) const [inline]

Return the current timeout for generation of multi-click events.

A multi-click event is a double-click, or a triple-click. The value returned here is the maximum allowable time between mouse button down events for which a multi-click event will be generated.

Returns:
double value equal to the current multi-click timeout value.

const Size& CEGUI::System::getMultiClickToleranceAreaSize ( void ) const [inline]

Return the size of the allowable mouse movement tolerance used when generating multi-click events.

This size defines an area with the mouse at the centre. The mouse must stay within the tolerance defined for a multi-click (double click, or triple click) event to be generated.

Returns:
Size object describing the current multi-click tolerance area size.

Renderer* CEGUI::System::getRenderer ( void ) const [inline]

Return a pointer to the Renderer object being used by the system.

Returns:
Pointer to the Renderer object used by the system.

ResourceProvider * CEGUI::System::getResourceProvider ( void ) const

Return a pointer to the ResourceProvider being used within the GUI system.

Returns:
Pointer to a ResourceProvider based object.

ScriptModule * CEGUI::System::getScriptingModule ( void ) const

Return a pointer to the ScriptModule being used for scripting within the GUI system.

Returns:
Pointer to a ScriptModule based object.

double CEGUI::System::getSingleClickTimeout ( void ) const [inline]

Return the current timeout for generation of single-click events.

A single-click is defined here as a button being pressed and then released.

Returns:
double value equal to the current single-click timeout value.

System & CEGUI::System::getSingleton ( void ) [static]

Return singleton System object.

Returns:
Singleton System object

System * CEGUI::System::getSingletonPtr ( void ) [static]

Return pointer to singleton System object.

Returns:
Pointer to singleton System object

uint CEGUI::System::getSystemKeys ( void ) const [inline]

Return the current system keys value.

Returns:
uint value representing a combination of the SystemKey bits.

Window* CEGUI::System::getWindowContainingMouse ( void ) const [inline]

Return the Window object that the mouse is presently within.

Returns:
Pointer to the Window object that currently contains the mouse cursor, or NULL if none.

bool CEGUI::System::injectChar ( utf32 code_point )

Method that injects a typed character event into the system.

Parameters:
code_point Unicode code point of the character that was typed.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectKeyDown ( uint key_code )

Method that injects a key down event into the system.

Parameters:
key_code uint value indicating which key was pressed.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectKeyUp ( uint key_code )

Method that injects a key up event into the system.

Parameters:
key_code uint value indicating which key was released.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectMouseButtonDown ( MouseButton button )

Method that injects a mouse button down event into the system.

Parameters:
button One of the MouseButton values indicating which button was pressed.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectMouseButtonUp ( MouseButton button )

Method that injects a mouse button up event into the system.

Parameters:
button One of the MouseButton values indicating which button was released.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectMouseLeaves ( void )

Method that injects that the mouse has left the application window.

Returns:
  • true if the generated mouse move event was handled.
  • false if the generated mouse move event was not handled.

bool CEGUI::System::injectMouseMove | ( | float | delta_x,
 |  | float | delta_y
 | ) |

Method that injects a mouse movement event into the system.

Parameters:
delta_x | amount the mouse moved on the x axis.
delta_y | amount the mouse moved on the y axis.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectMousePosition | ( | float | x_pos,
 |  | float | y_pos
 | ) |

Method that injects a new position for the mouse cursor.

Parameters:
x_pos | New absolute pixel position of the mouse cursor on the x axis.
y_pos | New absolute pixel position of the mouse cursoe in the y axis.
Returns:
  • true if the generated mouse move event was handled.
  • false if the generated mouse move event was not handled.

bool CEGUI::System::injectMouseWheelChange ( float delta )

Method that injects a mouse-wheel / scroll-wheel event into the system.

Parameters:
delta float value representing the amount the wheel moved.
Returns:
  • true if the input was processed by the gui system.
  • false if the input was not processed by the gui system.

bool CEGUI::System::injectTimePulse ( float timeElapsed )

Method to inject time pulses into the system.

Parameters:
timeElapsed float value indicating the amount of time passed, in seconds, since the last time this method was called.
Returns:
Currently, this method always returns true.

bool CEGUI::System::isRedrawRequested ( ) const [inline]

Return a boolean value to indicate whether a full re-draw is requested next time renderGUI() is called.

Returns:
true if a re-draw has been requested

void CEGUI::System::notifyWindowDestroyed ( const Window * window )

Internal method used to inform the System object whenever a window is destroyed, so that System can perform any required housekeeping.

Note:
This method is not intended for client code usage. If you use this method anything can, and probably will, go wrong!

void CEGUI::System::renderGUI ( void )

Render the GUI.

Depending upon the internal state, this may either re-use rendering from last time, or trigger a full re-draw from all elements.

Returns:
Nothing

void CEGUI::System::setDefaultFont ( Font * font )

Set the default font to be used by the system.

Parameters:
font Pointer to the font to be used as the system default.
Returns:
Nothing.

void CEGUI::System::setDefaultFont ( const String & name )

Set the default font to be used by the system.

Parameters:
name String object containing the name of the font to be used as the system default.
Returns:
Nothing.

void CEGUI::System::setDefaultMouseCursor | ( | const String & | imageset,
 |  | const String & | image_name
 | ) |

Set the image to be used as the default mouse cursor.

Parameters:
imageset | String object that contains the name of the Imageset that contains the image to be used.
image_name | String object that contains the name of the Image on imageset that is to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if imageset is not known, or if imageset contains no Image named image_name.

void CEGUI::System::setDefaultMouseCursor ( MouseCursorImage image ) [inline]

Set the image to be used as the default mouse cursor.

Parameters:
image One of the MouseCursorImage enumerated values.
Returns:
Nothing.

void CEGUI::System::setDefaultMouseCursor ( const Image * image )

Set the image to be used as the default mouse cursor.

Parameters:
image Pointer to an image object that is to be used as the default mouse cursor. To have no cursor rendered by default, you can specify NULL here.
Returns:
Nothing.

Window * CEGUI::System::setGUISheet ( Window * sheet )

Set the active GUI sheet (root) window.

Parameters:
sheet Pointer to a Window object that will become the new GUI 'root'
Returns:
Pointer to the window that was previously set as the GUI root.

void CEGUI::System::setModalTarget ( Window * target ) [inline]

Internal method to directly set the current modal target.

Note:
This method is called internally by Window, and must be used by client code. Doing so will most likely not have the expected results.

void CEGUI::System::setMouseMoveScaling ( float scaling )

Set the current mouse movement scaling factor.

Parameters:
scaling float value specifying the scaling to be applied to mouse movement inputs.
Returns:
nothing.

void CEGUI::System::setMultiClickTimeout ( double timeout )

Set the timeout to be used for the generation of multi-click events.

A multi-click event is a double-click, or a triple-click. The value returned here is the maximum allowable time between mouse button down events for which a multi-click event will be generated.

Parameters:
timeout double value equal to the multi-click timeout value to be used from now onwards.
Returns:
Nothing.

void CEGUI::System::setMultiClickToleranceAreaSize ( const Size & sz )

Set the size of the allowable mouse movement tolerance used when generating multi-click events.

This size defines an area with the mouse at the centre. The mouse must stay within the tolerance defined for a multi-click (double click, or triple click) event to be generated.

Parameters:
sz Size object describing the multi-click tolerance area size to be used.
Returns:
Nothing.

void CEGUI::System::setSingleClickTimeout ( double timeout )

Set the timeout used for generation of single-click events.

A single-click is defined here as a button being pressed and then released.

Parameters:
timeout double value equal to the single-click timeout value to be used from now onwards.
Returns:
Nothing.

void CEGUI::System::setTooltip ( const String & tooltipType )

Set the system default Tooltip to be used by specifying a Window type.

System will internally attempt to create an instance of the specified window type (which must be derived from the base Tooltip class). If the Tooltip creation fails, the error is logged and no system default Tooltip will be available.

Parameters:
tooltipType String object holding the name of the Tooltip based Window type which should be used as the Tooltip for the system default.
Returns:
Nothing.

void CEGUI::System::setTooltip ( Tooltip * tooltip )

Set the system default Tooltip object. This value may be NULL to indicate that no default Tooltip will be available.

Parameters:
tooltip Pointer to a valid Tooltip based object which should be used as the default tooltip for the system, or NULL to indicate that no system default tooltip is required. Note that when passing a pointer to a Tooltip object, ownership of the Tooltip does not pass to System.
Returns:
Nothing.

void CEGUI::System::signalRedraw ( ) [inline]

Causes a full re-draw next time renderGUI() is called.

Returns:
Nothing

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabButton Class Reference

CEGUI::TabButton

CEGUI::TabButton Class Reference

Base class for TabButtons. A TabButton based class is used internally as the button that appears at the top of a TabControl widget to select the active tab pane. More...

Inheritance diagram for CEGUI::TabButton:

[legend]
Collaboration diagram for CEGUI::TabButton:

[legend]
List of all members.

Public Member Functions

TabButton (const String &type, const String &name)
Constructor for base TabButton class.
virtual | ~TabButton (void)
Destructor for TabButton class.
virtual void | setSelected (bool selected)
Set whether this tab button is selected or not.
virtual void | setRightOfSelected (bool isRight)
Set whether this tab button is on the right of the selected button, used to disable edges of buttons when deselected (to give an overlapping look).
bool | isSelected (void) const
Return whether this tab button is selected or not.
void | setTargetWindow (Window *wnd)
Set the target window which is the content pane which this button is covering.
Window * | getTargetWindow (void)
Get the target window which is the content pane which this button is covering.
void | setTabIndex (uint idx)
Set the index at which this tab is positioned.
uint | getTabIndex (void)
Get the index at which this tab is positioned.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventClicked
The button was clicked.

Protected Member Functions

virtual void | onClicked (WindowEventArgs &e)
handler invoked internally when the button is clicked.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
void | addTabButtonEvents (void)
Add button specific events.
void | drawSelf (float z)
Perform the rendering for this widget.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

bool | d_selected
Is this button selected?
bool | d_rightOfSelected
Is this button to the right of the selected tab?
Window * d_targetWindow
The target window which this button is representing.
uint | d_tabIndex
The index at which this tab is positioned.

Detailed Description

Base class for TabButtons. A TabButton based class is used internally as the button that appears at the top of a TabControl widget to select the active tab pane.

Member Function Documentation

void CEGUI::TabButton::drawSelf ( float z ) [protected, virtual]

Perform the rendering for this widget.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented from CEGUI::ButtonBase.

void CEGUI::TabButton::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::ButtonBase.

virtual bool CEGUI::TabButton::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::ButtonBase.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControl Class Reference

CEGUI::TabControl

CEGUI::TabControl Class Reference

Base class for standard Tab Control widget. More...

Inheritance diagram for CEGUI::TabControl:

[legend]
Collaboration diagram for CEGUI::TabControl:

[legend]
List of all members.

Public Member Functions

uint | getTabCount (void) const
Return number of tabs.
void | setSelectedTab (const String &name)
Set the selected tab by the name of the root window within it.
Exceptions:
InvalidRequestException thrown if index is out of range.

void | setSelectedTab (uint ID)
Set the selected tab by the ID of the root window within it.
Exceptions:
InvalidRequestException thrown if index is out of range.

void | setSelectedTabAtIndex (uint index)
Set the selected tab by the index position in the tab control.
Exceptions:
InvalidRequestException thrown if index is out of range.

Window * | getTabContentsAtIndex (uint index) const
Return the Window which is the first child of the tab at index position index.
Window * | getTabContents (const String &name) const
Return the Window which is the tab content with the given name.
Window * | getTabContents (uint ID) const
Return the Window which is the tab content with the given ID.
bool | isTabContentsSelected (Window *wnd) const
Return whether the tab contents window is currently selected.
uint | getSelectedTabIndex () const
Return the index of the currently selected tab.
float | getRelativeTabHeight (void) const
Return the relative height of the tabs.
float | getAbsoluteTabHeight (void) const
Return the absolute height of the tabs.
float | getTabHeight (void) const
Return the height of the tabs in the current metrics mode.
float | getTabTextPadding (void) const
Return the amount of padding to add either side of the text in the tab, according to the current metrics mode.
float | getRelativeTabTextPadding (void) const
Return the relative amount of padding to add either side of the text in the tab.
float | getAbsoluteTabTextPadding (void) const
Return the absolute amount of padding to add either side of the text in the tab.
virtual void | initialise (void)
Initialise the Window based object ready for use.
void | setRelativeTabHeight (float height)
Set the relative height of the tabs.
void | setAbsoluteTabHeight (float height)
Set the absolute height of the tabs.
void | setTabHeight (float height)
Set the height of the tabs in the current metrics mode.
void | setTabTextPadding (float)
Set the amount of padding to add either side of the text in the tab, according to the current metrics mode.
void | setRelativeTabTextPadding (float)
Set the relative amount of padding to add either side of the text in the tab.
void | setAbsoluteTabTextPadding (float)
Set the absolute amount of padding to add either side of the text in the tab.
void | addTab (Window *wnd)
Add a new tab to the tab control.
void | removeTab (const String &name)
Remove the named tab from the tab control.
void | removeTab (uint ID)
Remove the tab with the given ID from the tab control.
TabControl (const String &type, const String &name)
Constructor for TabControl base class.
virtual | ~TabControl (void)
Destructor for Listbox base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventSelectionChanged
Event triggered when there is a change to the currently selected tab.

Protected Types

typedef std::map< uint, TabButton * > | TabButtonIndexMap

Protected Member Functions

virtual void | drawSelf (float z)
Perform the actual rendering for this Window.
void | addTabControlEvents (void)
Add tab control specific events.
virtual void | addButtonForTabContent (Window *wnd)
Add a TabButton for the specified child Window.
virtual void | removeButtonForTabContent (Window *wnd)
Remove the TabButton for the specified child Window.
TabButton * | getButtonForTabContents (Window *wnd) const
Return the TabButton associated with this Window.
Exceptions:
InvalidRequestException thrown if content is not found.

String | makeButtonName (Window *wnd)
Construct a button name to handle a window.
virtual void | selectTab_impl (Window *wnd)
Internal implementation of select tab.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
void | performChildWindowLayout ()
method called to perform extended laying out of attached child windows.
int | writeChildWindowsXML (OutStream &out_stream) const
virtual void | onSelectionChanged (WindowEventArgs &e)
Handler called internally when the currently selected item or items changes.
virtual void | onFontChanged (WindowEventArgs &e)
Handler called when the window's font is changed.
virtual TabPane * | createTabContentPane (const String &name) const =0
create and return a pointer to a TabPane widget for use as content area
virtual Window * | createTabButtonPane (const String &name) const
create and return a pointer to a widget for use as tab button area
virtual TabButton * | createTabButton (const String &name) const =0
create and return a pointer to a TabButton widget for use as a clickable tab header
void | calculateTabButtonSizePosition (TabButton *btn, uint targetIndex)
Calculate the correct position and size of a tab button, based on the index it is due to be placed at.
void | addTabControlProperties (void)
void | addChild_impl (Window *wnd)
Add given window to child list at an appropriate position.
void | removeChild_impl (Window *wnd)
Remove given window from child list.
bool | handleContentWindowTextChanged (const EventArgs &args)
bool | handleTabButtonClicked (const EventArgs &args)

Protected Attributes

Window * d_tabButtonPane
The area containing the tab buttons.
TabPane * d_tabContentPane
The content area window.
float | d_abs_tabHeight
The height of the tabs in pixels.
float | d_rel_tabHeight
The height of the tabs relative to parent.
float | d_abs_tabPadding
The padding of the tabs in pixels.
float | d_rel_tabPadding
The padding of the tabs relative to parent.
uint | d_nextTabIndex
The index to give the next tab.
TabButtonIndexMap | d_tabButtonIndexMap
Sorting for tabs.

Static Protected Attributes

static TabControlProperties::TabHeight | d_tabHeightProperty
static TabControlProperties::AbsoluteTabHeight | d_absoluteTabHeightProperty
static TabControlProperties::RelativeTabHeight | d_relativeTabHeightProperty
static TabControlProperties::TabTextPadding | d_tabTextPaddingProperty
static TabControlProperties::AbsoluteTabTextPadding | d_absoluteTabTextPaddingProperty
static TabControlProperties::RelativeTabTextPadding | d_relativeTabTextPaddingProperty

Detailed Description

Base class for standard Tab Control widget.

Member Function Documentation

void CEGUI::TabControl::addTab ( Window * wnd )

Add a new tab to the tab control.

The new tab will be added with the same text as the window passed in.
Parameters:
wnd The Window which will be placed in the content area of this new tab.

void CEGUI::TabControl::calculateTabButtonSizePosition | ( | TabButton * | btn,
 |  | uint | targetIndex
 | ) | [protected]

Calculate the correct position and size of a tab button, based on the index it is due to be placed at.

Parameters:
btn | Pointer to a button to calculate the size and position for. This button will be updated in place with these metrics.
targetIndex | The index at which the tab is/will be placed. Tabs must exist for all the indexes before this.

virtual TabButton* CEGUI::TabControl::createTabButton ( const String & name ) const [protected, pure virtual]

create and return a pointer to a TabButton widget for use as a clickable tab header

Parameters:
name Button name
Returns:
Pointer to a TabButton to be used for changing tabs.

Window * CEGUI::TabControl::createTabButtonPane ( const String & name ) const [protected, virtual]

create and return a pointer to a widget for use as tab button area

Parameters:
name String holding the name to be given to the new component.
Returns:
Pointer to a Static to be used for holding the tab buttons.

virtual TabPane* CEGUI::TabControl::createTabContentPane ( const String & name ) const [protected, pure virtual]

create and return a pointer to a TabPane widget for use as content area

Parameters:
name String holding the name to be given to the new component.
Returns:
Pointer to a TabPane to be used for holding the main content.

virtual void CEGUI::TabControl::drawSelf ( float z ) [inline, protected, virtual]

Perform the actual rendering for this Window.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented from CEGUI::Window.

uint CEGUI::TabControl::getSelectedTabIndex ( ) const

Return the index of the currently selected tab.

Returns:
index of the currently selected tab.

Window * CEGUI::TabControl::getTabContents ( uint ID ) const

Return the Window which is the tab content with the given ID.

Parameters:
ID ID of the Window which was attached as a tab content.
Returns:
Pointer to the Window with the given ID in the tab control.
Exceptions:
InvalidRequestException thrown if content is not found.

Window * CEGUI::TabControl::getTabContents ( const String & name ) const

Return the Window which is the tab content with the given name.

Parameters:
name Name of the Window which was attached as a tab content.
Returns:
Pointer to the named Window in the tab control.
Exceptions:
InvalidRequestException thrown if content is not found.

Window * CEGUI::TabControl::getTabContentsAtIndex ( uint index ) const

Return the Window which is the first child of the tab at index position index.

Parameters:
index Zero based index of the item to be returned.
Returns:
Pointer to the Window at index position index in the tab control.
Exceptions:
InvalidRequestException thrown if index is out of range.

uint CEGUI::TabControl::getTabCount ( void ) const

Return number of tabs.

Returns:
the number of tabs currently present.

void CEGUI::TabControl::initialise ( void ) [virtual]

Initialise the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented from CEGUI::Window.

bool CEGUI::TabControl::isTabContentsSelected ( Window * wnd ) const

Return whether the tab contents window is currently selected.

Parameters:
wnd The tab contents window to query.
Returns:
true if the tab is currently selected, false otherwise.
Exceptions:
InvalidRequestException thrown if wnd is not a valid tab contents window.

void CEGUI::TabControl::onFontChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's font is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::TabControl::performChildWindowLayout ( ) [protected, virtual]

method called to perform extended laying out of attached child windows.

The system may call this at various times (like when it is resized for example), and it may be invoked directly where required.

Returns:
Nothing.

Reimplemented from CEGUI::Window.

void CEGUI::TabControl::removeTab ( uint ID )

Remove the tab with the given ID from the tab control.

The tab content will be destroyed.

void CEGUI::TabControl::removeTab ( const String & name )

Remove the named tab from the tab control.

The tab content will be destroyed.

void CEGUI::TabControl::selectTab_impl ( Window * wnd ) [protected, virtual]

Internal implementation of select tab.

Parameters:
wnd Pointer to a Window which is the root of the tab content to select

virtual bool CEGUI::TabControl::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties::TabHeight Class Reference

CEGUI::TabControlProperties::TabHeight

CEGUI::TabControlProperties::TabHeight Class Reference

Property to access the tab height setting of the tab control. More...

Inheritance diagram for CEGUI::TabControlProperties::TabHeight:

[legend]
Collaboration diagram for CEGUI::TabControlProperties::TabHeight:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.
String | getDefault (const PropertyReceiver *receiver) const
Returns the default value of the Property as a String.

Detailed Description

Property to access the tab height setting of the tab control.

Usage:
  • Name: TabHeight
  • Format: "[float]"

Member Function Documentation

String CEGUI::TabControlProperties::TabHeight::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

String CEGUI::TabControlProperties::TabHeight::getDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns the default value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the default value for this property.

Reimplemented from CEGUI::Property.

bool CEGUI::TabControlProperties::TabHeight::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::TabControlProperties::TabHeight::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabPane Class Reference

CEGUI::TabPane

CEGUI::TabPane Class Reference

Base class for a tab pane. More...

Inheritance diagram for CEGUI::TabPane:

[legend]
Collaboration diagram for CEGUI::TabPane:

[legend]
List of all members.

Public Member Functions

TabPane (const String &type, const String &name)
Constructor for tab pane widgets.
virtual | ~TabPane (void)
Destructor for tab pane widgets.

Protected Member Functions

virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Detailed Description

Base class for a tab pane.

Member Function Documentation

virtual bool CEGUI::TabPane::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Static.

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties::TabTextPadding Class Reference

CEGUI::TabControlProperties::TabTextPadding

CEGUI::TabControlProperties::TabTextPadding Class Reference

Property to access the tab text padding setting of the tab control. More...

Inheritance diagram for CEGUI::TabControlProperties::TabTextPadding:

[legend]
Collaboration diagram for CEGUI::TabControlProperties::TabTextPadding:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.
String | getDefault (const PropertyReceiver *receiver) const
Returns the default value of the Property as a String.

Detailed Description

Property to access the tab text padding setting of the tab control.

Usage:
  • Name: TabTextPadding
  • Format: "[float]"

Member Function Documentation

String CEGUI::TabControlProperties::TabTextPadding::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

String CEGUI::TabControlProperties::TabTextPadding::getDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns the default value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the default value for this property.

Reimplemented from CEGUI::Property.

bool CEGUI::TabControlProperties::TabTextPadding::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::TabControlProperties::TabTextPadding::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Text Class Reference

CEGUI::WindowProperties::Text

CEGUI::WindowProperties::Text Class Reference

Property to access window text setting. More...

Inheritance diagram for CEGUI::WindowProperties::Text:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Text:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window text setting.

This property offers access to the current text for the window.

Usage:
  • Name: Text
  • Format: "[text]".
Where:
  • [text] is the name of the Font to assign for this window. The Font specified must already be loaded.

Member Function Documentation

String CEGUI::WindowProperties::Text::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Text::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TextItemProperties::TextColour Class Reference

CEGUI::TextItemProperties::TextColour

CEGUI::TextItemProperties::TextColour Class Reference

Property to access the text colour of the item. More...

Inheritance diagram for CEGUI::TextItemProperties::TextColour:

[legend]
Collaboration diagram for CEGUI::TextItemProperties::TextColour:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the text colour of the item.

Usage:
  • Name: TextColour
  • Format: "[aarrggbb]".
Where:
  • [aarrggbb] represents the text colour of the item.

Member Function Documentation

String CEGUI::TextItemProperties::TextColour::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TextItemProperties::TextColour::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticTextProperties::TextColours Class Reference

CEGUI::StaticTextProperties::TextColours

CEGUI::StaticTextProperties::TextColours Class Reference

Property to access the text colours for the StaticText widget. More...

Inheritance diagram for CEGUI::StaticTextProperties::TextColours:

[legend]
Collaboration diagram for CEGUI::StaticTextProperties::TextColours:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the text colours for the StaticText widget.

Usage:
  • Name: TextColours
  • Format: "tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]".
Where:
  • tl:[aarrggbb] is the top-left colour value specified as ARGB (hex).
  • tr:[aarrggbb] is the top-right colour value specified as ARGB (hex).
  • bl:[aarrggbb] is the bottom-left colour value specified as ARGB (hex).
  • br:[aarrggbb] is the bottom-right colour value specified as ARGB (hex).

Member Function Documentation

String CEGUI::StaticTextProperties::TextColours::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticTextProperties::TextColours::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TextComponent Class Reference

CEGUI::TextComponent

CEGUI::TextComponent Class Reference

Class that encapsulates information for a text component. More...

Inheritance diagram for CEGUI::TextComponent:

[legend]
Collaboration diagram for CEGUI::TextComponent:

[legend]
List of all members.

Public Member Functions

TextComponent ()
Constructor.
const String & | getText () const
Return the text object that will be rendered by this TextComponent.
void | setText (const String &text)
Set the text that will be rendered by this TextComponent.
const String & | getFont () const
Return the name of the font to be used when rendering this TextComponent.
void | setFont (const String &font)
Set the name of the font to be used when rendering this TextComponent.
VerticalTextFormatting | getVerticalFormatting () const
Return the current vertical formatting setting for this TextComponent.
void | setVerticalFormatting (VerticalTextFormatting fmt)
Set the vertical formatting setting for this TextComponent.
HorizontalTextFormatting | getHorizontalFormatting () const
Return the current horizontal formatting setting for this TextComponent.
void | setHorizontalFormatting (HorizontalTextFormatting fmt)
Set the horizontal formatting setting for this TextComponent.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this TextComponent to out_stream.

Protected Member Functions

void | render_impl (Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const
Method to do main render caching work.

Detailed Description

Class that encapsulates information for a text component.

Member Function Documentation

const String & CEGUI::TextComponent::getFont ( ) const

Return the name of the font to be used when rendering this TextComponent.

Returns:
String object containing the name of a font, or "" if the window font is to be used.

HorizontalTextFormatting CEGUI::TextComponent::getHorizontalFormatting ( ) const

Return the current horizontal formatting setting for this TextComponent.

Returns:
One of the HorizontalTextFormatting enumerated values.

const String & CEGUI::TextComponent::getText ( ) const

Return the text object that will be rendered by this TextComponent.

Returns:
String object containing the text that will be rendered.

VerticalTextFormatting CEGUI::TextComponent::getVerticalFormatting ( ) const

Return the current vertical formatting setting for this TextComponent.

Returns:
One of the VerticalTextFormatting enumerated values.

void CEGUI::TextComponent::setFont ( const String & font )

Set the name of the font to be used when rendering this TextComponent.

Note that setting this to the empty string ("") will cause the font from the base window passed when rendering to be used instead.

Parameters:
font String containing name of a font
Returns:
Nothing.

void CEGUI::TextComponent::setHorizontalFormatting ( HorizontalTextFormatting fmt )

Set the horizontal formatting setting for this TextComponent.

Parameters:
fmt One of the HorizontalTextFormatting enumerated values.
Returns:
Nothing.

void CEGUI::TextComponent::setText ( const String & text )

Set the text that will be rendered by this TextComponent.

Note that setting this to the empty string ("") will cause the text from the base window passed when rendering to be used instead.

Parameters:
text String containing text to render, or "" to render text from window.
Returns:
Nothing.

void CEGUI::TextComponent::setVerticalFormatting ( VerticalTextFormatting fmt )

Set the vertical formatting setting for this TextComponent.

Parameters:
fmt One of the VerticalTextFormatting enumerated values.
Returns:
Nothing.

void CEGUI::TextComponent::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this TextComponent to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TextItemProperties::TextFormatting Class Reference

CEGUI::TextItemProperties::TextFormatting

CEGUI::TextItemProperties::TextFormatting Class Reference

Property to access the horizontal formatting mode setting. More...

Inheritance diagram for CEGUI::TextItemProperties::TextFormatting:

[legend]
Collaboration diagram for CEGUI::TextItemProperties::TextFormatting:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the horizontal formatting mode setting.

Usage:
  • Name: TextFormatting
  • Format: "[text]".
Where [text] is one of:
  • "LeftAligned"
  • "RightAligned"
  • "HorzCentred"
  • "HorzJustified"
  • "WordWrapLeftAligned"
  • "WordWrapRightAligned"
  • "WordWrapCentred"
  • "WordWrapJustified"

Member Function Documentation

String CEGUI::TextItemProperties::TextFormatting::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TextItemProperties::TextFormatting::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SpinnerProperties::TextInputMode Class Reference

CEGUI::SpinnerProperties::TextInputMode

CEGUI::SpinnerProperties::TextInputMode Class Reference

Property to access the TextInputMode setting. More...

Inheritance diagram for CEGUI::SpinnerProperties::TextInputMode:

[legend]
Collaboration diagram for CEGUI::SpinnerProperties::TextInputMode:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the TextInputMode setting.

This property offers access the text display and input mode for the spinner.

Usage:
  • Name: TextInputMode
  • Format: "[text]".
Where [text] is:
  • "FloatingPoint" for floating point decimal numbers.
  • "Integer" for integer decimal numbers.
  • "Hexadecimal" for hexadecimal numbers.
  • "Octal" for octal numbers.

Member Function Documentation

String CEGUI::SpinnerProperties::TextInputMode::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::SpinnerProperties::TextInputMode::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TextItem Class Reference

CEGUI::TextItem

CEGUI::TextItem Class Reference

Base class for all the TextItem widgets. More...

Inheritance diagram for CEGUI::TextItem:

[legend]
Collaboration diagram for CEGUI::TextItem:

[legend]
List of all members.

Public Member Functions

TextFormatting | getTextFormatting () const
Return the TextFormatting currently used for rendering the text.
float | getTextXOffset (void) const
get the offset that is used to shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered
colour | getTextColour (void) const
Get the current text colour of the item.
void | setTextFormatting (TextFormatting format)
Set the TextFormatting to be used when rendering the text.
void | setTextColour (const colour &col)
Set the current text colour of the item.
void | setTextXOffset (float offset)
Set the offset to use for a shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered.
virtual Size | getItemPixelSize (void)
Return the "optimal" size for the item.
TextItem (const String &type, const String &name)
Constructor for TextItem objects.
virtual | ~TextItem (void)
Destructor for TextItem objects.

Static Public Attributes

static const colour | DefaultTextColour = 0xFFFFFFFF
Default colour used when rendering text.

Protected Member Functions

virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | populateRenderCache ()
Update the rendering cache.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

colour d_textColour
the current text colour
TextFormatting d_textFormatting
the current text formatting
float | d_textXOffset
offset applied to the x co-ordinate of the text rendered.

Detailed Description

Base class for all the TextItem widgets.

Member Function Documentation

Size CEGUI::TextItem::getItemPixelSize ( void ) [virtual]

Return the "optimal" size for the item.

Returns:
Size describing the size in pixel that this TextItem's content requires for non-clipped rendering

Implements CEGUI::ItemEntry.

colour CEGUI::TextItem::getTextColour ( void ) const [inline]

Get the current text colour of the item.

Returns:
The current text colour.

TextFormatting CEGUI::TextItem::getTextFormatting ( ) const [inline]

Return the TextFormatting currently used for rendering the text.

Returns:
TextFormatting value describing the currently used text formatting option.

float CEGUI::TextItem::getTextXOffset ( void ) const [inline]

get the offset that is used to shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered

Returns:
the offset in pixels

void CEGUI::TextItem::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::TextItem::populateRenderCache ( ) [protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented from CEGUI::Window.

void CEGUI::TextItem::setTextColour ( const colour & col ) [inline]

Set the current text colour of the item.

Parameters:
col The colour to set as the current text colour.

void CEGUI::TextItem::setTextXOffset ( float offset ) [inline]

Set the offset to use for a shift of the text in the x-direction this is useful if the button-images are not symmetrical and the text shouldn't be completely centered.

Parameters:
offset The offset to use - in pixels.
Returns:
Nothing.

virtual bool CEGUI::TextItem::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::ItemEntry.

Reimplemented in CEGUI::MenuItem.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Texture Class Reference

CEGUI::Texture

CEGUI::Texture Class Reference

Abstract base class specifying the required interface for Texture objects. More...

Inheritance diagram for CEGUI::Texture:

[legend]
Collaboration diagram for CEGUI::Texture:

[legend]
List of all members.

Public Member Functions

virtual ushort | getWidth (void) const =0
Returns the current pixel width of the texture.
virtual ushort | getHeight (void) const =0
Returns the current pixel height of the texture.
virtual void | loadFromFile (const String &filename, const String &resourceGroup)=0
Loads the specified image file into the texture. The texture is resized as required to hold the image.
virtual void | loadFromMemory (const void *buffPtr, uint buffWidth, uint buffHeight)=0
Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.
Renderer * | getRenderer (void) const
Return a pointer to the Renderer object that created and owns this Texture.
virtual | ~Texture (void)
Destructor for Texture base class. This is never called by client code.

Protected Member Functions

Texture (Renderer *owner)
Constructor for Texture base class. This is never called by client code.

Detailed Description

Abstract base class specifying the required interface for Texture objects.

Texture objects are created via the Renderer. The actual inner workings of any Texture object are dependant upon the Renderer (and underlying API) in use. This base class defines the minimal set of functions that is required for the rest of the system to work. Texture objects are only created through the Renderer object's texture creation functions.

Member Function Documentation

virtual ushort CEGUI::Texture::getHeight ( void ) const [pure virtual]

Returns the current pixel height of the texture.

Returns:
ushort value that is the current height of the texture in pixels

Implemented in CEGUI::DirectX81Texture, CEGUI::DirectX9Texture, and CEGUI::OpenGLTexture.

Renderer* CEGUI::Texture::getRenderer ( void ) const [inline]

Return a pointer to the Renderer object that created and owns this Texture.

Returns:
Pointer to the Renderer object that owns the Texture

virtual ushort CEGUI::Texture::getWidth ( void ) const [pure virtual]

Returns the current pixel width of the texture.

Returns:
ushort value that is the current width of the texture in pixels

Implemented in CEGUI::DirectX81Texture, CEGUI::DirectX9Texture, and CEGUI::OpenGLTexture.

virtual void CEGUI::Texture::loadFromFile | ( | const String & | filename,
 |  | const String & | resourceGroup
 | ) | [pure virtual]

Loads the specified image file into the texture. The texture is resized as required to hold the image.

Parameters:
filename | The filename of the image file that is to be loaded into the texture
resourceGroup | Resource group identifier to be passed to the resource provider when loading the image file.
Returns:
Nothing.

Implemented in CEGUI::DirectX81Texture, CEGUI::DirectX9Texture, and CEGUI::OpenGLTexture.

virtual void CEGUI::Texture::loadFromMemory | ( | const void * | buffPtr,
 |  | uint | buffWidth,
 |  | uint | buffHeight
 | ) | [pure virtual]

Loads (copies) an image in memory into the texture. The texture is resized as required to hold the image.

Parameters:
buffPtr | Pointer to the buffer containing the image data
buffWidth | Width of the buffer (in 0xAARRGGBB pixels)
buffHeight | Height of the buffer (in 0xAARRGGBB pixels)
Returns:
Nothing.

Implemented in CEGUI::DirectX81Texture, CEGUI::DirectX9Texture, and CEGUI::OpenGLTexture.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TextUtils Class Reference

CEGUI::TextUtils

CEGUI::TextUtils Class Reference

Text utility support class. This class is all static members. You do not create instances of this class. More...

Collaboration diagram for CEGUI::TextUtils:

[legend]
List of all members.

Static Public Member Functions

static String | getNextWord (const String &str, String::size_type start_idx=0, const String &delimiters=DefaultWhitespace)
return a String containing the the next word in a String.
static String::size_type | getWordStartIdx (const String &str, String::size_type idx)
Return the index of the first character of the word at idx.
static String::size_type | getNextWordStartIdx (const String &str, String::size_type idx)
Return the index of the first character of the word after the word at idx.
static void | trimLeadingChars (String &str, const String &chars)
Trim all characters from the set specified in chars from the begining of str.
static void | trimTrailingChars (String &str, const String &chars)
Trim all characters from the set specified in chars from the end of str.

Static Public Attributes

static const String | DefaultWhitespace = (utf8*)" \n\t\r"
The default set of whitespace.
static const String | DefaultAlphanumerical = (utf8*)"abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ1234567890"
default set of alphanumericals.
static const String | DefaultWrapDelimiters = (utf8*)" \n\t\r"
The default set of word-wrap delimiters.

Detailed Description

Text utility support class. This class is all static members. You do not create instances of this class.

Member Function Documentation

String CEGUI::TextUtils::getNextWord | ( | const String & | str,
 |  | String::size_type | start_idx = 0,
 |  | const String & | delimiters = DefaultWhitespace
 | ) | [static]

return a String containing the the next word in a String.

This method returns a String object containing the the word, starting at index start_idx, of String str as delimited by the code points specified in string delimiters (or the ends of the input string).

Parameters:
str | String object containing the input data.
start_idx | index into str where the search for the next word is to begin. Defaults to start of str.
delimiters | String object containing the set of delimiter code points to be used when determining the start and end points of a word in string str. Defaults to whitespace.
Returns:
String object containing the next delimiters delimited word from str, starting at index start_idx.

String::size_type CEGUI::TextUtils::getNextWordStartIdx | ( | const String & | str,
 |  | String::size_type | idx
 | ) | [static]

Return the index of the first character of the word after the word at idx.

/note This currently uses DefaultWhitespace and DefaultAlphanumerical to determine groupings for what constitutes a 'word'.

Parameters:
str | String containing text.
idx | Index into str where search is to begin.
Returns:
Index into str which marks the begining of the word at after the word at index idx. If idx is within the last word, then the return is the last index in str.

String::size_type CEGUI::TextUtils::getWordStartIdx | ( | const String & | str,
 |  | String::size_type | idx
 | ) | [static]

Return the index of the first character of the word at idx.

/note This currently uses DefaultWhitespace and DefaultAlphanumerical to determine groupings for what constitutes a 'word'.

Parameters:
str | String containing text.
idx | Index into str where search for start of word is to begin.
Returns:
Index into str which marks the begining of the word at index idx.

void CEGUI::TextUtils::trimLeadingChars | ( | String & | str,
 |  | const String & | chars
 | ) | [static]

Trim all characters from the set specified in chars from the begining of str.

Parameters:
str | String object to be trimmed.
chars | String object containing the set of code points to be trimmed.

void CEGUI::TextUtils::trimTrailingChars | ( | String & | str,
 |  | const String & | chars
 | ) | [static]

Trim all characters from the set specified in chars from the end of str.

Parameters:
str | String object to be trimmed.
chars | String object containing the set of code points to be trimmed.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties::TextXOffset Class Reference

CEGUI::PushButtonProperties::TextXOffset

CEGUI::PushButtonProperties::TextXOffset Class Reference

Property to access an offset that is used to shift the text in the x-direction. More...

Inheritance diagram for CEGUI::PushButtonProperties::TextXOffset:

[legend]
Collaboration diagram for CEGUI::PushButtonProperties::TextXOffset:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access an offset that is used to shift the text in the x-direction.

Usage:
  • Name: UseStandardImagery
  • Format: "<xoffset>".
where <xoffset> is a float value specifying the offset relative to the button-size

Member Function Documentation

String CEGUI::PushButtonProperties::TextXOffset::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PushButtonProperties::TextXOffset::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TextItemProperties::TextXOffset Class Reference

CEGUI::TextItemProperties::TextXOffset

CEGUI::TextItemProperties::TextXOffset Class Reference

Property to access the X offset of the text on the item. More...

Inheritance diagram for CEGUI::TextItemProperties::TextXOffset:

[legend]
Collaboration diagram for CEGUI::TextItemProperties::TextXOffset:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the X offset of the text on the item.

Usage:
  • Name: TextXOffset
  • Format: "[float]".
Where:
  • [float] represents the X offset of the text on the item.

Member Function Documentation

String CEGUI::TextItemProperties::TextXOffset::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::TextItemProperties::TextXOffset::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Thumb Class Reference

CEGUI::Thumb

CEGUI::Thumb Class Reference

Base class for Thumb widget. More...

Inheritance diagram for CEGUI::Thumb:

[legend]
Collaboration diagram for CEGUI::Thumb:

[legend]
List of all members.

Public Member Functions

bool | isHotTracked (void) const
return whether hot-tracking is enabled or not.
bool | isVertFree (void) const
return whether the thumb is movable on the vertical axis.
bool | isHorzFree (void) const
return whether the thumb is movable on the horizontal axis.
std::pair< float, float > | getVertRange (void) const
Return a std::pair that describes the current range set for the vertical movement.
std::pair< float, float > | getHorzRange (void) const
Return a std::pair that describes the current range set for the horizontal movement.
void | setHotTracked (bool setting)
set whether the thumb uses hot-tracking.
void | setVertFree (bool setting)
set whether thumb is movable on the vertical axis.
void | setHorzFree (bool setting)
set whether thumb is movable on the horizontal axis.
void | setVertRange (float min, float max)
set the movement range of the thumb for the vertical axis.
void | setHorzRange (float min, float max)
set the movement range of the thumb for the horizontal axis.
Thumb (const String &type, const String &name)
Constructor for Thumb objects.
virtual | ~Thumb (void)
Destructor for Thumb objects.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventThumbPositionChanged
The position of the thumb widget has changed.
static const String | EventThumbTrackStarted
Name of the event fired when the user begins dragging the thumb.
static const String | EventThumbTrackEnded
Name of the event fired when the user releases the thumb.

Protected Member Functions

void | addThumbEvents (void)
Add thumb specific events.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual void | onThumbPositionChanged (WindowEventArgs &e)
event triggered internally when the position of the thumb
virtual void | onThumbTrackStarted (WindowEventArgs &e)
Handler triggered when the user begins to drag the thumb.
virtual void | onThumbTrackEnded (WindowEventArgs &e)
Handler triggered when the thumb is released.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.

Protected Attributes

bool | d_hotTrack
true if events are to be sent real-time, else just when thumb is released
bool | d_vertFree
true if thumb is movable vertically
bool | d_horzFree
true if thumb is movable horizontally
float | d_vertMin
float | d_vertMax
vertical range
float | d_horzMin
float | d_horzMax
horizontal range
bool | d_beingDragged
true if thumb is being dragged
Point d_dragPoint
point where we are being dragged at.

Detailed Description

Base class for Thumb widget.

The thumb widget is used to compose other widgets (like sliders and scroll bars). You would not normally need to use this widget directly unless you are making a new widget of some type.

Member Function Documentation

std::pair< float, float > CEGUI::Thumb::getHorzRange ( void ) const

Return a std::pair that describes the current range set for the horizontal movement.

Returns:
a std::pair describing the current horizontal range. The first element is the minimum value, the second element is the maximum value.

std::pair< float, float > CEGUI::Thumb::getVertRange ( void ) const

Return a std::pair that describes the current range set for the vertical movement.

Returns:
a std::pair describing the current vertical range. The first element is the minimum value, the second element is the maximum value.

bool CEGUI::Thumb::isHorzFree ( void ) const [inline]

return whether the thumb is movable on the horizontal axis.

Returns:
true if the thumb is movable along the horizontal axis. false if the thumb is fixed on the horizontal axis.

bool CEGUI::Thumb::isHotTracked ( void ) const [inline]

return whether hot-tracking is enabled or not.

Returns:
true if hot-tracking is enabled. false if hot-tracking is disabled.

bool CEGUI::Thumb::isVertFree ( void ) const [inline]

return whether the thumb is movable on the vertical axis.

Returns:
true if the thumb is movable along the vertical axis. false if the thumb is fixed on the vertical axis.

void CEGUI::Thumb::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::ButtonBase.

void CEGUI::Thumb::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::ButtonBase.

void CEGUI::Thumb::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::ButtonBase.

void CEGUI::Thumb::setHorzFree ( bool setting ) [inline]

set whether thumb is movable on the horizontal axis.

Parameters:
setting true to allow movement of thumb along the horizontal axis. false to fix thumb on the horizontal axis.
Returns:
nothing.

void CEGUI::Thumb::setHorzRange | ( | float | min,
 |  | float | max
 | ) |

set the movement range of the thumb for the horizontal axis.

The values specified here are relative to the parent window for the thumb, and are specified in whichever metrics mode is active for the widget.

Parameters:
min | the minimum setting for the thumb on the horizontal axis.
max | the maximum setting for the thumb on the horizontal axis.
Returns:
Nothing.

void CEGUI::Thumb::setHotTracked ( bool setting ) [inline]

set whether the thumb uses hot-tracking.

Parameters:
setting true to enable hot-tracking. false to disable hot-tracking.
Returns:
Nothing.

void CEGUI::Thumb::setVertFree ( bool setting ) [inline]

set whether thumb is movable on the vertical axis.

Parameters:
setting true to allow movement of thumb along the vertical axis. false to fix thumb on the vertical axis.
Returns:
nothing.

void CEGUI::Thumb::setVertRange | ( | float | min,
 |  | float | max
 | ) |

set the movement range of the thumb for the vertical axis.

The values specified here are relative to the parent window for the thumb, and are specified in whichever metrics mode is active for the widget.

Parameters:
min | the minimum setting for the thumb on the vertical axis.
max | the maximum setting for the thumb on the vertical axis.
Returns:
Nothing.

virtual bool CEGUI::Thumb::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::PushButton.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TinyXMLParser Class Reference

CEGUI::TinyXMLParser

CEGUI::TinyXMLParser Class Reference

Implementation of XMLParser using TinyXML. More...

Inheritance diagram for CEGUI::TinyXMLParser:

[legend]
Collaboration diagram for CEGUI::TinyXMLParser:

[legend]
List of all members.

Public Member Functions

void | parseXMLFile (XMLHandler &handler, const String &filename, const String &schemaName, const String &resourceGroup)
abstract method which initiates parsing of an XML file.

Protected Member Functions

bool | initialiseImpl (void)
abstract method which initialises the XMLParser ready for use.
void | cleanupImpl (void)
abstract method which cleans up the XMLParser after use.

Detailed Description

Implementation of XMLParser using TinyXML.

Member Function Documentation

void CEGUI::TinyXMLParser::cleanupImpl ( void ) [protected, virtual]

abstract method which cleans up the XMLParser after use.

Returns:
Nothing.

Implements CEGUI::XMLParser.

bool CEGUI::TinyXMLParser::initialiseImpl ( void ) [protected, virtual]

abstract method which initialises the XMLParser ready for use.

Returns:
  • true if the module initialised successfully.
  • false if the module initialisation failed.

Implements CEGUI::XMLParser.

void CEGUI::TinyXMLParser::parseXMLFile | ( | XMLHandler & | handler,
 |  | const String & | filename,
 |  | const String & | schemaName,
 |  | const String & | resourceGroup
 | ) | [virtual]

abstract method which initiates parsing of an XML file.

Parameters:
handler | XMLHandler based object which will process the XML elements.
filename | String object holding the filename of the XML file to be parsed.
schemaName | String object holding the name of the XML schema file to use for validating the XML. Note that whether this is used or not is dependant upon the XMLParser in use.
resourceGroup | String object holding the resource group identifier which will be passed to the ResourceProvider when loading the XML and schema files.
Returns:
Nothing.

Implements CEGUI::XMLParser.

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Titlebar Class Reference

CEGUI::Titlebar

CEGUI::Titlebar Class Reference

Class representing the title bar for Frame Windows. More...

Inheritance diagram for CEGUI::Titlebar:

[legend]
Collaboration diagram for CEGUI::Titlebar:

[legend]
List of all members.

Public Member Functions

bool | isDraggingEnabled (void) const
Return whether this title bar will respond to dragging.
void | setDraggingEnabled (bool setting)
Set whether this title bar widget will respond to dragging.
colour | getCaptionColour (void) const
Return the current colour used for rendering the caption text.
void | setCaptionColour (const colour &col)
Sets the colour to be used for rendering the caption text.
Titlebar (const String &type, const String &name)
Constructor for Titlebar base class.
virtual | ~Titlebar (void)
Destructor for Titlebar base class.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.

Protected Member Functions

virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onMouseDoubleClicked (MouseEventArgs &e)
Handler called when a mouse button has been double-clicked within this window's area.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onFontChanged (WindowEventArgs &e)
Handler called when the window's font is changed.
virtual void | onDraggingModeChanged (WindowEventArgs &e)
Event handler called when the 'draggable' state for the title bar is changed.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Protected Attributes

bool | d_dragging
set to true when the window is being dragged.
Point d_dragPoint
Point at which we are being dragged.
bool | d_dragEnabled
true when dragging for the widget is enabled.
Rect d_oldCursorArea
Used to backup cursor restraint area.
colour d_captionColour
Colour used when rendering the title caption.

Detailed Description

Class representing the title bar for Frame Windows.

Member Function Documentation

colour CEGUI::Titlebar::getCaptionColour ( void ) const

Return the current colour used for rendering the caption text.

Returns:
colour value that specifies the colour used when rendering the title bar caption text.

bool CEGUI::Titlebar::isDraggingEnabled ( void ) const

Return whether this title bar will respond to dragging.

Returns:
true if the title bar will respond to dragging, false if the title bar will not respond.

void CEGUI::Titlebar::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

virtual void CEGUI::Titlebar::onDraggingModeChanged ( WindowEventArgs & e ) [inline, protected, virtual]

Event handler called when the 'draggable' state for the title bar is changed.

Note that this is for 'internal' use at the moment and as such does not add or fire a public Event that can be subscribed to.

void CEGUI::Titlebar::onFontChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's font is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Titlebar::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Titlebar::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Titlebar::onMouseDoubleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been double-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Titlebar::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Titlebar::setCaptionColour ( const colour & col )

Sets the colour to be used for rendering the caption text.

Parameters:
col colour value that specifies the colour to be used when rendering the title bar caption text.
Returns:
Nothing.

void CEGUI::Titlebar::setDraggingEnabled ( bool setting )

Set whether this title bar widget will respond to dragging.

Parameters:
setting true if the title bar should respond to being dragged, false if it should not respond.
Returns:
Nothing.

virtual bool CEGUI::Titlebar::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::TitlebarEnabled Class Reference

CEGUI::FrameWindowProperties::TitlebarEnabled

CEGUI::FrameWindowProperties::TitlebarEnabled Class Reference

Property to access the setting for whether the window title-bar will be enabled (or displayed depending upon choice of final widget type). More...

Inheritance diagram for CEGUI::FrameWindowProperties::TitlebarEnabled:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::TitlebarEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for whether the window title-bar will be enabled (or displayed depending upon choice of final widget type).

Usage:
  • Name: TitlebarEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the windows title bar should be enabled (and/or visible)
  • "False" to indicate the windows title bar should be disabled (and/or hidden)

Member Function Documentation

String CEGUI::FrameWindowProperties::TitlebarEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::TitlebarEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties::TitlebarFont Class Reference

CEGUI::FrameWindowProperties::TitlebarFont

CEGUI::FrameWindowProperties::TitlebarFont Class Reference

Property to access the Font set for the windows title bar. More...

Inheritance diagram for CEGUI::FrameWindowProperties::TitlebarFont:

[legend]
Collaboration diagram for CEGUI::FrameWindowProperties::TitlebarFont:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the Font set for the windows title bar.

Usage:
  • Name: TitlebarFont
  • Format: "[text]".
Where:
  • [text] is the name of the Font to assign for this windows title bar. The Font specified must already be loaded.

Member Function Documentation

String CEGUI::FrameWindowProperties::TitlebarFont::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::FrameWindowProperties::TitlebarFont::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlAttribute Class Reference

TiXmlAttribute Class Reference

Inheritance diagram for TiXmlAttribute:

[legend]
Collaboration diagram for TiXmlAttribute:

[legend]
List of all members.

Public Member Functions

TiXmlAttribute ()
Construct an empty attribute.
TiXmlAttribute (const char *_name, const char *_value)
Construct an attribute with a name and value.
const char * | Name () const
Return the name of this attribute.
const char * | Value () const
Return the value of this attribute.
const int | IntValue () const
Return the value of this attribute, converted to an integer.
const double | DoubleValue () const
Return the value of this attribute, converted to a double.
int | QueryIntValue (int *value) const
int | QueryDoubleValue (double *value) const
QueryDoubleValue examines the value string. See QueryIntValue().
void | SetName (const char *_name)
Set the name of this attribute.
void | SetValue (const char *_value)
Set the value.
void | SetIntValue (int value)
Set the value from an integer.
void | SetDoubleValue (double value)
Set the value from a double.
const TiXmlAttribute * | Next () const
Get the next sibling attribute in the DOM. Returns null at end.
TiXmlAttribute * | Next ()
const TiXmlAttribute * | Previous () const
Get the previous sibling attribute in the DOM. Returns null at beginning.
TiXmlAttribute * | Previous ()
bool | operator== (const TiXmlAttribute &rhs) const
bool | operator< (const TiXmlAttribute &rhs) const
bool | operator> (const TiXmlAttribute &rhs) const
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)
virtual void | Print (FILE *cfile, int depth) const
virtual void | StreamOut (TIXML_OSTREAM *out) const
void | SetDocument (TiXmlDocument *doc)

Friends

class | TiXmlAttributeSet

Detailed Description

An attribute is a name-value pair. Elements have an arbitrary number of attributes, each with a unique name.

Note:
The attributes are not TiXmlNodes, since they are not part of the tinyXML document object model. There are other suggested ways to look at this problem.

Member Function Documentation

void TiXmlAttribute::Print | ( | FILE * | cfile,
 |  | int | depth
 | ) | const [virtual]

All TinyXml classes can print themselves to a filestream. This is a formatted print, and will insert tabs and newlines.

(For an unformatted stream, use the << operator.)

Implements TiXmlBase.

int TiXmlAttribute::QueryIntValue ( int * value ) const

QueryIntValue examines the value string. It is an alternative to the IntValue() method with richer error checking. If the value is an integer, it is stored in 'value' and the call returns TIXML_SUCCESS. If it is not an integer, it returns TIXML_WRONG_TYPE.

A specialized but useful call. Note that for success it returns 0, which is the opposite of almost all other TinyXml calls.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlBase Class Reference

TiXmlBase Class Reference

Inheritance diagram for TiXmlBase:

[legend]
List of all members.

Public Types

enum {
TIXML_NO_ERROR = 0, TIXML_ERROR, TIXML_ERROR_OPENING_FILE, TIXML_ERROR_OUT_OF_MEMORY,
TIXML_ERROR_PARSING_ELEMENT, TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME, TIXML_ERROR_READING_ELEMENT_VALUE, TIXML_ERROR_READING_ATTRIBUTES,
TIXML_ERROR_PARSING_EMPTY, TIXML_ERROR_READING_END_TAG, TIXML_ERROR_PARSING_UNKNOWN, TIXML_ERROR_PARSING_COMMENT,
TIXML_ERROR_PARSING_DECLARATION, TIXML_ERROR_DOCUMENT_EMPTY, TIXML_ERROR_EMBEDDED_NULL, TIXML_ERROR_STRING_COUNT
}

Public Member Functions

virtual void | Print (FILE *cfile, int depth) const =0
int | Row () const
int | Column () const
See Row().
void | SetUserData (void *user)
void * | GetUserData ()
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)=0

Static Public Member Functions

static void | SetCondenseWhiteSpace (bool condense)
static bool | IsWhiteSpaceCondensed ()
Return the current white space setting.

Static Public Attributes

static const int | utf8ByteTable [256]

Protected Member Functions

virtual void | StreamOut (TIXML_OSTREAM *) const =0

Static Protected Member Functions

static const char * | SkipWhiteSpace (const char *, TiXmlEncoding encoding)
static bool | IsWhiteSpace (char c)
static const char * | ReadName (const char *p, TIXML_STRING *name, TiXmlEncoding encoding)
static const char * | ReadText (const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding)
static const char * | GetEntity (const char *in, char *value, int *length, TiXmlEncoding encoding)
static const char * | GetChar (const char *p, char *_value, int *length, TiXmlEncoding encoding)
static void | PutString (const TIXML_STRING &str, TIXML_OSTREAM *out)
static void | PutString (const TIXML_STRING &str, TIXML_STRING *out)
static bool | StringEqual (const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding)
static int | IsAlpha (unsigned char anyByte, TiXmlEncoding encoding)
static int | IsAlphaNum (unsigned char anyByte, TiXmlEncoding encoding)
static int | ToLower (int v, TiXmlEncoding encoding)
static void | ConvertUTF32ToUTF8 (unsigned long input, char *output, int *length)

Protected Attributes

TiXmlCursor | location
void * | userData
Field containing a generic user pointer.

Static Protected Attributes

static const char * | errorString [TIXML_ERROR_STRING_COUNT]

Friends

class | TiXmlNode
class | TiXmlElement
class | TiXmlDocument

Classes

struct | Entity
class | StringToBuffer

Detailed Description

TiXmlBase is a base class for every class in TinyXml. It does little except to establish that TinyXml classes can be printed and provide some utility functions.

In XML, the document and elements can contain other elements and other types of nodes.

    A Document can contain:	Element	(container or leaf)
                            Comment (leaf)
                            Unknown (leaf)
                            Declaration( leaf )

    An Element can contain:	Element (container or leaf)
                            Text	(leaf)
                            Attributes (not on tree)
                            Comment (leaf)
                            Unknown (leaf)

    A Decleration contains: Attributes (not on tree)

Member Function Documentation

virtual void TiXmlBase::Print | ( | FILE * | cfile,
 |  | int | depth
 | ) | const [pure virtual]

All TinyXml classes can print themselves to a filestream. This is a formatted print, and will insert tabs and newlines.

(For an unformatted stream, use the << operator.)

Implemented in TiXmlAttribute, TiXmlElement, TiXmlComment, TiXmlText, TiXmlDeclaration, TiXmlUnknown, and TiXmlDocument.

int TiXmlBase::Row ( ) const [inline]

Return the position, in the original source file, of this node or attribute. The row and column are 1-based. (That is the first row and first column is 1,1). If the returns values are 0 or less, then the parser does not have a row and column value.

Generally, the row and column value will be set when the TiXmlDocument::Load(), TiXmlDocument::LoadFile(), or any TiXmlNode::Parse() is called. It will NOT be set when the DOM was created from operator>>.

The values reflect the initial load. Once the DOM is modified programmatically (by adding or changing nodes and attributes) the new values will NOT update to reflect changes in the document.

There is a minor performance cost to computing the row and column. Computation can be disabled if TiXmlDocument::SetTabSize() is called with 0 as the value.

See also:
TiXmlDocument::SetTabSize()

static void TiXmlBase::SetCondenseWhiteSpace ( bool condense ) [inline, static]

The world does not agree on whether white space should be kept or not. In order to make everyone happy, these global, static functions are provided to set whether or not TinyXml will condense all white space into a single space or not. The default is to condense. Note changing this values is not thread safe.

Member Data Documentation

const char * TiXmlBase::errorString [static, protected]

Initial value:

{
        "No error",
        "Error",
        "Failed to open file",
        "Memory allocation failed.",
        "Error parsing Element.",
        "Failed to read Element name",
        "Error reading Element value.",
        "Error reading Attributes.",
        "Error: empty tag.",
        "Error reading end tag.",
        "Error parsing Unknown.",
        "Error parsing Comment.",
        "Error parsing Declaration.",
        "Error document empty.",
        "Error null (0) or unexpected EOF found in input stream.",
}

const int TiXmlBase::utf8ByteTable [static]

Initial value:

{

                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,
                1,      1,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,
                2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,      2,
                3,      3,      3,      3,      3,      3,      3,      3,      3,      3,      3,      3,      3,      3,      3,      3,
                4,      4,      4,      4,      4,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1,      1
}

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlComment Class Reference

TiXmlComment Class Reference

Inheritance diagram for TiXmlComment:

[legend]
Collaboration diagram for TiXmlComment:

[legend]
List of all members.

Public Member Functions

TiXmlComment ()
Constructs an empty comment.
TiXmlComment (const TiXmlComment &)
void | operator= (const TiXmlComment &base)
virtual TiXmlNode * | Clone () const
Returns a copy of this Comment.
virtual void | Print (FILE *cfile, int depth) const
Write this Comment to a FILE stream.
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)

Protected Member Functions

void | CopyTo (TiXmlComment *target) const
virtual void | StreamOut (TIXML_OSTREAM *out) const

Detailed Description

An XML comment.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlDeclaration Class Reference

TiXmlDeclaration Class Reference

Inheritance diagram for TiXmlDeclaration:

[legend]
Collaboration diagram for TiXmlDeclaration:

[legend]
List of all members.

Public Member Functions

TiXmlDeclaration ()
Construct an empty declaration.
TiXmlDeclaration (const char *_version, const char *_encoding, const char *_standalone)
Construct.
TiXmlDeclaration (const TiXmlDeclaration &copy)
void | operator= (const TiXmlDeclaration &copy)
const char * | Version () const
Version. Will return an empty string if none was found.
const char * | Encoding () const
Encoding. Will return an empty string if none was found.
const char * | Standalone () const
Is this a standalone document?
virtual TiXmlNode * | Clone () const
Creates a copy of this Declaration and returns it.
virtual void | Print (FILE *cfile, int depth) const
Print this declaration to a FILE stream.
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)

Protected Member Functions

void | CopyTo (TiXmlDeclaration *target) const
virtual void | StreamOut (TIXML_OSTREAM *out) const

Detailed Description

In correct XML the declaration is the first entry in the file.
        <?xml version="1.0" standalone="yes"?>

TinyXml will happily read or write files without a declaration, however. There are 3 possible attributes to the declaration: version, encoding, and standalone.

Note: In this version of the code, the attributes are handled as special cases, not generic attributes, simply because there can only be at most 3 and they are always the same.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlDocument Class Reference

TiXmlDocument Class Reference

Inheritance diagram for TiXmlDocument:

[legend]
Collaboration diagram for TiXmlDocument:

[legend]
List of all members.

Public Member Functions

TiXmlDocument ()
Create an empty document, that has no name.
TiXmlDocument (const char *documentName)
Create a document with a name. The name of the document is also the filename of the xml.
TiXmlDocument (const TiXmlDocument &copy)
void | operator= (const TiXmlDocument &copy)
bool | LoadFile (TiXmlEncoding encoding=TIXML_DEFAULT_ENCODING)
bool | SaveFile () const
Save a file using the current document value. Returns true if successful.
bool | LoadFile (const char *filename, TiXmlEncoding encoding=TIXML_DEFAULT_ENCODING)
Load a file using the given filename. Returns true if successful.
bool | SaveFile (const char *filename) const
Save a file using the given filename. Returns true if successful.
virtual const char * | Parse (const char *p, TiXmlParsingData *data=0, TiXmlEncoding encoding=TIXML_DEFAULT_ENCODING)
const TiXmlElement * | RootElement () const
TiXmlElement * | RootElement ()
bool | Error () const
const char * | ErrorDesc () const
Contains a textual (english) description of the error if one occurs.
const int | ErrorId () const
int | ErrorRow ()
int | ErrorCol ()
The column where the error occured. See ErrorRow().
void | SetTabSize (int _tabsize)
int | TabSize () const
void | ClearError ()
void | Print () const
virtual void | Print (FILE *cfile, int depth=0) const
Print this Document to a FILE stream.
void | SetError (int err, const char *errorLocation, TiXmlParsingData *prevData, TiXmlEncoding encoding)

Protected Member Functions

virtual void | StreamOut (TIXML_OSTREAM *out) const
virtual TiXmlNode * | Clone () const

Detailed Description

Always the top level node. A document binds together all the XML pieces. It can be saved, loaded, and printed to the screen. The 'value' of a document node is the xml file name.

Member Function Documentation

void TiXmlDocument::ClearError ( ) [inline]

If you have handled the error, it can be reset with this call. The error state is automatically cleared if you Parse a new XML block.

TiXmlNode * TiXmlDocument::Clone ( ) const [protected, virtual]

Create an exact duplicate of this node and return it. The memory must be deleted by the caller.

Implements TiXmlNode.

bool TiXmlDocument::Error ( ) const [inline]

If an error occurs, Error will be set to true. Also,

  • The ErrorId() will contain the integer identifier of the error (not generally useful)
  • The ErrorDesc() method will return the name of the error. (very useful)
  • The ErrorRow() and ErrorCol() will return the location of the error (if known)

const int TiXmlDocument::ErrorId ( ) const [inline]

Generally, you probably want the error string ( ErrorDesc() ). But if you prefer the ErrorId, this function will fetch it.

int TiXmlDocument::ErrorRow ( ) [inline]

Returns the location (if known) of the error. The first column is column 1, and the first row is row 1. A value of 0 means the row and column wasn't applicable (memory errors, for example, have no row/column) or the parser lost the error. (An error in the error reporting, in that case.)

See also:
SetTabSize, Row, Column

bool TiXmlDocument::LoadFile ( TiXmlEncoding encoding = TIXML_DEFAULT_ENCODING )

Load a file using the current document value. Returns true if successful. Will delete any existing document data before loading.

const char * TiXmlDocument::Parse | ( | const char * | p,
 |  | TiXmlParsingData * | data = 0,
 |  | TiXmlEncoding | encoding = TIXML_DEFAULT_ENCODING
 | ) | [virtual]

Parse the given null terminated block of xml data. Passing in an encoding to this method (either TIXML_ENCODING_LEGACY or TIXML_ENCODING_UTF8 will force TinyXml to use that encoding, regardless of what TinyXml might otherwise try to detect.

Implements TiXmlBase.

void TiXmlDocument::Print ( ) const [inline]

Dump the document to standard out.

const TiXmlElement* TiXmlDocument::RootElement ( ) const [inline]

Get the root element -- the only top level element -- of the document. In well formed XML, there should only be one. TinyXml is tolerant of multiple elements at the document level.

void TiXmlDocument::SetTabSize ( int _tabsize ) [inline]

By calling this method, with a tab size greater than 0, the row and column of each node and attribute is stored when the file is loaded. Very useful for tracking the DOM back in to the source file.

The tab size is required for calculating the location of nodes. If not set, the default of 4 is used. The tabsize is set per document. Setting the tabsize to 0 disables row/column tracking.

Note that row and column tracking is not supported when using operator>>.

The tab size needs to be enabled before the parse or load. Correct usage:

        TiXmlDocument doc;
        doc.SetTabSize( 8 );
        doc.Load( "myfile.xml" );

See also:
Row, Column

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlElement Class Reference

TiXmlElement Class Reference

Inheritance diagram for TiXmlElement:

[legend]
Collaboration diagram for TiXmlElement:

[legend]
List of all members.

Public Member Functions

TiXmlElement (const char *in_value)
Construct an element.
TiXmlElement (const TiXmlElement &)
void | operator= (const TiXmlElement &base)
const char * | Attribute (const char *name) const
const char * | Attribute (const char *name, int *i) const
const char * | Attribute (const char *name, double *d) const
int | QueryIntAttribute (const char *name, int *value) const
int | QueryDoubleAttribute (const char *name, double *value) const
QueryDoubleAttribute examines the attribute - see QueryIntAttribute().
int | QueryDoubleAttribute (const char *name, float *value) const
QueryFloatAttribute examines the attribute - see QueryIntAttribute().
void | SetAttribute (const char *name, const char *value)
void | SetAttribute (const char *name, int value)
void | SetDoubleAttribute (const char *name, double value)
void | RemoveAttribute (const char *name)
const TiXmlAttribute * | FirstAttribute () const
Access the first attribute in this element.
TiXmlAttribute * | FirstAttribute ()
const TiXmlAttribute * | LastAttribute () const
Access the last attribute in this element.
TiXmlAttribute * | LastAttribute ()
virtual TiXmlNode * | Clone () const
Creates a new Element and returns it - the returned element is a copy.
virtual void | Print (FILE *cfile, int depth) const
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)

Protected Member Functions

void | CopyTo (TiXmlElement *target) const
void | ClearThis ()
virtual void | StreamOut (TIXML_OSTREAM *out) const
const char * | ReadValue (const char *in, TiXmlParsingData *prevData, TiXmlEncoding encoding)

Detailed Description

The element is a container class. It has a value, the element name, and can contain other elements, text, comments, and unknowns. Elements also contain an arbitrary number of attributes.

Member Function Documentation

const char * TiXmlElement::Attribute | ( | const char * | name,
 |  | double * | d
 | ) | const

Given an attribute name, Attribute() returns the value for the attribute of that name, or null if none exists. If the attribute exists and can be converted to an double, the double value will be put in the return 'd', if 'd' is non-null.

const char * TiXmlElement::Attribute | ( | const char * | name,
 |  | int * | i
 | ) | const

Given an attribute name, Attribute() returns the value for the attribute of that name, or null if none exists. If the attribute exists and can be converted to an integer, the integer value will be put in the return 'i', if 'i' is non-null.

const char * TiXmlElement::Attribute ( const char * name ) const

Given an attribute name, Attribute() returns the value for the attribute of that name, or null if none exists.

void TiXmlElement::Print | ( | FILE * | cfile,
 |  | int | depth
 | ) | const [virtual]

All TinyXml classes can print themselves to a filestream. This is a formatted print, and will insert tabs and newlines.

(For an unformatted stream, use the << operator.)

Implements TiXmlBase.

int TiXmlElement::QueryIntAttribute | ( | const char * | name,
 |  | int * | value
 | ) | const

QueryIntAttribute examines the attribute - it is an alternative to the Attribute() method with richer error checking. If the attribute is an integer, it is stored in 'value' and the call returns TIXML_SUCCESS. If it is not an integer, it returns TIXML_WRONG_TYPE. If the attribute does not exist, then TIXML_NO_ATTRIBUTE is returned.

void TiXmlElement::RemoveAttribute ( const char * name )

Deletes an attribute with the given name.

void TiXmlElement::SetAttribute | ( | const char * | name,
 |  | int | value
 | ) |

Sets an attribute of name to a given value. The attribute will be created if it does not exist, or changed if it does.

void TiXmlElement::SetAttribute | ( | const char * | name,
 |  | const char * | value
 | ) |

Sets an attribute of name to a given value. The attribute will be created if it does not exist, or changed if it does.

void TiXmlElement::SetDoubleAttribute | ( | const char * | name,
 |  | double | value
 | ) |

Sets an attribute of name to a given value. The attribute will be created if it does not exist, or changed if it does.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlHandle Class Reference

TiXmlHandle Class Reference

Collaboration diagram for TiXmlHandle:

[legend]
List of all members.

Public Member Functions

TiXmlHandle (TiXmlNode *node)
Create a handle from any node (at any depth of the tree.) This can be a null pointer.
TiXmlHandle (const TiXmlHandle &ref)
Copy constructor.
TiXmlHandle | operator= (const TiXmlHandle &ref)
TiXmlHandle | FirstChild () const
Return a handle to the first child node.
TiXmlHandle | FirstChild (const char *value) const
Return a handle to the first child node with the given name.
TiXmlHandle | FirstChildElement () const
Return a handle to the first child element.
TiXmlHandle | FirstChildElement (const char *value) const
Return a handle to the first child element with the given name.
TiXmlHandle | Child (const char *value, int index) const
TiXmlHandle | Child (int index) const
TiXmlHandle | ChildElement (const char *value, int index) const
TiXmlHandle | ChildElement (int index) const
TiXmlNode * | Node () const
Return the handle as a TiXmlNode. This may return null.
TiXmlElement * | Element () const
Return the handle as a TiXmlElement. This may return null.
TiXmlText * | Text () const
Return the handle as a TiXmlText. This may return null.
TiXmlUnknown * | Unknown () const
Return the handle as a TiXmlUnknown. This may return null;.

Detailed Description

A TiXmlHandle is a class that wraps a node pointer with null checks; this is an incredibly useful thing. Note that TiXmlHandle is not part of the TinyXml DOM structure. It is a separate utility class.

Take an example:

    <Document>
        <Element attributeA = "valueA">
            <Child attributeB = "value1" />
            <Child attributeB = "value2" />
        </Element>
    <Document>

Assuming you want the value of "attributeB" in the 2nd "Child" element, it's very easy to write a *lot* of code that looks like:

    TiXmlElement* root = document.FirstChildElement( "Document" );
    if ( root )
    {
        TiXmlElement* element = root->FirstChildElement( "Element" );
        if ( element )
        {
            TiXmlElement* child = element->FirstChildElement( "Child" );
            if ( child )
            {
                TiXmlElement* child2 = child->NextSiblingElement( "Child" );
                if ( child2 )
                {
                    // Finally do something useful.

And that doesn't even cover "else" cases. TiXmlHandle addresses the verbosity of such code. A TiXmlHandle checks for null pointers so it is perfectly safe and correct to use:

    TiXmlHandle docHandle( &document );
    TiXmlElement* child2 = docHandle.FirstChild( "Document" ).FirstChild( "Element" ).Child( "Child", 1 ).Element();
    if ( child2 )
    {
        // do something useful

Which is MUCH more concise and useful.

It is also safe to copy handles - internally they are nothing more than node pointers.

    TiXmlHandle handleCopy = handle;

What they should not be used for is iteration:

    int i=0;
    while ( true )
    {
        TiXmlElement* child = docHandle.FirstChild( "Document" ).FirstChild( "Element" ).Child( "Child", i ).Element();
        if ( !child )
            break;
        // do something
        ++i;
    }

It seems reasonable, but it is in fact two embedded while loops. The Child method is a linear walk to find the element, so this code would iterate much more than it needs to. Instead, prefer:

    TiXmlElement* child = docHandle.FirstChild( "Document" ).FirstChild( "Element" ).FirstChild( "Child" ).Element();

    for( child; child; child=child->NextSiblingElement() )
    {
        // do something
    }

Member Function Documentation

TiXmlHandle TiXmlHandle::Child ( int index ) const

Return a handle to the "index" child. The first child is 0, the second 1, etc.

TiXmlHandle TiXmlHandle::Child | ( | const char * | value,
 |  | int | index
 | ) | const

Return a handle to the "index" child with the given name. The first child is 0, the second 1, etc.

TiXmlHandle TiXmlHandle::ChildElement ( int index ) const

Return a handle to the "index" child element. The first child element is 0, the second 1, etc. Note that only TiXmlElements are indexed: other types are not counted.

TiXmlHandle TiXmlHandle::ChildElement | ( | const char * | value,
 |  | int | index
 | ) | const

Return a handle to the "index" child element with the given name. The first child element is 0, the second 1, etc. Note that only TiXmlElements are indexed: other types are not counted.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlNode Class Reference

TiXmlNode Class Reference

Inheritance diagram for TiXmlNode:

[legend]
Collaboration diagram for TiXmlNode:

[legend]
List of all members.

Public Types

enum NodeType {
DOCUMENT, ELEMENT, COMMENT, UNKNOWN,
TEXT, DECLARATION, TYPECOUNT
}

Public Member Functions

const char * | Value () const
void | SetValue (const char *_value)
void | Clear ()
Delete all the children of this node. Does not affect 'this'.
TiXmlNode * Parent ()
One step up the DOM.
const TiXmlNode * | Parent () const
const TiXmlNode * | FirstChild () const
The first child of this node. Will be null if there are no children.
TiXmlNode * | FirstChild ()
const TiXmlNode * | FirstChild (const char *value) const
The first child of this node with the matching 'value'. Will be null if none found.
TiXmlNode * | FirstChild (const char *value)
The first child of this node with the matching 'value'. Will be null if none found.
const TiXmlNode * | LastChild () const
TiXmlNode * LastChild ()
The last child of this node. Will be null if there are no children.
const TiXmlNode * | LastChild (const char *value) const
TiXmlNode * | LastChild (const char *value)
The last child of this node matching 'value'. Will be null if there are no children.
const TiXmlNode * | IterateChildren (TiXmlNode *previous) const
TiXmlNode * | IterateChildren (TiXmlNode *previous)
const TiXmlNode * | IterateChildren (const char *value, TiXmlNode *previous) const
This flavor of IterateChildren searches for children with a particular 'value'.
TiXmlNode * | IterateChildren (const char *value, TiXmlNode *previous)
TiXmlNode * | InsertEndChild (const TiXmlNode &addThis)
TiXmlNode * | LinkEndChild (TiXmlNode *addThis)
TiXmlNode * | InsertBeforeChild (TiXmlNode *beforeThis, const TiXmlNode &addThis)
TiXmlNode * | InsertAfterChild (TiXmlNode *afterThis, const TiXmlNode &addThis)
TiXmlNode * | ReplaceChild (TiXmlNode *replaceThis, const TiXmlNode &withThis)
bool | RemoveChild (TiXmlNode *removeThis)
Delete a child of this node.
const TiXmlNode * | PreviousSibling () const
Navigate to a sibling node.
TiXmlNode * | PreviousSibling ()
const TiXmlNode * | PreviousSibling (const char *) const
Navigate to a sibling node.
TiXmlNode * | PreviousSibling (const char *)
const TiXmlNode * | NextSibling () const
Navigate to a sibling node.
TiXmlNode * | NextSibling ()
const TiXmlNode * | NextSibling (const char *) const
Navigate to a sibling node with the given 'value'.
TiXmlNode * | NextSibling (const char *)
const TiXmlElement * | NextSiblingElement () const
TiXmlElement * | NextSiblingElement ()
const TiXmlElement * | NextSiblingElement (const char *) const
TiXmlElement * | NextSiblingElement (const char *)
const TiXmlElement * | FirstChildElement () const
Convenience function to get through elements.
TiXmlElement * | FirstChildElement ()
const TiXmlElement * | FirstChildElement (const char *value) const
Convenience function to get through elements.
TiXmlElement * | FirstChildElement (const char *value)
virtual int | Type () const
const TiXmlDocument * | GetDocument () const
TiXmlDocument * | GetDocument ()
bool | NoChildren () const
Returns true if this node has no children.
const TiXmlDocument * | ToDocument () const
Cast to a more defined type. Will return null not of the requested type.
const TiXmlElement * | ToElement () const
Cast to a more defined type. Will return null not of the requested type.
const TiXmlComment * | ToComment () const
Cast to a more defined type. Will return null not of the requested type.
const TiXmlUnknown * | ToUnknown () const
Cast to a more defined type. Will return null not of the requested type.
const TiXmlText * | ToText () const
Cast to a more defined type. Will return null not of the requested type.
const TiXmlDeclaration * | ToDeclaration () const
Cast to a more defined type. Will return null not of the requested type.
TiXmlDocument * ToDocument ()
Cast to a more defined type. Will return null not of the requested type.
TiXmlElement * ToElement ()
Cast to a more defined type. Will return null not of the requested type.
TiXmlComment * ToComment ()
Cast to a more defined type. Will return null not of the requested type.
TiXmlUnknown * ToUnknown ()
Cast to a more defined type. Will return null not of the requested type.
TiXmlText * ToText ()
Cast to a more defined type. Will return null not of the requested type.
TiXmlDeclaration * ToDeclaration ()
Cast to a more defined type. Will return null not of the requested type.
virtual TiXmlNode * | Clone () const =0

Protected Member Functions

TiXmlNode (NodeType _type)
void | CopyTo (TiXmlNode *target) const
TiXmlNode * | Identify (const char *start, TiXmlEncoding encoding)
const TIXML_STRING & | SValue () const

Protected Attributes

TiXmlNode * | parent
NodeType | type
TiXmlNode * | firstChild
TiXmlNode * | lastChild
TIXML_STRING | value
TiXmlNode * | prev
TiXmlNode * | next

Friends

class | TiXmlDocument
class | TiXmlElement
TIXML_OSTREAM & | operator<< (TIXML_OSTREAM &out, const TiXmlNode &base)

Detailed Description

The parent class for everything in the Document Object Model. (Except for attributes). Nodes have siblings, a parent, and children. A node can be in a document, or stand on its own. The type of a TiXmlNode can be queried, and it can be cast to its more defined type.

Member Enumeration Documentation

enum TiXmlNode::NodeType

The types of XML nodes supported by TinyXml. (All the unsupported types are picked up by UNKNOWN.)

Member Function Documentation

virtual TiXmlNode* TiXmlNode::Clone ( ) const [pure virtual]

Create an exact duplicate of this node and return it. The memory must be deleted by the caller.

Implemented in TiXmlElement, TiXmlComment, TiXmlText, TiXmlDeclaration, TiXmlUnknown, and TiXmlDocument.

const TiXmlDocument * TiXmlNode::GetDocument ( ) const

Return a pointer to the Document this node lives in. Returns null if not in a document.

TiXmlNode * TiXmlNode::InsertAfterChild | ( | TiXmlNode * | afterThis,
 |  | const TiXmlNode & | addThis
 | ) |

Add a new node related to this. Adds a child after the specified child. Returns a pointer to the new object or NULL if an error occured.

TiXmlNode * TiXmlNode::InsertBeforeChild | ( | TiXmlNode * | beforeThis,
 |  | const TiXmlNode & | addThis
 | ) |

Add a new node related to this. Adds a child before the specified child. Returns a pointer to the new object or NULL if an error occured.

TiXmlNode * TiXmlNode::InsertEndChild ( const TiXmlNode & addThis )

Add a new node related to this. Adds a child past the LastChild. Returns a pointer to the new object or NULL if an error occured.

const TiXmlNode * TiXmlNode::IterateChildren ( TiXmlNode * previous ) const

An alternate way to walk the children of a node. One way to iterate over nodes is:

            for( child = parent->FirstChild(); child; child = child->NextSibling() )

IterateChildren does the same thing with the syntax:

            child = 0;
            while( child = parent->IterateChildren( child ) )

IterateChildren takes the previous child as input and finds the next one. If the previous child is null, it returns the first. IterateChildren will return null when done.

TiXmlNode * TiXmlNode::LinkEndChild ( TiXmlNode * addThis )

Add a new node related to this. Adds a child past the LastChild.

NOTE: the node to be added is passed by pointer, and will be henceforth owned (and deleted) by tinyXml. This method is efficient and avoids an extra copy, but should be used with care as it uses a different memory model than the other insert functions.

See also:
InsertEndChild

const TiXmlElement * TiXmlNode::NextSiblingElement ( const char * ) const

Convenience function to get through elements. Calls NextSibling and ToElement. Will skip all non-Element nodes. Returns 0 if there is not another element.

const TiXmlElement * TiXmlNode::NextSiblingElement ( ) const

Convenience function to get through elements. Calls NextSibling and ToElement. Will skip all non-Element nodes. Returns 0 if there is not another element.

TiXmlNode * TiXmlNode::ReplaceChild | ( | TiXmlNode * | replaceThis,
 |  | const TiXmlNode & | withThis
 | ) |

Replace a child of this node. Returns a pointer to the new object or NULL if an error occured.

void TiXmlNode::SetValue ( const char * _value ) [inline]

Changes the value of the node. Defined as:

        Document:	filename of the xml file
        Element:	name of the element
        Comment:	the comment text
        Unknown:	the tag contents
        Text:		the text string

virtual int TiXmlNode::Type ( ) const [inline, virtual]

Query the type (as an enumerated value, above) of this node. The possible types are: DOCUMENT, ELEMENT, COMMENT, UNKNOWN, TEXT, and DECLARATION.

const char* TiXmlNode::Value ( ) const [inline]

The meaning of 'value' changes for the specific type of TiXmlNode.

        Document:	filename of the xml file
        Element:	name of the element
        Comment:	the comment text
        Unknown:	the tag contents
        Text:		the text string

The subclasses will wrap this function.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlText Class Reference

TiXmlText Class Reference

Inheritance diagram for TiXmlText:

[legend]
Collaboration diagram for TiXmlText:

[legend]
List of all members.

Public Member Functions

TiXmlText (const char *initValue)
Constructor.
TiXmlText (const TiXmlText &copy)
void | operator= (const TiXmlText &base)
virtual void | Print (FILE *cfile, int depth) const
Write this text object to a FILE stream.
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)

Protected Member Functions

virtual TiXmlNode * | Clone () const
[internal use] Creates a new Element and returns it.
void | CopyTo (TiXmlText *target) const
virtual void | StreamOut (TIXML_OSTREAM *out) const
bool | Blank () const

Friends

class | TiXmlElement

Detailed Description

XML text. Contained in an element.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: TiXmlUnknown Class Reference

TiXmlUnknown Class Reference

Inheritance diagram for TiXmlUnknown:

[legend]
Collaboration diagram for TiXmlUnknown:

[legend]
List of all members.

Public Member Functions

TiXmlUnknown (const TiXmlUnknown &copy)
void | operator= (const TiXmlUnknown &copy)
virtual TiXmlNode * | Clone () const
Creates a copy of this Unknown and returns it.
virtual void | Print (FILE *cfile, int depth) const
Print this Unknown to a FILE stream.
virtual const char * | Parse (const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)

Protected Member Functions

void | CopyTo (TiXmlUnknown *target) const
virtual void | StreamOut (TIXML_OSTREAM *out) const

Detailed Description

Any tag that tinyXml doesn't recognize is saved as an unknown. It is a tag of text, but should not be modified. It will be written back to the XML, unchanged, when the file is saved.

DTD tags get thrown into TiXmlUnknowns.

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Tooltip Class Reference

CEGUI::WindowProperties::Tooltip

CEGUI::WindowProperties::Tooltip Class Reference

Property to access the tooltip text for this Window. More...

Inheritance diagram for CEGUI::WindowProperties::Tooltip:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Tooltip:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the tooltip text for this Window.

Usage:
  • Name: Tooltip
  • Format: "[text]".
Where:
  • [Text] is the tooltip text for this window.

Member Function Documentation

String CEGUI::WindowProperties::Tooltip::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Tooltip::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Tooltip Class Reference

CEGUI::Tooltip

CEGUI::Tooltip Class Reference

Base class for Tooltip widgets. More...

Inheritance diagram for CEGUI::Tooltip:

[legend]
Collaboration diagram for CEGUI::Tooltip:

[legend]
List of all members.

Public Member Functions

Tooltip (const String &type, const String &name)
Constructor for the Tooltip base class constructor.
~Tooltip (void)
Destructor for the Tooltip base class.
void | setTargetWindow (Window *wnd)
Sets the target window for the tooltip. This used internally to manage tooltips, you should not have to call this yourself.
const Window * | getTargetWindow ()
return the current target window for this Tooltip.
void | resetTimer (void)
Resets the timer on the tooltip when in the Active / Inactive states. This is used internally to control the tooltip, it is not normally necessary to call this method yourself.
float | getHoverTime (void) const
Return the number of seconds the mouse should hover stationary over the target window before the tooltip gets activated.
void | setDisplayTime (float seconds)
Set the number of seconds the tooltip should be displayed for before it automatically de-activates itself. 0 indicates that the tooltip should never timesout and auto-deactivate.
float | getFadeTime (void) const
Return the number of seconds that should be taken to fade the tooltip into and out of visibility.
void | setHoverTime (float seconds)
Set the number of seconds the mouse should hover stationary over the target window before the tooltip gets activated.
float | getDisplayTime (void) const
Return the number of seconds the tooltip should be displayed for before it automatically de-activates itself. 0 indicates that the tooltip never timesout and auto-deactivates.
void | setFadeTime (float seconds)
Set the number of seconds that should be taken to fade the tooltip into and out of visibility.
void | positionSelf (void)
Causes the tooltip to position itself appropriately.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventHoverTimeChanged
Event fired when the hover timeout gets changed.
static const String | EventDisplayTimeChanged
Event fired when the display timeout gets changed.
static const String | EventFadeTimeChanged
Event fired when the fade timeout gets changed.
static const String | EventTooltipActive
Event fired when the tooltip is about to get activated.
static const String | EventTooltipInactive
Event fired when the tooltip has been deactivated.

Protected Types

enum | TipState { Inactive, Active, FadeIn, FadeOut }
states for tooltip More...

Protected Member Functions

void | addTooltipEvents (void)
Add ScrollablePane specific events.
void | doActiveState (float elapsed)
void | doInactiveState (float elapsed)
void | doFadeInState (float elapsed)
void | doFadeOutState (float elapsed)
void | switchToInactiveState (void)
void | switchToActiveState (void)
void | switchToFadeInState (void)
void | switchToFadeOutState (void)
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
virtual Size | getTextSize () const
Return the size of the area that will be occupied by the tooltip text, given any current formatting options.
virtual void | onHoverTimeChanged (WindowEventArgs &e)
Event trigger method called when the hover timeout gets changed.
virtual void | onDisplayTimeChanged (WindowEventArgs &e)
Event trigger method called when the display timeout gets changed.
virtual void | onFadeTimeChanged (WindowEventArgs &e)
Event trigger method called when the fade timeout gets changed.
virtual void | onTooltipActive (WindowEventArgs &e)
Event trigger method called just before the tooltip becomes active.
virtual void | onTooltipInactive (WindowEventArgs &e)
Event trigger method called just after the tooltip is deactivated.
void | updateSelf (float elapsed)
Perform actual update processing for this Window.
void | onMouseEnters (MouseEventArgs &e)
Handler called when the mouse cursor has entered this window's area.
void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.

Protected Attributes

TipState d_state
Current tooltip state.
float | d_elapsed
Used to track state change timings.
const Window * | d_target
Current target Window for this Tooltip.
float | d_hoverTime
tool-tip hover time (seconds mouse must stay stationary before tip shows).
float | d_displayTime
tool-tip display time (seconds that tip is showsn for).
float | d_fadeTime
tool-tip fade time (seconds it takes for tip to fade in and/or out).

Detailed Description

Base class for Tooltip widgets.

The Tooltip class shows a simple pop-up window around the mouse position with some text information. The tool-tip fades in when the user hovers with the mouse over a window which has tool-tip text set, and then fades out after some pre-set time.

Note:
For Tooltip to work properly, you must specify a default tool-tip widget type via System::setTooltip, or by setting a custom tool-tip object for your Window(s). Additionally, you need to ensure that time pulses are properly passed to the system via System::injectTimePulse.

Member Enumeration Documentation

enum CEGUI::Tooltip::TipState [protected]

states for tooltip

Enumerator:
Inactive | Tooltip is currently inactive.
Active | Tooltip is currently displayed and active.
FadeIn | Tooltip is currently transitioning from Inactive to Active state.
FadeOut | Tooltip is currently transitioning from Active to Inactive state.

Member Function Documentation

float CEGUI::Tooltip::getDisplayTime ( void ) const

Return the number of seconds the tooltip should be displayed for before it automatically de-activates itself. 0 indicates that the tooltip never timesout and auto-deactivates.

Returns:
float value representing a number of seconds.

float CEGUI::Tooltip::getFadeTime ( void ) const

Return the number of seconds that should be taken to fade the tooltip into and out of visibility.

Returns:
float value representing a number of seconds.

float CEGUI::Tooltip::getHoverTime ( void ) const

Return the number of seconds the mouse should hover stationary over the target window before the tooltip gets activated.

Returns:
float value representing a number of seconds.

const Window * CEGUI::Tooltip::getTargetWindow ( )

return the current target window for this Tooltip.

Returns:
Pointer to the target window for this Tooltip or 0 for none.

Size CEGUI::Tooltip::getTextSize ( ) const [protected, virtual]

Return the size of the area that will be occupied by the tooltip text, given any current formatting options.

Returns:
Size object describing the size of the rendered tooltip text in pixels.

void CEGUI::Tooltip::onDisplayTimeChanged ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called when the display timeout gets changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::Tooltip::onFadeTimeChanged ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called when the fade timeout gets changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::Tooltip::onHoverTimeChanged ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called when the hover timeout gets changed.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::Tooltip::onMouseEnters ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has entered this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented from CEGUI::Window.

void CEGUI::Tooltip::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented from CEGUI::Window.

void CEGUI::Tooltip::onTooltipActive ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called just before the tooltip becomes active.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::Tooltip::onTooltipInactive ( WindowEventArgs & e ) [protected, virtual]

Event trigger method called just after the tooltip is deactivated.

Parameters:
e WindowEventArgs object.
Returns:
Nothing.

void CEGUI::Tooltip::positionSelf ( void )

Causes the tooltip to position itself appropriately.

Returns:
Nothing.

void CEGUI::Tooltip::resetTimer ( void )

Resets the timer on the tooltip when in the Active / Inactive states. This is used internally to control the tooltip, it is not normally necessary to call this method yourself.

Returns:
Nothing.

void CEGUI::Tooltip::setDisplayTime ( float seconds )

Set the number of seconds the tooltip should be displayed for before it automatically de-activates itself. 0 indicates that the tooltip should never timesout and auto-deactivate.

Parameters:
seconds float value representing a number of seconds.
Returns:
Nothing.

void CEGUI::Tooltip::setFadeTime ( float seconds )

Set the number of seconds that should be taken to fade the tooltip into and out of visibility.

Parameters:
seconds float value representing a number of seconds.
Returns:
Nothing.

void CEGUI::Tooltip::setHoverTime ( float seconds )

Set the number of seconds the mouse should hover stationary over the target window before the tooltip gets activated.

Parameters:
seconds float value representing a number of seconds.
Returns:
Nothing.

void CEGUI::Tooltip::setTargetWindow ( Window * wnd )

Sets the target window for the tooltip. This used internally to manage tooltips, you should not have to call this yourself.

Parameters:
wnd Window object that the tooltip should be associated with (for now).
Returns:
Nothing.

virtual bool CEGUI::Tooltip::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented from CEGUI::Window.

void CEGUI::Tooltip::updateSelf ( float elapsed ) [protected, virtual]

Perform actual update processing for this Window.

Parameters:
elapsed float value indicating the number of seconds elapsed since the last update call.
Returns:
Nothing.

Reimplemented from CEGUI::Window.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::TopFrameImage Class Reference

CEGUI::StaticProperties::TopFrameImage

CEGUI::StaticProperties::TopFrameImage Class Reference

Property to access the top edge image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::TopFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::TopFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the top edge image for the frame of the Static widget.

Usage:
  • Name: TopFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::TopFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::TopFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::TopLeftFrameImage Class Reference

CEGUI::StaticProperties::TopLeftFrameImage

CEGUI::StaticProperties::TopLeftFrameImage Class Reference

Property to access the top-left image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::TopLeftFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::TopLeftFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the top-left image for the frame of the Static widget.

Usage:
  • Name: TopLeftFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::TopLeftFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::TopLeftFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties::TopRightFrameImage Class Reference

CEGUI::StaticProperties::TopRightFrameImage

CEGUI::StaticProperties::TopRightFrameImage Class Reference

Property to access the top-right image for the frame of the Static widget. More...

Inheritance diagram for CEGUI::StaticProperties::TopRightFrameImage:

[legend]
Collaboration diagram for CEGUI::StaticProperties::TopRightFrameImage:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the top-right image for the frame of the Static widget.

Usage:
  • Name: TopRightFrameImage
  • Format: "set:[text] image:[text]".
Where:
  • set:[text] is the name of the Imageset containing the image. The Imageset name should not contain spaces. The Imageset specified must already be loaded.
  • image:[text] is the name of the Image on the specified Imageset. The Image name should not contain spaces.

Member Function Documentation

String CEGUI::StaticProperties::TopRightFrameImage::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticProperties::TopRightFrameImage::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::UDim Class Reference

CEGUI::UDim

CEGUI::UDim Class Reference

Class representing a unified dimension; that is a dimension that has both a relative 'scale' portion and and absolute 'offset' portion. More...

List of all members.

Public Member Functions

UDim (float scale, float offset)
float | asAbsolute (float base) const
float | asRelative (float base) const
UDim | operator+ (const UDim &other) const
UDim | operator- (const UDim &other) const
UDim | operator/ (const UDim &other) const
UDim | operator * (const UDim &other) const
const UDim & | operator+= (const UDim &other)
const UDim & | operator-= (const UDim &other)
const UDim & | operator/= (const UDim &other)
const UDim & | operator *= (const UDim &other)
bool | operator== (const UDim &other) const
bool | operator!= (const UDim &other) const

Public Attributes

float | d_scale
float | d_offset

Detailed Description

Class representing a unified dimension; that is a dimension that has both a relative 'scale' portion and and absolute 'offset' portion.

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::UnifiedDim Class Reference

CEGUI::UnifiedDim

CEGUI::UnifiedDim Class Reference

Dimension type that represents an Unified dimension. Implements BaseDim interface. More...

Inheritance diagram for CEGUI::UnifiedDim:

[legend]
Collaboration diagram for CEGUI::UnifiedDim:

[legend]
List of all members.

Public Member Functions

UnifiedDim (const UDim &value, DimensionType dim)
Constructor.

Protected Member Functions

float | getValue_impl (const Window &wnd) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
float | getValue_impl (const Window &wnd, const Rect &container) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
void | writeXMLElementName_impl (OutStream &out_stream) const
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
void | writeXMLElementAttributes_impl (OutStream &out_stream) const
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.
BaseDim * | clone_impl () const
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.

Detailed Description

Dimension type that represents an Unified dimension. Implements BaseDim interface.

Constructor & Destructor Documentation

CEGUI::UnifiedDim::UnifiedDim | ( | const UDim & | value,
 |  | DimensionType | dim
 | ) |

Constructor.

Parameters:
value | UDim holding the value to assign to this UnifiedDim.
dim | DimensionType value indicating what this UnifiedDim is to represent. This is required because we need to know what part of the base Window that the UDim scale component is to operate against.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::UnknownObjectException Class Reference

CEGUI::UnknownObjectException

CEGUI::UnknownObjectException Class Reference

Exception class used when a request was made using a name of an unknown object. More...

Inheritance diagram for CEGUI::UnknownObjectException:

[legend]
Collaboration diagram for CEGUI::UnknownObjectException:

[legend]
List of all members.

Public Member Functions

UnknownObjectException (const String &message)

Detailed Description

Exception class used when a request was made using a name of an unknown object.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::URect Class Reference

CEGUI::URect

CEGUI::URect Class Reference

Area rectangle class built using unified dimensions (UDims). More...

Collaboration diagram for CEGUI::URect:

[legend]
List of all members.

Public Member Functions

URect (const UVector2 &min, const UVector2 &max)
URect (const UDim &left, const UDim &top, const UDim &right, const UDim &bottom)
Rect | asAbsolute (const Size &base) const
Rect | asRelative (const Size &base) const
const UVector2 & | getPosition () const
UVector2 | getSize () const
UDim | getWidth () const
UDim | getHeight () const
void | setPosition (const UVector2 &pos)
void | setSize (const UVector2 &sz)
void | setWidth (const UDim &w)
void | setHeight (const UDim &h)
void | offset (const UVector2 &sz)

Public Attributes

UVector2 | d_min
UVector2 | d_max

Detailed Description

Area rectangle class built using unified dimensions (UDims).

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties::UseStandardImagery Class Reference

CEGUI::PushButtonProperties::UseStandardImagery

CEGUI::PushButtonProperties::UseStandardImagery Class Reference

Property to access whether to use the standard images or the supplied custom ones. More...

Inheritance diagram for CEGUI::PushButtonProperties::UseStandardImagery:

[legend]
Collaboration diagram for CEGUI::PushButtonProperties::UseStandardImagery:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access whether to use the standard images or the supplied custom ones.

Usage:
  • Name: UseStandardImagery
  • Format: "True|False".

Member Function Documentation

String CEGUI::PushButtonProperties::UseStandardImagery::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::PushButtonProperties::UseStandardImagery::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::UVector2 Class Reference

CEGUI::UVector2

CEGUI::UVector2 Class Reference

Two dimensional vector class built using unified dimensions (UDims). The UVector2 class is used for representing both positions and sizes. More...

Collaboration diagram for CEGUI::UVector2:

[legend]
List of all members.

Public Member Functions

UVector2 (const UDim &x, const UDim &y)
Vector2 | asAbsolute (const Size &base) const
Vector2 | asRelative (const Size &base) const
UVector2 | operator+ (const UVector2 &other) const
UVector2 | operator- (const UVector2 &other) const
UVector2 | operator/ (const UVector2 &other) const
UVector2 | operator * (const UVector2 &other) const
const UVector2 & | operator+= (const UVector2 &other)
const UVector2 & | operator-= (const UVector2 &other)
const UVector2 & | operator/= (const UVector2 &other)
const UVector2 & | operator *= (const UVector2 &other)
bool | operator== (const UVector2 &other) const
bool | operator!= (const UVector2 &other) const

Public Attributes

UDim | d_x
UDim | d_y

Detailed Description

Two dimensional vector class built using unified dimensions (UDims). The UVector2 class is used for representing both positions and sizes.

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties::ValidationString Class Reference

CEGUI::EditboxProperties::ValidationString

CEGUI::EditboxProperties::ValidationString Class Reference

Property to access the string used for regular expression validation of the edit box text. More...

Inheritance diagram for CEGUI::EditboxProperties::ValidationString:

[legend]
Collaboration diagram for CEGUI::EditboxProperties::ValidationString:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the string used for regular expression validation of the edit box text.

Usage:
  • Name: ValidationString
  • Format: "[text]"
Where:
  • [Text] is the string used for validating text entry.

Member Function Documentation

String CEGUI::EditboxProperties::ValidationString::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::EditboxProperties::ValidationString::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties::ValidationString Class Reference

CEGUI::ComboboxProperties::ValidationString

CEGUI::ComboboxProperties::ValidationString Class Reference

Property to access the string used for regular expression validation of the edit box text. More...

Inheritance diagram for CEGUI::ComboboxProperties::ValidationString:

[legend]
Collaboration diagram for CEGUI::ComboboxProperties::ValidationString:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the string used for regular expression validation of the edit box text.

Usage:
  • Name: ValidationString
  • Format: "[text]"
Where:
  • [Text] is the string used for validating text entry.

Member Function Documentation

String CEGUI::ComboboxProperties::ValidationString::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ComboboxProperties::ValidationString::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Vector2 Class Reference

CEGUI::Vector2

CEGUI::Vector2 Class Reference

Class used as a two dimensional vector (aka a Point). More...

List of all members.

Public Member Functions

Vector2 (float x, float y)
Vector2 & | operator *= (const Vector2 &vec)
Vector2 & | operator/= (const Vector2 &vec)
Vector2 & | operator+= (const Vector2 &vec)
Vector2 & | operator-= (const Vector2 &vec)
Vector2 | operator+ (const Vector2 &vec) const
Vector2 | operator- (const Vector2 &vec) const
Vector2 | operator * (const Vector2 &vec) const
bool | operator== (const Vector2 &vec) const
bool | operator!= (const Vector2 &vec) const
Size | asSize () const

Public Attributes

float | d_x
float | d_y

Detailed Description

Class used as a two dimensional vector (aka a Point).

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Vector3 Class Reference

CEGUI::Vector3

CEGUI::Vector3 Class Reference

Class used as a three dimensional vector. More...

List of all members.

Public Member Functions

Vector3 (float x, float y, float z)

Public Attributes

float | d_x
float | d_y
float | d_z

Detailed Description

Class used as a three dimensional vector.

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticImageProperties::VertFormatting Class Reference

CEGUI::StaticImageProperties::VertFormatting

CEGUI::StaticImageProperties::VertFormatting Class Reference

Property to access the vertical formatting mode setting. More...

Inheritance diagram for CEGUI::StaticImageProperties::VertFormatting:

[legend]
Collaboration diagram for CEGUI::StaticImageProperties::VertFormatting:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the vertical formatting mode setting.

Usage:
  • Name: VertFormatting
  • Format: "[text]".
Where [text] is one of:
  • "TopAligned"
  • "BottomAligned"
  • "VertCentred"
  • "VertStretched"
  • "VertTiled"

Member Function Documentation

String CEGUI::StaticImageProperties::VertFormatting::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticImageProperties::VertFormatting::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticTextProperties::VertFormatting Class Reference

CEGUI::StaticTextProperties::VertFormatting

CEGUI::StaticTextProperties::VertFormatting Class Reference

Property to access the vertical formatting mode setting. More...

Inheritance diagram for CEGUI::StaticTextProperties::VertFormatting:

[legend]
Collaboration diagram for CEGUI::StaticTextProperties::VertFormatting:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the vertical formatting mode setting.

Usage:
  • Name: VertFormatting
  • Format: "[text]".
Where [text] is one of:
  • "TopAligned"
  • "BottomAligned"
  • "VertCentred"

Member Function Documentation

String CEGUI::StaticTextProperties::VertFormatting::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticTextProperties::VertFormatting::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ThumbProperties::VertFree Class Reference

CEGUI::ThumbProperties::VertFree

CEGUI::ThumbProperties::VertFree Class Reference

Property to access the state the setting to free the thumb vertically. More...

Inheritance diagram for CEGUI::ThumbProperties::VertFree:

[legend]
Collaboration diagram for CEGUI::ThumbProperties::VertFree:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the state the setting to free the thumb vertically.

Usage:
  • Name: VertFree
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the thumb will be free (movable) vertically.
  • "False" to indicate the thumb will be fixed vertically.

Member Function Documentation

String CEGUI::ThumbProperties::VertFree::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ThumbProperties::VertFree::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::VerticalAlignment Class Reference

CEGUI::WindowProperties::VerticalAlignment

CEGUI::WindowProperties::VerticalAlignment Class Reference

Property to access the vertical alignment setting for the window. More...

Inheritance diagram for CEGUI::WindowProperties::VerticalAlignment:

[legend]
Collaboration diagram for CEGUI::WindowProperties::VerticalAlignment:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the vertical alignment setting for the window.

Usage:
  • Name: VerticalAlignment
  • Format: "[text]".
Where [Text] is:
  • "Top" to indicate the windows position is an offset of its top edge from its parents top edge.
  • "Centre" to indicate the windows position is an offset of its centre point from its parents centre point.
  • "Bottom" to indicate the windows position is an offset of its bottom edge from its parents bottom edge.

Member Function Documentation

String CEGUI::WindowProperties::VerticalAlignment::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::VerticalAlignment::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::VertOverlapSize Class Reference

CEGUI::ScrollablePaneProperties::VertOverlapSize

CEGUI::ScrollablePaneProperties::VertOverlapSize Class Reference

Property to access the overlap size for the vertical Scrollbar. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::VertOverlapSize:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::VertOverlapSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the overlap size for the vertical Scrollbar.

Usage:
  • Name: VertOverlapSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the per-page overlap (as a fraction of one page).

Member Function Documentation

String CEGUI::ScrollablePaneProperties::VertOverlapSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::VertOverlapSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MenuBaseProperties::VertPadding Class Reference

CEGUI::MenuBaseProperties::VertPadding

CEGUI::MenuBaseProperties::VertPadding Class Reference

Property to access the vert padding value of the menu. More...

Inheritance diagram for CEGUI::MenuBaseProperties::VertPadding:

[legend]
Collaboration diagram for CEGUI::MenuBaseProperties::VertPadding:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the vert padding value of the menu.

Usage:
  • Name: VertPadding
  • Format: "[float]".
Where:
  • [float] represents the vert padding of the slider.

Member Function Documentation

String CEGUI::MenuBaseProperties::VertPadding::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MenuBaseProperties::VertPadding::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ThumbProperties::VertRange Class Reference

CEGUI::ThumbProperties::VertRange

CEGUI::ThumbProperties::VertRange Class Reference

Property to access the vertical movement range for the thumb. More...

Inheritance diagram for CEGUI::ThumbProperties::VertRange:

[legend]
Collaboration diagram for CEGUI::ThumbProperties::VertRange:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the vertical movement range for the thumb.

Usage:
  • Name: VertRange
  • Format: "min:[float] max:[float]".
Where:
  • min:[float] specifies the minimum vertical setting (position) for the thumb, specified using the active metrics system for the window.
  • max:[float] specifies the maximum vertical setting (position) for the thumb, specified using the active metrics system for the window.

Member Function Documentation

String CEGUI::ThumbProperties::VertRange::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ThumbProperties::VertRange::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticTextProperties::VertScrollbar Class Reference

CEGUI::StaticTextProperties::VertScrollbar

CEGUI::StaticTextProperties::VertScrollbar Class Reference

Property to access the setting for enabling the vertical scroll bar. More...

Inheritance diagram for CEGUI::StaticTextProperties::VertScrollbar:

[legend]
Collaboration diagram for CEGUI::StaticTextProperties::VertScrollbar:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the setting for enabling the vertical scroll bar.

Usage:
  • Name: VertScrollbar
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the scroll bar is enabled and will be shown when needed.
  • "False" to indicate the scroll bar is disabled and will never be shown

Member Function Documentation

String CEGUI::StaticTextProperties::VertScrollbar::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::StaticTextProperties::VertScrollbar::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::VertScrollPosition Class Reference

CEGUI::ScrollablePaneProperties::VertScrollPosition

CEGUI::ScrollablePaneProperties::VertScrollPosition Class Reference

Property to access the scroll position of the vertical Scrollbar. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::VertScrollPosition:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::VertScrollPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the scroll position of the vertical Scrollbar.

Usage:
  • Name: VertScrollPosition
  • Format: "[float]".
Where:
  • [float] specifies the current scroll position / value of the vertical Scrollbar (as a fraction of the whole).

Member Function Documentation

String CEGUI::ScrollablePaneProperties::VertScrollPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::VertScrollPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties::VertStepSize Class Reference

CEGUI::ScrollablePaneProperties::VertStepSize

CEGUI::ScrollablePaneProperties::VertStepSize Class Reference

Property to access the step size for the vertical Scrollbar. More...

Inheritance diagram for CEGUI::ScrollablePaneProperties::VertStepSize:

[legend]
Collaboration diagram for CEGUI::ScrollablePaneProperties::VertStepSize:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the step size for the vertical Scrollbar.

Usage:
  • Name: VertStepSize
  • Format: "[float]".
Where:
  • [float] specifies the size of the increase/decrease button step for the vertical scrollbar (as a fraction of 1 page).

Member Function Documentation

String CEGUI::ScrollablePaneProperties::VertStepSize::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::ScrollablePaneProperties::VertStepSize::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Visible Class Reference

CEGUI::WindowProperties::Visible

CEGUI::WindowProperties::Visible Class Reference

Property to access window Visible setting. More...

Inheritance diagram for CEGUI::WindowProperties::Visible:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Visible:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.
bool | isDefault (const PropertyReceiver *receiver) const
Returns whether the property is at it's default value.

Detailed Description

Property to access window Visible setting.

This property offers access to the visible setting for the window.

Usage:
  • Name: Visible
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window is visible.
  • "False" to indicate the Window is not visible.

Member Function Documentation

String CEGUI::WindowProperties::Visible::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

bool CEGUI::WindowProperties::Visible::isDefault ( const PropertyReceiver * receiver ) const [virtual]

Returns whether the property is at it's default value.

Parameters:
receiver Pointer to the target object.
Returns:
  • true if the property has it's default value.
  • false if the property has been modified from it's default value.

Reimplemented from CEGUI::Property.

void CEGUI::WindowProperties::Visible::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::WantsMultiClickEvents Class Reference

CEGUI::WindowProperties::WantsMultiClickEvents

CEGUI::WindowProperties::WantsMultiClickEvents Class Reference

Property to control whether the window will receive double/triple-click events. More...

Inheritance diagram for CEGUI::WindowProperties::WantsMultiClickEvents:

[legend]
Collaboration diagram for CEGUI::WindowProperties::WantsMultiClickEvents:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to control whether the window will receive double/triple-click events.

This property offers access to the setting that controls whether a window will receive double-click and triple-click events, or whether the window will receive multiple single mouse button down events instead.

Usage:
  • Name: WantsMultiClickEvents
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window wants double-click and triple-click events.
  • "False" to indicate the Window wants multiple single mouse button down events.

Member Function Documentation

String CEGUI::WindowProperties::WantsMultiClickEvents::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::WantsMultiClickEvents::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WidgetComponent Class Reference

CEGUI::WidgetComponent

CEGUI::WidgetComponent Class Reference

Class that encapsulates information regarding a sub-widget required for a widget. More...

Collaboration diagram for CEGUI::WidgetComponent:

[legend]
List of all members.

Public Member Functions

WidgetComponent (const String &type, const String &look, const String &suffix)
void | create (Window &parent) const
Create an instance of this widget component adding it as a child to the given Window.
const ComponentArea & | getComponentArea () const
void | setComponentArea (const ComponentArea &area)
const String & | getBaseWidgetType () const
void | setBaseWidgetType (const String &type)
const String & | getWidgetLookName () const
void | setWidgetLookName (const String &look)
const String & | getWidgetNameSuffix () const
void | setWidgetNameSuffix (const String &suffix)
VerticalAlignment | getVerticalWidgetAlignemnt () const
void | setVerticalWidgetAlignment (VerticalAlignment alignment)
HorizontalAlignment | getHorizontalWidgetAlignemnt () const
void | setHorizontalWidgetAlignemnt (HorizontalAlignment alignment)
void | addPropertyInitialiser (const PropertyInitialiser &initialiser)
void | clearPropertyInitialisers ()
void | layout (const Window &owner) const
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this WidgetComponent to out_stream.

Detailed Description

Class that encapsulates information regarding a sub-widget required for a widget.

Todo:
This is not finished in the slightest! There will be many changes here...

Member Function Documentation

void CEGUI::WidgetComponent::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this WidgetComponent to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WidgetDim Class Reference

CEGUI::WidgetDim

CEGUI::WidgetDim Class Reference

Dimension type that represents some dimension of a Window/widget. Implements BaseDim interface. More...

Inheritance diagram for CEGUI::WidgetDim:

[legend]
Collaboration diagram for CEGUI::WidgetDim:

[legend]
List of all members.

Public Member Functions

WidgetDim (const String &name, DimensionType dim)
Constructor.
void | setWidgetName (const String &name)
Set the name suffix to use for this WidgetDim.
void | setSourceDimension (DimensionType dim)
Sets the source dimension type for this WidgetDim.

Protected Member Functions

float | getValue_impl (const Window &wnd) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically.
float | getValue_impl (const Window &wnd, const Rect &container) const
Implementataion method to return the base value for this BaseDim. This method should not attempt to apply the mathematical operator; this is handled automatically by BaseDim.
void | writeXMLElementName_impl (OutStream &out_stream) const
Implementataion method to output real xml element name to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element name itself.
void | writeXMLElementAttributes_impl (OutStream &out_stream) const
Implementataion method to output xml element attributes to an OutStream. This method should not write the element opening '<' character, nor close the element, it must write just the element attributes.
BaseDim * | clone_impl () const
Implementataion method to return a clone of this sub-class of BaseDim. This method should not attempt to clone the mathematical operator or operand; theis is handled automatically by BaseDim.

Detailed Description

Dimension type that represents some dimension of a Window/widget. Implements BaseDim interface.

When calculating the final pixel value for the dimension, a target widget name is built by appending the name suffix specified for the WidgetDim to the name of the window passed to getValue, we then find the window/widget with that name - the final value of the dimension is taken from this window/widget.

Constructor & Destructor Documentation

CEGUI::WidgetDim::WidgetDim | ( | const String & | name,
 |  | DimensionType | dim
 | ) |

Constructor.

Parameters:
name | String object holding the name suffix for a window/widget.
dim | DimensionType value indicating which dimension of the described image that this ImageDim is to represent.

Member Function Documentation

void CEGUI::WidgetDim::setSourceDimension ( DimensionType dim )

Sets the source dimension type for this WidgetDim.

Parameters:
dim DimensionType value indicating which dimension of the described image that this WidgetDim is to represent.
Returns:
Nothing.

void CEGUI::WidgetDim::setWidgetName ( const String & name )

Set the name suffix to use for this WidgetDim.

Parameters:
name String object holding the name suffix for a window/widget.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WidgetLookFeel Class Reference

CEGUI::WidgetLookFeel

CEGUI::WidgetLookFeel Class Reference

Class that encapsulates look & feel information for a particular widget type. More...

Collaboration diagram for CEGUI::WidgetLookFeel:

[legend]
List of all members.

Public Member Functions

WidgetLookFeel (const String &name)
const StateImagery & | getStateImagery (const CEGUI::String &state) const
Return a const reference to the StateImagery object for the specified state.
const ImagerySection & | getImagerySection (const CEGUI::String &section) const
Return a const reference to the ImagerySection object with the specified name.
const String & | getName () const
Return the name of the widget look.
void | addImagerySection (const ImagerySection &section)
Add an ImagerySection to the WidgetLookFeel.
void | addWidgetComponent (const WidgetComponent &widget)
Add a WidgetComponent to the WidgetLookFeel.
void | addStateSpecification (const StateImagery &state)
Add a state specification (StateImagery object) to the WidgetLookFeel.
void | addPropertyInitialiser (const PropertyInitialiser &initialiser)
Add a property initialiser to the WidgetLookFeel.
void | clearImagerySections ()
Clear all ImagerySections from the WidgetLookFeel.
void | clearWidgetComponents ()
Clear all WidgetComponents from the WidgetLookFeel.
void | clearStateSpecifications ()
Clear all StateImagery objects from the WidgetLookFeel.
void | clearPropertyInitialisers ()
Clear all PropertyInitialiser objects from the WidgetLookFeel.
void | initialiseWidget (Window &widget) const
Initialise the given window using PropertyInitialsers and component widgets specified for this WidgetLookFeel.
bool | isStateImageryPresent (const String &state) const
Return whether imagery is defined for the given state.
void | addNamedArea (const NamedArea &area)
Adds a named area to the WidgetLookFeel.
void | clearNamedAreas ()
Clear all defined named areas from the WidgetLookFeel.
const NamedArea & | getNamedArea (const String &name) const
Return the NamedArea with the specified name.
bool | isNamedAreaDefined (const String &name) const
return whether a NamedArea object with the specified name exists for this WidgetLookFeel.
void | layoutChildWidgets (const Window &owner) const
Layout the child widgets defined for this WidgetLookFeel which are attached to the given window.
void | addPropertyDefinition (const PropertyDefinition &propdef)
Adds a property definition to the WidgetLookFeel.
void | clearPropertyDefinitions ()
Clear all defined property definitions from the WidgetLookFeel.
void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this WidgetLookFeel to out_stream.
void | renameChildren (const Window &widget, const String &newBaseName) const
Uses the WindowManager to rename the child windows that are created for this WidgetLookFeel.

Detailed Description

Class that encapsulates look & feel information for a particular widget type.

Member Function Documentation

void CEGUI::WidgetLookFeel::addImagerySection ( const ImagerySection & section )

Add an ImagerySection to the WidgetLookFeel.

Parameters:
section ImagerySection object to be added.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::addNamedArea ( const NamedArea & area )

Adds a named area to the WidgetLookFeel.

Parameters:
area NamedArea to be added.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::addPropertyDefinition ( const PropertyDefinition & propdef )

Adds a property definition to the WidgetLookFeel.

Parameters:
propdef PropertyDefinition to be added.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::addPropertyInitialiser ( const PropertyInitialiser & initialiser )

Add a property initialiser to the WidgetLookFeel.

Parameters:
initialiser PropertyInitialiser object to be added.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::addStateSpecification ( const StateImagery & state )

Add a state specification (StateImagery object) to the WidgetLookFeel.

Parameters:
section StateImagery object to be added.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::addWidgetComponent ( const WidgetComponent & widget )

Add a WidgetComponent to the WidgetLookFeel.

Parameters:
widget WidgetComponent object to be added.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::clearImagerySections ( )

Clear all ImagerySections from the WidgetLookFeel.

Returns:
Nothing.

void CEGUI::WidgetLookFeel::clearNamedAreas ( )

Clear all defined named areas from the WidgetLookFeel.

Returns:
Nothing.

void CEGUI::WidgetLookFeel::clearPropertyDefinitions ( )

Clear all defined property definitions from the WidgetLookFeel.

Returns:
Nothing.

void CEGUI::WidgetLookFeel::clearPropertyInitialisers ( )

Clear all PropertyInitialiser objects from the WidgetLookFeel.

Returns:
Nothing.

void CEGUI::WidgetLookFeel::clearStateSpecifications ( )

Clear all StateImagery objects from the WidgetLookFeel.

Returns:
Nothing.

void CEGUI::WidgetLookFeel::clearWidgetComponents ( )

Clear all WidgetComponents from the WidgetLookFeel.

Returns:
Nothing.

const ImagerySection & CEGUI::WidgetLookFeel::getImagerySection ( const CEGUI::String & section ) const

Return a const reference to the ImagerySection object with the specified name.

Returns:
ImagerySection object with the specified name.

const String & CEGUI::WidgetLookFeel::getName ( ) const

Return the name of the widget look.

Returns:
String object holding the name of the WidgetLookFeel.

const NamedArea & CEGUI::WidgetLookFeel::getNamedArea ( const String & name ) const

Return the NamedArea with the specified name.

Parameters:
name String object holding the name of the NamedArea to be returned.
Returns:
The requested NamedArea object.

const StateImagery & CEGUI::WidgetLookFeel::getStateImagery ( const CEGUI::String & state ) const

Return a const reference to the StateImagery object for the specified state.

Returns:
StateImagery object for the requested state.

void CEGUI::WidgetLookFeel::initialiseWidget ( Window & widget ) const

Initialise the given window using PropertyInitialsers and component widgets specified for this WidgetLookFeel.

Parameters:
widget Window based object to be initialised.
Returns:
Nothing.

bool CEGUI::WidgetLookFeel::isNamedAreaDefined ( const String & name ) const

return whether a NamedArea object with the specified name exists for this WidgetLookFeel.

Parameters:
name String holding the name of the NamedArea to check for.
Returns:
  • true if a named area with the requested name is defined for this WidgetLookFeel.
  • false if no such named area is defined for this WidgetLookFeel.

bool CEGUI::WidgetLookFeel::isStateImageryPresent ( const String & state ) const

Return whether imagery is defined for the given state.

Parameters:
state String object containing name of state to look for.
Returns:
  • true if imagery exists for the specified state,
  • false if no imagery exists for the specified state.

void CEGUI::WidgetLookFeel::layoutChildWidgets ( const Window & owner ) const

Layout the child widgets defined for this WidgetLookFeel which are attached to the given window.

Parameters:
owner Window object that has the child widgets that require laying out.
Returns:
Nothing.

void CEGUI::WidgetLookFeel::renameChildren | ( | const Window & | widget,
 |  | const String & | newBaseName
 | ) | const

Uses the WindowManager to rename the child windows that are created for this WidgetLookFeel.

Parameters:
widget | The target Window containing the child windows that are to be renamed.
newBaseName | String object holding the new base name that will be used when constructing new names for the child windows.

void CEGUI::WidgetLookFeel::writeXMLToStream ( OutStream & out_stream ) const

Writes an xml representation of this WidgetLookFeel to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WidgetLookManager Class Reference

CEGUI::WidgetLookManager

CEGUI::WidgetLookManager Class Reference

Manager class that gives top-level access to widget data based "look and feel" specifications loaded into the system. More...

Collaboration diagram for CEGUI::WidgetLookManager:

[legend]
List of all members.

Public Member Functions

WidgetLookManager ()
Constructor.
~WidgetLookManager ()
Destructor.
void | parseLookNFeelSpecification (const String &filename, const String &resourceGroup="")
Parses a file containing window look & feel specifications (in the form of XML).
bool | isWidgetLookAvailable (const String &widget) const
Return whether a WidgetLookFeel has been created with the specified name.
const WidgetLookFeel & | getWidgetLook (const String &widget) const
Return a const reference to a WidgetLookFeel object which has the specified name.
void | eraseWidgetLook (const String &widget)
Erase the WidgetLookFeel that has the specified name.
void | addWidgetLook (const WidgetLookFeel &look)
Add the given WidgetLookFeel.
void | writeFalagardXMLHeadToStream (OutStream &out_stream) const
Writes the xml header and opening 'Falagard' tags to a stream.
void | writeFalagardXMLTailToStream (OutStream &out_stream) const
Writes closing xml 'Falagard' tag to a stream.
void | writeWidgetLookToStream (const String &name, OutStream &out_stream) const
Writes a complete Widge Look to a stream. Note that xml file header and falagard opening/closing tags will also be written.
void | writeWidgetLookSeriesToStream (const String &prefix, OutStream &out_stream) const
Writes a series of complete Widge Look objects to a stream. Note that xml file header and falagard opening/closing tags will also be written.

Static Public Member Functions

static WidgetLookManager & | getSingleton (void)
Return singleton WidgetLookManager object.
static WidgetLookManager * | getSingletonPtr (void)
Return pointer to singleton WindowFactoryManager object.

Detailed Description

Manager class that gives top-level access to widget data based "look and feel" specifications loaded into the system.

Member Function Documentation

void CEGUI::WidgetLookManager::addWidgetLook ( const WidgetLookFeel & look )

Add the given WidgetLookFeel.

Note:
If the WidgetLookFeel specification uses a name that already exists within the system, it is not an error; the previous definition is overwritten by the new data. An entry will appear in the log each time any look & feel component is overwritten.
Parameters:
look WidgetLookFeel object to be added to the system. NB: The WidgetLookFeel is copied, no change of ownership of the input object occurrs.
Returns:
Nothing.

void CEGUI::WidgetLookManager::eraseWidgetLook ( const String & widget )

Erase the WidgetLookFeel that has the specified name.

Parameters:
widget String object holding the name of a widget look to be erased. If no such WindowLookFeel exists, nothing happens.
Returns:
Nothing.

WidgetLookManager & CEGUI::WidgetLookManager::getSingleton ( void ) [static]

Return singleton WidgetLookManager object.

Returns:
Singleton WidgetLookManager object

WidgetLookManager * CEGUI::WidgetLookManager::getSingletonPtr ( void ) [static]

Return pointer to singleton WindowFactoryManager object.

Returns:
Pointer to singleton WindowFactoryManager object

const WidgetLookFeel & CEGUI::WidgetLookManager::getWidgetLook ( const String & widget ) const

Return a const reference to a WidgetLookFeel object which has the specified name.

Parameters:
widget String object holding the name of a widget look that is to be returned.
Returns:
const reference to the requested WidgetLookFeel object.
Exceptions:
UnknownObjectException thrown if no WindowLookFeel is available with the requested name.

bool CEGUI::WidgetLookManager::isWidgetLookAvailable ( const String & widget ) const

Return whether a WidgetLookFeel has been created with the specified name.

Parameters:
widget String object holding the name of a widget look to test for.
Returns:
  • true if a WindowLookFeel named widget is available.
  • false if so such WindowLookFeel is currently available.

void CEGUI::WidgetLookManager::parseLookNFeelSpecification | ( | const String & | filename,
 |  | const String & | resourceGroup = ""
 | ) |

Parses a file containing window look & feel specifications (in the form of XML).

Note:
If the new file contains specifications for widget types that are already specified, it is not an error; the previous definitions are overwritten by the new data. An entry will appear in the log each time any look & feel component is overwritten.
Parameters:
filename | String object containing the filename of a file containing the widget look & feel data
resourceGroup | Resource group identifier to pass to the resource provider when loading the file.
Returns:
Nothing.
Exceptions:
FileIOException | thrown if there was some problem accessing or parsing the file filename
InvalidRequestException | thrown if an invalid filename was provided.

void CEGUI::WidgetLookManager::writeFalagardXMLTailToStream ( OutStream & out_stream ) const

Writes closing xml 'Falagard' tag to a stream.

Parameters:
out_stream OutStream where XML data should be sent.

void CEGUI::WidgetLookManager::writeWidgetLookSeriesToStream | ( | const String & | prefix,
 |  | OutStream & | out_stream
 | ) | const

Writes a series of complete Widge Look objects to a stream. Note that xml file header and falagard opening/closing tags will also be written.

The prefix specifies a name prefix common to all widget looks to be written, you could specify this as "TaharezLook/" and then any defined widget look starting with that prefix, such as "TaharezLook/Button" and "TaharezLook/Listbox" will be written to the stream.

Parameters:
prefix | String holding the widget look name prefix, which will be used when searching for the widget looks to be output to the stream.
out_stream | OutStream where XML data should be sent.

void CEGUI::WidgetLookManager::writeWidgetLookToStream | ( | const String & | name,
 |  | OutStream & | out_stream
 | ) | const

Writes a complete Widge Look to a stream. Note that xml file header and falagard opening/closing tags will also be written.

Parameters:
name | String holding the name of the widget look to be output to the stream.
out_stream | OutStream where XML data should be sent.

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::Width Class Reference

CEGUI::WindowProperties::Width

CEGUI::WindowProperties::Width Class Reference

Property to access window width. More...

Inheritance diagram for CEGUI::WindowProperties::Width:

[legend]
Collaboration diagram for CEGUI::WindowProperties::Width:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window width.

This property offers access to the Width setting for the window, using the Windows active metrics mode.

Usage:
  • Name: Width
  • Format: "[float]".
Where:
  • [float] specifies the width as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::Width::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::Width::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::Window Class Reference

CEGUI::Window

CEGUI::Window Class Reference

An abstract base class providing common functionality and specifying the required interface for derived classes. More...

Inheritance diagram for CEGUI::Window:

[legend]
Collaboration diagram for CEGUI::Window:

[legend]
List of all members.

Public Member Functions

Window (const String &type, const String &name)
Constructor for Window base class.
virtual | ~Window (void)
Destructor for Window base class.
const String & | getType (void) const
return a String object holding the type name for this Window.
const String & | getName (void) const
return a String object holding the name of this Window.
bool | isDestroyedByParent (void) const
returns whether or not this Window is set to be destroyed when its parent is destroyed.
bool | isAlwaysOnTop (void) const
returns whether or not this Window is an always on top (a.k.a 'topmost') Window.
bool | isDisabled (bool localOnly=false) const
return true if the Window is currently disabled
bool | isVisible (bool localOnly=false) const
return true if the Window is currently visible.
bool | isActive (void) const
return true if this is the active Window (the window that receives inputs)
bool | isClippedByParent (void) const
return true if this Window is clipped so that its rendering does not pass outside its parent windows area.
uint | getID (void) const
return the ID code currently assigned to this Window by client code.
uint | getChildCount (void) const
return the number of child Window objects currently attached to this Window.
bool | isChild (const String &name) const
returns whether a Window with the specified name is currently attached to this Window as a child.
bool | isChild (uint ID) const
returns whether at least one window with the given ID code is attached as a child.
bool | isChild (const Window *window) const
return true if the given Window is a child of this window.
Window * | getChild (const String &name) const
return a pointer to the child window with the specified name.
Window * | getChild (uint ID) const
return a pointer to the first attached child window with the specified ID.
Window * | getChildAtIdx (uint idx) const
return a pointer to the child window that is attached to 'this' at the given index.
Window * | getActiveChild (void)
return a pointer to the Window that currently has input focus starting with this Window.
const Window * | getActiveChild (void) const
bool | isAncestor (const String &name) const
return true if the specified Window is some ancestor of this Window
bool | isAncestor (uint ID) const
return true if any Window with the given ID is some ancestor of this Window.
bool | isAncestor (const Window *window) const
return true if the specified Window is some ancestor of this Window.
const Font * | getFont (bool useDefault=true) const
return the Font object active for the Window.
const String & | getText (void) const
return the current text for the Window
bool | inheritsAlpha (void) const
return true if the Window inherits alpha from its parent(s).
float | getAlpha (void) const
return the current alpha value set for this Window
float | getEffectiveAlpha (void) const
return the effective alpha value that will be used when rendering this window, taking into account inheritance of parent window(s) alpha.
Rect | getRect (void) const
return a Rect object that describes the Window area.
virtual Rect | getPixelRect (void) const
return a Rect object describing the Window area in screen space.
Rect | getInnerRect (void) const
return a Rect object describing the clipped inner area for this window.
Rect | getUnclippedPixelRect (void) const
return a Rect object describing the Window area unclipped, in screen space.
virtual Rect | getUnclippedInnerRect (void) const
Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.
bool | isCapturedByThis (void) const
return true if this Window has input captured.
bool | isCapturedByAncestor (void) const
return true if a child window has captured inputs.
bool | isCapturedByChild (void) const
return true if an ancestor window has captured inputs.
virtual bool | isHit (const Point &position) const
check if the given position would hit this window.
Window * | getChildAtPosition (const Point &position) const
return the child Window that is 'hit' by the given position
MetricsMode | getMetricsMode (void) const
return the current metrics mode employed by the Window
float | getXPosition (void) const
return the x position of the window. Interpretation of return value depends upon the metric type in use by this window.
float | getYPosition (void) const
return the y position of the window. Interpretation of return value depends upon the metric type in use by this window.
Point | getPosition (void) const
return the position of the window. Interpretation of return value depends upon the metric type in use by this window.
float | getWidth (void) const
return the width of the Window. Interpretation of return value depends upon the metric type in use by this window.
float | getHeight (void) const
return the height of the Window. Interpretation of return value depends upon the metric type in use by this window.
Size | getSize (void) const
return the size of the Window. Interpretation of return value depends upon the metric type in use by this window.
Window * | getParent (void) const
return the parent of this Window.
Size | getMaximumSize (void) const
Return the current maximum size for this window.
Size | getMinimumSize (void) const
Return the current minimum size for this window.
const Image * | getMouseCursor (bool useDefault=true) const
Return a pointer to the mouse cursor image to use when the mouse is within this window.
Rect | getRelativeRect (void) const
Return the window area rect in relative metrics.
Point | getRelativePosition (void) const
Return the window position in relative metrics.
float | getRelativeXPosition (void) const
Return the window X position in relative metrics.
float | getRelativeYPosition (void) const
Return the window Y position in relative metrics.
Size | getRelativeSize (void) const
Return the window size in relative metrics.
float | getRelativeWidth (void) const
Return the window width in relative metrics.
float | getRelativeHeight (void) const
Return the window height in relative metrics.
Rect | getAbsoluteRect (void) const
Return the window area rect in absolute metrics.
Point | getAbsolutePosition (void) const
Return the window position in absolute metrics.
float | getAbsoluteXPosition (void) const
Return the window X position in absolute metrics.
float | getAbsoluteYPosition (void) const
Return the window Y position in absolute metrics.
Size | getAbsoluteSize (void) const
Return the window size in absolute metrics.
float | getAbsoluteWidth (void) const
Return the window width in absolute metrics.
float | getAbsoluteHeight (void) const
Return the window height in absolute metrics.
void * | getUserData (void) const
Return the user data set for this Window.
float | getXPosition (MetricsMode mode) const
return the x position of the window using the specified metrics system.
float | getYPosition (MetricsMode mode) const
return the y position of the window using the specified metrics system.
Point | getPosition (MetricsMode mode) const
return the position of the window using the specified metrics system.
float | getWidth (MetricsMode mode) const
return the width of the Window using the specified metrics system.
float | getHeight (MetricsMode mode) const
return the height of the Window using the specified metrics system.
Size | getSize (MetricsMode mode) const
return the size of the Window using the specified metrics system.
Rect | getRect (MetricsMode mode) const
return a Rect object that describes the Window area using the specified metrics system.
bool | restoresOldCapture (void) const
Return whether this window is set to restore old input capture when it loses input capture.
bool | isZOrderingEnabled (void) const
Return whether z-order changes are enabled or disabled for this Window.
bool | wantsMultiClickEvents (void) const
Return whether this window will receive multi-click events or multiple 'down' events instead.
bool | isMouseAutoRepeatEnabled (void) const
Return whether mouse button down event autorepeat is enabled for this window.
float | getAutoRepeatDelay (void) const
Return the current auto-repeat delay setting for this window.
float | getAutoRepeatRate (void) const
Return the current auto-repeat rate setting for this window.
bool | distributesCapturedInputs (void) const
Return whether the window wants inputs passed to its attached child windows when the window has inputs captured.
bool | isUsingDefaultTooltip (void) const
Return whether this Window is using the system default Tooltip for its Tooltip window.
Tooltip * | getTooltip (void) const
Return a pointer to the Tooltip object used by this Window. The value returned may point to the system default Tooltip, a custom Window specific Tooltip, or be NULL.
String | getTooltipType (void) const
Return the custom tooltip type.
const String & | getTooltipText (void) const
Return the current tooltip text set for this Window.
bool | inheritsTooltipText (void) const
Return whether this window inherits Tooltip text from its parent when its own tooltip text is not set.
bool | isRiseOnClickEnabled (void) const
Return whether this window will rise to the top of the z-order when clicked with the left mouse button.
bool | testClassName (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
VerticalAlignment | getVerticalAlignment () const
Get the vertical alignment.
HorizontalAlignment | getHorizontalAlignment () const
Get the horizontal alignment.
RenderCache & getRenderCache ()
Return the RenderCache object for this Window.
const String & | getLookNFeel ()
Get the name of the LookNFeel assigned to this window.
bool | getModalState (void) const
Get whether or not this Window is the modal target.
const String & | getUserString (const String &name) const
Returns a named user string.
bool | isUserStringDefined (const String &name) const
Return whether a user string with the specified name exists.
Window * getActiveSibling ()
Returns the active sibling window.
void | rename (const String &new_name)
Renames the window.
virtual void | initialise (void)
Initialises the Window based object ready for use.
void | setDestroyedByParent (bool setting)
Set whether or not this Window will automatically be destroyed when its parent Window is destroyed.
void | setAlwaysOnTop (bool setting)
Set whether this window is always on top, or not.
void | setEnabled (bool setting)
Set whether this window is enabled or disabled. A disabled window normally can not be interacted with, and may have different rendering.
void | enable (void)
enable the Window to allow interaction.
void | disable (void)
disable the Window to prevent interaction.
void | setVisible (bool setting)
Set whether the Window is visible or hidden.
void | show (void)
show the Window
void | hide (void)
hide the Window.
void | activate (void)
Activate the Window giving it input focus and bringing it to the top of all non always-on-top Windows.
void | deactivate (void)
Deactivate the window. No further inputs will be received by the window until it is re-activated either programmatically or by the user interacting with the gui.
void | setClippedByParent (bool setting)
Set whether this Window will be clipped by its parent window(s).
void | setID (uint ID)
Set the current ID for the Window.
void | setText (const String &text)
Set the current text string for the Window.
void | setWidth (float width)
Set the current width of the Window. Interpretation of the input value width is dependant upon the current metrics system set for the Window.
void | setHeight (float height)
Set the current height of the Window. Interpretation of the input value height is dependant upon the current metrics system set for the Window.
void | setSize (const Size &size)
Set the current size of the Window. Interpretation of the input value size is dependant upon the current metrics system set for the Window.
void | setXPosition (float x)
Set the current 'x' position of the Window. Interpretation of the input value x is dependant upon the current metrics system set for the Window.
void | setYPosition (float y)
Set the current 'y' position of the Window. Interpretation of the input value y is dependant upon the current metrics system set for the Window.
void | setPosition (const Point &position)
Set the current position of the Window. Interpretation of the input value position is dependant upon the current metrics system set for the Window.
void | setAreaRect (const Rect &area)
Set the current area for the Window, this allows for setting of position and size at the same time. Interpretation of the input value area is dependant upon the current metrics system set for the Window.
void | setFont (const Font *font)
Set the font used by this Window.
void | setFont (const String &name)
Set the font used by this Window.
void | addChildWindow (const String &name)
Add the named Window as a child of this Window. If the Window name is already attached to a Window, it is detached before being added to this Window.
void | addChildWindow (Window *window)
Add the specified Window as a child of this Window. If the Window window is already attached to a Window, it is detached before being added to this Window.
void | removeChildWindow (const String &name)
Remove the named Window from this windows child list.
void | removeChildWindow (Window *window)
Remove the specified Window form this windows child list.
void | removeChildWindow (uint ID)
Remove the first child Window with the specified ID. If there is more than one attached Window objects with the specified ID, only the fist one encountered will be removed.
void | moveToFront ()
Move the Window to the top of the z order.
void | moveToBack ()
Move the Window to the bottom of the Z order.
bool | captureInput (void)
Captures input to this window.
void | releaseInput (void)
Releases input capture from this Window. If this Window does not have inputs captured, nothing happens.
void | setRestoreCapture (bool setting)
Set whether this window will remember and restore the previous window that had inputs captured.
void | setAlpha (float alpha)
Set the current alpha value for this window.
void | setInheritsAlpha (bool setting)
Sets whether this Window will inherit alpha from its parent windows.
void | requestRedraw (void) const
Signal the System object to redraw (at least) this Window on the next render cycle.
void | setMetricsMode (MetricsMode mode)
set the current metrics mode employed by the Window
void | setMinimumSize (const Size &sz)
Set the minimum size for this window.
void | setMaximumSize (const Size &sz)
Set the maximum size for this window.
void | setMouseCursor (const Image *image)
Set the mouse cursor image to be used when the mouse enters this window.
void | setMouseCursor (MouseCursorImage image)
Set the mouse cursor image to be used when the mouse enters this window.
void | setMouseCursor (const String &imageset, const String &image_name)
Set the mouse cursor image to be used when the mouse enters this window.
void | setUserData (void *user_data)
Set the user data set for this Window.
void | setXPosition (MetricsMode mode, float x)
set the x position of the window using the specified metrics system.
void | setYPosition (MetricsMode mode, float y)
set the y position of the window using the specified metrics system.
void | setPosition (MetricsMode mode, const Point &position)
set the position of the window using the specified metrics system.
void | setWidth (MetricsMode mode, float width)
set the width of the Window using the specified metrics system.
void | setHeight (MetricsMode mode, float height)
set the height of the Window using the specified metrics system.
void | setSize (MetricsMode mode, const Size &size)
set the size of the Window using the specified metrics system.
void | setRect (MetricsMode mode, const Rect &area)
set the Rect that describes the Window area using the specified metrics system.
void | setZOrderingEnabled (bool setting)
Set whether z-order changes are enabled or disabled for this Window.
void | setWantsMultiClickEvents (bool setting)
Set whether this window will receive multi-click events or multiple 'down' events instead.
void | setMouseAutoRepeatEnabled (bool setting)
Set whether mouse button down event autorepeat is enabled for this window.
void | setAutoRepeatDelay (float delay)
Set the current auto-repeat delay setting for this window.
void | setAutoRepeatRate (float rate)
Set the current auto-repeat rate setting for this window.
void | setDistributesCapturedInputs (bool setting)
Set whether the window wants inputs passed to its attached child windows when the window has inputs captured.
void | notifyDragDropItemEnters (DragContainer *item)
Internal support method for drag & drop. You do not normally call this directly from client code. See the DragContainer class.
void | notifyDragDropItemLeaves (DragContainer *item)
Internal support method for drag & drop. You do not normally call this directly from client code. See the DragContainer class.
void | notifyDragDropItemDropped (DragContainer *item)
Internal support method for drag & drop. You do not normally call this directly from client code. See the DragContainer class.
virtual void | destroy (void)
Internal destroy method which actually just adds the window and any parent destructed child windows to the dead pool.
void | setTooltip (Tooltip *tooltip)
Set the custom Tooltip object for this Window. This value may be NULL to indicate that the Window should use the system default Tooltip object.
void | setTooltipType (const String &tooltipType)
Set the custom Tooltip to be used by this Window by specifying a Window type.
void | setTooltipText (const String &tip)
Set the tooltip text for this window.
void | setInheritsTooltipText (bool setting)
Set whether this window inherits Tooltip text from its parent when its own tooltip text is not set.
void | setRiseOnClickEnabled (bool setting)
Set whether this window will rise to the top of the z-order when clicked with the left mouse button.
void | setVerticalAlignment (const VerticalAlignment alignment)
Set the vertical alignment.
void | setHorizontalAlignment (const HorizontalAlignment alignment)
Set the horizontal alignment.
void | setLookNFeel (const String &falagardType, const String &look)
Set the LookNFeel that shoule be used for this window.
void | setModalState (bool state)
Set the modal state for this Window.
virtual void | performChildWindowLayout ()
method called to perform extended laying out of attached child windows.
void | setUserString (const String &name, const String &value)
Sets the value a named user string, creating it as required.
float | absoluteToRelativeX (float val) const
Convert the given X co-ordinate from absolute to relative metrics.
float | absoluteToRelativeY (float val) const
Convert the given Y co-ordinate from absolute to relative metrics.
Point | absoluteToRelative (const Point &pt) const
Convert the given position from absolute to relative metrics.
Size | absoluteToRelative (const Size &sze) const
Convert the given size from absolute to relative metrics.
Rect | absoluteToRelative (const Rect &rect) const
Convert the given area from absolute to relative metrics.
float | relativeToAbsoluteX (float val) const
Convert the given X co-ordinate from relative to absolute metrics.
float | relativeToAbsoluteY (float val) const
Convert the given Y co-ordinate from relative to absolute metrics.
Point | relativeToAbsolute (const Point &pt) const
Convert the given position from relative to absolute metrics.
Size | relativeToAbsolute (const Size &sze) const
Convert the given size from relative to absolute metrics.
Rect | relativeToAbsolute (const Rect &rect) const
Convert the given area from relative to absolute metrics.
float | windowToScreenX (float x) const
Convert a window co-ordinate value, specified in whichever metrics mode is active, to a screen relative pixel co-ordinate.
float | windowToScreenY (float y) const
Convert a window co-ordinate value, specified in whichever metrics mode is active, to a screen relative pixel co-ordinate.
Point | windowToScreen (const Point &pt) const
Convert a window co-ordinate position, specified in whichever metrics mode is active, to a screen relative pixel co-ordinate position.
Size | windowToScreen (const Size &sze) const
Convert a window size value, specified in whichever metrics mode is active, to a size in pixels.
Rect | windowToScreen (const Rect &rect) const
Convert a window area, specified in whichever metrics mode is active, to a screen area.
float | screenToWindowX (float x) const
Convert a screen relative pixel co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.
float | screenToWindowY (float y) const
Convert a screen relative pixel co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.
Point | screenToWindow (const Point &pt) const
Convert a screen relative pixel position to a window co-ordinate position, specified in whichever metrics mode is active.
Size | screenToWindow (const Size &sze) const
Convert a pixel screen size to a window based size, specified in whichever metrics mode is active.
Rect | screenToWindow (const Rect &rect) const
Convert a screen area to a window area, specified in whichever metrics mode is active.
float | unifiedToRelativeX (const UDim &val) const
Convert the given X co-ordinate from unified to relative metrics.
float | unifiedToRelativeY (const UDim &val) const
Convert the given Y co-ordinate from unified to relative metrics.
Vector2 | unifiedToRelative (const UVector2 &val) const
Convert the given UVector2 value from unified to relative metrics.
Rect | unifiedToRelative (const URect &val) const
Convert the given area from unfied to relative metrics.
float | unifiedToAbsoluteX (const UDim &val) const
Convert the given X co-ordinate from unified to absolute metrics.
float | unifiedToAbsoluteY (const UDim &val) const
Convert the given Y co-ordinate from unified to absolute metrics.
Vector2 | unifiedToAbsolute (const UVector2 &val) const
Convert the given UVector2 value from unified to absolute metrics.
Rect | unifiedToAbsolute (const URect &val) const
Convert the given area from unfied to absolute metrics.
float | windowToScreenX (const UDim &x) const
Convert a window co-ordinate value, specified as a UDim, to a screen relative pixel co-ordinate.
float | windowToScreenY (const UDim &y) const
Convert a window co-ordinate value, specified as a UDim, to a screen relative pixel co-ordinate.
Vector2 | windowToScreen (const UVector2 &vec) const
Convert a window co-ordinate point, specified as a UVector2, to a screen relative pixel co-ordinate point.
Rect | windowToScreen (const URect &rect) const
Convert a window area, specified as a URect, to a screen area.
float | screenToWindowX (const UDim &x) const
Convert a screen relative UDim co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.
float | screenToWindowY (const UDim &y) const
Convert a screen relative UDim co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.
Vector2 | screenToWindow (const UVector2 &vec) const
Convert a screen relative UVector2 point to a window co-ordinate point, specified in whichever metrics mode is active.
Rect | screenToWindow (const URect &rect) const
Convert a URect screen area to a window area, specified in whichever metrics mode is active.
void | setWindowArea (const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height)
Set the window area.
void | setWindowArea (const UVector2 &pos, const UVector2 &size)
Set the window area.
void | setWindowArea (const URect &area)
Set the window area.
void | setWindowPosition (const UVector2 &pos)
Set the window's position.
void | setWindowXPosition (const UDim &x)
Set the window's X position.
void | setWindowYPosition (const UDim &y)
Set the window's Y position.
void | setWindowSize (const UVector2 &size)
Set the window's size.
void | setWindowWidth (const UDim &width)
Set the window's width.
void | setWindowHeight (const UDim &height)
Set the window's height.
void | setWindowMaxSize (const UVector2 &size)
Set the window's maximum size.
void | setWindowMinSize (const UVector2 &size)
Set the window's minimum size.
const URect & | getWindowArea () const
Return the windows area.
const UVector2 & | getWindowPosition () const
Get the window's position.
const UDim & | getWindowXPosition () const
Get the window's X position.
const UDim & | getWindowYPosition () const
Get the window's Y position.
UVector2 | getWindowSize () const
Get the window's size.
UDim | getWindowWidth () const
Get the window's width.
UDim | getWindowHeight () const
Get the window's height.
const UVector2 & | getWindowMaxSize () const
Get the window's maximum size.
const UVector2 & | getWindowMinSize () const
Get the window's minimum size.
void | render (void)
Causes the Window object to render itself and all of it's attached children.
void | update (float elapsed)
Cause window to update itself and any attached children. Client code does not need to call this method; to ensure full, and proper updates, call the injectTimePulse methodname method provided by the System class.
virtual void | writeXMLToStream (OutStream &out_stream) const
Writes an xml representation of this window object to out_stream.

Static Public Member Functions

static Window * | getCaptureWindow (void)
return the Window that currently has inputs captured.

Static Public Attributes

static const String | EventNamespace
Namespace for global events.
static const String | EventParentSized
Parent of this Window has been re-sized.
static const String | EventSized
Window size has changed.
static const String | EventMoved
Window position has changed.
static const String | EventTextChanged
Text string for the Window has changed.
static const String | EventFontChanged
Font object for the Window has been changed.
static const String | EventAlphaChanged
Alpha blend value for the Window has changed.
static const String | EventIDChanged
Client assigned ID code for the Window has changed.
static const String | EventActivated
Window has been activated (has input focus).
static const String | EventDeactivated
Window has been deactivated (loses input focus).
static const String | EventShown
Window has been made visible.
static const String | EventHidden
Window has been hidden from view.
static const String | EventEnabled
Window has been enabled (interaction is possible).
static const String | EventDisabled
Window has been disabled (interaction is no longer possible).
static const String | EventMetricsModeChanged
Active metrics mode has been modified.
static const String | EventClippedByParentChanged
Clipping by parent mode has been modified.
static const String | EventDestroyedByParentChanged
Destruction by parent mode has been modified.
static const String | EventInheritsAlphaChanged
Alpha inherited from parent mode has been modified.
static const String | EventAlwaysOnTopChanged
Always on top mode has been modified.
static const String | EventInputCaptureGained
Window has captured all inputs.
static const String | EventInputCaptureLost
Window has lost it's capture on inputs.
static const String | EventRenderingStarted
Rendering of the Window has started.
static const String | EventRenderingEnded
Rendering for the Window has finished.
static const String | EventChildAdded
A child Window has been added.
static const String | EventChildRemoved
A child window has been removed.
static const String | EventDestructionStarted
Destruction of the Window is about to begin.
static const String | EventZOrderChanged
The z-order of the window has changed.
static const String | EventDragDropItemEnters
A DragContainer has been dragged over this window.
static const String | EventDragDropItemLeaves
A DragContainer has left this window.
static const String | EventDragDropItemDropped
A DragContainer was dropped on this Window.
static const String | EventVerticalAlignmentChanged
The vertical alignment of the window has changed.
static const String | EventHorizontalAlignmentChanged
The vertical alignment of the window has changed.
static const String | EventMouseEnters
Mouse cursor has entered the Window.
static const String | EventMouseLeaves
Mouse cursor has left the Window.
static const String | EventMouseMove
Mouse cursor was moved within the area of the Window.
static const String | EventMouseWheel
Mouse wheel was scrolled within the Window.
static const String | EventMouseButtonDown
A mouse button was pressed down within the Window.
static const String | EventMouseButtonUp
A mouse button was released within the Window.
static const String | EventMouseClick
A mouse button was clicked (down then up) within the Window.
static const String | EventMouseDoubleClick
A mouse button was double-clicked within the Window.
static const String | EventMouseTripleClick
A mouse button was triple-clicked within the Window.
static const String | EventKeyDown
A key on the keyboard was pressed.
static const String | EventKeyUp
A key on the keyboard was released.
static const String | EventCharacterKey
A text character was typed on the keyboard.

Protected Types

typedef std::vector< Window * > | ChildList
typedef std::map< String,
String > 		UserStringMap

Protected Member Functions

virtual void | onSized (WindowEventArgs &e)
Handler called when the window's size changes.
virtual void | onMoved (WindowEventArgs &e)
Handler called when the window's position changes.
virtual void | onTextChanged (WindowEventArgs &e)
Handler called when the window's text is changed.
virtual void | onFontChanged (WindowEventArgs &e)
Handler called when the window's font is changed.
virtual void | onAlphaChanged (WindowEventArgs &e)
Handler called when the window's alpha blend value is changed.
virtual void | onIDChanged (WindowEventArgs &e)
Handler called when the window's client assigned ID is changed.
virtual void | onShown (WindowEventArgs &e)
Handler called when the window is shown (made visible).
virtual void | onHidden (WindowEventArgs &e)
Handler called when the window is hidden.
virtual void | onEnabled (WindowEventArgs &e)
Handler called when the window is enabled.
virtual void | onDisabled (WindowEventArgs &e)
Handler called when the window is disabled.
virtual void | onMetricsChanged (WindowEventArgs &e)
Handler called when the window's active metrics system is changed.
virtual void | onClippingChanged (WindowEventArgs &e)
Handler called when the window's setting for being clipped by it's parent is changed.
virtual void | onParentDestroyChanged (WindowEventArgs &e)
Handler called when the window's setting for being destroyed automatically be it's parent is changed.
virtual void | onInheritsAlphaChanged (WindowEventArgs &e)
Handler called when the window's setting for inheriting alpha-blending is changed.
virtual void | onAlwaysOnTopChanged (WindowEventArgs &e)
Handler called when the window's always-on-top setting is changed.
virtual void | onCaptureGained (WindowEventArgs &e)
Handler called when this window gains capture of mouse inputs.
virtual void | onCaptureLost (WindowEventArgs &e)
Handler called when this window loses capture of mouse inputs.
virtual void | onRenderingStarted (WindowEventArgs &e)
Handler called when rendering for this window has started.
virtual void | onRenderingEnded (WindowEventArgs &e)
Handler called when rendering for this window has ended.
virtual void | onZChanged (WindowEventArgs &e)
Handler called when the z-order position of this window has changed.
virtual void | onDestructionStarted (WindowEventArgs &e)
Handler called when this window's destruction sequence has begun.
virtual void | onActivated (ActivationEventArgs &e)
Handler called when this window has become the active window.
virtual void | onDeactivated (ActivationEventArgs &e)
Handler called when this window has lost input focus and has been deactivated.
virtual void | onParentSized (WindowEventArgs &e)
Handler called when this window's parent window has been resized. If this window is the root / GUI Sheet window, this call will be made when the screen size changes.
virtual void | onChildAdded (WindowEventArgs &e)
Handler called when a child window is added to this window.
virtual void | onChildRemoved (WindowEventArgs &e)
Handler called when a child window is removed from this window.
virtual void | onMouseEnters (MouseEventArgs &e)
Handler called when the mouse cursor has entered this window's area.
virtual void | onMouseLeaves (MouseEventArgs &e)
Handler called when the mouse cursor has left this window's area.
virtual void | onMouseMove (MouseEventArgs &e)
Handler called when the mouse cursor has been moved within this window's area.
virtual void | onMouseWheel (MouseEventArgs &e)
Handler called when the mouse wheel (z-axis) position changes within this window's area.
virtual void | onMouseButtonDown (MouseEventArgs &e)
Handler called when a mouse button has been depressed within this window's area.
virtual void | onMouseButtonUp (MouseEventArgs &e)
Handler called when a mouse button has been released within this window's area.
virtual void | onMouseClicked (MouseEventArgs &e)
Handler called when a mouse button has been clicked (that is depressed and then released, within a specified time) within this window's area.
virtual void | onMouseDoubleClicked (MouseEventArgs &e)
Handler called when a mouse button has been double-clicked within this window's area.
virtual void | onMouseTripleClicked (MouseEventArgs &e)
Handler called when a mouse button has been triple-clicked within this window's area.
virtual void | onKeyDown (KeyEventArgs &e)
Handler called when a key as been depressed while this window has input focus.
virtual void | onKeyUp (KeyEventArgs &e)
Handler called when a key as been released while this window has input focus.
virtual void | onCharacter (KeyEventArgs &e)
Handler called when a character-key has been pressed while this window has input focus.
virtual void | onDragDropItemEnters (DragDropEventArgs &e)
Handler called when a DragContainer is dragged over this window.
virtual void | onDragDropItemLeaves (DragDropEventArgs &e)
Handler called when a DragContainer is dragged over this window.
virtual void | onDragDropItemDropped (DragDropEventArgs &e)
Handler called when a DragContainer is dragged over this window.
virtual void | onVerticalAlignmentChanged (WindowEventArgs &e)
Handler called when the vertical alignment setting for the window is changed.
virtual void | onHorizontalAlignmentChanged (WindowEventArgs &e)
Handler called when the horizontal alignment setting for the window is changed.
virtual void | updateSelf (float elapsed)
Perform actual update processing for this Window.
virtual void | drawSelf (float z)
Perform the actual rendering for this Window.
virtual void | populateRenderCache ()
Update the rendering cache.
virtual bool | testClassName_impl (const String &class_name) const
Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.
void | setParent (Window *parent)
Set the parent window for this window object.
float | getParentWidth (void) const
Return the pixel Width of the parent element. This always returns a valid number.
float | getParentHeight (void) const
Return the pixel Height of the parent element. This always returns a valid number.
Size | getParentSize (void) const
Return the pixel size of the parent element. This always returns a valid object.
Rect | absoluteToRelative_impl (const Window *window, const Rect &rect) const
Return a Rect object that describes, in values relative to window, the absolute area described by rect.
Size | absoluteToRelative_impl (const Window *window, const Size &sz) const
Point | absoluteToRelative_impl (const Window *window, const Point &pt) const
float | absoluteToRelativeX_impl (const Window *window, float x) const
float | absoluteToRelativeY_impl (const Window *window, float y) const
Rect | relativeToAbsolute_impl (const Window *window, const Rect &rect) const
Return a Rect object that describes, in absolute values offset from window, the relative area described by rect.
Size | relativeToAbsolute_impl (const Window *window, const Size &sz) const
Point | relativeToAbsolute_impl (const Window *window, const Point &pt) const
float | relativeToAbsoluteX_impl (const Window *window, float x) const
float | relativeToAbsoluteY_impl (const Window *window, float y) const
Size | getWindowSize_impl (const Window *window) const
MetricsMode | getInheritedMetricsMode (void) const
Return the inherited metrics mode. This is either the metrics mode of our parent, or Relative if we have no parent.
void | generateAutoRepeatEvent (MouseButton button)
Fires off a repeated mouse button down event for this window.
void | addStandardEvents (void)
Add standard CEGUI::Window events.
virtual void | cleanupChildren (void)
Cleanup child windows.
virtual void | addChild_impl (Window *wnd)
Add given window to child list at an appropriate position.
virtual void | removeChild_impl (Window *wnd)
Remove given window from child list.
virtual void | onZChange_impl (void)
Notify 'this' and all siblings of a ZOrder change event.
void | addStandardProperties (void)
Add standard CEGUI::Window properties.
virtual void | moveToFront_impl (bool wasClicked)
Implements move to fron behavior.
void | doRiseOnClick (void)
Implementation of rise on click functionality.
void | setWindowArea_impl (const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true)
Implementation method to modify window area while correctly applying min / max size processing, and firing any appropriate events.
void | addWindowToDrawList (Window &wnd, bool at_back=false)
Add the given window to the drawing list at an appropriate position for it's settings and the required direction. Basically, when at_back is false, the window will appear in front of all other windows with the same 'always on top' setting. When at_back is true, the window will appear behind all other windows wih the same 'always on top' setting.
void | removeWindowFromDrawList (const Window &wnd)
Removes the window from the drawing list. If the window is not attached to the drawing list then nothing happens.
virtual int | writePropertiesXML (OutStream &out_stream) const
virtual int | writeChildWindowsXML (OutStream &out_stream) const
Window (const Window &wnd)
Window & | operator= (const Window &wnd)

Protected Attributes

ChildList | d_children
The list of child Window objects attached to this.
ChildList | d_drawList
Child window objects arranged in rendering order.
MetricsMode d_metricsMode
Holds the active metrics mode for this window.
Window * d_oldCapture
The Window that previously had capture (used for restoreOldCapture mode).
Window * d_parent
Holds pointer to the parent window.
const Font * | d_font
Holds pointer to the Window objects current Font.
String d_text
Holds the text / label / caption for this Window.
uint | d_ID
User ID assigned to this Window.
float | d_alpha
Alpha transparency setting for the Window.
URect d_area
This Window objects area as defined by a URect.
Size d_pixelSize
Current constrained pixel size of the window.
const Image * | d_mouseCursor
Holds pointer to the Window objects current mouse cursor image.
void * | d_userData
Holds pointer to some user assigned data.
UserStringMap | d_userStrings
Holds a collection of named user string values.
HorizontalAlignment d_horzAlign
Specifies the base for horizontal alignment.
VerticalAlignment d_vertAlign
Specifies the base for vertical alignment.
UVector2 d_minSize
current minimum size for the window.
UVector2 d_maxSize
current maximum size for the window.
bool | d_enabled
true when Window is enabled
bool | d_visible
true when Window is visible (that is it will be rendered, but may be obscured so no necesarily really visible)
bool | d_active
true when Window is the active Window (receiving inputs).
bool | d_clippedByParent
true when Window will be clipped by parent Window area Rect.
bool | d_destroyedByParent
true when Window will be auto-destroyed by parent.
bool | d_alwaysOnTop
true if Window will be drawn on top of all other Windows
bool | d_inheritsAlpha
true if the Window inherits alpha from the parent Window
bool | d_restoreOldCapture
true if the Window restores capture to the previous window when it releases capture.
bool | d_zOrderingEnabled
true if the Window responds to z-order change requests.
bool | d_wantsMultiClicks
true if the Window wishes to hear about multi-click mouse events.
bool | d_distCapturedInputs
true if unhandled captured inputs should be distributed to child windows.
bool | d_riseOnClick
True if the window should come to the front of the z order in respose to a left mouse button down event.
bool | d_autoRepeat
true if button will auto-repeat mouse button down events while mouse button is held down,
float | d_repeatDelay
seconds before first repeat event is fired
float | d_repeatRate
secons between further repeats after delay has expired.
bool | d_repeating
implements repeating - is true after delay has elapsed,
float | d_repeatElapsed
implements repeating - tracks time elapsed.
MouseButton d_repeatButton
Button we're tracking (implication of this is that we only support one button at a time).
String d_tooltipText
Text string used as tip for this window.
Tooltip * d_customTip
Possible custom Tooltip for this window.
bool | d_weOwnTip
true if this Window created the custom Tooltip.
bool | d_inheritsTipText
true if the Window inherits tooltip text from its parent (when none set for itself).
RenderCache d_renderCache
Object which acts as a cache for Images to be drawn by this Window.
bool | d_needsRedraw
true if window image cache needs to be regenerated.
String d_lookName
Name of the Look assigned to this window (if any).
const String | d_type
String holding the type name for the Window (is also the name of the WindowFactory that created us).
String d_name
The name of the window (GUI system unique).
String d_falagardType
Type name of the window as defined in a Falagard mapping.

Static Protected Attributes

static Window * | d_captureWindow = NULL
Window that has captured inputs.
static WindowProperties::AbsoluteHeight | d_absHeightProperty
static WindowProperties::AbsoluteMaxSize | d_absMaxSizeProperty
static WindowProperties::AbsoluteMinSize | d_absMinSizeProperty
static WindowProperties::AbsolutePosition | d_absPositionProperty
static WindowProperties::AbsoluteRect | d_absRectProperty
static WindowProperties::AbsoluteSize | d_absSizeProperty
static WindowProperties::AbsoluteWidth | d_absWidthProperty
static WindowProperties::AbsoluteXPosition | d_absXPosProperty
static WindowProperties::AbsoluteYPosition | d_absYPosProperty
static WindowProperties::Alpha | d_alphaProperty
static WindowProperties::AlwaysOnTop | d_alwaysOnTopProperty
static WindowProperties::ClippedByParent | d_clippedByParentProperty
static WindowProperties::DestroyedByParent | d_destroyedByParentProperty
static WindowProperties::Disabled | d_disabledProperty
static WindowProperties::Font | d_fontProperty
static WindowProperties::Height | d_heightProperty
static WindowProperties::ID | d_IDProperty
static WindowProperties::InheritsAlpha | d_inheritsAlphaProperty
static WindowProperties::MetricsMode | d_metricsModeProperty
static WindowProperties::MouseCursorImage | d_mouseCursorProperty
static WindowProperties::Position | d_positionProperty
static WindowProperties::Rect | d_rectProperty
static WindowProperties::RelativeHeight | d_relHeightProperty
static WindowProperties::RelativeMaxSize | d_relMaxSizeProperty
static WindowProperties::RelativeMinSize | d_relMinSizeProperty
static WindowProperties::RelativePosition | d_relPositionProperty
static WindowProperties::RelativeRect | d_relRectProperty
static WindowProperties::RelativeSize | d_relSizeProperty
static WindowProperties::RelativeWidth | d_relWidthProperty
static WindowProperties::RelativeXPosition | d_relXPosProperty
static WindowProperties::RelativeYPosition | d_relYPosProperty
static WindowProperties::RestoreOldCapture | d_restoreOldCaptureProperty
static WindowProperties::Size | d_sizeProperty
static WindowProperties::Text | d_textProperty
static WindowProperties::Visible | d_visibleProperty
static WindowProperties::Width | d_widthProperty
static WindowProperties::XPosition | d_xPosProperty
static WindowProperties::YPosition | d_yPosProperty
static WindowProperties::ZOrderChangeEnabled | d_zOrderChangeProperty
static WindowProperties::WantsMultiClickEvents | d_wantsMultiClicksProperty
static WindowProperties::MouseButtonDownAutoRepeat | d_autoRepeatProperty
static WindowProperties::AutoRepeatDelay | d_autoRepeatDelayProperty
static WindowProperties::AutoRepeatRate | d_autoRepeatRateProperty
static WindowProperties::DistributeCapturedInputs | d_distInputsProperty
static WindowProperties::CustomTooltipType | d_tooltipTypeProperty
static WindowProperties::Tooltip | d_tooltipProperty
static WindowProperties::InheritsTooltipText | d_inheritsTooltipProperty
static WindowProperties::RiseOnClick | d_riseOnClickProperty
static WindowProperties::VerticalAlignment | d_vertAlignProperty
static WindowProperties::HorizontalAlignment | d_horzAlignProperty
static WindowProperties::UnifiedAreaRect | d_unifiedAreaRectProperty
static WindowProperties::UnifiedPosition | d_unifiedPositionProperty
static WindowProperties::UnifiedXPosition | d_unifiedXPositionProperty
static WindowProperties::UnifiedYPosition | d_unifiedYPositionProperty
static WindowProperties::UnifiedSize | d_unifiedSizeProperty
static WindowProperties::UnifiedWidth | d_unifiedWidthProperty
static WindowProperties::UnifiedHeight | d_unifiedHeightProperty
static WindowProperties::UnifiedMinSize | d_unifiedMinSizeProperty
static WindowProperties::UnifiedMaxSize | d_unifiedMaxSizeProperty

Friends

class | System

Detailed Description

An abstract base class providing common functionality and specifying the required interface for derived classes.

The Window base class is the only UI object class that the core of the system knows about, for this reason every other window, widget, or similar item within the system must be derived from Window. The base class provides the common functionality required by all UI objects, and specifies the minimal interface required to be implemented by derived classes.

Constructor & Destructor Documentation

CEGUI::Window::Window | ( | const String & | type,
 |  | const String & | name
 | ) |

Constructor for Window base class.

Parameters:
type | String object holding Window type (usually provided by WindowFactory).
name | String object holding unique name for the Window.

Member Function Documentation

Rect CEGUI::Window::absoluteToRelative ( const Rect & rect ) const

Convert the given area from absolute to relative metrics.

Parameters:
rect Rect object describing the area specified in pixels relative to this Window.
Returns:
A Rect object describing a relative metric area that is equivalent to rect, given the Window objects current size.

Size CEGUI::Window::absoluteToRelative ( const Size & sze ) const

Convert the given size from absolute to relative metrics.

Parameters:
sze Size object that describes a size specified in pixels.
Returns:
A Size object describing a relative metric size that is equivalent to sze, given the Window objects current size.

Point CEGUI::Window::absoluteToRelative ( const Point & pt ) const

Convert the given position from absolute to relative metrics.

Parameters:
pt Point object that describes a position specified in pixels relative to this Window (so 0,0 is this windows top-left corner).
Returns:
A Point object describing a relative metric position that is equivalent to pt, given the Window objects current size.

Rect CEGUI::Window::absoluteToRelative_impl | ( | const Window * | window,
 |  | const Rect & | rect
 | ) | const [protected]

Return a Rect object that describes, in values relative to window, the absolute area described by rect.

Parameters:
window | Pointer to a window object that is to be used as the base for the conversion. If this is NULL then the size of the display, as returned by the renderer object, is used.
rect | Rect object describing the area, in absolute values, that is to be returned as relative values.
Returns:
Rect object that describes in values relative to window, the same area described as absolute values in rect.

float CEGUI::Window::absoluteToRelativeX ( float val ) const

Convert the given X co-ordinate from absolute to relative metrics.

Parameters:
val X co-ordinate specified in pixels relative to this Window (so 0 is this windows left edge).
Returns:
A relative metric value that is equivalent to val, given the Window objects current width.

float CEGUI::Window::absoluteToRelativeY ( float val ) const

Convert the given Y co-ordinate from absolute to relative metrics.

Parameters:
val Y co-ordinate specified in pixels relative to this Window (so 0 is this windows top edge).
Returns:
A relative metric value that is equivalent to val, given the Window objects current height.

void CEGUI::Window::activate ( void )

Activate the Window giving it input focus and bringing it to the top of all non always-on-top Windows.

Returns:
Nothing

void CEGUI::Window::addChildWindow ( Window * window )

Add the specified Window as a child of this Window. If the Window window is already attached to a Window, it is detached before being added to this Window.

Parameters:
window Pointer to the Window object to be added.
Returns:
Nothing
Exceptions:
InvalidRequestException thrown if Window window is an ancestor of this Window, to prevent cyclic Window structures.

void CEGUI::Window::addChildWindow ( const String & name )

Add the named Window as a child of this Window. If the Window name is already attached to a Window, it is detached before being added to this Window.

Parameters:
name String object holding the name of the Window to be added.
Returns:
Nothing.
Exceptions:
UnknownObjectException | thrown if no Window named name exists.
InvalidRequestException | thrown if Window name is an ancestor of this Window, to prevent cyclic Window structures.

void CEGUI::Window::addWindowToDrawList | ( | Window & | wnd,
 |  | bool | at_back = false
 | ) | [protected]

Add the given window to the drawing list at an appropriate position for it's settings and the required direction. Basically, when at_back is false, the window will appear in front of all other windows with the same 'always on top' setting. When at_back is true, the window will appear behind all other windows wih the same 'always on top' setting.

Parameters:
wnd | Window object to be added to the drawing list.
at_back | Indicates whether the window should be placed at the back of other windows in the same group. If this is false, the window is place in front of other windows in the group.
Returns:
Nothing.

bool CEGUI::Window::captureInput ( void )

Captures input to this window.

Returns:
  • true if input was successfully captured to this window.
  • false if input could not be captured to this window (maybe because the window is not active).

void CEGUI::Window::deactivate ( void )

Deactivate the window. No further inputs will be received by the window until it is re-activated either programmatically or by the user interacting with the gui.

Returns:
Nothing.

void CEGUI::Window::destroy ( void ) [virtual]

Internal destroy method which actually just adds the window and any parent destructed child windows to the dead pool.

This is virtual to allow for specialised cleanup which may be required in some advanced cases. If you override this for the above reason, you MUST call this base class version.

Note:
You never have to call this method yourself, use WindowManager to destroy your Window objects (which will call this for you).

void CEGUI::Window::disable ( void ) [inline]

disable the Window to prevent interaction.

Returns:
Nothing

bool CEGUI::Window::distributesCapturedInputs ( void ) const

Return whether the window wants inputs passed to its attached child windows when the window has inputs captured.

Returns:
  • true if System should pass captured input events to child windows.
  • false if System should pass captured input events to this window only.

void CEGUI::Window::drawSelf ( float z ) [protected, virtual]

Perform the actual rendering for this Window.

Parameters:
z float value specifying the base Z co-ordinate that should be used when rendering
Returns:
Nothing

Reimplemented in CEGUI::ButtonBase, CEGUI::DragContainer, CEGUI::GUISheet, CEGUI::ScrolledContainer, CEGUI::TabButton, and CEGUI::TabControl.

void CEGUI::Window::enable ( void ) [inline]

enable the Window to allow interaction.

Returns:
Nothing

float CEGUI::Window::getAbsoluteHeight ( void ) const [inline]

Return the window height in absolute metrics.

Returns:
float value describing this windows height in absolute metrics.

Point CEGUI::Window::getAbsolutePosition ( void ) const [inline]

Return the window position in absolute metrics.

Returns:
Point object describing this windows position, relative to the parent window, in absolute metrics.

Rect CEGUI::Window::getAbsoluteRect ( void ) const [inline]

Return the window area rect in absolute metrics.

Returns:
Rect object describing this windows area, relative to the parent window, in absolute metrics

Size CEGUI::Window::getAbsoluteSize ( void ) const [inline]

Return the window size in absolute metrics.

Returns:
Size object describing this windows size in absolute metrics.

float CEGUI::Window::getAbsoluteWidth ( void ) const [inline]

Return the window width in absolute metrics.

Returns:
float value describing this windows width in absolute metrics.

float CEGUI::Window::getAbsoluteXPosition ( void ) const [inline]

Return the window X position in absolute metrics.

Returns:
float value describing this windows X position, relative to the parent window, in absolute metrics.

float CEGUI::Window::getAbsoluteYPosition ( void ) const [inline]

Return the window Y position in absolute metrics.

Returns:
float value describing this windows Y position, relative to the parent window, in absolute metrics.

Window * CEGUI::Window::getActiveChild ( void )

return a pointer to the Window that currently has input focus starting with this Window.

Returns:
Pointer to the window that is active (has input focus) starting at 'this. Will return 'this' if this Window is active and either no children are attached or if none of the attached children are active. Returns NULL if this Window (and therefore all children) are not active.

Window * CEGUI::Window::getActiveSibling ( )

Returns the active sibling window.

This searches the immediate children of this window's parent, and returns a pointer to the active window. The method will return this if we are the immediate child of our parent that is active. If our parent is not active, or if no immediate child of our parent is active then 0 is returned. If this window has no parent, and this window is not active then 0 is returned, else this is returned.

Returns:
A pointer to the immediate child window attached to our parent that is currently active, or 0 if no immediate child of our parent is active.

float CEGUI::Window::getAlpha ( void ) const [inline]

return the current alpha value set for this Window

Note:
The alpha value set for any given window may or may not be the final alpha value that is used when rendering. All window objects, by default, inherit alpha from thier parent window(s) - this will blend child windows, relatively, down the line of inheritance. This behaviour can be overridden via the setInheritsAlpha() method. To return the true alpha value that will be applied when rendering, use the getEffectiveAlpha() method.
Returns:
the currently set alpha value for this Window. Will be between 0.0f and 1.0f.

float CEGUI::Window::getAutoRepeatDelay ( void ) const

Return the current auto-repeat delay setting for this window.

Returns:
float value indicating the delay, in seconds, defore the first repeat mouse button down event will be triggered when autorepeat is enabled.

float CEGUI::Window::getAutoRepeatRate ( void ) const

Return the current auto-repeat rate setting for this window.

Returns:
float value indicating the rate, in seconds, at which repeat mouse button down events will be generated after the initial delay has expired.

static Window* CEGUI::Window::getCaptureWindow ( void ) [inline, static]

return the Window that currently has inputs captured.

Returns:
Pointer to the Window object that currently has inputs captured, or NULL if no Window has captured input.

Window * CEGUI::Window::getChild ( uint ID ) const

return a pointer to the first attached child window with the specified ID.

This function will throw an exception if no child object with the given ID is attached. This decision was made (over returning NULL if no window was found) so that client code can assume that if the call returns it has a valid window pointer. We provide the isChild() functions for checking if a given window is attached.

Parameters:
ID uint value specifying the ID code of the window to return a pointer to.
Returns:
Pointer to the (first) Window object attached to this window that has the ID code ID.
Exceptions:
UnknownObjectException thrown if no window with the ID code ID is attached to this Window.

Window * CEGUI::Window::getChild ( const String & name ) const

return a pointer to the child window with the specified name.

This function will throw an exception if no child object with the given name is attached. This decision was made (over returning NULL if no window was found) so that client code can assume that if the call returns it has a valid window pointer. We provide the isChild() functions for checking if a given window is attached.

Parameters:
name String object holding the name of the child window to return a pointer to.
Returns:
Pointer to the Window object attached to this window that has the name name.
Exceptions:
UnknownObjectException thrown if no window named name is attached to this Window.

Window* CEGUI::Window::getChildAtIdx ( uint idx ) const [inline]

return a pointer to the child window that is attached to 'this' at the given index.

Parameters:
idx Index of the child window whos pointer should be returned. This value is not bounds checked, client code should ensure that this is less than the value returned by getChildCount().
Returns:
Pointer to the child window currently attached at index position idx

Window * CEGUI::Window::getChildAtPosition ( const Point & position ) const

return the child Window that is 'hit' by the given position

Parameters:
position Point object that describes the position to check in screen pixels
Returns:
Pointer to the child Window that was hit according to the Point position, or NULL if no child window was hit.

uint CEGUI::Window::getChildCount ( void ) const [inline]

return the number of child Window objects currently attached to this Window.

Returns:
uint value equal to the number of Window objects directly attached to this Window as children.

float CEGUI::Window::getEffectiveAlpha ( void ) const

return the effective alpha value that will be used when rendering this window, taking into account inheritance of parent window(s) alpha.

Returns:
the effective alpha that will be applied to this Window when rendering. Will be between 0.0f and 1.0f.

const Font * CEGUI::Window::getFont ( bool useDefault = true ) const

return the Font object active for the Window.

Parameters:
useDefault Sepcifies whether to return the default font if Window has no preference set.
Returns:
Pointer to the Font being used by this Window. If the window has no assigned font, the default font is returned.

float CEGUI::Window::getHeight ( MetricsMode mode ) const

return the height of the Window using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
float value that specifies the height of the Window using the specified MetricsMode.

float CEGUI::Window::getHeight ( void ) const

return the height of the Window. Interpretation of return value depends upon the metric type in use by this window.

Returns:
float value that specifies the height of the Window. Depending upon the metrics system in use for this window, the return value will either be in pixels, or as a decimal fraction of the height of the parent Window.

HorizontalAlignment CEGUI::Window::getHorizontalAlignment ( ) const [inline]

Get the horizontal alignment.

Returns the horizontal alignment for the window. This setting affects how the windows position is interpreted relative to its parent.

Returns:
One of the HorizontalAlignment enumerated values.

uint CEGUI::Window::getID ( void ) const [inline]

return the ID code currently assigned to this Window by client code.

Returns:
uint value equal to the currently assigned ID code for this Window.

Rect CEGUI::Window::getInnerRect ( void ) const

return a Rect object describing the clipped inner area for this window.

Returns:
Rect object that describes, in appropriately clipped screen pixel co-ordinates, the window object's inner rect area.

const String & CEGUI::Window::getLookNFeel ( )

Get the name of the LookNFeel assigned to this window.

Returns:
String object holding the name of the look assigned to this window. Returns the empty string if no look is assigned.

Size CEGUI::Window::getMaximumSize ( void ) const

Return the current maximum size for this window.

Returns:
Size object describing the maximum size for this window. If using absolute co-ordinates the returned object has it's values expressed as screen pixels. If using relative co-ordinates the returned object has it's values expressed as fractions of the current display size.

MetricsMode CEGUI::Window::getMetricsMode ( void ) const

return the current metrics mode employed by the Window

Returns:
One of the values of the MectricsMode enumerated type, that describes the current metrics in use by the Window.

Size CEGUI::Window::getMinimumSize ( void ) const

Return the current minimum size for this window.

Returns:
Size object describing the minimum size for this window. If using absolute co-ordinates the returned object has it's values expressed as screen pixels. If using relative co-ordinates the returned object has it's values expressed as fractions of the current display size.

bool CEGUI::Window::getModalState ( void ) const [inline]

Get whether or not this Window is the modal target.

Returns:
Returns true if this Window is the modal target, otherwise false.

const Image * CEGUI::Window::getMouseCursor ( bool useDefault = true ) const

Return a pointer to the mouse cursor image to use when the mouse is within this window.

Parameters:
useDefault Sepcifies whether to return the default font if Window has no preference set.
Returns:
Pointer to the mouse cursor image that will be used when the mouse enters this window. May return NULL indicating no cursor.

const String& CEGUI::Window::getName ( void ) const [inline]

return a String object holding the name of this Window.

Returns:
String object holding the unique Window name.

Window* CEGUI::Window::getParent ( void ) const [inline]

return the parent of this Window.

Returns:
Pointer to the Window object that is the parent of this Window. This value can be NULL, in which case the Window is a GUI Sheet / Root.

float CEGUI::Window::getParentHeight ( void ) const [protected]

Return the pixel Height of the parent element. This always returns a valid number.

Returns:
float value that is equal to the pixel height of this Window objects parent

Size CEGUI::Window::getParentSize ( void ) const [protected]

Return the pixel size of the parent element. This always returns a valid object.

Returns:
Size object that describes the pixel dimensions of this Window objects parent

float CEGUI::Window::getParentWidth ( void ) const [protected]

Return the pixel Width of the parent element. This always returns a valid number.

Returns:
float value that is equal to the pixel width of this Window objects parent

Rect CEGUI::Window::getPixelRect ( void ) const [virtual]

return a Rect object describing the Window area in screen space.

Returns:
Rect object that describes the area covered by the Window. The values in the returned Rect are in screen pixels. The returned Rect is clipped as appropriate and depending upon the 'ClippedByParent' setting.
Note:
This has now been made virtual to ease some customisations that require more specialised clipping requirements.

Point CEGUI::Window::getPosition ( MetricsMode mode ) const

return the position of the window using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
Point object that describes the position of the Window relative to it's parent, using the specified MetricsMode.

Point CEGUI::Window::getPosition ( void ) const

return the position of the window. Interpretation of return value depends upon the metric type in use by this window.

Returns:
Point object that describes the position of the Window relative to it's parent, depending on the metrics system in use for this Window, the values in the Point will specify either pixels or decimal fractions of the total width and height of the parent.

Rect CEGUI::Window::getRect ( MetricsMode mode ) const

return a Rect object that describes the Window area using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
Rect object that describes the area covered by the Window using the specified MetricsMode.

Rect CEGUI::Window::getRect ( void ) const

return a Rect object that describes the Window area.

Returns:
Rect object that describes the area covered by the Window. The values in the returned Rect are in whatever form is set as the current metric type. The returned Rect is unclipped and relative to the Window objects parent.

float CEGUI::Window::getRelativeHeight ( void ) const [inline]

Return the window height in relative metrics.

Returns:
float value describing this windows height in parent relative metrics.

Point CEGUI::Window::getRelativePosition ( void ) const [inline]

Return the window position in relative metrics.

Returns:
Point object describing this windows position, relative to the parent window, in parent relative metrics.

Rect CEGUI::Window::getRelativeRect ( void ) const [inline]

Return the window area rect in relative metrics.

Returns:
Rect object describing this windows area, relative to the parent window, in parent relative metrics.

Size CEGUI::Window::getRelativeSize ( void ) const [inline]

Return the window size in relative metrics.

Returns:
Size object describing this windows size in parent relative metrics.

float CEGUI::Window::getRelativeWidth ( void ) const [inline]

Return the window width in relative metrics.

Returns:
float value describing this windows width in parent relative metrics.

float CEGUI::Window::getRelativeXPosition ( void ) const [inline]

Return the window X position in relative metrics.

Returns:
float value describing this windows X position, relative to the parent window, in parent relative metrics.

float CEGUI::Window::getRelativeYPosition ( void ) const [inline]

Return the window Y position in relative metrics.

Returns:
float value describing this windows Y position, relative to the parent window, in parent relative metrics.

RenderCache& CEGUI::Window::getRenderCache ( ) [inline]

Return the RenderCache object for this Window.

Returns:
Reference to the RenderCache object for this Window.

Size CEGUI::Window::getSize ( MetricsMode mode ) const

return the size of the Window using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
Size object that describes the dimensions of the Window using the specified MetricsMode.

Size CEGUI::Window::getSize ( void ) const

return the size of the Window. Interpretation of return value depends upon the metric type in use by this window.

Returns:
Size object that describes the dimensions of the Window. Depending upon the metrics system in use for this window, the values will either be in pixels, or as decimal fractions of the width and height of the parent Window.

const String& CEGUI::Window::getText ( void ) const [inline]

return the current text for the Window

Returns:
A String object that holds the current text for this Window.

Tooltip * CEGUI::Window::getTooltip ( void ) const

Return a pointer to the Tooltip object used by this Window. The value returned may point to the system default Tooltip, a custom Window specific Tooltip, or be NULL.

Returns:
Pointer to a Tooltip based object, or NULL.

const String & CEGUI::Window::getTooltipText ( void ) const

Return the current tooltip text set for this Window.

Returns:
String object holding the current tooltip text set for this window.

String CEGUI::Window::getTooltipType ( void ) const

Return the custom tooltip type.

Returns:
String object holding the current custom tooltip window type, or an empty string if no custom tooltip is set.

const String & CEGUI::Window::getType ( void ) const

return a String object holding the type name for this Window.

Returns:
String object holding the Window type.

Rect CEGUI::Window::getUnclippedInnerRect ( void ) const [virtual]

Return a Rect object that describes, unclipped, the inner rectangle for this window. The inner rectangle is typically an area that excludes some frame or other rendering that should not be touched by subsequent rendering.

Returns:
Rect object that describes, in unclipped screen pixel co-ordinates, the window object's inner rect area.

Reimplemented in CEGUI::ScrolledContainer, CEGUI::Static, and CEGUI::StaticText.

Rect CEGUI::Window::getUnclippedPixelRect ( void ) const

return a Rect object describing the Window area unclipped, in screen space.

Returns:
Rect object that describes the area covered by the Window. The values in the returned Rect are in screen pixels. The returned rect is fully unclipped.

void* CEGUI::Window::getUserData ( void ) const [inline]

Return the user data set for this Window.

Each Window can have some client assigned data attached to it, this data is not used by the GUI system in any way. Interpretation of the data is entirely application specific.

Returns:
pointer to the user data that is currently set for this window.

const String & CEGUI::Window::getUserString ( const String & name ) const

Returns a named user string.

Parameters:
name String object holding the name of the string to be returned.
Returns:
String object holding the data stored for the requested user string.
Exceptions:
UnknownObjectException thrown if a user string named name does not exist.

VerticalAlignment CEGUI::Window::getVerticalAlignment ( ) const [inline]

Get the vertical alignment.

Returns the vertical alignment for the window. This setting affects how the windows position is interpreted relative to its parent.

Returns:
One of the VerticalAlignment enumerated values.

float CEGUI::Window::getWidth ( MetricsMode mode ) const

return the width of the Window using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
float value that specifies the width of the Window using the specified MetricsMode.

float CEGUI::Window::getWidth ( void ) const

return the width of the Window. Interpretation of return value depends upon the metric type in use by this window.

Returns:
float value that specifies the width of the Window. Depending upon the metrics system in use for this window, the return value will either be in pixels, or as a decimal fraction of the width of the parent Window.

const URect & CEGUI::Window::getWindowArea ( ) const

Return the windows area.

Returns the area occupied by this window. The defined area is offset from the top-left corner of this windows parent window or from the top-left corner of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
URect describing the rectangle of the window area.

UDim CEGUI::Window::getWindowHeight ( ) const

Get the window's height.

Gets the height of the area occupied by this window.

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UDim describing the height of the window area.

const UVector2 & CEGUI::Window::getWindowMaxSize ( ) const

Get the window's maximum size.

Gets the maximum size that this windows area may occupy (whether size changes occur by user interaction, general system operation, or by direct setting by client code).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UVector2 describing the maximum size of the window area.

const UVector2 & CEGUI::Window::getWindowMinSize ( ) const

Get the window's minimum size.

Gets the minimum size that this windows area may occupy (whether size changes occur by user interaction, general system operation, or by direct setting by client code).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UVector2 describing the minimum size of the window area.

const UVector2 & CEGUI::Window::getWindowPosition ( ) const

Get the window's position.

Gets the position of the area occupied by this window. The position is offset from the top-left corner of this windows parent window or from the top-left corner of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UVector2 describing the position (top-left corner) of the window area.

UVector2 CEGUI::Window::getWindowSize ( ) const

Get the window's size.

Gets the size of the area occupied by this window.

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UVector2 describing the size of the window area.

UDim CEGUI::Window::getWindowWidth ( ) const

Get the window's width.

Gets the width of the area occupied by this window.

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UDim describing the width of the window area.

const UDim & CEGUI::Window::getWindowXPosition ( ) const

Get the window's X position.

Gets the x position (left edge) of the area occupied by this window. The position is offset from the left edge of this windows parent window or from the left edge of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UDim describing the x position of the window area.

const UDim & CEGUI::Window::getWindowYPosition ( ) const

Get the window's Y position.

Gets the y position (top edge) of the area occupied by this window. The position is offset from the top edge of this windows parent window or from the top edge of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Returns:
UDim describing the y position of the window area.

float CEGUI::Window::getXPosition ( MetricsMode mode ) const

return the x position of the window using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
float value that specifies the x position of the Window relative to it's parent, using the specified MetricsMode.

float CEGUI::Window::getXPosition ( void ) const

return the x position of the window. Interpretation of return value depends upon the metric type in use by this window.

Returns:
float value that specifies the x position of the Window relative to it's parent, depending on the metrics system in use for this Window, this value will specify either pixels or a decimal fraction of the width of the parent Window.

float CEGUI::Window::getYPosition ( MetricsMode mode ) const

return the y position of the window using the specified metrics system.

Parameters:
mode One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
Returns:
float value that specifies the y position of the Window relative to it's parent, using the specified MetricsMode.

float CEGUI::Window::getYPosition ( void ) const

return the y position of the window. Interpretation of return value depends upon the metric type in use by this window.

Returns:
float value that specifies the y position of the Window relative to it's parent, depending on the metrics system in use for this Window, this value will specify either pixels or a decimal fraction of the height of the parent Window.

void CEGUI::Window::hide ( void ) [inline]

hide the Window.

Returns:
Nothing

bool CEGUI::Window::inheritsAlpha ( void ) const [inline]

return true if the Window inherits alpha from its parent(s).

Returns:
true if the Window inherits alpha from its parent(s), false if the alpha for this Window is independant.

bool CEGUI::Window::inheritsTooltipText ( void ) const

Return whether this window inherits Tooltip text from its parent when its own tooltip text is not set.

Returns:
  • true if the window inherits tooltip text from its parent when its own text is not set.
  • false if the window does not inherit tooltip text from its parent (and shows no tooltip when no text is set).

virtual void CEGUI::Window::initialise ( void ) [inline, virtual]

Initialises the Window based object ready for use.

Note:
This must be called for every window created. Normally this is handled automatically by the WindowFactory for each Window type.
Returns:
Nothing

Reimplemented in CEGUI::Combobox, CEGUI::ComboDropList, CEGUI::FrameWindow, CEGUI::GUISheet, CEGUI::ItemListBase, CEGUI::Listbox, CEGUI::MultiColumnList, CEGUI::MultiLineEditbox, CEGUI::ScrollablePane, CEGUI::Scrollbar, CEGUI::Slider, CEGUI::Spinner, CEGUI::StaticText, and CEGUI::TabControl.

bool CEGUI::Window::isActive ( void ) const

return true if this is the active Window (the window that receives inputs)

Mouse events are always sent to the window containing the mouse cursor regardless of what this reports (unless the window has captured inputs). This mainly refers to where other (keyboard) inputs are sent.

Returns:
true if this window has input focus, or false if it does not.

bool CEGUI::Window::isAlwaysOnTop ( void ) const [inline]

returns whether or not this Window is an always on top (a.k.a 'topmost') Window.

Returns:
true if this Window is always show on top of other normal windows. false if the Window has normal z-order behaviour.

bool CEGUI::Window::isAncestor ( const Window * window ) const

return true if the specified Window is some ancestor of this Window.

Parameters:
window Pointer to the Window object to look for.
Returns:
true if window was found to be an ancestor (parent, or parent of parent, etc) of this Window, otherwise false.

bool CEGUI::Window::isAncestor ( uint ID ) const

return true if any Window with the given ID is some ancestor of this Window.

Parameters:
ID uint value specifying the ID to look for.
Returns:
true if an ancestor (parent, or parent of parent, etc) was found with the ID code ID, else false.

bool CEGUI::Window::isAncestor ( const String & name ) const

return true if the specified Window is some ancestor of this Window

Parameters:
name String object holding the name of the Window to check for.
Returns:
true if a Window named name is an ancestor (parent, or parent of parent, etc) of this Window, or false if not.

bool CEGUI::Window::isCapturedByAncestor ( void ) const [inline]

return true if a child window has captured inputs.

Returns:
true if inputs are captured by a Window that is attached as a child of this Window, else false.

bool CEGUI::Window::isCapturedByChild ( void ) const [inline]

return true if an ancestor window has captured inputs.

Returns:
true if inputs are captured by a Window that is some ancestor (parent, parent of parent, etc) of this Window, else false.

bool CEGUI::Window::isCapturedByThis ( void ) const [inline]

return true if this Window has input captured.

Returns:
true if this Window has captured inputs, or false if some other Window, or no Window, has captured inputs.

bool CEGUI::Window::isChild ( const Window * window ) const

return true if the given Window is a child of this window.

Parameters:
window Pointer to the Window object to look for.
Returns:
true if Window object window is attached to this window as a child.

bool CEGUI::Window::isChild ( uint ID ) const

returns whether at least one window with the given ID code is attached as a child.

Note:
ID codes are client assigned and may or may not be unique, and as such, the return from this function will only have meaning to the client code.
Parameters:
ID uint ID code to look for.
Returns:
true if a child window was found with the ID code ID, or false if no child window was found with the ID ID.

bool CEGUI::Window::isChild ( const String & name ) const

returns whether a Window with the specified name is currently attached to this Window as a child.

Parameters:
name String object containing the name of the Window to look for.
Returns:
true if a Window named name is currently attached to this Window as a child, else false.

bool CEGUI::Window::isClippedByParent ( void ) const [inline]

return true if this Window is clipped so that its rendering does not pass outside its parent windows area.

Returns:
true if the window will be clipped by its parent window, or false if this windows rendering may pass outside its parents area

bool CEGUI::Window::isDestroyedByParent ( void ) const [inline]

returns whether or not this Window is set to be destroyed when its parent is destroyed.

Returns:
true if the Window will be destroyed when its parent is destroyed, false if it will remain.

bool CEGUI::Window::isDisabled ( bool localOnly = false ) const

return true if the Window is currently disabled

Parameters:
localOnly States whether to only return the state set for this window, and so not factor in inherited state from ancestor windows.
Returns:
true if the window is disabled, false if the window is enabled.

bool CEGUI::Window::isHit ( const Point & position ) const [virtual]

check if the given position would hit this window.

Parameters:
position Point object describing the position to check in screen pixels
Returns:
true if position 'hits' this Window, else false.

Reimplemented in CEGUI::Combobox, and CEGUI::FrameWindow.

bool CEGUI::Window::isMouseAutoRepeatEnabled ( void ) const

Return whether mouse button down event autorepeat is enabled for this window.

Returns:
  • true if autorepeat of mouse button down events is enabled for this window.
  • false if autorepeat of mouse button down events is not enabled for this window.

bool CEGUI::Window::isRiseOnClickEnabled ( void ) const [inline]

Return whether this window will rise to the top of the z-order when clicked with the left mouse button.

Returns:
  • true if the window will come to the top of other windows when the left mouse button is pushed within its area.
  • false if the window does not change z-order position when the left mouse button is pushed within its area.

bool CEGUI::Window::isUserStringDefined ( const String & name ) const

Return whether a user string with the specified name exists.

Parameters:
name String object holding the name of the string to be checked.
Returns:
  • true if a user string named name exists.
  • false if no such user string exists.

bool CEGUI::Window::isUsingDefaultTooltip ( void ) const

Return whether this Window is using the system default Tooltip for its Tooltip window.

Returns:
  • true if the Window will use the system default tooltip.
  • false if the window has a custom Tooltip object.

bool CEGUI::Window::isVisible ( bool localOnly = false ) const

return true if the Window is currently visible.

A true return from this function does not mean that the window is not completely obscured by other windows, just that the window is processed when rendering and is not hidden.

Parameters:
localOnly States whether to only return the state set for this window, and so not factor in inherited state from ancestor windows.
Returns:
true if the window is drawn, false if the window is hidden and therefore ignored when rendering.

bool CEGUI::Window::isZOrderingEnabled ( void ) const

Return whether z-order changes are enabled or disabled for this Window.

Returns:
  • true if z-order changes are enabled for this window. moveToFront/moveToBack work normally as expected.
  • false: z-order changes are disabled for this window. moveToFront/moveToBack are ignored for this window.

void CEGUI::Window::moveToBack ( )

Move the Window to the bottom of the Z order.

  • If the window is non always-on-top the Window is sent to the very bottom of its sibling windows and the process repeated for all ancestors.
  • If the window is always-on-top, the Window is sent to the bottom of all sibling always-on-top windows and the process repeated for all ancestors.

Returns:
Nothing

void CEGUI::Window::moveToFront ( )

Move the Window to the top of the z order.

  • If the Window is a non always-on-top window it is moved the the top of all other non always-on-top sibling windows, and the process repeated for all ancestors.
  • If the Window is an always-on-top window it is moved to the of of all sibling Windows, and the process repeated for all ancestors.

Returns:
Nothing

void CEGUI::Window::onActivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has become the active window.

Parameters:
e ActivationEventArgs class whose 'otherWindow' field is set to the window that previously was active, or NULL for none.

Reimplemented in CEGUI::Combobox, CEGUI::ComboDropList, CEGUI::FrameWindow, and CEGUI::Spinner.

void CEGUI::Window::onAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's alpha blend value is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented in CEGUI::DragContainer, CEGUI::PopupMenu, CEGUI::Static, and CEGUI::StaticImage.

void CEGUI::Window::onAlwaysOnTopChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's always-on-top setting is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onCaptureGained ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window gains capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onCaptureLost ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window loses capture of mouse inputs.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented in CEGUI::ButtonBase, CEGUI::ComboDropList, CEGUI::DragContainer, CEGUI::Editbox, CEGUI::FrameWindow, CEGUI::ListHeaderSegment, CEGUI::MenuItem, CEGUI::MultiLineEditbox, CEGUI::Thumb, and CEGUI::Titlebar.

void CEGUI::Window::onCharacter ( KeyEventArgs & e ) [protected, virtual]

Handler called when a character-key has been pressed while this window has input focus.

Parameters:
e KeyEventArgs object whose 'codepoint' field is set to the Unicode code point (encoded as utf32) for the character typed, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated. All other fields should be considered as 'junk'.

Reimplemented in CEGUI::Editbox, and CEGUI::MultiLineEditbox.

void CEGUI::Window::onChildAdded ( WindowEventArgs & e ) [protected, virtual]

Handler called when a child window is added to this window.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that has been added.

Reimplemented in CEGUI::ScrolledContainer.

void CEGUI::Window::onChildRemoved ( WindowEventArgs & e ) [protected, virtual]

Handler called when a child window is removed from this window.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set the window that has been removed.

Reimplemented in CEGUI::ScrolledContainer.

void CEGUI::Window::onClippingChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's setting for being clipped by it's parent is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented in CEGUI::DragContainer.

void CEGUI::Window::onDeactivated ( ActivationEventArgs & e ) [protected, virtual]

Handler called when this window has lost input focus and has been deactivated.

Parameters:
e ActivationEventArgs object whose 'otherWindow' field is set to the window that has now become active, or NULL for none.

Reimplemented in CEGUI::FrameWindow.

void CEGUI::Window::onDestructionStarted ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window's destruction sequence has begun.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onDisabled ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window is disabled.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onDragDropItemDropped ( DragDropEventArgs & e ) [protected, virtual]

Handler called when a DragContainer is dragged over this window.

Parameters:
e DragDropEventArgs object initialised as follows:
  • window field is normaly set to point to 'this' window.
  • dragDropItem is a pointer to a DragContainer window that triggered the event.

void CEGUI::Window::onDragDropItemEnters ( DragDropEventArgs & e ) [protected, virtual]

Handler called when a DragContainer is dragged over this window.

Parameters:
e DragDropEventArgs object initialised as follows:
  • window field is normaly set to point to 'this' window.
  • dragDropItem is a pointer to a DragContainer window that triggered the event.

void CEGUI::Window::onDragDropItemLeaves ( DragDropEventArgs & e ) [protected, virtual]

Handler called when a DragContainer is dragged over this window.

Parameters:
e DragDropEventArgs object initialised as follows:
  • window field is normaly set to point to 'this' window.
  • dragDropItem is a pointer to a DragContainer window that triggered the event.

void CEGUI::Window::onEnabled ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window is enabled.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onFontChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's font is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented in CEGUI::Combobox, CEGUI::Spinner, CEGUI::StaticText, CEGUI::TabControl, and CEGUI::Titlebar.

void CEGUI::Window::onHidden ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window is hidden.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onHorizontalAlignmentChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the horizontal alignment setting for the window is changed.

Parameters:
e WindowEventArgs object initialised as follows:
  • window field is set to point to the Window object whos alignment has changed (typically 'this').

void CEGUI::Window::onIDChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's client assigned ID is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onInheritsAlphaChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's setting for inheriting alpha-blending is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onKeyDown ( KeyEventArgs & e ) [protected, virtual]

Handler called when a key as been depressed while this window has input focus.

Parameters:
e KeyEventArgs object whose 'scancode' field is set to the Key::Scan value representing the key that was pressed, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated.

Reimplemented in CEGUI::Editbox, and CEGUI::MultiLineEditbox.

void CEGUI::Window::onKeyUp ( KeyEventArgs & e ) [protected, virtual]

Handler called when a key as been released while this window has input focus.

Parameters:
e KeyEventArgs object whose 'scancode' field is set to the Key::Scan value representing the key that was released, and whose 'sysKeys' field represents the combination of SystemKey that were active when the event was generated. All other fields should be considered as 'junk'.

void CEGUI::Window::onMetricsChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's active metrics system is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onMouseButtonDown ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been depressed within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::ButtonBase, CEGUI::ComboDropList, CEGUI::DragContainer, CEGUI::Editbox, CEGUI::FrameWindow, CEGUI::Listbox, CEGUI::ListHeaderSegment, CEGUI::MenuItem, CEGUI::MultiColumnList, CEGUI::MultiLineEditbox, CEGUI::Scrollbar, CEGUI::Slider, CEGUI::Thumb, and CEGUI::Titlebar.

void CEGUI::Window::onMouseButtonUp ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been released within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::ButtonBase, CEGUI::Checkbox, CEGUI::ComboDropList, CEGUI::DragContainer, CEGUI::Editbox, CEGUI::FrameWindow, CEGUI::ListHeaderSegment, CEGUI::MenuItem, CEGUI::MultiLineEditbox, CEGUI::PushButton, CEGUI::RadioButton, CEGUI::TabButton, and CEGUI::Titlebar.

void CEGUI::Window::onMouseClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been clicked (that is depressed and then released, within a specified time) within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

void CEGUI::Window::onMouseDoubleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been double-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::Editbox, CEGUI::ListHeaderSegment, CEGUI::MultiLineEditbox, and CEGUI::Titlebar.

void CEGUI::Window::onMouseEnters ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has entered this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::Tooltip.

void CEGUI::Window::onMouseLeaves ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has left this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::ButtonBase, CEGUI::ListHeaderSegment, and CEGUI::MenuItem.

void CEGUI::Window::onMouseMove ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse cursor has been moved within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::ButtonBase, CEGUI::ComboDropList, CEGUI::DragContainer, CEGUI::Editbox, CEGUI::FrameWindow, CEGUI::Listbox, CEGUI::ListHeaderSegment, CEGUI::MenuItem, CEGUI::MultiLineEditbox, CEGUI::Thumb, and CEGUI::Titlebar.

void CEGUI::Window::onMouseTripleClicked ( MouseEventArgs & e ) [protected, virtual]

Handler called when a mouse button has been triple-clicked within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::Editbox, and CEGUI::MultiLineEditbox.

void CEGUI::Window::onMouseWheel ( MouseEventArgs & e ) [protected, virtual]

Handler called when the mouse wheel (z-axis) position changes within this window's area.

Parameters:
e MouseEventArgs object. All fields are valid.

Reimplemented in CEGUI::Listbox, CEGUI::MultiColumnList, CEGUI::MultiLineEditbox, CEGUI::ScrollablePane, CEGUI::Scrollbar, CEGUI::Slider, and CEGUI::StaticText.

void CEGUI::Window::onMoved ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's position changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onParentDestroyChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's setting for being destroyed automatically be it's parent is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onParentSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when this window's parent window has been resized. If this window is the root / GUI Sheet window, this call will be made when the screen size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set the the window that caused the event; this is typically either this window's parent window, or NULL to indicate the screen size has changed.

Reimplemented in CEGUI::ScrolledContainer.

void CEGUI::Window::onRenderingEnded ( WindowEventArgs & e ) [protected, virtual]

Handler called when rendering for this window has ended.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onRenderingStarted ( WindowEventArgs & e ) [protected, virtual]

Handler called when rendering for this window has started.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onShown ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window is shown (made visible).

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::onSized ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's size changes.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented in CEGUI::ItemListBase, CEGUI::Listbox, CEGUI::MultiColumnList, CEGUI::MultiLineEditbox, CEGUI::PushButton, CEGUI::ScrollablePane, CEGUI::Static, CEGUI::StaticImage, and CEGUI::StaticText.

void CEGUI::Window::onTextChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the window's text is changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

Reimplemented in CEGUI::Combobox, CEGUI::Editbox, CEGUI::FrameWindow, CEGUI::MultiLineEditbox, CEGUI::Spinner, CEGUI::StaticText, CEGUI::TextItem, and CEGUI::Tooltip.

void CEGUI::Window::onVerticalAlignmentChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the vertical alignment setting for the window is changed.

Parameters:
e WindowEventArgs object initialised as follows:
  • window field is set to point to the Window object whos alignment has changed (typically 'this').

void CEGUI::Window::onZChanged ( WindowEventArgs & e ) [protected, virtual]

Handler called when the z-order position of this window has changed.

Parameters:
e WindowEventArgs object whose 'window' pointer field is set to the window that triggered the event. For this event the trigger window is always 'this'.

void CEGUI::Window::performChildWindowLayout ( ) [virtual]

method called to perform extended laying out of attached child windows.

The system may call this at various times (like when it is resized for example), and it may be invoked directly where required.

Returns:
Nothing.

Reimplemented in CEGUI::TabControl.

virtual void CEGUI::Window::populateRenderCache ( ) [inline, protected, virtual]

Update the rendering cache.

Populates the Window's RenderCache with imagery to be sent to the renderer.

Reimplemented in CEGUI::ItemListBase, CEGUI::Listbox, CEGUI::MultiColumnList, CEGUI::MultiLineEditbox, CEGUI::Static, CEGUI::StaticImage, CEGUI::StaticText, and CEGUI::TextItem.

Rect CEGUI::Window::relativeToAbsolute ( const Rect & rect ) const

Convert the given area from relative to absolute metrics.

Parameters:
rect Rect object describing the area specified in relative metrics for this Window.
Returns:
A Rect object that describes an area in absolute metric values that is equivalent to rect, given the Window objects current size.

Size CEGUI::Window::relativeToAbsolute ( const Size & sze ) const

Convert the given size from relative to absolute metrics.

Parameters:
sze Size object describing a size specified in relative metrics for this Window.
Returns:
A Size object that describes a size in absolute metric values that is equivalent to sze, given the Window objects current size.

Point CEGUI::Window::relativeToAbsolute ( const Point & pt ) const

Convert the given position from relative to absolute metrics.

Parameters:
pt Point object describing a position specified in relative metrics for this Window (so 0,0 is this windows top-left corner).
Returns:
A Point object describing a position in absolute metric values that is equivalent to pt, given the Window objects current size.

Rect CEGUI::Window::relativeToAbsolute_impl | ( | const Window * | window,
 |  | const Rect & | rect
 | ) | const [protected]

Return a Rect object that describes, in absolute values offset from window, the relative area described by rect.

Parameters:
window | Pointer to a window object that is to be used as the base for the conversion. If this is NULL then the size of the display, as returned by the renderer object, is used.
rect | Rect object describing the area, in relative values, that is to be returned as absolute values.
Returns:
Rect object that describes in absolute values offset from window, the same area described as relative values in rect.

float CEGUI::Window::relativeToAbsoluteX ( float val ) const

Convert the given X co-ordinate from relative to absolute metrics.

Parameters:
val X co-ordinate specified in relative metrics for this Window (so 0 is this windows left edge).
Returns:
An absolute metric value that is equivalent to val, given the Window objects current width.

float CEGUI::Window::relativeToAbsoluteY ( float val ) const

Convert the given Y co-ordinate from relative to absolute metrics.

Parameters:
val Y co-ordinate specified in relative metrics for this Window (so 0 is this windows top edge).
Returns:
An absolute metric value that is equivalent to val, given the Window objects current height.

void CEGUI::Window::releaseInput ( void )

Releases input capture from this Window. If this Window does not have inputs captured, nothing happens.

Returns:
Nothing

void CEGUI::Window::removeChildWindow ( uint ID )

Remove the first child Window with the specified ID. If there is more than one attached Window objects with the specified ID, only the fist one encountered will be removed.

Parameters:
ID ID number assigned to the Window to be removed. If no Window with ID code ID is attached, nothing happens.
Returns:
Nothing.

void CEGUI::Window::removeChildWindow ( Window * window )

Remove the specified Window form this windows child list.

Parameters:
window Pointer to the Window object to be removed. If the window is not attached to this Window, then nothing happens.
Returns:
Nothing.

void CEGUI::Window::removeChildWindow ( const String & name )

Remove the named Window from this windows child list.

Parameters:
name String object holding the name of the Window to be removed. If the Window specified is not attached to this Window, nothing happens.
Returns:
Nothing.

void CEGUI::Window::removeWindowFromDrawList ( const Window & wnd ) [protected]

Removes the window from the drawing list. If the window is not attached to the drawing list then nothing happens.

Parameters:
wnd Window object to be removed from the drawing list.
Returns:
Nothing.

void CEGUI::Window::rename ( const String & new_name )

Renames the window.

Parameters:
new_name String object holding the new name for the window.
Exceptions:
AlreadyExistsException thrown if a Window named new_name already exists in the system.

void CEGUI::Window::render ( void )

Causes the Window object to render itself and all of it's attached children.

Returns:
Nothing

void CEGUI::Window::requestRedraw ( void ) const

Signal the System object to redraw (at least) this Window on the next render cycle.

Returns:
Nothing

bool CEGUI::Window::restoresOldCapture ( void ) const [inline]

Return whether this window is set to restore old input capture when it loses input capture.

This is only really useful for certain sub-components for widget writers.

Returns:
  • true if the window will restore the previous capture window when it loses input capture.
  • false if the window will set the capture window to NULL when it loses input capture (this is the default behaviour).

Rect CEGUI::Window::screenToWindow ( const URect & rect ) const

Convert a URect screen area to a window area, specified in whichever metrics mode is active.

Parameters:
rect URect object describing the area to be converted
Returns:
Rect object describing a window area that is equivalent to URect screen area rect.

Vector2 CEGUI::Window::screenToWindow ( const UVector2 & vec ) const

Convert a screen relative UVector2 point to a window co-ordinate point, specified in whichever metrics mode is active.

Parameters:
vec UVector2 object describing the point to be converted
Returns:
Vector2 object describing a window co-ordinate point that is equivalent to screen based UVector2 point vec.

Rect CEGUI::Window::screenToWindow ( const Rect & rect ) const

Convert a screen area to a window area, specified in whichever metrics mode is active.

Parameters:
rect Rect object describing the area to be converted
Returns:
Rect object describing a window area that is equivalent to screen area rect.

Size CEGUI::Window::screenToWindow ( const Size & sze ) const

Convert a pixel screen size to a window based size, specified in whichever metrics mode is active.

Parameters:
sze Size object describing the size to be converted
Returns:
Size object describing a window based size that is equivalent to screen based size sze.

Point CEGUI::Window::screenToWindow ( const Point & pt ) const

Convert a screen relative pixel position to a window co-ordinate position, specified in whichever metrics mode is active.

Parameters:
pt Point object describing the position to be converted
Returns:
Point object describing a window co-ordinate position that is equivalent to screen co-ordinate x.

float CEGUI::Window::screenToWindowX ( const UDim & x ) const

Convert a screen relative UDim co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.

Parameters:
x UDim x co-ordinate value to be converted
Returns:
float value describing a window co-ordinate value that is equivalent to screen UDim co-ordinate x.

float CEGUI::Window::screenToWindowX ( float x ) const

Convert a screen relative pixel co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.

Parameters:
x x co-ordinate value to be converted
Returns:
float value describing a window co-ordinate value that is equivalent to screen co-ordinate x.

float CEGUI::Window::screenToWindowY ( const UDim & y ) const

Convert a screen relative UDim co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.

Parameters:
y UDim y co-ordinate value to be converted
Returns:
float value describing a window co-ordinate value that is equivalent to screen UDim co-ordinate y.

float CEGUI::Window::screenToWindowY ( float y ) const

Convert a screen relative pixel co-ordinate value to a window co-ordinate value, specified in whichever metrics mode is active.

Parameters:
y y co-ordinate value to be converted
Returns:
float value describing a window co-ordinate value that is equivalent to screen co-ordinate y.

void CEGUI::Window::setAlpha ( float alpha )

Set the current alpha value for this window.

Note:
The alpha value set for any given window may or may not be the final alpha value that is used when rendering. All window objects, by default, inherit alpha from thier parent window(s) - this will blend child windows, relatively, down the line of inheritance. This behaviour can be overridden via the setInheritsAlpha() method. To return the true alpha value that will be applied when rendering, use the getEffectiveAlpha() method.
Parameters:
alpha The new alpha value for the window. Value should be between 0.0f and 1.0f.
Returns:
Nothing

void CEGUI::Window::setAlwaysOnTop ( bool setting )

Set whether this window is always on top, or not.

Parameters:
setting true to have the Window appear on top of all other non always on top windows, or false to allow the window to be covered by other windows.
Returns:
Nothing

void CEGUI::Window::setAreaRect ( const Rect & area )

Set the current area for the Window, this allows for setting of position and size at the same time. Interpretation of the input value area is dependant upon the current metrics system set for the Window.

Parameters:
area Rect object that describes the new area for Window, in units consistent with the current metrics mode.
Returns:
Nothing

void CEGUI::Window::setAutoRepeatDelay ( float delay )

Set the current auto-repeat delay setting for this window.

Parameters:
delay float value indicating the delay, in seconds, defore the first repeat mouse button down event should be triggered when autorepeat is enabled.
Returns:
Nothing.

void CEGUI::Window::setAutoRepeatRate ( float rate )

Set the current auto-repeat rate setting for this window.

Parameters:
rate float value indicating the rate, in seconds, at which repeat mouse button down events should be generated after the initial delay has expired.
Returns:
Nothing.

void CEGUI::Window::setClippedByParent ( bool setting )

Set whether this Window will be clipped by its parent window(s).

Parameters:
setting true to have the Window clipped so that rendering is constrained to within the area of its parent(s), or false to have rendering constrained to the screen only.
Returns:
Nothing

void CEGUI::Window::setDestroyedByParent ( bool setting )

Set whether or not this Window will automatically be destroyed when its parent Window is destroyed.

Parameters:
setting set to true to have the Window auto-destroyed when its parent is destroyed (default), or false to have the Window remain after its parent is destroyed.
Returns:
Nothing

void CEGUI::Window::setDistributesCapturedInputs ( bool setting )

Set whether the window wants inputs passed to its attached child windows when the window has inputs captured.

Parameters:
setting
  • true if System should pass captured input events to child windows.
  • false if System should pass captured input events to this window only.

void CEGUI::Window::setEnabled ( bool setting )

Set whether this window is enabled or disabled. A disabled window normally can not be interacted with, and may have different rendering.

Parameters:
setting true to enable the Window, and false to disable the Window.
Returns:
Nothing

void CEGUI::Window::setFont ( const String & name )

Set the font used by this Window.

Parameters:
name String object holding the name of the Font object to be used by this Window. If name == "", the default font will be used.
Returns:
Nothing
Exceptions:
UnknownObjectException thrown if the specified Font is unknown within the system.

void CEGUI::Window::setFont ( const Font * font )

Set the font used by this Window.

Parameters:
font Pointer to the Font object to be used by this Window. If font is NULL, the default font will be used.
Returns:
Nothing

void CEGUI::Window::setHeight | ( | MetricsMode | mode,
 |  | float | height
 | ) |

set the height of the Window using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
height | float value that specifies the height of the Window using the specified MetricsMode.
Returns:
Nothing.

void CEGUI::Window::setHeight ( float height )

Set the current height of the Window. Interpretation of the input value height is dependant upon the current metrics system set for the Window.

Parameters:
height float value that specifies the new height for the window, in units consistent with whatever metrics mode is in operation.
Returns:
Nothing

void CEGUI::Window::setHorizontalAlignment ( const HorizontalAlignment alignment )

Set the horizontal alignment.

Modifies the horizontal alignment for the window. This setting affects how the windows position is interpreted relative to its parent.

Parameters:
alignment One of the HorizontalAlignment enumerated values.
Returns:
Nothing.

void CEGUI::Window::setID ( uint ID )

Set the current ID for the Window.

Parameters:
ID Client assigned ID code for this Window. The GUI system assigns no meaning to any IDs, they are a device purely for client code usage.
Returns:
Nothing

void CEGUI::Window::setInheritsAlpha ( bool setting )

Sets whether this Window will inherit alpha from its parent windows.

Parameters:
setting true if the Window should use inherited alpha, or false if the Window should have an independant alpha value.
Returns:
Nothing

void CEGUI::Window::setInheritsTooltipText ( bool setting )

Set whether this window inherits Tooltip text from its parent when its own tooltip text is not set.

Parameters:
setting
  • true if the window should inherit tooltip text from its parent when its own text is not set.
  • false if the window should not inherit tooltip text from its parent (and so show no tooltip when no text is set).
Returns:
Nothing.

void CEGUI::Window::setLookNFeel | ( | const String & | falagardType,
 |  | const String & | look
 | ) |

Set the LookNFeel that shoule be used for this window.

Parameters:
falagardType | String object holding the mapped falagard type name (since actual window type will be "Falagard/something") and not what was passed to WindowManager. This will be returned from getType instead of the base type.
look | String object holding the name of the look to be assigned to the window.
Returns:
Nothing.
Exceptions:
InvalidRequestException thrown if the window already has a look assigned to it.

void CEGUI::Window::setMaximumSize ( const Size & sz )

Set the maximum size for this window.

Parameters:
sz Size object describing the maximum size for the window. For absolute metrics, the Size values are in screen pixels, for relative metrics the Size values are relative to the display size.

void CEGUI::Window::setMetricsMode ( MetricsMode mode )

set the current metrics mode employed by the Window

Parameters:
mode One of the values of the MectricsMode enumerated type, that describes the metrics mode to be used by the Window.
Returns:
Nothing

void CEGUI::Window::setMinimumSize ( const Size & sz )

Set the minimum size for this window.

Parameters:
sz Size object describing the minimum size for the window. For absolute metrics, the Size values are in screen pixels, for relative metrics the Size values are relative to the display size.

void CEGUI::Window::setModalState ( bool state )

Set the modal state for this Window.

Parameters:
state Boolean value defining if this Window should be the modal target. If true, this Window will be activated and set as the modal target. If false, the modal target will be cleared if this Window is currently the modal target.
Returns:
Nothing.

void CEGUI::Window::setMouseAutoRepeatEnabled ( bool setting )

Set whether mouse button down event autorepeat is enabled for this window.

Parameters:
setting
  • true to enable autorepeat of mouse button down events.
  • false to disable autorepeat of mouse button down events.
Returns:
Nothing.

void CEGUI::Window::setMouseCursor | ( | const String & | imageset,
 |  | const String & | image_name
 | ) |

Set the mouse cursor image to be used when the mouse enters this window.

Parameters:
imageset | String object that contains the name of the Imageset that contains the image to be used.
image_name | String object that contains the name of the Image on imageset that is to be used.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if imageset is not known, or if imageset contains no Image named image_name.

void CEGUI::Window::setMouseCursor ( MouseCursorImage image ) [inline]

Set the mouse cursor image to be used when the mouse enters this window.

Parameters:
image One of the MouseCursorImage enumerated values.
Returns:
Nothing.

void CEGUI::Window::setMouseCursor ( const Image * image ) [inline]

Set the mouse cursor image to be used when the mouse enters this window.

Parameters:
image Pointer to the Image object to use as the mouse cursor image when the mouse enters the area for this Window.
Returns:
Nothing.

void CEGUI::Window::setParent ( Window * parent ) [protected]

Set the parent window for this window object.

Parameters:
parent Pointer to a Window object that is to be assigned as the parent to this Window.
Returns:
Nothing

void CEGUI::Window::setPosition | ( | MetricsMode | mode,
 |  | const Point & | position
 | ) |

set the position of the window using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
position | Point object that describes the position of the Window relative to it's parent, using the specified MetricsMode.
Returns:
Nothing

void CEGUI::Window::setPosition ( const Point & position )

Set the current position of the Window. Interpretation of the input value position is dependant upon the current metrics system set for the Window.

Parameters:
position Point object that describes the new postion of the Window, in units consistent with the current metrics mode.
Returns:
Nothing

void CEGUI::Window::setRect | ( | MetricsMode | mode,
 |  | const Rect & | area
 | ) |

set the Rect that describes the Window area using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
area | Rect object that describes the area to be covered by the Window using the specified MetricsMode.
Returns:
Nothing.

void CEGUI::Window::setRestoreCapture ( bool setting )

Set whether this window will remember and restore the previous window that had inputs captured.

Parameters:
setting
  • true: The window will remember and restore the previous capture window. The CaptureLost event is not fired on the previous window when this window steals input capture. When this window releases capture, the old capture window is silently restored.
  • false: Input capture works as normal, each window losing capture is signalled via CaptureLost, and upon the final release of capture, no previous setting is restored (this is the default 'normal' behaviour).

Returns:
Nothing

void CEGUI::Window::setRiseOnClickEnabled ( bool setting ) [inline]

Set whether this window will rise to the top of the z-order when clicked with the left mouse button.

Parameters:
setting
  • true if the window should come to the top of other windows when the left mouse button is pushed within its area.
  • false if the window should not change z-order position when the left mouse button is pushed within its area.
Returns:
Nothing.

void CEGUI::Window::setSize | ( | MetricsMode | mode,
 |  | const Size & | size
 | ) |

set the size of the Window using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
size | Size object that describes the dimensions of the Window using the specified MetricsMode.
Returns:
Nothing.

void CEGUI::Window::setSize ( const Size & size )

Set the current size of the Window. Interpretation of the input value size is dependant upon the current metrics system set for the Window.

Parameters:
size Size object that describes the new dimensions for the window, in units consistent with whatever metrics mode is in operation.
Returns:
Nothing

void CEGUI::Window::setText ( const String & text )

Set the current text string for the Window.

Parameters:
text String object containing the text that is to be set as the Window text.
Returns:
Nothing

void CEGUI::Window::setTooltip ( Tooltip * tooltip )

Set the custom Tooltip object for this Window. This value may be NULL to indicate that the Window should use the system default Tooltip object.

Parameters:
tooltip Pointer to a valid Tooltip based object which should be used as the tooltip for this Window, or NULL to indicate that the Window should use the system default Tooltip object. Note that when passing a pointer to a Tooltip object, ownership of the Tooltip does not pass to this Window object.
Returns:
Nothing.

void CEGUI::Window::setTooltipText ( const String & tip )

Set the tooltip text for this window.

Parameters:
tip String object holding the text to be displayed in the tooltip for this Window.
Returns:
Nothing.

void CEGUI::Window::setTooltipType ( const String & tooltipType )

Set the custom Tooltip to be used by this Window by specifying a Window type.

The Window will internally attempt to create an instance of the specified window type (which must be derived from the base Tooltip class). If the Tooltip creation fails, the error is logged and the Window will revert to using either the existing custom Tooltip or the system default Tooltip.

Parameters:
tooltipType String object holding the name of the Tooltip based Window type which should be used as the Tooltip for this Window.
Returns:
Nothing.

void CEGUI::Window::setUserData ( void * user_data ) [inline]

Set the user data set for this Window.

Each Window can have some client assigned data attached to it, this data is not used by the GUI system in any way. Interpretation of the data is entirely application specific.

Parameters:
user_data pointer to the user data that is to be set for this window.
Returns:
Nothing.

void CEGUI::Window::setUserString | ( | const String & | name,
 |  | const String & | value
 | ) |

Sets the value a named user string, creating it as required.

Parameters:
name | String object holding the name of the string to be returned.
value | String object holding the value to be assigned to the user string.
Returns:
Nothing.

void CEGUI::Window::setVerticalAlignment ( const VerticalAlignment alignment )

Set the vertical alignment.

Modifies the vertical alignment for the window. This setting affects how the windows position is interpreted relative to its parent.

Parameters:
alignment One of the VerticalAlignment enumerated values.
Returns:
Nothing.

void CEGUI::Window::setVisible ( bool setting )

Set whether the Window is visible or hidden.

Parameters:
setting true to make the Window visible, or false to make the Window hidden
Returns:
Nothing

void CEGUI::Window::setWantsMultiClickEvents ( bool setting )

Set whether this window will receive multi-click events or multiple 'down' events instead.

Parameters:
setting
  • true if the Window will receive double-click and triple-click events.
  • false if the Window will receive multiple mouse button down events instead of double/triple click events.
Returns:
Nothing.

void CEGUI::Window::setWidth | ( | MetricsMode | mode,
 |  | float | width
 | ) |

set the width of the Window using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
width | float value that specifies the width of the Window using the specified MetricsMode.
Returns:
Nothing.

void CEGUI::Window::setWidth ( float width )

Set the current width of the Window. Interpretation of the input value width is dependant upon the current metrics system set for the Window.

Parameters:
width float value that specifies the new width for the window, in units consistent with whatever metrics mode is in operation.
Returns:
Nothing

void CEGUI::Window::setWindowArea ( const URect & area )

Set the window area.

Sets the area occupied by this window. The defined area is offset from the top-left corner of this windows parent window or from the top-left corner of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
area URect describing the new area rectangle of the window area.

void CEGUI::Window::setWindowArea | ( | const UVector2 & | pos,
 |  | const UVector2 & | size
 | ) |

Set the window area.

Sets the area occupied by this window. The defined area is offset from the top-left corner of this windows parent window or from the top-left corner of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
pos | UVector2 describing the new position (top-left corner) of the window area.
size | UVector2 describing the new size of the window area.

void CEGUI::Window::setWindowArea | ( | const UDim & | xpos,
 |  | const UDim & | ypos,
 |  | const UDim & | width,
 |  | const UDim & | height
 | ) |

Set the window area.

Sets the area occupied by this window. The defined area is offset from the top-left corner of this windows parent window or from the top-left corner of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
xpos | UDim describing the new x co-ordinate (left edge) of the window area.
ypos | UDim describing the new y co-ordinate (top-edge) of the window area.
width | UDim describing the new width of the window area.
height | UDim describing the new height of the window area.

void CEGUI::Window::setWindowArea_impl | ( | const UVector2 & | pos,
 |  | const UVector2 & | size,
 |  | bool | topLeftSizing = false,
 |  | bool | fireEvents = true
 | ) | [protected]

Implementation method to modify window area while correctly applying min / max size processing, and firing any appropriate events.

/note This is the implementation function for setting size and position. In order to simplify area management, from this point on, all modifications to window size and position (area rect) should come through here.

/param pos UVector2 object describing the new area position.

/param size UVector2 object describing the new area size.

/param topLeftSizing

  • true to indicate the the operation is a sizing operation on the top and/or left edges of the area, and so window movement should be inhibited if size is at max or min.
  • false to indicate the operation is not a strict sizing operation on the top and/or left edges and that the window position may change as required

/param fireEvents

  • true if events should be fired as normal.
  • false to inhibit firing of events (required, for example, if you need to call this from the onSize/onMove handlers).

void CEGUI::Window::setWindowHeight ( const UDim & height )

Set the window's height.

Sets the height of the area occupied by this window.

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
height UDim describing the new height of the window area.

void CEGUI::Window::setWindowMaxSize ( const UVector2 & size )

Set the window's maximum size.

Sets the maximum size that this windows area may occupy (whether size changes occur by user interaction, general system operation, or by direct setting by client code).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
size UVector2 describing the new maximum size of the window area.

void CEGUI::Window::setWindowMinSize ( const UVector2 & size )

Set the window's minimum size.

Sets the minimum size that this windows area may occupy (whether size changes occur by user interaction, general system operation, or by direct setting by client code).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
size UVector2 describing the new minimum size of the window area.

void CEGUI::Window::setWindowPosition ( const UVector2 & pos )

Set the window's position.

Sets the position of the area occupied by this window. The position is offset from the top-left corner of this windows parent window or from the top-left corner of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
pos UVector2 describing the new position (top-left corner) of the window area.

void CEGUI::Window::setWindowSize ( const UVector2 & size )

Set the window's size.

Sets the size of the area occupied by this window.

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
size UVector2 describing the new size of the window area.

void CEGUI::Window::setWindowWidth ( const UDim & width )

Set the window's width.

Sets the width of the area occupied by this window.

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
width UDim describing the new width of the window area.

void CEGUI::Window::setWindowXPosition ( const UDim & x )

Set the window's X position.

Sets the x position (left edge) of the area occupied by this window. The position is offset from the left edge of this windows parent window or from the left edge of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
x UDim describing the new x position of the window area.

void CEGUI::Window::setWindowYPosition ( const UDim & y )

Set the window's Y position.

Sets the y position (top edge) of the area occupied by this window. The position is offset from the top edge of this windows parent window or from the top edge of the display if this window has no parent (i.e. it is the root window).

Note:
This method makes use of "Unified Dimensions". These contain both parent relative and absolute pixel components, which are used in determining the final value used.
Parameters:
y UDim describing the new y position of the window area.

void CEGUI::Window::setXPosition | ( | MetricsMode | mode,
 |  | float | x
 | ) |

set the x position of the window using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
x | float value that specifies the x position of the Window relative to it's parent, using the specified MetricsMode.
Returns:
Nothing.

void CEGUI::Window::setXPosition ( float x )

Set the current 'x' position of the Window. Interpretation of the input value x is dependant upon the current metrics system set for the Window.

Parameters:
x float value that specifies the new x postion of the Window, in units consistent with the current metrics mode.
Returns:
Nothing

void CEGUI::Window::setYPosition | ( | MetricsMode | mode,
 |  | float | y
 | ) |

set the y position of the window using the specified metrics system.

Parameters:
mode | One of the MetricsMode enumerated values specifying the metrics system to be used for the return value.
y | float value that specifies the y position of the Window relative to it's parent, using the specified MetricsMode.
Returns:
Nothing.

void CEGUI::Window::setYPosition ( float y )

Set the current 'y' position of the Window. Interpretation of the input value y is dependant upon the current metrics system set for the Window.

Parameters:
y float value that specifies the new y postion of the Window, in units consistent with the current metrics mode.
Returns:
Nothing

void CEGUI::Window::setZOrderingEnabled ( bool setting )

Set whether z-order changes are enabled or disabled for this Window.

Parameters:
setting
  • true if z-order changes are enabled for this window. moveToFront/moveToBack work normally as expected.
  • false: z-order changes are disabled for this window. moveToFront/moveToBack are ignored for this window.
Returns:
Nothing.

void CEGUI::Window::show ( void ) [inline]

show the Window

Returns:
Nothing

bool CEGUI::Window::testClassName ( const String & class_name ) const [inline]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

virtual bool CEGUI::Window::testClassName_impl ( const String & class_name ) const [inline, protected, virtual]

Return whether this window was inherited from the given class name at some point in the inheritance heirarchy.

Parameters:
class_name The class name that is to be checked.
Returns:
true if this window was inherited from class_name. false if not.

Reimplemented in CEGUI::ButtonBase, CEGUI::Checkbox, CEGUI::Combobox, CEGUI::ComboDropList, CEGUI::DragContainer, CEGUI::Editbox, CEGUI::FrameWindow, CEGUI::GUISheet, CEGUI::ItemEntry, CEGUI::ItemListBase, CEGUI::Listbox, CEGUI::ListHeader, CEGUI::ListHeaderSegment, CEGUI::Menubar, CEGUI::MenuBase, CEGUI::MenuItem, CEGUI::MultiColumnList, CEGUI::MultiLineEditbox, CEGUI::PopupMenu, CEGUI::ProgressBar, CEGUI::PushButton, CEGUI::RadioButton, CEGUI::ScrollablePane, CEGUI::Scrollbar, CEGUI::ScrolledContainer, CEGUI::Slider, CEGUI::Spinner, CEGUI::Static, CEGUI::StaticImage, CEGUI::StaticText, CEGUI::TabButton, CEGUI::TabControl, CEGUI::TabPane, CEGUI::TextItem, CEGUI::Thumb, CEGUI::Titlebar, and CEGUI::Tooltip.

Rect CEGUI::Window::unifiedToAbsolute ( const URect & val ) const

Convert the given area from unfied to absolute metrics.

Parameters:
val URect object describing the area specified in unified dimensions relative to this Window.
Returns:
A Rect object describing an absolute metric area that is equivalent to val, given the Window objects current size.

Vector2 CEGUI::Window::unifiedToAbsolute ( const UVector2 & val ) const

Convert the given UVector2 value from unified to absolute metrics.

Parameters:
val UVector2 object that describes a position specified in unified dimensions relative to this Window (so {{0, 0}, {0, 0}) is this windows top-left corner).
Returns:
A Vector2 object describing a absolute metric point that is equivalent to val, given the Window objects current size.

float CEGUI::Window::unifiedToAbsoluteX ( const UDim & val ) const

Convert the given X co-ordinate from unified to absolute metrics.

Parameters:
val X co-ordinate specified as a UDim relative to this Window (so {0, 0} is this windows left edge).
Returns:
An absolute metric value that is equivalent to val, given the Window objects current width.

float CEGUI::Window::unifiedToAbsoluteY ( const UDim & val ) const

Convert the given Y co-ordinate from unified to absolute metrics.

Parameters:
val Y co-ordinate specified in as a UDim relative to this Window (so {0, 0} is this windows top edge).
Returns:
An absolute metric value that is equivalent to val, given the Window objects current height.

Rect CEGUI::Window::unifiedToRelative ( const URect & val ) const

Convert the given area from unfied to relative metrics.

Parameters:
val URect object describing the area specified in unified dimensions relative to this Window.
Returns:
A Rect object describing a relative metric area that is equivalent to val, given the Window objects current size.

Vector2 CEGUI::Window::unifiedToRelative ( const UVector2 & val ) const

Convert the given UVector2 value from unified to relative metrics.

Parameters:
val UVector2 object that describes a position specified in unified dimensions relative to this Window (so {{0, 0}, {0, 0}) is this windows top-left corner).
Returns:
A Vector2 object describing a relative metric point that is equivalent to val, given the Window objects current size.

float CEGUI::Window::unifiedToRelativeX ( const UDim & val ) const

Convert the given X co-ordinate from unified to relative metrics.

Parameters:
val X co-ordinate specified as a UDim relative to this Window (so {0, 0} is this windows left edge).
Returns:
A relative metric value that is equivalent to val, given the Window objects current width.

float CEGUI::Window::unifiedToRelativeY ( const UDim & val ) const

Convert the given Y co-ordinate from unified to relative metrics.

Parameters:
val Y co-ordinate specified in as a UDim relative to this Window (so {0, 0} is this windows top edge).
Returns:
A relative metric value that is equivalent to val, given the Window objects current height.

void CEGUI::Window::update ( float elapsed )

Cause window to update itself and any attached children. Client code does not need to call this method; to ensure full, and proper updates, call the injectTimePulse methodname method provided by the System class.

Note:
The update order is such that 'this' window is updated prior to any child windows, this is so that child windows that access the parent in their update code get the correct updated state.
Parameters:
elapsed float value indicating the number of seconds passed since the last update.
Returns:
Nothing.

void CEGUI::Window::updateSelf ( float elapsed ) [protected, virtual]

Perform actual update processing for this Window.

Parameters:
elapsed float value indicating the number of seconds elapsed since the last update call.
Returns:
Nothing.

Reimplemented in CEGUI::PopupMenu, and CEGUI::Tooltip.

bool CEGUI::Window::wantsMultiClickEvents ( void ) const

Return whether this window will receive multi-click events or multiple 'down' events instead.

Returns:
  • true if the Window will receive double-click and triple-click events.
  • false if the Window will receive multiple mouse button down events instead of double/triple click events.

Rect CEGUI::Window::windowToScreen ( const URect & rect ) const

Convert a window area, specified as a URect, to a screen area.

Parameters:
rect URect object describing the area to be converted
Returns:
Rect object describing a screen area that is equivalent to window area rect.

Vector2 CEGUI::Window::windowToScreen ( const UVector2 & vec ) const

Convert a window co-ordinate point, specified as a UVector2, to a screen relative pixel co-ordinate point.

Parameters:
vec UVector2 object describing the point to be converted
Returns:
Vector2 object describing a screen co-ordinate position that is equivalent to window based UVector2 vec.

Rect CEGUI::Window::windowToScreen ( const Rect & rect ) const

Convert a window area, specified in whichever metrics mode is active, to a screen area.

Parameters:
rect Rect object describing the area to be converted
Returns:
Rect object describing a screen area that is equivalent to window area rect.

Size CEGUI::Window::windowToScreen ( const Size & sze ) const

Convert a window size value, specified in whichever metrics mode is active, to a size in pixels.

Parameters:
sze Size object describing the size to be converted
Returns:
Size object describing describing a size in pixels that is equivalent to the window based size sze.

Point CEGUI::Window::windowToScreen ( const Point & pt ) const

Convert a window co-ordinate position, specified in whichever metrics mode is active, to a screen relative pixel co-ordinate position.

Parameters:
pt Point object describing the position to be converted
Returns:
Point object describing a screen co-ordinate position that is equivalent to window co-ordinate position pt.

float CEGUI::Window::windowToScreenX ( const UDim & x ) const

Convert a window co-ordinate value, specified as a UDim, to a screen relative pixel co-ordinate.

Parameters:
x UDim x co-ordinate value to be converted
Returns:
float value describing a pixel screen co-ordinate that is equivalent to window UDim co-ordinate x.

float CEGUI::Window::windowToScreenX ( float x ) const

Convert a window co-ordinate value, specified in whichever metrics mode is active, to a screen relative pixel co-ordinate.

Parameters:
x x co-ordinate value to be converted
Returns:
float value describing a pixel screen co-ordinate that is equivalent to window co-ordinate x.

float CEGUI::Window::windowToScreenY ( const UDim & y ) const

Convert a window co-ordinate value, specified as a UDim, to a screen relative pixel co-ordinate.

Parameters:
y UDim y co-ordinate value to be converted
Returns:
float value describing a screen co-ordinate that is equivalent to window UDim co-ordinate y.

float CEGUI::Window::windowToScreenY ( float y ) const

Convert a window co-ordinate value, specified in whichever metrics mode is active, to a screen relative pixel co-ordinate.

Parameters:
y y co-ordinate value to be converted
Returns:
float value describing a screen co-ordinate that is equivalent to window co-ordinate y.

void CEGUI::Window::writeXMLToStream ( OutStream & out_stream ) const [virtual]

Writes an xml representation of this window object to out_stream.

Parameters:
out_stream Stream where xml data should be output.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowEventArgs Class Reference

CEGUI::WindowEventArgs

CEGUI::WindowEventArgs Class Reference

EventArgs based class that is used for objects passed to handlers triggered for events concerning some Window object. More...

Inheritance diagram for CEGUI::WindowEventArgs:

[legend]
Collaboration diagram for CEGUI::WindowEventArgs:

[legend]
List of all members.

Public Member Functions

WindowEventArgs (Window *wnd)

Public Attributes

Window * window
pointer to a Window object of relevance to the event.

Detailed Description

EventArgs based class that is used for objects passed to handlers triggered for events concerning some Window object.

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowFactory Class Reference

CEGUI::WindowFactory

CEGUI::WindowFactory Class Reference

Abstract class that defines the required interface for all WindowFactory objects. More...

Inheritance diagram for CEGUI::WindowFactory:

[legend]
Collaboration diagram for CEGUI::WindowFactory:

[legend]
List of all members.

Public Member Functions

virtual Window * | createWindow (const String &name)=0
Create a new Window object of whatever type this WindowFactory produces.
virtual void | destroyWindow (Window *window)=0
Destroys the given Window object.
const String & | getTypeName (void) const
Get the string that describes the type of Window object this WindowFactory produces.

Protected Member Functions

WindowFactory (const String &type)

Protected Attributes

String d_type
String holding the type of object created by this factory.

Detailed Description

Abstract class that defines the required interface for all WindowFactory objects.

A WindowFactory is used to create and destroy windows of a specific type. For every type of Window object wihin the system (widgets, dialogs, movable windows etc) there must be an associated WindowFactory registered with the WindowManager so that the system knows how to create and destroy those types of Window base object.

Member Function Documentation

virtual Window* CEGUI::WindowFactory::createWindow ( const String & name ) [pure virtual]

Create a new Window object of whatever type this WindowFactory produces.

Parameters:
name A unique name that is to be assigned to the newly created Window object
Returns:
Pointer to the new Window object.

Implemented in CEGUI::DragContainerFactory, CEGUI::GUISheetFactory, and CEGUI::ScrolledContainerFactory.

virtual void CEGUI::WindowFactory::destroyWindow ( Window * window ) [pure virtual]

Destroys the given Window object.

Parameters:
window Pointer to the Window object to be destroyed.
Returns:
Nothing.

Implemented in CEGUI::DragContainerFactory, CEGUI::GUISheetFactory, and CEGUI::ScrolledContainerFactory.

const String& CEGUI::WindowFactory::getTypeName ( void ) const [inline]

Get the string that describes the type of Window object this WindowFactory produces.

Returns:
String object that contains the unique Window object type produced by this WindowFactory

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowFactoryManager Class Reference

CEGUI::WindowFactoryManager

CEGUI::WindowFactoryManager Class Reference

Class that manages WindowFactory objects. More...

List of all members.

Public Types

typedef ConstBaseIterator<
WindowFactoryRegistry > 		WindowFactoryIterator
typedef ConstBaseIterator<
TypeAliasRegistry > 		TypeAliasIterator
typedef ConstBaseIterator<
FalagardMapRegistry > 		FalagardMappingIterator

Public Member Functions

WindowFactoryManager (void)
Constructs a new WindowFactoryManager object.
~WindowFactoryManager (void)
Destructor for WindowFactoryManager objects.
void | addFactory (WindowFactory *factory)
Adds a new WindowFactory to the list of registered factories.
void | removeFactory (const String &name)
Removes a WindowFactory from the list of registered factories.
void | removeFactory (WindowFactory *factory)
Removes a WindowFactory from the list of registered factories.
void | removeAllFactories (void)
Remove all WindowFactory objects from the list.
WindowFactory * | getFactory (const String &type) const
Return a pointer to the specified WindowFactory object.
bool | isFactoryPresent (const String &name) const
Checks the list of registered WindowFactory objects, aliases, and falagard mapped types for one which can create Window objects of the specified type.
void | addWindowTypeAlias (const String &aliasName, const String &targetType)
Adds an alias for a current window type.
void | removeWindowTypeAlias (const String &aliasName, const String &targetType)
Remove the specified alias mapping. If the alias mapping does not exist, nothing happens.
void | addFalagardWindowMapping (const String &newType, const String &targetType, const String &lookName)
Add a mapping for a falagard based window.
void | removeFalagardWindowMapping (const String &type)
Remove the specified falagard type mapping if it exists.
bool | isFalagardMappedType (const String &type) const
Return whether the given type is a falagard mapped type.
const String & | getMappedLookForType (const String &type) const
Return the name of the LookN'Feel assigned to the specified window mapping.
String | getDereferencedAliasType (const String &type) const
Use the alias system, where required, to 'de-reference' the specified type to an actual window type that can be created directly (that being either a concrete window type, or a falagard mapped type).
WindowFactoryIterator | getIterator (void) const
Return a WindowFactoryManager::WindowFactoryIterator object to iterate over the available WindowFactory types.
TypeAliasIterator | getAliasIterator (void) const
Return a WindowFactoryManager::TypeAliasIterator object to iterate over the defined aliases for window types.
FalagardMappingIterator | getFalagardMappingIterator () const
Return a WindowFactoryManager::FalagardMappingIterator object to iterate over the defined falagard window mappings.

Static Public Member Functions

static WindowFactoryManager & | getSingleton (void)
Return singleton WindowFactoryManager object.
static WindowFactoryManager * | getSingletonPtr (void)
Return pointer to singleton WindowFactoryManager object.

Classes

class | AliasTargetStack
Class used to track active alias targets for Window factory types. More...
struct | FalagardWindowMapping
struct used to hold mapping information required to create a falagard based window. More...

Detailed Description

Class that manages WindowFactory objects.

Member Function Documentation

void CEGUI::WindowFactoryManager::addFactory ( WindowFactory * factory )

Adds a new WindowFactory to the list of registered factories.

Parameters:
factory Pointer to the WindowFactory to be added to the WindowManager.
Returns:
Nothing
Exceptions:
NullObjectException | factory was null.
AlreadyExistsException | factory provided a Window type name which is in use by another registered WindowFactory.

void CEGUI::WindowFactoryManager::addFalagardWindowMapping | ( | const String & | newType,
 |  | const String & | targetType,
 |  | const String & | lookName
 | ) |

Add a mapping for a falagard based window.

This function creates maps a target window type and target 'look' name onto a registered window type, thus allowing the ususal window creation interface to be used to create windows that require extra information to full initialise themselves.

Note:
These mappings support 'late binding' to the target window type, as such the type indicated by targetType need not exist in the system until attempting to create a Window using the type.
Also note that creating a mapping for an existing type will replace any previous mapping for that same type.
Parameters:
newType | The type name that will be used to create windows using the target type and look.
targetType | The base window type.
lookName | The name of the 'look' that will be used by windows of this type.
Returns:
Nothing.

void CEGUI::WindowFactoryManager::addWindowTypeAlias | ( | const String & | aliasName,
 |  | const String & | targetType
 | ) |

Adds an alias for a current window type.

This method allows you to create an alias for a specified window type. This means that you can then use either name as the type parameter when creating a window.

Note:
You need to be careful using this system. Creating an alias using a name that already exists will replace the previous mapping for that alias. Each alias name maintains a stack, which means that it is possible to remove an alias and have the previous alias restored. The windows created via an alias use the real type, so removing an alias after window creation is always safe (i.e. it is not the same as removing a real factory, which would cause an exception when trying to destroy a window with a missing factory).
Parameters:
aliasName | String object holding the alias name. That is the name that targetType will also be known as from no on.
targetType | String object holding the type window type name that is to be aliased. This type must already exist.
Returns:
Nothing.
Exceptions:
UnknownObjectException thrown if targetType is not known within the system.

String CEGUI::WindowFactoryManager::getDereferencedAliasType ( const String & type ) const

Use the alias system, where required, to 'de-reference' the specified type to an actual window type that can be created directly (that being either a concrete window type, or a falagard mapped type).

Note:
Even though implied by the above description, this method does not check that a factory for the final type exists; we simply say that the returned type is not an alias for some other type.
Parameters:
type String describing the type to be de-referenced.
Returns:
String object holding a type for a window that can be created directly; that is, a type that does not describe an alias to some other type.

WindowFactory * CEGUI::WindowFactoryManager::getFactory ( const String & type ) const

Return a pointer to the specified WindowFactory object.

Parameters:
type String holding the Window object type to return the WindowFactory for.
Returns:
Pointer to the WindowFactory object that creates Windows of the type type.
Exceptions:
UnknownObjectException No WindowFactory object for Window objects of type type was found.

const String & CEGUI::WindowFactoryManager::getMappedLookForType ( const String & type ) const

Return the name of the LookN'Feel assigned to the specified window mapping.

Parameters:
type Name of a window type. The window type referenced should be a falagard mapped type.
Returns:
String object holding the name of the look mapped for the requested type.
Exceptions:
InvalidRequestException thrown if type is not a falagard mapping type (or maybe the type didn't exist).

WindowFactoryManager & CEGUI::WindowFactoryManager::getSingleton ( void ) [static]

Return singleton WindowFactoryManager object.

Returns:
Singleton WindowFactoryManager object

WindowFactoryManager * CEGUI::WindowFactoryManager::getSingletonPtr ( void ) [static]

Return pointer to singleton WindowFactoryManager object.

Returns:
Pointer to singleton WindowFactoryManager object

bool CEGUI::WindowFactoryManager::isFactoryPresent ( const String & name ) const

Checks the list of registered WindowFactory objects, aliases, and falagard mapped types for one which can create Window objects of the specified type.

Parameters:
name String containing the Window type name to check for.
Returns:
  • true if a WindowFactory, alias, or falagard mapping for Window objects of type name is registered.
  • false if the system knows nothing about windows of type name.

bool CEGUI::WindowFactoryManager::isFalagardMappedType ( const String & type ) const

Return whether the given type is a falagard mapped type.

Parameters:
type Name of a window type.
Returns:
  • true if the requested type is a Falagard mapped window type.
  • false if the requested type is a normal WindowFactory (or alias), or if the type does not exist.

void CEGUI::WindowFactoryManager::removeAllFactories ( void ) [inline]

Remove all WindowFactory objects from the list.

Returns:
Nothing

void CEGUI::WindowFactoryManager::removeFactory ( WindowFactory * factory )

Removes a WindowFactory from the list of registered factories.

Note:
The WindowFactory object is not destroyed (since it was created externally), instead it is just removed from the list.
Parameters:
factory Pointer to the factory object to be removed. If factory is null, or if no such WindowFactory is in the list, no error occurs (nothing happens).
Returns:
Nothing

void CEGUI::WindowFactoryManager::removeFactory ( const String & name )

Removes a WindowFactory from the list of registered factories.

Note:
The WindowFactory object is not destroyed (since it was created externally), instead it is just removed from the list.
Parameters:
name String which holds the name (technically, Window type name) of the WindowFactory to be removed. If name is not in the list, no error occurs (nothing happens).
Returns:
Nothing

void CEGUI::WindowFactoryManager::removeFalagardWindowMapping ( const String & type )

Remove the specified falagard type mapping if it exists.

Returns:
Nothing.

void CEGUI::WindowFactoryManager::removeWindowTypeAlias | ( | const String & | aliasName,
 |  | const String & | targetType
 | ) |

Remove the specified alias mapping. If the alias mapping does not exist, nothing happens.

Note:
You are required to supply both the alias and target names because there may exist more than one entry for a given alias - therefore you are required to be explicit about which alias is to be removed.
Parameters:
aliasName | String object holding the alias name.
targetType | String object holding the type window type name that was aliased.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowFactoryManager::AliasTargetStack Class Reference

CEGUI::WindowFactoryManager::AliasTargetStack

CEGUI::WindowFactoryManager::AliasTargetStack Class Reference

Class used to track active alias targets for Window factory types. More...

List of all members.

Public Member Functions

AliasTargetStack (void)
Constructor for WindowAliasTargetStack objects.
~AliasTargetStack (void)
Destructor for WindowAliasTargetStack objects.
const String & | getActiveTarget (void) const
Return a String holding the current target type for this stack.
uint | getStackedTargetCount (void) const
Return the number of stacked target types in the stack.

Friends

class | WindowFactoryManager

Detailed Description

Class used to track active alias targets for Window factory types.

Member Function Documentation

const String & CEGUI::WindowFactoryManager::AliasTargetStack::getActiveTarget ( void ) const

Return a String holding the current target type for this stack.

Returns:
reference to a String object holding the currently active target type name for this stack.

uint CEGUI::WindowFactoryManager::AliasTargetStack::getStackedTargetCount ( void ) const

Return the number of stacked target types in the stack.

Returns:
number of target types stacked for this alias.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowFactoryManager::FalagardWindowMapping Struct Reference

CEGUI::WindowFactoryManager::FalagardWindowMapping

CEGUI::WindowFactoryManager::FalagardWindowMapping Struct Reference

struct used to hold mapping information required to create a falagard based window. More...

Collaboration diagram for CEGUI::WindowFactoryManager::FalagardWindowMapping:

[legend]
List of all members.

Public Attributes

String | d_windowType
String | d_lookName
String | d_baseType

Detailed Description

struct used to hold mapping information required to create a falagard based window.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowManager Class Reference

CEGUI::WindowManager

CEGUI::WindowManager Class Reference

The WindowManager class describes an object that manages creation and lifetime of Window objects. More...

Collaboration diagram for CEGUI::WindowManager:

[legend]
List of all members.

Public Types

typedef bool | PropertyCallback (Window *window, String &propname, String &propvalue, void *userdata)
Function type that is used as a callback when loading layouts from XML; the function is called for each Property element encountered.
typedef ConstBaseIterator<
WindowRegistry > 		WindowIterator

Public Member Functions

WindowManager (void)
Constructs a new WindowManager object.
~WindowManager (void)
Destructor for WindowManager objects.
Window * | createWindow (const String &type, const String &name="")
Creates a new Window object of the specified type, and gives it the specified unique name.
void | destroyWindow (Window *window)
Destroy the specified Window object.
void | destroyWindow (const String &window)
Destroy the specified Window object.
Window * | getWindow (const String &name) const
Return a pointer to the specified Window object.
bool | isWindowPresent (const String &name) const
Examines the list of Window objects to see if one exists with the given name.
void | destroyAllWindows (void)
Destroys all Window objects within the system.
Window * | loadWindowLayout (const String &filename, const String &name_prefix="", const String &resourceGroup="", PropertyCallback *callback=NULL, void *userdata=NULL)
Creates a set of windows (a Gui layout) from the information in the specified XML file.
bool | isDeadPoolEmpty (void) const
Return whether the window dead pool is empty.
void | cleanDeadPool (void)
Permanently destroys any windows placed in the dead pool.
void | writeWindowLayoutToStream (const Window &window, OutStream &out_stream, bool writeParent=false) const
Writes a full XML window layout, starting at the given Window to the given OutStream.
void | writeWindowLayoutToStream (const String &window, OutStream &out_stream, bool writeParent=false) const
Writes a full XML window layout, starting at the given Window to the given OutStream.
void | renameWindow (const String &window, const String &new_name)
Rename a window.
void | renameWindow (Window *window, const String &new_name)
Rename a window.
WindowIterator | getIterator (void) const
Return a WindowManager::WindowIterator object to iterate over the currently defined Windows.

Static Public Member Functions

static WindowManager & | getSingleton (void)
Return singleton WindowManager object.
static WindowManager * | getSingletonPtr (void)
Return pointer to singleton WindowManager object.

Static Public Attributes

static const String | GeneratedWindowNameBase
Base name to use for generated window names.

Detailed Description

The WindowManager class describes an object that manages creation and lifetime of Window objects.

The WindowManager is the means by which Window objects are created and destroyed. For each sub-class of Window that is to be created, there must exist a WindowFactory object which is registered with the WindowFactoryManager. Additionally, the WindowManager tracks every Window object created, and can be used to access those Window objects by name.

Member Typedef Documentation

typedef bool CEGUI::WindowManager::PropertyCallback(Window *window, String &propname, String &propvalue, void *userdata)

Function type that is used as a callback when loading layouts from XML; the function is called for each Property element encountered.

Parameters:
window | Window object that the property is to be applied to.
propname | String holding the name of the property that is being set.
propvalue | String holding the new value that will be applied to the property specified by /a propname.
userdata | Some client code supplied data.
Returns:
  • true if the property should be set.
  • false if the property should not be set,

Constructor & Destructor Documentation

CEGUI::WindowManager::WindowManager ( void )

Constructs a new WindowManager object.

NB: Client code should not create WindowManager objects - they are of limited use to you! The intended pattern of access is to get a pointer to the GUI system's WindowManager via the System object, and use that.

CEGUI::WindowManager::~WindowManager ( void )

Destructor for WindowManager objects.

This will properly destry all remaining Window objects. Note that WindowFactory objects will not be destroyed (since they are owned by whoever created them).

Member Function Documentation

void CEGUI::WindowManager::cleanDeadPool ( void )

Permanently destroys any windows placed in the dead pool.

Note:
It is probably not a good idea to call this from a Window based event handler if the specific window has been or is being destroyed.
Returns:
Nothing.

Window * CEGUI::WindowManager::createWindow | ( | const String & | type,
 |  | const String & | name = ""
 | ) |

Creates a new Window object of the specified type, and gives it the specified unique name.

Parameters:
type | String that describes the type of Window to be created. A valid WindowFactory for the specified type must be registered.
name | String that holds a unique name that is to be given to the new window. If this string is empty (""), a name will be generated for the window.
Returns:
Pointer to the newly created Window object.
Exceptions:
AlreadyExistsException | A Window object with the name name already exists.
UnknownObjectException | No WindowFactory is registered for type Window objects.
GenericException | Some other error occurred (Exception message has details).

void CEGUI::WindowManager::destroyAllWindows ( void )

Destroys all Window objects within the system.

Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown if the WindowFactory for any Window object type has been removed.

void CEGUI::WindowManager::destroyWindow ( const String & window )

Destroy the specified Window object.

Parameters:
window String containing the name of the Window object to be destroyed. If window is not recognised, nothing happens.
Returns:
Nothing.
Exceptions:
InvalidRequestException Can be thrown if the WindowFactory for window's object type was removed.

void CEGUI::WindowManager::destroyWindow ( Window * window )

Destroy the specified Window object.

Parameters:
window Pointer to the Window object to be destroyed. If the window is null, or is not recognised, nothing happens.
Returns:
Nothing
Exceptions:
InvalidRequestException Can be thrown if the WindowFactory for window's object type was removed.

WindowManager & CEGUI::WindowManager::getSingleton ( void ) [static]

Return singleton WindowManager object.

Returns:
Singleton WindowManager object

WindowManager * CEGUI::WindowManager::getSingletonPtr ( void ) [static]

Return pointer to singleton WindowManager object.

Returns:
Pointer to singleton WindowManager object

Window * CEGUI::WindowManager::getWindow ( const String & name ) const

Return a pointer to the specified Window object.

Parameters:
name String holding the name of the Window object to be returned.
Returns:
Pointer to the Window object with the name name.
Exceptions:
UnknownObjectException No Window object with a name matching name was found.

bool CEGUI::WindowManager::isDeadPoolEmpty ( void ) const

Return whether the window dead pool is empty.

Returns:
  • true if there are no windows in the dead pool.
  • false if the dead pool contains >=1 window awaiting destruction.

bool CEGUI::WindowManager::isWindowPresent ( const String & name ) const

Examines the list of Window objects to see if one exists with the given name.

Parameters:
name String holding the name of the Window object to look for.
Returns:
true if a Window object was found with a name matching name. false if no matching Window object was found.

Window * CEGUI::WindowManager::loadWindowLayout | ( | const String & | filename,
 |  | const String & | name_prefix = "",
 |  | const String & | resourceGroup = "",
 |  | PropertyCallback * | callback = NULL,
 |  | void * | userdata = NULL
 | ) |

Creates a set of windows (a Gui layout) from the information in the specified XML file.

Parameters:
filename | String object holding the filename of the XML file to be processed.
name_prefix | String object holding the prefix that is to be used when creating the windows in the layout file, this function allows a layout to be loaded multiple times without having name clashes. Note that if you use this facility, then all windows defined within the layout must have names assigned; you currently can not use this feature in combination with automatically generated window names.
resourceGroup | Resource group identifier to be passed to the resource provider when loading the layout file.
callback | PropertyCallback function to be called for each Property element loaded from the layout. This is called prior to the property value being applied to the window enabling client code manipulation of properties.
userdata | Client code data pointer passed to the PropertyCallback function.
Returns:
Pointer to the root Window object defined in the layout.
Exceptions:
FileIOException | thrown if something goes wrong while processing the file filename.
InvalidRequestException | thrown if filename appears to be invalid.

void CEGUI::WindowManager::renameWindow | ( | Window * | window,
 |  | const String & | new_name
 | ) |

Rename a window.

Parameters:
window | Pointer to the window to be renamed.
new_name | String holding the new name for the window
Exceptions:
AlreadyExistsException thrown if a Window named new_name already exists.

void CEGUI::WindowManager::renameWindow | ( | const String & | window,
 |  | const String & | new_name
 | ) |

Rename a window.

Parameters:
window | String holding the current name of the window to be renamed.
new_name | String holding the new name for the window
Exceptions:
UnknownObjectException | thrown if window is not known in the system.
AlreadyExistsException | thrown if a Window named new_name already exists.

void CEGUI::WindowManager::writeWindowLayoutToStream | ( | const String & | window,
 |  | OutStream & | out_stream,
 |  | bool | writeParent = false
 | ) | const

Writes a full XML window layout, starting at the given Window to the given OutStream.

Parameters:
window | String holding the name of the Window object to become the root of the layout.
out_stream | OutStream (std::ostream based) object where data is to be sent.
writeParent | If the starting window has a parent window, specifies whether to write the parent name into the Parent attribute of the GUILayout XML element.
Returns:
Nothing.

void CEGUI::WindowManager::writeWindowLayoutToStream | ( | const Window & | window,
 |  | OutStream & | out_stream,
 |  | bool | writeParent = false
 | ) | const

Writes a full XML window layout, starting at the given Window to the given OutStream.

Parameters:
window | Window object to become the root of the layout.
out_stream | OutStream (std::ostream based) object where data is to be sent.
writeParent | If the starting window has a parent window, specifies whether to write the parent name into the Parent attribute of the GUILayout XML element.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties::WordWrap Class Reference

CEGUI::MultiLineEditboxProperties::WordWrap

CEGUI::MultiLineEditboxProperties::WordWrap Class Reference

Property to access the word-wrap setting of the edit box. More...

Inheritance diagram for CEGUI::MultiLineEditboxProperties::WordWrap:

[legend]
Collaboration diagram for CEGUI::MultiLineEditboxProperties::WordWrap:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access the word-wrap setting of the edit box.

Usage:
  • Name: WordWrap
  • Format: "[text]"
Where [Text] is:
  • "True" to indicate the text should be word-wrapped.
  • "False" to indicate the text should not be word-wrapped.

Member Function Documentation

String CEGUI::MultiLineEditboxProperties::WordWrap::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::MultiLineEditboxProperties::WordWrap::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::XercesParser Class Reference

CEGUI::XercesParser

CEGUI::XercesParser Class Reference

Implementation of XMLParser using Xerces-C++. More...

Inheritance diagram for CEGUI::XercesParser:

[legend]
Collaboration diagram for CEGUI::XercesParser:

[legend]
List of all members.

Public Member Functions

void | parseXMLFile (XMLHandler &handler, const String &filename, const String &schemaName, const String &resourceGroup)
abstract method which initiates parsing of an XML file.

Static Public Member Functions

static void | populateAttributesBlock (const XERCES_CPP_NAMESPACE::Attributes &src, XMLAttributes &dest)
Populate the CEGUI::XMLAttributes object with attribute data from the Xerces attributes block.
static String | transcodeXmlCharToString (const XMLCh *const xmlch_str)
Return a CEGUI::String containing the Xerces XMLChar string data in xmlch_str.

Protected Member Functions

bool | initialiseImpl (void)
abstract method which initialises the XMLParser ready for use.
void | cleanupImpl (void)
abstract method which cleans up the XMLParser after use.

Static Protected Member Functions

static void | initialiseSchema (XERCES_CPP_NAMESPACE::SAX2XMLReader *reader, const String &schemaName, const String &xmlFilename, const String &resourceGroup)
static XERCES_CPP_NAMESPACE::SAX2XMLReader * | createReader (XERCES_CPP_NAMESPACE::DefaultHandler &handler)
static void | doParse (XERCES_CPP_NAMESPACE::SAX2XMLReader *parser, const String &xmlFilename, const String &resourceGroup)

Detailed Description

Implementation of XMLParser using Xerces-C++.

Member Function Documentation

void CEGUI::XercesParser::cleanupImpl ( void ) [protected, virtual]

abstract method which cleans up the XMLParser after use.

Returns:
Nothing.

Implements CEGUI::XMLParser.

bool CEGUI::XercesParser::initialiseImpl ( void ) [protected, virtual]

abstract method which initialises the XMLParser ready for use.

Returns:
  • true if the module initialised successfully.
  • false if the module initialisation failed.

Implements CEGUI::XMLParser.

void CEGUI::XercesParser::parseXMLFile | ( | XMLHandler & | handler,
 |  | const String & | filename,
 |  | const String & | schemaName,
 |  | const String & | resourceGroup
 | ) | [virtual]

abstract method which initiates parsing of an XML file.

Parameters:
handler | XMLHandler based object which will process the XML elements.
filename | String object holding the filename of the XML file to be parsed.
schemaName | String object holding the name of the XML schema file to use for validating the XML. Note that whether this is used or not is dependant upon the XMLParser in use.
resourceGroup | String object holding the resource group identifier which will be passed to the ResourceProvider when loading the XML and schema files.
Returns:
Nothing.

Implements CEGUI::XMLParser.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::XMLAttributes Class Reference

CEGUI::XMLAttributes

CEGUI::XMLAttributes Class Reference

Class representing a block of attributes associated with an XML element. More...

List of all members.

Public Member Functions

XMLAttributes (void)
XMLAttributes constructor.
virtual | ~XMLAttributes (void)
XMLAttributes Destructor.
void | add (const String &attrName, const String &attrValue)
Adds an attribute to the attribute block. If the attribute value already exists, it is replaced with the new value.
void | remove (const String &attrName)
Removes an attribute from the attribute block.
bool | exists (const String &attrName) const
Return whether the named attribute exists within the attribute block.
size_t | getCount (void) const
Return the number of attributes in the attribute block.
const String & | getName (size_t index) const
Return the name of an attribute based upon its index within the attribute block.
const String & | getValue (size_t index) const
Return the value string of an attribute based upon its index within the attribute block.
const String & | getValue (const String &attrName) const
Return the value string for attribute attrName.
const String & | getValueAsString (const String &attrName, const String &def="") const
Return the value of attribute attrName as a string.
bool | getValueAsBool (const String &attrName, bool def=false) const
Return the value of attribute attrName as a boolean value.
int | getValueAsInteger (const String &attrName, int def=0) const
Return the value of attribute attrName as a integer value.
float | getValueAsFloat (const String &attrName, float def=0.0f) const
Return the value of attribute attrName as a floating point value.

Protected Types

typedef std::map< String,
String > 		AttributeMap

Protected Attributes

AttributeMap | d_attrs

Detailed Description

Class representing a block of attributes associated with an XML element.

Member Function Documentation

void CEGUI::XMLAttributes::add | ( | const String & | attrName,
 |  | const String & | attrValue
 | ) |

Adds an attribute to the attribute block. If the attribute value already exists, it is replaced with the new value.

Parameters:
attrName | String object holding the name of the attribute to be added.
attrValue | String object holding a string representation of the attribute value.
Returns:
Nothing.

bool CEGUI::XMLAttributes::exists ( const String & attrName ) const

Return whether the named attribute exists within the attribute block.

Parameters:
attrName String object holding the name of the attribute to be checked.
Returns:
  • true if an attribute with the name attrName is present in the attribute block.
  • false if no attribute named attrName is present in the attribute block.

size_t CEGUI::XMLAttributes::getCount ( void ) const

Return the number of attributes in the attribute block.

Returns:
value specifying the number of attributes in this attribute block.

const String & CEGUI::XMLAttributes::getName ( size_t index ) const

Return the name of an attribute based upon its index within the attribute block.

Note:
Nothing is specified about the order of elements within the attribute block. Elements may not, for example, appear in the order they were specified in the XML file.
Parameters:
index zero based index of the attribute whos name is to be returned.
Returns:
String object holding the name of the attribute at the requested index.
Exceptions:
IllegalRequestException thrown if index is out of range for this attribute block.

const String & CEGUI::XMLAttributes::getValue ( const String & attrName ) const

Return the value string for attribute attrName.

Parameters:
attrName String object holding the name of the attribute whos value string is to be returned
Returns:
String object hilding the value string for attribute attrName.
Exceptions:
UnknownObjectException thrown if no attribute named attrName is present in the attribute block.

const String & CEGUI::XMLAttributes::getValue ( size_t index ) const

Return the value string of an attribute based upon its index within the attribute block.

Note:
Nothing is specified about the order of elements within the attribute block. Elements may not, for example, appear in the order they were specified in the XML file.
Parameters:
index zero based index of the attribute whos value string is to be returned.
Returns:
String object holding the string value of the attribute at the requested index.
Exceptions:
IllegalRequestException thrown if index is out of range for this attribute block.

bool CEGUI::XMLAttributes::getValueAsBool | ( | const String & | attrName,
 |  | bool | def = false
 | ) | const

Return the value of attribute attrName as a boolean value.

Parameters:
attrName | String object holding the name of the attribute whos value is to be returned.
def | bool value specifying the default value to be returned if attrName does not exist in the attribute block. For some parsers, defaults can be gotten from schemas and such like, though for others this may not be desired or possible, so this parameter is used to ensure a default is available in the abscence of other mechanisms.
Returns:
bool value equal to the value of attribute attrName if present, or def if not.
Exceptions:
IllegalRequestException thrown if the attribute value string coul dnot be converted to the requested type.

float CEGUI::XMLAttributes::getValueAsFloat | ( | const String & | attrName,
 |  | float | def = 0.0f
 | ) | const

Return the value of attribute attrName as a floating point value.

Parameters:
attrName | String object holding the name of the attribute whos value is to be returned.
def | float value specifying the default value to be returned if attrName does not exist in the attribute block. For some parsers, defaults can be gotten from schemas and such like, though for others this may not be desired or possible, so this parameter is used to ensure a default is available in the abscence of other mechanisms.
Returns:
float value equal to the value of attribute attrName if present, or def if not.
Exceptions:
IllegalRequestException thrown if the attribute value string coul dnot be converted to the requested type.

int CEGUI::XMLAttributes::getValueAsInteger | ( | const String & | attrName,
 |  | int | def = 0
 | ) | const

Return the value of attribute attrName as a integer value.

Parameters:
attrName | String object holding the name of the attribute whos value is to be returned.
def | integer value specifying the default value to be returned if attrName does not exist in the attribute block. For some parsers, defaults can be gotten from schemas and such like, though for others this may not be desired or possible, so this parameter is used to ensure a default is available in the abscence of other mechanisms.
Returns:
integer value equal to the value of attribute attrName if present, or def if not.
Exceptions:
IllegalRequestException thrown if the attribute value string coul dnot be converted to the requested type.

const String & CEGUI::XMLAttributes::getValueAsString | ( | const String & | attrName,
 |  | const String & | def = ""
 | ) | const

Return the value of attribute attrName as a string.

Parameters:
attrName | String object holding the name of the attribute whos value is to be returned.
def | String object holding the default value to be returned if attrName does not exist in the attribute block. For some parsers, defaults can be gotten from schemas and such like, though for others this may not be desired or possible, so this parameter is used to ensure a default is available in the abscence of other mechanisms.
Returns:
String object containing the value of attribute attrName if present, or def if not.

void CEGUI::XMLAttributes::remove ( const String & attrName )

Removes an attribute from the attribute block.

Parameters:
attrName String object holding the name of the attribute to be removed.
Returns:
Nothing.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::XMLParser Class Reference

CEGUI::XMLParser

CEGUI::XMLParser Class Reference

This is an abstract class that is used by CEGUI to interface with XML parser libraries. More...

Inheritance diagram for CEGUI::XMLParser:

[legend]
Collaboration diagram for CEGUI::XMLParser:

[legend]
List of all members.

Public Member Functions

XMLParser (void)
XMLParser base class constructor.
virtual | ~XMLParser (void)
XMLParser base class destructor.
bool | initialise (void)
Initialises the XMLParser module ready for use.
void | cleanup (void)
Cleans up the XMLParser module after use.
virtual void | parseXMLFile (XMLHandler &handler, const String &filename, const String &schemaName, const String &resourceGroup)=0
abstract method which initiates parsing of an XML file.
const String & | getIdentifierString () const
Return identification string for the XML parser module. If the internal id string has not been set by the XML parser module creator, a generic string of "Unknown XML parser" will be returned.

Protected Member Functions

virtual bool | initialiseImpl (void)=0
abstract method which initialises the XMLParser ready for use.
virtual void | cleanupImpl (void)=0
abstract method which cleans up the XMLParser after use.

Protected Attributes

String d_identifierString
String that holds some id information about the module.

Detailed Description

This is an abstract class that is used by CEGUI to interface with XML parser libraries.

Member Function Documentation

void CEGUI::XMLParser::cleanup ( void )

Cleans up the XMLParser module after use.

Note that this calls the protected abstract method 'cleanupImpl', which should be provided in your implementation to perform any required cleanup.

Returns:
Nothing.

virtual void CEGUI::XMLParser::cleanupImpl ( void ) [protected, pure virtual]

abstract method which cleans up the XMLParser after use.

Returns:
Nothing.

Implemented in CEGUI::TinyXMLParser, and CEGUI::XercesParser.

const String & CEGUI::XMLParser::getIdentifierString ( ) const

Return identification string for the XML parser module. If the internal id string has not been set by the XML parser module creator, a generic string of "Unknown XML parser" will be returned.

Returns:
String object holding a string that identifies the XML parser in use.

bool CEGUI::XMLParser::initialise ( void )

Initialises the XMLParser module ready for use.

Note that this calls the protected abstract method 'initialiseImpl', which should be provided in your implementation to perform any required initialisation.

Returns:
  • true if the module initialised successfully.
  • false if the module initialisation failed.

virtual bool CEGUI::XMLParser::initialiseImpl ( void ) [protected, pure virtual]

abstract method which initialises the XMLParser ready for use.

Returns:
  • true if the module initialised successfully.
  • false if the module initialisation failed.

Implemented in CEGUI::TinyXMLParser, and CEGUI::XercesParser.

virtual void CEGUI::XMLParser::parseXMLFile | ( | XMLHandler & | handler,
 |  | const String & | filename,
 |  | const String & | schemaName,
 |  | const String & | resourceGroup
 | ) | [pure virtual]

abstract method which initiates parsing of an XML file.

Parameters:
handler | XMLHandler based object which will process the XML elements.
filename | String object holding the filename of the XML file to be parsed.
schemaName | String object holding the name of the XML schema file to use for validating the XML. Note that whether this is used or not is dependant upon the XMLParser in use.
resourceGroup | String object holding the resource group identifier which will be passed to the ResourceProvider when loading the XML and schema files.
Returns:
Nothing.

Implemented in CEGUI::TinyXMLParser, and CEGUI::XercesParser.

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::XPosition Class Reference

CEGUI::WindowProperties::XPosition

CEGUI::WindowProperties::XPosition Class Reference

Property to access window X position. More...

Inheritance diagram for CEGUI::WindowProperties::XPosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::XPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window X position.

This property offers access to the X position for the window, using the Windows active metrics mode.

Usage:
  • Name: XPosition
  • Format: "[float]".
Where:
  • [float] specifies the x position co-ordinate as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::XPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::XPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::YPosition Class Reference

CEGUI::WindowProperties::YPosition

CEGUI::WindowProperties::YPosition Class Reference

Property to access window Y position. More...

Inheritance diagram for CEGUI::WindowProperties::YPosition:

[legend]
Collaboration diagram for CEGUI::WindowProperties::YPosition:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window Y position.

This property offers access to the Y position for the window, using the Windows active metrics mode.

Usage:
  • Name: YPosition
  • Format: "[float]".
Where:
  • [float] specifies the y position co-ordinate as a floating point number, using the active metrics system for the Window.

Member Function Documentation

String CEGUI::WindowProperties::YPosition::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::YPosition::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties::ZOrderChangeEnabled Class Reference

CEGUI::WindowProperties::ZOrderChangeEnabled

CEGUI::WindowProperties::ZOrderChangeEnabled Class Reference

Property to access window Z-Order changing enabled setting. More...

Inheritance diagram for CEGUI::WindowProperties::ZOrderChangeEnabled:

[legend]
Collaboration diagram for CEGUI::WindowProperties::ZOrderChangeEnabled:

[legend]
List of all members.

Public Member Functions

String | get (const PropertyReceiver *receiver) const
Return the current value of the Property as a String.
void | set (PropertyReceiver *receiver, const String &value)
Sets the value of the property.

Detailed Description

Property to access window Z-Order changing enabled setting.

This property offers access to the setting that controls whether z-order changes are enabled for the window.

Usage:
  • Name: ZOrderChangeEnabled
  • Format: "[text]".
Where [Text] is:
  • "True" to indicate the Window should respect requests to change z-order.
  • "False" to indicate the Window should not change it's z-order.

Member Function Documentation

String CEGUI::WindowProperties::ZOrderChangeEnabled::get ( const PropertyReceiver * receiver ) const [virtual]

Return the current value of the Property as a String.

Parameters:
receiver Pointer to the target object.
Returns:
String object containing a textual representation of the current value of the Property

Implements CEGUI::Property.

void CEGUI::WindowProperties::ZOrderChangeEnabled::set | ( | PropertyReceiver * | receiver,
 |  | const String & | value
 | ) | [virtual]

Sets the value of the property.

Parameters:
receiver | Pointer to the target object.
value | A String object that contains a textual representation of the new value to assign to the Property.
Returns:
Nothing.
Exceptions:
InvalidRequestException Thrown when the Property was unable to interpret the content of value.

Implements CEGUI::Property.

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Hierarchical Index

Crazy Eddies GUI System Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

  • CEGUI::BaseDim
    • CEGUI::AbsoluteDim
    • CEGUI::FontDim
    • CEGUI::ImageDim
    • CEGUI::PropertyDim
    • CEGUI::UnifiedDim
    • CEGUI::WidgetDim
  • CEGUI::colour
  • CEGUI::ColourRect
  • CEGUI::ComponentArea
  • CEGUI::Config_xmlHandler
  • CEGUI::ConstBaseIterator< T >
  • CEGUI::Dimension
  • CEGUI::Event
  • CEGUI::Event::ConnectionInterface
  • CEGUI::Event::ScopedConnection
  • CEGUI::EventArgs
    • CEGUI::MouseCursorEventArgs
    • CEGUI::WindowEventArgs
      • CEGUI::ActivationEventArgs
      • CEGUI::DragDropEventArgs
      • CEGUI::HeaderSequenceEventArgs
      • CEGUI::KeyEventArgs
      • CEGUI::MouseEventArgs
  • CEGUI::EventSet
    • CEGUI::GlobalEventSet
    • CEGUI::MouseCursor
    • CEGUI::Renderer
      • CEGUI::DirectX81Renderer
      • CEGUI::DirectX9Renderer
      • CEGUI::IrrlichtRenderer
      • CEGUI::OpenGLRenderer
    • CEGUI::System
    • CEGUI::Window
      • CEGUI::ButtonBase
        • CEGUI::Checkbox
        • CEGUI::PushButton
          • CEGUI::Thumb
        • CEGUI::RadioButton
        • CEGUI::TabButton
      • CEGUI::Combobox
      • CEGUI::DragContainer
      • CEGUI::Editbox
      • CEGUI::FrameWindow
      • CEGUI::GUISheet
      • CEGUI::ItemEntry
        • CEGUI::TextItem
          • CEGUI::MenuItem
      • CEGUI::ItemListBase
        • CEGUI::MenuBase
          • CEGUI::Menubar
          • CEGUI::PopupMenu
      • CEGUI::Listbox
        • CEGUI::ComboDropList
      • CEGUI::ListHeader
      • CEGUI::ListHeaderSegment
      • CEGUI::MultiColumnList
      • CEGUI::MultiLineEditbox
      • CEGUI::ProgressBar
      • CEGUI::ScrollablePane
      • CEGUI::Scrollbar
      • CEGUI::ScrolledContainer
      • CEGUI::Slider
      • CEGUI::Spinner
      • CEGUI::Static
        • CEGUI::StaticImage
        • CEGUI::StaticText
        • CEGUI::TabPane
      • CEGUI::TabControl
      • CEGUI::Titlebar
      • CEGUI::Tooltip
  • CEGUI::Exception
    • CEGUI::AlreadyExistsException
    • CEGUI::FileIOException
    • CEGUI::GenericException
    • CEGUI::InvalidRequestException
    • CEGUI::MemoryException
    • CEGUI::NullObjectException
    • CEGUI::ObjectInUseException
    • CEGUI::RendererException
    • CEGUI::UnknownObjectException
  • CEGUI::FactoryModule
  • CEGUI::Falagard_xmlHandler
  • CEGUI::FalagardComponentBase
    • CEGUI::FrameComponent
    • CEGUI::ImageryComponent
    • CEGUI::TextComponent
  • CEGUI::FalagardXMLHelper
  • CEGUI::Font
  • CEGUI::Font_xmlHandler
  • CEGUI::FontManager
  • CEGUI::GUILayout_xmlHandler
  • CEGUI::Image
  • CEGUI::ImagerySection
  • CEGUI::Imageset
  • CEGUI::Imageset_xmlHandler
  • CEGUI::ImagesetManager
  • CEGUI::Key
  • CEGUI::LayerSpecification
  • CEGUI::ListboxItem
    • CEGUI::ListboxTextItem
  • CEGUI::Logger
  • CEGUI::MCLGridRef
  • CEGUI::MouseClickTracker
  • CEGUI::MultiColumnList::ListRow
  • CEGUI::MultiLineEditbox::LineInfo
  • CEGUI::NamedArea
  • CEGUI::Property
    • CEGUI::ButtonBaseProperties::DisabledTextColour
    • CEGUI::ButtonBaseProperties::HoverTextColour
    • CEGUI::ButtonBaseProperties::NormalTextColour
    • CEGUI::ButtonBaseProperties::PushedTextColour
    • CEGUI::CheckboxProperties::Selected
    • CEGUI::ComboboxProperties::ActiveEditSelectionColour
    • CEGUI::ComboboxProperties::CaratIndex
    • CEGUI::ComboboxProperties::EditSelectionLength
    • CEGUI::ComboboxProperties::EditSelectionStart
    • CEGUI::ComboboxProperties::ForceHorzScrollbar
    • CEGUI::ComboboxProperties::ForceVertScrollbar
    • CEGUI::ComboboxProperties::InactiveEditSelectionColour
    • CEGUI::ComboboxProperties::MaxEditTextLength
    • CEGUI::ComboboxProperties::NormalEditTextColour
    • CEGUI::ComboboxProperties::ReadOnly
    • CEGUI::ComboboxProperties::SelectedEditTextColour
    • CEGUI::ComboboxProperties::SingleClickMode
    • CEGUI::ComboboxProperties::SortList
    • CEGUI::ComboboxProperties::ValidationString
    • CEGUI::DragContainerProperties::DragAlpha
    • CEGUI::DragContainerProperties::DragCursorImage
    • CEGUI::DragContainerProperties::DraggingEnabled
    • CEGUI::DragContainerProperties::DragThreshold
    • CEGUI::EditboxProperties::ActiveSelectionColour
    • CEGUI::EditboxProperties::CaratIndex
    • CEGUI::EditboxProperties::InactiveSelectionColour
    • CEGUI::EditboxProperties::MaskCodepoint
    • CEGUI::EditboxProperties::MaskText
    • CEGUI::EditboxProperties::MaxTextLength
    • CEGUI::EditboxProperties::NormalTextColour
    • CEGUI::EditboxProperties::ReadOnly
    • CEGUI::EditboxProperties::SelectedTextColour
    • CEGUI::EditboxProperties::SelectionLength
    • CEGUI::EditboxProperties::SelectionStart
    • CEGUI::EditboxProperties::ValidationString
    • CEGUI::FrameWindowProperties::CaptionColour
    • CEGUI::FrameWindowProperties::CloseButtonEnabled
    • CEGUI::FrameWindowProperties::DragMovingEnabled
    • CEGUI::FrameWindowProperties::EWSizingCursorImage
    • CEGUI::FrameWindowProperties::FrameEnabled
    • CEGUI::FrameWindowProperties::NESWSizingCursorImage
    • CEGUI::FrameWindowProperties::NSSizingCursorImage
    • CEGUI::FrameWindowProperties::NWSESizingCursorImage
    • CEGUI::FrameWindowProperties::RollUpEnabled
    • CEGUI::FrameWindowProperties::RollUpState
    • CEGUI::FrameWindowProperties::SizingBorderThickness
    • CEGUI::FrameWindowProperties::SizingEnabled
    • CEGUI::FrameWindowProperties::TitlebarEnabled
    • CEGUI::FrameWindowProperties::TitlebarFont
    • CEGUI::ItemListBaseProperties::AutoResizeEnabled
    • CEGUI::ListboxProperties::ForceHorzScrollbar
    • CEGUI::ListboxProperties::ForceVertScrollbar
    • CEGUI::ListboxProperties::ItemTooltips
    • CEGUI::ListboxProperties::MultiSelect
    • CEGUI::ListboxProperties::Sort
    • CEGUI::ListHeaderProperties::ColumnsMovable
    • CEGUI::ListHeaderProperties::ColumnsSizable
    • CEGUI::ListHeaderProperties::SortColumnID
    • CEGUI::ListHeaderProperties::SortDirection
    • CEGUI::ListHeaderProperties::SortSettingEnabled
    • CEGUI::ListHeaderSegmentProperties::Clickable
    • CEGUI::ListHeaderSegmentProperties::Dragable
    • CEGUI::ListHeaderSegmentProperties::Sizable
    • CEGUI::ListHeaderSegmentProperties::SortDirection
    • CEGUI::MenuBaseProperties::AllowMultiplePopups
    • CEGUI::MenuBaseProperties::BackgroundColours
    • CEGUI::MenuBaseProperties::BorderWidth
    • CEGUI::MenuBaseProperties::HorzPadding
    • CEGUI::MenuBaseProperties::ItemSpacing
    • CEGUI::MenuBaseProperties::VertPadding
    • CEGUI::MenuItemProperties::DisabledTextColour
    • CEGUI::MenuItemProperties::HoverColour
    • CEGUI::MenuItemProperties::NormalTextColour
    • CEGUI::MenuItemProperties::OpenedColour
    • CEGUI::MenuItemProperties::PushedColour
    • CEGUI::MultiColumnListProperties::ColumnHeader
    • CEGUI::MultiColumnListProperties::ColumnsMovable
    • CEGUI::MultiColumnListProperties::ColumnsSizable
    • CEGUI::MultiColumnListProperties::ForceHorzScrollbar
    • CEGUI::MultiColumnListProperties::ForceVertScrollbar
    • CEGUI::MultiColumnListProperties::NominatedSelectionColumnID
    • CEGUI::MultiColumnListProperties::NominatedSelectionRow
    • CEGUI::MultiColumnListProperties::RowCount
    • CEGUI::MultiColumnListProperties::SelectionMode
    • CEGUI::MultiColumnListProperties::SortColumnID
    • CEGUI::MultiColumnListProperties::SortDirection
    • CEGUI::MultiColumnListProperties::SortSettingEnabled
    • CEGUI::MultiLineEditboxProperties::ActiveSelectionColour
    • CEGUI::MultiLineEditboxProperties::CaratIndex
    • CEGUI::MultiLineEditboxProperties::InactiveSelectionColour
    • CEGUI::MultiLineEditboxProperties::MaxTextLength
    • CEGUI::MultiLineEditboxProperties::NormalTextColour
    • CEGUI::MultiLineEditboxProperties::ReadOnly
    • CEGUI::MultiLineEditboxProperties::SelectedTextColour
    • CEGUI::MultiLineEditboxProperties::SelectionLength
    • CEGUI::MultiLineEditboxProperties::SelectionStart
    • CEGUI::MultiLineEditboxProperties::WordWrap
    • CEGUI::PopupMenuProperties::FadeInTime
    • CEGUI::PopupMenuProperties::FadeOutTime
    • CEGUI::ProgressBarProperties::CurrentProgress
    • CEGUI::ProgressBarProperties::StepSize
    • CEGUI::PropertyDefinition
    • CEGUI::PushButtonProperties::DisabledImage
    • CEGUI::PushButtonProperties::HoverImage
    • CEGUI::PushButtonProperties::NormalImage
    • CEGUI::PushButtonProperties::PushedImage
    • CEGUI::PushButtonProperties::TextXOffset
    • CEGUI::PushButtonProperties::UseStandardImagery
    • CEGUI::RadioButtonProperties::GroupID
    • CEGUI::RadioButtonProperties::Selected
    • CEGUI::ScrollablePaneProperties::ContentArea
    • CEGUI::ScrollablePaneProperties::ContentPaneAutoSized
    • CEGUI::ScrollablePaneProperties::ForceHorzScrollbar
    • CEGUI::ScrollablePaneProperties::ForceVertScrollbar
    • CEGUI::ScrollablePaneProperties::HorzOverlapSize
    • CEGUI::ScrollablePaneProperties::HorzScrollPosition
    • CEGUI::ScrollablePaneProperties::HorzStepSize
    • CEGUI::ScrollablePaneProperties::VertOverlapSize
    • CEGUI::ScrollablePaneProperties::VertScrollPosition
    • CEGUI::ScrollablePaneProperties::VertStepSize
    • CEGUI::ScrollbarProperties::DocumentSize
    • CEGUI::ScrollbarProperties::OverlapSize
    • CEGUI::ScrollbarProperties::PageSize
    • CEGUI::ScrollbarProperties::ScrollPosition
    • CEGUI::ScrollbarProperties::StepSize
    • CEGUI::ScrolledContainerProperties::ChildExtentsArea
    • CEGUI::ScrolledContainerProperties::ContentArea
    • CEGUI::ScrolledContainerProperties::ContentPaneAutoSized
    • CEGUI::SliderProperties::ClickStepSize
    • CEGUI::SliderProperties::CurrentValue
    • CEGUI::SliderProperties::MaximumValue
    • CEGUI::SpinnerProperties::CurrentValue
    • CEGUI::SpinnerProperties::MaximumValue
    • CEGUI::SpinnerProperties::MinimumValue
    • CEGUI::SpinnerProperties::StepSize
    • CEGUI::SpinnerProperties::TextInputMode
    • CEGUI::StaticImageProperties::HorzFormatting
    • CEGUI::StaticImageProperties::Image
    • CEGUI::StaticImageProperties::ImageColours
    • CEGUI::StaticImageProperties::VertFormatting
    • CEGUI::StaticProperties::BackgroundColours
    • CEGUI::StaticProperties::BackgroundEnabled
    • CEGUI::StaticProperties::BackgroundImage
    • CEGUI::StaticProperties::BottomFrameImage
    • CEGUI::StaticProperties::BottomLeftFrameImage
    • CEGUI::StaticProperties::BottomRightFrameImage
    • CEGUI::StaticProperties::FrameColours
    • CEGUI::StaticProperties::FrameEnabled
    • CEGUI::StaticProperties::LeftFrameImage
    • CEGUI::StaticProperties::RightFrameImage
    • CEGUI::StaticProperties::TopFrameImage
    • CEGUI::StaticProperties::TopLeftFrameImage
    • CEGUI::StaticProperties::TopRightFrameImage
    • CEGUI::StaticTextProperties::HorzFormatting
    • CEGUI::StaticTextProperties::HorzScrollbar
    • CEGUI::StaticTextProperties::TextColours
    • CEGUI::StaticTextProperties::VertFormatting
    • CEGUI::StaticTextProperties::VertScrollbar
    • CEGUI::TabControlProperties::AbsoluteTabHeight
    • CEGUI::TabControlProperties::AbsoluteTabTextPadding
    • CEGUI::TabControlProperties::RelativeTabHeight
    • CEGUI::TabControlProperties::RelativeTabTextPadding
    • CEGUI::TabControlProperties::TabHeight
    • CEGUI::TabControlProperties::TabTextPadding
    • CEGUI::TextItemProperties::TextColour
    • CEGUI::TextItemProperties::TextFormatting
    • CEGUI::TextItemProperties::TextXOffset
    • CEGUI::ThumbProperties::HorzFree
    • CEGUI::ThumbProperties::HorzRange
    • CEGUI::ThumbProperties::HotTracked
    • CEGUI::ThumbProperties::VertFree
    • CEGUI::ThumbProperties::VertRange
    • CEGUI::TitlebarProperties::CaptionColour
    • CEGUI::TitlebarProperties::DraggingEnabled
    • CEGUI::TooltipProperties::DisplayTime
    • CEGUI::TooltipProperties::FadeTime
    • CEGUI::TooltipProperties::HoverTime
    • CEGUI::WindowProperties::AbsoluteHeight
    • CEGUI::WindowProperties::AbsoluteMaxSize
    • CEGUI::WindowProperties::AbsoluteMinSize
    • CEGUI::WindowProperties::AbsolutePosition
    • CEGUI::WindowProperties::AbsoluteRect
    • CEGUI::WindowProperties::AbsoluteSize
    • CEGUI::WindowProperties::AbsoluteWidth
    • CEGUI::WindowProperties::AbsoluteXPosition
    • CEGUI::WindowProperties::AbsoluteYPosition
    • CEGUI::WindowProperties::Alpha
    • CEGUI::WindowProperties::AlwaysOnTop
    • CEGUI::WindowProperties::AutoRepeatDelay
    • CEGUI::WindowProperties::AutoRepeatRate
    • CEGUI::WindowProperties::ClippedByParent
    • CEGUI::WindowProperties::CustomTooltipType
    • CEGUI::WindowProperties::DestroyedByParent
    • CEGUI::WindowProperties::Disabled
    • CEGUI::WindowProperties::DistributeCapturedInputs
    • CEGUI::WindowProperties::Font
    • CEGUI::WindowProperties::Height
    • CEGUI::WindowProperties::HorizontalAlignment
    • CEGUI::WindowProperties::ID
    • CEGUI::WindowProperties::InheritsAlpha
    • CEGUI::WindowProperties::InheritsTooltipText
    • CEGUI::WindowProperties::MetricsMode
    • CEGUI::WindowProperties::MouseButtonDownAutoRepeat
    • CEGUI::WindowProperties::MouseCursorImage
    • CEGUI::WindowProperties::Position
    • CEGUI::WindowProperties::Rect
    • CEGUI::WindowProperties::RelativeHeight
    • CEGUI::WindowProperties::RelativeMaxSize
    • CEGUI::WindowProperties::RelativeMinSize
    • CEGUI::WindowProperties::RelativePosition
    • CEGUI::WindowProperties::RelativeRect
    • CEGUI::WindowProperties::RelativeSize
    • CEGUI::WindowProperties::RelativeWidth
    • CEGUI::WindowProperties::RelativeXPosition
    • CEGUI::WindowProperties::RelativeYPosition
    • CEGUI::WindowProperties::RestoreOldCapture
    • CEGUI::WindowProperties::RiseOnClick
    • CEGUI::WindowProperties::Size
    • CEGUI::WindowProperties::Text
    • CEGUI::WindowProperties::Tooltip
    • CEGUI::WindowProperties::VerticalAlignment
    • CEGUI::WindowProperties::Visible
    • CEGUI::WindowProperties::WantsMultiClickEvents
    • CEGUI::WindowProperties::Width
    • CEGUI::WindowProperties::XPosition
    • CEGUI::WindowProperties::YPosition
    • CEGUI::WindowProperties::ZOrderChangeEnabled
  • CEGUI::PropertyHelper
  • CEGUI::PropertyInitialiser
  • CEGUI::PropertyReceiver
    • CEGUI::PropertySet
      • CEGUI::Window
  • CEGUI::Rect
  • CEGUI::RegexValidator
  • CEGUI::RenderableFrame
  • CEGUI::RenderableImage
  • CEGUI::RenderCache
  • CEGUI::ResourceProvider
  • CEGUI::Scheme
  • CEGUI::Scheme_xmlHandler
  • CEGUI::SchemeManager
  • CEGUI::ScriptFunctor
  • CEGUI::ScriptModule
  • CEGUI::SectionSpecification
  • CEGUI::SimpleTimer
  • CEGUI::Size
  • CEGUI::StateImagery
  • CEGUI::String
  • CEGUI::String::const_iterator
    • CEGUI::String::iterator
  • CEGUI::SubscriberInterface< Ret, Args >
    • CEGUI::_freeBinder< Ret, Args >
    • CEGUI::_functorBinder< Functor, Ret, Args >
    • CEGUI::_memberBinder< T, Ret, Args >
    • CEGUI::_refBinder< Functor, Ret, Args >
  • CEGUI::SubscriberTemplate< Ret, Args >
  • CEGUI::Texture
    • CEGUI::DirectX81Texture
    • CEGUI::DirectX9Texture
    • CEGUI::OpenGLTexture
  • CEGUI::TextUtils
  • TiXmlBase
    • TiXmlAttribute
    • TiXmlNode
      • TiXmlComment
      • TiXmlDeclaration
      • TiXmlDocument
      • TiXmlElement
      • TiXmlText
      • TiXmlUnknown
  • TiXmlHandle
  • CEGUI::UDim
  • CEGUI::URect
  • CEGUI::UVector2
  • CEGUI::Vector2
  • CEGUI::Vector3
  • CEGUI::WidgetComponent
  • CEGUI::WidgetLookFeel
  • CEGUI::WidgetLookManager
  • CEGUI::WindowFactory
    • CEGUI::DragContainerFactory
    • CEGUI::GUISheetFactory
    • CEGUI::ScrolledContainerFactory
  • CEGUI::WindowFactoryManager
  • CEGUI::WindowFactoryManager::AliasTargetStack
  • CEGUI::WindowFactoryManager::FalagardWindowMapping
  • CEGUI::WindowManager
  • CEGUI::XMLAttributes
  • CEGUI::XMLParser
    • CEGUI::TinyXMLParser
    • CEGUI::XercesParser
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AbsoluteDim() : CEGUI::AbsoluteDim
  • absoluteToRelative() : CEGUI::Window
  • absoluteToRelative_impl() : CEGUI::Window
  • absoluteToRelativeX() : CEGUI::Window
  • absoluteToRelativeY() : CEGUI::Window
  • activate() : CEGUI::Window
  • activateEditbox() : CEGUI::Combobox
  • Active : CEGUI::Tooltip
  • add() : CEGUI::XMLAttributes
  • addButtonForTabContent() : CEGUI::TabControl
  • addCheckboxEvents() : CEGUI::Checkbox
  • addChild_impl() : CEGUI::TabControl, CEGUI::ScrollablePane, CEGUI::Window
  • addChildWindow() : CEGUI::Window
  • addColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • addComboboxEvents() : CEGUI::Combobox
  • addComboDropListEvents() : CEGUI::ComboDropList
  • addDragContainerEvents() : CEGUI::DragContainer
  • addEditboxEvents() : CEGUI::Editbox
  • addEvent() : CEGUI::EventSet
  • addFactory() : CEGUI::WindowFactoryManager
  • addFalagardWindowMapping() : CEGUI::WindowFactoryManager
  • addFrameComponent() : CEGUI::ImagerySection
  • addFrameWindowEvents() : CEGUI::FrameWindow
  • addHeaderSegmentEvents() : CEGUI::ListHeaderSegment
  • addImageryComponent() : CEGUI::ImagerySection
  • addImagerySection() : CEGUI::WidgetLookFeel
  • addItem() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • addItemEntryEvents() : CEGUI::ItemEntry
  • addItemListBaseEvents() : CEGUI::ItemListBase
  • addLayer() : CEGUI::StateImagery
  • addListboxEvents() : CEGUI::Listbox
  • addListHeaderEvents() : CEGUI::ListHeader
  • addMenuBaseEvents() : CEGUI::MenuBase
  • addMenuItemEvents() : CEGUI::MenuItem
  • addMouseCursorEvents() : CEGUI::MouseCursor
  • addMultiColumnListboxEvents() : CEGUI::MultiColumnList
  • addMultiLineEditboxEvents() : CEGUI::MultiLineEditbox
  • addNamedArea() : CEGUI::WidgetLookFeel
  • addProgressBarEvents() : CEGUI::ProgressBar
  • addProperty() : CEGUI::PropertySet
  • addPropertyDefinition() : CEGUI::WidgetLookFeel
  • addPropertyInitialiser() : CEGUI::WidgetLookFeel
  • addPushButtonEvents() : CEGUI::PushButton
  • addQuad() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • addRadioButtonEvents() : CEGUI::RadioButton
  • addRow() : CEGUI::MultiColumnList
  • addScrollablePaneEvents() : CEGUI::ScrollablePane
  • addScrollbarEvents() : CEGUI::Scrollbar
  • addScrolledContainerEvents() : CEGUI::ScrolledContainer
  • addSectionSpecification() : CEGUI::LayerSpecification
  • addSliderEvents() : CEGUI::Slider
  • addSpinnerEvents() : CEGUI::Spinner
  • addStandardEvents() : CEGUI::Window
  • addStandardProperties() : CEGUI::Window
  • addStateSpecification() : CEGUI::WidgetLookFeel
  • addTab() : CEGUI::TabControl
  • addTabButtonEvents() : CEGUI::TabButton
  • addTabControlEvents() : CEGUI::TabControl
  • addTextComponent() : CEGUI::ImagerySection
  • addThumbEvents() : CEGUI::Thumb
  • addTooltipEvents() : CEGUI::Tooltip
  • addWidgetComponent() : CEGUI::WidgetLookFeel
  • addWidgetLook() : CEGUI::WidgetLookManager
  • addWindowToDrawList() : CEGUI::Window
  • addWindowTypeAlias() : CEGUI::WindowFactoryManager
  • adjustProgress() : CEGUI::ProgressBar
  • advanceZValue() : CEGUI::Renderer
  • AliasTargetStack() : CEGUI::WindowFactoryManager::AliasTargetStack
  • append() : CEGUI::String
  • apply() : CEGUI::PropertyInitialiser
  • Ascending : CEGUI::ListHeaderSegment
  • assign() : CEGUI::String
  • at() : CEGUI::String
  • Attribute() : TiXmlElement
  • autoSizeColumnHeader() : CEGUI::MultiColumnList
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Namespace Index

  • Namespace List
  • Namespace Members

Crazy Eddies GUI System Namespace List

Here is a list of all documented namespaces with brief descriptions:
CEGUI | Main namespace for Crazy Eddie's GUI Library
CEGUI::ButtonBaseProperties | Namespace containing all classes that make up the properties interface for the ButtonBase class
CEGUI::CheckboxProperties | Namespace containing all classes that make up the properties interface for the Checkbox class
CEGUI::ComboboxProperties | Namespace containing all classes that make up the properties interface for the Combobox class
CEGUI::EditboxProperties | Namespace containing all classes that make up the properties interface for the Editbox class
CEGUI::FrameWindowProperties | Namespace containing all classes that make up the properties interface for the FrameWindow class
CEGUI::ListboxProperties | Namespace containing all classes that make up the properties interface for the Listbox class
CEGUI::ListHeaderProperties | Namespace containing all classes that make up the properties interface for the ListHeader class
CEGUI::ListHeaderSegmentProperties | Namespace containing all classes that make up the properties interface for the ListHeaderSegment class
CEGUI::MultiColumnListProperties | Namespace containing all classes that make up the properties interface for the MultiColumnList class
CEGUI::MultiLineEditboxProperties | Namespace containing all classes that make up the properties interface for the MultiLineEditbox class
CEGUI::ProgressBarProperties | Namespace containing all classes that make up the properties interface for the ProgressBar class
CEGUI::PushButtonProperties | Namespace containing all classes that make up the properties interface for the PushButton class
CEGUI::RadioButtonProperties | Namespace containing all classes that make up the properties interface for the RadioButton class
CEGUI::ScrollablePaneProperties | Namespace containing all classes that make up the properties interface for the ScrollablePane class
CEGUI::ScrollbarProperties | Namespace containing all classes that make up the properties interface for the Scrollbar class
CEGUI::ScrolledContainerProperties | Namespace containing all classes that make up the properties interface for the ScrolledContainer class
CEGUI::SliderProperties | Namespace containing all classes that make up the properties interface for the Slider class
CEGUI::StaticImageProperties | Namespace containing all classes that make up the properties interface for the StaticImage class
CEGUI::StaticProperties | Namespace containing all classes that make up the properties interface for the Static (base) class
CEGUI::StaticTextProperties | Namespace containing all classes that make up the properties interface for the StaticText class
CEGUI::TabControlProperties | Namespace containing all classes that make up the properties interface for the Listbox class
CEGUI::ThumbProperties | Namespace containing all classes that make up the properties interface for the Thumb class
CEGUI::TitlebarProperties | Namespace containing all classes that make up the properties interface for the Titlebar class
CEGUI::TooltipProperties | Namespace containing all classes that make up the properties interface for the Tooltip class
CEGUI::WindowProperties | Namespace containing all classes that make up the properties interface for the Window base class
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI Namespace Reference

  • Namespace List
  • Namespace Members

CEGUI Namespace Reference

Main namespace for Crazy Eddie's GUI Library. More...

Classes

class | colour
Class representing colour values within the system. More...
class | ColourRect
Class that holds details of colours for the four corners of a rectangle. More...
class | Config_xmlHandler
Handler class used to parse the Configuration XML file. More...
class | DataContainer
class | RawDataContainer
class | DefaultResourceProvider
class | SubscriberInterface
The base class for the various binders. This provides a consistent interface for firing functions bound to an event. More...
class | _freeBinder
This class binds a free function. More...
class | _functorBinder
This class binds a copy of a functor. More...
class | _memberBinder
This class binds a member function along with a target object. More...
class | SubscriberTemplate
This template describes the Subscriber class. It is a wrapper for a pointer to a SubscriberInterface with various constructors that will by implicit conversion construct the various binders. More...
class | _refBinder
This class binds a const reference to a generalized functor. Sometimes it may not be appropriate for the functor to be cloned. In which case, use SubscriberRef() (which uses this). More...
class | Event
Defines an 'event' which can be subscribed to by interested parties. More...
class | EventArgs
Base class used as the argument to all subscribers Event object. More...
class | EventSet
Class that collects together a set of Event objects. More...
class | Exception
Root exception class used within the GUI system. More...
class | GenericException
Exception class used when none of the other classes are applicable. More...
class | UnknownObjectException
Exception class used when a request was made using a name of an unknown object. More...
class | InvalidRequestException
Exception class used when some impossible request was made for the current system state. More...
class | FileIOException
Exception class used when a file handling problem occurs. More...
class | RendererException
Exception class used when an problem is detected within the Renderer or related objects. More...
class | AlreadyExistsException
Exception class used when an attempt is made to use an object name that is already in use within the system. More...
class | MemoryException
Exception class used when a memory handling error is detected. More...
class | NullObjectException
Exception class used when some required object or parameter is null. More...
class | ObjectInUseException
Exception class used when some attempt to delete, remove, or otherwise invalidate some object that is still in use occurs. More...
class | FactoryModule
Class that encapsulates access to a dynamic loadable module containing implementations of Windows, Widgets, and their factories. More...
class | Font
Class that encapsulates text rendering functionality for a typeface. More...
class | Font_xmlHandler
Handler class used to parse the Font XML files using SAX2. More...
class | FontManager
Class providing a shared library of Font objects to the system. More...
class | GlobalEventSet
The GlobalEventSet singleton allows you to subscribe to an event for all instances of a class. The GlobalEventSet effectively supports "late binding" to events; which means you can subscribe to some event that does not actually exist (yet). More...
class | GUILayout_xmlHandler
Handler class used to parse the GUILayout XML files using SAX2. More...
class | Image
Class that represents a single Image of an Imageset. More...
class | Imageset
Offers functions to define, access, and draw, a set of image components on a single graphical surface or Texture. More...
class | Imageset_xmlHandler
Handler class used to parse the Imageset XML files using SAX2. More...
class | ImagesetManager
Class providing a shared library of Imageset objects to the system. More...
struct | Key
struct to give scope to scan code enumeration. More...
class | WindowEventArgs
EventArgs based class that is used for objects passed to handlers triggered for events concerning some Window object. More...
class | MouseEventArgs
EventArgs based class that is used for objects passed to input event handlers concerning mouse input. More...
class | MouseCursorEventArgs
EventArgs based class that is used for objects passed to input event handlers concerning mouse cursor events. More...
class | KeyEventArgs
EventArgs based class that is used for objects passed to input event handlers concerning keyboard input. More...
class | ActivationEventArgs
EventArgs based class that is used for Activated and Deactivated window events. More...
class | DragDropEventArgs
EventArgs based class used for certain drag/drop notifications. More...
class | ConstBaseIterator
Base class constant iterator used to offer iteration over various collections within the system. More...
class | Logger
Class that implements logging for the GUI system. More...
class | MouseCursor
Class that allows access to the GUI system mouse cursor. More...
class | PropertyReceiver
Dummy base class to ensure correct casting of receivers. More...
class | Property
An abstract class that defines the interface to access object properties by name. More...
class | PropertyHelper
Helper class used to convert various data types to and from the format expected in Propery strings. More...
class | PropertySet
Class that contains a collection of Property objects. More...
class | Rect
Class encapsulating operations on a Rectangle. More...
class | Referenced
class | RefPtr
class | RenderableElement
class | RenderableFrame
A higher order GUI entity that represents a renderable frame. More...
class | RenderableImage
A higher order GUI entity that represents a renderable image with formatting options. More...
class | RenderCache
Class that acts as a cache for images that need to be rendered. More...
class | Renderer
Abstract class defining the interface for Renderer objects. More...
class | ResourceProvider
Abstract class that defines the required interface for all resource provider sub-classes. More...
class | Scheme
A class that groups a set of GUI elements and initialises the system to access those elements. More...
class | Scheme_xmlHandler
Handler class used to parse the Scheme XML files using SAX2. More...
class | SchemeManager
A class that manages the creation of, access to, and destruction of GUI Scheme objects. More...
class | ScriptModule
Abstract interface required for all scripting support modules to be used with the CEGUI system. More...
class | ScriptFunctor
Functor class used for binding named script functions to events. More...
class | Singleton
class | Size
Class that holds the size (width & height) of something. More...
class | String
String class used within the GUI system. More...
class | System
The System class is the CEGUI class that provides access to all other elements in this system. More...
class | Texture
Abstract base class specifying the required interface for Texture objects. More...
class | TextUtils
Text utility support class. This class is all static members. You do not create instances of this class. More...
class | TinyXMLParser
Implementation of XMLParser using TinyXML. More...
class | UDim
Class representing a unified dimension; that is a dimension that has both a relative 'scale' portion and and absolute 'offset' portion. More...
class | UVector2
Two dimensional vector class built using unified dimensions (UDims). The UVector2 class is used for representing both positions and sizes. More...
class | URect
Area rectangle class built using unified dimensions (UDims). More...
class | Vector2
Class used as a two dimensional vector (aka a Point). More...
class | Vector3
Class used as a three dimensional vector. More...
class | Window
An abstract base class providing common functionality and specifying the required interface for derived classes. More...
class | WindowFactory
Abstract class that defines the required interface for all WindowFactory objects. More...
class | WindowFactoryManager
Class that manages WindowFactory objects. More...
class | WindowManager
The WindowManager class describes an object that manages creation and lifetime of Window objects. More...
class | XercesHandler
class | XercesParser
Implementation of XMLParser using Xerces-C++. More...
class | XMLAttributes
Class representing a block of attributes associated with an XML element. More...
class | XMLHandler
class | XMLParser
This is an abstract class that is used by CEGUI to interface with XML parser libraries. More...
class | ButtonBase
Base class for all the 'button' type widgets (push button, radio button, check-box, etc). More...
class | Checkbox
Base class providing logic for Check-box widgets. More...
class | Combobox
Base class for the Combobox widget. More...
class | ComboDropList
Base class for the combo box drop down list. This is a specialisation of the Listbox class. More...
class | DragContainer
Generic drag & drop enabled window class. More...
class | DragContainerFactory
Factory class for producing DragContainer windows. More...
class | Editbox
Base class for an Editbox widget. More...
class | FrameWindow
Abstract base class for a movable, sizable, window with a title-bar and a frame. More...
class | GUISheet
Window class intended to be used as a simple, generic Window. More...
class | GUISheetFactory
Factory class for producing default windows. More...
class | ItemEntry
Base class for item type widgets. More...
class | ItemListBase
Base class for item list widgets. More...
class | Listbox
Base class for standard Listbox widget. More...
class | ListboxItem
Base class for list box items. More...
class | ListboxTextItem
Class used for textual items in a list box. More...
class | HeaderSequenceEventArgs
EventArgs class used for segment move (sequence changed) events. More...
class | ListHeader
Base class for the multi column list header widget. More...
class | ListHeaderSegment
Base class for list header segment window. More...
class | Menubar
Base class for menu bars. More...
class | MenuBase
Abstract base class for menus. More...
class | MenuItem
Base class for menu items. More...
struct | MCLGridRef
Simple grid index structure. More...
class | MultiColumnList
Base class for the multi column list widget. More...
class | MultiLineEditbox
Base class for the multi-line edit box widget. More...
class | PopupMenu
Base class for popup menus. More...
class | ProgressBar
Base class for progress bars. More...
class | PushButton
Base class to provide logic for push button type widgets. More...
class | RadioButton
Base class to provide the logic for Radio Button widgets. More...
class | ScrollablePane
Base class for the ScrollablePane widget. More...
class | Scrollbar
Base scroll bar class. More...
class | ScrolledContainer
Helper container window class which is used in the implementation of the ScrollablePane widget class. More...
class | ScrolledContainerFactory
Factory class for producing ScrolledContainer windows. More...
class | Slider
Base class for Slider widgets. More...
class | Spinner
Base class for the Spinner widget. More...
class | Static
Base class for static widgets. More...
class | StaticImage
Static image widget class. More...
class | StaticText
Base class for a static text widget. More...
class | TabButton
Base class for TabButtons. A TabButton based class is used internally as the button that appears at the top of a TabControl widget to select the active tab pane. More...
class | TabControl
Base class for standard Tab Control widget. More...
class | TabPane
Base class for a tab pane. More...
class | TextItem
Base class for all the TextItem widgets. More...
class | Thumb
Base class for Thumb widget. More...
class | Titlebar
Class representing the title bar for Frame Windows. More...
class | Tooltip
Base class for Tooltip widgets. More...
class | Falagard_xmlHandler
Handler class used to parse look & feel XML files used by the Falagard system. More...
class | FalagardComponentBase
Common base class used for renderable components within an ImagerySection. More...
class | BaseDim
Abstract interface for a generic 'dimension' class. More...
class | AbsoluteDim
Dimension type that represents an absolute pixel value. Implements BaseDim interface. More...
class | ImageDim
Dimension type that represents some dimension of a named Image. Implements BaseDim interface. More...
class | WidgetDim
Dimension type that represents some dimension of a Window/widget. Implements BaseDim interface. More...
class | UnifiedDim
Dimension type that represents an Unified dimension. Implements BaseDim interface. More...
class | FontDim
Dimension type that represents some metric of a Font. Implements BaseDim interface. More...
class | PropertyDim
Dimension type that represents the value of a Window property. Implements BaseDim interface. More...
class | Dimension
Class representing some kind of dimension. More...
class | ComponentArea
Class that represents a target area for a widget or imagery component. More...
class | FrameComponent
Class that encapsulates information for a frame with background (9 images in total). More...
class | ImageryComponent
Class that encapsulates information for a single image component. More...
class | ImagerySection
Class that encapsulates a re-usable collection of imagery specifications. More...
class | LayerSpecification
Class that encapsulates a single layer of imagery. More...
class | NamedArea
NamedArea defines an area for a component which may later be obtained and referenced by a name unique to the WidgetLook holding the NamedArea. More...
class | PropertyDefinition
class representing a new property to be available on all widgets that use the WidgetLook that this PropertyDefinition is defiend for. More...
class | PropertyInitialiser
Class that holds information about a property and it's required initial value. More...
class | SectionSpecification
Class that represents a simple 'link' to an ImagerySection. More...
class | StateImagery
Class the encapsulates imagery for a given widget state. More...
class | TextComponent
Class that encapsulates information for a text component. More...
class | WidgetComponent
Class that encapsulates information regarding a sub-widget required for a widget. More...
class | WidgetLookFeel
Class that encapsulates look & feel information for a particular widget type. More...
class | WidgetLookManager
Manager class that gives top-level access to widget data based "look and feel" specifications loaded into the system. More...
class | FalagardXMLHelper
Utility helper class primarily intended for use by the falagard xml parser. More...
class | DirectX81Renderer
Renderer class to interface with Microsoft DirectX 8.1. More...
class | DirectX81Texture
Texture class that is created by DirectX81Renderer objects. More...
class | DirectX9Renderer
Renderer class to interface with Microsoft DirectX 9.0. More...
class | DirectX9Texture
Texture class that is created by DirectX9Renderer objects. More...
class | IrrlichtRenderer
class implementing the interface for Renderer objects with the irrlicht graphics engine. More...
class | IrrlichtResourceProvider
class | IrrlichtTexture
class | OpenGLRenderer
Renderer class to interface with OpenGL. More...
class | OpenGLTexture
Texture class that is created by OpenGLRenderer objects. More...
class | ConnectionImpl
class | SimpleTimer
Simple timer class. More...
struct | MouseClickTracker
Implementation structure used in tracking up & down mouse button inputs in order to generate click, double-click, and triple-click events. More...
struct | MouseClickTrackerImpl
class | TinyXMLDocument
struct | RegexValidator
Internal struct to contain compiled regex string. More...
class | EventPusher

Namespaces

namespace | ButtonBaseProperties
Namespace containing all classes that make up the properties interface for the ButtonBase class.
namespace | CheckboxProperties
Namespace containing all classes that make up the properties interface for the Checkbox class.
namespace | ComboboxProperties
Namespace containing all classes that make up the properties interface for the Combobox class.
namespace | EditboxProperties
Namespace containing all classes that make up the properties interface for the Editbox class.
namespace | FrameWindowProperties
Namespace containing all classes that make up the properties interface for the FrameWindow class.
namespace | ListboxProperties
Namespace containing all classes that make up the properties interface for the Listbox class.
namespace | ListHeaderProperties
Namespace containing all classes that make up the properties interface for the ListHeader class.
namespace | ListHeaderSegmentProperties
Namespace containing all classes that make up the properties interface for the ListHeaderSegment class.
namespace | MultiColumnListProperties
Namespace containing all classes that make up the properties interface for the MultiColumnList class.
namespace | MultiLineEditboxProperties
Namespace containing all classes that make up the properties interface for the MultiLineEditbox class.
namespace | ProgressBarProperties
Namespace containing all classes that make up the properties interface for the ProgressBar class.
namespace | PushButtonProperties
Namespace containing all classes that make up the properties interface for the PushButton class.
namespace | RadioButtonProperties
Namespace containing all classes that make up the properties interface for the RadioButton class.
namespace | ScrollablePaneProperties
Namespace containing all classes that make up the properties interface for the ScrollablePane class.
namespace | ScrollbarProperties
Namespace containing all classes that make up the properties interface for the Scrollbar class.
namespace | ScrolledContainerProperties
Namespace containing all classes that make up the properties interface for the ScrolledContainer class.
namespace | SliderProperties
Namespace containing all classes that make up the properties interface for the Slider class.
namespace | StaticImageProperties
Namespace containing all classes that make up the properties interface for the StaticImage class.
namespace | StaticProperties
Namespace containing all classes that make up the properties interface for the Static (base) class.
namespace | StaticTextProperties
Namespace containing all classes that make up the properties interface for the StaticText class.
namespace | TabControlProperties
Namespace containing all classes that make up the properties interface for the Listbox class.
namespace | ThumbProperties
Namespace containing all classes that make up the properties interface for the Thumb class.
namespace | TitlebarProperties
Namespace containing all classes that make up the properties interface for the Titlebar class.
namespace | TooltipProperties
Namespace containing all classes that make up the properties interface for the Tooltip class.
namespace | WindowProperties
Namespace containing all classes that make up the properties interface for the Window base class.

Typedefs

typedef unsigned long | ulong
typedef unsigned short | ushort
typedef unsigned int | uint
typedef unsigned char | uchar
typedef unsigned int | uint32
typedef unsigned short | uint16
typedef unsigned char | uint8
typedef std::ostream | OutStream
Output stream class.
typedef uint32 | argb_t
32 bit ARGB representation of a colour.
typedef uint8 | utf8
typedef uint32 | utf32
typedef Vector2 | Point
Point class.
typedef GUISheet | DefaultWindow
typedef for DefaultWindow, which is the new name for GUISheet.

Enumerations

enum | FontFlag { Default, NoAntiAlias }
Enumerated type that contains the valid flags that can be passed to createFont when creating a new font. More...
enum TextFormatting {
LeftAligned, RightAligned, Centred, Justified,
WordWrapLeftAligned, WordWrapRightAligned, WordWrapCentred, WordWrapJustified
}
Enumerated type that contains valid formatting types that can be specified when rendering text into a Rect area (the formatting Rect). More...
enum MouseButton {
LeftButton, RightButton, MiddleButton, X1Button,
X2Button, MouseButtonCount, NoButton
}
enum SystemKey {
LeftMouse = 0x0001, RightMouse = 0x0002, Shift = 0x0004, Control = 0x0008,
MiddleMouse = 0x0010, X1Mouse = 0x0020, X2Mouse = 0x0040, Alt = 0x0080
}
System key flag values. More...
enum | LoggingLevel { Errors, Standard, Informative, Insane }
Enumeration of logging levels. More...
enum | MouseCursorImage { BlankMouseCursor = 0, DefaultMouseCursor = -1 }
Enumeration of special values used for mouse cursor settings in Window objects. More...
enum FrameLocation {
Invalid, TopLeftCorner, TopRightCorner, BottomLeftCorner,
BottomRightCorner, LeftEdge, TopEdge, RightEdge,
BottomEdge
}
Enumeration of positions for a frame.
enum | OrientationFlags { FlipHorizontal = 1, FlipVertical = 2, RotateRightAngle = 4 }
Enumerated type that contains the valid flags that can be to use when rendering image. More...
enum | QuadSplitMode { TopLeftToBottomRight, BottomLeftToTopRight }
Enumerated type that contains the valid diagonal-mode that specify how a quad is split into triangles when rendered with fx. a 3D API. More...
enum | MetricsMode { Relative, Absolute, Inherited }
Mode used for Window size and position metrics. More...
enum | VerticalAlignment { VA_TOP, VA_CENTRE, VA_BOTTOM }
Enumerated type used when specifying vertical alignments. More...
enum | HorizontalAlignment { HA_LEFT, HA_CENTRE, HA_RIGHT }
Enumerated type used when specifying horizontal alignments. More...
enum DimensionType {
DT_LEFT_EDGE, DT_X_POSITION, DT_TOP_EDGE, DT_Y_POSITION,
DT_RIGHT_EDGE, DT_BOTTOM_EDGE, DT_WIDTH, DT_HEIGHT,
DT_X_OFFSET, DT_Y_OFFSET, DT_INVALID
}
Enumeration of possible values to indicate what a given dimension represents. More...
enum VerticalFormatting {
VF_TOP_ALIGNED, VF_CENTRE_ALIGNED, VF_BOTTOM_ALIGNED, VF_STRETCHED,
VF_TILED
}
Enumeration of possible values to indicate the vertical formatting to be used for an image component. More...
enum HorizontalFormatting {
HF_LEFT_ALIGNED, HF_CENTRE_ALIGNED, HF_RIGHT_ALIGNED, HF_STRETCHED,
HF_TILED
}
Enumeration of possible values to indicate the horizontal formatting to be used for an image component. More...
enum | VerticalTextFormatting { VTF_TOP_ALIGNED, VTF_CENTRE_ALIGNED, VTF_BOTTOM_ALIGNED }
Enumeration of possible values to indicate the vertical formatting to be used for a text component. More...
enum HorizontalTextFormatting {
HTF_LEFT_ALIGNED, HTF_RIGHT_ALIGNED, HTF_CENTRE_ALIGNED, HTF_JUSTIFIED,
HTF_WORDWRAP_LEFT_ALIGNED, HTF_WORDWRAP_RIGHT_ALIGNED, HTF_WORDWRAP_CENTRE_ALIGNED, HTF_WORDWRAP_JUSTIFIED
}
Enumeration of possible values to indicate the horizontal formatting to be used for a text component. More...
enum | FontMetricType { FMT_LINE_SPACING, FMT_BASELINE, FMT_HORZ_EXTENT }
Enumeration of possible values to indicate a particular font metric. More...
enum DimensionOperator {
DOP_NOOP, DOP_ADD, DOP_SUBTRACT, DOP_MULTIPLY,
DOP_DIVIDE
}
Enumeration of values representing mathematical operations on dimensions. More...
enum FrameImageComponent {
FIC_BACKGROUND, FIC_TOP_LEFT_CORNER, FIC_TOP_RIGHT_CORNER, FIC_BOTTOM_LEFT_CORNER,
FIC_BOTTOM_RIGHT_CORNER, FIC_LEFT_EDGE, FIC_RIGHT_EDGE, FIC_TOP_EDGE,
FIC_BOTTOM_EDGE, FIC_FRAME_IMAGE_COUNT
}
Enumeration of values referencing available images forming a frame component. More...

Functions

template<class Functor>
SubscriberInterface< bool,
const EventArgs & > * 		SubscriberRef (const Functor &f)
This helper function produces a const reference binding.
bool CEGUIEXPORT | operator== (const String &str1, const String &str2)
Return true if String str1 is equal to String str2.
bool CEGUIEXPORT | operator== (const String &str, const std::string &std_str)
Return true if String str is equal to std::string std_str.
bool CEGUIEXPORT | operator== (const std::string &std_str, const String &str)
Return true if String str is equal to std::string std_str.
bool CEGUIEXPORT | operator== (const String &str, const utf8 *utf8_str)
Return true if String str is equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator== (const utf8 *utf8_str, const String &str)
Return true if String str is equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator!= (const String &str1, const String &str2)
Return true if String str1 is not equal to String str2.
bool CEGUIEXPORT | operator!= (const String &str, const std::string &std_str)
Return true if String str is not equal to std::string std_str.
bool CEGUIEXPORT | operator!= (const std::string &std_str, const String &str)
Return true if String str is not equal to std::string std_str.
bool CEGUIEXPORT | operator!= (const String &str, const utf8 *utf8_str)
Return true if String str is not equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator!= (const utf8 *utf8_str, const String &str)
Return true if String str is not equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator< (const String &str1, const String &str2)
Return true if String str1 is lexicographically less than String str2.
bool CEGUIEXPORT | operator< (const String &str, const std::string &std_str)
Return true if String str is lexicographically less than std::string std_str.
bool CEGUIEXPORT | operator< (const std::string &std_str, const String &str)
Return true if String str is lexicographically less than std::string std_str.
bool CEGUIEXPORT | operator< (const String &str, const utf8 *utf8_str)
Return true if String str is lexicographically less than null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator< (const utf8 *utf8_str, const String &str)
Return true if String str is lexicographically less than null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator> (const String &str1, const String &str2)
Return true if String str1 is lexicographically greater than String str2.
bool CEGUIEXPORT | operator> (const String &str, const std::string &std_str)
Return true if String str is lexicographically greater than std::string std_str.
bool CEGUIEXPORT | operator> (const std::string &std_str, const String &str)
Return true if String str is lexicographically greater than std::string std_str.
bool CEGUIEXPORT | operator> (const String &str, const utf8 *utf8_str)
Return true if String str is lexicographically greater than null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator> (const utf8 *utf8_str, const String &str)
Return true if String str is lexicographically greater than null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator<= (const String &str1, const String &str2)
Return true if String str1 is lexicographically less than or equal to String str2.
bool CEGUIEXPORT | operator<= (const String &str, const std::string &std_str)
Return true if String str is lexicographically less than or equal to std::string std_str.
bool CEGUIEXPORT | operator<= (const std::string &std_str, const String &str)
Return true if String str is lexicographically less than or equal to std::string std_str.
bool CEGUIEXPORT | operator<= (const String &str, const utf8 *utf8_str)
Return true if String str is lexicographically less than or equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator<= (const utf8 *utf8_str, const String &str)
Return true if String str is lexicographically less than or equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator>= (const String &str1, const String &str2)
Return true if String str1 is lexicographically greater than or equal to String str2.
bool CEGUIEXPORT | operator>= (const String &str, const std::string &std_str)
Return true if String str is lexicographically greater than or equal to std::string std_str.
bool CEGUIEXPORT | operator>= (const std::string &std_str, const String &str)
Return true if String str is lexicographically greater than or equal to std::string std_str.
bool CEGUIEXPORT | operator>= (const String &str, const utf8 *utf8_str)
Return true if String str is lexicographically greater than or equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator>= (const utf8 *utf8_str, const String &str)
Return true if String str is lexicographically greater than or equal to null-terminated utf8 data utf8_str.
bool CEGUIEXPORT | operator== (const String &str, const char *c_str)
Return true if String str is equal to c-string c_str.
bool CEGUIEXPORT | operator== (const char *c_str, const String &str)
Return true if c-string c_str is equal to String str.
bool CEGUIEXPORT | operator!= (const String &str, const char *c_str)
Return true if String str is not equal to c-string c_str.
bool CEGUIEXPORT | operator!= (const char *c_str, const String &str)
Return true if c-string c_str is not equal to String str.
bool CEGUIEXPORT | operator< (const String &str, const char *c_str)
Return true if String str is lexicographically less than c-string c_str.
bool CEGUIEXPORT | operator< (const char *c_str, const String &str)
Return true if c-string c_str is lexicographically less than String str.
bool CEGUIEXPORT | operator> (const String &str, const char *c_str)
Return true if String str is lexicographically greater than c-string c_str.
bool CEGUIEXPORT | operator> (const char *c_str, const String &str)
Return true if c-string c_str is lexicographically greater than String str.
bool CEGUIEXPORT | operator<= (const String &str, const char *c_str)
Return true if String str is lexicographically less than or equal to c-string c_str.
bool CEGUIEXPORT | operator<= (const char *c_str, const String &str)
Return true if c-string c_str is lexicographically less than or equal to String str.
bool CEGUIEXPORT | operator>= (const String &str, const char *c_str)
Return true if String str is lexicographically greater than or equal to c-string c_str.
bool CEGUIEXPORT | operator>= (const char *c_str, const String &str)
Return true if c-string c_str is lexicographically greater than or equal to String str.
String CEGUIEXPORT | operator+ (const String &str1, const String &str2)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const String &str, const std::string &std_str)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const std::string &std_str, const String &str)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const String &str, const utf8 *utf8_str)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const utf8 *utf8_str, const String &str)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const String &str, utf32 code_point)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (utf32 code_point, const String &str)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const String &str, const char *c_str)
Return String object that is the concatenation of the given inputs.
String CEGUIEXPORT | operator+ (const char *c_str, const String &str)
Return String object that is the concatenation of the given inputs.
CEGUIEXPORT std::ostream & | operator<< (std::ostream &s, const String &str)
void CEGUIEXPORT | swap (String &str1, String &str2)
Swap the contents for two String objects.
bool | lbi_less (const ListboxItem *a, const ListboxItem *b)
Helper function used in sorting to compare two list box item text strings via the ListboxItem pointers and return if a is less than b.
bool | lbi_greater (const ListboxItem *a, const ListboxItem *b)
Helper function used in sorting to compare two list box item text strings via the ListboxItem pointers and return if a is greater than b.
CFBundleRef | mac_loadExeBundle (const char *name)
void * | mac_getBundleSym (CFBundleRef bundle, const char *name)
bool | mac_unloadExeBundle (CFBundleRef bundle)
const char * | mac_errorBundle ()

Variables

static const float | DefaultNativeHorzRes = 640.0f
Default native horizontal resolution (for fonts and imagesets).
static const float | DefaultNativeVertRes = 480.0f
Default native vertical resolution (for fonts and imagesets).

Detailed Description

Main namespace for Crazy Eddie's GUI Library.

The CEGUI namespace contains all the classes and other items that comprise the core of Crazy Eddie's GUI system.

Enumeration Type Documentation

enum CEGUI::DimensionOperator

Enumeration of values representing mathematical operations on dimensions.

Enumerator:
DOP_NOOP | Do nothing operator.
DOP_ADD | Dims should be added.
DOP_SUBTRACT | Dims should be subtracted.
DOP_MULTIPLY | Dims should be multiplied.
DOP_DIVIDE | Dims should be divided.

enum CEGUI::DimensionType

Enumeration of possible values to indicate what a given dimension represents.

Enumerator:
DT_LEFT_EDGE | Dimension represents the left edge of some entity (same as DT_X_POSITION).
DT_X_POSITION | Dimension represents the x position of some entity (same as DT_LEFT_EDGE).
DT_TOP_EDGE | Dimension represents the top edge of some entity (same as DT_Y_POSITION).
DT_Y_POSITION | Dimension represents the y position of some entity (same as DT_TOP_EDGE).
DT_RIGHT_EDGE | Dimension represents the right edge of some entity.
DT_BOTTOM_EDGE | Dimension represents the bottom edge of some entity.
DT_WIDTH | Dimension represents the width of some entity.
DT_HEIGHT | Dimension represents the height of some entity.
DT_X_OFFSET | Dimension represents the x offset of some entity (usually only applies to an Image entity).
DT_Y_OFFSET | Dimension represents the y offset of some entity (usually only applies to an Image entity).
DT_INVALID | Invalid / uninitialised DimensionType.

enum CEGUI::FontFlag

Enumerated type that contains the valid flags that can be passed to createFont when creating a new font.

Enumerator:
Default | Default / None.
NoAntiAlias | Fonts generated from TrueType files should not be anti-aliased.

enum CEGUI::FontMetricType

Enumeration of possible values to indicate a particular font metric.

Enumerator:
FMT_LINE_SPACING | Vertical line spacing value for font.
FMT_BASELINE | Vertical baseline value for font.
FMT_HORZ_EXTENT | Horizontal extent of a string.

enum CEGUI::FrameImageComponent

Enumeration of values referencing available images forming a frame component.

Enumerator:
FIC_BACKGROUND | References image used for the background.
FIC_TOP_LEFT_CORNER | References image used for the top-left corner.
FIC_TOP_RIGHT_CORNER | References image used for the top-right corner.
FIC_BOTTOM_LEFT_CORNER | References image used for the bottom-left corner.
FIC_BOTTOM_RIGHT_CORNER | References image used for the bottom-right corner.
FIC_LEFT_EDGE | References image used for the left edge.
FIC_RIGHT_EDGE | References image used for the right edge.
FIC_TOP_EDGE | References image used for the top edge.
FIC_BOTTOM_EDGE | References image used for the bottom edge.
FIC_FRAME_IMAGE_COUNT | Max number of images for a frame.

enum CEGUI::HorizontalAlignment

Enumerated type used when specifying horizontal alignments.

Enumerator:
HA_LEFT | Elements position specifies an offset of it's left edge from the left edge of it's parent.
HA_CENTRE | Elements position specifies an offset of it's horizontal centre from the horizontal centre of it's parent.
HA_RIGHT | Elements position specifies an offset of it's right edge from the right edge of it's parent.

enum CEGUI::HorizontalFormatting

Enumeration of possible values to indicate the horizontal formatting to be used for an image component.

Enumerator:
HF_LEFT_ALIGNED | Left of Image should be aligned with the left of the destination area.
HF_CENTRE_ALIGNED | Image should be horizontally centred within the destination area.
HF_RIGHT_ALIGNED | Right of Image should be aligned with the right of the destination area.
HF_STRETCHED | Image should be stretched horizontally to fill the destination area.
HF_TILED | Image should be tiled horizontally to fill the destination area (right-most tile may be clipped).

enum CEGUI::HorizontalTextFormatting

Enumeration of possible values to indicate the horizontal formatting to be used for a text component.

Enumerator:
HTF_LEFT_ALIGNED | Left of text should be aligned with the left of the destination area (single line of text only).
HTF_RIGHT_ALIGNED | Right of text should be aligned with the right of the destination area (single line of text only).
HTF_CENTRE_ALIGNED | text should be horizontally centred within the destination area (single line of text only).
HTF_JUSTIFIED | text should be spaced so that it takes the full width of the destination area (single line of text only).
HTF_WORDWRAP_LEFT_ALIGNED | Left of text should be aligned with the left of the destination area (word wrapped to multiple lines as needed).
HTF_WORDWRAP_RIGHT_ALIGNED | Right of text should be aligned with the right of the destination area (word wrapped to multiple lines as needed).
HTF_WORDWRAP_CENTRE_ALIGNED | text should be horizontally centred within the destination area (word wrapped to multiple lines as needed).
HTF_WORDWRAP_JUSTIFIED | text should be spaced so that it takes the full width of the destination area (word wrapped to multiple lines as needed).

enum CEGUI::LoggingLevel

Enumeration of logging levels.

Enumerator:
Errors | Only actual error conditions will be logged.
Standard | Basic events will be logged (default level).
Informative | Useful tracing (object creations etc) information will be logged.
Insane | Mostly everything gets logged (use for heavy tracing only, log WILL be big).

enum CEGUI::MetricsMode

Mode used for Window size and position metrics.

Position information for a Window is always 'relative' to it's parent even in Absolute mode. In Relative mode, layout is maintained for different screen resolutions, and also offers the ability for child windows to properly adjust their layout as their parent is sized.

Enumerator:
Relative | Metrics are specified as a decimal fraction of parent Window size.
Absolute | Metrics are specified as whole pixels.
Inherited | Metrics are inherited from parent.

enum CEGUI::MouseButton

/brief Enumeration of mouse buttons

Enumerator:
NoButton Value set for no mouse button. NB: This is not 0, do not assume!

enum CEGUI::MouseCursorImage

Enumeration of special values used for mouse cursor settings in Window objects.

Enumerator:
BlankMouseCursor | No image should be displayed for the mouse cursor.
DefaultMouseCursor | The default mouse cursor image should be displayed.

enum CEGUI::OrientationFlags

Enumerated type that contains the valid flags that can be to use when rendering image.

Enumerator:
FlipHorizontal | Horizontal flip the image.
FlipVertical | Vertical flip the image.
RotateRightAngle | Rotate the image anticlockwise 90 degree.

enum CEGUI::QuadSplitMode

Enumerated type that contains the valid diagonal-mode that specify how a quad is split into triangles when rendered with fx. a 3D API.

Enumerator:
TopLeftToBottomRight | Diagonal goes from top-left to bottom-right.
BottomLeftToTopRight | Diagonal goes from bottom-left to top-right.

enum CEGUI::SystemKey

System key flag values.

Enumerator:
LeftMouse | The left mouse button.
RightMouse | The right mouse button.
Shift | Either shift key.
Control | Either control key.
MiddleMouse | The middle mouse button.
X1Mouse | The first 'extra' mouse button.
X2Mouse | The second 'extra' mouse button.
Alt | Either alt key.

enum CEGUI::TextFormatting

Enumerated type that contains valid formatting types that can be specified when rendering text into a Rect area (the formatting Rect).

Enumerator:
LeftAligned | All text is printed on a single line. The left-most character is aligned with the left edge of the formatting Rect.
RightAligned | All text is printed on a single line. The right-most character is aligned with the right edge of the formatting Rect.
Centred | All text is printed on a single line. The text is centred horizontally in the formatting Rect.
Justified | All text is printed on a single line. The left-most and right-most characters are aligned with the edges of the formatting Rect.
WordWrapLeftAligned | Text is broken into multiple lines no wider than the formatting Rect. The left-most character of each line is aligned with the left edge of the formatting Rect.
WordWrapRightAligned | Text is broken into multiple lines no wider than the formatting Rect. The right-most character of each line is aligned with the right edge of the formatting Rect.
WordWrapCentred | Text is broken into multiple lines no wider than the formatting Rect. Each line is centred horizontally in the formatting Rect.
WordWrapJustified | Text is broken into multiple lines no wider than the formatting Rect. The left-most and right-most characters of each line are aligned with the edges of the formatting Rect.

enum CEGUI::VerticalAlignment

Enumerated type used when specifying vertical alignments.

Enumerator:
VA_TOP | Elements position specifies an offset of it's top edge from the top edge of it's parent.
VA_CENTRE | Elements position specifies an offset of it's vertical centre from the vertical centre of it's parent.
VA_BOTTOM | Elements position specifies an offset of it's bottom edge from the bottom edge of it's parent.

enum CEGUI::VerticalFormatting

Enumeration of possible values to indicate the vertical formatting to be used for an image component.

Enumerator:
VF_TOP_ALIGNED | Top of Image should be aligned with the top of the destination area.
VF_CENTRE_ALIGNED | Image should be vertically centred within the destination area.
VF_BOTTOM_ALIGNED | Bottom of Image should be aligned with the bottom of the destination area.
VF_STRETCHED | Image should be stretched vertically to fill the destination area.
VF_TILED | Image should be tiled vertically to fill the destination area (bottom-most tile may be clipped).

enum CEGUI::VerticalTextFormatting

Enumeration of possible values to indicate the vertical formatting to be used for a text component.

Enumerator:
VTF_TOP_ALIGNED | Top of text should be aligned with the top of the destination area.
VTF_CENTRE_ALIGNED | text should be vertically centred within the destination area.
VTF_BOTTOM_ALIGNED | Bottom of text should be aligned with the bottom of the destination area.

Function Documentation

String CEGUI::operator+ | ( | const char * | c_str,
 |  | const String & | str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
c_str | c-string describing the first part of the new string
str | String object describing the second part of the new string
Returns:
A String object that is the concatenation of c_str and str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const String & | str,
 |  | const char * | c_str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
str | String object describing first part of the new string
c_str | c-string describing the second part of the new string
Returns:
A String object that is the concatenation of str and c_str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | utf32 | code_point,
 |  | const String & | str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
code_point | utf32 code point describing the first part of the new string
str | String object describing the second part of the new string
Returns:
A String object that is the concatenation of code_point and str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const String & | str,
 |  | utf32 | code_point
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
str | String object describing the first part of the new string
code_point | utf32 code point describing the second part of the new string
Returns:
A String object that is the concatenation of str and code_point
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const utf8 * | utf8_str,
 |  | const String & | str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
utf8_str | Buffer containing null-terminated utf8 encoded data describing the first part of the new string
str | String object describing the second part of the new string
Returns:
A String object that is the concatenation of str and utf8_str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const String & | str,
 |  | const utf8 * | utf8_str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
str | String object describing first part of the new string
utf8_str | Buffer containing null-terminated utf8 encoded data describing the second part of the new string
Returns:
A String object that is the concatenation of str and utf8_str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const std::string & | std_str,
 |  | const String & | str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
std_str | std::string object describing the first part of the new string
str | String object describing the second part of the new string
Returns:
A String object that is the concatenation of std_str and str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const String & | str,
 |  | const std::string & | std_str
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
str | String object describing first part of the new string
std_str | std::string object describing the second part of the new string
Returns:
A String object that is the concatenation of str and std_str
Exceptions:
std::length_error Thrown if the resulting String would be too large.

String CEGUI::operator+ | ( | const String & | str1,
 |  | const String & | str2
 | ) |

Return String object that is the concatenation of the given inputs.

Parameters:
str1 | String object describing first part of the new string
str2 | String object describing the second part of the new string
Returns:
A String object that is the concatenation of str1 and str2
Exceptions:
std::length_error Thrown if the resulting String would be too large.

void CEGUI::swap | ( | String & | str1,
 |  | String & | str2
 | ) |

Swap the contents for two String objects.

Parameters:
str1 | String object who's contents are to be swapped with str2
str2 | String object who's contents are to be swapped with str1
Returns:
Nothing

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ButtonBaseProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ButtonBaseProperties

CEGUI::ButtonBaseProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the ButtonBase class. More...

Classes

class | NormalTextColour
Property to access the normal text colour. More...
class | HoverTextColour
Property to access the hover / highlight text colour. More...
class | PushedTextColour
Property to access the pushed text colour. More...
class | DisabledTextColour
Property to access the disabled text colour. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the ButtonBase class.
Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::CheckboxProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::CheckboxProperties

CEGUI::CheckboxProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Checkbox class. More...

Classes

class Selected
Property to access the selected state of the check box. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Checkbox class.
Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ComboboxProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ComboboxProperties

CEGUI::ComboboxProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Combobox class. More...

Classes

class | ReadOnly
Property to access the read-only setting of the edit box. More...
class | ValidationString
Property to access the string used for regular expression validation of the edit box text. More...
class | CaratIndex
Property to access the current carat index. More...
class | EditSelectionStart
Property to access the current selection start index. More...
class | EditSelectionLength
Property to access the current selection length. More...
class | MaxEditTextLength
Property to access the maximum text length for the edit box. More...
class | NormalEditTextColour
Property to access the normal, unselected, text colour used for rendering text. More...
class | SelectedEditTextColour
Property to access the colour used for rendering text within the selection area. More...
class | ActiveEditSelectionColour
Property to access the colour used for rendering the selection highlight when the edit box is active. More...
class | InactiveEditSelectionColour
Property to access the colour used for rendering the selection highlight when the edit box is inactive. More...
class | SortList
Property to access the sort setting of the list box. More...
class | ForceVertScrollbar
Property to access the 'always show' setting for the vertical scroll bar of the list box. More...
class | ForceHorzScrollbar
Property to access the 'always show' setting for the horizontal scroll bar of the list box. More...
class | SingleClickMode
Property to access the 'single click mode' setting for the combo box. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Combobox class.
Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::EditboxProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::EditboxProperties

CEGUI::EditboxProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Editbox class. More...

Classes

class | ReadOnly
Property to access the read-only setting of the edit box. More...
class | MaskText
Property to access the mask text setting of the edit box. More...
class | MaskCodepoint
Property to access the mask text setting of the edit box. More...
class | ValidationString
Property to access the string used for regular expression validation of the edit box text. More...
class | CaratIndex
Property to access the current carat index. More...
class | SelectionStart
Property to access the current selection start index. More...
class | SelectionLength
Property to access the current selection length. More...
class | MaxTextLength
Property to access the maximum text length for the edit box. More...
class | NormalTextColour
Property to access the normal, unselected, text colour used for rendering text. More...
class | SelectedTextColour
Property to access the colour used for rendering text within the selection area. More...
class | ActiveSelectionColour
Property to access the colour used for rendering the selection highlight when the edit box is active. More...
class | InactiveSelectionColour
Property to access the colour used for rendering the selection highlight when the edit box is inactive. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Editbox class.
Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::FrameWindowProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::FrameWindowProperties

CEGUI::FrameWindowProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the FrameWindow class. More...

Classes

class | SizingEnabled
Property to access the state of the sizable setting for the FrameWindow. More...
class | FrameEnabled
Property to access the setting for whether the window frame will be displayed. More...
class | TitlebarEnabled
Property to access the setting for whether the window title-bar will be enabled (or displayed depending upon choice of final widget type). More...
class | CloseButtonEnabled
Property to access the setting for whether the window close button will be enabled (or displayed depending upon choice of final widget type). More...
class | RollUpEnabled
Property to access the setting for whether the user is able to roll-up / shade the window. More...
class | RollUpState
Property to access the roll-up / shade state of the window. More...
class | DragMovingEnabled
Property to access the setting for whether the user may drag the window around by its title bar. More...
class | SizingBorderThickness
Property to access the setting for the sizing border thickness. More...
class | TitlebarFont
Property to access the Font set for the windows title bar. More...
class | CaptionColour
Property to colour used for rendering the caption text. More...
class | NSSizingCursorImage
Property to access the N-S (up-down) sizing cursor image. More...
class | EWSizingCursorImage
Property to access the E-W (left/right) sizing cursor image. More...
class | NWSESizingCursorImage
Property to access the NW-SE diagonal sizing cursor image. More...
class | NESWSizingCursorImage
Property to access the NE-SW diagonal sizing cursor image. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the FrameWindow class.
Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListboxProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ListboxProperties

CEGUI::ListboxProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Listbox class. More...

Classes

class | Sort
Property to access the sort setting of the list box. More...
class | MultiSelect
Property to access the multi-select setting of the list box. More...
class | ForceVertScrollbar
Property to access the 'always show' setting for the vertical scroll bar of the list box. More...
class | ForceHorzScrollbar
Property to access the 'always show' setting for the horizontal scroll bar of the list box. More...
class | ItemTooltips
Property to access the show item tooltips setting of the list box. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Listbox class.
Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ListHeaderProperties

CEGUI::ListHeaderProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the ListHeader class. More...

Classes

class | ColumnsSizable
Property to access the setting for user sizing of the column headers. More...
class | ColumnsMovable
Property to access the setting for user moving of the column headers. More...
class | SortSettingEnabled
Property to access the setting for user modification of the sort column & direction. More...
class | SortDirection
Property to access the sort direction setting of the list header. More...
class | SortColumnID
Property to access the current sort column (via ID code). More...

Detailed Description

Namespace containing all classes that make up the properties interface for the ListHeader class.
Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ListHeaderSegmentProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ListHeaderSegmentProperties

CEGUI::ListHeaderSegmentProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the ListHeaderSegment class. More...

Classes

class | Sizable
Property to access the sizable setting of the header segment. More...
class | Clickable
Property to access the click-able setting of the header segment. More...
class | Dragable
Property to access the drag-able setting of the header segment. More...
class | SortDirection
Property to access the sort direction setting of the header segment. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the ListHeaderSegment class.
Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiColumnListProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::MultiColumnListProperties

CEGUI::MultiColumnListProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the MultiColumnList class. More...

Classes

class | ColumnsSizable
Property to access the setting for user sizing of the column headers. More...
class | ColumnsMovable
Property to access the setting for user moving of the column headers. More...
class | SortSettingEnabled
Property to access the setting for user modification of the sort column & direction. More...
class | SortDirection
Property to access the sort direction setting of the list. More...
class | SortColumnID
Property to access the current sort column (via ID code). More...
class | NominatedSelectionColumnID
Property to access the nominated selection column (via ID). More...
class | NominatedSelectionRow
Property to access the nominated selection row. More...
class | ForceVertScrollbar
Property to access the 'always show' setting for the vertical scroll bar of the list box. More...
class | ForceHorzScrollbar
Property to access the 'always show' setting for the horizontal scroll bar of the list box. More...
class | SelectionMode
Property to access the selection mode setting of the list. More...
class | ColumnHeader
Property to access a column. More...
class | RowCount
Property to access the number of rows in the list (read-only). More...

Detailed Description

Namespace containing all classes that make up the properties interface for the MultiColumnList class.
Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::MultiLineEditboxProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::MultiLineEditboxProperties

CEGUI::MultiLineEditboxProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the MultiLineEditbox class. More...

Classes

class | ReadOnly
Property to access the read-only setting of the edit box. More...
class | WordWrap
Property to access the word-wrap setting of the edit box. More...
class | CaratIndex
Property to access the current carat index. More...
class | SelectionStart
Property to access the current selection start index. More...
class | SelectionLength
Property to access the current selection length. More...
class | MaxTextLength
Property to access the maximum text length for the edit box. More...
class | NormalTextColour
Property to access the normal, unselected, text colour used for rendering text. More...
class | SelectedTextColour
Property to access the colour used for rendering text within the selection area. More...
class | ActiveSelectionColour
Property to access the colour used for rendering the selection highlight when the edit box is active. More...
class | InactiveSelectionColour
Property to access the colour used for rendering the selection highlight when the edit box is inactive. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the MultiLineEditbox class.
Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ProgressBarProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ProgressBarProperties

CEGUI::ProgressBarProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the ProgressBar class. More...

Classes

class | CurrentProgress
Property to access the current progress of the progress bar. More...
class | StepSize
Property to access the step size setting for the progress bar. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the ProgressBar class.
Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::PushButtonProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::PushButtonProperties

CEGUI::PushButtonProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the PushButton class. More...

Classes

class | NormalImage
Property to access the normal image of the button. More...
class | PushedImage
Property to access the pushed image of the button. More...
class | HoverImage
Property to access the hover image of the button. More...
class | DisabledImage
Property to access the disabled image of the button. More...
class | UseStandardImagery
Property to access whether to use the standard images or the supplied custom ones. More...
class | TextXOffset
Property to access an offset that is used to shift the text in the x-direction. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the PushButton class.
Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::RadioButtonProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::RadioButtonProperties

CEGUI::RadioButtonProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the RadioButton class. More...

Classes

class | Selected
Property to access the selected state of the RadioButton. More...
class | GroupID
Property to access the radio button group ID. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the RadioButton class.
Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollablePaneProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ScrollablePaneProperties

CEGUI::ScrollablePaneProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the ScrollablePane class. More...

Classes

class | ContentPaneAutoSized
Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content. More...
class | ContentArea
Property to access the current content pane area rectangle (as window relative pixels). More...
class | ForceVertScrollbar
Property to access the setting which controls whether the vertical scroll bar will always be displayed, or only displayed when it is required. More...
class | ForceHorzScrollbar
Property to access the setting which controls whether the horizontal scroll bar will always be displayed, or only displayed when it is required. More...
class | HorzStepSize
Property to access the step size for the horizontal Scrollbar. More...
class | HorzOverlapSize
Property to access the overlap size for the horizontal Scrollbar. More...
class | HorzScrollPosition
Property to access the scroll position of the horizontal Scrollbar. More...
class | VertStepSize
Property to access the step size for the vertical Scrollbar. More...
class | VertOverlapSize
Property to access the overlap size for the vertical Scrollbar. More...
class | VertScrollPosition
Property to access the scroll position of the vertical Scrollbar. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the ScrollablePane class.
Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrollbarProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ScrollbarProperties

CEGUI::ScrollbarProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Scrollbar class. More...

Classes

class | DocumentSize
Property to access the document size for the Scrollbar. More...
class | PageSize
Property to access the page size for the Scrollbar. More...
class | StepSize
Property to access the step size for the Scrollbar. More...
class | OverlapSize
Property to access the overlap size for the Scrollbar. More...
class | ScrollPosition
Property to access the scroll position of the Scrollbar. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Scrollbar class.
Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ScrolledContainerProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ScrolledContainerProperties

CEGUI::ScrolledContainerProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the ScrolledContainer class. More...

Classes

class | ContentPaneAutoSized
Property to access the setting which controls whether the content pane is automatically resized according to the size and position of attached content. More...
class | ContentArea
Property to access the current content pane area rectangle (as window relative pixels). More...
class | ChildExtentsArea
Property offering read-only access to the current content extents rectangle (as window relative pixels). More...

Detailed Description

Namespace containing all classes that make up the properties interface for the ScrolledContainer class.
Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::SliderProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::SliderProperties

CEGUI::SliderProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Slider class. More...

Classes

class | CurrentValue
Property to access the current value of the slider. More...
class | MaximumValue
Property to access the maximum value of the slider. More...
class | ClickStepSize
Property to access the click-step size for the slider. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Slider class.
Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticImageProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::StaticImageProperties

CEGUI::StaticImageProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the StaticImage class. More...

Classes

class | Image
Property to access the image for the StaticImage widget. More...
class | ImageColours
Property to access the image colours for the StaticImage widget. More...
class | HorzFormatting
Property to access the horizontal formatting mode setting. More...
class | VertFormatting
Property to access the vertical formatting mode setting. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the StaticImage class.
Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::StaticProperties

CEGUI::StaticProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Static (base) class. More...

Classes

class | FrameEnabled
Property to access the state of the frame enabled setting for the Static widget. More...
class | BackgroundEnabled
Property to access the state of the frame background setting for the Static widget. More...
class | FrameColours
Property to access the frame colours for the Static widget. More...
class | BackgroundColours
Property to access the background colours for the Static widget. More...
class | BackgroundImage
Property to access the background image for the Static widget. More...
class | TopLeftFrameImage
Property to access the top-left image for the frame of the Static widget. More...
class | TopRightFrameImage
Property to access the top-right image for the frame of the Static widget. More...
class | BottomLeftFrameImage
Property to access the bottom-left image for the frame of the Static widget. More...
class | BottomRightFrameImage
Property to access the bottom-right image for the frame of the Static widget. More...
class | LeftFrameImage
Property to access the left edge image for the frame of the Static widget. More...
class | RightFrameImage
Property to access the right edge image for the frame of the Static widget. More...
class | TopFrameImage
Property to access the top edge image for the frame of the Static widget. More...
class | BottomFrameImage
Property to access the bottom edge image for the frame of the Static widget. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Static (base) class.
Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::StaticTextProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::StaticTextProperties

CEGUI::StaticTextProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the StaticText class. More...

Classes

class | TextColours
Property to access the text colours for the StaticText widget. More...
class | HorzFormatting
Property to access the horizontal formatting mode setting. More...
class | VertFormatting
Property to access the vertical formatting mode setting. More...
class | VertScrollbar
Property to access the setting for enabling the vertical scroll bar. More...
class | HorzScrollbar
Property to access the setting for enabling the horizontal scroll bar. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the StaticText class.
Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TabControlProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::TabControlProperties

CEGUI::TabControlProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Listbox class. More...

Classes

class | TabHeight
Property to access the tab height setting of the tab control. More...
class | AbsoluteTabHeight
Property to access the absolute tab height setting of the tab control. More...
class | RelativeTabHeight
Property to access the relative tab height setting of the tab control. More...
class | TabTextPadding
Property to access the tab text padding setting of the tab control. More...
class | AbsoluteTabTextPadding
Property to access the absolute tab text padding setting of the tab control. More...
class | RelativeTabTextPadding
Property to access the relative tab text padding setting of the tab control. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Listbox class.
Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::ThumbProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::ThumbProperties

CEGUI::ThumbProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Thumb class. More...

Classes

class | HotTracked
Property to access the state of the "hot-tracked" setting for the thumb. More...
class | VertFree
Property to access the state the setting to free the thumb vertically. More...
class | HorzFree
Property to access the state the setting to free the thumb horizontally. More...
class | VertRange
Property to access the vertical movement range for the thumb. More...
class | HorzRange
Property to access the horizontal movement range for the thumb. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Thumb class.
Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TitlebarProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::TitlebarProperties

CEGUI::TitlebarProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Titlebar class. More...

Classes

class | DraggingEnabled
Property to access the state of the dragging enabled setting for the Titlebar. More...
class | CaptionColour
Property to colour used for rendering the caption text. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Titlebar class.
Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::TooltipProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::TooltipProperties

CEGUI::TooltipProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Tooltip class. More...

Classes

class | HoverTime
Property to access the timout that must expire before the tooltip gets activated. More...
class | DisplayTime
Property to access the time after which the tooltip automatically de-activates itself. More...
class | FadeTime
Property to access the duration of the fade effect for the tooltip. More...

Detailed Description

Namespace containing all classes that make up the properties interface for the Tooltip class.
Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI::WindowProperties Namespace Reference

  • Namespace List
  • Namespace Members
CEGUI::WindowProperties

CEGUI::WindowProperties Namespace Reference

Namespace containing all classes that make up the properties interface for the Window base class. More...

Classes

class | RelativeMinSize
Property to access minimum window size. More...
class | RelativeMaxSize
Property to access maximum window size. More...
class | AbsoluteMinSize
Property to access minimum window size. More...
class | AbsoluteMaxSize
Property to access maximum window size. More...
class | MetricsMode
Property to access the metrics mode setting. More...
class | ID
Property to access window ID field. More...
class | Alpha
Property to access window alpha setting. More...
class | Font
Property to access window Font setting. More...
class | Text
Property to access window text setting. More...
class | MouseCursorImage
Property to access window mouse cursor setting. More...
class | ClippedByParent
Property to access window "clipped by parent" setting. More...
class | InheritsAlpha
Property to access window "Inherits Alpha" setting. More...
class | AlwaysOnTop
Property to access window "Always-On-Top" setting. More...
class | Disabled
Property to access window Disabled setting. More...
class | Visible
Property to access window Visible setting. More...
class | RestoreOldCapture
Property to access window Restore Old Capture setting. More...
class | DestroyedByParent
Property to access window Destroyed by Parent setting. More...
class | Width
Property to access window width. More...
class | RelativeWidth
Property to access window width. More...
class | AbsoluteWidth
Property to access window width. More...
class | Height
Property to access window height. More...
class | RelativeHeight
Property to access window height. More...
class | AbsoluteHeight
Property to access window height. More...
class | Size
Property to access the window size. More...
class | RelativeSize
Property to access the window size. More...
class | AbsoluteSize
Property to access the window size. More...
class | XPosition
Property to access window X position. More...
class | RelativeXPosition
Property to access window X position. More...
class | AbsoluteXPosition
Property to access window X position. More...
class | YPosition
Property to access window Y position. More...
class | RelativeYPosition
Property to access window Y position. More...
class | AbsoluteYPosition
Property to access window Y position. More...
class | Position
Property to access window position. More...
class | RelativePosition
Property to access window position. More...
class | AbsolutePosition
Property to access window position. More...
class | Rect
Property to access window area rectangle. More...
class | RelativeRect
Property to access window area rectangle. More...
class | AbsoluteRect
Property to access window area rectangle. More...
class | ZOrderChangeEnabled
Property to access window Z-Order changing enabled setting. More...
class | WantsMultiClickEvents
Property to control whether the window will receive double/triple-click events. More...
class | MouseButtonDownAutoRepeat
Property to control whether the window will receive autorepeat mouse button down events. More...
class | AutoRepeatDelay
Property to access window autorepeat delay value. More...
class | AutoRepeatRate
Property to access window autorepeat rate value. More...
class | DistributeCapturedInputs
Property to access whether inputs are passed to child windows when input is captured to this window. More...
class | CustomTooltipType
Property to access the custom tooltip for this Window. More...
class | Tooltip
Property to access the tooltip text for this Window. More...
class | InheritsTooltipText
Property to access whether the window inherits its tooltip text from its parent whn it has no tooltip text of its own. More...
class | RiseOnClick
Property to access whether the window rises to the top of the z order when clicked. More...
class | VerticalAlignment
Property to access the vertical alignment setting for the window. More...
class | HorizontalAlignment
Property to access the horizontal alignment setting for the window. More...
class | UnifiedAreaRect
class | UnifiedPosition
class | UnifiedXPosition
class | UnifiedYPosition
class | UnifiedSize
class | UnifiedWidth
class | UnifiedHeight
class | UnifiedMinSize
class | UnifiedMaxSize

Detailed Description

Namespace containing all classes that make up the properties interface for the Window base class.
Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Directory Hierarchy

Crazy Eddies GUI System Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • include
    • elements
    • falagard
    • renderers
      • directx81GUIRenderer
      • directx9GUIRenderer
      • IrrlichtRenderer
      • OpenGLGUIRenderer
  • src
    • elements
    • falagard
    • implementations
      • mac
    • pcre
    • renderers
      • directx81GUIRenderer
      • directx9GUIRenderer
      • IrrlichtRenderer
      • OpenGLGUIRenderer
    • tinyxml
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/ Directory Reference

include

include Directory Reference

Directories

directory | elements
directory | falagard
directory | renderers

Files

file | CEGUI.h [code]
file | CEGUIBase.h [code]
file | CEGUIcolour.h [code]
file | CEGUIColourRect.h [code]
file | CEGUIConfig.h [code]
file | CEGUIConfig_xmlHandler.h [code]
file | CEGUIDataContainer.h [code]
file | CEGUIDefaultResourceProvider.h [code]
file | CEGUIEvent.h [code]
file | CEGUIEventArgs.h [code]
file | CEGUIEventSet.h [code]
file | CEGUIExceptions.h [code]
file | CEGUIFactoryModule.h [code]
file | CEGUIFont.h [code]
file | CEGUIFont_implData.h [code]
file | CEGUIFont_xmlHandler.h [code]
file | CEGUIFontManager.h [code]
file | CEGUIFontManager_implData.h [code]
file | CEGUIForwardRefs.h [code]
file | CEGUIGlobalEventSet.h [code]
file | CEGUIGUILayout_xmlHandler.h [code]
file | CEGUIImage.h [code]
file | CEGUIImageset.h [code]
file | CEGUIImageset_xmlHandler.h [code]
file | CEGUIImagesetManager.h [code]
file | CEGUIInputEvent.h [code]
file | CEGUIIteratorBase.h [code]
file | CEGUILogger.h [code]
file | CEGUIMouseCursor.h [code]
file | CEGUIProperty.h [code]
file | CEGUIPropertyHelper.h [code]
file | CEGUIPropertySet.h [code]
file | CEGUIRect.h [code]
file | CEGUIRefPtr.h [code]
file | CEGUIRenderableElement.h [code]
file | CEGUIRenderableFrame.h [code]
file | CEGUIRenderableImage.h [code]
file | CEGUIRenderCache.h [code]
file | CEGUIRenderer.h [code]
file | CEGUIResourceProvider.h [code]
file | CEGUIScheme.h [code]
file | CEGUIScheme_xmlHandler.h [code]
file | CEGUISchemeManager.h [code]
file | CEGUIScriptModule.h [code]
file | CEGUISingleton.h [code]
file | CEGUISize.h [code]
file | CEGUIString.h [code]
file | CEGUISystem.h [code]
file | CEGUITexture.h [code]
file | CEGUITextUtils.h [code]
file | CEGUITinyXMLParser.h [code]
file | CEGUIUDim.h [code]
file | CEGUIVector.h [code]
file | CEGUIVersion.h [code]
file | CEGUIWindow.h [code]
file | CEGUIWindowFactory.h [code]
file | CEGUIWindowFactoryManager.h [code]
file | CEGUIWindowManager.h [code]
file | CEGUIWindowProperties.h [code]
file | CEGUIXercesParser.h [code]
file | CEGUIXMLAttributes.h [code]
file | CEGUIXMLHandler.h [code]
file | CEGUIXMLParser.h [code]
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/elements/ Directory Reference

include » elements

elements Directory Reference

Files

file | CEGUIButtonBase.h [code]
file | CEGUIButtonBaseProperties.h [code]
file | CEGUICheckbox.h [code]
file | CEGUICheckboxProperties.h [code]
file | CEGUICombobox.h [code]
file | CEGUIComboboxProperties.h [code]
file | CEGUIComboDropList.h [code]
file | CEGUIDragContainer.h [code]
file | CEGUIDragContainerProperties.h [code]
file | CEGUIEditbox.h [code]
file | CEGUIEditboxProperties.h [code]
file | CEGUIFrameWindow.h [code]
file | CEGUIFrameWindowProperties.h [code]
file | CEGUIGUISheet.h [code]
file | CEGUIItemEntry.h [code]
file | CEGUIItemListBase.h [code]
file | CEGUIItemListBaseProperties.h [code]
file | CEGUIListbox.h [code]
file | CEGUIListboxItem.h [code]
file | CEGUIListboxProperties.h [code]
file | CEGUIListboxTextItem.h [code]
file | CEGUIListHeader.h [code]
file | CEGUIListHeaderProperties.h [code]
file | CEGUIListHeaderSegment.h [code]
file | CEGUIListHeaderSegmentProperties.h [code]
file | CEGUIMenubar.h [code]
file | CEGUIMenuBase.h [code]
file | CEGUIMenuBaseProperties.h [code]
file | CEGUIMenuItem.h [code]
file | CEGUIMenuItemProperties.h [code]
file | CEGUIMultiColumnList.h [code]
file | CEGUIMultiColumnListProperties.h [code]
file | CEGUIMultiLineEditbox.h [code]
file | CEGUIMultiLineEditboxProperties.h [code]
file | CEGUIPopupMenu.h [code]
file | CEGUIPopupMenuProperties.h [code]
file | CEGUIProgressBar.h [code]
file | CEGUIProgressBarProperties.h [code]
file | CEGUIPushButton.h [code]
file | CEGUIPushButtonProperties.h [code]
file | CEGUIRadioButton.h [code]
file | CEGUIRadioButtonProperties.h [code]
file | CEGUIScrollablePane.h [code]
file | CEGUIScrollablePaneProperties.h [code]
file | CEGUIScrollbar.h [code]
file | CEGUIScrollbarProperties.h [code]
file | CEGUIScrolledContainer.h [code]
file | CEGUIScrolledContainerProperties.h [code]
file | CEGUISlider.h [code]
file | CEGUISliderProperties.h [code]
file | CEGUISpinner.h [code]
file | CEGUISpinnerProperties.h [code]
file | CEGUIStatic.h [code]
file | CEGUIStaticImage.h [code]
file | CEGUIStaticImageProperties.h [code]
file | CEGUIStaticProperties.h [code]
file | CEGUIStaticText.h [code]
file | CEGUIStaticTextProperties.h [code]
file | CEGUITabButton.h [code]
file | CEGUITabControl.h [code]
file | CEGUITabControlProperties.h [code]
file | CEGUITabPane.h [code]
file | CEGUITextItem.h [code]
file | CEGUITextItemProperties.h [code]
file | CEGUIThumb.h [code]
file | CEGUIThumbProperties.h [code]
file | CEGUITitlebar.h [code]
file | CEGUITitlebarProperties.h [code]
file | CEGUITooltip.h [code]
file | CEGUITooltipProperties.h [code]
Generated on Sat Nov 26 10:09:57 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/falagard/ Directory Reference

include » falagard

falagard Directory Reference

Files

file | CEGUIFalagard_xmlHandler.h [code]
file | CEGUIFalComponentBase.h [code]
file | CEGUIFalDimensions.h [code]
file | CEGUIFalEnums.h [code]
file | CEGUIFalFrameComponent.h [code]
file | CEGUIFalImageryComponent.h [code]
file | CEGUIFalImagerySection.h [code]
file | CEGUIFalLayerSpecification.h [code]
file | CEGUIFalNamedArea.h [code]
file | CEGUIFalPropertyDefinition.h [code]
file | CEGUIFalPropertyInitialiser.h [code]
file | CEGUIFalSectionSpecification.h [code]
file | CEGUIFalStateImagery.h [code]
file | CEGUIFalTextComponent.h [code]
file | CEGUIFalWidgetComponent.h [code]
file | CEGUIFalWidgetLookFeel.h [code]
file | CEGUIFalWidgetLookManager.h [code]
file | CEGUIFalXMLEnumHelper.h [code]
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/renderers/ Directory Reference

include » renderers

renderers Directory Reference

Directories

directory | directx81GUIRenderer
directory | directx9GUIRenderer
directory | IrrlichtRenderer
directory | OpenGLGUIRenderer
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/renderers/directx81GUIRenderer/ Directory Reference

include » renderers » directx81GUIRenderer

directx81GUIRenderer Directory Reference

Files

file | renderer.h [code]
file | texture.h [code]
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/renderers/directx9GUIRenderer/ Directory Reference

include » renderers » directx9GUIRenderer

directx9GUIRenderer Directory Reference

Files

file | d3d9renderer.h [code]
file | d3d9texture.h [code]
Generated on Sat Nov 26 10:09:57 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/renderers/IrrlichtRenderer/ Directory Reference

include » renderers » IrrlichtRenderer

IrrlichtRenderer Directory Reference

Files

file | irrlichtrenderer.h [code]
file | IrrlichtRendererDef.h [code]
file | IrrlichtResourceProvider.h [code]
file | irrlichttexture.h [code]
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: include/renderers/OpenGLGUIRenderer/ Directory Reference

include » renderers » OpenGLGUIRenderer

OpenGLGUIRenderer Directory Reference

Files

file | openglrenderer.h [code]
file | opengltexture.h [code]
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/ Directory Reference

src

src Directory Reference

Directories

directory | elements
directory | falagard
directory | implementations
directory | pcre
directory | renderers
directory | tinyxml

Files

file | CEGUIBase.cpp
file | CEGUIcolour.cpp
file | CEGUIColourRect.cpp
file | CEGUIConfig_xmlHandler.cpp
file | CEGUIDefaultResourceProvider.cpp
file | CEGUIEvent.cpp
file | CEGUIEventArgs.cpp
file | CEGUIEventSet.cpp
file | CEGUIEventSignal.cpp
file | CEGUIEventSignalSet.cpp
file | CEGUIExceptions.cpp
file | CEGUIFactoryModule.cpp
file | CEGUIFont.cpp
file | CEGUIFont_xmlHandler.cpp
file | CEGUIFontManager.cpp
file | CEGUIGlobalEventSet.cpp
file | CEGUIGUILayout_xmlHandler.cpp
file | CEGUIImage.cpp
file | CEGUIImageset.cpp
file | CEGUIImageset_xmlHandler.cpp
file | CEGUIImagesetManager.cpp
file | CEGUILogger.cpp
file | CEGUIMacXMLSelectHack.cpp
file | CEGUIMouseCursor.cpp
file | CEGUIProperty.cpp
file | CEGUIPropertyHelper.cpp
file | CEGUIPropertySet.cpp
file | CEGUIRect.cpp
file | CEGUIRefPtr.cpp
file | CEGUIRenderableElement.cpp
file | CEGUIRenderableFrame.cpp
file | CEGUIRenderableImage.cpp
file | CEGUIRenderCache.cpp
file | CEGUIRenderer.cpp
file | CEGUIScheme.cpp
file | CEGUIScheme_xmlHandler.cpp
file | CEGUISchemeManager.cpp
file | CEGUIScriptModule.cpp
file | CEGUISize.cpp
file | CEGUIString.cpp
file | CEGUISystem.cpp
file | CEGUITexture.cpp
file | CEGUITextUtils.cpp
file | CEGUITinyXMLParser.cpp
file | CEGUIVector.cpp
file | CEGUIWin32XMLSelectHack.cpp
file | CEGUIWindow.cpp
file | CEGUIWindowFactory.cpp
file | CEGUIWindowFactoryManager.cpp
file | CEGUIWindowManager.cpp
file | CEGUIWindowProperties.cpp
file | CEGUIXercesParser.cpp
file | CEGUIXMLAttributes.cpp
file | CEGUIXMLHandler.cpp
file | CEGUIXMLParser.cpp
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/elements/ Directory Reference

src » elements

elements Directory Reference

Files

file | CEGUIButtonBase.cpp
file | CEGUIButtonBaseProperties.cpp
file | CEGUICheckbox.cpp
file | CEGUICheckboxProperties.cpp
file | CEGUICombobox.cpp
file | CEGUIComboboxProperties.cpp
file | CEGUIComboDropList.cpp
file | CEGUIDragContainer.cpp
file | CEGUIDragContainerProperties.cpp
file | CEGUIEditbox.cpp
file | CEGUIEditboxProperties.cpp
file | CEGUIFrameWindow.cpp
file | CEGUIFrameWindowProperties.cpp
file | CEGUIGUISheet.cpp
file | CEGUIItemEntry.cpp
file | CEGUIItemListBase.cpp
file | CEGUIItemListBaseProperties.cpp
file | CEGUIListbox.cpp
file | CEGUIListboxItem.cpp
file | CEGUIListboxProperties.cpp
file | CEGUIListboxTextItem.cpp
file | CEGUIListHeader.cpp
file | CEGUIListHeaderProperties.cpp
file | CEGUIListHeaderSegment.cpp
file | CEGUIListHeaderSegmentProperties.cpp
file | CEGUIMenubar.cpp
file | CEGUIMenuBase.cpp
file | CEGUIMenuBaseProperties.cpp
file | CEGUIMenuItem.cpp
file | CEGUIMenuItemProperties.cpp
file | CEGUIMultiColumnList.cpp
file | CEGUIMultiColumnListProperties.cpp
file | CEGUIMultiLineEditbox.cpp
file | CEGUIMultiLineEditboxProperties.cpp
file | CEGUIPopupMenu.cpp
file | CEGUIPopupMenuProperties.cpp
file | CEGUIProgressBar.cpp
file | CEGUIProgressBarProperties.cpp
file | CEGUIPushButton.cpp
file | CEGUIPushButtonProperties.cpp
file | CEGUIRadioButton.cpp
file | CEGUIRadioButtonProperties.cpp
file | CEGUIScrollablePane.cpp
file | CEGUIScrollablePaneProperties.cpp
file | CEGUIScrollbar.cpp
file | CEGUIScrollbarProperties.cpp
file | CEGUIScrolledContainer.cpp
file | CEGUIScrolledContainerProperties.cpp
file | CEGUISlider.cpp
file | CEGUISliderProperties.cpp
file | CEGUISpinner.cpp
file | CEGUISpinnerProperties.cpp
file | CEGUIStatic.cpp
file | CEGUIStaticImage.cpp
file | CEGUIStaticImageProperties.cpp
file | CEGUIStaticProperties.cpp
file | CEGUIStaticText.cpp
file | CEGUIStaticTextProperties.cpp
file | CEGUITabButton.cpp
file | CEGUITabControl.cpp
file | CEGUITabControlProperties.cpp
file | CEGUITextItem.cpp
file | CEGUITextItemProperties.cpp
file | CEGUIThumb.cpp
file | CEGUIThumbProperties.cpp
file | CEGUITitlebar.cpp
file | CEGUITitlebarProperties.cpp
file | CEGUITooltip.cpp
file | CEGUITooltipProperties.cpp
Generated on Sat Nov 26 10:09:57 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/falagard/ Directory Reference

src » falagard

falagard Directory Reference

Files

file | CEGUIFalagard_xmlHandler.cpp
file | CEGUIFalComponentBase.cpp
file | CEGUIFalDimensions.cpp
file | CEGUIFalFrameComponent.cpp
file | CEGUIFalImageryComponent.cpp
file | CEGUIFalImagerySection.cpp
file | CEGUIFalLayerSpecification.cpp
file | CEGUIFalNamedArea.cpp
file | CEGUIFalPropertyDefinition.cpp
file | CEGUIFalPropertyInitialiser.cpp
file | CEGUIFalSectionSpecification.cpp
file | CEGUIFalStateImagery.cpp
file | CEGUIFalTextComponent.cpp
file | CEGUIFalWidgetComponent.cpp
file | CEGUIFalWidgetLookFeel.cpp
file | CEGUIFalWidgetLookManager.cpp
file | CEGUIFalXMLEnumHelper.cpp
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/implementations/ Directory Reference

src » implementations

implementations Directory Reference

Directories

directory mac
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/implementations/mac/ Directory Reference

src » implementations » mac

mac Directory Reference

Files

file | macPlugins.cpp
file | macPlugins.h [code]
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/pcre/ Directory Reference

src » pcre

pcre Directory Reference

Files

file | internal.h [code]
file | pcre.h [code]
file | pcreconfig.h [code]
file | pcreposix.h [code]
file | ucp.h [code]
file | ucpinternal.h [code]
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/renderers/ Directory Reference

src » renderers

renderers Directory Reference

Directories

directory | directx81GUIRenderer
directory | directx9GUIRenderer
directory | IrrlichtRenderer
directory | OpenGLGUIRenderer
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/renderers/directx81GUIRenderer/ Directory Reference

src » renderers » directx81GUIRenderer

directx81GUIRenderer Directory Reference

Files

file | renderer.cpp
file | texture.cpp
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/renderers/directx9GUIRenderer/ Directory Reference

src » renderers » directx9GUIRenderer

directx9GUIRenderer Directory Reference

Files

file | d3d9renderer.cpp
file | d3d9texture.cpp
Generated on Sat Nov 26 10:09:57 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/renderers/IrrlichtRenderer/ Directory Reference

src » renderers » IrrlichtRenderer

IrrlichtRenderer Directory Reference

Files

file | IrrlichtEventPusher.h [code]
file | irrlichtrenderer.cpp
file | IrrlichtResourceProvider.cpp
file | irrlichttexture.cpp
Generated on Sat Nov 26 10:09:58 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/renderers/OpenGLGUIRenderer/ Directory Reference

src » renderers » OpenGLGUIRenderer

OpenGLGUIRenderer Directory Reference

Files

file | openglrenderer.cpp
file | opengltexture.cpp
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: src/tinyxml/ Directory Reference

src » tinyxml

tinyxml Directory Reference

Files

file | tinystr.cpp
file | tinystr.h [code]
file | tinyxml.cpp
file | tinyxml.h [code]
file | tinyxmlerror.cpp
file | tinyxmlparser.cpp
Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w
  • x

Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • Absolute : CEGUI
  • Alt : CEGUI
  • argb_t : CEGUI

- b -

  • BlankMouseCursor : CEGUI
  • BottomLeftToTopRight : CEGUI

- c -

  • Centred : CEGUI
  • Control : CEGUI

- d -

  • Default : CEGUI
  • DefaultMouseCursor : CEGUI
  • DefaultNativeHorzRes : CEGUI
  • DefaultNativeVertRes : CEGUI
  • DefaultWindow : CEGUI
  • DimensionOperator : CEGUI
  • DimensionType : CEGUI
  • DOP_ADD : CEGUI
  • DOP_DIVIDE : CEGUI
  • DOP_MULTIPLY : CEGUI
  • DOP_NOOP : CEGUI
  • DOP_SUBTRACT : CEGUI
  • DT_BOTTOM_EDGE : CEGUI
  • DT_HEIGHT : CEGUI
  • DT_INVALID : CEGUI
  • DT_LEFT_EDGE : CEGUI
  • DT_RIGHT_EDGE : CEGUI
  • DT_TOP_EDGE : CEGUI
  • DT_WIDTH : CEGUI
  • DT_X_OFFSET : CEGUI
  • DT_X_POSITION : CEGUI
  • DT_Y_OFFSET : CEGUI
  • DT_Y_POSITION : CEGUI

- e -

  • Errors : CEGUI

- f -

  • FIC_BACKGROUND : CEGUI
  • FIC_BOTTOM_EDGE : CEGUI
  • FIC_BOTTOM_LEFT_CORNER : CEGUI
  • FIC_BOTTOM_RIGHT_CORNER : CEGUI
  • FIC_FRAME_IMAGE_COUNT : CEGUI
  • FIC_LEFT_EDGE : CEGUI
  • FIC_RIGHT_EDGE : CEGUI
  • FIC_TOP_EDGE : CEGUI
  • FIC_TOP_LEFT_CORNER : CEGUI
  • FIC_TOP_RIGHT_CORNER : CEGUI
  • FlipHorizontal : CEGUI
  • FlipVertical : CEGUI
  • FMT_BASELINE : CEGUI
  • FMT_HORZ_EXTENT : CEGUI
  • FMT_LINE_SPACING : CEGUI
  • FontFlag : CEGUI
  • FontMetricType : CEGUI
  • FrameImageComponent : CEGUI
  • FrameLocation : CEGUI

- h -

  • HA_CENTRE : CEGUI
  • HA_LEFT : CEGUI
  • HA_RIGHT : CEGUI
  • HF_CENTRE_ALIGNED : CEGUI
  • HF_LEFT_ALIGNED : CEGUI
  • HF_RIGHT_ALIGNED : CEGUI
  • HF_STRETCHED : CEGUI
  • HF_TILED : CEGUI
  • HorizontalAlignment : CEGUI
  • HorizontalFormatting : CEGUI
  • HorizontalTextFormatting : CEGUI
  • HTF_CENTRE_ALIGNED : CEGUI
  • HTF_JUSTIFIED : CEGUI
  • HTF_LEFT_ALIGNED : CEGUI
  • HTF_RIGHT_ALIGNED : CEGUI
  • HTF_WORDWRAP_CENTRE_ALIGNED : CEGUI
  • HTF_WORDWRAP_JUSTIFIED : CEGUI
  • HTF_WORDWRAP_LEFT_ALIGNED : CEGUI
  • HTF_WORDWRAP_RIGHT_ALIGNED : CEGUI

- i -

  • Informative : CEGUI
  • Inherited : CEGUI
  • Insane : CEGUI

- j -

  • Justified : CEGUI

- l -

  • lbi_greater() : CEGUI
  • lbi_less() : CEGUI
  • LeftAligned : CEGUI
  • LeftMouse : CEGUI
  • LoggingLevel : CEGUI

- m -

  • MetricsMode : CEGUI
  • MiddleMouse : CEGUI
  • MouseButton : CEGUI
  • MouseCursorImage : CEGUI

- n -

  • NoAntiAlias : CEGUI
  • NoButton : CEGUI

- o -

  • operator!=() : CEGUI
  • operator+() : CEGUI
  • operator<() : CEGUI
  • operator<=() : CEGUI
  • operator==() : CEGUI
  • operator>() : CEGUI
  • operator>=() : CEGUI
  • OrientationFlags : CEGUI
  • OutStream : CEGUI

- p -

  • Point : CEGUI

- q -

  • QuadSplitMode : CEGUI

- r -

  • Relative : CEGUI
  • RightAligned : CEGUI
  • RightMouse : CEGUI
  • RotateRightAngle : CEGUI

- s -

  • Shift : CEGUI
  • Standard : CEGUI
  • SubscriberRef() : CEGUI
  • swap() : CEGUI
  • SystemKey : CEGUI

- t -

  • TextFormatting : CEGUI
  • TopLeftToBottomRight : CEGUI

- v -

  • VA_BOTTOM : CEGUI
  • VA_CENTRE : CEGUI
  • VA_TOP : CEGUI
  • VerticalAlignment : CEGUI
  • VerticalFormatting : CEGUI
  • VerticalTextFormatting : CEGUI
  • VF_BOTTOM_ALIGNED : CEGUI
  • VF_CENTRE_ALIGNED : CEGUI
  • VF_STRETCHED : CEGUI
  • VF_TILED : CEGUI
  • VF_TOP_ALIGNED : CEGUI
  • VTF_BOTTOM_ALIGNED : CEGUI
  • VTF_CENTRE_ALIGNED : CEGUI
  • VTF_TOP_ALIGNED : CEGUI

- w -

  • WordWrapCentred : CEGUI
  • WordWrapJustified : CEGUI
  • WordWrapLeftAligned : CEGUI
  • WordWrapRightAligned : CEGUI

- x -

  • X1Mouse : CEGUI
  • X2Mouse : CEGUI
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Page Index

Crazy Eddies GUI System Related Pages

Here is a list of all related documentation pages:
  • Todo List
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Todo List

Todo List

Class CEGUI::WidgetComponent
This is not finished in the slightest! There will be many changes here...
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Graphical Class Hierarchy

Crazy Eddies GUI System Graphical Class Hierarchy

Go to the textual class hierarchy

Generated on Sat Nov 26 10:10:21 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUI.h Source File

include

CEGUI.h

00001 /************************************************************************
00002         filename:       CEGUI.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Main system include for client code
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUI_h_
00027 #define _CEGUI_h_
00028
00029 // base stuff
00030 #include "CEGUIBase.h"
00031 #include "CEGUIString.h"
00032 #include "CEGUIRect.h"
00033 #include "CEGUIExceptions.h"
00034 #include "CEGUITexture.h"
00035 #include "CEGUIRenderer.h"
00036 #include "CEGUIImageset.h"
00037 #include "CEGUIImagesetManager.h"
00038 #include "CEGUILogger.h"
00039 #include "CEGUIMouseCursor.h"
00040 #include "CEGUIFont.h"
00041 #include "CEGUIFontManager.h"
00042 #include "CEGUIEventArgs.h"
00043 #include "CEGUIEvent.h"
00044 #include "CEGUIEventSet.h"
00045 #include "CEGUIGlobalEventSet.h"
00046 #include "CEGUIProperty.h"
00047 #include "CEGUIPropertySet.h"
00048 #include "CEGUIWindow.h"
00049 #include "CEGUIWindowFactory.h"
00050 #include "CEGUIWindowFactoryManager.h"
00051 #include "CEGUIWindowManager.h"
00052 #include "CEGUIScheme.h"
00053 #include "CEGUISchemeManager.h"
00054 #include "CEGUISystem.h"
00055 #include "CEGUIScriptModule.h"
00056
00057 // mid-level renderables
00058 #include "CEGUIRenderableFrame.h"
00059 #include "CEGUIRenderableImage.h"
00060
00061 // gui elements
00062 #include "elements/CEGUIButtonBase.h"
00063 #include "elements/CEGUIPushButton.h"
00064 #include "elements/CEGUICheckbox.h"
00065 #include "elements/CEGUIRadioButton.h"
00066 #include "elements/CEGUITitlebar.h"
00067 #include "elements/CEGUIFrameWindow.h"
00068 #include "elements/CEGUIProgressBar.h"
00069 #include "elements/CEGUIEditbox.h"
00070 #include "elements/CEGUIThumb.h"
00071 #include "elements/CEGUISlider.h"
00072 #include "elements/CEGUIScrollbar.h"
00073 #include "elements/CEGUIStatic.h"
00074 #include "elements/CEGUIListbox.h"
00075 #include "elements/CEGUICombobox.h"
00076 #include "elements/CEGUIListHeader.h"
00077 #include "elements/CEGUIMultiColumnList.h"
00078 #include "elements/CEGUIStaticText.h"
00079 #include "elements/CEGUIStaticImage.h"
00080 #include "elements/CEGUIGUISheet.h"
00081 #include "elements/CEGUIListboxTextItem.h"
00082 #include "elements/CEGUIComboDropList.h"
00083 #include "elements/CEGUIMultiLineEditbox.h"
00084 #include "elements/CEGUITabButton.h"
00085 #include "elements/CEGUITabPane.h"
00086 #include "elements/CEGUITabControl.h"
00087 #include "elements/CEGUISpinner.h"
00088 #include "elements/CEGUIDragContainer.h"
00089 #include "elements/CEGUIScrolledContainer.h"
00090 #include "elements/CEGUIScrollablePane.h"
00091 #include "elements/CEGUITooltip.h"
00092 #include "elements/CEGUIItemEntry.h"
00093 #include "elements/CEGUITextItem.h"
00094 #include "elements/CEGUIMenuItem.h"
00095 #include "elements/CEGUIItemListBase.h"
00096 #include "elements/CEGUIMenuBase.h"
00097 #include "elements/CEGUIMenubar.h"
00098 #include "elements/CEGUIPopupMenu.h"
00099
00100 #endif  // end of guard _CEGUI_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIBase.h Source File

include

CEGUIBase.h

00001 /************************************************************************
00002         filename:       CEGUIBase.h
00003         created:        20/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Base include used within the system
00007                                 This contains various lower level bits required
00008                                 by other parts of the system.  All other library
00009                                 headers will include this file.
00010 *************************************************************************/
00011 /*************************************************************************
00012     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00013     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00014
00015     This library is free software; you can redistribute it and/or
00016     modify it under the terms of the GNU Lesser General Public
00017     License as published by the Free Software Foundation; either
00018     version 2.1 of the License, or (at your option) any later version.
00019
00020     This library is distributed in the hope that it will be useful,
00021     but WITHOUT ANY WARRANTY; without even the implied warranty of
00022     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00023     Lesser General Public License for more details.
00024
00025     You should have received a copy of the GNU Lesser General Public
00026     License along with this library; if not, write to the Free Software
00027     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00028 *************************************************************************/
00029 #ifndef _CEGUIBase_h_
00030 #define _CEGUIBase_h_
00031
00032 #include <cassert>
00033
00034 // bring in configuration options
00035 #include "CEGUIConfig.h"
00036
00037 // add CEGUI version defines
00038 #include "CEGUIVersion.h"
00039
00040 /*************************************************************************
00041         Dynamic Library import / export control conditional
00042         (Define CEGUIBASE_EXPORTS to export symbols, else they are imported)
00043 *************************************************************************/
00044 #if defined( __WIN32__ ) || defined( _WIN32 )
00045 #   ifdef CEGUIBASE_EXPORTS
00046 #       define CEGUIEXPORT __declspec(dllexport)
00047 #   else
00048 #       define CEGUIEXPORT __declspec(dllimport)
00049 #   endif
00050 #       define CEGUIPRIVATE
00051 #else
00052 #       define CEGUIEXPORT
00053 #       define CEGUIPRIVATE
00054 #endif
00055
00056
00057 // totally kill this warning (debug info truncated to 255 chars etc...) on <= VC6
00058 #if defined(_MSC_VER) && (_MSC_VER <= 1200)
00059 #   pragma warning(disable : 4786)
00060 #endif
00061
00062
00063 // Detect macros for min / max and undefine (with a warning where possible)
00064 #if defined(max)
00065 #   if defined(_MSC_VER)
00066 #       pragma message("Macro defintion of max detected - undefining")
00067 #   elif defined (__GNUC__)
00068 #       warning ("Macro defintion of max detected - undefining")
00069 #   endif
00070 #   undef max
00071 #endif
00072 #if defined(min)
00073 #   if defined(_MSC_VER)
00074 #       pragma message("Macro defintion of min detected - undefining")
00075 #   elif defined (__GNUC__)
00076 #       warning ("Macro defintion of min detected - undefining")
00077 #   endif
00078 #   undef min
00079 #endif
00080
00081
00082 // include this to see if it defines _STLPORT_VERION
00083 #       include <string>
00084
00085 // fix to undefine _STLP_DEBUG if STLport is not actually being used
00086 // (resolves some unresolved externals concerning boost)
00087 #if defined(_STLP_DEBUG) && defined(_MSC_VER) && (_MSC_VER >= 1200)
00088 #       if !defined(_STLPORT_VERSION)
00089 #               undef _STLP_DEBUG
00090 #       endif
00091 #endif
00092
00093
00094 // The following defines macros used within CEGUI for std::min/std::max
00095 // usage, and is done as a compatibility measure for VC6 with native STL.
00096 #if defined(_MSC_VER) && (_MSC_VER <= 1200) && !defined(_STLPORT_VERSION)
00097 #    define ceguimin    std::_cpp_min
00098 #    define ceguimax    std::_cpp_max
00099 #else
00100 #    define ceguimin    std::min
00101 #    define ceguimax    std::max
00102 #endif
00103
00104
00105 /*************************************************************************
00106         Documentation for the CEGUI namespace itself
00107 *************************************************************************/
00115 namespace CEGUI
00116 {
00117
00118 /*************************************************************************
00119         Simplification of some 'unsigned' types
00120 *************************************************************************/
00121 typedef unsigned long   ulong;
00122 typedef unsigned short  ushort;
00123 typedef unsigned int    uint;
00124 typedef unsigned char   uchar;
00125
00126 typedef unsigned int    uint32;
00127 typedef unsigned short  uint16;
00128 typedef unsigned char   uint8;
00129
00130
00131 /*************************************************************************
00132         System wide constants
00133 *************************************************************************/
00134 static const float              DefaultNativeHorzRes    = 640.0f;
00135 static const float              DefaultNativeVertRes    = 480.0f;
00136
00137
00138 /*************************************************************************
00139     Additional typedefs
00140 *************************************************************************/
00141 typedef std::ostream OutStream;
00142 }  // end of CEGUI namespace section
00143
00144
00158 #if defined(CEGUI_ALIGN_ELEMENTS_TO_PIXELS)
00159 #       define PixelAligned(x)  ( (float)(int)(( x ) + 0.5f) )
00160 #else
00161 #       define PixelAligned(x)  ( x )
00162 #endif
00163
00164
00165 /*************************************************************************
00166         Bring in forward references to all GUI base system classes
00167 *************************************************************************/
00168 #include "CEGUIForwardRefs.h"
00169
00170
00171 #endif  // end of guard _CEGUIBase_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIButtonBase.h Source File

include » elements

CEGUIButtonBase.h

00001 /************************************************************************
00002         filename:       CEGUIButtonBase.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for ButtonBase widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIButtonBase_h_
00027 #define _CEGUIButtonBase_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIButtonBaseProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00043
00048 class CEGUIEXPORT ButtonBase : public Window
00049 {
00050 public:
00051         /*************************************************************************
00052                 Constants
00053         *************************************************************************/
00054         // default colours for text label rendering
00055         static const colour             DefaultNormalLabelColour;
00056         static const colour             DefaultHoverLabelColour;
00057         static const colour             DefaultPushedLabelColour;
00058         static const colour             DefaultDisabledLabelColour;
00059
00060
00061         /*************************************************************************
00062                 Accessor type functions
00063         *************************************************************************/
00071         bool    isHovering(void) const                  {return d_hovering;}
00072
00073
00081         bool    isPushed(void) const                    {return d_pushed;}
00082
00083
00091         colour  getNormalTextColour(void) const                 {return d_normalColour;}
00092
00093
00101         colour  getHoverTextColour(void) const                  {return d_hoverColour;}
00102
00103
00111         colour  getPushedTextColour(void) const                 {return d_pushedColour;}
00112
00113
00121         colour  getDisabledTextColour(void) const               {return d_disabledColour;}
00122
00123         /*************************************************************************
00124                 Manipulators
00125         *************************************************************************/
00136         void    setNormalTextColour(const colour& colour);
00137
00138
00149         void    setHoverTextColour(const colour& colour);
00150
00151
00162         void    setPushedTextColour(const colour& colour);
00163
00164
00175         void    setDisabledTextColour(const colour& colour);
00176
00177         /*************************************************************************
00178                 Construction and Destruction
00179         *************************************************************************/
00184         ButtonBase(const String& type, const String& name);
00185
00186
00191         virtual ~ButtonBase(void);
00192
00193
00194 protected:
00195         /*************************************************************************
00196                 Overridden event handlers
00197         *************************************************************************/
00198         virtual void    onMouseMove(MouseEventArgs& e);
00199         virtual void    onMouseButtonDown(MouseEventArgs& e);
00200         virtual void    onMouseButtonUp(MouseEventArgs& e);
00201         virtual void    onCaptureLost(WindowEventArgs& e);
00202         virtual void    onMouseLeaves(MouseEventArgs& e);
00203
00204
00205         /*************************************************************************
00206                 Implementation Functions
00207         *************************************************************************/
00218         void    updateInternalState(const Point& mouse_pos);
00219
00220
00231         virtual bool    testClassName_impl(const String& class_name) const
00232         {
00233                 if (class_name==(const utf8*)"ButtonBase")      return true;
00234                 return Window::testClassName_impl(class_name);
00235         }
00236
00237
00238         /*************************************************************************
00239                 Implementation Rendering Functions
00240         *************************************************************************/
00251         virtual void    drawSelf(float z);
00252
00253
00264         virtual void    drawNormal(float z)             = 0;
00265
00266
00277         virtual void    drawHover(float z)                      {drawNormal(z);}
00278
00279
00290         virtual void    drawPushed(float z)             {drawNormal(z);}
00291
00292
00303         virtual void    drawDisabled(float z)           {drawNormal(z);}
00304
00305
00306         /*************************************************************************
00307                 Implementation Data
00308         *************************************************************************/
00309         bool    d_pushed;
00310         bool    d_hovering;
00311
00312         // common rendering setting data
00313         colour  d_normalColour;
00314         colour  d_hoverColour;
00315         colour  d_pushedColour;
00316         colour  d_disabledColour;
00317
00318 private:
00319         /*************************************************************************
00320                 Static Properties for this class
00321         *************************************************************************/
00322         static ButtonBaseProperties::NormalTextColour   d_normalTextColourProperty;
00323         static ButtonBaseProperties::HoverTextColour    d_hoverTextColourProperty;
00324         static ButtonBaseProperties::PushedTextColour   d_pushedTextColourProperty;
00325         static ButtonBaseProperties::DisabledTextColour d_disabledTextColourProperty;
00326
00327         /*************************************************************************
00328                 Private methods
00329         *************************************************************************/
00330         void    addButtonBaseProperties(void);
00331 };
00332
00333 } // End of  CEGUI namespace section
00334
00335 #if defined(_MSC_VER)
00336 #       pragma warning(pop)
00337 #endif
00338
00339 #endif  // end of guard _CEGUIButtonBase_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIButtonBaseProperties.h Source File

include » elements

CEGUIButtonBaseProperties.h

00001 /************************************************************************
00002         filename:       CEGUIButtonBaseProperties.h
00003         created:        9/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for button base class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIButtonBaseProperties_h_
00027 #define _CEGUIButtonBaseProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035 // Start of ButtonBaseProperties namespace section
00040 namespace ButtonBaseProperties
00041 {
00055 class NormalTextColour : public Property
00056 {
00057 public:
00058         NormalTextColour() : Property(
00059                 "NormalTextColour",
00060                 "Property to get/set the colour to use when rendering label text for normal state.  Value is \"aarrggbb\" (hex).",
00061                 "FFFFFFFF")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00082 class HoverTextColour : public Property
00083 {
00084 public:
00085         HoverTextColour() : Property(
00086                 "HoverTextColour",
00087                 "Property to get/set the colour to use when rendering label text for hover/highlight state.  Value is \"aarrggbb\" (hex).",
00088                 "FFFFFFFF")
00089         {}
00090
00091         String  get(const PropertyReceiver* receiver) const;
00092         void    set(PropertyReceiver* receiver, const String& value);
00093 };
00094
00095
00109 class PushedTextColour : public Property
00110 {
00111 public:
00112         PushedTextColour() : Property(
00113                 "PushedTextColour",
00114                 "Property to get/set the colour to use when rendering label text for pushed state.  Value is \"aarrggbb\" (hex).",
00115                 "FFFFFFFF")
00116         {}
00117
00118         String  get(const PropertyReceiver* receiver) const;
00119         void    set(PropertyReceiver* receiver, const String& value);
00120 };
00121
00122
00136 class DisabledTextColour : public Property
00137 {
00138 public:
00139         DisabledTextColour() : Property(
00140                 "DisabledTextColour",
00141                 "Property to get/set the colour to use when rendering label text for disabled state.  Value is \"aarrggbb\" (hex).",
00142                 "FF7F7F7F")
00143         {}
00144
00145         String  get(const PropertyReceiver* receiver) const;
00146         void    set(PropertyReceiver* receiver, const String& value);
00147 };
00148
00149
00150 } // End of  ButtonBaseProperties namespace section
00151
00152
00153 } // End of  CEGUI namespace section
00154
00155
00156 #endif  // end of guard _CEGUIButtonBaseProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUICheckbox.h Source File

include » elements

CEGUICheckbox.h

00001 /************************************************************************
00002         filename:       CEGUICheckbox.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Checkbox Widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUICheckbox_h_
00027 #define _CEGUICheckbox_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "elements/CEGUIButtonBase.h"
00031 #include "elements/CEGUICheckboxProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00043
00048 class CEGUIEXPORT Checkbox : public ButtonBase
00049 {
00050 public:
00051         static const String EventNamespace;
00052
00053         /*************************************************************************
00054                 Event name constants
00055         *************************************************************************/
00056         // generated internally by Window
00057         static const String EventCheckStateChanged;
00058
00059
00060         /*************************************************************************
00061                 Accessor Functions
00062         *************************************************************************/
00071         bool    isSelected(void) const                                          {return d_selected;}
00072
00073
00074         /*************************************************************************
00075                 Manipulator Functions
00076         *************************************************************************/
00088         void    setSelected(bool select);
00089
00090
00091         /*************************************************************************
00092                 Construction / Destruction
00093         *************************************************************************/
00098         Checkbox(const String& type, const String& name);
00099
00100
00105         virtual ~Checkbox(void);
00106
00107
00108 protected:
00109         /*************************************************************************
00110                 New event handlers
00111         *************************************************************************/
00116         virtual void    onSelectStateChange(WindowEventArgs& e);
00117
00118
00119         /*************************************************************************
00120                 Overridden event handlers
00121         *************************************************************************/
00122         virtual void    onMouseButtonUp(MouseEventArgs& e);
00123
00124
00125         /*************************************************************************
00126                 Implementation Functions
00127         *************************************************************************/
00132         void    addCheckboxEvents(void);
00133
00134
00145         virtual bool    testClassName_impl(const String& class_name) const
00146         {
00147                 if (class_name==(const utf8*)"Checkbox")        return true;
00148                 return ButtonBase::testClassName_impl(class_name);
00149         }
00150
00151
00152         /*************************************************************************
00153                 Implementation Data
00154         *************************************************************************/
00155         bool            d_selected;
00156
00157 private:
00158         /*************************************************************************
00159                 Static Properties for this class
00160         *************************************************************************/
00161         static CheckboxProperties::Selected     d_selectedProperty;
00162
00163
00164         /*************************************************************************
00165                 Private methods
00166         *************************************************************************/
00167         void    addCheckboxProperties(void);
00168 };
00169
00170 } // End of  CEGUI namespace section
00171
00172
00173 #if defined(_MSC_VER)
00174 #       pragma warning(pop)
00175 #endif
00176
00177 #endif  // end of guard _CEGUICheckbox_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUICheckboxProperties.h Source File

include » elements

CEGUICheckboxProperties.h

00001 /************************************************************************
00002         filename:       CEGUICheckboxProperties.h
00003         created:        9/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for the Checkbox class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUICheckboxProperties_h_
00027 #define _CEGUICheckboxProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of CheckboxProperties namespace section
00041 namespace CheckboxProperties
00042 {
00057 class Selected : public Property
00058 {
00059 public:
00060         Selected() : Property(
00061                 "Selected",
00062                 "Property to get/set the selected state of the Checkbox.  Value is either \"True\" or \"False\".",
00063                 "False")
00064         {}
00065
00066         String  get(const PropertyReceiver* receiver) const;
00067         void    set(PropertyReceiver* receiver, const String& value);
00068 };
00069
00070 } // End of  CheckboxProperties namespace section
00071
00072 } // End of  CEGUI namespace section
00073
00074
00075 #endif  // end of guard _CEGUICheckboxProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIcolour.h Source File

include

CEGUIcolour.h

00001 /************************************************************************
00002         filename:       CEGUIcolour.h
00003         created:        20/8/2004
00004         author:         Paul D Turner (with code from Jeff Leigh)
00005
00006         purpose:        Defines interface to the colour class used to represent
00007                                 colour values within the system
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIcolour_h_
00028 #define _CEGUIcolour_h_
00029
00030 #include "CEGUIBase.h"
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035 typedef uint32 argb_t;
00036
00041 class CEGUIEXPORT colour
00042 {
00043 public:
00044         /*************************************************************************
00045                 Construction & Destruction
00046         *************************************************************************/
00047         colour(void);
00048         colour(const colour& val);
00049         colour(float red, float green, float blue, float alpha = 1.0f);
00050         colour(argb_t argb);
00051
00052         /*************************************************************************
00053                 Accessors
00054         *************************************************************************/
00055         argb_t  getARGB(void) const
00056         {
00057                 if (!d_argbValid)
00058                 {
00059                         d_argb = calculateARGB();
00060                         d_argbValid = true;
00061                 }
00062
00063                 return d_argb;
00064         }
00065
00066         float   getAlpha(void) const    {return d_alpha;}
00067         float   getRed(void) const              {return d_red;}
00068         float   getGreen(void) const    {return d_green;}
00069         float   getBlue(void) const             {return d_blue;}
00070
00071         float   getHue(void) const;
00072         float   getSaturation(void) const;
00073         float   getLumination(void) const;
00074
00075
00076         /*************************************************************************
00077                 Manipulators
00078         *************************************************************************/
00079         void    setARGB(argb_t argb);
00080         inline void setAlpha(float alpha)
00081     {
00082         d_argbValid = false;
00083         d_alpha = alpha;
00084     }
00085
00086         inline void setRed(float red)
00087     {
00088         d_argbValid = false;
00089         d_red = red;
00090     }
00091
00092         inline void setGreen(float green)
00093     {
00094         d_argbValid = false;
00095         d_green = green;
00096     }
00097
00098         inline void setBlue(float blue)
00099     {
00100         d_argbValid = false;
00101         d_blue = blue;
00102     }
00103
00104         inline void set(float red, float green, float blue, float alpha = 1.0f)
00105     {
00106         d_argbValid = false;
00107         d_alpha = alpha;
00108         d_red = red;
00109         d_green = green;
00110         d_blue = blue;
00111     }
00112
00113         inline void setRGB(float red, float green, float blue)
00114     {
00115         d_argbValid = false;
00116         d_red = red;
00117         d_green = green;
00118         d_blue = blue;
00119     }
00120
00121         inline void setRGB(const colour& val)
00122     {
00123         d_red = val.d_red;
00124         d_green = val.d_green;
00125         d_blue = val.d_blue;
00126         if (d_argbValid)
00127         {
00128             d_argbValid = val.d_argbValid;
00129             if (d_argbValid)
00130                 d_argb = (d_argb & 0xFF000000) | (val.d_argb & 0x00FFFFFF);
00131         }
00132     }
00133
00134         void    setHSL(float hue, float saturation, float luminance, float alpha = 1.0f);
00135
00136         void    invertColour(void);
00137         void    invertColourWithAlpha(void);
00138
00139         /*************************************************************************
00140                 Operators
00141         *************************************************************************/
00142         inline colour& operator=(argb_t val)
00143     {
00144         setARGB(val);
00145         return *this;
00146     }
00147
00148         inline colour& operator=(const colour& val)
00149     {
00150         d_alpha = val.d_alpha;
00151         d_red   = val.d_red;
00152         d_green = val.d_green;
00153         d_blue  = val.d_blue;
00154         d_argb  = val.d_argb;
00155         d_argbValid = val.d_argbValid;
00156
00157         return *this;
00158     }
00159
00160         inline colour& operator&=(argb_t val)
00161     {
00162         setARGB(getARGB() & val);
00163         return *this;
00164     }
00165
00166         inline colour& operator&=(const colour& val)
00167     {
00168         setARGB(getARGB() & val.getARGB());
00169         return *this;
00170     }
00171
00172         inline colour& operator|=(argb_t val)
00173     {
00174         setARGB(getARGB() | val);
00175         return *this;
00176     }
00177
00178         inline colour& operator|=(const colour& val)
00179     {
00180         setARGB(getARGB() | val.getARGB());
00181         return *this;
00182     }
00183
00184         inline colour& operator<<=(int val)
00185     {
00186         setARGB(getARGB() << val);
00187         return *this;
00188     }
00189
00190         inline colour& operator>>=(int val)
00191     {
00192         setARGB(getARGB() >> val);
00193         return *this;
00194     }
00195
00196         inline colour operator+(const colour& val) const
00197     {
00198         return colour(
00199             d_red   + val.d_red,
00200             d_green + val.d_green,
00201             d_blue  + val.d_blue,
00202             d_alpha + val.d_alpha
00203         );
00204     }
00205
00206         inline colour operator-(const colour& val) const
00207     {
00208         return colour(
00209             d_red   - val.d_red,
00210             d_green - val.d_green,
00211             d_blue  - val.d_blue,
00212             d_alpha - val.d_alpha
00213         );
00214     }
00215
00216         inline colour operator*(const float val) const
00217     {
00218         return colour(
00219             d_red   * val,
00220             d_green * val,
00221             d_blue  * val,
00222             d_alpha * val
00223         );
00224     }
00225
00226     inline colour& operator*=(const colour& val)
00227     {
00228         d_red *= val.d_red;
00229         d_blue *= val.d_blue;
00230         d_green *= val.d_green;
00231         d_alpha *= val.d_alpha;
00232
00233                 d_argbValid = false;
00234
00235         return *this;
00236     }
00237
00238         /*************************************************************************
00239                 Compare operators
00240         *************************************************************************/
00241         inline bool operator==(const colour& rhs) const
00242     {
00243         return d_red   == rhs.d_red   &&
00244                d_green == rhs.d_green &&
00245                d_blue  == rhs.d_blue  &&
00246                d_alpha == rhs.d_alpha;
00247     }
00248
00249         inline bool operator!=(const colour& rhs) const
00250     {
00251         return !(*this == rhs);
00252     }
00253
00254         //
00255         // Conversion operators
00256         //
00257         operator argb_t() const         {return getARGB();}
00258
00259 private:
00260         /*************************************************************************
00261                 Implementation Methods
00262         *************************************************************************/
00267         argb_t  calculateARGB(void) const;
00268
00269         /*************************************************************************
00270                 Implementation Data
00271         *************************************************************************/
00272         float d_alpha, d_red, d_green, d_blue;
00273         mutable argb_t d_argb;
00274         mutable bool d_argbValid;
00275 };
00276
00277 } // End of  CEGUI namespace section
00278
00279
00280 #endif  // end of guard _CEGUIcolour_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIColourRect.h Source File

include

CEGUIColourRect.h

00001 /************************************************************************
00002         filename:       CEGUIColourRect.h
00003         created:        8/3/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines class representing colours for four corners of a
00007                                 rectangle
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIColourRect_h_
00028 #define _CEGUIColourRect_h_
00029
00030 #include "CEGUIBase.h"
00031 #include "CEGUIcolour.h"
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00040 class CEGUIEXPORT ColourRect
00041 {
00042 public:
00047         ColourRect(void);
00048
00049
00054         ColourRect(const colour& col);
00055
00056
00061         ColourRect(const colour& top_left, const colour& top_right, const colour& bottom_left, const colour& bottom_right);
00062
00063
00074         void    setAlpha(float alpha);
00075
00076
00087         void    setTopAlpha(float alpha);
00088
00089
00100         void    setBottomAlpha(float alpha);
00101
00102
00113         void    setLeftAlpha(float alpha);
00114
00115
00126         void    setRightAlpha(float alpha);
00127
00128
00136         bool    isMonochromatic() const;
00137
00138
00155         ColourRect getSubRectangle( float left, float right, float top, float bottom ) const;
00156
00169         colour getColourAtPoint( float x, float y ) const;
00170
00171
00179         void    setColours(const colour& col);
00180
00181
00189         void    modulateAlpha(float alpha);
00190
00195     ColourRect& operator*=(const ColourRect& other);
00196
00197
00198         colour  d_top_left, d_top_right, d_bottom_left, d_bottom_right;         //<! ColourRect component colours
00199 };
00200
00201 } // End of  CEGUI namespace section
00202
00203
00204 #endif  // end of guard _CEGUIColourRect_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUICombobox.h Source File

include » elements

CEGUICombobox.h

00001 /************************************************************************
00002         filename:       CEGUICombobox.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Combobox widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUICombobox_h_
00027 #define _CEGUICombobox_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIComboboxProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00043
00048 class CEGUIEXPORT Combobox : public Window
00049 {
00050 public:
00051         static const String EventNamespace;
00052
00053         /*************************************************************************
00054                 Constants
00055         *************************************************************************/
00056         // event names from edit box
00057         static const String EventReadOnlyModeChanged;
00058         static const String EventValidationStringChanged;
00059         static const String EventMaximumTextLengthChanged;
00060         static const String EventTextInvalidated;
00061         static const String EventInvalidEntryAttempted;
00062         static const String EventCaratMoved;
00063         static const String EventTextSelectionChanged;
00064         static const String EventEditboxFull;
00065         static const String EventTextAccepted;
00066
00067         // event names from list box
00068         static const String EventListContentsChanged;
00069         static const String EventListSelectionChanged;
00070         static const String EventSortModeChanged;
00071         static const String EventVertScrollbarModeChanged;
00072         static const String EventHorzScrollbarModeChanged;
00073
00074         // events we produce / generate ourselves
00075         static const String EventDropListDisplayed;
00076         static const String EventDropListRemoved;
00077         static const String EventListSelectionAccepted;
00078
00079
00090         virtual bool    isHit(const Point& position) const              {return false;}
00091
00092
00101         bool    getSingleClickEnabled(void) const;
00102
00103
00111         bool    isDropDownListVisible(void) const;
00112
00113
00114         /*************************************************************************
00115                 Editbox Accessors
00116         *************************************************************************/
00124         bool    hasInputFocus(void) const;
00125
00126
00135         bool    isReadOnly(void) const;
00136
00137
00154         bool    isTextValid(void) const;
00155
00156
00168         const String&   getValidationString(void) const;
00169
00170
00178         size_t  getCaratIndex(void) const;
00179
00180
00189         size_t  getSelectionStartIndex(void) const;
00190
00191
00200         size_t  getSelectionEndIndex(void) const;
00201
00202
00210         size_t  getSelectionLength(void) const;
00211
00212
00224         size_t  getMaxTextLength(void) const;
00225
00226
00235         colour  getNormalTextColour(void) const;
00236
00237
00246         colour  getSelectedTextColour(void) const;
00247
00248
00257         colour  getNormalSelectBrushColour(void) const;
00258
00259
00268         colour  getInactiveSelectBrushColour(void) const;
00269
00270
00271         /*************************************************************************
00272                 List Accessors
00273         *************************************************************************/
00281         size_t  getItemCount(void) const;
00282
00283
00292         ListboxItem*    getSelectedItem(void) const;
00293
00294
00307         ListboxItem*    getListboxItemFromIndex(size_t index) const;
00308
00309
00322         size_t  getItemIndex(const ListboxItem* item) const;
00323
00324
00332         bool    isSortEnabled(void) const;
00333
00334
00347         bool    isItemSelected(size_t index) const;
00348
00349
00367         ListboxItem*    findItemWithText(const String& text, const ListboxItem* start_item);
00368
00369
00377         bool    isListboxItemInList(const ListboxItem* item) const;
00378
00379
00388         bool    isVertScrollbarAlwaysShown(void) const;
00389
00390
00399         bool    isHorzScrollbarAlwaysShown(void) const;
00400
00401
00402         /*************************************************************************
00403                 Combobox Manipulators
00404         *************************************************************************/
00415         virtual void    initialise(void);
00416
00417
00425         void    showDropList(void);
00426
00427
00435         void    hideDropList(void);
00436
00437
00449         void    setSingleClickEnabled(bool setting);
00450
00451
00452         /*************************************************************************
00453                 Editbox Manipulators
00454         *************************************************************************/
00466         void    setReadOnly(bool setting);
00467
00468
00483         void    setValidationString(const String& validation_string);
00484
00485
00497         void    setCaratIndex(size_t carat_pos);
00498
00499
00515         void    setSelection(size_t start_pos, size_t end_pos);
00516
00517
00532         void    setMaxTextLength(size_t max_len);
00533
00534
00545         void    setNormalTextColour(colour col);
00546
00547
00556         void    setSelectedTextColour(colour col);
00557
00558
00570         void    setNormalSelectBrushColour(colour col);
00571
00572
00584         void    setInactiveSelectBrushColour(colour col);
00585
00586
00594         void    activateEditbox(void);
00595
00596
00597         /*************************************************************************
00598                 List Manipulators
00599         *************************************************************************/
00606         void    resetList(void);
00607
00608
00620         void    addItem(ListboxItem* item);
00621
00622
00640         void    insertItem(ListboxItem* item, const ListboxItem* position);
00641
00642
00654         void    removeItem(const ListboxItem* item);
00655
00656
00664         void    clearAllSelections(void);
00665
00666
00677         void    setSortingEnabled(bool setting);
00678
00679
00691         void    setShowVertScrollbar(bool setting);
00692
00693
00705         void    setShowHorzScrollbar(bool setting);
00706
00707
00727         void    setItemSelectState(ListboxItem* item, bool state);
00728
00729
00749         void    setItemSelectState(size_t item_index, bool state);
00750
00751
00764         void    handleUpdatedListItemData(void);
00765
00766
00767         /*************************************************************************
00768                 Construction and Destruction
00769         *************************************************************************/
00774         Combobox(const String& type, const String& name);
00775
00776
00781         virtual ~Combobox(void);
00782
00783
00784 protected:
00785         /*************************************************************************
00786                 Implementation Methods
00787         *************************************************************************/
00792         void    addComboboxEvents(void);
00793
00794
00803         virtual Editbox*        createEditbox(const String& name) const         = 0;
00804
00805
00814         virtual PushButton*     createPushButton(const String& name) const      = 0;
00815
00816
00825         virtual ComboDropList*  createDropList(const String& name) const        = 0;
00826
00827
00832         bool    button_PressHandler(const EventArgs& e);
00833
00834
00839         bool    droplist_SelectionAcceptedHandler(const EventArgs& e);
00840
00841
00846         bool    droplist_HiddenHandler(const EventArgs& e);
00847
00848
00853         bool    editbox_MouseDownHandler(const EventArgs& e);
00854
00855
00866         virtual bool    testClassName_impl(const String& class_name) const
00867         {
00868                 if (class_name==(const utf8*)"Combobox")        return true;
00869                 return Window::testClassName_impl(class_name);
00870         }
00871
00872
00873         /*************************************************************************
00874                 Handlers to relay child widget events so they appear to come from us
00875         *************************************************************************/
00876         bool editbox_ReadOnlyChangedHandler(const EventArgs& e);
00877         bool editbox_ValidationStringChangedHandler(const EventArgs& e);
00878         bool editbox_MaximumTextLengthChangedHandler(const EventArgs& e);
00879         bool editbox_TextInvalidatedEventHandler(const EventArgs& e);
00880         bool editbox_InvalidEntryAttemptedHandler(const EventArgs& e);
00881         bool editbox_CaratMovedHandler(const EventArgs& e);
00882         bool editbox_TextSelectionChangedHandler(const EventArgs& e);
00883         bool editbox_EditboxFullEventHandler(const EventArgs& e);
00884         bool editbox_TextAcceptedEventHandler(const EventArgs& e);
00885         bool editbox_TextChangedEventHandler(const EventArgs& e);
00886         bool listbox_ListContentsChangedHandler(const EventArgs& e);
00887         bool listbox_ListSelectionChangedHandler(const EventArgs& e);
00888         bool listbox_SortModeChangedHandler(const EventArgs& e);
00889         bool listbox_VertScrollModeChangedHandler(const EventArgs& e);
00890         bool listbox_HorzScrollModeChangedHandler(const EventArgs& e);
00891
00892
00893         /*************************************************************************
00894                 New Events for Combobox
00895         *************************************************************************/
00900         virtual void    onReadOnlyChanged(WindowEventArgs& e);
00901
00902
00907         virtual void    onValidationStringChanged(WindowEventArgs& e);
00908
00909
00914         virtual void    onMaximumTextLengthChanged(WindowEventArgs& e);
00915
00916
00921         virtual void    onTextInvalidatedEvent(WindowEventArgs& e);
00922
00923
00928         virtual void    onInvalidEntryAttempted(WindowEventArgs& e);
00929
00930
00935         virtual void    onCaratMoved(WindowEventArgs& e);
00936
00937
00942         virtual void    onTextSelectionChanged(WindowEventArgs& e);
00943
00944
00949         virtual void    onEditboxFullEvent(WindowEventArgs& e);
00950
00951
00956         virtual void    onTextAcceptedEvent(WindowEventArgs& e);
00957
00958
00963         virtual void    onListContentsChanged(WindowEventArgs& e);
00964
00965
00971         virtual void    onListSelectionChanged(WindowEventArgs& e);
00972
00973
00978         virtual void    onSortModeChanged(WindowEventArgs& e);
00979
00980
00986         virtual void    onVertScrollbarModeChanged(WindowEventArgs& e);
00987
00988
00994         virtual void    onHorzScrollbarModeChanged(WindowEventArgs& e);
00995
00996
01001         virtual void    onDropListDisplayed(WindowEventArgs& e);
01002
01003
01008         virtual void    onDroplistRemoved(WindowEventArgs& e);
01009
01010
01015         virtual void    onListSelectionAccepted(WindowEventArgs& e);
01016
01017
01018         /*************************************************************************
01019                 Overridden Event handlers
01020         *************************************************************************/
01021         virtual void    onFontChanged(WindowEventArgs& e);
01022         virtual void    onTextChanged(WindowEventArgs& e);
01023         virtual void    onActivated(ActivationEventArgs& e);
01024
01025
01026         /*************************************************************************
01027                 Implementation Data
01028         *************************************************************************/
01029         Editbox*                d_editbox;
01030         ComboDropList*  d_droplist;
01031         PushButton*             d_button;
01032         bool                    d_singleClickOperation;
01033
01034
01035 private:
01036         /*************************************************************************
01037                 Static Properties for this class
01038         *************************************************************************/
01039         static ComboboxProperties::ReadOnly                                             d_readOnlyProperty;
01040         static ComboboxProperties::ValidationString                             d_validationStringProperty;
01041         static ComboboxProperties::CaratIndex                                   d_caratIndexProperty;
01042         static ComboboxProperties::EditSelectionStart                   d_selStartProperty;
01043         static ComboboxProperties::EditSelectionLength                  d_selLengthProperty;
01044         static ComboboxProperties::MaxEditTextLength                    d_maxTextLengthProperty;
01045         static ComboboxProperties::NormalEditTextColour                 d_normalTextColourProperty;
01046         static ComboboxProperties::SelectedEditTextColour               d_selectedTextColourProperty;
01047         static ComboboxProperties::ActiveEditSelectionColour    d_activeSelectionColourProperty;
01048         static ComboboxProperties::InactiveEditSelectionColour  d_inactiveSelectionColourProperty;
01049         static ComboboxProperties::SortList                                             d_sortProperty;
01050         static ComboboxProperties::ForceVertScrollbar                   d_forceVertProperty;
01051         static ComboboxProperties::ForceHorzScrollbar                   d_forceHorzProperty;
01052         static ComboboxProperties::SingleClickMode                              d_singleClickOperationProperty;
01053
01054         /*************************************************************************
01055                 Private methods
01056         *************************************************************************/
01057         void    addComboboxProperties(void);
01058 };
01059
01060 } // End of  CEGUI namespace section
01061
01062 #if defined(_MSC_VER)
01063 #       pragma warning(pop)
01064 #endif
01065
01066 #endif  // end of guard _CEGUICombobox_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIComboboxProperties.h Source File

include » elements

CEGUIComboboxProperties.h

00001 /************************************************************************
00002         filename:       CEGUIComboboxProperties.h
00003         created:        11/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to Combobox property classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIComboboxProperties_h_
00027 #define _CEGUIComboboxProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ComboboxProperties namespace section
00041 namespace ComboboxProperties
00042 {
00055 class ReadOnly : public Property
00056 {
00057 public:
00058         ReadOnly() : Property(
00059                 "ReadOnly",
00060                 "Property to get/set the read-only setting for the Editbox.  Value is either \"True\" or \"False\".",
00061                 "False")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00080 class ValidationString : public Property
00081 {
00082 public:
00083         ValidationString() : Property(
00084                 "ValidationString",
00085                 "Property to get/set the validation string Editbox.  Value is a text string.",
00086                 ".*")
00087         {}
00088
00089         String  get(const PropertyReceiver* receiver) const;
00090         void    set(PropertyReceiver* receiver, const String& value);
00091 };
00092
00093
00105 class CaratIndex : public Property
00106 {
00107 public:
00108         CaratIndex() : Property(
00109                 "CaratIndex",
00110                 "Property to get/set the current carat index.  Value is \"[uint]\".",
00111                 "0")
00112         {}
00113
00114         String  get(const PropertyReceiver* receiver) const;
00115         void    set(PropertyReceiver* receiver, const String& value);
00116 };
00117
00118
00130 class EditSelectionStart : public Property
00131 {
00132 public:
00133         EditSelectionStart() : Property(
00134                 "EditSelectionStart",
00135                 "Property to get/set the zero based index of the selection start position within the text.  Value is \"[uint]\".",
00136                 "0")
00137         {}
00138
00139         String  get(const PropertyReceiver* receiver) const;
00140         void    set(PropertyReceiver* receiver, const String& value);
00141 };
00142
00143
00155 class EditSelectionLength : public Property
00156 {
00157 public:
00158         EditSelectionLength() : Property(
00159                 "EditSelectionLength",
00160                 "Property to get/set the length of the selection (as a count of the number of code points selected).  Value is \"[uint]\".",
00161                 "0")
00162         {}
00163
00164         String  get(const PropertyReceiver* receiver) const;
00165         void    set(PropertyReceiver* receiver, const String& value);
00166 };
00167
00168
00180 class MaxEditTextLength : public Property
00181 {
00182 public:
00183         MaxEditTextLength() : Property(
00184                 "MaxEditTextLength",
00185                 "Property to get/set the the maximum allowed text length (as a count of code points).  Value is \"[uint]\".",
00186                 "1073741824")
00187         {}
00188
00189         String  get(const PropertyReceiver* receiver) const;
00190         void    set(PropertyReceiver* receiver, const String& value);
00191 };
00192
00193
00205 class NormalEditTextColour : public Property
00206 {
00207 public:
00208         NormalEditTextColour() : Property(
00209                 "NormalEditTextColour",
00210                 "Property to get/set the normal, unselected, text colour used for rendering text.  Value is \"aarrggbb\" (hex).",
00211                 "00FFFFFF")
00212         {}
00213
00214         String  get(const PropertyReceiver* receiver) const;
00215         void    set(PropertyReceiver* receiver, const String& value);
00216 };
00217
00218
00230 class SelectedEditTextColour : public Property
00231 {
00232 public:
00233         SelectedEditTextColour() : Property(
00234                 "SelectedEditTextColour",
00235                 "Property to get/set the colour used for rendering text within the selection area.  Value is \"aarrggbb\" (hex).",
00236                 "00000000")
00237         {}
00238
00239         String  get(const PropertyReceiver* receiver) const;
00240         void    set(PropertyReceiver* receiver, const String& value);
00241 };
00242
00243
00255 class ActiveEditSelectionColour : public Property
00256 {
00257 public:
00258         ActiveEditSelectionColour() : Property(
00259                 "ActiveEditSelectionColour",
00260                 "Property to get/set the colour used for rendering the selection highlight when the edit box is active.  Value is \"aarrggbb\" (hex).",
00261                 "006060FF")
00262         {}
00263
00264         String  get(const PropertyReceiver* receiver) const;
00265         void    set(PropertyReceiver* receiver, const String& value);
00266 };
00267
00268
00280 class InactiveEditSelectionColour : public Property
00281 {
00282 public:
00283         InactiveEditSelectionColour() : Property(
00284                 "InactiveEditSelectionColour",
00285                 "Property to get/set the colour used for rendering the selection highlight when the edit box is inactive.  Value is \"aarrggbb\" (hex).",
00286                 "00808080")
00287         {}
00288
00289         String  get(const PropertyReceiver* receiver) const;
00290         void    set(PropertyReceiver* receiver, const String& value);
00291 };
00292
00293
00306 class SortList : public Property
00307 {
00308 public:
00309         SortList() : Property(
00310                 "SortList",
00311                 "Property to get/set the sort setting of the list box.  Value is either \"True\" or \"False\".",
00312                 "False")
00313         {}
00314
00315         String  get(const PropertyReceiver* receiver) const;
00316         void    set(PropertyReceiver* receiver, const String& value);
00317 };
00318
00319
00332 class ForceVertScrollbar : public Property
00333 {
00334 public:
00335         ForceVertScrollbar() : Property(
00336                 "ForceVertScrollbar",
00337                 "Property to get/set the 'always show' setting for the vertical scroll bar of the list box.  Value is either \"True\" or \"False\".",
00338                 "False")
00339         {}
00340
00341         String  get(const PropertyReceiver* receiver) const;
00342         void    set(PropertyReceiver* receiver, const String& value);
00343 };
00344
00345
00358 class ForceHorzScrollbar : public Property
00359 {
00360 public:
00361         ForceHorzScrollbar() : Property(
00362                 "ForceHorzScrollbar",
00363                 "Property to get/set the 'always show' setting for the horizontal scroll bar of the list box.  Value is either \"True\" or \"False\".",
00364                 "False")
00365         {}
00366
00367         String  get(const PropertyReceiver* receiver) const;
00368         void    set(PropertyReceiver* receiver, const String& value);
00369 };
00370
00371
00384 class SingleClickMode : public Property
00385 {
00386 public:
00387         SingleClickMode() : Property(
00388                 "SingleClickMode",
00389                 "Property to get/set the 'single click mode' setting for the combo box.  Value is either \"True\" or \"False\".",
00390                 "False")
00391         {}
00392
00393         String  get(const PropertyReceiver* receiver) const;
00394         void    set(PropertyReceiver* receiver, const String& value);
00395 };
00396
00397
00398 } // End of  ComboboxProperties namespace section
00399
00400 } // End of  CEGUI namespace section
00401
00402
00403 #endif  // end of guard _CEGUIComboboxProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIComboDropList.h Source File

include » elements

CEGUIComboDropList.h

00001 /************************************************************************
00002         filename:       CEGUIComboDropList.h
00003         created:        13/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for the Combobox Drop-List widget base class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIComboDropList_h_
00027 #define _CEGUIComboDropList_h_
00028
00029 #include "elements/CEGUIListbox.h"
00030
00031
00032 #if defined(_MSC_VER)
00033 #       pragma warning(push)
00034 #       pragma warning(disable : 4251)
00035 #endif
00036
00037
00038 // Start of CEGUI namespace section
00039 namespace CEGUI
00040 {
00045 class CEGUIEXPORT ComboDropList : public Listbox
00046 {
00047 public:
00048         static const String EventNamespace;
00049
00050
00051         /*************************************************************************
00052                 Constants
00053         *************************************************************************/
00054         // Event names
00055         static const String EventListSelectionAccepted;
00056
00057
00068         virtual void    initialise(void);
00069
00070
00089         void    setArmed(bool setting)          { d_armed = setting; }
00090
00091
00102         bool    isArmed(void) const             { return d_armed; }
00103
00104
00116         void    setAutoArmEnabled(bool setting)         { d_autoArm = setting; }
00117
00118
00127         bool    isAutoArmEnabled(void) const            { return d_autoArm; }
00128
00129
00130         /*************************************************************************
00131                 Constructor & Destructor
00132         *************************************************************************/
00137         ComboDropList(const String& type, const String& name);
00138
00139
00144         virtual ~ComboDropList(void);
00145
00146
00147 protected:
00152         void    addComboDropListEvents(void);
00153
00154
00165         virtual bool    testClassName_impl(const String& class_name) const
00166         {
00167                 if (class_name==(const utf8*)"ComboDropList")   return true;
00168                 return Listbox::testClassName_impl(class_name);
00169         }
00170
00171         /*************************************************************************
00172                 New event handlers
00173         *************************************************************************/
00178         void    onListSelectionAccepted(WindowEventArgs& e);
00179
00180
00181         /*************************************************************************
00182                 Overridden Event handling
00183         *************************************************************************/
00184         virtual void    onMouseMove(MouseEventArgs& e);
00185         virtual void    onMouseButtonDown(MouseEventArgs& e);
00186         virtual void    onMouseButtonUp(MouseEventArgs& e);
00187         virtual void    onCaptureLost(WindowEventArgs& e);
00188         virtual void    onActivated(ActivationEventArgs& e);
00189
00190
00191         /*************************************************************************
00192                 Implementation Data
00193         *************************************************************************/
00194         bool    d_autoArm;
00195         bool    d_armed;
00196 };
00197
00198 } // End of  CEGUI namespace section
00199
00200 #if defined(_MSC_VER)
00201 #       pragma warning(pop)
00202 #endif
00203
00204 #endif  // end of guard _CEGUIComboDropList_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIConfig.h Source File

include

CEGUIConfig.h

00001 /************************************************************************
00002         filename:       CEGUIConfig.h
00003         created:        1/10/2004
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00025 /*************************************************************************
00026
00027 This file can be used to set certain configuration options which are used
00028 when compiling Crazy Eddie's GUI System and associated components.
00029
00030 Each item in here has a comment to describe what it's for.
00031
00032 *************************************************************************/
00034 #ifndef _CEGUIConfig_h_
00035 #define _CEGUIConfig_h_
00036
00037
00039 // Uncomment this line if you are using the 0.14.x or earlier release of Ogre.
00041 //#define CEGUI_USEOLDOGRESTRING 1
00042
00043
00045 // comment this line to suppress the auto appending of '_d' to loaded module
00046 // names under Win32.
00048 #define CEGUI_LOAD_MODULE_APPEND_SUFFIX_FOR_DEBUG 1
00049
00050
00052 // this is what gets appended to module names when
00053 // CEGUI_LOAD_MODULE_APPEND_FOR_DEBUG is defined
00055 #define CEGUI_LOAD_MODULE_DEBUG_SUFFIX  "_d"
00056
00057
00059 // Comment this line to remove the alignment of elements to pixel
00060 // boundaries.  This may give you a performance boost at the expense
00061 // of visual quality
00063 #define CEGUI_ALIGN_ELEMENTS_TO_PIXELS 1
00064
00066 // The following are intended for MSVC++ and X-Code users.
00067 //
00068 // The Linux build can both auto-configure itself, and also take
00069 // configure parameters which control the settings presented below.
00071 #if defined(_MSC_VER) || defined(__APPLE__)
00072
00074 // Comment this line if you wish to remove the Xerces-C++ dependency.
00075 // The system will revert to using an embedded version of TinyXML instead.
00077 #define CEGUI_WITH_XERCES
00078
00080 // Comment/Uncomment these lines to control renderer use in samples where
00081 // MSVC/XCode are used (since they don't auto-detect such things).
00083 #define CEGUI_SAMPLES_USE_OPENGL
00084 //#define CEGUI_SAMPLES_USE_OGRE
00085 //#define CEGUI_SAMPLES_USE_IRRLICHT
00086
00087 #endif // defined(_MSC_VER) || defined(__APPLE__)
00088
00089
00091 // The following are intended for MSVC++ users.
00093 #if defined(_MSC_VER)
00094
00096 // Comment/Uncomment these lines to control renderer use in samples where
00097 // MSVC is used (since it can't auto-detect such things).
00099 //#define CEGUI_SAMPLES_USE_DIRECTX_8
00100 #define CEGUI_SAMPLES_USE_DIRECTX_9
00101
00103 // It is expected by now you are running a recent PSDK and not one that is
00104 // seven years old.  If you wish to try your luck, comment this line!
00106 #define _STLP_NEW_PLATFORM_SDK
00107
00108 #endif // defined(_MSC_VER)
00109
00110 #endif  // end of guard _CEGUIConfig_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIConfig_xmlHandler.h Source File

include

CEGUIConfig_xmlHandler.h

00001 /************************************************************************
00002         filename:       CEGUIConfig_xmlHandler.h
00003         created:        17/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to configuration file parser
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIConfig_xmlHandler_h_
00027 #define _CEGUIConfig_xmlHandler_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUILogger.h"
00032 #include "CEGUIXMLHandler.h"
00033
00034 #include <vector>
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00043 class Config_xmlHandler : public XMLHandler
00044 {
00045 public:
00046         /*************************************************************************
00047                 Construction & Destruction
00048         *************************************************************************/
00053         Config_xmlHandler(void) {}
00054
00059         virtual ~Config_xmlHandler(void) {}
00060
00061         /*************************************************************************
00062                 SAX2 Handler overrides
00063         *************************************************************************/
00068     virtual void elementStart(const String& element, const XMLAttributes& attributes);
00069
00070         /*************************************************************************
00071                 Functions used by our implementation
00072         *************************************************************************/
00077         const String&   getLogFilename(void) const                              {return d_logFilename;}
00078
00079
00084         const String&   getSchemeFilename(void) const                   {return d_schemeFilename;}
00085
00086
00091         const String&   getLayoutFilename(void) const                   {return d_layoutFilename;}
00092
00093
00098         const String&   getInitScriptFilename(void) const               {return d_initScriptFilename;}
00099
00100
00105         const String&   getTermScriptFilename(void) const               {return d_termScriptFilename;}
00106
00107
00112         const String&   getDefaultFontName(void) const          {return d_defaultFontName;}
00113
00114
00119         const String&   getDefaultResourceGroup(void) const             {return d_defaultResourceGroup;}
00120
00125     LoggingLevel getLoggingLevel(void) const     {return d_logLevel;}
00126
00127
00128 private:
00129         /*************************************************************************
00130                 Implementation Constants
00131         *************************************************************************/
00132         static const String CEGUIConfigElement;
00133         static const char       ConfigLogfileAttribute[];
00134         static const char       ConfigSchemeAttribute[];
00135         static const char       ConfigLayoutAttribute[];
00136         static const char       ConfigDefaultFontAttribute[];
00137         static const char       ConfigInitScriptAttribute[];
00138         static const char       ConfigTerminateScriptAttribute[];
00139     static const char   ConfigDefaultResourceGroupAttribute[];
00140     static const char   ConfigLoggingLevelAttribute[];
00141
00142         /*************************************************************************
00143                 Implementation Data
00144         *************************************************************************/
00145         String          d_logFilename;
00146         String          d_schemeFilename;
00147         String          d_layoutFilename;
00148         String          d_initScriptFilename;
00149         String          d_termScriptFilename;
00150         String          d_defaultFontName;
00151     String      d_defaultResourceGroup;
00152     LoggingLevel    d_logLevel;
00153 };
00154
00155
00156 } // End of  CEGUI namespace section
00157
00158 #endif  // end of guard _CEGUIConfig_xmlHandler_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIDataContainer.h Source File

include

CEGUIDataContainer.h

00001 /************************************************************************
00002         filename:       CEGUIDataContainer.h
00003         created:        10/8/2004
00004         author:         James '_mental_' O'Sullivan
00005
00006         purpose:        Defines abstract base class for Window objects
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIDataContainer_h_
00027 #define _CEGUIDataContainer_h_
00028
00029 #include "CEGUIBase.h"
00030
00031 #include <malloc.h>
00032 //#include <xercesc/sax/InputSource.hpp>
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00037
00038 template <class T>
00039 class CEGUIEXPORT DataContainer
00040 {
00041 public:
00042         /*************************************************************************
00043                 Construction and Destruction
00044         *************************************************************************/
00049     DataContainer()
00050       : mData(0),
00051         mSize(0)
00052     {
00053     }
00054
00059         virtual ~DataContainer(void)
00060     {
00061         release();
00062     }
00063
00064         /*************************************************************************
00065                 Accessor functions
00066         *************************************************************************/
00074     void setData(T* data) { mData = data; }
00075
00083     T* getDataPtr(void) { return mData; }
00084
00092     void setSize(size_t size) { mSize = size; }
00093
00101     size_t getSize(void) const { return mSize; }
00102
00108     virtual void release(void)
00109     {
00110         if(mData)
00111         {
00112             delete mData;
00113             mData = 0;
00114         }
00115     }
00116         /*************************************************************************
00117                 Implementation Data
00118         *************************************************************************/
00119 protected:
00120     T* mData;
00121     size_t mSize;
00122 };
00123
00124 // Specialized templates
00125 class RawDataContainer : public DataContainer<unsigned char>
00126 {
00127 public:
00128     RawDataContainer() : DataContainer<unsigned char>()
00129     {
00130     }
00131
00132     ~RawDataContainer()
00133     {
00134         release();
00135     }
00136
00137     void release(void)
00138     {
00139         if(mData)
00140         {
00141             delete [] mData;
00142             mData = 0;
00143         }
00144     }
00145 };
00146
00147 //typedef DataContainer<unsigned char> RawDataContainer;
00148 //typedef DataContainer<XERCES_CPP_NAMESPACE::InputSource> InputSourceContainer;
00149
00150 } // End of  CEGUI namespace section
00151
00152 #endif  // end of guard _CEGUIDataContainer_h_
00153
00154
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIDefaultResourceProvider.h Source File

include

CEGUIDefaultResourceProvider.h

00001 /************************************************************************
00002         filename:       CEGUIDefaultResourceProvider.h
00003         created:        8/7/2004
00004         author:         James '_mental_' O'Sullivan
00005
00006         purpose:        Defines abstract base class for CEGUIData objects
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIDefaultResourceProvider_h_
00027 #define _CEGUIDefaultResourceProvider_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIResourceProvider.h"
00031
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00036 class CEGUIEXPORT DefaultResourceProvider : public ResourceProvider
00037 {
00038 public:
00039         /*************************************************************************
00040                 Construction and Destruction
00041         *************************************************************************/
00042         DefaultResourceProvider() {}
00043         ~DefaultResourceProvider(void) {}
00044
00045 //    void loadInputSourceContainer(const String& filename, InputSourceContainer& output);
00046     void loadRawDataContainer(const String& filename, RawDataContainer& output, const String& resourceGroup);
00047 };
00048
00049 } // End of  CEGUI namespace section
00050
00051 #endif  // end of guard _CEGUIDefaultResourceProvider_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIDragContainer.h Source File

include » elements

CEGUIDragContainer.h

00001 /************************************************************************
00002         filename:       CEGUIDragContainer.h
00003         created:        14/2/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIDragContainer_h_
00025 #define _CEGUIDragContainer_h_
00026
00027 #include "CEGUIWindow.h"
00028 #include "CEGUIWindowFactory.h"
00029 #include "elements/CEGUIDragContainerProperties.h"
00030
00031
00032 #if defined(_MSC_VER)
00033 #       pragma warning(push)
00034 #       pragma warning(disable : 4251)
00035 #endif
00036
00037 // Start of CEGUI namespace section
00038 namespace CEGUI
00039 {
00044     class CEGUIEXPORT DragContainer : public Window
00045     {
00046     public:
00047         /*************************************************************************
00048             Constants
00049         *************************************************************************/
00050         static const String WidgetTypeName;
00051         static const String EventNamespace;
00052         static const String EventDragStarted;
00053         static const String EventDragEnded;
00054         static const String EventDragPositionChanged;
00055         static const String EventDragEnabledChanged;
00056         static const String EventDragAlphaChanged;
00057         static const String EventDragMouseCursorChanged;
00058         static const String EventDragThresholdChanged;
00059         static const String EventDragDropTargetChanged;
00060
00061         /*************************************************************************
00062             Object Construction and Destruction
00063         *************************************************************************/
00068         DragContainer(const String& type, const String& name);
00069
00074         virtual ~DragContainer(void);
00075
00076         /*************************************************************************
00077                 Public Interface to DragContainer
00078         *************************************************************************/
00087         bool isDraggingEnabled(void) const;
00088
00100         void setDraggingEnabled(bool setting);
00101
00110         bool isBeingDragged(void) const;
00111
00123         float getPixelDragThreshold(void) const;
00124
00139         void setPixelDragThreshold(float pixels);
00140
00149         float getDragAlpha(void) const;
00150
00166         void setDragAlpha(float alpha);
00167
00176         const Image* getDragCursorImage(void) const;
00177
00192         void setDragCursorImage(const Image* image);
00193
00208         void setDragCursorImage(MouseCursorImage image);
00209
00230         void setDragCursorImage(const String& imageset, const String& image);
00231
00243         Window* getCurrentDropTarget(void) const;
00244
00245     protected:
00246         /*************************************************************************
00247                 Protected Implementation Methods
00248         *************************************************************************/
00256         void addDragContainerEvents(void);
00257
00270         bool isDraggingThresholdExceeded(const Point& local_mouse);
00271
00279         void initialiseDragging(void);
00280
00291         void doDragging(const Point& local_mouse);
00292
00297         void updateActiveMouseCursor(void) const;
00298
00299
00310                 virtual bool    testClassName_impl(const String& class_name) const
00311                 {
00312                         if (class_name==(const utf8*)"DragContainer")   return true;
00313                         return Window::testClassName_impl(class_name);
00314                 }
00315
00316
00317         /*************************************************************************
00318                 Implementation of abstract methods in Window
00319         *************************************************************************/
00320         void drawSelf(float z);
00321
00322         /*************************************************************************
00323                 Overrides of methods in Window
00324         *************************************************************************/
00325
00326         /*************************************************************************
00327                 Overrides for Event handler methods
00328         *************************************************************************/
00329         virtual void onMouseButtonDown(MouseEventArgs& e);
00330         virtual void onMouseButtonUp(MouseEventArgs& e);
00331         virtual void onMouseMove(MouseEventArgs& e);
00332         virtual void onCaptureLost(WindowEventArgs& e);
00333         virtual void onAlphaChanged(WindowEventArgs& e);
00334         virtual void onClippingChanged(WindowEventArgs& e);/*Window::drawSelf(z);*/
00335
00336         /*************************************************************************
00337                 New Event handler methods
00338         *************************************************************************/
00349         virtual void onDragStarted(WindowEventArgs& e);
00350
00361         virtual void onDragEnded(WindowEventArgs& e);
00362
00373         virtual void onDragPositionChanged(WindowEventArgs& e);
00374
00383         virtual void onDragEnabledChanged(WindowEventArgs& e);
00384
00393         virtual void onDragAlphaChanged(WindowEventArgs& e);
00394
00403         virtual void onDragMouseCursorChanged(WindowEventArgs& e);
00404
00413         virtual void onDragThresholdChanged(WindowEventArgs& e);
00414
00430         virtual void onDragDropTargetChanged(DragDropEventArgs& e);
00431
00432         /*************************************************************************
00433                 Data
00434         *************************************************************************/
00435         bool    d_draggingEnabled;
00436         bool    d_leftMouseDown;
00437         bool    d_dragging;
00438         Point   d_dragPoint;
00439         Point   d_startPosition;
00440         float   d_dragThreshold;
00441         float   d_dragAlpha;
00442         float   d_storedAlpha;
00443         bool    d_storedClipState;
00444         Window* d_dropTarget;
00445         const Image* d_dragCursorImage;
00446
00447     private:
00448         /*************************************************************************
00449             Static properties for the Spinner widget
00450         *************************************************************************/
00451         static DragContainerProperties::DragAlpha       d_dragAlphaProperty;
00452         static DragContainerProperties::DragCursorImage d_dragCursorImageProperty;
00453         static DragContainerProperties::DraggingEnabled d_dragEnabledProperty;
00454         static DragContainerProperties::DragThreshold   d_dragThresholdProperty;
00455
00456         /*************************************************************************
00457                 Implementation methods
00458         *************************************************************************/
00466         void addDragContainerProperties(void);
00467     };
00468
00473     class DragContainerFactory : public WindowFactory
00474     {
00475     public:
00476         DragContainerFactory(void) : WindowFactory(DragContainer::WidgetTypeName) { }
00477         ~DragContainerFactory(void){}
00478
00479         Window* createWindow(const String& name)
00480         {
00481             DragContainer* wnd = new DragContainer(d_type, name);
00482             return wnd;
00483         }
00484
00485         void destroyWindow(Window* window)
00486         {
00487             if (window->getType() == d_type)
00488                 delete window;
00489         }
00490
00491     };
00492
00493
00494 } // End of  CEGUI namespace section
00495
00496
00497 #if defined(_MSC_VER)
00498 #       pragma warning(pop)
00499 #endif
00500
00501 #endif  // end of guard _CEGUIDragContainer_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIDragContainerProperties.h Source File

include » elements

CEGUIDragContainerProperties.h

00001 /************************************************************************
00002         filename:       CEGUIDragContainerProperties.h
00003         created:        15/2/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIDragContainerProperties_h_
00025 #define _CEGUIDragContainerProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of DragContainerProperties namespace section
00033 namespace DragContainerProperties
00034 {
00047     class DraggingEnabled : public Property
00048     {
00049     public:
00050             DraggingEnabled() : Property(
00051                     "DraggingEnabled",
00052                     "Property to get/set the state of the dragging enabled setting for the DragContainer.  Value is either \"True\" or \"False\".",
00053                     "True")
00054             {}
00055
00056             String      get(const PropertyReceiver* receiver) const;
00057             void        set(PropertyReceiver* receiver, const String& value);
00058     };
00059
00071     class DragAlpha : public Property
00072     {
00073     public:
00074             DragAlpha() : Property(
00075                     "DragAlpha",
00076                     "Property to get/set the dragging alpha value.  Value is a float.",
00077                     "0.500000")
00078             {}
00079
00080             String get(const PropertyReceiver* receiver) const;
00081             void set(PropertyReceiver* receiver, const String& value);
00082     };
00083
00095     class DragThreshold : public Property
00096     {
00097     public:
00098             DragThreshold() : Property(
00099                     "DragThreshold",
00100                     "Property to get/set the dragging threshold value.  Value is a float.",
00101                     "8.000000")
00102             {}
00103
00104             String get(const PropertyReceiver* receiver) const;
00105             void set(PropertyReceiver* receiver, const String& value);
00106     };
00107
00122     class DragCursorImage : public Property
00123     {
00124     public:
00125             DragCursorImage() : Property(
00126                     "DragCursorImage",
00127                     "Property to get/set the mouse cursor image used when dragging.  Value should be \"set:<imageset name> image:<image name>\".",
00128                     "")
00129             {}
00130
00131             String      get(const PropertyReceiver* receiver) const;
00132             void        set(PropertyReceiver* receiver, const String& value);
00133     };
00134
00135 } // End of  DragContainerProperties namespace section
00136 } // End of  CEGUI namespace section
00137
00138 #endif  // end of guard _CEGUIDragContainerProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIEditbox.h Source File

include » elements

CEGUIEditbox.h

00001 /************************************************************************
00002         filename:       CEGUIEditbox.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Editbox widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIEditbox_h_
00027 #define _CEGUIEditbox_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIEditboxProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00043 // forward declare implementation data type
00044 struct RegexValidator;
00045
00046
00051 class CEGUIEXPORT Editbox : public Window
00052 {
00053 public:
00054         static const String EventNamespace;
00055
00056
00057         /*************************************************************************
00058                 Constants
00059         *************************************************************************/
00060         // default colours
00061         static const argb_t     DefaultNormalTextColour;
00062         static const argb_t     DefaultSelectedTextColour;
00063         static const argb_t     DefaultNormalSelectionColour;
00064         static const argb_t     DefaultInactiveSelectionColour;
00065
00066
00067         /*************************************************************************
00068                 Event name constants
00069         *************************************************************************/
00070         static const String EventReadOnlyModeChanged;
00071         static const String EventMaskedRenderingModeChanged;
00072         static const String EventMaskCodePointChanged;
00073         static const String EventValidationStringChanged;
00074         static const String EventMaximumTextLengthChanged;
00075         static const String EventTextInvalidated;
00076         static const String EventInvalidEntryAttempted;
00077         static const String EventCaratMoved;
00078         static const String EventTextSelectionChanged;
00079         static const String EventEditboxFull;
00080         static const String EventTextAccepted;
00081
00082
00083         /*************************************************************************
00084                 Accessor Functions
00085         *************************************************************************/
00093         bool    hasInputFocus(void) const;
00094
00095
00104         bool    isReadOnly(void) const          {return d_readOnly;}
00105
00106
00115         bool    isTextMasked(void) const        {return d_maskText;}
00116
00117
00134         bool    isTextValid(void) const;
00135
00136
00148         const String&   getValidationString(void) const         {return d_validationString;}
00149
00150
00158         size_t  getCaratIndex(void) const               {return d_caratPos;}
00159
00160
00169         size_t  getSelectionStartIndex(void) const;
00170
00171
00180         size_t  getSelectionEndIndex(void) const;
00181
00182
00190         size_t  getSelectionLength(void) const;
00191
00192
00201         utf32   getMaskCodePoint(void) const            {return d_maskCodePoint;}
00202
00203
00215         size_t  getMaxTextLength(void) const            {return d_maxTextLen;}
00216
00217
00226         colour  getNormalTextColour(void) const                         {return d_normalTextColour;}
00227
00228
00237         colour  getSelectedTextColour(void) const                       {return d_selectTextColour;}
00238
00239
00248         colour  getNormalSelectBrushColour(void) const          {return d_selectBrushColour;}
00249
00250
00259         colour  getInactiveSelectBrushColour(void) const        {return d_inactiveSelectBrushColour;}
00260
00261
00262         /*************************************************************************
00263                 Manipulators
00264         *************************************************************************/
00276         void    setReadOnly(bool setting);
00277
00278
00290         void    setTextMasked(bool setting);
00291
00292
00307         void    setValidationString(const String& validation_string);
00308
00309
00321         void    setCaratIndex(size_t carat_pos);
00322
00323
00339         void    setSelection(size_t start_pos, size_t end_pos);
00340
00341
00353         void    setMaskCodePoint(utf32 code_point);
00354
00355
00370         void    setMaxTextLength(size_t max_len);
00371
00372
00383         void    setNormalTextColour(const colour& col);
00384
00385
00394         void    setSelectedTextColour(const colour& col);
00395
00396
00408         void    setNormalSelectBrushColour(const colour& col);
00409
00410
00422         void    setInactiveSelectBrushColour(const colour& col);
00423
00424
00425         /*************************************************************************
00426                 Construction / Destruction
00427         *************************************************************************/
00432         Editbox(const String& type, const String& name);
00433
00434
00439         virtual ~Editbox(void);
00440
00441
00442 protected:
00443         /*************************************************************************
00444                 Implementation functions
00445         *************************************************************************/
00450         void    addEditboxEvents(void);
00451
00452
00463         virtual size_t  getTextIndexFromPosition(const Point& pt) const         = 0;
00464
00465
00470         void    clearSelection(void);
00471
00472
00480         void    eraseSelectedText(bool modify_text = true);
00481
00482
00487         bool    isStringValid(const String& str) const;
00488
00489
00490
00495         void    handleBackspace(void);
00496
00497
00502         void    handleDelete(void);
00503
00504
00509         void    handleCharLeft(uint sysKeys);
00510
00511
00516         void    handleWordLeft(uint sysKeys);
00517
00518
00523         void    handleCharRight(uint sysKeys);
00524
00525
00530         void    handleWordRight(uint sysKeys);
00531
00532
00537         void    handleHome(uint sysKeys);
00538
00539
00544         void    handleEnd(uint sysKeys);
00545
00546
00557         virtual bool    testClassName_impl(const String& class_name) const
00558         {
00559                 if (class_name==(const utf8*)"Editbox") return true;
00560                 return Window::testClassName_impl(class_name);
00561         }
00562
00563
00564         /*************************************************************************
00565                 New event handlers
00566         *************************************************************************/
00571         virtual void    onReadOnlyChanged(WindowEventArgs& e);
00572
00573
00578         virtual void    onMaskedRenderingModeChanged(WindowEventArgs& e);
00579
00580
00585         virtual void    onMaskCodePointChanged(WindowEventArgs& e);
00586
00587
00592         virtual void    onValidationStringChanged(WindowEventArgs& e);
00593
00594
00599         virtual void    onMaximumTextLengthChanged(WindowEventArgs& e);
00600
00601
00609         virtual void    onTextInvalidatedEvent(WindowEventArgs& e);
00610
00611
00617         virtual void    onInvalidEntryAttempted(WindowEventArgs& e);
00618
00619
00624         virtual void    onCaratMoved(WindowEventArgs& e);
00625
00626
00631         virtual void    onTextSelectionChanged(WindowEventArgs& e);
00632
00633
00638         virtual void    onEditboxFullEvent(WindowEventArgs& e);
00639
00640
00645         virtual void    onTextAcceptedEvent(WindowEventArgs& e);
00646
00647
00648         /*************************************************************************
00649                 Overridden event handlers
00650         *************************************************************************/
00651         virtual void    onMouseButtonDown(MouseEventArgs& e);
00652         virtual void    onMouseButtonUp(MouseEventArgs& e);
00653         virtual void    onMouseDoubleClicked(MouseEventArgs& e);
00654         virtual void    onMouseTripleClicked(MouseEventArgs& e);
00655         virtual void    onMouseMove(MouseEventArgs& e);
00656         virtual void    onCaptureLost(WindowEventArgs& e);
00657         virtual void    onCharacter(KeyEventArgs& e);
00658         virtual void    onKeyDown(KeyEventArgs& e);
00659         virtual void    onTextChanged(WindowEventArgs& e);
00660
00661
00662         /*************************************************************************
00663                 Implementation data
00664         *************************************************************************/
00665         bool    d_readOnly;
00666         bool    d_maskText;
00667         utf32   d_maskCodePoint;
00668         size_t  d_maxTextLen;
00669         size_t  d_caratPos;
00670         size_t  d_selectionStart;
00671         size_t  d_selectionEnd;
00672         String  d_validationString;
00673         RegexValidator* d_validator;
00674         bool    d_dragging;
00675         size_t  d_dragAnchorIdx;
00676
00677         // basic rendering colours
00678         colour  d_normalTextColour;
00679         colour  d_selectTextColour;
00680         colour  d_selectBrushColour;
00681         colour  d_inactiveSelectBrushColour;
00682
00683
00684 private:
00685         /*************************************************************************
00686                 Static Properties for this class
00687         *************************************************************************/
00688         static EditboxProperties::ReadOnly                                      d_readOnlyProperty;
00689         static EditboxProperties::MaskText                                      d_maskTextProperty;
00690         static EditboxProperties::MaskCodepoint                         d_maskCodepointProperty;
00691         static EditboxProperties::ValidationString                      d_validationStringProperty;
00692         static EditboxProperties::CaratIndex                            d_caratIndexProperty;
00693         static EditboxProperties::SelectionStart                        d_selectionStartProperty;
00694         static EditboxProperties::SelectionLength                       d_selectionLengthProperty;
00695         static EditboxProperties::MaxTextLength                         d_maxTextLengthProperty;
00696         static EditboxProperties::NormalTextColour                      d_normalTextColourProperty;
00697         static EditboxProperties::SelectedTextColour            d_selectedTextColourProperty;
00698         static EditboxProperties::ActiveSelectionColour         d_activeSelectionColourProperty;
00699         static EditboxProperties::InactiveSelectionColour       d_inactiveSelectionColourProperty;
00700
00701
00702         /*************************************************************************
00703                 Private methods
00704         *************************************************************************/
00705         void    addEditboxProperties(void);
00706 };
00707
00708 } // End of  CEGUI namespace section
00709
00710
00711 #if defined(_MSC_VER)
00712 #       pragma warning(pop)
00713 #endif
00714
00715 #endif  // end of guard _CEGUIEditbox_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIEditboxProperties.h Source File

include » elements

CEGUIEditboxProperties.h

00001 /************************************************************************
00002         filename:       CEGUIEditboxProperties.h
00003         created:        9/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to Properties for Editbox class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIEditboxProperties_h_
00027 #define _CEGUIEditboxProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of EditboxProperties namespace section
00041 namespace EditboxProperties
00042 {
00057 class ReadOnly : public Property
00058 {
00059 public:
00060         ReadOnly() : Property(
00061                 "ReadOnly",
00062                 "Property to get/set the read-only setting for the Editbox.  Value is either \"True\" or \"False\".",
00063                 "False")
00064         {}
00065
00066         String  get(const PropertyReceiver* receiver) const;
00067         void    set(PropertyReceiver* receiver, const String& value);
00068 };
00069
00070
00085 class MaskText : public Property
00086 {
00087 public:
00088         MaskText() : Property(
00089                 "MaskText",
00090                 "Property to get/set the mask text setting for the Editbox.  Value is either \"True\" or \"False\".",
00091                 "False")
00092         {}
00093
00094         String  get(const PropertyReceiver* receiver) const;
00095         void    set(PropertyReceiver* receiver, const String& value);
00096 };
00097
00098
00112 class MaskCodepoint : public Property
00113 {
00114 public:
00115         MaskCodepoint() : Property(
00116                 "MaskCodepoint",
00117                 "Property to get/set the utf32 codepoint value used for masking text.  Value is \"[uint]\".",
00118                 "42")
00119         {}
00120
00121         String  get(const PropertyReceiver* receiver) const;
00122         void    set(PropertyReceiver* receiver, const String& value);
00123 };
00124
00125
00137 class ValidationString : public Property
00138 {
00139 public:
00140         ValidationString() : Property(
00141                 "ValidationString",
00142                 "Property to get/set the validation string Editbox.  Value is a text string.",
00143                 ".*")
00144         {}
00145
00146         String  get(const PropertyReceiver* receiver) const;
00147         void    set(PropertyReceiver* receiver, const String& value);
00148 };
00149
00150
00162 class CaratIndex : public Property
00163 {
00164 public:
00165         CaratIndex() : Property(
00166                 "CaratIndex",
00167                 "Property to get/set the current carat index.  Value is \"[uint]\".",
00168                 "0")
00169         {}
00170
00171         String  get(const PropertyReceiver* receiver) const;
00172         void    set(PropertyReceiver* receiver, const String& value);
00173 };
00174
00175
00187 class SelectionStart : public Property
00188 {
00189 public:
00190         SelectionStart() : Property(
00191                 "SelectionStart",
00192                 "Property to get/set the zero based index of the selection start position within the text.  Value is \"[uint]\".",
00193                 "0")
00194         {}
00195
00196         String  get(const PropertyReceiver* receiver) const;
00197         void    set(PropertyReceiver* receiver, const String& value);
00198 };
00199
00200
00212 class SelectionLength : public Property
00213 {
00214 public:
00215         SelectionLength() : Property(
00216                 "SelectionLength",
00217                 "Property to get/set the length of the selection (as a count of the number of code points selected).  Value is \"[uint]\".",
00218                 "0")
00219         {}
00220
00221         String  get(const PropertyReceiver* receiver) const;
00222         void    set(PropertyReceiver* receiver, const String& value);
00223 };
00224
00225
00237 class MaxTextLength : public Property
00238 {
00239 public:
00240         MaxTextLength() : Property(
00241                 "MaxTextLength",
00242                 "Property to get/set the the maximum allowed text length (as a count of code points).  Value is \"[uint]\".",
00243                 "1073741824")
00244         {}
00245
00246         String  get(const PropertyReceiver* receiver) const;
00247         void    set(PropertyReceiver* receiver, const String& value);
00248 };
00249
00250
00262 class NormalTextColour : public Property
00263 {
00264 public:
00265         NormalTextColour() : Property(
00266                 "NormalTextColour",
00267                 "Property to get/set the normal, unselected, text colour used for rendering text.  Value is \"aarrggbb\" (hex).",
00268                 "FFFFFFFF")
00269         {}
00270
00271         String  get(const PropertyReceiver* receiver) const;
00272         void    set(PropertyReceiver* receiver, const String& value);
00273 };
00274
00275
00287 class SelectedTextColour : public Property
00288 {
00289 public:
00290         SelectedTextColour() : Property(
00291                 "SelectedTextColour",
00292                 "Property to get/set the colour used for rendering text within the selection area.  Value is \"aarrggbb\" (hex).",
00293                 "FF000000")
00294         {}
00295
00296         String  get(const PropertyReceiver* receiver) const;
00297         void    set(PropertyReceiver* receiver, const String& value);
00298 };
00299
00300
00312 class ActiveSelectionColour : public Property
00313 {
00314 public:
00315         ActiveSelectionColour() : Property(
00316                 "ActiveSelectionColour",
00317                 "Property to get/set the colour used for rendering the selection highlight when the edit box is active.  Value is \"aarrggbb\" (hex).",
00318                 "FF6060FF")
00319         {}
00320
00321         String  get(const PropertyReceiver* receiver) const;
00322         void    set(PropertyReceiver* receiver, const String& value);
00323 };
00324
00325
00337 class InactiveSelectionColour : public Property
00338 {
00339 public:
00340         InactiveSelectionColour() : Property(
00341                 "InactiveSelectionColour",
00342                 "Property to get/set the colour used for rendering the selection highlight when the edit box is inactive.  Value is \"aarrggbb\" (hex).",
00343                 "FF808080")
00344         {}
00345
00346         String  get(const PropertyReceiver* receiver) const;
00347         void    set(PropertyReceiver* receiver, const String& value);
00348 };
00349
00350 } // End of  EditboxProperties namespace section
00351
00352 } // End of  CEGUI namespace section
00353
00354
00355 #endif  // end of guard _CEGUIEditboxProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIEvent.h Source File

include

CEGUIEvent.h

00001 /************************************************************************
00002         filename: CEGUIEvent.h
00003         created:  15/10/2004
00004         authors:  Paul D Turner (High-level design)
00005             Gerald Lindsly (Coder)
00006
00007         purpose:  Defines interface for Event class
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIEvent_h_
00028 #define _CEGUIEvent_h_
00029
00030 #if defined (_MSC_VER)
00031 #       pragma warning(push)
00032 #       pragma warning(disable : 4786)
00033 #       pragma warning(disable : 4251)
00034 #       if !defined (_MSC_EXTENSIONS)
00035 #               pragma warning (disable : 4224)
00036 #       endif
00037 #endif
00038
00039 #include "CEGUIBase.h"
00040 #include "CEGUIString.h"
00041 #include "CEGUIEventArgs.h"
00042 #include "CEGUIRefPtr.h"
00043
00044 #include <map>
00045
00046
00047 // Start of CEGUI namespace section
00048 namespace CEGUI
00049 {
00050
00056 template <typename Ret, typename Args>
00057 class SubscriberInterface {
00058 public:
00059   virtual Ret operator()(Args) const = 0;
00060   virtual ~SubscriberInterface() {}
00061 };
00062
00063
00068 template <typename Ret, typename Args>
00069 class _freeBinder : public SubscriberInterface<Ret,Args>
00070 {
00071 public:
00072   virtual Ret operator()(Args args) const
00073   {
00074     return d_f(args);
00075   }
00076   typedef Ret (*SlotFunction)(Args);
00077   _freeBinder(SlotFunction f) : d_f(f) {}
00078 protected:
00079   SlotFunction d_f;
00080 };
00081
00082
00087 template <class Functor, typename Ret, typename Args>
00088 class _functorBinder : public SubscriberInterface<Ret,Args>
00089 {
00090 public:
00091   virtual Ret operator()(Args args) const
00092   {
00093     return d_f(args);
00094   }
00095   _functorBinder(const Functor& f) : d_f(f) {}
00096 protected:
00097   Functor d_f;
00098 };
00099
00100
00105 template <class T, typename Ret, typename Args>
00106 class _memberBinder : public SubscriberInterface<Ret,Args>
00107 {
00108   typedef Ret (T::*F)(Args);
00109 public:
00110   virtual Ret operator()(Args args) const
00111   {
00112     return (d_t->*d_f)(args);
00113   }
00114   _memberBinder(F f, T* t) : d_f(f), d_t(t) {}
00115 protected:
00116   F  d_f;
00117   T* d_t;
00118 };
00119
00120
00127 template <typename Ret, typename Args>
00128 class SubscriberTemplate
00129 {
00130 public:
00131   Ret operator()(Args args) const
00132   {
00133     return (*d_si)(args);  // call the bound function
00134   }
00135
00136   typedef Ret (*SlotFunction)(Args);
00137
00139   SubscriberTemplate(SlotFunction f)
00140   {
00141     d_si = new _freeBinder<Ret,Args>(f);
00142   }
00143
00145   template <class T>
00146   SubscriberTemplate(Ret (T::*f)(Args), T* target)
00147   {
00148     d_si = new _memberBinder<T,Ret,Args>(f, target);
00149   }
00150
00152   template <typename Functor>
00153   SubscriberTemplate(const Functor& f)
00154   {
00155     d_si = new _functorBinder<Functor,Ret,Args>(f);
00156   }
00157
00163   SubscriberTemplate(SubscriberInterface<Ret,Args>* si) : d_si(si) {}
00164
00166   SubscriberTemplate(const SubscriberTemplate<Ret,Args>& copy) : d_si(copy.d_si) {}
00167
00169   bool operator<(const SubscriberTemplate<Ret,Args>& rhs) const { return d_si < rhs.d_si; }
00170
00172   void release() const
00173   {
00174     delete d_si;
00175   }
00176
00177 protected:
00178   SubscriberInterface<Ret,Args>* d_si;
00179 };
00180
00181
00188 template <class Functor, typename Ret, typename Args>
00189 class _refBinder : public SubscriberInterface<Ret,Args>
00190 {
00191 public:
00192   virtual Ret operator()(Args args) const
00193   {
00194     return d_f(args);
00195   }
00196   _refBinder(const Functor& f) : d_f(f) {}
00197 protected:
00198   const Functor& d_f;
00199 };
00200
00205 template <class Functor>
00206 SubscriberInterface<bool, const EventArgs&>*
00207 SubscriberRef(const Functor& f)
00208 {
00209   return new _refBinder<Functor,bool,const EventArgs&>(f);
00210 }
00211
00212
00224 class CEGUIEXPORT Event
00225 {
00226 public:
00231         class ConnectionInterface : public Referenced {
00232         public:
00233                 virtual bool connected() { return false; }
00234                 virtual void disconnect() {}
00235         };
00236         typedef RefPtr<ConnectionInterface> Connection;
00237
00243         class ScopedConnection {
00244         public:
00245                 ScopedConnection(Connection conn_) : conn(conn_) {}
00246                 ~ScopedConnection() { conn->disconnect(); }
00247                 Connection conn;
00248         };
00249
00250
00251         typedef SubscriberTemplate<bool, const EventArgs&> Subscriber;
00252         typedef int Group;
00253
00254         /*************************************************************************
00255                 Construction and Destruction
00256         *************************************************************************/
00261         Event(const String& name);
00262
00267         virtual ~Event(void);
00268
00269
00277         const String& getName(void) const       {return d_name;}
00278
00279
00290         Connection subscribe(Subscriber subscriber) { return subscribe(0, subscriber); }
00291
00292
00307         Connection subscribe(Group group, Subscriber subscriber);
00308
00309
00310         /*
00311         \brief
00312                 Fires the event.  All event subscribers get called in the appropriate sequence.
00313
00314         \param args
00315                 An object derived from EventArgs to be passed to each event subscriber.
00316
00317         \return
00318                 Nothing.
00319         */
00320         void    operator()(EventArgs& args);
00321
00322 private:
00323         /*************************************************************************
00324                 Copy constructor and assignment are not allowed for events
00325         *************************************************************************/
00326         Event(const Event& evt) {}
00327         Event& operator=(const Event& evt)      {return *this;}
00328
00329         /*
00330         \brief
00331                 removes the subscriber from the event.
00332
00333         \param subscriber
00334                 A pointer to a SubscriberInterface which is to be removed from the event.
00335
00336         \return
00337                 - true, if the subscriber was registered with the event in the specified group and it was removed.
00338                 - false, if not.
00339         */
00340         bool unsubscribe(Subscriber subscriber, Group group=0);
00341
00342         class GroupSubscriber {
00343         public:
00344                 Group group;
00345                 Subscriber subscriber;
00346                 GroupSubscriber(Group group_, Subscriber subscriber_)
00347                         : group(group_), subscriber(subscriber_) {}
00348         };
00349
00350         struct ltGroupSubscriber
00351         {
00352                 bool operator()(const GroupSubscriber& gs1, const GroupSubscriber& gs2) const
00353                 {
00354                         return gs1.group <  gs2.group ||
00355                                 gs1.group == gs2.group && gs1.subscriber < gs2.subscriber;
00356                 }
00357         };
00358         typedef std::map<GroupSubscriber, Connection, ltGroupSubscriber> ConnectionOrdering;
00359
00360
00361         /*************************************************************************
00362                 Implementation Data
00363         *************************************************************************/
00364         const String    d_name;
00365         ConnectionOrdering connectionOrdering;
00366         friend class ConnectionImpl;
00367 };
00368
00369
00370 } // End of  CEGUI namespace section
00371
00372 #if defined(_MSC_VER)
00373 #       pragma warning(pop)
00374 #endif
00375
00376 #endif  // end of guard _CEGUIEvent_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIEventArgs.h Source File

include

CEGUIEventArgs.h

00001 /************************************************************************
00002         filename:       CEGUIEventArgs.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines base EventArgs class used with event signalling
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIEventArgs_h_
00027 #define _CEGUIEventArgs_h_
00028
00029 #include "CEGUIBase.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00048 class CEGUIEXPORT EventArgs
00049 {
00050 public:
00051         /*************************************************************************
00052                 Construction
00053         *************************************************************************/
00054         EventArgs(void) : handled(false) {}
00055         virtual ~EventArgs(void) {}
00056
00057
00058         /*************************************************************************
00059                 Data members
00060         *************************************************************************/
00061         bool    handled;
00062 };
00063
00064 } // End of  CEGUI namespace section
00065
00066 #endif  // end of guard _CEGUIEventArgs_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIEventSet.h Source File

include

CEGUIEventSet.h

00001 /************************************************************************
00002         filename:       CEGUIEventSet.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines class for a named collection of Event objects
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIEventSet_h_
00027 #define _CEGUIEventSet_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIEvent.h"
00032 #include "CEGUIIteratorBase.h"
00033 #include <map>
00034
00035 #if defined (_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00051 class CEGUIEXPORT EventSet
00052 {
00053 public:
00058         EventSet();
00059
00060
00065         virtual ~EventSet(void);
00066
00067
00080         void    addEvent(const String& name);
00081
00082
00093         void    removeEvent(const String& name);
00094
00095
00103         void    removeAllEvents(void);
00104
00105
00113         bool    isEventPresent(const String& name);
00114
00115
00131         virtual Event::Connection       subscribeEvent(const String& name, Event::Subscriber subscriber);
00132
00133
00152         virtual Event::Connection       subscribeEvent(const String& name, Event::Group group, Event::Subscriber subscriber);
00153
00154
00170         virtual Event::Connection       subscribeScriptedEvent(const String& name, const String& subscriber_name);
00171
00172
00191         virtual Event::Connection       subscribeScriptedEvent(const String& name, Event::Group group, const String& subscriber_name);
00192
00193
00213         virtual void    fireEvent(const String& name, EventArgs& args, const String& eventNamespace = "");
00214
00215
00224         bool    isMuted(void) const;
00225
00226
00238         void    setMutedState(bool setting);
00239
00240
00241 protected:
00242         // Do not allow copying, assignment, or any other usage than simple creation.
00243         EventSet(EventSet& e) {}
00244         EventSet& operator=(EventSet& e) {return *this;}
00245
00246         typedef std::map<String, Event*>        EventMap;
00247         EventMap        d_events;
00248
00249         bool    d_muted;
00250
00251 public:
00252         /*************************************************************************
00253                 Iterator stuff
00254         *************************************************************************/
00255         typedef ConstBaseIterator<EventMap>     EventIterator;
00256
00261         EventIterator   getIterator(void) const;
00262 };
00263
00264 } // End of  CEGUI namespace section
00265
00266
00267 #if defined(_MSC_VER)
00268 #       pragma warning(pop)
00269 #endif
00270
00271 #endif  // end of guard _CEGUIEventSet_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIExceptions.h Source File

include

CEGUIExceptions.h

00001 /************************************************************************
00002         filename:       CEGUIExceptions.h
00003         created:        20/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines exceptions used within the system
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIExceptions_h_
00027 #define _CEGUIExceptions_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00040 class  CEGUIEXPORT Exception
00041 {
00042 public:
00043         /*************************************************************************
00044                 Construction and Destruction
00045         *************************************************************************/
00046         Exception(const String& message);
00047         virtual ~Exception(void);
00048
00056         const String&   getMessage(void) const          {return d_message;}
00057
00058
00059 protected:
00060         String  d_message;
00061 };
00062
00067 class CEGUIEXPORT GenericException : public Exception
00068 {
00069 public:
00070         /*************************************************************************
00071                 Construction and Destruction
00072         *************************************************************************/
00073         GenericException(const String& message) : Exception(message) {}
00074 };
00075
00080 class CEGUIEXPORT UnknownObjectException : public Exception
00081 {
00082 public:
00083         /*************************************************************************
00084                 Construction and Destruction
00085         *************************************************************************/
00086         UnknownObjectException(const String& message) : Exception(message) {}
00087 };
00088
00093 class CEGUIEXPORT InvalidRequestException : public Exception
00094 {
00095 public:
00096         /*************************************************************************
00097                 Construction and Destruction
00098         *************************************************************************/
00099         InvalidRequestException(const String& message) : Exception(message) {}
00100 };
00101
00106 class CEGUIEXPORT FileIOException : public Exception
00107 {
00108 public:
00109         /*************************************************************************
00110                 Construction and Destruction
00111         *************************************************************************/
00112         FileIOException(const String& message) : Exception(message) {}
00113 };
00114
00119 class CEGUIEXPORT RendererException : public Exception
00120 {
00121 public:
00122         /*************************************************************************
00123                 Construction and Destruction
00124         *************************************************************************/
00125         RendererException(const String& message) : Exception(message) {}
00126 };
00127
00132 class CEGUIEXPORT AlreadyExistsException : public Exception
00133 {
00134 public:
00135         /*************************************************************************
00136                 Construction and Destruction
00137         *************************************************************************/
00138         AlreadyExistsException(const String& message) : Exception(message) {}
00139 };
00140
00145 class CEGUIEXPORT MemoryException : public Exception
00146 {
00147 public:
00148         /*************************************************************************
00149                 Construction and Destruction
00150         *************************************************************************/
00151         MemoryException(const String& message) : Exception(message) {}
00152 };
00153
00158 class CEGUIEXPORT NullObjectException : public Exception
00159 {
00160 public:
00161         /*************************************************************************
00162                 Construction and Destruction
00163         *************************************************************************/
00164         NullObjectException(const String& message) : Exception(message) {}
00165 };
00166
00171 class CEGUIEXPORT ObjectInUseException : public Exception
00172 {
00173 public:
00174         /*************************************************************************
00175                 Construction and Destruction
00176         *************************************************************************/
00177         ObjectInUseException(const String& message) : Exception(message) {}
00178 };
00179
00180
00181 } // End of  CEGUI namespace section
00182
00183
00184 #endif  // end of guard _CEGUIExceptions_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFactoryModule.h Source File

include

CEGUIFactoryModule.h

00001 /************************************************************************
00002         filename:       CEGUIFactoryModule.h
00003         created:        12/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for object that controls a loadable
00007                                 module (.dll/.so/ whatever) that contains concrete
00008                                 window / widget implementations and their factories.
00009 *************************************************************************/
00010 /*************************************************************************
00011     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00012     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00013
00014     This library is free software; you can redistribute it and/or
00015     modify it under the terms of the GNU Lesser General Public
00016     License as published by the Free Software Foundation; either
00017     version 2.1 of the License, or (at your option) any later version.
00018
00019     This library is distributed in the hope that it will be useful,
00020     but WITHOUT ANY WARRANTY; without even the implied warranty of
00021     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00022     Lesser General Public License for more details.
00023
00024     You should have received a copy of the GNU Lesser General Public
00025     License along with this library; if not, write to the Free Software
00026     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00027 *************************************************************************/
00028 #ifndef _CEGUIFactoryModule_h_
00029 #define _CEGUIFactoryModule_h_
00030
00031 /*************************************************************************
00032         The following is basically taken from DynLib.h, which is part of
00033         the Ogre project (http://www.ogre3d.org/)
00034 *************************************************************************/
00035 #if defined(__WIN32__) || defined(_WIN32)
00036 #    define DYNLIB_HANDLE hInstance
00037 #    define DYNLIB_LOAD( a ) LoadLibrary( a )
00038 #    define DYNLIB_GETSYM( a, b ) GetProcAddress( a, b )
00039 #    define DYNLIB_UNLOAD( a ) !FreeLibrary( a )
00040 #    define DYNLIB_ERROR( )  "Unknown Error"
00041
00042         struct HINSTANCE__;
00043         typedef struct HINSTANCE__* hInstance;
00044
00045 #elif defined(__linux__)
00046 #    define DYNLIB_HANDLE void*
00047 #    define DYNLIB_LOAD( a ) dlopen( a, RTLD_LAZY )
00048 #    define DYNLIB_GETSYM( a, b ) dlsym( a, b )
00049 #    define DYNLIB_UNLOAD( a ) dlclose( a )
00050 #    define DYNLIB_ERROR( ) dlerror( )
00051
00052 #elif defined(__APPLE_CC__)
00053 #    define DYNLIB_HANDLE CFBundleRef
00054 #    define DYNLIB_LOAD( a ) mac_loadExeBundle( a )
00055 #    define DYNLIB_GETSYM( a, b ) mac_getBundleSym( a, b )
00056 #    define DYNLIB_UNLOAD( a ) mac_unloadExeBundle( a )
00057 #    define DYNLIB_ERROR( ) mac_errorBundle()
00058 #endif
00059
00060
00061 // Start of CEGUI namespace section
00062 namespace CEGUI
00063 {
00064
00069 class FactoryModule
00070 {
00071 public:
00082         FactoryModule(const String& filename);
00083
00084
00092         virtual ~FactoryModule(void);
00093
00094
00105         void    registerFactory(const String& type) const;
00106
00107
00115     uint registerAllFactories() const;
00116
00117 private:
00118         /*************************************************************************
00119                 Implementation Data
00120         *************************************************************************/
00121         static const char       RegisterFactoryFunctionName[];
00122     static const char   RegisterAllFunctionName[];
00123
00124         typedef void (*FactoryRegisterFunction)(const String&);
00125     typedef uint (*RegisterAllFunction)(void);
00126
00127         FactoryRegisterFunction d_regFunc;
00128     RegisterAllFunction d_regAllFunc;
00129         String                  d_moduleName;
00130         DYNLIB_HANDLE   d_handle;
00131 };
00132
00133 } // End of  CEGUI namespace section
00134
00135
00136 #endif  // end of guard _CEGUIFactoryModule_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalagard_xmlHandler.h Source File

include » falagard

CEGUIFalagard_xmlHandler.h

00001 /************************************************************************
00002     filename:   CEGUIFalagard_xmlHandler.h
00003     created:    Fri Jun 17 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalagard_xmlHandler_h_
00025 #define _CEGUIFalagard_xmlHandler_h_
00026
00027 #include "CEGUIXMLHandler.h"
00028 #include "CEGUIcolour.h"
00029 #include "falagard/CEGUIFalDimensions.h"
00030 #include "CEGUIWindow.h"
00031 #include <vector>
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00036     // forward refs
00037     class WidgetLookManager;
00038     class WidgetLookFeel;
00039     class WidgetComponent;
00040     class ImagerySection;
00041     class StateImagery;
00042     class LayerSpecification;
00043     class SectionSpecification;
00044     class ImageryComponent;
00045     class ComponentArea;
00046     class Dimension;
00047     class TextComponent;
00048     class NamedArea;
00049     class FrameComponent;
00050
00055     class Falagard_xmlHandler : public XMLHandler
00056     {
00057     public:
00062         Falagard_xmlHandler(WidgetLookManager* mgr);
00063
00068         ~Falagard_xmlHandler();
00069
00070         /*************************************************************************
00071             XMLHandler base class overrides
00072         *************************************************************************/
00073         void elementStart(const String& element, const XMLAttributes& attributes);
00074         void elementEnd(const String& element);
00075
00076     private:
00077         /*************************************************************************
00078             Implementation Constants
00079         *************************************************************************/
00080         // element names
00081         static const String FalagardElement;
00082         static const String WidgetLookElement;
00083         static const String ChildElement;
00084         static const String ImagerySectionElement;
00085         static const String StateImageryElement;
00086         static const String LayerElement;
00087         static const String SectionElement;
00088         static const String ImageryComponentElement;
00089         static const String TextComponentElement;
00090         static const String FrameComponentElement;
00091         static const String AreaElement;
00092         static const String ImageElement;
00093         static const String ColoursElement;
00094         static const String VertFormatElement;
00095         static const String HorzFormatElement;
00096         static const String VertAlignmentElement;
00097         static const String HorzAlignmentElement;
00098         static const String PropertyElement;
00099                 static const String DimElement;
00100                 static const String UnifiedDimElement;
00101         static const String AbsoluteDimElement;
00102         static const String ImageDimElement;
00103         static const String WidgetDimElement;
00104         static const String FontDimElement;
00105         static const String PropertyDimElement;
00106         static const String TextElement;
00107         static const String ColourPropertyElement;
00108         static const String ColourRectPropertyElement;
00109         static const String NamedAreaElement;
00110         static const String PropertyDefinitionElement;
00111         static const String DimOperatorElement;
00112         static const String VertFormatPropertyElement;
00113         static const String HorzFormatPropertyElement;
00114         static const String AreaPropertyElement;
00115         static const String ImagePropertyElement;
00116         // attribute names
00117         static const String TopLeftAttribute;
00118         static const String TopRightAttribute;
00119         static const String BottomLeftAttribute;
00120         static const String BottomRightAttribute;
00121         static const String ImagesetAttribute;
00122         static const String ImageAttribute;
00123         static const String TypeAttribute;
00124         static const String NameAttribute;
00125         static const String PriorityAttribute;
00126         static const String SectionNameAttribute;
00127         static const String NameSuffixAttribute;
00128         static const String LookAttribute;
00129         static const String ScaleAttribute;
00130         static const String OffsetAttribute;
00131         static const String ValueAttribute;
00132         static const String DimensionAttribute;
00133         static const String WidgetAttribute;
00134         static const String StringAttribute;
00135         static const String FontAttribute;
00136         static const String InitialValueAttribute;
00137         static const String ClippedAttribute;
00138         static const String OperatorAttribute;
00139         static const String PaddingAttribute;
00140         static const String LayoutOnWriteAttribute;
00141         static const String RedrawOnWriteAttribute;
00142
00143         /*************************************************************************
00144             helper methods
00145         **************************************************************************/
00146         static argb_t hexStringToARGB(const String& str);
00147
00148         /*************************************************************************
00149             implementation methods
00150         **************************************************************************/
00151         void assignAreaDimension(Dimension& dim);
00152
00153         void doBaseDimStart(const BaseDim* dim);
00154         void doBaseDimEnd();
00155
00156         /*************************************************************************
00157             Implementation Data
00158         *************************************************************************/
00159         WidgetLookManager* d_manager;
00160
00161         // these hold pointers to various objects under construction.
00162         WidgetLookFeel*     d_widgetlook;
00163         WidgetComponent*    d_childcomponent;
00164         ImagerySection*     d_imagerysection;
00165         StateImagery*       d_stateimagery;
00166         LayerSpecification* d_layer;
00167         SectionSpecification* d_section;
00168         ImageryComponent*   d_imagerycomponent;
00169         ComponentArea*   d_area;
00170         Dimension       d_dimension;
00171         TextComponent*  d_textcomponent;
00172         NamedArea*      d_namedArea;
00173         FrameComponent*  d_framecomponent;
00174
00175         std::vector<BaseDim*>    d_dimStack;
00176     };
00177
00178 } // End of  CEGUI namespace section
00179
00180
00181 #endif  // end of guard _CEGUIFalagard_xmlHandler_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalComponentBase.h Source File

include » falagard

CEGUIFalComponentBase.h

00001 /************************************************************************
00002     filename:   CEGUIFalComponentBase.h
00003     created:    Mon Jul 18 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalComponentBase_h_
00025 #define _CEGUIFalComponentBase_h_
00026
00027 #include "falagard/CEGUIFalDimensions.h"
00028 #include "CEGUIWindow.h"
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00037     class CEGUIEXPORT FalagardComponentBase
00038     {
00039     public:
00044         FalagardComponentBase();
00045
00050         virtual ~FalagardComponentBase();
00051
00070         void render(Window& srcWindow, float base_z, const CEGUI::ColourRect* modColours = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00071
00093         void render(Window& srcWindow, const Rect& baseRect, float base_z, const CEGUI::ColourRect* modColours = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00094
00102         const ComponentArea& getComponentArea() const;
00103
00114         void setComponentArea(const ComponentArea& area);
00115
00123         const ColourRect& getColours() const;
00124
00132         void setColours(const ColourRect& cols);
00133
00144         void setColoursPropertySource(const String& property);
00145
00157         void setColoursPropertyIsColourRect(bool setting = true);
00158
00169         void setVertFormattingPropertySource(const String& property);
00170
00181         void setHorzFormattingPropertySource(const String& property);
00182
00183     protected:
00193         void initColoursRect(const Window& wnd, const ColourRect* modCols, ColourRect& cr) const;
00194
00199         virtual void render_impl(Window& srcWindow, Rect& destRect, float base_z, const CEGUI::ColourRect* modColours, const Rect* clipper, bool clipToDisplay) const = 0;
00200
00212         bool writeColoursXML(OutStream& out_stream) const;
00213
00225         bool writeVertFormatXML(OutStream& out_stream) const;
00226
00238         bool writeHorzFormatXML(OutStream& out_stream) const;
00239
00240
00241         // data fields
00242         ComponentArea   d_area;
00243         ColourRect      d_colours;
00244         String          d_colourPropertyName;
00245         bool            d_colourProperyIsRect;
00246         String          d_vertFormatPropertyName;
00247         String          d_horzFormatPropertyName;
00248     };
00249 } // End of  CEGUI namespace section
00250
00251
00252 #endif  // end of guard _CEGUIFalComponentBase_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalDimensions.h Source File

include » falagard

CEGUIFalDimensions.h

00001 /************************************************************************
00002     filename:   CEGUIFalDimensions.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalDimensions_h_
00025 #define _CEGUIFalDimensions_h_
00026
00027 #include "falagard/CEGUIFalEnums.h"
00028 #include "CEGUIString.h"
00029 #include "CEGUIUDim.h"
00030
00031 // Start of CEGUI namespace section
00032 namespace CEGUI
00033 {
00038     class CEGUIEXPORT BaseDim
00039     {
00040     public:
00041         BaseDim();
00042
00043         virtual ~BaseDim();
00044
00056         float getValue(const Window& wnd) const;
00057
00075         float getValue(const Window& wnd, const Rect& container) const;
00076
00089         BaseDim* clone() const;
00090
00099         DimensionOperator getDimensionOperator() const;
00100
00112         void setDimensionOperator(DimensionOperator op);
00113
00121         const BaseDim* getOperand() const;
00122
00134         void setOperand(const BaseDim& operand);
00135
00146         void writeXMLToStream(OutStream& out_stream) const;
00147
00148     protected:
00154         virtual float getValue_impl(const Window& wnd) const = 0;
00155
00161         virtual float getValue_impl(const Window& wnd, const Rect& container) const = 0;
00162
00169         virtual BaseDim* clone_impl() const = 0;
00170
00177         virtual void writeXMLElementName_impl(OutStream& out_stream) const = 0;
00178
00185         virtual void writeXMLElementAttributes_impl(OutStream& out_stream) const = 0;
00186
00187     private:
00188         DimensionOperator   d_operator;
00189         BaseDim*            d_operand;
00190     };
00191
00192
00197     class CEGUIEXPORT AbsoluteDim : public BaseDim
00198     {
00199     public:
00207         AbsoluteDim(float val);
00208
00213         void setValue(float val);
00214
00215     protected:
00216         // Implementation of the base class interface
00217         float getValue_impl(const Window& wnd) const;
00218         float getValue_impl(const Window& wnd, const Rect& container) const;
00219         void writeXMLElementName_impl(OutStream& out_stream) const;
00220         void writeXMLElementAttributes_impl(OutStream& out_stream) const;
00221
00222         BaseDim* clone_impl() const;
00223
00224     private:
00225         float d_val;
00226     };
00227
00228
00233     class CEGUIEXPORT ImageDim : public BaseDim
00234     {
00235     public:
00250         ImageDim(const String& imageset, const String& image, DimensionType dim);
00251
00265         void setSourceImage(const String& imageset, const String& image);
00266
00278         void setSourceDimension(DimensionType dim);
00279
00280     protected:
00281         // Implementation of the base class interface
00282         float getValue_impl(const Window& wnd) const;
00283         float getValue_impl(const Window& wnd, const Rect& container) const;
00284         void writeXMLElementName_impl(OutStream& out_stream) const;
00285         void writeXMLElementAttributes_impl(OutStream& out_stream) const;
00286         BaseDim* clone_impl() const;
00287
00288     private:
00289         String d_imageset;
00290         String d_image;
00291         DimensionType d_what;
00292     };
00293
00294
00304     class CEGUIEXPORT WidgetDim : public BaseDim
00305     {
00306     public:
00318         WidgetDim(const String& name, DimensionType dim);
00319
00330         void setWidgetName(const String& name);
00331
00343         void setSourceDimension(DimensionType dim);
00344
00345     protected:
00346         // Implementation of the base class interface
00347         float getValue_impl(const Window& wnd) const;
00348         float getValue_impl(const Window& wnd, const Rect& container) const;
00349         void writeXMLElementName_impl(OutStream& out_stream) const;
00350         void writeXMLElementAttributes_impl(OutStream& out_stream) const;
00351         BaseDim* clone_impl() const;
00352
00353     private:
00354         String d_widgetName;
00355         DimensionType d_what;
00356     };
00357
00358
00363     class CEGUIEXPORT UnifiedDim : public BaseDim
00364     {
00365     public:
00378         UnifiedDim(const UDim& value, DimensionType dim);
00379
00380     protected:
00381         // Implementation of the base class interface
00382         float getValue_impl(const Window& wnd) const;
00383         float getValue_impl(const Window& wnd, const Rect& container) const;
00384         void writeXMLElementName_impl(OutStream& out_stream) const;
00385         void writeXMLElementAttributes_impl(OutStream& out_stream) const;
00386         BaseDim* clone_impl() const;
00387
00388     private:
00389         UDim d_value;
00390         DimensionType d_what;
00391     };
00392
00397     class CEGUIEXPORT FontDim : public BaseDim
00398     {
00399     public:
00422         FontDim(const String& name, const String& font, const String& text, FontMetricType metric, float padding = 0);
00423
00424     protected:
00425         // Implementation of the base class interface
00426         float getValue_impl(const Window& wnd) const;
00427         float getValue_impl(const Window& wnd, const Rect& container) const;
00428         void writeXMLElementName_impl(OutStream& out_stream) const;
00429         void writeXMLElementAttributes_impl(OutStream& out_stream) const;
00430         BaseDim* clone_impl() const;
00431
00432     private:
00433         String  d_font;
00434         String  d_text;
00435         String  d_childSuffix;
00436         FontMetricType d_metric;
00437         float   d_padding;
00438     };
00439
00444     class CEGUIEXPORT PropertyDim : public BaseDim
00445     {
00446     public:
00458         PropertyDim(const String& name, const String& property);
00459
00460     protected:
00461         // Implementation of the base class interface
00462         float getValue_impl(const Window& wnd) const;
00463         float getValue_impl(const Window& wnd, const Rect& container) const;
00464         void writeXMLElementName_impl(OutStream& out_stream) const;
00465         void writeXMLElementAttributes_impl(OutStream& out_stream) const;
00466         BaseDim* clone_impl() const;
00467
00468     private:
00469         String d_property;
00470         String  d_childSuffix;
00471     };
00472
00481     class CEGUIEXPORT Dimension
00482     {
00483     public:
00488         Dimension();
00489
00494         ~Dimension();
00495
00506         Dimension(const BaseDim& dim, DimensionType type);
00507
00512         Dimension(const Dimension& other);
00513
00518         Dimension& operator=(const Dimension& other);
00519
00527         const BaseDim& getBaseDimension() const;
00528
00539         void setBaseDimension(const BaseDim& dim);
00540
00548         DimensionType getDimensionType() const;
00549
00560         void setDimensionType(DimensionType type);
00561
00572         void writeXMLToStream(OutStream& out_stream) const;
00573
00574     private:
00575         BaseDim*        d_value;
00576         DimensionType   d_type;
00577     };
00578
00579
00589     class CEGUIEXPORT ComponentArea
00590     {
00591     public:
00603         Rect getPixelRect(const Window& wnd) const;
00604
00619         Rect getPixelRect(const Window& wnd, const Rect& container) const;
00620
00631         void writeXMLToStream(OutStream& out_stream) const;
00632
00641         bool isAreaFetchedFromProperty() const;
00642
00650         const String& getAreaPropertySource() const;
00651
00662         void setAreaPropertySource(const String& property);
00663
00664
00665         Dimension d_left;
00666         Dimension d_top;
00667         Dimension d_right_or_width;
00668         Dimension d_bottom_or_height;
00669
00670     private:
00671         String  d_areaProperty;
00672     };
00673
00674 } // End of  CEGUI namespace section
00675
00676
00677 #endif  // end of guard _CEGUIFalDimensions_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalEnums.h Source File

include » falagard

CEGUIFalEnums.h

00001 /************************************************************************
00002     filename:   CEGUIFalEnums.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalEnums_h_
00025 #define _CEGUIFalEnums_h_
00026
00027 // Start of CEGUI namespace section
00028 namespace CEGUI
00029 {
00034     enum DimensionType
00035     {
00036         DT_LEFT_EDGE,
00037         DT_X_POSITION,
00038         DT_TOP_EDGE,
00039         DT_Y_POSITION,
00040         DT_RIGHT_EDGE,
00041         DT_BOTTOM_EDGE,
00042         DT_WIDTH,
00043         DT_HEIGHT,
00044         DT_X_OFFSET,
00045         DT_Y_OFFSET,
00046         DT_INVALID
00047     };
00048
00053     enum VerticalFormatting
00054     {
00055         VF_TOP_ALIGNED,
00056         VF_CENTRE_ALIGNED,
00057         VF_BOTTOM_ALIGNED,
00058         VF_STRETCHED,
00059         VF_TILED
00060     };
00061
00066     enum HorizontalFormatting
00067     {
00068         HF_LEFT_ALIGNED,
00069         HF_CENTRE_ALIGNED,
00070         HF_RIGHT_ALIGNED,
00071         HF_STRETCHED,
00072         HF_TILED
00073     };
00074
00079     enum VerticalTextFormatting
00080     {
00081         VTF_TOP_ALIGNED,
00082         VTF_CENTRE_ALIGNED,
00083         VTF_BOTTOM_ALIGNED
00084     };
00085
00090     enum HorizontalTextFormatting
00091     {
00092         HTF_LEFT_ALIGNED,
00093         HTF_RIGHT_ALIGNED,
00094         HTF_CENTRE_ALIGNED,
00095         HTF_JUSTIFIED,
00096         HTF_WORDWRAP_LEFT_ALIGNED,
00097         HTF_WORDWRAP_RIGHT_ALIGNED,
00098         HTF_WORDWRAP_CENTRE_ALIGNED,
00099         HTF_WORDWRAP_JUSTIFIED
00100     };
00101
00106     enum FontMetricType
00107     {
00108         FMT_LINE_SPACING,
00109         FMT_BASELINE,
00110         FMT_HORZ_EXTENT
00111     };
00112
00117     enum DimensionOperator
00118     {
00119         DOP_NOOP,
00120         DOP_ADD,
00121         DOP_SUBTRACT,
00122         DOP_MULTIPLY,
00123         DOP_DIVIDE
00124     };
00125
00130     enum FrameImageComponent
00131     {
00132         FIC_BACKGROUND,
00133         FIC_TOP_LEFT_CORNER,
00134         FIC_TOP_RIGHT_CORNER,
00135         FIC_BOTTOM_LEFT_CORNER,
00136         FIC_BOTTOM_RIGHT_CORNER,
00137         FIC_LEFT_EDGE,
00138         FIC_RIGHT_EDGE,
00139         FIC_TOP_EDGE,
00140         FIC_BOTTOM_EDGE,
00141         FIC_FRAME_IMAGE_COUNT
00142     };
00143
00144 } // End of  CEGUI namespace section
00145
00146
00147 #endif  // end of guard _CEGUIFalEnums_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalFrameComponent.h Source File

include » falagard

CEGUIFalFrameComponent.h

00001 /************************************************************************
00002     filename:   CEGUIFalFrameComponent.h
00003     created:    Mon Jul 18 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalFrameComponent_h_
00025 #define _CEGUIFalFrameComponent_h_
00026
00027 #include "falagard/CEGUIFalComponentBase.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00040     class CEGUIEXPORT FrameComponent : public FalagardComponentBase
00041     {
00042     public:
00047         FrameComponent();
00048
00056         VerticalFormatting getBackgroundVerticalFormatting() const;
00057
00068         void setBackgroundVerticalFormatting(VerticalFormatting fmt);
00069
00077         HorizontalFormatting getBackgroundHorizontalFormatting() const;
00078
00089         void setBackgroundHorizontalFormatting(HorizontalFormatting fmt);
00090
00101         const Image* getImage(FrameImageComponent part) const;
00102
00116         void setImage(FrameImageComponent part, const Image* image);
00117
00134         void setImage(FrameImageComponent part, const String& imageset, const String& image);
00135
00146         void writeXMLToStream(OutStream& out_stream) const;
00147
00148     protected:
00149         // implemets abstract from base
00150         void render_impl(Window& srcWindow, Rect& destRect, float base_z, const CEGUI::ColourRect* modColours, const Rect* clipper, bool clipToDisplay) const;
00151
00152         // renders the background image (basically a clone of render_impl from ImageryComponent - maybe we need a helper class?)
00153         void doBackgroundRender(Window& srcWindow, Rect& destRect, float base_z, const ColourRect& colours, const Rect* clipper, bool clipToDisplay) const;
00154
00155         // formatting options for background
00156         VerticalFormatting   d_vertFormatting;
00157         HorizontalFormatting d_horzFormatting;
00158         // images for the frame
00159         const Image* d_frameImages[FIC_FRAME_IMAGE_COUNT];
00160     };
00161
00162 } // End of  CEGUI namespace section
00163
00164
00165 #endif  // end of guard _CEGUIFalFrameComponent_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalImageryComponent.h Source File

include » falagard

CEGUIFalImageryComponent.h

00001 /************************************************************************
00002     filename:   CEGUIFalImageryComponent.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalImageryComponent_h_
00025 #define _CEGUIFalImageryComponent_h_
00026
00027 #include "falagard/CEGUIFalComponentBase.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00036     class CEGUIEXPORT ImageryComponent : public FalagardComponentBase
00037     {
00038     public:
00043         ImageryComponent();
00044
00052         const Image* getImage() const;
00053
00064         void setImage(const Image* image);
00065
00079         void setImage(const String& imageset, const String& image);
00080
00088         VerticalFormatting getVerticalFormatting() const;
00089
00100         void setVerticalFormatting(VerticalFormatting fmt);
00101
00109         HorizontalFormatting getHorizontalFormatting() const;
00110
00121         void setHorizontalFormatting(HorizontalFormatting fmt);
00122
00133         void writeXMLToStream(OutStream& out_stream) const;
00134
00143         bool isImageFetchedFromProperty() const;
00144
00152         const String& getImagePropertySource() const;
00153
00164         void setImagePropertySource(const String& property);
00165
00166     protected:
00167         // implemets abstract from base
00168         void render_impl(Window& srcWindow, Rect& destRect, float base_z, const CEGUI::ColourRect* modColours, const Rect* clipper, bool clipToDisplay) const;
00169
00170         const Image*         d_image;
00171         VerticalFormatting   d_vertFormatting;
00172         HorizontalFormatting d_horzFormatting;
00173         String  d_imagePropertyName;
00174     };
00175
00176 } // End of  CEGUI namespace section
00177
00178
00179 #endif  // end of guard _CEGUIFalImageryComponent_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalImagerySection.h Source File

include » falagard

CEGUIFalImagerySection.h

00001 /************************************************************************
00002     filename:   CEGUIFalImagerySection.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalImagerySection_h_
00025 #define _CEGUIFalImagerySection_h_
00026
00027 #include "falagard/CEGUIFalImageryComponent.h"
00028 #include "falagard/CEGUIFalTextComponent.h"
00029 #include "falagard/CEGUIFalFrameComponent.h"
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4251)
00034 #endif
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00043     class CEGUIEXPORT ImagerySection
00044     {
00045     public:
00050         ImagerySection();
00051
00059         ImagerySection(const String& name);
00060
00077         void render(Window& srcWindow, float base_z, const CEGUI::ColourRect* modColours = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00078
00098         void render(Window& srcWindow, const Rect& baseRect, float base_z, const CEGUI::ColourRect* modColours = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00099
00110         void addImageryComponent(const ImageryComponent& img);
00111
00119         void clearImageryComponents();
00120
00131         void addTextComponent(const TextComponent& text);
00132
00140         void clearTextComponents();
00141
00149         void clearFrameComponents();
00150
00161         void addFrameComponent(const FrameComponent& frame);
00162
00170         const ColourRect& getMasterColours() const;
00171
00182         void setMasterColours(const ColourRect& cols);
00183
00191         const String& getName() const;
00192
00203         void setMasterColoursPropertySource(const String& property);
00204
00216         void setMasterColoursPropertyIsColourRect(bool setting = true);
00217
00222         Rect getBoundingRect(const Window& wnd) const;
00223
00228         Rect getBoundingRect(const Window& wnd, const Rect& rect) const;
00229
00240         void writeXMLToStream(OutStream& out_stream) const;
00241
00242     protected:
00252         void initMasterColourRect(const Window& wnd, ColourRect& cr) const;
00253
00254     private:
00255         typedef std::vector<ImageryComponent> ImageryList;
00256         typedef std::vector<TextComponent> TextList;
00257         typedef std::vector<FrameComponent> FrameList;
00258
00259         CEGUI::String       d_name;
00260         CEGUI::ColourRect   d_masterColours;
00261         FrameList           d_frames;
00262         ImageryList         d_images;
00263         TextList            d_texts;
00264         String              d_colourPropertyName;
00265         bool                d_colourProperyIsRect;
00266     };
00267
00268 } // End of  CEGUI namespace section
00269
00270
00271 #if defined(_MSC_VER)
00272 #       pragma warning(pop)
00273 #endif
00274
00275 #endif  // end of guard _CEGUIFalImagerySection_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalLayerSpecification.h Source File

include » falagard

CEGUIFalLayerSpecification.h

00001 /************************************************************************
00002     filename:   CEGUIFalLayerSpecification.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalLayerSpecification_h_
00025 #define _CEGUIFalLayerSpecification_h_
00026
00027 #include "falagard/CEGUIFalSectionSpecification.h"
00028 #include "CEGUIWindow.h"
00029
00030 #if defined(_MSC_VER)
00031 #       pragma warning(push)
00032 #       pragma warning(disable : 4251)
00033 #endif
00034
00035 // Start of CEGUI namespace section
00036 namespace CEGUI
00037 {
00042     class CEGUIEXPORT LayerSpecification
00043     {
00044     public:
00053         LayerSpecification(uint priority);
00054
00068         void render(Window& srcWindow, float base_z, const ColourRect* modcols = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00069
00086         void render(Window& srcWindow, const Rect& baseRect, float base_z, const ColourRect* modcols = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00087
00100         void addSectionSpecification(const SectionSpecification& section);
00101
00109         void clearSectionSpecifications();
00110
00118         uint getLayerPriority() const;
00119
00120         // required to sort layers according to priority
00121         bool operator<(const LayerSpecification& other) const;
00122
00133         void writeXMLToStream(OutStream& out_stream) const;
00134
00135     private:
00136         typedef std::vector<SectionSpecification> SectionList;
00137
00138         SectionList d_sections;
00139         uint        d_layerPriority;
00140     };
00141
00142 } // End of  CEGUI namespace section
00143
00144
00145 #if defined(_MSC_VER)
00146 #       pragma warning(pop)
00147 #endif
00148
00149 #endif  // end of guard _CEGUIFalLayerSpecification_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalNamedArea.h Source File

include » falagard

CEGUIFalNamedArea.h

00001 /************************************************************************
00002     filename:   CEGUIFalNamedArea.h
00003     created:    Sun Jun 26 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalNamedArea_h_
00025 #define _CEGUIFalNamedArea_h_
00026
00027 #include "falagard/CEGUIFalDimensions.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00037     class CEGUIEXPORT NamedArea
00038     {
00039     public:
00040         NamedArea() {}
00041         NamedArea(const String& name);
00042
00050         const String& getName() const;
00051
00059         const ComponentArea& getArea() const;
00060
00071         void setArea(const ComponentArea& area);
00072
00083         void writeXMLToStream(OutStream& out_stream) const;
00084
00085     private:
00086         String d_name;
00087         ComponentArea d_area;
00088     };
00089
00090 } // End of  CEGUI namespace section
00091
00092
00093 #endif  // end of guard _CEGUIFalNamedArea_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalPropertyDefinition.h Source File

include » falagard

CEGUIFalPropertyDefinition.h

00001 /************************************************************************
00002     filename:   CEGUIFalPropertyDefinition.h
00003     created:    Sun Jun 26 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalPropertyDefinition_h_
00025 #define _CEGUIFalPropertyDefinition_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00037     class CEGUIEXPORT PropertyDefinition : public Property
00038     {
00039     public:
00040         PropertyDefinition(const String& name, const String& initialValue, bool redrawOnWrite, bool layoutOnWrite);
00041
00042         // abstract members from Property
00043         String get(const PropertyReceiver* receiver) const;
00044         void set(PropertyReceiver* receiver, const String& value);
00045
00056         void writeXMLToStream(OutStream& out_stream) const;
00057
00058     protected:
00059         String d_userStringName;
00060         bool d_writeCausesRedraw;
00061         bool d_writeCausesLayout;
00062     };
00063
00064 } // End of  CEGUI namespace section
00065
00066
00067 #endif  // end of guard _CEGUIFalPropertyDefinition_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalPropertyInitialiser.h Source File

include » falagard

CEGUIFalPropertyInitialiser.h

00001 /************************************************************************
00002     filename:   CEGUIFalPropertyInitialiser.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalPropertyInitialiser_h_
00025 #define _CEGUIFalPropertyInitialiser_h_
00026
00027 #include "CEGUIPropertySet.h"
00028
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00037     class CEGUIEXPORT PropertyInitialiser
00038     {
00039     public:
00050         PropertyInitialiser(const String& property, const String& value);
00051
00062         void apply(PropertySet& target) const;
00063
00071         const String& getTargetPropertyName() const;
00072
00080         const String& getInitialiserValue() const;
00081
00092         void writeXMLToStream(OutStream& out_stream) const;
00093
00094     private:
00095         CEGUI::String   d_propertyName;
00096         CEGUI::String   d_propertyValue;
00097     };
00098
00099 } // End of  CEGUI namespace section
00100
00101
00102 #endif  // end of guard _CEGUIFalPropertyInitialiser_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalSectionSpecification.h Source File

include » falagard

CEGUIFalSectionSpecification.h

00001 /************************************************************************
00002     filename:   CEGUIFalSectionSpecification.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalSectionSpecification_h_
00025 #define _CEGUIFalSectionSpecification_h_
00026
00027 #include "CEGUIWindow.h"
00028
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00033     // forward refs
00034     class WidgetLookFeel;
00035
00043     class CEGUIEXPORT SectionSpecification
00044     {
00045     public:
00056         SectionSpecification(const String& owner, const String& sectionName);
00057
00071         SectionSpecification(const String& owner, const String& sectionName, const ColourRect& cols);
00072
00086         void render(Window& srcWindow, float base_z, const ColourRect* modcols = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00087
00104         void render(Window& srcWindow, const Rect& baseRect, float base_z, const ColourRect* modcols = 0, const Rect* clipper = 0, bool clipToDisplay = false) const;
00105
00113         const String& getOwnerWidgetLookFeel() const;
00114
00122         const String& getSectionName() const;
00123
00132         const ColourRect& getOverrideColours() const;
00133
00144         void setOverrideColours(const ColourRect& cols);
00145
00154         bool isUsingOverrideColours() const;
00155
00167         void setUsingOverrideColours(bool setting = true);
00168
00179         void setOverrideColoursPropertySource(const String& property);
00180
00192         void setOverrideColoursPropertyIsColourRect(bool setting = true);
00193
00204         void writeXMLToStream(OutStream& out_stream) const;
00205
00206     protected:
00217         void initColourRectForOverride(const Window& wnd, ColourRect& cr) const;
00218
00219     private:
00220         String          d_owner;
00221         String          d_sectionName;
00222         ColourRect      d_coloursOverride;
00223         bool            d_usingColourOverride;
00224         String          d_colourPropertyName;
00225         bool            d_colourProperyIsRect;
00226     };
00227
00228
00229 } // End of  CEGUI namespace section
00230
00231
00232 #endif  // end of guard _CEGUIFalSectionSpecification_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalStateImagery.h Source File

include » falagard

CEGUIFalStateImagery.h

00001 /************************************************************************
00002     filename:   CEGUIFalStateImagery.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalStateImagery_h_
00025 #define _CEGUIFalStateImagery_h_
00026
00027 #include "falagard/CEGUIFalLayerSpecification.h"
00028 #include "CEGUIWindow.h"
00029 #include <set>
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4251)
00034 #endif
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00043     class CEGUIEXPORT StateImagery
00044     {
00045     public:
00050         StateImagery() {}
00051
00059         StateImagery(const String& name);
00060
00071         void render(Window& srcWindow, const ColourRect* modcols = 0, const Rect* clipper = 0) const;
00072
00086         void render(Window& srcWindow, const Rect& baseRect, const ColourRect* modcols = 0, const Rect* clipper = 0) const;
00087
00098         void addLayer(const LayerSpecification& layer);
00099
00107         void clearLayers();
00108
00116         const String& getName() const;
00117
00128         bool isClippedToDisplay() const;
00129
00143         void setClippedToDisplay(bool setting);
00144
00155         void writeXMLToStream(OutStream& out_stream) const;
00156
00157     private:
00158         typedef std::multiset<LayerSpecification> LayersList;
00159
00160         CEGUI::String   d_stateName;
00161         LayersList      d_layers;
00162         bool            d_clipToDisplay;
00163     };
00164
00165 } // End of  CEGUI namespace section
00166
00167
00168 #if defined(_MSC_VER)
00169 #       pragma warning(pop)
00170 #endif
00171
00172 #endif  // end of guard _CEGUIFalStateImagery_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalTextComponent.h Source File

include » falagard

CEGUIFalTextComponent.h

00001 /************************************************************************
00002     filename:   CEGUIFalTextComponent.h
00003     created:    Sun Jun 19 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalTextComponent_h_
00025 #define _CEGUIFalTextComponent_h_
00026
00027 #include "falagard/CEGUIFalComponentBase.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00036     class CEGUIEXPORT TextComponent : public FalagardComponentBase
00037     {
00038     public:
00043         TextComponent();
00044
00052         const String& getText() const;
00053
00067         void setText(const String& text);
00068
00076         const String& getFont() const;
00077
00091         void setFont(const String& font);
00092
00100         VerticalTextFormatting getVerticalFormatting() const;
00101
00112         void setVerticalFormatting(VerticalTextFormatting fmt);
00113
00121         HorizontalTextFormatting getHorizontalFormatting() const;
00122
00133         void setHorizontalFormatting(HorizontalTextFormatting fmt);
00134
00145         void writeXMLToStream(OutStream& out_stream) const;
00146
00147     protected:
00148         // implemets abstract from base
00149         void render_impl(Window& srcWindow, Rect& destRect, float base_z, const CEGUI::ColourRect* modColours, const Rect* clipper, bool clipToDisplay) const;
00150
00151     private:
00152         String               d_text;
00153         String               d_font;
00154         VerticalTextFormatting   d_vertFormatting;
00155         HorizontalTextFormatting d_horzFormatting;
00156     };
00157
00158 } // End of  CEGUI namespace section
00159
00160
00161 #endif  // end of guard _CEGUIFalTextComponent_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalWidgetComponent.h Source File

include » falagard

CEGUIFalWidgetComponent.h

00001 /************************************************************************
00002     filename:   CEGUIFalWidgetComponent.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalWidgetComponent_h_
00025 #define _CEGUIFalWidgetComponent_h_
00026
00027 #include "falagard/CEGUIFalDimensions.h"
00028 #include "falagard/CEGUIFalPropertyInitialiser.h"
00029 #include "CEGUIWindow.h"
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4251)
00034 #endif
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00046     class CEGUIEXPORT WidgetComponent
00047     {
00048     public:
00049         WidgetComponent() {}
00050         WidgetComponent(const String& type, const String& look, const String& suffix);
00051
00056         void create(Window& parent) const;
00057
00058         const ComponentArea& getComponentArea() const;
00059         void setComponentArea(const ComponentArea& area);
00060
00061         const String& getBaseWidgetType() const;
00062         void setBaseWidgetType(const String& type);
00063
00064         const String& getWidgetLookName() const;
00065         void setWidgetLookName(const String& look);
00066
00067         const String& getWidgetNameSuffix() const;
00068         void setWidgetNameSuffix(const String& suffix);
00069
00070         VerticalAlignment getVerticalWidgetAlignemnt() const;
00071         void setVerticalWidgetAlignment(VerticalAlignment alignment);
00072
00073         HorizontalAlignment getHorizontalWidgetAlignemnt() const;
00074         void setHorizontalWidgetAlignemnt(HorizontalAlignment alignment);
00075
00076         void addPropertyInitialiser(const PropertyInitialiser& initialiser);
00077         void clearPropertyInitialisers();
00078
00079         void layout(const Window& owner) const;
00080
00091         void writeXMLToStream(OutStream& out_stream) const;
00092
00093     private:
00094         typedef std::vector<PropertyInitialiser> PropertiesList;
00095
00096         ComponentArea   d_area;
00097         String   d_baseType;
00098         String   d_imageryName;
00099         String   d_nameSuffix;
00100         VerticalAlignment    d_vertAlign;
00101         HorizontalAlignment  d_horzAlign;
00102         PropertiesList  d_properties;
00103     };
00104
00105 } // End of  CEGUI namespace section
00106
00107
00108 #if defined(_MSC_VER)
00109 #       pragma warning(pop)
00110 #endif
00111
00112 #endif  // end of guard _CEGUIFalWidgetComponent_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalWidgetLookFeel.h Source File

include » falagard

CEGUIFalWidgetLookFeel.h

00001 /************************************************************************
00002     filename:   CEGUIFalWidgetLookFeel.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalWidgetLookFeel_h_
00025 #define _CEGUIFalWidgetLookFeel_h_
00026
00027 #include "falagard/CEGUIFalStateImagery.h"
00028 #include "falagard/CEGUIFalWidgetComponent.h"
00029 #include "falagard/CEGUIFalImagerySection.h"
00030 #include "falagard/CEGUIFalPropertyInitialiser.h"
00031 #include "falagard/CEGUIFalPropertyDefinition.h"
00032 #include "falagard/CEGUIFalNamedArea.h"
00033 #include <map>
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00048     class CEGUIEXPORT WidgetLookFeel
00049     {
00050     public:
00051         WidgetLookFeel(const String& name);
00052         WidgetLookFeel() {}
00053
00061         const StateImagery& getStateImagery(const CEGUI::String& state) const;
00062
00070         const ImagerySection& getImagerySection(const CEGUI::String& section) const;
00071
00079         const String& getName() const;
00080
00090         void addImagerySection(const ImagerySection& section);
00091
00101         void addWidgetComponent(const WidgetComponent& widget);
00102
00112         void addStateSpecification(const StateImagery& state);
00113
00123         void addPropertyInitialiser(const PropertyInitialiser& initialiser);
00124
00132         void clearImagerySections();
00133
00141         void clearWidgetComponents();
00142
00150         void clearStateSpecifications();
00151
00159         void clearPropertyInitialisers();
00160
00172         void initialiseWidget(Window& widget) const;
00173
00185         bool isStateImageryPresent(const String& state) const;
00186
00197         void addNamedArea(const NamedArea& area);
00198
00206         void clearNamedAreas();
00207
00218         const NamedArea& getNamedArea(const String& name) const;
00219
00231         bool isNamedAreaDefined(const String& name) const;
00232
00243         void layoutChildWidgets(const Window& owner) const;
00244
00255         void addPropertyDefinition(const PropertyDefinition& propdef);
00256
00264         void clearPropertyDefinitions();
00265
00276         void writeXMLToStream(OutStream& out_stream) const;
00277
00291         void renameChildren(const Window& widget, const String& newBaseName) const;
00292
00293     private:
00294         typedef std::map<String, StateImagery>    StateList;
00295         typedef std::map<String, ImagerySection>  ImageryList;
00296         typedef std::map<String, NamedArea>       NamedAreaList;
00297         typedef std::vector<WidgetComponent>      WidgetList;
00298         typedef std::vector<PropertyInitialiser>  PropertyList;
00299         typedef std::vector<PropertyDefinition>   PropertyDefinitionList;
00300
00301         CEGUI::String   d_lookName;
00302         ImageryList     d_imagerySections;
00303         WidgetList      d_childWidgets;
00304         StateList       d_stateImagery;
00305         PropertyList    d_properties;
00306         NamedAreaList   d_namedAreas;
00307         mutable PropertyDefinitionList  d_propertyDefinitions;
00308     };
00309
00310
00311 } // End of  CEGUI namespace section
00312
00313
00314 #if defined(_MSC_VER)
00315 #       pragma warning(pop)
00316 #endif
00317
00318 #endif  // end of guard _CEGUIFalWidgetLookFeel_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalWidgetLookManager.h Source File

include » falagard

CEGUIFalWidgetLookManager.h

00001 /************************************************************************
00002     filename:   CEGUIFalWidgetLookManager.h
00003     created:    Mon Jun 13 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalWidgetLookManager_h_
00025 #define _CEGUIFalWidgetLookManager_h_
00026
00027 #include "CEGUISingleton.h"
00028 #include "CEGUIString.h"
00029 #include "CEGUIExceptions.h"
00030 #include "falagard/CEGUIFalWidgetLookFeel.h"
00031 #include <map>
00032
00033 #if defined(_MSC_VER)
00034 #       pragma warning(push)
00035 #       pragma warning(disable : 4251)
00036 #       pragma warning(disable : 4275)
00037 #endif
00038
00039 // Start of CEGUI namespace section
00040 namespace CEGUI
00041 {
00046     class CEGUIEXPORT WidgetLookManager : public Singleton<WidgetLookManager>
00047     {
00048     public:
00053         WidgetLookManager();
00054
00059         ~WidgetLookManager();
00060
00068               static    WidgetLookManager&      getSingleton(void);
00069
00070
00078               static    WidgetLookManager*      getSingletonPtr(void);
00079
00080
00102         void parseLookNFeelSpecification(const String& filename, const String& resourceGroup = "");
00103
00104
00116         bool isWidgetLookAvailable(const String& widget) const;
00117
00118
00131         const WidgetLookFeel& getWidgetLook(const String& widget) const;
00132
00133
00145         void eraseWidgetLook(const String& widget);
00146
00147
00164         void addWidgetLook(const WidgetLookFeel& look);
00165
00170         void writeFalagardXMLHeadToStream(OutStream& out_stream) const;
00171
00179         void writeFalagardXMLTailToStream(OutStream& out_stream) const;
00180
00192         void writeWidgetLookToStream(const String& name, OutStream& out_stream) const;
00193
00210         void writeWidgetLookSeriesToStream(const String& prefix, OutStream& out_stream) const;
00211
00212
00213     private:
00214         static const String FalagardSchemaName;
00215
00216         typedef std::map<String, WidgetLookFeel> WidgetLookList;
00217         WidgetLookList  d_widgetLooks;
00218     };
00219
00220 } // End of  CEGUI namespace section
00221
00222
00223 #if defined(_MSC_VER)
00224 #       pragma warning(pop)
00225 #endif
00226
00227 #endif  // end of guard _CEGUIFalWidgetLookManager_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFalXMLEnumHelper.h Source File

include » falagard

CEGUIFalXMLEnumHelper.h

00001 /************************************************************************
00002     filename:   CEGUIFalXMLEnumHelper.h
00003     created:    Mon Jul 18 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIFalXMLEnumHelper_h_
00025 #define _CEGUIFalXMLEnumHelper_h_
00026
00027 #include "CEGUIString.h"
00028 #include "CEGUIWindow.h"
00029 #include "falagard/CEGUIFalEnums.h"
00030
00031 // Start of CEGUI namespace section
00032 namespace CEGUI
00033 {
00038     class CEGUIEXPORT FalagardXMLHelper
00039     {
00040     public:
00041         static VerticalFormatting stringToVertFormat(const String& str);
00042         static HorizontalFormatting stringToHorzFormat(const String& str);
00043         static VerticalAlignment stringToVertAlignment(const String& str);
00044         static HorizontalAlignment stringToHorzAlignment(const String& str);
00045         static DimensionType stringToDimensionType(const String& str);
00046         static VerticalTextFormatting stringToVertTextFormat(const String& str);
00047         static HorizontalTextFormatting stringToHorzTextFormat(const String& str);
00048         static FontMetricType stringToFontMetricType(const String& str);
00049         static DimensionOperator stringToDimensionOperator(const String& str);
00050         static FrameImageComponent stringToFrameImageComponent(const String& str);
00051
00052         static String vertFormatToString(VerticalFormatting format);
00053         static String horzFormatToString(HorizontalFormatting format);
00054         static String vertAlignmentToString(VerticalAlignment alignment);
00055         static String horzAlignmentToString(HorizontalAlignment alignment);
00056         static String dimensionTypeToString(DimensionType dim);
00057         static String vertTextFormatToString(VerticalTextFormatting format);
00058         static String horzTextFormatToString(HorizontalTextFormatting format);
00059         static String fontMetricTypeToString(FontMetricType metric);
00060         static String dimensionOperatorToString(DimensionOperator op);
00061         static String frameImageComponentToString(FrameImageComponent imageComp);
00062     };
00063 } // End of  CEGUI namespace section
00064
00065
00066 #endif  // end of guard _CEGUIFalXMLEnumHelper_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFont.h Source File

include

CEGUIFont.h

00001 /************************************************************************
00002         filename:       CEGUIFont.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for the Font class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIFont_h_
00027 #define _CEGUIFont_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIRect.h"
00032 #include "CEGUIVector.h"
00033 #include "CEGUIColourRect.h"
00034
00035 #include <map>
00036
00037
00038 #if defined(_MSC_VER)
00039 #       pragma warning(push)
00040 #       pragma warning(disable : 4251)
00041 #endif
00042
00043
00044 // Start of CEGUI namespace section
00045 namespace CEGUI
00046 {
00051 enum FontFlag
00052 {
00053         Default,
00054         NoAntiAlias
00055 };
00056
00057
00062 enum TextFormatting
00063 {
00064         LeftAligned,
00065         RightAligned,
00066         Centred,
00067         Justified,
00068         WordWrapLeftAligned,
00069         WordWrapRightAligned,
00070         WordWrapCentred,
00071         WordWrapJustified
00072 };
00073
00082 class CEGUIEXPORT Font
00083 {
00084         friend class Font_xmlHandler;
00085 public:
00086         /*************************************************************************
00087                 Constants
00088         *************************************************************************/
00089         static const argb_t             DefaultColour;
00090
00091
00092         /*************************************************************************
00093                 Text drawing methods
00094         *************************************************************************/
00128         size_t  drawText(const String& text, const Rect& draw_area, float z, const Rect& clip_rect, TextFormatting fmt, const ColourRect& colours, float x_scale = 1.0f, float y_scale = 1.0f) const;
00129
00130
00160         size_t  drawText(const String& text, const Rect& draw_area, float z, const Rect& clip_rect, TextFormatting fmt, float x_scale = 1.0f, float y_scale = 1.0f) const
00161         { return drawText(text, draw_area, z, clip_rect, fmt, ColourRect(DefaultColour, DefaultColour, DefaultColour, DefaultColour), x_scale, y_scale); }
00162
00163
00190         void    drawText(const String& text, const Rect& draw_area, float z, const Rect& clip_rect, float x_scale = 1.0f, float y_scale = 1.0f) const
00191         { drawText(text, draw_area, z, clip_rect, LeftAligned, ColourRect(DefaultColour, DefaultColour, DefaultColour, DefaultColour), x_scale, y_scale); }
00192
00193
00225         size_t  drawText(const String& text, const Rect& draw_area, float z, TextFormatting fmt, const ColourRect& colours, float x_scale = 1.0f, float y_scale = 1.0f) const
00226         { return drawText(text, draw_area, z, draw_area, fmt, colours, x_scale, y_scale); }
00227
00228
00256         size_t  drawText(const String& text, const Rect& draw_area, float z, TextFormatting fmt, float x_scale = 1.0f, float y_scale = 1.0f) const
00257         { return drawText(text, draw_area, z, draw_area, fmt, ColourRect(DefaultColour, DefaultColour, DefaultColour, DefaultColour), x_scale, y_scale); }
00258
00259
00284         void    drawText(const String& text, const Rect& draw_area, float z, float x_scale = 1.0f, float y_scale = 1.0f) const
00285         { drawText(text, draw_area, z, draw_area, LeftAligned, ColourRect(DefaultColour, DefaultColour, DefaultColour, DefaultColour), x_scale, y_scale); }
00286
00287
00315         void    drawText(const String& text, const Vector3& position, const Rect& clip_rect, const ColourRect& colours, float x_scale = 1.0f, float y_scale = 1.0f) const
00316         { drawText(text, Rect(position.d_x, position.d_y, position.d_x, position.d_y), position.d_z, clip_rect, LeftAligned, colours, x_scale, y_scale); }
00317
00318
00342         void    drawText(const String& text, const Vector3& position, const Rect& clip_rect, float x_scale = 1.0f, float y_scale = 1.0f) const
00343         { drawText(text, Rect(position.d_x, position.d_y, position.d_x, position.d_y), position.d_z, clip_rect, LeftAligned, ColourRect(DefaultColour, DefaultColour, DefaultColour, DefaultColour), x_scale, y_scale); }
00344
00345
00346         /*************************************************************************
00347                 Methods to define available glyphs (truetype fonts only)
00348         *************************************************************************/
00367         void    defineFontGlyphs(const String& glyph_set);
00368
00369
00394         void    defineFontGlyphs(utf32 first_code_point, utf32 last_code_point);
00395
00396
00407         void    setNativeResolution(const Size& size);
00408
00409
00420         void    notifyScreenResolution(const Size& size);
00421
00422
00433         void    setAutoScalingEnabled(bool setting);
00434
00435
00448         void    setAntiAliased(bool setting);
00449
00450
00451         /*************************************************************************
00452                 Informational methods
00453         *************************************************************************/
00467         float   getTextExtent(const String& text, float x_scale = 1.0f) const;
00468
00469
00480         float   getLineSpacing(float y_scale = 1.0f) const              {return d_lineSpacing * y_scale;}
00481
00482
00493         float   getFontHeight(float y_scale = 1.0f) const       {return d_lineHeight * y_scale;}
00494
00495
00506         float   getBaseline(float y_scale = 1.0f) const                 {return d_max_bearingY * y_scale;}
00507
00508
00527         size_t  getCharAtPixel(const String& text, float pixel, float x_scale = 1.0f) const             {return getCharAtPixel(text, 0, pixel, x_scale);}
00528
00529
00552         size_t  getCharAtPixel(const String& text, size_t start_char, float pixel, float x_scale = 1.0f) const;
00553
00554
00562         const String&   getName(void) const             {return d_name;}
00563
00564
00572         Size    getNativeResolution(void) const {return Size(d_nativeHorzRes, d_nativeVertRes);}
00573
00574
00582         bool    isAutoScaled(void) const                {return d_autoScale;}
00583
00584
00595         bool    isCodepointAvailable(utf32 cp) const            {return (d_cp_map.find(cp) != d_cp_map.end());}
00596
00597
00620         size_t  getFormattedLineCount(const String& text, const Rect& format_area, TextFormatting fmt, float x_scale = 1.0f) const;
00621
00622
00644         float   getFormattedTextExtent(const String& text, const Rect& format_area, TextFormatting fmt, float x_scale = 1.0f) const;
00645
00646
00655         bool    isAntiAliased(void) const;
00656
00657
00665         const String& getAvailableGlyphs(void) const;
00666
00667
00677         uint    getPointSize(void) const;
00678
00679
00680 private:
00681         /*************************************************************************
00682                 Implementation Constants
00683         *************************************************************************/
00684         static const char       FontSchemaName[];
00685         static const uint       InterGlyphPadSpace;
00686
00687
00688         /*************************************************************************
00689                 Friends so that only FontManager can create and destroy font objects
00690         *************************************************************************/
00691         friend class FontManager;
00692
00693         /*************************************************************************
00694                 Private forward refs
00695         *************************************************************************/
00696         struct FontImplData;
00697
00698
00699         /*************************************************************************
00700                 Construction & Destruction
00701         *************************************************************************/
00720         Font(const String& filename, const String& resourceGroup, FontImplData* dat);
00721
00722
00748         Font(const String& name, const String& fontname, const String& resourceGroup, uint size, uint flags, FontImplData* dat);
00749
00750
00779         Font(const String& name, const String& fontname, const String& resourceGroup, uint size, uint flags, const String& glyph_set, FontImplData* dat);
00780
00781
00813         Font(const String& name, const String& fontname, const String& resourceGroup, uint size, uint flags, utf32 first_code_point, utf32 last_code_point, FontImplData* dat);
00814
00815
00816 public:         // For luabind support
00821         ~Font(void);
00822
00823
00824 private:
00825         /*************************************************************************
00826                 Implementation Methods
00827         *************************************************************************/
00842         void    load(const String& filename, const String& resourceGroup);
00843
00844
00852         void    unload(void);
00853
00854
00866         uint    getRequiredTextureSize(const String& glyph_set);
00867
00868
00883         uint    getRequiredTextureSize(utf32 first_code_point, utf32 last_code_point);
00884
00885
00904         void    createFontGlyphSet(const String& glyph_set, uint size, argb_t* buffer);
00905
00906
00928         void    createFontGlyphSet(utf32 first_code_point, utf32 last_code_point, uint size, argb_t* buffer);
00929
00930
00944         void    drawGlyphToBuffer(argb_t* buffer, uint buf_width);
00945
00946
00951         size_t  drawWrappedText(const String& text, const Rect& draw_area, float z, const Rect& clip_rect, TextFormatting fmt, const ColourRect& colours, float x_scale = 1.0f, float y_scale = 1.0f) const;
00952
00953
00958         size_t  getNextWord(const String& in_string, size_t start_idx, String& out_string) const;
00959
00960
00965         void    drawTextLine(const String& text, const Vector3& position, const Rect& clip_rect, const ColourRect& colours, float x_scale = 1.0f, float y_scale = 1.0f) const;
00966
00967
00972         void    drawTextLineJustified(const String& text, const Rect& draw_area, const Vector3& position, const Rect& clip_rect, const ColourRect& colours, float x_scale = 1.0f, float y_scale = 1.0f) const;
00973
00974
00979         void    createFontFromFT_Face(uint size, uint horzDpi, uint vertDpi);
00980
00981
00986         void    updateFontScaling(void);
00987
00988
00993         void    calculateStaticVertSpacing(void);
00994
00999         void    constructor_impl(const String& name, const String& fontname, const String& resourceGroup, uint size, uint flags, const String& glyph_set);
01000
01001
01017         void    defineFontGlyphs_impl(void);
01018
01019
01024         float   getWrappedTextExtent(const String& text, float wrapWidth, float x_scale = 1.0f) const;
01025
01026
01037     void writeXMLToStream(OutStream& out_stream) const;
01038
01039
01040         /*************************************************************************
01041                 Implementation structs
01042         *************************************************************************/
01047         struct glyphDat
01048         {
01049                 const Image*    d_image;
01050                 int                     d_horz_advance;
01051                 int                     d_horz_advance_unscaled;
01052         };
01053
01054         /*************************************************************************
01055                 Implementation Data
01056         *************************************************************************/
01057         typedef         std::map<utf32, glyphDat>               CodepointMap;
01058         CodepointMap    d_cp_map;
01059
01060         String          d_name;
01061         Imageset*       d_glyph_images;
01062         String     d_sourceFilename;
01063
01064         bool    d_freetype;
01065         float   d_lineHeight;
01066         float   d_lineSpacing;
01067         float   d_max_bearingY;
01068         uint    d_maxGlyphHeight;
01069
01070         FontImplData*   d_impldat;
01071         uint            d_ptSize;
01072         String          d_glyphset;
01073
01074         // auto-scaling fields
01075         bool    d_autoScale;
01076         float   d_horzScaling;
01077         float   d_vertScaling;
01078         float   d_nativeHorzRes;
01079         float   d_nativeVertRes;
01080
01081         bool    d_antiAliased;
01082 };
01083
01084 } // End of  CEGUI namespace section
01085
01086 #if defined(_MSC_VER)
01087 #       pragma warning(pop)
01088 #endif
01089
01090
01091 #endif  // end of guard _CEGUIFont_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFont_implData.h Source File

include

CEGUIFont_implData.h

00001 /************************************************************************
00002         filename:       CEGUIFont_implData.h
00003         created:        23/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Implementation data used within the Font class
00007                                 Used to break dependency on FreeType2 for clients
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIFont_implData_h_
00028 #define _CEGUIFont_implData_h_
00029
00030 #include <ft2build.h>
00031 #include FT_FREETYPE_H
00032 #include "CEGUIDataContainer.h"
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00037 struct Font::FontImplData
00038 {
00039         FontImplData(FT_Library lib) : library(lib) {}
00040
00041         FT_Library      library;
00042         FT_Face         fontFace;
00043     RawDataContainer fontData;
00044 };
00045
00046 } // End of  CEGUI namespace section
00047
00048
00049 #endif  // end of guard _CEGUIFont_implData_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFont_xmlHandler.h Source File

include

CEGUIFont_xmlHandler.h

00001 /************************************************************************
00002 filename:       CEGUIFont_xmlHandler.h
00003 created:        21/2/2004
00004 author:         Paul D Turner
00005
00006 purpose:        Defines interface for the Font class
00007 *************************************************************************/
00008 /*************************************************************************
00009 Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010 Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012 This library is free software; you can redistribute it and/or
00013 modify it under the terms of the GNU Lesser General Public
00014 License as published by the Free Software Foundation; either
00015 version 2.1 of the License, or (at your option) any later version.
00016
00017 This library is distributed in the hope that it will be useful,
00018 but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020 Lesser General Public License for more details.
00021
00022 You should have received a copy of the GNU Lesser General Public
00023 License along with this library; if not, write to the Free Software
00024 Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIFont_xmlHandler_h_
00027 #define _CEGUIFont_xmlHandler_h_
00028
00029 #include "CEGUIFont.h"
00030 #include "CEGUIXMLHandler.h"
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00040 class Font_xmlHandler : public XMLHandler
00041 {
00042 public:
00043         /*************************************************************************
00044         Construction & Destruction
00045         *************************************************************************/
00053         Font_xmlHandler(Font* font) : d_font(font) {}
00054
00059         virtual ~Font_xmlHandler(void) {}
00060
00061         /*************************************************************************
00062         SAX2 Handler overrides
00063         *************************************************************************/
00068     virtual void elementStart(const String& element, const XMLAttributes& attributes);
00069     virtual void elementEnd(const String& element);
00070
00071 private:
00072         /*************************************************************************
00073         Implementation Constants
00074         *************************************************************************/
00075         // XML related strings
00076         static const String FontElement;
00077         static const String MappingElement;
00078         static const String FontTypeStatic;
00079         static const String FontTypeDynamic;
00080         static const String GlyphElement;
00081         static const String GlyphRangeElement;
00082         static const String GlyphSetElement;
00083         static const char       FontNameAttribute[];
00084     static const char   FontFilenameAttribute[];
00085     static const char   FontResourceGroupAttribute[];
00086         static const char       FontTypeAttribute[];
00087         static const char       FontSizeAttribute[];
00088         static const char       FontFirstCodepointAttribute[];
00089         static const char       FontLastCodepointAttribute[];
00090         static const char       FontNativeHorzResAttribute[];
00091         static const char       FontNativeVertResAttribute[];
00092         static const char       FontAutoScaledAttribute[];
00093         static const char       FontAntiAliasedAttribute[];
00094         static const char       MappingCodepointAttribute[];
00095         static const char       MappingImageAttribute[];
00096         static const char       MappingHorzAdvanceAttribute[];
00097         static const char       GlyphCodepointAttribute[];
00098         static const char       GlyphRangeStartCodepointAttribute[];
00099         static const char       GlyphRangeEndCodepointAttribute[];
00100         static const char       GlyphSetGlyphsAttribute[];
00101
00102         // general constants
00103         static const int        AutoGenerateHorzAdvance;
00104
00105         /*************************************************************************
00106         Implementation Data
00107         *************************************************************************/
00108         Font*   d_font;
00109         String  d_glyphSet;
00110 };
00111
00112 } // End of  CEGUI namespace section
00113
00114 #endif
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFontManager.h Source File

include

CEGUIFontManager.h

00001 /************************************************************************
00002         filename:       CEGUIFontManager.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for the FontManager class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIFontManager_h_
00027 #define _CEGUIFontManager_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUIIteratorBase.h"
00033 #include <map>
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4275)
00038 #       pragma warning(disable : 4251)
00039 #endif
00040
00041
00042 // Start of CEGUI namespace section
00043 namespace CEGUI
00044 {
00054 class CEGUIEXPORT FontManager : public Singleton<FontManager>
00055 {
00056 public:
00061         FontManager(void);
00062
00063
00068         ~FontManager(void);
00069
00070
00078         static  FontManager&    getSingleton(void);
00079
00080
00088         static  FontManager*    getSingletonPtr(void);
00089
00090
00111         Font*   createFont(const String& filename, const String& resourceGroup = "");
00112
00113
00141         Font*   createFont(const String& name, const String& fontname, uint size, uint flags, const String& resourceGroup = "");
00142
00143
00154         void    destroyFont(const String& name);
00155
00156
00167         void    destroyFont(Font* font);
00168
00169
00177         void    destroyAllFonts(void);
00178
00179
00190         bool    isFontPresent(const String& name) const;
00191
00192
00205         Font*   getFont(const String& name) const;
00206
00207
00218         void    notifyScreenResolution(const Size& size);
00219
00220
00234     void writeFontToStream(const String& name, OutStream& out_stream) const;
00235
00236
00237 private:
00238         /*************************************************************************
00239                 Implementation Data
00240         *************************************************************************/
00241         typedef std::map<String, Font*>         FontRegistry;
00242         FontRegistry            d_fonts;
00243
00244         struct FontManagerImplData;
00245         FontManagerImplData*    d_implData;
00246
00247
00248 public:
00249         /*************************************************************************
00250                 Iterator stuff
00251         *************************************************************************/
00252         typedef ConstBaseIterator<FontRegistry> FontIterator;
00253
00258         FontIterator    getIterator(void) const;
00259 };
00260
00261 } // End of  CEGUI namespace section
00262
00263
00264 #if defined(_MSC_VER)
00265 #       pragma warning(pop)
00266 #endif
00267
00268 #endif  // end of guard _CEGUIFontManager_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFontManager_implData.h Source File

include

CEGUIFontManager_implData.h

00001 /************************************************************************
00002         filename:       CEGUIFontManager_implData.h
00003         created:        23/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Implementation data for FontManager to break
00007                                 dependency on FreeType2 for clients
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIFontManager_implData_h_
00028 #define _CEGUIFontManager_implData_h_
00029
00030 #include <ft2build.h>
00031 #include FT_FREETYPE_H
00032
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00037 struct FontManager::FontManagerImplData
00038 {
00039         FT_Library              d_ftlib;
00040 };
00041
00042 } // End of  CEGUI namespace section
00043
00044
00045 #endif  // end of guard _CEGUIFontManager_implData_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIForwardRefs.h Source File

include

CEGUIForwardRefs.h

00001 /************************************************************************
00002         filename:       CEGUIForwardRefs.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Forward declares all core system classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIForwardRefs_h_
00027 #define _CEGUIForwardRefs_h_
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032
00033 /*************************************************************************
00034         Forward reference declarations of all core GUI system classes
00035 *************************************************************************/
00036 class String;
00037 class Vector3;
00038 class Size;
00039 class Exception;
00040 class Rect;
00041 class ColourRect;
00042 class colour;
00043 class Texture;
00044 class Renderer;
00045 class Image;
00046 class Imageset;
00047 class ImagesetManager;
00048 class MouseCursor;
00049 class Font;
00050 class FontManager;
00051 class EventArgs;
00052 class Event;
00053 class EventSet;
00054 class Property;
00055 class PropertySet;
00056 class Window;
00057 class WindowFactory;
00058 class WindowManager;
00059 class Scheme;
00060 class SchemeManager;
00061 class System;
00062 class FactoryModule;
00063 class ScriptModule;
00064 class ResourceProvider;
00065 class DefaultResourceProvider;
00066 class PropertyReceiver;
00067 class GlobalEventSet;
00068 class XMLAttributes;
00069 class XMLHandler;
00070 class XMLParser;
00071
00072 /*************************************************************************
00073         Forward reference declarations for GUI element base classes
00074 *************************************************************************/
00075 class ButtonBase;
00076 class RadioButton;
00077 class Checkbox;
00078 class PushButton;
00079 class Titlebar;
00080 class FrameWindow;
00081 class Editbox;
00082 class Listbox;
00083 class Combobox;
00084 class ListHeaderSegment;
00085 class ListHeader;
00086 class MultiColumnList;
00087 class ProgressBar;
00088 class Thumb;
00089 class Scrollbar;
00090 class Slider;
00091 class Static;
00092 class StaticText;
00093 class StaticImage;
00094 class ListboxItem;
00095 class ListboxTextItem;
00096 class ComboDropList;
00097 class MultiLineEditbox;
00098 class Spinner;
00099 class GUISheet;
00100 class DragContainer;
00101 class ScrollablePane;
00102 class ScrolledContainer;
00103 class Tooltip;
00104 class ItemEntry;
00105 class TextItem;
00106 class MenuItem;
00107 class ItemListBase;
00108 class MenuBase;
00109 class Menubar;
00110 class PopupMenu;
00111
00112 } // End of  CEGUI namespace section
00113
00114 #endif  // end of guard _CEGUIForwardRefs_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFrameWindow.h Source File

include » elements

CEGUIFrameWindow.h

00001 /************************************************************************
00002         filename:       CEGUIFrameWindow.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for FrameWindow
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIFrameWindow_h_
00027 #define _CEGUIFrameWindow_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIFrameWindowProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00047 class CEGUIEXPORT FrameWindow : public Window
00048 {
00049 public:
00050         static const String EventNamespace;
00051
00052
00053         /*************************************************************************
00054                 Constants
00055         *************************************************************************/
00056         // additional event names for this window
00057         static const String EventRollupToggled;
00058         static const String EventCloseClicked;
00059
00060         // other bits
00061         static const float      DefaultSizingBorderSize;
00062
00063
00068         enum SizingLocation {
00069                 SizingNone,
00070                 SizingTopLeft,
00071                 SizingTopRight,
00072                 SizingBottomLeft,
00073                 SizingBottomRight,
00074                 SizingTop,
00075                 SizingLeft,
00076                 SizingBottom,
00077                 SizingRight
00078         };
00079
00090         virtual void    initialise(void);
00091
00092
00100         bool    isSizingEnabled(void) const                                     {return d_sizingEnabled && isFrameEnabled();}
00101
00102
00110         bool    isFrameEnabled(void) const                                      {return d_frameEnabled;}
00111
00112
00120         bool    isTitleBarEnabled(void) const                           {return (d_titlebar != NULL) && !((Window*)d_titlebar)->isDisabled();}
00121
00122
00130         bool    isCloseButtonEnabled(void) const                        {return (d_closeButton != NULL) && !((Window*)d_closeButton)->isDisabled();}
00131
00132
00140         bool    isRollupEnabled(void) const                                     {return d_rollupEnabled;}
00141
00142
00150         bool    isRolledup(void) const                                          {return d_rolledup;}
00151
00152
00160         float   getSizingBorderThickness(void) const            {return d_borderSize;}
00161
00162
00173         void    setSizingEnabled(bool setting);
00174
00175
00186         void    setFrameEnabled(bool setting);
00187
00188
00199         void    setTitleBarEnabled(bool setting);
00200
00201
00212         void    setCloseButtonEnabled(bool setting);
00213
00214
00225         void    setRollupEnabled(bool setting);
00226
00227
00235         void    toggleRollup(void);
00236
00237
00248         void    setSizingBorderThickness(float pixels)          {d_borderSize = pixels;}
00249
00250
00261         void    setTitlebarFont(const String& name);
00262
00263
00274         void    setTitlebarFont(Font* font);
00275
00276
00289         void    offsetPixelPosition(const Vector2& offset);
00290
00291
00299         bool    isDragMovingEnabled(void) const         {return d_dragMovable;}
00300
00301
00312         void    setDragMovingEnabled(bool setting);
00313
00314
00322         const Font*     getTitlebarFont(void) const;
00323
00324
00332         colour  getCaptionColour(void) const;
00333
00334
00345         void    setCaptionColour(colour col);
00346
00355     const Image* getNSSizingCursorImage() const;
00356
00365     const Image* getEWSizingCursorImage() const;
00366
00375     const Image* getNWSESizingCursorImage() const;
00376
00385     const Image* getNESWSizingCursorImage() const;
00386
00397     void setNSSizingCursorImage(const Image* image);
00398
00409     void setEWSizingCursorImage(const Image* image);
00410
00421     void setNWSESizingCursorImage(const Image* image);
00422
00433     void setNESWSizingCursorImage(const Image* image);
00434
00450     void setNSSizingCursorImage(const String& imageset, const String& image);
00451
00467     void setEWSizingCursorImage(const String& imageset, const String& image);
00468
00484     void setNWSESizingCursorImage(const String& imageset, const String& image);
00485
00501     void setNESWSizingCursorImage(const String& imageset, const String& image);
00502
00503     // overridden from Window class
00504     bool    isHit(const Point& position) const      { return Window::isHit(position) && !d_rolledup; }
00505
00506
00507         /*************************************************************************
00508                 Construction / Destruction
00509         *************************************************************************/
00514         FrameWindow(const String& name, const String& type);
00515
00520         virtual ~FrameWindow(void);
00521
00522
00523 protected:
00524         /*************************************************************************
00525                 Implementation Functions
00526         *************************************************************************/
00537         virtual Titlebar*       createTitlebar(const String& name) const                = 0;
00538
00539
00550         virtual PushButton*     createCloseButton(const String& name) const     = 0;
00551
00552
00560         void    moveLeftEdge(float delta);
00561
00562
00570         void    moveRightEdge(float delta);
00571
00572
00580         void    moveTopEdge(float delta);
00581
00582
00590         void    moveBottomEdge(float delta);
00591
00592
00606         SizingLocation  getSizingBorderAtPoint(const Point& pt) const;
00607
00608
00619         bool    isLeftSizingLocation(SizingLocation loc) const                  {return ((loc == SizingLeft) || (loc == SizingTopLeft) || (loc == SizingBottomLeft));}
00620
00621
00632         bool    isRightSizingLocation(SizingLocation loc) const                 {return ((loc == SizingRight) || (loc == SizingTopRight) || (loc == SizingBottomRight));}
00633
00634
00645         bool    isTopSizingLocation(SizingLocation loc) const                   {return ((loc == SizingTop) || (loc == SizingTopLeft) || (loc == SizingTopRight));}
00646
00647
00658         bool    isBottomSizingLocation(SizingLocation loc) const                {return ((loc == SizingBottom) || (loc == SizingBottomLeft) || (loc == SizingBottomRight));}
00659
00660
00665         void    addFrameWindowEvents(void);
00666
00667
00672         bool    closeClickHandler(const EventArgs& e);
00673
00674
00679         void    setCursorForPoint(const Point& pt) const;
00680
00681
00686         virtual Rect    getSizingRect(void) const               {return Rect(0, 0, getAbsoluteWidth(), getAbsoluteHeight());}
00687
00688
00699         virtual bool    testClassName_impl(const String& class_name) const
00700         {
00701                 if (class_name==(const utf8*)"FrameWindow")     return true;
00702                 return Window::testClassName_impl(class_name);
00703         }
00704
00705
00706         /*************************************************************************
00707                 New events for Frame Windows
00708         *************************************************************************/
00714         virtual void    onRollupToggled(WindowEventArgs& e);
00715
00716
00721         virtual void    onCloseClicked(WindowEventArgs& e);
00722
00723
00724         /*************************************************************************
00725                 Overridden event handlers
00726         *************************************************************************/
00727         virtual void    onMouseMove(MouseEventArgs& e);
00728         virtual void    onMouseButtonDown(MouseEventArgs& e);
00729         virtual void    onMouseButtonUp(MouseEventArgs& e);
00730         virtual void    onCaptureLost(WindowEventArgs& e);
00731         virtual void    onTextChanged(WindowEventArgs& e);
00732         virtual void    onActivated(ActivationEventArgs& e);
00733         virtual void    onDeactivated(ActivationEventArgs& e);
00734
00735
00736         /*************************************************************************
00737                 Implementation Data
00738         *************************************************************************/
00739         // frame data
00740         bool    d_frameEnabled;
00741
00742         // window roll-up data
00743         bool    d_rollupEnabled;
00744         bool    d_rolledup;
00745
00746         // drag-sizing data
00747         bool    d_sizingEnabled;
00748         bool    d_beingSized;
00749         float   d_borderSize;
00750         Point   d_dragPoint;
00751
00752         // composite controls
00753         Titlebar*       d_titlebar;
00754         PushButton*     d_closeButton;
00755
00756         // images for cursor when on sizing border
00757         const Image*    d_nsSizingCursor;
00758         const Image*    d_ewSizingCursor;
00759         const Image*    d_nwseSizingCursor;
00760         const Image*    d_neswSizingCursor;
00761
00762         bool    d_dragMovable;
00763
00764
00765 private:
00766         /*************************************************************************
00767                 Static Properties for this class
00768         *************************************************************************/
00769         static FrameWindowProperties::SizingEnabled             d_sizingEnabledProperty;
00770         static FrameWindowProperties::FrameEnabled              d_frameEnabledProperty;
00771         static FrameWindowProperties::TitlebarEnabled   d_titlebarEnabledProperty;
00772         static FrameWindowProperties::CloseButtonEnabled d_closeButtonEnabledProperty;
00773         static FrameWindowProperties::RollUpState               d_rollUpStateProperty;
00774         static FrameWindowProperties::RollUpEnabled             d_rollUpEnabledProperty;
00775         static FrameWindowProperties::DragMovingEnabled d_dragMovingEnabledProperty;
00776         static FrameWindowProperties::SizingBorderThickness d_sizingBorderThicknessProperty;
00777         static FrameWindowProperties::TitlebarFont              d_titlebarFontProperty;
00778         static FrameWindowProperties::CaptionColour             d_captionColourProperty;
00779     static FrameWindowProperties::NSSizingCursorImage   d_nsSizingCursorProperty;
00780     static FrameWindowProperties::EWSizingCursorImage   d_ewSizingCursorProperty;
00781     static FrameWindowProperties::NWSESizingCursorImage d_nwseSizingCursorProperty;
00782     static FrameWindowProperties::NESWSizingCursorImage d_neswSizingCursorProperty;
00783
00784
00785         /*************************************************************************
00786                 Private methods
00787         *************************************************************************/
00788         void    addFrameWindowProperties(void);
00789 };
00790
00791 } // End of  CEGUI namespace section
00792
00793 #if defined(_MSC_VER)
00794 #       pragma warning(pop)
00795 #endif
00796
00797 #endif  // end of guard _CEGUIFrameWindow_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIFrameWindowProperties.h Source File

include » elements

CEGUIFrameWindowProperties.h

00001 /************************************************************************
00002         filename:       CEGUIFrameWindowProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for FrameWIndow class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIFrameWindowProperties_h_
00027 #define _CEGUIFrameWindowProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of FrameWindowProperties namespace section
00041 namespace FrameWindowProperties
00042 {
00055 class SizingEnabled : public Property
00056 {
00057 public:
00058         SizingEnabled() : Property(
00059                 "SizingEnabled",
00060                 "Property to get/set the state of the sizable setting for the FrameWindow.  Value is either \"True\" or \"False\".",
00061                 "True")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class FrameEnabled : public Property
00082 {
00083 public:
00084         FrameEnabled() : Property(
00085                 "FrameEnabled",
00086                 "Property to get/set the setting for whether the window frame will be displayed.  Value is either \"True\" or \"False\".",
00087                 "True")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00107 class TitlebarEnabled : public Property
00108 {
00109 public:
00110         TitlebarEnabled() : Property(
00111                 "TitlebarEnabled",
00112                 "Property to get/set the setting for whether the window title-bar will be enabled (or displayed depending upon choice of final widget type).  Value is either \"True\" or \"False\".",
00113                 "")
00114         {}
00115
00116         String  get(const PropertyReceiver* receiver) const;
00117         void    set(PropertyReceiver* receiver, const String& value);
00118 };
00119
00120
00133 class CloseButtonEnabled : public Property
00134 {
00135 public:
00136         CloseButtonEnabled() : Property(
00137                 "CloseButtonEnabled",
00138                 "Property to get/set the setting for whether the window close button will be enabled (or displayed depending upon choice of final widget type).  Value is either \"True\" or \"False\".",
00139                 "True")
00140         {}
00141
00142         String  get(const PropertyReceiver* receiver) const;
00143         void    set(PropertyReceiver* receiver, const String& value);
00144 };
00145
00146
00159 class RollUpEnabled : public Property
00160 {
00161 public:
00162         RollUpEnabled() : Property(
00163                 "RollUpEnabled",
00164                 "Property to get/set the setting for whether the user is able to roll-up / shade the window.  Value is either \"True\" or \"False\".",
00165                 "True")
00166         {}
00167
00168         String  get(const PropertyReceiver* receiver) const;
00169         void    set(PropertyReceiver* receiver, const String& value);
00170 };
00171
00172
00185 class RollUpState : public Property
00186 {
00187 public:
00188         RollUpState() : Property(
00189                 "RollUpState",
00190                 "Property to get/set the roll-up / shade state of the window.  Value is either \"True\" or \"False\".",
00191                 "False")
00192         {}
00193
00194         String  get(const PropertyReceiver* receiver) const;
00195         void    set(PropertyReceiver* receiver, const String& value);
00196 };
00197
00198
00211 class DragMovingEnabled : public Property
00212 {
00213 public:
00214         DragMovingEnabled() : Property(
00215                 "DragMovingEnabled",
00216                 "Property to get/set the setting for whether the user may drag the window around by its title bar.  Value is either \"True\" or \"False\".",
00217                 "True")
00218         {}
00219
00220         String  get(const PropertyReceiver* receiver) const;
00221         void    set(PropertyReceiver* receiver, const String& value);
00222 };
00223
00224
00236 class SizingBorderThickness : public Property
00237 {
00238 public:
00239         SizingBorderThickness() : Property(
00240                 "SizingBorderThickness",
00241                 "Property to get/set the setting for the sizing border thickness.  Value is a float specifying the border thickness in pixels.",
00242                 "8.000000")
00243         {}
00244
00245         String  get(const PropertyReceiver* receiver) const;
00246         void    set(PropertyReceiver* receiver, const String& value);
00247 };
00248
00249
00261 class TitlebarFont : public Property
00262 {
00263 public:
00264         TitlebarFont() : Property(
00265                 "TitlebarFont",
00266                 "Property to get/set the Font set for the windows title bar.  Value is the name of the font to use (must be loaded already).",
00267                 "")
00268         {}
00269
00270         String  get(const PropertyReceiver* receiver) const;
00271         void    set(PropertyReceiver* receiver, const String& value);
00272 };
00273
00285 class CaptionColour : public Property
00286 {
00287 public:
00288         CaptionColour() : Property(
00289                 "CaptionColour",
00290                 "Property to get/set the colour used for rendering the caption text.  Value is \"aarrggbb\" (hex).",
00291                 "FF000000")
00292         {}
00293
00294         String  get(const PropertyReceiver* receiver) const;
00295         void    set(PropertyReceiver* receiver, const String& value);
00296 };
00297
00307 class NSSizingCursorImage : public Property
00308 {
00309 public:
00310    NSSizingCursorImage() : Property(
00311            "NSSizingCursorImage",
00312            "Property to get/set the N-S (up-down) sizing cursor image for the FramwWindow.  Value should be \"set:[imageset name] image:[image name]\".",
00313            "")
00314    {}
00315
00316    String   get(const PropertyReceiver* receiver) const;
00317    void   set(PropertyReceiver* receiver, const String& value);
00318 };
00319
00329 class EWSizingCursorImage : public Property
00330 {
00331 public:
00332    EWSizingCursorImage() : Property(
00333            "EWSizingCursorImage",
00334            "Property to get/set the E-W (left-right) sizing cursor image for the FramwWindow.  Value should be \"set:[imageset name] image:[image name]\".",
00335            "")
00336    {}
00337
00338    String   get(const PropertyReceiver* receiver) const;
00339    void   set(PropertyReceiver* receiver, const String& value);
00340 };
00341
00351 class NWSESizingCursorImage : public Property
00352 {
00353 public:
00354    NWSESizingCursorImage() : Property(
00355            "NWSESizingCursorImage",
00356            "Property to get/set the NW-SE diagonal sizing cursor image for the FramwWindow.  Value should be \"set:[imageset name] image:[image name]\".",
00357            "")
00358    {}
00359
00360    String   get(const PropertyReceiver* receiver) const;
00361    void   set(PropertyReceiver* receiver, const String& value);
00362 };
00363
00373 class NESWSizingCursorImage : public Property
00374 {
00375 public:
00376    NESWSizingCursorImage() : Property(
00377            "NESWSizingCursorImage",
00378            "Property to get/set the NE-SW diagonal sizing cursor image for the FramwWindow.  Value should be \"set:[imageset name] image:[image name]\".",
00379            "")
00380    {}
00381
00382    String   get(const PropertyReceiver* receiver) const;
00383    void   set(PropertyReceiver* receiver, const String& value);
00384 };
00385
00386 } // End of  FrameWindowProperties namespace section
00387
00388 } // End of  CEGUI namespace section
00389
00390
00391 #endif  // end of guard _CEGUIFrameWindowProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIGlobalEventSet.h Source File

include

CEGUIGlobalEventSet.h

00001 /************************************************************************
00002         filename:       CEGUIGlobalEventSet.h
00003         created:        16/1/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http:www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIGlobalEventSet_h_
00025 #define _CEGUIGlobalEventSet_h_
00026
00027 #include "CEGUIEventSet.h"
00028 #include "CEGUISingleton.h"
00029
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4275)
00034 #endif
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00046 class CEGUIEXPORT GlobalEventSet : public EventSet, public Singleton<GlobalEventSet>
00047 {
00048 public:
00049         GlobalEventSet();
00050         ~GlobalEventSet();
00051
00052
00060         static  GlobalEventSet& getSingleton(void);
00061
00062
00070         static  GlobalEventSet* getSingletonPtr(void);
00071
00072
00089         virtual Event::Connection       subscribeEvent(const String& name, Event::Subscriber subscriber);
00090
00091
00111         virtual Event::Connection       subscribeEvent(const String& name, Event::Group group, Event::Subscriber subscriber);
00112
00113
00131         virtual void    fireEvent(const String& name, EventArgs& args, const String& eventNamespace = "");
00132 };
00133
00134 } // End of  CEGUI namespace section
00135
00136
00137 #if defined(_MSC_VER)
00138 #       pragma warning(pop)
00139 #endif
00140
00141 #endif  // end of guard _CEGUIGlobalEventSet_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIGUILayout_xmlHandler.h Source File

include

CEGUIGUILayout_xmlHandler.h

00001 /************************************************************************
00002         filename:       CEGUIGUILayout_xmlHandler.h
00003         created:        5/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to XML parser for GUILayout files
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIGUILayout_xmlHandler_h_
00027 #define _CEGUIGUILayout_xmlHandler_h_
00028
00029 #include "CEGUIWindowManager.h"
00030 #include "CEGUIWindow.h"
00031 #include "CEGUIXMLHandler.h"
00032
00033 #include <vector>
00034
00035 // Start of CEGUI namespace section
00036 namespace CEGUI
00037 {
00042 class GUILayout_xmlHandler : public XMLHandler
00043 {
00044         typedef WindowManager::PropertyCallback PropertyCallback;
00045 public:
00046         /*************************************************************************
00047                 Construction & Destruction
00048         *************************************************************************/
00053         GUILayout_xmlHandler(const String& name_prefix, PropertyCallback* callback = NULL, void* userdata = NULL) :
00054           d_root(NULL),
00055           d_namingPrefix(name_prefix),
00056           d_propertyCallback(callback),
00057           d_userData(userdata)
00058           {}
00059
00064         virtual ~GUILayout_xmlHandler(void) {}
00065
00066         /*************************************************************************
00067                 SAX2 Handler overrides
00068         *************************************************************************/
00073     virtual void elementStart(const String& element, const XMLAttributes& attributes);
00074     virtual void elementEnd(const String& element);
00075
00076         /*************************************************************************
00077                 Functions used by our implementation
00078         *************************************************************************/
00083         void    cleanupLoadedWindows(void);
00084
00085
00090         Window* getLayoutRootWindow(void) const;
00091
00092 private:
00093         /*************************************************************************
00094                 Implementation Constants
00095         *************************************************************************/
00096         static const String GUILayoutElement;
00097         static const String WindowElement;
00098         static const String PropertyElement;
00099         static const String LayoutImportElement;
00100         static const String EventElement;
00101         static const char       WindowTypeAttribute[];
00102         static const char       WindowNameAttribute[];
00103         static const char       PropertyNameAttribute[];
00104         static const char       PropertyValueAttribute[];
00105         static const char       LayoutParentAttribute[];
00106         static const char       LayoutImportFilenameAttribute[];
00107         static const char       LayoutImportPrefixAttribute[];
00108     static const char   LayoutImportResourceGroupAttribute[];
00109         static const char       EventNameAttribute[];
00110         static const char       EventFunctionAttribute[];
00111
00112
00113         /*************************************************************************
00114                 Implementation Data
00115         *************************************************************************/
00116         typedef std::vector<Window*>    WindowStack;
00117         Window* d_root;
00118         WindowStack     d_stack;
00119         String          d_layoutParent;
00120         const String&           d_namingPrefix;
00121         PropertyCallback*       d_propertyCallback;
00122         void*                           d_userData;
00123 };
00124
00125
00126 } // End of  CEGUI namespace section
00127
00128
00129 #endif  // end of guard _CEGUIGUILayout_xmlHandler_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIGUISheet.h Source File

include » elements

CEGUIGUISheet.h

00001 /************************************************************************
00002     filename:   CEGUIGUISheet.h
00003     created:    5/6/2004
00004     author:     Paul D Turner
00005
00006     purpose:    Interface to a default window
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIGUISheet_h_
00027 #define _CEGUIGUISheet_h_
00028
00029 #include "CEGUIWindow.h"
00030 #include "CEGUIWindowFactory.h"
00031
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00047 class CEGUIEXPORT GUISheet : public Window
00048 {
00049 public:
00050     /*************************************************************************
00051         Constants
00052     *************************************************************************/
00053     // type name for this widget
00054     static const String WidgetTypeName;
00055
00056
00057     /*************************************************************************
00058         Construction and Destruction
00059     *************************************************************************/
00064     GUISheet(const String& type, const String& name) : Window(type, name) {}
00065
00066
00071     virtual ~GUISheet(void) {}
00072
00073
00074 protected:
00085     virtual void    drawSelf(float z) {}
00086
00087
00092     void initialise(void)
00093     {
00094         Window::initialise();
00095
00096         setMaximumSize(Size(1.0f, 1.0f));
00097         setSize(Size(1.0f, 1.0f));
00098     }
00099
00100
00111         virtual bool    testClassName_impl(const String& class_name) const
00112         {
00113                 if (class_name==(const utf8*)"GUISheet")        return true;
00114                 return Window::testClassName_impl(class_name);
00115         }
00116 };
00117
00118
00123 class GUISheetFactory : public WindowFactory
00124 {
00125 public:
00126     /*************************************************************************
00127         Construction and Destruction
00128     *************************************************************************/
00129     GUISheetFactory(void) : WindowFactory(GUISheet::WidgetTypeName) { }
00130     ~GUISheetFactory(void){}
00131
00132
00143     Window* createWindow(const String& name)
00144     {
00145         return new GUISheet(d_type, name);
00146     }
00147
00148
00159     virtual void    destroyWindow(Window* window)    { if (window->getType() == d_type) delete window; }
00160 };
00161
00166 typedef GUISheet DefaultWindow;
00167
00168
00169 } // End of  CEGUI namespace section
00170
00171
00172 #endif  // end of guard _CEGUIGUISheet_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIImage.h Source File

include

CEGUIImage.h

00001 /************************************************************************
00002         filename:       CEGUIImage.h
00003         created:        13/3/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for Image class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIImage_h_
00027 #define _CEGUIImage_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIRect.h"
00032 #include "CEGUIColourRect.h"
00033 #include "CEGUIVector.h"
00034 #include "CEGUISize.h"
00035 #include "CEGUIRenderer.h"
00036 #include <map>
00037
00038
00039 #if defined(_MSC_VER)
00040 #       pragma warning(push)
00041 #       pragma warning(disable : 4251)
00042 #endif
00043
00044
00045 // Start of CEGUI namespace section
00046 namespace CEGUI
00047 {
00052 class CEGUIEXPORT Image
00053 {
00054 public:
00062         Size    getSize(void) const                     {return Size(d_scaledWidth, d_scaledHeight);}
00063
00064
00072         float   getWidth(void) const            {return d_scaledWidth;}
00073
00074
00082         float   getHeight(void) const           {return d_scaledHeight;}
00083
00084
00092         Point   getOffsets(void) const          {return d_scaledOffset;}
00093
00094
00102         float   getOffsetX(void) const          {return d_scaledOffset.d_x;}
00103
00104
00112         float   getOffsetY(void) const          {return d_scaledOffset.d_y;}
00113
00114
00122         const String&   getName(void) const;
00123
00124
00132         const String&   getImagesetName(void) const;
00133
00142     const Rect& getSourceTextureArea(void) const;
00143
00181         void    draw(const Vector3& position, const Size& size, const Rect& clip_rect, const colour& top_left_colour = 0xFFFFFFFF, const colour& top_right_colour = 0xFFFFFFFF, const colour& bottom_left_colour = 0xFFFFFFFF, const colour& bottom_right_colour = 0xFFFFFFFF, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const
00182         {
00183                 draw(Rect(position.d_x, position.d_y, position.d_x + size.d_width, position.d_y + size.d_height), position.d_z, clip_rect,
00184                         ColourRect(top_left_colour, top_right_colour, bottom_left_colour, bottom_right_colour), quad_split_mode);
00185         }
00186
00187
00225         void    draw(const Rect& dest_rect, float z, const Rect& clip_rect, const colour& top_left_colour = 0xFFFFFFFF, const colour& top_right_colour = 0xFFFFFFFF, const colour& bottom_left_colour = 0xFFFFFFFF, const colour& bottom_right_colour = 0xFFFFFFFF, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const
00226         {
00227                 draw(dest_rect, z, clip_rect, ColourRect(top_left_colour, top_right_colour, bottom_left_colour, bottom_right_colour), quad_split_mode);
00228         }
00229
00230
00259         void    draw(const Vector3& position, const Size& size, const Rect& clip_rect, const ColourRect& colours, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const
00260         {
00261                 draw(Rect(position.d_x, position.d_y, position.d_x + size.d_width, position.d_y + size.d_height), position.d_z, clip_rect, colours, quad_split_mode);
00262         }
00263
00264
00293         void    draw(const Vector3& position, const Rect& clip_rect, const ColourRect& colours, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const
00294         {
00295                 draw(Rect(position.d_x, position.d_y, position.d_x + getWidth(), position.d_y + getHeight()), position.d_z, clip_rect, colours, quad_split_mode);
00296         }
00297
00298
00333         void    draw(const Vector3& position, const Rect& clip_rect, const colour& top_left_colour = 0xFFFFFFFF, const colour& top_right_colour = 0xFFFFFFFF, const colour& bottom_left_colour = 0xFFFFFFFF, const colour& bottom_right_colour = 0xFFFFFFFF, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const
00334         {
00335                 draw(Rect(position.d_x, position.d_y, position.d_x + getWidth(), position.d_y + getHeight()), position.d_z, clip_rect, ColourRect(top_left_colour, top_right_colour, bottom_left_colour, bottom_right_colour), quad_split_mode);
00336         }
00337
00338
00367         void    draw(const Rect& dest_rect, float z, const Rect& clip_rect,const ColourRect& colours, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const;
00368
00369
00380     void writeXMLToStream(OutStream& out_stream) const;
00381
00382
00383         friend class std::map<String, Image>;
00384         friend struct std::pair<const String, Image>;
00385
00386
00387         /*************************************************************************
00388                 Construction and Destruction
00389         *************************************************************************/
00394         Image(void) {}
00395
00396
00421         Image(const Imageset* owner, const String& name, const Rect& area, const Point& render_offset, float horzScaling = 1.0f, float vertScaling = 1.0f);
00422
00423
00424
00429         Image(const Image& image);
00430
00431
00436         ~Image(void);
00437
00438
00439 private:
00440         /*************************************************************************
00441                 Friends
00442         *************************************************************************/
00443         friend class Imageset;
00444
00445
00446         /*************************************************************************
00447                 Implementation Methods
00448         *************************************************************************/
00459         void    setHorzScaling(float factor);
00460
00461
00472         void    setVertScaling(float factor);
00473
00474
00475         /*************************************************************************
00476                 Implementation Data
00477         *************************************************************************/
00478         const Imageset* d_owner;
00479         Rect                    d_area;
00480         Point                   d_offset;
00481
00482         // image auto-scaling fields.
00483         float   d_scaledWidth;
00484         float   d_scaledHeight;
00485         Point   d_scaledOffset;
00486         String  d_name;
00487 };
00488
00489 } // End of  CEGUI namespace section
00490
00491 #if defined(_MSC_VER)
00492 #       pragma warning(pop)
00493 #endif
00494
00495 #endif  // end of guard _CEGUIImage_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIImageset.h Source File

include

CEGUIImageset.h

00001 /************************************************************************
00002         filename:       CEGUIImageset.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines the interface for the Imageset class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIImageset_h_
00027 #define _CEGUIImageset_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIRect.h"
00032 #include "CEGUIColourRect.h"
00033 #include "CEGUIImagesetManager.h"
00034 #include "CEGUIImage.h"
00035 #include "CEGUIIteratorBase.h"
00036
00037 #include <map>
00038
00039
00040 #if defined(_MSC_VER)
00041 #       pragma warning(push)
00042 #       pragma warning(disable : 4251)
00043 #endif
00044
00045
00046 // Start of CEGUI namespace section
00047 namespace CEGUI
00048 {
00049
00058 class CEGUIEXPORT Imageset
00059 {
00060         friend class Imageset_xmlHandler;
00061 private:
00062         typedef std::map<String, Image> ImageRegistry;
00063
00064         /*************************************************************************
00065                 Friends to allow access to constructors and destructors
00066         *************************************************************************/
00067         friend Imageset*        ImagesetManager::createImageset(const String& name, Texture* texture);
00068         friend Imageset*        ImagesetManager::createImageset(const String& filename, const String& resourceGroup);
00069         friend Imageset*        ImagesetManager::createImagesetFromImageFile(const String& name, const String& filename, const String& resourceGroup);
00070         friend void                     ImagesetManager::destroyImageset(const String& name);
00071
00072
00073         /*************************************************************************
00074                 Construction and Destruction (private, only ImagesetManager can
00075                 create and destroy Imageset objects).
00076         *************************************************************************/
00084         Imageset(const String& name, Texture* texture);
00085
00086
00100         Imageset(const String& filename, const String& resourceGroup);
00101
00102
00128     Imageset(const String& name, const String& filename, const String& resourceGroup);
00129
00130
00131 public: // For luabind support
00136         ~Imageset(void);
00137
00138
00139 public:
00140         typedef ConstBaseIterator<ImageRegistry>        ImageIterator;
00141
00142         /*************************************************************************
00143                 Public interface
00144         *************************************************************************/
00152         Texture*        getTexture(void) const                                          {return d_texture;}
00153
00154
00162         const String&   getName(void) const                                             {return d_name;}
00163
00164
00172         uint      getImageCount(void) const               {return (uint)d_images.size();}
00173
00174
00185         bool            isImageDefined(const String& name) const        {return d_images.find(name) != d_images.end();}
00186
00187
00200         const Image&    getImage(const String& name) const;
00201
00202
00212         void    undefineImage(const String& name);
00213
00214
00222         void    undefineAllImages(void);
00223
00224
00237         Size    getImageSize(const String& name) const                  {return getImage(name).getSize();}
00238
00239
00252         float   getImageWidth(const String& name) const                 {return getImage(name).getWidth();}
00253
00254
00267         float   getImageHeight(const String& name) const                {return getImage(name).getHeight();}
00268
00269
00282         Point   getImageOffset(const String& name) const                {return getImage(name).getOffsets();}
00283
00284
00297         float   getImageOffsetX(const String& name) const               {return getImage(name).getOffsetX();}
00298
00299
00312         float   getImageOffsetY(const String& name) const               {return getImage(name).getOffsetY();}
00313
00314
00336         void    defineImage(const String& name, const Point& position, const Size& size, const Point& render_offset)
00337         {
00338                 defineImage(name, Rect(position.d_x, position.d_y, position.d_x + size.d_width, position.d_y + size.d_height), render_offset);
00339         }
00340
00341
00360         void    defineImage(const String& name, const Rect& image_rect, const Point& render_offset);
00361
00362
00388         void    draw(const Rect& source_rect, const Rect& dest_rect, float z, const Rect& clip_rect,const ColourRect& colours, QuadSplitMode quad_split_mode) const;
00389
00390
00425         void    draw(const Rect& source_rect, const Rect& dest_rect, float z, const Rect& clip_rect, const colour& top_left_colour = 0xFFFFFFFF, const colour& top_right_colour = 0xFFFFFFFF,  const colour& bottom_left_colour = 0xFFFFFFFF, const colour& bottom_right_colour = 0xFFFFFFFF, QuadSplitMode quad_split_mode = TopLeftToBottomRight) const
00426         {
00427                 draw(source_rect, dest_rect, z, clip_rect, ColourRect(top_left_colour, top_right_colour, bottom_left_colour, bottom_right_colour), quad_split_mode);
00428         }
00429
00430
00438         bool    isAutoScaled(void) const                {return d_autoScale;}
00439
00440
00448         Size    getNativeResolution(void) const {return Size(d_nativeHorzRes, d_nativeVertRes);}
00449
00450
00461         void    setAutoScalingEnabled(bool setting);
00462
00463
00474         void    setNativeResolution(const Size& size);
00475
00476
00487         void    notifyScreenResolution(const Size& size);
00488
00489
00494         ImageIterator   getIterator(void) const;
00495
00496
00507     void writeXMLToStream(OutStream& out_stream) const;
00508
00509
00510 protected:
00511         /*************************************************************************
00512                 Implementation Constants
00513         *************************************************************************/
00514         static const char       ImagesetSchemaName[];
00515
00516
00517         /*************************************************************************
00518                 Implementation Functions
00519         *************************************************************************/
00536         void    load(const String& filename, const String& resourceGroup);
00537
00538
00543         void    unload(void);
00544
00545
00558         void    setTexture(Texture* texture);
00559
00560
00568         void    updateImageScalingFactors(void);
00569
00570         /*************************************************************************
00571                 Implementation Data
00572         *************************************************************************/
00573         String                  d_name;
00574         ImageRegistry   d_images;
00575         Texture*                d_texture;
00576     String          d_textureFilename;
00577
00578         // auto-scaling fields
00579         bool    d_autoScale;
00580         float   d_horzScaling;
00581         float   d_vertScaling;
00582         float   d_nativeHorzRes;
00583         float   d_nativeVertRes;
00584 };
00585
00586 } // End of  CEGUI namespace section
00587
00588 #if defined(_MSC_VER)
00589 #       pragma warning(pop)
00590 #endif
00591
00592 #endif  // end of guard _CEGUIImageset_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIImageset_xmlHandler.h Source File

include

CEGUIImageset_xmlHandler.h

00001 /************************************************************************
00002 filename:       CEGUIImageset_xmlHandler.h
00003 created:        21/2/2004
00004 author:         Paul D Turner
00005
00006 purpose:        Defines the interface for the Imageset class
00007 *************************************************************************/
00008 /*************************************************************************
00009 Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010 Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012 This library is free software; you can redistribute it and/or
00013 modify it under the terms of the GNU Lesser General Public
00014 License as published by the Free Software Foundation; either
00015 version 2.1 of the License, or (at your option) any later version.
00016
00017 This library is distributed in the hope that it will be useful,
00018 but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020 Lesser General Public License for more details.
00021
00022 You should have received a copy of the GNU Lesser General Public
00023 License along with this library; if not, write to the Free Software
00024 Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIImageset_xmlHandler_h_
00027 #define _CEGUIImageset_xmlHandler_h_
00028
00029 #include "CEGUIImageset.h"
00030 #include "CEGUIXMLHandler.h"
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 /*************************************************************************
00037 Implementation Classes
00038 *************************************************************************/
00043 class Imageset_xmlHandler : public XMLHandler
00044 {
00045 public:
00046         /*************************************************************************
00047         Construction & Destruction
00048         *************************************************************************/
00056         Imageset_xmlHandler(Imageset* imageset) : d_imageset(imageset) {}
00057
00062         virtual ~Imageset_xmlHandler(void) {}
00063
00064         /*************************************************************************
00065         SAX2 Handler overrides
00066         *************************************************************************/
00071     virtual void elementStart(const String& element, const XMLAttributes& attributes);
00072     virtual void elementEnd(const String& element);
00073
00074         /*************************************************************************
00075         Functions used by our implementation
00076         *************************************************************************/
00077         Imageset*       getImageset(void) const                         {return d_imageset;}
00078
00079 private:
00080         /*************************************************************************
00081         Implementation Constants
00082         *************************************************************************/
00083         static const String ImagesetElement;
00084         static const String ImageElement;
00085         static const char       ImagesetNameAttribute[];
00086         static const char       ImagesetImageFileAttribute[];
00087     static const char   ImagesetResourceGroupAttribute[];
00088         static const char       ImagesetNativeHorzResAttribute[];
00089         static const char       ImagesetNativeVertResAttribute[];
00090         static const char       ImagesetAutoScaledAttribute[];
00091         static const char       ImageNameAttribute[];
00092         static const char       ImageXPosAttribute[];
00093         static const char       ImageYPosAttribute[];
00094         static const char       ImageWidthAttribute[];
00095         static const char       ImageHeightAttribute[];
00096         static const char       ImageXOffsetAttribute[];
00097         static const char       ImageYOffsetAttribute[];
00098
00099         /*************************************************************************
00100         Implementation Data
00101         *************************************************************************/
00102         Imageset*       d_imageset;
00103 };
00104
00105 } // End of  CEGUI namespace section
00106
00107 #endif  // end of guard _CEGUIImageset_xmlHandler_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIImagesetManager.h Source File

include

CEGUIImagesetManager.h

00001 /************************************************************************
00002         filename:       CEGUIImagesetManager.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for ImagesetManager object
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIImagesetManager_h_
00027 #define _CEGUIImagesetManager_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUIIteratorBase.h"
00033 #include <map>
00034
00035
00036 #if defined(_MSC_VER)
00037 #       pragma warning(push)
00038 #       pragma warning(disable : 4275)
00039 #       pragma warning(disable : 4251)
00040 #endif
00041
00042
00043 // Start of CEGUI namespace section
00044 namespace CEGUI
00045 {
00054 class CEGUIEXPORT ImagesetManager : public Singleton<ImagesetManager>
00055 {
00056 public:
00061         ImagesetManager(void);
00062
00063
00068         ~ImagesetManager(void);
00069
00070
00078         static  ImagesetManager&        getSingleton(void);
00079
00080
00088         static  ImagesetManager*        getSingletonPtr(void);
00089
00090
00108         Imageset*       createImageset(const String& name, Texture* texture);
00109
00127         Imageset*       createImageset(const String& filename, const String& resourceGroup = "");
00128
00129
00150     Imageset* createImagesetFromImageFile(const String& name, const String& filename, const String& resourceGroup = "");
00151
00152
00163         void    destroyImageset(const String& name);
00164
00175         void    destroyImageset(Imageset* imageset);
00176
00177
00185         void    destroyAllImagesets(void);
00186
00187
00200         Imageset*       getImageset(const String& name) const;
00201
00202
00213         bool    isImagesetPresent(const String& name) const                     {return d_imagesets.find(name) != d_imagesets.end();}
00214
00215
00226         void    notifyScreenResolution(const Size& size);
00227
00228
00242     void writeImagesetToStream(const String& imageset, OutStream& out_stream) const;
00243
00244
00245 private:
00246         /*************************************************************************
00247                 Implementation Data
00248         *************************************************************************/
00249         typedef std::map<String, Imageset*>             ImagesetRegistry;
00250         ImagesetRegistry        d_imagesets;
00251
00252 public:
00253         /*************************************************************************
00254                 Iterator stuff
00255         *************************************************************************/
00256         typedef ConstBaseIterator<ImagesetRegistry>     ImagesetIterator;
00257
00262         ImagesetIterator        getIterator(void) const;
00263 };
00264
00265 } // End of  CEGUI namespace section
00266
00267 #if defined(_MSC_VER)
00268 #       pragma warning(pop)
00269 #endif
00270
00271 #endif  // end of guard _CEGUIImageSetManager_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIInputEvent.h Source File

include

CEGUIInputEvent.h

00001 /************************************************************************
00002         filename:       CEGUIInputEvent.h
00003         created:        30/5/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface to input event classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIInputEvent_h_
00027 #define _CEGUIInputEvent_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIEventArgs.h"
00031 #include "CEGUIString.h"
00032 #include "CEGUIVector.h"
00033
00034
00035 // Start of CEGUI namespace section
00036 namespace CEGUI
00037 {
00042 struct CEGUIEXPORT Key
00043 {
00044         // enumeration of scan codes.  Customised from table taken from Ogre, which took them from DirectInput...
00045         enum Scan
00046     {
00047         Escape          =0x01,
00048         One             =0x02,
00049         Two             =0x03,
00050         Three           =0x04,
00051         Four            =0x05,
00052         Five            =0x06,
00053         Six             =0x07,
00054         Seven           =0x08,
00055         Eight           =0x09,
00056         Nine            =0x0A,
00057         Zero            =0x0B,
00058         Minus           =0x0C,    /* - on main keyboard */
00059         Equals                  =0x0D,
00060         Backspace               =0x0E,    /* backspace */
00061         Tab                             =0x0F,
00062         Q               =0x10,
00063         W               =0x11,
00064         E               =0x12,
00065         R               =0x13,
00066         T               =0x14,
00067         Y               =0x15,
00068         U               =0x16,
00069         I               =0x17,
00070         O               =0x18,
00071         P               =0x19,
00072         LeftBracket     =0x1A,
00073         RightBracket    =0x1B,
00074         Return                  =0x1C,    /* Enter on main keyboard */
00075         LeftControl             =0x1D,
00076         A               =0x1E,
00077         S               =0x1F,
00078         D               =0x20,
00079         F               =0x21,
00080         G               =0x22,
00081         H               =0x23,
00082         J               =0x24,
00083         K               =0x25,
00084         L               =0x26,
00085         Semicolon       =0x27,
00086         Apostrophe              =0x28,
00087         Grave           =0x29,    /* accent grave */
00088         LeftShift       =0x2A,
00089         Backslash       =0x2B,
00090         Z               =0x2C,
00091         X               =0x2D,
00092         C               =0x2E,
00093         V               =0x2F,
00094         B               =0x30,
00095         N               =0x31,
00096         M               =0x32,
00097         Comma           =0x33,
00098         Period          =0x34,    /* . on main keyboard */
00099         Slash           =0x35,    /* '/' on main keyboard */
00100         RightShift      =0x36,
00101         Multiply        =0x37,    /* * on numeric keypad */
00102         LeftAlt        =0x38,    /* left Alt */
00103         Space           =0x39,
00104         Capital         =0x3A,
00105         F1              =0x3B,
00106         F2              =0x3C,
00107         F3              =0x3D,
00108         F4              =0x3E,
00109         F5              =0x3F,
00110         F6              =0x40,
00111         F7              =0x41,
00112         F8              =0x42,
00113         F9              =0x43,
00114         F10             =0x44,
00115         NumLock         =0x45,
00116         ScrollLock      =0x46,    /* Scroll Lock */
00117         Numpad7         =0x47,
00118         Numpad8         =0x48,
00119         Numpad9         =0x49,
00120         Subtract        =0x4A,    /* - on numeric keypad */
00121         Numpad4         =0x4B,
00122         Numpad5         =0x4C,
00123         Numpad6         =0x4D,
00124         Add                             =0x4E,    /* + on numeric keypad */
00125         Numpad1         =0x4F,
00126         Numpad2         =0x50,
00127         Numpad3         =0x51,
00128         Numpad0         =0x52,
00129         Decimal                 =0x53,    /* . on numeric keypad */
00130         OEM_102         =0x56,    /* < > | on UK/Germany keyboards */
00131         F11             =0x57,
00132         F12             =0x58,
00133         F13             =0x64,    /*                     (NEC PC98) */
00134         F14             =0x65,    /*                     (NEC PC98) */
00135         F15             =0x66,    /*                     (NEC PC98) */
00136         Kana            =0x70,    /* (Japanese keyboard)            */
00137         ABNT_C1         =0x73,    /* / ? on Portugese (Brazilian) keyboards */
00138         Convert         =0x79,    /* (Japanese keyboard)            */
00139         NoConvert       =0x7B,    /* (Japanese keyboard)            */
00140         Yen             =0x7D,    /* (Japanese keyboard)            */
00141         ABNT_C2         =0x7E,    /* Numpad . on Portugese (Brazilian) keyboards */
00142         NumpadEquals    =0x8D,    /* = on numeric keypad (NEC PC98) */
00143         PrevTrack       =0x90,    /* Previous Track (KC_CIRCUMFLEX on Japanese keyboard) */
00144         At              =0x91,    /*                     (NEC PC98) */
00145         Colon           =0x92,    /*                     (NEC PC98) */
00146         Underline       =0x93,    /*                     (NEC PC98) */
00147         Kanji           =0x94,    /* (Japanese keyboard)            */
00148         Stop            =0x95,    /*                     (NEC PC98) */
00149         AX              =0x96,    /*                     (Japan AX) */
00150         Unlabeled       =0x97,    /*                        (J3100) */
00151         NextTrack       =0x99,    /* Next Track */
00152         NumpadEnter     =0x9C,    /* Enter on numeric keypad */
00153         RightControl    =0x9D,
00154         Mute            =0xA0,    /* Mute */
00155         Calculator      =0xA1,    /* Calculator */
00156         PlayPause       =0xA2,    /* Play / Pause */
00157         MediaStop       =0xA4,    /* Media Stop */
00158         VolumeDown      =0xAE,    /* Volume - */
00159         VolumeUp        =0xB0,    /* Volume + */
00160         WebHome         =0xB2,    /* Web home */
00161         NumpadComma     =0xB3,    /* , on numeric keypad (NEC PC98) */
00162         Divide          =0xB5,    /* / on numeric keypad */
00163         SysRq           =0xB7,
00164         RightAlt        =0xB8,    /* right Alt */
00165         Pause           =0xC5,    /* Pause */
00166         Home            =0xC7,    /* Home on arrow keypad */
00167         ArrowUp         =0xC8,    /* UpArrow on arrow keypad */
00168         PageUp          =0xC9,    /* PgUp on arrow keypad */
00169         ArrowLeft       =0xCB,    /* LeftArrow on arrow keypad */
00170         ArrowRight      =0xCD,    /* RightArrow on arrow keypad */
00171         End             =0xCF,    /* End on arrow keypad */
00172         ArrowDown       =0xD0,    /* DownArrow on arrow keypad */
00173         PageDown                =0xD1,    /* PgDn on arrow keypad */
00174         Insert          =0xD2,    /* Insert on arrow keypad */
00175         Delete          =0xD3,    /* Delete on arrow keypad */
00176         LeftWindows     =0xDB,    /* Left Windows key */
00177         RightWindow     =0xDC,    /* Right Windows key */
00178         RightWindows    =0xDC,    /* Right Windows key - Correct spelling :) */
00179         AppMenu         =0xDD,    /* AppMenu key */
00180         Power           =0xDE,    /* System Power */
00181         Sleep           =0xDF,    /* System Sleep */
00182         Wake                    =0xE3,    /* System Wake */
00183         WebSearch               =0xE5,    /* Web Search */
00184         WebFavorites    =0xE6,    /* Web Favorites */
00185         WebRefresh              =0xE7,    /* Web Refresh */
00186         WebStop                 =0xE8,    /* Web Stop */
00187         WebForward              =0xE9,    /* Web Forward */
00188         WebBack                 =0xEA,    /* Web Back */
00189         MyComputer              =0xEB,    /* My Computer */
00190         Mail                    =0xEC,    /* Mail */
00191         MediaSelect             =0xED     /* Media Select */
00192     };
00193
00194 };
00195
00196
00201 enum MouseButton
00202 {
00203         LeftButton,
00204         RightButton,
00205         MiddleButton,
00206         X1Button,
00207         X2Button,
00208         MouseButtonCount,               //<! Dummy value that is == to the maximum number of mouse buttons supported.
00209         NoButton
00210 };
00211
00212
00217 enum SystemKey
00218 {
00219         LeftMouse               = 0x0001,
00220         RightMouse              = 0x0002,
00221         Shift                   = 0x0004,
00222         Control                 = 0x0008,
00223         MiddleMouse             = 0x0010,
00224         X1Mouse                 = 0x0020,
00225         X2Mouse                 = 0x0040,
00226         Alt                             = 0x0080
00227 };
00228
00229
00235 class CEGUIEXPORT WindowEventArgs : public EventArgs
00236 {
00237 public:
00238         WindowEventArgs(Window* wnd) : window(wnd) {}
00239
00240         Window* window;
00241 };
00242
00243
00249 class CEGUIEXPORT MouseEventArgs : public WindowEventArgs
00250 {
00251 public:
00252         MouseEventArgs(Window* wnd) : WindowEventArgs(wnd) {}
00253
00254         Point           position;
00255         Vector2         moveDelta;
00256         MouseButton     button;
00257         uint            sysKeys;
00258         float           wheelChange;
00259         uint        clickCount;
00260 };
00261
00262
00268 class CEGUIEXPORT MouseCursorEventArgs : public EventArgs
00269 {
00270 public:
00271         MouseCursorEventArgs(MouseCursor* cursor) : mouseCursor(cursor) {}
00272
00273         MouseCursor* mouseCursor;
00274         const Image* image;
00275 };
00276
00277
00283 class CEGUIEXPORT KeyEventArgs : public WindowEventArgs
00284 {
00285 public:
00286         KeyEventArgs(Window* wnd) : WindowEventArgs(wnd) {}
00287
00288         utf32           codepoint;
00289         Key::Scan       scancode;
00290         uint            sysKeys;
00291 };
00292
00293
00298 class CEGUIEXPORT ActivationEventArgs : public WindowEventArgs
00299 {
00300 public:
00301         ActivationEventArgs(Window* wnd) : WindowEventArgs(wnd) {}
00302
00303         Window* otherWindow;
00304 };
00305
00310 class CEGUIEXPORT DragDropEventArgs : public WindowEventArgs
00311 {
00312 public:
00313         DragDropEventArgs(Window* wnd) : WindowEventArgs(wnd) {}
00314         DragContainer*  dragDropItem; //<! pointer to the DragContainer window being dragged / dropped.
00315 };
00316
00317 } // End of  CEGUI namespace section
00318
00319
00320 #endif  // end of guard _CEGUIInputEvent_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIItemEntry.h Source File

include » elements

CEGUIItemEntry.h

00001 /************************************************************************
00002         filename:       CEGUIItemEntry.h
00003         created:        31/3/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005
00006         purpose:        Interface to base class for ItemEntry widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIItemEntry_h_
00027 #define _CEGUIItemEntry_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031
00032
00033 #if defined(_MSC_VER)
00034 #       pragma warning(push)
00035 #       pragma warning(disable : 4251)
00036 #endif
00037
00038
00039 // Start of CEGUI namespace section
00040 namespace CEGUI
00041 {
00042
00047 class CEGUIEXPORT ItemEntry : public Window
00048 {
00049 public:
00050         /*************************************************************************
00051                 Abstract Implementation Functions (must be provided by derived class)
00052         *************************************************************************/
00061         virtual Size getItemPixelSize(void) = 0;
00062
00063         /*************************************************************************
00064                 Construction and Destruction
00065         *************************************************************************/
00070         ItemEntry(const String& type, const String& name);
00071
00072
00077         virtual ~ItemEntry(void);
00078
00079
00080 protected:
00081         /*************************************************************************
00082                 Implementation Functions
00083         *************************************************************************/
00088         void    addItemEntryEvents(void);
00089
00090
00098     virtual void    populateRenderCahce() {};
00099
00100
00111         virtual bool    testClassName_impl(const String& class_name) const
00112         {
00113                 if (class_name==(const utf8*)"ItemEntry")       return true;
00114                 return Window::testClassName_impl(class_name);
00115         }
00116
00117 };
00118
00119 } // End of  CEGUI namespace section
00120
00121
00122 #if defined(_MSC_VER)
00123 #       pragma warning(pop)
00124 #endif
00125
00126
00127 #endif  // end of guard _CEGUIItemEntry_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIItemListBase.h Source File

include » elements

CEGUIItemListBase.h

00001 /************************************************************************
00002         filename:       CEGUIItemListBase.h
00003         created:        31/3/2005
00004         author:         Tomas Lindquist Olsen (based on original Listbox code by Paul D Turner)
00005
00006         purpose:        Interface to base class for ItemListBase widgets
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIItemListBase_h_
00027 #define _CEGUIItemListBase_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIItemListBaseProperties.h"
00032 #include "elements/CEGUIItemEntry.h"
00033
00034 #include <vector>
00035
00036
00037 #if defined(_MSC_VER)
00038 #       pragma warning(push)
00039 #       pragma warning(disable : 4251)
00040 #endif
00041
00042
00043 // Start of CEGUI namespace section
00044 namespace CEGUI
00045 {
00046
00051 class CEGUIEXPORT ItemListBase : public Window
00052 {
00053 public:
00054         static const String EventNamespace;
00055
00056
00057         /*************************************************************************
00058                 Constants
00059         *************************************************************************/
00060         // event names
00061         static const String EventListContentsChanged;
00062
00063
00064         /*************************************************************************
00065                 Accessor Methods
00066         *************************************************************************/
00074         size_t  getItemCount(void) const                {return d_listItems.size();}
00075
00076
00089         ItemEntry*      getItemFromIndex(size_t index) const;
00090
00091
00104         size_t  getItemIndex(const ItemEntry* item) const;
00105
00106
00124         ItemEntry*      findItemWithText(const String& text, const ItemEntry* start_item);
00125
00126
00134         bool    isItemInList(const ItemEntry* item) const;
00135
00136
00144         bool isAutoResizeEnabled() const                {return d_autoResize;}
00145
00146
00147         /*************************************************************************
00148                 Manipulator Methods
00149         *************************************************************************/
00160         virtual void    initialise(void);
00161
00162
00169         void    resetList(void);
00170
00171
00183         void    addItem(ItemEntry* item);
00184
00185
00203         void    insertItem(ItemEntry* item, const ItemEntry* position);
00204
00205
00217         void    removeItem(ItemEntry* item);
00218
00219
00232         void    handleUpdatedItemData(void);
00233
00234
00245         void setAutoResizeEnabled(bool setting);
00246
00247
00257         virtual void    sizeToContent(void)             {sizeToContent_impl();}
00258
00259
00260         /*************************************************************************
00261                 Construction and Destruction
00262         *************************************************************************/
00267         ItemListBase(const String& type, const String& name);
00268
00269
00274         virtual ~ItemListBase(void);
00275
00276
00277 protected:
00278         /*************************************************************************
00279                 Abstract Implementation Functions (must be provided by derived class)
00280         *************************************************************************/
00290         virtual void    sizeToContent_impl(void)                = 0;
00291
00292
00300         virtual Size getContentSize()           = 0;
00301
00302
00312         virtual Rect    getItemRenderArea(void) const           = 0;
00313
00314
00322         virtual void    layoutItemWidgets()     = 0;
00323
00324
00332         virtual void    populateRenderCache() = 0;
00333
00334
00335         /*************************************************************************
00336                 Implementation Functions
00337         *************************************************************************/
00342         void    addItemListBaseEvents(void);
00343
00344
00356         bool    resetList_impl(void);
00357
00358
00369         virtual bool    testClassName_impl(const String& class_name) const
00370         {
00371                 if (class_name==(const utf8*)"ItemListBase")    return true;
00372                 return Window::testClassName_impl(class_name);
00373         }
00374
00375         /*************************************************************************
00376                 New event handlers
00377         *************************************************************************/
00382         virtual void    onListContentsChanged(WindowEventArgs& e);
00383
00384
00385         /*************************************************************************
00386                 Overridden Event handlers
00387         *************************************************************************/
00388         virtual void    onSized(WindowEventArgs& e);
00389
00390
00391         /*************************************************************************
00392                 Implementation Data
00393         *************************************************************************/
00394         typedef std::vector<ItemEntry*> ItemEntryList;
00395         ItemEntryList   d_listItems;
00396
00397         // boolean telling if this ItemListBase widget should automatically resize to fit its content.
00398         bool d_autoResize;
00399
00400 private:
00401         /*************************************************************************
00402         Static Properties for this class
00403         *************************************************************************/
00404         static ItemListBaseProperties::AutoResizeEnabled        d_autoResizeEnabledProperty;
00405
00406
00407         /*************************************************************************
00408                 Private methods
00409         *************************************************************************/
00410         void    addItemListBaseProperties(void);
00411
00412
00417         virtual void    addChild_impl(Window* wnd);
00418 };
00419
00420 } // End of  CEGUI namespace section
00421
00422
00423 #if defined(_MSC_VER)
00424 #       pragma warning(pop)
00425 #endif
00426
00427 #endif  // end of guard _CEGUIItemListBase_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIItemListBaseProperties.h Source File

include » elements

CEGUIItemListBaseProperties.h

00001 /************************************************************************
00002         filename:       CEGUIItemListBaseProperties.h
00003         created:        5/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIItemListBaseProperties_h_
00025 #define _CEGUIItemListBaseProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of ItemListBaseProperties namespace section
00033 namespace ItemListBaseProperties
00034 {
00047     class AutoResizeEnabled : public Property
00048     {
00049     public:
00050             AutoResizeEnabled() : Property(
00051                     "AutoResizeEnabled",
00052                     "Property to get/set the state of the auto resizing enabled setting for the ItemListBase.  Value is either \"True\" or \"False\".",
00053                     "False")
00054             {}
00055
00056             String      get(const PropertyReceiver* receiver) const;
00057             void        set(PropertyReceiver* receiver, const String& value);
00058     };
00059
00060 } // End of  ItemListBaseProperties namespace section
00061 } // End of  CEGUI namespace section
00062
00063 #endif  // end of guard _CEGUIItemListBaseProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIIteratorBase.h Source File

include

CEGUIIteratorBase.h

00001 /************************************************************************
00002         filename:       CEGUIIteratorBase.h
00003         created:        26/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for base iterator class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 /*************************************************************************
00027         This is based somewhat on MapIterator in the Ogre library (www.ogre3d.org)
00028 *************************************************************************/
00029 #ifndef _CEGUIIteratorBase_h_
00030 #define _CEGUIIteratorBase_h_
00031
00032 #include "CEGUIBase.h"
00033
00034
00035 // Start of CEGUI namespace section
00036 namespace CEGUI
00037 {
00042 template<class T>
00043 class ConstBaseIterator
00044 {
00045 public:
00046 #if defined(_MSC_VER) && (_MSC_VER <= 1200) && !defined(_STLPORT_VERSION)
00047         typedef typename T::referent_type       mapped_type;
00048 #else
00049         typedef typename T::mapped_type         mapped_type;
00050 #endif
00051
00062         ConstBaseIterator(typename T::const_iterator start_iter, typename T::const_iterator end_iter) :
00063                 d_currIter(start_iter),
00064                 d_startIter(start_iter),
00065                 d_endIter(end_iter)
00066         {
00067         }
00068
00069
00074         ~ConstBaseIterator(void)
00075         {
00076         }
00077
00078
00083         ConstBaseIterator(const ConstBaseIterator<T>& org) :
00084                 d_currIter(org.d_currIter),
00085                 d_startIter(org.d_startIter),
00086                 d_endIter(org.d_endIter)
00087         {
00088         }
00089
00090
00095         ConstBaseIterator<T>&   operator=(const ConstBaseIterator<T>& rhs)
00096         {
00097                 d_currIter      = rhs.d_currIter;
00098                 d_startIter     = rhs.d_startIter;
00099                 d_endIter       = rhs.d_endIter;
00100
00101                 return *this;
00102         }
00103
00104
00109         typename T::key_type    getCurrentKey(void) const
00110         {
00111                 return d_currIter->first;
00112         }
00113
00114
00119         mapped_type     getCurrentValue(void) const
00120         {
00121                 return d_currIter->second;
00122         }
00123
00124
00129         bool    isAtEnd(void) const
00130         {
00131                 return d_currIter == d_endIter;
00132         }
00133
00134
00139         bool    isAtStart(void) const
00140         {
00141                 return d_currIter == d_startIter;
00142         }
00143
00144
00152         ConstBaseIterator<T>&   operator++()
00153         {
00154                 if (d_currIter != d_endIter)
00155                         ++d_currIter;
00156
00157                 return *this;
00158         }
00159
00160
00168         ConstBaseIterator<T>    operator++(int)
00169         {
00170                 ConstBaseIterator<T> tmp = *this;
00171                 ++*this;
00172
00173                 return tmp;
00174         }
00175
00176
00184         ConstBaseIterator<T>&   operator--()
00185         {
00186                 if (d_currIter != d_startIter)
00187                         --d_currIter;
00188
00189                 return *this;
00190         }
00191
00192
00200         ConstBaseIterator<T>    operator--(int)
00201         {
00202                 ConstBaseIterator<T> tmp = *this;
00203                 --*this;
00204
00205                 return tmp;
00206         }
00207
00208
00213         bool    operator==(const ConstBaseIterator<T>& rhs) const
00214         {
00215                 return d_currIter == rhs.d_currIter;
00216         }
00217
00218
00223         bool    operator!=(const ConstBaseIterator<T>& rhs) const
00224         {
00225                 return !this == rhs;
00226         }
00227
00228
00233         mapped_type     operator*() const
00234         {
00235                 return d_currIter->second;
00236         }
00237
00238
00243         void    toStart(void)
00244         {
00245                 d_currIter = d_startIter;
00246         }
00247
00248
00253         void    toEnd(void)
00254         {
00255                 d_currIter = d_endIter;
00256         }
00257
00258
00259 private:
00260         /*************************************************************************
00261                 No default construction available
00262         *************************************************************************/
00263         ConstBaseIterator(void) {}
00264
00265         /*************************************************************************
00266                 Implementation Data
00267         *************************************************************************/
00268         typename T::const_iterator      d_currIter;
00269         typename T::const_iterator      d_startIter;
00270         typename T::const_iterator      d_endIter;
00271 };
00272
00273 } // End of  CEGUI namespace section
00274
00275
00276 #endif  // end of guard _CEGUIIteratorBase_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListbox.h Source File

include » elements

CEGUIListbox.h

00001 /************************************************************************
00002         filename:       CEGUIListbox.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Listbox widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListbox_h_
00027 #define _CEGUIListbox_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIListboxProperties.h"
00032 #include <vector>
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00044
00049 class CEGUIEXPORT Listbox : public Window
00050 {
00051 public:
00052         static const String EventNamespace;
00053
00054
00055         /*************************************************************************
00056                 Constants
00057         *************************************************************************/
00058         // event names
00059         static const String EventListContentsChanged;
00060         static const String EventSelectionChanged;
00061         static const String EventSortModeChanged;
00062         static const String EventMultiselectModeChanged;
00063         static const String EventVertScrollbarModeChanged;
00064         static const String EventHorzScrollbarModeChanged;
00065
00066
00067         /*************************************************************************
00068                 Accessor Methods
00069         *************************************************************************/
00077         size_t  getItemCount(void) const                {return d_listItems.size();}
00078
00079
00087         size_t  getSelectedCount(void) const;
00088
00089
00098         ListboxItem*    getFirstSelectedItem(void) const;
00099
00100
00115         ListboxItem*    getNextSelected(const ListboxItem* start_item) const;
00116
00117
00130         ListboxItem*    getListboxItemFromIndex(size_t index) const;
00131
00132
00145         size_t  getItemIndex(const ListboxItem* item) const;
00146
00147
00155         bool    isSortEnabled(void) const               {return d_sorted;}
00156
00164         bool    isMultiselectEnabled(void) const        {return d_multiselect;}
00165
00166         bool    isItemTooltipsEnabled(void) const       {return d_itemTooltips;}
00167
00180         bool    isItemSelected(size_t index) const;
00181
00182
00200         ListboxItem*    findItemWithText(const String& text, const ListboxItem* start_item);
00201
00202
00210         bool    isListboxItemInList(const ListboxItem* item) const;
00211
00212
00221         bool    isVertScrollbarAlwaysShown(void) const;
00222
00223
00232         bool    isHorzScrollbarAlwaysShown(void) const;
00233
00234
00235         /*************************************************************************
00236                 Manipulator Methods
00237         *************************************************************************/
00248         virtual void    initialise(void);
00249
00250
00257         void    resetList(void);
00258
00259
00271         void    addItem(ListboxItem* item);
00272
00273
00293         void    insertItem(ListboxItem* item, const ListboxItem* position);
00294
00295
00307         void    removeItem(const ListboxItem* item);
00308
00309
00317         void    clearAllSelections(void);
00318
00319
00330         void    setSortingEnabled(bool setting);
00331
00332
00344         void    setMultiselectEnabled(bool setting);
00345
00346
00358         void    setShowVertScrollbar(bool setting);
00359
00360
00372         void    setShowHorzScrollbar(bool setting);
00373
00374         void    setItemTooltipsEnabled(bool setting);
00394         void    setItemSelectState(ListboxItem* item, bool state);
00395
00396
00416         void    setItemSelectState(size_t item_index, bool state);
00417
00418
00431         void    handleUpdatedItemData(void);
00432
00433
00445         void    ensureItemIsVisible(size_t item_index);
00446
00447
00460         void    ensureItemIsVisible(const ListboxItem* item);
00461
00462
00463         /*************************************************************************
00464                 Construction and Destruction
00465         *************************************************************************/
00470         Listbox(const String& type, const String& name);
00471
00472
00477         virtual ~Listbox(void);
00478
00479
00480 protected:
00481         /*************************************************************************
00482                 Abstract Implementation Functions (must be provided by derived class)
00483         *************************************************************************/
00493         virtual Rect    getListRenderArea(void) const           = 0;
00494
00495
00506         virtual Scrollbar*      createVertScrollbar(const String& name) const           = 0;
00507
00508
00519         virtual Scrollbar*      createHorzScrollbar(const String& name) const           = 0;
00520
00521
00532         virtual void cacheListboxBaseImagery() = 0;
00533
00534
00535         /*************************************************************************
00536                 Implementation Functions
00537         *************************************************************************/
00542         void    addListboxEvents(void);
00543
00544
00549         void    configureScrollbars(void);
00550
00556         void    selectRange(size_t start, size_t end);
00557
00558
00563         float   getTotalItemsHeight(void) const;
00564
00565
00570         float   getWidestItemWidth(void) const;
00571
00572
00580         bool    clearAllSelections_impl(void);
00581
00582
00591         ListboxItem*    getItemAtPoint(const Point& pt) const;
00592
00593
00605         bool    resetList_impl(void);
00606
00607
00618         virtual bool    testClassName_impl(const String& class_name) const
00619         {
00620                 if (class_name==(const utf8*)"Listbox") return true;
00621                 return Window::testClassName_impl(class_name);
00622         }
00623
00628     bool handle_scrollChange(const EventArgs& args);
00629
00630     // overridden from Window base class.
00631     void populateRenderCache();
00632
00633
00634         /*************************************************************************
00635                 New event handlers
00636         *************************************************************************/
00641         virtual void    onListContentsChanged(WindowEventArgs& e);
00642
00643
00648         virtual void    onSelectionChanged(WindowEventArgs& e);
00649
00650
00655         virtual void    onSortModeChanged(WindowEventArgs& e);
00656
00657
00662         virtual void    onMultiselectModeChanged(WindowEventArgs& e);
00663
00664
00669         virtual void    onVertScrollbarModeChanged(WindowEventArgs& e);
00670
00671
00676         virtual void    onHorzScrollbarModeChanged(WindowEventArgs& e);
00677
00678
00679         /*************************************************************************
00680                 Overridden Event handlers
00681         *************************************************************************/
00682         virtual void    onSized(WindowEventArgs& e);
00683         virtual void    onMouseButtonDown(MouseEventArgs& e);
00684         virtual void    onMouseWheel(MouseEventArgs& e);
00685         virtual void    onMouseMove(MouseEventArgs& e);
00686
00687
00688         /*************************************************************************
00689                 Implementation Data
00690         *************************************************************************/
00691         typedef std::vector<ListboxItem*>       LBItemList;
00692         bool    d_sorted;
00693         bool    d_multiselect;
00694         bool    d_forceVertScroll;
00695         bool    d_forceHorzScroll;
00696         bool    d_itemTooltips;
00697         Scrollbar*      d_vertScrollbar;
00698         Scrollbar*      d_horzScrollbar;
00699         LBItemList      d_listItems;
00700         ListboxItem*    d_lastSelected;
00701
00702
00703 private:
00704         /*************************************************************************
00705                 Static Properties for this class
00706         *************************************************************************/
00707         static ListboxProperties::Sort                                  d_sortProperty;
00708         static ListboxProperties::MultiSelect                   d_multiSelectProperty;
00709         static ListboxProperties::ForceVertScrollbar    d_forceVertProperty;
00710         static ListboxProperties::ForceHorzScrollbar    d_forceHorzProperty;
00711         static ListboxProperties::ItemTooltips                  d_itemTooltipsProperty;
00712
00713         /*************************************************************************
00714                 Private methods
00715         *************************************************************************/
00716         void    addListboxProperties(void);
00717 };
00718
00719
00725 bool lbi_less(const ListboxItem* a, const ListboxItem* b);
00726
00727
00733 bool lbi_greater(const ListboxItem* a, const ListboxItem* b);
00734
00735 } // End of  CEGUI namespace section
00736
00737
00738 #if defined(_MSC_VER)
00739 #       pragma warning(pop)
00740 #endif
00741
00742 #endif  // end of guard _CEGUIListbox_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListboxItem.h Source File

include » elements

CEGUIListboxItem.h

00001 /************************************************************************
00002         filename:       CEGUIListboxItem.h
00003         created:        8/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for list items
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListboxItem_h_
00027 #define _CEGUIListboxItem_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIColourRect.h"
00032 #include "CEGUIRenderCache.h"
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00041 class CEGUIEXPORT ListboxItem
00042 {
00043 public:
00044         /*************************************************************************
00045                 Constants
00046         *************************************************************************/
00047         static const colour     DefaultSelectionColour;
00048
00049
00050         /*************************************************************************
00051                 Construction and Destruction
00052         *************************************************************************/
00057         ListboxItem(const String& text, uint item_id = 0, void* item_data = NULL, bool disabled = false, bool auto_delete = true);
00058
00059
00064         virtual ~ListboxItem(void) {}
00065
00066
00067         /*************************************************************************
00068                 Accessors
00069         *************************************************************************/
00080         const String&   getText(void) const             {return d_itemText;}
00081         const String&   getTooltipText(void) const              {return d_tooltipText;}
00082
00093         uint    getID(void) const                       {return d_itemID;}
00094
00095
00106         void*   getUserData(void) const         {return d_itemData;}
00107
00108
00116         bool    isSelected(void) const          {return d_selected;}
00117
00118
00126         bool    isDisabled(void) const          {return d_disabled;}
00127
00128
00139         bool    isAutoDeleted(void) const       {return d_autoDelete;}
00140
00141
00151         const Window*   getOwnerWindow(const Window* owner)             {return d_owner;}
00152
00153
00161         ColourRect      getSelectionColours(void) const         {return d_selectCols;}
00162
00163
00171         const Image*    getSelectionBrushImage(void) const              {return d_selectBrush;}
00172
00173
00174         /*************************************************************************
00175                 Manipulators
00176         *************************************************************************/
00190         void    setText(const String& text)             {d_itemText = text;}
00191
00192         void    setTooltipText(const String& text)              {d_tooltipText = text;}
00193
00207         void    setID(uint item_id)             {d_itemID = item_id;}
00208
00209
00223         void    setUserData(void* item_data)    {d_itemData = item_data;}
00224
00225
00236         void    setSelected(bool setting)               {d_selected = setting;}
00237
00238
00249         void    setDisabled(bool setting)               {d_disabled = setting;}
00250
00264         void    setAutoDeleted(bool setting)            {d_autoDelete = setting;}
00265
00266
00278         void    setOwnerWindow(const Window* owner)             {d_owner = owner;}
00279
00280
00291         void    setSelectionColours(const ColourRect& cols)             {d_selectCols = cols;}
00292
00293
00313         void    setSelectionColours(colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour);
00314
00315
00326         void    setSelectionColours(colour col)         {setSelectionColours(col, col, col, col);}
00327
00328
00339         void    setSelectionBrushImage(const Image* image)              {d_selectBrush = image;}
00340
00341
00355         void    setSelectionBrushImage(const String& imageset, const String& image);
00356
00357
00358         /*************************************************************************
00359                 Abstract portion of interface
00360         *************************************************************************/
00368         virtual Size    getPixelSize(void) const        = 0;
00369
00370
00387         virtual void    draw(const Vector3& position, float alpha, const Rect& clipper) const   = 0;
00388
00389     virtual void    draw(RenderCache& cache,const Rect& targetRect, float zBase,  float alpha, const Rect* clipper) const = 0;
00390
00391         /*************************************************************************
00392                 Operators
00393         *************************************************************************/
00398         virtual bool    operator<(const ListboxItem& rhs) const         {return d_itemText < rhs.getText();}
00399
00400
00405         virtual bool    operator>(const ListboxItem& rhs) const         {return d_itemText > rhs.getText();}
00406
00407
00408 protected:
00409         /*************************************************************************
00410                 Implementation methods
00411         *************************************************************************/
00417         ColourRect getModulateAlphaColourRect(const ColourRect& cols, float alpha) const;
00418
00419
00425         colour calculateModulatedAlphaColour(colour col, float alpha) const;
00426
00427
00428         /*************************************************************************
00429                 Implementation Data
00430         *************************************************************************/
00431         String  d_itemText;
00432         String  d_tooltipText;
00433         uint    d_itemID;
00434         void*   d_itemData;
00435         bool    d_selected;
00436         bool    d_disabled;
00437         bool    d_autoDelete;
00438         const Window*   d_owner;
00439         ColourRect              d_selectCols;
00440         const Image*    d_selectBrush;
00441 };
00442
00443 } // End of  CEGUI namespace section
00444
00445
00446 #endif  // end of guard _CEGUIListboxItem_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListboxProperties.h Source File

include » elements

CEGUIListboxProperties.h

00001 /************************************************************************
00002         filename:       CEGUIListboxProperties.h
00003         created:        11/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to Listbox property classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListboxProperties_h_
00027 #define _CEGUIListboxProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ListboxProperties namespace section
00041 namespace ListboxProperties
00042 {
00055 class Sort : public Property
00056 {
00057 public:
00058         Sort() : Property(
00059                 "Sort",
00060                 "Property to get/set the sort setting of the list box.  Value is either \"True\" or \"False\".",
00061                 "False")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class MultiSelect : public Property
00082 {
00083 public:
00084         MultiSelect() : Property(
00085                 "MultiSelect",
00086                 "Property to get/set the multi-select setting of the list box.  Value is either \"True\" or \"False\".",
00087                 "False")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00107 class ForceVertScrollbar : public Property
00108 {
00109 public:
00110         ForceVertScrollbar() : Property(
00111                 "ForceVertScrollbar",
00112                 "Property to get/set the 'always show' setting for the vertical scroll bar of the list box.  Value is either \"True\" or \"False\".",
00113                 "False")
00114         {}
00115
00116         String  get(const PropertyReceiver* receiver) const;
00117         void    set(PropertyReceiver* receiver, const String& value);
00118 };
00119
00120
00133 class ForceHorzScrollbar : public Property
00134 {
00135 public:
00136         ForceHorzScrollbar() : Property(
00137                 "ForceHorzScrollbar",
00138                 "Property to get/set the 'always show' setting for the horizontal scroll bar of the list box.  Value is either \"True\" or \"False\".",
00139                 "False")
00140         {}
00141
00142         String  get(const PropertyReceiver* receiver) const;
00143         void    set(PropertyReceiver* receiver, const String& value);
00144 };
00145
00158 class ItemTooltips : public Property
00159 {
00160 public:
00161         ItemTooltips() : Property(
00162                 "ItemTooltips",
00163                 "Property to access the show item tooltips setting of the list box.  Value is either \"True\" or \"False\".",
00164                 "False")
00165         {}
00166
00167         String  get(const PropertyReceiver* receiver) const;
00168         void    set(PropertyReceiver* receiver, const String& value);
00169 };
00170
00171 } // End of  ListboxProperties namespace section
00172
00173 } // End of  CEGUI namespace section
00174
00175 #endif  // end of guard _CEGUIListboxProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListboxTextItem.h Source File

include » elements

CEGUIListboxTextItem.h

00001 /************************************************************************
00002         filename:       CEGUIListboxTextItem.h
00003         created:        12/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for list box text items
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListboxTextItem_h_
00027 #define _CEGUIListboxTextItem_h_
00028 #include "elements/CEGUIListboxItem.h"
00029
00030
00031 // Start of CEGUI namespace section
00032 namespace CEGUI
00033 {
00038 class CEGUIEXPORT ListboxTextItem : public ListboxItem
00039 {
00040 public:
00041         /*************************************************************************
00042                 Constants
00043         *************************************************************************/
00044         static const colour     DefaultTextColour;
00045
00046
00047         /*************************************************************************
00048                 Construction and Destruction
00049         *************************************************************************/
00054         ListboxTextItem(const String& text, uint item_id = 0, void* item_data = NULL, bool disabled = false, bool auto_delete = true);
00055
00056
00061         virtual ~ListboxTextItem(void) {}
00062
00063
00064         /*************************************************************************
00065                 Accessor methods
00066         *************************************************************************/
00077         const Font*     getFont(void) const;
00078
00079
00087         ColourRect      getTextColours(void) const              {return d_textCols;}
00088
00089
00090         /*************************************************************************
00091                 Manipulator methods
00092         *************************************************************************/
00103         void    setFont(const Font* font)               {d_font = font;}
00104
00105
00116         void    setFont(const String& font_name);
00117
00118
00129         void    setTextColours(const ColourRect& cols)                  {d_textCols = cols;}
00130
00131
00151         void    setTextColours(colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour);
00152
00153
00164         void    setTextColours(colour col)              {setTextColours(col, col, col, col);}
00165
00166
00167         /*************************************************************************
00168                 Required implementations of pure virtuals from the base class.
00169         *************************************************************************/
00170     Size getPixelSize(void) const;
00171     void draw(const Vector3& position, float alpha, const Rect& clipper) const;
00172     void draw(RenderCache& cache,const Rect& targetRect, float zBase,  float alpha, const Rect* clipper) const;
00173
00174 protected:
00175         /*************************************************************************
00176                 Implementation Data
00177         *************************************************************************/
00178         ColourRect              d_textCols;
00179         const Font*             d_font;
00180 };
00181
00182 } // End of  CEGUI namespace section
00183
00184
00185 #endif  // end of guard _CEGUIListboxTextItem_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListHeader.h Source File

include » elements

CEGUIListHeader.h

00001 /************************************************************************
00002         filename:       CEGUIListHeader.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for ListHeader widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListHeader_h_
00027 #define _CEGUIListHeader_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIListHeaderSegment.h"
00032 #include "elements/CEGUIListHeaderProperties.h"
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00048 class CEGUIEXPORT HeaderSequenceEventArgs : public WindowEventArgs
00049 {
00050 public:
00051         HeaderSequenceEventArgs(Window* wnd, uint old_idx, uint new_idx) : WindowEventArgs(wnd), d_oldIdx(old_idx), d_newIdx(new_idx) {};
00052
00053         uint d_oldIdx;
00054         uint d_newIdx;
00055 };
00056
00057
00062 class CEGUIEXPORT ListHeader : public Window
00063 {
00064 public:
00065         static const String EventNamespace;
00066
00067
00068         /*************************************************************************
00069                 Constants
00070         *************************************************************************/
00071         // Event names
00072         static const String EventSortColumnChanged;
00073         static const String EventSortDirectionChanged;
00074         static const String EventSegmentSized;
00075         static const String EventSegmentClicked;
00076         static const String EventSplitterDoubleClicked;
00077         static const String EventSegmentSequenceChanged;
00078         static const String EventSegmentAdded;
00079         static const String EventSegmentRemoved;
00080         static const String EventSortSettingChanged;
00081         static const String EventDragMoveSettingChanged;
00082         static const String EventDragSizeSettingChanged;
00083         static const String EventSegmentRenderOffsetChanged;
00084
00085         // values
00086         static const float      ScrollSpeed;
00087         static const float      MinimumSegmentPixelWidth;
00088
00089
00090         /*************************************************************************
00091                 Accessor Methods
00092         *************************************************************************/
00100         uint    getColumnCount(void) const;
00101
00102
00115         ListHeaderSegment&      getSegmentFromColumn(uint column) const;
00116
00117
00131         ListHeaderSegment&      getSegmentFromID(uint id) const;
00132
00133
00144         ListHeaderSegment&      getSortSegment(void) const;
00145
00146
00159         uint    getColumnFromSegment(const ListHeaderSegment& segment) const;
00160
00161
00174         uint    getColumnFromID(uint id) const;
00175
00176
00187         uint    getSortColumn(void) const;
00188
00189
00202         uint    getColumnWithText(const String& text) const;
00203
00204
00217         float   getPixelOffsetToSegment(const ListHeaderSegment& segment) const;
00218
00219
00233         float   getPixelOffsetToColumn(uint column) const;
00234
00235
00243         float   getTotalSegmentsPixelExtent(void) const;
00244
00245
00258         float   getColumnPixelWidth(uint column) const;
00259
00260
00268         ListHeaderSegment::SortDirection        getSortDirection(void) const;
00269
00270
00279         bool    isSortingEnabled(void) const;
00280
00281
00289         bool    isColumnSizingEnabled(void) const;
00290
00291
00299         bool    isColumnDraggingEnabled(void) const;
00300
00301
00310         float   getSegmentOffset(void) const    {return d_segmentOffset;}
00311
00312
00313         /*************************************************************************
00314                 Manipulator Methods
00315         *************************************************************************/
00327         void    setSortingEnabled(bool setting);
00328
00329
00340         void    setSortDirection(ListHeaderSegment::SortDirection direction);
00341
00342
00355         void    setSortSegment(const ListHeaderSegment& segment);
00356
00357
00370         void    setSortColumn(uint column);
00371
00372
00385         void    setSortColumnFromID(uint id);
00386
00387
00399         void    setColumnSizingEnabled(bool setting);
00400
00401
00413         void    setColumnDraggingEnabled(bool setting);
00414
00415
00432         void    addColumn(const String& text, uint id, float width);
00433
00434
00455         void    insertColumn(const String& text, uint id, float width, uint position);
00456
00457
00480         void    insertColumn(const String& text, uint id, float width, const ListHeaderSegment& position);
00481
00482
00495         void    removeColumn(uint column);
00496
00497
00510         void    removeSegment(const ListHeaderSegment& segment);
00511
00512
00529         void    moveColumn(uint column, uint position);
00530
00531
00550         void    moveColumn(uint column, const ListHeaderSegment& position);
00551
00552
00569         void    moveSegment(const ListHeaderSegment& segment, uint position);
00570
00571
00589         void    moveSegment(const ListHeaderSegment& segment, const ListHeaderSegment& position);
00590
00591
00604         void    setSegmentOffset(float offset);
00605
00606
00623         void    setColumnPixelWidth(uint column, float width);
00624
00625
00626         /*************************************************************************
00627                 Construction and Destruction
00628         *************************************************************************/
00633         ListHeader(const String& type, const String& name);
00634
00635
00640         virtual ~ListHeader(void);
00641
00642
00643 protected:
00644         /*************************************************************************
00645                 Abstract Implementation Methods
00646         *************************************************************************/
00658         virtual ListHeaderSegment*      createNewSegment(const String& name) const      = 0;
00659
00660
00672         virtual void    destroyListSegment(ListHeaderSegment* segment) const = 0;
00673
00674
00675         /*************************************************************************
00676                 Implementation Methods
00677         *************************************************************************/
00682         ListHeaderSegment*      createInitialisedSegment(const String& text, uint id, float width);
00683
00684
00689         void    layoutSegments(void);
00690
00691
00696         void    addListHeaderEvents(void);
00697
00698
00709         virtual bool    testClassName_impl(const String& class_name) const
00710         {
00711                 if (class_name==(const utf8*)"ListHeader")      return true;
00712                 return Window::testClassName_impl(class_name);
00713         }
00714
00715
00716         /*************************************************************************
00717                 New List header event handlers
00718         *************************************************************************/
00723         virtual void    onSortColumnChanged(WindowEventArgs& e);
00724
00725
00730         virtual void    onSortDirectionChanged(WindowEventArgs& e);
00731
00732
00737         virtual void    onSegmentSized(WindowEventArgs& e);
00738
00739
00744         virtual void    onSegmentClicked(WindowEventArgs& e);
00745
00746
00751         virtual void    onSplitterDoubleClicked(WindowEventArgs& e);
00752
00753
00758         virtual void    onSegmentSequenceChanged(WindowEventArgs& e);
00759
00760
00765         virtual void    onSegmentAdded(WindowEventArgs& e);
00766
00767
00772         virtual void    onSegmentRemoved(WindowEventArgs& e);
00773
00774
00779         virtual void    onSortSettingChanged(WindowEventArgs& e);
00780
00781
00786         virtual void    onDragMoveSettingChanged(WindowEventArgs& e);
00787
00788
00793         virtual void    onDragSizeSettingChanged(WindowEventArgs& e);
00794
00795
00800         virtual void    onSegmentOffsetChanged(WindowEventArgs& e);
00801
00802
00803         /*************************************************************************
00804                 handlers for events we subscribe to from segments
00805         *************************************************************************/
00806         bool    segmentSizedHandler(const EventArgs& e);
00807         bool    segmentMovedHandler(const EventArgs& e);
00808         bool    segmentClickedHandler(const EventArgs& e);
00809         bool    segmentDoubleClickHandler(const EventArgs& e);
00810         bool    segmentDragHandler(const EventArgs& e);
00811
00812
00813         /*************************************************************************
00814                 Implementation Data
00815         *************************************************************************/
00816         typedef std::vector<ListHeaderSegment*>         SegmentList;
00817         SegmentList     d_segments;
00818         ListHeaderSegment*      d_sortSegment;
00819         bool    d_sizingEnabled;
00820         bool    d_sortingEnabled;
00821         bool    d_movingEnabled;
00822         uint    d_uniqueIDNumber;
00823         float   d_segmentOffset;
00824         ListHeaderSegment::SortDirection        d_sortDir;
00825
00826
00827 private:
00828         /*************************************************************************
00829                 Static Properties for this class
00830         *************************************************************************/
00831         static ListHeaderProperties::SortSettingEnabled         d_sortSettingProperty;
00832         static ListHeaderProperties::ColumnsSizable                     d_sizableProperty;
00833         static ListHeaderProperties::ColumnsMovable                     d_movableProperty;
00834         static ListHeaderProperties::SortColumnID                       d_sortColumnIDProperty;
00835         static ListHeaderProperties::SortDirection                      d_sortDirectionProperty;
00836
00837
00838         /*************************************************************************
00839                 Private methods
00840         *************************************************************************/
00841         void    addHeaderProperties(void);
00842 };
00843
00844 } // End of  CEGUI namespace section
00845
00846
00847 #if defined(_MSC_VER)
00848 #       pragma warning(pop)
00849 #endif
00850
00851 #endif  // end of guard _CEGUIListHeader_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListHeaderProperties.h Source File

include » elements

CEGUIListHeaderProperties.h

00001 /************************************************************************
00002         filename:       CEGUIListHeaderProperties.h
00003         created:        11/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to the properties for the ListHeader class.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListHeaderProperties_h_
00027 #define _CEGUIListHeaderProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ListHeaderProperties namespace section
00041 namespace ListHeaderProperties
00042 {
00055 class ColumnsSizable : public Property
00056 {
00057 public:
00058         ColumnsSizable() : Property(
00059                 "ColumnsSizable",
00060                 "Property to get/set the setting for user sizing of the column headers.  Value is either \"True\" or \"False\".",
00061                 "True")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class ColumnsMovable : public Property
00082 {
00083 public:
00084         ColumnsMovable() : Property(
00085                 "ColumnsMovable",
00086                 "Property to get/set the setting for user moving of the column headers.  Value is either \"True\" or \"False\".",
00087                 "True")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00107 class SortSettingEnabled : public Property
00108 {
00109 public:
00110         SortSettingEnabled() : Property(
00111                 "SortSettingEnabled",
00112                 "Property to get/set the setting for for user modification of the sort column & direction.  Value is either \"True\" or \"False\".",
00113                 "True")
00114         {}
00115
00116         String  get(const PropertyReceiver* receiver) const;
00117         void    set(PropertyReceiver* receiver, const String& value);
00118 };
00119
00120
00134 class SortDirection : public Property
00135 {
00136 public:
00137         SortDirection() : Property(
00138                 "SortDirection",
00139                 "Property to get/set the sort direction setting of the header.  Value is the text of one of the SortDirection enumerated value names.",
00140                 "None")
00141         {}
00142
00143         String  get(const PropertyReceiver* receiver) const;
00144         void    set(PropertyReceiver* receiver, const String& value);
00145 };
00146
00147
00159 class SortColumnID : public Property
00160 {
00161 public:
00162         SortColumnID() : Property(
00163                 "SortColumnID",
00164                 "Property to get/set the current sort column (via ID code).  Value is an unsigned integer number.",
00165                 "0")
00166         {}
00167
00168         String  get(const PropertyReceiver* receiver) const;
00169         void    set(PropertyReceiver* receiver, const String& value);
00170 };
00171
00172 } // End of  ListHeaderProperties namespace section
00173
00174 } // End of  CEGUI namespace section
00175
00176
00177 #endif  // end of guard _CEGUIListHeaderProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListHeaderSegment.h Source File

include » elements

CEGUIListHeaderSegment.h

00001 /************************************************************************
00002         filename:       CEGUIListHeaderSegment.h
00003         created:        15/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to list header segment class.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListHeaderSegment_h_
00027 #define _CEGUIListHeaderSegment_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIListHeaderSegmentProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00047 class CEGUIEXPORT ListHeaderSegment : public Window
00048 {
00049 public:
00050         static const String EventNamespace;
00051
00052
00053         /*************************************************************************
00054                 Constants
00055         *************************************************************************/
00056         // Event names
00057         static const String EventSegmentClicked;
00058         static const String EventSplitterDoubleClicked;
00059         static const String EventSizingSettingChanged;
00060         static const String EventSortDirectionChanged;
00061         static const String EventMovableSettingChanged;
00062         static const String EventSegmentDragStart;
00063         static const String EventSegmentDragStop;
00064         static const String EventSegmentDragPositionChanged;
00065         static const String EventSegmentSized;
00066         static const String EventClickableSettingChanged;
00067
00068         // Defaults
00069         static const float      DefaultSizingArea;
00070         static const float      SegmentMoveThreshold;
00071
00072
00073         /*************************************************************************
00074                 Enumerated types
00075         *************************************************************************/
00080         enum SortDirection
00081         {
00082                 None,
00083                 Ascending,
00084                 Descending
00085         };
00086
00087
00088         /*************************************************************************
00089                 Accessor Methods
00090         *************************************************************************/
00098         bool    isSizingEnabled(void) const                     {return d_sizingEnabled;}
00099
00100
00113         SortDirection   getSortDirection(void) const    {return d_sortDir;}
00114
00115
00123         bool    isDragMovingEnabled(void) const         {return d_movingEnabled;}
00124
00125
00133         const Point&    getDragMoveOffset(void) const   {return d_dragPosition;}
00134
00135
00143         bool    isClickable(void) const         {return d_allowClicks;}
00144
00145
00146         /*************************************************************************
00147                 Manipulator Methods
00148         *************************************************************************/
00159         void    setSizingEnabled(bool setting);
00160
00161
00177         void    setSortDirection(SortDirection sort_dir);
00178
00179
00190         void    setDragMovingEnabled(bool setting);
00191
00192
00203         void setClickable(bool setting);
00204
00205
00206         /*************************************************************************
00207                 Construction & Destruction
00208         *************************************************************************/
00213         ListHeaderSegment(const String& type, const String& name);
00214
00215
00220         virtual ~ListHeaderSegment(void);
00221
00222
00223 protected:
00224         /*************************************************************************
00225                 Implementation Methods
00226         *************************************************************************/
00231         void    addHeaderSegmentEvents(void);
00232
00233
00244         void    doDragSizing(const Point& local_mouse);
00245
00246
00257         void    doDragMoving(const Point& local_mouse);
00258
00259
00264         void    initDragMoving(void);
00265
00266
00271         void    initSizingHoverState(void);
00272
00273
00278         void    initSegmentHoverState(void);
00279
00280
00293         bool    isDragMoveThresholdExceeded(const Point& local_mouse);
00294
00295
00306         virtual bool    testClassName_impl(const String& class_name) const
00307         {
00308                 if (class_name==(const utf8*)"ListHeaderSegment")       return true;
00309                 return Window::testClassName_impl(class_name);
00310         }
00311
00312
00313         /*************************************************************************
00314                 New Event Handlers
00315         *************************************************************************/
00320         virtual void    onSegmentClicked(WindowEventArgs& e);
00321
00322
00327         virtual void    onSplitterDoubleClicked(WindowEventArgs& e);
00328
00329
00334         virtual void    onSizingSettingChanged(WindowEventArgs& e);
00335
00336
00341         virtual void    onSortDirectionChanged(WindowEventArgs& e);
00342
00343
00348         virtual void    onMovableSettingChanged(WindowEventArgs& e);
00349
00350
00355         virtual void    onSegmentDragStart(WindowEventArgs& e);
00356
00357
00362         virtual void    onSegmentDragStop(WindowEventArgs& e);
00363
00364
00369         virtual void    onSegmentDragPositionChanged(WindowEventArgs& e);
00370
00371
00376         virtual void    onSegmentSized(WindowEventArgs& e);
00377
00378
00383         virtual void    onClickableSettingChanged(WindowEventArgs& e);
00384
00385
00386         /*************************************************************************
00387                 Overridden Event Handlers
00388         *************************************************************************/
00389         virtual void    onMouseMove(MouseEventArgs& e);
00390         virtual void    onMouseButtonDown(MouseEventArgs& e);
00391         virtual void    onMouseButtonUp(MouseEventArgs& e);
00392         virtual void    onMouseDoubleClicked(MouseEventArgs& e);
00393         virtual void    onMouseLeaves(MouseEventArgs& e);
00394         virtual void    onCaptureLost(WindowEventArgs& e);
00395
00396
00397         /*************************************************************************
00398                 Implementation Data
00399         *************************************************************************/
00400         const Image*    d_sizingMouseCursor;
00401         const Image*    d_movingMouseCursor;
00402
00403         float   d_splitterSize;
00404         bool    d_splitterHover;
00405
00406         bool    d_dragSizing;
00407         Point   d_dragPoint;
00408
00409         SortDirection   d_sortDir;
00410
00411         bool    d_segmentHover;
00412         bool    d_segmentPushed;
00413         bool    d_sizingEnabled;
00414         bool    d_movingEnabled;
00415         bool    d_dragMoving;
00416         Point   d_dragPosition;
00417         bool    d_allowClicks;
00418
00419
00420 private:
00421         /*************************************************************************
00422                 Static Properties for this class
00423         *************************************************************************/
00424         static ListHeaderSegmentProperties::Clickable           d_clickableProperty;
00425         static ListHeaderSegmentProperties::Dragable            d_dragableProperty;
00426         static ListHeaderSegmentProperties::Sizable                     d_sizableProperty;
00427         static ListHeaderSegmentProperties::SortDirection       d_sortDirectionProperty;
00428
00429
00430         /*************************************************************************
00431                 Private methods
00432         *************************************************************************/
00433         void    addHeaderSegmentProperties(void);
00434 };
00435
00436 } // End of  CEGUI namespace section
00437
00438 #if defined(_MSC_VER)
00439 #       pragma warning(pop)
00440 #endif
00441
00442 #endif  // end of guard _CEGUIListHeaderSegment_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIListHeaderSegmentProperties.h Source File

include » elements

CEGUIListHeaderSegmentProperties.h

00001 /************************************************************************
00002         filename:       CEGUIListHeaderSegmentProperties.h
00003         created:        11/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for ListHeaderSegment class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIListHeaderSegmentProperties_h_
00027 #define _CEGUIListHeaderSegmentProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ListHeaderSegmentProperties namespace section
00041 namespace ListHeaderSegmentProperties
00042 {
00055 class Sizable : public Property
00056 {
00057 public:
00058         Sizable() : Property(
00059                 "Sizable",
00060                 "Property to get/set the sizable setting of the header segment.  Value is either \"True\" or \"False\".",
00061                 "True")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class Clickable : public Property
00082 {
00083 public:
00084         Clickable() : Property(
00085                 "Clickable",
00086                 "Property to get/set the click-able setting of the header segment.  Value is either \"True\" or \"False\".",
00087                 "True")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00107 class Dragable : public Property
00108 {
00109 public:
00110         Dragable() : Property(
00111                 "Dragable",
00112                 "Property to get/set the drag-able setting of the header segment.  Value is either \"True\" or \"False\".",
00113                 "True")
00114         {}
00115
00116         String  get(const PropertyReceiver* receiver) const;
00117         void    set(PropertyReceiver* receiver, const String& value);
00118 };
00119
00120
00134 class SortDirection : public Property
00135 {
00136 public:
00137         SortDirection() : Property(
00138                 "SortDirection",
00139                 "Property to get/set the sort direction setting of the header segment.  Value is the text of one of the SortDirection enumerated value names.",
00140                 "None")
00141         {}
00142
00143         String  get(const PropertyReceiver* receiver) const;
00144         void    set(PropertyReceiver* receiver, const String& value);
00145 };
00146
00147 } // End of  ListHeaderSegmentProperties namespace section
00148
00149 } // End of  CEGUI namespace section
00150
00151
00152 #endif  // end of guard _CEGUIListHeaderSegmentProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUILogger.h Source File

include

CEGUILogger.h

00001 /************************************************************************
00002         filename:       CEGUILogger.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for the Logger class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUILogger_h_
00027 #define _CEGUILogger_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include <fstream>
00032 #include <sstream>
00033 #include <vector>
00034 #include <utility>
00035 #include "CEGUISingleton.h"
00036
00037
00038 #if defined(_MSC_VER)
00039 #       pragma warning(push)
00040 #       pragma warning(disable : 4275)
00041 #       pragma warning(disable : 4251)
00042 #endif
00043
00044
00045 // Start of CEGUI namespace section
00046 namespace CEGUI
00047 {
00048
00053 enum LoggingLevel
00054 {
00055         Errors,
00056         Standard,
00057         Informative,
00058         Insane
00059 };
00060
00065 class CEGUIEXPORT Logger : public Singleton <Logger>
00066 {
00067 public:
00072         Logger(void);
00073
00077         ~Logger(void);
00078
00079
00087         static Logger&  getSingleton(void);
00088
00089
00100         void    setLoggingLevel(LoggingLevel level)             {d_level = level;}
00101
00102
00110         LoggingLevel    getLoggingLevel(void) const             {return d_level;}
00111
00112
00126         void    logEvent(const String& message, LoggingLevel level = Standard);
00127
00143     void    setLogFilename(const String& filename, bool append = false);
00144
00145 protected:
00146     /*************************************************************************
00147                 Implementation Data
00148         *************************************************************************/
00149         LoggingLevel    d_level;
00150         std::ofstream   d_ostream;
00151     std::vector<std::pair<String, LoggingLevel> > d_cache;
00152     std::ostringstream d_workstream;
00153     bool d_caching;
00154
00155 private:
00156         /*************************************************************************
00157                 Copy constructor and assignment usage is denied.
00158         *************************************************************************/
00159         Logger(const Logger& logger) {}
00160         Logger& operator=(const Logger& logger) {return *this;}
00161
00162 };
00163
00164 /*************************************************************************
00165         This macro is used for 'Insane' level logging so that those items are
00166         excluded from non-debug builds
00167 *************************************************************************/
00168 #if defined(DEBUG) || defined (_DEBUG)
00169 #       define CEGUI_LOGINSANE( message ) CEGUI::Logger::getSingleton().logEvent((message), CEGUI::Insane);
00170 #else
00171 #       define CEGUI_LOGINSANE( message )
00172 #endif
00173
00174 } // End of  CEGUI namespace section
00175
00176 #if defined(_MSC_VER)
00177 #       pragma warning(pop)
00178 #endif
00179
00180 #endif  // end of guard _CEGUILogger_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMenubar.h Source File

include » elements

CEGUIMenubar.h

00001 /************************************************************************
00002         filename:       CEGUIMenubar.h
00003         created:        27/3/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005
00006         purpose:        Interface to base class for Menubar widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMenubar_h_
00027 #define _CEGUIMenubar_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIMenuBase.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00043
00048 class CEGUIEXPORT Menubar : public MenuBase
00049 {
00050 public:
00051         static const String EventNamespace;
00052
00053         /*************************************************************************
00054                 Construction and Destruction
00055         *************************************************************************/
00060         Menubar(const String& type, const String& name);
00061
00062
00067         virtual ~Menubar(void);
00068
00069
00070 protected:
00071         /*************************************************************************
00072                 Implementation Functions
00073         *************************************************************************/
00081         virtual void    layoutItemWidgets();
00082
00083
00091         virtual Size getContentSize();
00092
00093
00104         virtual bool    testClassName_impl(const String& class_name) const
00105         {
00106                 if (class_name==(const utf8*)"Menubar") return true;
00107                 return MenuBase::testClassName_impl(class_name);
00108         }
00109
00110 };
00111
00112 } // End of  CEGUI namespace section
00113
00114
00115 #if defined(_MSC_VER)
00116 #       pragma warning(pop)
00117 #endif
00118
00119 #endif  // end of guard _CEGUIMenubar_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMenuBase.h Source File

include » elements

CEGUIMenuBase.h

00001 /************************************************************************
00002         filename:       CEGUIMenuBase.h
00003         created:        5/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005
00006         purpose:        Interface to base class for MenuBase widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMenuBase_h_
00027 #define _CEGUIMenuBase_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIMenuBaseProperties.h"
00032 #include "elements/CEGUIItemListBase.h"
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00044
00049 class CEGUIEXPORT MenuBase : public ItemListBase
00050 {
00051 public:
00052         static const String EventNamespace;
00053
00054         /*************************************************************************
00055                 Constants
00056         *************************************************************************/
00057         static const colour DefaultBackgroundColour;
00058
00059
00060         /*************************************************************************
00061                 Event name constants
00062         *************************************************************************/
00063         // generated internally by Window
00064         static const String EventPopupOpened;
00065         static const String EventPopupClosed;
00066
00067
00068         /*************************************************************************
00069                 Accessor type functions
00070         *************************************************************************/
00078         float   getItemSpacing(void) const                                      {return d_itemSpacing;}
00079
00080
00088         float   getHorzPadding(void) const                                      {return d_horzPadding;}
00089
00090
00098         float   getVertPadding(void) const                                      {return d_vertPadding;}
00099
00100
00108         float   getBorderWidth(void) const                                      {return d_borderWidth;}
00109
00110
00118         const ColourRect&       getBackgroundColours(void) const        {return d_backgroundColours;}
00119
00120
00128         bool    isMultiplePopupsAllowed(void) const                     {return d_allowMultiplePopups;}
00129
00130
00138         MenuItem*       getPopupMenuItem(void) const                            {return d_popup;}
00139
00140
00141         /*************************************************************************
00142                 Manipulators
00143         *************************************************************************/
00148         void    setItemSpacing(float spacing)                           {d_itemSpacing=spacing;handleUpdatedItemData();}
00149
00150
00155         void    setHorzPadding(float padding)                           {d_horzPadding=padding;handleUpdatedItemData();}
00156
00157
00162         void    setVertPadding(float padding)                           {d_vertPadding=padding;handleUpdatedItemData();}
00163
00164
00169         void    setBorderWidth(float border)                            {d_borderWidth=border;handleUpdatedItemData();}
00170
00171
00176         void    setBackgroundColours(const ColourRect& cr)      {d_backgroundColours=cr;}
00177
00178
00186         void    changePopupMenuItem(MenuItem* item);
00187
00188
00193         void    setAllowMultiplePopups(bool setting)            {d_allowMultiplePopups=setting;}
00194
00195
00196         /*************************************************************************
00197                 Construction and Destruction
00198         *************************************************************************/
00203         MenuBase(const String& type, const String& name);
00204
00205
00210         virtual ~MenuBase(void);
00211
00212
00213 protected:
00214         /*************************************************************************
00215                 New Event Handlers
00216         *************************************************************************/
00221         virtual void    onPopupOpened(WindowEventArgs& e);
00222
00223
00228         virtual void    onPopupClosed(WindowEventArgs& e);
00229
00230
00231         /*************************************************************************
00232                 Implementation Functions
00233         *************************************************************************/
00238         void    addMenuBaseEvents(void);
00239
00240
00251         virtual bool    testClassName_impl(const String& class_name) const
00252         {
00253                 if (class_name==(const utf8*)"MenuBase")        return true;
00254                 return ItemListBase::testClassName_impl(class_name);
00255         }
00256
00257
00258         /*************************************************************************
00259                 Implementation Data
00260         *************************************************************************/
00261         float d_itemSpacing;
00262         float d_horzPadding;
00263         float d_vertPadding;
00264         float d_borderWidth;
00265
00266         ColourRect d_backgroundColours;
00267
00268         MenuItem* d_popup;
00269         bool d_allowMultiplePopups;
00270
00271
00272 private:
00273         /*************************************************************************
00274         Static Properties for this class
00275         *************************************************************************/
00276         static MenuBaseProperties::ItemSpacing                  d_itemSpacingProperty;
00277         static MenuBaseProperties::HorzPadding                  d_horzPaddingProperty;
00278         static MenuBaseProperties::VertPadding                  d_vertPaddingProperty;
00279         static MenuBaseProperties::BorderWidth                  d_borderWidthProperty;
00280         static MenuBaseProperties::BackgroundColours    d_backgroundColoursProperty;
00281         static MenuBaseProperties::AllowMultiplePopups  d_allowMultiplePopupsProperty;
00282
00283         /*************************************************************************
00284         Private methods
00285         *************************************************************************/
00286         void    addMenuBaseProperties(void);
00287 };
00288
00289 } // End of  CEGUI namespace section
00290
00291
00292 #if defined(_MSC_VER)
00293 #       pragma warning(pop)
00294 #endif
00295
00296 #endif  // end of guard _CEGUIMenuBase_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMenuBaseProperties.h Source File

include » elements

CEGUIMenuBaseProperties.h

00001 /************************************************************************
00002         filename:       CEGUIMenuBaseProperties.h
00003         created:        5/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIMenuBaseProperties_h_
00025 #define _CEGUIMenuBaseProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of ItemListBaseProperties namespace section
00033 namespace MenuBaseProperties
00034 {
00035
00047 class ItemSpacing : public Property
00048 {
00049 public:
00050         ItemSpacing() : Property(
00051                 "ItemSpacing",
00052                 "Property to get/set the item spacing of the menu.  Value is a float.",
00053                 "10.000000")
00054         {}
00055
00056         String  get(const PropertyReceiver* receiver) const;
00057         void    set(PropertyReceiver* receiver, const String& value);
00058 };
00059
00060
00072 class HorzPadding : public Property
00073 {
00074 public:
00075         HorzPadding() : Property(
00076                 "HorzPadding",
00077                 "Property to get/set the horizontal padding of the menu.  Value is a float.",
00078                 "3.000000")
00079         {}
00080
00081         String  get(const PropertyReceiver* receiver) const;
00082         void    set(PropertyReceiver* receiver, const String& value);
00083 };
00084
00085
00097 class VertPadding : public Property
00098 {
00099 public:
00100         VertPadding() : Property(
00101                 "VertPadding",
00102                 "Property to get/set the vertical padding of the menu.  Value is a float.",
00103                 "3.000000")
00104         {}
00105
00106         String  get(const PropertyReceiver* receiver) const;
00107         void    set(PropertyReceiver* receiver, const String& value);
00108 };
00109
00110
00122 class BorderWidth : public Property
00123 {
00124 public:
00125         BorderWidth() : Property(
00126                 "BorderWidth",
00127                 "Property to get/set the border width of the menu.  Value is a float.",
00128                 "5.000000")
00129         {}
00130
00131         String  get(const PropertyReceiver* receiver) const;
00132         void    set(PropertyReceiver* receiver, const String& value);
00133 };
00134
00135
00147 class BackgroundColours : public Property
00148 {
00149 public:
00150         BackgroundColours() : Property(
00151                 "BackgroundColours",
00152                 "Property to get/set the background colours of the menu.  Value is a ColourRect.",
00153                 "tl:FFFFFFFF tr:FFFFFFFF bl:FFFFFFFF br:FFFFFFFF")
00154         {}
00155
00156         String  get(const PropertyReceiver* receiver) const;
00157         void    set(PropertyReceiver* receiver, const String& value);
00158 };
00159
00160
00173 class AllowMultiplePopups : public Property
00174 {
00175 public:
00176     AllowMultiplePopups() : Property(
00177             "AllowMultiplePopups",
00178             "Property to get/set the state of the allow multiple popups setting for the menu.  Value is either \"True\" or \"False\".",
00179             "False")
00180     {}
00181
00182     String      get(const PropertyReceiver* receiver) const;
00183     void        set(PropertyReceiver* receiver, const String& value);
00184 };
00185
00186 } // End of  MenuBaseProperties namespace section
00187 } // End of  CEGUI namespace section
00188
00189 #endif  // end of guard _CEGUIMenuBaseProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMenuItem.h Source File

include » elements

CEGUIMenuItem.h

00001 /************************************************************************
00002         filename:       CEGUIMenuItem.h
00003         created:        2/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005
00006         purpose:        Interface to base class for MenuItem widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMenuItem_h_
00027 #define _CEGUIMenuItem_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUITextItem.h"
00032 #include "elements/CEGUIMenuItemProperties.h"
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00044
00049 class CEGUIEXPORT MenuItem : public TextItem
00050 {
00051 public:
00052         static const String EventNamespace;
00053
00054         /*************************************************************************
00055                 Constants
00056         *************************************************************************/
00057         // default colours for rendering
00058
00059         static const colour             DefaultHoverColour;
00060         static const colour             DefaultPushedColour;
00061         static const colour             DefaultOpenedColour;
00062         static const colour             DefaultNormalTextColour;
00063         static const colour             DefaultDisabledTextColour;
00064
00065
00066         /*************************************************************************
00067                 Event name constants
00068         *************************************************************************/
00069         // generated internally by Window
00070         static const String EventClicked;
00071
00072
00073         /*************************************************************************
00074                 Accessor type functions
00075         *************************************************************************/
00083         bool    isHovering(void) const                  {return d_hovering;}
00084
00085
00093         bool    isPushed(void) const                    {return d_pushed;}
00094
00095
00103         colour  getHoverColour(void) const                      {return d_hoverColour;}
00104
00105
00113         colour  getPushedColour(void) const                     {return d_pushedColour;}
00114
00115
00123         colour  getOpenedColour(void) const                     {return d_openedColour;}
00124
00125
00133         colour  getNormalTextColour(void) const                 {return d_normalTextColour;}
00134
00135
00143         colour  getDisabledTextColour(void) const               {return d_disabledTextColour;}
00144
00145
00153         PopupMenu*      getPopupMenu(void) const                        {return d_popup;}
00154
00155
00156         /*************************************************************************
00157                 Manipulators
00158         *************************************************************************/
00169         void    setHoverColour(const colour& colour);
00170
00171
00182         void    setPushedColour(const colour& colour);
00183
00184
00195         void    setOpenedColour(const colour& colour);
00196
00197
00208         void    setNormalTextColour(const colour& colour);
00209
00210
00221         void    setDisabledTextColour(const colour& colour);
00222
00223
00234         void    setPopupMenu(PopupMenu* popup);
00235
00236
00241         void    openPopupMenu(void);
00242
00243
00254         void    closePopupMenu(bool notify=true);
00255
00256
00264         bool    togglePopupMenu(void);
00265
00266
00267         /*************************************************************************
00268                 Construction and Destruction
00269         *************************************************************************/
00274         MenuItem(const String& type, const String& name);
00275
00276
00281         virtual ~MenuItem(void);
00282
00283
00284 protected:
00285         /*************************************************************************
00286                 New Event Handlers
00287         *************************************************************************/
00292         virtual void    onClicked(WindowEventArgs& e);
00293
00294
00295         /*************************************************************************
00296                 Overridden event handlers
00297         *************************************************************************/
00298         virtual void    onMouseMove(MouseEventArgs& e);
00299         virtual void    onMouseButtonDown(MouseEventArgs& e);
00300         virtual void    onMouseButtonUp(MouseEventArgs& e);
00301         virtual void    onCaptureLost(WindowEventArgs& e);
00302         virtual void    onMouseLeaves(MouseEventArgs& e);
00303
00304
00305         /*************************************************************************
00306                 Implementation Functions
00307         *************************************************************************/
00318         void    updateInternalState(const Point& mouse_pos);
00319
00320
00325         void    addMenuItemEvents(void);
00326
00327
00335         void    closeAllMenuItemPopups();
00336
00337
00348         virtual bool    testClassName_impl(const String& class_name) const
00349         {
00350                 if (class_name==(const utf8*)"MenuItem")        return true;
00351                 return TextItem::testClassName_impl(class_name);
00352         }
00353
00354
00355         /*************************************************************************
00356                 Implementation Rendering Functions
00357         *************************************************************************/
00358
00359         /*************************************************************************
00360                 Implementation Data
00361         *************************************************************************/
00362         bool    d_pushed;
00363         bool    d_hovering;
00364         bool    d_opened;
00365
00366         // common rendering setting data
00367         colour  d_hoverColour;
00368         colour  d_pushedColour;
00369         colour  d_openedColour;
00370         colour  d_normalTextColour;
00371         colour  d_disabledTextColour;
00372
00373         PopupMenu* d_popup;
00374
00375         bool    d_popupWasClosed;
00376
00377 private:
00378         /*************************************************************************
00379                 Static Properties for this class
00380         *************************************************************************/
00381         static MenuItemProperties::HoverColour                  d_hoverColourProperty;
00382         static MenuItemProperties::PushedColour                 d_pushedColourProperty;
00383         static MenuItemProperties::OpenedColour                 d_openedColourProperty;
00384         static MenuItemProperties::NormalTextColour             d_normalTextColourProperty;
00385         static MenuItemProperties::DisabledTextColour   d_disabledTextColourProperty;
00386
00387
00388         /*************************************************************************
00389                 Private methods
00390         *************************************************************************/
00391         void addMenuItemProperties(void);
00392
00393
00398         virtual void    addChild_impl(Window* wnd);
00399 };
00400
00401 } // End of  CEGUI namespace section
00402
00403
00404 #if defined(_MSC_VER)
00405 #       pragma warning(pop)
00406 #endif
00407
00408
00409 #endif  // end of guard _CEGUIMenuItem_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMenuItemProperties.h Source File

include » elements

CEGUIMenuItemProperties.h

00001 /************************************************************************
00002         filename:       CEGUIMenuItemProperties.h
00003         created:        8/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIMenuItemProperties_h_
00025 #define _CEGUIMenuItemProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of MenuItemProperties namespace section
00033 namespace MenuItemProperties
00034 {
00035
00047 class HoverColour : public Property
00048 {
00049 public:
00050         HoverColour() : Property(
00051                 "HoverColour",
00052                 "Property to get/set the hover colour of the item.  Value is a colour.",
00053                 "00FFFFFF")
00054         {}
00055
00056         String  get(const PropertyReceiver* receiver) const;
00057         void    set(PropertyReceiver* receiver, const String& value);
00058 };
00059
00060
00072 class PushedColour : public Property
00073 {
00074 public:
00075         PushedColour() : Property(
00076                 "PushedColour",
00077                 "Property to get/set the pushed colour of the item.  Value is a colour.",
00078                 "00FFFFFF")
00079         {}
00080
00081         String  get(const PropertyReceiver* receiver) const;
00082         void    set(PropertyReceiver* receiver, const String& value);
00083 };
00084
00085
00097 class OpenedColour : public Property
00098 {
00099 public:
00100         OpenedColour() : Property(
00101                 "OpenedColour",
00102                 "Property to get/set the opened colour of the item.  Value is a colour.",
00103                 "00EFEFEF")
00104         {}
00105
00106         String  get(const PropertyReceiver* receiver) const;
00107         void    set(PropertyReceiver* receiver, const String& value);
00108 };
00109
00110
00122 class NormalTextColour : public Property
00123 {
00124 public:
00125         NormalTextColour() : Property(
00126                 "NormalTextColour",
00127                 "Property to get/set the normal text colour of the item.  Value is a colour.",
00128                 "00FFFFFF")
00129         {}
00130
00131         String  get(const PropertyReceiver* receiver) const;
00132         void    set(PropertyReceiver* receiver, const String& value);
00133 };
00134
00135
00147 class DisabledTextColour : public Property
00148 {
00149 public:
00150         DisabledTextColour() : Property(
00151                 "DisabledTextColour",
00152                 "Property to get/set the disabled text colour of the item.  Value is a colour.",
00153                 "007F7F7F")
00154         {}
00155
00156         String  get(const PropertyReceiver* receiver) const;
00157         void    set(PropertyReceiver* receiver, const String& value);
00158 };
00159
00160
00161 } // End of  MenuItemProperties namespace section
00162 } // End of  CEGUI namespace section
00163
00164 #endif  // end of guard _CEGUIMenuItemProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMouseCursor.h Source File

include

CEGUIMouseCursor.h

00001 /************************************************************************
00002         filename:       CEGUIMouseCursor.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for the MouseCursor class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMouseCursor_h_
00027 #define _CEGUIMouseCursor_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUIVector.h"
00033 #include "CEGUIRect.h"
00034 #include "CEGUIEventSet.h"
00035 #include "CEGUIInputEvent.h"
00036 #include "CEGUIUDim.h"
00037
00038
00039 #if defined(_MSC_VER)
00040 #       pragma warning(push)
00041 #       pragma warning(disable : 4275)
00042 #       pragma warning(disable : 4251)
00043 #endif
00044
00045
00046 // Start of CEGUI namespace section
00047 namespace CEGUI
00048 {
00049
00054 enum MouseCursorImage
00055 {
00056         BlankMouseCursor        = 0,
00057         DefaultMouseCursor      = -1
00058 };
00059
00060
00067 class CEGUIEXPORT MouseCursor : public EventSet, public Singleton<MouseCursor>
00068 {
00069 public:
00070         static const String EventNamespace;
00071
00072         /*************************************************************************
00073                 Event name constants
00074         *************************************************************************/
00075         // generated internally by MouseCursor
00076         static const String EventImageChanged;
00077
00078
00083         MouseCursor(void);
00084
00085
00090         ~MouseCursor(void);
00091
00092
00100         static  MouseCursor&    getSingleton(void);
00101
00102
00110         static  MouseCursor*    getSingletonPtr(void);
00111
00112
00128         void    setImage(const String& imageset, const String& image_name);
00129
00130
00135         void    setImage(const Image* image);
00136
00137
00144         const Image*    getImage(void) const    {return d_cursorImage;}
00145
00146
00154         void    draw(void) const;
00155
00156
00164         void    setPosition(const Point& position);
00165
00166
00177         void    offsetPosition(const Point& offset);
00178
00179
00192         void    setConstraintArea(const Rect* area);
00193
00194
00207         void    setUnifiedConstraintArea(const URect* area);
00208
00209
00217         void    hide(void)              {d_visible = false;}
00218
00219
00227         void    show(void)              {d_visible = true;}
00228
00229
00237         bool    isVisible(void) const   {return d_visible;}
00238
00239
00247         Point   getPosition(void) const         {return Point(d_position.d_x, d_position.d_y);}
00248
00249
00257         Rect    getConstraintArea(void) const;
00258
00259
00267         const URect& getUnifiedConstraintArea(void) const;
00268
00269
00279         Point   getDisplayIndependantPosition(void) const;
00280
00281
00282 protected:
00283         /*************************************************************************
00284                 New event handlers
00285         *************************************************************************/
00290         virtual void    onImageChanged(MouseCursorEventArgs& e);
00291
00292
00293         /*************************************************************************
00294                 Implementation Functions
00295         *************************************************************************/
00300         void    addMouseCursorEvents(void);
00301
00302
00303 private:
00304         /*************************************************************************
00305                 Implementation Methods
00306         *************************************************************************/
00311         void    constrainPosition(void);
00312
00313
00314         /*************************************************************************
00315                 Implementation Data
00316         *************************************************************************/
00317         const Image*    d_cursorImage;
00318         Vector3 d_position;
00319         bool    d_visible;
00320         URect   d_constraints;
00321 };
00322
00323 } // End of  CEGUI namespace section
00324
00325 #if defined(_MSC_VER)
00326 #       pragma warning(pop)
00327 #endif
00328
00329 #endif  // end of guard _CEGUIMouseCursor_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMultiColumnList.h Source File

include » elements

CEGUIMultiColumnList.h

00001 /************************************************************************
00002         filename:       CEGUIMultiColumnList.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for MultiColumnList widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMultiColumnList_h_
00027 #define _CEGUIMultiColumnList_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "CEGUIListHeader.h"
00032 #include "elements/CEGUIMultiColumnListProperties.h"
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00044
00049 struct CEGUIEXPORT MCLGridRef
00050 {
00051         MCLGridRef(uint r, uint c) : row(r), column(c) {}
00052
00053         uint    row;
00054         uint    column;
00055
00056         // operators
00057         MCLGridRef& operator=(const MCLGridRef& rhs);
00058         bool operator<(const MCLGridRef& rhs) const;
00059         bool operator<=(const MCLGridRef& rhs) const;
00060         bool operator>(const MCLGridRef& rhs) const;
00061         bool operator>=(const MCLGridRef& rhs) const;
00062         bool operator==(const MCLGridRef& rhs) const;
00063         bool operator!=(const MCLGridRef& rhs) const;
00064 };
00065
00066
00071 class CEGUIEXPORT MultiColumnList : public Window
00072 {
00073 public:
00074         static const String EventNamespace;
00075
00076
00077         /*************************************************************************
00078                 Constants
00079         *************************************************************************/
00080         // Event names
00081         static const String EventSelectionModeChanged;
00082         static const String EventNominatedSelectColumnChanged;
00083         static const String EventNominatedSelectRowChanged;
00084         static const String EventVertScrollbarModeChanged;
00085         static const String EventHorzScrollbarModeChanged;
00086         static const String EventSelectionChanged;
00087         static const String EventListContentsChanged;
00088         static const String EventSortColumnChanged;
00089         static const String EventSortDirectionChanged;
00090         static const String EventListColumnSized;
00091         static const String EventListColumnMoved;
00092
00093
00094         /*************************************************************************
00095                 Enumerations
00096         *************************************************************************/
00101         enum SelectionMode
00102         {
00103                 RowSingle,                                      // Any single row may be selected.  All items in the row are selected.
00104                 RowMultiple,                            // Multiple rows may be selected.  All items in the row are selected.
00105                 CellSingle,                                     // Any single cell may be selected.
00106                 CellMultiple,                           // Multiple cells bay be selected.
00107                 NominatedColumnSingle,          // Any single item in a nominated column may be selected.
00108                 NominatedColumnMultiple,        // Multiple items in a nominated column may be selected.
00109                 ColumnSingle,                           // Any single column may be selected.  All items in the column are selected.
00110                 ColumnMultiple,                         // Multiple columns may be selected.  All items in the column are selected.
00111                 NominatedRowSingle,                     // Any single item in a nominated row may be selected.
00112                 NominatedRowMultiple            // Multiple items in a nominated row may be selected.
00113         };
00114
00115
00116         /*************************************************************************
00117                 Accessor Methods
00118         *************************************************************************/
00127         bool    isUserSortControlEnabled(void) const;
00128
00129
00137         bool    isUserColumnSizingEnabled(void) const;
00138
00139
00147         bool    isUserColumnDraggingEnabled(void) const;
00148
00149
00157         uint    getColumnCount(void) const;
00158
00159
00167         uint    getRowCount(void) const;
00168
00169
00180         uint    getSortColumn(void) const;
00181
00182
00195         uint    getColumnWithID(uint col_id) const;
00196
00197
00210         uint    getColumnWithHeaderText(const String& text) const;
00211
00212
00220         float   getTotalColumnHeadersWidth(void) const;
00221
00222
00235         float   getColumnHeaderWidth(uint col_idx) const;
00236
00237
00245         ListHeaderSegment::SortDirection        getSortDirection(void) const;
00246
00247
00260         ListHeaderSegment&      getHeaderSegmentForColumn(uint col_idx) const;
00261
00262
00275         uint    getItemRowIndex(const ListboxItem* item) const;
00276
00277
00290         uint    getItemColumnIndex(const ListboxItem* item) const;
00291
00292
00305         MCLGridRef      getItemGridReference(const ListboxItem* item) const;
00306
00307
00320         ListboxItem*    getItemAtGridReference(const MCLGridRef& grid_ref) const;
00321
00322
00339         bool    isListboxItemInColumn(const ListboxItem* item, uint col_idx) const;
00340
00341
00358         bool    isListboxItemInRow(const ListboxItem* item, uint row_idx) const;
00359
00360
00372         bool    isListboxItemInList(const ListboxItem* item) const;
00373
00374
00393         ListboxItem*    findColumnItemWithText(const String& text, uint col_idx, const ListboxItem* start_item) const;
00394
00395
00414         ListboxItem*    findRowItemWithText(const String& text, uint row_idx, const ListboxItem* start_item) const;
00415
00416
00435         ListboxItem*    findListItemWithText(const String& text, const ListboxItem* start_item) const;
00436
00437
00448         ListboxItem*    getFirstSelectedItem(void) const;
00449
00450
00466         ListboxItem*    getNextSelected(const ListboxItem* start_item) const;
00467
00468
00476         uint    getSelectedCount(void) const;
00477
00478
00492         bool    isItemSelected(const MCLGridRef& grid_ref) const;
00493
00494
00506         uint    getNominatedSelectionColumnID(void) const;
00507
00508
00517         uint    getNominatedSelectionColumn(void) const;
00518
00519
00528         uint    getNominatedSelectionRow(void) const;
00529
00530
00538         MultiColumnList::SelectionMode  getSelectionMode(void) const;
00539
00540
00549         bool    isVertScrollbarAlwaysShown(void) const;
00550
00551
00560         bool    isHorzScrollbarAlwaysShown(void) const;
00561
00562
00575         uint    getColumnID(uint col_idx) const;
00576
00577
00590         uint    getRowID(uint row_idx) const;
00591
00592
00605         uint    getRowWithID(uint row_id) const;
00606
00607
00608         /*************************************************************************
00609                 Manipulator Methods
00610         *************************************************************************/
00621         virtual void    initialise(void);
00622
00623
00630         void    resetList(void);
00631
00632
00649         void    addColumn(const String& text, uint col_id, float width);
00650
00651
00672         void    insertColumn(const String& text, uint col_id, float width, uint position);
00673
00674
00687         void    removeColumn(uint col_idx);
00688
00689
00702         void    removeColumnWithID(uint col_id);
00703
00704
00720         void    moveColumn(uint col_idx, uint position);
00721
00722
00738         void    moveColumnWithID(uint col_id, uint position);
00739
00740
00755         uint    addRow(uint row_id = 0);
00756
00757
00780         uint    addRow(ListboxItem* item, uint col_id, uint row_id = 0);
00781
00782
00801         uint    insertRow(uint row_idx, uint row_id = 0);
00802
00803
00830         uint    insertRow(ListboxItem* item, uint col_id, uint row_idx, uint row_id = 0);
00831
00832
00845         void    removeRow(uint row_idx);
00846
00847
00863         void    setItem(ListboxItem* item, const MCLGridRef& position);
00864
00865
00884         void    setItem(ListboxItem* item, uint col_id, uint row_idx);
00885
00886
00899         void    setSelectionMode(MultiColumnList::SelectionMode sel_mode);
00900
00901
00914         void    setNominatedSelectionColumnID(uint col_id);
00915
00916
00929         void    setNominatedSelectionColumn(uint col_idx);
00930
00931
00944         void    setNominatedSelectionRow(uint row_idx);
00945
00946
00957         void    setSortDirection(ListHeaderSegment::SortDirection direction);
00958
00959
00972         void    setSortColumn(uint col_idx);
00973
00974
00987         void    setSortColumnByID(uint col_id);
00988
00989
01001         void    setShowVertScrollbar(bool setting);
01002
01003
01015         void    setShowHorzScrollbar(bool setting);
01016
01017
01025         void    clearAllSelections(void);
01026
01027
01048         void    setItemSelectState(ListboxItem* item, bool state);
01049
01050
01071         void    setItemSelectState(const MCLGridRef& grid_ref, bool state);
01072
01073
01082         void    handleUpdatedItemData(void);
01083
01084
01100         void    setColumnHeaderWidth(uint col_idx, float width);
01101
01102
01114         void    setUserSortControlEnabled(bool setting);
01115
01116
01128         void    setUserColumnSizingEnabled(bool setting);
01129
01130
01139         void    setUserColumnDraggingEnabled(bool setting);
01140
01141
01155         void    autoSizeColumnHeader(uint col_idx);
01156
01157
01173         void    setRowID(uint row_idx, uint row_id);
01174
01175
01176         /*************************************************************************
01177                 Construction and Destruction
01178         *************************************************************************/
01183         MultiColumnList(const String& type, const String& name);
01184
01185
01190         virtual ~MultiColumnList(void);
01191
01192
01193 protected:
01194         /*************************************************************************
01195                 Implementation Functions (abstract interface)
01196         *************************************************************************/
01206         virtual Rect    getListRenderArea(void) const           = 0;
01207
01208
01219         virtual ListHeader*     createListHeader(const String& name) const              = 0;
01220
01221
01232         virtual Scrollbar*      createVertScrollbar(const String& name) const           = 0;
01233
01234
01245         virtual Scrollbar*      createHorzScrollbar(const String& name) const           = 0;
01246
01247
01258         virtual void    cacheListboxBaseImagery()               = 0;
01259
01260
01261         /*************************************************************************
01262                 Implementation Functions
01263         *************************************************************************/
01268         void    addMultiColumnListboxEvents(void);
01269
01270     // overridden from base class.
01271         virtual void populateRenderCache();
01272
01273
01278         void    configureScrollbars(void);
01279
01280
01285         bool    selectRange(const MCLGridRef& start, const MCLGridRef& end);
01286
01287
01292         float   getTotalRowsHeight(void) const;
01293
01294
01299         float   getWidestColumnItemWidth(uint col_idx) const;
01300
01301
01306         float   getHighestRowItemHeight(uint row_idx) const;
01307
01308
01316         bool    clearAllSelections_impl(void);
01317
01318
01327         ListboxItem*    getItemAtPoint(const Point& pt) const;
01328
01329
01336         bool    setItemSelectState_impl(const MCLGridRef grid_ref, bool state);
01337
01338
01343         void    setSelectForItemsInRow(uint row_idx, bool state);
01344
01345
01350         void    setSelectForItemsInColumn(uint col_idx, bool state);
01351
01352
01360         void    moveColumn_impl(uint col_idx, uint position);
01361
01362
01374         bool    resetList_impl(void);
01375
01376
01387         virtual bool    testClassName_impl(const String& class_name) const
01388         {
01389                 if (class_name==(const utf8*)"MultiColumnList") return true;
01390                 return Window::testClassName_impl(class_name);
01391         }
01392
01393     // overrides function in base class.
01394     int writePropertiesXML(OutStream& out_stream) const;
01395
01396         /*************************************************************************
01397                 New event handlers for multi column list
01398         *************************************************************************/
01403         virtual void    onSelectionModeChanged(WindowEventArgs& e);
01404
01405
01410         virtual void    onNominatedSelectColumnChanged(WindowEventArgs& e);
01411
01412
01417         virtual void    onNominatedSelectRowChanged(WindowEventArgs& e);
01418
01419
01424         virtual void    onVertScrollbarModeChanged(WindowEventArgs& e);
01425
01426
01431         virtual void    onHorzScrollbarModeChanged(WindowEventArgs& e);
01432
01433
01438         virtual void    onSelectionChanged(WindowEventArgs& e);
01439
01440
01445         virtual void    onListContentsChanged(WindowEventArgs& e);
01446
01447
01452         virtual void    onSortColumnChanged(WindowEventArgs& e);
01453
01454
01459         virtual void    onSortDirectionChanged(WindowEventArgs& e);
01460
01461
01466         virtual void    onListColumnSized(WindowEventArgs& e);
01467
01468
01473         virtual void    onListColumnMoved(WindowEventArgs& e);
01474
01475
01476         /*************************************************************************
01477                 Overridden Event handlers
01478         *************************************************************************/
01479         virtual void    onSized(WindowEventArgs& e);
01480         virtual void    onMouseButtonDown(MouseEventArgs& e);
01481         virtual void    onMouseWheel(MouseEventArgs& e);
01482
01483
01484         /*************************************************************************
01485                 Handlers for subscribed events
01486         *************************************************************************/
01487         bool    handleHeaderScroll(const EventArgs& e);
01488         bool    handleHeaderSegMove(const EventArgs& e);
01489         bool    handleColumnSizeChange(const EventArgs& e);
01490         bool    handleHorzScrollbar(const EventArgs& e);
01491         bool    handleVertScrollbar(const EventArgs& e);
01492         bool    handleSortColumnChange(const EventArgs& e);
01493         bool    handleSortDirectionChange(const EventArgs& e);
01494         bool    handleHeaderSegDblClick(const EventArgs& e);
01495
01501         struct ListRow
01502         {
01503                 typedef std::vector<ListboxItem*>       RowItems;
01504                 RowItems        d_items;
01505                 uint            d_sortColumn;
01506                 uint            d_rowID;
01507
01508                 // operators
01509                 ListboxItem* const& operator[](uint idx) const  {return d_items[idx];}
01510                 ListboxItem*&   operator[](uint idx) {return d_items[idx];}
01511                 bool    operator<(const ListRow& rhs) const;
01512                 bool    operator>(const ListRow& rhs) const;
01513         };
01514
01515
01520         static bool pred_descend(const ListRow& a, const ListRow& b);
01521
01522
01523         /*************************************************************************
01524                 Implementation Data
01525         *************************************************************************/
01526         // component widgets and settings.
01527         Scrollbar*      d_vertScrollbar;
01528         Scrollbar*      d_horzScrollbar;
01529         ListHeader*     d_header;
01530         bool    d_forceVertScroll;
01531         bool    d_forceHorzScroll;
01532
01533         // selection abilities.
01534         SelectionMode   d_selectMode;
01535         uint    d_nominatedSelectCol;
01536         uint    d_nominatedSelectRow;
01537         bool    d_multiSelect;
01538         bool    d_fullRowSelect;
01539         bool    d_fullColSelect;
01540         bool    d_useNominatedRow;
01541         bool    d_useNominatedCol;
01542         ListboxItem*    d_lastSelected;
01543
01544         // storage of items in the list box.
01545         typedef std::vector<ListRow>            ListItemGrid;
01546         ListItemGrid    d_grid;
01547
01548
01549 private:
01550         /*************************************************************************
01551                 Static Properties for this class
01552         *************************************************************************/
01553         static MultiColumnListProperties::ColumnsMovable                                d_columnsMovableProperty;
01554         static MultiColumnListProperties::ColumnsSizable                                d_columnsSizableProperty;
01555         static MultiColumnListProperties::ForceHorzScrollbar                    d_forceHorzScrollProperty;
01556         static MultiColumnListProperties::ForceVertScrollbar                    d_forceVertScrollProperty;
01557         static MultiColumnListProperties::NominatedSelectionColumnID    d_nominatedSelectColProperty;
01558         static MultiColumnListProperties::NominatedSelectionRow                 d_nominatedSelectRowProperty;
01559         static MultiColumnListProperties::SelectionMode                                 d_selectModeProperty;
01560         static MultiColumnListProperties::SortColumnID                                  d_sortColumnIDProperty;
01561         static MultiColumnListProperties::SortDirection                                 d_sortDirectionProperty;
01562         static MultiColumnListProperties::SortSettingEnabled                    d_sortSettingProperty;
01563         static MultiColumnListProperties::ColumnHeader                                  d_columnHeaderProperty;
01564         static MultiColumnListProperties::RowCount                                              d_rowCountProperty;
01565
01566
01567         /*************************************************************************
01568                 Private methods
01569         *************************************************************************/
01570         void    addMultiColumnListProperties(void);
01571 };
01572
01573 } // End of  CEGUI namespace section
01574
01575 #if defined(_MSC_VER)
01576 #       pragma warning(pop)
01577 #endif
01578
01579 #endif  // end of guard _CEGUIMultiColumnList_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMultiColumnListProperties.h Source File

include » elements

CEGUIMultiColumnListProperties.h

00001 /************************************************************************
00002         filename:       CEGUIMultiColumnListProperties.h
00003         created:        11/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to multi-column list properties.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMultiColumnListProperties_h_
00027 #define _CEGUIMultiColumnListProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of MultiColumnListProperties namespace section
00041 namespace MultiColumnListProperties
00042 {
00055 class ColumnsSizable : public Property
00056 {
00057 public:
00058         ColumnsSizable() : Property(
00059                 "ColumnsSizable",
00060                 "Property to get/set the setting for user sizing of the column headers.  Value is either \"True\" or \"False\".",
00061                 "True")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class ColumnsMovable : public Property
00082 {
00083 public:
00084         ColumnsMovable() : Property(
00085                 "ColumnsMovable",
00086                 "Property to get/set the setting for user moving of the column headers.  Value is either \"True\" or \"False\".",
00087                 "True")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00107 class SortSettingEnabled : public Property
00108 {
00109 public:
00110         SortSettingEnabled() : Property(
00111                 "SortSettingEnabled",
00112                 "Property to get/set the setting for for user modification of the sort column & direction.  Value is either \"True\" or \"False\".",
00113                 "True")
00114         {}
00115
00116         String  get(const PropertyReceiver* receiver) const;
00117         void    set(PropertyReceiver* receiver, const String& value);
00118 };
00119
00120
00134 class SortDirection : public Property
00135 {
00136 public:
00137         SortDirection() : Property(
00138                 "SortDirection",
00139                 "Property to get/set the sort direction setting of the list.  Value is the text of one of the SortDirection enumerated value names.",
00140                 "None")
00141         {}
00142
00143         String  get(const PropertyReceiver* receiver) const;
00144         void    set(PropertyReceiver* receiver, const String& value);
00145 };
00146
00147
00159 class SortColumnID : public Property
00160 {
00161 public:
00162         SortColumnID() : Property(
00163                 "SortColumnID",
00164                 "Property to get/set the current sort column (via ID code).  Value is an unsigned integer number.",
00165                 "0", false)
00166         {}
00167
00168         String  get(const PropertyReceiver* receiver) const;
00169         void    set(PropertyReceiver* receiver, const String& value);
00170 };
00171
00172
00184 class NominatedSelectionColumnID : public Property
00185 {
00186 public:
00187         NominatedSelectionColumnID() : Property(
00188                 "NominatedSelectionColumnID",
00189                 "Property to get/set the nominated selection column (via ID).  Value is an unsigned integer number.",
00190                 "0")
00191         {}
00192
00193         String  get(const PropertyReceiver* receiver) const;
00194         void    set(PropertyReceiver* receiver, const String& value);
00195 };
00196
00197
00209 class NominatedSelectionRow : public Property
00210 {
00211 public:
00212         NominatedSelectionRow() : Property(
00213                 "NominatedSelectionRow",
00214                 "Property to get/set the nominated selection row.  Value is an unsigned integer number.",
00215                 "0")
00216         {}
00217
00218         String  get(const PropertyReceiver* receiver) const;
00219         void    set(PropertyReceiver* receiver, const String& value);
00220 };
00221
00222
00235 class ForceVertScrollbar : public Property
00236 {
00237 public:
00238         ForceVertScrollbar() : Property(
00239                 "ForceVertScrollbar",
00240                 "Property to get/set the 'always show' setting for the vertical scroll bar of the list box.  Value is either \"True\" or \"False\".",
00241                 "False")
00242         {}
00243
00244         String  get(const PropertyReceiver* receiver) const;
00245         void    set(PropertyReceiver* receiver, const String& value);
00246 };
00247
00248
00261 class ForceHorzScrollbar : public Property
00262 {
00263 public:
00264         ForceHorzScrollbar() : Property(
00265                 "ForceHorzScrollbar",
00266                 "Property to get/set the 'always show' setting for the horizontal scroll bar of the list box.  Value is either \"True\" or \"False\".",
00267                 "False")
00268         {}
00269
00270         String  get(const PropertyReceiver* receiver) const;
00271         void    set(PropertyReceiver* receiver, const String& value);
00272 };
00273
00274
00295 class SelectionMode : public Property
00296 {
00297 public:
00298         SelectionMode() : Property(
00299                 "SelectionMode",
00300                 "Property to get/set the selection mode setting of the list.  Value is the text of one of the SelectionMode enumerated value names.",
00301                 "RowSingle")
00302         {}
00303
00304         String  get(const PropertyReceiver* receiver) const;
00305         void    set(PropertyReceiver* receiver, const String& value);
00306 };
00307
00308
00322 class ColumnHeader : public Property
00323 {
00324 public:
00325         ColumnHeader() : Property(
00326                 "ColumnHeader",
00327                 "Property to set up a column (there is no getter for this property)",
00328                 "", false)
00329         {}
00330
00331         String  get(const PropertyReceiver* receiver) const;
00332         void    set(PropertyReceiver* receiver, const String& value);
00333 };
00334
00343 class RowCount : public Property
00344 {
00345 public:
00346         RowCount() : Property(
00347                 "RowCount",
00348                 "Property to access the number of rows in the list (read only)",
00349                 "", false)
00350         {}
00351
00352         String  get(const PropertyReceiver* receiver) const;
00353         void    set(PropertyReceiver* receiver, const String& value);
00354 };
00355
00356
00357 } // End of  MultiColumnListProperties namespace section
00358
00359 } // End of  CEGUI namespace section
00360
00361
00362 #endif  // end of guard _CEGUIMultiColumnListProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMultiLineEditbox.h Source File

include » elements

CEGUIMultiLineEditbox.h

00001 /************************************************************************
00002         filename:       CEGUIMultiLineEditbox.h
00003         created:        30/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to the Multi-lien edit box base class.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMultiLineEditbox_h_
00027 #define _CEGUIMultiLineEditbox_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "CEGUIFont.h"
00032 #include "elements/CEGUIMultiLineEditboxProperties.h"
00033
00034 #include <vector>
00035
00036
00037 #if defined(_MSC_VER)
00038 #       pragma warning(push)
00039 #       pragma warning(disable : 4251)
00040 #endif
00041
00042
00043 // Start of CEGUI namespace section
00044 namespace CEGUI
00045 {
00050 class CEGUIEXPORT MultiLineEditbox : public Window
00051 {
00052 public:
00053         static const String EventNamespace;
00054
00055
00056         /*************************************************************************
00057                 Constants
00058         *************************************************************************/
00059         // event names
00060         static const String EventReadOnlyModeChanged;
00061         static const String EventWordWrapModeChanged;
00062         static const String EventMaximumTextLengthChanged;
00063         static const String EventCaratMoved;
00064         static const String EventTextSelectionChanged;
00065         static const String EventEditboxFull;
00066         static const String EventVertScrollbarModeChanged;
00067         static const String EventHorzScrollbarModeChanged;
00068
00069         // default colours
00070         static const argb_t     DefaultNormalTextColour;
00071         static const argb_t     DefaultSelectedTextColour;
00072         static const argb_t     DefaultNormalSelectionColour;
00073         static const argb_t     DefaultInactiveSelectionColour;
00074
00075
00076         /*************************************************************************
00077                 Accessor Functions
00078         *************************************************************************/
00087         bool    hasInputFocus(void) const;
00088
00089
00098         bool    isReadOnly(void) const          {return d_readOnly;}
00099
00100
00108         size_t  getCaratIndex(void) const               {return d_caratPos;}
00109
00110
00119         size_t  getSelectionStartIndex(void) const;
00120
00121
00130         size_t  getSelectionEndIndex(void) const;
00131
00132
00140         size_t  getSelectionLength(void) const;
00141
00142
00150         size_t  getMaxTextLength(void) const            {return d_maxTextLen;}
00151
00152
00161         colour  getNormalTextColour(void) const                         {return d_normalTextColour;}
00162
00163
00172         colour  getSelectedTextColour(void) const                       {return d_selectTextColour;}
00173
00174
00183         colour  getNormalSelectBrushColour(void) const          {return d_selectBrushColour;}
00184
00185
00194         colour  getInactiveSelectBrushColour(void) const        {return d_inactiveSelectBrushColour;}
00195
00196
00205         bool    isWordWrapped(void) const;
00206
00207
00208         /*************************************************************************
00209                 Manipulators
00210         *************************************************************************/
00221         virtual void    initialise(void);
00222
00223
00235         void    setReadOnly(bool setting);
00236
00237
00249         void    setCaratIndex(size_t carat_pos);
00250
00251
00267         void    setSelection(size_t start_pos, size_t end_pos);
00268
00269
00280         void    setMaxTextLength(size_t max_len);
00281
00282
00293         void    setNormalTextColour(const colour& col);
00294
00295
00304         void    setSelectedTextColour(const colour& col);
00305
00306
00318         void    setNormalSelectBrushColour(const colour& col);
00319
00320
00332         void    setInactiveSelectBrushColour(const colour& col);
00333
00334
00339         void    ensureCaratIsVisible(void);
00340
00341
00353         void    setWordWrapping(bool setting);
00354
00355
00356         /*************************************************************************
00357                 Construction and Destruction
00358         *************************************************************************/
00363         MultiLineEditbox(const String& type, const String& name);
00364
00365
00370         virtual ~MultiLineEditbox(void);
00371
00372
00373 protected:
00374         /*************************************************************************
00375                 Implementation Methods (abstract)
00376         *************************************************************************/
00385         virtual Rect    getTextRenderArea(void) const           = 0;
00386
00387
00398         virtual Scrollbar*      createVertScrollbar(const String& name) const           = 0;
00399
00400
00411         virtual Scrollbar*      createHorzScrollbar(const String& name) const           = 0;
00412
00413
00424         virtual void    cacheEditboxBaseImagery()               = 0;
00425
00426
00434         virtual void    cacheCaratImagery(const Rect& textArea) = 0;
00435
00436
00437         /*************************************************************************
00438                 Implementation Methods
00439         *************************************************************************/
00444         void    addMultiLineEditboxEvents(void);
00445
00446
00451         void    cacheTextLines(const Rect& dest_area);
00452
00453
00458         void    formatText(void);
00459
00460
00471         size_t  getNextTokenLength(const String& text, size_t start_idx) const;
00472
00473
00474         virtual void populateRenderCache();
00475
00476
00481         void    configureScrollbars(void);
00482
00483
00494         size_t  getTextIndexFromPosition(const Point& pt) const;
00495
00496
00502         size_t  getLineNumberFromIndex(size_t index) const;
00503
00504
00509         void    clearSelection(void);
00510
00511
00519         void    eraseSelectedText(bool modify_text = true);
00520
00521
00526         void    handleBackspace(void);
00527
00528
00533         void    handleDelete(void);
00534
00535
00540         void    handleCharLeft(uint sysKeys);
00541
00542
00547         void    handleWordLeft(uint sysKeys);
00548
00549
00554         void    handleCharRight(uint sysKeys);
00555
00556
00561         void    handleWordRight(uint sysKeys);
00562
00563
00568         void    handleDocHome(uint sysKeys);
00569
00570
00575         void    handleDocEnd(uint sysKeys);
00576
00577
00582         void    handleLineHome(uint sysKeys);
00583
00584
00589         void    handleLineEnd(uint sysKeys);
00590
00591
00596         void    handleLineUp(uint sysKeys);
00597
00598
00603         void    handleLineDown(uint sysKeys);
00604
00605
00610         void    handleNewLine(uint sysKeys);
00611
00612
00623         virtual bool    testClassName_impl(const String& class_name) const
00624         {
00625                 if ((class_name==(const utf8*)"MultiLineEditBox") ||
00626                         (class_name==(const utf8*)"MultiLineEditbox"))
00627                 {
00628                         return true;
00629                 }
00630
00631                 return Window::testClassName_impl(class_name);
00632         }
00633
00638     bool handle_scrollChange(const EventArgs& args);
00639
00640
00641         /*************************************************************************
00642                 New event handlers
00643         *************************************************************************/
00648         void    onReadOnlyChanged(WindowEventArgs& e);
00649
00650
00655         void    onWordWrapModeChanged(WindowEventArgs& e);
00656
00657
00662         void    onMaximumTextLengthChanged(WindowEventArgs& e);
00663
00664
00669         void    onCaratMoved(WindowEventArgs& e);
00670
00671
00676         void    onTextSelectionChanged(WindowEventArgs& e);
00677
00678
00683         void    onEditboxFullEvent(WindowEventArgs& e);
00684
00685
00690         void    onVertScrollbarModeChanged(WindowEventArgs& e);
00691
00692
00697         void    onHorzScrollbarModeChanged(WindowEventArgs& e);
00698
00699
00700         /*************************************************************************
00701                 Overridden event handlers
00702         *************************************************************************/
00703         virtual void    onMouseButtonDown(MouseEventArgs& e);
00704         virtual void    onMouseButtonUp(MouseEventArgs& e);
00705         virtual void    onMouseDoubleClicked(MouseEventArgs& e);
00706         virtual void    onMouseTripleClicked(MouseEventArgs& e);
00707         virtual void    onMouseMove(MouseEventArgs& e);
00708         virtual void    onCaptureLost(WindowEventArgs& e);
00709         virtual void    onCharacter(KeyEventArgs& e);
00710         virtual void    onKeyDown(KeyEventArgs& e);
00711         virtual void    onTextChanged(WindowEventArgs& e);
00712         virtual void    onSized(WindowEventArgs& e);
00713         virtual void    onMouseWheel(MouseEventArgs& e);
00714
00715
00716         /*************************************************************************
00717                 Implementation struct
00718         *************************************************************************/
00724         struct LineInfo
00725         {
00726                 size_t  d_startIdx;
00727                 size_t  d_length;
00728                 float   d_extent;
00729         };
00730
00731
00732         /*************************************************************************
00733                 Implementation data
00734         *************************************************************************/
00735         bool    d_readOnly;
00736         size_t  d_maxTextLen;
00737         size_t  d_caratPos;
00738         size_t  d_selectionStart;
00739         size_t  d_selectionEnd;
00740         bool    d_dragging;
00741         size_t  d_dragAnchorIdx;
00742
00743         typedef std::vector<LineInfo>   LineList;
00744         static String d_lineBreakChars;
00745         bool            d_wordWrap;
00746         LineList        d_lines;
00747         float           d_widestExtent;
00748
00749         // component widgets
00750         Scrollbar*      d_vertScrollbar;
00751         Scrollbar*      d_horzScrollbar;
00752         bool    d_forceVertScroll;
00753         bool    d_forceHorzScroll;
00754
00755         // images
00756         const Image*    d_selectionBrush;
00757
00758         // basic rendering colours
00759         colour  d_normalTextColour;
00760         colour  d_selectTextColour;
00761         colour  d_selectBrushColour;
00762         colour  d_inactiveSelectBrushColour;
00763
00764
00765 private:
00766         /*************************************************************************
00767                 Static Properties for this class
00768         *************************************************************************/
00769         static MultiLineEditboxProperties::ReadOnly                                     d_readOnlyProperty;
00770         static MultiLineEditboxProperties::WordWrap                                     d_wordWrapProperty;
00771         static MultiLineEditboxProperties::CaratIndex                           d_caratIndexProperty;
00772         static MultiLineEditboxProperties::SelectionStart                       d_selectionStartProperty;
00773         static MultiLineEditboxProperties::SelectionLength                      d_selectionLengthProperty;
00774         static MultiLineEditboxProperties::MaxTextLength                        d_maxTextLengthProperty;
00775         static MultiLineEditboxProperties::NormalTextColour                     d_normalTextColourProperty;
00776         static MultiLineEditboxProperties::SelectedTextColour           d_selectedTextColourProperty;
00777         static MultiLineEditboxProperties::ActiveSelectionColour        d_activeSelectionColourProperty;
00778         static MultiLineEditboxProperties::InactiveSelectionColour      d_inactiveSelectionColourProperty;
00779
00780
00781         /*************************************************************************
00782                 Private methods
00783         *************************************************************************/
00784         void    addMultiLineEditboxProperties(void);
00785 };
00786
00787 } // End of  CEGUI namespace section
00788
00789 #if defined(_MSC_VER)
00790 #       pragma warning(pop)
00791 #endif
00792
00793 #endif  // end of guard _CEGUIMultiLineEditbox_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIMultiLineEditboxProperties.h Source File

include » elements

CEGUIMultiLineEditboxProperties.h

00001 /************************************************************************
00002         filename:       CEGUIMultiLineEditboxProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for the MultiLineEditbox class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIMultiLineEditboxProperties_h_
00027 #define _CEGUIMultiLineEditboxProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of MultiLineEditboxProperties namespace section
00041 namespace MultiLineEditboxProperties
00042 {
00055 class ReadOnly : public Property
00056 {
00057 public:
00058         ReadOnly() : Property(
00059                 "ReadOnly",
00060                 "Property to get/set the read-only setting for the edit box.  Value is either \"True\" or \"False\".",
00061                 "False")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class WordWrap : public Property
00082 {
00083 public:
00084         WordWrap() : Property(
00085                 "WordWrap",
00086                 "Property to get/set the word-wrap setting of the edit box.  Value is either \"True\" or \"False\".",
00087                 "True")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00106 class CaratIndex : public Property
00107 {
00108 public:
00109         CaratIndex() : Property(
00110                 "CaratIndex",
00111                 "Property to get/set the current carat index.  Value is \"[uint]\".",
00112                 "0")
00113         {}
00114
00115         String  get(const PropertyReceiver* receiver) const;
00116         void    set(PropertyReceiver* receiver, const String& value);
00117 };
00118
00119
00131 class SelectionStart : public Property
00132 {
00133 public:
00134         SelectionStart() : Property(
00135                 "SelectionStart",
00136                 "Property to get/set the zero based index of the selection start position within the text.  Value is \"[uint]\".",
00137                 "0")
00138         {}
00139
00140         String  get(const PropertyReceiver* receiver) const;
00141         void    set(PropertyReceiver* receiver, const String& value);
00142 };
00143
00144
00156 class SelectionLength : public Property
00157 {
00158 public:
00159         SelectionLength() : Property(
00160                 "SelectionLength",
00161                 "Property to get/set the length of the selection (as a count of the number of code points selected).  Value is \"[uint]\".",
00162                 "0")
00163         {}
00164
00165         String  get(const PropertyReceiver* receiver) const;
00166         void    set(PropertyReceiver* receiver, const String& value);
00167 };
00168
00169
00181 class MaxTextLength : public Property
00182 {
00183 public:
00184         MaxTextLength() : Property(
00185                 "MaxTextLength",
00186                 "Property to get/set the the maximum allowed text length (as a count of code points).  Value is \"[uint]\".",
00187                 "1073741824")
00188         {}
00189
00190         String  get(const PropertyReceiver* receiver) const;
00191         void    set(PropertyReceiver* receiver, const String& value);
00192 };
00193
00194
00206 class NormalTextColour : public Property
00207 {
00208 public:
00209         NormalTextColour() : Property(
00210                 "NormalTextColour",
00211                 "Property to get/set the normal, unselected, text colour used for rendering text.  Value is \"aarrggbb\" (hex).",
00212                 "FFFFFFFF")
00213         {}
00214
00215         String  get(const PropertyReceiver* receiver) const;
00216         void    set(PropertyReceiver* receiver, const String& value);
00217 };
00218
00219
00231 class SelectedTextColour : public Property
00232 {
00233 public:
00234         SelectedTextColour() : Property(
00235                 "SelectedTextColour",
00236                 "Property to get/set the colour used for rendering text within the selection area.  Value is \"aarrggbb\" (hex).",
00237                 "FF000000")
00238         {}
00239
00240         String  get(const PropertyReceiver* receiver) const;
00241         void    set(PropertyReceiver* receiver, const String& value);
00242 };
00243
00244
00256 class ActiveSelectionColour : public Property
00257 {
00258 public:
00259         ActiveSelectionColour() : Property(
00260                 "ActiveSelectionColour",
00261                 "Property to get/set the colour used for rendering the selection highlight when the edit box is active.  Value is \"aarrggbb\" (hex).",
00262                 "FF6060FF")
00263         {}
00264
00265         String  get(const PropertyReceiver* receiver) const;
00266         void    set(PropertyReceiver* receiver, const String& value);
00267 };
00268
00269
00281 class InactiveSelectionColour : public Property
00282 {
00283 public:
00284         InactiveSelectionColour() : Property(
00285                 "InactiveSelectionColour",
00286                 "Property to get/set the colour used for rendering the selection highlight when the edit box is inactive.  Value is \"aarrggbb\" (hex).",
00287                 "FF808080")
00288         {}
00289
00290         String  get(const PropertyReceiver* receiver) const;
00291         void    set(PropertyReceiver* receiver, const String& value);
00292 };
00293
00294
00295 } // End of  MultiLineEditboxProperties namespace section
00296
00297 } // End of  CEGUI namespace section
00298
00299
00300 #endif  // end of guard _CEGUIMultiLineEditboxProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIPopupMenu.h Source File

include » elements

CEGUIPopupMenu.h

00001 /************************************************************************
00002         filename:       CEGUIPopupMenu.h
00003         created:        27/3/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005
00006         purpose:        Interface to base class for PopupMenu widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIPopupMenu_h_
00027 #define _CEGUIPopupMenu_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIPopupMenuProperties.h"
00032 #include "elements/CEGUIMenuBase.h"
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00044
00049 class CEGUIEXPORT PopupMenu : public MenuBase
00050 {
00051 public:
00052         static const String EventNamespace;
00053
00054         /*************************************************************************
00055                 Accessor type functions
00056         *************************************************************************/
00065         float   getFadeInTime(void) const                       {return d_fadeInTime;}
00066
00067
00076         float   getFadeOutTime(void) const                      {return d_fadeOutTime;}
00077
00078
00079         /*************************************************************************
00080                 Manipulators
00081         *************************************************************************/
00090         void    setFadeInTime(float fadetime)           {d_fadeInTime=fadetime;}
00091
00092
00101         void    setFadeOutTime(float fadetime)          {d_fadeOutTime=fadetime;}
00102
00107         void    openPopupMenu(void);
00108
00109
00114         void    closePopupMenu(void);
00115
00116
00117         /*************************************************************************
00118                 Construction and Destruction
00119         *************************************************************************/
00124         PopupMenu(const String& type, const String& name);
00125
00126
00131         virtual ~PopupMenu(void);
00132
00133
00134 protected:
00135         /*************************************************************************
00136                 Implementation Functions
00137         *************************************************************************/
00148         virtual void    updateSelf(float elapsed);
00149
00150
00158         virtual void    layoutItemWidgets(void);
00159
00160
00168         virtual Size getContentSize(void);
00169
00170
00181         virtual bool    testClassName_impl(const String& class_name) const
00182         {
00183                 if (class_name==(const utf8*)"PopupMenu")       return true;
00184                 return MenuBase::testClassName_impl(class_name);
00185         }
00186
00187
00188         /*************************************************************************
00189                 Overridden event handlers
00190         *************************************************************************/
00191         virtual void onAlphaChanged(WindowEventArgs& e);
00192
00193
00194         /*************************************************************************
00195                 Implementation Data
00196         *************************************************************************/
00197         float d_origAlpha;
00198
00199         float d_fadeElapsed;
00200         float d_fadeOutTime;
00201         float d_fadeInTime;
00202         bool d_fading;
00203         bool d_fadingOut;
00204
00205 private:
00206         /*************************************************************************
00207         Static Properties for this class
00208         *************************************************************************/
00209         static PopupMenuProperties::FadeInTime  d_fadeInTimeProperty;
00210         static PopupMenuProperties::FadeOutTime d_fadeOutTimeProperty;
00211
00212
00213         /*************************************************************************
00214         Private methods
00215         *************************************************************************/
00216         void    addPopupMenuProperties(void);
00217 };
00218
00219 } // End of  CEGUI namespace section
00220
00221
00222 #if defined(_MSC_VER)
00223 #       pragma warning(pop)
00224 #endif
00225
00226
00227 #endif  // end of guard _CEGUIPopupMenu_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIPopupMenuProperties.h Source File

include » elements

CEGUIPopupMenuProperties.h

00001 /************************************************************************
00002         filename:       CEGUIPopupMenuProperties.h
00003         created:        5/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIPopupMenuProperties_h_
00025 #define _CEGUIPopupMenuProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of ItemListBaseProperties namespace section
00033 namespace PopupMenuProperties
00034 {
00035
00047 class FadeInTime : public Property
00048 {
00049 public:
00050         FadeInTime() : Property(
00051                 "FadeInTime",
00052                 "Property to get/set the fade in time in seconds of the menu bar.  Value is a float.",
00053                 "0.000000")
00054         {}
00055
00056         String  get(const PropertyReceiver* receiver) const;
00057         void    set(PropertyReceiver* receiver, const String& value);
00058 };
00059
00060
00072 class FadeOutTime : public Property
00073 {
00074 public:
00075         FadeOutTime() : Property(
00076                 "FadeOutTime",
00077                 "Property to get/set the fade out time in seconds of the menu bar.  Value is a float.",
00078                 "0.000000")
00079         {}
00080
00081         String  get(const PropertyReceiver* receiver) const;
00082         void    set(PropertyReceiver* receiver, const String& value);
00083 };
00084
00085 } // End of  PopupMenuProperties namespace section
00086 } // End of  CEGUI namespace section
00087
00088 #endif  // end of guard _CEGUIPopupMenuProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIProgressBar.h Source File

include » elements

CEGUIProgressBar.h

00001 /************************************************************************
00002         filename:       CEGUIProgressBar.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for ProgressBar widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIProgressBar_h_
00027 #define _CEGUIProgressBar_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIProgressBarProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00047 class CEGUIEXPORT ProgressBar : public Window
00048 {
00049 public:
00050         static const String EventNamespace;
00051
00052
00053         /*************************************************************************
00054                 Event name constants
00055         *************************************************************************/
00056         static const String EventProgressChanged;
00057         static const String EventProgressDone;
00058
00059
00060         /************************************************************************
00061                 Accessor Functions
00062         ************************************************************************/
00067         float   getProgress(void) const         {return d_progress;}
00068
00073         float   getStep(void) const                     {return d_step;}
00074
00075
00076         /*************************************************************************
00077                 Manipulator Functions
00078         *************************************************************************/
00089         void    setProgress(float progress);
00090
00091
00102         void    setStepSize(float step_val)             {d_step = step_val;}
00103
00104
00115         void    step(void)                      {setProgress(d_progress + d_step);}
00116
00117
00129         void    adjustProgress(float delta)             {setProgress(d_progress + delta);}
00130
00131
00132         /*************************************************************************
00133                 Construction / Destruction
00134         *************************************************************************/
00139         ProgressBar(const String& type, const String& name);
00140
00141
00146         virtual ~ProgressBar(void);
00147
00148
00149 protected:
00150         /*************************************************************************
00151                 Implementation methods
00152         *************************************************************************/
00157         void    addProgressBarEvents(void);
00158
00159
00170         virtual bool    testClassName_impl(const String& class_name) const
00171         {
00172                 if (class_name==(const utf8*)"ProgressBar")     return true;
00173                 return Window::testClassName_impl(class_name);
00174         }
00175
00176
00177         /*************************************************************************
00178                 Event handlers for progress bar specific events
00179         *************************************************************************/
00184         virtual void    onProgressChanged(WindowEventArgs& e);
00185
00186
00191         virtual void    onProgressDone(WindowEventArgs& e);
00192
00193
00194         /*************************************************************************
00195                 Implementation Data
00196         *************************************************************************/
00197         float   d_progress;
00198         float   d_step;
00199
00200
00201 private:
00202         /*************************************************************************
00203                 Static Properties for this class
00204         *************************************************************************/
00205         static ProgressBarProperties::CurrentProgress   d_currentProgressProperty;
00206         static ProgressBarProperties::StepSize                  d_stepSizeProperty;
00207
00208
00209         /*************************************************************************
00210                 Private methods
00211         *************************************************************************/
00212         void    addProgressBarProperties(void);
00213 };
00214
00215
00216 } // End of  CEGUI namespace section
00217
00218 #if defined(_MSC_VER)
00219 #       pragma warning(pop)
00220 #endif
00221
00222 #endif  // end of guard _CEGUIProgressBar_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIProgressBarProperties.h Source File

include » elements

CEGUIProgressBarProperties.h

00001 /************************************************************************
00002         filename:       CEGUIProgressBarProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for the ProgressBar class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIProgressBarProperties_h_
00027 #define _CEGUIProgressBarProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ProgressBarProperties namespace section
00041 namespace ProgressBarProperties
00042 {
00054 class CurrentProgress : public Property
00055 {
00056 public:
00057         CurrentProgress() : Property(
00058                 "CurrentProgress",
00059                 "Property to get/set the current progress of the progress bar.  Value is a float  value between 0.0 and 1.0 specifying the progress.",
00060                 "0.000000")
00061         {}
00062
00063         String  get(const PropertyReceiver* receiver) const;
00064         void    set(PropertyReceiver* receiver, const String& value);
00065 };
00066
00067
00079 class StepSize : public Property
00080 {
00081 public:
00082         StepSize() : Property(
00083                 "StepSize",
00084                 "Property to get/set the step size setting for the progress bar.  Value is a float value.",
00085                 "0.010000")
00086         {}
00087
00088         String  get(const PropertyReceiver* receiver) const;
00089         void    set(PropertyReceiver* receiver, const String& value);
00090 };
00091
00092
00093 } // End of  ProgressBarProperties namespace section
00094
00095 } // End of  CEGUI namespace section
00096
00097
00098 #endif  // end of guard _CEGUIProgressBarProperties_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIProperty.h Source File

include

CEGUIProperty.h

00001 /************************************************************************
00002         filename:       CEGUIProperty.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines the Property class which forms part of a
00007                                 PropertySet
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIProperty_h_
00028 #define _CEGUIProperty_h_
00029
00030 #include "CEGUIBase.h"
00031 #include "CEGUIString.h"
00032
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00037
00042 class CEGUIEXPORT PropertyReceiver
00043 {
00044 public:
00045         PropertyReceiver() {}
00046         virtual ~PropertyReceiver() {}
00047 };
00048
00049
00057 class CEGUIEXPORT Property
00058 {
00059 public:
00077         Property(const String& name, const String& help, const String& defaultValue = "", bool writesXML = true) :
00078           d_name(name),
00079           d_help(help),
00080           d_default(defaultValue),
00081           d_writeXML(writesXML)
00082         {
00083         }
00084
00085
00090         virtual ~Property(void) {}
00091
00092
00100         const String& getHelp(void) const               {return d_help;}
00101
00102
00110         const String& getName(void) const               {return d_name;}
00111
00112
00123         virtual String  get(const PropertyReceiver* receiver) const = 0;
00124
00125
00141         virtual void    set(PropertyReceiver* receiver, const String& value) = 0;
00142
00143
00155         virtual bool    isDefault(const PropertyReceiver* receiver) const;
00156
00157
00168         virtual String  getDefault(const PropertyReceiver* receiver) const;
00169
00170
00179     void writeXMLToStream(const PropertyReceiver* receiver, OutStream& out_stream) const;
00180
00181 protected:
00182         String  d_name;
00183         String  d_help;
00184         String  d_default;
00185         bool    d_writeXML;
00186 };
00187
00188 } // End of  CEGUI namespace section
00189
00190 #endif  // end of guard _CEGUIProperty_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIPropertyHelper.h Source File

include

CEGUIPropertyHelper.h

00001 /************************************************************************
00002         filename:       CEGUIPropertyHelper.h
00003         created:        6/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to the PropertyHelper class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIPropertyHelper_h_
00027 #define _CEGUIPropertyHelper_h_
00028
00029 #include "CEGUIWindow.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00039 class CEGUIEXPORT PropertyHelper
00040 {
00041 public:
00042         static  float   stringToFloat(const String& str);
00043         static  uint    stringToUint(const String& str);
00044         static  int             stringToInt(const String& str);
00045         static  bool    stringToBool(const String& str);
00046         static  Size    stringToSize(const String& str);
00047         static  Point   stringToPoint(const String& str);
00048         static  Rect    stringToRect(const String& str);
00049         static  MetricsMode     stringToMetricsMode(const String& str);
00050         static const Image*     stringToImage(const String& str);
00051         static  colour  stringToColour(const String& str);
00052         static  ColourRect      stringToColourRect(const String& str);
00053         static  UDim    stringToUDim(const String& str);
00054         static  UVector2        stringToUVector2(const String& str);
00055         static  URect   stringToURect(const String& str);
00056
00057         static String   floatToString(float val);
00058         static String   uintToString(uint val);
00059         static String   intToString(int val);
00060         static String   boolToString(bool val);
00061         static String   sizeToString(const Size& val);
00062         static String   pointToString(const Point& val);
00063         static String   rectToString(const Rect& val);
00064         static String   metricsModeToString(MetricsMode val);
00065         static String   imageToString(const Image* const val);
00066         static String   colourToString(const colour& val);
00067         static String   colourRectToString(const ColourRect& val);
00068         static String   udimToString(const UDim& val);
00069         static String   uvector2ToString(const UVector2& val);
00070         static String   urectToString(const URect& val);
00071 };
00072
00073 } // End of  CEGUI namespace section
00074
00075
00076 #endif  // end of guard _CEGUIPropertyHelper_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIPropertySet.h Source File

include

CEGUIPropertySet.h

00001 /************************************************************************
00002         filename:       CEGUIPropertySet.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for the PropertySet class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIPropertySet_h_
00027 #define _CEGUIPropertySet_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIIteratorBase.h"
00032 #include "CEGUIProperty.h"
00033 #include <map>
00034
00035
00036 #if defined(_MSC_VER)
00037 #       pragma warning(push)
00038 #       pragma warning(disable : 4251)
00039 #endif
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00048 class CEGUIEXPORT PropertySet : public PropertyReceiver
00049 {
00050 public:
00055         PropertySet(void) {}
00056
00057
00062         virtual ~PropertySet(void) {}
00063
00064
00078         void    addProperty(Property* property);
00079
00080
00091         void    removeProperty(const String& name);
00092
00093
00101         void    clearProperties(void);
00102
00103
00114         bool    isPropertyPresent(const String& name) const;
00115
00116
00129         const String&   getPropertyHelp(const String& name) const;
00130
00131
00144         String  getProperty(const String& name) const;
00145
00146
00163         void    setProperty(const String& name, const String& value);
00164
00165
00177         bool    isPropertyDefault(const String& name) const;
00178
00179
00190         String  getPropertyDefault(const String& name) const;
00191
00192 private:
00193         typedef std::map<String, Property*>     PropertyRegistry;
00194         PropertyRegistry        d_properties;
00195
00196
00197 public:
00198         /*************************************************************************
00199                 Iterator stuff
00200         *************************************************************************/
00201         typedef ConstBaseIterator<PropertyRegistry>     PropertyIterator;
00202
00207         PropertyIterator        getIterator(void) const;
00208 };
00209
00210 } // End of  CEGUI namespace section
00211
00212 #if defined(_MSC_VER)
00213 #       pragma warning(pop)
00214 #endif
00215
00216 #endif  // end of guard _CEGUIPropertySet_h_
Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIPushButton.h Source File

include » elements

CEGUIPushButton.h

00001 /************************************************************************
00002         filename:       CEGUIPushButton.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for PushButton widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIPushButton_h_
00027 #define _CEGUIPushButton_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "elements/CEGUIButtonBase.h"
00031 #include "elements/CEGUIPushButtonProperties.h"
00032 #include "CEGUIRenderableImage.h"
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039 // Start of CEGUI namespace section
00040 namespace CEGUI
00041 {
00046 class CEGUIEXPORT PushButton : public ButtonBase
00047 {
00048 public:
00049         static const String EventNamespace;
00050
00051
00052         /*************************************************************************
00053                 Event name constants
00054         *************************************************************************/
00055         // generated internally by Window
00056         static const String EventClicked;
00057
00058         /*************************************************************************
00059                 Construction and Destruction
00060         *************************************************************************/
00065         PushButton(const String& type, const String& name);
00066
00067
00072         virtual ~PushButton(void);
00073
00074     /*************************************************************************
00075         Common Public Interface
00076     *************************************************************************/
00084         bool    isStandardImageryEnabled(void) const;
00085
00086
00095         bool    isCustomImageryAutoSized(void) const;
00096
00106         const RenderableImage*  getNormalImage(void) const;
00107
00117         const RenderableImage*  getHoverImage(void) const;
00118
00128         const RenderableImage*  getPushedImage(void) const;
00129
00139         const RenderableImage*  getDisabledImage(void) const;
00140
00150     float   getTextXOffset(void) const;
00151
00162         void    setStandardImageryEnabled(bool setting);
00163
00174         void    setCustomImageryAutoSized(bool setting);
00175
00188         void    setNormalImage(const RenderableImage* image);
00189
00202         void    setHoverImage(const RenderableImage* image);
00203
00216         void    setPushedImage(const RenderableImage* image);
00217
00230         void    setDisabledImage(const RenderableImage* image);
00231
00244     void   setTextXOffset(float offset);
00245
00246 protected:
00247         /*************************************************************************
00248                 New Event Handlers
00249         *************************************************************************/
00254         virtual void    onClicked(WindowEventArgs& e);
00255
00256
00257         /*************************************************************************
00258                 Overridden Event Handlers
00259         *************************************************************************/
00260         virtual void    onMouseButtonUp(MouseEventArgs& e);
00261     virtual void    onSized(WindowEventArgs& e);
00262
00263
00264         /*************************************************************************
00265                 Implementation Functions
00266         *************************************************************************/
00271         void    addPushButtonEvents(void);
00272
00273
00284         virtual bool    testClassName_impl(const String& class_name) const
00285         {
00286                 if (class_name==(const utf8*)"PushButton")      return true;
00287                 return ButtonBase::testClassName_impl(class_name);
00288         }
00289
00290
00291     /*************************************************************************
00292         Data Fields
00293     *************************************************************************/
00294     // flags stating which imagery is to be rendered and how.
00295     bool        d_autoscaleImages;
00296     bool        d_useStandardImagery;
00297     bool        d_useNormalImage;
00298     bool        d_useHoverImage;
00299     bool        d_usePushedImage;
00300     bool        d_useDisabledImage;
00301
00302     // button RenderableImage objects
00303     RenderableImage             d_normalImage;
00304     RenderableImage             d_hoverImage;
00305     RenderableImage             d_pushedImage;
00306     RenderableImage             d_disabledImage;
00307
00308     //text-offset
00309     float d_textXOffset;
00310
00311 private:
00312     /*************************************************************************
00313         Static Properties for this class
00314     *************************************************************************/
00315     static PushButtonProperties::NormalImage    d_normalImageProperty;
00316     static PushButtonProperties::PushedImage    d_pushedImageProperty;
00317     static PushButtonProperties::HoverImage     d_hoverImageProperty;
00318     static PushButtonProperties::DisabledImage  d_disabledImageProperty;
00319     static PushButtonProperties::UseStandardImagery d_useStandardImageryProperty;
00320     static PushButtonProperties::TextXOffset    d_textXOffsetProperty;
00321
00322     /*************************************************************************
00323         Private methods
00324     *************************************************************************/
00325     void        addPushButtonProperties(void);
00326 };
00327
00328
00329 } // End of  CEGUI namespace section
00330
00331 #if defined(_MSC_VER)
00332 #       pragma warning(pop)
00333 #endif
00334
00335 #endif  // end of guard _CEGUIPushButton_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIPushButtonProperties.h Source File

include » elements

CEGUIPushButtonProperties.h

00001 /************************************************************************
00002         filename:       CEGUIPushButtonProperties.h
00003         created:        22/2/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIPushButtonProperties_h_
00025 #define _CEGUIPushButtonProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00033
00034 // Start of PushButtonProperties namespace section
00040 namespace PushButtonProperties
00041 {
00042
00052 class NormalImage : public Property
00053 {
00054 public:
00055    NormalImage() : Property(
00056            "NormalImage",
00057            "Property to get/set the normal image for the PushButton widget.  Value should be \"set:[imageset name] image:[image name]\".",
00058            "")
00059    {}
00060
00061    String   get(const PropertyReceiver* receiver) const;
00062    void   set(PropertyReceiver* receiver, const String& value);
00063 };
00064
00074 class PushedImage : public Property
00075 {
00076 public:
00077    PushedImage() : Property(
00078            "PushedImage",
00079            "Property to get/set the pushed image for the PushButton widget.  Value should be \"set:[imageset name] image:[image name]\".",
00080            "")
00081    {}
00082
00083    String   get(const PropertyReceiver* receiver) const;
00084    void   set(PropertyReceiver* receiver, const String& value);
00085 };
00086
00096 class HoverImage : public Property
00097 {
00098 public:
00099    HoverImage() : Property(
00100            "HoverImage",
00101            "Property to get/set the hover image for the PushButton widget.  Value should be \"set:[imageset name] image:[image name]\".",
00102            "")
00103    {}
00104
00105    String   get(const PropertyReceiver* receiver) const;
00106    void   set(PropertyReceiver* receiver, const String& value);
00107 };
00108
00118 class DisabledImage : public Property
00119 {
00120 public:
00121    DisabledImage() : Property(
00122            "DisabledImage",
00123            "Property to get/set the disabled image for the PushButton widget.  Value should be \"set:[imageset name] image:[image name]\".",
00124            "")
00125    {}
00126
00127    String   get(const PropertyReceiver* receiver) const;
00128    void   set(PropertyReceiver* receiver, const String& value);
00129 };
00130
00140 class UseStandardImagery : public Property
00141 {
00142 public:
00143    UseStandardImagery() : Property(
00144            "UseStandardImagery",
00145            "Property to get/set whether to use the standard imagery for the PushButton widget.  Value should be \"True\" or \"False\".",
00146            "True")
00147    {}
00148
00149    String   get(const PropertyReceiver* receiver) const;
00150    void   set(PropertyReceiver* receiver, const String& value);
00151 };
00152
00165 class TextXOffset : public Property
00166 {
00167 public:
00168    TextXOffset() : Property(
00169            "TextXOffset",
00170            "Property to get/set a relative x offset for the button's text",
00171            "0.000000")
00172    {}
00173
00174    String get(const PropertyReceiver* receiver) const;
00175    void set(PropertyReceiver* receiver, const String& value);
00176 };
00177
00178 }
00179
00180 }
00181 #endif
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRadioButton.h Source File

include » elements

CEGUIRadioButton.h

00001 /************************************************************************
00002         filename:       CEGUIRadioButton.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for RadioButton widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIRadioButton_h_
00027 #define _CEGUIRadioButton_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "elements/CEGUIButtonBase.h"
00031 #include "elements/CEGUIRadioButtonProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00048 class CEGUIEXPORT RadioButton : public ButtonBase
00049 {
00050 public:
00051         static const String EventNamespace;
00052
00053
00054         /*************************************************************************
00055                 Event name constants
00056         *************************************************************************/
00057         // generated internally by Window
00058         static const String EventSelectStateChanged;
00059
00060
00061         /*************************************************************************
00062                 Accessor Functions
00063         *************************************************************************/
00071         bool    isSelected(void) const                          {return d_selected;}
00072
00073
00081         ulong   getGroupID(void) const                          {return d_groupID;}
00082
00083
00094         RadioButton*    getSelectedButtonInGroup(void) const;
00095
00096
00097         /*************************************************************************
00098                 Manipulator Functions
00099         *************************************************************************/
00112         void    setSelected(bool select);
00113
00114
00125         void    setGroupID(ulong group);
00126
00127
00128         /*************************************************************************
00129                 Construction / Destruction
00130         *************************************************************************/
00131         RadioButton(const String& type, const String& name);
00132         virtual ~RadioButton(void);
00133
00134
00135 protected:
00136         /*************************************************************************
00137                 Implementation Functions
00138         *************************************************************************/
00143         void    addRadioButtonEvents(void);
00144
00145
00151         void    deselectOtherButtonsInGroup(void) const;
00152
00153
00164         virtual bool    testClassName_impl(const String& class_name) const
00165         {
00166                 if (class_name==(const utf8*)"RadioButton")     return true;
00167                 return ButtonBase::testClassName_impl(class_name);
00168         }
00169
00170
00171         /*************************************************************************
00172                 New Radio Button Events
00173         *************************************************************************/
00178         virtual void    onSelectStateChanged(WindowEventArgs& e);
00179
00180
00181         /*************************************************************************
00182                 Overridden Event handlers
00183         *************************************************************************/
00184         virtual void    onMouseButtonUp(MouseEventArgs& e);
00185
00186
00187         /*************************************************************************
00188                 Implementation Data
00189         *************************************************************************/
00190         bool            d_selected;                             // true when radio button is selected (has checkmark)
00191         ulong           d_groupID;                              // radio button group ID
00192
00193
00194 private:
00195         /*************************************************************************
00196                 Static Properties for this class
00197         *************************************************************************/
00198         static RadioButtonProperties::Selected  d_selectedProperty;
00199         static RadioButtonProperties::GroupID   d_groupIDProperty;
00200
00201
00202         /*************************************************************************
00203                 Private methods
00204         *************************************************************************/
00205         void    addRadioButtonProperties(void);
00206 };
00207
00208
00209 } // End of  CEGUI namespace section
00210
00211 #if defined(_MSC_VER)
00212 #       pragma warning(pop)
00213 #endif
00214
00215 #endif  // end of guard _CEGUIRadioButton_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRadioButtonProperties.h Source File

include » elements

CEGUIRadioButtonProperties.h

00001 /************************************************************************
00002         filename:       CEGUIRadioButtonProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for RadioButton class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIRadioButtonProperties_h_
00027 #define _CEGUIRadioButtonProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of RadioButtonProperties namespace section
00041 namespace RadioButtonProperties
00042 {
00055 class Selected : public Property
00056 {
00057 public:
00058         Selected() : Property(
00059                 "Selected",
00060                 "Property to get/set the selected state of the RadioButton.  Value is either \"True\" or \"False\".",
00061                 "False")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00080 class GroupID : public Property
00081 {
00082 public:
00083         GroupID() : Property(
00084                 "GroupID",
00085                 "Property to get/set the radio button group ID.  Value is an unsigned integer number.",
00086                 "0")
00087         {}
00088
00089         String  get(const PropertyReceiver* receiver) const;
00090         void    set(PropertyReceiver* receiver, const String& value);
00091 };
00092
00093
00094 } // End of  RadioButtonProperties namespace section
00095
00096 } // End of  CEGUI namespace section
00097
00098
00099 #endif  // end of guard _CEGUIRadioButtonProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRect.h Source File

include

CEGUIRect.h

00001 /************************************************************************
00002         filename:       CEGUIRect.h
00003         created:        8/3/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines 'Rect' class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIRect_h_
00027 #define _CEGUIRect_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIVector.h"
00031 #include "CEGUISize.h"
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00040 class CEGUIEXPORT Rect
00041 {
00042 public:
00043         Rect(void) {}
00044
00045
00050         Rect(float left, float top, float right, float bottom);
00051
00052     Rect(Point pos, Size sz);
00053
00054
00059         Point   getPosition(void) const         {return Point(d_left, d_top);}
00060
00065         float   getWidth(void) const            {return d_right - d_left;}
00066
00067
00072         float   getHeight(void) const           {return d_bottom - d_top;}
00073
00074
00079         Size    getSize(void) const                     {return Size(getWidth(), getHeight());}
00080
00081
00086         void    setPosition(const Point& pt);
00087
00088
00093         void    setWidth(float width)           {d_right = d_left + width;}
00094
00099         void    setHeight(float height)         {d_bottom = d_top + height;}
00100
00101
00106         void    setSize(const Size& sze)        {setWidth(sze.d_width); setHeight(sze.d_height);}
00107
00108
00117         Rect    getIntersection(const Rect& rect) const;
00118
00119
00130         Rect&   offset(const Point& pt);
00131
00132
00143         bool    isPointInRect(const Point& pt) const;
00144
00145
00156         Rect&   constrainSizeMax(const Size& sz);
00157
00158
00169         Rect&   constrainSizeMin(const Size& sz);
00170
00171
00185         Rect&   constrainSize(const Size& max_sz, const Size& min_sz);
00186
00187
00188         /*************************************************************************
00189                 Operators
00190         *************************************************************************/
00191         bool    operator==(const Rect& rhs) const
00192         {
00193                 return ((d_left == rhs.d_left) && (d_right == rhs.d_right) && (d_top == rhs.d_top) && (d_bottom == rhs.d_bottom));
00194         }
00195
00196         bool    operator!=(const Rect& rhs) const               {return !operator==(rhs);}
00197
00198         Rect&   operator=(const Rect& rhs);
00199
00200     Rect operator*(float scalar) const      { return Rect(d_left * scalar, d_top * scalar, d_right * scalar, d_bottom * scalar); }
00201     const Rect& operator*=(float scalar)    { d_left *= scalar; d_top *= scalar; d_right *= scalar; d_bottom *= scalar; return *this; }
00202
00203
00204         /*************************************************************************
00205                 Data Fields
00206         *************************************************************************/
00207         float   d_top, d_bottom, d_left, d_right;
00208 };
00209
00210 } // End of  CEGUI namespace section
00211
00212
00213 #endif  // end of guard _CEGUIRect_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRefPtr.h Source File

include

CEGUIRefPtr.h

00001 /************************************************************************
00002         filename:       CEGUIRefPtr.h
00003         created:        15/10/2004
00004         author:         Gerald Lindsly
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIRefPtr_h_
00025 #define _CEGUIRefPtr_h_
00026
00027 #include "CEGUIBase.h"
00028
00029 namespace CEGUI {
00030
00031 class CEGUIEXPORT Referenced
00032 {
00033 public:
00034   Referenced() : d_refCount(0) {}
00035   Referenced(const Referenced&) : d_refCount(0) {}
00036
00037   Referenced& operator=(Referenced&) { return *this; }
00038
00039   /* Increment the reference count by one, indicating that
00040       a pointer to this object is referencing it. */
00041   void addRef() const { ++d_refCount; }
00042
00043   /* Decrement the reference count by one, indicating that
00044      a pointer to this object is no longer referencing it.
00045      if the count drops to zero, this is deleted. */
00046   void release() const { if (!--d_refCount) delete this; }
00047
00048   /* Decrement the reference count by one, indicating that
00049       a pointer to this object is no longer referencing it;
00050       however, do not delete it, even if ref count goes to 0. */
00051   void releaseButKeep() const { --d_refCount; }
00052
00054   int refCount() const { return d_refCount; }
00055
00056 protected:
00057   virtual ~Referenced();
00058   mutable int d_refCount;
00059 };
00060
00061
00062 template<class T> class RefPtr
00063 {
00064   T* d_p;
00065
00066 public:
00067 //  RefPtr()     : d_p(0) {}
00068
00069   RefPtr()     : d_p(new T()) { d_p->addRef(); }
00070
00071   RefPtr(T* t) : d_p(t) { if (t)   d_p->addRef(); }
00072   RefPtr(const RefPtr& r) : d_p(r.d_p)
00073                         { if (r.d_p) d_p->addRef(); }
00074   ~RefPtr()
00075   { if (d_p) {
00076       d_p->release();
00077       d_p = 0;
00078     }
00079   }
00080
00081   RefPtr& operator=(T* q)
00082   {
00083     if (d_p != q) {
00084       T* t = d_p;
00085       d_p = q;
00086       if (q) q->addRef();
00087       if (t) t->release();
00088     }
00089     return *this;
00090   }
00091
00092   RefPtr& operator=(const RefPtr& r) { return *this = r.d_p; }
00093
00094   bool operator==(const RefPtr& r) const { return d_p == r.d_p; }
00095   bool operator!=(const RefPtr& r) const { return d_p != r.d_p; }
00096   bool operator< (const RefPtr& r) const { return d_p <  r.d_p; }
00097   bool operator> (const RefPtr& r) const { return d_p >  r.d_p; }
00098
00099   bool operator ==(const T* q) const { return d_p == q; }
00100   bool operator !=(const T* q) const { return d_p != q; }
00101   bool operator < (const T* q) const { return d_p <  q; }
00102   bool operator > (const T* q) const { return d_p >  q; }
00103
00104
00105         T& operator*()        { return *d_p; }
00106   const T& operator*() const  { return *d_p; }
00107
00108         T* operator->()       { return d_p; }
00109   const T* operator->() const { return d_p; }
00110
00111         T* get()              { return d_p; }
00112   const T* get() const        { return d_p; }
00113
00114   bool operator!() const            { return d_p == 0; }
00115   bool valid() const            { return d_p != 0; }
00116
00117   T* release()
00118   {
00119     T* t = d_p;
00120     if (d_p) {
00121       d_p->releaseButKeep();
00122       d_p = 0;
00123     }
00124     return t;
00125   }
00126 };
00127
00128 } // end namespace CEGUI
00129
00130 #endif
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRenderableElement.h Source File

include

CEGUIRenderableElement.h

00001 /************************************************************************
00002         filename:       CEGUIRenderableElement.h
00003         created:        14/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for base class of a 'higher-level' renderable
00007                                 UI entity.
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIRenderableElement_h_
00028 #define _CEGUIRenderableElement_h_
00029
00030 #include "CEGUIBase.h"
00031 #include "CEGUISystem.h"
00032 #include "CEGUIColourRect.h"
00033 #include "CEGUIVector.h"
00034 #include "CEGUIRenderCache.h"
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00043 class CEGUIEXPORT RenderableElement
00044 {
00045 public:
00046         /*************************************************************************
00047                 Drawing methods
00048         *************************************************************************/
00060         void    draw(const Vector3& position, const Rect& clip_rect);
00061
00072     void draw(RenderCache& renderCache) const;
00073
00074         /*************************************************************************
00075                 Accessors
00076         *************************************************************************/
00084         RenderableElement*      getNextElement(void) const                      {return d_next;}
00085
00086
00094         const ColourRect&       getColours(void) const                                          {return d_colours;}
00095
00096
00106         Point   getPosition(void) const                                                 {return Point(d_area.d_left, d_area.d_top);}
00107
00108
00116         Size    getSize(void) const                             {return Size(d_area.getWidth(), d_area.getHeight());}
00117
00118
00126         const Rect&     getRect(void) const                             {return d_area;}
00127
00128
00138         bool    isColourRectPerImage(bool setting) const                {return d_useColoursPerImage;}
00139
00140
00141         /*************************************************************************
00142                 Manipulators
00143         *************************************************************************/
00158         void    setNextElement(RenderableElement* element)              {d_next = element;}
00159
00160
00171         void    setColours(const ColourRect& colours)                   {d_colours = colours;}
00172
00173
00193         void    setColours(const colour& top_left_colour, const colour& top_right_colour, const colour& bottom_left_colour, const colour& bottom_right_colour);
00194
00195
00208         void    setPosition(const Point& position)                              {d_area.setPosition(position);}
00209
00210
00218         void    setSize(const Size& size)               {d_area.setSize(size);}
00219
00220
00231         void    setRect(const Rect& area)               {d_area = area;}
00232
00233
00246         void    setColourRectPerImage(bool setting)             {d_useColoursPerImage = setting;}
00247
00248
00249         /*************************************************************************
00250                 Construction / Destruction
00251         *************************************************************************/
00256         RenderableElement(void);
00257
00258
00259
00264         virtual ~RenderableElement(void);
00265
00266
00267 protected:
00268         /*************************************************************************
00269                 Implementation methods
00270         *************************************************************************/
00284         virtual void    draw_impl(const Vector3& position, const Rect& clip_rect) const = 0;
00285
00296     virtual void draw_impl(RenderCache& renderCache) const = 0;
00297
00298
00299         /*************************************************************************
00300                 Implementation Data
00301         *************************************************************************/
00302         RenderableElement*      d_next;
00303         ColourRect      d_colours;
00304         Rect            d_area;
00305         bool            d_useColoursPerImage;
00306 };
00307
00308 } // End of  CEGUI namespace section
00309
00310
00311 #endif  // end of guard _CEGUIRenderableElement_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRenderableFrame.h Source File

include

CEGUIRenderableFrame.h

00001 /************************************************************************
00002         filename:       CEGUIRenderableFrame.h
00003         created:        14/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to RenderableFrame UI construct
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIRenderableFrame_h_
00027 #define _CEGUIRenderableFrame_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIRenderableElement.h"
00031
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00040 enum FrameLocation
00041 {
00042         Invalid,                        // Value reserved to indicate some invalid or unknown location.
00043         TopLeftCorner,          // Top-Left corner of a frame / rectangle.
00044         TopRightCorner,         // Top-Right corner of a frame / rectangle.
00045         BottomLeftCorner,       // Bottom-Left corner of a frame / rectangle.
00046         BottomRightCorner,      // Bottom-Right corner of a frame / rectangle.
00047         LeftEdge,                       // Left edge of a frame / rectangle.
00048         TopEdge,                        // Top edge of a frame / rectangle.
00049         RightEdge,                      // Right edge of a frame / rectangle.
00050         BottomEdge                      // Bottom edge of a frame / rectangle.
00051 };
00052
00053
00065 class CEGUIEXPORT RenderableFrame : public RenderableElement
00066 {
00067 public:
00068         /*************************************************************************
00069                 Construction / Destruction
00070         *************************************************************************/
00075         RenderableFrame(void);
00076
00077
00082         virtual ~RenderableFrame(void);
00083
00084
00116         void    setImages(const Image* topleft, const Image* topright, const Image* bottomleft, const Image* bottomright, const Image* left, const Image* top, const Image* right, const Image* bottom);
00117
00118
00133         void    setImageForLocation(FrameLocation location, const Image* image);
00134
00135
00136
00148         const Image*    getImageForLocation(FrameLocation location) const;
00149
00150
00151 protected:
00152         /*************************************************************************
00153                 Implementation functions
00154         *************************************************************************/
00168         void draw_impl(const Vector3& position, const Rect& clip_rect) const;
00169
00170     // implements abstract method
00171     void draw_impl(RenderCache& renderCache) const;
00172
00173         /*************************************************************************
00174                 Implementation Data
00175         *************************************************************************/
00176         // image pointers
00177         const Image*    d_topleft;
00178         const Image*    d_topright;
00179         const Image*    d_bottomleft;
00180         const Image*    d_bottomright;
00181         const Image*    d_left;
00182         const Image*    d_right;
00183         const Image*    d_top;
00184         const Image*    d_bottom;
00185 };
00186
00187 } // End of  CEGUI namespace section
00188
00189
00190 #endif  // end of guard _CEGUIRenderableFrame_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRenderableImage.h Source File

include

CEGUIRenderableImage.h

00001 /************************************************************************
00002         filename:       CEGUIRenderableImage.h
00003         created:        17/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to renderable image UI entity
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIRenderableImage_h_
00027 #define _CEGUIRenderableImage_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIRenderableElement.h"
00031
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00044 class CEGUIEXPORT RenderableImage : public RenderableElement
00045 {
00046 public:
00047         /*************************************************************************
00048                 Formatting Enumerations
00049         *************************************************************************/
00054         enum HorzFormatting
00055         {
00056                 LeftAligned,
00057                 RightAligned,
00058                 HorzCentred,
00059                 HorzStretched,
00060                 HorzTiled
00061         };
00062
00063
00068         enum VertFormatting
00069         {
00070                 TopAligned,
00071                 BottomAligned,
00072                 VertCentred,
00073                 VertStretched,
00074                 VertTiled
00075         };
00076
00077
00078         /*************************************************************************
00079                 Construction / Destruction
00080         *************************************************************************/
00085         RenderableImage(void);
00086
00087
00092         virtual ~RenderableImage(void);
00093
00094
00095         /*************************************************************************
00096                 Public Interface
00097         *************************************************************************/
00108         void    setImage(const Image* image)            {d_image = image;}
00109
00110
00121         void    setHorzFormatting(HorzFormatting formatting)                    {d_horzFormat = formatting;}
00122
00123
00134         void    setVertFormatting(VertFormatting formatting)                    {d_vertFormat = formatting;}
00135
00136
00147         void    setQuadSplitMode(QuadSplitMode split_mode)                              {d_quadSplitMode = split_mode;}
00148
00149
00157         const Image*    getImage(void) const            {return d_image;}
00158
00159
00167         HorzFormatting  getHorzFormatting(void) const                           {return d_horzFormat;}
00168
00169
00177         VertFormatting  getVertFormatting(void) const                           {return d_vertFormat;}
00178
00179
00187         QuadSplitMode   getQuadSplitMode(void) const                            {return d_quadSplitMode;}
00188
00189
00190 protected:
00191         /*************************************************************************
00192                 Implementation functions
00193         *************************************************************************/
00207         void draw_impl(const Vector3& position, const Rect& clip_rect) const;
00208
00209     // implements abstract method
00210     void draw_impl(RenderCache& renderCache) const;
00211
00216     uint getHorzTileCount() const;
00217
00222     uint getVertTileCount() const;
00223
00228     float getBaseXCoord(const Size& sz) const;
00229
00234     float getBaseYCoord(const Size& sz) const;
00235
00240     Size getDestinationSize() const;
00241
00242         /*************************************************************************
00243                 Implementation Data
00244         *************************************************************************/
00245         HorzFormatting  d_horzFormat;
00246         VertFormatting  d_vertFormat;
00247         QuadSplitMode   d_quadSplitMode;
00248         const Image*    d_image;
00249 };
00250
00251 } // End of  CEGUI namespace section
00252
00253
00254 #endif  // end of guard _CEGUIRenderableImage_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRenderCache.h Source File

include

CEGUIRenderCache.h

00001 /************************************************************************
00002     filename:   CEGUIRenderCache.h
00003     created:    Fri Jun 17 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIRenderCache_h_
00025 #define _CEGUIRenderCache_h_
00026
00027 #include "CEGUIVector.h"
00028 #include "CEGUIRect.h"
00029 #include "CEGUIImage.h"
00030 #include "CEGUIFont.h"
00031 #include <vector>
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00059     class CEGUIEXPORT RenderCache
00060     {
00061     public:
00066         RenderCache();
00067
00072         ~RenderCache();
00073
00082         bool hasCachedImagery() const;
00083
00100         void render(const Point& basePos, float baseZ, const Rect& clipper) const;
00101
00106         void clearCachedImagery();
00107
00129         void cacheImage(const Image& image, const Rect& destArea, float zOffset, const ColourRect& cols, const Rect* clipper = 0, bool clipToDisplay = false);
00130
00158         void cacheText(const String& text, const Font* font, TextFormatting format, const Rect& destArea, float zOffset, const ColourRect& cols, const Rect* clipper = 0, bool clipToDisplay = false);
00159
00160     private:
00165         struct ImageInfo
00166         {
00167             const Image* source_image;
00168             Rect target_area;
00169             float z_offset;
00170             ColourRect colours;
00171             Rect customClipper;
00172             bool usingCustomClipper;
00173             bool clipToDisplay;
00174         };
00175
00180         struct TextInfo
00181         {
00182             String text;
00183             const Font* source_font;
00184             TextFormatting formatting;
00185             Rect target_area;
00186             float z_offset;
00187             ColourRect colours;
00188             Rect customClipper;
00189             bool usingCustomClipper;
00190             bool clipToDisplay;
00191         };
00192
00193         typedef std::vector<ImageInfo>  ImageryList;
00194         typedef std::vector<TextInfo>   TextList;
00195
00196         ImageryList d_cachedImages;
00197         TextList d_cachedTexts;
00198     };
00199
00200 } // End of  CEGUI namespace section
00201
00202
00203 #if defined(_MSC_VER)
00204 #       pragma warning(pop)
00205 #endif
00206
00207
00208 #endif  // end of guard _CEGUIRenderCache_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIRenderer.h Source File

include

CEGUIRenderer.h

00001 /************************************************************************
00002         filename:       CEGUIRenderer.h
00003         created:        20/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for abstract Renderer class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIRenderer_h_
00027 #define _CEGUIRenderer_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIRect.h"
00032 #include "CEGUIColourRect.h"
00033 #include "CEGUIEventSet.h"
00034
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00043 enum OrientationFlags {
00044         FlipHorizontal          = 1,
00045         FlipVertical            = 2,
00046         RotateRightAngle        = 4
00047 };
00048
00053 enum QuadSplitMode
00054 {
00055         TopLeftToBottomRight,
00056         BottomLeftToTopRight
00057 };
00058
00059
00068 class CEGUIEXPORT Renderer : public EventSet
00069 {
00070 public:
00071         static const String EventNamespace;
00072
00073         /*************************************************************************
00074                 Event name constants
00075         *************************************************************************/
00082         static const String EventDisplaySizeChanged;
00083
00084
00085         /*************************************************************************
00086                 Abstract interface methods
00087         *************************************************************************/
00113         virtual void    addQuad(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode) = 0;
00114
00115
00125         virtual void    doRender(void) = 0;
00126
00127
00135         virtual void    clearRenderList(void) = 0;
00136
00137
00153         virtual void    setQueueingEnabled(bool setting) = 0;
00154
00155
00164         virtual Texture*        createTexture(void) = 0;
00165
00166
00186         virtual Texture*        createTexture(const String& filename, const String& resourceGroup) = 0;
00187
00188
00204         virtual Texture*        createTexture(float size) = 0;
00205
00206
00217         virtual void            destroyTexture(Texture* texture) = 0;
00218
00219
00227         virtual void            destroyAllTextures(void) = 0;
00228
00229
00237         virtual bool    isQueueingEnabled(void) const = 0;
00238
00239
00247         virtual float   getWidth(void) const    = 0;
00248
00249
00257         virtual float   getHeight(void) const   = 0;
00258
00259
00267         virtual Size    getSize(void) const             = 0;
00268
00269
00278         virtual Rect    getRect(void) const             = 0;
00279
00280
00288         virtual uint    getMaxTextureSize(void) const   = 0;
00289
00290
00298         virtual uint    getHorzScreenDPI(void) const    = 0;
00299
00300
00308         virtual uint    getVertScreenDPI(void) const    = 0;
00309
00310
00311         /*************************************************************************
00312                 Basic stuff we provide in base class
00313         *************************************************************************/
00321         void    resetZValue(void)                               {d_current_z = GuiZInitialValue;}
00322
00323
00331         void    advanceZValue(void)                             {d_current_z -= GuiZElementStep;}
00332
00333
00341         float   getCurrentZ(void) const                 {return d_current_z;}
00342
00343
00355         float   getZLayer(uint layer) const             {return d_current_z - ((float)layer * GuiZLayerStep);}
00356
00357
00366     const String& getIdentifierString() const;
00367
00368     virtual ResourceProvider* createResourceProvider(void);
00369
00370 protected:
00371         /*************************************************************************
00372                 Construction and Destruction
00373         *************************************************************************/
00374         Renderer(void);
00375
00376 public:         // for luabind support
00377         virtual ~Renderer(void);
00378
00379 private:
00380         /*************************************************************************
00381                 Implementation constants
00382         *************************************************************************/
00383         static const float      GuiZInitialValue;
00384         static const float      GuiZElementStep;
00385         static const float      GuiZLayerStep;
00386
00387
00388         /*************************************************************************
00389                 Implementation Data
00390         *************************************************************************/
00391         float   d_current_z;
00392
00393 protected:
00394     ResourceProvider* d_resourceProvider;
00395     String d_identifierString;
00396 };
00397
00398 } // End of  CEGUI namespace section
00399
00400
00401 #endif  // end of guard _CEGUIRenderer_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIResourceProvider.h Source File

include

CEGUIResourceProvider.h

00001 /************************************************************************
00002         filename:       CEGUIResourceProvider.h
00003         created:        8/7/2004
00004         author:         James '_mental_' O'Sullivan
00005
00006         purpose:        Defines abstract base class for loading DataContainer objects
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIResourceProvider_h_
00027 #define _CEGUIResourceProvider_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIDataContainer.h"
00031 #include "CEGUIString.h"
00032
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00043 class CEGUIEXPORT ResourceProvider
00044 {
00045 public:
00046         /*************************************************************************
00047                 Construction and Destruction
00048         *************************************************************************/
00053         ResourceProvider() { }
00054
00059         virtual ~ResourceProvider(void) { }
00060
00061     /*************************************************************************
00062         Accessor functions
00063     *************************************************************************/
00064
00065 //    /*!
00066 //    \brief
00067 //        Load XML data using InputSource objects.
00068 //
00069 //    \param filename
00070 //        String containing a filename of the resource to be loaded.
00071 //
00072 //      \param output
00073 //              Reference to a InputSourceContainer object to load the data into.
00074 //   */
00075 //    virtual void loadInputSourceContainer(const String& filename, InputSourceContainer& output) = 0;
00076
00091     virtual void loadRawDataContainer(const String& filename, RawDataContainer& output, const String& resourceGroup) = 0;
00092
00103     virtual void unloadRawDataContainer(RawDataContainer& data)  { }
00104
00112     const String&   getDefaultResourceGroup(void) const     { return d_defaultResourceGroup; }
00113
00124     void    setDefaultResourceGroup(const String& resourceGroup)    { d_defaultResourceGroup = resourceGroup; }
00125
00126 protected:
00127     String  d_defaultResourceGroup;
00128 };
00129
00130 } // End of  CEGUI namespace section
00131
00132 #endif  // end of guard _CEGUIResourceProvider_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScheme.h Source File

include

CEGUIScheme.h

00001 /************************************************************************
00002         filename:       CEGUIScheme.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines abstract base class for the GUI Scheme object.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIScheme_h_
00027 #define _CEGUIScheme_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISchemeManager.h"
00032
00033 #include <vector>
00034
00035
00036 #if defined(_MSC_VER)
00037 #       pragma warning(push)
00038 #       pragma warning(disable : 4251)
00039 #endif
00040
00041
00042 // Start of CEGUI namespace section
00043 namespace CEGUI
00044 {
00054 class CEGUIEXPORT Scheme
00055 {
00056         friend class Scheme_xmlHandler;
00057 public:
00065         void    loadResources(void);
00066
00067
00075         void    unloadResources(void);
00076
00077
00085         bool    resourcesLoaded(void) const;
00086
00087
00095         const String& getName(void) const               {return d_name;}
00096
00097 private:
00098         /*************************************************************************
00099                 Implementation Constants
00100         *************************************************************************/
00101         static const char       GUISchemeSchemaName[];
00102
00103         /*************************************************************************
00104                 Friends
00105         *************************************************************************/
00106         friend  Scheme* SchemeManager::loadScheme(const String& scheme_filename, const String& resourceGroup);
00107         friend  void    SchemeManager::unloadScheme(const String& scheme_name);
00108
00109
00110         /*************************************************************************
00111                 Construction and Destruction
00112         *************************************************************************/
00127         Scheme(const String& filename, const String& resourceGroup);
00128
00129
00130 public:         // for luabind compatibility
00138         ~Scheme(void);
00139
00140
00141 private:
00142         /*************************************************************************
00143                 Structs used to hold scheme information
00144         *************************************************************************/
00145         struct LoadableUIElement
00146         {
00147                 String  name;
00148                 String  filename;
00149         String  resourceGroup;
00150         };
00151
00152         struct  UIElementFactory
00153         {
00154                 String name;
00155         };
00156
00157         struct  UIModule
00158         {
00159                 String name;
00160                 FactoryModule*  module;
00161                 std::vector<UIElementFactory>   factories;
00162         };
00163
00164         struct AliasMapping
00165         {
00166                 String aliasName;
00167                 String targetName;
00168         };
00169
00170     struct FalagardMapping
00171     {
00172         String windowName;
00173         String targetName;
00174         String lookName;
00175     };
00176
00177         /*************************************************************************
00178                 Implementation Data
00179         *************************************************************************/
00180         String  d_name;
00181
00182         std::vector<LoadableUIElement>          d_imagesets;
00183         std::vector<LoadableUIElement>          d_imagesetsFromImages;
00184         std::vector<LoadableUIElement>          d_fonts;
00185         std::vector<UIModule>                           d_widgetModules;
00186         std::vector<AliasMapping>                       d_aliasMappings;
00187     std::vector<LoadableUIElement>              d_looknfeels;
00188     std::vector<FalagardMapping>        d_falagardMappings;
00189 };
00190
00191 } // End of  CEGUI namespace section
00192
00193 #if defined(_MSC_VER)
00194 #       pragma warning(pop)
00195 #endif
00196
00197 #endif  // end of guard _CEGUIScheme_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScheme_xmlHandler.h Source File

include

CEGUIScheme_xmlHandler.h

00001 /************************************************************************
00002     filename:   CEGUIScheme_xmlHandler.h
00003     created:    21/2/2004
00004     author:     Paul D Turner
00005
00006     purpose:    Defines abstract base class for the GUI Scheme object.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIScheme_xmlHandler_h_
00027 #define _CEGUIScheme_xmlHandler_h_
00028
00029 #include "CEGUIScheme.h"
00030 #include "CEGUIXMLHandler.h"
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00040     class Scheme_xmlHandler : public XMLHandler
00041     {
00042     public:
00043         /*************************************************************************
00044         Construction & Destruction
00045         *************************************************************************/
00053         Scheme_xmlHandler(Scheme* scheme) : d_scheme(scheme)
00054         {}
00055
00060         virtual ~Scheme_xmlHandler(void)
00061         {}
00062
00063         /*************************************************************************
00064         SAX2 Handler overrides
00065         *************************************************************************/
00070         virtual void elementStart(const String& element, const XMLAttributes& attributes);
00071         virtual void elementEnd(const String& element);
00072
00073     private:
00074         /*************************************************************************
00075         Implementation Constants
00076         *************************************************************************/
00077         // XML related strings
00078         static const String GUISchemeElement;
00079         static const String ImagesetElement;
00080         static const String ImagesetFromImageElement;
00081         static const String FontElement;
00082         static const String WindowSetElement;
00083         static const String WindowFactoryElement;
00084         static const String WindowAliasElement;
00085         static const String FalagardMappingElement;
00086         static const String LookNFeelElement;
00087         static const String NameAttribute;
00088         static const String FilenameAttribute;
00089         static const String AliasAttribute;
00090         static const String TargetAttribute;
00091         static const String ResourceGroupAttribute;
00092         static const String WindowTypeAttribute;
00093         static const String TargetTypeAttribute;
00094         static const String LookNFeelAttribute;
00095
00096
00097         /*************************************************************************
00098         Implementation Data
00099         *************************************************************************/
00100         Scheme* d_scheme;
00101     };
00102
00103 } // End of  CEGUI namespace section
00104
00105 #endif  // end of guard _CEGUIScheme_xmlHandler_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISchemeManager.h Source File

include

CEGUISchemeManager.h

00001 /************************************************************************
00002         filename:       CEGUISchemeManager.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines the interface to the SchemeManager class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUISchemeManager_h_
00027 #define _CEGUISchemeManager_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUIIteratorBase.h"
00033 #include <map>
00034
00035
00036 #if defined(_MSC_VER)
00037 #       pragma warning(push)
00038 #       pragma warning(disable : 4275)
00039 #       pragma warning(disable : 4251)
00040 #endif
00041
00042
00043 // Start of CEGUI namespace section
00044 namespace CEGUI
00045 {
00050 class CEGUIEXPORT SchemeManager : public Singleton<SchemeManager>
00051 {
00052 public:
00057         SchemeManager(void);
00058
00059
00064         ~SchemeManager(void);
00065
00066
00074         static  SchemeManager&  getSingleton(void);
00075
00076
00084         static  SchemeManager*  getSingletonPtr(void);
00085
00086
00102         Scheme* loadScheme(const String& scheme_filename, const String& resourceGroup = "");
00103
00104
00113         void    unloadScheme(const String& scheme_name);
00114
00115
00126         bool    isSchemePresent(const String& scheme_name) const                {return (d_schemes.find(scheme_name) != d_schemes.end());}
00127
00128
00141         Scheme* getScheme(const String& name) const;
00142
00143
00156         void    unloadAllSchemes(void);
00157
00158 private:
00159         /*************************************************************************
00160                 Implementation Data
00161         *************************************************************************/
00162         typedef std::map<String, Scheme*> SchemeRegistry;
00163         SchemeRegistry  d_schemes;
00164
00165
00166 public:
00167         /*************************************************************************
00168                 Iterator stuff
00169         *************************************************************************/
00170         typedef ConstBaseIterator<SchemeRegistry>       SchemeIterator;
00171
00176         SchemeIterator  getIterator(void) const;
00177 };
00178
00179 } // End of  CEGUI namespace section
00180
00181 #if defined(_MSC_VER)
00182 #       pragma warning(pop)
00183 #endif
00184
00185 #endif  // end of guard _CEGUISchemeManager_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScriptModule.h Source File

include

CEGUIScriptModule.h

00001 /************************************************************************
00002         filename:       CEGUIScriptModule.h
00003         created:        16/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Abstract class interface for scripting support
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIScriptModule_h_
00027 #define _CEGUIScriptModule_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIEvent.h"
00032
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00042 class CEGUIEXPORT ScriptModule
00043 {
00044 public:
00045         /*************************************************************************
00046                 Construction and Destruction
00047         *************************************************************************/
00052         ScriptModule(void);
00053
00054
00059         virtual ~ScriptModule(void) {}
00060
00061
00062         /*************************************************************************
00063                 Abstract interface
00064         *************************************************************************/
00075         virtual void    executeScriptFile(const String& filename, const String& resourceGroup = "")     = 0;
00076
00077
00089         virtual int     executeScriptGlobal(const String& function_name)        = 0;
00090
00091
00108         virtual bool    executeScriptedEventHandler(const String& handler_name, const EventArgs& e)             = 0;
00109
00110
00121     virtual void executeString(const String& str) = 0;
00122
00123
00132     virtual void createBindings(void) {}
00133
00134
00144     virtual void destroyBindings(void) {}
00145
00154     const String& getIdentifierString() const;
00155
00156 protected:
00157     String d_identifierString;
00158 };
00159
00160
00165 class ScriptFunctor
00166 {
00167 public:
00168         ScriptFunctor(const String& functionName) : scriptFunctionName(functionName) {}
00169     ScriptFunctor(const ScriptFunctor& obj) : scriptFunctionName(obj.scriptFunctionName) {}
00170         bool    operator()(const EventArgs& e) const;
00171
00172 private:
00173     // no assignment possible
00174     ScriptFunctor& operator=(const ScriptFunctor& rhs);
00175
00176         const String    scriptFunctionName;
00177 };
00178
00179 } // End of  CEGUI namespace section
00180
00181
00182 #endif  // end of guard _CEGUIScriptModule_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScrollablePane.h Source File

include » elements

CEGUIScrollablePane.h

00001 /************************************************************************
00002         filename:       CEGUIScrollablePane.h
00003         created:        1/3/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIScrollablePane_h_
00025 #define _CEGUIScrollablePane_h_
00026
00027 #include "CEGUIBase.h"
00028 #include "CEGUIWindow.h"
00029 #include "elements/CEGUIScrollablePaneProperties.h"
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4251)
00034 #endif
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00047     class CEGUIEXPORT ScrollablePane : public Window
00048     {
00049     public:
00050         /*************************************************************************
00051             Constants
00052         *************************************************************************/
00053         static const String EventNamespace;
00054         static const String EventContentPaneChanged;
00055         static const String EventVertScrollbarModeChanged;
00056         static const String EventHorzScrollbarModeChanged;
00057         static const String EventAutoSizeSettingChanged;
00058         static const String EventContentPaneScrolled;
00059
00060         /*************************************************************************
00061             Construction / Destruction
00062         *************************************************************************/
00067         ScrollablePane(const String& type, const String& name);
00068
00073         ~ScrollablePane(void);
00074
00075         /*************************************************************************
00076                 Public interface
00077         *************************************************************************/
00090         const ScrolledContainer* getContentPane(void) const;
00091
00100         bool    isVertScrollbarAlwaysShown(void) const;
00112         void    setShowVertScrollbar(bool setting);
00113
00122         bool    isHorzScrollbarAlwaysShown(void) const;
00123
00135         void    setShowHorzScrollbar(bool setting);
00136
00145         bool isContentPaneAutoSized(void) const;
00146
00158         void setContentPaneAutoSized(bool setting);
00159
00168         const Rect& getContentPaneArea(void) const;
00169
00185         void setContentPaneArea(const Rect& area);
00186
00196         float getHorizontalStepSize(void) const;
00197
00210         void setHorizontalStepSize(float step);
00211
00221         float getHorizontalOverlapSize(void) const;
00222
00235         void setHorizontalOverlapSize(float overlap);
00236
00245         float getHorizontalScrollPosition(void) const;
00246
00258         void setHorizontalScrollPosition(float position);
00259
00269         float getVerticalStepSize(void) const;
00270
00283         void setVerticalStepSize(float step);
00284
00294         float getVerticalOverlapSize(void) const;
00295
00308         void setVerticalOverlapSize(float overlap);
00309
00318         float getVerticalScrollPosition(void) const;
00319
00331         void setVerticalScrollPosition(float position);
00332
00333         /*************************************************************************
00334             Overridden from Window
00335         *************************************************************************/
00336         void initialise(void);
00337
00338     protected:
00339         /*************************************************************************
00340                 Abstract interface
00341         *************************************************************************/
00352         virtual Scrollbar* createHorizontalScrollbar(const String& name) const = 0;
00353
00364         virtual Scrollbar* createVerticalScrollbar(const String& name) const = 0;
00365
00374         virtual Rect getViewableArea(void) const = 0;
00375
00376         /*************************************************************************
00377                 Implementation Methods
00378         *************************************************************************/
00383         void addScrollablePaneEvents(void);
00384
00390             void configureScrollbars(void);
00391
00400         bool isVertScrollbarNeeded(void) const;
00401
00410         bool isHorzScrollbarNeeded(void) const;
00411
00417         void updateContainerPosition(void);
00418
00419
00430                 virtual bool    testClassName_impl(const String& class_name) const
00431                 {
00432                         if (class_name==(const utf8*)"ScrollablePane")  return true;
00433                         return Window::testClassName_impl(class_name);
00434                 }
00435
00436
00437         /*************************************************************************
00438                 Event triggers
00439         *************************************************************************/
00451         virtual void onContentPaneChanged(WindowEventArgs& e);
00452
00464         virtual void onVertScrollbarModeChanged(WindowEventArgs& e);
00465
00477         virtual void onHorzScrollbarModeChanged(WindowEventArgs& e);
00478
00490         virtual void onAutoSizeSettingChanged(WindowEventArgs& e);
00491
00503         virtual void onContentPaneScrolled(WindowEventArgs& e);
00504
00505         /*************************************************************************
00506                 Event handler methods
00507         *************************************************************************/
00513         bool handleScrollChange(const EventArgs&  e);
00514
00520         bool handleContentAreaChange(const EventArgs& e);
00521
00527         bool handleAutoSizePaneChanged(const EventArgs& e);
00528
00529         /*************************************************************************
00530                 Overridden from Window
00531         *************************************************************************/
00532         void addChild_impl(Window* wnd);
00533         void removeChild_impl(Window* wnd);
00534         void onSized(WindowEventArgs& e);
00535         void onMouseWheel(MouseEventArgs& e);
00536
00537         /*************************************************************************
00538                 Data fields
00539         *************************************************************************/
00540         bool    d_forceVertScroll;
00541         bool    d_forceHorzScroll;
00542         Rect    d_contentRect;
00543         float   d_vertStep;
00544         float   d_vertOverlap;
00545         float   d_horzStep;
00546         float   d_horzOverlap;
00547
00548         // component widgets
00549         Scrollbar*  d_vertScrollbar;
00550         Scrollbar*  d_horzScrollbar;
00551         ScrolledContainer*  d_container;
00552
00553     private:
00554             /*************************************************************************
00555                     Static Properties for this class
00556             *************************************************************************/
00557         static ScrollablePaneProperties::ForceHorzScrollbar     d_horzScrollbarProperty;
00558         static ScrollablePaneProperties::ForceVertScrollbar     d_vertScrollbarProperty;
00559             static ScrollablePaneProperties::ContentPaneAutoSized       d_autoSizedProperty;
00560             static ScrollablePaneProperties::ContentArea            d_contentAreaProperty;
00561         static ScrollablePaneProperties::HorzStepSize           d_horzStepProperty;
00562         static ScrollablePaneProperties::HorzOverlapSize        d_horzOverlapProperty;
00563         static ScrollablePaneProperties::HorzScrollPosition     d_horzScrollPositionProperty;
00564         static ScrollablePaneProperties::VertStepSize           d_vertStepProperty;
00565         static ScrollablePaneProperties::VertOverlapSize        d_vertOverlapProperty;
00566         static ScrollablePaneProperties::VertScrollPosition     d_vertScrollPositionProperty;
00567
00568             /*************************************************************************
00569                     Private methods
00570             *************************************************************************/
00571             void addScrollablePaneProperties(void);
00572     };
00573
00574 } // End of  CEGUI namespace section
00575
00576
00577 #if defined(_MSC_VER)
00578 #       pragma warning(pop)
00579 #endif
00580
00581 #endif  // end of guard _CEGUIScrollablePane_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScrollablePaneProperties.h Source File

include » elements

CEGUIScrollablePaneProperties.h

00001 /************************************************************************
00002         filename:       CEGUIScrollablePaneProperties.h
00003         created:        3/3/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIScrollablePaneProperties_h_
00025 #define _CEGUIScrollablePaneProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of ScrollablePaneProperties namespace section
00037 namespace ScrollablePaneProperties
00038 {
00052     class ContentPaneAutoSized : public Property
00053     {
00054     public:
00055         ContentPaneAutoSized() : Property(
00056             "ContentPaneAutoSized",
00057             "Property to get/set the setting which controls whether the content pane will auto-size itself.  Value is either \"True\" or \"False\".",
00058             "True")
00059         {}
00060
00061         String  get(const PropertyReceiver* receiver) const;
00062         void    set(PropertyReceiver* receiver, const String& value);
00063     };
00064
00079     class ContentArea : public Property
00080     {
00081     public:
00082         ContentArea() : Property(
00083             "ContentArea",
00084             "Property to get/set the current content area rectangle of the content pane.  Value is \"l:[float] t:[float] r:[float] b:[float]\" (where l is left, t is top, r is right, and b is bottom).",
00085             "l:0.000000 t:0.000000 r:0.000000 b:0.000000")
00086         {}
00087
00088         String  get(const PropertyReceiver* receiver) const;
00089         void    set(PropertyReceiver* receiver, const String& value);
00090     };
00091
00105     class ForceVertScrollbar : public Property
00106     {
00107     public:
00108         ForceVertScrollbar() : Property(
00109             "ForceVertScrollbar",
00110             "Property to get/set the setting which controls whether the vertical scroll bar is aways shown.  Value is either \"True\" or \"False\".",
00111             "False")
00112         {}
00113
00114         String  get(const PropertyReceiver* receiver) const;
00115         void    set(PropertyReceiver* receiver, const String& value);
00116     };
00117
00118
00132     class ForceHorzScrollbar : public Property
00133     {
00134     public:
00135         ForceHorzScrollbar() : Property(
00136             "ForceHorzScrollbar",
00137             "Property to get/set the setting which controls whether the horizontal scroll bar is aways shown.  Value is either \"True\" or \"False\".",
00138             "False")
00139         {}
00140
00141         String  get(const PropertyReceiver* receiver) const;
00142         void    set(PropertyReceiver* receiver, const String& value);
00143     };
00144
00156     class HorzStepSize : public Property
00157     {
00158     public:
00159         HorzStepSize() : Property(
00160             "HorzStepSize",
00161             "Property to get/set the step size for the horizontal Scrollbar.  Value is a float.",
00162             "0.100000")
00163         {}
00164
00165         String  get(const PropertyReceiver* receiver) const;
00166         void    set(PropertyReceiver* receiver, const String& value);
00167     };
00168
00180     class HorzOverlapSize : public Property
00181     {
00182     public:
00183         HorzOverlapSize() : Property(
00184             "HorzOverlapSize",
00185             "Property to get/set the overlap size for the horizontal Scrollbar.  Value is a float.",
00186             "0.010000")
00187         {}
00188
00189         String  get(const PropertyReceiver* receiver) const;
00190         void    set(PropertyReceiver* receiver, const String& value);
00191     };
00192
00204     class HorzScrollPosition : public Property
00205     {
00206     public:
00207         HorzScrollPosition() : Property(
00208             "HorzScrollPosition",
00209             "Property to get/set the scroll position of the horizontal Scrollbar as a fraction.  Value is a float.",
00210             "0.000000")
00211         {}
00212
00213         String  get(const PropertyReceiver* receiver) const;
00214         void    set(PropertyReceiver* receiver, const String& value);
00215     };
00216
00228     class VertStepSize : public Property
00229     {
00230     public:
00231         VertStepSize() : Property(
00232             "VertStepSize",
00233             "Property to get/set the step size for the vertical Scrollbar.  Value is a float.",
00234             "0.100000")
00235         {}
00236
00237         String  get(const PropertyReceiver* receiver) const;
00238         void    set(PropertyReceiver* receiver, const String& value);
00239     };
00240
00252     class VertOverlapSize : public Property
00253     {
00254     public:
00255         VertOverlapSize() : Property(
00256             "VertOverlapSize",
00257             "Property to get/set the overlap size for the vertical Scrollbar.  Value is a float.",
00258             "0.010000")
00259         {}
00260
00261         String  get(const PropertyReceiver* receiver) const;
00262         void    set(PropertyReceiver* receiver, const String& value);
00263     };
00264
00276     class VertScrollPosition : public Property
00277     {
00278     public:
00279         VertScrollPosition() : Property(
00280             "VertScrollPosition",
00281             "Property to get/set the scroll position of the vertical Scrollbar as a fraction.  Value is a float.",
00282             "0.000000")
00283         {}
00284
00285         String  get(const PropertyReceiver* receiver) const;
00286         void    set(PropertyReceiver* receiver, const String& value);
00287     };
00288
00289 } // End of  ScrollablePaneProperties namespace section
00290 } // End of  CEGUI namespace section
00291
00292
00293 #endif  // end of guard _CEGUIScrollablePaneProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScrollbar.h Source File

include » elements

CEGUIScrollbar.h

00001 /************************************************************************
00002         filename:       CEGUIScrollbar.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Scrollbar widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIScrollbar_h_
00027 #define _CEGUIScrollbar_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIScrollbarProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00051 class CEGUIEXPORT Scrollbar : public Window
00052 {
00053 public:
00054         static const String EventNamespace;
00055
00056         /*************************************************************************
00057                 Event name constants
00058         *************************************************************************/
00059         static const String EventScrollPositionChanged;
00060         static const String EventThumbTrackStarted;
00061         static const String EventThumbTrackEnded;
00062         static const String EventScrollConfigChanged;
00063
00064
00065         /*************************************************************************
00066                 Accessor functions
00067         *************************************************************************/
00083         float   getDocumentSize(void) const                     {return d_documentSize;}
00084
00085
00103         float   getPageSize(void) const                         {return d_pageSize;}
00104
00105
00122         float   getStepSize(void) const                         {return d_stepSize;}
00123
00124
00142         float   getOverlapSize(void) const                      {return d_overlapSize;}
00143
00144
00161         float   getScrollPosition(void) const           {return d_position;}
00162
00163
00164         /*************************************************************************
00165                 Manipulator Commands
00166         *************************************************************************/
00177         virtual void    initialise(void);
00178
00179
00198         void    setDocumentSize(float document_size);
00199
00200
00221         void    setPageSize(float page_size);
00222
00223
00243         void    setStepSize(float step_size);
00244
00245
00266         void    setOverlapSize(float overlap_size);
00267
00268
00290         void    setScrollPosition(float position);
00291
00292
00293         /*************************************************************************
00294                 Construction / Destruction
00295         *************************************************************************/
00300         Scrollbar(const String& type, const String& name);
00301
00302
00307         virtual ~Scrollbar(void);
00308
00309
00310 protected:
00311         /*************************************************************************
00312                 Implementation Methods
00313         *************************************************************************/
00318         void    addScrollbarEvents(void);
00319
00320
00328         virtual PushButton*     createIncreaseButton(const String& name) const          = 0;
00329
00330
00338         virtual PushButton*     createDecreaseButton(const String& name) const          = 0;
00339
00340
00348         virtual Thumb*  createThumb(const String& name) const           = 0;
00349
00350
00355         virtual void    updateThumb(void)       = 0;
00356
00357
00365         virtual float   getValueFromThumb(void) const   = 0;
00366
00367
00381         virtual float   getAdjustDirectionFromPoint(const Point& pt) const      = 0;
00382
00383
00388         bool    handleThumbMoved(const EventArgs& e);
00389
00390
00395         bool    handleIncreaseClicked(const EventArgs& e);
00396
00397
00402         bool    handleDecreaseClicked(const EventArgs& e);
00403
00404
00409         bool    handleThumbTrackStarted(const EventArgs& e);
00410
00411
00416         bool    handleThumbTrackEnded(const EventArgs& e);
00417
00418
00429         virtual bool    testClassName_impl(const String& class_name) const
00430         {
00431                 if (class_name==(const utf8*)"Scrollbar")       return true;
00432                 return Window::testClassName_impl(class_name);
00433         }
00434
00435
00436         /*************************************************************************
00437                 New event handlers for slider widget
00438         *************************************************************************/
00443         virtual void    onScrollPositionChanged(WindowEventArgs& e);
00444
00445
00450         virtual void    onThumbTrackStarted(WindowEventArgs& e);
00451
00452
00457         virtual void    onThumbTrackEnded(WindowEventArgs& e);
00458
00459
00464         virtual void    onScrollConfigChanged(WindowEventArgs& e);
00465
00466
00467         /*************************************************************************
00468                 Overridden event handlers
00469         *************************************************************************/
00470         virtual void    onMouseButtonDown(MouseEventArgs& e);
00471         virtual void    onMouseWheel(MouseEventArgs& e);
00472
00473
00474         /*************************************************************************
00475                 Implementation Data
00476         *************************************************************************/
00477         float   d_documentSize;
00478         float   d_pageSize;
00479         float   d_stepSize;
00480         float   d_overlapSize;
00481         float   d_position;
00482
00483         // Pointers to the controls that make up the scroll bar
00484         Thumb*          d_thumb;
00485         PushButton*     d_increase;
00486         PushButton*     d_decrease;
00487
00488
00489 private:
00490         /*************************************************************************
00491                 Static Properties for this class
00492         *************************************************************************/
00493         static ScrollbarProperties::DocumentSize        d_documentSizeProperty;
00494         static ScrollbarProperties::PageSize            d_pageSizeProperty;
00495         static ScrollbarProperties::StepSize            d_stepSizeProperty;
00496         static ScrollbarProperties::OverlapSize         d_overlapSizeProperty;
00497         static ScrollbarProperties::ScrollPosition      d_scrollPositionProperty;
00498
00499
00500         /*************************************************************************
00501                 Private methods
00502         *************************************************************************/
00503         void    addScrollbarProperties(void);
00504 };
00505
00506
00507 } // End of  CEGUI namespace section
00508
00509 #if defined(_MSC_VER)
00510 #       pragma warning(pop)
00511 #endif
00512
00513 #endif  // end of guard _CEGUIScrollbar_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScrollbarProperties.h Source File

include » elements

CEGUIScrollbarProperties.h

00001 /************************************************************************
00002         filename:       CEGUIScrollbarProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for Scrollbar properties
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIScrollbarProperties_h_
00027 #define _CEGUIScrollbarProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ScrollbarProperties namespace section
00041 namespace ScrollbarProperties
00042 {
00054 class DocumentSize : public Property
00055 {
00056 public:
00057         DocumentSize() : Property(
00058                 "DocumentSize",
00059                 "Property to get/set the document size for the Scrollbar.  Value is a float.",
00060                 "1.000000")
00061         {}
00062
00063         String  get(const PropertyReceiver* receiver) const;
00064         void    set(PropertyReceiver* receiver, const String& value);
00065 };
00066
00067
00079 class PageSize : public Property
00080 {
00081 public:
00082         PageSize() : Property(
00083                 "PageSize",
00084                 "Property to get/set the page size for the Scrollbar.  Value is a float.",
00085                 "0.000000")
00086         {}
00087
00088         String  get(const PropertyReceiver* receiver) const;
00089         void    set(PropertyReceiver* receiver, const String& value);
00090 };
00091
00092
00104 class StepSize : public Property
00105 {
00106 public:
00107         StepSize() : Property(
00108                 "StepSize",
00109                 "Property to get/set the step size for the Scrollbar.  Value is a float.",
00110                 "1.000000")
00111         {}
00112
00113         String  get(const PropertyReceiver* receiver) const;
00114         void    set(PropertyReceiver* receiver, const String& value);
00115 };
00116
00117
00129 class OverlapSize : public Property
00130 {
00131 public:
00132         OverlapSize() : Property(
00133                 "OverlapSize",
00134                 "Property to get/set the overlap size for the Scrollbar.  Value is a float.",
00135                 "0.000000")
00136         {}
00137
00138         String  get(const PropertyReceiver* receiver) const;
00139         void    set(PropertyReceiver* receiver, const String& value);
00140 };
00141
00153 class ScrollPosition : public Property
00154 {
00155 public:
00156         ScrollPosition() : Property(
00157                 "ScrollPosition",
00158                 "Property to get/set the scroll position of the Scrollbar.  Value is a float.",
00159                 "0.000000")
00160         {}
00161
00162         String  get(const PropertyReceiver* receiver) const;
00163         void    set(PropertyReceiver* receiver, const String& value);
00164 };
00165
00166 } // End of  ScrollbarProperties namespace section
00167
00168 } // End of  CEGUI namespace section
00169
00170
00171 #endif  // end of guard _CEGUIScrollbarProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScrolledContainer.h Source File

include » elements

CEGUIScrolledContainer.h

00001 /************************************************************************
00002         filename:       CEGUIScrolledContainer.h
00003         created:        1/3/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIScrolledContainer_h_
00025 #define _CEGUIScrolledContainer_h_
00026
00027 #include "CEGUIWindow.h"
00028 #include "CEGUIWindowFactory.h"
00029 #include "elements/CEGUIScrolledContainerProperties.h"
00030 #include <map>
00031
00032 #if defined(_MSC_VER)
00033 #       pragma warning(push)
00034 #       pragma warning(disable : 4251)
00035 #endif
00036
00037 // Start of CEGUI namespace section
00038 namespace CEGUI
00039 {
00045     class CEGUIEXPORT ScrolledContainer : public Window
00046     {
00047     public:
00048         /*************************************************************************
00049             Constants
00050         *************************************************************************/
00051         static const String WidgetTypeName;
00052         static const String EventNamespace;
00053         static const String EventContentChanged;
00054         static const String EventAutoSizeSettingChanged;
00055
00056         /*************************************************************************
00057                 Object construction and destruction
00058         *************************************************************************/
00063         ScrolledContainer(const String& type, const String& name);
00064
00069         ~ScrolledContainer(void);
00070
00071         /*************************************************************************
00072                 Public interface methods
00073         *************************************************************************/
00082         bool isContentPaneAutoSized(void) const;
00083
00095         void setContentPaneAutoSized(bool setting);
00096
00105         const Rect& getContentArea(void) const;
00106
00122         void setContentArea(const Rect& area);
00123
00133         Rect getChildExtentsArea(void) const;
00134
00135     protected:
00136         /*************************************************************************
00137                 Implementation methods
00138         *************************************************************************/
00143         void addScrolledContainerEvents(void);
00144
00145
00156                 virtual bool    testClassName_impl(const String& class_name) const
00157                 {
00158                         if (class_name==(const utf8*)"ScrolledContainer")       return true;
00159                         return Window::testClassName_impl(class_name);
00160                 }
00161
00162         /*************************************************************************
00163                 Implementation of abstract methods from Window
00164         *************************************************************************/
00165         void drawSelf(float z) {};
00166
00167         /*************************************************************************
00168                 Event trigger methods.
00169         *************************************************************************/
00180         virtual void onContentChanged(WindowEventArgs& e);
00181
00193         virtual void onAutoSizeSettingChanged(WindowEventArgs& e);
00194
00195         /*************************************************************************
00196                 Event callbacks
00197         *************************************************************************/
00202         bool handleChildSized(const EventArgs& e);
00203
00208         bool handleChildMoved(const EventArgs& e);
00209
00210         /*************************************************************************
00211                 Overridden from Window.
00212         *************************************************************************/
00213         Rect getUnclippedInnerRect(void) const;
00214         void onChildAdded(WindowEventArgs& e);
00215         void onChildRemoved(WindowEventArgs& e);
00216         void onParentSized(WindowEventArgs& e);
00217
00218         /*************************************************************************
00219                 Data fields
00220         *************************************************************************/
00221         typedef std::multimap<Window*, Event::Connection>  ConnectionTracker;
00222         ConnectionTracker d_eventConnections;
00223         Rect d_contentArea;
00224         bool d_autosizePane;
00225
00226     private:
00227             /*************************************************************************
00228                     Static Properties for this class
00229             *************************************************************************/
00230             static ScrolledContainerProperties::ContentPaneAutoSized    d_autoSizedProperty;
00231             static ScrolledContainerProperties::ContentArea             d_contentAreaProperty;
00232             static ScrolledContainerProperties::ChildExtentsArea        d_childExtentsAreaProperty;
00233
00234             /*************************************************************************
00235                     Private methods
00236             *************************************************************************/
00237             void addScrolledContainerProperties(void);
00238     };
00239
00244     class ScrolledContainerFactory : public WindowFactory
00245     {
00246     public:
00247         ScrolledContainerFactory(void) : WindowFactory(ScrolledContainer::WidgetTypeName) { }
00248         ~ScrolledContainerFactory(void){}
00249
00250         Window* createWindow(const String& name)
00251         {
00252             ScrolledContainer* wnd = new ScrolledContainer(d_type, name);
00253             return wnd;
00254         }
00255
00256         void destroyWindow(Window* window)
00257         {
00258             if (window->getType() == d_type)
00259                 delete window;
00260         }
00261
00262     };
00263
00264 } // End of  CEGUI namespace section
00265
00266
00267 #if defined(_MSC_VER)
00268 #       pragma warning(pop)
00269 #endif
00270
00271 #endif  // end of guard _CEGUIScrolledContainer_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIScrolledContainerProperties.h Source File

include » elements

CEGUIScrolledContainerProperties.h

00001 /************************************************************************
00002         filename:       CEGUIScrolledContainerProperties.h
00003         created:        3/3/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIScrolledContainerProperties_h_
00025 #define _CEGUIScrolledContainerProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of ScrolledContainerProperties namespace section
00037 namespace ScrolledContainerProperties
00038 {
00052     class ContentPaneAutoSized : public Property
00053     {
00054     public:
00055         ContentPaneAutoSized() : Property(
00056             "ContentPaneAutoSized",
00057             "Property to get/set the setting which controls whether the content pane will auto-size itself.  Value is either \"True\" or \"False\".",
00058             "True")
00059         {}
00060
00061         String  get(const PropertyReceiver* receiver) const;
00062         void    set(PropertyReceiver* receiver, const String& value);
00063     };
00064
00079     class ContentArea : public Property
00080     {
00081     public:
00082         ContentArea() : Property(
00083             "ContentArea",
00084             "Property to get/set the current content area rectangle of the content pane.  Value is \"l:[float] t:[float] r:[float] b:[float]\" (where l is left, t is top, r is right, and b is bottom).",
00085             "l:0.000000 t:0.000000 r:0.000000 b:0.000000")
00086         {}
00087
00088         String  get(const PropertyReceiver* receiver) const;
00089         void    set(PropertyReceiver* receiver, const String& value);
00090     };
00091
00106     class ChildExtentsArea : public Property
00107     {
00108     public:
00109         ChildExtentsArea() : Property(
00110             "ChildExtentsArea",
00111             "Property to get the current content extents rectangle.  Value is \"l:[float] t:[float] r:[float] b:[float]\" (where l is left, t is top, r is right, and b is bottom).",
00112             "l:0.000000 t:0.000000 r:0.000000 b:0.000000")
00113         {}
00114
00115         String  get(const PropertyReceiver* receiver) const;
00116         void    set(PropertyReceiver* receiver, const String& value);
00117     };
00118
00119 } // End of  ScrolledContainerProperties namespace section
00120 } // End of  CEGUI namespace section
00121
00122
00123 #endif  // end of guard _CEGUIScrolledContainerProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISingleton.h Source File

include

CEGUISingleton.h

00001 /************************************************************************
00002         filename:       CEGUISingleton.h
00003         created:        22/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Singleton Base Class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 /*************************************************************************
00027
00028         The code in this file is taken from article 1.3 in the the book:
00029         Game Programming Gems from Charles River Media
00030
00031 *************************************************************************/
00032 #ifndef _CEGUISingleton_h_
00033 #define _CEGUISingleton_h_
00034
00035 #include "CEGUIBase.h"
00036 #include <cassert>
00037
00038 // Start of CEGUI namespace section
00039 namespace CEGUI
00040 {
00041 /* Copyright (C) Scott Bilas, 2000.
00042  * All rights reserved worldwide.
00043  *
00044  * This software is provided "as is" without express or implied
00045  * warranties. You may freely copy and compile this source into
00046  * applications you distribute provided that the copyright text
00047  * below is included in the resulting source code, for example:
00048  * "Portions Copyright (C) Scott Bilas, 2000"
00049  */
00050
00051
00052 template <typename T> class CEGUIEXPORT Singleton
00053 {
00054 protected:
00055     static T* ms_Singleton;
00056
00057 public:
00058     Singleton( void )
00059     {
00060         assert( !ms_Singleton );
00061         ms_Singleton = static_cast<T*>(this);
00062     }
00063    ~Singleton( void )
00064         {  assert( ms_Singleton );  ms_Singleton = 0;  }
00065     static T& getSingleton( void )
00066         {  assert( ms_Singleton );  return ( *ms_Singleton );  }
00067     static T* getSingletonPtr( void )
00068         {  return ( ms_Singleton );  }
00069 };
00070
00071 } // End of  CEGUI namespace section
00072
00073
00074
00075 #endif  // end of guard _CEGUISingleton_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISize.h Source File

include

CEGUISize.h

00001 /************************************************************************
00002         filename:       CEGUISize.h
00003         created:        14/3/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for Size class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUISize_h_
00027 #define _CEGUISize_h_
00028
00029 #include "CEGUIBase.h"
00030
00031 // Start of CEGUI namespace section
00032 namespace CEGUI
00033 {
00034
00039 class CEGUIEXPORT Size
00040 {
00041 public:
00042         Size(void) {}
00043         Size(float width, float height) : d_width(width), d_height(height) {}
00044
00045         bool operator==(const Size& other) const;
00046         bool operator!=(const Size& other) const;
00047
00048         float d_width, d_height;
00049 };
00050
00051 } // End of  CEGUI namespace section
00052
00053
00054 #endif  // end of guard _CEGUISize_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISlider.h Source File

include » elements

CEGUISlider.h

00001 /************************************************************************
00002         filename:       CEGUISlider.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Slider widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUISlider_h_
00027 #define _CEGUISlider_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUISliderProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00043
00051 class CEGUIEXPORT Slider : public Window
00052 {
00053 public:
00054         static const String EventNamespace;
00055
00056
00057         /*************************************************************************
00058                 Event name constants
00059         *************************************************************************/
00060         static const String EventValueChanged;
00061         static const String EventThumbTrackStarted;
00062         static const String EventThumbTrackEnded;
00063
00064
00065         /*************************************************************************
00066                 Accessors
00067         *************************************************************************/
00075         float   getCurrentValue(void) const                     {return d_value;}
00076
00077
00085         float   getMaxValue(void) const                         {return d_maxValue;}
00086
00087
00098         float   getClickStep(void) const                {return d_step;}
00099
00100
00101         /*************************************************************************
00102                 Manipulators
00103         *************************************************************************/
00114         virtual void    initialise(void);
00115
00116
00127         void    setMaxValue(float maxVal);
00128
00129
00140         void    setCurrentValue(float value);
00141
00142
00156         void    setClickStep(float step)                {d_step = step;}
00157
00158
00159         /*************************************************************************
00160                 Construction / Destruction
00161         *************************************************************************/
00166         Slider(const String& type, const String& name);
00167
00168
00173         virtual ~Slider(void);
00174
00175
00176 protected:
00177         /*************************************************************************
00178                 Implementation Functions
00179         *************************************************************************/
00184         void    addSliderEvents(void);
00185
00186
00194         virtual Thumb*  createThumb(const String& name) const           = 0;
00195
00196
00201         virtual void    updateThumb(void)       = 0;
00202
00203
00211         virtual float   getValueFromThumb(void) const   = 0;
00212
00213
00227         virtual float   getAdjustDirectionFromPoint(const Point& pt) const      = 0;
00228
00229
00234         bool    handleThumbMoved(const EventArgs& e);
00235
00236
00241         bool    handleThumbTrackStarted(const EventArgs& e);
00242
00243
00248         bool    handleThumbTrackEnded(const EventArgs& e);
00249
00250
00261         virtual bool    testClassName_impl(const String& class_name) const
00262         {
00263                 if (class_name==(const utf8*)"Slider")  return true;
00264                 return Window::testClassName_impl(class_name);
00265         }
00266
00267
00268         /*************************************************************************
00269                 New event handlers for slider widget
00270         *************************************************************************/
00275         virtual void    onValueChanged(WindowEventArgs& e);
00276
00277
00282         virtual void    onThumbTrackStarted(WindowEventArgs& e);
00283
00284
00289         virtual void    onThumbTrackEnded(WindowEventArgs& e);
00290
00291
00292         /*************************************************************************
00293                 Overridden event handlers
00294         *************************************************************************/
00295         virtual void    onMouseButtonDown(MouseEventArgs& e);
00296         virtual void    onMouseWheel(MouseEventArgs& e);
00297
00298
00299         /*************************************************************************
00300                 Implementation Data
00301         *************************************************************************/
00302         float   d_value;
00303         float   d_maxValue;
00304         float   d_step;
00305
00306         // Pointers to the controls that make up the slider
00307         Thumb*  d_thumb;
00308
00309
00310 private:
00311         /*************************************************************************
00312                 Static Properties for this class
00313         *************************************************************************/
00314         static SliderProperties::CurrentValue   d_currentValueProperty;
00315         static SliderProperties::MaximumValue   d_maximumValueProperty;
00316         static SliderProperties::ClickStepSize  d_clickStepSizeProperty;
00317
00318
00319         /*************************************************************************
00320                 Private methods
00321         *************************************************************************/
00322         void    addSliderProperties(void);
00323 };
00324
00325 } // End of  CEGUI namespace section
00326
00327 #if defined(_MSC_VER)
00328 #       pragma warning(pop)
00329 #endif
00330
00331 #endif  // end of guard _CEGUISlider_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISliderProperties.h Source File

include » elements

CEGUISliderProperties.h

00001 /************************************************************************
00002         filename:       CEGUISliderProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for Slider class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUISliderProperties_h_
00027 #define _CEGUISliderProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of SliderProperties namespace section
00041 namespace SliderProperties
00042 {
00054 class CurrentValue : public Property
00055 {
00056 public:
00057         CurrentValue() : Property(
00058                 "CurrentValue",
00059                 "Property to get/set the current value of the slider.  Value is a float.",
00060                 "0.000000")
00061         {}
00062
00063         String  get(const PropertyReceiver* receiver) const;
00064         void    set(PropertyReceiver* receiver, const String& value);
00065 };
00066
00067
00079 class MaximumValue : public Property
00080 {
00081 public:
00082         MaximumValue() : Property(
00083                 "MaximumValue",
00084                 "Property to get/set the maximum value of the slider.  Value is a float.",
00085                 "1.000000")
00086         {}
00087
00088         String  get(const PropertyReceiver* receiver) const;
00089         void    set(PropertyReceiver* receiver, const String& value);
00090 };
00091
00092
00104 class ClickStepSize : public Property
00105 {
00106 public:
00107         ClickStepSize() : Property(
00108                 "ClickStepSize",
00109                 "Property to get/set the click-step size for the slider.  Value is a float.",
00110                 "0.010000")
00111         {}
00112
00113         String  get(const PropertyReceiver* receiver) const;
00114         void    set(PropertyReceiver* receiver, const String& value);
00115 };
00116
00117 } // End of  SliderProperties namespace section
00118
00119 } // End of  CEGUI namespace section
00120
00121
00122 #endif  // end of guard _CEGUISliderProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISpinner.h Source File

include » elements

CEGUISpinner.h

00001 /************************************************************************
00002     filename:   CEGUISpinner.h
00003     created:    3/2/2005
00004     author:             Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUISpinner_h_
00025 #define _CEGUISpinner_h_
00026
00027 #include "CEGUIBase.h"
00028 #include "CEGUIWindow.h"
00029 #include "elements/CEGUISpinnerProperties.h"
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4251)
00034 #endif
00035
00036
00037 // Start of CEGUI namespace section
00038 namespace CEGUI
00039 {
00048     class CEGUIEXPORT Spinner : public Window
00049     {
00050     public:
00055         enum TextInputMode
00056         {
00057             FloatingPoint,
00058             Integer,
00059             Hexadecimal,
00060             Octal
00061         };
00062
00063         /*************************************************************************
00064             Events system constants
00065         *************************************************************************/
00066         static const String EventNamespace;
00067         static const String EventValueChanged;
00068         static const String EventStepChanged;
00069         static const String EventMaximumValueChanged;
00070         static const String EventMinimumValueChanged;
00071         static const String EventTextInputModeChanged;
00072
00073         /*************************************************************************
00074             Object Construction and Destruction
00075         *************************************************************************/
00080         Spinner(const String& type, const String& name);
00081
00086         virtual ~Spinner(void);
00087
00098         void initialise(void);
00099
00100
00101         /*************************************************************************
00102                 Accessors
00103         *************************************************************************/
00111         float getCurrentValue(void) const;
00112
00121         float getStepSize(void) const;
00122
00130         float getMaximumValue(void) const;
00131
00139         float getMinimumValue(void) const;
00140
00149         TextInputMode getTextInputMode(void) const;
00150
00151         /*************************************************************************
00152                 Manipulators
00153         *************************************************************************/
00164         void setCurrentValue(float value);
00165
00177         void setStepSize(float step);
00178
00189         void setMaximumValue(float maxValue);
00190
00201         void setMinimumValue(float minVaue);
00202
00214         void setTextInputMode(TextInputMode mode);
00215
00216     protected:
00217         /*************************************************************************
00218                 Constants
00219         *************************************************************************/
00220         static const String FloatValidator;
00221         static const String IntegerValidator;
00222         static const String HexValidator;
00223         static const String OctalValidator;
00224
00225         /*************************************************************************
00226                 Protected Implementation Methods
00227         *************************************************************************/
00235         void addSpinnerEvents(void);
00236
00246         virtual float getValueFromText(void) const;
00247
00255         virtual String getTextFromValue(void) const;
00256
00257
00268                 virtual bool    testClassName_impl(const String& class_name) const
00269                 {
00270                         if (class_name==(const utf8*)"Spinner") return true;
00271                         return Window::testClassName_impl(class_name);
00272                 }
00273
00274
00275         /*************************************************************************
00276                 Abstract Implementation methods
00277         *************************************************************************/
00286         virtual PushButton* createIncreaseButton(const String& name) const = 0;
00287
00296         virtual PushButton* createDecreaseButton(const String& name) const = 0;
00297
00306         virtual Editbox* createEditbox(const String& name) const = 0;
00307
00308         /*************************************************************************
00309                 Overrides for Event handler methods
00310         *************************************************************************/
00311         virtual void onFontChanged(WindowEventArgs& e);
00312         virtual void onTextChanged(WindowEventArgs& e);
00313         virtual void onActivated(ActivationEventArgs& e);
00314
00315         /*************************************************************************
00316                 New Event handler methods
00317         *************************************************************************/
00328         virtual void onValueChanged(WindowEventArgs& e);
00329
00340         virtual void onStepChanged(WindowEventArgs& e);
00341
00352         virtual void onMaximumValueChanged(WindowEventArgs& e);
00353
00364         virtual void onMinimumValueChanged(WindowEventArgs& e);
00365
00376         virtual void onTextInputModeChanged(WindowEventArgs& e);
00377
00378         /*************************************************************************
00379                 Internal event listener methods
00380         *************************************************************************/
00381         bool handleIncreaseButton(const EventArgs& e);
00382         bool handleDecreaseButton(const EventArgs& e);
00383         bool handleEditTextChange(const EventArgs& e);
00384
00385
00386         /*************************************************************************
00387                 Data Fields
00388         *************************************************************************/
00389         PushButton* d_increaseButton;
00390         PushButton* d_decreaseButton;
00391         Editbox*    d_editbox;
00392
00393         float   d_stepSize;
00394         float   d_currentValue;
00395         float   d_maxValue;
00396         float   d_minValue;
00397         TextInputMode   d_inputMode;
00398
00399     private:
00400         /*************************************************************************
00401                 Static properties for the Spinner widget
00402         *************************************************************************/
00403         static SpinnerProperties::CurrentValue  d_currentValueProperty;
00404         static SpinnerProperties::StepSize      d_stepSizeProperty;
00405         static SpinnerProperties::MaximumValue  d_maxValueProperty;
00406         static SpinnerProperties::MinimumValue  d_minValueProperty;
00407         static SpinnerProperties::TextInputMode d_textInputModeProperty;
00408
00409         /*************************************************************************
00410                 Private Implementation Methods
00411         *************************************************************************/
00419         void    addSpinnerProperties(void);
00420     };
00421
00422 } // End of  CEGUI namespace section
00423
00424
00425 #endif  // end of guard _CEGUISpinner_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISpinnerProperties.h Source File

include » elements

CEGUISpinnerProperties.h

00001 /************************************************************************
00002         filename:       CEGUISpinnerProperties.h
00003         created:        7/2/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUISpinnerProperties_h_
00025 #define _CEGUISpinnerProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00033 // Start of SpinnerProperties namespace section
00034 namespace SpinnerProperties
00035 {
00047     class CurrentValue : public Property
00048     {
00049     public:
00050             CurrentValue() : Property(
00051                     "CurrentValue",
00052                     "Property to get/set the current value of the spinner.  Value is a float.",
00053                     "0.000000")
00054             {}
00055
00056             String get(const PropertyReceiver* receiver) const;
00057             void set(PropertyReceiver* receiver, const String& value);
00058     };
00059
00071     class StepSize : public Property
00072     {
00073     public:
00074             StepSize() : Property(
00075                     "StepSize",
00076                     "Property to get/set the step size of the spinner.  Value is a float.",
00077                     "1.000000")
00078             {}
00079
00080             String get(const PropertyReceiver* receiver) const;
00081             void set(PropertyReceiver* receiver, const String& value);
00082     };
00083
00095     class MinimumValue : public Property
00096     {
00097     public:
00098             MinimumValue() : Property(
00099                     "MinimumValue",
00100                     "Property to get/set the minimum value setting of the spinner.  Value is a float.",
00101                     "-32768.000000")
00102             {}
00103
00104             String get(const PropertyReceiver* receiver) const;
00105             void set(PropertyReceiver* receiver, const String& value);
00106     };
00107
00119     class MaximumValue : public Property
00120     {
00121     public:
00122             MaximumValue() : Property(
00123                     "MaximumValue",
00124                     "Property to get/set the maximum value setting of the spinner.  Value is a float.",
00125                     "32767.000000")
00126             {}
00127
00128             String get(const PropertyReceiver* receiver) const;
00129             void set(PropertyReceiver* receiver, const String& value);
00130     };
00131
00148     class TextInputMode : public Property
00149     {
00150     public:
00151             TextInputMode() : Property(
00152                     "TextInputMode",
00153                     "Property to get/set the TextInputMode setting for the spinner.  Value is \"FloatingPoint\", \"Integer\", \"Hexadecimal\", or \"Octal\".",
00154                     "Integer")
00155             {}
00156
00157             String      get(const PropertyReceiver* receiver) const;
00158             void        set(PropertyReceiver* receiver, const String& value);
00159     };
00160
00161 } // End of  SpinnerProperties namespace section
00162 } // End of  CEGUI namespace section
00163
00164
00165 #endif  // end of guard _CEGUISpinnerProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIStatic.h Source File

include » elements

CEGUIStatic.h

00001 /************************************************************************
00002         filename:       CEGUIStatic.h
00003         created:        13/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to base class for Static widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIStatic_h_
00027 #define _CEGUIStatic_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "CEGUIRenderableFrame.h"
00032 #include "elements/CEGUIStaticProperties.h"
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00048 class CEGUIEXPORT Static : public Window
00049 {
00050 public:
00051         static const String EventNamespace;
00052
00053
00054         /*************************************************************************
00055                 Accessors
00056         *************************************************************************/
00064         bool    isFrameEnabled(void) const              {return d_frameEnabled;}
00065
00066
00074         bool    isBackgroundEnabled(void) const         {return d_backgroundEnabled;}
00075
00076
00084         ColourRect      getFrameColours(void) const             {return d_frameCols;}
00085
00086
00094         ColourRect      getBackgroundColours(void) const                {return d_backgroundCols;}
00095
00096
00097         // overridden so derived classes are auto-clipped to within the inner area of the frame when it's active.
00098         virtual Rect    getUnclippedInnerRect(void) const;
00099
00100
00112         const Image*    getImageForFrameLocation(FrameLocation location) const;
00113
00114
00123         const Image* getBackgroundImage(void) const;
00124
00125
00126         /*************************************************************************
00127                 Manipulators
00128         *************************************************************************/
00138         void    setFrameEnabled(bool setting);
00139
00140
00172         void    setFrameImages(const Image* topleft, const Image* topright, const Image* bottomleft, const Image* bottomright, const Image* left, const Image* top, const Image* right, const Image* bottom);
00173
00174
00185         void    setFrameColours(const ColourRect& colours);
00186
00187
00207         void    setFrameColours(const colour& top_left_colour, const colour& top_right_colour, const colour& bottom_left_colour, const colour& bottom_right_colour);
00208
00209
00220         void    setFrameColours(const colour& col)              {setFrameColours(col, col, col, col);}
00221
00222
00230         void    setBackgroundEnabled(bool setting);
00231
00232
00243         void    setBackgroundImage(const Image* image);
00244
00245
00261         void    setBackgroundImage(const String& imageset, const String& image);
00262
00263
00274         void    setBackgroundColours(const ColourRect& colours);
00275
00276
00296         void    setBackgroundColours(const colour& top_left_colour, const colour& top_right_colour, const colour& bottom_left_colour, const colour& bottom_right_colour);
00297
00298
00309         void    setBackgroundColours(const colour& col)         {setBackgroundColours(col, col, col, col);}
00310
00311
00326         void    setImageForFrameLocation(FrameLocation location, const Image* image);
00327
00328
00329         /*************************************************************************
00330                 Construction and Destruction
00331         *************************************************************************/
00336         Static(const String& type, const String& name);
00337
00338
00343         virtual ~Static(void);
00344
00345
00346 protected:
00347         /*************************************************************************
00348                 Overridden from base class
00349         *************************************************************************/
00350         virtual void populateRenderCache();
00351
00352
00353         /*************************************************************************
00354                 Event handling
00355         *************************************************************************/
00356         virtual void    onSized(WindowEventArgs& e);
00357         virtual void    onAlphaChanged(WindowEventArgs& e);
00358
00359
00360         /*************************************************************************
00361                 Implementation methods
00362         *************************************************************************/
00368         void    updateRenderableFrameColours(void);
00369
00370
00375         colour  calculateModulatedAlphaColour(const colour& col, float alpha) const;
00376
00377
00385         virtual void    onStaticFrameChanged(WindowEventArgs& e)        {}
00386
00387
00398         virtual bool    testClassName_impl(const String& class_name) const
00399         {
00400                 if (class_name==(const utf8*)"Static")  return true;
00401                 return Window::testClassName_impl(class_name);
00402         }
00403
00404         /*************************************************************************
00405                 Implementation Data
00406         *************************************************************************/
00407         bool                            d_frameEnabled;
00408         ColourRect                      d_frameCols;
00409         RenderableFrame         d_frame;
00410         bool                            d_backgroundEnabled;
00411         ColourRect                      d_backgroundCols;
00412         const Image*            d_background;
00413
00414         // cache of frame edge sizes
00415         float   d_left_width;
00416         float   d_right_width;
00417         float   d_top_height;
00418         float   d_bottom_height;
00419
00420
00421 private:
00422         /*************************************************************************
00423                 Static Properties for this class
00424         *************************************************************************/
00425         static StaticProperties::FrameEnabled                           d_frameEnabledProperty;
00426         static StaticProperties::BackgroundEnabled                      d_backgroundEnabledProperty;
00427         static StaticProperties::FrameColours                           d_frameColoursProperty;
00428         static StaticProperties::BackgroundColours                      d_backgroundColoursProperty;
00429         static StaticProperties::BackgroundImage                        d_backgroundImageProperty;
00430         static StaticProperties::TopLeftFrameImage                      d_topLeftFrameProperty;
00431         static StaticProperties::TopRightFrameImage                     d_topRightFrameProperty;
00432         static StaticProperties::BottomLeftFrameImage           d_bottomLeftFrameProperty;
00433         static StaticProperties::BottomRightFrameImage          d_bottomRightFrameProperty;
00434         static StaticProperties::LeftFrameImage                         d_leftFrameProperty;
00435         static StaticProperties::RightFrameImage                        d_rightFrameProperty;
00436         static StaticProperties::TopFrameImage                          d_topFrameProperty;
00437         static StaticProperties::BottomFrameImage                       d_bottomFrameProperty;
00438
00439
00440         /*************************************************************************
00441                 Private methods
00442         *************************************************************************/
00443         void    addStaticProperties(void);
00444 };
00445
00446
00447 } // End of  CEGUI namespace section
00448
00449 #if defined(_MSC_VER)
00450 #       pragma warning(pop)
00451 #endif
00452
00453 #endif  // end of guard _CEGUIStatic_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIStaticImage.h Source File

include » elements

CEGUIStaticImage.h

00001 /************************************************************************
00002         filename:       CEGUIStaticImage.h
00003         created:        4/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for the static image widget.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIStaticImage_h_
00027 #define _CEGUIStaticImage_h_
00028
00029 #include "elements/CEGUIStatic.h"
00030 #include "CEGUIRenderableImage.h"
00031 #include "elements/CEGUIStaticImageProperties.h"
00032
00033
00034 #if defined(_MSC_VER)
00035 #       pragma warning(push)
00036 #       pragma warning(disable : 4251)
00037 #endif
00038
00039
00040 // Start of CEGUI namespace section
00041 namespace CEGUI
00042 {
00050 class CEGUIEXPORT StaticImage : public Static
00051 {
00052 public:
00053         static const String EventNamespace;
00054
00055
00056         /*************************************************************************
00057                 Formatting Enumerations
00058         *************************************************************************/
00063         enum HorzFormatting
00064         {
00065                 LeftAligned,
00066                 RightAligned,
00067                 HorzCentred,
00068                 HorzStretched,
00069                 HorzTiled
00070         };
00071
00072
00077         enum VertFormatting
00078         {
00079                 TopAligned,
00080                 BottomAligned,
00081                 VertCentred,
00082                 VertStretched,
00083                 VertTiled
00084         };
00085
00086
00087         /*************************************************************************
00088                 Construction and Destruction
00089         *************************************************************************/
00094         StaticImage(const String& type, const String& name);
00095
00096
00101         virtual ~StaticImage(void);
00102
00103
00104         /*************************************************************************
00105                 Accessors
00106         *************************************************************************/
00114         const Image*    getImage(void) const            {return d_image.getImage();}
00115
00116
00124         ColourRect      getImageColours(void) const             {return d_imageCols;}
00125
00126
00134         HorzFormatting  getHorizontalFormatting(void) const             {return (HorzFormatting)d_image.getHorzFormatting();}
00135
00136
00144         VertFormatting  getVerticalFormatting(void) const               {return (VertFormatting)d_image.getVertFormatting();}
00145
00146
00147         /*************************************************************************
00148                 Manipulators
00149         *************************************************************************/
00160         void    setImage(const Image* image);
00161
00162
00178         void    setImage(const String& imageset, const String& image);
00179
00180
00191         void    setImageColours(const ColourRect& colours);
00192
00193
00213         void    setImageColours(const colour& top_left_colour, const colour& top_right_colour, const colour& bottom_left_colour, const colour& bottom_right_colour);
00214
00215
00226         void    setImageColours(const colour& col)              {setImageColours(col, col, col, col);}
00227
00228
00242         void    setFormatting(HorzFormatting h_fmt, VertFormatting v_fmt);
00243
00244
00255         void    setVerticalFormatting(VertFormatting v_fmt);
00256
00257
00268         void    setHorizontalFormatting(HorzFormatting h_fmt);
00269
00270
00271 protected:
00272         /*************************************************************************
00273                 Overridden from base class
00274         *************************************************************************/
00275         virtual void populateRenderCache();
00276
00277
00278         /*************************************************************************
00279                 Event handling
00280         *************************************************************************/
00281         virtual void    onSized(WindowEventArgs& e);
00282         virtual void    onAlphaChanged(WindowEventArgs& e);
00283         virtual void    onStaticFrameChanged(WindowEventArgs& e);
00284
00285
00286         /*************************************************************************
00287                 Implementation Methods
00288         *************************************************************************/
00294         void    updateRenderableImageColours(void);
00295
00296
00307         virtual bool    testClassName_impl(const String& class_name) const
00308         {
00309                 if (class_name==(const utf8*)"StaticImage")     return true;
00310                 return Static::testClassName_impl(class_name);
00311         }
00312
00313
00314         /*************************************************************************
00315                 Implementation Data
00316         *************************************************************************/
00317         RenderableImage d_image;
00318         ColourRect              d_imageCols;
00319
00320
00321 private:
00322         /*************************************************************************
00323                 Static Properties for this class
00324         *************************************************************************/
00325         static StaticImageProperties::Image                             d_imageProperty;
00326         static StaticImageProperties::ImageColours              d_imageColoursProperty;
00327         static StaticImageProperties::VertFormatting    d_vertFormattingProperty;
00328         static StaticImageProperties::HorzFormatting    d_horzFormattingProperty;
00329
00330
00331         /*************************************************************************
00332                 Private methods
00333         *************************************************************************/
00334         void    addStaticImageProperties(void);
00335 };
00336
00337 } // End of  CEGUI namespace section
00338
00339 #if defined(_MSC_VER)
00340 #       pragma warning(pop)
00341 #endif
00342
00343 #endif  // end of guard _CEGUIStaticImage_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIStaticImageProperties.h Source File

include » elements

CEGUIStaticImageProperties.h

00001 /************************************************************************
00002         filename:       CEGUIStaticImageProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for StaticImage property classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIStaticImageProperties_h_
00027 #define _CEGUIStaticImageProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of StaticImageProperties namespace section
00041 namespace StaticImageProperties
00042 {
00055 class Image : public Property
00056 {
00057 public:
00058         Image() : Property(
00059                 "Image",
00060                 "Property to get/set the image for the StaticImage widget.  Value should be \"set:[imageset name] image:[image name]\".",
00061                 "")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00083 class ImageColours : public Property
00084 {
00085 public:
00086         ImageColours() : Property(
00087                 "ImageColours",
00088                 "Property to get/set the text colours for the StaticImage widget.  Value is \"tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]\".",
00089                 "tl:FFFFFFFF tr:FFFFFFFF bl:FFFFFFFF br:FFFFFFFF")
00090         {}
00091
00092         String  get(const PropertyReceiver* receiver) const;
00093         void    set(PropertyReceiver* receiver, const String& value);
00094 };
00095
00096
00112 class HorzFormatting : public Property
00113 {
00114 public:
00115         HorzFormatting() : Property(
00116                 "HorzFormatting",
00117                 "Property to get/set the horizontal formatting mode.  Value is one of the HorzFormatting strings.",
00118                 "HorzStretched")
00119         {}
00120
00121         String  get(const PropertyReceiver* receiver) const;
00122         void    set(PropertyReceiver* receiver, const String& value);
00123 };
00124
00125
00141 class VertFormatting : public Property
00142 {
00143 public:
00144         VertFormatting() : Property(
00145                 "VertFormatting",
00146                 "Property to get/set the vertical formatting mode.  Value is one of the VertFormatting strings.",
00147                 "VertStretched")
00148         {}
00149
00150         String  get(const PropertyReceiver* receiver) const;
00151         void    set(PropertyReceiver* receiver, const String& value);
00152 };
00153
00154
00155 } // End of  StaticImageProperties namespace section
00156
00157 } // End of  CEGUI namespace section
00158
00159
00160 #endif  // end of guard _CEGUIStaticImageProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIStaticProperties.h Source File

include » elements

CEGUIStaticProperties.h

00001 /************************************************************************
00002         filename:       CEGUIStaticProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to properties for Static (base class) widget.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIStaticProperties_h_
00027 #define _CEGUIStaticProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031 // Start of CEGUI namespace section
00032 namespace CEGUI
00033 {
00034
00035 // Start of StaticProperties namespace section
00040 namespace StaticProperties
00041 {
00054 class FrameEnabled : public Property
00055 {
00056 public:
00057         FrameEnabled() : Property(
00058                 "FrameEnabled",
00059                 "Property to get/set the state of the frame enabled setting for the Static widget.  Value is either \"True\" or \"False\".",
00060                 "True")
00061         {}
00062
00063         String  get(const PropertyReceiver* receiver) const;
00064         void    set(PropertyReceiver* receiver, const String& value);
00065 };
00066
00067
00080 class BackgroundEnabled : public Property
00081 {
00082 public:
00083         BackgroundEnabled() : Property(
00084                 "BackgroundEnabled",
00085                 "Property to get/set the state of the frame background setting for the Static widget.  Value is either \"True\" or \"False\".",
00086                 "True")
00087         {}
00088
00089         String  get(const PropertyReceiver* receiver) const;
00090         void    set(PropertyReceiver* receiver, const String& value);
00091 };
00092
00093
00108 class FrameColours : public Property
00109 {
00110 public:
00111         FrameColours() : Property(
00112                 "FrameColours",
00113                 "Property to get/set the frame colours for the Static widget.  Value is \"tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]\".",
00114                 "tl:FFFFFFFF tr:FFFFFFFF bl:FFFFFFFF br:FFFFFFFF")
00115         {}
00116
00117         String  get(const PropertyReceiver* receiver) const;
00118         void    set(PropertyReceiver* receiver, const String& value);
00119 };
00120
00121
00136 class BackgroundColours : public Property
00137 {
00138 public:
00139         BackgroundColours() : Property(
00140                 "BackgroundColours",
00141                 "Property to get/set the background colours for the Static widget.  Value is \"tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]\".",
00142                 "tl:FFFFFFFF tr:FFFFFFFF bl:FFFFFFFF br:FFFFFFFF")
00143         {}
00144
00145         String  get(const PropertyReceiver* receiver) const;
00146         void    set(PropertyReceiver* receiver, const String& value);
00147 };
00148
00149
00162 class BackgroundImage : public Property
00163 {
00164 public:
00165         BackgroundImage() : Property(
00166                 "BackgroundImage",
00167                 "Property to get/set the background image for the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00168                 "")
00169         {}
00170
00171         String  get(const PropertyReceiver* receiver) const;
00172         void    set(PropertyReceiver* receiver, const String& value);
00173 };
00174
00175
00188 class TopLeftFrameImage : public Property
00189 {
00190 public:
00191         TopLeftFrameImage() : Property(
00192                 "TopLeftFrameImage",
00193                 "Property to get/set the top-left image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00194                 "")
00195         {}
00196
00197         String  get(const PropertyReceiver* receiver) const;
00198         void    set(PropertyReceiver* receiver, const String& value);
00199 };
00200
00201
00214 class TopRightFrameImage : public Property
00215 {
00216 public:
00217         TopRightFrameImage() : Property(
00218                 "TopRightFrameImage",
00219                 "Property to get/set the top-right image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00220                 "")
00221         {}
00222
00223         String  get(const PropertyReceiver* receiver) const;
00224         void    set(PropertyReceiver* receiver, const String& value);
00225 };
00226
00227
00240 class BottomLeftFrameImage : public Property
00241 {
00242 public:
00243         BottomLeftFrameImage() : Property(
00244                 "BottomLeftFrameImage",
00245                 "Property to get/set the bottom-left image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00246                 "")
00247         {}
00248
00249         String  get(const PropertyReceiver* receiver) const;
00250         void    set(PropertyReceiver* receiver, const String& value);
00251 };
00252
00253
00266 class BottomRightFrameImage : public Property
00267 {
00268 public:
00269         BottomRightFrameImage() : Property(
00270                 "BottomRightFrameImage",
00271                 "Property to get/set the bottom-right image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00272                 "")
00273         {}
00274
00275         String  get(const PropertyReceiver* receiver) const;
00276         void    set(PropertyReceiver* receiver, const String& value);
00277 };
00278
00279
00292 class LeftFrameImage : public Property
00293 {
00294 public:
00295         LeftFrameImage() : Property(
00296                 "LeftFrameImage",
00297                 "Property to get/set the left edge image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00298                 "")
00299         {}
00300
00301         String  get(const PropertyReceiver* receiver) const;
00302         void    set(PropertyReceiver* receiver, const String& value);
00303 };
00304
00305
00318 class RightFrameImage : public Property
00319 {
00320 public:
00321         RightFrameImage() : Property(
00322                 "RightFrameImage",
00323                 "Property to get/set the right edge image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00324                 "")
00325         {}
00326
00327         String  get(const PropertyReceiver* receiver) const;
00328         void    set(PropertyReceiver* receiver, const String& value);
00329 };
00330
00331
00344 class TopFrameImage : public Property
00345 {
00346 public:
00347         TopFrameImage() : Property(
00348                 "TopFrameImage",
00349                 "Property to get/set the top edge image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00350                 "")
00351         {}
00352
00353         String  get(const PropertyReceiver* receiver) const;
00354         void    set(PropertyReceiver* receiver, const String& value);
00355 };
00356
00357
00370 class BottomFrameImage : public Property
00371 {
00372 public:
00373         BottomFrameImage() : Property(
00374                 "BottomFrameImage",
00375                 "Property to get/set the bottom edge image for the frame of the Static widget.  Value should be \"set:[imageset name] image:[image name]\".",
00376                 "")
00377         {}
00378
00379         String  get(const PropertyReceiver* receiver) const;
00380         void    set(PropertyReceiver* receiver, const String& value);
00381 };
00382
00383
00384
00385
00386 } // End of  StaticProperties namespace section
00387
00388 } // End of  CEGUI namespace section
00389
00390
00391 #endif  // end of guard _CEGUIStaticProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIStaticText.h Source File

include » elements

CEGUIStaticText.h

00001 /************************************************************************
00002         filename:       CEGUIStaticText.h
00003         created:        4/6/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for a static text widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIStaticText_h_
00027 #define _CEGUIStaticText_h_
00028
00029 #include "elements/CEGUIStatic.h"
00030 #include "elements/CEGUIStaticTextProperties.h"
00031
00032
00033 #if defined(_MSC_VER)
00034 #       pragma warning(push)
00035 #       pragma warning(disable : 4251)
00036 #endif
00037
00038
00039 // Start of CEGUI namespace section
00040 namespace CEGUI
00041 {
00046 class CEGUIEXPORT StaticText : public Static
00047 {
00048 public:
00049         static const String EventNamespace;
00050
00051
00052         /*************************************************************************
00053                 Formatting Enumerations
00054         *************************************************************************/
00059         enum HorzFormatting
00060         {
00061                 LeftAligned,
00062                 RightAligned,
00063                 HorzCentred,
00064                 HorzJustified,
00065                 WordWrapLeftAligned,
00066                 WordWrapRightAligned,
00067                 WordWrapCentred,
00068                 WordWrapJustified
00069         };
00070
00071
00076         enum VertFormatting
00077         {
00078                 TopAligned,
00079                 BottomAligned,
00080                 VertCentred
00081         };
00082
00083
00084         /*************************************************************************
00085                 Construction and Destruction
00086         *************************************************************************/
00091         StaticText(const String& type, const String& name);
00092
00093
00098         virtual ~StaticText(void);
00099
00100
00101         /*************************************************************************
00102                 Accessors
00103         *************************************************************************/
00111         ColourRect      getTextColours(void) const              {return d_textCols;}
00112
00113
00121         HorzFormatting  getHorizontalFormatting(void) const             {return d_horzFormatting;}
00122
00123
00131         VertFormatting  getVerticalFormatting(void) const               {return d_vertFormatting;}
00132
00133
00142         bool    isVerticalScrollbarEnabled(void) const;
00143
00144
00153         bool    isHorizontalScrollbarEnabled(void) const;
00154
00155
00156         // overridden (again) so scroll bars are not clipped when they are active
00157         virtual Rect    getUnclippedInnerRect(void) const;
00158
00159
00160         /*************************************************************************
00161                 Manipulators
00162         *************************************************************************/
00173         virtual void    initialise(void);
00174
00175
00186         void    setTextColours(const ColourRect& colours);
00187
00188
00208         void    setTextColours(const colour& top_left_colour, const colour& top_right_colour, const colour& bottom_left_colour, const colour& bottom_right_colour);
00209
00210
00221         void    setTextColours(const colour& col)               {setTextColours(col, col, col, col);}
00222
00223
00237         void    setFormatting(HorzFormatting h_fmt, VertFormatting v_fmt);
00238
00239
00250         void    setVerticalFormatting(VertFormatting v_fmt);
00251
00252
00263         void    setHorizontalFormatting(HorzFormatting h_fmt);
00264
00265
00274         void    setVerticalScrollbarEnabled(bool setting);
00275
00276
00285         void    setHorizontalScrollbarEnabled(bool setting);
00286
00287
00288 protected:
00289         /*************************************************************************
00290                 Overridden from base class
00291         *************************************************************************/
00292         virtual void populateRenderCache();
00293
00294
00295         /*************************************************************************
00296                 Overridden events
00297         *************************************************************************/
00298         virtual void    onTextChanged(WindowEventArgs& e);
00299         virtual void    onSized(WindowEventArgs& e);
00300         virtual void    onFontChanged(WindowEventArgs& e);
00301         virtual void    onMouseWheel(MouseEventArgs& e);
00302
00303
00304         /*************************************************************************
00305                 Implementation methods
00306         *************************************************************************/
00315         virtual Rect    getTextRenderArea(void) const;
00316
00317
00322         void    configureScrollbars(void);
00323
00324
00335         virtual bool    testClassName_impl(const String& class_name) const
00336         {
00337                 if (class_name==(const utf8*)"StaticText")      return true;
00338                 return Static::testClassName_impl(class_name);
00339         }
00340
00341
00342         /*************************************************************************
00343                 Implementation Methods (abstract)
00344         *************************************************************************/
00355         virtual Scrollbar*      createVertScrollbar(const String& name) const           = 0;
00356
00357
00368         virtual Scrollbar*      createHorzScrollbar(const String& name) const           = 0;
00369
00370
00371         /*************************************************************************
00372                 Event subscribers
00373         *************************************************************************/
00374         bool    handleScrollbarChange(const EventArgs& e);
00375
00376
00377         /*************************************************************************
00378                 Implementation Data
00379         *************************************************************************/
00380         HorzFormatting  d_horzFormatting;
00381         VertFormatting  d_vertFormatting;
00382         ColourRect              d_textCols;
00383         Scrollbar*              d_vertScrollbar;
00384         Scrollbar*              d_horzScrollbar;
00385         bool                    d_enableVertScrollbar;
00386         bool                    d_enableHorzScrollbar;
00387
00388 private:
00389         /*************************************************************************
00390                 Static Properties for this class
00391         *************************************************************************/
00392         static StaticTextProperties::TextColours        d_textColoursProperty;
00393         static StaticTextProperties::VertFormatting     d_vertFormattingProperty;
00394         static StaticTextProperties::HorzFormatting     d_horzFormattingProperty;
00395         static StaticTextProperties::VertScrollbar      d_vertScrollbarProperty;
00396         static StaticTextProperties::HorzScrollbar      d_horzScrollbarProperty;
00397
00398
00399         /*************************************************************************
00400                 Private methods
00401         *************************************************************************/
00402         void    addStaticTextProperties(void);
00403 };
00404
00405 } // End of  CEGUI namespace section
00406
00407 #if defined(_MSC_VER)
00408 #       pragma warning(pop)
00409 #endif
00410
00411 #endif  // end of guard _CEGUIStaticText_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIStaticTextProperties.h Source File

include » elements

CEGUIStaticTextProperties.h

00001 /************************************************************************
00002         filename:       CEGUIStaticTextProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for properties for the StaticText class.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIStaticTextProperties_h_
00027 #define _CEGUIStaticTextProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of StaticTextProperties namespace section
00041 namespace StaticTextProperties
00042 {
00057 class TextColours : public Property
00058 {
00059 public:
00060         TextColours() : Property(
00061                 "TextColours",
00062                 "Property to get/set the text colours for the StaticText widget.  Value is \"tl:[aarrggbb] tr:[aarrggbb] bl:[aarrggbb] br:[aarrggbb]\".",
00063                 "tl:FFFFFFFF tr:FFFFFFFF bl:FFFFFFFF br:FFFFFFFF")
00064         {}
00065
00066         String  get(const PropertyReceiver* receiver) const;
00067         void    set(PropertyReceiver* receiver, const String& value);
00068 };
00069
00070
00089 class HorzFormatting : public Property
00090 {
00091 public:
00092         HorzFormatting() : Property(
00093                 "HorzFormatting",
00094                 "Property to get/set the horizontal formatting mode.  Value is one of the HorzFormatting strings.",
00095                 "LeftAligned")
00096         {}
00097
00098         String  get(const PropertyReceiver* receiver) const;
00099         void    set(PropertyReceiver* receiver, const String& value);
00100 };
00101
00102
00116 class VertFormatting : public Property
00117 {
00118 public:
00119         VertFormatting() : Property(
00120                 "VertFormatting",
00121                 "Property to get/set the vertical formatting mode.  Value is one of the VertFormatting strings.",
00122                 "VertCentred")
00123         {}
00124
00125         String  get(const PropertyReceiver* receiver) const;
00126         void    set(PropertyReceiver* receiver, const String& value);
00127 };
00128
00129
00142 class VertScrollbar : public Property
00143 {
00144 public:
00145         VertScrollbar() : Property(
00146                 "VertScrollbar",
00147                 "Property to get/set the setting for the vertical scroll bar.  Value is either \"True\" or \"False\".",
00148                 "False")
00149         {}
00150
00151         String  get(const PropertyReceiver* receiver) const;
00152         void    set(PropertyReceiver* receiver, const String& value);
00153 };
00154
00155
00168 class HorzScrollbar : public Property
00169 {
00170 public:
00171         HorzScrollbar() : Property(
00172                 "HorzScrollbar",
00173                 "Property to get/set the setting for the horizontal scroll bar.  Value is either \"True\" or \"False\".",
00174                 "False")
00175         {}
00176
00177         String  get(const PropertyReceiver* receiver) const;
00178         void    set(PropertyReceiver* receiver, const String& value);
00179 };
00180
00181 } // End of  StaticTextProperties namespace section
00182
00183 } // End of  CEGUI namespace section
00184
00185
00186 #endif  // end of guard _CEGUIStaticTextProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIString.h Source File

include

CEGUIString.h

00001 /************************************************************************
00002         filename:       CEGUIString.h
00003         created:        26/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines string class used within the GUI system.
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIString_h_
00027 #define _CEGUIString_h_
00028
00029 #include "CEGUIBase.h"
00030 #include <string>
00031 #include <string.h>
00032 #include <stdexcept>
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00037 #define STR_QUICKBUFF_SIZE      32
00038         /*************************************************************************
00039                 Basic Types
00040         *************************************************************************/
00041         typedef         uint8   utf8;
00042         //typedef               uint16  utf16;  // removed typedef to prevent usage, as utf16 is not supported (yet)
00043         typedef         uint32  utf32;
00044
00053 class CEGUIEXPORT String
00054 {
00055 public:
00056         /*************************************************************************
00057                 Integral Types
00058         *************************************************************************/
00059         typedef         utf32                   value_type;
00060         typedef         size_t                  size_type;
00061         typedef         ptrdiff_t               difference_type;
00062         typedef         utf32&                  reference;
00063         typedef         const utf32&    const_reference;
00064         typedef         utf32*                  pointer;
00065         typedef         const utf32*    const_pointer;
00066
00067         static const size_type          npos;
00068
00069 private:
00070         /*************************************************************************
00071                 Implementation data
00072         *************************************************************************/
00073         size_type       d_cplength;
00074         size_type       d_reserve;
00075
00076         mutable utf8*           d_encodedbuff;
00077         mutable size_type       d_encodeddatlen;
00078         mutable size_type       d_encodedbufflen;
00079
00080         utf32           d_quickbuff[STR_QUICKBUFF_SIZE];
00081         utf32*          d_buffer;
00082
00083 public:
00084         /*************************************************************************
00085                 Iterator Classes
00086         *************************************************************************/
00091 #if defined(_MSC_VER) && (_MSC_VER <= 1200)
00092         class const_iterator : public std::iterator<std::random_access_iterator_tag, utf32>
00093 #else
00094         class const_iterator : public std::iterator<std::random_access_iterator_tag, utf32, std::ptrdiff_t, const utf32*, const utf32&>
00095 #endif
00096         {
00097
00098         public:
00100                 // data
00102                 const utf32*    d_ptr;
00103
00104
00106                 // Methods
00108                 const_iterator(void)
00109                 {
00110                         d_ptr = 0;
00111                 }
00112                 const_iterator(const_pointer ptr)
00113                 {
00114                         d_ptr = ptr;
00115                 }
00116
00117                 const_reference operator*() const
00118                 {
00119                         return *d_ptr;
00120                 }
00121
00122 #if defined(_MSC_VER) && (_MSC_VER <= 1200)
00123 #       pragma warning (push)
00124 #       pragma warning (disable : 4284)
00125 #endif
00126                 const_pointer   operator->() const
00127                 {
00128                         return &**this;
00129                 }
00130
00131 #if defined(_MSC_VER) && (_MSC_VER <= 1200)
00132 #       pragma warning (pop)
00133 #endif
00134
00135                 const_iterator& operator++()
00136                 {
00137                         ++d_ptr;
00138                         return *this;
00139                 }
00140
00141                 const_iterator  operator++(int)
00142                 {
00143                         const_iterator temp = *this;
00144                         ++*this;
00145                         return temp;
00146                 }
00147
00148                 const_iterator& operator--()
00149                 {
00150                         --d_ptr;
00151                         return *this;
00152                 }
00153
00154                 const_iterator  operator--(int)
00155                 {
00156                         const_iterator temp = *this;
00157                         --*this;
00158                         return temp;
00159                 }
00160
00161                 const_iterator& operator+=(difference_type offset)
00162                 {
00163                         d_ptr += offset;
00164                         return *this;
00165                 }
00166
00167                 const_iterator operator+(difference_type offset) const
00168                 {
00169                         const_iterator temp = *this;
00170                         return temp += offset;
00171                 }
00172
00173                 const_iterator& operator-=(difference_type offset)
00174                 {
00175                         return *this += -offset;
00176                 }
00177
00178                 const_iterator operator-(difference_type offset) const
00179                 {
00180                         const_iterator temp = *this;
00181                         return temp -= offset;
00182                 }
00183
00184                 difference_type operator-(const const_iterator& iter) const
00185                 {
00186                         return d_ptr - iter.d_ptr;
00187                 }
00188
00189                 const_reference operator[](difference_type offset) const
00190                 {
00191                         return *(*this + offset);
00192                 }
00193
00194                 bool operator==(const const_iterator& iter) const
00195                 {
00196                         return d_ptr == iter.d_ptr;
00197                 }
00198
00199                 bool operator!=(const const_iterator& iter) const
00200                 {
00201                         return !(*this == iter);
00202                 }
00203
00204                 bool operator<(const const_iterator& iter) const
00205                 {
00206                         return d_ptr < iter.d_ptr;
00207                 }
00208
00209                 bool operator>(const const_iterator& iter) const
00210                 {
00211                         return (!(iter < *this));
00212                 }
00213
00214                 bool operator<=(const const_iterator& iter) const
00215                 {
00216                         return (!(iter < *this));
00217                 }
00218
00219                 bool operator>=(const const_iterator& iter) const
00220                 {
00221                         return (!(*this < iter));
00222                 }
00223
00224                 friend const_iterator operator+(difference_type offset, const const_iterator& iter)
00225                 {
00226                         return iter + offset;
00227                 }
00228
00229         };
00230
00235         class iterator : public const_iterator
00236         {
00237         public:
00238                 iterator(void) {}
00239                 iterator(pointer ptr) : const_iterator(ptr) {}
00240
00241
00242                 reference operator*() const
00243                 {
00244                         return ((reference)**(const_iterator *)this);
00245                 }
00246
00247 #if defined(_MSC_VER) && (_MSC_VER <= 1200)
00248 #       pragma warning (push)
00249 #       pragma warning (disable : 4284)
00250 #endif
00251
00252                 pointer operator->() const
00253                 {
00254                         return &**this;
00255                 }
00256
00257 #if defined(_MSC_VER) && (_MSC_VER <= 1200)
00258 #       pragma warning (pop)
00259 #endif
00260
00261                 iterator& operator++()
00262                 {
00263                         ++this->d_ptr;
00264                         return *this;
00265                 }
00266
00267                 iterator operator++(int)
00268                 {
00269                         iterator temp = *this;
00270                         ++*this;
00271                         return temp;
00272                 }
00273
00274                 iterator& operator--()
00275                 {
00276                         --this->d_ptr;
00277                         return *this;
00278                 }
00279
00280                 iterator operator--(int)
00281                 {
00282                         iterator temp = *this;
00283                         --*this;
00284                         return temp;
00285                 }
00286
00287                 iterator& operator+=(difference_type offset)
00288                 {
00289                         this->d_ptr += offset;
00290                         return *this;
00291                 }
00292
00293                 iterator operator+(difference_type offset) const
00294                 {
00295                         iterator temp = *this;
00296                         return temp + offset;
00297                 }
00298
00299                 iterator& operator-=(difference_type offset)
00300                 {
00301                         return *this += -offset;
00302                 }
00303
00304                 iterator operator-(difference_type offset) const
00305                 {
00306                         iterator temp = *this;
00307                         return temp -= offset;
00308                 }
00309
00310                 difference_type operator-(const const_iterator& iter) const
00311                 {
00312                         return ((const_iterator)*this - iter);
00313                 }
00314
00315                 reference operator[](difference_type offset) const
00316                 {
00317                         return *(*this + offset);
00318                 }
00319
00320                 friend iterator operator+(difference_type offset, const iterator& iter)
00321                 {
00322                         return iter + offset;
00323                 }
00324
00325         };
00326
00331 #if defined(_MSC_VER) && ((_MSC_VER <= 1200) || ((_MSC_VER <= 1300) && defined(_STLPORT_VERSION)))
00332         typedef std::reverse_iterator<const_iterator, const_pointer, const_reference, difference_type>  const_reverse_iterator;
00333 #else
00334         typedef std::reverse_iterator<const_iterator>   const_reverse_iterator;
00335 #endif
00336
00341 #if defined(_MSC_VER) && ((_MSC_VER <= 1200) || ((_MSC_VER <= 1300) && defined(_STLPORT_VERSION)))
00342         typedef std::reverse_iterator<iterator, pointer, reference, difference_type>                    reverse_iterator;
00343 #else
00344         typedef std::reverse_iterator<iterator>                 reverse_iterator;
00345 #endif
00346
00347 public:
00349         // Default Construction and Destructor
00351
00355         String(void)
00356         {
00357                 init();
00358         }
00359
00364         ~String(void);
00365
00367         // Construction via CEGUI::String
00369
00379         String(const String& str)
00380         {
00381                 init();
00382                 assign(str);
00383         }
00384
00385
00402         String(const String& str, size_type str_idx, size_type str_num = npos)
00403         {
00404                 init();
00405                 assign(str, str_idx, str_num);
00406         }
00407
00409         // Construction via std::string
00411
00427         String(const std::string& std_str)
00428         {
00429                 init();
00430                 assign(std_str);
00431         }
00432
00455         String(const std::string& std_str, size_type str_idx, size_type str_num = npos)
00456         {
00457                 init();
00458                 assign(std_str, str_idx, str_num);
00459         }
00460
00461
00463         // Construction via UTF-8 stream (for straight ASCII use, only codes 0x00 - 0x7f are valid)
00465
00483         String(const utf8* utf8_str)
00484         {
00485                 init();
00486                 assign(utf8_str);
00487         }
00488
00515         String(const utf8* utf8_str, size_type chars_len)
00516         {
00517                 init();
00518                 assign(utf8_str, chars_len);
00519         }
00520
00522         // Construction via code-point (using a UTF-32 code unit)
00524
00539         String(size_type num, utf32 code_point)
00540         {
00541                 init();
00542                 assign(num, code_point);
00543         }
00544
00546         // Construction via iterator
00548         // Create string with characters in the range [beg, end)
00562         String(const_iterator iter_beg, const_iterator iter_end)
00563         {
00564                 init();
00565                 append(iter_beg, iter_end);
00566         }
00567
00568
00570         // Construction via c-string
00572
00584         String(const char* cstr)
00585         {
00586                 init();
00587                 assign(cstr);
00588         }
00589
00605         String(const char* chars, size_type chars_len)
00606         {
00607                 init();
00608                 assign(chars, chars_len);
00609         }
00610
00611
00613         // Size operations
00615
00622         size_type       size(void) const
00623         {
00624                 return d_cplength;
00625         }
00626
00634         size_type       length(void) const
00635         {
00636                 return d_cplength;
00637         }
00638
00646         bool    empty(void) const
00647         {
00648                 return  (d_cplength == 0);
00649         }
00650
00660         static size_type        max_size(void)
00661         {
00662                 return (((size_type)-1) / sizeof(utf32));
00663         }
00664
00666         // Capacity Operations
00668         // return the number of code points the string could hold without re-allocation
00669         // (due to internal encoding this will always report the figure for worst-case encoding, and could even be < size()!)
00678         size_type capacity(void) const
00679         {
00680                 return d_reserve - 1;
00681         }
00682
00683         // reserve internal memory for at-least 'num' code-points (characters).  if num is 0, request is shrink-to-fit.
00698         void    reserve(size_type num = 0)
00699         {
00700                 if (num == 0)
00701                         trim();
00702                 else
00703                         grow(num);
00704         }
00705
00707         // Comparisons
00709
00724         int             compare(const String& str) const
00725         {
00726                 return compare(0, d_cplength, str);
00727         }
00728
00758         int             compare(size_type idx, size_type len, const String& str, size_type str_idx = 0, size_type str_len = npos) const
00759         {
00760                 if ((d_cplength < idx) || (str.d_cplength < str_idx))
00761                         throw std::out_of_range("Index is out of range for CEGUI::String");
00762
00763                 if ((len == npos) || (idx + len > d_cplength))
00764                         len = d_cplength - idx;
00765
00766                 if ((str_len == npos) || (str_idx + str_len > str.d_cplength))
00767                         str_len = str.d_cplength - str_idx;
00768
00769                 int val = (len == 0) ? 0 : utf32_comp_utf32(&ptr()[idx], &str.ptr()[str_idx], (len < str_len) ? len : str_len);
00770
00771                 return (val != 0) ? ((val < 0) ? -1 : 1) : (len < str_len) ? -1 : (len == str_len) ? 0 : 1;
00772         }
00773
00774
00794         int             compare(const std::string& std_str) const
00795         {
00796                 return compare(0, d_cplength, std_str);
00797         }
00798
00799
00833         int             compare(size_type idx, size_type len, const std::string& std_str, size_type str_idx = 0, size_type str_len = npos) const
00834         {
00835                 if (d_cplength < idx)
00836                         throw std::out_of_range("Index is out of range for CEGUI::String");
00837
00838                 if (std_str.size() < str_idx)
00839                         throw std::out_of_range("Index is out of range for std::string");
00840
00841                 if ((len == npos) || (idx + len > d_cplength))
00842                         len = d_cplength - idx;
00843
00844                 if ((str_len == npos) || (str_idx + str_len > std_str.size()))
00845                         str_len = (size_type)std_str.size() - str_idx;
00846
00847                 int val = (len == 0) ? 0 : utf32_comp_char(&ptr()[idx], &std_str.c_str()[str_idx], (len < str_len) ? len : str_len);
00848
00849                 return (val != 0) ? ((val < 0) ? -1 : 1) : (len < str_len) ? -1 : (len == str_len) ? 0 : 1;
00850         }
00851
00852
00874         int             compare(const utf8* utf8_str) const
00875         {
00876                 return compare(0, d_cplength, utf8_str, encoded_size(utf8_str));
00877         }
00878
00879
00909         int             compare(size_type idx, size_type len, const utf8* utf8_str) const
00910         {
00911                 return compare(idx, len, utf8_str, encoded_size(utf8_str));
00912         }
00913
00947         int             compare(size_type idx, size_type len, const utf8* utf8_str, size_type str_cplen) const
00948         {
00949                 if (d_cplength < idx)
00950                         throw std::out_of_range("Index is out of range for CEGUI::String");
00951
00952                 if (str_cplen == npos)
00953                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
00954
00955                 if ((len == npos) || (idx + len > d_cplength))
00956                         len = d_cplength - idx;
00957
00958                 int val = (len == 0) ? 0 : utf32_comp_utf8(&ptr()[idx], utf8_str, (len < str_cplen) ? len : str_cplen);
00959
00960                 return (val != 0) ? ((val < 0) ? -1 : 1) : (len < str_cplen) ? -1 : (len == str_cplen) ? 0 : 1;
00961         }
00962
00963
00979         int             compare(const char* cstr) const
00980         {
00981                 return compare(0, d_cplength, cstr, strlen(cstr));
00982         }
00983
00984
01008         int             compare(size_type idx, size_type len, const char* cstr) const
01009         {
01010                 return compare(idx, len, cstr, strlen(cstr));
01011         }
01012
01013
01041         int             compare(size_type idx, size_type len, const char* chars, size_type chars_len) const
01042         {
01043                 if (d_cplength < idx)
01044                         throw std::out_of_range("Index is out of range for CEGUI::String");
01045
01046                 if (chars_len == npos)
01047                         throw std::length_error("Length for char array can not be 'npos'");
01048
01049                 if ((len == npos) || (idx + len > d_cplength))
01050                         len = d_cplength - idx;
01051
01052                 int val = (len == 0) ? 0 : utf32_comp_char(&ptr()[idx], chars, (len < chars_len) ? len : chars_len);
01053
01054                 return (val != 0) ? ((val < 0) ? -1 : 1) : (len < chars_len) ? -1 : (len == chars_len) ? 0 : 1;
01055         }
01056
01057
01059         // Character access
01061
01075         reference       operator[](size_type idx)
01076         {
01077                 return (ptr()[idx]);
01078         }
01079
01094         value_type      operator[](size_type idx) const
01095         {
01096                 return ptr()[idx];
01097         }
01098
01111         reference       at(size_type idx)
01112         {
01113                 if (d_cplength <= idx)
01114                         throw std::out_of_range("Index is out of range for CEGUI::String");
01115
01116                 return ptr()[idx];
01117         }
01118
01131         const_reference at(size_type idx) const
01132         {
01133                 if (d_cplength <= idx)
01134                         throw std::out_of_range("Index is out of range for CEGUI::String");
01135
01136                 return ptr()[idx];
01137         }
01138
01139
01141         // C-Strings and arrays
01143
01156         const char* c_str(void) const
01157         {
01158                 return (const char*)build_utf8_buff();
01159         }
01160
01174         const utf8* data(void) const
01175         {
01176                 return build_utf8_buff();
01177         }
01178
01179         // copy, at most, 'len' code-points of the string, begining with code-point 'idx', into the array 'buf' as valid utf8 encoded data
01180         // return number of utf8 code units placed into the buffer
01201         size_type       copy(utf8* buf, size_type len = npos, size_type idx = 0) const
01202         {
01203                 if (d_cplength < idx)
01204                         throw std::out_of_range("Index is out of range for CEGUI::String");
01205
01206                 if (len == npos)
01207                         len = d_cplength;
01208
01209                 return encode(&ptr()[idx], buf, npos, len);
01210         }
01211
01213         // UTF8 Encoding length information
01215         // return the number of bytes required to hold 'num' code-points, starting at code-point 'idx', of the the string when encoded as utf8 data.
01231         size_type       utf8_stream_len(size_type num = npos, size_type idx = 0)
01232         {
01233                 using namespace std;
01234
01235                 if (d_cplength < idx)
01236                         throw out_of_range("Index was out of range for CEGUI::String object");
01237
01238                 size_type       maxlen = d_cplength - idx;
01239
01240                 return encoded_size(&ptr()[idx], ceguimin(num, maxlen));
01241         }
01242
01244         // Assignment Functions
01246
01256         String& operator=(const String& str)
01257         {
01258                 return assign(str);
01259         }
01260
01279         String& assign(const String& str, size_type str_idx = 0, size_type str_num = npos)
01280         {
01281                 if (str.d_cplength < str_idx)
01282                         throw std::out_of_range("Index was out of range for CEGUI::String object");
01283
01284                 if (str_num == npos)
01285                         str_num = str.d_cplength - str_idx;
01286
01287                 grow(str_num);
01288                 setlen(str_num);
01289                 memcpy(ptr(), &str.ptr()[str_idx], str_num * sizeof(utf32));
01290
01291                 return *this;
01292         }
01293
01310         String& operator=(const std::string& std_str)
01311         {
01312                 return assign(std_str);
01313         }
01314
01338         String& assign(const std::string& std_str, size_type str_idx = 0, size_type str_num = npos)
01339         {
01340                 if (std_str.size() < str_idx)
01341                         throw std::out_of_range("Index was out of range for std::string object");
01342
01343                 if (str_num == npos)
01344                         str_num = (size_type)std_str.size() - str_idx;
01345
01346                 grow(str_num);
01347                 setlen(str_num);
01348
01349                 while(str_num--)
01350                 {
01351                         ((*this)[str_num]) = static_cast<utf32>(static_cast<unsigned char>(std_str[str_num + str_idx]));
01352                 }
01353
01354                 return *this;
01355         }
01356
01375         String& operator=(const utf8* utf8_str)
01376         {
01377                 return assign(utf8_str, utf_length(utf8_str));
01378         }
01379
01398         String& assign(const utf8* utf8_str)
01399         {
01400                 return assign(utf8_str, utf_length(utf8_str));
01401         }
01402
01424         String& assign(const utf8* utf8_str, size_type str_num)
01425         {
01426                 if (str_num == npos)
01427                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
01428
01429                 size_type enc_sze = encoded_size(utf8_str, str_num);
01430
01431                 grow(enc_sze);
01432                 encode(utf8_str, ptr(), d_reserve, str_num);
01433                 setlen(enc_sze);
01434                 return *this;
01435         }
01436
01447         String& operator=(utf32 code_point)
01448         {
01449                 return assign(1, code_point);
01450         }
01451
01467         String& assign(size_type num, utf32 code_point)
01468         {
01469                 if (num == npos)
01470                         throw std::length_error("Code point count can not be 'npos'");
01471
01472                 grow(num);
01473                 setlen(num);
01474                 utf32* p = ptr();
01475
01476                 while(num--)
01477                         *p++ = code_point;
01478
01479                 return *this;
01480         }
01481
01482
01495         String& operator=(const char* cstr)
01496         {
01497                 return assign(cstr, strlen(cstr));
01498         }
01499
01500
01513         String& assign(const char* cstr)
01514         {
01515                 return assign(cstr, strlen(cstr));
01516         }
01517
01518
01534         String& assign(const char* chars, size_type chars_len)
01535         {
01536                 grow(chars_len);
01537                 utf32* pt = ptr();
01538
01539                 for (size_type i = 0; i < chars_len; ++i)
01540                 {
01541                         *pt++ = static_cast<utf32>(static_cast<unsigned char>(*chars++));
01542                 }
01543
01544                 setlen(chars_len);
01545                 return *this;
01546         }
01547
01548
01559         void    swap(String& str)
01560         {
01561                 size_type       temp_len        = d_cplength;
01562                 d_cplength = str.d_cplength;
01563                 str.d_cplength = temp_len;
01564
01565                 size_type       temp_res        = d_reserve;
01566                 d_reserve = str.d_reserve;
01567                 str.d_reserve = temp_res;
01568
01569                 utf32*          temp_buf        = d_buffer;
01570                 d_buffer = str.d_buffer;
01571                 str.d_buffer = temp_buf;
01572
01573                 // see if we need to swap 'quick buffer' data
01574                 if (temp_res <= STR_QUICKBUFF_SIZE)
01575                 {
01576                         utf32           temp_qbf[STR_QUICKBUFF_SIZE];
01577
01578                         memcpy(temp_qbf, d_quickbuff, STR_QUICKBUFF_SIZE * sizeof(utf32));
01579                         memcpy(d_quickbuff, str.d_quickbuff, STR_QUICKBUFF_SIZE * sizeof(utf32));
01580                         memcpy(str.d_quickbuff, temp_qbf, STR_QUICKBUFF_SIZE * sizeof(utf32));
01581                 }
01582
01583         }
01584
01586         // Appending Functions
01588
01600         String& operator+=(const String& str)
01601         {
01602                 return append(str);
01603         }
01604
01624         String& append(const String& str, size_type str_idx = 0, size_type str_num = npos)
01625         {
01626                 if (str.d_cplength < str_idx)
01627                         throw std::out_of_range("Index is out of range for CEGUI::String");
01628
01629                 if (str_num == npos)
01630                         str_num = str.d_cplength - str_idx;
01631
01632                 grow(d_cplength + str_num);
01633                 memcpy(&ptr()[d_cplength], &str.ptr()[str_idx], str_num * sizeof(utf32));
01634                 setlen(d_cplength + str_num);
01635                 return *this;
01636         }
01637
01638
01655         String& operator+=(const std::string& std_str)
01656         {
01657                 return append(std_str);
01658         }
01659
01683         String& append(const std::string& std_str, size_type str_idx = 0, size_type str_num = npos)
01684         {
01685                 if (std_str.size() < str_idx)
01686                         throw std::out_of_range("Index is out of range for std::string");
01687
01688                 if (str_num == npos)
01689                         str_num = (size_type)std_str.size() - str_idx;
01690
01691                 size_type newsze = d_cplength + str_num;
01692
01693                 grow(newsze);
01694                 utf32* pt = &ptr()[newsze-1];
01695
01696                 while(str_num--)
01697                         *pt-- = static_cast<utf32>(static_cast<unsigned char>(std_str[str_num]));
01698
01699                 setlen(newsze);
01700                 return *this;
01701         }
01702
01703
01722         String& operator+=(const utf8* utf8_str)
01723         {
01724                 return append(utf8_str, utf_length(utf8_str));
01725         }
01726
01745         String& append(const utf8* utf8_str)
01746         {
01747                 return append(utf8_str, utf_length(utf8_str));
01748         }
01749
01750
01772         String& append(const utf8* utf8_str, size_type len)
01773         {
01774                 if (len == npos)
01775                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
01776
01777                 size_type encsz = encoded_size(utf8_str, len);
01778                 size_type newsz = d_cplength + encsz;
01779
01780                 grow(newsz);
01781                 encode(utf8_str, &ptr()[d_cplength], encsz, len);
01782                 setlen(newsz);
01783
01784                 return *this;
01785         }
01786
01787
01800         String& operator+=(utf32 code_point)
01801         {
01802                 return append(1, code_point);
01803         }
01804
01820         String& append(size_type num, utf32 code_point)
01821         {
01822                 if (num == npos)
01823                         throw std::length_error("Code point count can not be 'npos'");
01824
01825                 size_type newsz = d_cplength + num;
01826                 grow(newsz);
01827
01828                 utf32* p = &ptr()[d_cplength];
01829
01830                 while(num--)
01831                         *p++ = code_point;
01832
01833                 setlen(newsz);
01834
01835                 return *this;
01836         }
01837
01850         void    push_back(utf32 code_point)
01851         {
01852                 append(1, code_point);
01853         }
01854
01870         String& append(const_iterator iter_beg, const_iterator iter_end)
01871         {
01872                 return replace(end(), end(), iter_beg, iter_end);
01873         }
01874
01875
01888         String& operator+=(const char* cstr)
01889         {
01890                 return append(cstr, strlen(cstr));
01891         }
01892
01893
01906         String& append(const char* cstr)
01907         {
01908                 return append(cstr, strlen(cstr));
01909         }
01910
01911
01927         String& append(const char* chars, size_type chars_len)
01928         {
01929                 if (chars_len == npos)
01930                         throw std::length_error("Length for char array can not be 'npos'");
01931
01932                 size_type newsz = d_cplength + chars_len;
01933
01934                 grow(newsz);
01935
01936                 utf32* pt = &ptr()[newsz-1];
01937
01938                 while(chars_len--)
01939                         *pt-- = static_cast<utf32>(static_cast<unsigned char>(chars[chars_len]));
01940
01941                 setlen(newsz);
01942
01943                 return *this;
01944         }
01945
01946
01948         // Insertion Functions
01950
01966         String& insert(size_type idx, const String& str)
01967         {
01968                 return insert(idx, str, 0, npos);
01969         }
01970
01993         String& insert(size_type idx, const String& str, size_type str_idx, size_type str_num)
01994         {
01995                 if ((d_cplength < idx) || (str.d_cplength < str_idx))
01996                         throw std::out_of_range("Index is out of range for CEGUI::String");
01997
01998                 if (str_num == npos)
01999                         str_num = str.d_cplength - str_idx;
02000
02001                 size_type newsz = d_cplength + str_num;
02002                 grow(newsz);
02003                 memmove(&ptr()[idx + str_num], &ptr()[idx], (d_cplength - idx) * sizeof(utf32));
02004                 memcpy(&ptr()[idx], &str.ptr()[str_idx], str_num * sizeof(utf32));
02005                 setlen(newsz);
02006
02007                 return *this;
02008         }
02009
02030         String& insert(size_type idx, const std::string& std_str)
02031         {
02032                 return insert(idx, std_str, 0, npos);
02033         }
02034
02061         String& insert(size_type idx, const std::string& std_str, size_type str_idx, size_type str_num)
02062         {
02063                 if (d_cplength < idx)
02064                         throw std::out_of_range("Index is out of range for CEGUI::String");
02065
02066                 if (std_str.size() < str_idx)
02067                         throw std::out_of_range("Index is out of range for std::string");
02068
02069                 if (str_num == npos)
02070                         str_num = (size_type)std_str.size() - str_idx;
02071
02072                 size_type newsz = d_cplength + str_num;
02073                 grow(newsz);
02074
02075                 memmove(&ptr()[idx + str_num], &ptr()[idx], (d_cplength - idx) * sizeof(utf32));
02076
02077                 utf32* pt = &ptr()[idx + str_num - 1];
02078
02079                 while(str_num--)
02080                         *pt-- = static_cast<utf32>(static_cast<unsigned char>(std_str[str_idx + str_num]));
02081
02082                 setlen(newsz);
02083
02084                 return *this;
02085         }
02086
02109         String& insert(size_type idx, const utf8* utf8_str)
02110         {
02111                 return insert(idx, utf8_str, utf_length(utf8_str));
02112         }
02113
02139         String& insert(size_type idx, const utf8* utf8_str, size_type len)
02140         {
02141                 if (d_cplength < idx)
02142                         throw std::out_of_range("Index is out of range for CEGUI::String");
02143
02144                 if (len == npos)
02145                         throw std::length_error("Length of utf8 encoded string can not be 'npos'");
02146
02147                 size_type encsz = encoded_size(utf8_str, len);
02148                 size_type newsz = d_cplength + encsz;
02149
02150                 grow(newsz);
02151                 memmove(&ptr()[idx + encsz], &ptr()[idx], (d_cplength - idx) * sizeof(utf32));
02152                 encode(utf8_str, &ptr()[idx], encsz, len);
02153                 setlen(newsz);
02154
02155                 return *this;
02156         }
02157
02177         String& insert(size_type idx, size_type num, utf32 code_point)
02178         {
02179                 if (d_cplength < idx)
02180                         throw std::out_of_range("Index is out of range for CEGUI::String");
02181
02182                 if (num == npos)
02183                         throw std::length_error("Code point count can not be 'npos'");
02184
02185                 size_type newsz = d_cplength + num;
02186                 grow(newsz);
02187
02188                 memmove(&ptr()[idx + num], &ptr()[idx], (d_cplength - idx) * sizeof(utf32));
02189
02190                 utf32* pt = &ptr()[idx + num - 1];
02191
02192                 while(num--)
02193                         *pt-- = code_point;
02194
02195                 setlen(newsz);
02196
02197                 return *this;
02198         }
02199
02218         void insert(iterator pos, size_type num, utf32 code_point)
02219         {
02220                 insert(safe_iter_dif(pos, begin()), num, code_point);
02221         }
02222
02238         iterator insert(iterator pos, utf32 code_point)
02239         {
02240                 insert(pos, 1, code_point);
02241                 return pos;
02242         }
02243
02262         void    insert(iterator iter_pos, const_iterator iter_beg, const_iterator iter_end)
02263         {
02264                 replace(iter_pos, iter_pos, iter_beg, iter_end);
02265         }
02266
02267
02284         String& insert(size_type idx, const char* cstr)
02285         {
02286                 return insert(idx, cstr, strlen(cstr));
02287         }
02288
02289
02309         String& insert(size_type idx, const char* chars, size_type chars_len)
02310         {
02311                 if (d_cplength < idx)
02312                         throw std::out_of_range("Index is out of range for CEGUI::String");
02313
02314                 if (chars_len == npos)
02315                         throw std::length_error("Length of char array can not be 'npos'");
02316
02317                 size_type newsz = d_cplength + chars_len;
02318
02319                 grow(newsz);
02320                 memmove(&ptr()[idx + chars_len], &ptr()[idx], (d_cplength - idx) * sizeof(utf32));
02321
02322                 utf32* pt = &ptr()[idx + chars_len - 1];
02323
02324                 while(chars_len--)
02325                         *pt-- = static_cast<utf32>(static_cast<unsigned char>(chars[chars_len]));
02326
02327                 setlen(newsz);
02328
02329                 return *this;
02330         }
02331
02332
02334         // Erasing characters
02336
02343         void    clear(void)
02344         {
02345                 setlen(0);
02346                 trim();
02347         }
02348
02356         String& erase(void)
02357         {
02358                 clear();
02359                 return *this;
02360         }
02361
02374         String& erase(size_type idx)
02375         {
02376                 return erase(idx, 1);
02377         }
02378
02394         String& erase(size_type idx, size_type len = npos)
02395         {
02396                 if (d_cplength < idx)
02397                         throw std::out_of_range("Index is out of range foe CEGUI::String");
02398
02399                 if (len == npos)
02400                         len = d_cplength - idx;
02401
02402                 size_type newsz = d_cplength - len;
02403
02404                 memmove(&ptr()[idx], &ptr()[idx + len], (d_cplength - idx - len) * sizeof(utf32));
02405                 setlen(newsz);
02406                 return  *this;
02407         }
02408
02419         String& erase(iterator pos)
02420         {
02421                 return erase(safe_iter_dif(pos, begin()), 1);
02422         }
02423
02437         String& erase(iterator iter_beg, iterator iter_end)
02438         {
02439                 return erase(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg));
02440         }
02441
02443         // Resizing
02445
02457         void    resize(size_type num)
02458         {
02459                 resize(num, utf32());
02460         }
02461
02477         void    resize(size_type num, utf32 code_point)
02478         {
02479                 if (num < d_cplength)
02480                 {
02481                         setlen(num);
02482                 }
02483                 else
02484                 {
02485                         append(num - d_cplength, code_point);
02486                 }
02487
02488         }
02489
02491         // Replacing Characters
02493
02512         String& replace(size_type idx, size_type len, const String& str)
02513         {
02514                 return replace(idx, len, str, 0, npos);
02515         }
02516
02538         String& replace(iterator iter_beg, iterator iter_end, const String& str)
02539         {
02540                 return replace(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg), str, 0, npos);
02541         }
02542
02568         String& replace(size_type idx, size_type len, const String& str, size_type str_idx, size_type str_num)
02569         {
02570                 if ((d_cplength < idx) || (str.d_cplength < str_idx))
02571                         throw std::out_of_range("Index is out of range for CEGUI::String");
02572
02573                 if (((str_idx + str_num) > str.d_cplength) || (str_num == npos))
02574                         str_num = str.d_cplength - str_idx;
02575
02576                 if (((len + idx) > d_cplength) || (len == npos))
02577                         len = d_cplength - idx;
02578
02579                 size_type newsz = d_cplength + str_num - len;
02580
02581                 grow(newsz);
02582
02583                 if ((idx + len) < d_cplength)
02584                         memmove(&ptr()[idx + str_num], &ptr()[len + idx], (d_cplength - idx - len) * sizeof(utf32));
02585
02586                 memcpy(&ptr()[idx], &str.ptr()[str_idx], str_num * sizeof(utf32));
02587                 setlen(newsz);
02588
02589                 return *this;
02590         }
02591
02592
02616         String& replace(size_type idx, size_type len, const std::string& std_str)
02617         {
02618                 return replace(idx, len, std_str, 0, npos);
02619         }
02620
02646         String& replace(iterator iter_beg, iterator iter_end, const std::string& std_str)
02647         {
02648                 return replace(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg), std_str, 0, npos);
02649         }
02650
02680         String& replace(size_type idx, size_type len, const std::string& std_str, size_type str_idx, size_type str_num)
02681         {
02682                 if (d_cplength < idx)
02683                         throw std::out_of_range("Index is out of range for CEGUI::String");
02684
02685                 if (std_str.size() < str_idx)
02686                         throw std::out_of_range("Index is out of range for std::string");
02687
02688                 if (((str_idx + str_num) > std_str.size()) || (str_num == npos))
02689                         str_num = (size_type)std_str.size() - str_idx;
02690
02691                 if (((len + idx) > d_cplength) || (len == npos))
02692                         len = d_cplength - idx;
02693
02694                 size_type newsz = d_cplength + str_num - len;
02695
02696                 grow(newsz);
02697
02698                 if ((idx + len) < d_cplength)
02699                         memmove(&ptr()[idx + str_num], &ptr()[len + idx], (d_cplength - idx - len) * sizeof(utf32));
02700
02701                 utf32* pt = &ptr()[idx + str_num - 1];
02702
02703                 while (str_num--)
02704                         *pt-- = static_cast<utf32>(static_cast<unsigned char>(std_str[str_idx + str_num]));
02705
02706                 setlen(newsz);
02707
02708                 return *this;
02709         }
02710
02711
02737         String& replace(size_type idx, size_type len, const utf8* utf8_str)
02738         {
02739                 return replace(idx, len, utf8_str, utf_length(utf8_str));
02740         }
02741
02769         String& replace(iterator iter_beg, iterator iter_end, const utf8* utf8_str)
02770         {
02771                 return replace(iter_beg, iter_end, utf8_str, utf_length(utf8_str));
02772         }
02773
02802         String& replace(size_type idx, size_type len, const utf8* utf8_str, size_type str_len)
02803         {
02804                 if (d_cplength < idx)
02805                         throw std::out_of_range("Index is out of range for CEGUI::String");
02806
02807                 if (str_len == npos)
02808                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
02809
02810                 if (((len + idx) > d_cplength) || (len == npos))
02811                         len = d_cplength - idx;
02812
02813                 size_type encsz = encoded_size(utf8_str, str_len);
02814                 size_type newsz = d_cplength + encsz - len;
02815
02816                 grow(newsz);
02817
02818                 if ((idx + len) < d_cplength)
02819                         memmove(&ptr()[idx + encsz], &ptr()[len + idx], (d_cplength - idx - len) * sizeof(utf32));
02820
02821                 encode(utf8_str, &ptr()[idx], encsz, str_len);
02822
02823                 setlen(newsz);
02824                 return *this;
02825         }
02826
02857         String& replace(iterator iter_beg, iterator iter_end, const utf8* utf8_str, size_type str_len)
02858         {
02859                 return replace(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg), utf8_str, str_len);
02860         }
02861
02884         String& replace(size_type idx, size_type len, size_type num, utf32 code_point)
02885         {
02886                 if (d_cplength < idx)
02887                         throw std::out_of_range("Index is out of range for CEGUI::String");
02888
02889                 if (num == npos)
02890                         throw std::length_error("Code point count can not be 'npos'");
02891
02892                 if (((len + idx) > d_cplength) || (len == npos))
02893                         len = d_cplength - idx;
02894
02895                 size_type newsz = d_cplength + num - len;
02896
02897                 grow(newsz);
02898
02899                 if ((idx + len) < d_cplength)
02900                         memmove(&ptr()[idx + num], &ptr()[len + idx], (d_cplength - idx - len) * sizeof(utf32));
02901
02902                 utf32* pt = &ptr()[idx + num - 1];
02903
02904                 while (num--)
02905                         *pt-- = code_point;
02906
02907                 setlen(newsz);
02908
02909                 return *this;
02910         }
02911
02936         String& replace(iterator iter_beg, iterator iter_end, size_type num, utf32 code_point)
02937         {
02938                 return replace(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg), num, code_point);
02939         }
02940
02941
02966         String& replace(iterator iter_beg, iterator iter_end, const_iterator iter_newBeg, const_iterator iter_newEnd)
02967         {
02968                 if (iter_beg == iter_end)
02969                 {
02970                         erase(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg));
02971                 }
02972                 else
02973                 {
02974                         size_type str_len = safe_iter_dif(iter_newEnd, iter_newBeg);
02975                         size_type idx = safe_iter_dif(iter_beg, begin());
02976                         size_type len = safe_iter_dif(iter_end, iter_beg);
02977
02978                         if ((len + idx) > d_cplength)
02979                                 len = d_cplength - idx;
02980
02981                         size_type newsz = d_cplength + str_len - len;
02982
02983                         grow(newsz);
02984
02985                         if ((idx + len) < d_cplength)
02986                                 memmove(&ptr()[idx + str_len], &ptr()[len + idx], (d_cplength - idx - len) * sizeof(utf32));
02987
02988                         memcpy(&ptr()[idx], iter_newBeg.d_ptr, str_len * sizeof(utf32));
02989                         setlen(newsz);
02990                 }
02991
02992                 return *this;
02993         }
02994
02995
03015         String& replace(size_type idx, size_type len, const char* cstr)
03016         {
03017                 return replace(idx, len, cstr, strlen(cstr));
03018         }
03019
03020
03042         String& replace(iterator iter_beg, iterator iter_end, const char* cstr)
03043         {
03044                 return replace(iter_beg, iter_end, cstr, strlen(cstr));
03045         }
03046
03047
03070         String& replace(size_type idx, size_type len, const char* chars, size_type chars_len)
03071         {
03072                 if (d_cplength < idx)
03073                         throw std::out_of_range("Index is out of range for CEGUI::String");
03074
03075                 if (chars_len == npos)
03076                         throw std::length_error("Length for the char array can not be 'npos'");
03077
03078                 if (((len + idx) > d_cplength) || (len == npos))
03079                         len = d_cplength - idx;
03080
03081                 size_type newsz = d_cplength + chars_len - len;
03082
03083                 grow(newsz);
03084
03085                 if ((idx + len) < d_cplength)
03086                         memmove(&ptr()[idx + chars_len], &ptr()[len + idx], (d_cplength - idx - len) * sizeof(utf32));
03087
03088                 utf32* pt = &ptr()[idx + chars_len - 1];
03089
03090                 while (chars_len--)
03091                         *pt-- = static_cast<utf32>(static_cast<unsigned char>(chars[chars_len]));
03092
03093                 setlen(newsz);
03094                 return *this;
03095         }
03096
03097
03122         String& replace(iterator iter_beg, iterator iter_end, const char* chars, size_type chars_len)
03123         {
03124                 return replace(safe_iter_dif(iter_beg, begin()), safe_iter_dif(iter_end, iter_beg), chars, chars_len);
03125         }
03126
03127
03129         // Find a code point
03131
03145         size_type       find(utf32 code_point, size_type idx = 0) const
03146         {
03147                 if (idx < d_cplength)
03148                 {
03149                         const utf32* pt = &ptr()[idx];
03150
03151                         while (idx < d_cplength)
03152                         {
03153                                 if (*pt++ == code_point)
03154                                         return idx;
03155
03156                                 ++idx;
03157                         }
03158
03159                 }
03160
03161                 return npos;
03162         }
03163
03178         size_type       rfind(utf32 code_point, size_type idx = npos) const
03179         {
03180                 if (idx >= d_cplength)
03181                         idx = d_cplength - 1;
03182
03183                 if (d_cplength > 0)
03184                 {
03185                         const utf32* pt = &ptr()[idx];
03186
03187                         do
03188                         {
03189                                 if (*pt-- == code_point)
03190                                         return idx;
03191
03192                         } while (idx-- != 0);
03193
03194                 }
03195
03196                 return npos;
03197         }
03198
03200         // Find a substring
03202
03216         size_type       find(const String& str, size_type idx = 0) const
03217         {
03218                 if ((str.d_cplength == 0) && (idx < d_cplength))
03219                         return idx;
03220
03221                 if (idx < d_cplength)
03222                 {
03223                         // loop while search string could fit in to search area
03224                         while (d_cplength - idx >= str.d_cplength)
03225                         {
03226                                 if (0 == compare(idx, str.d_cplength, str))
03227                                         return idx;
03228
03229                                 ++idx;
03230                         }
03231
03232                 }
03233
03234                 return npos;
03235         }
03236
03251         size_type       rfind(const String& str, size_type idx = npos) const
03252         {
03253                 if (str.d_cplength == 0)
03254                         return (idx < d_cplength) ? idx : d_cplength;
03255
03256                 if (str.d_cplength <= d_cplength)
03257                 {
03258                         if (idx > (d_cplength - str.d_cplength))
03259                                 idx = d_cplength - str.d_cplength;
03260
03261                         do
03262                         {
03263                                 if (0 == compare(idx, str.d_cplength, str))
03264                                         return idx;
03265
03266                         } while (idx-- != 0);
03267
03268                 }
03269
03270                 return npos;
03271         }
03272
03291         size_type       find(const std::string& std_str, size_type idx = 0) const
03292         {
03293                 std::string::size_type sze = std_str.size();
03294
03295                 if ((sze == 0) && (idx < d_cplength))
03296                         return idx;
03297
03298                 if (idx < d_cplength)
03299                 {
03300                         // loop while search string could fit in to search area
03301                         while (d_cplength - idx >= sze)
03302                         {
03303                                 if (0 == compare(idx, (size_type)sze, std_str))
03304                                         return idx;
03305
03306                                 ++idx;
03307                         }
03308
03309                 }
03310
03311                 return npos;
03312         }
03313
03332         size_type       rfind(const std::string& std_str, size_type idx = npos) const
03333         {
03334                 std::string::size_type sze = std_str.size();
03335
03336                 if (sze == 0)
03337                         return (idx < d_cplength) ? idx : d_cplength;
03338
03339                 if (sze <= d_cplength)
03340                 {
03341                         if (idx > (d_cplength - sze))
03342                                 idx = d_cplength - sze;
03343
03344                         do
03345                         {
03346                                 if (0 == compare(idx, (size_type)sze, std_str))
03347                                         return idx;
03348
03349                         } while (idx-- != 0);
03350
03351                 }
03352
03353                 return npos;
03354         }
03355
03378         size_type       find(const utf8* utf8_str, size_type idx = 0) const
03379         {
03380                 return find(utf8_str, idx, utf_length(utf8_str));
03381         }
03382
03405         size_type       rfind(const utf8* utf8_str, size_type idx = npos) const
03406         {
03407                 return rfind(utf8_str, idx, utf_length(utf8_str));
03408         }
03409
03435         size_type       find(const utf8* utf8_str, size_type idx, size_type str_len) const
03436         {
03437                 if (str_len == npos)
03438                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
03439
03440                 size_type sze = encoded_size(utf8_str, str_len);
03441
03442                 if ((sze == 0) && (idx < d_cplength))
03443                         return idx;
03444
03445                 if (idx < d_cplength)
03446                 {
03447                         // loop while search string could fit in to search area
03448                         while (d_cplength - idx >= sze)
03449                         {
03450                                 if (0 == compare(idx, sze, utf8_str, sze))
03451                                         return idx;
03452
03453                                 ++idx;
03454                         }
03455
03456                 }
03457
03458                 return npos;
03459         }
03460
03486         size_type       rfind(const utf8* utf8_str, size_type idx, size_type str_len) const
03487         {
03488                 if (str_len == npos)
03489                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
03490
03491                 size_type sze = encoded_size(utf8_str, str_len);
03492
03493                 if (sze == 0)
03494                         return (idx < d_cplength) ? idx : d_cplength;
03495
03496                 if (sze <= d_cplength)
03497                 {
03498                         if (idx > (d_cplength - sze))
03499                                 idx = d_cplength - sze;
03500
03501                         do
03502                         {
03503                                 if (0 == compare(idx, sze, utf8_str, sze))
03504                                         return idx;
03505
03506                         } while (idx-- != 0);
03507
03508                 }
03509
03510                 return npos;
03511         }
03512
03513
03530         size_type       find(const char* cstr, size_type idx = 0) const
03531         {
03532                 return find(cstr, idx, strlen(cstr));
03533         }
03534
03535
03552         size_type       rfind(const char* cstr, size_type idx = npos) const
03553         {
03554                 return rfind(cstr, idx, strlen(cstr));
03555         }
03556
03557
03577         size_type       find(const char* chars, size_type idx, size_type chars_len) const
03578         {
03579                 if (chars_len == npos)
03580                         throw std::length_error("Length for char array can not be 'npos'");
03581
03582                 if ((chars_len == 0) && (idx < d_cplength))
03583                         return idx;
03584
03585                 if (idx < d_cplength)
03586                 {
03587                         // loop while search string could fit in to search area
03588                         while (d_cplength - idx >= chars_len)
03589                         {
03590                                 if (0 == compare(idx, chars_len, chars, chars_len))
03591                                         return idx;
03592
03593                                 ++idx;
03594                         }
03595
03596                 }
03597
03598                 return npos;
03599         }
03600
03601
03621         size_type       rfind(const char* chars, size_type idx, size_type chars_len) const
03622         {
03623                 if (chars_len == npos)
03624                         throw std::length_error("Length for char array can not be 'npos'");
03625
03626                 if (chars_len == 0)
03627                         return (idx < d_cplength) ? idx : d_cplength;
03628
03629                 if (chars_len <= d_cplength)
03630                 {
03631                         if (idx > (d_cplength - chars_len))
03632                                 idx = d_cplength - chars_len;
03633
03634                         do
03635                         {
03636                                 if (0 == compare(idx, chars_len, chars, chars_len))
03637                                         return idx;
03638
03639                         } while (idx-- != 0);
03640
03641                 }
03642
03643                 return npos;
03644         }
03645
03646
03648         // Find first of different code-points
03650
03664         size_type       find_first_of(const String& str, size_type idx = 0) const
03665         {
03666                 if (idx < d_cplength)
03667                 {
03668                         const utf32* pt = &ptr()[idx];
03669
03670                         do
03671                         {
03672                                 if (npos != str.find(*pt++))
03673                                         return idx;
03674
03675                         } while (++idx != d_cplength);
03676
03677                 }
03678
03679                 return npos;
03680         }
03681
03696         size_type       find_first_not_of(const String& str, size_type idx = 0) const
03697         {
03698                 if (idx < d_cplength)
03699                 {
03700                         const utf32* pt = &ptr()[idx];
03701
03702                         do
03703                         {
03704                                 if (npos == str.find(*pt++))
03705                                         return idx;
03706
03707                         } while (++idx != d_cplength);
03708
03709                 }
03710
03711                 return npos;
03712         }
03713
03714
03733         size_type       find_first_of(const std::string& std_str, size_type idx = 0) const
03734         {
03735                 if (idx < d_cplength)
03736                 {
03737                         const utf32* pt = &ptr()[idx];
03738
03739                         do
03740                         {
03741                                 if (npos != find_codepoint(std_str, *pt++))
03742                                         return idx;
03743
03744                         } while (++idx != d_cplength);
03745
03746                 }
03747
03748                 return npos;
03749         }
03750
03769         size_type       find_first_not_of(const std::string& std_str, size_type idx = 0) const
03770         {
03771                 if (idx < d_cplength)
03772                 {
03773                         const utf32* pt = &ptr()[idx];
03774
03775                         do
03776                         {
03777                                 if (npos == find_codepoint(std_str, *pt++))
03778                                         return idx;
03779
03780                         } while (++idx != d_cplength);
03781
03782                 }
03783
03784                 return npos;
03785         }
03786
03787
03810         size_type       find_first_of(const utf8* utf8_str, size_type idx = 0) const
03811         {
03812                 return find_first_of(utf8_str, idx, utf_length(utf8_str));
03813         }
03814
03837         size_type       find_first_not_of(const utf8* utf8_str, size_type idx = 0) const
03838         {
03839                 return find_first_not_of(utf8_str, idx, utf_length(utf8_str));
03840         }
03841
03867         size_type       find_first_of(const utf8* utf8_str, size_type idx, size_type str_len) const
03868         {
03869                 if (str_len == npos)
03870                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
03871
03872                 if (idx < d_cplength)
03873                 {
03874                         size_type encsze = encoded_size(utf8_str, str_len);
03875
03876                         const utf32* pt = &ptr()[idx];
03877
03878                         do
03879                         {
03880                                 if (npos != find_codepoint(utf8_str, encsze, *pt++))
03881                                         return idx;
03882
03883                         } while (++idx != d_cplength);
03884
03885                 }
03886
03887                 return npos;
03888         }
03889
03915         size_type       find_first_not_of(const utf8* utf8_str, size_type idx, size_type str_len) const
03916         {
03917                 if (str_len == npos)
03918                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
03919
03920                 if (idx < d_cplength)
03921                 {
03922                         size_type encsze = encoded_size(utf8_str, str_len);
03923
03924                         const utf32* pt = &ptr()[idx];
03925
03926                         do
03927                         {
03928                                 if (npos == find_codepoint(utf8_str, encsze, *pt++))
03929                                         return idx;
03930
03931                         } while (++idx != d_cplength);
03932
03933                 }
03934
03935                 return npos;
03936         }
03937
03938
03953         size_type       find_first_of(utf32 code_point, size_type idx = 0) const
03954         {
03955                 return find(code_point, idx);
03956         }
03957
03974         size_type       find_first_not_of(utf32 code_point, size_type idx = 0) const
03975         {
03976                 if (idx < d_cplength)
03977                 {
03978                         do
03979                         {
03980                                 if ((*this)[idx] != code_point)
03981                                         return idx;
03982
03983                         } while(idx++ < d_cplength);
03984
03985                 }
03986
03987                 return npos;
03988         }
03989
03990
04007         size_type       find_first_of(const char* cstr, size_type idx = 0) const
04008         {
04009                 return find_first_of(cstr, idx, strlen(cstr));
04010         }
04011
04012
04029         size_type       find_first_not_of(const char* cstr, size_type idx = 0) const
04030         {
04031                 return find_first_not_of(cstr, idx, strlen(cstr));
04032         }
04033
04034
04054         size_type       find_first_of(const char* chars, size_type idx, size_type chars_len) const
04055         {
04056                 if (chars_len == npos)
04057                         throw std::length_error("Length for char array can not be 'npos'");
04058
04059                 if (idx < d_cplength)
04060                 {
04061                         const utf32* pt = &ptr()[idx];
04062
04063                         do
04064                         {
04065                                 if (npos != find_codepoint(chars, chars_len, *pt++))
04066                                         return idx;
04067
04068                         } while (++idx != d_cplength);
04069
04070                 }
04071
04072                 return npos;
04073         }
04074
04075
04095         size_type       find_first_not_of(const char* chars, size_type idx, size_type chars_len) const
04096         {
04097                 if (chars_len == npos)
04098                         throw std::length_error("Length for char array can not be 'npos'");
04099
04100                 if (idx < d_cplength)
04101                 {
04102                         const utf32* pt = &ptr()[idx];
04103
04104                         do
04105                         {
04106                                 if (npos == find_codepoint(chars, chars_len, *pt++))
04107                                         return idx;
04108
04109                         } while (++idx != d_cplength);
04110
04111                 }
04112
04113                 return npos;
04114         }
04115
04116
04118         // Find last of different code-points
04120
04134         size_type       find_last_of(const String& str, size_type idx = npos) const
04135         {
04136                 if (d_cplength > 0)
04137                 {
04138                         if (idx >= d_cplength)
04139                                 idx = d_cplength - 1;
04140
04141                         const utf32* pt = &ptr()[idx];
04142
04143                         do
04144                         {
04145                                 if (npos != str.find(*pt--))
04146                                         return idx;
04147
04148                         } while (idx-- != 0);
04149
04150                 }
04151
04152                 return npos;
04153         }
04154
04169         size_type       find_last_not_of(const String& str, size_type idx = npos) const
04170         {
04171                 if (d_cplength > 0)
04172                 {
04173                         if (idx >= d_cplength)
04174                                 idx = d_cplength - 1;
04175
04176                         const utf32* pt = &ptr()[idx];
04177
04178                         do
04179                         {
04180                                 if (npos == str.find(*pt--))
04181                                         return idx;
04182
04183                         } while (idx-- != 0);
04184
04185                 }
04186
04187                 return npos;
04188         }
04189
04190
04209         size_type       find_last_of(const std::string& std_str, size_type idx = npos) const
04210         {
04211                 if (d_cplength > 0)
04212                 {
04213                         if (idx >= d_cplength)
04214                                 idx = d_cplength - 1;
04215
04216                         const utf32* pt = &ptr()[idx];
04217
04218                         do
04219                         {
04220                                 if (npos != find_codepoint(std_str, *pt--))
04221                                         return idx;
04222
04223                         } while (idx-- != 0);
04224
04225                 }
04226
04227                 return npos;
04228         }
04229
04248         size_type       find_last_not_of(const std::string& std_str, size_type idx = npos) const
04249         {
04250                 if (d_cplength > 0)
04251                 {
04252                         if (idx >= d_cplength)
04253                                 idx = d_cplength - 1;
04254
04255                         const utf32* pt = &ptr()[idx];
04256
04257                         do
04258                         {
04259                                 if (npos == find_codepoint(std_str, *pt--))
04260                                         return idx;
04261
04262                         } while (idx-- != 0);
04263
04264                 }
04265
04266                 return npos;
04267         }
04268
04269
04292         size_type       find_last_of(const utf8* utf8_str, size_type idx = npos) const
04293         {
04294                 return find_last_of(utf8_str, idx, utf_length(utf8_str));
04295         }
04296
04319         size_type       find_last_not_of(const utf8* utf8_str, size_type idx = npos) const
04320         {
04321                 return find_last_not_of(utf8_str, idx, utf_length(utf8_str));
04322         }
04323
04349         size_type       find_last_of(const utf8* utf8_str, size_type idx, size_type str_len) const
04350         {
04351                 if (str_len == npos)
04352                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
04353
04354                 if (d_cplength > 0)
04355                 {
04356                         if (idx >= d_cplength)
04357                                 idx = d_cplength - 1;
04358
04359                         size_type encsze = encoded_size(utf8_str, str_len);
04360
04361                         const utf32* pt = &ptr()[idx];
04362
04363                         do
04364                         {
04365                                 if (npos != find_codepoint(utf8_str, encsze, *pt--))
04366                                         return idx;
04367
04368                         } while (idx-- != 0);
04369
04370                 }
04371
04372                 return npos;
04373         }
04374
04400         size_type       find_last_not_of(const utf8* utf8_str, size_type idx, size_type str_len) const
04401         {
04402                 if (str_len == npos)
04403                         throw std::length_error("Length for utf8 encoded string can not be 'npos'");
04404
04405                 if (d_cplength > 0)
04406                 {
04407                         if (idx >= d_cplength)
04408                                 idx = d_cplength - 1;
04409
04410                         size_type encsze = encoded_size(utf8_str, str_len);
04411
04412                         const utf32* pt = &ptr()[idx];
04413
04414                         do
04415                         {
04416                                 if (npos == find_codepoint(utf8_str, encsze, *pt--))
04417                                         return idx;
04418
04419                         } while (idx-- != 0);
04420
04421                 }
04422
04423                 return npos;
04424         }
04425
04426
04441         size_type       find_last_of(utf32 code_point, size_type idx = npos) const
04442         {
04443                 return rfind(code_point, idx);
04444         }
04445
04460         size_type       find_last_not_of(utf32 code_point, size_type idx = npos) const
04461         {
04462                 if (d_cplength > 0)
04463                 {
04464                         if (idx >= d_cplength)
04465                                 idx = d_cplength - 1;
04466
04467                         do
04468                         {
04469                                 if ((*this)[idx] != code_point)
04470                                         return idx;
04471
04472                         } while(idx-- != 0);
04473
04474                 }
04475
04476                 return npos;
04477         }
04478
04479
04496         size_type       find_last_of(const char* cstr, size_type idx = npos) const
04497         {
04498                 return find_last_of(cstr, idx, strlen(cstr));
04499         }
04500
04501
04518         size_type       find_last_not_of(const char* cstr, size_type idx = npos) const
04519         {
04520                 return find_last_not_of(cstr, idx, strlen(cstr));
04521         }
04522
04523
04543         size_type       find_last_of(const char* chars, size_type idx, size_type chars_len) const
04544         {
04545                 if (chars_len == npos)
04546                         throw std::length_error("Length for char array can not be 'npos'");
04547
04548                 if (d_cplength > 0)
04549                 {
04550                         if (idx >= d_cplength)
04551                                 idx = d_cplength - 1;
04552
04553                         const utf32* pt = &ptr()[idx];
04554
04555                         do
04556                         {
04557                                 if (npos != find_codepoint(chars, chars_len, *pt--))
04558                                         return idx;
04559
04560                         } while (idx-- != 0);
04561
04562                 }
04563
04564                 return npos;
04565         }
04566
04567
04587         size_type       find_last_not_of(const char* chars, size_type idx, size_type chars_len) const
04588         {
04589                 if (chars_len == npos)
04590                         throw std::length_error("Length for char array can not be 'npos'");
04591
04592                 if (d_cplength > 0)
04593                 {
04594                         if (idx >= d_cplength)
04595                                 idx = d_cplength - 1;
04596
04597                         const utf32* pt = &ptr()[idx];
04598
04599                         do
04600                         {
04601                                 if (npos == find_codepoint(chars, chars_len, *pt--))
04602                                         return idx;
04603
04604                         } while (idx-- != 0);
04605
04606                 }
04607
04608                 return npos;
04609         }
04610
04611
04613         // Substring
04615
04630         String  substr(size_type idx = 0, size_type len = npos) const
04631         {
04632                 if (d_cplength < idx)
04633                         throw std::out_of_range("Index is out of range for this CEGUI::String");
04634
04635                 return String(*this, idx, len);
04636         }
04637
04639         // Iterator creation
04641
04648         iterator                begin(void)
04649         {
04650                 return iterator(ptr());
04651         }
04652
04660         const_iterator  begin(void) const
04661         {
04662                 return const_iterator(ptr());
04663         }
04664
04672         iterator                end(void)
04673         {
04674                 return iterator(&ptr()[d_cplength]);
04675         }
04676
04684         const_iterator  end(void) const
04685         {
04686                 return const_iterator(&ptr()[d_cplength]);
04687         }
04688
04696         reverse_iterator                rbegin(void)
04697         {
04698                 return reverse_iterator(end());
04699         }
04700
04708         const_reverse_iterator  rbegin(void) const
04709         {
04710                 return const_reverse_iterator(end());
04711         }
04712
04720         reverse_iterator                rend(void)
04721         {
04722                 return reverse_iterator(begin());
04723         }
04724
04732         const_reverse_iterator  rend(void) const
04733         {
04734                 return const_reverse_iterator(begin());
04735         }
04736
04737 private:
04738         /*************************************************************************
04739                 Implementation Functions
04740         *************************************************************************/
04741         // string management
04742
04743         // change size of allocated buffer so it is at least 'new_size'.
04744         // May or may not cause re-allocation and copy of buffer if size is larger
04745         // will never re-allocate to make size smaller.  (see trim())
04746     bool        grow(size_type new_size);
04747
04748         // perform re-allocation to remove wasted space.
04749     void        trim(void);
04750
04751         // set the length of the string, and terminate it, according to the given value (will not re-allocate, use grow() first).
04752         void    setlen(size_type len)
04753         {
04754                 d_cplength = len;
04755                 ptr()[len] = (utf32)(0);
04756         }
04757
04758         // return a ptr to the buffer in use.
04759         utf32*  ptr(void)
04760         {
04761                 return (d_reserve > STR_QUICKBUFF_SIZE) ? d_buffer : d_quickbuff;
04762         }
04763
04764         // return a ptr tot he buffer in use (const version)
04765         const utf32*    ptr(void) const
04766         {
04767                 return (d_reserve > STR_QUICKBUFF_SIZE) ? d_buffer : d_quickbuff;
04768         }
04769
04770         // initialise string object
04771         void    init(void)
04772         {
04773                 d_reserve                       = STR_QUICKBUFF_SIZE;
04774                 d_encodedbuff           = NULL;
04775                 d_encodedbufflen        = 0;
04776                 d_encodeddatlen         = 0;
04777                 setlen(0);
04778         }
04779
04780         // return true if the given pointer is inside the string data
04781         bool    inside(utf32* inptr)
04782         {
04783                 if (inptr < ptr() || ptr() + d_cplength <= inptr)
04784                         return false;
04785                 else
04786                         return true;
04787         }
04788
04789         // compute distance between two iterators, returning a 'safe' value
04790         size_type safe_iter_dif(const const_iterator& iter1, const const_iterator& iter2) const
04791         {
04792                 return (iter1.d_ptr == 0) ? 0 : (iter1 - iter2);
04793         }
04794
04795         // encoding functions
04796         // for all:
04797         //      src_len is in code units, or 0 for null terminated string.
04798         //      dest_len is in code units.
04799         //      returns number of code units put into dest buffer.
04800         size_type encode(const utf32* src, utf8* dest, size_type dest_len, size_type src_len = 0) const
04801         {
04802                 // count length for null terminated source...
04803                 if (src_len == 0)
04804                 {
04805                         src_len = utf_length(src);
04806                 }
04807
04808                 size_type destCapacity = dest_len;
04809
04810                 // while there is data in the source buffer,
04811                 for (uint idx = 0; idx < src_len; ++idx)
04812                 {
04813                         utf32   cp = src[idx];
04814
04815                         // check there is enough destination buffer to receive this encoded unit (exit loop & return if not)
04816                         if (destCapacity < encoded_size(cp))
04817                         {
04818                                 break;
04819                         }
04820
04821                         if (cp < 0x80)
04822                         {
04823                                 *dest++ = (utf8)cp;
04824                                 --destCapacity;
04825                         }
04826                         else if (cp < 0x0800)
04827                         {
04828                                 *dest++ = (utf8)((cp >> 6) | 0xC0);
04829                                 *dest++ = (utf8)((cp & 0x3F) | 0x80);
04830                                 destCapacity -= 2;
04831                         }
04832                         else if (cp < 0x10000)
04833                         {
04834                                 *dest++ = (utf8)((cp >> 12) | 0xE0);
04835                                 *dest++ = (utf8)(((cp >> 6) & 0x3F) | 0x80);
04836                                 *dest++ = (utf8)((cp & 0x3F) | 0x80);
04837                                 destCapacity -= 3;
04838                         }
04839                         else
04840                         {
04841                                 *dest++ = (utf8)((cp >> 18) | 0xF0);
04842                                 *dest++ = (utf8)(((cp >> 12) & 0x3F) | 0x80);
04843                                 *dest++ = (utf8)(((cp >> 6) & 0x3F) | 0x80);
04844                                 *dest++ = (utf8)((cp & 0x3F) | 0x80);
04845                                 destCapacity -= 4;
04846                         }
04847
04848                 }
04849
04850                 return dest_len - destCapacity;
04851         }
04852
04853         size_type encode(const utf8* src, utf32* dest, size_type dest_len, size_type src_len = 0) const
04854         {
04855                 // count length for null terminated source...
04856                 if (src_len == 0)
04857                 {
04858                         src_len = utf_length(src);
04859                 }
04860
04861                 size_type destCapacity = dest_len;
04862
04863                 // while there is data in the source buffer, and space in the dest buffer
04864                 for (uint idx = 0; ((idx < src_len) && (destCapacity > 0));)
04865                 {
04866                         utf32   cp;
04867                         utf8    cu = src[idx++];
04868
04869                         if (cu < 0x80)
04870                         {
04871                                 cp = (utf32)(cu);
04872                         }
04873                         else if (cu < 0xE0)
04874                         {
04875                                 cp = ((cu & 0x1F) << 6);
04876                                 cp |= (src[idx++] & 0x3F);
04877                         }
04878                         else if (cu < 0xF0)
04879                         {
04880                                 cp = ((cu & 0x0F) << 12);
04881                                 cp |= ((src[idx++] & 0x3F) << 6);
04882                                 cp |= (src[idx++] & 0x3F);
04883                         }
04884                         else
04885                         {
04886                                 cp = ((cu & 0x07) << 18);
04887                                 cp |= ((src[idx++] & 0x3F) << 12);
04888                                 cp |= ((src[idx++] & 0x3F) << 6);
04889                                 cp |= (src[idx++] & 0x3F);
04890                         }
04891
04892                         *dest++ = cp;
04893                         --destCapacity;
04894                 }
04895
04896                 return dest_len - destCapacity;
04897         }
04898
04899         // return the number of utf8 code units required to encode the given utf32 code point
04900         size_type encoded_size(utf32 code_point) const
04901         {
04902                 if (code_point < 0x80)
04903                         return 1;
04904                 else if (code_point < 0x0800)
04905                         return 2;
04906                 else if (code_point < 0x10000)
04907                         return 3;
04908                 else
04909                         return 4;
04910         }
04911
04912         // return number of code units required to re-encode given null-terminated utf32 data as utf8.  return does not include terminating null.
04913         size_type encoded_size(const utf32* buf) const
04914         {
04915                 return encoded_size(buf, utf_length(buf));
04916         }
04917
04918         // return number of code units required to re-encode given utf32 data as utf8.   len is number of code units in 'buf'.
04919         size_type encoded_size(const utf32* buf, size_type len) const
04920         {
04921                 size_type count = 0;
04922
04923                 while (len--)
04924                 {
04925                         count += encoded_size(*buf++);
04926                 }
04927
04928                 return count;
04929         }
04930
04931         // return number of utf32 code units required to re-encode given utf8 data as utf32.  return does not include terminating null.
04932         size_type encoded_size(const utf8* buf) const
04933         {
04934                 return encoded_size(buf, utf_length(buf));
04935         }
04936
04937         // return number of utf32 code units required to re-encode given utf8 data as utf32.  len is number of code units in 'buf'.
04938         size_type encoded_size(const utf8* buf, size_type len) const
04939         {
04940                 utf8 tcp;
04941                 size_type count = 0;
04942
04943                 while (len--)
04944                 {
04945                         tcp = *buf++;
04946                         ++count;
04947
04948                         if (tcp < 0x80)
04949                         {
04950                         }
04951                         else if (tcp < 0xE0)
04952                         {
04953                                 --len;
04954                                 ++buf;
04955                         }
04956                         else if (tcp < 0xF0)
04957                         {
04958                                 len -= 2;
04959                                 buf += 2;
04960                         }
04961                         else
04962                         {
04963                                 len -= 2;
04964                                 buf += 3;
04965                         }
04966
04967                 }
04968
04969                 return count;
04970         }
04971
04972         // return number of code units in a null terminated string
04973         size_type utf_length(const utf8* utf8_str) const
04974         {
04975                 size_type cnt = 0;
04976                 while (*utf8_str++)
04977                         cnt++;
04978
04979                 return cnt;
04980         }
04981
04982         // return number of code units in a null terminated string
04983         size_type utf_length(const utf32* utf32_str) const
04984         {
04985                 size_type cnt = 0;
04986                 while (*utf32_str++)
04987                         cnt++;
04988
04989                 return cnt;
04990         }
04991
04992         // build an internal buffer with the string encoded as utf8 (remains valid until string is modified).
04993     utf8* build_utf8_buff(void) const;
04994
04995         // compare two utf32 buffers
04996         int     utf32_comp_utf32(const utf32* buf1, const utf32* buf2, size_type cp_count) const
04997         {
04998                 if (!cp_count)
04999                         return 0;
05000
05001                 while ((--cp_count) && (*buf1 == *buf2))
05002                         buf1++, buf2++;
05003
05004                 return *buf1 - *buf2;
05005         }
05006
05007         // compare utf32 buffer with char buffer (chars are taken to be code-points in the range 0x00-0xFF)
05008         int utf32_comp_char(const utf32* buf1, const char* buf2, size_type cp_count) const
05009         {
05010                 if (!cp_count)
05011                         return 0;
05012
05013                 while ((--cp_count) && (*buf1 == static_cast<utf32>(static_cast<unsigned char>(*buf2))))
05014                         buf1++, buf2++;
05015
05016                 return *buf1 - static_cast<utf32>(static_cast<unsigned char>(*buf2));
05017         }
05018
05019         // compare utf32 buffer with encoded utf8 data
05020         int utf32_comp_utf8(const utf32* buf1, const utf8* buf2, size_type cp_count) const
05021         {
05022                 if (!cp_count)
05023                         return 0;
05024
05025                 utf32   cp;
05026                 utf8    cu;
05027
05028                 do
05029                 {
05030                         cu = *buf2++;
05031
05032                         if (cu < 0x80)
05033                         {
05034                                 cp = (utf32)(cu);
05035                         }
05036                         else if (cu < 0xE0)
05037                         {
05038                                 cp = ((cu & 0x1F) << 6);
05039                                 cp |= (*buf2++ & 0x3F);
05040                         }
05041                         else if (cu < 0xF0)
05042                         {
05043                                 cp = ((cu & 0x0F) << 12);
05044                                 cp |= ((*buf2++ & 0x3F) << 6);
05045                                 cp |= (*buf2++ & 0x3F);
05046                         }
05047                         else
05048                         {
05049                                 cp = ((cu & 0x07) << 18);
05050                                 cp |= ((*buf2++ & 0x3F) << 12);
05051                                 cp |= ((*buf2++ & 0x3F) << 6);
05052                                 cp |= (*buf2++ & 0x3F);
05053                         }
05054
05055                 } while ((*buf1++ == cp) && (--cp_count));
05056
05057                 return (*--buf1) - cp;
05058         }
05059
05060         // return index of first occurrence of 'code_point' in std::string 'str', or npos if none
05061         size_type find_codepoint(const std::string& str, utf32 code_point) const
05062         {
05063                 size_type idx = 0, sze = (size_type)str.size();
05064
05065                 while (idx != sze)
05066                 {
05067                         if (code_point == static_cast<utf32>(static_cast<unsigned char>(str[idx])))
05068                                 return idx;
05069
05070                         ++idx;
05071                 }
05072
05073                 return npos;
05074         }
05075
05076         // return index of first occurrence of 'code_point' in utf8 encoded string 'str', or npos if none.  len is in code points.
05077         size_type find_codepoint(const utf8* str, size_type len, utf32 code_point) const
05078         {
05079                 size_type idx = 0;
05080
05081                 utf32   cp;
05082                 utf8    cu;
05083
05084                 while (idx != len) {
05085                         cu = *str++;
05086
05087                         if (cu < 0x80)
05088                         {
05089                                 cp = (utf32)(cu);
05090                         }
05091                         else if (cu < 0xE0)
05092                         {
05093                                 cp = ((cu & 0x1F) << 6);
05094                                 cp |= (*str++ & 0x3F);
05095                         }
05096                         else if (cu < 0xF0)
05097                         {
05098                                 cp = ((cu & 0x0F) << 12);
05099                                 cp |= ((*str++ & 0x3F) << 6);
05100                                 cp |= (*str++ & 0x3F);
05101                         }
05102                         else
05103                         {
05104                                 cp = ((cu & 0x07) << 18);
05105                                 cp |= ((*str++ & 0x3F) << 12);
05106                                 cp |= ((*str++ & 0x3F) << 6);
05107                                 cp |= (*str++ & 0x3F);
05108                         }
05109
05110                         if (code_point == cp)
05111                                 return idx;
05112
05113                         ++idx;
05114                 }
05115
05116                 return npos;
05117         }
05118
05119
05120         // return index of first occurrence of 'code_point' in char array 'chars', or npos if none
05121         size_type find_codepoint(const char* chars, size_type chars_len, utf32 code_point) const
05122         {
05123                 for (size_type idx = 0; idx != chars_len; ++idx)
05124                 {
05125                         if (code_point == static_cast<utf32>(static_cast<unsigned char>(chars[idx])))
05126                                 return idx;
05127                 }
05128
05129                 return npos;
05130         }
05131
05132 };
05133
05134
05136 // Comparison operators
05138
05142 bool CEGUIEXPORT        operator==(const String& str1, const String& str2);
05143
05148 bool CEGUIEXPORT        operator==(const String& str, const std::string& std_str);
05149
05154 bool CEGUIEXPORT        operator==(const std::string& std_str, const String& str);
05155
05160 bool CEGUIEXPORT        operator==(const String& str, const utf8* utf8_str);
05161
05166 bool CEGUIEXPORT        operator==(const utf8* utf8_str, const String& str);
05167
05172 bool CEGUIEXPORT        operator!=(const String& str1, const String& str2);
05173
05178 bool CEGUIEXPORT        operator!=(const String& str, const std::string& std_str);
05179
05184 bool CEGUIEXPORT        operator!=(const std::string& std_str, const String& str);
05185
05190 bool CEGUIEXPORT        operator!=(const String& str, const utf8* utf8_str);
05191
05196 bool CEGUIEXPORT        operator!=(const utf8* utf8_str, const String& str);
05197
05202 bool CEGUIEXPORT        operator<(const String& str1, const String& str2);
05203
05208 bool CEGUIEXPORT        operator<(const String& str, const std::string& std_str);
05209
05214 bool CEGUIEXPORT        operator<(const std::string& std_str, const String& str);
05215
05220 bool CEGUIEXPORT        operator<(const String& str, const utf8* utf8_str);
05221
05226 bool CEGUIEXPORT        operator<(const utf8* utf8_str, const String& str);
05227
05232 bool CEGUIEXPORT        operator>(const String& str1, const String& str2);
05233
05238 bool CEGUIEXPORT        operator>(const String& str, const std::string& std_str);
05239
05244 bool CEGUIEXPORT        operator>(const std::string& std_str, const String& str);
05245
05250 bool CEGUIEXPORT        operator>(const String& str, const utf8* utf8_str);
05251
05256 bool CEGUIEXPORT        operator>(const utf8* utf8_str, const String& str);
05257
05262 bool CEGUIEXPORT        operator<=(const String& str1, const String& str2);
05263
05268 bool CEGUIEXPORT        operator<=(const String& str, const std::string& std_str);
05269
05274 bool CEGUIEXPORT        operator<=(const std::string& std_str, const String& str);
05275
05280 bool CEGUIEXPORT        operator<=(const String& str, const utf8* utf8_str);
05281
05286 bool CEGUIEXPORT        operator<=(const utf8* utf8_str, const String& str);
05287
05292 bool CEGUIEXPORT        operator>=(const String& str1, const String& str2);
05293
05298 bool CEGUIEXPORT        operator>=(const String& str, const std::string& std_str);
05299
05304 bool CEGUIEXPORT        operator>=(const std::string& std_str, const String& str);
05305
05310 bool CEGUIEXPORT        operator>=(const String& str, const utf8* utf8_str);
05311
05316 bool CEGUIEXPORT        operator>=(const utf8* utf8_str, const String& str);
05317
05322 bool CEGUIEXPORT        operator==(const String& str, const char* c_str);
05323
05328 bool CEGUIEXPORT        operator==(const char* c_str, const String& str);
05329
05334 bool CEGUIEXPORT        operator!=(const String& str, const char* c_str);
05335
05340 bool CEGUIEXPORT        operator!=(const char* c_str, const String& str);
05341
05346 bool CEGUIEXPORT        operator<(const String& str, const char* c_str);
05347
05352 bool CEGUIEXPORT        operator<(const char* c_str, const String& str);
05353
05358 bool CEGUIEXPORT        operator>(const String& str, const char* c_str);
05359
05364 bool CEGUIEXPORT        operator>(const char* c_str, const String& str);
05365
05370 bool CEGUIEXPORT        operator<=(const String& str, const char* c_str);
05371
05376 bool CEGUIEXPORT        operator<=(const char* c_str, const String& str);
05377
05382 bool CEGUIEXPORT        operator>=(const String& str, const char* c_str);
05383
05388 bool CEGUIEXPORT        operator>=(const char* c_str, const String& str);
05389
05391 // Concatenation operator functions
05393
05408 String CEGUIEXPORT      operator+(const String& str1, const String& str2);
05409
05425 String CEGUIEXPORT      operator+(const String& str, const std::string& std_str);
05426
05442 String CEGUIEXPORT      operator+(const std::string& std_str, const String& str);
05443
05459 String CEGUIEXPORT      operator+(const String& str, const utf8* utf8_str);
05460
05476 String CEGUIEXPORT      operator+(const utf8* utf8_str, const String& str);
05477
05493 String CEGUIEXPORT      operator+(const String& str, utf32 code_point);
05494
05510 String CEGUIEXPORT      operator+(utf32 code_point, const String& str);
05511
05527 String CEGUIEXPORT      operator+(const String& str, const char* c_str);
05528
05544 String CEGUIEXPORT      operator+(const char* c_str, const String& str);
05545
05546
05548 // Output (stream) functions
05550 CEGUIEXPORT std::ostream& operator<<(std::ostream& s, const String& str);
05551
05552
05554 // Modifying operations
05556
05569 void CEGUIEXPORT swap(String& str1, String& str2);
05570
05571
05572 } // End of  CEGUI namespace section
05573
05574
05575 #endif  // end of guard _CEGUIString_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUISystem.h Source File

include

CEGUISystem.h

00001 /************************************************************************
00002         filename:       CEGUISystem.h
00003         created:        20/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for main GUI system class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUISystem_h_
00027 #define _CEGUISystem_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUIRenderer.h"
00033 #include "CEGUIMouseCursor.h"
00034 #include "CEGUIInputEvent.h"
00035 #include "CEGUIResourceProvider.h"
00036
00037
00038 #if defined(_MSC_VER)
00039 #       pragma warning(push)
00040 #       pragma warning(disable : 4275)
00041 #       pragma warning(disable : 4251)
00042 #endif
00043
00044
00045 // Start of CEGUI namespace section
00046 namespace CEGUI
00047 {
00049 struct MouseClickTrackerImpl;
00050
00051
00060 class CEGUIEXPORT System : public Singleton<System>, public EventSet
00061 {
00062 public:
00063         static const String EventNamespace;
00064
00065         /*************************************************************************
00066                 Constants
00067         *************************************************************************/
00068         static const double             DefaultSingleClickTimeout;
00069         static const double             DefaultMultiClickTimeout;
00070         static const Size               DefaultMultiClickAreaSize;
00071
00072         // event names
00073         static const String EventGUISheetChanged;
00074         static const String EventSingleClickTimeoutChanged;
00075         static const String EventMultiClickTimeoutChanged;
00076         static const String EventMultiClickAreaSizeChanged;
00077         static const String EventDefaultFontChanged;
00078         static const String EventDefaultMouseCursorChanged;
00079         static const String EventMouseMoveScalingChanged;
00080
00081
00082         /*************************************************************************
00083                 Construction and Destruction
00084         *************************************************************************/
00095         System(Renderer* renderer, const utf8* logFile = (const utf8*)"CEGUI.log");
00096
00110     System(Renderer* renderer, ResourceProvider* resourceProvider, const utf8* logFile = (const utf8*)"CEGUI.log");
00111
00112
00126         System(Renderer* renderer, ScriptModule* scriptModule, const utf8* configFile = (const utf8*)"cegui.config");
00127
00128
00145         System(Renderer* renderer, ScriptModule* scriptModule, ResourceProvider* resourceProvider, const utf8* configFile = (const utf8*)"cegui.config");
00146
00147
00161     System(Renderer* renderer, XMLParser* xmlParser, const utf8* logFile = (const utf8*)"CEGUI.log");
00162
00163
00180     System(Renderer* renderer, ResourceProvider* resourceProvider, XMLParser* xmlParser, const utf8* logFile = (const utf8*)"CEGUI.log");
00181
00182
00199     System(Renderer* renderer, XMLParser* xmlParser, ScriptModule* scriptModule, const utf8* configFile = (const utf8*)"cegui.config");
00200
00201
00221     System(Renderer* renderer, ResourceProvider* resourceProvider, XMLParser* xmlParser, ScriptModule* scriptModule, const utf8* configFile = (const utf8*)"cegui.config");
00222
00223
00228         ~System(void);
00229
00230
00238         Renderer*       getRenderer(void) const                 {return d_renderer;}
00239
00240
00248         static  System& getSingleton(void);
00249
00250
00258         static  System* getSingletonPtr(void);
00259
00260
00271         void    setDefaultFont(const String& name);
00272
00273
00284         void    setDefaultFont(Font* font);
00285
00286
00294         Font*   getDefaultFont(void) const                              {return d_defaultFont;}
00295
00296
00304         void    signalRedraw()          {d_gui_redraw = true;}
00305
00306
00314         bool    isRedrawRequested() const               {return d_gui_redraw;}
00315
00316
00326         void    renderGUI(void);
00327
00328
00339         Window* setGUISheet(Window* sheet);
00340
00341
00349         Window* getGUISheet(void) const         {return d_activeSheet;}
00350
00351
00361         double  getSingleClickTimeout(void) const               {return d_click_timeout;}
00362
00363
00375         double  getMultiClickTimeout(void) const                {return d_dblclick_timeout;}
00376
00377
00388         const Size&     getMultiClickToleranceAreaSize(void) const              {return d_dblclick_size;}
00389
00390
00403         void    setSingleClickTimeout(double timeout);
00404
00405
00420         void setMultiClickTimeout(double timeout);
00421
00422
00436         void setMultiClickToleranceAreaSize(const Size& sz);
00437
00438
00447         const Image*    getDefaultMouseCursor(void) const       {return d_defaultMouseCursor;}
00448
00449
00461         void    setDefaultMouseCursor(const Image* image);
00462
00463
00474         void    setDefaultMouseCursor(MouseCursorImage image)           {setDefaultMouseCursor((const Image*)image);}
00475
00476
00492         void    setDefaultMouseCursor(const String& imageset, const String& image_name);
00493
00494
00502         Window* getWindowContainingMouse(void) const    {return d_wndWithMouse;}
00503
00504
00512         ScriptModule*   getScriptingModule(void) const;
00513
00521         ResourceProvider* getResourceProvider(void) const;
00522
00533         void    executeScriptFile(const String& filename, const String& resourceGroup = "") const;
00534
00535
00547         int             executeScriptGlobal(const String& function_name) const;
00548
00549
00560     void executeScriptString(const String& str) const;
00561
00562
00570         float   getMouseMoveScaling(void) const;
00571
00572
00583         void    setMouseMoveScaling(float scaling);
00584
00585
00594         void    notifyWindowDestroyed(const Window* window);
00595
00596
00604     uint    getSystemKeys(void) const   { return d_sysKeys; }
00605
00610     XMLParser* getXMLParser(void) const     { return d_xmlParser; }
00611
00612
00626     void setTooltip(Tooltip* tooltip);
00627
00643     void setTooltip(const String& tooltipType);
00644
00653     Tooltip* getDefaultTooltip(void) const  { return d_defaultTooltip; }
00654
00655
00664         void setModalTarget(Window* target)             {d_modalTarget = target;}
00665
00673         Window* getModalTarget(void) const              {return d_modalTarget;}
00674
00675
00676         /*************************************************************************
00677                 Input injection interface
00678         *************************************************************************/
00693         bool    injectMouseMove(float delta_x, float delta_y);
00694
00695
00704         bool    injectMouseLeaves(void);
00705
00706
00718         bool    injectMouseButtonDown(MouseButton button);
00719
00720
00732         bool    injectMouseButtonUp(MouseButton button);
00733
00734
00746         bool    injectKeyDown(uint key_code);
00747
00748
00760         bool    injectKeyUp(uint key_code);
00761
00762
00774         bool    injectChar(utf32 code_point);
00775
00776
00788         bool    injectMouseWheelChange(float delta);
00789
00790
00805         bool    injectMousePosition(float x_pos, float y_pos);
00806
00807
00818         bool    injectTimePulse(float timeElapsed);
00819
00820
00821 private:
00822     // unimplemented constructors / assignment
00823     System(const System& obj);
00824     System& operator=(const System& obj);
00825
00826         /*************************************************************************
00827                 Implementation Constants
00828         *************************************************************************/
00829         static const char       CEGUIConfigSchemaName[];
00830
00831
00832         /*************************************************************************
00833                 Implementation Functions
00834         *************************************************************************/
00845         Window* getTargetWindow(const Point& pt) const;
00846
00847
00855         Window* getKeyboardTargetWindow(void) const;
00856
00857
00868         Window* getNextTargetWindow(Window* w) const;
00869
00870
00881         SystemKey       mouseButtonToSyskey(MouseButton btn) const;
00882
00883
00899         SystemKey       keyCodeToSyskey(Key::Scan key, bool direction);
00900
00901
00906        void     constructor_impl(Renderer* renderer, ResourceProvider* resourceProvider, XMLParser* xmlParser, ScriptModule* scriptModule, const String& configFile, const String& logFile);
00907
00908
00913         void    addSystemEvents(void);
00914
00915
00920         bool    handleDisplaySizeChange(const EventArgs& e);
00921
00922
00923         /*************************************************************************
00924                 Handlers for System events
00925         *************************************************************************/
00932         void    onGUISheetChanged(WindowEventArgs& e);
00933
00934
00939         void    onSingleClickTimeoutChanged(EventArgs& e);
00940
00941
00946         void    onMultiClickTimeoutChanged(EventArgs& e);
00947
00948
00953         void    onMultiClickAreaSizeChanged(EventArgs& e);
00954
00955
00960         void    onDefaultFontChanged(EventArgs& e);
00961
00962
00967         void    onDefaultMouseCursorChanged(EventArgs& e);
00968
00969
00974         void    onMouseMoveScalingChanged(EventArgs& e);
00975
00976
00977         /*************************************************************************
00978                 Implementation Data
00979         *************************************************************************/
00980         Renderer*       d_renderer;
00981     ResourceProvider* d_resourceProvider;
00982         Font*           d_defaultFont;
00983         bool            d_gui_redraw;
00984
00985         Window*         d_wndWithMouse;
00986         Window*         d_activeSheet;
00987         Window*         d_modalTarget;
00988
00989         String d_strVersion;
00990
00991         uint            d_sysKeys;
00992         bool            d_lshift;
00993         bool            d_rshift;
00994         bool            d_lctrl;
00995         bool            d_rctrl;
00996         bool            d_lalt;
00997         bool            d_ralt;
00998
00999         double          d_click_timeout;
01000         double          d_dblclick_timeout;
01001         Size            d_dblclick_size;
01002
01003         MouseClickTrackerImpl* const    d_clickTrackerPimpl;
01004
01005         // mouse cursor related
01006         const Image*    d_defaultMouseCursor;
01007
01008         // scripting
01009         ScriptModule*   d_scriptModule;
01010         String                  d_termScriptName;
01011
01012         float   d_mouseScalingFactor;
01013
01014     XMLParser*  d_xmlParser;
01015     bool        d_ourXmlParser;
01016
01017     Tooltip* d_defaultTooltip;
01018     bool     d_weOwnTooltip;
01019 };
01020
01021 } // End of  CEGUI namespace section
01022
01023
01024 #if defined(_MSC_VER)
01025 #       pragma warning(pop)
01026 #endif
01027
01028 #endif  // end of guard _CEGUISystem_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITabButton.h Source File

include » elements

CEGUITabButton.h

00001 /************************************************************************
00002         filename:       CEGUITabButton.h
00003         created:        8/8/2004
00004         author:         Steve Streeting
00005
00006         purpose:        Interface to base class for TabButton widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITabButton_h_
00027 #define _CEGUITabButton_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "elements/CEGUIButtonBase.h"
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00041 class CEGUIEXPORT TabButton : public ButtonBase
00042 {
00043 public:
00044         static const String EventNamespace;
00045
00046
00047         /*************************************************************************
00048                 Event name constants
00049         *************************************************************************/
00050         // generated internally by Window
00051         static const String EventClicked;
00052
00053         /*************************************************************************
00054                 Construction and Destruction
00055         *************************************************************************/
00060         TabButton(const String& type, const String& name);
00061
00062
00067         virtual ~TabButton(void);
00068
00073     virtual void setSelected(bool selected) { d_selected = selected; requestRedraw(); }
00074
00081     virtual void setRightOfSelected(bool isRight) { d_rightOfSelected = isRight; requestRedraw(); }
00082
00087     bool isSelected(void) const { return d_selected; }
00088
00089
00095     void setTargetWindow(Window* wnd);
00101     Window* getTargetWindow(void) { return d_targetWindow; }
00102
00107     void setTabIndex(uint idx) { d_tabIndex = idx; }
00108
00113     uint getTabIndex(void) { return d_tabIndex; }
00114 protected:
00115     /*************************************************************************
00116     Implementation Data
00117     *************************************************************************/
00118     bool    d_selected;
00119     bool    d_rightOfSelected;
00120     Window* d_targetWindow;
00121     uint    d_tabIndex;
00122         /*************************************************************************
00123                 New Event Handlers
00124         *************************************************************************/
00129         virtual void    onClicked(WindowEventArgs& e);
00130
00131
00132         /*************************************************************************
00133                 Overridden Event Handlers
00134         *************************************************************************/
00135         virtual void    onMouseButtonUp(MouseEventArgs& e);
00136
00137
00138         /*************************************************************************
00139                 Implementation Functions
00140         *************************************************************************/
00145         void    addTabButtonEvents(void);
00156         void    drawSelf(float z);
00157
00158
00169         virtual bool    testClassName_impl(const String& class_name) const
00170         {
00171                 if (class_name==(const utf8*)"TabButton")       return true;
00172                 return ButtonBase::testClassName_impl(class_name);
00173         }
00174 };
00175
00176
00177 } // End of  CEGUI namespace section
00178
00179
00180 #endif  // end of guard _CEGUITabButton_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITabControl.h Source File

include » elements

CEGUITabControl.h

00001 /************************************************************************
00002         filename:       CEGUITabControl.h
00003         created:        08/08/2004
00004         author:         Steve Streeting
00005
00006         purpose:        Interface to base class for TabControl widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITabControl_h_
00027 #define _CEGUITabControl_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUITabControlProperties.h"
00032 #include "elements/CEGUITabPane.h"
00033 #include <vector>
00034
00035
00036 #if defined(_MSC_VER)
00037 #       pragma warning(push)
00038 #       pragma warning(disable : 4251)
00039 #endif
00040
00041
00042 // Start of CEGUI namespace section
00043 namespace CEGUI
00044 {
00045
00046     // Forward declaration
00047     class TabButton;
00048
00053 class CEGUIEXPORT TabControl : public Window
00054 {
00055 public:
00056         static const String EventNamespace;
00057
00058
00059         /*************************************************************************
00060                 Constants
00061         *************************************************************************/
00062         // event names
00063         static const String EventSelectionChanged;
00064
00065
00066         /*************************************************************************
00067                 Accessor Methods
00068         *************************************************************************/
00076         uint    getTabCount(void) const;
00077
00078
00084     void    setSelectedTab(const String &name);
00085
00091     void    setSelectedTab(uint ID);
00092
00098     void    setSelectedTabAtIndex(uint index);
00099
00112     Window*     getTabContentsAtIndex(uint index) const;
00113
00126     Window*     getTabContents(const String& name) const;
00127
00140     Window*     getTabContents(uint ID) const;
00141
00154     bool        isTabContentsSelected(Window* wnd) const;
00155
00163     uint        getSelectedTabIndex() const;
00164
00169     float getRelativeTabHeight(void) const { return d_rel_tabHeight; }
00174     float getAbsoluteTabHeight(void) const { return d_abs_tabHeight; }
00179     float getTabHeight(void) const;
00185     float getTabTextPadding(void) const;
00190     float getRelativeTabTextPadding(void) const { return d_rel_tabPadding; }
00195     float getAbsoluteTabTextPadding(void) const { return d_abs_tabPadding; }
00196
00197
00198     /*************************************************************************
00199                 Manipulator Methods
00200         *************************************************************************/
00211         virtual void    initialise(void);
00212
00217     void setRelativeTabHeight(float height);
00222     void setAbsoluteTabHeight(float height);
00227     void setTabHeight(float height);
00228
00234     void setTabTextPadding(float);
00239     void setRelativeTabTextPadding(float);
00244     void setAbsoluteTabTextPadding(float);
00253     void addTab(Window* wnd);
00260     void removeTab(const String& name);
00267     void removeTab(uint ID);
00268
00269
00270         /*************************************************************************
00271                 Construction and Destruction
00272         *************************************************************************/
00277         TabControl(const String& type, const String& name);
00278
00279
00284         virtual ~TabControl(void);
00285
00286
00287 protected:
00288
00289         /*************************************************************************
00290                 Implementation Functions
00291         *************************************************************************/
00302     virtual     void    drawSelf(float z) { /* do nothing; rendering handled by children */ }
00303
00308         void    addTabControlEvents(void);
00309
00314     virtual void addButtonForTabContent(Window* wnd);
00319     virtual void removeButtonForTabContent(Window* wnd);
00325         TabButton* getButtonForTabContents(Window* wnd) const;
00330     String makeButtonName(Window* wnd);
00331
00338     virtual void selectTab_impl(Window* wnd);
00339
00340
00351         virtual bool    testClassName_impl(const String& class_name) const
00352         {
00353                 if (class_name==(const utf8*)"TabControl")      return true;
00354                 return Window::testClassName_impl(class_name);
00355         }
00356
00357         void performChildWindowLayout();
00358     int writeChildWindowsXML(OutStream& out_stream) const;
00359
00360         /*************************************************************************
00361                 New event handlers
00362         *************************************************************************/
00363
00368         virtual void    onSelectionChanged(WindowEventArgs& e);
00369
00378         virtual void    onFontChanged(WindowEventArgs& e);
00379
00380         /*************************************************************************
00381                 Implementation Data
00382         *************************************************************************/
00383     Window*     d_tabButtonPane;
00384     TabPane*    d_tabContentPane;
00385     float       d_abs_tabHeight;
00386     float       d_rel_tabHeight;
00387     float       d_abs_tabPadding;
00388     float       d_rel_tabPadding;
00389     uint        d_nextTabIndex;
00390     typedef std::map<uint, TabButton*> TabButtonIndexMap;
00391     TabButtonIndexMap d_tabButtonIndexMap;
00392     /*************************************************************************
00393     Abstract Implementation Functions (must be provided by derived class)
00394     *************************************************************************/
00405     virtual TabPane*    createTabContentPane(const String& name) const          = 0;
00406
00417     virtual Window*     createTabButtonPane(const String& name) const;
00418
00427     virtual TabButton*  createTabButton(const String& name) const               = 0;
00428
00440     void calculateTabButtonSizePosition(TabButton* btn, uint targetIndex);
00441
00442 protected:
00443         /*************************************************************************
00444                 Static Properties for this class
00445         *************************************************************************/
00446         static TabControlProperties::TabHeight                  d_tabHeightProperty;
00447     static TabControlProperties::AbsoluteTabHeight      d_absoluteTabHeightProperty;
00448     static TabControlProperties::RelativeTabHeight      d_relativeTabHeightProperty;
00449
00450     static TabControlProperties::TabTextPadding                 d_tabTextPaddingProperty;
00451     static TabControlProperties::AbsoluteTabTextPadding d_absoluteTabTextPaddingProperty;
00452     static TabControlProperties::RelativeTabTextPadding d_relativeTabTextPaddingProperty;
00453         /*************************************************************************
00454                 Private methods
00455         *************************************************************************/
00456         void    addTabControlProperties(void);
00457
00458     void    addChild_impl(Window* wnd);
00459     void    removeChild_impl(Window* wnd);
00460
00461     /*************************************************************************
00462     Event handlers
00463     *************************************************************************/
00464     bool handleContentWindowTextChanged(const EventArgs& args);
00465     bool handleTabButtonClicked(const EventArgs& args);
00466 };
00467
00468
00469
00470 } // End of  CEGUI namespace section
00471
00472
00473 #if defined(_MSC_VER)
00474 #       pragma warning(pop)
00475 #endif
00476
00477 #endif  // end of guard _CEGUITabControl_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITabControlProperties.h Source File

include » elements

CEGUITabControlProperties.h

00001 /************************************************************************
00002         filename:       CEGUITabControlProperties.h
00003         created:        08/08/2004
00004         author:         Steve Streeting
00005
00006         purpose:        Interface to TabControl property classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITabControlProperties_h_
00027 #define _CEGUITabControlProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of TabControlProperties namespace section
00041 namespace TabControlProperties
00042 {
00052 class TabHeight : public Property
00053 {
00054 public:
00055         TabHeight() : Property(
00056                 "TabHeight",
00057                 "Property to get/set the height of the tabs.",
00058                 "")
00059         {}
00060
00061         String  get(const PropertyReceiver* receiver) const;
00062         void    set(PropertyReceiver* receiver, const String& value);
00063
00064         // default depends upon current metrics mode
00065         bool    isDefault(const PropertyReceiver* receiver) const;
00066         String  getDefault(const PropertyReceiver* receiver) const;
00067 };
00068
00078 class AbsoluteTabHeight : public Property
00079 {
00080 public:
00081     AbsoluteTabHeight() : Property(
00082                 "AbsoluteTabHeight",
00083                 "Property to get/set the absolute height of the tabs.",
00084                 "", false)
00085         {}
00086
00087     String      get(const PropertyReceiver* receiver) const;
00088     void        set(PropertyReceiver* receiver, const String& value);
00089
00090         // default depends upon size of parent
00091         bool    isDefault(const PropertyReceiver* receiver) const;
00092         String  getDefault(const PropertyReceiver* receiver) const;
00093 };
00094
00104 class RelativeTabHeight : public Property
00105 {
00106 public:
00107     RelativeTabHeight() : Property(
00108                 "RelativeTabHeight",
00109                 "Property to get/set the relative height of the tabs.",
00110                 "0.050000", false)
00111         {}
00112
00113     String      get(const PropertyReceiver* receiver) const;
00114     void        set(PropertyReceiver* receiver, const String& value);
00115 };
00116
00126 class TabTextPadding : public Property
00127 {
00128 public:
00129     TabTextPadding() : Property(
00130                 "TabTextPadding",
00131                 "Property to get/set the padding either side of the tab buttons.",
00132                 "")
00133         {}
00134
00135     String      get(const PropertyReceiver* receiver) const;
00136     void        set(PropertyReceiver* receiver, const String& value);
00137
00138         // default depends upon current metrics mode
00139         bool    isDefault(const PropertyReceiver* receiver) const;
00140         String  getDefault(const PropertyReceiver* receiver) const;
00141 };
00142
00152 class AbsoluteTabTextPadding : public Property
00153 {
00154 public:
00155     AbsoluteTabTextPadding() : Property(
00156                 "AbsoluteTabTextPadding",
00157                 "Property to get/set the absolute padding either side of the tab buttons.",
00158                 "5", false)
00159         {}
00160
00161     String      get(const PropertyReceiver* receiver) const;
00162     void        set(PropertyReceiver* receiver, const String& value);
00163 };
00164
00174 class RelativeTabTextPadding : public Property
00175 {
00176 public:
00177     RelativeTabTextPadding() : Property(
00178                 "RelativeTabTextPadding",
00179                 "Property to get/set the relative padding either side of the tab buttons.",
00180                 "", false)
00181         {}
00182
00183     String      get(const PropertyReceiver* receiver) const;
00184     void        set(PropertyReceiver* receiver, const String& value);
00185
00186         // default depends upon size of parent
00187         bool    isDefault(const PropertyReceiver* receiver) const;
00188         String  getDefault(const PropertyReceiver* receiver) const;
00189 };
00190
00191
00192
00193
00194
00195 } // End of  TabControlProperties namespace section
00196
00197 } // End of  CEGUI namespace section
00198
00199
00200 #endif  // end of guard _CEGUIListboxProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITabPane.h Source File

include » elements

CEGUITabPane.h

00001 /************************************************************************
00002         filename:       CEGUITabPane.h
00003         created:        8/8/2004
00004         author:         Steve Streeting
00005
00006         purpose:        Defines interface for the content area of a tab control
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITabPane_h_
00027 #define _CEGUITabPane_h_
00028
00029 #include "elements/CEGUIStatic.h"
00030
00031
00032 #if defined(_MSC_VER)
00033 #       pragma warning(push)
00034 #       pragma warning(disable : 4251)
00035 #endif
00036
00037
00038 // Start of CEGUI namespace section
00039 namespace CEGUI
00040 {
00045 class CEGUIEXPORT TabPane : public Static
00046 {
00047 public:
00048         /*************************************************************************
00049                 Construction and Destruction
00050         *************************************************************************/
00055     TabPane(const String& type, const String& name) : Static(type, name) {}
00056
00057
00062     virtual ~TabPane(void) {}
00063
00064
00065         /*************************************************************************
00066                 Accessors
00067         *************************************************************************/
00068
00069         /*************************************************************************
00070                 Manipulators
00071         *************************************************************************/
00072
00073 protected:
00074         /*************************************************************************
00075                 Overridden from base class
00076         *************************************************************************/
00077
00078     /*************************************************************************
00079                 Implementation methods
00080         *************************************************************************/
00091         virtual bool    testClassName_impl(const String& class_name) const
00092         {
00093                 if (class_name==(const utf8*)"Tabpane") return true;
00094                 return Static::testClassName_impl(class_name);
00095         }
00096
00097         /*************************************************************************
00098                 Implementation Data
00099         *************************************************************************/
00100
00101 private:
00102         /*************************************************************************
00103                 Static Properties for this class
00104         *************************************************************************/
00105
00106
00107         /*************************************************************************
00108                 Private methods
00109         *************************************************************************/
00110 };
00111
00112 } // End of  CEGUI namespace section
00113
00114 #if defined(_MSC_VER)
00115 #       pragma warning(pop)
00116 #endif
00117
00118 #endif  // end of guard _CEGUITabPane_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITextItem.h Source File

include » elements

CEGUITextItem.h

00001 /************************************************************************
00002         filename:       CEGUITextItem.h
00003         created:        31/3/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005
00006         purpose:        Interface to base class for TextItem widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITextItem_h_
00027 #define _CEGUITextItem_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIWindow.h"
00031 #include "elements/CEGUIItemEntry.h"
00032 #include "elements/CEGUITextItemProperties.h"
00033 #include "CEGUIFont.h"
00034
00035
00036 #if defined(_MSC_VER)
00037 #       pragma warning(push)
00038 #       pragma warning(disable : 4251)
00039 #endif
00040
00041
00042 // Start of CEGUI namespace section
00043 namespace CEGUI
00044 {
00045
00050 class CEGUIEXPORT TextItem : public ItemEntry
00051 {
00052 public:
00053         /*************************************************************************
00054                 Constants
00055         *************************************************************************/
00056         static const colour             DefaultTextColour;
00057
00058
00059         /*************************************************************************
00060                 Accessors
00061         *************************************************************************/
00069         TextFormatting getTextFormatting() const                {return d_textFormatting;}
00070
00071
00081     float   getTextXOffset(void) const                          {return d_textXOffset;}
00082
00083
00091         colour getTextColour(void) const                        {return d_textColour;}
00092
00093
00094         /*************************************************************************
00095                 Manipulators
00096         *************************************************************************/
00101         void setTextFormatting(TextFormatting format)   {d_textFormatting=format;}
00102
00103
00111         void setTextColour(const colour& col)                   {d_textColour=col;}
00112
00113
00126     void   setTextXOffset(float offset)                         {d_textXOffset=offset;}
00127
00128
00129         /*************************************************************************
00130                 Pure functions from ItemEntry
00131         *************************************************************************/
00140         virtual Size getItemPixelSize(void);
00141
00142
00143         /*************************************************************************
00144                 Construction and Destruction
00145         *************************************************************************/
00150         TextItem(const String& type, const String& name);
00151
00152
00157         virtual ~TextItem(void);
00158
00159
00160 protected:
00161         /*************************************************************************
00162                 Abstract Implementation Functions (must be provided by derived class)
00163         *************************************************************************/
00164
00165         /*************************************************************************
00166                 Overridden event handlers
00167         *************************************************************************/
00176         virtual void    onTextChanged(WindowEventArgs& e);
00177
00178
00179         /*************************************************************************
00180                 Implementation Functions
00181         *************************************************************************/
00182     virtual void populateRenderCache();
00183
00184
00195         virtual bool    testClassName_impl(const String& class_name) const
00196         {
00197                 if (class_name==(const utf8*)"TextItem")        return true;
00198                 return ItemEntry::testClassName_impl(class_name);
00199         }
00200
00201
00202         /*************************************************************************
00203                 Implementation Rendering Functions
00204         *************************************************************************/
00205
00206         /*************************************************************************
00207                 Implementation Data
00208         *************************************************************************/
00209         colour d_textColour;
00210         TextFormatting d_textFormatting;
00211
00212         //text-offset
00213     float d_textXOffset;
00214
00215
00216 private:
00217         /*************************************************************************
00218                 Static Properties for this class
00219         *************************************************************************/
00220         static TextItemProperties::TextColour           d_textColourProperty;
00221         static TextItemProperties::TextFormatting       d_textFormattingProperty;
00222         static TextItemProperties::TextXOffset          d_textXOffsetProperty;
00223
00224         /*************************************************************************
00225                 Private methods
00226         *************************************************************************/
00227         void    addTextItemProperties(void);
00228 };
00229
00230 } // End of  CEGUI namespace section
00231
00232
00233 #if defined(_MSC_VER)
00234 #       pragma warning(pop)
00235 #endif
00236
00237
00238 #endif  // end of guard _CEGUITextItem_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITextItemProperties.h Source File

include » elements

CEGUITextItemProperties.h

00001 /************************************************************************
00002         filename:       CEGUITextItemProperties.h
00003         created:        8/4/2005
00004         author:         Tomas Lindquist Olsen (based on code by Paul D Turner)
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUITextItemProperties_h_
00025 #define _CEGUITextItemProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of TextItemProperties namespace section
00033 namespace TextItemProperties
00034 {
00035
00047 class TextXOffset : public Property
00048 {
00049 public:
00050         TextXOffset() : Property(
00051                 "TextXOffset",
00052                 "Property to get/set the X offset of the text on the item.  Value is a float.",
00053                 "0.000000")
00054         {}
00055
00056         String  get(const PropertyReceiver* receiver) const;
00057         void    set(PropertyReceiver* receiver, const String& value);
00058 };
00059
00060
00072 class TextColour : public Property
00073 {
00074 public:
00075         TextColour() : Property(
00076                 "TextColour",
00077                 "Property to get/set the text colour of the item.  Value is a colour.",
00078                 "00FFFFFF")
00079         {}
00080
00081         String  get(const PropertyReceiver* receiver) const;
00082         void    set(PropertyReceiver* receiver, const String& value);
00083 };
00084
00085
00104 class TextFormatting : public Property
00105 {
00106 public:
00107         TextFormatting() : Property(
00108                 "TextFormatting",
00109                 "Property to get/set the horizontal formatting mode.  Value is one of the HorzFormatting strings.",
00110                 "LeftAligned")
00111         {}
00112
00113         String  get(const PropertyReceiver* receiver) const;
00114         void    set(PropertyReceiver* receiver, const String& value);
00115 };
00116
00117 } // End of  TextItemProperties namespace section
00118 } // End of  CEGUI namespace section
00119
00120 #endif  // end of guard _CEGUITextItemProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITexture.h Source File

include

CEGUITexture.h

00001 /************************************************************************
00002         filename:       CEGUITexture.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines abstract interface for texture objects.  Texture
00007                                 objects are created & destroyed by the Renderer.
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUITexture_h_
00028 #define _CEGUITexture_h_
00029
00030 #include "CEGUIBase.h"
00031 #include "CEGUIString.h"
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00045 class CEGUIEXPORT Texture
00046 {
00047 public:
00048         /*************************************************************************
00049                 Abstract Interface
00050         *************************************************************************/
00058         virtual ushort  getWidth(void) const = 0;
00059
00060
00068         virtual ushort  getHeight(void) const = 0;
00069
00070
00084         virtual void    loadFromFile(const String& filename, const String& resourceGroup) = 0;
00085
00086
00103         virtual void    loadFromMemory(const void* buffPtr, uint buffWidth, uint buffHeight) = 0;
00104
00105
00113         Renderer*       getRenderer(void) const                 {return d_owner;}
00114
00115
00116 protected:
00117         /*************************************************************************
00118                 Construction and Destruction
00119         *************************************************************************/
00124         Texture(Renderer* owner) : d_owner(owner) {}
00125
00126 public:         // luabind compatibility
00131         virtual ~Texture(void) {}
00132
00133 private:
00134         Renderer* d_owner;              //<! Renderer object that created and owns this texture
00135 };
00136
00137 } // End of  CEGUI namespace section
00138
00139 #endif  // end of guard _CEGUITexture_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITextUtils.h Source File

include

CEGUITextUtils.h

00001 /************************************************************************
00002         filename:       CEGUITextUtils.h
00003         created:        30/5/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to a static class containing some utility
00007                                 functions for text / string operations
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUITextUtils_h_
00028 #define _CEGUITextUtils_h_
00029
00030 #include "CEGUIBase.h"
00031 #include "CEGUIString.h"
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00040 class CEGUIEXPORT TextUtils
00041 {
00042 public:
00043         /*************************************************************************
00044                 Constants
00045         *************************************************************************/
00046         static const String     DefaultWhitespace;
00047         static const String     DefaultAlphanumerical;
00048         static const String     DefaultWrapDelimiters;
00049
00050
00051         /*************************************************************************
00052                 Methods
00053         *************************************************************************/
00074         static  String  getNextWord(const String& str, String::size_type start_idx = 0, const String& delimiters = DefaultWhitespace);
00075
00076
00093         static  String::size_type       getWordStartIdx(const String& str, String::size_type idx);
00094
00095
00113         static  String::size_type       getNextWordStartIdx(const String& str, String::size_type idx);
00114
00115
00126         static  void    trimLeadingChars(String& str, const String& chars);
00127
00128
00139         static  void    trimTrailingChars(String& str, const String& chars);
00140
00141
00142 private:
00143         /*************************************************************************
00144                 Data
00145         *************************************************************************/
00146         static  String          d_delimiters;
00147         static  String          d_whitespace;
00148
00149
00150         /*************************************************************************
00151                 Construction / Destruction
00152         *************************************************************************/
00157         TextUtils(void);
00158         ~TextUtils(void);
00159 };
00160
00161 } // End of  CEGUI namespace section
00162
00163
00164 #endif  // end of guard _CEGUITextUtils_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIThumb.h Source File

include » elements

CEGUIThumb.h

00001 /************************************************************************
00002         filename:       CEGUIThumb.h
00003         created:        25/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for a 'Thumb' widget.  Intended to be used as
00007                                 part of other widgets such as scrollers and sliders.
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _CEGUIThumb_h_
00028 #define _CEGUIThumb_h_
00029
00030 #include "CEGUIPushButton.h"
00031 #include "elements/CEGUIThumbProperties.h"
00032 #include <utility>
00033
00034
00035 #if defined(_MSC_VER)
00036 #       pragma warning(push)
00037 #       pragma warning(disable : 4251)
00038 #endif
00039
00040
00041 // Start of CEGUI namespace section
00042 namespace CEGUI
00043 {
00044
00052 class CEGUIEXPORT Thumb : public PushButton
00053 {
00054 public:
00055         static const String EventNamespace;
00056
00057
00058         /*************************************************************************
00059                 Event name constants
00060         *************************************************************************/
00061         // generated internally by Window
00062         static const String EventThumbPositionChanged;
00063         static const String EventThumbTrackStarted;
00064         static const String EventThumbTrackEnded;
00065
00066
00067         /*************************************************************************
00068                 Accessor Functions
00069         *************************************************************************/
00077         bool    isHotTracked(void) const                        {return d_hotTrack;}
00078
00087         bool    isVertFree(void) const                          {return d_vertFree;}
00088
00097         bool    isHorzFree(void) const                          {return d_horzFree;}
00098
00099
00108         std::pair<float, float> getVertRange(void) const;
00109
00110
00119         std::pair<float, float> getHorzRange(void) const;
00120
00121
00122         /*************************************************************************
00123                 Manipulator Functions
00124         *************************************************************************/
00135         void    setHotTracked(bool setting)                             {d_hotTrack = setting;}
00136
00137
00148         void    setVertFree(bool setting)                                               {d_vertFree = setting;}
00149
00150
00161         void    setHorzFree(bool setting)                                               {d_horzFree = setting;}
00162
00163
00180         void    setVertRange(float min, float max);
00181
00182
00199         void    setHorzRange(float min, float max);
00200
00201
00202         /*************************************************************************
00203                 Construction / Destruction
00204         *************************************************************************/
00209         Thumb(const String& type, const String& name);
00210
00211
00216         virtual ~Thumb(void);
00217
00218
00219 protected:
00220         /*************************************************************************
00221                 Implementation Functions
00222         *************************************************************************/
00227         void    addThumbEvents(void);
00228
00229
00240         virtual bool    testClassName_impl(const String& class_name) const
00241         {
00242                 if (class_name==(const utf8*)"Thumb")   return true;
00243                 return PushButton::testClassName_impl(class_name);
00244         }
00245
00246
00247         /*************************************************************************
00248                 New Thumb Events
00249         *************************************************************************/
00254         virtual void    onThumbPositionChanged(WindowEventArgs& e);
00255
00256
00261         virtual void    onThumbTrackStarted(WindowEventArgs& e);
00262
00263
00268         virtual void    onThumbTrackEnded(WindowEventArgs& e);
00269
00270
00271
00272         /*************************************************************************
00273                 Overridden event handling routines
00274         *************************************************************************/
00275         virtual void    onMouseMove(MouseEventArgs& e);
00276         virtual void    onMouseButtonDown(MouseEventArgs& e);
00277         virtual void    onCaptureLost(WindowEventArgs& e);
00278
00279
00280         /*************************************************************************
00281                 Implementation Data
00282         *************************************************************************/
00283         // general settings
00284         bool    d_hotTrack;
00285         bool    d_vertFree;
00286         bool    d_horzFree;
00287
00288         // operational limits
00289         float   d_vertMin, d_vertMax;
00290         float   d_horzMin, d_horzMax;
00291
00292         // internal state
00293         bool    d_beingDragged;
00294         Point   d_dragPoint;
00295
00296
00297 private:
00298         /*************************************************************************
00299                 Static Properties for this class
00300         *************************************************************************/
00301         static ThumbProperties::HotTracked      d_hotTrackedProperty;
00302         static ThumbProperties::VertFree        d_vertFreeProperty;
00303         static ThumbProperties::HorzFree        d_horzFreeProperty;
00304         static ThumbProperties::VertRange       d_vertRangeProperty;
00305         static ThumbProperties::HorzRange       d_horzRangeProperty;
00306
00307
00308         /*************************************************************************
00309                 Private methods
00310         *************************************************************************/
00311         void    addThumbProperties(void);
00312 };
00313
00314 } // End of  CEGUI namespace section
00315
00316 #if defined(_MSC_VER)
00317 #       pragma warning(pop)
00318 #endif
00319
00320 #endif  // end of guard _CEGUIThumb_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIThumbProperties.h Source File

include » elements

CEGUIThumbProperties.h

00001 /************************************************************************
00002         filename:       CEGUIThumbProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for Thumb properties
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIThumbProperties_h_
00027 #define _CEGUIThumbProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of ThumbProperties namespace section
00041 namespace ThumbProperties
00042 {
00055 class HotTracked : public Property
00056 {
00057 public:
00058         HotTracked() : Property(
00059                 "HotTracked",
00060                 "Property to get/set the state of the state of the 'hot-tracked' setting for the thumb.  Value is either \"True\" or \"False\".",
00061                 "True")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00081 class VertFree : public Property
00082 {
00083 public:
00084         VertFree() : Property(
00085                 "VertFree",
00086                 "Property to get/set the state the setting to free the thumb vertically.  Value is either \"True\" or \"False\".",
00087                 "False")
00088         {}
00089
00090         String  get(const PropertyReceiver* receiver) const;
00091         void    set(PropertyReceiver* receiver, const String& value);
00092 };
00093
00094
00107 class HorzFree : public Property
00108 {
00109 public:
00110         HorzFree() : Property(
00111                 "HorzFree",
00112                 "Property to get/set the state the setting to free the thumb horizontally.  Value is either \"True\" or \"False\".",
00113                 "False")
00114         {}
00115
00116         String  get(const PropertyReceiver* receiver) const;
00117         void    set(PropertyReceiver* receiver, const String& value);
00118 };
00119
00120
00133 class VertRange : public Property
00134 {
00135 public:
00136         VertRange() : Property(
00137                 "VertRange",
00138                 "Property to get/set the vertical movement range for the thumb.  Value is \"min:[float] max:[float]\".",
00139                 "min:0.000000 max:1.000000")
00140         {}
00141
00142         String  get(const PropertyReceiver* receiver) const;
00143         void    set(PropertyReceiver* receiver, const String& value);
00144 };
00145
00146
00159 class HorzRange : public Property
00160 {
00161 public:
00162         HorzRange() : Property(
00163                 "HorzRange",
00164                 "Property to get/set the horizontal movement range for the thumb.  Value is \"min:[float] max:[float]\".",
00165                 "min:0.000000 max:1.000000")
00166         {}
00167
00168         String  get(const PropertyReceiver* receiver) const;
00169         void    set(PropertyReceiver* receiver, const String& value);
00170 };
00171
00172
00173 } // End of  ThumbProperties namespace section
00174
00175 } // End of  CEGUI namespace section
00176
00177
00178 #endif  // end of guard _CEGUIThumbProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITinyXMLParser.h Source File

include

CEGUITinyXMLParser.h

00001 /************************************************************************
00002     filename:   CEGUITinyXMLParser.h
00003     created:    Sun Mar 13 2005
00004     author:     Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUITinyXMLParser_h_
00025 #define _CEGUITinyXMLParser_h_
00026
00027 #include "CEGUIXMLParser.h"
00028
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00037     class TinyXMLParser : public XMLParser
00038     {
00039     public:
00040         TinyXMLParser(void);
00041         ~TinyXMLParser(void);
00042
00043         // Implementation of public abstract interface
00044         void parseXMLFile(XMLHandler& handler, const String& filename, const String& schemaName, const String& resourceGroup);
00045
00046     protected:
00047         // Implementation of abstract interface.
00048         bool initialiseImpl(void);
00049         void cleanupImpl(void);
00050     };
00051
00052 } // End of  CEGUI namespace section
00053
00054
00055 #endif  // end of guard _CEGUITinyXMLParser_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITitlebar.h Source File

include » elements

CEGUITitlebar.h

00001 /************************************************************************
00002         filename:       CEGUITitlebar.h
00003         created:        25/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for a Titlebar Widget
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITitlebar_h_
00027 #define _CEGUITitlebar_h_
00028
00029 #include "CEGUIWindow.h"
00030 #include "elements/CEGUITitlebarProperties.h"
00031
00032
00033 #if defined(_MSC_VER)
00034 #       pragma warning(push)
00035 #       pragma warning(disable : 4251)
00036 #endif
00037
00038
00039 // Start of CEGUI namespace section
00040 namespace CEGUI
00041 {
00042
00048 class CEGUIEXPORT Titlebar : public Window
00049 {
00050 public:
00051         static const String EventNamespace;
00052
00053
00061         bool    isDraggingEnabled(void) const;
00062
00063
00074         void    setDraggingEnabled(bool setting);
00075
00076
00084         colour  getCaptionColour(void) const;
00085
00086
00097         void    setCaptionColour(const colour& col);
00098
00099
00100         /*************************************************************************
00101                 Construction / Destruction
00102         *************************************************************************/
00107         Titlebar(const String& type, const String& name);
00108
00109
00114         virtual ~Titlebar(void);
00115
00116
00117 protected:
00118         /*************************************************************************
00119                 Overridden event handler functions
00120         *************************************************************************/
00121         virtual void    onMouseMove(MouseEventArgs& e);
00122         virtual void    onMouseButtonDown(MouseEventArgs& e);
00123         virtual void    onMouseButtonUp(MouseEventArgs& e);
00124         virtual void    onMouseDoubleClicked(MouseEventArgs& e);
00125         virtual void    onCaptureLost(WindowEventArgs& e);
00126         virtual void    onFontChanged(WindowEventArgs &e);
00127
00128
00129         /*************************************************************************
00130                 New event handlers for title bar
00131         *************************************************************************/
00139         virtual void    onDraggingModeChanged(WindowEventArgs& e) {}
00140
00141
00142         /*************************************************************************
00143                 Implementation Functions
00144         *************************************************************************/
00155         virtual bool    testClassName_impl(const String& class_name) const
00156         {
00157                 if (class_name==(const utf8*)"Titlebar")        return true;
00158                 return Window::testClassName_impl(class_name);
00159         }
00160
00161
00162         /*************************************************************************
00163                 Implementation Data
00164         *************************************************************************/
00165         bool    d_dragging;
00166         Point   d_dragPoint;
00167         bool    d_dragEnabled;
00168
00169         Rect    d_oldCursorArea;
00170
00171         colour  d_captionColour;
00172
00173
00174 private:
00175         /*************************************************************************
00176                 Static Properties for this class
00177         *************************************************************************/
00178         static TitlebarProperties::DraggingEnabled      d_dragEnabledProperty;
00179         static TitlebarProperties::CaptionColour        d_captionColourProperty;
00180
00181
00182         /*************************************************************************
00183                 Private methods
00184         *************************************************************************/
00185         void    addTitlebarProperties(void);
00186 };
00187
00188 } // End of  CEGUI namespace section
00189
00190 #if defined(_MSC_VER)
00191 #       pragma warning(pop)
00192 #endif
00193
00194 #endif  // end of guard _CEGUITitlebar_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITitlebarProperties.h Source File

include » elements

CEGUITitlebarProperties.h

00001 /************************************************************************
00002         filename:       CEGUITitlebarProperties.h
00003         created:        10/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for title bar property classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUITitlebarProperties_h_
00027 #define _CEGUITitlebarProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of TitlebarProperties namespace section
00041 namespace TitlebarProperties
00042 {
00055 class DraggingEnabled : public Property
00056 {
00057 public:
00058         DraggingEnabled() : Property(
00059                 "DraggingEnabled",
00060                 "Property to get/set the state of the dragging enabled setting for the Titlebar.  Value is either \"True\" or \"False\".",
00061                 "True")
00062         {}
00063
00064         String  get(const PropertyReceiver* receiver) const;
00065         void    set(PropertyReceiver* receiver, const String& value);
00066 };
00067
00068
00080 class CaptionColour : public Property
00081 {
00082 public:
00083         CaptionColour() : Property(
00084                 "CaptionColour",
00085                 "Property to get/set the colour used for rendering the caption text.  Value is \"aarrggbb\" (hex).",
00086                 "FF000000")
00087         {}
00088
00089         String  get(const PropertyReceiver* receiver) const;
00090         void    set(PropertyReceiver* receiver, const String& value);
00091 };
00092
00093 } // End of  TitlebarProperties namespace section
00094
00095 } // End of  CEGUI namespace section
00096
00097
00098 #endif  // end of guard _CEGUITitlebarProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITooltip.h Source File

include » elements

CEGUITooltip.h

00001 /************************************************************************
00002     filename:   CEGUITooltip.h
00003     created:    21/2/2005
00004     author:     Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUITooltip_h_
00025 #define _CEGUITooltip_h_
00026
00027 #include "CEGUIWindow.h"
00028 #include "elements/CEGUITooltipProperties.h"
00029
00030 #if defined(_MSC_VER)
00031 #       pragma warning(push)
00032 #       pragma warning(disable : 4251)
00033 #endif
00034
00035 // Start of CEGUI namespace section
00036 namespace CEGUI
00037 {
00053     class CEGUIEXPORT Tooltip : public Window
00054     {
00055     public:
00056         /*************************************************************************
00057             Constants
00058         *************************************************************************/
00059         static const String EventNamespace;
00060         static const String EventHoverTimeChanged;
00061         static const String EventDisplayTimeChanged;
00062         static const String EventFadeTimeChanged;
00063         static const String EventTooltipActive;
00064         static const String EventTooltipInactive;
00065
00066         /************************************************************************
00067             Object Construction and Destruction
00068         ************************************************************************/
00073         Tooltip(const String& type, const String& name);
00074
00079         ~Tooltip(void);
00080
00081         /************************************************************************
00082             Public interface
00083         ************************************************************************/
00095         void setTargetWindow(Window* wnd);
00096
00104         const Window* getTargetWindow();
00105
00114         void resetTimer(void);
00115
00124         float getHoverTime(void) const;
00125
00137         void setDisplayTime(float seconds);
00138
00147         float getFadeTime(void) const;
00148
00160         void setHoverTime(float seconds);
00161
00170         float getDisplayTime(void) const;
00171
00183         void setFadeTime(float seconds);
00184
00185         //
00193         void positionSelf(void);
00194
00195     protected:
00196         /*************************************************************************
00197             Implementation Methods
00198         *************************************************************************/
00203         void addTooltipEvents(void);
00204
00205         // methods to perform processing for each of the widget states
00206         void doActiveState(float elapsed);
00207         void doInactiveState(float elapsed);
00208         void doFadeInState(float elapsed);
00209         void doFadeOutState(float elapsed);
00210
00211         // methods to switch widget states
00212         void switchToInactiveState(void);
00213         void switchToActiveState(void);
00214         void switchToFadeInState(void);
00215         void switchToFadeOutState(void);
00216
00217
00228                 virtual bool    testClassName_impl(const String& class_name) const
00229                 {
00230                         if (class_name==(const utf8*)"Tooltip") return true;
00231                         return Window::testClassName_impl(class_name);
00232                 }
00233
00242         virtual Size getTextSize() const;
00243
00244         /*************************************************************************
00245             Event triggers
00246         *************************************************************************/
00257         virtual void onHoverTimeChanged(WindowEventArgs& e);
00258
00269         virtual void onDisplayTimeChanged(WindowEventArgs& e);
00270
00281         virtual void onFadeTimeChanged(WindowEventArgs& e);
00282
00293         virtual void onTooltipActive(WindowEventArgs& e);
00294
00305         virtual void onTooltipInactive(WindowEventArgs& e);
00306
00307
00308         /************************************************************************
00309             Overridden from Window.
00310         ************************************************************************/
00311         void updateSelf(float elapsed);
00312         void onMouseEnters(MouseEventArgs& e);
00313         void onTextChanged(WindowEventArgs& e);
00314
00315         /************************************************************************
00316             Enumerations
00317         ************************************************************************/
00322         enum TipState
00323         {
00324             Inactive,
00325             Active,
00326             FadeIn,
00327             FadeOut
00328         };
00329
00330         /************************************************************************
00331             Data fields
00332         ************************************************************************/
00333         TipState    d_state;
00334         float       d_elapsed;
00335         const Window* d_target;
00336         float       d_hoverTime;
00337         float       d_displayTime;
00338         float       d_fadeTime;
00339
00340     private:
00341         /*************************************************************************
00342             Static Properties for this class
00343         *************************************************************************/
00344         static TooltipProperties::HoverTime      d_hoverTimeProperty;
00345         static TooltipProperties::DisplayTime    d_displayTimeProperty;
00346         static TooltipProperties::FadeTime       d_fadeTimeProperty;
00347
00348         /*************************************************************************
00349             Private methods
00350         *************************************************************************/
00351         void addTooltipProperties(void);
00352     };
00353
00354 } // End of  CEGUI namespace section
00355
00356
00357 #if defined(_MSC_VER)
00358 #       pragma warning(pop)
00359 #endif
00360
00361 #endif  // end of guard _CEGUITooltip_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUITooltipProperties.h Source File

include » elements

CEGUITooltipProperties.h

00001 /************************************************************************
00002         filename:       CEGUITooltipProperties.h
00003         created:        3/3/2005
00004         author:         Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUITooltipProperties_h_
00025 #define _CEGUITooltipProperties_h_
00026
00027 #include "CEGUIProperty.h"
00028
00029 // Start of CEGUI namespace section
00030 namespace CEGUI
00031 {
00032 // Start of TooltipProperties namespace section
00037 namespace TooltipProperties
00038 {
00050     class HoverTime : public Property
00051     {
00052     public:
00053         HoverTime() : Property(
00054             "HoverTime",
00055             "Property to get/set the hover timeout value in seconds.  Value is a float.",
00056             "0.400000")
00057         {}
00058
00059         String  get(const PropertyReceiver* receiver) const;
00060         void    set(PropertyReceiver* receiver, const String& value);
00061     };
00062
00074     class DisplayTime : public Property
00075     {
00076     public:
00077         DisplayTime() : Property(
00078             "DisplayTime",
00079             "Property to get/set the display timeout value in seconds.  Value is a float.",
00080             "7.500000")
00081         {}
00082
00083         String  get(const PropertyReceiver* receiver) const;
00084         void    set(PropertyReceiver* receiver, const String& value);
00085     };
00086
00098     class FadeTime : public Property
00099     {
00100     public:
00101         FadeTime() : Property(
00102             "FadeTime",
00103             "Property to get/set duration of the fade effect in seconds.  Value is a float.",
00104             "0.330000")
00105         {}
00106
00107         String  get(const PropertyReceiver* receiver) const;
00108         void    set(PropertyReceiver* receiver, const String& value);
00109     };
00110
00111 } // End of  TooltipProperties namespace section
00112 } // End of  CEGUI namespace section
00113
00114
00115 #endif  // end of guard _CEGUITooltipProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIUDim.h Source File

include

CEGUIUDim.h

00001 /************************************************************************
00002     filename:   CEGUIUDim.h
00003     created:    Tue May 31 2005
00004     author:     Paul D Turner <paul@cegui.org.uk>
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIUDim_h_
00025 #define _CEGUIUDim_h_
00026
00027 #include "CEGUIRect.h"
00028 #include "CEGUIVector.h"
00029
00030 // some macros to aid in the creation of UDims
00031 #define cegui_absdim(x)     UDim(0,(x))
00032 #define cegui_reldim(x)     UDim((x),0)
00033
00034
00035 // Start of CEGUI namespace section
00036 namespace CEGUI
00037 {
00043     class CEGUIEXPORT UDim
00044     {
00045     public:
00046         UDim() {}
00047         UDim(float scale, float offset) : d_scale(scale), d_offset(offset) {}
00048         ~UDim() {}
00049
00050         float asAbsolute(float base) const    { return PixelAligned(base * d_scale) + d_offset; }
00051         float asRelative(float base) const    { return (base != 0.0f) ? d_offset / base + d_scale : 0.0f; }
00052
00053         UDim operator+(const UDim& other) const     { return UDim(d_scale + other.d_scale, d_offset + other.d_offset); }
00054         UDim operator-(const UDim& other) const     { return UDim(d_scale - other.d_scale, d_offset - other.d_offset); }
00055         UDim operator/(const UDim& other) const     { return UDim(d_scale / other.d_scale, d_offset / other.d_offset); }
00056         UDim operator*(const UDim& other) const     { return UDim(d_scale * other.d_scale, d_offset * other.d_offset); }
00057
00058         const UDim& operator+=(const UDim& other)   { d_scale += other.d_scale; d_offset += other.d_offset; return *this; }
00059         const UDim& operator-=(const UDim& other)   { d_scale -= other.d_scale; d_offset -= other.d_offset; return *this; }
00060         const UDim& operator/=(const UDim& other)   { d_scale /= other.d_scale; d_offset /= other.d_offset; return *this; }
00061         const UDim& operator*=(const UDim& other)   { d_scale *= other.d_scale; d_offset *= other.d_offset; return *this; }
00062
00063         bool operator==(const UDim& other) const    { return d_scale == other.d_scale && d_offset == other.d_offset; }
00064         bool operator!=(const UDim& other) const    { return !operator==(other); }
00065
00066         float d_scale, d_offset;
00067     };
00068
00074     class CEGUIEXPORT UVector2
00075     {
00076     public:
00077         UVector2() {}
00078         UVector2(const UDim& x, const UDim& y) : d_x(x), d_y(y) {}
00079         ~UVector2() {}
00080
00081         Vector2 asAbsolute(const Size& base) const    { return Vector2(d_x.asAbsolute(base.d_width), d_y.asAbsolute(base.d_height)); }
00082         Vector2 asRelative(const Size& base) const    { return Vector2(d_x.asRelative(base.d_width), d_y.asRelative(base.d_height)); }
00083
00084         UVector2 operator+(const UVector2& other) const     { return UVector2(d_x + other.d_x, d_y + other.d_y); }
00085         UVector2 operator-(const UVector2& other) const     { return UVector2(d_x - other.d_x, d_y - other.d_y); }
00086         UVector2 operator/(const UVector2& other) const     { return UVector2(d_x / other.d_x, d_y / other.d_y); }
00087         UVector2 operator*(const UVector2& other) const     { return UVector2(d_x * other.d_x, d_y * other.d_y); }
00088
00089         const UVector2& operator+=(const UVector2& other)   { d_x += other.d_x; d_y += other.d_y; return *this; }
00090         const UVector2& operator-=(const UVector2& other)   { d_x -= other.d_x; d_y -= other.d_y; return *this; }
00091         const UVector2& operator/=(const UVector2& other)   { d_x /= other.d_x; d_y /= other.d_y; return *this; }
00092         const UVector2& operator*=(const UVector2& other)   { d_x *= other.d_x; d_y *= other.d_y; return *this; }
00093
00094         bool operator==(const UVector2& other) const    { return d_x == other.d_x && d_y == other.d_y; }
00095         bool operator!=(const UVector2& other) const    { return !operator==(other); }
00096
00097         UDim d_x, d_y;
00098     };
00099
00104     class CEGUIEXPORT URect
00105     {
00106     public:
00107         URect() {}
00108
00109         URect(const UVector2& min, const UVector2& max) : d_min(min), d_max(max) {}
00110
00111         URect(const UDim& left, const UDim& top, const UDim& right, const UDim& bottom)
00112         {
00113             d_min.d_x = left;
00114             d_min.d_y = top;
00115             d_max.d_x = right;
00116             d_max.d_y = bottom;
00117         }
00118
00119         ~URect() {}
00120
00121         Rect asAbsolute(const Size& base) const
00122         {
00123             return Rect(
00124                     d_min.d_x.asAbsolute(base.d_width),
00125                     d_min.d_y.asAbsolute(base.d_height),
00126                     d_max.d_x.asAbsolute(base.d_width),
00127                     d_max.d_y.asAbsolute(base.d_height)
00128                 );
00129         }
00130
00131         Rect asRelative(const Size& base) const
00132         {
00133             return Rect(
00134                     d_min.d_x.asRelative(base.d_width),
00135                     d_min.d_y.asRelative(base.d_height),
00136                     d_max.d_x.asRelative(base.d_width),
00137                     d_max.d_y.asRelative(base.d_height)
00138                 );
00139         }
00140
00141         const UVector2& getPosition() const     { return d_min; }
00142         UVector2 getSize() const                { return d_max - d_min; }
00143         UDim getWidth() const                   { return d_max.d_x - d_min.d_x; }
00144         UDim getHeight() const                  { return d_max.d_y - d_min.d_y; }
00145
00146         void setPosition(const UVector2& pos)
00147         {
00148             UVector2 sz(d_max - d_min);
00149             d_min = pos;
00150             d_max = d_min + sz;
00151         }
00152
00153         void setSize(const UVector2& sz)
00154         {
00155             d_max = d_min + sz;
00156         }
00157
00158         void setWidth(const UDim& w)        { d_max.d_x = d_min.d_x + w; }
00159         void setHeight(const UDim& h)       { d_max.d_y = d_min.d_y + h; }
00160
00161         void offset(const UVector2& sz)
00162         {
00163             d_min += sz;
00164             d_max += sz;
00165         }
00166
00167         UVector2 d_min, d_max;
00168     };
00169
00170 } // End of  CEGUI namespace section
00171
00172
00173 #endif  // end of guard _CEGUIUDim_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIVector.h Source File

include

CEGUIVector.h

00001 /************************************************************************
00002         filename:       CEGUIVector.h
00003         created:        14/3/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interfaces for Vector classes
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIVector_h_
00027 #define _CEGUIVector_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUISize.h"
00031
00032
00033 // Start of CEGUI namespace section
00034 namespace CEGUI
00035 {
00036
00041 class CEGUIEXPORT Vector2
00042 {
00043 public:
00044         Vector2(void) {}
00045         Vector2(float x, float y) : d_x(x), d_y(y) {}
00046
00047         Vector2& operator*=(const Vector2& vec)
00048         {
00049                 d_x *= vec.d_x;
00050                 d_y *= vec.d_y;
00051
00052                 return *this;
00053         }
00054
00055         Vector2& operator/=(const Vector2& vec)
00056         {
00057                 d_x /= vec.d_x;
00058                 d_y /= vec.d_y;
00059
00060                 return *this;
00061         }
00062
00063         Vector2& operator+=(const Vector2& vec)
00064         {
00065                 d_x += vec.d_x;
00066                 d_y += vec.d_y;
00067
00068                 return *this;
00069         }
00070
00071         Vector2& operator-=(const Vector2& vec)
00072         {
00073                 d_x -= vec.d_x;
00074                 d_y -= vec.d_y;
00075
00076                 return *this;
00077         }
00078
00079         Vector2 operator+(const Vector2& vec) const
00080         {
00081                 return Vector2(d_x + vec.d_x, d_y + vec.d_y);
00082         }
00083
00084         Vector2 operator-(const Vector2& vec) const
00085         {
00086                 return Vector2(d_x - vec.d_x, d_y - vec.d_y);
00087         }
00088
00089         Vector2 operator*(const Vector2& vec) const
00090         {
00091                 return Vector2(d_x * vec.d_x, d_y * vec.d_y);
00092         }
00093
00094         bool    operator==(const Vector2& vec) const
00095         {
00096                 return ((d_x == vec.d_x) && (d_y == vec.d_y));
00097         }
00098
00099         bool    operator!=(const Vector2& vec) const
00100         {
00101                 return !(operator==(vec));
00102         }
00103
00104     Size asSize() const     { return Size(d_x, d_y); }
00105
00106         float d_x, d_y;
00107 };
00108
00113 typedef Vector2         Point;
00114
00115
00120 class CEGUIEXPORT Vector3
00121 {
00122 public:
00123         Vector3(void) {}
00124         Vector3(float x, float y, float z) : d_x(x), d_y(y), d_z(z) {}
00125
00126         float   d_x, d_y, d_z;
00127 };
00128
00129 } // End of  CEGUI namespace section
00130
00131
00132 #endif  // end of guard _CEGUIVector_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIVersion.h Source File

include

CEGUIVersion.h

00001 /************************************************************************
00002         filename:       CEGUIVersion.h
00003         created:        7/3/2005
00004         author:         jacmoe
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00025 /*************************************************************************
00026
00027 This file contains CEGUI version defines
00028 *************************************************************************/
00030 #ifndef _CEGUIVersion_h_
00031 #define _CEGUIVersion_h_
00032
00034 // Define CEGUI version
00036 #define CEGUI_VERSION_MAJOR 0
00037 #define CEGUI_VERSION_MINOR 4
00038 #define CEGUI_VERSION_PATCH 1
00039
00040 #endif  // end of guard _CEGUIVersion_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIWindow.h Source File

include

CEGUIWindow.h

00001 /************************************************************************
00002         filename:       CEGUIWindow.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines abstract base class for Window objects
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIWindow_h_
00027 #define _CEGUIWindow_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIVector.h"
00032 #include "CEGUIRect.h"
00033 #include "CEGUISize.h"
00034 #include "CEGUIEventSet.h"
00035 #include "CEGUIPropertySet.h"
00036 #include "CEGUISystem.h"
00037 #include "CEGUIInputEvent.h"
00038 #include "CEGUIWindowProperties.h"
00039 #include "CEGUIUDim.h"
00040 #include "CEGUIRenderCache.h"
00041 #include <vector>
00042
00043
00044 #if defined(_MSC_VER)
00045 #       pragma warning(push)
00046 #       pragma warning(disable : 4251)
00047 #endif
00048
00049
00050 // Start of CEGUI namespace section
00051 namespace CEGUI
00052 {
00053
00062 enum MetricsMode
00063 {
00064         Relative,
00065         Absolute,
00066         Inherited
00067 };
00068
00073 enum VerticalAlignment
00074 {
00075     VA_TOP,
00076     VA_CENTRE,
00077     VA_BOTTOM
00078 };
00079
00084 enum HorizontalAlignment
00085 {
00086     HA_LEFT,
00087     HA_CENTRE,
00088     HA_RIGHT
00089 };
00090
00100 class CEGUIEXPORT Window : public PropertySet, public EventSet
00101 {
00102 public:
00103         static const String EventNamespace;
00104
00105         /*************************************************************************
00106                 Event name constants
00107         *************************************************************************/
00108         // generated internally by Window
00109         static const String EventParentSized;
00110         static const String EventSized;
00111         static const String EventMoved;
00112         static const String EventTextChanged;
00113         static const String EventFontChanged;
00114         static const String EventAlphaChanged;
00115         static const String EventIDChanged;
00116         static const String EventActivated;
00117         static const String EventDeactivated;
00118         static const String EventShown;
00119         static const String EventHidden;
00120         static const String EventEnabled;
00121         static const String EventDisabled;
00122         static const String EventMetricsModeChanged;
00123         static const String EventClippedByParentChanged;
00124         static const String EventDestroyedByParentChanged;
00125         static const String EventInheritsAlphaChanged;
00126         static const String EventAlwaysOnTopChanged;
00127         static const String EventInputCaptureGained;
00128         static const String EventInputCaptureLost;
00129         static const String EventRenderingStarted;
00130         static const String EventRenderingEnded;
00131         static const String EventChildAdded;
00132         static const String EventChildRemoved;
00133         static const String EventDestructionStarted;
00134         static const String EventZOrderChanged;
00135         static const String EventDragDropItemEnters;
00136         static const String EventDragDropItemLeaves;
00137         static const String EventDragDropItemDropped;
00138     static const String EventVerticalAlignmentChanged;
00139     static const String EventHorizontalAlignmentChanged;
00140
00141         // generated externally (inputs)
00142         static const String EventMouseEnters;
00143         static const String EventMouseLeaves;
00144         static const String EventMouseMove;
00145         static const String EventMouseWheel;
00146         static const String EventMouseButtonDown;
00147         static const String EventMouseButtonUp;
00148         static const String EventMouseClick;
00149         static const String EventMouseDoubleClick;
00150         static const String EventMouseTripleClick;
00151         static const String EventKeyDown;
00152         static const String EventKeyUp;
00153         static const String EventCharacterKey;
00154
00155
00156         /*************************************************************************
00157                 Construction and Destruction
00158         *************************************************************************/
00169         Window(const String& type, const String& name);
00170
00171
00176         virtual ~Window(void);
00177
00178
00179         /*************************************************************************
00180                 Accessor functions
00181         *************************************************************************/
00189         const String& getType(void) const;
00190
00191
00199         const String& getName(void) const               {return d_name;}
00200
00201
00209         bool    isDestroyedByParent(void) const         {return d_destroyedByParent;}
00210
00211
00219         bool    isAlwaysOnTop(void) const                       {return d_alwaysOnTop;}
00220
00221
00233         bool    isDisabled(bool localOnly = false) const;
00234
00235
00250         bool    isVisible(bool localOnly = false) const;
00251
00252
00263         bool    isActive(void) const;
00264
00265
00273         bool    isClippedByParent(void) const           {return d_clippedByParent;}
00274
00275
00283         uint    getID(void) const               {return d_ID;}
00284
00285
00293         uint   getChildCount(void) const      {return (uint)d_children.size();}
00294
00295
00306         bool    isChild(const String& name) const;
00307
00308
00323         bool    isChild(uint ID) const;
00324
00325
00336         bool    isChild(const Window* window) const;
00337
00338
00356         Window* getChild(const String& name) const;
00357
00358
00376         Window* getChild(uint ID) const;
00377
00378
00390         Window* getChildAtIdx(uint idx) const           {return d_children[idx];}
00391
00392
00402         Window* getActiveChild(void);
00403         const Window* getActiveChild(void) const;
00404
00405
00416         bool    isAncestor(const String& name) const;
00417
00418
00429         bool    isAncestor(uint ID) const;
00430
00431
00442         bool    isAncestor(const Window* window) const;
00443
00444
00455         const Font*             getFont(bool useDefault = true) const;
00456
00457
00465         const String&   getText(void) const             {return d_text;}
00466
00467
00475         bool    inheritsAlpha(void) const               {return d_inheritsAlpha;}
00476
00477
00491         float   getAlpha(void) const                    {return d_alpha;}
00492
00493
00502         float   getEffectiveAlpha(void) const;
00503
00504
00513         Rect    getRect(void) const;
00514
00515
00527         virtual Rect    getPixelRect(void) const;
00528
00529
00537         Rect    getInnerRect(void) const;
00538
00539
00548         Rect    getUnclippedPixelRect(void) const;
00549
00550
00559         virtual Rect    getUnclippedInnerRect(void) const;
00560
00561
00569         static  Window* getCaptureWindow(void)          {return d_captureWindow;}
00570
00571
00579         bool    isCapturedByThis(void) const            {return getCaptureWindow() == this;}
00580
00581
00589         bool    isCapturedByAncestor(void) const        {return isAncestor(getCaptureWindow());}
00590
00591
00599         bool    isCapturedByChild(void) const           {return isChild(getCaptureWindow());}
00600
00601
00612         virtual bool    isHit(const Point& position) const;
00613
00614
00625         Window* getChildAtPosition(const Point& position) const;
00626
00627
00635         MetricsMode     getMetricsMode(void) const;
00636
00637
00646         float   getXPosition(void) const;
00647
00648
00657         float   getYPosition(void) const;
00658
00659
00668         Point   getPosition(void) const;
00669
00670
00679         float   getWidth(void) const;
00680
00689         float   getHeight(void) const;
00690
00691
00700         Size    getSize(void) const;
00701
00702
00711         Window* getParent(void) const                           {return d_parent;}
00712
00713
00722         Size    getMaximumSize(void) const;
00723
00724
00733         Size    getMinimumSize(void) const;
00734
00735
00746         const Image*    getMouseCursor(bool useDefault = true) const;
00747
00748
00756     Rect        getRelativeRect(void) const                             { return d_area.asRelative(getParentSize()); }
00757
00758
00766         Point   getRelativePosition(void) const                 { return d_area.getPosition().asRelative(getParentSize()); }
00767
00768
00776         float   getRelativeXPosition(void) const                { return d_area.d_min.d_x.asRelative(getParentWidth()); }
00777
00778
00786         float   getRelativeYPosition(void) const                { return d_area.d_min.d_y.asRelative(getParentHeight()); }
00787
00788
00796     Size        getRelativeSize(void) const                             { return d_area.getSize().asRelative(getParentSize()).asSize(); }
00797
00798
00806         float   getRelativeWidth(void) const                    { return d_area.getWidth().asRelative(getParentWidth()); }
00807
00808
00816         float   getRelativeHeight(void) const                   { return d_area.getHeight().asRelative(getParentHeight()); }
00817
00818
00826     Rect        getAbsoluteRect(void) const                             { return Rect(d_area.getPosition().asAbsolute(getParentSize()), d_pixelSize); }
00827
00828
00836         Point   getAbsolutePosition(void) const                 { return d_area.getPosition().asAbsolute(getParentSize()); }
00837
00838
00846         float   getAbsoluteXPosition(void) const                { return d_area.d_min.d_x.asAbsolute(getParentWidth()); }
00847
00848
00856         float   getAbsoluteYPosition(void) const                { return d_area.d_min.d_y.asAbsolute(getParentHeight()); }
00857
00858
00866         Size    getAbsoluteSize(void) const                             { return d_pixelSize; }
00867
00868
00876         float   getAbsoluteWidth(void) const                    { return d_pixelSize.d_width; }
00877
00878
00886         float   getAbsoluteHeight(void) const                   { return d_pixelSize.d_height; }
00887
00888
00899         void*   getUserData(void) const                 {return d_userData;}
00900
00901
00912         float   getXPosition(MetricsMode mode) const;
00913
00914
00925         float   getYPosition(MetricsMode mode) const;
00926
00927
00938         Point   getPosition(MetricsMode mode) const;
00939
00940
00951         float   getWidth(MetricsMode mode) const;
00952
00953
00964         float   getHeight(MetricsMode mode) const;
00965
00966
00977         Size    getSize(MetricsMode mode) const;
00978
00979
00990         Rect    getRect(MetricsMode mode) const;
00991
00992
01003         bool    restoresOldCapture(void) const          {return d_restoreOldCapture;}
01004
01005
01014         bool    isZOrderingEnabled(void) const;
01015
01016
01025     bool    wantsMultiClickEvents(void) const;
01026
01027
01036     bool    isMouseAutoRepeatEnabled(void) const;
01037
01038
01046     float   getAutoRepeatDelay(void) const;
01047
01048
01056     float   getAutoRepeatRate(void) const;
01057
01058
01068     bool    distributesCapturedInputs(void) const;
01069
01070
01079     bool isUsingDefaultTooltip(void) const;
01080
01089     Tooltip* getTooltip(void) const;
01090
01098     String getTooltipType(void) const;
01099
01107     const String& getTooltipText(void) const;
01108
01117     bool inheritsTooltipText(void) const;
01118
01127     bool isRiseOnClickEnabled(void) const   { return d_riseOnClick; }
01128
01139         bool testClassName(const String& class_name) const              {return testClassName_impl(class_name);}
01140
01151     VerticalAlignment getVerticalAlignment() const  {return d_vertAlign;}
01152
01163     HorizontalAlignment getHorizontalAlignment() const  {return d_horzAlign;}
01164
01172     RenderCache& getRenderCache()   { return d_renderCache; }
01173
01182     const String& getLookNFeel();
01183
01191         bool getModalState(void) const  {return (System::getSingleton().getModalTarget() == this);}
01192
01193
01206     const String& getUserString(const String& name) const;
01207
01219     bool isUserStringDefined(const String& name) const;
01220
01235     Window* getActiveSibling();
01236
01237     /*************************************************************************
01238                 Manipulator functions
01239         *************************************************************************/
01250     void rename(const String& new_name);
01251
01262         virtual void    initialise(void) {}
01263
01264
01276         void    setDestroyedByParent(bool setting);
01277
01278
01289         void    setAlwaysOnTop(bool setting);
01290
01291
01302         void    setEnabled(bool setting);
01303
01304
01312         void    enable(void)            {setEnabled(true);}
01313
01314
01322         void    disable(void)           {setEnabled(false);}
01323
01324
01335         void    setVisible(bool setting);
01336
01337
01345         void    show(void)                      {setVisible(true);}
01346
01347
01355         void    hide(void)                      {setVisible(false);}
01356
01357
01365         void    activate(void);
01366
01367
01376         void    deactivate(void);
01377
01378
01390         void    setClippedByParent(bool setting);
01391
01392
01403         void    setID(uint ID);
01404
01405
01416         void    setText(const String& text);
01417
01418
01429         void    setWidth(float width);
01430
01431
01442         void    setHeight(float height);
01443
01444
01455         void    setSize(const Size& size);
01456
01457
01468         void    setXPosition(float x);
01469
01470
01481         void    setYPosition(float y);
01482
01483
01494         void    setPosition(const Point& position);
01495
01496
01508         void    setAreaRect(const Rect& area);
01509
01510
01521         void    setFont(const Font* font);
01522
01523
01536         void    setFont(const String& name);
01537
01538
01553         void    addChildWindow(const String& name);
01554
01555
01569         void    addChildWindow(Window* window);
01570
01571
01582         void    removeChildWindow(const String& name);
01583
01584
01595         void    removeChildWindow(Window* window);
01596
01597
01609         void    removeChildWindow(uint ID);
01610
01611
01623         void    moveToFront();
01624
01625
01636         void    moveToBack();
01637
01638
01647         bool    captureInput(void);
01648
01649
01657         void    releaseInput(void);
01658
01659
01675         void    setRestoreCapture(bool setting);
01676
01677
01694         void    setAlpha(float alpha);
01695
01696
01707         void    setInheritsAlpha(bool setting);
01708
01709
01717         void    requestRedraw(void) const;
01718
01719
01730         void setMetricsMode(MetricsMode mode);
01731
01732
01741         void    setMinimumSize(const Size& sz);
01742
01743
01752         void    setMaximumSize(const Size& sz);
01753
01754
01765         void    setMouseCursor(const Image* image)              {d_mouseCursor = image;}
01766
01767
01778         void    setMouseCursor(MouseCursorImage image)          {d_mouseCursor = (const Image*)image;}
01779
01780
01796         void    setMouseCursor(const String& imageset, const String& image_name);
01797
01798
01812         void    setUserData(void* user_data)            {d_userData = user_data;}
01813
01814
01828         void    setXPosition(MetricsMode mode, float x);
01829
01830
01844         void    setYPosition(MetricsMode mode, float y);
01845
01846
01860         void    setPosition(MetricsMode mode, const Point& position);
01861
01862
01876         void    setWidth(MetricsMode mode, float width);
01877
01878
01892         void    setHeight(MetricsMode mode, float height);
01893
01894
01908         void    setSize(MetricsMode mode, const Size& size);
01909
01910
01924         void    setRect(MetricsMode mode, const Rect& area);
01925
01926
01938         void    setZOrderingEnabled(bool setting);
01939
01940
01952     void setWantsMultiClickEvents(bool setting);
01953
01954
01966     void    setMouseAutoRepeatEnabled(bool setting);
01967
01968
01979     void   setAutoRepeatDelay(float delay);
01980
01981
01992     void   setAutoRepeatRate(float rate);
01993
01994
02004     void    setDistributesCapturedInputs(bool setting);
02005
02011     void    notifyDragDropItemEnters(DragContainer* item);
02012
02018     void    notifyDragDropItemLeaves(DragContainer* item);
02019
02025     void    notifyDragDropItemDropped(DragContainer* item);
02026
02040     virtual void    destroy(void);
02041
02055     void setTooltip(Tooltip* tooltip);
02056
02072     void setTooltipType(const String& tooltipType);
02073
02084     void setTooltipText(const String& tip);
02085
02097     void setInheritsTooltipText(bool setting);
02098
02110     void setRiseOnClickEnabled(bool setting)    { d_riseOnClick = setting; }
02111
02125     void setVerticalAlignment(const VerticalAlignment alignment);
02126
02140     void setHorizontalAlignment(const HorizontalAlignment alignment);
02141
02158     void setLookNFeel(const String& falagardType, const String& look);
02159
02172         void setModalState(bool state);
02173
02184     virtual void performChildWindowLayout();
02185
02199     void setUserString(const String& name, const String& value);
02200
02201     /*************************************************************************
02202                 Co-ordinate and Size Conversion Functions
02203         *************************************************************************/
02214         float   absoluteToRelativeX(float val) const;
02215
02216
02227         float   absoluteToRelativeY(float val) const;
02228
02229
02240         Point   absoluteToRelative(const Point& pt) const;
02241
02242
02253         Size    absoluteToRelative(const Size& sze) const;
02254
02255
02266         Rect    absoluteToRelative(const Rect& rect) const;
02267
02268
02279         float   relativeToAbsoluteX(float val) const;
02280
02281
02292         float   relativeToAbsoluteY(float val) const;
02293
02294
02305         Point   relativeToAbsolute(const Point& pt) const;
02306
02307
02318         Size    relativeToAbsolute(const Size& sze) const;
02319
02320
02331         Rect    relativeToAbsolute(const Rect& rect) const;
02332
02333
02344         float   windowToScreenX(float x) const;
02345
02346
02357         float   windowToScreenY(float y) const;
02358
02359
02370         Point   windowToScreen(const Point& pt) const;
02371
02372
02383         Size    windowToScreen(const Size& sze) const;
02384
02385
02396         Rect    windowToScreen(const Rect& rect) const;
02397
02398
02409         float   screenToWindowX(float x) const;
02410
02411
02422         float   screenToWindowY(float y) const;
02423
02424
02435         Point   screenToWindow(const Point& pt) const;
02436
02437
02448         Size    screenToWindow(const Size& sze) const;
02449
02450
02461         Rect    screenToWindow(const Rect& rect) const;
02462
02463
02474     float unifiedToRelativeX(const UDim& val) const;
02475
02476
02487     float       unifiedToRelativeY(const UDim& val) const;
02488
02489
02500     Vector2 unifiedToRelative(const UVector2& val) const;
02501
02502
02513     Rect unifiedToRelative(const URect& val) const;
02514
02515
02526     float unifiedToAbsoluteX(const UDim& val) const;
02527
02528
02539     float       unifiedToAbsoluteY(const UDim& val) const;
02540
02541
02552     Vector2 unifiedToAbsolute(const UVector2& val) const;
02553
02554
02565     Rect unifiedToAbsolute(const URect& val) const;
02566
02567
02578     float windowToScreenX(const UDim& x) const;
02579
02580
02591     float windowToScreenY(const UDim& y) const;
02592
02593
02604     Vector2 windowToScreen(const UVector2& vec) const;
02605
02606
02617     Rect windowToScreen(const URect& rect) const;
02618
02619
02630     float screenToWindowX(const UDim& x) const;
02631
02632
02643     float screenToWindowY(const UDim& y) const;
02644
02645
02656     Vector2 screenToWindow(const UVector2& vec) const;
02657
02658
02669     Rect screenToWindow(const URect& rect) const;
02670
02671
02672     /*************************************************************************
02673         Interface to unified co-ordinate system
02674     *************************************************************************/
02699     void setWindowArea(const UDim& xpos, const UDim& ypos, const UDim& width, const UDim& height);
02700
02719     void setWindowArea(const UVector2& pos, const UVector2& size);
02720
02736     void setWindowArea(const URect& area);
02737
02753     void setWindowPosition(const UVector2& pos);
02754
02770     void setWindowXPosition(const UDim& x);
02771
02787     void setWindowYPosition(const UDim& y);
02788
02802     void setWindowSize(const UVector2& size);
02803
02817     void setWindowWidth(const UDim& width);
02818
02832     void setWindowHeight(const UDim& height);
02833
02848     void setWindowMaxSize(const UVector2& size);
02849
02864     void setWindowMinSize(const UVector2& size);
02865
02881     const URect& getWindowArea() const;
02882
02898     const UVector2& getWindowPosition() const;
02899
02915     const UDim& getWindowXPosition() const;
02916
02932     const UDim& getWindowYPosition() const;
02933
02947     UVector2 getWindowSize() const;
02948
02962     UDim getWindowWidth() const;
02963
02977     UDim getWindowHeight() const;
02978
02993     const UVector2& getWindowMaxSize() const;
02994
03009     const UVector2& getWindowMinSize() const;
03010
03011
03012         /*************************************************************************
03013                 Main render function.
03014         *************************************************************************/
03022         void    render(void);
03023
03024
03040         void    update(float elapsed);
03041
03042
03053     virtual void writeXMLToStream(OutStream& out_stream) const;
03054
03055 protected:
03056         /*************************************************************************
03057                 System object can trigger events directly
03058         *************************************************************************/
03059         friend  class System;
03060
03061
03062         /*************************************************************************
03063                 Event trigger methods
03064         *************************************************************************/
03073         virtual void    onSized(WindowEventArgs& e);
03074
03075
03084         virtual void    onMoved(WindowEventArgs& e);
03085
03086
03095         virtual void    onTextChanged(WindowEventArgs& e);
03096
03097
03106         virtual void    onFontChanged(WindowEventArgs& e);
03107
03108
03117         virtual void    onAlphaChanged(WindowEventArgs& e);
03118
03119
03128         virtual void    onIDChanged(WindowEventArgs& e);
03129
03130
03139         virtual void    onShown(WindowEventArgs& e);
03140
03141
03150         virtual void    onHidden(WindowEventArgs& e);
03151
03152
03161         virtual void    onEnabled(WindowEventArgs& e);
03162
03163
03172         virtual void    onDisabled(WindowEventArgs& e);
03173
03174
03183         virtual void    onMetricsChanged(WindowEventArgs& e);
03184
03185
03194         virtual void    onClippingChanged(WindowEventArgs& e);
03195
03196
03205         virtual void    onParentDestroyChanged(WindowEventArgs& e);
03206
03207
03216         virtual void    onInheritsAlphaChanged(WindowEventArgs& e);
03217
03218
03227         virtual void    onAlwaysOnTopChanged(WindowEventArgs& e);
03228
03229
03238         virtual void    onCaptureGained(WindowEventArgs& e);
03239
03240
03249         virtual void    onCaptureLost(WindowEventArgs& e);
03250
03251
03260         virtual void    onRenderingStarted(WindowEventArgs& e);
03261
03262
03271         virtual void    onRenderingEnded(WindowEventArgs& e);
03272
03273
03282         virtual void    onZChanged(WindowEventArgs& e);
03283
03284
03293         virtual void    onDestructionStarted(WindowEventArgs& e);
03294
03295
03303         virtual void    onActivated(ActivationEventArgs& e);
03304
03305
03313         virtual void    onDeactivated(ActivationEventArgs& e);
03314
03315
03325         virtual void    onParentSized(WindowEventArgs& e);
03326
03327
03335         virtual void    onChildAdded(WindowEventArgs& e);
03336
03337
03345         virtual void    onChildRemoved(WindowEventArgs& e);
03346
03347
03355         virtual void    onMouseEnters(MouseEventArgs& e);
03356
03357
03365         virtual void    onMouseLeaves(MouseEventArgs& e);
03366
03367
03375         virtual void    onMouseMove(MouseEventArgs& e);
03376
03377
03385         virtual void    onMouseWheel(MouseEventArgs& e);
03386
03387
03395         virtual void    onMouseButtonDown(MouseEventArgs& e);
03396
03397
03405         virtual void    onMouseButtonUp(MouseEventArgs& e);
03406
03407
03416         virtual void    onMouseClicked(MouseEventArgs& e);
03417
03418
03426         virtual void    onMouseDoubleClicked(MouseEventArgs& e);
03427
03428
03436         virtual void    onMouseTripleClicked(MouseEventArgs& e);
03437
03438
03447         virtual void    onKeyDown(KeyEventArgs& e);
03448
03449
03459         virtual void    onKeyUp(KeyEventArgs& e);
03460
03461
03471         virtual void    onCharacter(KeyEventArgs& e);
03472
03482     virtual void    onDragDropItemEnters(DragDropEventArgs& e);
03483
03484
03494     virtual void    onDragDropItemLeaves(DragDropEventArgs& e);
03495
03496
03506     virtual void    onDragDropItemDropped(DragDropEventArgs& e);
03507
03508
03517     virtual void    onVerticalAlignmentChanged(WindowEventArgs& e);
03518
03519
03528     virtual void    onHorizontalAlignmentChanged(WindowEventArgs& e);
03529
03530
03531         /*************************************************************************
03532                 Implementation Functions
03533         *************************************************************************/
03544         virtual void    updateSelf(float elapsed);
03545
03546
03557         virtual void    drawSelf(float z);
03558
03559
03566     virtual void populateRenderCache()  {}
03567
03568
03579         virtual bool    testClassName_impl(const String& class_name) const
03580         {
03581                 if (class_name==(const utf8*)"Window")  return true;
03582                 return false;
03583         }
03584
03585
03596         void    setParent(Window* parent);
03597
03598
03606         float   getParentWidth(void) const;
03607
03608
03616         float   getParentHeight(void) const;
03617
03618
03626         Size    getParentSize(void) const;
03627
03628
03643         Rect    absoluteToRelative_impl(const Window* window, const Rect& rect) const;
03644         Size    absoluteToRelative_impl(const Window* window, const Size& sz) const;
03645         Point   absoluteToRelative_impl(const Window* window, const Point& pt) const;
03646         float   absoluteToRelativeX_impl(const Window* window, float x) const;
03647         float   absoluteToRelativeY_impl(const Window* window, float y) const;
03648
03649
03664         Rect    relativeToAbsolute_impl(const Window* window, const Rect& rect) const;
03665         Size    relativeToAbsolute_impl(const Window* window, const Size& sz) const;
03666         Point   relativeToAbsolute_impl(const Window* window, const Point& pt) const;
03667         float   relativeToAbsoluteX_impl(const Window* window, float x) const;
03668         float   relativeToAbsoluteY_impl(const Window* window, float y) const;
03669
03670         Size    getWindowSize_impl(const Window* window) const;
03671
03672
03678         MetricsMode getInheritedMetricsMode(void) const;
03679
03680
03685     void    generateAutoRepeatEvent(MouseButton button);
03686
03687
03688         /*************************************************************************
03689                 Implementation Data
03690         *************************************************************************/
03691         // child stuff
03692         typedef std::vector<Window*>    ChildList;
03693         ChildList               d_children;
03694     ChildList       d_drawList;
03695
03696         // general data
03697         MetricsMode             d_metricsMode;
03698         static Window*  d_captureWindow;
03699         Window*                 d_oldCapture;
03700         Window*                 d_parent;
03701         const Font*             d_font;
03702         String                  d_text;
03703         uint                    d_ID;
03704         float                   d_alpha;
03705     URect                       d_area;
03706     Size            d_pixelSize;
03707         const Image*    d_mouseCursor;
03708         void*                   d_userData;
03709
03710         typedef std::map<String, String>   UserStringMap;
03711         UserStringMap  d_userStrings;
03712
03713     // positional alignments
03714     HorizontalAlignment d_horzAlign;
03715     VerticalAlignment   d_vertAlign;
03716
03717         // maximum and minimum sizes
03718         UVector2       d_minSize;
03719         UVector2       d_maxSize;
03720
03721         // settings
03722         bool    d_enabled;
03723         bool    d_visible;
03724         bool    d_active;
03725         bool    d_clippedByParent;
03726         bool    d_destroyedByParent;
03727         bool    d_alwaysOnTop;
03728         bool    d_inheritsAlpha;
03729         bool    d_restoreOldCapture;
03730         bool    d_zOrderingEnabled;
03731     bool    d_wantsMultiClicks;
03732     bool    d_distCapturedInputs;
03733     bool    d_riseOnClick;
03734
03735     // mouse button autorepeat data
03736     bool    d_autoRepeat;
03737     float   d_repeatDelay;
03738     float   d_repeatRate;
03739     bool    d_repeating;
03740     float   d_repeatElapsed;
03741     MouseButton d_repeatButton;
03742
03743     // Tooltip stuff
03744     String   d_tooltipText;
03745     Tooltip* d_customTip;
03746     bool     d_weOwnTip;
03747     bool     d_inheritsTipText;
03748
03749     // rendering
03750     RenderCache d_renderCache;
03751     mutable bool d_needsRedraw;
03752
03753     // Look'N'Feel stuff
03754     String  d_lookName;
03755
03756 protected:
03757         /*************************************************************************
03758                 Properties for Window base class
03759         *************************************************************************/
03760         static  WindowProperties::AbsoluteHeight        d_absHeightProperty;
03761         static  WindowProperties::AbsoluteMaxSize       d_absMaxSizeProperty;
03762         static  WindowProperties::AbsoluteMinSize       d_absMinSizeProperty;
03763         static  WindowProperties::AbsolutePosition      d_absPositionProperty;
03764         static  WindowProperties::AbsoluteRect          d_absRectProperty;
03765         static  WindowProperties::AbsoluteSize          d_absSizeProperty;
03766         static  WindowProperties::AbsoluteWidth         d_absWidthProperty;
03767         static  WindowProperties::AbsoluteXPosition     d_absXPosProperty;
03768         static  WindowProperties::AbsoluteYPosition     d_absYPosProperty;
03769         static  WindowProperties::Alpha                         d_alphaProperty;
03770         static  WindowProperties::AlwaysOnTop           d_alwaysOnTopProperty;
03771         static  WindowProperties::ClippedByParent       d_clippedByParentProperty;
03772         static  WindowProperties::DestroyedByParent     d_destroyedByParentProperty;
03773         static  WindowProperties::Disabled                      d_disabledProperty;
03774         static  WindowProperties::Font                          d_fontProperty;
03775         static  WindowProperties::Height                        d_heightProperty;
03776         static  WindowProperties::ID                            d_IDProperty;
03777         static  WindowProperties::InheritsAlpha         d_inheritsAlphaProperty;
03778         static  WindowProperties::MetricsMode           d_metricsModeProperty;
03779         static  WindowProperties::MouseCursorImage      d_mouseCursorProperty;
03780         static  WindowProperties::Position                      d_positionProperty;
03781         static  WindowProperties::Rect                          d_rectProperty;
03782         static  WindowProperties::RelativeHeight        d_relHeightProperty;
03783         static  WindowProperties::RelativeMaxSize       d_relMaxSizeProperty;
03784         static  WindowProperties::RelativeMinSize       d_relMinSizeProperty;
03785         static  WindowProperties::RelativePosition      d_relPositionProperty;
03786         static  WindowProperties::RelativeRect          d_relRectProperty;
03787         static  WindowProperties::RelativeSize          d_relSizeProperty;
03788         static  WindowProperties::RelativeWidth         d_relWidthProperty;
03789         static  WindowProperties::RelativeXPosition     d_relXPosProperty;
03790         static  WindowProperties::RelativeYPosition     d_relYPosProperty;
03791         static  WindowProperties::RestoreOldCapture     d_restoreOldCaptureProperty;
03792         static  WindowProperties::Size                          d_sizeProperty;
03793         static  WindowProperties::Text                          d_textProperty;
03794         static  WindowProperties::Visible                       d_visibleProperty;
03795         static  WindowProperties::Width                         d_widthProperty;
03796         static  WindowProperties::XPosition                     d_xPosProperty;
03797         static  WindowProperties::YPosition                     d_yPosProperty;
03798         static  WindowProperties::ZOrderChangeEnabled   d_zOrderChangeProperty;
03799     static  WindowProperties::WantsMultiClickEvents d_wantsMultiClicksProperty;
03800     static  WindowProperties::MouseButtonDownAutoRepeat d_autoRepeatProperty;
03801     static  WindowProperties::AutoRepeatDelay   d_autoRepeatDelayProperty;
03802     static  WindowProperties::AutoRepeatRate    d_autoRepeatRateProperty;
03803     static  WindowProperties::DistributeCapturedInputs d_distInputsProperty;
03804     static  WindowProperties::CustomTooltipType d_tooltipTypeProperty;
03805     static  WindowProperties::Tooltip           d_tooltipProperty;
03806     static  WindowProperties::InheritsTooltipText d_inheritsTooltipProperty;
03807     static  WindowProperties::RiseOnClick       d_riseOnClickProperty;
03808     static  WindowProperties::VerticalAlignment   d_vertAlignProperty;
03809     static  WindowProperties::HorizontalAlignment d_horzAlignProperty;
03810     static      WindowProperties::UnifiedAreaRect       d_unifiedAreaRectProperty;
03811     static      WindowProperties::UnifiedPosition       d_unifiedPositionProperty;
03812     static      WindowProperties::UnifiedXPosition      d_unifiedXPositionProperty;
03813     static      WindowProperties::UnifiedYPosition      d_unifiedYPositionProperty;
03814     static      WindowProperties::UnifiedSize           d_unifiedSizeProperty;
03815     static      WindowProperties::UnifiedWidth          d_unifiedWidthProperty;
03816     static      WindowProperties::UnifiedHeight         d_unifiedHeightProperty;
03817     static      WindowProperties::UnifiedMinSize        d_unifiedMinSizeProperty;
03818     static      WindowProperties::UnifiedMaxSize        d_unifiedMaxSizeProperty;
03819
03820
03821         /*************************************************************************
03822                 implementation functions
03823         *************************************************************************/
03828         void    addStandardEvents(void);
03829
03834         virtual void    cleanupChildren(void);
03835
03840         virtual void    addChild_impl(Window* wnd);
03841
03846         virtual void    removeChild_impl(Window* wnd);
03847
03852         virtual void    onZChange_impl(void);
03853
03854
03859         void    addStandardProperties(void);
03860
03861
03866     virtual void moveToFront_impl(bool wasClicked);
03867
03868
03873     void doRiseOnClick(void);
03874
03875
03903     void setWindowArea_impl(const UVector2& pos, const UVector2& size, bool topLeftSizing = false, bool fireEvents = true);
03904
03922     void addWindowToDrawList(Window& wnd, bool at_back = false);
03923
03935     void removeWindowFromDrawList(const Window& wnd);
03936
03937     virtual int writePropertiesXML(OutStream& out_stream) const;
03938     virtual int writeChildWindowsXML(OutStream& out_stream) const;
03939
03940         /*************************************************************************
03941                 May not copy or assign Window objects
03942         *************************************************************************/
03943         Window(const Window& wnd) {}
03944         Window& operator=(const Window& wnd) {return *this;}
03945
03946         /*************************************************************************
03947                 Private implementation Data
03948         *************************************************************************/
03949         const String    d_type;
03950         String  d_name;
03951         String    d_falagardType;
03952 };
03953
03954 } // End of  CEGUI namespace section
03955
03956
03957 #if defined(_MSC_VER)
03958 #       pragma warning(pop)
03959 #endif
03960
03961 #endif  // end of guard _CEGUIWindow_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIWindowFactory.h Source File

include

CEGUIWindowFactory.h

00001 /************************************************************************
00002         filename:       CEGUIWindowFactory.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines abstract base class for WindowFactory objects
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIWindowFactory_h_
00027 #define _CEGUIWindowFactory_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUIWindow.h"
00032
00033
00034 // Start of CEGUI namespace section
00035 namespace CEGUI
00036 {
00046 class CEGUIEXPORT WindowFactory
00047 {
00048 public:
00059         virtual Window* createWindow(const String& name) = 0;
00060
00071         virtual void    destroyWindow(Window* window) = 0;
00072
00080         const String& getTypeName(void) const           {return d_type;}
00081
00082 protected:
00083         /*************************************************************************
00084                 Construction and Destruction
00085         *************************************************************************/
00086         WindowFactory(const String& type) : d_type(type) {}
00087
00088 public:         // luabind compatibility
00089         virtual ~WindowFactory(void) {}
00090
00091 protected:
00092         /*************************************************************************
00093                 Implementation Data
00094         *************************************************************************/
00095         String          d_type;
00096 };
00097
00098 } // End of  CEGUI namespace section
00099
00100 #endif  // end of guard _CEGUIWindowFactory_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIWindowFactoryManager.h Source File

include

CEGUIWindowFactoryManager.h

00001 /************************************************************************
00002         filename:       CEGUIWindowFactoryManager.h
00003         created:        22/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines interface for WindowFactoryManager class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIWindowFactoryManager_h_
00027 #define _CEGUIWindowFactoryManager_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUILogger.h"
00033 #include "CEGUIIteratorBase.h"
00034 #include <map>
00035 #include <vector>
00036
00037 #if defined(_MSC_VER)
00038 #       pragma warning(push)
00039 #       pragma warning(disable : 4275)
00040 #       pragma warning(disable : 4251)
00041 #endif
00042
00043
00044 // Start of CEGUI namespace section
00045 namespace CEGUI
00046 {
00051 class CEGUIEXPORT WindowFactoryManager : public Singleton<WindowFactoryManager>
00052 {
00053 public:
00058     struct CEGUIEXPORT FalagardWindowMapping
00059     {
00060         String  d_windowType;
00061         String  d_lookName;
00062         String  d_baseType;
00063     };
00064
00069         class CEGUIEXPORT AliasTargetStack
00070         {
00071         public:
00076                 AliasTargetStack(void) {}
00077
00078
00083                 ~AliasTargetStack(void) {}
00084
00085
00093                 const String&   getActiveTarget(void) const;
00094
00102                 uint    getStackedTargetCount(void) const;
00103
00104
00105         private:
00106                 friend class WindowFactoryManager;
00107                 typedef std::vector<String>     TargetTypeStack;
00108
00109                 TargetTypeStack d_targetStack;
00110         };
00111
00112
00113         /*************************************************************************
00114                 Construction and Destruction
00115         *************************************************************************/
00120         WindowFactoryManager(void)
00121         {
00122                 Logger::getSingleton().logEvent((utf8*)"CEGUI::WindowFactoryManager singleton created");
00123         }
00124
00125
00130         ~WindowFactoryManager(void)
00131         {
00132                 Logger::getSingleton().logEvent((utf8*)"CEGUI::WindowFactoryManager singleton destroyed");
00133         }
00134
00135
00136         /*************************************************************************
00137                 Public Interface
00138         *************************************************************************/
00146         static  WindowFactoryManager&   getSingleton(void);
00147
00148
00156         static  WindowFactoryManager*   getSingletonPtr(void);
00157
00158
00172         void    addFactory(WindowFactory* factory);
00173
00174
00189         void    removeFactory(const String& name);
00190
00191
00206         void    removeFactory(WindowFactory* factory);
00207
00208
00216         void    removeAllFactories(void)                {d_factoryRegistry.clear();}
00217
00218
00231         WindowFactory*  getFactory(const String& type) const;
00232
00233
00248     bool        isFactoryPresent(const String& name) const;
00249
00250
00276         void    addWindowTypeAlias(const String& aliasName, const String& targetType);
00277
00278
00296         void    removeWindowTypeAlias(const String& aliasName, const String& targetType);
00297
00323     void addFalagardWindowMapping(const String& newType, const String& targetType, const String& lookName);
00324
00332     void removeFalagardWindowMapping(const String& type);
00333
00345     bool isFalagardMappedType(const String& type) const;
00346
00359     const String& getMappedLookForType(const String& type) const;
00360
00361
00380     String getDereferencedAliasType(const String& type) const;
00381
00382 private:
00383         /*************************************************************************
00384                 Implementation Data
00385         *************************************************************************/
00386         typedef std::map<String, WindowFactory*>        WindowFactoryRegistry;
00387         typedef std::map<String, AliasTargetStack>      TypeAliasRegistry;
00388     typedef std::map<String, FalagardWindowMapping> FalagardMapRegistry;
00389
00390         WindowFactoryRegistry   d_factoryRegistry;
00391         TypeAliasRegistry               d_aliasRegistry;
00392     FalagardMapRegistry     d_falagardRegistry;
00393
00394 public:
00395         /*************************************************************************
00396                 Iterator stuff
00397         *************************************************************************/
00398         typedef ConstBaseIterator<WindowFactoryRegistry>        WindowFactoryIterator;
00399         typedef ConstBaseIterator<TypeAliasRegistry>            TypeAliasIterator;
00400     typedef ConstBaseIterator<FalagardMapRegistry>      FalagardMappingIterator;
00401
00406         WindowFactoryIterator   getIterator(void) const;
00407
00408
00413         TypeAliasIterator       getAliasIterator(void) const;
00414
00415
00420     FalagardMappingIterator getFalagardMappingIterator() const;
00421 };
00422
00423 } // End of  CEGUI namespace section
00424
00425
00426 #if defined(_MSC_VER)
00427 #       pragma warning(pop)
00428 #endif
00429
00430 #endif  // end of guard _CEGUIWindowFactoryManager_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIWindowManager.h Source File

include

CEGUIWindowManager.h

00001 /************************************************************************
00002         filename:       CEGUIWindowManager.h
00003         created:        21/2/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines the interface for the WindowManager object
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIWindowManager_h_
00027 #define _CEGUIWindowManager_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIString.h"
00031 #include "CEGUISingleton.h"
00032 #include "CEGUILogger.h"
00033 #include "CEGUIIteratorBase.h"
00034 #include <map>
00035 #include <vector>
00036
00037 #if defined(_MSC_VER)
00038 #       pragma warning(push)
00039 #       pragma warning(disable : 4275)
00040 #       pragma warning(disable : 4251)
00041 #endif
00042
00043
00044 // Start of CEGUI namespace section
00045 namespace CEGUI
00046 {
00056 class CEGUIEXPORT WindowManager : public Singleton <WindowManager>
00057 {
00058 public:
00059     /*************************************************************************
00060         Public static data
00061     *************************************************************************/
00062     static const String GeneratedWindowNameBase;
00063
00085         typedef bool PropertyCallback(Window* window, String& propname, String& propvalue, void* userdata);
00086
00087         /*************************************************************************
00088                 Construction and Destruction
00089         *************************************************************************/
00098         WindowManager(void);
00099
00100
00108         ~WindowManager(void);
00109
00110
00118         static  WindowManager&  getSingleton(void);
00119
00120
00128         static  WindowManager*  getSingletonPtr(void);
00129
00130
00131         /*************************************************************************
00132                 Window Related Methods
00133         *************************************************************************/
00152         Window* createWindow(const String& type, const String& name = "");
00153
00154
00167         void    destroyWindow(Window* window);
00168
00169
00182         void    destroyWindow(const String& window);
00183
00184
00197         Window* getWindow(const String& name) const;
00198
00199
00210         bool    isWindowPresent(const String& name) const;
00211
00212
00222         void    destroyAllWindows(void);
00223
00224
00255         Window* loadWindowLayout(const String& filename, const String& name_prefix = "", const String& resourceGroup = "", PropertyCallback* callback = NULL, void* userdata = NULL);
00256
00265     bool isDeadPoolEmpty(void) const;
00266
00278     void cleanDeadPool(void);
00279
00297     void writeWindowLayoutToStream(const Window& window, OutStream& out_stream, bool writeParent = false) const;
00298
00316     void writeWindowLayoutToStream(const String& window, OutStream& out_stream, bool writeParent = false) const;
00317
00334     void renameWindow(const String& window, const String& new_name);
00335
00349     void renameWindow(Window* window, const String& new_name);
00350
00351 private:
00352     /*************************************************************************
00353         Implementation Methods
00354     *************************************************************************/
00359     String generateUniqueWindowName();
00360
00361         /*************************************************************************
00362                 Implementation Constants
00363         *************************************************************************/
00364         static const char       GUILayoutSchemaName[];
00365
00366
00367         /*************************************************************************
00368                 Implementation Data
00369         *************************************************************************/
00370         typedef std::map<String, Window*>                       WindowRegistry;
00371     typedef std::vector<Window*>    WindowVector;
00372
00373         WindowRegistry                  d_windowRegistry;
00374     WindowVector    d_deathrow;
00375
00376     unsigned long   d_uid_counter;
00377
00378 public:
00379         /*************************************************************************
00380                 Iterator stuff
00381         *************************************************************************/
00382         typedef ConstBaseIterator<WindowRegistry>       WindowIterator;
00383
00388         WindowIterator  getIterator(void) const;
00389 };
00390
00391 } // End of  CEGUI namespace section
00392
00393 #if defined(_MSC_VER)
00394 #       pragma warning(pop)
00395 #endif
00396
00397 #endif  // end of guard _CEGUIWindowManager_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIWindowProperties.h Source File

include

CEGUIWindowProperties.h

00001 /************************************************************************
00002         filename:       CEGUIWindowProperties.h
00003         created:        5/7/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface to available window base class properties
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIWindowProperties_h_
00027 #define _CEGUIWindowProperties_h_
00028
00029 #include "CEGUIProperty.h"
00030
00031
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035
00036 // Start of WindowProperties namespace section
00041 namespace WindowProperties
00042 {
00057 class RelativeMinSize : public Property
00058 {
00059 public:
00060         RelativeMinSize() : Property(
00061                 "RelativeMinSize",
00062                 "Property to get/set the minimum size for the Window.  Value is \"w:[float] h:[float]\" using relative metrics (this setting is relative to the display size).",
00063                 "w:0.000000 h:0.000000", false)
00064         {}
00065
00066         String  get(const PropertyReceiver* receiver) const;
00067         void    set(PropertyReceiver* receiver, const String& value);
00068 };
00069
00070
00085 class RelativeMaxSize : public Property
00086 {
00087 public:
00088         RelativeMaxSize() : Property(
00089                 "RelativeMaxSize",
00090                 "Property to get/set the maximum size for the Window.  Value is \"w:[float] h:[float]\" using relative metrics (this setting is relative to the display size).",
00091                 "w:1.000000 h:1.000000", false)
00092         {}
00093
00094         String  get(const PropertyReceiver* receiver) const;
00095         void    set(PropertyReceiver* receiver, const String& value);
00096 };
00097
00098
00113 class AbsoluteMinSize : public Property
00114 {
00115 public:
00116         AbsoluteMinSize() : Property(
00117                 "AbsoluteMinSize",
00118                 "Property to get/set the minimum size for the Window.  Value is \"w:[float] h:[float]\" using absolute (pixel) metrics.",
00119                 "w:0.000000 h:0.000000", false)
00120         {}
00121
00122         String  get(const PropertyReceiver* receiver) const;
00123         void    set(PropertyReceiver* receiver, const String& value);
00124 };
00125
00126
00141 class AbsoluteMaxSize : public Property
00142 {
00143 public:
00144         AbsoluteMaxSize() : Property(
00145                 "AbsoluteMaxSize",
00146                 "Property to get/set the maximum size for the Window.  Value is \"w:[float] h:[float]\" using absolute (pixel) metrics.",
00147                 "", false)
00148                 {}
00149
00150         String  get(const PropertyReceiver* receiver) const;
00151         void    set(PropertyReceiver* receiver, const String& value);
00152
00153         // default depends upon current size of display.
00154         bool    isDefault(const PropertyReceiver* receiver) const;
00155         String  getDefault(const PropertyReceiver* receiver) const;
00156 };
00157
00158
00174 class MetricsMode : public Property
00175 {
00176 public:
00177         MetricsMode() : Property(
00178                 "MetricsMode",
00179                 "Property to get/set the metrics mode for the Window.  Value is \"Relative\", \"Absolute\", or \"Inherited\".",
00180                 "Relative")
00181         {}
00182
00183         String  get(const PropertyReceiver* receiver) const;
00184         void    set(PropertyReceiver* receiver, const String& value);
00185 };
00186
00187
00201 class ID : public Property
00202 {
00203 public:
00204         ID() : Property(
00205                 "ID",
00206                 "Property to get/set the ID value of the Window.  Value is an unsigned integer number.",
00207                 "0")
00208         {}
00209
00210         String  get(const PropertyReceiver* receiver) const;
00211         void    set(PropertyReceiver* receiver, const String& value);
00212 };
00213
00214
00228 class Alpha : public Property
00229 {
00230 public:
00231         Alpha() : Property(
00232                 "Alpha",
00233                 "Property to get/set the alpha value of the Window.  Value is floating point number.",
00234                 "1.000000")
00235         {}
00236
00237         String  get(const PropertyReceiver* receiver) const;
00238         void    set(PropertyReceiver* receiver, const String& value);
00239 };
00240
00241
00255 class Font : public Property
00256 {
00257 public:
00258         Font() : Property(
00259                 "Font",
00260                 "Property to get/set the font for the Window.  Value is the name of the font to use (must be loaded already).",
00261                 "")
00262         {}
00263
00264         String  get(const PropertyReceiver* receiver) const;
00265         void    set(PropertyReceiver* receiver, const String& value);
00266         bool    isDefault(const PropertyReceiver* receiver) const;
00267 };
00268
00269
00283 class Text : public Property
00284 {
00285 public:
00286         Text() : Property(
00287                 "Text",
00288                 "Property to get/set the text / caption for the Window.  Value is the text string to use.",
00289                 "")
00290         {}
00291
00292         String  get(const PropertyReceiver* receiver) const;
00293         void    set(PropertyReceiver* receiver, const String& value);
00294 };
00295
00296
00311 class MouseCursorImage : public Property
00312 {
00313 public:
00314         MouseCursorImage() : Property(
00315                 "MouseCursorImage",
00316                 "Property to get/set the mouse cursor image for the Window.  Value should be \"set:<imageset name> image:<image name>\".",
00317                 "")
00318         {}
00319
00320         String  get(const PropertyReceiver* receiver) const;
00321         void    set(PropertyReceiver* receiver, const String& value);
00322         bool    isDefault(const PropertyReceiver* receiver) const;
00323 };
00324
00325
00340 class ClippedByParent : public Property
00341 {
00342 public:
00343         ClippedByParent() : Property(
00344                 "ClippedByParent",
00345                 "Property to get/set the 'clipped by parent' setting for the Window.  Value is either \"True\" or \"False\".",
00346                 "True")
00347         {}
00348
00349         String  get(const PropertyReceiver* receiver) const;
00350         void    set(PropertyReceiver* receiver, const String& value);
00351 };
00352
00353
00368 class InheritsAlpha : public Property
00369 {
00370 public:
00371         InheritsAlpha() : Property(
00372                 "InheritsAlpha",
00373                 "Property to get/set the 'inherits alpha' setting for the Window.  Value is either \"True\" or \"False\".",
00374                 "True")
00375         {}
00376
00377         String  get(const PropertyReceiver* receiver) const;
00378         void    set(PropertyReceiver* receiver, const String& value);
00379 };
00380
00381
00396 class AlwaysOnTop : public Property
00397 {
00398 public:
00399         AlwaysOnTop() : Property(
00400                 "AlwaysOnTop",
00401                 "Property to get/set the 'always on top' setting for the Window.  Value is either \"True\" or \"False\".",
00402                 "False")
00403         {}
00404
00405         String  get(const PropertyReceiver* receiver) const;
00406         void    set(PropertyReceiver* receiver, const String& value);
00407 };
00408
00409
00424 class Disabled : public Property
00425 {
00426 public:
00427         Disabled() : Property(
00428                 "Disabled",
00429                 "Property to get/set the 'disabled state' setting for the Window.  Value is either \"True\" or \"False\".",
00430                 "False")
00431         {}
00432
00433         String  get(const PropertyReceiver* receiver) const;
00434         void    set(PropertyReceiver* receiver, const String& value);
00435         bool    isDefault(const PropertyReceiver* receiver) const;
00436 };
00437
00438
00453 class Visible : public Property
00454 {
00455 public:
00456         Visible() : Property(
00457                 "Visible",
00458                 "Property to get/set the 'visible state' setting for the Window.  Value is either \"True\" or \"False\".",
00459                 "True")
00460         {}
00461
00462         String  get(const PropertyReceiver* receiver) const;
00463         void    set(PropertyReceiver* receiver, const String& value);
00464         bool    isDefault(const PropertyReceiver* receiver) const;
00465 };
00466
00467
00483 class RestoreOldCapture : public Property
00484 {
00485 public:
00486         RestoreOldCapture() : Property(
00487                 "RestoreOldCapture",
00488                 "Property to get/set the 'restore old capture' setting for the Window.  Value is either \"True\" or \"False\".",
00489                 "False")
00490         {}
00491
00492         String  get(const PropertyReceiver* receiver) const;
00493         void    set(PropertyReceiver* receiver, const String& value);
00494 };
00495
00496
00511 class DestroyedByParent : public Property
00512 {
00513 public:
00514         DestroyedByParent() : Property(
00515                 "DestroyedByParent",
00516                 "Property to get/set the 'destroyed by parent' setting for the Window.  Value is either \"True\" or \"False\".",
00517                 "True")
00518         {}
00519
00520         String  get(const PropertyReceiver* receiver) const;
00521         void    set(PropertyReceiver* receiver, const String& value);
00522 };
00523
00524
00538 class Width : public Property
00539 {
00540 public:
00541         Width() : Property(
00542                 "Width",
00543                 "Property to get/set the width of the Window.  Value is floating point using the active metrics mode.",
00544                 "0.000000", false) {}
00545
00546         String  get(const PropertyReceiver* receiver) const;
00547         void    set(PropertyReceiver* receiver, const String& value);
00548 };
00549
00550
00564 class RelativeWidth : public Property
00565 {
00566 public:
00567         RelativeWidth() : Property(
00568                 "RelativeWidth",
00569                 "Property to get/set the width of the Window.  Value is floating point using relative metrics.",
00570                 "0.000000", false)
00571         {}
00572
00573         String  get(const PropertyReceiver* receiver) const;
00574         void    set(PropertyReceiver* receiver, const String& value);
00575 };
00576
00577
00591 class AbsoluteWidth: public Property
00592 {
00593 public:
00594         AbsoluteWidth() : Property(
00595                 "AbsoluteWidth",
00596                 "Property to get/set the width of the Window.  Value is floating point using absolute metrics.",
00597                 "0.000000", false)
00598         {}
00599
00600         String  get(const PropertyReceiver* receiver) const;
00601         void    set(PropertyReceiver* receiver, const String& value);
00602 };
00603
00604
00618 class Height : public Property
00619 {
00620 public:
00621         Height() : Property(
00622                 "Height",
00623                 "Property to get/set the height of the Window.  Value is floating point using the active metrics mode.",
00624                 "0.000000", false)
00625         {}
00626
00627         String  get(const PropertyReceiver* receiver) const;
00628         void    set(PropertyReceiver* receiver, const String& value);
00629 };
00630
00631
00645 class RelativeHeight : public Property
00646 {
00647 public:
00648         RelativeHeight() : Property(
00649                 "RelativeHeight",
00650                 "Property to get/set the height of the Window.  Value is floating point using relative metrics.",
00651                 "0.000000", false)
00652         {}
00653
00654         String  get(const PropertyReceiver* receiver) const;
00655         void    set(PropertyReceiver* receiver, const String& value);
00656 };
00657
00658
00672 class AbsoluteHeight : public Property
00673 {
00674 public:
00675         AbsoluteHeight() : Property(
00676                 "AbsoluteHeight",
00677                 "Property to get/set the height of the Window.  Value is floating point using absolute metrics.",
00678                 "0.000000", false)
00679         {}
00680
00681         String  get(const PropertyReceiver* receiver) const;
00682         void    set(PropertyReceiver* receiver, const String& value);
00683 };
00684
00685
00700 class Size : public Property
00701 {
00702 public:
00703         Size() : Property(
00704                 "Size",
00705                 "Property to get/set the size of the Window.  Value is \"w:[float] h:[float]\" using the active metrics mode.",
00706                 "w:0.000000 h:0.000000", false)
00707         {}
00708
00709         String  get(const PropertyReceiver* receiver) const;
00710         void    set(PropertyReceiver* receiver, const String& value);
00711 };
00712
00713
00728 class RelativeSize : public Property
00729 {
00730 public:
00731         RelativeSize() : Property(
00732                 "RelativeSize",
00733                 "Property to get/set the size of the Window.  Value is \"w:[float] h:[float]\" using relative metrics.",
00734                 "w:0.000000 h:0.000000", false)
00735         {}
00736
00737         String  get(const PropertyReceiver* receiver) const;
00738         void    set(PropertyReceiver* receiver, const String& value);
00739 };
00740
00741
00756 class AbsoluteSize : public Property
00757 {
00758 public:
00759         AbsoluteSize() : Property(
00760                 "AbsoluteSize",
00761                 "Property to get/set the size of the Window.  Value is \"w:[float] h:[float]\" using absolute metrics.",
00762                 "w:0.000000 h:0.000000", false)
00763         {}
00764
00765         String  get(const PropertyReceiver* receiver) const;
00766         void    set(PropertyReceiver* receiver, const String& value);
00767 };
00768
00769
00783 class XPosition : public Property
00784 {
00785 public:
00786         XPosition() : Property(
00787                 "XPosition",
00788                 "Property to get/set the x co-ordinate position of the Window.  Value is a floating point number using the active metrics mode.",
00789                 "0.000000", false)
00790         {}
00791
00792         String  get(const PropertyReceiver* receiver) const;
00793         void    set(PropertyReceiver* receiver, const String& value);
00794 };
00795
00796
00810 class RelativeXPosition : public Property
00811 {
00812 public:
00813         RelativeXPosition() : Property(
00814                 "RelativeXPosition",
00815                 "Property to get/set the x co-ordinate position of the Window.  Value is a floating point number using relative metrics.",
00816                 "0.000000", false)
00817         {}
00818
00819         String  get(const PropertyReceiver* receiver) const;
00820         void    set(PropertyReceiver* receiver, const String& value);
00821 };
00822
00823
00837 class AbsoluteXPosition : public Property
00838 {
00839 public:
00840         AbsoluteXPosition() : Property(
00841                 "AbsoluteXPosition",
00842                 "Property to get/set the x co-ordinate position of the Window.  Value is a floating point number using absolute metrics.",
00843                 "0.000000", false)
00844         {}
00845
00846         String  get(const PropertyReceiver* receiver) const;
00847         void    set(PropertyReceiver* receiver, const String& value);
00848 };
00849
00850
00864 class YPosition : public Property
00865 {
00866 public:
00867         YPosition() : Property(
00868                 "YPosition",
00869                 "Property to get/set the y co-ordinate position of the Window.  Value is a floating point number using the active metrics mode.",
00870                 "0.000000", false)
00871         {}
00872
00873         String  get(const PropertyReceiver* receiver) const;
00874         void    set(PropertyReceiver* receiver, const String& value);
00875 };
00876
00877
00891 class RelativeYPosition : public Property
00892 {
00893 public:
00894         RelativeYPosition() : Property(
00895                 "RelativeYPosition",
00896                 "Property to get/set the y co-ordinate position of the Window.  Value is a floating point number using relative metrics.",
00897                 "0.000000", false)
00898         {}
00899
00900         String  get(const PropertyReceiver* receiver) const;
00901         void    set(PropertyReceiver* receiver, const String& value);
00902 };
00903
00904
00918 class AbsoluteYPosition : public Property
00919 {
00920 public:
00921         AbsoluteYPosition() : Property(
00922                 "AbsoluteYPosition",
00923                 "Property to get/set the y co-ordinate position of the Window.  Value is a floating point number using absolute metrics.",
00924                 "0.000000", false)
00925         {}
00926
00927         String  get(const PropertyReceiver* receiver) const;
00928         void    set(PropertyReceiver* receiver, const String& value);
00929 };
00930
00931
00946 class Position : public Property
00947 {
00948 public:
00949         Position() : Property(
00950                 "Position",
00951                 "Property to get/set the position of the Window.  Value is \"x:[float] y:[float]\" using the active metrics mode.",
00952                 "x:0.000000 y:0.000000", false)
00953         {}
00954
00955         String  get(const PropertyReceiver* receiver) const;
00956         void    set(PropertyReceiver* receiver, const String& value);
00957 };
00958
00959
00974 class RelativePosition : public Property
00975 {
00976 public:
00977         RelativePosition() : Property(
00978                 "RelativePosition",
00979                 "Property to get/set the position of the Window.  Value is \"x:[float] y:[float]\" using relative metrics.",
00980                 "x:0.000000 y:0.000000", false)
00981         {}
00982
00983         String  get(const PropertyReceiver* receiver) const;
00984         void    set(PropertyReceiver* receiver, const String& value);
00985 };
00986
00987
01002 class AbsolutePosition : public Property
01003 {
01004 public:
01005         AbsolutePosition() : Property(
01006                 "AbsolutePosition",
01007                 "Property to get/set the position of the Window.  Value is \"x:[float] y:[float]\" using absolute metrics.",
01008                 "x:0.000000 y:0.000000", false)
01009         {}
01010
01011         String  get(const PropertyReceiver* receiver) const;
01012         void    set(PropertyReceiver* receiver, const String& value);
01013 };
01014
01015
01032 class Rect : public Property
01033 {
01034 public:
01035         Rect() : Property(
01036                 "Rect",
01037                 "Property to get/set the area rectangle of the Window.  Value is \"l:[float] t:[float] r:[float] b:[float]\" (where l is left, t is top, r is right, and b is bottom) using the active metrics system.",
01038                 "l:0.000000 t:0.000000 r:0.000000 b:0.000000", false)
01039         {}
01040
01041         String  get(const PropertyReceiver* receiver) const;
01042         void    set(PropertyReceiver* receiver, const String& value);
01043 };
01044
01045
01062 class RelativeRect : public Property
01063 {
01064 public:
01065         RelativeRect() : Property(
01066                 "RelativeRect",
01067                 "Property to get/set the area rectangle of the Window.  Value is \"l:[float] t:[float] r:[float] b:[float]\" (where l is left, t is top, r is right, and b is bottom) using relative metrics.",
01068                 "l:0.000000 t:0.000000 r:0.000000 b:0.000000", false)
01069         {}
01070
01071         String  get(const PropertyReceiver* receiver) const;
01072         void    set(PropertyReceiver* receiver, const String& value);
01073 };
01074
01075
01092 class AbsoluteRect : public Property
01093 {
01094 public:
01095         AbsoluteRect() : Property(
01096                 "AbsoluteRect",
01097                 "Property to get/set the area rectangle of the Window.  Value is \"l:[float] t:[float] r:[float] b:[float]\" (where l is left, t is top, r is right, and b is bottom) using absolute metrics.",
01098                 "l:0.000000 t:0.000000 r:0.000000 b:0.000000", false)
01099         {}
01100
01101         String  get(const PropertyReceiver* receiver) const;
01102         void    set(PropertyReceiver* receiver, const String& value);
01103 };
01104
01105
01120 class ZOrderChangeEnabled : public Property
01121 {
01122 public:
01123         ZOrderChangeEnabled() : Property(
01124                 "ZOrderChangeEnabled",
01125                 "Property to get/set the 'z-order changing enabled' setting for the Window.  Value is either \"True\" or \"False\".",
01126                 "True")
01127         {}
01128
01129         String  get(const PropertyReceiver* receiver) const;
01130         void    set(PropertyReceiver* receiver, const String& value);
01131 };
01132
01133
01149 class WantsMultiClickEvents : public Property
01150 {
01151 public:
01152     WantsMultiClickEvents() : Property(
01153         "WantsMultiClickEvents",
01154         "Property to get/set whether the window will receive double-click and triple-click events.  Value is either \"True\" or \"False\".",
01155         "True")
01156     {}
01157
01158     String      get(const PropertyReceiver* receiver) const;
01159     void        set(PropertyReceiver* receiver, const String& value);
01160 };
01161
01162
01178 class MouseButtonDownAutoRepeat : public Property
01179 {
01180 public:
01181     MouseButtonDownAutoRepeat() : Property(
01182         "MouseButtonDownAutoRepeat",
01183         "Property to get/set whether the window will receive autorepeat mouse button down events.  Value is either \"True\" or \"False\".",
01184         "False")
01185     {}
01186
01187     String  get(const PropertyReceiver* receiver) const;
01188     void    set(PropertyReceiver* receiver, const String& value);
01189 };
01190
01191
01205 class AutoRepeatDelay : public Property
01206 {
01207 public:
01208     AutoRepeatDelay() : Property(
01209         "AutoRepeatDelay",
01210         "Property to get/set the autorepeat delay.  Value is a floating point number indicating the delay required in seconds.",
01211         "0.300000")
01212     {}
01213
01214     String  get(const PropertyReceiver* receiver) const;
01215     void    set(PropertyReceiver* receiver, const String& value);
01216 };
01217
01218
01232 class AutoRepeatRate : public Property
01233 {
01234 public:
01235     AutoRepeatRate() : Property(
01236         "AutoRepeatRate",
01237         "Property to get/set the autorepeat rate.  Value is a floating point number indicating the rate required in seconds.",
01238         "0.060000")
01239     {}
01240
01241     String  get(const PropertyReceiver* receiver) const;
01242     void    set(PropertyReceiver* receiver, const String& value);
01243 };
01244
01258 class DistributeCapturedInputs : public Property
01259 {
01260 public:
01261         DistributeCapturedInputs() : Property(
01262                 "DistributeCapturedInputs",
01263                 "Property to get/set whether captured inputs are passed to child windows.  Value is either \"True\" or \"False\".",
01264                 "False")
01265         {}
01266
01267         String  get(const PropertyReceiver* receiver) const;
01268         void    set(PropertyReceiver* receiver, const String& value);
01269 };
01270
01282 class CustomTooltipType : public Property
01283 {
01284 public:
01285     CustomTooltipType() : Property(
01286     "CustomTooltipType",
01287     "Property to get/set the custom tooltip for the window.  Value is the type name of the custom tooltip.",
01288     "")
01289     {}
01290
01291     String  get(const PropertyReceiver* receiver) const;
01292     void    set(PropertyReceiver* receiver, const String& value);
01293 };
01294
01306 class Tooltip : public Property
01307 {
01308 public:
01309     Tooltip() : Property(
01310     "Tooltip",
01311     "Property to get/set the tooltip text for the window.  Value is the tooltip text for the window.",
01312     "")
01313     {}
01314
01315     String  get(const PropertyReceiver* receiver) const;
01316     void    set(PropertyReceiver* receiver, const String& value);
01317 };
01318
01331 class InheritsTooltipText : public Property
01332 {
01333 public:
01334     InheritsTooltipText() : Property(
01335         "InheritsTooltipText",
01336         "Property to get/set whether the window inherits its parents tooltip text when it has none of its own.  Value is either \"True\" or \"False\".",
01337         "False")
01338     {}
01339
01340     String  get(const PropertyReceiver* receiver) const;
01341     void    set(PropertyReceiver* receiver, const String& value);
01342 };
01343
01344
01357 class RiseOnClick : public Property
01358 {
01359 public:
01360     RiseOnClick() : Property(
01361                 "RiseOnClick",
01362                 "Property to get/set whether the window will come tot he top of the z order hwn clicked.  Value is either \"True\" or \"False\".",
01363                 "True")
01364         {}
01365
01366         String  get(const PropertyReceiver* receiver) const;
01367         void    set(PropertyReceiver* receiver, const String& value);
01368 };
01369
01370
01384 class VerticalAlignment : public Property
01385 {
01386     public:
01387         VerticalAlignment() : Property(
01388         "VerticalAlignment",
01389         "Property to get/set the windows vertical alignment.  Value is one of \"Top\", \"Centre\" or \"Bottom\".",
01390         "Top")
01391         {}
01392
01393         String  get(const PropertyReceiver* receiver) const;
01394         void    set(PropertyReceiver* receiver, const String& value);
01395 };
01396
01397
01411 class HorizontalAlignment : public Property
01412 {
01413     public:
01414         HorizontalAlignment() : Property(
01415         "HorizontalAlignment",
01416         "Property to get/set the windows horizontal alignment.  Value is one of \"Left\", \"Centre\" or \"Right\".",
01417         "Left")
01418         {}
01419
01420         String  get(const PropertyReceiver* receiver) const;
01421         void    set(PropertyReceiver* receiver, const String& value);
01422 };
01423
01424
01425 /*
01426 \brief
01427         Property to access the unified area rectangle of the window.
01428
01429         \par Usage:
01430                 - Name: UnifiedAreaRect
01431                 - Format: "{{[ls],[lo]},{[ts],[to]},{[rs],[ro]},{[bs],[bo]}}"
01432
01433         \par Where:
01434                 - [ls] is a floating point value describing the relative scale value for the left edge.
01435                 - [lo] is a floating point value describing the absolute offset value for the left edge.
01436                 - [ts] is a floating point value describing the relative scale value for the top edge.
01437                 - [to] is a floating point value describing the absolute offset value for the top edge.
01438                 - [rs] is a floating point value describing the relative scale value for the right edge.
01439                 - [ro] is a floating point value describing the absolute offset value for the right edge.
01440                 - [bs] is a floating point value describing the relative scale value for the bottom edge.
01441                 - [bo] is a floating point value describing the absolute offset value for the bottom edge.
01442 */
01443 class UnifiedAreaRect : public Property
01444 {
01445         public:
01446                 UnifiedAreaRect() : Property(
01447                 "UnifiedAreaRect",
01448                 "Property to get/set the windows unified area rectangle.  Value is a \"URect\".",
01449                 "{{0.000000,0.000000},{0.000000,0.000000},{0.000000,0.000000},{0.000000,0.000000}}")
01450                 {}
01451
01452                 String  get(const PropertyReceiver* receiver) const;
01453                 void    set(PropertyReceiver* receiver, const String& value);
01454 };
01455
01456
01457 /*
01458 \brief
01459         Property to access the unified position of the window.
01460
01461         \par Usage:
01462                 - Name: UnifiedPosition
01463                 - Format: "{{[xs],[xo]},{[ys],[yo]}}"
01464
01465         \par Where:
01466                 - [xs] is a floating point value describing the relative scale value for the position x-coordinate.
01467                 - [xo] is a floating point value describing the absolute offset value for the position x-coordinate.
01468                 - [ys] is a floating point value describing the relative scale value for the position y-coordinate.
01469                 - [yo] is a floating point value describing the absolute offset value for the position y-coordinate.
01470 */
01471 class UnifiedPosition : public Property
01472 {
01473         public:
01474                 UnifiedPosition() : Property(
01475                 "UnifiedPosition",
01476                 "Property to get/set the windows unified position.  Value is a \"UVector2\".",
01477                 "{{0.000000,0.000000},{0.000000,0.000000}}", false)
01478                 {}
01479
01480                 String  get(const PropertyReceiver* receiver) const;
01481                 void    set(PropertyReceiver* receiver, const String& value);
01482 };
01483
01484
01485 /*
01486 \brief
01487         Property to access the unified position x-coordinate of the window.
01488
01489         \par Usage:
01490                 - Name: UnifiedXPosition
01491                 - Format: "{[s],[o]}"
01492
01493         \par Where:
01494                 - [s] is a floating point value describing the relative scale value for the position x-coordinate.
01495                 - [o] is a floating point value describing the absolute offset value for the position x-coordinate.
01496 */
01497 class UnifiedXPosition : public Property
01498 {
01499         public:
01500                 UnifiedXPosition() : Property(
01501                 "UnifiedXPosition",
01502                 "Property to get/set the windows unified position x-coordinate.  Value is a \"UDim\".",
01503                 "{0.000000,0.000000}", false)
01504                 {}
01505
01506                 String  get(const PropertyReceiver* receiver) const;
01507                 void    set(PropertyReceiver* receiver, const String& value);
01508 };
01509
01510
01511 /*
01512 \brief
01513         Property to access the unified position y-coordinate of the window.
01514
01515         \par Usage:
01516                 - Name: UnifiedYPosition
01517                 - Format: "{[s],[o]}"
01518
01519         \par Where:
01520                 - [s] is a floating point value describing the relative scale value for the position y-coordinate.
01521                 - [o] is a floating point value describing the absolute offset value for the position y-coordinate.
01522 */
01523 class UnifiedYPosition : public Property
01524 {
01525         public:
01526                 UnifiedYPosition() : Property(
01527                 "UnifiedYPosition",
01528                 "Property to get/set the windows unified position y-coordinate.  Value is a \"UDim\".",
01529                 "{0.000000,0.000000}", false)
01530                 {}
01531
01532                 String  get(const PropertyReceiver* receiver) const;
01533                 void    set(PropertyReceiver* receiver, const String& value);
01534 };
01535
01536
01537 /*
01538 \brief
01539         Property to access the unified position of the window.
01540
01541         \par Usage:
01542                 - Name: UnifiedSize
01543                 - Format: "{{[ws],[wo]},{[hs],[ho]}}"
01544
01545         \par Where:
01546                 - [ws] is a floating point value describing the relative scale value for the width.
01547                 - [wo] is a floating point value describing the absolute offset value for the width.
01548                 - [hs] is a floating point value describing the relative scale value for the height.
01549                 - [ho] is a floating point value describing the absolute offset value for the height.
01550 */
01551 class UnifiedSize : public Property
01552 {
01553         public:
01554                 UnifiedSize() : Property(
01555                 "UnifiedSize",
01556                 "Property to get/set the windows unified size.  Value is a \"UVector2\".",
01557                 "{{0.000000,0.000000},{0.000000,0.000000}}", false)
01558                 {}
01559
01560                 String  get(const PropertyReceiver* receiver) const;
01561                 void    set(PropertyReceiver* receiver, const String& value);
01562 };
01563
01564
01565 /*
01566 \brief
01567         Property to access the unified width of the window.
01568
01569         \par Usage:
01570                 - Name: UnifiedWidth
01571                 - Format: "{[s],[o]}"
01572
01573         \par Where:
01574                 - [s] is a floating point value describing the relative scale value for the width.
01575                 - [o] is a floating point value describing the absolute offset value for the width.
01576 */
01577 class UnifiedWidth : public Property
01578 {
01579         public:
01580                 UnifiedWidth() : Property(
01581                 "UnifiedWidth",
01582                 "Property to get/set the windows unified width.  Value is a \"UDim\".",
01583                 "{0.000000,0.000000}", false)
01584                 {}
01585
01586                 String  get(const PropertyReceiver* receiver) const;
01587                 void    set(PropertyReceiver* receiver, const String& value);
01588 };
01589
01590
01591 /*
01592 \brief
01593         Property to access the unified height of the window.
01594
01595         \par Usage:
01596                 - Name: UnifiedHeight
01597                 - Format: "{[s],[o]}"
01598
01599         \par Where:
01600                 - [s] is a floating point value describing the relative scale value for the height.
01601                 - [o] is a floating point value describing the absolute offset value for the height.
01602 */
01603 class UnifiedHeight : public Property
01604 {
01605         public:
01606                 UnifiedHeight() : Property(
01607                 "UnifiedHeight",
01608                 "Property to get/set the windows unified height.  Value is a \"UDim\".",
01609                 "{0.000000,0.000000}", false)
01610                 {}
01611
01612                 String  get(const PropertyReceiver* receiver) const;
01613                 void    set(PropertyReceiver* receiver, const String& value);
01614 };
01615
01616
01617 /*
01618 \brief
01619         Property to access the unified minimum size of the window.
01620
01621         \par Usage:
01622                 - Name: UnifiedMinSize
01623                 - Format: "{{[ws],[wo]},{[hs],[ho]}}"
01624
01625         \par Where:
01626                 - [ws] is a floating point value describing the relative scale value for the minimum width.
01627                 - [wo] is a floating point value describing the absolute offset value for the minimum width.
01628                 - [hs] is a floating point value describing the relative scale value for the minimum height.
01629                 - [ho] is a floating point value describing the absolute offset value for the minimum height.
01630 */
01631 class UnifiedMinSize : public Property
01632 {
01633         public:
01634                 UnifiedMinSize() : Property(
01635                 "UnifiedMinSize",
01636                 "Property to get/set the windows unified minimum size.  Value is a \"UVector2\".",
01637                 "{{0.000000,0.000000},{0.000000,0.000000}}")
01638                 {}
01639
01640                 String  get(const PropertyReceiver* receiver) const;
01641                 void    set(PropertyReceiver* receiver, const String& value);
01642 };
01643
01644
01645 /*
01646 \brief
01647         Property to access the unified maximum size of the window.
01648
01649         \par Usage:
01650                 - Name: UnifiedMaxSize
01651                 - Format: "{{[ws],[wo]},{[hs],[ho]}}"
01652
01653         \par Where:
01654                 - [ws] is a floating point value describing the relative scale value for the maximum width.
01655                 - [wo] is a floating point value describing the absolute offset value for the maximum width.
01656                 - [hs] is a floating point value describing the relative scale value for the maximum height.
01657                 - [ho] is a floating point value describing the absolute offset value for the maximum height.
01658 */
01659 class UnifiedMaxSize : public Property
01660 {
01661         public:
01662                 UnifiedMaxSize() : Property(
01663                 "UnifiedMaxSize",
01664                 "Property to get/set the windows unified maximum size.  Value is a \"UVector2\".",
01665                 "{{0.000000,0.000000},{0.000000,0.000000}}")
01666                 {}
01667
01668                 String  get(const PropertyReceiver* receiver) const;
01669                 void    set(PropertyReceiver* receiver, const String& value);
01670 };
01671
01672
01673 } // End of  WindowProperties namespace section
01674
01675
01676 } // End of  CEGUI namespace section
01677
01678 #endif  // end of guard _CEGUIWindowProperties_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIXercesParser.h Source File

include

CEGUIXercesParser.h

00001 /************************************************************************
00002     filename:   CEGUIXercesParser.h
00003     created:    Sat Mar 12 2005
00004     author:     Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIXercesParser_h_
00025 #define _CEGUIXercesParser_h_
00026
00027 #include "CEGUIXMLParser.h"
00028
00029 // Xerces-C includes
00030 #include <xercesc/framework/MemBufInputSource.hpp>
00031 #include <xercesc/util/PlatformUtils.hpp>
00032 #include <xercesc/util/TransService.hpp>
00033 #include <xercesc/util/XMLString.hpp>
00034 #include <xercesc/sax2/Attributes.hpp>
00035 #include <xercesc/sax2/DefaultHandler.hpp>
00036 #include <xercesc/sax2/SAX2XMLReader.hpp>
00037 #include <xercesc/sax2/XMLReaderFactory.hpp>
00038
00039 // Start of CEGUI namespace section
00040 namespace CEGUI
00041 {
00042     class XercesHandler : public XERCES_CPP_NAMESPACE::DefaultHandler
00043     {
00044     public:
00045         XercesHandler(XMLHandler& handler);
00046         ~XercesHandler(void);
00047
00048         // Implementation of methods in Xerces DefaultHandler.
00049         void startElement(const XMLCh* const uri, const XMLCh* const localname, const XMLCh* const qname, const XERCES_CPP_NAMESPACE::Attributes& attrs);
00050         void endElement(const XMLCh* const uri, const XMLCh* const localname, const XMLCh* const qname);
00051         void warning (const XERCES_CPP_NAMESPACE::SAXParseException &exc);
00052         void error (const XERCES_CPP_NAMESPACE::SAXParseException &exc);
00053         void fatalError (const XERCES_CPP_NAMESPACE::SAXParseException &exc);
00054
00055     protected:
00056         XMLHandler& d_handler;
00057     };
00058
00063     class XercesParser : public XMLParser
00064     {
00065     public:
00066         XercesParser(void);
00067         ~XercesParser(void);
00068
00069         // Implementation of public abstract interface
00070         void parseXMLFile(XMLHandler& handler, const String& filename, const String& schemaName, const String& resourceGroup);
00071
00072         // Internal methods
00077         static void populateAttributesBlock(const XERCES_CPP_NAMESPACE::Attributes& src, XMLAttributes& dest);
00078
00083         static String transcodeXmlCharToString(const XMLCh* const xmlch_str);
00084
00085     protected:
00086         static void initialiseSchema(XERCES_CPP_NAMESPACE::SAX2XMLReader* reader, const String& schemaName, const String& xmlFilename, const String& resourceGroup);
00087         static XERCES_CPP_NAMESPACE::SAX2XMLReader* createReader(XERCES_CPP_NAMESPACE::DefaultHandler& handler);
00088         static void doParse(XERCES_CPP_NAMESPACE::SAX2XMLReader* parser, const String& xmlFilename, const String& resourceGroup);
00089
00090         // Implementation of abstract interface.
00091         bool initialiseImpl(void);
00092         void cleanupImpl(void);
00093     };
00094
00095 } // End of  CEGUI namespace section
00096
00097
00098 #endif  // end of guard _CEGUIXercesParser_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIXMLAttributes.h Source File

include

CEGUIXMLAttributes.h

00001 /************************************************************************
00002     filename:   CEGUIXMLAttributes.h
00003     created:    Sat Mar 12 2005
00004     author:     Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIXMLAttributes_h_
00025 #define _CEGUIXMLAttributes_h_
00026
00027 #include "CEGUIBase.h"
00028 #include "CEGUIString.h"
00029 #include <map>
00030
00031 #if defined(_MSC_VER)
00032 #       pragma warning(push)
00033 #       pragma warning(disable : 4251)
00034 #endif
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00043     class CEGUIEXPORT XMLAttributes
00044     {
00045     public:
00050         XMLAttributes(void);
00051
00056         virtual ~XMLAttributes(void);
00057
00072         void add(const String& attrName, const String& attrValue);
00073
00084         void remove(const String& attrName);
00085
00097         bool exists(const String& attrName) const;
00098
00106         size_t getCount(void) const;
00107
00124         const String& getName(size_t index) const;
00125
00142         const String& getValue(size_t index) const;
00143
00156         const String& getValue(const String& attrName) const;
00157
00173         const String& getValueAsString(const String& attrName, const String& def = "") const;
00174
00192         bool getValueAsBool(const String& attrName, bool def = false) const;
00193
00211         int getValueAsInteger(const String& attrName, int def = 0) const;
00212
00230         float getValueAsFloat(const String& attrName, float def = 0.0f) const;
00231
00232     protected:
00233         typedef std::map<String, String> AttributeMap;
00234         AttributeMap    d_attrs;
00235     };
00236
00237 } // End of  CEGUI namespace section
00238
00239
00240 #if defined(_MSC_VER)
00241 #       pragma warning(pop)
00242 #endif
00243
00244 #endif  // end of guard _CEGUIXMLAttributes_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIXMLHandler.h Source File

include

CEGUIXMLHandler.h

00001 /************************************************************************
00002     filename:   CEGUIXMLHandler.h
00003     created:    12/3/2005
00004     author:     Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIXMLHandler_h_
00025 #define _CEGUIXMLHandler_h_
00026
00027 #include "CEGUIBase.h"
00028
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00033     class CEGUIEXPORT XMLHandler
00034     {
00035     public:
00040         XMLHandler(void);
00041
00046         virtual ~XMLHandler(void);
00047
00061         virtual void elementStart(const String& element, const XMLAttributes& attributes);
00062
00073         virtual void elementEnd(const String& element);
00074     };
00075
00076 } // End of  CEGUI namespace section
00077
00078
00079 #endif  // end of guard _CEGUIXMLHandler_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: CEGUIXMLParser.h Source File

include

CEGUIXMLParser.h

00001 /************************************************************************
00002     filename:   CEGUIXMLParser.h
00003     created:    12/3/2005
00004     author:     Paul D Turner
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUIXMLParser_h_
00025 #define _CEGUIXMLParser_h_
00026
00027 #include "CEGUIBase.h"
00028 #include "CEGUIString.h"
00029
00030 // Start of CEGUI namespace section
00031 namespace CEGUI
00032 {
00037     class CEGUIEXPORT XMLParser
00038     {
00039     public:
00044         XMLParser(void);
00045
00050         virtual ~XMLParser(void);
00051
00063         bool initialise(void);
00064
00075         void cleanup(void);
00076
00098         virtual void parseXMLFile(XMLHandler& handler, const String& filename, const String& schemaName, const String& resourceGroup) = 0;
00099
00108         const String& getIdentifierString() const;
00109
00110     protected:
00119         virtual bool initialiseImpl(void) = 0;
00120
00129         virtual void cleanupImpl(void) = 0;
00130
00131         // data fields
00132         String d_identifierString;
00133
00134     private:
00135         bool d_initialised;
00136     };
00137
00138 } // End of  CEGUI namespace section
00139
00140
00141 #endif  // end of guard _CEGUIXMLParser_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::_freeBinder< Ret, Args > Member List

This is the complete list of members for CEGUI::_freeBinder< Ret, Args >, including all inherited members.

_freeBinder(SlotFunction f) (defined in CEGUI::_freeBinder< Ret, Args >) | CEGUI::_freeBinder< Ret, Args > | [inline]
d_f (defined in CEGUI::_freeBinder< Ret, Args >) | CEGUI::_freeBinder< Ret, Args > | [protected]
operator()(Args args) const (defined in CEGUI::_freeBinder< Ret, Args >) | CEGUI::_freeBinder< Ret, Args > | [inline, virtual]
SlotFunction typedef (defined in CEGUI::_freeBinder< Ret, Args >) | CEGUI::_freeBinder< Ret, Args > |
~SubscriberInterface() (defined in CEGUI::SubscriberInterface< Ret, Args >) | CEGUI::SubscriberInterface< Ret, Args > | [inline, virtual]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::_functorBinder< Functor, Ret, Args > Member List

This is the complete list of members for CEGUI::_functorBinder< Functor, Ret, Args >, including all inherited members.

_functorBinder(const Functor &f) (defined in CEGUI::_functorBinder< Functor, Ret, Args >) | CEGUI::_functorBinder< Functor, Ret, Args > | [inline]
d_f (defined in CEGUI::_functorBinder< Functor, Ret, Args >) | CEGUI::_functorBinder< Functor, Ret, Args > | [protected]
operator()(Args args) const (defined in CEGUI::_functorBinder< Functor, Ret, Args >) | CEGUI::_functorBinder< Functor, Ret, Args > | [inline, virtual]
~SubscriberInterface() (defined in CEGUI::SubscriberInterface< Ret, Args >) | CEGUI::SubscriberInterface< Ret, Args > | [inline, virtual]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::_memberBinder< T, Ret, Args > Member List

This is the complete list of members for CEGUI::_memberBinder< T, Ret, Args >, including all inherited members.

_memberBinder(F f, T *t) (defined in CEGUI::_memberBinder< T, Ret, Args >) | CEGUI::_memberBinder< T, Ret, Args > | [inline]
d_f (defined in CEGUI::_memberBinder< T, Ret, Args >) | CEGUI::_memberBinder< T, Ret, Args > | [protected]
d_t (defined in CEGUI::_memberBinder< T, Ret, Args >) | CEGUI::_memberBinder< T, Ret, Args > | [protected]
operator()(Args args) const (defined in CEGUI::_memberBinder< T, Ret, Args >) | CEGUI::_memberBinder< T, Ret, Args > | [inline, virtual]
~SubscriberInterface() (defined in CEGUI::SubscriberInterface< Ret, Args >) | CEGUI::SubscriberInterface< Ret, Args > | [inline, virtual]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::_refBinder< Functor, Ret, Args > Member List

This is the complete list of members for CEGUI::_refBinder< Functor, Ret, Args >, including all inherited members.

_refBinder(const Functor &f) (defined in CEGUI::_refBinder< Functor, Ret, Args >) | CEGUI::_refBinder< Functor, Ret, Args > | [inline]
d_f (defined in CEGUI::_refBinder< Functor, Ret, Args >) | CEGUI::_refBinder< Functor, Ret, Args > | [protected]
operator()(Args args) const (defined in CEGUI::_refBinder< Functor, Ret, Args >) | CEGUI::_refBinder< Functor, Ret, Args > | [inline, virtual]
~SubscriberInterface() (defined in CEGUI::SubscriberInterface< Ret, Args >) | CEGUI::SubscriberInterface< Ret, Args > | [inline, virtual]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::AbsoluteDim Member List

This is the complete list of members for CEGUI::AbsoluteDim, including all inherited members.

AbsoluteDim(float val) | CEGUI::AbsoluteDim |
BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const | CEGUI::AbsoluteDim | [protected, virtual]
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const | CEGUI::AbsoluteDim | [protected, virtual]
getValue_impl(const Window &wnd, const Rect &container) const | CEGUI::AbsoluteDim | [protected, virtual]
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
setValue(float val) | CEGUI::AbsoluteDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const | CEGUI::AbsoluteDim | [protected, virtual]
writeXMLElementName_impl(OutStream &out_stream) const | CEGUI::AbsoluteDim | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ActivationEventArgs Member List

This is the complete list of members for CEGUI::ActivationEventArgs, including all inherited members.

ActivationEventArgs(Window *wnd) (defined in CEGUI::ActivationEventArgs) | CEGUI::ActivationEventArgs | [inline]
EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
otherWindow | CEGUI::ActivationEventArgs |
window | CEGUI::WindowEventArgs |
WindowEventArgs(Window *wnd) (defined in CEGUI::WindowEventArgs) | CEGUI::WindowEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::AlreadyExistsException Member List

This is the complete list of members for CEGUI::AlreadyExistsException, including all inherited members.

AlreadyExistsException(const String &message) (defined in CEGUI::AlreadyExistsException) | CEGUI::AlreadyExistsException | [inline]
d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::BaseDim Member List

This is the complete list of members for CEGUI::BaseDim, including all inherited members.

BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const =0 | CEGUI::BaseDim | [protected, pure virtual]
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const =0 | CEGUI::BaseDim | [protected, pure virtual]
getValue_impl(const Window &wnd, const Rect &container) const =0 | CEGUI::BaseDim | [protected, pure virtual]
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const =0 | CEGUI::BaseDim | [protected, pure virtual]
writeXMLElementName_impl(OutStream &out_stream) const =0 | CEGUI::BaseDim | [protected, pure virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ButtonBase Member List

This is the complete list of members for CEGUI::ButtonBase, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
ButtonBase(const String &type, const String &name) | CEGUI::ButtonBase |
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledColour | CEGUI::ButtonBase | [protected]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverColour | CEGUI::ButtonBase | [protected]
d_hovering | CEGUI::ButtonBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalColour | CEGUI::ButtonBase | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::ButtonBase | [protected]
d_pushedColour | CEGUI::ButtonBase | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledLabelColour | CEGUI::ButtonBase | [static]
DefaultHoverLabelColour | CEGUI::ButtonBase | [static]
DefaultNormalLabelColour | CEGUI::ButtonBase | [static]
DefaultPushedLabelColour | CEGUI::ButtonBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawDisabled(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawHover(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawNormal(float z)=0 | CEGUI::ButtonBase | [protected, pure virtual]
drawPushed(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawSelf(float z) | CEGUI::ButtonBase | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Window | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledTextColour(void) const | CEGUI::ButtonBase | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverTextColour(void) const | CEGUI::ButtonBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalTextColour(void) const | CEGUI::ButtonBase | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedTextColour(void) const | CEGUI::ButtonBase | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHovering(void) const | CEGUI::ButtonBase | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::ButtonBase | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledTextColour(const colour &colour) | CEGUI::ButtonBase |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverTextColour(const colour &colour) | CEGUI::ButtonBase |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalTextColour(const colour &colour) | CEGUI::ButtonBase |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedTextColour(const colour &colour) | CEGUI::ButtonBase |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ButtonBase | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::ButtonBase | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ButtonBase(void) | CEGUI::ButtonBase | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ButtonBaseProperties::DisabledTextColour Member List

This is the complete list of members for CEGUI::ButtonBaseProperties::DisabledTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DisabledTextColour() (defined in CEGUI::ButtonBaseProperties::DisabledTextColour) | CEGUI::ButtonBaseProperties::DisabledTextColour | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ButtonBaseProperties::DisabledTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ButtonBaseProperties::DisabledTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ButtonBaseProperties::HoverTextColour Member List

This is the complete list of members for CEGUI::ButtonBaseProperties::HoverTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ButtonBaseProperties::HoverTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HoverTextColour() (defined in CEGUI::ButtonBaseProperties::HoverTextColour) | CEGUI::ButtonBaseProperties::HoverTextColour | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ButtonBaseProperties::HoverTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ButtonBaseProperties::NormalTextColour Member List

This is the complete list of members for CEGUI::ButtonBaseProperties::NormalTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ButtonBaseProperties::NormalTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NormalTextColour() (defined in CEGUI::ButtonBaseProperties::NormalTextColour) | CEGUI::ButtonBaseProperties::NormalTextColour | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ButtonBaseProperties::NormalTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ButtonBaseProperties::PushedTextColour Member List

This is the complete list of members for CEGUI::ButtonBaseProperties::PushedTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ButtonBaseProperties::PushedTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
PushedTextColour() (defined in CEGUI::ButtonBaseProperties::PushedTextColour) | CEGUI::ButtonBaseProperties::PushedTextColour | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ButtonBaseProperties::PushedTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Checkbox Member List

This is the complete list of members for CEGUI::Checkbox, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addCheckboxEvents(void) | CEGUI::Checkbox | [protected]
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
ButtonBase(const String &type, const String &name) | CEGUI::ButtonBase |
captureInput(void) | CEGUI::Window |
Checkbox(const String &type, const String &name) | CEGUI::Checkbox |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledColour | CEGUI::ButtonBase | [protected]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverColour | CEGUI::ButtonBase | [protected]
d_hovering | CEGUI::ButtonBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalColour | CEGUI::ButtonBase | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::ButtonBase | [protected]
d_pushedColour | CEGUI::ButtonBase | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_selected | CEGUI::Checkbox | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledLabelColour | CEGUI::ButtonBase | [static]
DefaultHoverLabelColour | CEGUI::ButtonBase | [static]
DefaultNormalLabelColour | CEGUI::ButtonBase | [static]
DefaultPushedLabelColour | CEGUI::ButtonBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawDisabled(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawHover(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawNormal(float z)=0 | CEGUI::ButtonBase | [protected, pure virtual]
drawPushed(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawSelf(float z) | CEGUI::ButtonBase | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventCheckStateChanged | CEGUI::Checkbox | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Checkbox | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledTextColour(void) const | CEGUI::ButtonBase | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverTextColour(void) const | CEGUI::ButtonBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalTextColour(void) const | CEGUI::ButtonBase | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedTextColour(void) const | CEGUI::ButtonBase | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHovering(void) const | CEGUI::ButtonBase | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::ButtonBase | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSelected(void) const | CEGUI::Checkbox | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Checkbox | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSelectStateChange(WindowEventArgs &e) | CEGUI::Checkbox | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledTextColour(const colour &colour) | CEGUI::ButtonBase |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverTextColour(const colour &colour) | CEGUI::ButtonBase |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalTextColour(const colour &colour) | CEGUI::ButtonBase |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedTextColour(const colour &colour) | CEGUI::ButtonBase |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelected(bool select) | CEGUI::Checkbox |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Checkbox | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::ButtonBase | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ButtonBase(void) | CEGUI::ButtonBase | [virtual]
~Checkbox(void) | CEGUI::Checkbox | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::CheckboxProperties::Selected Member List

This is the complete list of members for CEGUI::CheckboxProperties::Selected, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::CheckboxProperties::Selected | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
Selected() (defined in CEGUI::CheckboxProperties::Selected) | CEGUI::CheckboxProperties::Selected | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::CheckboxProperties::Selected | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::colour Member List

This is the complete list of members for CEGUI::colour, including all inherited members.

colour(void) (defined in CEGUI::colour) | CEGUI::colour |
colour(const colour &val) (defined in CEGUI::colour) | CEGUI::colour |
colour(float red, float green, float blue, float alpha=1.0f) (defined in CEGUI::colour) | CEGUI::colour |
colour(argb_t argb) (defined in CEGUI::colour) | CEGUI::colour |
getAlpha(void) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
getARGB(void) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
getBlue(void) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
getGreen(void) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
getHue(void) const (defined in CEGUI::colour) | CEGUI::colour |
getLumination(void) const (defined in CEGUI::colour) | CEGUI::colour |
getRed(void) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
getSaturation(void) const (defined in CEGUI::colour) | CEGUI::colour |
invertColour(void) (defined in CEGUI::colour) | CEGUI::colour |
invertColourWithAlpha(void) (defined in CEGUI::colour) | CEGUI::colour |
operator &=(argb_t val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator &=(const colour &val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator *(const float val) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator *=(const colour &val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator argb_t() const (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator!=(const colour &rhs) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator+(const colour &val) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator-(const colour &val) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator<<=(int val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator=(argb_t val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator=(const colour &val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator==(const colour &rhs) const (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator>>=(int val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator|=(argb_t val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
operator|=(const colour &val) (defined in CEGUI::colour) | CEGUI::colour | [inline]
set(float red, float green, float blue, float alpha=1.0f) (defined in CEGUI::colour) | CEGUI::colour | [inline]
setAlpha(float alpha) (defined in CEGUI::colour) | CEGUI::colour | [inline]
setARGB(argb_t argb) (defined in CEGUI::colour) | CEGUI::colour |
setBlue(float blue) (defined in CEGUI::colour) | CEGUI::colour | [inline]
setGreen(float green) (defined in CEGUI::colour) | CEGUI::colour | [inline]
setHSL(float hue, float saturation, float luminance, float alpha=1.0f) (defined in CEGUI::colour) | CEGUI::colour |
setRed(float red) (defined in CEGUI::colour) | CEGUI::colour | [inline]
setRGB(float red, float green, float blue) (defined in CEGUI::colour) | CEGUI::colour | [inline]
setRGB(const colour &val) (defined in CEGUI::colour) | CEGUI::colour | [inline]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ColourRect Member List

This is the complete list of members for CEGUI::ColourRect, including all inherited members.

ColourRect(void) | CEGUI::ColourRect
ColourRect(const colour &col) | CEGUI::ColourRect
ColourRect(const colour &top_left, const colour &top_right, const colour &bottom_left, const colour &bottom_right) | CEGUI::ColourRect
d_bottom_left (defined in CEGUI::ColourRect) | CEGUI::ColourRect
d_bottom_right (defined in CEGUI::ColourRect) | CEGUI::ColourRect
d_top_left (defined in CEGUI::ColourRect) | CEGUI::ColourRect
d_top_right (defined in CEGUI::ColourRect) | CEGUI::ColourRect
getColourAtPoint(float x, float y) const | CEGUI::ColourRect
getSubRectangle(float left, float right, float top, float bottom) const | CEGUI::ColourRect
isMonochromatic() const | CEGUI::ColourRect
modulateAlpha(float alpha) | CEGUI::ColourRect
operator *=(const ColourRect &other) | CEGUI::ColourRect
setAlpha(float alpha) | CEGUI::ColourRect
setBottomAlpha(float alpha) | CEGUI::ColourRect
setColours(const colour &col) | CEGUI::ColourRect
setLeftAlpha(float alpha) | CEGUI::ColourRect
setRightAlpha(float alpha) | CEGUI::ColourRect
setTopAlpha(float alpha) | CEGUI::ColourRect

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Combobox Member List

This is the complete list of members for CEGUI::Combobox, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
activateEditbox(void) | CEGUI::Combobox |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addComboboxEvents(void) | CEGUI::Combobox | [protected]
addEvent(const String &name) | CEGUI::EventSet |
addItem(ListboxItem *item) | CEGUI::Combobox |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
button_PressHandler(const EventArgs &e) | CEGUI::Combobox | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearAllSelections(void) | CEGUI::Combobox |
clearProperties(void) | CEGUI::PropertySet |
Combobox(const String &type, const String &name) | CEGUI::Combobox |
createDropList(const String &name) const =0 | CEGUI::Combobox | [protected, pure virtual]
createEditbox(const String &name) const =0 | CEGUI::Combobox | [protected, pure virtual]
createPushButton(const String &name) const =0 | CEGUI::Combobox | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_button | CEGUI::Combobox | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_droplist | CEGUI::Combobox | [protected]
d_editbox | CEGUI::Combobox | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_singleClickOperation | CEGUI::Combobox | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
droplist_HiddenHandler(const EventArgs &e) | CEGUI::Combobox | [protected]
droplist_SelectionAcceptedHandler(const EventArgs &e) | CEGUI::Combobox | [protected]
editbox_CaratMovedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_EditboxFullEventHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_InvalidEntryAttemptedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_MaximumTextLengthChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_MouseDownHandler(const EventArgs &e) | CEGUI::Combobox | [protected]
editbox_ReadOnlyChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_TextAcceptedEventHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_TextChangedEventHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_TextInvalidatedEventHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_TextSelectionChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
editbox_ValidationStringChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCaratMoved | CEGUI::Combobox | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventDropListDisplayed | CEGUI::Combobox | [static]
EventDropListRemoved | CEGUI::Combobox | [static]
EventEditboxFull | CEGUI::Combobox | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHorzScrollbarModeChanged | CEGUI::Combobox | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventInvalidEntryAttempted | CEGUI::Combobox | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::Combobox | [static]
EventListSelectionAccepted | CEGUI::Combobox | [static]
EventListSelectionChanged | CEGUI::Combobox | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMaximumTextLengthChanged | CEGUI::Combobox | [static]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Combobox | [static]
EventParentSized | CEGUI::Window | [static]
EventReadOnlyModeChanged | CEGUI::Combobox | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventSortModeChanged | CEGUI::Combobox | [static]
EventTextAccepted | CEGUI::Combobox | [static]
EventTextChanged | CEGUI::Window | [static]
EventTextInvalidated | CEGUI::Combobox | [static]
EventTextSelectionChanged | CEGUI::Combobox | [static]
EventValidationStringChanged | CEGUI::Combobox | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventVertScrollbarModeChanged | CEGUI::Combobox | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ListboxItem *start_item) | CEGUI::Combobox |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getCaratIndex(void) const | CEGUI::Combobox |
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInactiveSelectBrushColour(void) const | CEGUI::Combobox |
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemCount(void) const | CEGUI::Combobox |
getItemIndex(const ListboxItem *item) const | CEGUI::Combobox |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getListboxItemFromIndex(size_t index) const | CEGUI::Combobox |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMaxTextLength(void) const | CEGUI::Combobox |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalSelectBrushColour(void) const | CEGUI::Combobox |
getNormalTextColour(void) const | CEGUI::Combobox |
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedItem(void) const | CEGUI::Combobox |
getSelectedTextColour(void) const | CEGUI::Combobox |
getSelectionEndIndex(void) const | CEGUI::Combobox |
getSelectionLength(void) const | CEGUI::Combobox |
getSelectionStartIndex(void) const | CEGUI::Combobox |
getSingleClickEnabled(void) const | CEGUI::Combobox |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getValidationString(void) const | CEGUI::Combobox |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleUpdatedListItemData(void) | CEGUI::Combobox |
hasInputFocus(void) const | CEGUI::Combobox |
hide(void) | CEGUI::Window | [inline]
hideDropList(void) | CEGUI::Combobox |
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Combobox | [virtual]
insertItem(ListboxItem *item, const ListboxItem *position) | CEGUI::Combobox |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isDropDownListVisible(void) const | CEGUI::Combobox |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Combobox | [inline, virtual]
isHorzScrollbarAlwaysShown(void) const | CEGUI::Combobox |
isItemSelected(size_t index) const | CEGUI::Combobox |
isListboxItemInList(const ListboxItem *item) const | CEGUI::Combobox |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isReadOnly(void) const | CEGUI::Combobox |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSortEnabled(void) const | CEGUI::Combobox |
isTextValid(void) const | CEGUI::Combobox |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVertScrollbarAlwaysShown(void) const | CEGUI::Combobox |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
listbox_HorzScrollModeChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
listbox_ListContentsChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
listbox_ListSelectionChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
listbox_SortModeChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
listbox_VertScrollModeChangedHandler(const EventArgs &e) (defined in CEGUI::Combobox) | CEGUI::Combobox | [protected]
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaratMoved(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDropListDisplayed(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onDroplistRemoved(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onEditboxFullEvent(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorzScrollbarModeChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInvalidEntryAttempted(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onListSelectionAccepted(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onListSelectionChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onMaximumTextLengthChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onReadOnlyChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSortModeChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onTextAcceptedEvent(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onTextInvalidatedEvent(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onTextSelectionChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onValidationStringChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVertScrollbarModeChanged(WindowEventArgs &e) | CEGUI::Combobox | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(const ListboxItem *item) | CEGUI::Combobox |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::Combobox |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setCaratIndex(size_t carat_pos) | CEGUI::Combobox |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInactiveSelectBrushColour(colour col) | CEGUI::Combobox |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItemSelectState(ListboxItem *item, bool state) | CEGUI::Combobox |
setItemSelectState(size_t item_index, bool state) | CEGUI::Combobox |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMaxTextLength(size_t max_len) | CEGUI::Combobox |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalSelectBrushColour(colour col) | CEGUI::Combobox |
setNormalTextColour(colour col) | CEGUI::Combobox |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setReadOnly(bool setting) | CEGUI::Combobox |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelectedTextColour(colour col) | CEGUI::Combobox |
setSelection(size_t start_pos, size_t end_pos) | CEGUI::Combobox |
setShowHorzScrollbar(bool setting) | CEGUI::Combobox |
setShowVertScrollbar(bool setting) | CEGUI::Combobox |
setSingleClickEnabled(bool setting) | CEGUI::Combobox |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSortingEnabled(bool setting) | CEGUI::Combobox |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setValidationString(const String &validation_string) | CEGUI::Combobox |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
showDropList(void) | CEGUI::Combobox |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Combobox | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~Combobox(void) | CEGUI::Combobox | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::ActiveEditSelectionColour Member List

This is the complete list of members for CEGUI::ComboboxProperties::ActiveEditSelectionColour, including all inherited members.

ActiveEditSelectionColour() (defined in CEGUI::ComboboxProperties::ActiveEditSelectionColour) | CEGUI::ComboboxProperties::ActiveEditSelectionColour | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::ActiveEditSelectionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::ActiveEditSelectionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::CaratIndex Member List

This is the complete list of members for CEGUI::ComboboxProperties::CaratIndex, including all inherited members.

CaratIndex() (defined in CEGUI::ComboboxProperties::CaratIndex) | CEGUI::ComboboxProperties::CaratIndex | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::CaratIndex | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::CaratIndex | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::EditSelectionLength Member List

This is the complete list of members for CEGUI::ComboboxProperties::EditSelectionLength, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
EditSelectionLength() (defined in CEGUI::ComboboxProperties::EditSelectionLength) | CEGUI::ComboboxProperties::EditSelectionLength | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::EditSelectionLength | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::EditSelectionLength | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::EditSelectionStart Member List

This is the complete list of members for CEGUI::ComboboxProperties::EditSelectionStart, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
EditSelectionStart() (defined in CEGUI::ComboboxProperties::EditSelectionStart) | CEGUI::ComboboxProperties::EditSelectionStart | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::EditSelectionStart | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::EditSelectionStart | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::ForceHorzScrollbar Member List

This is the complete list of members for CEGUI::ComboboxProperties::ForceHorzScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceHorzScrollbar() (defined in CEGUI::ComboboxProperties::ForceHorzScrollbar) | CEGUI::ComboboxProperties::ForceHorzScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::ForceHorzScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::ForceHorzScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::ForceVertScrollbar Member List

This is the complete list of members for CEGUI::ComboboxProperties::ForceVertScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceVertScrollbar() (defined in CEGUI::ComboboxProperties::ForceVertScrollbar) | CEGUI::ComboboxProperties::ForceVertScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::ForceVertScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::ForceVertScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::InactiveEditSelectionColour Member List

This is the complete list of members for CEGUI::ComboboxProperties::InactiveEditSelectionColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::InactiveEditSelectionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
InactiveEditSelectionColour() (defined in CEGUI::ComboboxProperties::InactiveEditSelectionColour) | CEGUI::ComboboxProperties::InactiveEditSelectionColour | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::InactiveEditSelectionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::MaxEditTextLength Member List

This is the complete list of members for CEGUI::ComboboxProperties::MaxEditTextLength, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::MaxEditTextLength | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaxEditTextLength() (defined in CEGUI::ComboboxProperties::MaxEditTextLength) | CEGUI::ComboboxProperties::MaxEditTextLength | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::MaxEditTextLength | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::NormalEditTextColour Member List

This is the complete list of members for CEGUI::ComboboxProperties::NormalEditTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::NormalEditTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NormalEditTextColour() (defined in CEGUI::ComboboxProperties::NormalEditTextColour) | CEGUI::ComboboxProperties::NormalEditTextColour | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::NormalEditTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::ReadOnly Member List

This is the complete list of members for CEGUI::ComboboxProperties::ReadOnly, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::ReadOnly | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
ReadOnly() (defined in CEGUI::ComboboxProperties::ReadOnly) | CEGUI::ComboboxProperties::ReadOnly | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::ReadOnly | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::SelectedEditTextColour Member List

This is the complete list of members for CEGUI::ComboboxProperties::SelectedEditTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::SelectedEditTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectedEditTextColour() (defined in CEGUI::ComboboxProperties::SelectedEditTextColour) | CEGUI::ComboboxProperties::SelectedEditTextColour | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::SelectedEditTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::SingleClickMode Member List

This is the complete list of members for CEGUI::ComboboxProperties::SingleClickMode, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::SingleClickMode | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::SingleClickMode | [virtual]
SingleClickMode() (defined in CEGUI::ComboboxProperties::SingleClickMode) | CEGUI::ComboboxProperties::SingleClickMode | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::SortList Member List

This is the complete list of members for CEGUI::ComboboxProperties::SortList, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::SortList | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::SortList | [virtual]
SortList() (defined in CEGUI::ComboboxProperties::SortList) | CEGUI::ComboboxProperties::SortList | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboboxProperties::ValidationString Member List

This is the complete list of members for CEGUI::ComboboxProperties::ValidationString, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ComboboxProperties::ValidationString | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ComboboxProperties::ValidationString | [virtual]
ValidationString() (defined in CEGUI::ComboboxProperties::ValidationString) | CEGUI::ComboboxProperties::ValidationString | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComboDropList Member List

This is the complete list of members for CEGUI::ComboDropList, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addComboDropListEvents(void) | CEGUI::ComboDropList | [protected]
addEvent(const String &name) | CEGUI::EventSet |
addItem(ListboxItem *item) | CEGUI::Listbox |
addListboxEvents(void) | CEGUI::Listbox | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
cacheListboxBaseImagery()=0 | CEGUI::Listbox | [protected, pure virtual]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearAllSelections(void) | CEGUI::Listbox |
clearAllSelections_impl(void) | CEGUI::Listbox | [protected]
clearProperties(void) | CEGUI::PropertySet |
ComboDropList(const String &type, const String &name) | CEGUI::ComboDropList |
configureScrollbars(void) | CEGUI::Listbox | [protected]
createHorzScrollbar(const String &name) const =0 | CEGUI::Listbox | [protected, pure virtual]
createVertScrollbar(const String &name) const =0 | CEGUI::Listbox | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_armed | CEGUI::ComboDropList | [protected]
d_autoArm | CEGUI::ComboDropList | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_forceHorzScroll | CEGUI::Listbox | [protected]
d_forceVertScroll | CEGUI::Listbox | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzScrollbar | CEGUI::Listbox | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_itemTooltips | CEGUI::Listbox | [protected]
d_lastSelected | CEGUI::Listbox | [protected]
d_listItems | CEGUI::Listbox | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_multiselect | CEGUI::Listbox | [protected]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sorted | CEGUI::Listbox | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertScrollbar | CEGUI::Listbox | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
ensureItemIsVisible(size_t item_index) | CEGUI::Listbox |
ensureItemIsVisible(const ListboxItem *item) | CEGUI::Listbox |
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHorzScrollbarModeChanged | CEGUI::Listbox | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::Listbox | [static]
EventListSelectionAccepted | CEGUI::ComboDropList | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventMultiselectModeChanged | CEGUI::Listbox | [static]
EventNamespace | CEGUI::ComboDropList | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSelectionChanged | CEGUI::Listbox | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventSortModeChanged | CEGUI::Listbox | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventVertScrollbarModeChanged | CEGUI::Listbox | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ListboxItem *start_item) | CEGUI::Listbox |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFirstSelectedItem(void) const | CEGUI::Listbox |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemAtPoint(const Point &pt) const | CEGUI::Listbox | [protected]
getItemCount(void) const | CEGUI::Listbox | [inline]
getItemIndex(const ListboxItem *item) const | CEGUI::Listbox |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getListboxItemFromIndex(size_t index) const | CEGUI::Listbox |
getListRenderArea(void) const =0 | CEGUI::Listbox | [protected, pure virtual]
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNextSelected(const ListboxItem *start_item) const | CEGUI::Listbox |
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedCount(void) const | CEGUI::Listbox |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getTotalItemsHeight(void) const | CEGUI::Listbox | [protected]
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidestItemWidth(void) const | CEGUI::Listbox | [protected]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handle_scrollChange(const EventArgs &args) | CEGUI::Listbox | [protected]
handleUpdatedItemData(void) | CEGUI::Listbox |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::ComboDropList | [virtual]
insertItem(ListboxItem *item, const ListboxItem *position) | CEGUI::Listbox |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isArmed(void) const | CEGUI::ComboDropList | [inline]
isAutoArmEnabled(void) const | CEGUI::ComboDropList | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHorzScrollbarAlwaysShown(void) const | CEGUI::Listbox |
isItemSelected(size_t index) const | CEGUI::Listbox |
isItemTooltipsEnabled(void) const (defined in CEGUI::Listbox) | CEGUI::Listbox | [inline]
isListboxItemInList(const ListboxItem *item) const | CEGUI::Listbox |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMultiselectEnabled(void) const | CEGUI::Listbox | [inline]
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSortEnabled(void) const | CEGUI::Listbox | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVertScrollbarAlwaysShown(void) const | CEGUI::Listbox |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
LBItemList typedef (defined in CEGUI::Listbox) | CEGUI::Listbox | [protected]
Listbox(const String &type, const String &name) | CEGUI::Listbox |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::ComboDropList | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ComboDropList | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorzScrollbarModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onListSelectionAccepted(WindowEventArgs &e) | CEGUI::ComboDropList | [protected]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ComboDropList | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::ComboDropList | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ComboDropList | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMultiselectModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSelectionChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onSortModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVertScrollbarModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Listbox | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(const ListboxItem *item) | CEGUI::Listbox |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::Listbox |
resetList_impl(void) | CEGUI::Listbox | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
selectRange(size_t start, size_t end) | CEGUI::Listbox | [protected]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setArmed(bool setting) | CEGUI::ComboDropList | [inline]
setAutoArmEnabled(bool setting) | CEGUI::ComboDropList | [inline]
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItemSelectState(ListboxItem *item, bool state) | CEGUI::Listbox |
setItemSelectState(size_t item_index, bool state) | CEGUI::Listbox |
setItemTooltipsEnabled(bool setting) (defined in CEGUI::Listbox) | CEGUI::Listbox |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMultiselectEnabled(bool setting) | CEGUI::Listbox |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setShowHorzScrollbar(bool setting) | CEGUI::Listbox |
setShowVertScrollbar(bool setting) | CEGUI::Listbox |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSortingEnabled(bool setting) | CEGUI::Listbox |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ComboDropList | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ComboDropList(void) | CEGUI::ComboDropList | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~Listbox(void) | CEGUI::Listbox | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ComponentArea Member List

This is the complete list of members for CEGUI::ComponentArea, including all inherited members.

d_bottom_or_height | CEGUI::ComponentArea
d_left | CEGUI::ComponentArea
d_right_or_width | CEGUI::ComponentArea
d_top | CEGUI::ComponentArea
getAreaPropertySource() const | CEGUI::ComponentArea
getPixelRect(const Window &wnd) const | CEGUI::ComponentArea
getPixelRect(const Window &wnd, const Rect &container) const | CEGUI::ComponentArea
isAreaFetchedFromProperty() const | CEGUI::ComponentArea
setAreaPropertySource(const String &property) | CEGUI::ComponentArea
writeXMLToStream(OutStream &out_stream) const | CEGUI::ComponentArea

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Config_xmlHandler Member List

This is the complete list of members for CEGUI::Config_xmlHandler, including all inherited members.

Config_xmlHandler(void) | CEGUI::Config_xmlHandler | [inline]
elementStart(const String &element, const XMLAttributes &attributes) | CEGUI::Config_xmlHandler | [virtual]
getDefaultFontName(void) const | CEGUI::Config_xmlHandler | [inline]
getDefaultResourceGroup(void) const | CEGUI::Config_xmlHandler | [inline]
getInitScriptFilename(void) const | CEGUI::Config_xmlHandler | [inline]
getLayoutFilename(void) const | CEGUI::Config_xmlHandler | [inline]
getLogFilename(void) const | CEGUI::Config_xmlHandler | [inline]
getLoggingLevel(void) const | CEGUI::Config_xmlHandler | [inline]
getSchemeFilename(void) const | CEGUI::Config_xmlHandler | [inline]
getTermScriptFilename(void) const | CEGUI::Config_xmlHandler | [inline]
~Config_xmlHandler(void) | CEGUI::Config_xmlHandler | [inline, virtual]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ConstBaseIterator< T > Member List

This is the complete list of members for CEGUI::ConstBaseIterator< T >, including all inherited members.

ConstBaseIterator(typename T::const_iterator start_iter, typename T::const_iterator end_iter) | CEGUI::ConstBaseIterator< T > | [inline]
ConstBaseIterator(const ConstBaseIterator< T > &org) | CEGUI::ConstBaseIterator< T > | [inline]
getCurrentKey(void) const | CEGUI::ConstBaseIterator< T > | [inline]
getCurrentValue(void) const | CEGUI::ConstBaseIterator< T > | [inline]
isAtEnd(void) const | CEGUI::ConstBaseIterator< T > | [inline]
isAtStart(void) const | CEGUI::ConstBaseIterator< T > | [inline]
mapped_type typedef (defined in CEGUI::ConstBaseIterator< T >) | CEGUI::ConstBaseIterator< T > |
operator *() const | CEGUI::ConstBaseIterator< T > | [inline]
operator!=(const ConstBaseIterator< T > &rhs) const | CEGUI::ConstBaseIterator< T > | [inline]
operator++() | CEGUI::ConstBaseIterator< T > | [inline]
operator++(int) | CEGUI::ConstBaseIterator< T > | [inline]
operator--() | CEGUI::ConstBaseIterator< T > | [inline]
operator--(int) | CEGUI::ConstBaseIterator< T > | [inline]
operator=(const ConstBaseIterator< T > &rhs) | CEGUI::ConstBaseIterator< T > | [inline]
operator==(const ConstBaseIterator< T > &rhs) const | CEGUI::ConstBaseIterator< T > | [inline]
toEnd(void) | CEGUI::ConstBaseIterator< T > | [inline]
toStart(void) | CEGUI::ConstBaseIterator< T > | [inline]
~ConstBaseIterator(void) | CEGUI::ConstBaseIterator< T > | [inline]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Dimension Member List

This is the complete list of members for CEGUI::Dimension, including all inherited members.

Dimension() | CEGUI::Dimension
Dimension(const BaseDim &dim, DimensionType type) | CEGUI::Dimension
Dimension(const Dimension &other) | CEGUI::Dimension
getBaseDimension() const | CEGUI::Dimension
getDimensionType() const | CEGUI::Dimension
operator=(const Dimension &other) | CEGUI::Dimension
setBaseDimension(const BaseDim &dim) | CEGUI::Dimension
setDimensionType(DimensionType type) | CEGUI::Dimension
writeXMLToStream(OutStream &out_stream) const | CEGUI::Dimension
~Dimension() | CEGUI::Dimension

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DirectX9Renderer Member List

This is the complete list of members for CEGUI::DirectX9Renderer, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
addQuad(const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode) | CEGUI::DirectX9Renderer | [virtual]
advanceZValue(void) | CEGUI::Renderer | [inline]
clearRenderList(void) | CEGUI::DirectX9Renderer | [virtual]
createResourceProvider(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]
createTexture(void) | CEGUI::DirectX9Renderer | [virtual]
createTexture(const String &filename, const String &resourceGroup) | CEGUI::DirectX9Renderer | [virtual]
createTexture(float size) | CEGUI::DirectX9Renderer | [virtual]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_identifierString | CEGUI::Renderer | [protected]
d_muted | CEGUI::EventSet | [protected]
d_resourceProvider | CEGUI::Renderer | [protected]
destroyAllTextures(void) | CEGUI::DirectX9Renderer | [virtual]
destroyTexture(Texture *texture) | CEGUI::DirectX9Renderer | [virtual]
DirectX9Renderer(LPDIRECT3DDEVICE9 device, uint max_quads) | CEGUI::DirectX9Renderer |
doRender(void) | CEGUI::DirectX9Renderer | [virtual]
EventDisplaySizeChanged | CEGUI::Renderer | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventNamespace | CEGUI::Renderer | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getCurrentZ(void) const | CEGUI::Renderer | [inline]
getDevice(void) const (defined in CEGUI::DirectX9Renderer) | CEGUI::DirectX9Renderer | [inline]
getHeight(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getHorzScreenDPI(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getIdentifierString() const | CEGUI::Renderer |
getIterator(void) const | CEGUI::EventSet |
getMaxTextureSize(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getRect(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getSize(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getVertScreenDPI(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getWidth(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
getZLayer(uint layer) const | CEGUI::Renderer | [inline]
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isQueueingEnabled(void) const | CEGUI::DirectX9Renderer | [inline, virtual]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
postD3DReset(void) | CEGUI::DirectX9Renderer | [virtual]
preD3DReset(void) | CEGUI::DirectX9Renderer | [virtual]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [protected]
resetZValue(void) | CEGUI::Renderer | [inline]
setDisplaySize(const Size &sz) | CEGUI::DirectX9Renderer |
setMutedState(bool setting) | CEGUI::EventSet |
setQueueingEnabled(bool setting) | CEGUI::DirectX9Renderer | [inline, virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~DirectX9Renderer(void) | CEGUI::DirectX9Renderer | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DirectX9Texture Member List

This is the complete list of members for CEGUI::DirectX9Texture, including all inherited members.

DirectX9Renderer::createTexture (defined in CEGUI::DirectX9Texture) | CEGUI::DirectX9Texture | [friend]
DirectX9Renderer::createTexture (defined in CEGUI::DirectX9Texture) | CEGUI::DirectX9Texture | [friend]
DirectX9Renderer::createTexture (defined in CEGUI::DirectX9Texture) | CEGUI::DirectX9Texture | [friend]
DirectX9Renderer::destroyTexture (defined in CEGUI::DirectX9Texture) | CEGUI::DirectX9Texture | [friend]
getD3DTexture(void) const | CEGUI::DirectX9Texture | [inline]
getHeight(void) const | CEGUI::DirectX9Texture | [inline, virtual]
getRenderer(void) const | CEGUI::Texture | [inline]
getWidth(void) const | CEGUI::DirectX9Texture | [inline, virtual]
loadFromFile(const String &filename, const String &resourceGroup) | CEGUI::DirectX9Texture | [virtual]
loadFromMemory(const void *buffPtr, uint buffWidth, uint buffHeight) | CEGUI::DirectX9Texture | [virtual]
postD3DReset(void) | CEGUI::DirectX9Texture | [virtual]
preD3DReset(void) | CEGUI::DirectX9Texture | [virtual]
setD3DTextureSize(uint size) | CEGUI::DirectX9Texture |
Texture(Renderer *owner) | CEGUI::Texture | [inline, protected]
~Texture(void) | CEGUI::Texture | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DirectX81Renderer Member List

This is the complete list of members for CEGUI::DirectX81Renderer, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
addQuad(const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode) | CEGUI::DirectX81Renderer | [virtual]
advanceZValue(void) | CEGUI::Renderer | [inline]
clearRenderList(void) | CEGUI::DirectX81Renderer | [virtual]
createResourceProvider(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]
createTexture(void) | CEGUI::DirectX81Renderer | [virtual]
createTexture(const String &filename, const String &resourceGroup) | CEGUI::DirectX81Renderer | [virtual]
createTexture(float size) | CEGUI::DirectX81Renderer | [virtual]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_identifierString | CEGUI::Renderer | [protected]
d_muted | CEGUI::EventSet | [protected]
d_resourceProvider | CEGUI::Renderer | [protected]
destroyAllTextures(void) | CEGUI::DirectX81Renderer | [virtual]
destroyTexture(Texture *texture) | CEGUI::DirectX81Renderer | [virtual]
DirectX81Renderer(LPDIRECT3DDEVICE8 device, uint max_quads=0) | CEGUI::DirectX81Renderer |
DirectX81Renderer(LPDIRECT3DDEVICE8 device, const Size &sz) | CEGUI::DirectX81Renderer |
doRender(void) | CEGUI::DirectX81Renderer | [virtual]
EventDisplaySizeChanged | CEGUI::Renderer | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventNamespace | CEGUI::Renderer | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getCurrentZ(void) const | CEGUI::Renderer | [inline]
getDevice(void) const (defined in CEGUI::DirectX81Renderer) | CEGUI::DirectX81Renderer | [inline]
getHeight(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getHorzScreenDPI(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getIdentifierString() const | CEGUI::Renderer |
getIterator(void) const | CEGUI::EventSet |
getMaxTextureSize(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getRect(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getSize(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getVertScreenDPI(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getWidth(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
getZLayer(uint layer) const | CEGUI::Renderer | [inline]
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isQueueingEnabled(void) const | CEGUI::DirectX81Renderer | [inline, virtual]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
postD3DReset(void) | CEGUI::DirectX81Renderer | [virtual]
preD3DReset(void) | CEGUI::DirectX81Renderer | [virtual]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [protected]
resetZValue(void) | CEGUI::Renderer | [inline]
setDisplaySize(const Size &sz) | CEGUI::DirectX81Renderer |
setMutedState(bool setting) | CEGUI::EventSet |
setQueueingEnabled(bool setting) | CEGUI::DirectX81Renderer | [inline, virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~DirectX81Renderer(void) | CEGUI::DirectX81Renderer | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DirectX81Texture Member List

This is the complete list of members for CEGUI::DirectX81Texture, including all inherited members.

DirectX81Renderer::createTexture (defined in CEGUI::DirectX81Texture) | CEGUI::DirectX81Texture | [friend]
DirectX81Renderer::createTexture (defined in CEGUI::DirectX81Texture) | CEGUI::DirectX81Texture | [friend]
DirectX81Renderer::createTexture (defined in CEGUI::DirectX81Texture) | CEGUI::DirectX81Texture | [friend]
DirectX81Renderer::destroyTexture (defined in CEGUI::DirectX81Texture) | CEGUI::DirectX81Texture | [friend]
getD3DTexture(void) const | CEGUI::DirectX81Texture | [inline]
getHeight(void) const | CEGUI::DirectX81Texture | [inline, virtual]
getRenderer(void) const | CEGUI::Texture | [inline]
getWidth(void) const | CEGUI::DirectX81Texture | [inline, virtual]
loadFromFile(const String &filename, const String &resourceGroup) | CEGUI::DirectX81Texture | [virtual]
loadFromMemory(const void *buffPtr, uint buffWidth, uint buffHeight) | CEGUI::DirectX81Texture | [virtual]
postD3DReset(void) | CEGUI::DirectX81Texture | [virtual]
preD3DReset(void) | CEGUI::DirectX81Texture | [virtual]
setD3DTextureSize(uint size) | CEGUI::DirectX81Texture |
Texture(Renderer *owner) | CEGUI::Texture | [inline, protected]
~Texture(void) | CEGUI::Texture | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragContainer Member List

This is the complete list of members for CEGUI::DragContainer, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addDragContainerEvents(void) | CEGUI::DragContainer | [protected]
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragAlpha | CEGUI::DragContainer | [protected]
d_dragCursorImage | CEGUI::DragContainer | [protected]
d_dragging | CEGUI::DragContainer | [protected]
d_draggingEnabled | CEGUI::DragContainer | [protected]
d_dragPoint | CEGUI::DragContainer | [protected]
d_dragThreshold | CEGUI::DragContainer | [protected]
d_drawList | CEGUI::Window | [protected]
d_dropTarget | CEGUI::DragContainer | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_leftMouseDown | CEGUI::DragContainer | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_startPosition | CEGUI::DragContainer | [protected]
d_storedAlpha | CEGUI::DragContainer | [protected]
d_storedClipState | CEGUI::DragContainer | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doDragging(const Point &local_mouse) | CEGUI::DragContainer | [protected]
doRiseOnClick(void) | CEGUI::Window | [protected]
DragContainer(const String &type, const String &name) | CEGUI::DragContainer |
drawSelf(float z) | CEGUI::DragContainer | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragAlphaChanged | CEGUI::DragContainer | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventDragDropTargetChanged | CEGUI::DragContainer | [static]
EventDragEnabledChanged | CEGUI::DragContainer | [static]
EventDragEnded | CEGUI::DragContainer | [static]
EventDragMouseCursorChanged | CEGUI::DragContainer | [static]
EventDragPositionChanged | CEGUI::DragContainer | [static]
EventDragStarted | CEGUI::DragContainer | [static]
EventDragThresholdChanged | CEGUI::DragContainer | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::DragContainer | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getCurrentDropTarget(void) const | CEGUI::DragContainer |
getDragAlpha(void) const | CEGUI::DragContainer |
getDragCursorImage(void) const | CEGUI::DragContainer |
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelDragThreshold(void) const | CEGUI::DragContainer |
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
initialiseDragging(void) | CEGUI::DragContainer | [protected]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isBeingDragged(void) const | CEGUI::DragContainer |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isDraggingEnabled(void) const | CEGUI::DragContainer |
isDraggingThresholdExceeded(const Point &local_mouse) | CEGUI::DragContainer | [protected]
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragAlphaChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropTargetChanged(DragDropEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragEnabledChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragEnded(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragMouseCursorChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragPositionChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragStarted(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onDragThresholdChanged(WindowEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::DragContainer | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setDragAlpha(float alpha) | CEGUI::DragContainer |
setDragCursorImage(const Image *image) | CEGUI::DragContainer |
setDragCursorImage(MouseCursorImage image) | CEGUI::DragContainer |
setDragCursorImage(const String &imageset, const String &image) | CEGUI::DragContainer |
setDraggingEnabled(bool setting) | CEGUI::DragContainer |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPixelDragThreshold(float pixels) | CEGUI::DragContainer |
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::DragContainer | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateActiveMouseCursor(void) const | CEGUI::DragContainer | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
WidgetTypeName | CEGUI::DragContainer | [static]
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~DragContainer(void) | CEGUI::DragContainer | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragContainerFactory Member List

This is the complete list of members for CEGUI::DragContainerFactory, including all inherited members.

createWindow(const String &name) | CEGUI::DragContainerFactory | [inline, virtual]
d_type | CEGUI::WindowFactory | [protected]
destroyWindow(Window *window) | CEGUI::DragContainerFactory | [inline, virtual]
DragContainerFactory(void) (defined in CEGUI::DragContainerFactory) | CEGUI::DragContainerFactory | [inline]
getTypeName(void) const | CEGUI::WindowFactory | [inline]
WindowFactory(const String &type) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, protected]
~DragContainerFactory(void) (defined in CEGUI::DragContainerFactory) | CEGUI::DragContainerFactory | [inline]
~WindowFactory(void) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragContainerProperties::DragAlpha Member List

This is the complete list of members for CEGUI::DragContainerProperties::DragAlpha, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DragAlpha() (defined in CEGUI::DragContainerProperties::DragAlpha) | CEGUI::DragContainerProperties::DragAlpha | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::DragContainerProperties::DragAlpha | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::DragContainerProperties::DragAlpha | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragContainerProperties::DragCursorImage Member List

This is the complete list of members for CEGUI::DragContainerProperties::DragCursorImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DragCursorImage() (defined in CEGUI::DragContainerProperties::DragCursorImage) | CEGUI::DragContainerProperties::DragCursorImage | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::DragContainerProperties::DragCursorImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::DragContainerProperties::DragCursorImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragContainerProperties::DraggingEnabled Member List

This is the complete list of members for CEGUI::DragContainerProperties::DraggingEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DraggingEnabled() (defined in CEGUI::DragContainerProperties::DraggingEnabled) | CEGUI::DragContainerProperties::DraggingEnabled | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::DragContainerProperties::DraggingEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::DragContainerProperties::DraggingEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragContainerProperties::DragThreshold Member List

This is the complete list of members for CEGUI::DragContainerProperties::DragThreshold, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DragThreshold() (defined in CEGUI::DragContainerProperties::DragThreshold) | CEGUI::DragContainerProperties::DragThreshold | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::DragContainerProperties::DragThreshold | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::DragContainerProperties::DragThreshold | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::DragDropEventArgs Member List

This is the complete list of members for CEGUI::DragDropEventArgs, including all inherited members.

DragDropEventArgs(Window *wnd) (defined in CEGUI::DragDropEventArgs) | CEGUI::DragDropEventArgs | [inline]
dragDropItem (defined in CEGUI::DragDropEventArgs) | CEGUI::DragDropEventArgs |
EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
window | CEGUI::WindowEventArgs |
WindowEventArgs(Window *wnd) (defined in CEGUI::WindowEventArgs) | CEGUI::WindowEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Editbox Member List

This is the complete list of members for CEGUI::Editbox, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEditboxEvents(void) | CEGUI::Editbox | [protected]
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
clearSelection(void) | CEGUI::Editbox | [protected]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_caratPos | CEGUI::Editbox | [protected]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragAnchorIdx | CEGUI::Editbox | [protected]
d_dragging | CEGUI::Editbox | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inactiveSelectBrushColour | CEGUI::Editbox | [protected]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maskCodePoint | CEGUI::Editbox | [protected]
d_maskText | CEGUI::Editbox | [protected]
d_maxSize | CEGUI::Window | [protected]
d_maxTextLen | CEGUI::Editbox | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalTextColour | CEGUI::Editbox | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_readOnly | CEGUI::Editbox | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_selectBrushColour | CEGUI::Editbox | [protected]
d_selectionEnd | CEGUI::Editbox | [protected]
d_selectionStart | CEGUI::Editbox | [protected]
d_selectTextColour | CEGUI::Editbox | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_validationString | CEGUI::Editbox | [protected]
d_validator | CEGUI::Editbox | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultInactiveSelectionColour | CEGUI::Editbox | [static]
DefaultNormalSelectionColour | CEGUI::Editbox | [static]
DefaultNormalTextColour | CEGUI::Editbox | [static]
DefaultSelectedTextColour | CEGUI::Editbox | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
Editbox(const String &type, const String &name) | CEGUI::Editbox |
enable(void) | CEGUI::Window | [inline]
eraseSelectedText(bool modify_text=true) | CEGUI::Editbox | [protected]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCaratMoved | CEGUI::Editbox | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEditboxFull | CEGUI::Editbox | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventInvalidEntryAttempted | CEGUI::Editbox | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMaskCodePointChanged | CEGUI::Editbox | [static]
EventMaskedRenderingModeChanged | CEGUI::Editbox | [static]
EventMaximumTextLengthChanged | CEGUI::Editbox | [static]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Editbox | [static]
EventParentSized | CEGUI::Window | [static]
EventReadOnlyModeChanged | CEGUI::Editbox | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextAccepted | CEGUI::Editbox | [static]
EventTextChanged | CEGUI::Window | [static]
EventTextInvalidated | CEGUI::Editbox | [static]
EventTextSelectionChanged | CEGUI::Editbox | [static]
EventValidationStringChanged | CEGUI::Editbox | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getCaratIndex(void) const | CEGUI::Editbox | [inline]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInactiveSelectBrushColour(void) const | CEGUI::Editbox | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaskCodePoint(void) const | CEGUI::Editbox | [inline]
getMaximumSize(void) const | CEGUI::Window |
getMaxTextLength(void) const | CEGUI::Editbox | [inline]
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalSelectBrushColour(void) const | CEGUI::Editbox | [inline]
getNormalTextColour(void) const | CEGUI::Editbox | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedTextColour(void) const | CEGUI::Editbox | [inline]
getSelectionEndIndex(void) const | CEGUI::Editbox |
getSelectionLength(void) const | CEGUI::Editbox |
getSelectionStartIndex(void) const | CEGUI::Editbox |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextIndexFromPosition(const Point &pt) const =0 | CEGUI::Editbox | [protected, pure virtual]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getValidationString(void) const | CEGUI::Editbox | [inline]
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleBackspace(void) | CEGUI::Editbox | [protected]
handleCharLeft(uint sysKeys) | CEGUI::Editbox | [protected]
handleCharRight(uint sysKeys) | CEGUI::Editbox | [protected]
handleDelete(void) | CEGUI::Editbox | [protected]
handleEnd(uint sysKeys) | CEGUI::Editbox | [protected]
handleHome(uint sysKeys) | CEGUI::Editbox | [protected]
handleWordLeft(uint sysKeys) | CEGUI::Editbox | [protected]
handleWordRight(uint sysKeys) | CEGUI::Editbox | [protected]
hasInputFocus(void) const | CEGUI::Editbox |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isReadOnly(void) const | CEGUI::Editbox | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isStringValid(const String &str) const | CEGUI::Editbox | [protected]
isTextMasked(void) const | CEGUI::Editbox | [inline]
isTextValid(void) const | CEGUI::Editbox |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onCaratMoved(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEditboxFullEvent(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInvalidEntryAttempted(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMaskCodePointChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMaskedRenderingModeChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMaximumTextLengthChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onReadOnlyChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextAcceptedEvent(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onTextInvalidatedEvent(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onTextSelectionChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onValidationStringChanged(WindowEventArgs &e) | CEGUI::Editbox | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setCaratIndex(size_t carat_pos) | CEGUI::Editbox |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInactiveSelectBrushColour(const colour &col) | CEGUI::Editbox |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaskCodePoint(utf32 code_point) | CEGUI::Editbox |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMaxTextLength(size_t max_len) | CEGUI::Editbox |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalSelectBrushColour(const colour &col) | CEGUI::Editbox |
setNormalTextColour(const colour &col) | CEGUI::Editbox |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setReadOnly(bool setting) | CEGUI::Editbox |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelectedTextColour(const colour &col) | CEGUI::Editbox |
setSelection(size_t start_pos, size_t end_pos) | CEGUI::Editbox |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTextMasked(bool setting) | CEGUI::Editbox |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setValidationString(const String &validation_string) | CEGUI::Editbox |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Editbox | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~Editbox(void) | CEGUI::Editbox | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::ActiveSelectionColour Member List

This is the complete list of members for CEGUI::EditboxProperties::ActiveSelectionColour, including all inherited members.

ActiveSelectionColour() (defined in CEGUI::EditboxProperties::ActiveSelectionColour) | CEGUI::EditboxProperties::ActiveSelectionColour | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::ActiveSelectionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::ActiveSelectionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::CaratIndex Member List

This is the complete list of members for CEGUI::EditboxProperties::CaratIndex, including all inherited members.

CaratIndex() (defined in CEGUI::EditboxProperties::CaratIndex) | CEGUI::EditboxProperties::CaratIndex | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::CaratIndex | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::CaratIndex | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::InactiveSelectionColour Member List

This is the complete list of members for CEGUI::EditboxProperties::InactiveSelectionColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::InactiveSelectionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
InactiveSelectionColour() (defined in CEGUI::EditboxProperties::InactiveSelectionColour) | CEGUI::EditboxProperties::InactiveSelectionColour | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::InactiveSelectionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::MaskCodepoint Member List

This is the complete list of members for CEGUI::EditboxProperties::MaskCodepoint, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::MaskCodepoint | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaskCodepoint() (defined in CEGUI::EditboxProperties::MaskCodepoint) | CEGUI::EditboxProperties::MaskCodepoint | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::MaskCodepoint | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::MaskText Member List

This is the complete list of members for CEGUI::EditboxProperties::MaskText, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::MaskText | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaskText() (defined in CEGUI::EditboxProperties::MaskText) | CEGUI::EditboxProperties::MaskText | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::MaskText | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::MaxTextLength Member List

This is the complete list of members for CEGUI::EditboxProperties::MaxTextLength, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::MaxTextLength | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaxTextLength() (defined in CEGUI::EditboxProperties::MaxTextLength) | CEGUI::EditboxProperties::MaxTextLength | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::MaxTextLength | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::NormalTextColour Member List

This is the complete list of members for CEGUI::EditboxProperties::NormalTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::NormalTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NormalTextColour() (defined in CEGUI::EditboxProperties::NormalTextColour) | CEGUI::EditboxProperties::NormalTextColour | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::NormalTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::ReadOnly Member List

This is the complete list of members for CEGUI::EditboxProperties::ReadOnly, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::ReadOnly | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
ReadOnly() (defined in CEGUI::EditboxProperties::ReadOnly) | CEGUI::EditboxProperties::ReadOnly | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::ReadOnly | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::SelectedTextColour Member List

This is the complete list of members for CEGUI::EditboxProperties::SelectedTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::SelectedTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectedTextColour() (defined in CEGUI::EditboxProperties::SelectedTextColour) | CEGUI::EditboxProperties::SelectedTextColour | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::SelectedTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::SelectionLength Member List

This is the complete list of members for CEGUI::EditboxProperties::SelectionLength, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::SelectionLength | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectionLength() (defined in CEGUI::EditboxProperties::SelectionLength) | CEGUI::EditboxProperties::SelectionLength | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::SelectionLength | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::SelectionStart Member List

This is the complete list of members for CEGUI::EditboxProperties::SelectionStart, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::SelectionStart | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectionStart() (defined in CEGUI::EditboxProperties::SelectionStart) | CEGUI::EditboxProperties::SelectionStart | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::SelectionStart | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EditboxProperties::ValidationString Member List

This is the complete list of members for CEGUI::EditboxProperties::ValidationString, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::EditboxProperties::ValidationString | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::EditboxProperties::ValidationString | [virtual]
ValidationString() (defined in CEGUI::EditboxProperties::ValidationString) | CEGUI::EditboxProperties::ValidationString | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Event Member List

This is the complete list of members for CEGUI::Event, including all inherited members.

Connection typedef (defined in CEGUI::Event) | CEGUI::Event |
ConnectionImpl (defined in CEGUI::Event) | CEGUI::Event | [friend]
Event(const String &name) | CEGUI::Event |
getName(void) const | CEGUI::Event | [inline]
Group typedef (defined in CEGUI::Event) | CEGUI::Event |
operator()(EventArgs &args) (defined in CEGUI::Event) | CEGUI::Event |
subscribe(Subscriber subscriber) | CEGUI::Event | [inline]
subscribe(Group group, Subscriber subscriber) | CEGUI::Event |
Subscriber typedef (defined in CEGUI::Event) | CEGUI::Event |
~Event(void) | CEGUI::Event | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Event::ConnectionInterface Member List

This is the complete list of members for CEGUI::Event::ConnectionInterface, including all inherited members.

connected() (defined in CEGUI::Event::ConnectionInterface) | CEGUI::Event::ConnectionInterface | [inline, virtual]
disconnect() (defined in CEGUI::Event::ConnectionInterface) | CEGUI::Event::ConnectionInterface | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Event::ScopedConnection Member List

This is the complete list of members for CEGUI::Event::ScopedConnection, including all inherited members.

conn (defined in CEGUI::Event::ScopedConnection) | CEGUI::Event::ScopedConnection |
ScopedConnection(Connection conn_) (defined in CEGUI::Event::ScopedConnection) | CEGUI::Event::ScopedConnection | [inline]
~ScopedConnection() (defined in CEGUI::Event::ScopedConnection) | CEGUI::Event::ScopedConnection | [inline]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EventArgs Member List

This is the complete list of members for CEGUI::EventArgs, including all inherited members.

EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::EventSet Member List

This is the complete list of members for CEGUI::EventSet, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_muted | CEGUI::EventSet | [protected]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getIterator(void) const | CEGUI::EventSet |
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
setMutedState(bool setting) | CEGUI::EventSet |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Exception Member List

This is the complete list of members for CEGUI::Exception, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FactoryModule Member List

This is the complete list of members for CEGUI::FactoryModule, including all inherited members.

FactoryModule(const String &filename) | CEGUI::FactoryModule |
registerAllFactories() const | CEGUI::FactoryModule |
registerFactory(const String &type) const | CEGUI::FactoryModule |
~FactoryModule(void) | CEGUI::FactoryModule | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Falagard_xmlHandler Member List

This is the complete list of members for CEGUI::Falagard_xmlHandler, including all inherited members.

elementEnd(const String &element) (defined in CEGUI::Falagard_xmlHandler) | CEGUI::Falagard_xmlHandler
elementStart(const String &element, const XMLAttributes &attributes) (defined in CEGUI::Falagard_xmlHandler) | CEGUI::Falagard_xmlHandler
Falagard_xmlHandler(WidgetLookManager *mgr) | CEGUI::Falagard_xmlHandler
~Falagard_xmlHandler() | CEGUI::Falagard_xmlHandler

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FalagardComponentBase Member List

This is the complete list of members for CEGUI::FalagardComponentBase, including all inherited members.

d_area | CEGUI::FalagardComponentBase | [protected]
d_colourPropertyName | CEGUI::FalagardComponentBase | [protected]
d_colourProperyIsRect | CEGUI::FalagardComponentBase | [protected]
d_colours | CEGUI::FalagardComponentBase | [protected]
d_horzFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
d_vertFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
FalagardComponentBase() | CEGUI::FalagardComponentBase |
getColours() const | CEGUI::FalagardComponentBase |
getComponentArea() const | CEGUI::FalagardComponentBase |
initColoursRect(const Window &wnd, const ColourRect *modCols, ColourRect &cr) const | CEGUI::FalagardComponentBase | [protected]
render(Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render(Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render_impl(Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const =0 | CEGUI::FalagardComponentBase | [protected, pure virtual]
setColours(const ColourRect &cols) | CEGUI::FalagardComponentBase |
setColoursPropertyIsColourRect(bool setting=true) | CEGUI::FalagardComponentBase |
setColoursPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setComponentArea(const ComponentArea &area) | CEGUI::FalagardComponentBase |
setHorzFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setVertFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
writeColoursXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeHorzFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeVertFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
~FalagardComponentBase() | CEGUI::FalagardComponentBase | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FalagardXMLHelper Member List

This is the complete list of members for CEGUI::FalagardXMLHelper, including all inherited members.

dimensionOperatorToString(DimensionOperator op) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
dimensionTypeToString(DimensionType dim) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
fontMetricTypeToString(FontMetricType metric) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
frameImageComponentToString(FrameImageComponent imageComp) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
horzAlignmentToString(HorizontalAlignment alignment) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
horzFormatToString(HorizontalFormatting format) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
horzTextFormatToString(HorizontalTextFormatting format) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToDimensionOperator(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToDimensionType(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToFontMetricType(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToFrameImageComponent(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToHorzAlignment(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToHorzFormat(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToHorzTextFormat(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToVertAlignment(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToVertFormat(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
stringToVertTextFormat(const String &str) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
vertAlignmentToString(VerticalAlignment alignment) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
vertFormatToString(VerticalFormatting format) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]
vertTextFormatToString(VerticalTextFormatting format) (defined in CEGUI::FalagardXMLHelper) | CEGUI::FalagardXMLHelper | [static]

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FileIOException Member List

This is the complete list of members for CEGUI::FileIOException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
FileIOException(const String &message) (defined in CEGUI::FileIOException) | CEGUI::FileIOException | [inline]
getMessage(void) const | CEGUI::Exception | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Font Member List

This is the complete list of members for CEGUI::Font, including all inherited members.

DefaultColour | CEGUI::Font | [static]
defineFontGlyphs(const String &glyph_set) | CEGUI::Font |
defineFontGlyphs(utf32 first_code_point, utf32 last_code_point) | CEGUI::Font |
drawText(const String &text, const Rect &draw_area, float z, const Rect &clip_rect, TextFormatting fmt, const ColourRect &colours, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font |
drawText(const String &text, const Rect &draw_area, float z, const Rect &clip_rect, TextFormatting fmt, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
drawText(const String &text, const Rect &draw_area, float z, const Rect &clip_rect, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
drawText(const String &text, const Rect &draw_area, float z, TextFormatting fmt, const ColourRect &colours, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
drawText(const String &text, const Rect &draw_area, float z, TextFormatting fmt, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
drawText(const String &text, const Rect &draw_area, float z, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
drawText(const String &text, const Vector3 &position, const Rect &clip_rect, const ColourRect &colours, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
drawText(const String &text, const Vector3 &position, const Rect &clip_rect, float x_scale=1.0f, float y_scale=1.0f) const | CEGUI::Font | [inline]
Font_xmlHandler (defined in CEGUI::Font) | CEGUI::Font | [friend]
FontManager (defined in CEGUI::Font) | CEGUI::Font | [friend]
getAvailableGlyphs(void) const | CEGUI::Font |
getBaseline(float y_scale=1.0f) const | CEGUI::Font | [inline]
getCharAtPixel(const String &text, float pixel, float x_scale=1.0f) const | CEGUI::Font | [inline]
getCharAtPixel(const String &text, size_t start_char, float pixel, float x_scale=1.0f) const | CEGUI::Font |
getFontHeight(float y_scale=1.0f) const | CEGUI::Font | [inline]
getFormattedLineCount(const String &text, const Rect &format_area, TextFormatting fmt, float x_scale=1.0f) const | CEGUI::Font |
getFormattedTextExtent(const String &text, const Rect &format_area, TextFormatting fmt, float x_scale=1.0f) const | CEGUI::Font |
getLineSpacing(float y_scale=1.0f) const | CEGUI::Font | [inline]
getName(void) const | CEGUI::Font | [inline]
getNativeResolution(void) const | CEGUI::Font | [inline]
getPointSize(void) const | CEGUI::Font |
getTextExtent(const String &text, float x_scale=1.0f) const | CEGUI::Font |
isAntiAliased(void) const | CEGUI::Font |
isAutoScaled(void) const | CEGUI::Font | [inline]
isCodepointAvailable(utf32 cp) const | CEGUI::Font | [inline]
notifyScreenResolution(const Size &size) | CEGUI::Font |
setAntiAliased(bool setting) | CEGUI::Font |
setAutoScalingEnabled(bool setting) | CEGUI::Font |
setNativeResolution(const Size &size) | CEGUI::Font |
~Font(void) | CEGUI::Font |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Font_xmlHandler Member List

This is the complete list of members for CEGUI::Font_xmlHandler, including all inherited members.

elementEnd(const String &element) (defined in CEGUI::Font_xmlHandler) | CEGUI::Font_xmlHandler | [virtual]
elementStart(const String &element, const XMLAttributes &attributes) | CEGUI::Font_xmlHandler | [virtual]
Font_xmlHandler(Font *font) | CEGUI::Font_xmlHandler | [inline]
~Font_xmlHandler(void) | CEGUI::Font_xmlHandler | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FontDim Member List

This is the complete list of members for CEGUI::FontDim, including all inherited members.

BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const | CEGUI::FontDim | [protected, virtual]
FontDim(const String &name, const String &font, const String &text, FontMetricType metric, float padding=0) | CEGUI::FontDim |
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const | CEGUI::FontDim | [protected, virtual]
getValue_impl(const Window &wnd, const Rect &container) const | CEGUI::FontDim | [protected, virtual]
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const | CEGUI::FontDim | [protected, virtual]
writeXMLElementName_impl(OutStream &out_stream) const | CEGUI::FontDim | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FontManager Member List

This is the complete list of members for CEGUI::FontManager, including all inherited members.

createFont(const String &filename, const String &resourceGroup="") | CEGUI::FontManager |
createFont(const String &name, const String &fontname, uint size, uint flags, const String &resourceGroup="") | CEGUI::FontManager |
destroyAllFonts(void) | CEGUI::FontManager |
destroyFont(const String &name) | CEGUI::FontManager |
destroyFont(Font *font) | CEGUI::FontManager |
FontIterator typedef (defined in CEGUI::FontManager) | CEGUI::FontManager |
FontManager(void) | CEGUI::FontManager |
getFont(const String &name) const | CEGUI::FontManager |
getIterator(void) const | CEGUI::FontManager |
getSingleton(void) | CEGUI::FontManager | [static]
getSingletonPtr(void) | CEGUI::FontManager | [static]
isFontPresent(const String &name) const | CEGUI::FontManager |
notifyScreenResolution(const Size &size) | CEGUI::FontManager |
writeFontToStream(const String &name, OutStream &out_stream) const | CEGUI::FontManager |
~FontManager(void) | CEGUI::FontManager |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameComponent Member List

This is the complete list of members for CEGUI::FrameComponent, including all inherited members.

d_area | CEGUI::FalagardComponentBase | [protected]
d_colourPropertyName | CEGUI::FalagardComponentBase | [protected]
d_colourProperyIsRect | CEGUI::FalagardComponentBase | [protected]
d_colours | CEGUI::FalagardComponentBase | [protected]
d_frameImages | CEGUI::FrameComponent | [protected]
d_horzFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
d_horzFormatting | CEGUI::FrameComponent | [protected]
d_vertFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
d_vertFormatting | CEGUI::FrameComponent | [protected]
doBackgroundRender(Window &srcWindow, Rect &destRect, float base_z, const ColourRect &colours, const Rect *clipper, bool clipToDisplay) const (defined in CEGUI::FrameComponent) | CEGUI::FrameComponent | [protected]
FalagardComponentBase() | CEGUI::FalagardComponentBase |
FrameComponent() | CEGUI::FrameComponent |
getBackgroundHorizontalFormatting() const | CEGUI::FrameComponent |
getBackgroundVerticalFormatting() const | CEGUI::FrameComponent |
getColours() const | CEGUI::FalagardComponentBase |
getComponentArea() const | CEGUI::FalagardComponentBase |
getImage(FrameImageComponent part) const | CEGUI::FrameComponent |
initColoursRect(const Window &wnd, const ColourRect *modCols, ColourRect &cr) const | CEGUI::FalagardComponentBase | [protected]
render(Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render(Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render_impl(Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const | CEGUI::FrameComponent | [protected, virtual]
setBackgroundHorizontalFormatting(HorizontalFormatting fmt) | CEGUI::FrameComponent |
setBackgroundVerticalFormatting(VerticalFormatting fmt) | CEGUI::FrameComponent |
setColours(const ColourRect &cols) | CEGUI::FalagardComponentBase |
setColoursPropertyIsColourRect(bool setting=true) | CEGUI::FalagardComponentBase |
setColoursPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setComponentArea(const ComponentArea &area) | CEGUI::FalagardComponentBase |
setHorzFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setImage(FrameImageComponent part, const Image *image) | CEGUI::FrameComponent |
setImage(FrameImageComponent part, const String &imageset, const String &image) | CEGUI::FrameComponent |
setVertFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
writeColoursXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeHorzFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeVertFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeXMLToStream(OutStream &out_stream) const | CEGUI::FrameComponent |
~FalagardComponentBase() | CEGUI::FalagardComponentBase | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindow Member List

This is the complete list of members for CEGUI::FrameWindow, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addFrameWindowEvents(void) | CEGUI::FrameWindow | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
closeClickHandler(const EventArgs &e) | CEGUI::FrameWindow | [protected]
createCloseButton(const String &name) const =0 | CEGUI::FrameWindow | [protected, pure virtual]
createTitlebar(const String &name) const =0 | CEGUI::FrameWindow | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_beingSized | CEGUI::FrameWindow | [protected]
d_borderSize | CEGUI::FrameWindow | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_closeButton | CEGUI::FrameWindow | [protected]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragMovable | CEGUI::FrameWindow | [protected]
d_dragPoint | CEGUI::FrameWindow | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_ewSizingCursor | CEGUI::FrameWindow | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_frameEnabled | CEGUI::FrameWindow | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_neswSizingCursor | CEGUI::FrameWindow | [protected]
d_nsSizingCursor | CEGUI::FrameWindow | [protected]
d_nwseSizingCursor | CEGUI::FrameWindow | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rolledup | CEGUI::FrameWindow | [protected]
d_rollupEnabled | CEGUI::FrameWindow | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizingEnabled | CEGUI::FrameWindow | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_titlebar | CEGUI::FrameWindow | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultSizingBorderSize | CEGUI::FrameWindow | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventCloseClicked | CEGUI::FrameWindow | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::FrameWindow | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventRollupToggled | CEGUI::FrameWindow | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
FrameWindow(const String &name, const String &type) | CEGUI::FrameWindow |
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptionColour(void) const | CEGUI::FrameWindow |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getEWSizingCursorImage() const | CEGUI::FrameWindow |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNESWSizingCursorImage() const | CEGUI::FrameWindow |
getNSSizingCursorImage() const | CEGUI::FrameWindow |
getNWSESizingCursorImage() const | CEGUI::FrameWindow |
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getSizingBorderAtPoint(const Point &pt) const | CEGUI::FrameWindow | [protected]
getSizingBorderThickness(void) const | CEGUI::FrameWindow | [inline]
getSizingRect(void) const | CEGUI::FrameWindow | [inline, protected, virtual]
getText(void) const | CEGUI::Window | [inline]
getTitlebarFont(void) const | CEGUI::FrameWindow |
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::FrameWindow | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isBottomSizingLocation(SizingLocation loc) const | CEGUI::FrameWindow | [inline, protected]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isCloseButtonEnabled(void) const | CEGUI::FrameWindow | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isDragMovingEnabled(void) const | CEGUI::FrameWindow | [inline]
isEventPresent(const String &name) | CEGUI::EventSet |
isFrameEnabled(void) const | CEGUI::FrameWindow | [inline]
isHit(const Point &position) const | CEGUI::FrameWindow | [inline, virtual]
isLeftSizingLocation(SizingLocation loc) const | CEGUI::FrameWindow | [inline, protected]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRightSizingLocation(SizingLocation loc) const | CEGUI::FrameWindow | [inline, protected]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isRolledup(void) const | CEGUI::FrameWindow | [inline]
isRollupEnabled(void) const | CEGUI::FrameWindow | [inline]
isSizingEnabled(void) const | CEGUI::FrameWindow | [inline]
isTitleBarEnabled(void) const | CEGUI::FrameWindow | [inline]
isTopSizingLocation(SizingLocation loc) const | CEGUI::FrameWindow | [inline, protected]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveBottomEdge(float delta) | CEGUI::FrameWindow | [protected]
moveLeftEdge(float delta) | CEGUI::FrameWindow | [protected]
moveRightEdge(float delta) | CEGUI::FrameWindow | [protected]
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
moveTopEdge(float delta) | CEGUI::FrameWindow | [protected]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
offsetPixelPosition(const Vector2 &offset) | CEGUI::FrameWindow |
onActivated(ActivationEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCloseClicked(WindowEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRollupToggled(WindowEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::FrameWindow | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setCaptionColour(colour col) | CEGUI::FrameWindow |
setClippedByParent(bool setting) | CEGUI::Window |
setCloseButtonEnabled(bool setting) | CEGUI::FrameWindow |
setCursorForPoint(const Point &pt) const | CEGUI::FrameWindow | [protected]
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setDragMovingEnabled(bool setting) | CEGUI::FrameWindow |
setEnabled(bool setting) | CEGUI::Window |
setEWSizingCursorImage(const Image *image) | CEGUI::FrameWindow |
setEWSizingCursorImage(const String &imageset, const String &image) | CEGUI::FrameWindow |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setFrameEnabled(bool setting) | CEGUI::FrameWindow |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNESWSizingCursorImage(const Image *image) | CEGUI::FrameWindow |
setNESWSizingCursorImage(const String &imageset, const String &image) | CEGUI::FrameWindow |
setNSSizingCursorImage(const Image *image) | CEGUI::FrameWindow |
setNSSizingCursorImage(const String &imageset, const String &image) | CEGUI::FrameWindow |
setNWSESizingCursorImage(const Image *image) | CEGUI::FrameWindow |
setNWSESizingCursorImage(const String &imageset, const String &image) | CEGUI::FrameWindow |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setRollupEnabled(bool setting) | CEGUI::FrameWindow |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSizingBorderThickness(float pixels) | CEGUI::FrameWindow | [inline]
setSizingEnabled(bool setting) | CEGUI::FrameWindow |
setText(const String &text) | CEGUI::Window |
setTitleBarEnabled(bool setting) | CEGUI::FrameWindow |
setTitlebarFont(const String &name) | CEGUI::FrameWindow |
setTitlebarFont(Font *font) | CEGUI::FrameWindow |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
SizingBottom enum value | CEGUI::FrameWindow |
SizingBottomLeft enum value | CEGUI::FrameWindow |
SizingBottomRight enum value | CEGUI::FrameWindow |
SizingLeft enum value | CEGUI::FrameWindow |
SizingLocation enum name | CEGUI::FrameWindow |
SizingNone enum value | CEGUI::FrameWindow |
SizingRight enum value | CEGUI::FrameWindow |
SizingTop enum value | CEGUI::FrameWindow |
SizingTopLeft enum value | CEGUI::FrameWindow |
SizingTopRight enum value | CEGUI::FrameWindow |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::FrameWindow | [inline, protected, virtual]
toggleRollup(void) | CEGUI::FrameWindow |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~FrameWindow(void) | CEGUI::FrameWindow | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::CaptionColour Member List

This is the complete list of members for CEGUI::FrameWindowProperties::CaptionColour, including all inherited members.

CaptionColour() (defined in CEGUI::FrameWindowProperties::CaptionColour) | CEGUI::FrameWindowProperties::CaptionColour | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::CaptionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::CaptionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::CloseButtonEnabled Member List

This is the complete list of members for CEGUI::FrameWindowProperties::CloseButtonEnabled, including all inherited members.

CloseButtonEnabled() (defined in CEGUI::FrameWindowProperties::CloseButtonEnabled) | CEGUI::FrameWindowProperties::CloseButtonEnabled | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::CloseButtonEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::CloseButtonEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::DragMovingEnabled Member List

This is the complete list of members for CEGUI::FrameWindowProperties::DragMovingEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DragMovingEnabled() (defined in CEGUI::FrameWindowProperties::DragMovingEnabled) | CEGUI::FrameWindowProperties::DragMovingEnabled | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::DragMovingEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::DragMovingEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::EWSizingCursorImage Member List

This is the complete list of members for CEGUI::FrameWindowProperties::EWSizingCursorImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
EWSizingCursorImage() (defined in CEGUI::FrameWindowProperties::EWSizingCursorImage) | CEGUI::FrameWindowProperties::EWSizingCursorImage | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::EWSizingCursorImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::EWSizingCursorImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::FrameEnabled Member List

This is the complete list of members for CEGUI::FrameWindowProperties::FrameEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
FrameEnabled() (defined in CEGUI::FrameWindowProperties::FrameEnabled) | CEGUI::FrameWindowProperties::FrameEnabled | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::FrameEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::FrameEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::NESWSizingCursorImage Member List

This is the complete list of members for CEGUI::FrameWindowProperties::NESWSizingCursorImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::NESWSizingCursorImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NESWSizingCursorImage() (defined in CEGUI::FrameWindowProperties::NESWSizingCursorImage) | CEGUI::FrameWindowProperties::NESWSizingCursorImage | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::NESWSizingCursorImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::NSSizingCursorImage Member List

This is the complete list of members for CEGUI::FrameWindowProperties::NSSizingCursorImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::NSSizingCursorImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NSSizingCursorImage() (defined in CEGUI::FrameWindowProperties::NSSizingCursorImage) | CEGUI::FrameWindowProperties::NSSizingCursorImage | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::NSSizingCursorImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::NWSESizingCursorImage Member List

This is the complete list of members for CEGUI::FrameWindowProperties::NWSESizingCursorImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::NWSESizingCursorImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NWSESizingCursorImage() (defined in CEGUI::FrameWindowProperties::NWSESizingCursorImage) | CEGUI::FrameWindowProperties::NWSESizingCursorImage | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::NWSESizingCursorImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::RollUpEnabled Member List

This is the complete list of members for CEGUI::FrameWindowProperties::RollUpEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::RollUpEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RollUpEnabled() (defined in CEGUI::FrameWindowProperties::RollUpEnabled) | CEGUI::FrameWindowProperties::RollUpEnabled | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::RollUpEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::RollUpState Member List

This is the complete list of members for CEGUI::FrameWindowProperties::RollUpState, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::RollUpState | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RollUpState() (defined in CEGUI::FrameWindowProperties::RollUpState) | CEGUI::FrameWindowProperties::RollUpState | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::RollUpState | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::SizingBorderThickness Member List

This is the complete list of members for CEGUI::FrameWindowProperties::SizingBorderThickness, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::SizingBorderThickness | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::SizingBorderThickness | [virtual]
SizingBorderThickness() (defined in CEGUI::FrameWindowProperties::SizingBorderThickness) | CEGUI::FrameWindowProperties::SizingBorderThickness | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::SizingEnabled Member List

This is the complete list of members for CEGUI::FrameWindowProperties::SizingEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::SizingEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::SizingEnabled | [virtual]
SizingEnabled() (defined in CEGUI::FrameWindowProperties::SizingEnabled) | CEGUI::FrameWindowProperties::SizingEnabled | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::TitlebarEnabled Member List

This is the complete list of members for CEGUI::FrameWindowProperties::TitlebarEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::TitlebarEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::TitlebarEnabled | [virtual]
TitlebarEnabled() (defined in CEGUI::FrameWindowProperties::TitlebarEnabled) | CEGUI::FrameWindowProperties::TitlebarEnabled | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::FrameWindowProperties::TitlebarFont Member List

This is the complete list of members for CEGUI::FrameWindowProperties::TitlebarFont, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::FrameWindowProperties::TitlebarFont | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::FrameWindowProperties::TitlebarFont | [virtual]
TitlebarFont() (defined in CEGUI::FrameWindowProperties::TitlebarFont) | CEGUI::FrameWindowProperties::TitlebarFont | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::GenericException Member List

This is the complete list of members for CEGUI::GenericException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
GenericException(const String &message) (defined in CEGUI::GenericException) | CEGUI::GenericException | [inline]
getMessage(void) const | CEGUI::Exception | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::GlobalEventSet Member List

This is the complete list of members for CEGUI::GlobalEventSet, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_muted | CEGUI::EventSet | [protected]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::GlobalEventSet | [virtual]
getIterator(void) const | CEGUI::EventSet |
getSingleton(void) | CEGUI::GlobalEventSet | [static]
getSingletonPtr(void) | CEGUI::GlobalEventSet | [static]
GlobalEventSet() (defined in CEGUI::GlobalEventSet) | CEGUI::GlobalEventSet |
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
setMutedState(bool setting) | CEGUI::EventSet |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::GlobalEventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::GlobalEventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~GlobalEventSet() (defined in CEGUI::GlobalEventSet) | CEGUI::GlobalEventSet |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::GUILayout_xmlHandler Member List

This is the complete list of members for CEGUI::GUILayout_xmlHandler, including all inherited members.

cleanupLoadedWindows(void) | CEGUI::GUILayout_xmlHandler |
elementEnd(const String &element) (defined in CEGUI::GUILayout_xmlHandler) | CEGUI::GUILayout_xmlHandler | [virtual]
elementStart(const String &element, const XMLAttributes &attributes) | CEGUI::GUILayout_xmlHandler | [virtual]
getLayoutRootWindow(void) const | CEGUI::GUILayout_xmlHandler |
GUILayout_xmlHandler(const String &name_prefix, PropertyCallback *callback=NULL, void *userdata=NULL) | CEGUI::GUILayout_xmlHandler | [inline]
~GUILayout_xmlHandler(void) | CEGUI::GUILayout_xmlHandler | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::GUISheet Member List

This is the complete list of members for CEGUI::GUISheet, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::GUISheet | [inline, protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Window | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
GUISheet(const String &type, const String &name) | CEGUI::GUISheet | [inline]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::GUISheet | [inline, protected, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::GUISheet | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
WidgetTypeName | CEGUI::GUISheet | [static]
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~GUISheet(void) | CEGUI::GUISheet | [inline, virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::GUISheetFactory Member List

This is the complete list of members for CEGUI::GUISheetFactory, including all inherited members.

createWindow(const String &name) | CEGUI::GUISheetFactory | [inline, virtual]
d_type | CEGUI::WindowFactory | [protected]
destroyWindow(Window *window) | CEGUI::GUISheetFactory | [inline, virtual]
getTypeName(void) const | CEGUI::WindowFactory | [inline]
GUISheetFactory(void) (defined in CEGUI::GUISheetFactory) | CEGUI::GUISheetFactory | [inline]
WindowFactory(const String &type) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, protected]
~GUISheetFactory(void) (defined in CEGUI::GUISheetFactory) | CEGUI::GUISheetFactory | [inline]
~WindowFactory(void) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::HeaderSequenceEventArgs Member List

This is the complete list of members for CEGUI::HeaderSequenceEventArgs, including all inherited members.

d_newIdx | CEGUI::HeaderSequenceEventArgs |
d_oldIdx | CEGUI::HeaderSequenceEventArgs |
EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
HeaderSequenceEventArgs(Window *wnd, uint old_idx, uint new_idx) (defined in CEGUI::HeaderSequenceEventArgs) | CEGUI::HeaderSequenceEventArgs | [inline]
window | CEGUI::WindowEventArgs |
WindowEventArgs(Window *wnd) (defined in CEGUI::WindowEventArgs) | CEGUI::WindowEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Image Member List

This is the complete list of members for CEGUI::Image, including all inherited members.

draw(const Vector3 &position, const Size &size, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Image | [inline]
draw(const Rect &dest_rect, float z, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Image | [inline]
draw(const Vector3 &position, const Size &size, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Image | [inline]
draw(const Vector3 &position, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Image | [inline]
draw(const Vector3 &position, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Image | [inline]
draw(const Rect &dest_rect, float z, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Image |
getHeight(void) const | CEGUI::Image | [inline]
getImagesetName(void) const | CEGUI::Image |
getName(void) const | CEGUI::Image |
getOffsets(void) const | CEGUI::Image | [inline]
getOffsetX(void) const | CEGUI::Image | [inline]
getOffsetY(void) const | CEGUI::Image | [inline]
getSize(void) const | CEGUI::Image | [inline]
getSourceTextureArea(void) const | CEGUI::Image |
getWidth(void) const | CEGUI::Image | [inline]
Image(void) | CEGUI::Image | [inline]
Image(const Imageset *owner, const String &name, const Rect &area, const Point &render_offset, float horzScaling=1.0f, float vertScaling=1.0f) | CEGUI::Image |
Image(const Image &image) | CEGUI::Image |
Imageset (defined in CEGUI::Image) | CEGUI::Image | [friend]
std::map< String, Image > (defined in CEGUI::Image) | CEGUI::Image | [friend]
std::pair< const String, Image > (defined in CEGUI::Image) | CEGUI::Image | [friend]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Image |
~Image(void) | CEGUI::Image |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ImageDim Member List

This is the complete list of members for CEGUI::ImageDim, including all inherited members.

BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const | CEGUI::ImageDim | [protected, virtual]
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const | CEGUI::ImageDim | [protected, virtual]
getValue_impl(const Window &wnd, const Rect &container) const | CEGUI::ImageDim | [protected, virtual]
ImageDim(const String &imageset, const String &image, DimensionType dim) | CEGUI::ImageDim |
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
setSourceDimension(DimensionType dim) | CEGUI::ImageDim |
setSourceImage(const String &imageset, const String &image) | CEGUI::ImageDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const | CEGUI::ImageDim | [protected, virtual]
writeXMLElementName_impl(OutStream &out_stream) const | CEGUI::ImageDim | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ImageryComponent Member List

This is the complete list of members for CEGUI::ImageryComponent, including all inherited members.

d_area | CEGUI::FalagardComponentBase | [protected]
d_colourPropertyName | CEGUI::FalagardComponentBase | [protected]
d_colourProperyIsRect | CEGUI::FalagardComponentBase | [protected]
d_colours | CEGUI::FalagardComponentBase | [protected]
d_horzFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
d_horzFormatting | CEGUI::ImageryComponent | [protected]
d_image | CEGUI::ImageryComponent | [protected]
d_imagePropertyName | CEGUI::ImageryComponent | [protected]
d_vertFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
d_vertFormatting | CEGUI::ImageryComponent | [protected]
FalagardComponentBase() | CEGUI::FalagardComponentBase |
getColours() const | CEGUI::FalagardComponentBase |
getComponentArea() const | CEGUI::FalagardComponentBase |
getHorizontalFormatting() const | CEGUI::ImageryComponent |
getImage() const | CEGUI::ImageryComponent |
getImagePropertySource() const | CEGUI::ImageryComponent |
getVerticalFormatting() const | CEGUI::ImageryComponent |
ImageryComponent() | CEGUI::ImageryComponent |
initColoursRect(const Window &wnd, const ColourRect *modCols, ColourRect &cr) const | CEGUI::FalagardComponentBase | [protected]
isImageFetchedFromProperty() const | CEGUI::ImageryComponent |
render(Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render(Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render_impl(Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const | CEGUI::ImageryComponent | [protected, virtual]
setColours(const ColourRect &cols) | CEGUI::FalagardComponentBase |
setColoursPropertyIsColourRect(bool setting=true) | CEGUI::FalagardComponentBase |
setColoursPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setComponentArea(const ComponentArea &area) | CEGUI::FalagardComponentBase |
setHorizontalFormatting(HorizontalFormatting fmt) | CEGUI::ImageryComponent |
setHorzFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setImage(const Image *image) | CEGUI::ImageryComponent |
setImage(const String &imageset, const String &image) | CEGUI::ImageryComponent |
setImagePropertySource(const String &property) | CEGUI::ImageryComponent |
setVertFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setVerticalFormatting(VerticalFormatting fmt) | CEGUI::ImageryComponent |
writeColoursXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeHorzFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeVertFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeXMLToStream(OutStream &out_stream) const | CEGUI::ImageryComponent |
~FalagardComponentBase() | CEGUI::FalagardComponentBase | [virtual]

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ImagerySection Member List

This is the complete list of members for CEGUI::ImagerySection, including all inherited members.

addFrameComponent(const FrameComponent &frame) | CEGUI::ImagerySection |
addImageryComponent(const ImageryComponent &img) | CEGUI::ImagerySection |
addTextComponent(const TextComponent &text) | CEGUI::ImagerySection |
clearFrameComponents() | CEGUI::ImagerySection |
clearImageryComponents() | CEGUI::ImagerySection |
clearTextComponents() | CEGUI::ImagerySection |
getBoundingRect(const Window &wnd) const | CEGUI::ImagerySection |
getBoundingRect(const Window &wnd, const Rect &rect) const | CEGUI::ImagerySection |
getMasterColours() const | CEGUI::ImagerySection |
getName() const | CEGUI::ImagerySection |
ImagerySection() | CEGUI::ImagerySection |
ImagerySection(const String &name) | CEGUI::ImagerySection |
initMasterColourRect(const Window &wnd, ColourRect &cr) const | CEGUI::ImagerySection | [protected]
render(Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::ImagerySection |
render(Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::ImagerySection |
setMasterColours(const ColourRect &cols) | CEGUI::ImagerySection |
setMasterColoursPropertyIsColourRect(bool setting=true) | CEGUI::ImagerySection |
setMasterColoursPropertySource(const String &property) | CEGUI::ImagerySection |
writeXMLToStream(OutStream &out_stream) const | CEGUI::ImagerySection |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Imageset Member List

This is the complete list of members for CEGUI::Imageset, including all inherited members.

d_autoScale | CEGUI::Imageset | [protected]
d_horzScaling | CEGUI::Imageset | [protected]
d_images | CEGUI::Imageset | [protected]
d_name | CEGUI::Imageset | [protected]
d_nativeHorzRes | CEGUI::Imageset | [protected]
d_nativeVertRes | CEGUI::Imageset | [protected]
d_texture | CEGUI::Imageset | [protected]
d_textureFilename | CEGUI::Imageset | [protected]
d_vertScaling | CEGUI::Imageset | [protected]
defineImage(const String &name, const Point &position, const Size &size, const Point &render_offset) | CEGUI::Imageset | [inline]
defineImage(const String &name, const Rect &image_rect, const Point &render_offset) | CEGUI::Imageset |
draw(const Rect &source_rect, const Rect &dest_rect, float z, const Rect &clip_rect, const ColourRect &colours, QuadSplitMode quad_split_mode) const | CEGUI::Imageset |
draw(const Rect &source_rect, const Rect &dest_rect, float z, const Rect &clip_rect, const colour &top_left_colour=0xFFFFFFFF, const colour &top_right_colour=0xFFFFFFFF, const colour &bottom_left_colour=0xFFFFFFFF, const colour &bottom_right_colour=0xFFFFFFFF, QuadSplitMode quad_split_mode=TopLeftToBottomRight) const | CEGUI::Imageset | [inline]
getImage(const String &name) const | CEGUI::Imageset |
getImageCount(void) const | CEGUI::Imageset | [inline]
getImageHeight(const String &name) const | CEGUI::Imageset | [inline]
getImageOffset(const String &name) const | CEGUI::Imageset | [inline]
getImageOffsetX(const String &name) const | CEGUI::Imageset | [inline]
getImageOffsetY(const String &name) const | CEGUI::Imageset | [inline]
getImageSize(const String &name) const | CEGUI::Imageset | [inline]
getImageWidth(const String &name) const | CEGUI::Imageset | [inline]
getIterator(void) const | CEGUI::Imageset |
getName(void) const | CEGUI::Imageset | [inline]
getNativeResolution(void) const | CEGUI::Imageset | [inline]
getTexture(void) const | CEGUI::Imageset | [inline]
ImageIterator typedef | CEGUI::Imageset |
Imageset_xmlHandler (defined in CEGUI::Imageset) | CEGUI::Imageset | [friend]
ImagesetManager::createImageset (defined in CEGUI::Imageset) | CEGUI::Imageset | [friend]
ImagesetManager::createImageset (defined in CEGUI::Imageset) | CEGUI::Imageset | [friend]
ImagesetManager::createImagesetFromImageFile (defined in CEGUI::Imageset) | CEGUI::Imageset | [friend]
ImagesetManager::destroyImageset (defined in CEGUI::Imageset) | CEGUI::Imageset | [friend]
ImagesetSchemaName | CEGUI::Imageset | [protected, static]
isAutoScaled(void) const | CEGUI::Imageset | [inline]
isImageDefined(const String &name) const | CEGUI::Imageset | [inline]
load(const String &filename, const String &resourceGroup) | CEGUI::Imageset | [protected]
notifyScreenResolution(const Size &size) | CEGUI::Imageset |
setAutoScalingEnabled(bool setting) | CEGUI::Imageset |
setNativeResolution(const Size &size) | CEGUI::Imageset |
setTexture(Texture *texture) | CEGUI::Imageset | [protected]
undefineAllImages(void) | CEGUI::Imageset |
undefineImage(const String &name) | CEGUI::Imageset |
unload(void) | CEGUI::Imageset | [protected]
updateImageScalingFactors(void) | CEGUI::Imageset | [protected]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Imageset |
~Imageset(void) | CEGUI::Imageset |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Imageset_xmlHandler Member List

This is the complete list of members for CEGUI::Imageset_xmlHandler, including all inherited members.

elementEnd(const String &element) (defined in CEGUI::Imageset_xmlHandler) | CEGUI::Imageset_xmlHandler | [virtual]
elementStart(const String &element, const XMLAttributes &attributes) | CEGUI::Imageset_xmlHandler | [virtual]
getImageset(void) const (defined in CEGUI::Imageset_xmlHandler) | CEGUI::Imageset_xmlHandler | [inline]
Imageset_xmlHandler(Imageset *imageset) | CEGUI::Imageset_xmlHandler | [inline]
~Imageset_xmlHandler(void) | CEGUI::Imageset_xmlHandler | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ImagesetManager Member List

This is the complete list of members for CEGUI::ImagesetManager, including all inherited members.

createImageset(const String &name, Texture *texture) | CEGUI::ImagesetManager |
createImageset(const String &filename, const String &resourceGroup="") | CEGUI::ImagesetManager |
createImagesetFromImageFile(const String &name, const String &filename, const String &resourceGroup="") | CEGUI::ImagesetManager |
destroyAllImagesets(void) | CEGUI::ImagesetManager |
destroyImageset(const String &name) | CEGUI::ImagesetManager |
destroyImageset(Imageset *imageset) | CEGUI::ImagesetManager |
getImageset(const String &name) const | CEGUI::ImagesetManager |
getIterator(void) const | CEGUI::ImagesetManager |
getSingleton(void) | CEGUI::ImagesetManager | [static]
getSingletonPtr(void) | CEGUI::ImagesetManager | [static]
ImagesetIterator typedef (defined in CEGUI::ImagesetManager) | CEGUI::ImagesetManager |
ImagesetManager(void) | CEGUI::ImagesetManager |
isImagesetPresent(const String &name) const | CEGUI::ImagesetManager | [inline]
notifyScreenResolution(const Size &size) | CEGUI::ImagesetManager |
writeImagesetToStream(const String &imageset, OutStream &out_stream) const | CEGUI::ImagesetManager |
~ImagesetManager(void) | CEGUI::ImagesetManager |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::InvalidRequestException Member List

This is the complete list of members for CEGUI::InvalidRequestException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
InvalidRequestException(const String &message) (defined in CEGUI::InvalidRequestException) | CEGUI::InvalidRequestException | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::IrrlichtRenderer Member List

This is the complete list of members for CEGUI::IrrlichtRenderer, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
addQuad(const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode) | CEGUI::IrrlichtRenderer | [virtual]
advanceZValue(void) | CEGUI::Renderer | [inline]
clearRenderList(void) | CEGUI::IrrlichtRenderer | [virtual]
createResourceProvider(void) | CEGUI::IrrlichtRenderer | [virtual]
createTexture(void) | CEGUI::IrrlichtRenderer | [virtual]
createTexture(const String &filename, const String &resourceGroup) | CEGUI::IrrlichtRenderer | [virtual]
createTexture(float size) | CEGUI::IrrlichtRenderer | [virtual]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_identifierString | CEGUI::Renderer | [protected]
d_muted | CEGUI::EventSet | [protected]
d_resourceProvider | CEGUI::Renderer | [protected]
destroyAllTextures(void) | CEGUI::IrrlichtRenderer | [virtual]
destroyTexture(Texture *texture) | CEGUI::IrrlichtRenderer | [virtual]
doRender(void) | CEGUI::IrrlichtRenderer | [virtual]
EventDisplaySizeChanged | CEGUI::Renderer | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventNamespace | CEGUI::Renderer | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getCurrentZ(void) const | CEGUI::Renderer | [inline]
getHeight(void) const | CEGUI::IrrlichtRenderer | [virtual]
getHorzScreenDPI(void) const | CEGUI::IrrlichtRenderer | [virtual]
getIdentifierString() const | CEGUI::Renderer |
getIterator(void) const | CEGUI::EventSet |
getMaxTextureSize(void) const | CEGUI::IrrlichtRenderer | [virtual]
getRect(void) const | CEGUI::IrrlichtRenderer | [virtual]
getSize(void) const | CEGUI::IrrlichtRenderer | [virtual]
getVertScreenDPI(void) const | CEGUI::IrrlichtRenderer | [virtual]
getWidth(void) const | CEGUI::IrrlichtRenderer | [virtual]
getZLayer(uint layer) const | CEGUI::Renderer | [inline]
IrrlichtRenderer(irr::IrrlichtDevice *dev, bool bWithIrrlichtResourceProvicer=false) | CEGUI::IrrlichtRenderer |
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isQueueingEnabled(void) const | CEGUI::IrrlichtRenderer | [virtual]
OnEvent(irr::SEvent &event) | CEGUI::IrrlichtRenderer |
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [protected]
resetZValue(void) | CEGUI::Renderer | [inline]
setMutedState(bool setting) | CEGUI::EventSet |
setQueueingEnabled(bool setting) | CEGUI::IrrlichtRenderer | [virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~IrrlichtRenderer() | CEGUI::IrrlichtRenderer | [virtual]
~Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ItemEntry Member List

This is the complete list of members for CEGUI::ItemEntry, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItemEntryEvents(void) | CEGUI::ItemEntry | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Window | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemPixelSize(void)=0 | CEGUI::ItemEntry | [pure virtual]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntry(const String &type, const String &name) | CEGUI::ItemEntry |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
populateRenderCahce() | CEGUI::ItemEntry | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ItemEntry | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemEntry(void) | CEGUI::ItemEntry | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ItemListBase Member List

This is the complete list of members for CEGUI::ItemListBase, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItem(ItemEntry *item) | CEGUI::ItemListBase |
addItemListBaseEvents(void) | CEGUI::ItemListBase | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoResize (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_listItems | CEGUI::ItemListBase | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::ItemListBase | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::ItemListBase | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ItemEntry *start_item) | CEGUI::ItemListBase |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getContentSize()=0 | CEGUI::ItemListBase | [protected, pure virtual]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemCount(void) const | CEGUI::ItemListBase | [inline]
getItemFromIndex(size_t index) const | CEGUI::ItemListBase |
getItemIndex(const ItemEntry *item) const | CEGUI::ItemListBase |
getItemRenderArea(void) const =0 | CEGUI::ItemListBase | [protected, pure virtual]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleUpdatedItemData(void) | CEGUI::ItemListBase |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::ItemListBase | [virtual]
insertItem(ItemEntry *item, const ItemEntry *position) | CEGUI::ItemListBase |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isAutoResizeEnabled() const | CEGUI::ItemListBase | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isItemInList(const ItemEntry *item) const | CEGUI::ItemListBase |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntryList typedef (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
ItemListBase(const String &type, const String &name) | CEGUI::ItemListBase |
layoutItemWidgets()=0 | CEGUI::ItemListBase | [protected, pure virtual]
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache()=0 | CEGUI::ItemListBase | [protected, pure virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(ItemEntry *item) | CEGUI::ItemListBase |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::ItemListBase |
resetList_impl(void) | CEGUI::ItemListBase | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setAutoResizeEnabled(bool setting) | CEGUI::ItemListBase |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
sizeToContent(void) | CEGUI::ItemListBase | [inline, virtual]
sizeToContent_impl(void)=0 | CEGUI::ItemListBase | [protected, pure virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ItemListBase | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemListBase(void) | CEGUI::ItemListBase | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:04 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ItemListBaseProperties::AutoResizeEnabled Member List

This is the complete list of members for CEGUI::ItemListBaseProperties::AutoResizeEnabled, including all inherited members.

AutoResizeEnabled() (defined in CEGUI::ItemListBaseProperties::AutoResizeEnabled) | CEGUI::ItemListBaseProperties::AutoResizeEnabled | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ItemListBaseProperties::AutoResizeEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ItemListBaseProperties::AutoResizeEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::KeyEventArgs Member List

This is the complete list of members for CEGUI::KeyEventArgs, including all inherited members.

codepoint | CEGUI::KeyEventArgs |
EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
KeyEventArgs(Window *wnd) (defined in CEGUI::KeyEventArgs) | CEGUI::KeyEventArgs | [inline]
scancode | CEGUI::KeyEventArgs |
sysKeys | CEGUI::KeyEventArgs |
window | CEGUI::WindowEventArgs |
WindowEventArgs(Window *wnd) (defined in CEGUI::WindowEventArgs) | CEGUI::WindowEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::LayerSpecification Member List

This is the complete list of members for CEGUI::LayerSpecification, including all inherited members.

addSectionSpecification(const SectionSpecification &section) | CEGUI::LayerSpecification
clearSectionSpecifications() | CEGUI::LayerSpecification
getLayerPriority() const | CEGUI::LayerSpecification
LayerSpecification(uint priority) | CEGUI::LayerSpecification
operator<(const LayerSpecification &other) const (defined in CEGUI::LayerSpecification) | CEGUI::LayerSpecification
render(Window &srcWindow, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::LayerSpecification
render(Window &srcWindow, const Rect &baseRect, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::LayerSpecification
writeXMLToStream(OutStream &out_stream) const | CEGUI::LayerSpecification

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Listbox Member List

This is the complete list of members for CEGUI::Listbox, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItem(ListboxItem *item) | CEGUI::Listbox |
addListboxEvents(void) | CEGUI::Listbox | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
cacheListboxBaseImagery()=0 | CEGUI::Listbox | [protected, pure virtual]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearAllSelections(void) | CEGUI::Listbox |
clearAllSelections_impl(void) | CEGUI::Listbox | [protected]
clearProperties(void) | CEGUI::PropertySet |
configureScrollbars(void) | CEGUI::Listbox | [protected]
createHorzScrollbar(const String &name) const =0 | CEGUI::Listbox | [protected, pure virtual]
createVertScrollbar(const String &name) const =0 | CEGUI::Listbox | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_forceHorzScroll | CEGUI::Listbox | [protected]
d_forceVertScroll | CEGUI::Listbox | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzScrollbar | CEGUI::Listbox | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_itemTooltips | CEGUI::Listbox | [protected]
d_lastSelected | CEGUI::Listbox | [protected]
d_listItems | CEGUI::Listbox | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_multiselect | CEGUI::Listbox | [protected]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sorted | CEGUI::Listbox | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertScrollbar | CEGUI::Listbox | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
ensureItemIsVisible(size_t item_index) | CEGUI::Listbox |
ensureItemIsVisible(const ListboxItem *item) | CEGUI::Listbox |
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHorzScrollbarModeChanged | CEGUI::Listbox | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::Listbox | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventMultiselectModeChanged | CEGUI::Listbox | [static]
EventNamespace | CEGUI::Listbox | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSelectionChanged | CEGUI::Listbox | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventSortModeChanged | CEGUI::Listbox | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventVertScrollbarModeChanged | CEGUI::Listbox | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ListboxItem *start_item) | CEGUI::Listbox |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFirstSelectedItem(void) const | CEGUI::Listbox |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemAtPoint(const Point &pt) const | CEGUI::Listbox | [protected]
getItemCount(void) const | CEGUI::Listbox | [inline]
getItemIndex(const ListboxItem *item) const | CEGUI::Listbox |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getListboxItemFromIndex(size_t index) const | CEGUI::Listbox |
getListRenderArea(void) const =0 | CEGUI::Listbox | [protected, pure virtual]
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNextSelected(const ListboxItem *start_item) const | CEGUI::Listbox |
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedCount(void) const | CEGUI::Listbox |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getTotalItemsHeight(void) const | CEGUI::Listbox | [protected]
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidestItemWidth(void) const | CEGUI::Listbox | [protected]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handle_scrollChange(const EventArgs &args) | CEGUI::Listbox | [protected]
handleUpdatedItemData(void) | CEGUI::Listbox |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Listbox | [virtual]
insertItem(ListboxItem *item, const ListboxItem *position) | CEGUI::Listbox |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHorzScrollbarAlwaysShown(void) const | CEGUI::Listbox |
isItemSelected(size_t index) const | CEGUI::Listbox |
isItemTooltipsEnabled(void) const (defined in CEGUI::Listbox) | CEGUI::Listbox | [inline]
isListboxItemInList(const ListboxItem *item) const | CEGUI::Listbox |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMultiselectEnabled(void) const | CEGUI::Listbox | [inline]
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSortEnabled(void) const | CEGUI::Listbox | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVertScrollbarAlwaysShown(void) const | CEGUI::Listbox |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
LBItemList typedef (defined in CEGUI::Listbox) | CEGUI::Listbox | [protected]
Listbox(const String &type, const String &name) | CEGUI::Listbox |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorzScrollbarModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMultiselectModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSelectionChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onSortModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVertScrollbarModeChanged(WindowEventArgs &e) | CEGUI::Listbox | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Listbox | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(const ListboxItem *item) | CEGUI::Listbox |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::Listbox |
resetList_impl(void) | CEGUI::Listbox | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
selectRange(size_t start, size_t end) | CEGUI::Listbox | [protected]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItemSelectState(ListboxItem *item, bool state) | CEGUI::Listbox |
setItemSelectState(size_t item_index, bool state) | CEGUI::Listbox |
setItemTooltipsEnabled(bool setting) (defined in CEGUI::Listbox) | CEGUI::Listbox |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMultiselectEnabled(bool setting) | CEGUI::Listbox |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setShowHorzScrollbar(bool setting) | CEGUI::Listbox |
setShowVertScrollbar(bool setting) | CEGUI::Listbox |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSortingEnabled(bool setting) | CEGUI::Listbox |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Listbox | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~Listbox(void) | CEGUI::Listbox | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxItem Member List

This is the complete list of members for CEGUI::ListboxItem, including all inherited members.

calculateModulatedAlphaColour(colour col, float alpha) const | CEGUI::ListboxItem | [protected]
d_autoDelete | CEGUI::ListboxItem | [protected]
d_disabled | CEGUI::ListboxItem | [protected]
d_itemData | CEGUI::ListboxItem | [protected]
d_itemID | CEGUI::ListboxItem | [protected]
d_itemText | CEGUI::ListboxItem | [protected]
d_owner | CEGUI::ListboxItem | [protected]
d_selectBrush | CEGUI::ListboxItem | [protected]
d_selectCols | CEGUI::ListboxItem | [protected]
d_selected | CEGUI::ListboxItem | [protected]
d_tooltipText | CEGUI::ListboxItem | [protected]
DefaultSelectionColour | CEGUI::ListboxItem | [static]
draw(const Vector3 &position, float alpha, const Rect &clipper) const =0 | CEGUI::ListboxItem | [pure virtual]
draw(RenderCache &cache, const Rect &targetRect, float zBase, float alpha, const Rect *clipper) const =0 (defined in CEGUI::ListboxItem) | CEGUI::ListboxItem | [pure virtual]
getID(void) const | CEGUI::ListboxItem | [inline]
getModulateAlphaColourRect(const ColourRect &cols, float alpha) const | CEGUI::ListboxItem | [protected]
getOwnerWindow(const Window *owner) | CEGUI::ListboxItem | [inline]
getPixelSize(void) const =0 | CEGUI::ListboxItem | [pure virtual]
getSelectionBrushImage(void) const | CEGUI::ListboxItem | [inline]
getSelectionColours(void) const | CEGUI::ListboxItem | [inline]
getText(void) const | CEGUI::ListboxItem | [inline]
getTooltipText(void) const (defined in CEGUI::ListboxItem) | CEGUI::ListboxItem | [inline]
getUserData(void) const | CEGUI::ListboxItem | [inline]
isAutoDeleted(void) const | CEGUI::ListboxItem | [inline]
isDisabled(void) const | CEGUI::ListboxItem | [inline]
isSelected(void) const | CEGUI::ListboxItem | [inline]
ListboxItem(const String &text, uint item_id=0, void *item_data=NULL, bool disabled=false, bool auto_delete=true) | CEGUI::ListboxItem |
operator<(const ListboxItem &rhs) const | CEGUI::ListboxItem | [inline, virtual]
operator>(const ListboxItem &rhs) const | CEGUI::ListboxItem | [inline, virtual]
setAutoDeleted(bool setting) | CEGUI::ListboxItem | [inline]
setDisabled(bool setting) | CEGUI::ListboxItem | [inline]
setID(uint item_id) | CEGUI::ListboxItem | [inline]
setOwnerWindow(const Window *owner) | CEGUI::ListboxItem | [inline]
setSelected(bool setting) | CEGUI::ListboxItem | [inline]
setSelectionBrushImage(const Image *image) | CEGUI::ListboxItem | [inline]
setSelectionBrushImage(const String &imageset, const String &image) | CEGUI::ListboxItem |
setSelectionColours(const ColourRect &cols) | CEGUI::ListboxItem | [inline]
setSelectionColours(colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour) | CEGUI::ListboxItem |
setSelectionColours(colour col) | CEGUI::ListboxItem | [inline]
setText(const String &text) | CEGUI::ListboxItem | [inline]
setTooltipText(const String &text) (defined in CEGUI::ListboxItem) | CEGUI::ListboxItem | [inline]
setUserData(void *item_data) | CEGUI::ListboxItem | [inline]
~ListboxItem(void) | CEGUI::ListboxItem | [inline, virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxProperties::ForceHorzScrollbar Member List

This is the complete list of members for CEGUI::ListboxProperties::ForceHorzScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceHorzScrollbar() (defined in CEGUI::ListboxProperties::ForceHorzScrollbar) | CEGUI::ListboxProperties::ForceHorzScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ListboxProperties::ForceHorzScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListboxProperties::ForceHorzScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxProperties::ForceVertScrollbar Member List

This is the complete list of members for CEGUI::ListboxProperties::ForceVertScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceVertScrollbar() (defined in CEGUI::ListboxProperties::ForceVertScrollbar) | CEGUI::ListboxProperties::ForceVertScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ListboxProperties::ForceVertScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListboxProperties::ForceVertScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxProperties::ItemTooltips Member List

This is the complete list of members for CEGUI::ListboxProperties::ItemTooltips, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListboxProperties::ItemTooltips | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
ItemTooltips() (defined in CEGUI::ListboxProperties::ItemTooltips) | CEGUI::ListboxProperties::ItemTooltips | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListboxProperties::ItemTooltips | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxProperties::MultiSelect Member List

This is the complete list of members for CEGUI::ListboxProperties::MultiSelect, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListboxProperties::MultiSelect | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MultiSelect() (defined in CEGUI::ListboxProperties::MultiSelect) | CEGUI::ListboxProperties::MultiSelect | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListboxProperties::MultiSelect | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxProperties::Sort Member List

This is the complete list of members for CEGUI::ListboxProperties::Sort, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListboxProperties::Sort | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListboxProperties::Sort | [virtual]
Sort() (defined in CEGUI::ListboxProperties::Sort) | CEGUI::ListboxProperties::Sort | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListboxTextItem Member List

This is the complete list of members for CEGUI::ListboxTextItem, including all inherited members.

calculateModulatedAlphaColour(colour col, float alpha) const | CEGUI::ListboxItem | [protected]
d_autoDelete | CEGUI::ListboxItem | [protected]
d_disabled | CEGUI::ListboxItem | [protected]
d_font | CEGUI::ListboxTextItem | [protected]
d_itemData | CEGUI::ListboxItem | [protected]
d_itemID | CEGUI::ListboxItem | [protected]
d_itemText | CEGUI::ListboxItem | [protected]
d_owner | CEGUI::ListboxItem | [protected]
d_selectBrush | CEGUI::ListboxItem | [protected]
d_selectCols | CEGUI::ListboxItem | [protected]
d_selected | CEGUI::ListboxItem | [protected]
d_textCols | CEGUI::ListboxTextItem | [protected]
d_tooltipText | CEGUI::ListboxItem | [protected]
DefaultSelectionColour | CEGUI::ListboxItem | [static]
DefaultTextColour | CEGUI::ListboxTextItem | [static]
draw(const Vector3 &position, float alpha, const Rect &clipper) const | CEGUI::ListboxTextItem | [virtual]
draw(RenderCache &cache, const Rect &targetRect, float zBase, float alpha, const Rect *clipper) const (defined in CEGUI::ListboxTextItem) | CEGUI::ListboxTextItem | [virtual]
getFont(void) const | CEGUI::ListboxTextItem |
getID(void) const | CEGUI::ListboxItem | [inline]
getModulateAlphaColourRect(const ColourRect &cols, float alpha) const | CEGUI::ListboxItem | [protected]
getOwnerWindow(const Window *owner) | CEGUI::ListboxItem | [inline]
getPixelSize(void) const | CEGUI::ListboxTextItem | [virtual]
getSelectionBrushImage(void) const | CEGUI::ListboxItem | [inline]
getSelectionColours(void) const | CEGUI::ListboxItem | [inline]
getText(void) const | CEGUI::ListboxItem | [inline]
getTextColours(void) const | CEGUI::ListboxTextItem | [inline]
getTooltipText(void) const (defined in CEGUI::ListboxItem) | CEGUI::ListboxItem | [inline]
getUserData(void) const | CEGUI::ListboxItem | [inline]
isAutoDeleted(void) const | CEGUI::ListboxItem | [inline]
isDisabled(void) const | CEGUI::ListboxItem | [inline]
isSelected(void) const | CEGUI::ListboxItem | [inline]
ListboxItem(const String &text, uint item_id=0, void *item_data=NULL, bool disabled=false, bool auto_delete=true) | CEGUI::ListboxItem |
ListboxTextItem(const String &text, uint item_id=0, void *item_data=NULL, bool disabled=false, bool auto_delete=true) | CEGUI::ListboxTextItem |
operator<(const ListboxItem &rhs) const | CEGUI::ListboxItem | [inline, virtual]
operator>(const ListboxItem &rhs) const | CEGUI::ListboxItem | [inline, virtual]
setAutoDeleted(bool setting) | CEGUI::ListboxItem | [inline]
setDisabled(bool setting) | CEGUI::ListboxItem | [inline]
setFont(const Font *font) | CEGUI::ListboxTextItem | [inline]
setFont(const String &font_name) | CEGUI::ListboxTextItem |
setID(uint item_id) | CEGUI::ListboxItem | [inline]
setOwnerWindow(const Window *owner) | CEGUI::ListboxItem | [inline]
setSelected(bool setting) | CEGUI::ListboxItem | [inline]
setSelectionBrushImage(const Image *image) | CEGUI::ListboxItem | [inline]
setSelectionBrushImage(const String &imageset, const String &image) | CEGUI::ListboxItem |
setSelectionColours(const ColourRect &cols) | CEGUI::ListboxItem | [inline]
setSelectionColours(colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour) | CEGUI::ListboxItem |
setSelectionColours(colour col) | CEGUI::ListboxItem | [inline]
setText(const String &text) | CEGUI::ListboxItem | [inline]
setTextColours(const ColourRect &cols) | CEGUI::ListboxTextItem | [inline]
setTextColours(colour top_left_colour, colour top_right_colour, colour bottom_left_colour, colour bottom_right_colour) | CEGUI::ListboxTextItem |
setTextColours(colour col) | CEGUI::ListboxTextItem | [inline]
setTooltipText(const String &text) (defined in CEGUI::ListboxItem) | CEGUI::ListboxItem | [inline]
setUserData(void *item_data) | CEGUI::ListboxItem | [inline]
~ListboxItem(void) | CEGUI::ListboxItem | [inline, virtual]
~ListboxTextItem(void) | CEGUI::ListboxTextItem | [inline, virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeader Member List

This is the complete list of members for CEGUI::ListHeader, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addColumn(const String &text, uint id, float width) | CEGUI::ListHeader |
addEvent(const String &name) | CEGUI::EventSet |
addListHeaderEvents(void) | CEGUI::ListHeader | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
createInitialisedSegment(const String &text, uint id, float width) | CEGUI::ListHeader | [protected]
createNewSegment(const String &name) const =0 | CEGUI::ListHeader | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_movingEnabled | CEGUI::ListHeader | [protected]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_segmentOffset | CEGUI::ListHeader | [protected]
d_segments | CEGUI::ListHeader | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizingEnabled | CEGUI::ListHeader | [protected]
d_sortDir | CEGUI::ListHeader | [protected]
d_sortingEnabled | CEGUI::ListHeader | [protected]
d_sortSegment | CEGUI::ListHeader | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_uniqueIDNumber | CEGUI::ListHeader | [protected]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
destroyListSegment(ListHeaderSegment *segment) const =0 | CEGUI::ListHeader | [protected, pure virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventDragMoveSettingChanged | CEGUI::ListHeader | [static]
EventDragSizeSettingChanged | CEGUI::ListHeader | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::ListHeader | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSegmentAdded | CEGUI::ListHeader | [static]
EventSegmentClicked | CEGUI::ListHeader | [static]
EventSegmentRemoved | CEGUI::ListHeader | [static]
EventSegmentRenderOffsetChanged | CEGUI::ListHeader | [static]
EventSegmentSequenceChanged | CEGUI::ListHeader | [static]
EventSegmentSized | CEGUI::ListHeader | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventSortColumnChanged | CEGUI::ListHeader | [static]
EventSortDirectionChanged | CEGUI::ListHeader | [static]
EventSortSettingChanged | CEGUI::ListHeader | [static]
EventSplitterDoubleClicked | CEGUI::ListHeader | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getColumnCount(void) const | CEGUI::ListHeader |
getColumnFromID(uint id) const | CEGUI::ListHeader |
getColumnFromSegment(const ListHeaderSegment &segment) const | CEGUI::ListHeader |
getColumnPixelWidth(uint column) const | CEGUI::ListHeader |
getColumnWithText(const String &text) const | CEGUI::ListHeader |
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelOffsetToColumn(uint column) const | CEGUI::ListHeader |
getPixelOffsetToSegment(const ListHeaderSegment &segment) const | CEGUI::ListHeader |
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSegmentFromColumn(uint column) const | CEGUI::ListHeader |
getSegmentFromID(uint id) const | CEGUI::ListHeader |
getSegmentOffset(void) const | CEGUI::ListHeader | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getSortColumn(void) const | CEGUI::ListHeader |
getSortDirection(void) const | CEGUI::ListHeader |
getSortSegment(void) const | CEGUI::ListHeader |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getTotalSegmentsPixelExtent(void) const | CEGUI::ListHeader |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
insertColumn(const String &text, uint id, float width, uint position) | CEGUI::ListHeader |
insertColumn(const String &text, uint id, float width, const ListHeaderSegment &position) | CEGUI::ListHeader |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isColumnDraggingEnabled(void) const | CEGUI::ListHeader |
isColumnSizingEnabled(void) const | CEGUI::ListHeader |
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSortingEnabled(void) const | CEGUI::ListHeader |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
layoutSegments(void) | CEGUI::ListHeader | [protected]
ListHeader(const String &type, const String &name) | CEGUI::ListHeader |
MinimumSegmentPixelWidth | CEGUI::ListHeader | [static]
moveColumn(uint column, uint position) | CEGUI::ListHeader |
moveColumn(uint column, const ListHeaderSegment &position) | CEGUI::ListHeader |
moveSegment(const ListHeaderSegment &segment, uint position) | CEGUI::ListHeader |
moveSegment(const ListHeaderSegment &segment, const ListHeaderSegment &position) | CEGUI::ListHeader |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragMoveSettingChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onDragSizeSettingChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSegmentAdded(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSegmentClicked(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSegmentOffsetChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSegmentRemoved(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSegmentSequenceChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSegmentSized(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSortColumnChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSortDirectionChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSortSettingChanged(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onSplitterDoubleClicked(WindowEventArgs &e) | CEGUI::ListHeader | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeColumn(uint column) | CEGUI::ListHeader |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeSegment(const ListHeaderSegment &segment) | CEGUI::ListHeader |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
ScrollSpeed | CEGUI::ListHeader | [static]
segmentClickedHandler(const EventArgs &e) (defined in CEGUI::ListHeader) | CEGUI::ListHeader | [protected]
segmentDoubleClickHandler(const EventArgs &e) (defined in CEGUI::ListHeader) | CEGUI::ListHeader | [protected]
segmentDragHandler(const EventArgs &e) (defined in CEGUI::ListHeader) | CEGUI::ListHeader | [protected]
SegmentList typedef (defined in CEGUI::ListHeader) | CEGUI::ListHeader | [protected]
segmentMovedHandler(const EventArgs &e) (defined in CEGUI::ListHeader) | CEGUI::ListHeader | [protected]
segmentSizedHandler(const EventArgs &e) (defined in CEGUI::ListHeader) | CEGUI::ListHeader | [protected]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setColumnDraggingEnabled(bool setting) | CEGUI::ListHeader |
setColumnPixelWidth(uint column, float width) | CEGUI::ListHeader |
setColumnSizingEnabled(bool setting) | CEGUI::ListHeader |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSegmentOffset(float offset) | CEGUI::ListHeader |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSortColumn(uint column) | CEGUI::ListHeader |
setSortColumnFromID(uint id) | CEGUI::ListHeader |
setSortDirection(ListHeaderSegment::SortDirection direction) | CEGUI::ListHeader |
setSortingEnabled(bool setting) | CEGUI::ListHeader |
setSortSegment(const ListHeaderSegment &segment) | CEGUI::ListHeader |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ListHeader | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ListHeader(void) | CEGUI::ListHeader | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderProperties::ColumnsMovable Member List

This is the complete list of members for CEGUI::ListHeaderProperties::ColumnsMovable, including all inherited members.

ColumnsMovable() (defined in CEGUI::ListHeaderProperties::ColumnsMovable) | CEGUI::ListHeaderProperties::ColumnsMovable | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderProperties::ColumnsMovable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderProperties::ColumnsMovable | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderProperties::ColumnsSizable Member List

This is the complete list of members for CEGUI::ListHeaderProperties::ColumnsSizable, including all inherited members.

ColumnsSizable() (defined in CEGUI::ListHeaderProperties::ColumnsSizable) | CEGUI::ListHeaderProperties::ColumnsSizable | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderProperties::ColumnsSizable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderProperties::ColumnsSizable | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderProperties::SortColumnID Member List

This is the complete list of members for CEGUI::ListHeaderProperties::SortColumnID, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderProperties::SortColumnID | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderProperties::SortColumnID | [virtual]
SortColumnID() (defined in CEGUI::ListHeaderProperties::SortColumnID) | CEGUI::ListHeaderProperties::SortColumnID | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderProperties::SortDirection Member List

This is the complete list of members for CEGUI::ListHeaderProperties::SortDirection, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderProperties::SortDirection | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderProperties::SortDirection | [virtual]
SortDirection() (defined in CEGUI::ListHeaderProperties::SortDirection) | CEGUI::ListHeaderProperties::SortDirection | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderProperties::SortSettingEnabled Member List

This is the complete list of members for CEGUI::ListHeaderProperties::SortSettingEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderProperties::SortSettingEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderProperties::SortSettingEnabled | [virtual]
SortSettingEnabled() (defined in CEGUI::ListHeaderProperties::SortSettingEnabled) | CEGUI::ListHeaderProperties::SortSettingEnabled | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderSegment Member List

This is the complete list of members for CEGUI::ListHeaderSegment, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addHeaderSegmentEvents(void) | CEGUI::ListHeaderSegment | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
Ascending enum value | CEGUI::ListHeaderSegment |
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_allowClicks | CEGUI::ListHeaderSegment | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragMoving | CEGUI::ListHeaderSegment | [protected]
d_dragPoint | CEGUI::ListHeaderSegment | [protected]
d_dragPosition | CEGUI::ListHeaderSegment | [protected]
d_dragSizing | CEGUI::ListHeaderSegment | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_movingEnabled | CEGUI::ListHeaderSegment | [protected]
d_movingMouseCursor | CEGUI::ListHeaderSegment | [protected]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_segmentHover | CEGUI::ListHeaderSegment | [protected]
d_segmentPushed | CEGUI::ListHeaderSegment | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizingEnabled | CEGUI::ListHeaderSegment | [protected]
d_sizingMouseCursor | CEGUI::ListHeaderSegment | [protected]
d_sortDir | CEGUI::ListHeaderSegment | [protected]
d_splitterHover | CEGUI::ListHeaderSegment | [protected]
d_splitterSize | CEGUI::ListHeaderSegment | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultSizingArea | CEGUI::ListHeaderSegment | [static]
Descending enum value | CEGUI::ListHeaderSegment |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doDragMoving(const Point &local_mouse) | CEGUI::ListHeaderSegment | [protected]
doDragSizing(const Point &local_mouse) | CEGUI::ListHeaderSegment | [protected]
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClickableSettingChanged | CEGUI::ListHeaderSegment | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMovableSettingChanged | CEGUI::ListHeaderSegment | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::ListHeaderSegment | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSegmentClicked | CEGUI::ListHeaderSegment | [static]
EventSegmentDragPositionChanged | CEGUI::ListHeaderSegment | [static]
EventSegmentDragStart | CEGUI::ListHeaderSegment | [static]
EventSegmentDragStop | CEGUI::ListHeaderSegment | [static]
EventSegmentSized | CEGUI::ListHeaderSegment | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventSizingSettingChanged | CEGUI::ListHeaderSegment | [static]
EventSortDirectionChanged | CEGUI::ListHeaderSegment | [static]
EventSplitterDoubleClicked | CEGUI::ListHeaderSegment | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDragMoveOffset(void) const | CEGUI::ListHeaderSegment | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getSortDirection(void) const | CEGUI::ListHeaderSegment | [inline]
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initDragMoving(void) | CEGUI::ListHeaderSegment | [protected]
initialise(void) | CEGUI::Window | [inline, virtual]
initSegmentHoverState(void) | CEGUI::ListHeaderSegment | [protected]
initSizingHoverState(void) | CEGUI::ListHeaderSegment | [protected]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClickable(void) const | CEGUI::ListHeaderSegment | [inline]
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isDragMoveThresholdExceeded(const Point &local_mouse) | CEGUI::ListHeaderSegment | [protected]
isDragMovingEnabled(void) const | CEGUI::ListHeaderSegment | [inline]
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSizingEnabled(void) const | CEGUI::ListHeaderSegment | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ListHeaderSegment(const String &type, const String &name) | CEGUI::ListHeaderSegment |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
None enum value | CEGUI::ListHeaderSegment |
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClickableSettingChanged(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMovableSettingChanged(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSegmentClicked(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onSegmentDragPositionChanged(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onSegmentDragStart(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onSegmentDragStop(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onSegmentSized(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSizingSettingChanged(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onSortDirectionChanged(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onSplitterDoubleClicked(WindowEventArgs &e) | CEGUI::ListHeaderSegment | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
SegmentMoveThreshold | CEGUI::ListHeaderSegment | [static]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClickable(bool setting) | CEGUI::ListHeaderSegment |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setDragMovingEnabled(bool setting) | CEGUI::ListHeaderSegment |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSizingEnabled(bool setting) | CEGUI::ListHeaderSegment |
setSortDirection(SortDirection sort_dir) | CEGUI::ListHeaderSegment |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
SortDirection enum name | CEGUI::ListHeaderSegment |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ListHeaderSegment | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ListHeaderSegment(void) | CEGUI::ListHeaderSegment | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderSegmentProperties::Clickable Member List

This is the complete list of members for CEGUI::ListHeaderSegmentProperties::Clickable, including all inherited members.

Clickable() (defined in CEGUI::ListHeaderSegmentProperties::Clickable) | CEGUI::ListHeaderSegmentProperties::Clickable | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderSegmentProperties::Clickable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderSegmentProperties::Clickable | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderSegmentProperties::Dragable Member List

This is the complete list of members for CEGUI::ListHeaderSegmentProperties::Dragable, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
Dragable() (defined in CEGUI::ListHeaderSegmentProperties::Dragable) | CEGUI::ListHeaderSegmentProperties::Dragable | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderSegmentProperties::Dragable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderSegmentProperties::Dragable | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderSegmentProperties::Sizable Member List

This is the complete list of members for CEGUI::ListHeaderSegmentProperties::Sizable, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderSegmentProperties::Sizable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderSegmentProperties::Sizable | [virtual]
Sizable() (defined in CEGUI::ListHeaderSegmentProperties::Sizable) | CEGUI::ListHeaderSegmentProperties::Sizable | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:12 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ListHeaderSegmentProperties::SortDirection Member List

This is the complete list of members for CEGUI::ListHeaderSegmentProperties::SortDirection, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ListHeaderSegmentProperties::SortDirection | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ListHeaderSegmentProperties::SortDirection | [virtual]
SortDirection() (defined in CEGUI::ListHeaderSegmentProperties::SortDirection) | CEGUI::ListHeaderSegmentProperties::SortDirection | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Logger Member List

This is the complete list of members for CEGUI::Logger, including all inherited members.

d_cache | CEGUI::Logger | [protected]
d_caching | CEGUI::Logger | [protected]
d_level | CEGUI::Logger | [protected]
d_ostream | CEGUI::Logger | [protected]
d_workstream | CEGUI::Logger | [protected]
getLoggingLevel(void) const | CEGUI::Logger | [inline]
getSingleton(void) | CEGUI::Logger | [static]
logEvent(const String &message, LoggingLevel level=Standard) | CEGUI::Logger |
Logger(void) | CEGUI::Logger |
setLogFilename(const String &filename, bool append=false) | CEGUI::Logger |
setLoggingLevel(LoggingLevel level) | CEGUI::Logger | [inline]
~Logger(void) | CEGUI::Logger |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MemoryException Member List

This is the complete list of members for CEGUI::MemoryException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
MemoryException(const String &message) (defined in CEGUI::MemoryException) | CEGUI::MemoryException | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Menubar Member List

This is the complete list of members for CEGUI::Menubar, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItem(ItemEntry *item) | CEGUI::ItemListBase |
addItemListBaseEvents(void) | CEGUI::ItemListBase | [protected]
addMenuBaseEvents(void) | CEGUI::MenuBase | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
changePopupMenuItem(MenuItem *item) | CEGUI::MenuBase |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_allowMultiplePopups | CEGUI::MenuBase | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoResize (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
d_backgroundColours | CEGUI::MenuBase | [protected]
d_borderWidth | CEGUI::MenuBase | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzPadding | CEGUI::MenuBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_itemSpacing | CEGUI::MenuBase | [protected]
d_listItems | CEGUI::ItemListBase | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_popup | CEGUI::MenuBase | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertPadding | CEGUI::MenuBase | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultBackgroundColour | CEGUI::MenuBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::ItemListBase | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Menubar | [static]
EventParentSized | CEGUI::Window | [static]
EventPopupClosed | CEGUI::MenuBase | [static]
EventPopupOpened | CEGUI::MenuBase | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ItemEntry *start_item) | CEGUI::ItemListBase |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::MenuBase | [inline]
getBorderWidth(void) const | CEGUI::MenuBase | [inline]
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getContentSize() | CEGUI::Menubar | [protected, virtual]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorzPadding(void) const | CEGUI::MenuBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemCount(void) const | CEGUI::ItemListBase | [inline]
getItemFromIndex(size_t index) const | CEGUI::ItemListBase |
getItemIndex(const ItemEntry *item) const | CEGUI::ItemListBase |
getItemRenderArea(void) const =0 | CEGUI::ItemListBase | [protected, pure virtual]
getItemSpacing(void) const | CEGUI::MenuBase | [inline]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPopupMenuItem(void) const | CEGUI::MenuBase | [inline]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVertPadding(void) const | CEGUI::MenuBase | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleUpdatedItemData(void) | CEGUI::ItemListBase |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::ItemListBase | [virtual]
insertItem(ItemEntry *item, const ItemEntry *position) | CEGUI::ItemListBase |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isAutoResizeEnabled() const | CEGUI::ItemListBase | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isItemInList(const ItemEntry *item) const | CEGUI::ItemListBase |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMultiplePopupsAllowed(void) const | CEGUI::MenuBase | [inline]
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntryList typedef (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
ItemListBase(const String &type, const String &name) | CEGUI::ItemListBase |
layoutItemWidgets() | CEGUI::Menubar | [protected, virtual]
Menubar(const String &type, const String &name) | CEGUI::Menubar |
MenuBase(const String &type, const String &name) | CEGUI::MenuBase |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onPopupClosed(WindowEventArgs &e) | CEGUI::MenuBase | [protected, virtual]
onPopupOpened(WindowEventArgs &e) | CEGUI::MenuBase | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache()=0 | CEGUI::ItemListBase | [protected, pure virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(ItemEntry *item) | CEGUI::ItemListBase |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::ItemListBase |
resetList_impl(void) | CEGUI::ItemListBase | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAllowMultiplePopups(bool setting) | CEGUI::MenuBase | [inline]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setAutoResizeEnabled(bool setting) | CEGUI::ItemListBase |
setBackgroundColours(const ColourRect &cr) | CEGUI::MenuBase | [inline]
setBorderWidth(float border) | CEGUI::MenuBase | [inline]
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorzPadding(float padding) | CEGUI::MenuBase | [inline]
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItemSpacing(float spacing) | CEGUI::MenuBase | [inline]
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVertPadding(float padding) | CEGUI::MenuBase | [inline]
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
sizeToContent(void) | CEGUI::ItemListBase | [inline, virtual]
sizeToContent_impl(void)=0 | CEGUI::ItemListBase | [protected, pure virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Menubar | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemListBase(void) | CEGUI::ItemListBase | [virtual]
~Menubar(void) | CEGUI::Menubar | [virtual]
~MenuBase(void) | CEGUI::MenuBase | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBase Member List

This is the complete list of members for CEGUI::MenuBase, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItem(ItemEntry *item) | CEGUI::ItemListBase |
addItemListBaseEvents(void) | CEGUI::ItemListBase | [protected]
addMenuBaseEvents(void) | CEGUI::MenuBase | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
changePopupMenuItem(MenuItem *item) | CEGUI::MenuBase |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_allowMultiplePopups | CEGUI::MenuBase | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoResize (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
d_backgroundColours | CEGUI::MenuBase | [protected]
d_borderWidth | CEGUI::MenuBase | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzPadding | CEGUI::MenuBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_itemSpacing | CEGUI::MenuBase | [protected]
d_listItems | CEGUI::ItemListBase | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_popup | CEGUI::MenuBase | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertPadding | CEGUI::MenuBase | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultBackgroundColour | CEGUI::MenuBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::ItemListBase | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::MenuBase | [static]
EventParentSized | CEGUI::Window | [static]
EventPopupClosed | CEGUI::MenuBase | [static]
EventPopupOpened | CEGUI::MenuBase | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ItemEntry *start_item) | CEGUI::ItemListBase |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::MenuBase | [inline]
getBorderWidth(void) const | CEGUI::MenuBase | [inline]
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getContentSize()=0 | CEGUI::ItemListBase | [protected, pure virtual]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorzPadding(void) const | CEGUI::MenuBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemCount(void) const | CEGUI::ItemListBase | [inline]
getItemFromIndex(size_t index) const | CEGUI::ItemListBase |
getItemIndex(const ItemEntry *item) const | CEGUI::ItemListBase |
getItemRenderArea(void) const =0 | CEGUI::ItemListBase | [protected, pure virtual]
getItemSpacing(void) const | CEGUI::MenuBase | [inline]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPopupMenuItem(void) const | CEGUI::MenuBase | [inline]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVertPadding(void) const | CEGUI::MenuBase | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleUpdatedItemData(void) | CEGUI::ItemListBase |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::ItemListBase | [virtual]
insertItem(ItemEntry *item, const ItemEntry *position) | CEGUI::ItemListBase |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isAutoResizeEnabled() const | CEGUI::ItemListBase | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isItemInList(const ItemEntry *item) const | CEGUI::ItemListBase |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMultiplePopupsAllowed(void) const | CEGUI::MenuBase | [inline]
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntryList typedef (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
ItemListBase(const String &type, const String &name) | CEGUI::ItemListBase |
layoutItemWidgets()=0 | CEGUI::ItemListBase | [protected, pure virtual]
MenuBase(const String &type, const String &name) | CEGUI::MenuBase |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onPopupClosed(WindowEventArgs &e) | CEGUI::MenuBase | [protected, virtual]
onPopupOpened(WindowEventArgs &e) | CEGUI::MenuBase | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache()=0 | CEGUI::ItemListBase | [protected, pure virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(ItemEntry *item) | CEGUI::ItemListBase |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::ItemListBase |
resetList_impl(void) | CEGUI::ItemListBase | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAllowMultiplePopups(bool setting) | CEGUI::MenuBase | [inline]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setAutoResizeEnabled(bool setting) | CEGUI::ItemListBase |
setBackgroundColours(const ColourRect &cr) | CEGUI::MenuBase | [inline]
setBorderWidth(float border) | CEGUI::MenuBase | [inline]
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorzPadding(float padding) | CEGUI::MenuBase | [inline]
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItemSpacing(float spacing) | CEGUI::MenuBase | [inline]
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVertPadding(float padding) | CEGUI::MenuBase | [inline]
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
sizeToContent(void) | CEGUI::ItemListBase | [inline, virtual]
sizeToContent_impl(void)=0 | CEGUI::ItemListBase | [protected, pure virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::MenuBase | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemListBase(void) | CEGUI::ItemListBase | [virtual]
~MenuBase(void) | CEGUI::MenuBase | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBaseProperties::AllowMultiplePopups Member List

This is the complete list of members for CEGUI::MenuBaseProperties::AllowMultiplePopups, including all inherited members.

AllowMultiplePopups() (defined in CEGUI::MenuBaseProperties::AllowMultiplePopups) | CEGUI::MenuBaseProperties::AllowMultiplePopups | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuBaseProperties::AllowMultiplePopups | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuBaseProperties::AllowMultiplePopups | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBaseProperties::BackgroundColours Member List

This is the complete list of members for CEGUI::MenuBaseProperties::BackgroundColours, including all inherited members.

BackgroundColours() (defined in CEGUI::MenuBaseProperties::BackgroundColours) | CEGUI::MenuBaseProperties::BackgroundColours | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuBaseProperties::BackgroundColours | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuBaseProperties::BackgroundColours | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBaseProperties::BorderWidth Member List

This is the complete list of members for CEGUI::MenuBaseProperties::BorderWidth, including all inherited members.

BorderWidth() (defined in CEGUI::MenuBaseProperties::BorderWidth) | CEGUI::MenuBaseProperties::BorderWidth | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuBaseProperties::BorderWidth | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuBaseProperties::BorderWidth | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBaseProperties::HorzPadding Member List

This is the complete list of members for CEGUI::MenuBaseProperties::HorzPadding, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuBaseProperties::HorzPadding | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzPadding() (defined in CEGUI::MenuBaseProperties::HorzPadding) | CEGUI::MenuBaseProperties::HorzPadding | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuBaseProperties::HorzPadding | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBaseProperties::ItemSpacing Member List

This is the complete list of members for CEGUI::MenuBaseProperties::ItemSpacing, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuBaseProperties::ItemSpacing | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
ItemSpacing() (defined in CEGUI::MenuBaseProperties::ItemSpacing) | CEGUI::MenuBaseProperties::ItemSpacing | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuBaseProperties::ItemSpacing | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuBaseProperties::VertPadding Member List

This is the complete list of members for CEGUI::MenuBaseProperties::VertPadding, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuBaseProperties::VertPadding | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuBaseProperties::VertPadding | [virtual]
VertPadding() (defined in CEGUI::MenuBaseProperties::VertPadding) | CEGUI::MenuBaseProperties::VertPadding | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuItem Member List

This is the complete list of members for CEGUI::MenuItem, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItemEntryEvents(void) | CEGUI::ItemEntry | [protected]
addMenuItemEvents(void) | CEGUI::MenuItem | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
closeAllMenuItemPopups() | CEGUI::MenuItem | [protected]
closePopupMenu(bool notify=true) | CEGUI::MenuItem |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledTextColour | CEGUI::MenuItem | [protected]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverColour | CEGUI::MenuItem | [protected]
d_hovering | CEGUI::MenuItem | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalTextColour | CEGUI::MenuItem | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_opened | CEGUI::MenuItem | [protected]
d_openedColour | CEGUI::MenuItem | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_popup | CEGUI::MenuItem | [protected]
d_popupWasClosed | CEGUI::MenuItem | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::MenuItem | [protected]
d_pushedColour | CEGUI::MenuItem | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textColour | CEGUI::TextItem | [protected]
d_textFormatting | CEGUI::TextItem | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_textXOffset | CEGUI::TextItem | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledTextColour | CEGUI::MenuItem | [static]
DefaultHoverColour | CEGUI::MenuItem | [static]
DefaultNormalTextColour | CEGUI::MenuItem | [static]
DefaultOpenedColour | CEGUI::MenuItem | [static]
DefaultPushedColour | CEGUI::MenuItem | [static]
DefaultTextColour | CEGUI::TextItem | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClicked | CEGUI::MenuItem | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::MenuItem | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledTextColour(void) const | CEGUI::MenuItem | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverColour(void) const | CEGUI::MenuItem | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemPixelSize(void) | CEGUI::TextItem | [virtual]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalTextColour(void) const | CEGUI::MenuItem | [inline]
getOpenedColour(void) const | CEGUI::MenuItem | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPopupMenu(void) const | CEGUI::MenuItem | [inline]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedColour(void) const | CEGUI::MenuItem | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextColour(void) const | CEGUI::TextItem | [inline]
getTextFormatting() const | CEGUI::TextItem | [inline]
getTextXOffset(void) const | CEGUI::TextItem | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHovering(void) const | CEGUI::MenuItem | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::MenuItem | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntry(const String &type, const String &name) | CEGUI::ItemEntry |
MenuItem(const String &type, const String &name) | CEGUI::MenuItem |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::MenuItem | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClicked(WindowEventArgs &e) | CEGUI::MenuItem | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::MenuItem | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::MenuItem | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::MenuItem | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::MenuItem | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::TextItem | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
openPopupMenu(void) | CEGUI::MenuItem |
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::TextItem | [protected, virtual]
populateRenderCahce() | CEGUI::ItemEntry | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledTextColour(const colour &colour) | CEGUI::MenuItem |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverColour(const colour &colour) | CEGUI::MenuItem |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalTextColour(const colour &colour) | CEGUI::MenuItem |
setOpenedColour(const colour &colour) | CEGUI::MenuItem |
setParent(Window *parent) | CEGUI::Window | [protected]
setPopupMenu(PopupMenu *popup) | CEGUI::MenuItem |
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedColour(const colour &colour) | CEGUI::MenuItem |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTextColour(const colour &col) | CEGUI::TextItem | [inline]
setTextFormatting(TextFormatting format) | CEGUI::TextItem | [inline]
setTextXOffset(float offset) | CEGUI::TextItem | [inline]
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::MenuItem | [inline, protected, virtual]
TextItem(const String &type, const String &name) | CEGUI::TextItem |
togglePopupMenu(void) | CEGUI::MenuItem |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::MenuItem | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemEntry(void) | CEGUI::ItemEntry | [virtual]
~MenuItem(void) | CEGUI::MenuItem | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~TextItem(void) | CEGUI::TextItem | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:05 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuItemProperties::DisabledTextColour Member List

This is the complete list of members for CEGUI::MenuItemProperties::DisabledTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DisabledTextColour() (defined in CEGUI::MenuItemProperties::DisabledTextColour) | CEGUI::MenuItemProperties::DisabledTextColour | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::MenuItemProperties::DisabledTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuItemProperties::DisabledTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuItemProperties::HoverColour Member List

This is the complete list of members for CEGUI::MenuItemProperties::HoverColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuItemProperties::HoverColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HoverColour() (defined in CEGUI::MenuItemProperties::HoverColour) | CEGUI::MenuItemProperties::HoverColour | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuItemProperties::HoverColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuItemProperties::NormalTextColour Member List

This is the complete list of members for CEGUI::MenuItemProperties::NormalTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuItemProperties::NormalTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NormalTextColour() (defined in CEGUI::MenuItemProperties::NormalTextColour) | CEGUI::MenuItemProperties::NormalTextColour | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuItemProperties::NormalTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuItemProperties::OpenedColour Member List

This is the complete list of members for CEGUI::MenuItemProperties::OpenedColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuItemProperties::OpenedColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
OpenedColour() (defined in CEGUI::MenuItemProperties::OpenedColour) | CEGUI::MenuItemProperties::OpenedColour | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuItemProperties::OpenedColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MenuItemProperties::PushedColour Member List

This is the complete list of members for CEGUI::MenuItemProperties::PushedColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MenuItemProperties::PushedColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
PushedColour() (defined in CEGUI::MenuItemProperties::PushedColour) | CEGUI::MenuItemProperties::PushedColour | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MenuItemProperties::PushedColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MouseCursor Member List

This is the complete list of members for CEGUI::MouseCursor, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
addMouseCursorEvents(void) | CEGUI::MouseCursor | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_muted | CEGUI::EventSet | [protected]
draw(void) const | CEGUI::MouseCursor |
EventImageChanged | CEGUI::MouseCursor | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventNamespace | CEGUI::MouseCursor | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getConstraintArea(void) const | CEGUI::MouseCursor |
getDisplayIndependantPosition(void) const | CEGUI::MouseCursor |
getImage(void) const | CEGUI::MouseCursor | [inline]
getIterator(void) const | CEGUI::EventSet |
getPosition(void) const | CEGUI::MouseCursor | [inline]
getSingleton(void) | CEGUI::MouseCursor | [static]
getSingletonPtr(void) | CEGUI::MouseCursor | [static]
getUnifiedConstraintArea(void) const | CEGUI::MouseCursor |
hide(void) | CEGUI::MouseCursor | [inline]
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isVisible(void) const | CEGUI::MouseCursor | [inline]
MouseCursor(void) | CEGUI::MouseCursor |
offsetPosition(const Point &offset) | CEGUI::MouseCursor |
onImageChanged(MouseCursorEventArgs &e) | CEGUI::MouseCursor | [protected, virtual]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
setConstraintArea(const Rect *area) | CEGUI::MouseCursor |
setImage(const String &imageset, const String &image_name) | CEGUI::MouseCursor |
setImage(const Image *image) | CEGUI::MouseCursor |
setMutedState(bool setting) | CEGUI::EventSet |
setPosition(const Point &position) | CEGUI::MouseCursor |
setUnifiedConstraintArea(const URect *area) | CEGUI::MouseCursor |
show(void) | CEGUI::MouseCursor | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~MouseCursor(void) | CEGUI::MouseCursor |

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MouseCursorEventArgs Member List

This is the complete list of members for CEGUI::MouseCursorEventArgs, including all inherited members.

EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
image | CEGUI::MouseCursorEventArgs |
mouseCursor | CEGUI::MouseCursorEventArgs |
MouseCursorEventArgs(MouseCursor *cursor) (defined in CEGUI::MouseCursorEventArgs) | CEGUI::MouseCursorEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MouseEventArgs Member List

This is the complete list of members for CEGUI::MouseEventArgs, including all inherited members.

button | CEGUI::MouseEventArgs |
clickCount | CEGUI::MouseEventArgs |
EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
MouseEventArgs(Window *wnd) (defined in CEGUI::MouseEventArgs) | CEGUI::MouseEventArgs | [inline]
moveDelta | CEGUI::MouseEventArgs |
position | CEGUI::MouseEventArgs |
sysKeys | CEGUI::MouseEventArgs |
wheelChange | CEGUI::MouseEventArgs |
window | CEGUI::WindowEventArgs |
WindowEventArgs(Window *wnd) (defined in CEGUI::WindowEventArgs) | CEGUI::WindowEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnList Member List

This is the complete list of members for CEGUI::MultiColumnList, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addColumn(const String &text, uint col_id, float width) | CEGUI::MultiColumnList |
addEvent(const String &name) | CEGUI::EventSet |
addMultiColumnListboxEvents(void) | CEGUI::MultiColumnList | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addRow(uint row_id=0) | CEGUI::MultiColumnList |
addRow(ListboxItem *item, uint col_id, uint row_id=0) | CEGUI::MultiColumnList |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
autoSizeColumnHeader(uint col_idx) | CEGUI::MultiColumnList |
cacheListboxBaseImagery()=0 | CEGUI::MultiColumnList | [protected, pure virtual]
captureInput(void) | CEGUI::Window |
CellMultiple enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
CellSingle enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearAllSelections(void) | CEGUI::MultiColumnList |
clearAllSelections_impl(void) | CEGUI::MultiColumnList | [protected]
clearProperties(void) | CEGUI::PropertySet |
ColumnMultiple enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
ColumnSingle enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
configureScrollbars(void) | CEGUI::MultiColumnList | [protected]
createHorzScrollbar(const String &name) const =0 | CEGUI::MultiColumnList | [protected, pure virtual]
createListHeader(const String &name) const =0 | CEGUI::MultiColumnList | [protected, pure virtual]
createVertScrollbar(const String &name) const =0 | CEGUI::MultiColumnList | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_forceHorzScroll | CEGUI::MultiColumnList | [protected]
d_forceVertScroll | CEGUI::MultiColumnList | [protected]
d_fullColSelect | CEGUI::MultiColumnList | [protected]
d_fullRowSelect | CEGUI::MultiColumnList | [protected]
d_grid | CEGUI::MultiColumnList | [protected]
d_header | CEGUI::MultiColumnList | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzScrollbar | CEGUI::MultiColumnList | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lastSelected | CEGUI::MultiColumnList | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_multiSelect | CEGUI::MultiColumnList | [protected]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_nominatedSelectCol | CEGUI::MultiColumnList | [protected]
d_nominatedSelectRow | CEGUI::MultiColumnList | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_selectMode | CEGUI::MultiColumnList | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_useNominatedCol | CEGUI::MultiColumnList | [protected]
d_useNominatedRow | CEGUI::MultiColumnList | [protected]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertScrollbar | CEGUI::MultiColumnList | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHorzScrollbarModeChanged | CEGUI::MultiColumnList | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListColumnMoved | CEGUI::MultiColumnList | [static]
EventListColumnSized | CEGUI::MultiColumnList | [static]
EventListContentsChanged | CEGUI::MultiColumnList | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::MultiColumnList | [static]
EventNominatedSelectColumnChanged | CEGUI::MultiColumnList | [static]
EventNominatedSelectRowChanged | CEGUI::MultiColumnList | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSelectionChanged | CEGUI::MultiColumnList | [static]
EventSelectionModeChanged | CEGUI::MultiColumnList | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventSortColumnChanged | CEGUI::MultiColumnList | [static]
EventSortDirectionChanged | CEGUI::MultiColumnList | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventVertScrollbarModeChanged | CEGUI::MultiColumnList | [static]
EventZOrderChanged | CEGUI::Window | [static]
findColumnItemWithText(const String &text, uint col_idx, const ListboxItem *start_item) const | CEGUI::MultiColumnList |
findListItemWithText(const String &text, const ListboxItem *start_item) const | CEGUI::MultiColumnList |
findRowItemWithText(const String &text, uint row_idx, const ListboxItem *start_item) const | CEGUI::MultiColumnList |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getColumnCount(void) const | CEGUI::MultiColumnList |
getColumnHeaderWidth(uint col_idx) const | CEGUI::MultiColumnList |
getColumnID(uint col_idx) const | CEGUI::MultiColumnList |
getColumnWithHeaderText(const String &text) const | CEGUI::MultiColumnList |
getColumnWithID(uint col_id) const | CEGUI::MultiColumnList |
getEffectiveAlpha(void) const | CEGUI::Window |
getFirstSelectedItem(void) const | CEGUI::MultiColumnList |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeaderSegmentForColumn(uint col_idx) const | CEGUI::MultiColumnList |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHighestRowItemHeight(uint row_idx) const | CEGUI::MultiColumnList | [protected]
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemAtGridReference(const MCLGridRef &grid_ref) const | CEGUI::MultiColumnList |
getItemAtPoint(const Point &pt) const | CEGUI::MultiColumnList | [protected]
getItemColumnIndex(const ListboxItem *item) const | CEGUI::MultiColumnList |
getItemGridReference(const ListboxItem *item) const | CEGUI::MultiColumnList |
getItemRowIndex(const ListboxItem *item) const | CEGUI::MultiColumnList |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getListRenderArea(void) const =0 | CEGUI::MultiColumnList | [protected, pure virtual]
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNextSelected(const ListboxItem *start_item) const | CEGUI::MultiColumnList |
getNominatedSelectionColumn(void) const | CEGUI::MultiColumnList |
getNominatedSelectionColumnID(void) const | CEGUI::MultiColumnList |
getNominatedSelectionRow(void) const | CEGUI::MultiColumnList |
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getRowCount(void) const | CEGUI::MultiColumnList |
getRowID(uint row_idx) const | CEGUI::MultiColumnList |
getRowWithID(uint row_id) const | CEGUI::MultiColumnList |
getSelectedCount(void) const | CEGUI::MultiColumnList |
getSelectionMode(void) const | CEGUI::MultiColumnList |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getSortColumn(void) const | CEGUI::MultiColumnList |
getSortDirection(void) const | CEGUI::MultiColumnList |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getTotalColumnHeadersWidth(void) const | CEGUI::MultiColumnList |
getTotalRowsHeight(void) const | CEGUI::MultiColumnList | [protected]
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidestColumnItemWidth(uint col_idx) const | CEGUI::MultiColumnList | [protected]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleColumnSizeChange(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleHeaderScroll(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleHeaderSegDblClick(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleHeaderSegMove(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleHorzScrollbar(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleSortColumnChange(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleSortDirectionChange(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
handleUpdatedItemData(void) | CEGUI::MultiColumnList |
handleVertScrollbar(const EventArgs &e) (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::MultiColumnList | [virtual]
insertColumn(const String &text, uint col_id, float width, uint position) | CEGUI::MultiColumnList |
insertRow(uint row_idx, uint row_id=0) | CEGUI::MultiColumnList |
insertRow(ListboxItem *item, uint col_id, uint row_idx, uint row_id=0) | CEGUI::MultiColumnList |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHorzScrollbarAlwaysShown(void) const | CEGUI::MultiColumnList |
isItemSelected(const MCLGridRef &grid_ref) const | CEGUI::MultiColumnList |
isListboxItemInColumn(const ListboxItem *item, uint col_idx) const | CEGUI::MultiColumnList |
isListboxItemInList(const ListboxItem *item) const | CEGUI::MultiColumnList |
isListboxItemInRow(const ListboxItem *item, uint row_idx) const | CEGUI::MultiColumnList |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserColumnDraggingEnabled(void) const | CEGUI::MultiColumnList |
isUserColumnSizingEnabled(void) const | CEGUI::MultiColumnList |
isUserSortControlEnabled(void) const | CEGUI::MultiColumnList |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVertScrollbarAlwaysShown(void) const | CEGUI::MultiColumnList |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ListItemGrid typedef (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected]
moveColumn(uint col_idx, uint position) | CEGUI::MultiColumnList |
moveColumn_impl(uint col_idx, uint position) | CEGUI::MultiColumnList | [protected]
moveColumnWithID(uint col_id, uint position) | CEGUI::MultiColumnList |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
MultiColumnList(const String &type, const String &name) | CEGUI::MultiColumnList |
NominatedColumnMultiple enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
NominatedColumnSingle enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
NominatedRowMultiple enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
NominatedRowSingle enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorzScrollbarModeChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListColumnMoved(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onListColumnSized(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onNominatedSelectColumnChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onNominatedSelectRowChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSelectionChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onSelectionModeChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onSortColumnChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onSortDirectionChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVertScrollbarModeChanged(WindowEventArgs &e) | CEGUI::MultiColumnList | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::MultiColumnList | [protected, virtual]
pred_descend(const ListRow &a, const ListRow &b) | CEGUI::MultiColumnList | [protected, static]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeColumn(uint col_idx) | CEGUI::MultiColumnList |
removeColumnWithID(uint col_id) | CEGUI::MultiColumnList |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeRow(uint row_idx) | CEGUI::MultiColumnList |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::MultiColumnList |
resetList_impl(void) | CEGUI::MultiColumnList | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
RowMultiple enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
RowSingle enum value (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList |
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
SelectionMode enum name | CEGUI::MultiColumnList |
selectRange(const MCLGridRef &start, const MCLGridRef &end) | CEGUI::MultiColumnList | [protected]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setColumnHeaderWidth(uint col_idx, float width) | CEGUI::MultiColumnList |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItem(ListboxItem *item, const MCLGridRef &position) | CEGUI::MultiColumnList |
setItem(ListboxItem *item, uint col_id, uint row_idx) | CEGUI::MultiColumnList |
setItemSelectState(ListboxItem *item, bool state) | CEGUI::MultiColumnList |
setItemSelectState(const MCLGridRef &grid_ref, bool state) | CEGUI::MultiColumnList |
setItemSelectState_impl(const MCLGridRef grid_ref, bool state) | CEGUI::MultiColumnList | [protected]
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNominatedSelectionColumn(uint col_idx) | CEGUI::MultiColumnList |
setNominatedSelectionColumnID(uint col_id) | CEGUI::MultiColumnList |
setNominatedSelectionRow(uint row_idx) | CEGUI::MultiColumnList |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setRowID(uint row_idx, uint row_id) | CEGUI::MultiColumnList |
setSelectForItemsInColumn(uint col_idx, bool state) | CEGUI::MultiColumnList | [protected]
setSelectForItemsInRow(uint row_idx, bool state) | CEGUI::MultiColumnList | [protected]
setSelectionMode(MultiColumnList::SelectionMode sel_mode) | CEGUI::MultiColumnList |
setShowHorzScrollbar(bool setting) | CEGUI::MultiColumnList |
setShowVertScrollbar(bool setting) | CEGUI::MultiColumnList |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setSortColumn(uint col_idx) | CEGUI::MultiColumnList |
setSortColumnByID(uint col_id) | CEGUI::MultiColumnList |
setSortDirection(ListHeaderSegment::SortDirection direction) | CEGUI::MultiColumnList |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserColumnDraggingEnabled(bool setting) | CEGUI::MultiColumnList |
setUserColumnSizingEnabled(bool setting) | CEGUI::MultiColumnList |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserSortControlEnabled(bool setting) | CEGUI::MultiColumnList |
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::MultiColumnList | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::MultiColumnList) | CEGUI::MultiColumnList | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~MultiColumnList(void) | CEGUI::MultiColumnList | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::ColumnHeader Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::ColumnHeader, including all inherited members.

ColumnHeader() (defined in CEGUI::MultiColumnListProperties::ColumnHeader) | CEGUI::MultiColumnListProperties::ColumnHeader | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::ColumnHeader | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::ColumnHeader | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::ColumnsMovable Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::ColumnsMovable, including all inherited members.

ColumnsMovable() (defined in CEGUI::MultiColumnListProperties::ColumnsMovable) | CEGUI::MultiColumnListProperties::ColumnsMovable | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::ColumnsMovable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::ColumnsMovable | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::ColumnsSizable Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::ColumnsSizable, including all inherited members.

ColumnsSizable() (defined in CEGUI::MultiColumnListProperties::ColumnsSizable) | CEGUI::MultiColumnListProperties::ColumnsSizable | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::ColumnsSizable | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::ColumnsSizable | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::ForceHorzScrollbar Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::ForceHorzScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceHorzScrollbar() (defined in CEGUI::MultiColumnListProperties::ForceHorzScrollbar) | CEGUI::MultiColumnListProperties::ForceHorzScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::ForceHorzScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::ForceHorzScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::ForceVertScrollbar Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::ForceVertScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceVertScrollbar() (defined in CEGUI::MultiColumnListProperties::ForceVertScrollbar) | CEGUI::MultiColumnListProperties::ForceVertScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::ForceVertScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::ForceVertScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::NominatedSelectionColumnID Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::NominatedSelectionColumnID | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NominatedSelectionColumnID() (defined in CEGUI::MultiColumnListProperties::NominatedSelectionColumnID) | CEGUI::MultiColumnListProperties::NominatedSelectionColumnID | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::NominatedSelectionColumnID | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::NominatedSelectionRow Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::NominatedSelectionRow, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::NominatedSelectionRow | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NominatedSelectionRow() (defined in CEGUI::MultiColumnListProperties::NominatedSelectionRow) | CEGUI::MultiColumnListProperties::NominatedSelectionRow | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::NominatedSelectionRow | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::RowCount Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::RowCount, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::RowCount | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RowCount() (defined in CEGUI::MultiColumnListProperties::RowCount) | CEGUI::MultiColumnListProperties::RowCount | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::RowCount | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::SelectionMode Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::SelectionMode, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::SelectionMode | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectionMode() (defined in CEGUI::MultiColumnListProperties::SelectionMode) | CEGUI::MultiColumnListProperties::SelectionMode | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::SelectionMode | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::SortColumnID Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::SortColumnID, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::SortColumnID | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::SortColumnID | [virtual]
SortColumnID() (defined in CEGUI::MultiColumnListProperties::SortColumnID) | CEGUI::MultiColumnListProperties::SortColumnID | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::SortDirection Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::SortDirection, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::SortDirection | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::SortDirection | [virtual]
SortDirection() (defined in CEGUI::MultiColumnListProperties::SortDirection) | CEGUI::MultiColumnListProperties::SortDirection | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnListProperties::SortSettingEnabled Member List

This is the complete list of members for CEGUI::MultiColumnListProperties::SortSettingEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiColumnListProperties::SortSettingEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiColumnListProperties::SortSettingEnabled | [virtual]
SortSettingEnabled() (defined in CEGUI::MultiColumnListProperties::SortSettingEnabled) | CEGUI::MultiColumnListProperties::SortSettingEnabled | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditbox Member List

This is the complete list of members for CEGUI::MultiLineEditbox, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addMultiLineEditboxEvents(void) | CEGUI::MultiLineEditbox | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
cacheCaratImagery(const Rect &textArea)=0 | CEGUI::MultiLineEditbox | [protected, pure virtual]
cacheEditboxBaseImagery()=0 | CEGUI::MultiLineEditbox | [protected, pure virtual]
cacheTextLines(const Rect &dest_area) | CEGUI::MultiLineEditbox | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
clearSelection(void) | CEGUI::MultiLineEditbox | [protected]
configureScrollbars(void) | CEGUI::MultiLineEditbox | [protected]
createHorzScrollbar(const String &name) const =0 | CEGUI::MultiLineEditbox | [protected, pure virtual]
createVertScrollbar(const String &name) const =0 | CEGUI::MultiLineEditbox | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_caratPos | CEGUI::MultiLineEditbox | [protected]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragAnchorIdx | CEGUI::MultiLineEditbox | [protected]
d_dragging | CEGUI::MultiLineEditbox | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_forceHorzScroll | CEGUI::MultiLineEditbox | [protected]
d_forceVertScroll | CEGUI::MultiLineEditbox | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzScrollbar | CEGUI::MultiLineEditbox | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inactiveSelectBrushColour | CEGUI::MultiLineEditbox | [protected]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lineBreakChars | CEGUI::MultiLineEditbox | [protected, static]
d_lines | CEGUI::MultiLineEditbox | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_maxTextLen | CEGUI::MultiLineEditbox | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalTextColour | CEGUI::MultiLineEditbox | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_readOnly | CEGUI::MultiLineEditbox | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_selectBrushColour | CEGUI::MultiLineEditbox | [protected]
d_selectionBrush | CEGUI::MultiLineEditbox | [protected]
d_selectionEnd | CEGUI::MultiLineEditbox | [protected]
d_selectionStart | CEGUI::MultiLineEditbox | [protected]
d_selectTextColour | CEGUI::MultiLineEditbox | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertScrollbar | CEGUI::MultiLineEditbox | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widestExtent | CEGUI::MultiLineEditbox | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wordWrap | CEGUI::MultiLineEditbox | [protected]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultInactiveSelectionColour | CEGUI::MultiLineEditbox | [static]
DefaultNormalSelectionColour | CEGUI::MultiLineEditbox | [static]
DefaultNormalTextColour | CEGUI::MultiLineEditbox | [static]
DefaultSelectedTextColour | CEGUI::MultiLineEditbox | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
ensureCaratIsVisible(void) | CEGUI::MultiLineEditbox |
eraseSelectedText(bool modify_text=true) | CEGUI::MultiLineEditbox | [protected]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCaratMoved | CEGUI::MultiLineEditbox | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEditboxFull | CEGUI::MultiLineEditbox | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHorzScrollbarModeChanged | CEGUI::MultiLineEditbox | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMaximumTextLengthChanged | CEGUI::MultiLineEditbox | [static]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::MultiLineEditbox | [static]
EventParentSized | CEGUI::Window | [static]
EventReadOnlyModeChanged | CEGUI::MultiLineEditbox | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventTextSelectionChanged | CEGUI::MultiLineEditbox | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventVertScrollbarModeChanged | CEGUI::MultiLineEditbox | [static]
EventWordWrapModeChanged | CEGUI::MultiLineEditbox | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
formatText(void) | CEGUI::MultiLineEditbox | [protected]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getCaratIndex(void) const | CEGUI::MultiLineEditbox | [inline]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInactiveSelectBrushColour(void) const | CEGUI::MultiLineEditbox | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLineNumberFromIndex(size_t index) const | CEGUI::MultiLineEditbox | [protected]
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMaxTextLength(void) const | CEGUI::MultiLineEditbox | [inline]
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNextTokenLength(const String &text, size_t start_idx) const | CEGUI::MultiLineEditbox | [protected]
getNormalSelectBrushColour(void) const | CEGUI::MultiLineEditbox | [inline]
getNormalTextColour(void) const | CEGUI::MultiLineEditbox | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedTextColour(void) const | CEGUI::MultiLineEditbox | [inline]
getSelectionEndIndex(void) const | CEGUI::MultiLineEditbox |
getSelectionLength(void) const | CEGUI::MultiLineEditbox |
getSelectionStartIndex(void) const | CEGUI::MultiLineEditbox |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextIndexFromPosition(const Point &pt) const | CEGUI::MultiLineEditbox | [protected]
getTextRenderArea(void) const =0 | CEGUI::MultiLineEditbox | [protected, pure virtual]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handle_scrollChange(const EventArgs &args) | CEGUI::MultiLineEditbox | [protected]
handleBackspace(void) | CEGUI::MultiLineEditbox | [protected]
handleCharLeft(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleCharRight(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleDelete(void) | CEGUI::MultiLineEditbox | [protected]
handleDocEnd(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleDocHome(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleLineDown(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleLineEnd(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleLineHome(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleLineUp(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleNewLine(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleWordLeft(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
handleWordRight(uint sysKeys) | CEGUI::MultiLineEditbox | [protected]
hasInputFocus(void) const | CEGUI::MultiLineEditbox |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::MultiLineEditbox | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isReadOnly(void) const | CEGUI::MultiLineEditbox | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isWordWrapped(void) const | CEGUI::MultiLineEditbox |
isZOrderingEnabled(void) const | CEGUI::Window |
LineList typedef | CEGUI::MultiLineEditbox | [protected]
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
MultiLineEditbox(const String &type, const String &name) | CEGUI::MultiLineEditbox |
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onCaratMoved(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onCharacter(KeyEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEditboxFullEvent(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorzScrollbarModeChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMaximumTextLengthChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onReadOnlyChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected, virtual]
onTextSelectionChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVertScrollbarModeChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onWordWrapModeChanged(WindowEventArgs &e) | CEGUI::MultiLineEditbox | [protected]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::MultiLineEditbox | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setCaratIndex(size_t carat_pos) | CEGUI::MultiLineEditbox |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInactiveSelectBrushColour(const colour &col) | CEGUI::MultiLineEditbox |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMaxTextLength(size_t max_len) | CEGUI::MultiLineEditbox |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalSelectBrushColour(const colour &col) | CEGUI::MultiLineEditbox |
setNormalTextColour(const colour &col) | CEGUI::MultiLineEditbox |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setReadOnly(bool setting) | CEGUI::MultiLineEditbox |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelectedTextColour(const colour &col) | CEGUI::MultiLineEditbox |
setSelection(size_t start_pos, size_t end_pos) | CEGUI::MultiLineEditbox |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setWordWrapping(bool setting) | CEGUI::MultiLineEditbox |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::MultiLineEditbox | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~MultiLineEditbox(void) | CEGUI::MultiLineEditbox | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::ActiveSelectionColour Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, including all inherited members.

ActiveSelectionColour() (defined in CEGUI::MultiLineEditboxProperties::ActiveSelectionColour) | CEGUI::MultiLineEditboxProperties::ActiveSelectionColour | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::ActiveSelectionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::ActiveSelectionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::CaratIndex Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::CaratIndex, including all inherited members.

CaratIndex() (defined in CEGUI::MultiLineEditboxProperties::CaratIndex) | CEGUI::MultiLineEditboxProperties::CaratIndex | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::CaratIndex | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::CaratIndex | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::InactiveSelectionColour Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::InactiveSelectionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
InactiveSelectionColour() (defined in CEGUI::MultiLineEditboxProperties::InactiveSelectionColour) | CEGUI::MultiLineEditboxProperties::InactiveSelectionColour | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::InactiveSelectionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::MaxTextLength Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::MaxTextLength, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::MaxTextLength | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaxTextLength() (defined in CEGUI::MultiLineEditboxProperties::MaxTextLength) | CEGUI::MultiLineEditboxProperties::MaxTextLength | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::MaxTextLength | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::NormalTextColour Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::NormalTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::NormalTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NormalTextColour() (defined in CEGUI::MultiLineEditboxProperties::NormalTextColour) | CEGUI::MultiLineEditboxProperties::NormalTextColour | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::NormalTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::ReadOnly Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::ReadOnly, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::ReadOnly | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
ReadOnly() (defined in CEGUI::MultiLineEditboxProperties::ReadOnly) | CEGUI::MultiLineEditboxProperties::ReadOnly | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::ReadOnly | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::SelectedTextColour Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::SelectedTextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::SelectedTextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectedTextColour() (defined in CEGUI::MultiLineEditboxProperties::SelectedTextColour) | CEGUI::MultiLineEditboxProperties::SelectedTextColour | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::SelectedTextColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::SelectionLength Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::SelectionLength, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::SelectionLength | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectionLength() (defined in CEGUI::MultiLineEditboxProperties::SelectionLength) | CEGUI::MultiLineEditboxProperties::SelectionLength | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::SelectionLength | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::SelectionStart Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::SelectionStart, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::SelectionStart | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
SelectionStart() (defined in CEGUI::MultiLineEditboxProperties::SelectionStart) | CEGUI::MultiLineEditboxProperties::SelectionStart | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::SelectionStart | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditboxProperties::WordWrap Member List

This is the complete list of members for CEGUI::MultiLineEditboxProperties::WordWrap, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::MultiLineEditboxProperties::WordWrap | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::MultiLineEditboxProperties::WordWrap | [virtual]
WordWrap() (defined in CEGUI::MultiLineEditboxProperties::WordWrap) | CEGUI::MultiLineEditboxProperties::WordWrap | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:13 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::NamedArea Member List

This is the complete list of members for CEGUI::NamedArea, including all inherited members.

getArea() const | CEGUI::NamedArea |
getName() const | CEGUI::NamedArea |
NamedArea() (defined in CEGUI::NamedArea) | CEGUI::NamedArea | [inline]
NamedArea(const String &name) (defined in CEGUI::NamedArea) | CEGUI::NamedArea |
setArea(const ComponentArea &area) | CEGUI::NamedArea |
writeXMLToStream(OutStream &out_stream) const | CEGUI::NamedArea |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::NullObjectException Member List

This is the complete list of members for CEGUI::NullObjectException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
NullObjectException(const String &message) (defined in CEGUI::NullObjectException) | CEGUI::NullObjectException | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ObjectInUseException Member List

This is the complete list of members for CEGUI::ObjectInUseException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
ObjectInUseException(const String &message) (defined in CEGUI::ObjectInUseException) | CEGUI::ObjectInUseException | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::OpenGLRenderer Member List

This is the complete list of members for CEGUI::OpenGLRenderer, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
addQuad(const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode) | CEGUI::OpenGLRenderer | [virtual]
advanceZValue(void) | CEGUI::Renderer | [inline]
clearRenderList(void) | CEGUI::OpenGLRenderer | [virtual]
createResourceProvider(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]
createTexture(void) | CEGUI::OpenGLRenderer | [virtual]
createTexture(const String &filename, const String &resourceGroup) | CEGUI::OpenGLRenderer | [virtual]
createTexture(float size) | CEGUI::OpenGLRenderer | [virtual]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_identifierString | CEGUI::Renderer | [protected]
d_muted | CEGUI::EventSet | [protected]
d_resourceProvider | CEGUI::Renderer | [protected]
destroyAllTextures(void) | CEGUI::OpenGLRenderer | [virtual]
destroyTexture(Texture *texture) | CEGUI::OpenGLRenderer | [virtual]
doRender(void) | CEGUI::OpenGLRenderer | [virtual]
EventDisplaySizeChanged | CEGUI::Renderer | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventNamespace | CEGUI::Renderer | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getCurrentZ(void) const | CEGUI::Renderer | [inline]
getHeight(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getHorzScreenDPI(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getIdentifierString() const | CEGUI::Renderer |
getIterator(void) const | CEGUI::EventSet |
getMaxTextureSize(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getRect(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getSize(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getVertScreenDPI(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getWidth(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
getZLayer(uint layer) const | CEGUI::Renderer | [inline]
grabTextures(void) | CEGUI::OpenGLRenderer |
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isQueueingEnabled(void) const | CEGUI::OpenGLRenderer | [inline, virtual]
OpenGLRenderer(uint max_quads) | CEGUI::OpenGLRenderer |
OpenGLRenderer(uint max_quads, int width, int height) (defined in CEGUI::OpenGLRenderer) | CEGUI::OpenGLRenderer |
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [protected]
resetZValue(void) | CEGUI::Renderer | [inline]
restoreTextures(void) | CEGUI::OpenGLRenderer |
setDisplaySize(const Size &sz) | CEGUI::OpenGLRenderer |
setMutedState(bool setting) | CEGUI::EventSet |
setQueueingEnabled(bool setting) | CEGUI::OpenGLRenderer | [inline, virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~OpenGLRenderer(void) | CEGUI::OpenGLRenderer | [virtual]
~Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::OpenGLTexture Member List

This is the complete list of members for CEGUI::OpenGLTexture, including all inherited members.

getHeight(void) const | CEGUI::OpenGLTexture | [inline, virtual]
getOGLTexid(void) const | CEGUI::OpenGLTexture | [inline]
getRenderer(void) const | CEGUI::Texture | [inline]
getWidth(void) const | CEGUI::OpenGLTexture | [inline, virtual]
grabTexture(void) | CEGUI::OpenGLTexture |
loadFromFile(const String &filename, const String &resourceGroup) | CEGUI::OpenGLTexture | [virtual]
loadFromMemory(const void *buffPtr, uint buffWidth, uint buffHeight) | CEGUI::OpenGLTexture | [virtual]
OpenGLRenderer::createTexture (defined in CEGUI::OpenGLTexture) | CEGUI::OpenGLTexture | [friend]
OpenGLRenderer::createTexture (defined in CEGUI::OpenGLTexture) | CEGUI::OpenGLTexture | [friend]
OpenGLRenderer::createTexture (defined in CEGUI::OpenGLTexture) | CEGUI::OpenGLTexture | [friend]
OpenGLRenderer::destroyTexture (defined in CEGUI::OpenGLTexture) | CEGUI::OpenGLTexture | [friend]
restoreTexture(void) | CEGUI::OpenGLTexture |
setOGLTextureSize(uint size) | CEGUI::OpenGLTexture |
Texture(Renderer *owner) | CEGUI::Texture | [inline, protected]
~Texture(void) | CEGUI::Texture | [inline, virtual]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PopupMenu Member List

This is the complete list of members for CEGUI::PopupMenu, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItem(ItemEntry *item) | CEGUI::ItemListBase |
addItemListBaseEvents(void) | CEGUI::ItemListBase | [protected]
addMenuBaseEvents(void) | CEGUI::MenuBase | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
changePopupMenuItem(MenuItem *item) | CEGUI::MenuBase |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
closePopupMenu(void) | CEGUI::PopupMenu |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_allowMultiplePopups | CEGUI::MenuBase | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoResize (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
d_backgroundColours | CEGUI::MenuBase | [protected]
d_borderWidth | CEGUI::MenuBase | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_fadeElapsed | CEGUI::PopupMenu | [protected]
d_fadeInTime | CEGUI::PopupMenu | [protected]
d_fadeOutTime | CEGUI::PopupMenu | [protected]
d_fading | CEGUI::PopupMenu | [protected]
d_fadingOut | CEGUI::PopupMenu | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzPadding | CEGUI::MenuBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_itemSpacing | CEGUI::MenuBase | [protected]
d_listItems | CEGUI::ItemListBase | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_origAlpha | CEGUI::PopupMenu | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_popup | CEGUI::MenuBase | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertPadding | CEGUI::MenuBase | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultBackgroundColour | CEGUI::MenuBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventListContentsChanged | CEGUI::ItemListBase | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::PopupMenu | [static]
EventParentSized | CEGUI::Window | [static]
EventPopupClosed | CEGUI::MenuBase | [static]
EventPopupOpened | CEGUI::MenuBase | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
findItemWithText(const String &text, const ItemEntry *start_item) | CEGUI::ItemListBase |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::MenuBase | [inline]
getBorderWidth(void) const | CEGUI::MenuBase | [inline]
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getContentSize(void) | CEGUI::PopupMenu | [protected, virtual]
getEffectiveAlpha(void) const | CEGUI::Window |
getFadeInTime(void) const | CEGUI::PopupMenu | [inline]
getFadeOutTime(void) const | CEGUI::PopupMenu | [inline]
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorzPadding(void) const | CEGUI::MenuBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemCount(void) const | CEGUI::ItemListBase | [inline]
getItemFromIndex(size_t index) const | CEGUI::ItemListBase |
getItemIndex(const ItemEntry *item) const | CEGUI::ItemListBase |
getItemRenderArea(void) const =0 | CEGUI::ItemListBase | [protected, pure virtual]
getItemSpacing(void) const | CEGUI::MenuBase | [inline]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPopupMenuItem(void) const | CEGUI::MenuBase | [inline]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVertPadding(void) const | CEGUI::MenuBase | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleUpdatedItemData(void) | CEGUI::ItemListBase |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::ItemListBase | [virtual]
insertItem(ItemEntry *item, const ItemEntry *position) | CEGUI::ItemListBase |
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isAutoResizeEnabled() const | CEGUI::ItemListBase | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isItemInList(const ItemEntry *item) const | CEGUI::ItemListBase |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMultiplePopupsAllowed(void) const | CEGUI::MenuBase | [inline]
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntryList typedef (defined in CEGUI::ItemListBase) | CEGUI::ItemListBase | [protected]
ItemListBase(const String &type, const String &name) | CEGUI::ItemListBase |
layoutItemWidgets(void) | CEGUI::PopupMenu | [protected, virtual]
MenuBase(const String &type, const String &name) | CEGUI::MenuBase |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::PopupMenu | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onListContentsChanged(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onPopupClosed(WindowEventArgs &e) | CEGUI::MenuBase | [protected, virtual]
onPopupOpened(WindowEventArgs &e) | CEGUI::MenuBase | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::ItemListBase | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
openPopupMenu(void) | CEGUI::PopupMenu |
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache()=0 | CEGUI::ItemListBase | [protected, pure virtual]
PopupMenu(const String &type, const String &name) | CEGUI::PopupMenu |
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeItem(ItemEntry *item) | CEGUI::ItemListBase |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetList(void) | CEGUI::ItemListBase |
resetList_impl(void) | CEGUI::ItemListBase | [protected]
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAllowMultiplePopups(bool setting) | CEGUI::MenuBase | [inline]
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setAutoResizeEnabled(bool setting) | CEGUI::ItemListBase |
setBackgroundColours(const ColourRect &cr) | CEGUI::MenuBase | [inline]
setBorderWidth(float border) | CEGUI::MenuBase | [inline]
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFadeInTime(float fadetime) | CEGUI::PopupMenu | [inline]
setFadeOutTime(float fadetime) | CEGUI::PopupMenu | [inline]
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorzPadding(float padding) | CEGUI::MenuBase | [inline]
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setItemSpacing(float spacing) | CEGUI::MenuBase | [inline]
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVertPadding(float padding) | CEGUI::MenuBase | [inline]
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
sizeToContent(void) | CEGUI::ItemListBase | [inline, virtual]
sizeToContent_impl(void)=0 | CEGUI::ItemListBase | [protected, pure virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::PopupMenu | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::PopupMenu | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemListBase(void) | CEGUI::ItemListBase | [virtual]
~MenuBase(void) | CEGUI::MenuBase | [virtual]
~PopupMenu(void) | CEGUI::PopupMenu | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PopupMenuProperties::FadeInTime Member List

This is the complete list of members for CEGUI::PopupMenuProperties::FadeInTime, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
FadeInTime() (defined in CEGUI::PopupMenuProperties::FadeInTime) | CEGUI::PopupMenuProperties::FadeInTime | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::PopupMenuProperties::FadeInTime | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PopupMenuProperties::FadeInTime | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PopupMenuProperties::FadeOutTime Member List

This is the complete list of members for CEGUI::PopupMenuProperties::FadeOutTime, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
FadeOutTime() (defined in CEGUI::PopupMenuProperties::FadeOutTime) | CEGUI::PopupMenuProperties::FadeOutTime | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::PopupMenuProperties::FadeOutTime | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PopupMenuProperties::FadeOutTime | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ProgressBar Member List

This is the complete list of members for CEGUI::ProgressBar, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProgressBarEvents(void) | CEGUI::ProgressBar | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
adjustProgress(float delta) | CEGUI::ProgressBar | [inline]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_progress | CEGUI::ProgressBar | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_step | CEGUI::ProgressBar | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::ProgressBar | [static]
EventParentSized | CEGUI::Window | [static]
EventProgressChanged | CEGUI::ProgressBar | [static]
EventProgressDone | CEGUI::ProgressBar | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProgress(void) const | CEGUI::ProgressBar | [inline]
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getStep(void) const | CEGUI::ProgressBar | [inline]
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onProgressChanged(WindowEventArgs &e) | CEGUI::ProgressBar | [protected, virtual]
onProgressDone(WindowEventArgs &e) | CEGUI::ProgressBar | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
ProgressBar(const String &type, const String &name) | CEGUI::ProgressBar |
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProgress(float progress) | CEGUI::ProgressBar |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setStepSize(float step_val) | CEGUI::ProgressBar | [inline]
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
step(void) | CEGUI::ProgressBar | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ProgressBar | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ProgressBar(void) | CEGUI::ProgressBar | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ProgressBarProperties::CurrentProgress Member List

This is the complete list of members for CEGUI::ProgressBarProperties::CurrentProgress, including all inherited members.

CurrentProgress() (defined in CEGUI::ProgressBarProperties::CurrentProgress) | CEGUI::ProgressBarProperties::CurrentProgress | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ProgressBarProperties::CurrentProgress | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ProgressBarProperties::CurrentProgress | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ProgressBarProperties::StepSize Member List

This is the complete list of members for CEGUI::ProgressBarProperties::StepSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ProgressBarProperties::StepSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ProgressBarProperties::StepSize | [virtual]
StepSize() (defined in CEGUI::ProgressBarProperties::StepSize) | CEGUI::ProgressBarProperties::StepSize | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Property Member List

This is the complete list of members for CEGUI::Property, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const =0 | CEGUI::Property | [pure virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value)=0 | CEGUI::Property | [pure virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PropertyDefinition Member List

This is the complete list of members for CEGUI::PropertyDefinition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_userStringName (defined in CEGUI::PropertyDefinition) | CEGUI::PropertyDefinition | [protected]
d_writeCausesLayout (defined in CEGUI::PropertyDefinition) | CEGUI::PropertyDefinition | [protected]
d_writeCausesRedraw (defined in CEGUI::PropertyDefinition) | CEGUI::PropertyDefinition | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::PropertyDefinition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
PropertyDefinition(const String &name, const String &initialValue, bool redrawOnWrite, bool layoutOnWrite) (defined in CEGUI::PropertyDefinition) | CEGUI::PropertyDefinition |
set(PropertyReceiver *receiver, const String &value) | CEGUI::PropertyDefinition | [virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::PropertyDefinition |
CEGUI::Property::writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PropertyDim Member List

This is the complete list of members for CEGUI::PropertyDim, including all inherited members.

BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const | CEGUI::PropertyDim | [protected, virtual]
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const | CEGUI::PropertyDim | [protected, virtual]
getValue_impl(const Window &wnd, const Rect &container) const | CEGUI::PropertyDim | [protected, virtual]
PropertyDim(const String &name, const String &property) | CEGUI::PropertyDim |
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const | CEGUI::PropertyDim | [protected, virtual]
writeXMLElementName_impl(OutStream &out_stream) const | CEGUI::PropertyDim | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PropertyHelper Member List

This is the complete list of members for CEGUI::PropertyHelper, including all inherited members.

boolToString(bool val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
colourRectToString(const ColourRect &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
colourToString(const colour &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
floatToString(float val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
imageToString(const Image *const val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
intToString(int val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
metricsModeToString(MetricsMode val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
pointToString(const Point &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
rectToString(const Rect &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
sizeToString(const Size &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToBool(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToColour(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToColourRect(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToFloat(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToImage(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToInt(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToMetricsMode(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToPoint(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToRect(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToSize(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToUDim(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToUint(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToURect(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
stringToUVector2(const String &str) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
udimToString(const UDim &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
uintToString(uint val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
urectToString(const URect &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]
uvector2ToString(const UVector2 &val) (defined in CEGUI::PropertyHelper) | CEGUI::PropertyHelper | [static]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PropertyInitialiser Member List

This is the complete list of members for CEGUI::PropertyInitialiser, including all inherited members.

apply(PropertySet &target) const | CEGUI::PropertyInitialiser
getInitialiserValue() const | CEGUI::PropertyInitialiser
getTargetPropertyName() const | CEGUI::PropertyInitialiser
PropertyInitialiser(const String &property, const String &value) | CEGUI::PropertyInitialiser
writeXMLToStream(OutStream &out_stream) const | CEGUI::PropertyInitialiser

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PropertyReceiver Member List

This is the complete list of members for CEGUI::PropertyReceiver, including all inherited members.

PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PropertySet Member List

This is the complete list of members for CEGUI::PropertySet, including all inherited members.

addProperty(Property *property) | CEGUI::PropertySet |
clearProperties(void) | CEGUI::PropertySet |
getIterator(void) const | CEGUI::PropertySet |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
removeProperty(const String &name) | CEGUI::PropertySet |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButton Member List

This is the complete list of members for CEGUI::PushButton, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addPushButtonEvents(void) | CEGUI::PushButton | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
ButtonBase(const String &type, const String &name) | CEGUI::ButtonBase |
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoscaleImages | CEGUI::PushButton | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledColour | CEGUI::ButtonBase | [protected]
d_disabledImage | CEGUI::PushButton | [protected]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverColour | CEGUI::ButtonBase | [protected]
d_hoverImage | CEGUI::PushButton | [protected]
d_hovering | CEGUI::ButtonBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalColour | CEGUI::ButtonBase | [protected]
d_normalImage | CEGUI::PushButton | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::ButtonBase | [protected]
d_pushedColour | CEGUI::ButtonBase | [protected]
d_pushedImage | CEGUI::PushButton | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_textXOffset | CEGUI::PushButton | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_useDisabledImage | CEGUI::PushButton | [protected]
d_useHoverImage | CEGUI::PushButton | [protected]
d_useNormalImage | CEGUI::PushButton | [protected]
d_usePushedImage | CEGUI::PushButton | [protected]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_useStandardImagery | CEGUI::PushButton | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledLabelColour | CEGUI::ButtonBase | [static]
DefaultHoverLabelColour | CEGUI::ButtonBase | [static]
DefaultNormalLabelColour | CEGUI::ButtonBase | [static]
DefaultPushedLabelColour | CEGUI::ButtonBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawDisabled(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawHover(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawNormal(float z)=0 | CEGUI::ButtonBase | [protected, pure virtual]
drawPushed(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawSelf(float z) | CEGUI::ButtonBase | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClicked | CEGUI::PushButton | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::PushButton | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledImage(void) const | CEGUI::PushButton |
getDisabledTextColour(void) const | CEGUI::ButtonBase | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverImage(void) const | CEGUI::PushButton |
getHoverTextColour(void) const | CEGUI::ButtonBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalImage(void) const | CEGUI::PushButton |
getNormalTextColour(void) const | CEGUI::ButtonBase | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedImage(void) const | CEGUI::PushButton |
getPushedTextColour(void) const | CEGUI::ButtonBase | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextXOffset(void) const | CEGUI::PushButton |
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isCustomImageryAutoSized(void) const | CEGUI::PushButton |
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHovering(void) const | CEGUI::ButtonBase | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::ButtonBase | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isStandardImageryEnabled(void) const | CEGUI::PushButton |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClicked(WindowEventArgs &e) | CEGUI::PushButton | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::PushButton | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::PushButton | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
PushButton(const String &type, const String &name) | CEGUI::PushButton |
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setCustomImageryAutoSized(bool setting) | CEGUI::PushButton |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledImage(const RenderableImage *image) | CEGUI::PushButton |
setDisabledTextColour(const colour &colour) | CEGUI::ButtonBase |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverImage(const RenderableImage *image) | CEGUI::PushButton |
setHoverTextColour(const colour &colour) | CEGUI::ButtonBase |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalImage(const RenderableImage *image) | CEGUI::PushButton |
setNormalTextColour(const colour &colour) | CEGUI::ButtonBase |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedImage(const RenderableImage *image) | CEGUI::PushButton |
setPushedTextColour(const colour &colour) | CEGUI::ButtonBase |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setStandardImageryEnabled(bool setting) | CEGUI::PushButton |
setText(const String &text) | CEGUI::Window |
setTextXOffset(float offset) | CEGUI::PushButton |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::PushButton | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::ButtonBase | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ButtonBase(void) | CEGUI::ButtonBase | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~PushButton(void) | CEGUI::PushButton | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButtonProperties::DisabledImage Member List

This is the complete list of members for CEGUI::PushButtonProperties::DisabledImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DisabledImage() (defined in CEGUI::PushButtonProperties::DisabledImage) | CEGUI::PushButtonProperties::DisabledImage | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::PushButtonProperties::DisabledImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PushButtonProperties::DisabledImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButtonProperties::HoverImage Member List

This is the complete list of members for CEGUI::PushButtonProperties::HoverImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::PushButtonProperties::HoverImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HoverImage() (defined in CEGUI::PushButtonProperties::HoverImage) | CEGUI::PushButtonProperties::HoverImage | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PushButtonProperties::HoverImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButtonProperties::NormalImage Member List

This is the complete list of members for CEGUI::PushButtonProperties::NormalImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::PushButtonProperties::NormalImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
NormalImage() (defined in CEGUI::PushButtonProperties::NormalImage) | CEGUI::PushButtonProperties::NormalImage | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PushButtonProperties::NormalImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButtonProperties::PushedImage Member List

This is the complete list of members for CEGUI::PushButtonProperties::PushedImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::PushButtonProperties::PushedImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
PushedImage() (defined in CEGUI::PushButtonProperties::PushedImage) | CEGUI::PushButtonProperties::PushedImage | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PushButtonProperties::PushedImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButtonProperties::TextXOffset Member List

This is the complete list of members for CEGUI::PushButtonProperties::TextXOffset, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::PushButtonProperties::TextXOffset | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PushButtonProperties::TextXOffset | [virtual]
TextXOffset() (defined in CEGUI::PushButtonProperties::TextXOffset) | CEGUI::PushButtonProperties::TextXOffset | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::PushButtonProperties::UseStandardImagery Member List

This is the complete list of members for CEGUI::PushButtonProperties::UseStandardImagery, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::PushButtonProperties::UseStandardImagery | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::PushButtonProperties::UseStandardImagery | [virtual]
UseStandardImagery() (defined in CEGUI::PushButtonProperties::UseStandardImagery) | CEGUI::PushButtonProperties::UseStandardImagery | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RadioButton Member List

This is the complete list of members for CEGUI::RadioButton, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addRadioButtonEvents(void) | CEGUI::RadioButton | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
ButtonBase(const String &type, const String &name) | CEGUI::ButtonBase |
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledColour | CEGUI::ButtonBase | [protected]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_groupID (defined in CEGUI::RadioButton) | CEGUI::RadioButton | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverColour | CEGUI::ButtonBase | [protected]
d_hovering | CEGUI::ButtonBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalColour | CEGUI::ButtonBase | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::ButtonBase | [protected]
d_pushedColour | CEGUI::ButtonBase | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_selected (defined in CEGUI::RadioButton) | CEGUI::RadioButton | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledLabelColour | CEGUI::ButtonBase | [static]
DefaultHoverLabelColour | CEGUI::ButtonBase | [static]
DefaultNormalLabelColour | CEGUI::ButtonBase | [static]
DefaultPushedLabelColour | CEGUI::ButtonBase | [static]
deselectOtherButtonsInGroup(void) const | CEGUI::RadioButton | [protected]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawDisabled(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawHover(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawNormal(float z)=0 | CEGUI::ButtonBase | [protected, pure virtual]
drawPushed(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawSelf(float z) | CEGUI::ButtonBase | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::RadioButton | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSelectStateChanged | CEGUI::RadioButton | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledTextColour(void) const | CEGUI::ButtonBase | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getGroupID(void) const | CEGUI::RadioButton | [inline]
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverTextColour(void) const | CEGUI::ButtonBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalTextColour(void) const | CEGUI::ButtonBase | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedTextColour(void) const | CEGUI::ButtonBase | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedButtonInGroup(void) const | CEGUI::RadioButton |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHovering(void) const | CEGUI::ButtonBase | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::ButtonBase | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSelected(void) const | CEGUI::RadioButton | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::RadioButton | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSelectStateChanged(WindowEventArgs &e) | CEGUI::RadioButton | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
RadioButton(const String &type, const String &name) (defined in CEGUI::RadioButton) | CEGUI::RadioButton |
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledTextColour(const colour &colour) | CEGUI::ButtonBase |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setGroupID(ulong group) | CEGUI::RadioButton |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverTextColour(const colour &colour) | CEGUI::ButtonBase |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalTextColour(const colour &colour) | CEGUI::ButtonBase |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedTextColour(const colour &colour) | CEGUI::ButtonBase |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelected(bool select) | CEGUI::RadioButton |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::RadioButton | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::ButtonBase | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ButtonBase(void) | CEGUI::ButtonBase | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~RadioButton(void) (defined in CEGUI::RadioButton) | CEGUI::RadioButton | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RadioButtonProperties::GroupID Member List

This is the complete list of members for CEGUI::RadioButtonProperties::GroupID, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::RadioButtonProperties::GroupID | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
GroupID() (defined in CEGUI::RadioButtonProperties::GroupID) | CEGUI::RadioButtonProperties::GroupID | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::RadioButtonProperties::GroupID | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RadioButtonProperties::Selected Member List

This is the complete list of members for CEGUI::RadioButtonProperties::Selected, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::RadioButtonProperties::Selected | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
Selected() (defined in CEGUI::RadioButtonProperties::Selected) | CEGUI::RadioButtonProperties::Selected | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::RadioButtonProperties::Selected | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Rect Member List

This is the complete list of members for CEGUI::Rect, including all inherited members.

constrainSize(const Size &max_sz, const Size &min_sz) | CEGUI::Rect |
constrainSizeMax(const Size &sz) | CEGUI::Rect |
constrainSizeMin(const Size &sz) | CEGUI::Rect |
d_bottom (defined in CEGUI::Rect) | CEGUI::Rect |
d_left (defined in CEGUI::Rect) | CEGUI::Rect |
d_right (defined in CEGUI::Rect) | CEGUI::Rect |
d_top (defined in CEGUI::Rect) | CEGUI::Rect |
getHeight(void) const | CEGUI::Rect | [inline]
getIntersection(const Rect &rect) const | CEGUI::Rect |
getPosition(void) const | CEGUI::Rect | [inline]
getSize(void) const | CEGUI::Rect | [inline]
getWidth(void) const | CEGUI::Rect | [inline]
isPointInRect(const Point &pt) const | CEGUI::Rect |
offset(const Point &pt) | CEGUI::Rect |
operator *(float scalar) const (defined in CEGUI::Rect) | CEGUI::Rect | [inline]
operator *=(float scalar) (defined in CEGUI::Rect) | CEGUI::Rect | [inline]
operator!=(const Rect &rhs) const (defined in CEGUI::Rect) | CEGUI::Rect | [inline]
operator=(const Rect &rhs) (defined in CEGUI::Rect) | CEGUI::Rect |
operator==(const Rect &rhs) const (defined in CEGUI::Rect) | CEGUI::Rect | [inline]
Rect(void) (defined in CEGUI::Rect) | CEGUI::Rect | [inline]
Rect(float left, float top, float right, float bottom) | CEGUI::Rect |
Rect(Point pos, Size sz) (defined in CEGUI::Rect) | CEGUI::Rect |
setHeight(float height) | CEGUI::Rect | [inline]
setPosition(const Point &pt) | CEGUI::Rect |
setSize(const Size &sze) | CEGUI::Rect | [inline]
setWidth(float width) | CEGUI::Rect | [inline]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RenderableFrame Member List

This is the complete list of members for CEGUI::RenderableFrame, including all inherited members.

d_bottom | CEGUI::RenderableFrame | [protected]
d_bottomleft | CEGUI::RenderableFrame | [protected]
d_bottomright | CEGUI::RenderableFrame | [protected]
d_left | CEGUI::RenderableFrame | [protected]
d_right | CEGUI::RenderableFrame | [protected]
d_top | CEGUI::RenderableFrame | [protected]
d_topleft | CEGUI::RenderableFrame | [protected]
d_topright | CEGUI::RenderableFrame | [protected]
draw_impl(const Vector3 &position, const Rect &clip_rect) const | CEGUI::RenderableFrame | [protected]
draw_impl(RenderCache &renderCache) const (defined in CEGUI::RenderableFrame) | CEGUI::RenderableFrame | [protected]
getImageForLocation(FrameLocation location) const | CEGUI::RenderableFrame |
RenderableFrame(void) | CEGUI::RenderableFrame |
setImageForLocation(FrameLocation location, const Image *image) | CEGUI::RenderableFrame |
setImages(const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom) | CEGUI::RenderableFrame |
~RenderableFrame(void) | CEGUI::RenderableFrame | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RenderableImage Member List

This is the complete list of members for CEGUI::RenderableImage, including all inherited members.

BottomAligned enum value | CEGUI::RenderableImage |
d_horzFormat | CEGUI::RenderableImage | [protected]
d_image | CEGUI::RenderableImage | [protected]
d_quadSplitMode | CEGUI::RenderableImage | [protected]
d_vertFormat | CEGUI::RenderableImage | [protected]
draw_impl(const Vector3 &position, const Rect &clip_rect) const | CEGUI::RenderableImage | [protected]
draw_impl(RenderCache &renderCache) const (defined in CEGUI::RenderableImage) | CEGUI::RenderableImage | [protected]
getBaseXCoord(const Size &sz) const | CEGUI::RenderableImage | [protected]
getBaseYCoord(const Size &sz) const | CEGUI::RenderableImage | [protected]
getDestinationSize() const | CEGUI::RenderableImage | [protected]
getHorzFormatting(void) const | CEGUI::RenderableImage | [inline]
getHorzTileCount() const | CEGUI::RenderableImage | [protected]
getImage(void) const | CEGUI::RenderableImage | [inline]
getQuadSplitMode(void) const | CEGUI::RenderableImage | [inline]
getVertFormatting(void) const | CEGUI::RenderableImage | [inline]
getVertTileCount() const | CEGUI::RenderableImage | [protected]
HorzCentred enum value | CEGUI::RenderableImage |
HorzFormatting enum name | CEGUI::RenderableImage |
HorzStretched enum value | CEGUI::RenderableImage |
HorzTiled enum value | CEGUI::RenderableImage |
LeftAligned enum value | CEGUI::RenderableImage |
RenderableImage(void) | CEGUI::RenderableImage |
RightAligned enum value | CEGUI::RenderableImage |
setHorzFormatting(HorzFormatting formatting) | CEGUI::RenderableImage | [inline]
setImage(const Image *image) | CEGUI::RenderableImage | [inline]
setQuadSplitMode(QuadSplitMode split_mode) | CEGUI::RenderableImage | [inline]
setVertFormatting(VertFormatting formatting) | CEGUI::RenderableImage | [inline]
TopAligned enum value | CEGUI::RenderableImage |
VertCentred enum value | CEGUI::RenderableImage |
VertFormatting enum name | CEGUI::RenderableImage |
VertStretched enum value | CEGUI::RenderableImage |
VertTiled enum value | CEGUI::RenderableImage |
~RenderableImage(void) | CEGUI::RenderableImage | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RenderCache Member List

This is the complete list of members for CEGUI::RenderCache, including all inherited members.

cacheImage(const Image &image, const Rect &destArea, float zOffset, const ColourRect &cols, const Rect *clipper=0, bool clipToDisplay=false) | CEGUI::RenderCache
cacheText(const String &text, const Font *font, TextFormatting format, const Rect &destArea, float zOffset, const ColourRect &cols, const Rect *clipper=0, bool clipToDisplay=false) | CEGUI::RenderCache
clearCachedImagery() | CEGUI::RenderCache
hasCachedImagery() const | CEGUI::RenderCache
render(const Point &basePos, float baseZ, const Rect &clipper) const | CEGUI::RenderCache
RenderCache() | CEGUI::RenderCache
~RenderCache() | CEGUI::RenderCache

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Renderer Member List

This is the complete list of members for CEGUI::Renderer, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
addQuad(const Rect &dest_rect, float z, const Texture *tex, const Rect &texture_rect, const ColourRect &colours, QuadSplitMode quad_split_mode)=0 | CEGUI::Renderer | [pure virtual]
advanceZValue(void) | CEGUI::Renderer | [inline]
clearRenderList(void)=0 | CEGUI::Renderer | [pure virtual]
createResourceProvider(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]
createTexture(void)=0 | CEGUI::Renderer | [pure virtual]
createTexture(const String &filename, const String &resourceGroup)=0 | CEGUI::Renderer | [pure virtual]
createTexture(float size)=0 | CEGUI::Renderer | [pure virtual]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_identifierString | CEGUI::Renderer | [protected]
d_muted | CEGUI::EventSet | [protected]
d_resourceProvider | CEGUI::Renderer | [protected]
destroyAllTextures(void)=0 | CEGUI::Renderer | [pure virtual]
destroyTexture(Texture *texture)=0 | CEGUI::Renderer | [pure virtual]
doRender(void)=0 | CEGUI::Renderer | [pure virtual]
EventDisplaySizeChanged | CEGUI::Renderer | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventNamespace | CEGUI::Renderer | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getCurrentZ(void) const | CEGUI::Renderer | [inline]
getHeight(void) const =0 | CEGUI::Renderer | [pure virtual]
getHorzScreenDPI(void) const =0 | CEGUI::Renderer | [pure virtual]
getIdentifierString() const | CEGUI::Renderer |
getIterator(void) const | CEGUI::EventSet |
getMaxTextureSize(void) const =0 | CEGUI::Renderer | [pure virtual]
getRect(void) const =0 | CEGUI::Renderer | [pure virtual]
getSize(void) const =0 | CEGUI::Renderer | [pure virtual]
getVertScreenDPI(void) const =0 | CEGUI::Renderer | [pure virtual]
getWidth(void) const =0 | CEGUI::Renderer | [pure virtual]
getZLayer(uint layer) const | CEGUI::Renderer | [inline]
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isQueueingEnabled(void) const =0 | CEGUI::Renderer | [pure virtual]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [protected]
resetZValue(void) | CEGUI::Renderer | [inline]
setMutedState(bool setting) | CEGUI::EventSet |
setQueueingEnabled(bool setting)=0 | CEGUI::Renderer | [pure virtual]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~Renderer(void) (defined in CEGUI::Renderer) | CEGUI::Renderer | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RendererException Member List

This is the complete list of members for CEGUI::RendererException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
RendererException(const String &message) (defined in CEGUI::RendererException) | CEGUI::RendererException | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ResourceProvider Member List

This is the complete list of members for CEGUI::ResourceProvider, including all inherited members.

d_defaultResourceGroup | CEGUI::ResourceProvider | [protected]
getDefaultResourceGroup(void) const | CEGUI::ResourceProvider | [inline]
loadRawDataContainer(const String &filename, RawDataContainer &output, const String &resourceGroup)=0 | CEGUI::ResourceProvider | [pure virtual]
ResourceProvider() | CEGUI::ResourceProvider | [inline]
setDefaultResourceGroup(const String &resourceGroup) | CEGUI::ResourceProvider | [inline]
unloadRawDataContainer(RawDataContainer &data) | CEGUI::ResourceProvider | [inline, virtual]
~ResourceProvider(void) | CEGUI::ResourceProvider | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Scheme Member List

This is the complete list of members for CEGUI::Scheme, including all inherited members.

getName(void) const | CEGUI::Scheme | [inline]
loadResources(void) | CEGUI::Scheme |
resourcesLoaded(void) const | CEGUI::Scheme |
Scheme_xmlHandler (defined in CEGUI::Scheme) | CEGUI::Scheme | [friend]
SchemeManager::loadScheme (defined in CEGUI::Scheme) | CEGUI::Scheme | [friend]
SchemeManager::unloadScheme (defined in CEGUI::Scheme) | CEGUI::Scheme | [friend]
unloadResources(void) | CEGUI::Scheme |
~Scheme(void) | CEGUI::Scheme |

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Scheme_xmlHandler Member List

This is the complete list of members for CEGUI::Scheme_xmlHandler, including all inherited members.

elementEnd(const String &element) (defined in CEGUI::Scheme_xmlHandler) | CEGUI::Scheme_xmlHandler | [virtual]
elementStart(const String &element, const XMLAttributes &attributes) | CEGUI::Scheme_xmlHandler | [virtual]
Scheme_xmlHandler(Scheme *scheme) | CEGUI::Scheme_xmlHandler | [inline]
~Scheme_xmlHandler(void) | CEGUI::Scheme_xmlHandler | [inline, virtual]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SchemeManager Member List

This is the complete list of members for CEGUI::SchemeManager, including all inherited members.

getIterator(void) const | CEGUI::SchemeManager |
getScheme(const String &name) const | CEGUI::SchemeManager |
getSingleton(void) | CEGUI::SchemeManager | [static]
getSingletonPtr(void) | CEGUI::SchemeManager | [static]
isSchemePresent(const String &scheme_name) const | CEGUI::SchemeManager | [inline]
loadScheme(const String &scheme_filename, const String &resourceGroup="") | CEGUI::SchemeManager |
SchemeIterator typedef (defined in CEGUI::SchemeManager) | CEGUI::SchemeManager |
SchemeManager(void) | CEGUI::SchemeManager |
unloadAllSchemes(void) | CEGUI::SchemeManager |
unloadScheme(const String &scheme_name) | CEGUI::SchemeManager |
~SchemeManager(void) | CEGUI::SchemeManager |

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScriptFunctor Member List

This is the complete list of members for CEGUI::ScriptFunctor, including all inherited members.

operator()(const EventArgs &e) const (defined in CEGUI::ScriptFunctor) | CEGUI::ScriptFunctor |
ScriptFunctor(const String &functionName) (defined in CEGUI::ScriptFunctor) | CEGUI::ScriptFunctor | [inline]
ScriptFunctor(const ScriptFunctor &obj) (defined in CEGUI::ScriptFunctor) | CEGUI::ScriptFunctor | [inline]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScriptModule Member List

This is the complete list of members for CEGUI::ScriptModule, including all inherited members.

createBindings(void) | CEGUI::ScriptModule | [inline, virtual]
d_identifierString | CEGUI::ScriptModule | [protected]
destroyBindings(void) | CEGUI::ScriptModule | [inline, virtual]
executeScriptedEventHandler(const String &handler_name, const EventArgs &e)=0 | CEGUI::ScriptModule | [pure virtual]
executeScriptFile(const String &filename, const String &resourceGroup="")=0 | CEGUI::ScriptModule | [pure virtual]
executeScriptGlobal(const String &function_name)=0 | CEGUI::ScriptModule | [pure virtual]
executeString(const String &str)=0 | CEGUI::ScriptModule | [pure virtual]
getIdentifierString() const | CEGUI::ScriptModule |
ScriptModule(void) | CEGUI::ScriptModule |
~ScriptModule(void) | CEGUI::ScriptModule | [inline, virtual]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePane Member List

This is the complete list of members for CEGUI::ScrollablePane, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::ScrollablePane | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addScrollablePaneEvents(void) | CEGUI::ScrollablePane | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
configureScrollbars(void) | CEGUI::ScrollablePane | [protected]
createHorizontalScrollbar(const String &name) const =0 | CEGUI::ScrollablePane | [protected, pure virtual]
createVerticalScrollbar(const String &name) const =0 | CEGUI::ScrollablePane | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_container | CEGUI::ScrollablePane | [protected]
d_contentRect | CEGUI::ScrollablePane | [protected]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_forceHorzScroll | CEGUI::ScrollablePane | [protected]
d_forceVertScroll | CEGUI::ScrollablePane | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzOverlap | CEGUI::ScrollablePane | [protected]
d_horzScrollbar | CEGUI::ScrollablePane | [protected]
d_horzStep | CEGUI::ScrollablePane | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertOverlap | CEGUI::ScrollablePane | [protected]
d_vertScrollbar | CEGUI::ScrollablePane | [protected]
d_vertStep | CEGUI::ScrollablePane | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventAutoSizeSettingChanged | CEGUI::ScrollablePane | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventContentPaneChanged | CEGUI::ScrollablePane | [static]
EventContentPaneScrolled | CEGUI::ScrollablePane | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHorzScrollbarModeChanged | CEGUI::ScrollablePane | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::ScrollablePane | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventVertScrollbarModeChanged | CEGUI::ScrollablePane | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getContentPane(void) const | CEGUI::ScrollablePane |
getContentPaneArea(void) const | CEGUI::ScrollablePane |
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorizontalOverlapSize(void) const | CEGUI::ScrollablePane |
getHorizontalScrollPosition(void) const | CEGUI::ScrollablePane |
getHorizontalStepSize(void) const | CEGUI::ScrollablePane |
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVerticalOverlapSize(void) const | CEGUI::ScrollablePane |
getVerticalScrollPosition(void) const | CEGUI::ScrollablePane |
getVerticalStepSize(void) const | CEGUI::ScrollablePane |
getViewableArea(void) const =0 | CEGUI::ScrollablePane | [protected, pure virtual]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleAutoSizePaneChanged(const EventArgs &e) | CEGUI::ScrollablePane | [protected]
handleContentAreaChange(const EventArgs &e) | CEGUI::ScrollablePane | [protected]
handleScrollChange(const EventArgs &e) | CEGUI::ScrollablePane | [protected]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::ScrollablePane | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isContentPaneAutoSized(void) const | CEGUI::ScrollablePane |
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHorzScrollbarAlwaysShown(void) const | CEGUI::ScrollablePane |
isHorzScrollbarNeeded(void) const | CEGUI::ScrollablePane | [protected]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVertScrollbarAlwaysShown(void) const | CEGUI::ScrollablePane |
isVertScrollbarNeeded(void) const | CEGUI::ScrollablePane | [protected]
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAutoSizeSettingChanged(WindowEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onContentPaneChanged(WindowEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onContentPaneScrolled(WindowEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorzScrollbarModeChanged(WindowEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVertScrollbarModeChanged(WindowEventArgs &e) | CEGUI::ScrollablePane | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::ScrollablePane | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
ScrollablePane(const String &type, const String &name) | CEGUI::ScrollablePane |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setContentPaneArea(const Rect &area) | CEGUI::ScrollablePane |
setContentPaneAutoSized(bool setting) | CEGUI::ScrollablePane |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorizontalOverlapSize(float overlap) | CEGUI::ScrollablePane |
setHorizontalScrollPosition(float position) | CEGUI::ScrollablePane |
setHorizontalStepSize(float step) | CEGUI::ScrollablePane |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setShowHorzScrollbar(bool setting) | CEGUI::ScrollablePane |
setShowVertScrollbar(bool setting) | CEGUI::ScrollablePane |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVerticalOverlapSize(float overlap) | CEGUI::ScrollablePane |
setVerticalScrollPosition(float position) | CEGUI::ScrollablePane |
setVerticalStepSize(float step) | CEGUI::ScrollablePane |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ScrollablePane | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateContainerPosition(void) | CEGUI::ScrollablePane | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~ScrollablePane(void) | CEGUI::ScrollablePane |
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::ContentArea Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::ContentArea, including all inherited members.

ContentArea() (defined in CEGUI::ScrollablePaneProperties::ContentArea) | CEGUI::ScrollablePaneProperties::ContentArea | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::ContentArea | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::ContentArea | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::ContentPaneAutoSized Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, including all inherited members.

ContentPaneAutoSized() (defined in CEGUI::ScrollablePaneProperties::ContentPaneAutoSized) | CEGUI::ScrollablePaneProperties::ContentPaneAutoSized | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::ContentPaneAutoSized | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::ContentPaneAutoSized | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::ForceHorzScrollbar Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceHorzScrollbar() (defined in CEGUI::ScrollablePaneProperties::ForceHorzScrollbar) | CEGUI::ScrollablePaneProperties::ForceHorzScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::ForceHorzScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::ForceHorzScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::ForceVertScrollbar Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::ForceVertScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
ForceVertScrollbar() (defined in CEGUI::ScrollablePaneProperties::ForceVertScrollbar) | CEGUI::ScrollablePaneProperties::ForceVertScrollbar | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::ForceVertScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::ForceVertScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::HorzOverlapSize Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::HorzOverlapSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::HorzOverlapSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzOverlapSize() (defined in CEGUI::ScrollablePaneProperties::HorzOverlapSize) | CEGUI::ScrollablePaneProperties::HorzOverlapSize | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::HorzOverlapSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::HorzScrollPosition Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::HorzScrollPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::HorzScrollPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzScrollPosition() (defined in CEGUI::ScrollablePaneProperties::HorzScrollPosition) | CEGUI::ScrollablePaneProperties::HorzScrollPosition | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::HorzScrollPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::HorzStepSize Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::HorzStepSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::HorzStepSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzStepSize() (defined in CEGUI::ScrollablePaneProperties::HorzStepSize) | CEGUI::ScrollablePaneProperties::HorzStepSize | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::HorzStepSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::VertOverlapSize Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::VertOverlapSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::VertOverlapSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::VertOverlapSize | [virtual]
VertOverlapSize() (defined in CEGUI::ScrollablePaneProperties::VertOverlapSize) | CEGUI::ScrollablePaneProperties::VertOverlapSize | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::VertScrollPosition Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::VertScrollPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::VertScrollPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::VertScrollPosition | [virtual]
VertScrollPosition() (defined in CEGUI::ScrollablePaneProperties::VertScrollPosition) | CEGUI::ScrollablePaneProperties::VertScrollPosition | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollablePaneProperties::VertStepSize Member List

This is the complete list of members for CEGUI::ScrollablePaneProperties::VertStepSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollablePaneProperties::VertStepSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollablePaneProperties::VertStepSize | [virtual]
VertStepSize() (defined in CEGUI::ScrollablePaneProperties::VertStepSize) | CEGUI::ScrollablePaneProperties::VertStepSize | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:14 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Scrollbar Member List

This is the complete list of members for CEGUI::Scrollbar, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addScrollbarEvents(void) | CEGUI::Scrollbar | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
createDecreaseButton(const String &name) const =0 | CEGUI::Scrollbar | [protected, pure virtual]
createIncreaseButton(const String &name) const =0 | CEGUI::Scrollbar | [protected, pure virtual]
createThumb(const String &name) const =0 | CEGUI::Scrollbar | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_decrease | CEGUI::Scrollbar | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_documentSize | CEGUI::Scrollbar | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_increase | CEGUI::Scrollbar | [protected]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_overlapSize | CEGUI::Scrollbar | [protected]
d_pageSize | CEGUI::Scrollbar | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_position | CEGUI::Scrollbar | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_stepSize | CEGUI::Scrollbar | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_thumb | CEGUI::Scrollbar | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Scrollbar | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventScrollConfigChanged | CEGUI::Scrollbar | [static]
EventScrollPositionChanged | CEGUI::Scrollbar | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventThumbTrackEnded | CEGUI::Scrollbar | [static]
EventThumbTrackStarted | CEGUI::Scrollbar | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAdjustDirectionFromPoint(const Point &pt) const =0 | CEGUI::Scrollbar | [protected, pure virtual]
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDocumentSize(void) const | CEGUI::Scrollbar | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getOverlapSize(void) const | CEGUI::Scrollbar | [inline]
getPageSize(void) const | CEGUI::Scrollbar | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getScrollPosition(void) const | CEGUI::Scrollbar | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getStepSize(void) const | CEGUI::Scrollbar | [inline]
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getValueFromThumb(void) const =0 | CEGUI::Scrollbar | [protected, pure virtual]
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleDecreaseClicked(const EventArgs &e) | CEGUI::Scrollbar | [protected]
handleIncreaseClicked(const EventArgs &e) | CEGUI::Scrollbar | [protected]
handleThumbMoved(const EventArgs &e) | CEGUI::Scrollbar | [protected]
handleThumbTrackEnded(const EventArgs &e) | CEGUI::Scrollbar | [protected]
handleThumbTrackStarted(const EventArgs &e) | CEGUI::Scrollbar | [protected]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Scrollbar | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Scrollbar | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Scrollbar | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onScrollConfigChanged(WindowEventArgs &e) | CEGUI::Scrollbar | [protected, virtual]
onScrollPositionChanged(WindowEventArgs &e) | CEGUI::Scrollbar | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onThumbTrackEnded(WindowEventArgs &e) | CEGUI::Scrollbar | [protected, virtual]
onThumbTrackStarted(WindowEventArgs &e) | CEGUI::Scrollbar | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
Scrollbar(const String &type, const String &name) | CEGUI::Scrollbar |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setDocumentSize(float document_size) | CEGUI::Scrollbar |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setOverlapSize(float overlap_size) | CEGUI::Scrollbar |
setPageSize(float page_size) | CEGUI::Scrollbar |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setScrollPosition(float position) | CEGUI::Scrollbar |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setStepSize(float step_size) | CEGUI::Scrollbar |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Scrollbar | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
updateThumb(void)=0 | CEGUI::Scrollbar | [protected, pure virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Scrollbar(void) | CEGUI::Scrollbar | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollbarProperties::DocumentSize Member List

This is the complete list of members for CEGUI::ScrollbarProperties::DocumentSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DocumentSize() (defined in CEGUI::ScrollbarProperties::DocumentSize) | CEGUI::ScrollbarProperties::DocumentSize | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollbarProperties::DocumentSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollbarProperties::DocumentSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollbarProperties::OverlapSize Member List

This is the complete list of members for CEGUI::ScrollbarProperties::OverlapSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollbarProperties::OverlapSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
OverlapSize() (defined in CEGUI::ScrollbarProperties::OverlapSize) | CEGUI::ScrollbarProperties::OverlapSize | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollbarProperties::OverlapSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollbarProperties::PageSize Member List

This is the complete list of members for CEGUI::ScrollbarProperties::PageSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollbarProperties::PageSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
PageSize() (defined in CEGUI::ScrollbarProperties::PageSize) | CEGUI::ScrollbarProperties::PageSize | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollbarProperties::PageSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollbarProperties::ScrollPosition Member List

This is the complete list of members for CEGUI::ScrollbarProperties::ScrollPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollbarProperties::ScrollPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
ScrollPosition() (defined in CEGUI::ScrollbarProperties::ScrollPosition) | CEGUI::ScrollbarProperties::ScrollPosition | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollbarProperties::ScrollPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrollbarProperties::StepSize Member List

This is the complete list of members for CEGUI::ScrollbarProperties::StepSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrollbarProperties::StepSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrollbarProperties::StepSize | [virtual]
StepSize() (defined in CEGUI::ScrollbarProperties::StepSize) | CEGUI::ScrollbarProperties::StepSize | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrolledContainer Member List

This is the complete list of members for CEGUI::ScrolledContainer, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addScrolledContainerEvents(void) | CEGUI::ScrolledContainer | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
ConnectionTracker typedef (defined in CEGUI::ScrolledContainer) | CEGUI::ScrolledContainer | [protected]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autosizePane | CEGUI::ScrolledContainer | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_contentArea | CEGUI::ScrolledContainer | [protected]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_eventConnections | CEGUI::ScrolledContainer | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::ScrolledContainer | [inline, protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventAutoSizeSettingChanged | CEGUI::ScrolledContainer | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventContentChanged | CEGUI::ScrolledContainer | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::ScrolledContainer | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getChildExtentsArea(void) const | CEGUI::ScrolledContainer |
getContentArea(void) const | CEGUI::ScrolledContainer |
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::ScrolledContainer | [protected, virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleChildMoved(const EventArgs &e) | CEGUI::ScrolledContainer | [protected]
handleChildSized(const EventArgs &e) | CEGUI::ScrolledContainer | [protected]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isContentPaneAutoSized(void) const | CEGUI::ScrolledContainer |
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAutoSizeSettingChanged(WindowEventArgs &e) | CEGUI::ScrolledContainer | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::ScrolledContainer | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::ScrolledContainer | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onContentChanged(WindowEventArgs &e) | CEGUI::ScrolledContainer | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::ScrolledContainer | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
ScrolledContainer(const String &type, const String &name) | CEGUI::ScrolledContainer |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setContentArea(const Rect &area) | CEGUI::ScrolledContainer |
setContentPaneAutoSized(bool setting) | CEGUI::ScrolledContainer |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::ScrolledContainer | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
WidgetTypeName | CEGUI::ScrolledContainer | [static]
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~ScrolledContainer(void) | CEGUI::ScrolledContainer |
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrolledContainerFactory Member List

This is the complete list of members for CEGUI::ScrolledContainerFactory, including all inherited members.

createWindow(const String &name) | CEGUI::ScrolledContainerFactory | [inline, virtual]
d_type | CEGUI::WindowFactory | [protected]
destroyWindow(Window *window) | CEGUI::ScrolledContainerFactory | [inline, virtual]
getTypeName(void) const | CEGUI::WindowFactory | [inline]
ScrolledContainerFactory(void) (defined in CEGUI::ScrolledContainerFactory) | CEGUI::ScrolledContainerFactory | [inline]
WindowFactory(const String &type) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, protected]
~ScrolledContainerFactory(void) (defined in CEGUI::ScrolledContainerFactory) | CEGUI::ScrolledContainerFactory | [inline]
~WindowFactory(void) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrolledContainerProperties::ChildExtentsArea Member List

This is the complete list of members for CEGUI::ScrolledContainerProperties::ChildExtentsArea, including all inherited members.

ChildExtentsArea() (defined in CEGUI::ScrolledContainerProperties::ChildExtentsArea) | CEGUI::ScrolledContainerProperties::ChildExtentsArea | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrolledContainerProperties::ChildExtentsArea | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrolledContainerProperties::ChildExtentsArea | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrolledContainerProperties::ContentArea Member List

This is the complete list of members for CEGUI::ScrolledContainerProperties::ContentArea, including all inherited members.

ContentArea() (defined in CEGUI::ScrolledContainerProperties::ContentArea) | CEGUI::ScrolledContainerProperties::ContentArea | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrolledContainerProperties::ContentArea | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrolledContainerProperties::ContentArea | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ScrolledContainerProperties::ContentPaneAutoSized Member List

This is the complete list of members for CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, including all inherited members.

ContentPaneAutoSized() (defined in CEGUI::ScrolledContainerProperties::ContentPaneAutoSized) | CEGUI::ScrolledContainerProperties::ContentPaneAutoSized | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ScrolledContainerProperties::ContentPaneAutoSized | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ScrolledContainerProperties::ContentPaneAutoSized | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SectionSpecification Member List

This is the complete list of members for CEGUI::SectionSpecification, including all inherited members.

getOverrideColours() const | CEGUI::SectionSpecification |
getOwnerWidgetLookFeel() const | CEGUI::SectionSpecification |
getSectionName() const | CEGUI::SectionSpecification |
initColourRectForOverride(const Window &wnd, ColourRect &cr) const | CEGUI::SectionSpecification | [protected]
isUsingOverrideColours() const | CEGUI::SectionSpecification |
render(Window &srcWindow, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::SectionSpecification |
render(Window &srcWindow, const Rect &baseRect, float base_z, const ColourRect *modcols=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::SectionSpecification |
SectionSpecification(const String &owner, const String &sectionName) | CEGUI::SectionSpecification |
SectionSpecification(const String &owner, const String &sectionName, const ColourRect &cols) | CEGUI::SectionSpecification |
setOverrideColours(const ColourRect &cols) | CEGUI::SectionSpecification |
setOverrideColoursPropertyIsColourRect(bool setting=true) | CEGUI::SectionSpecification |
setOverrideColoursPropertySource(const String &property) | CEGUI::SectionSpecification |
setUsingOverrideColours(bool setting=true) | CEGUI::SectionSpecification |
writeXMLToStream(OutStream &out_stream) const | CEGUI::SectionSpecification |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SimpleTimer Member List

This is the complete list of members for CEGUI::SimpleTimer, including all inherited members.

elapsed() (defined in CEGUI::SimpleTimer) | CEGUI::SimpleTimer | [inline]
restart() (defined in CEGUI::SimpleTimer) | CEGUI::SimpleTimer | [inline]
SimpleTimer() (defined in CEGUI::SimpleTimer) | CEGUI::SimpleTimer | [inline]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Size Member List

This is the complete list of members for CEGUI::Size, including all inherited members.

d_height (defined in CEGUI::Size) | CEGUI::Size |
d_width (defined in CEGUI::Size) | CEGUI::Size |
operator!=(const Size &other) const (defined in CEGUI::Size) | CEGUI::Size |
operator==(const Size &other) const (defined in CEGUI::Size) | CEGUI::Size |
Size(void) (defined in CEGUI::Size) | CEGUI::Size | [inline]
Size(float width, float height) (defined in CEGUI::Size) | CEGUI::Size | [inline]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Slider Member List

This is the complete list of members for CEGUI::Slider, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addSliderEvents(void) | CEGUI::Slider | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
createThumb(const String &name) const =0 | CEGUI::Slider | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_maxValue | CEGUI::Slider | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_step | CEGUI::Slider | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_thumb | CEGUI::Slider | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_value | CEGUI::Slider | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Slider | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventThumbTrackEnded | CEGUI::Slider | [static]
EventThumbTrackStarted | CEGUI::Slider | [static]
EventValueChanged | CEGUI::Slider | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAdjustDirectionFromPoint(const Point &pt) const =0 | CEGUI::Slider | [protected, pure virtual]
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getClickStep(void) const | CEGUI::Slider | [inline]
getCurrentValue(void) const | CEGUI::Slider | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMaxValue(void) const | CEGUI::Slider | [inline]
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getValueFromThumb(void) const =0 | CEGUI::Slider | [protected, pure virtual]
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleThumbMoved(const EventArgs &e) | CEGUI::Slider | [protected]
handleThumbTrackEnded(const EventArgs &e) | CEGUI::Slider | [protected]
handleThumbTrackStarted(const EventArgs &e) | CEGUI::Slider | [protected]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Slider | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Slider | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Slider | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onThumbTrackEnded(WindowEventArgs &e) | CEGUI::Slider | [protected, virtual]
onThumbTrackStarted(WindowEventArgs &e) | CEGUI::Slider | [protected, virtual]
onValueChanged(WindowEventArgs &e) | CEGUI::Slider | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClickStep(float step) | CEGUI::Slider | [inline]
setClippedByParent(bool setting) | CEGUI::Window |
setCurrentValue(float value) | CEGUI::Slider |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMaxValue(float maxVal) | CEGUI::Slider |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
Slider(const String &type, const String &name) | CEGUI::Slider |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Slider | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
updateThumb(void)=0 | CEGUI::Slider | [protected, pure virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Slider(void) | CEGUI::Slider | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:07 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SliderProperties::ClickStepSize Member List

This is the complete list of members for CEGUI::SliderProperties::ClickStepSize, including all inherited members.

ClickStepSize() (defined in CEGUI::SliderProperties::ClickStepSize) | CEGUI::SliderProperties::ClickStepSize | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SliderProperties::ClickStepSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SliderProperties::ClickStepSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SliderProperties::CurrentValue Member List

This is the complete list of members for CEGUI::SliderProperties::CurrentValue, including all inherited members.

CurrentValue() (defined in CEGUI::SliderProperties::CurrentValue) | CEGUI::SliderProperties::CurrentValue | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SliderProperties::CurrentValue | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SliderProperties::CurrentValue | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SliderProperties::MaximumValue Member List

This is the complete list of members for CEGUI::SliderProperties::MaximumValue, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SliderProperties::MaximumValue | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaximumValue() (defined in CEGUI::SliderProperties::MaximumValue) | CEGUI::SliderProperties::MaximumValue | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SliderProperties::MaximumValue | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:15 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Spinner Member List

This is the complete list of members for CEGUI::Spinner, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addSpinnerEvents(void) | CEGUI::Spinner | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
createDecreaseButton(const String &name) const =0 | CEGUI::Spinner | [protected, pure virtual]
createEditbox(const String &name) const =0 | CEGUI::Spinner | [protected, pure virtual]
createIncreaseButton(const String &name) const =0 | CEGUI::Spinner | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_currentValue | CEGUI::Spinner | [protected]
d_customTip | CEGUI::Window | [protected]
d_decreaseButton | CEGUI::Spinner | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_editbox | CEGUI::Spinner | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_increaseButton | CEGUI::Spinner | [protected]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inputMode | CEGUI::Spinner | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_maxValue | CEGUI::Spinner | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_minValue | CEGUI::Spinner | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_stepSize | CEGUI::Spinner | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMaximumValueChanged | CEGUI::Spinner | [static]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMinimumValueChanged | CEGUI::Spinner | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Spinner | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventStepChanged | CEGUI::Spinner | [static]
EventTextChanged | CEGUI::Window | [static]
EventTextInputModeChanged | CEGUI::Spinner | [static]
EventValueChanged | CEGUI::Spinner | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
FloatingPoint enum value | CEGUI::Spinner |
FloatValidator | CEGUI::Spinner | [protected, static]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getCurrentValue(void) const | CEGUI::Spinner |
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMaximumValue(void) const | CEGUI::Spinner |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getMinimumValue(void) const | CEGUI::Spinner |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getStepSize(void) const | CEGUI::Spinner |
getText(void) const | CEGUI::Window | [inline]
getTextFromValue(void) const | CEGUI::Spinner | [protected, virtual]
getTextInputMode(void) const | CEGUI::Spinner |
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getValueFromText(void) const | CEGUI::Spinner | [protected, virtual]
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleDecreaseButton(const EventArgs &e) (defined in CEGUI::Spinner) | CEGUI::Spinner | [protected]
handleEditTextChange(const EventArgs &e) (defined in CEGUI::Spinner) | CEGUI::Spinner | [protected]
handleIncreaseButton(const EventArgs &e) (defined in CEGUI::Spinner) | CEGUI::Spinner | [protected]
Hexadecimal enum value | CEGUI::Spinner |
HexValidator | CEGUI::Spinner | [protected, static]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Spinner | [virtual]
Integer enum value | CEGUI::Spinner |
IntegerValidator | CEGUI::Spinner | [protected, static]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
Octal enum value | CEGUI::Spinner |
OctalValidator | CEGUI::Spinner | [protected, static]
onActivated(ActivationEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMaximumValueChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMinimumValueChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onStepChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onTextInputModeChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onValueChanged(WindowEventArgs &e) | CEGUI::Spinner | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setCurrentValue(float value) | CEGUI::Spinner |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMaximumValue(float maxValue) | CEGUI::Spinner |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setMinimumValue(float minVaue) | CEGUI::Spinner |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setStepSize(float step) | CEGUI::Spinner |
setText(const String &text) | CEGUI::Window |
setTextInputMode(TextInputMode mode) | CEGUI::Spinner |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
Spinner(const String &type, const String &name) | CEGUI::Spinner |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Spinner | [inline, protected, virtual]
TextInputMode enum name | CEGUI::Spinner |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Spinner(void) | CEGUI::Spinner | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SpinnerProperties::CurrentValue Member List

This is the complete list of members for CEGUI::SpinnerProperties::CurrentValue, including all inherited members.

CurrentValue() (defined in CEGUI::SpinnerProperties::CurrentValue) | CEGUI::SpinnerProperties::CurrentValue | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SpinnerProperties::CurrentValue | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SpinnerProperties::CurrentValue | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SpinnerProperties::MaximumValue Member List

This is the complete list of members for CEGUI::SpinnerProperties::MaximumValue, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SpinnerProperties::MaximumValue | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MaximumValue() (defined in CEGUI::SpinnerProperties::MaximumValue) | CEGUI::SpinnerProperties::MaximumValue | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SpinnerProperties::MaximumValue | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SpinnerProperties::MinimumValue Member List

This is the complete list of members for CEGUI::SpinnerProperties::MinimumValue, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SpinnerProperties::MinimumValue | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MinimumValue() (defined in CEGUI::SpinnerProperties::MinimumValue) | CEGUI::SpinnerProperties::MinimumValue | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SpinnerProperties::MinimumValue | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SpinnerProperties::StepSize Member List

This is the complete list of members for CEGUI::SpinnerProperties::StepSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SpinnerProperties::StepSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SpinnerProperties::StepSize | [virtual]
StepSize() (defined in CEGUI::SpinnerProperties::StepSize) | CEGUI::SpinnerProperties::StepSize | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SpinnerProperties::TextInputMode Member List

This is the complete list of members for CEGUI::SpinnerProperties::TextInputMode, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::SpinnerProperties::TextInputMode | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::SpinnerProperties::TextInputMode | [virtual]
TextInputMode() (defined in CEGUI::SpinnerProperties::TextInputMode) | CEGUI::SpinnerProperties::TextInputMode | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StateImagery Member List

This is the complete list of members for CEGUI::StateImagery, including all inherited members.

addLayer(const LayerSpecification &layer) | CEGUI::StateImagery |
clearLayers() | CEGUI::StateImagery |
getName() const | CEGUI::StateImagery |
isClippedToDisplay() const | CEGUI::StateImagery |
render(Window &srcWindow, const ColourRect *modcols=0, const Rect *clipper=0) const | CEGUI::StateImagery |
render(Window &srcWindow, const Rect &baseRect, const ColourRect *modcols=0, const Rect *clipper=0) const | CEGUI::StateImagery |
setClippedToDisplay(bool setting) | CEGUI::StateImagery |
StateImagery() | CEGUI::StateImagery | [inline]
StateImagery(const String &name) | CEGUI::StateImagery |
writeXMLToStream(OutStream &out_stream) const | CEGUI::StateImagery |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Static Member List

This is the complete list of members for CEGUI::Static, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
calculateModulatedAlphaColour(const colour &col, float alpha) const | CEGUI::Static | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_background | CEGUI::Static | [protected]
d_backgroundCols | CEGUI::Static | [protected]
d_backgroundEnabled | CEGUI::Static | [protected]
d_bottom_height | CEGUI::Static | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_frame | CEGUI::Static | [protected]
d_frameCols | CEGUI::Static | [protected]
d_frameEnabled | CEGUI::Static | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_left_width | CEGUI::Static | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_right_width | CEGUI::Static | [protected]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_top_height | CEGUI::Static | [protected]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Static | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::Static | [inline]
getBackgroundImage(void) const | CEGUI::Static |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getFrameColours(void) const | CEGUI::Static | [inline]
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getImageForFrameLocation(FrameLocation location) const | CEGUI::Static |
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Static | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isBackgroundEnabled(void) const | CEGUI::Static | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isFrameEnabled(void) const | CEGUI::Static | [inline]
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Static | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Static | [protected, virtual]
onStaticFrameChanged(WindowEventArgs &e) | CEGUI::Static | [inline, protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Static | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setBackgroundColours(const ColourRect &colours) | CEGUI::Static |
setBackgroundColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setBackgroundColours(const colour &col) | CEGUI::Static | [inline]
setBackgroundEnabled(bool setting) | CEGUI::Static |
setBackgroundImage(const Image *image) | CEGUI::Static |
setBackgroundImage(const String &imageset, const String &image) | CEGUI::Static |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setFrameColours(const ColourRect &colours) | CEGUI::Static |
setFrameColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setFrameColours(const colour &col) | CEGUI::Static | [inline]
setFrameEnabled(bool setting) | CEGUI::Static |
setFrameImages(const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom) | CEGUI::Static |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setImageForFrameLocation(FrameLocation location, const Image *image) | CEGUI::Static |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
Static(const String &type, const String &name) | CEGUI::Static |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Static | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateRenderableFrameColours(void) | CEGUI::Static | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Static(void) | CEGUI::Static | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticImage Member List

This is the complete list of members for CEGUI::StaticImage, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
BottomAligned enum value | CEGUI::StaticImage |
calculateModulatedAlphaColour(const colour &col, float alpha) const | CEGUI::Static | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_background | CEGUI::Static | [protected]
d_backgroundCols | CEGUI::Static | [protected]
d_backgroundEnabled | CEGUI::Static | [protected]
d_bottom_height | CEGUI::Static | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_frame | CEGUI::Static | [protected]
d_frameCols | CEGUI::Static | [protected]
d_frameEnabled | CEGUI::Static | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_image | CEGUI::StaticImage | [protected]
d_imageCols | CEGUI::StaticImage | [protected]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_left_width | CEGUI::Static | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_right_width | CEGUI::Static | [protected]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_top_height | CEGUI::Static | [protected]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::StaticImage | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::Static | [inline]
getBackgroundImage(void) const | CEGUI::Static |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getFrameColours(void) const | CEGUI::Static | [inline]
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorizontalFormatting(void) const | CEGUI::StaticImage | [inline]
getID(void) const | CEGUI::Window | [inline]
getImage(void) const | CEGUI::StaticImage | [inline]
getImageColours(void) const | CEGUI::StaticImage | [inline]
getImageForFrameLocation(FrameLocation location) const | CEGUI::Static |
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Static | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVerticalFormatting(void) const | CEGUI::StaticImage | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
HorzCentred enum value | CEGUI::StaticImage |
HorzFormatting enum name | CEGUI::StaticImage |
HorzStretched enum value | CEGUI::StaticImage |
HorzTiled enum value | CEGUI::StaticImage |
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isBackgroundEnabled(void) const | CEGUI::Static | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isFrameEnabled(void) const | CEGUI::Static | [inline]
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
LeftAligned enum value | CEGUI::StaticImage |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::StaticImage | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::StaticImage | [protected, virtual]
onStaticFrameChanged(WindowEventArgs &e) | CEGUI::StaticImage | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::StaticImage | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
RightAligned enum value | CEGUI::StaticImage |
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setBackgroundColours(const ColourRect &colours) | CEGUI::Static |
setBackgroundColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setBackgroundColours(const colour &col) | CEGUI::Static | [inline]
setBackgroundEnabled(bool setting) | CEGUI::Static |
setBackgroundImage(const Image *image) | CEGUI::Static |
setBackgroundImage(const String &imageset, const String &image) | CEGUI::Static |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setFormatting(HorzFormatting h_fmt, VertFormatting v_fmt) | CEGUI::StaticImage |
setFrameColours(const ColourRect &colours) | CEGUI::Static |
setFrameColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setFrameColours(const colour &col) | CEGUI::Static | [inline]
setFrameEnabled(bool setting) | CEGUI::Static |
setFrameImages(const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom) | CEGUI::Static |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorizontalFormatting(HorzFormatting h_fmt) | CEGUI::StaticImage |
setID(uint ID) | CEGUI::Window |
setImage(const Image *image) | CEGUI::StaticImage |
setImage(const String &imageset, const String &image) | CEGUI::StaticImage |
setImageColours(const ColourRect &colours) | CEGUI::StaticImage |
setImageColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::StaticImage |
setImageColours(const colour &col) | CEGUI::StaticImage | [inline]
setImageForFrameLocation(FrameLocation location, const Image *image) | CEGUI::Static |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVerticalFormatting(VertFormatting v_fmt) | CEGUI::StaticImage |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
Static(const String &type, const String &name) | CEGUI::Static |
StaticImage(const String &type, const String &name) | CEGUI::StaticImage |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::StaticImage | [inline, protected, virtual]
TopAligned enum value | CEGUI::StaticImage |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateRenderableFrameColours(void) | CEGUI::Static | [protected]
updateRenderableImageColours(void) | CEGUI::StaticImage | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
VertCentred enum value | CEGUI::StaticImage |
VertFormatting enum name | CEGUI::StaticImage |
VertStretched enum value | CEGUI::StaticImage |
VertTiled enum value | CEGUI::StaticImage |
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Static(void) | CEGUI::Static | [virtual]
~StaticImage(void) | CEGUI::StaticImage | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticImageProperties::HorzFormatting Member List

This is the complete list of members for CEGUI::StaticImageProperties::HorzFormatting, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticImageProperties::HorzFormatting | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzFormatting() (defined in CEGUI::StaticImageProperties::HorzFormatting) | CEGUI::StaticImageProperties::HorzFormatting | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticImageProperties::HorzFormatting | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticImageProperties::Image Member List

This is the complete list of members for CEGUI::StaticImageProperties::Image, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticImageProperties::Image | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
Image() (defined in CEGUI::StaticImageProperties::Image) | CEGUI::StaticImageProperties::Image | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticImageProperties::Image | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticImageProperties::ImageColours Member List

This is the complete list of members for CEGUI::StaticImageProperties::ImageColours, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticImageProperties::ImageColours | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
ImageColours() (defined in CEGUI::StaticImageProperties::ImageColours) | CEGUI::StaticImageProperties::ImageColours | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticImageProperties::ImageColours | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticImageProperties::VertFormatting Member List

This is the complete list of members for CEGUI::StaticImageProperties::VertFormatting, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticImageProperties::VertFormatting | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticImageProperties::VertFormatting | [virtual]
VertFormatting() (defined in CEGUI::StaticImageProperties::VertFormatting) | CEGUI::StaticImageProperties::VertFormatting | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::BackgroundColours Member List

This is the complete list of members for CEGUI::StaticProperties::BackgroundColours, including all inherited members.

BackgroundColours() (defined in CEGUI::StaticProperties::BackgroundColours) | CEGUI::StaticProperties::BackgroundColours | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::BackgroundColours | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::BackgroundColours | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::BackgroundEnabled Member List

This is the complete list of members for CEGUI::StaticProperties::BackgroundEnabled, including all inherited members.

BackgroundEnabled() (defined in CEGUI::StaticProperties::BackgroundEnabled) | CEGUI::StaticProperties::BackgroundEnabled | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::BackgroundEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::BackgroundEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::BackgroundImage Member List

This is the complete list of members for CEGUI::StaticProperties::BackgroundImage, including all inherited members.

BackgroundImage() (defined in CEGUI::StaticProperties::BackgroundImage) | CEGUI::StaticProperties::BackgroundImage | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::BackgroundImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::BackgroundImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::BottomFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::BottomFrameImage, including all inherited members.

BottomFrameImage() (defined in CEGUI::StaticProperties::BottomFrameImage) | CEGUI::StaticProperties::BottomFrameImage | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::BottomFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::BottomFrameImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::BottomLeftFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::BottomLeftFrameImage, including all inherited members.

BottomLeftFrameImage() (defined in CEGUI::StaticProperties::BottomLeftFrameImage) | CEGUI::StaticProperties::BottomLeftFrameImage | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::BottomLeftFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::BottomLeftFrameImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::BottomRightFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::BottomRightFrameImage, including all inherited members.

BottomRightFrameImage() (defined in CEGUI::StaticProperties::BottomRightFrameImage) | CEGUI::StaticProperties::BottomRightFrameImage | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::BottomRightFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::BottomRightFrameImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::FrameColours Member List

This is the complete list of members for CEGUI::StaticProperties::FrameColours, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
FrameColours() (defined in CEGUI::StaticProperties::FrameColours) | CEGUI::StaticProperties::FrameColours | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::FrameColours | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::FrameColours | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::FrameEnabled Member List

This is the complete list of members for CEGUI::StaticProperties::FrameEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
FrameEnabled() (defined in CEGUI::StaticProperties::FrameEnabled) | CEGUI::StaticProperties::FrameEnabled | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::FrameEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::FrameEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:16 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::LeftFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::LeftFrameImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::LeftFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
LeftFrameImage() (defined in CEGUI::StaticProperties::LeftFrameImage) | CEGUI::StaticProperties::LeftFrameImage | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::LeftFrameImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::RightFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::RightFrameImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::RightFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RightFrameImage() (defined in CEGUI::StaticProperties::RightFrameImage) | CEGUI::StaticProperties::RightFrameImage | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::RightFrameImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::TopFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::TopFrameImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::TopFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::TopFrameImage | [virtual]
TopFrameImage() (defined in CEGUI::StaticProperties::TopFrameImage) | CEGUI::StaticProperties::TopFrameImage | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::TopLeftFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::TopLeftFrameImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::TopLeftFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::TopLeftFrameImage | [virtual]
TopLeftFrameImage() (defined in CEGUI::StaticProperties::TopLeftFrameImage) | CEGUI::StaticProperties::TopLeftFrameImage | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticProperties::TopRightFrameImage Member List

This is the complete list of members for CEGUI::StaticProperties::TopRightFrameImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticProperties::TopRightFrameImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticProperties::TopRightFrameImage | [virtual]
TopRightFrameImage() (defined in CEGUI::StaticProperties::TopRightFrameImage) | CEGUI::StaticProperties::TopRightFrameImage | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticText Member List

This is the complete list of members for CEGUI::StaticText, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
BottomAligned enum value | CEGUI::StaticText |
calculateModulatedAlphaColour(const colour &col, float alpha) const | CEGUI::Static | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
configureScrollbars(void) | CEGUI::StaticText | [protected]
createHorzScrollbar(const String &name) const =0 | CEGUI::StaticText | [protected, pure virtual]
createVertScrollbar(const String &name) const =0 | CEGUI::StaticText | [protected, pure virtual]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_background | CEGUI::Static | [protected]
d_backgroundCols | CEGUI::Static | [protected]
d_backgroundEnabled | CEGUI::Static | [protected]
d_bottom_height | CEGUI::Static | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_enableHorzScrollbar | CEGUI::StaticText | [protected]
d_enableVertScrollbar | CEGUI::StaticText | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_frame | CEGUI::Static | [protected]
d_frameCols | CEGUI::Static | [protected]
d_frameEnabled | CEGUI::Static | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzFormatting | CEGUI::StaticText | [protected]
d_horzScrollbar | CEGUI::StaticText | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_left_width | CEGUI::Static | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_right_width | CEGUI::Static | [protected]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textCols | CEGUI::StaticText | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_top_height | CEGUI::Static | [protected]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertFormatting | CEGUI::StaticText | [protected]
d_vertScrollbar | CEGUI::StaticText | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::StaticText | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::Static | [inline]
getBackgroundImage(void) const | CEGUI::Static |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getFrameColours(void) const | CEGUI::Static | [inline]
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorizontalFormatting(void) const | CEGUI::StaticText | [inline]
getID(void) const | CEGUI::Window | [inline]
getImageForFrameLocation(FrameLocation location) const | CEGUI::Static |
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextColours(void) const | CEGUI::StaticText | [inline]
getTextRenderArea(void) const | CEGUI::StaticText | [protected, virtual]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::StaticText | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVerticalFormatting(void) const | CEGUI::StaticText | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleScrollbarChange(const EventArgs &e) (defined in CEGUI::StaticText) | CEGUI::StaticText | [protected]
hide(void) | CEGUI::Window | [inline]
HorzCentred enum value | CEGUI::StaticText |
HorzFormatting enum name | CEGUI::StaticText |
HorzJustified enum value | CEGUI::StaticText |
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::StaticText | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isBackgroundEnabled(void) const | CEGUI::Static | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isFrameEnabled(void) const | CEGUI::Static | [inline]
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHorizontalScrollbarEnabled(void) const | CEGUI::StaticText |
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVerticalScrollbarEnabled(void) const | CEGUI::StaticText |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
LeftAligned enum value | CEGUI::StaticText |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Static | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::StaticText | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::StaticText | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::StaticText | [protected, virtual]
onStaticFrameChanged(WindowEventArgs &e) | CEGUI::Static | [inline, protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::StaticText | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::StaticText | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
RightAligned enum value | CEGUI::StaticText |
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setBackgroundColours(const ColourRect &colours) | CEGUI::Static |
setBackgroundColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setBackgroundColours(const colour &col) | CEGUI::Static | [inline]
setBackgroundEnabled(bool setting) | CEGUI::Static |
setBackgroundImage(const Image *image) | CEGUI::Static |
setBackgroundImage(const String &imageset, const String &image) | CEGUI::Static |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setFormatting(HorzFormatting h_fmt, VertFormatting v_fmt) | CEGUI::StaticText |
setFrameColours(const ColourRect &colours) | CEGUI::Static |
setFrameColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setFrameColours(const colour &col) | CEGUI::Static | [inline]
setFrameEnabled(bool setting) | CEGUI::Static |
setFrameImages(const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom) | CEGUI::Static |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorizontalFormatting(HorzFormatting h_fmt) | CEGUI::StaticText |
setHorizontalScrollbarEnabled(bool setting) | CEGUI::StaticText |
setID(uint ID) | CEGUI::Window |
setImageForFrameLocation(FrameLocation location, const Image *image) | CEGUI::Static |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTextColours(const ColourRect &colours) | CEGUI::StaticText |
setTextColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::StaticText |
setTextColours(const colour &col) | CEGUI::StaticText | [inline]
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVerticalFormatting(VertFormatting v_fmt) | CEGUI::StaticText |
setVerticalScrollbarEnabled(bool setting) | CEGUI::StaticText |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
Static(const String &type, const String &name) | CEGUI::Static |
StaticText(const String &type, const String &name) | CEGUI::StaticText |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::StaticText | [inline, protected, virtual]
TopAligned enum value | CEGUI::StaticText |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateRenderableFrameColours(void) | CEGUI::Static | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
VertCentred enum value | CEGUI::StaticText |
VertFormatting enum name | CEGUI::StaticText |
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
WordWrapCentred enum value | CEGUI::StaticText |
WordWrapJustified enum value | CEGUI::StaticText |
WordWrapLeftAligned enum value | CEGUI::StaticText |
WordWrapRightAligned enum value | CEGUI::StaticText |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Static(void) | CEGUI::Static | [virtual]
~StaticText(void) | CEGUI::StaticText | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticTextProperties::HorzFormatting Member List

This is the complete list of members for CEGUI::StaticTextProperties::HorzFormatting, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticTextProperties::HorzFormatting | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzFormatting() (defined in CEGUI::StaticTextProperties::HorzFormatting) | CEGUI::StaticTextProperties::HorzFormatting | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticTextProperties::HorzFormatting | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticTextProperties::HorzScrollbar Member List

This is the complete list of members for CEGUI::StaticTextProperties::HorzScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticTextProperties::HorzScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzScrollbar() (defined in CEGUI::StaticTextProperties::HorzScrollbar) | CEGUI::StaticTextProperties::HorzScrollbar | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticTextProperties::HorzScrollbar | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticTextProperties::TextColours Member List

This is the complete list of members for CEGUI::StaticTextProperties::TextColours, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticTextProperties::TextColours | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticTextProperties::TextColours | [virtual]
TextColours() (defined in CEGUI::StaticTextProperties::TextColours) | CEGUI::StaticTextProperties::TextColours | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticTextProperties::VertFormatting Member List

This is the complete list of members for CEGUI::StaticTextProperties::VertFormatting, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticTextProperties::VertFormatting | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticTextProperties::VertFormatting | [virtual]
VertFormatting() (defined in CEGUI::StaticTextProperties::VertFormatting) | CEGUI::StaticTextProperties::VertFormatting | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::StaticTextProperties::VertScrollbar Member List

This is the complete list of members for CEGUI::StaticTextProperties::VertScrollbar, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::StaticTextProperties::VertScrollbar | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::StaticTextProperties::VertScrollbar | [virtual]
VertScrollbar() (defined in CEGUI::StaticTextProperties::VertScrollbar) | CEGUI::StaticTextProperties::VertScrollbar | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::String Member List

This is the complete list of members for CEGUI::String, including all inherited members.

append(const String &str, size_type str_idx=0, size_type str_num=npos) | CEGUI::String | [inline]
append(const std::string &std_str, size_type str_idx=0, size_type str_num=npos) | CEGUI::String | [inline]
append(const utf8 *utf8_str) | CEGUI::String | [inline]
append(const utf8 *utf8_str, size_type len) | CEGUI::String | [inline]
append(size_type num, utf32 code_point) | CEGUI::String | [inline]
append(const_iterator iter_beg, const_iterator iter_end) | CEGUI::String | [inline]
append(const char *cstr) | CEGUI::String | [inline]
append(const char *chars, size_type chars_len) | CEGUI::String | [inline]
assign(const String &str, size_type str_idx=0, size_type str_num=npos) | CEGUI::String | [inline]
assign(const std::string &std_str, size_type str_idx=0, size_type str_num=npos) | CEGUI::String | [inline]
assign(const utf8 *utf8_str) | CEGUI::String | [inline]
assign(const utf8 *utf8_str, size_type str_num) | CEGUI::String | [inline]
assign(size_type num, utf32 code_point) | CEGUI::String | [inline]
assign(const char *cstr) | CEGUI::String | [inline]
assign(const char *chars, size_type chars_len) | CEGUI::String | [inline]
at(size_type idx) | CEGUI::String | [inline]
at(size_type idx) const | CEGUI::String | [inline]
begin(void) | CEGUI::String | [inline]
begin(void) const | CEGUI::String | [inline]
c_str(void) const | CEGUI::String | [inline]
capacity(void) const | CEGUI::String | [inline]
clear(void) | CEGUI::String | [inline]
compare(const String &str) const | CEGUI::String | [inline]
compare(size_type idx, size_type len, const String &str, size_type str_idx=0, size_type str_len=npos) const | CEGUI::String | [inline]
compare(const std::string &std_str) const | CEGUI::String | [inline]
compare(size_type idx, size_type len, const std::string &std_str, size_type str_idx=0, size_type str_len=npos) const | CEGUI::String | [inline]
compare(const utf8 *utf8_str) const | CEGUI::String | [inline]
compare(size_type idx, size_type len, const utf8 *utf8_str) const | CEGUI::String | [inline]
compare(size_type idx, size_type len, const utf8 *utf8_str, size_type str_cplen) const | CEGUI::String | [inline]
compare(const char *cstr) const | CEGUI::String | [inline]
compare(size_type idx, size_type len, const char *cstr) const | CEGUI::String | [inline]
compare(size_type idx, size_type len, const char *chars, size_type chars_len) const | CEGUI::String | [inline]
const_pointer typedef | CEGUI::String |
const_reference typedef | CEGUI::String |
const_reverse_iterator typedef | CEGUI::String |
copy(utf8 *buf, size_type len=npos, size_type idx=0) const | CEGUI::String | [inline]
data(void) const | CEGUI::String | [inline]
difference_type typedef | CEGUI::String |
empty(void) const | CEGUI::String | [inline]
end(void) | CEGUI::String | [inline]
end(void) const | CEGUI::String | [inline]
erase(void) | CEGUI::String | [inline]
erase(size_type idx) | CEGUI::String | [inline]
erase(size_type idx, size_type len=npos) | CEGUI::String | [inline]
erase(iterator pos) | CEGUI::String | [inline]
erase(iterator iter_beg, iterator iter_end) | CEGUI::String | [inline]
find(utf32 code_point, size_type idx=0) const | CEGUI::String | [inline]
find(const String &str, size_type idx=0) const | CEGUI::String | [inline]
find(const std::string &std_str, size_type idx=0) const | CEGUI::String | [inline]
find(const utf8 *utf8_str, size_type idx=0) const | CEGUI::String | [inline]
find(const utf8 *utf8_str, size_type idx, size_type str_len) const | CEGUI::String | [inline]
find(const char *cstr, size_type idx=0) const | CEGUI::String | [inline]
find(const char *chars, size_type idx, size_type chars_len) const | CEGUI::String | [inline]
find_first_not_of(const String &str, size_type idx=0) const | CEGUI::String | [inline]
find_first_not_of(const std::string &std_str, size_type idx=0) const | CEGUI::String | [inline]
find_first_not_of(const utf8 *utf8_str, size_type idx=0) const | CEGUI::String | [inline]
find_first_not_of(const utf8 *utf8_str, size_type idx, size_type str_len) const | CEGUI::String | [inline]
find_first_not_of(utf32 code_point, size_type idx=0) const | CEGUI::String | [inline]
find_first_not_of(const char *cstr, size_type idx=0) const | CEGUI::String | [inline]
find_first_not_of(const char *chars, size_type idx, size_type chars_len) const | CEGUI::String | [inline]
find_first_of(const String &str, size_type idx=0) const | CEGUI::String | [inline]
find_first_of(const std::string &std_str, size_type idx=0) const | CEGUI::String | [inline]
find_first_of(const utf8 *utf8_str, size_type idx=0) const | CEGUI::String | [inline]
find_first_of(const utf8 *utf8_str, size_type idx, size_type str_len) const | CEGUI::String | [inline]
find_first_of(utf32 code_point, size_type idx=0) const | CEGUI::String | [inline]
find_first_of(const char *cstr, size_type idx=0) const | CEGUI::String | [inline]
find_first_of(const char *chars, size_type idx, size_type chars_len) const | CEGUI::String | [inline]
find_last_not_of(const String &str, size_type idx=npos) const | CEGUI::String | [inline]
find_last_not_of(const std::string &std_str, size_type idx=npos) const | CEGUI::String | [inline]
find_last_not_of(const utf8 *utf8_str, size_type idx=npos) const | CEGUI::String | [inline]
find_last_not_of(const utf8 *utf8_str, size_type idx, size_type str_len) const | CEGUI::String | [inline]
find_last_not_of(utf32 code_point, size_type idx=npos) const | CEGUI::String | [inline]
find_last_not_of(const char *cstr, size_type idx=npos) const | CEGUI::String | [inline]
find_last_not_of(const char *chars, size_type idx, size_type chars_len) const | CEGUI::String | [inline]
find_last_of(const String &str, size_type idx=npos) const | CEGUI::String | [inline]
find_last_of(const std::string &std_str, size_type idx=npos) const | CEGUI::String | [inline]
find_last_of(const utf8 *utf8_str, size_type idx=npos) const | CEGUI::String | [inline]
find_last_of(const utf8 *utf8_str, size_type idx, size_type str_len) const | CEGUI::String | [inline]
find_last_of(utf32 code_point, size_type idx=npos) const | CEGUI::String | [inline]
find_last_of(const char *cstr, size_type idx=npos) const | CEGUI::String | [inline]
find_last_of(const char *chars, size_type idx, size_type chars_len) const | CEGUI::String | [inline]
insert(size_type idx, const String &str) | CEGUI::String | [inline]
insert(size_type idx, const String &str, size_type str_idx, size_type str_num) | CEGUI::String | [inline]
insert(size_type idx, const std::string &std_str) | CEGUI::String | [inline]
insert(size_type idx, const std::string &std_str, size_type str_idx, size_type str_num) | CEGUI::String | [inline]
insert(size_type idx, const utf8 *utf8_str) | CEGUI::String | [inline]
insert(size_type idx, const utf8 *utf8_str, size_type len) | CEGUI::String | [inline]
insert(size_type idx, size_type num, utf32 code_point) | CEGUI::String | [inline]
insert(iterator pos, size_type num, utf32 code_point) | CEGUI::String | [inline]
insert(iterator pos, utf32 code_point) | CEGUI::String | [inline]
insert(iterator iter_pos, const_iterator iter_beg, const_iterator iter_end) | CEGUI::String | [inline]
insert(size_type idx, const char *cstr) | CEGUI::String | [inline]
insert(size_type idx, const char *chars, size_type chars_len) | CEGUI::String | [inline]
length(void) const | CEGUI::String | [inline]
max_size(void) | CEGUI::String | [inline, static]
npos | CEGUI::String | [static]
operator+=(const String &str) | CEGUI::String | [inline]
operator+=(const std::string &std_str) | CEGUI::String | [inline]
operator+=(const utf8 *utf8_str) | CEGUI::String | [inline]
operator+=(utf32 code_point) | CEGUI::String | [inline]
operator+=(const char *cstr) | CEGUI::String | [inline]
operator=(const String &str) | CEGUI::String | [inline]
operator=(const std::string &std_str) | CEGUI::String | [inline]
operator=(const utf8 *utf8_str) | CEGUI::String | [inline]
operator=(utf32 code_point) | CEGUI::String | [inline]
operator=(const char *cstr) | CEGUI::String | [inline]
operator[](size_type idx) | CEGUI::String | [inline]
operator[](size_type idx) const | CEGUI::String | [inline]
pointer typedef | CEGUI::String |
push_back(utf32 code_point) | CEGUI::String | [inline]
rbegin(void) | CEGUI::String | [inline]
rbegin(void) const | CEGUI::String | [inline]
reference typedef | CEGUI::String |
rend(void) | CEGUI::String | [inline]
rend(void) const | CEGUI::String | [inline]
replace(size_type idx, size_type len, const String &str) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const String &str) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const String &str, size_type str_idx, size_type str_num) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const std::string &std_str) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const std::string &std_str) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const std::string &std_str, size_type str_idx, size_type str_num) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const utf8 *utf8_str) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const utf8 *utf8_str) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const utf8 *utf8_str, size_type str_len) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const utf8 *utf8_str, size_type str_len) | CEGUI::String | [inline]
replace(size_type idx, size_type len, size_type num, utf32 code_point) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, size_type num, utf32 code_point) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const_iterator iter_newBeg, const_iterator iter_newEnd) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const char *cstr) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const char *cstr) | CEGUI::String | [inline]
replace(size_type idx, size_type len, const char *chars, size_type chars_len) | CEGUI::String | [inline]
replace(iterator iter_beg, iterator iter_end, const char *chars, size_type chars_len) | CEGUI::String | [inline]
reserve(size_type num=0) | CEGUI::String | [inline]
resize(size_type num) | CEGUI::String | [inline]
resize(size_type num, utf32 code_point) | CEGUI::String | [inline]
reverse_iterator typedef | CEGUI::String |
rfind(utf32 code_point, size_type idx=npos) const | CEGUI::String | [inline]
rfind(const String &str, size_type idx=npos) const | CEGUI::String | [inline]
rfind(const std::string &std_str, size_type idx=npos) const | CEGUI::String | [inline]
rfind(const utf8 *utf8_str, size_type idx=npos) const | CEGUI::String | [inline]
rfind(const utf8 *utf8_str, size_type idx, size_type str_len) const | CEGUI::String | [inline]
rfind(const char *cstr, size_type idx=npos) const | CEGUI::String | [inline]
rfind(const char *chars, size_type idx, size_type chars_len) const | CEGUI::String | [inline]
size(void) const | CEGUI::String | [inline]
size_type typedef | CEGUI::String |
String(void) | CEGUI::String | [inline]
String(const String &str) | CEGUI::String | [inline]
String(const String &str, size_type str_idx, size_type str_num=npos) | CEGUI::String | [inline]
String(const std::string &std_str) | CEGUI::String | [inline]
String(const std::string &std_str, size_type str_idx, size_type str_num=npos) | CEGUI::String | [inline]
String(const utf8 *utf8_str) | CEGUI::String | [inline]
String(const utf8 *utf8_str, size_type chars_len) | CEGUI::String | [inline]
String(size_type num, utf32 code_point) | CEGUI::String | [inline]
String(const_iterator iter_beg, const_iterator iter_end) | CEGUI::String | [inline]
String(const char *cstr) | CEGUI::String | [inline]
String(const char *chars, size_type chars_len) | CEGUI::String | [inline]
substr(size_type idx=0, size_type len=npos) const | CEGUI::String | [inline]
swap(String &str) | CEGUI::String | [inline]
utf8_stream_len(size_type num=npos, size_type idx=0) | CEGUI::String | [inline]
value_type typedef | CEGUI::String |
~String(void) | CEGUI::String |

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::String::const_iterator Member List

This is the complete list of members for CEGUI::String::const_iterator, including all inherited members.

const_iterator(void) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
const_iterator(const_pointer ptr) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
d_ptr (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator |
operator *() const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator!=(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator+(difference_type offset) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator+ (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [friend]
operator++() (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator++(int) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator+=(difference_type offset) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator-(difference_type offset) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator-(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator--() (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator--(int) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator-=(difference_type offset) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator->() const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator<(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator<=(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator==(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator>(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator>=(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator[](difference_type offset) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::String::iterator Member List

This is the complete list of members for CEGUI::String::iterator, including all inherited members.

const_iterator(void) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
const_iterator(const_pointer ptr) (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
d_ptr (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator |
iterator(void) (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
iterator(pointer ptr) (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator *() const (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator!=(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator+(difference_type offset) const (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator+ (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [friend]
operator+ (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [friend]
operator++() (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator++(int) (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator+=(difference_type offset) (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator-(difference_type offset) const (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator-(const const_iterator &iter) const (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator--() (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator--(int) (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator-=(difference_type offset) (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator->() const (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]
operator<(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator<=(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator==(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator>(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator>=(const const_iterator &iter) const (defined in CEGUI::String::const_iterator) | CEGUI::String::const_iterator | [inline]
operator[](difference_type offset) const (defined in CEGUI::String::iterator) | CEGUI::String::iterator | [inline]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SubscriberInterface< Ret, Args > Member List

This is the complete list of members for CEGUI::SubscriberInterface< Ret, Args >, including all inherited members.

operator()(Args) const =0 (defined in CEGUI::SubscriberInterface< Ret, Args >) | CEGUI::SubscriberInterface< Ret, Args > | [pure virtual]
~SubscriberInterface() (defined in CEGUI::SubscriberInterface< Ret, Args >) | CEGUI::SubscriberInterface< Ret, Args > | [inline, virtual]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::SubscriberTemplate< Ret, Args > Member List

This is the complete list of members for CEGUI::SubscriberTemplate< Ret, Args >, including all inherited members.

d_si (defined in CEGUI::SubscriberTemplate< Ret, Args >) | CEGUI::SubscriberTemplate< Ret, Args > | [protected]
operator()(Args args) const (defined in CEGUI::SubscriberTemplate< Ret, Args >) | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
operator<(const SubscriberTemplate< Ret, Args > &rhs) const | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
release() const | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
SlotFunction typedef (defined in CEGUI::SubscriberTemplate< Ret, Args >) | CEGUI::SubscriberTemplate< Ret, Args > |
SubscriberTemplate(SlotFunction f) | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
SubscriberTemplate(Ret(T::*f)(Args), T *target) | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
SubscriberTemplate(const Functor &f) | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
SubscriberTemplate(SubscriberInterface< Ret, Args > *si) | CEGUI::SubscriberTemplate< Ret, Args > | [inline]
SubscriberTemplate(const SubscriberTemplate< Ret, Args > &copy) | CEGUI::SubscriberTemplate< Ret, Args > | [inline]

Generated on Sat Nov 26 10:09:59 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::System Member List

This is the complete list of members for CEGUI::System, including all inherited members.

addEvent(const String &name) | CEGUI::EventSet |
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_muted | CEGUI::EventSet | [protected]
DefaultMultiClickAreaSize | CEGUI::System | [static]
DefaultMultiClickTimeout | CEGUI::System | [static]
DefaultSingleClickTimeout | CEGUI::System | [static]
EventDefaultFontChanged | CEGUI::System | [static]
EventDefaultMouseCursorChanged | CEGUI::System | [static]
EventGUISheetChanged | CEGUI::System | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMouseMoveScalingChanged | CEGUI::System | [static]
EventMultiClickAreaSizeChanged | CEGUI::System | [static]
EventMultiClickTimeoutChanged | CEGUI::System | [static]
EventNamespace | CEGUI::System | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventSingleClickTimeoutChanged | CEGUI::System | [static]
executeScriptFile(const String &filename, const String &resourceGroup="") const | CEGUI::System |
executeScriptGlobal(const String &function_name) const | CEGUI::System |
executeScriptString(const String &str) const | CEGUI::System |
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
getDefaultFont(void) const | CEGUI::System | [inline]
getDefaultMouseCursor(void) const | CEGUI::System | [inline]
getDefaultTooltip(void) const | CEGUI::System | [inline]
getGUISheet(void) const | CEGUI::System | [inline]
getIterator(void) const | CEGUI::EventSet |
getModalTarget(void) const | CEGUI::System | [inline]
getMouseMoveScaling(void) const | CEGUI::System |
getMultiClickTimeout(void) const | CEGUI::System | [inline]
getMultiClickToleranceAreaSize(void) const | CEGUI::System | [inline]
getRenderer(void) const | CEGUI::System | [inline]
getResourceProvider(void) const | CEGUI::System |
getScriptingModule(void) const | CEGUI::System |
getSingleClickTimeout(void) const | CEGUI::System | [inline]
getSingleton(void) | CEGUI::System | [static]
getSingletonPtr(void) | CEGUI::System | [static]
getSystemKeys(void) const | CEGUI::System | [inline]
getWindowContainingMouse(void) const | CEGUI::System | [inline]
getXMLParser(void) const | CEGUI::System | [inline]
injectChar(utf32 code_point) | CEGUI::System |
injectKeyDown(uint key_code) | CEGUI::System |
injectKeyUp(uint key_code) | CEGUI::System |
injectMouseButtonDown(MouseButton button) | CEGUI::System |
injectMouseButtonUp(MouseButton button) | CEGUI::System |
injectMouseLeaves(void) | CEGUI::System |
injectMouseMove(float delta_x, float delta_y) | CEGUI::System |
injectMousePosition(float x_pos, float y_pos) | CEGUI::System |
injectMouseWheelChange(float delta) | CEGUI::System |
injectTimePulse(float timeElapsed) | CEGUI::System |
isEventPresent(const String &name) | CEGUI::EventSet |
isMuted(void) const | CEGUI::EventSet |
isRedrawRequested() const | CEGUI::System | [inline]
notifyWindowDestroyed(const Window *window) | CEGUI::System |
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
removeAllEvents(void) | CEGUI::EventSet |
removeEvent(const String &name) | CEGUI::EventSet |
renderGUI(void) | CEGUI::System |
setDefaultFont(const String &name) | CEGUI::System |
setDefaultFont(Font *font) | CEGUI::System |
setDefaultMouseCursor(const Image *image) | CEGUI::System |
setDefaultMouseCursor(MouseCursorImage image) | CEGUI::System | [inline]
setDefaultMouseCursor(const String &imageset, const String &image_name) | CEGUI::System |
setGUISheet(Window *sheet) | CEGUI::System |
setModalTarget(Window *target) | CEGUI::System | [inline]
setMouseMoveScaling(float scaling) | CEGUI::System |
setMultiClickTimeout(double timeout) | CEGUI::System |
setMultiClickToleranceAreaSize(const Size &sz) | CEGUI::System |
setMutedState(bool setting) | CEGUI::EventSet |
setSingleClickTimeout(double timeout) | CEGUI::System |
setTooltip(Tooltip *tooltip) | CEGUI::System |
setTooltip(const String &tooltipType) | CEGUI::System |
signalRedraw() | CEGUI::System | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System(Renderer *renderer, const utf8 *logFile=(const utf8 *)"CEGUI.log") | CEGUI::System |
System(Renderer *renderer, ResourceProvider *resourceProvider, const utf8 *logFile=(const utf8 *)"CEGUI.log") | CEGUI::System |
System(Renderer *renderer, ScriptModule *scriptModule, const utf8 *configFile=(const utf8 *)"cegui.config") | CEGUI::System |
System(Renderer *renderer, ScriptModule *scriptModule, ResourceProvider *resourceProvider, const utf8 *configFile=(const utf8 *)"cegui.config") | CEGUI::System |
System(Renderer *renderer, XMLParser *xmlParser, const utf8 *logFile=(const utf8 *)"CEGUI.log") | CEGUI::System |
System(Renderer *renderer, ResourceProvider *resourceProvider, XMLParser *xmlParser, const utf8 *logFile=(const utf8 *)"CEGUI.log") | CEGUI::System |
System(Renderer *renderer, XMLParser *xmlParser, ScriptModule *scriptModule, const utf8 *configFile=(const utf8 *)"cegui.config") | CEGUI::System |
System(Renderer *renderer, ResourceProvider *resourceProvider, XMLParser *xmlParser, ScriptModule *scriptModule, const utf8 *configFile=(const utf8 *)"cegui.config") | CEGUI::System |
~EventSet(void) | CEGUI::EventSet | [virtual]
~System(void) | CEGUI::System |

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabButton Member List

This is the complete list of members for CEGUI::TabButton, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addTabButtonEvents(void) | CEGUI::TabButton | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
ButtonBase(const String &type, const String &name) | CEGUI::ButtonBase |
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledColour | CEGUI::ButtonBase | [protected]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverColour | CEGUI::ButtonBase | [protected]
d_hovering | CEGUI::ButtonBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalColour | CEGUI::ButtonBase | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::ButtonBase | [protected]
d_pushedColour | CEGUI::ButtonBase | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rightOfSelected | CEGUI::TabButton | [protected]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_selected | CEGUI::TabButton | [protected]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tabIndex | CEGUI::TabButton | [protected]
d_targetWindow | CEGUI::TabButton | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledLabelColour | CEGUI::ButtonBase | [static]
DefaultHoverLabelColour | CEGUI::ButtonBase | [static]
DefaultNormalLabelColour | CEGUI::ButtonBase | [static]
DefaultPushedLabelColour | CEGUI::ButtonBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawDisabled(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawHover(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawNormal(float z)=0 | CEGUI::ButtonBase | [protected, pure virtual]
drawPushed(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawSelf(float z) | CEGUI::TabButton | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClicked | CEGUI::TabButton | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::TabButton | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledTextColour(void) const | CEGUI::ButtonBase | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverTextColour(void) const | CEGUI::ButtonBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalTextColour(void) const | CEGUI::ButtonBase | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedTextColour(void) const | CEGUI::ButtonBase | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getTabIndex(void) | CEGUI::TabButton | [inline]
getTargetWindow(void) | CEGUI::TabButton | [inline]
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHovering(void) const | CEGUI::ButtonBase | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::ButtonBase | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isSelected(void) const | CEGUI::TabButton | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClicked(WindowEventArgs &e) | CEGUI::TabButton | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::TabButton | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledTextColour(const colour &colour) | CEGUI::ButtonBase |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverTextColour(const colour &colour) | CEGUI::ButtonBase |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalTextColour(const colour &colour) | CEGUI::ButtonBase |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedTextColour(const colour &colour) | CEGUI::ButtonBase |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRightOfSelected(bool isRight) | CEGUI::TabButton | [inline, virtual]
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelected(bool selected) | CEGUI::TabButton | [inline, virtual]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setTabIndex(uint idx) | CEGUI::TabButton | [inline]
setTargetWindow(Window *wnd) | CEGUI::TabButton |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
TabButton(const String &type, const String &name) | CEGUI::TabButton |
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::TabButton | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::ButtonBase | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ButtonBase(void) | CEGUI::ButtonBase | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~TabButton(void) | CEGUI::TabButton | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControl Member List

This is the complete list of members for CEGUI::TabControl, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addButtonForTabContent(Window *wnd) | CEGUI::TabControl | [protected, virtual]
addChild_impl(Window *wnd) | CEGUI::TabControl | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addTab(Window *wnd) | CEGUI::TabControl |
addTabControlEvents(void) | CEGUI::TabControl | [protected]
addTabControlProperties(void) (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
calculateTabButtonSizePosition(TabButton *btn, uint targetIndex) | CEGUI::TabControl | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
createTabButton(const String &name) const =0 | CEGUI::TabControl | [protected, pure virtual]
createTabButtonPane(const String &name) const | CEGUI::TabControl | [protected, virtual]
createTabContentPane(const String &name) const =0 | CEGUI::TabControl | [protected, pure virtual]
d_abs_tabHeight | CEGUI::TabControl | [protected]
d_abs_tabPadding | CEGUI::TabControl | [protected]
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absoluteTabHeightProperty (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, static]
d_absoluteTabTextPaddingProperty (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_nextTabIndex | CEGUI::TabControl | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rel_tabHeight | CEGUI::TabControl | [protected]
d_rel_tabPadding | CEGUI::TabControl | [protected]
d_relativeTabHeightProperty (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, static]
d_relativeTabTextPaddingProperty (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tabButtonIndexMap | CEGUI::TabControl | [protected]
d_tabButtonPane | CEGUI::TabControl | [protected]
d_tabContentPane | CEGUI::TabControl | [protected]
d_tabHeightProperty (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, static]
d_tabTextPaddingProperty (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::TabControl | [inline, protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::TabControl | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSelectionChanged | CEGUI::TabControl | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteTabHeight(void) const | CEGUI::TabControl | [inline]
getAbsoluteTabTextPadding(void) const | CEGUI::TabControl | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getButtonForTabContents(Window *wnd) const | CEGUI::TabControl | [protected]
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeTabHeight(void) const | CEGUI::TabControl | [inline]
getRelativeTabTextPadding(void) const | CEGUI::TabControl | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSelectedTabIndex() const | CEGUI::TabControl |
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getTabContents(const String &name) const | CEGUI::TabControl |
getTabContents(uint ID) const | CEGUI::TabControl |
getTabContentsAtIndex(uint index) const | CEGUI::TabControl |
getTabCount(void) const | CEGUI::TabControl |
getTabHeight(void) const | CEGUI::TabControl |
getTabTextPadding(void) const | CEGUI::TabControl |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
handleContentWindowTextChanged(const EventArgs &args) (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected]
handleTabButtonClicked(const EventArgs &args) (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected]
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::TabControl | [virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isTabContentsSelected(Window *wnd) const | CEGUI::TabControl |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
makeButtonName(Window *wnd) | CEGUI::TabControl | [protected]
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::TabControl | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSelectionChanged(WindowEventArgs &e) | CEGUI::TabControl | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::TabControl | [protected, virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeButtonForTabContent(Window *wnd) | CEGUI::TabControl | [protected, virtual]
removeChild_impl(Window *wnd) | CEGUI::TabControl | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeTab(const String &name) | CEGUI::TabControl |
removeTab(uint ID) | CEGUI::TabControl |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
selectTab_impl(Window *wnd) | CEGUI::TabControl | [protected, virtual]
setAbsoluteTabHeight(float height) | CEGUI::TabControl |
setAbsoluteTabTextPadding(float) | CEGUI::TabControl |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRelativeTabHeight(float height) | CEGUI::TabControl |
setRelativeTabTextPadding(float) | CEGUI::TabControl |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSelectedTab(const String &name) | CEGUI::TabControl |
setSelectedTab(uint ID) | CEGUI::TabControl |
setSelectedTabAtIndex(uint index) | CEGUI::TabControl |
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setTabHeight(float height) | CEGUI::TabControl |
setTabTextPadding(float) | CEGUI::TabControl |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
TabButtonIndexMap typedef (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected]
TabControl(const String &type, const String &name) | CEGUI::TabControl |
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::TabControl | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::TabControl) | CEGUI::TabControl | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~TabControl(void) | CEGUI::TabControl | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControlProperties::AbsoluteTabHeight Member List

This is the complete list of members for CEGUI::TabControlProperties::AbsoluteTabHeight, including all inherited members.

AbsoluteTabHeight() (defined in CEGUI::TabControlProperties::AbsoluteTabHeight) | CEGUI::TabControlProperties::AbsoluteTabHeight | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::AbsoluteTabHeight | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::AbsoluteTabHeight | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::AbsoluteTabHeight | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TabControlProperties::AbsoluteTabHeight | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControlProperties::AbsoluteTabTextPadding Member List

This is the complete list of members for CEGUI::TabControlProperties::AbsoluteTabTextPadding, including all inherited members.

AbsoluteTabTextPadding() (defined in CEGUI::TabControlProperties::AbsoluteTabTextPadding) | CEGUI::TabControlProperties::AbsoluteTabTextPadding | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::AbsoluteTabTextPadding | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TabControlProperties::AbsoluteTabTextPadding | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControlProperties::RelativeTabHeight Member List

This is the complete list of members for CEGUI::TabControlProperties::RelativeTabHeight, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::RelativeTabHeight | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeTabHeight() (defined in CEGUI::TabControlProperties::RelativeTabHeight) | CEGUI::TabControlProperties::RelativeTabHeight | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TabControlProperties::RelativeTabHeight | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControlProperties::RelativeTabTextPadding Member List

This is the complete list of members for CEGUI::TabControlProperties::RelativeTabTextPadding, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::RelativeTabTextPadding | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::RelativeTabTextPadding | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::RelativeTabTextPadding | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeTabTextPadding() (defined in CEGUI::TabControlProperties::RelativeTabTextPadding) | CEGUI::TabControlProperties::RelativeTabTextPadding | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TabControlProperties::RelativeTabTextPadding | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControlProperties::TabHeight Member List

This is the complete list of members for CEGUI::TabControlProperties::TabHeight, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::TabHeight | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::TabHeight | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::TabHeight | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TabControlProperties::TabHeight | [virtual]
TabHeight() (defined in CEGUI::TabControlProperties::TabHeight) | CEGUI::TabControlProperties::TabHeight | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:17 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabControlProperties::TabTextPadding Member List

This is the complete list of members for CEGUI::TabControlProperties::TabTextPadding, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::TabTextPadding | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::TabTextPadding | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::TabControlProperties::TabTextPadding | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TabControlProperties::TabTextPadding | [virtual]
TabTextPadding() (defined in CEGUI::TabControlProperties::TabTextPadding) | CEGUI::TabControlProperties::TabTextPadding | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TabPane Member List

This is the complete list of members for CEGUI::TabPane, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
calculateModulatedAlphaColour(const colour &col, float alpha) const | CEGUI::Static | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_background | CEGUI::Static | [protected]
d_backgroundCols | CEGUI::Static | [protected]
d_backgroundEnabled | CEGUI::Static | [protected]
d_bottom_height | CEGUI::Static | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_frame | CEGUI::Static | [protected]
d_frameCols | CEGUI::Static | [protected]
d_frameEnabled | CEGUI::Static | [protected]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_left_width | CEGUI::Static | [protected]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_right_width | CEGUI::Static | [protected]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_top_height | CEGUI::Static | [protected]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Static | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getBackgroundColours(void) const | CEGUI::Static | [inline]
getBackgroundImage(void) const | CEGUI::Static |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getFrameColours(void) const | CEGUI::Static | [inline]
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getImageForFrameLocation(FrameLocation location) const | CEGUI::Static |
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Static | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isBackgroundEnabled(void) const | CEGUI::Static | [inline]
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isFrameEnabled(void) const | CEGUI::Static | [inline]
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Static | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Static | [protected, virtual]
onStaticFrameChanged(WindowEventArgs &e) | CEGUI::Static | [inline, protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Static | [protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setBackgroundColours(const ColourRect &colours) | CEGUI::Static |
setBackgroundColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setBackgroundColours(const colour &col) | CEGUI::Static | [inline]
setBackgroundEnabled(bool setting) | CEGUI::Static |
setBackgroundImage(const Image *image) | CEGUI::Static |
setBackgroundImage(const String &imageset, const String &image) | CEGUI::Static |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setFrameColours(const ColourRect &colours) | CEGUI::Static |
setFrameColours(const colour &top_left_colour, const colour &top_right_colour, const colour &bottom_left_colour, const colour &bottom_right_colour) | CEGUI::Static |
setFrameColours(const colour &col) | CEGUI::Static | [inline]
setFrameEnabled(bool setting) | CEGUI::Static |
setFrameImages(const Image *topleft, const Image *topright, const Image *bottomleft, const Image *bottomright, const Image *left, const Image *top, const Image *right, const Image *bottom) | CEGUI::Static |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setImageForFrameLocation(FrameLocation location, const Image *image) | CEGUI::Static |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
Static(const String &type, const String &name) | CEGUI::Static |
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
TabPane(const String &type, const String &name) | CEGUI::TabPane | [inline]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::TabPane | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateRenderableFrameColours(void) | CEGUI::Static | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Static(void) | CEGUI::Static | [virtual]
~TabPane(void) | CEGUI::TabPane | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:08 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TextComponent Member List

This is the complete list of members for CEGUI::TextComponent, including all inherited members.

d_area | CEGUI::FalagardComponentBase | [protected]
d_colourPropertyName | CEGUI::FalagardComponentBase | [protected]
d_colourProperyIsRect | CEGUI::FalagardComponentBase | [protected]
d_colours | CEGUI::FalagardComponentBase | [protected]
d_horzFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
d_vertFormatPropertyName | CEGUI::FalagardComponentBase | [protected]
FalagardComponentBase() | CEGUI::FalagardComponentBase |
getColours() const | CEGUI::FalagardComponentBase |
getComponentArea() const | CEGUI::FalagardComponentBase |
getFont() const | CEGUI::TextComponent |
getHorizontalFormatting() const | CEGUI::TextComponent |
getText() const | CEGUI::TextComponent |
getVerticalFormatting() const | CEGUI::TextComponent |
initColoursRect(const Window &wnd, const ColourRect *modCols, ColourRect &cr) const | CEGUI::FalagardComponentBase | [protected]
render(Window &srcWindow, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render(Window &srcWindow, const Rect &baseRect, float base_z, const CEGUI::ColourRect *modColours=0, const Rect *clipper=0, bool clipToDisplay=false) const | CEGUI::FalagardComponentBase |
render_impl(Window &srcWindow, Rect &destRect, float base_z, const CEGUI::ColourRect *modColours, const Rect *clipper, bool clipToDisplay) const | CEGUI::TextComponent | [protected, virtual]
setColours(const ColourRect &cols) | CEGUI::FalagardComponentBase |
setColoursPropertyIsColourRect(bool setting=true) | CEGUI::FalagardComponentBase |
setColoursPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setComponentArea(const ComponentArea &area) | CEGUI::FalagardComponentBase |
setFont(const String &font) | CEGUI::TextComponent |
setHorizontalFormatting(HorizontalTextFormatting fmt) | CEGUI::TextComponent |
setHorzFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setText(const String &text) | CEGUI::TextComponent |
setVertFormattingPropertySource(const String &property) | CEGUI::FalagardComponentBase |
setVerticalFormatting(VerticalTextFormatting fmt) | CEGUI::TextComponent |
TextComponent() | CEGUI::TextComponent |
writeColoursXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeHorzFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeVertFormatXML(OutStream &out_stream) const | CEGUI::FalagardComponentBase | [protected]
writeXMLToStream(OutStream &out_stream) const | CEGUI::TextComponent |
~FalagardComponentBase() | CEGUI::FalagardComponentBase | [virtual]

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TextItem Member List

This is the complete list of members for CEGUI::TextItem, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addItemEntryEvents(void) | CEGUI::ItemEntry | [protected]
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textColour | CEGUI::TextItem | [protected]
d_textFormatting | CEGUI::TextItem | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_textXOffset | CEGUI::TextItem | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultTextColour | CEGUI::TextItem | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Window | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
getItemPixelSize(void) | CEGUI::TextItem | [virtual]
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextColour(void) const | CEGUI::TextItem | [inline]
getTextFormatting() const | CEGUI::TextItem | [inline]
getTextXOffset(void) const | CEGUI::TextItem | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
ItemEntry(const String &type, const String &name) | CEGUI::ItemEntry |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::TextItem | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::TextItem | [protected, virtual]
populateRenderCahce() | CEGUI::ItemEntry | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTextColour(const colour &col) | CEGUI::TextItem | [inline]
setTextFormatting(TextFormatting format) | CEGUI::TextItem | [inline]
setTextXOffset(float offset) | CEGUI::TextItem | [inline]
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::TextItem | [inline, protected, virtual]
TextItem(const String &type, const String &name) | CEGUI::TextItem |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~ItemEntry(void) | CEGUI::ItemEntry | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~TextItem(void) | CEGUI::TextItem | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TextItemProperties::TextColour Member List

This is the complete list of members for CEGUI::TextItemProperties::TextColour, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TextItemProperties::TextColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TextItemProperties::TextColour | [virtual]
TextColour() (defined in CEGUI::TextItemProperties::TextColour) | CEGUI::TextItemProperties::TextColour | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TextItemProperties::TextFormatting Member List

This is the complete list of members for CEGUI::TextItemProperties::TextFormatting, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TextItemProperties::TextFormatting | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TextItemProperties::TextFormatting | [virtual]
TextFormatting() (defined in CEGUI::TextItemProperties::TextFormatting) | CEGUI::TextItemProperties::TextFormatting | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TextItemProperties::TextXOffset Member List

This is the complete list of members for CEGUI::TextItemProperties::TextXOffset, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TextItemProperties::TextXOffset | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TextItemProperties::TextXOffset | [virtual]
TextXOffset() (defined in CEGUI::TextItemProperties::TextXOffset) | CEGUI::TextItemProperties::TextXOffset | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Texture Member List

This is the complete list of members for CEGUI::Texture, including all inherited members.

getHeight(void) const =0 | CEGUI::Texture | [pure virtual]
getRenderer(void) const | CEGUI::Texture | [inline]
getWidth(void) const =0 | CEGUI::Texture | [pure virtual]
loadFromFile(const String &filename, const String &resourceGroup)=0 | CEGUI::Texture | [pure virtual]
loadFromMemory(const void *buffPtr, uint buffWidth, uint buffHeight)=0 | CEGUI::Texture | [pure virtual]
Texture(Renderer *owner) | CEGUI::Texture | [inline, protected]
~Texture(void) | CEGUI::Texture | [inline, virtual]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TextUtils Member List

This is the complete list of members for CEGUI::TextUtils, including all inherited members.

DefaultAlphanumerical | CEGUI::TextUtils | [static]
DefaultWhitespace | CEGUI::TextUtils | [static]
DefaultWrapDelimiters | CEGUI::TextUtils | [static]
getNextWord(const String &str, String::size_type start_idx=0, const String &delimiters=DefaultWhitespace) | CEGUI::TextUtils | [static]
getNextWordStartIdx(const String &str, String::size_type idx) | CEGUI::TextUtils | [static]
getWordStartIdx(const String &str, String::size_type idx) | CEGUI::TextUtils | [static]
trimLeadingChars(String &str, const String &chars) | CEGUI::TextUtils | [static]
trimTrailingChars(String &str, const String &chars) | CEGUI::TextUtils | [static]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Thumb Member List

This is the complete list of members for CEGUI::Thumb, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addPushButtonEvents(void) | CEGUI::PushButton | [protected]
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addThumbEvents(void) | CEGUI::Thumb | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
ButtonBase(const String &type, const String &name) | CEGUI::ButtonBase |
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoscaleImages | CEGUI::PushButton | [protected]
d_beingDragged | CEGUI::Thumb | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledColour | CEGUI::ButtonBase | [protected]
d_disabledImage | CEGUI::PushButton | [protected]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragPoint | CEGUI::Thumb | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzFree | CEGUI::Thumb | [protected]
d_horzMax | CEGUI::Thumb | [protected]
d_horzMin (defined in CEGUI::Thumb) | CEGUI::Thumb | [protected]
d_hotTrack | CEGUI::Thumb | [protected]
d_hoverColour | CEGUI::ButtonBase | [protected]
d_hoverImage | CEGUI::PushButton | [protected]
d_hovering | CEGUI::ButtonBase | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_normalColour | CEGUI::ButtonBase | [protected]
d_normalImage | CEGUI::PushButton | [protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_pushed | CEGUI::ButtonBase | [protected]
d_pushedColour | CEGUI::ButtonBase | [protected]
d_pushedImage | CEGUI::PushButton | [protected]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_textXOffset | CEGUI::PushButton | [protected]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_useDisabledImage | CEGUI::PushButton | [protected]
d_useHoverImage | CEGUI::PushButton | [protected]
d_useNormalImage | CEGUI::PushButton | [protected]
d_usePushedImage | CEGUI::PushButton | [protected]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_useStandardImagery | CEGUI::PushButton | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_vertFree | CEGUI::Thumb | [protected]
d_vertMax | CEGUI::Thumb | [protected]
d_vertMin (defined in CEGUI::Thumb) | CEGUI::Thumb | [protected]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
DefaultDisabledLabelColour | CEGUI::ButtonBase | [static]
DefaultHoverLabelColour | CEGUI::ButtonBase | [static]
DefaultNormalLabelColour | CEGUI::ButtonBase | [static]
DefaultPushedLabelColour | CEGUI::ButtonBase | [static]
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawDisabled(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawHover(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawNormal(float z)=0 | CEGUI::ButtonBase | [protected, pure virtual]
drawPushed(float z) | CEGUI::ButtonBase | [inline, protected, virtual]
drawSelf(float z) | CEGUI::ButtonBase | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClicked | CEGUI::PushButton | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Thumb | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventThumbPositionChanged | CEGUI::Thumb | [static]
EventThumbTrackEnded | CEGUI::Thumb | [static]
EventThumbTrackStarted | CEGUI::Thumb | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisabledImage(void) const | CEGUI::PushButton |
getDisabledTextColour(void) const | CEGUI::ButtonBase | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHorzRange(void) const | CEGUI::Thumb |
getHoverImage(void) const | CEGUI::PushButton |
getHoverTextColour(void) const | CEGUI::ButtonBase | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getNormalImage(void) const | CEGUI::PushButton |
getNormalTextColour(void) const | CEGUI::ButtonBase | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getPushedImage(void) const | CEGUI::PushButton |
getPushedTextColour(void) const | CEGUI::ButtonBase | [inline]
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTextXOffset(void) const | CEGUI::PushButton |
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getVertRange(void) const | CEGUI::Thumb |
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isCustomImageryAutoSized(void) const | CEGUI::PushButton |
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isHorzFree(void) const | CEGUI::Thumb | [inline]
isHotTracked(void) const | CEGUI::Thumb | [inline]
isHovering(void) const | CEGUI::ButtonBase | [inline]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isPushed(void) const | CEGUI::ButtonBase | [inline]
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isStandardImageryEnabled(void) const | CEGUI::PushButton |
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVertFree(void) const | CEGUI::Thumb | [inline]
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Thumb | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClicked(WindowEventArgs &e) | CEGUI::PushButton | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Thumb | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::PushButton | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::ButtonBase | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Thumb | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::PushButton | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onThumbPositionChanged(WindowEventArgs &e) | CEGUI::Thumb | [protected, virtual]
onThumbTrackEnded(WindowEventArgs &e) | CEGUI::Thumb | [protected, virtual]
onThumbTrackStarted(WindowEventArgs &e) | CEGUI::Thumb | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
PushButton(const String &type, const String &name) | CEGUI::PushButton |
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setCustomImageryAutoSized(bool setting) | CEGUI::PushButton |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisabledImage(const RenderableImage *image) | CEGUI::PushButton |
setDisabledTextColour(const colour &colour) | CEGUI::ButtonBase |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHorzFree(bool setting) | CEGUI::Thumb | [inline]
setHorzRange(float min, float max) | CEGUI::Thumb |
setHotTracked(bool setting) | CEGUI::Thumb | [inline]
setHoverImage(const RenderableImage *image) | CEGUI::PushButton |
setHoverTextColour(const colour &colour) | CEGUI::ButtonBase |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setNormalImage(const RenderableImage *image) | CEGUI::PushButton |
setNormalTextColour(const colour &colour) | CEGUI::ButtonBase |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setPushedImage(const RenderableImage *image) | CEGUI::PushButton |
setPushedTextColour(const colour &colour) | CEGUI::ButtonBase |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setStandardImageryEnabled(bool setting) | CEGUI::PushButton |
setText(const String &text) | CEGUI::Window |
setTextXOffset(float offset) | CEGUI::PushButton |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVertFree(bool setting) | CEGUI::Thumb | [inline]
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVertRange(float min, float max) | CEGUI::Thumb |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Thumb | [inline, protected, virtual]
Thumb(const String &type, const String &name) | CEGUI::Thumb |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateInternalState(const Point &mouse_pos) | CEGUI::ButtonBase | [protected]
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~ButtonBase(void) | CEGUI::ButtonBase | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~PushButton(void) | CEGUI::PushButton | [virtual]
~Thumb(void) | CEGUI::Thumb | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ThumbProperties::HorzFree Member List

This is the complete list of members for CEGUI::ThumbProperties::HorzFree, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ThumbProperties::HorzFree | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzFree() (defined in CEGUI::ThumbProperties::HorzFree) | CEGUI::ThumbProperties::HorzFree | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ThumbProperties::HorzFree | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ThumbProperties::HorzRange Member List

This is the complete list of members for CEGUI::ThumbProperties::HorzRange, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ThumbProperties::HorzRange | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorzRange() (defined in CEGUI::ThumbProperties::HorzRange) | CEGUI::ThumbProperties::HorzRange | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ThumbProperties::HorzRange | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ThumbProperties::HotTracked Member List

This is the complete list of members for CEGUI::ThumbProperties::HotTracked, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ThumbProperties::HotTracked | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HotTracked() (defined in CEGUI::ThumbProperties::HotTracked) | CEGUI::ThumbProperties::HotTracked | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ThumbProperties::HotTracked | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ThumbProperties::VertFree Member List

This is the complete list of members for CEGUI::ThumbProperties::VertFree, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ThumbProperties::VertFree | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ThumbProperties::VertFree | [virtual]
VertFree() (defined in CEGUI::ThumbProperties::VertFree) | CEGUI::ThumbProperties::VertFree | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::ThumbProperties::VertRange Member List

This is the complete list of members for CEGUI::ThumbProperties::VertRange, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::ThumbProperties::VertRange | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::ThumbProperties::VertRange | [virtual]
VertRange() (defined in CEGUI::ThumbProperties::VertRange) | CEGUI::ThumbProperties::VertRange | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TinyXMLParser Member List

This is the complete list of members for CEGUI::TinyXMLParser, including all inherited members.

cleanup(void) | CEGUI::XMLParser |
cleanupImpl(void) | CEGUI::TinyXMLParser | [protected, virtual]
d_identifierString | CEGUI::XMLParser | [protected]
getIdentifierString() const | CEGUI::XMLParser |
initialise(void) | CEGUI::XMLParser |
initialiseImpl(void) | CEGUI::TinyXMLParser | [protected, virtual]
parseXMLFile(XMLHandler &handler, const String &filename, const String &schemaName, const String &resourceGroup) | CEGUI::TinyXMLParser | [virtual]
TinyXMLParser(void) (defined in CEGUI::TinyXMLParser) | CEGUI::TinyXMLParser |
XMLParser(void) | CEGUI::XMLParser |
~TinyXMLParser(void) (defined in CEGUI::TinyXMLParser) | CEGUI::TinyXMLParser |
~XMLParser(void) | CEGUI::XMLParser | [virtual]

Generated on Sat Nov 26 10:10:01 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Titlebar Member List

This is the complete list of members for CEGUI::Titlebar, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captionColour | CEGUI::Titlebar | [protected]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_dragEnabled | CEGUI::Titlebar | [protected]
d_dragging | CEGUI::Titlebar | [protected]
d_dragPoint | CEGUI::Titlebar | [protected]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_oldCursorArea | CEGUI::Titlebar | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Titlebar | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptionColour(void) const | CEGUI::Titlebar |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isDraggingEnabled(void) const | CEGUI::Titlebar |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Titlebar | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDraggingModeChanged(WindowEventArgs &e) | CEGUI::Titlebar | [inline, protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Titlebar | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Titlebar | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Titlebar | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Titlebar | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Titlebar | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setCaptionColour(const colour &col) | CEGUI::Titlebar |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setDraggingEnabled(bool setting) | CEGUI::Titlebar |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Titlebar | [inline, protected, virtual]
Titlebar(const String &type, const String &name) | CEGUI::Titlebar |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Titlebar(void) | CEGUI::Titlebar | [virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TitlebarProperties::CaptionColour Member List

This is the complete list of members for CEGUI::TitlebarProperties::CaptionColour, including all inherited members.

CaptionColour() (defined in CEGUI::TitlebarProperties::CaptionColour) | CEGUI::TitlebarProperties::CaptionColour | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TitlebarProperties::CaptionColour | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TitlebarProperties::CaptionColour | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TitlebarProperties::DraggingEnabled Member List

This is the complete list of members for CEGUI::TitlebarProperties::DraggingEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DraggingEnabled() (defined in CEGUI::TitlebarProperties::DraggingEnabled) | CEGUI::TitlebarProperties::DraggingEnabled | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::TitlebarProperties::DraggingEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TitlebarProperties::DraggingEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Tooltip Member List

This is the complete list of members for CEGUI::Tooltip, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
Active enum value | CEGUI::Tooltip | [protected]
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addTooltipEvents(void) | CEGUI::Tooltip | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_displayTime | CEGUI::Tooltip | [protected]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_elapsed | CEGUI::Tooltip | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_fadeTime | CEGUI::Tooltip | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_hoverTime | CEGUI::Tooltip | [protected]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_state | CEGUI::Tooltip | [protected]
d_target | CEGUI::Tooltip | [protected]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doActiveState(float elapsed) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
doFadeInState(float elapsed) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
doFadeOutState(float elapsed) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
doInactiveState(float elapsed) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDisplayTimeChanged | CEGUI::Tooltip | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFadeTimeChanged | CEGUI::Tooltip | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventHoverTimeChanged | CEGUI::Tooltip | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Tooltip | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventTooltipActive | CEGUI::Tooltip | [static]
EventTooltipInactive | CEGUI::Tooltip | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
FadeIn enum value | CEGUI::Tooltip | [protected]
FadeOut enum value | CEGUI::Tooltip | [protected]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getDisplayTime(void) const | CEGUI::Tooltip |
getEffectiveAlpha(void) const | CEGUI::Window |
getFadeTime(void) const | CEGUI::Tooltip |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getHoverTime(void) const | CEGUI::Tooltip |
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getTargetWindow() | CEGUI::Tooltip |
getText(void) const | CEGUI::Window | [inline]
getTextSize() const | CEGUI::Tooltip | [protected, virtual]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
Inactive enum value | CEGUI::Tooltip | [protected]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisplayTimeChanged(WindowEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFadeTimeChanged(WindowEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHoverTimeChanged(WindowEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onTooltipActive(WindowEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onTooltipInactive(WindowEventArgs &e) | CEGUI::Tooltip | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
positionSelf(void) | CEGUI::Tooltip |
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
resetTimer(void) | CEGUI::Tooltip |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDisplayTime(float seconds) | CEGUI::Tooltip |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFadeTime(float seconds) | CEGUI::Tooltip |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setHoverTime(float seconds) | CEGUI::Tooltip |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setTargetWindow(Window *wnd) | CEGUI::Tooltip |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
switchToActiveState(void) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
switchToFadeInState(void) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
switchToFadeOutState(void) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
switchToInactiveState(void) (defined in CEGUI::Tooltip) | CEGUI::Tooltip | [protected]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Tooltip | [inline, protected, virtual]
TipState enum name | CEGUI::Tooltip | [protected]
Tooltip(const String &type, const String &name) | CEGUI::Tooltip |
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Tooltip | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Tooltip(void) | CEGUI::Tooltip |
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TooltipProperties::DisplayTime Member List

This is the complete list of members for CEGUI::TooltipProperties::DisplayTime, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DisplayTime() (defined in CEGUI::TooltipProperties::DisplayTime) | CEGUI::TooltipProperties::DisplayTime | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::TooltipProperties::DisplayTime | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TooltipProperties::DisplayTime | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TooltipProperties::FadeTime Member List

This is the complete list of members for CEGUI::TooltipProperties::FadeTime, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
FadeTime() (defined in CEGUI::TooltipProperties::FadeTime) | CEGUI::TooltipProperties::FadeTime | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::TooltipProperties::FadeTime | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TooltipProperties::FadeTime | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::TooltipProperties::HoverTime Member List

This is the complete list of members for CEGUI::TooltipProperties::HoverTime, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::TooltipProperties::HoverTime | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HoverTime() (defined in CEGUI::TooltipProperties::HoverTime) | CEGUI::TooltipProperties::HoverTime | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::TooltipProperties::HoverTime | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::UDim Member List

This is the complete list of members for CEGUI::UDim, including all inherited members.

asAbsolute(float base) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
asRelative(float base) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
d_offset (defined in CEGUI::UDim) | CEGUI::UDim |
d_scale (defined in CEGUI::UDim) | CEGUI::UDim |
operator *(const UDim &other) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator *=(const UDim &other) (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator!=(const UDim &other) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator+(const UDim &other) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator+=(const UDim &other) (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator-(const UDim &other) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator-=(const UDim &other) (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator/(const UDim &other) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator/=(const UDim &other) (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
operator==(const UDim &other) const (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
UDim() (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
UDim(float scale, float offset) (defined in CEGUI::UDim) | CEGUI::UDim | [inline]
~UDim() (defined in CEGUI::UDim) | CEGUI::UDim | [inline]

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::UnifiedDim Member List

This is the complete list of members for CEGUI::UnifiedDim, including all inherited members.

BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const | CEGUI::UnifiedDim | [protected, virtual]
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const | CEGUI::UnifiedDim | [protected, virtual]
getValue_impl(const Window &wnd, const Rect &container) const | CEGUI::UnifiedDim | [protected, virtual]
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
UnifiedDim(const UDim &value, DimensionType dim) | CEGUI::UnifiedDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const | CEGUI::UnifiedDim | [protected, virtual]
writeXMLElementName_impl(OutStream &out_stream) const | CEGUI::UnifiedDim | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::UnknownObjectException Member List

This is the complete list of members for CEGUI::UnknownObjectException, including all inherited members.

d_message (defined in CEGUI::Exception) | CEGUI::Exception | [protected]
Exception(const String &message) (defined in CEGUI::Exception) | CEGUI::Exception |
getMessage(void) const | CEGUI::Exception | [inline]
UnknownObjectException(const String &message) (defined in CEGUI::UnknownObjectException) | CEGUI::UnknownObjectException | [inline]
~Exception(void) (defined in CEGUI::Exception) | CEGUI::Exception | [virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::URect Member List

This is the complete list of members for CEGUI::URect, including all inherited members.

asAbsolute(const Size &base) const (defined in CEGUI::URect) | CEGUI::URect | [inline]
asRelative(const Size &base) const (defined in CEGUI::URect) | CEGUI::URect | [inline]
d_max (defined in CEGUI::URect) | CEGUI::URect |
d_min (defined in CEGUI::URect) | CEGUI::URect |
getHeight() const (defined in CEGUI::URect) | CEGUI::URect | [inline]
getPosition() const (defined in CEGUI::URect) | CEGUI::URect | [inline]
getSize() const (defined in CEGUI::URect) | CEGUI::URect | [inline]
getWidth() const (defined in CEGUI::URect) | CEGUI::URect | [inline]
offset(const UVector2 &sz) (defined in CEGUI::URect) | CEGUI::URect | [inline]
setHeight(const UDim &h) (defined in CEGUI::URect) | CEGUI::URect | [inline]
setPosition(const UVector2 &pos) (defined in CEGUI::URect) | CEGUI::URect | [inline]
setSize(const UVector2 &sz) (defined in CEGUI::URect) | CEGUI::URect | [inline]
setWidth(const UDim &w) (defined in CEGUI::URect) | CEGUI::URect | [inline]
URect() (defined in CEGUI::URect) | CEGUI::URect | [inline]
URect(const UVector2 &min, const UVector2 &max) (defined in CEGUI::URect) | CEGUI::URect | [inline]
URect(const UDim &left, const UDim &top, const UDim &right, const UDim &bottom) (defined in CEGUI::URect) | CEGUI::URect | [inline]
~URect() (defined in CEGUI::URect) | CEGUI::URect | [inline]

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::UVector2 Member List

This is the complete list of members for CEGUI::UVector2, including all inherited members.

asAbsolute(const Size &base) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
asRelative(const Size &base) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
d_x (defined in CEGUI::UVector2) | CEGUI::UVector2 |
d_y (defined in CEGUI::UVector2) | CEGUI::UVector2 |
operator *(const UVector2 &other) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator *=(const UVector2 &other) (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator!=(const UVector2 &other) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator+(const UVector2 &other) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator+=(const UVector2 &other) (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator-(const UVector2 &other) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator-=(const UVector2 &other) (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator/(const UVector2 &other) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator/=(const UVector2 &other) (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
operator==(const UVector2 &other) const (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
UVector2() (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
UVector2(const UDim &x, const UDim &y) (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]
~UVector2() (defined in CEGUI::UVector2) | CEGUI::UVector2 | [inline]

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Vector2 Member List

This is the complete list of members for CEGUI::Vector2, including all inherited members.

asSize() const (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
d_x (defined in CEGUI::Vector2) | CEGUI::Vector2 |
d_y (defined in CEGUI::Vector2) | CEGUI::Vector2 |
operator *(const Vector2 &vec) const (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator *=(const Vector2 &vec) (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator!=(const Vector2 &vec) const (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator+(const Vector2 &vec) const (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator+=(const Vector2 &vec) (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator-(const Vector2 &vec) const (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator-=(const Vector2 &vec) (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator/=(const Vector2 &vec) (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
operator==(const Vector2 &vec) const (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
Vector2(void) (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]
Vector2(float x, float y) (defined in CEGUI::Vector2) | CEGUI::Vector2 | [inline]

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Vector3 Member List

This is the complete list of members for CEGUI::Vector3, including all inherited members.

d_x (defined in CEGUI::Vector3) | CEGUI::Vector3 |
d_y (defined in CEGUI::Vector3) | CEGUI::Vector3 |
d_z (defined in CEGUI::Vector3) | CEGUI::Vector3 |
Vector3(void) (defined in CEGUI::Vector3) | CEGUI::Vector3 | [inline]
Vector3(float x, float y, float z) (defined in CEGUI::Vector3) | CEGUI::Vector3 | [inline]

Generated on Sat Nov 26 10:10:02 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WidgetComponent Member List

This is the complete list of members for CEGUI::WidgetComponent, including all inherited members.

addPropertyInitialiser(const PropertyInitialiser &initialiser) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
clearPropertyInitialisers() (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
create(Window &parent) const | CEGUI::WidgetComponent |
getBaseWidgetType() const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
getComponentArea() const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
getHorizontalWidgetAlignemnt() const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
getVerticalWidgetAlignemnt() const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
getWidgetLookName() const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
getWidgetNameSuffix() const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
layout(const Window &owner) const (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
setBaseWidgetType(const String &type) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
setComponentArea(const ComponentArea &area) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
setHorizontalWidgetAlignemnt(HorizontalAlignment alignment) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
setVerticalWidgetAlignment(VerticalAlignment alignment) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
setWidgetLookName(const String &look) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
setWidgetNameSuffix(const String &suffix) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
WidgetComponent() (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent | [inline]
WidgetComponent(const String &type, const String &look, const String &suffix) (defined in CEGUI::WidgetComponent) | CEGUI::WidgetComponent |
writeXMLToStream(OutStream &out_stream) const | CEGUI::WidgetComponent |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WidgetDim Member List

This is the complete list of members for CEGUI::WidgetDim, including all inherited members.

BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim |
clone() const | CEGUI::BaseDim |
clone_impl() const | CEGUI::WidgetDim | [protected, virtual]
getDimensionOperator() const | CEGUI::BaseDim |
getOperand() const | CEGUI::BaseDim |
getValue(const Window &wnd) const | CEGUI::BaseDim |
getValue(const Window &wnd, const Rect &container) const | CEGUI::BaseDim |
getValue_impl(const Window &wnd) const | CEGUI::WidgetDim | [protected, virtual]
getValue_impl(const Window &wnd, const Rect &container) const | CEGUI::WidgetDim | [protected, virtual]
setDimensionOperator(DimensionOperator op) | CEGUI::BaseDim |
setOperand(const BaseDim &operand) | CEGUI::BaseDim |
setSourceDimension(DimensionType dim) | CEGUI::WidgetDim |
setWidgetName(const String &name) | CEGUI::WidgetDim |
WidgetDim(const String &name, DimensionType dim) | CEGUI::WidgetDim |
writeXMLElementAttributes_impl(OutStream &out_stream) const | CEGUI::WidgetDim | [protected, virtual]
writeXMLElementName_impl(OutStream &out_stream) const | CEGUI::WidgetDim | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::BaseDim |
~BaseDim() (defined in CEGUI::BaseDim) | CEGUI::BaseDim | [virtual]

Generated on Sat Nov 26 10:10:09 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WidgetLookFeel Member List

This is the complete list of members for CEGUI::WidgetLookFeel, including all inherited members.

addImagerySection(const ImagerySection &section) | CEGUI::WidgetLookFeel |
addNamedArea(const NamedArea &area) | CEGUI::WidgetLookFeel |
addPropertyDefinition(const PropertyDefinition &propdef) | CEGUI::WidgetLookFeel |
addPropertyInitialiser(const PropertyInitialiser &initialiser) | CEGUI::WidgetLookFeel |
addStateSpecification(const StateImagery &state) | CEGUI::WidgetLookFeel |
addWidgetComponent(const WidgetComponent &widget) | CEGUI::WidgetLookFeel |
clearImagerySections() | CEGUI::WidgetLookFeel |
clearNamedAreas() | CEGUI::WidgetLookFeel |
clearPropertyDefinitions() | CEGUI::WidgetLookFeel |
clearPropertyInitialisers() | CEGUI::WidgetLookFeel |
clearStateSpecifications() | CEGUI::WidgetLookFeel |
clearWidgetComponents() | CEGUI::WidgetLookFeel |
getImagerySection(const CEGUI::String &section) const | CEGUI::WidgetLookFeel |
getName() const | CEGUI::WidgetLookFeel |
getNamedArea(const String &name) const | CEGUI::WidgetLookFeel |
getStateImagery(const CEGUI::String &state) const | CEGUI::WidgetLookFeel |
initialiseWidget(Window &widget) const | CEGUI::WidgetLookFeel |
isNamedAreaDefined(const String &name) const | CEGUI::WidgetLookFeel |
isStateImageryPresent(const String &state) const | CEGUI::WidgetLookFeel |
layoutChildWidgets(const Window &owner) const | CEGUI::WidgetLookFeel |
renameChildren(const Window &widget, const String &newBaseName) const | CEGUI::WidgetLookFeel |
WidgetLookFeel(const String &name) (defined in CEGUI::WidgetLookFeel) | CEGUI::WidgetLookFeel |
WidgetLookFeel() (defined in CEGUI::WidgetLookFeel) | CEGUI::WidgetLookFeel | [inline]
writeXMLToStream(OutStream &out_stream) const | CEGUI::WidgetLookFeel |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WidgetLookManager Member List

This is the complete list of members for CEGUI::WidgetLookManager, including all inherited members.

addWidgetLook(const WidgetLookFeel &look) | CEGUI::WidgetLookManager |
eraseWidgetLook(const String &widget) | CEGUI::WidgetLookManager |
getSingleton(void) | CEGUI::WidgetLookManager | [static]
getSingletonPtr(void) | CEGUI::WidgetLookManager | [static]
getWidgetLook(const String &widget) const | CEGUI::WidgetLookManager |
isWidgetLookAvailable(const String &widget) const | CEGUI::WidgetLookManager |
parseLookNFeelSpecification(const String &filename, const String &resourceGroup="") | CEGUI::WidgetLookManager |
WidgetLookManager() | CEGUI::WidgetLookManager |
writeFalagardXMLHeadToStream(OutStream &out_stream) const | CEGUI::WidgetLookManager |
writeFalagardXMLTailToStream(OutStream &out_stream) const | CEGUI::WidgetLookManager |
writeWidgetLookSeriesToStream(const String &prefix, OutStream &out_stream) const | CEGUI::WidgetLookManager |
writeWidgetLookToStream(const String &name, OutStream &out_stream) const | CEGUI::WidgetLookManager |
~WidgetLookManager() | CEGUI::WidgetLookManager |

Generated on Sat Nov 26 10:10:10 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Window Member List

This is the complete list of members for CEGUI::Window, including all inherited members.

absoluteToRelative(const Point &pt) const | CEGUI::Window |
absoluteToRelative(const Size &sze) const | CEGUI::Window |
absoluteToRelative(const Rect &rect) const | CEGUI::Window |
absoluteToRelative_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelative_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeX(float val) const | CEGUI::Window |
absoluteToRelativeX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
absoluteToRelativeY(float val) const | CEGUI::Window |
absoluteToRelativeY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
activate(void) | CEGUI::Window |
addChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
addChildWindow(const String &name) | CEGUI::Window |
addChildWindow(Window *window) | CEGUI::Window |
addEvent(const String &name) | CEGUI::EventSet |
addProperty(Property *property) | CEGUI::PropertySet |
addStandardEvents(void) | CEGUI::Window | [protected]
addStandardProperties(void) | CEGUI::Window | [protected]
addWindowToDrawList(Window &wnd, bool at_back=false) | CEGUI::Window | [protected]
captureInput(void) | CEGUI::Window |
ChildList typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
cleanupChildren(void) | CEGUI::Window | [protected, virtual]
clearProperties(void) | CEGUI::PropertySet |
d_absHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_absYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_active | CEGUI::Window | [protected]
d_alpha | CEGUI::Window | [protected]
d_alphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_alwaysOnTop | CEGUI::Window | [protected]
d_alwaysOnTopProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_area | CEGUI::Window | [protected]
d_autoRepeat | CEGUI::Window | [protected]
d_autoRepeatDelayProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_autoRepeatRateProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_captureWindow | CEGUI::Window | [protected, static]
d_children | CEGUI::Window | [protected]
d_clippedByParent | CEGUI::Window | [protected]
d_clippedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_customTip | CEGUI::Window | [protected]
d_destroyedByParent | CEGUI::Window | [protected]
d_destroyedByParentProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_disabledProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_distCapturedInputs | CEGUI::Window | [protected]
d_distInputsProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_drawList | CEGUI::Window | [protected]
d_enabled | CEGUI::Window | [protected]
d_events (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
d_falagardType | CEGUI::Window | [protected]
d_font | CEGUI::Window | [protected]
d_fontProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_heightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_horzAlign | CEGUI::Window | [protected]
d_horzAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_ID | CEGUI::Window | [protected]
d_IDProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsAlpha | CEGUI::Window | [protected]
d_inheritsAlphaProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_inheritsTipText | CEGUI::Window | [protected]
d_inheritsTooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_lookName | CEGUI::Window | [protected]
d_maxSize | CEGUI::Window | [protected]
d_metricsMode | CEGUI::Window | [protected]
d_metricsModeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_minSize | CEGUI::Window | [protected]
d_mouseCursor | CEGUI::Window | [protected]
d_mouseCursorProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_muted | CEGUI::EventSet | [protected]
d_name | CEGUI::Window | [protected]
d_needsRedraw | CEGUI::Window | [mutable, protected]
d_oldCapture | CEGUI::Window | [protected]
d_parent | CEGUI::Window | [protected]
d_pixelSize | CEGUI::Window | [protected]
d_positionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_rectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relXPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_relYPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_renderCache | CEGUI::Window | [protected]
d_repeatButton | CEGUI::Window | [protected]
d_repeatDelay | CEGUI::Window | [protected]
d_repeatElapsed | CEGUI::Window | [protected]
d_repeating | CEGUI::Window | [protected]
d_repeatRate | CEGUI::Window | [protected]
d_restoreOldCapture | CEGUI::Window | [protected]
d_restoreOldCaptureProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_riseOnClick | CEGUI::Window | [protected]
d_riseOnClickProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_sizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_text | CEGUI::Window | [protected]
d_textProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_tooltipText | CEGUI::Window | [protected]
d_tooltipTypeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_type | CEGUI::Window | [protected]
d_unifiedAreaRectProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedHeightProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMaxSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedMinSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedSizeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedWidthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedXPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_unifiedYPositionProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_userData | CEGUI::Window | [protected]
d_userStrings | CEGUI::Window | [protected]
d_vertAlign | CEGUI::Window | [protected]
d_vertAlignProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_visible | CEGUI::Window | [protected]
d_visibleProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_wantsMultiClicks | CEGUI::Window | [protected]
d_wantsMultiClicksProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_weOwnTip | CEGUI::Window | [protected]
d_widthProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_xPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_yPosProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderChangeProperty (defined in CEGUI::Window) | CEGUI::Window | [protected, static]
d_zOrderingEnabled | CEGUI::Window | [protected]
deactivate(void) | CEGUI::Window |
destroy(void) | CEGUI::Window | [virtual]
disable(void) | CEGUI::Window | [inline]
distributesCapturedInputs(void) const | CEGUI::Window |
doRiseOnClick(void) | CEGUI::Window | [protected]
drawSelf(float z) | CEGUI::Window | [protected, virtual]
enable(void) | CEGUI::Window | [inline]
EventActivated | CEGUI::Window | [static]
EventAlphaChanged | CEGUI::Window | [static]
EventAlwaysOnTopChanged | CEGUI::Window | [static]
EventCharacterKey | CEGUI::Window | [static]
EventChildAdded | CEGUI::Window | [static]
EventChildRemoved | CEGUI::Window | [static]
EventClippedByParentChanged | CEGUI::Window | [static]
EventDeactivated | CEGUI::Window | [static]
EventDestroyedByParentChanged | CEGUI::Window | [static]
EventDestructionStarted | CEGUI::Window | [static]
EventDisabled | CEGUI::Window | [static]
EventDragDropItemDropped | CEGUI::Window | [static]
EventDragDropItemEnters | CEGUI::Window | [static]
EventDragDropItemLeaves | CEGUI::Window | [static]
EventEnabled | CEGUI::Window | [static]
EventFontChanged | CEGUI::Window | [static]
EventHidden | CEGUI::Window | [static]
EventHorizontalAlignmentChanged | CEGUI::Window | [static]
EventIDChanged | CEGUI::Window | [static]
EventInheritsAlphaChanged | CEGUI::Window | [static]
EventInputCaptureGained | CEGUI::Window | [static]
EventInputCaptureLost | CEGUI::Window | [static]
EventIterator typedef (defined in CEGUI::EventSet) | CEGUI::EventSet |
EventKeyDown | CEGUI::Window | [static]
EventKeyUp | CEGUI::Window | [static]
EventMap typedef (defined in CEGUI::EventSet) | CEGUI::EventSet | [protected]
EventMetricsModeChanged | CEGUI::Window | [static]
EventMouseButtonDown | CEGUI::Window | [static]
EventMouseButtonUp | CEGUI::Window | [static]
EventMouseClick | CEGUI::Window | [static]
EventMouseDoubleClick | CEGUI::Window | [static]
EventMouseEnters | CEGUI::Window | [static]
EventMouseLeaves | CEGUI::Window | [static]
EventMouseMove | CEGUI::Window | [static]
EventMouseTripleClick | CEGUI::Window | [static]
EventMouseWheel | CEGUI::Window | [static]
EventMoved | CEGUI::Window | [static]
EventNamespace | CEGUI::Window | [static]
EventParentSized | CEGUI::Window | [static]
EventRenderingEnded | CEGUI::Window | [static]
EventRenderingStarted | CEGUI::Window | [static]
EventSet() | CEGUI::EventSet |
EventSet(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
EventShown | CEGUI::Window | [static]
EventSized | CEGUI::Window | [static]
EventTextChanged | CEGUI::Window | [static]
EventVerticalAlignmentChanged | CEGUI::Window | [static]
EventZOrderChanged | CEGUI::Window | [static]
fireEvent(const String &name, EventArgs &args, const String &eventNamespace="") | CEGUI::EventSet | [virtual]
generateAutoRepeatEvent(MouseButton button) | CEGUI::Window | [protected]
getAbsoluteHeight(void) const | CEGUI::Window | [inline]
getAbsolutePosition(void) const | CEGUI::Window | [inline]
getAbsoluteRect(void) const | CEGUI::Window | [inline]
getAbsoluteSize(void) const | CEGUI::Window | [inline]
getAbsoluteWidth(void) const | CEGUI::Window | [inline]
getAbsoluteXPosition(void) const | CEGUI::Window | [inline]
getAbsoluteYPosition(void) const | CEGUI::Window | [inline]
getActiveChild(void) | CEGUI::Window |
getActiveChild(void) const (defined in CEGUI::Window) | CEGUI::Window |
getActiveSibling() | CEGUI::Window |
getAlpha(void) const | CEGUI::Window | [inline]
getAutoRepeatDelay(void) const | CEGUI::Window |
getAutoRepeatRate(void) const | CEGUI::Window |
getCaptureWindow(void) | CEGUI::Window | [inline, static]
getChild(const String &name) const | CEGUI::Window |
getChild(uint ID) const | CEGUI::Window |
getChildAtIdx(uint idx) const | CEGUI::Window | [inline]
getChildAtPosition(const Point &position) const | CEGUI::Window |
getChildCount(void) const | CEGUI::Window | [inline]
getEffectiveAlpha(void) const | CEGUI::Window |
getFont(bool useDefault=true) const | CEGUI::Window |
getHeight(void) const | CEGUI::Window |
getHeight(MetricsMode mode) const | CEGUI::Window |
getHorizontalAlignment() const | CEGUI::Window | [inline]
getID(void) const | CEGUI::Window | [inline]
getInheritedMetricsMode(void) const | CEGUI::Window | [protected]
getInnerRect(void) const | CEGUI::Window |
CEGUI::getIterator(void) const | CEGUI::PropertySet |
CEGUI::EventSet::getIterator(void) const | CEGUI::EventSet |
getLookNFeel() | CEGUI::Window |
getMaximumSize(void) const | CEGUI::Window |
getMetricsMode(void) const | CEGUI::Window |
getMinimumSize(void) const | CEGUI::Window |
getModalState(void) const | CEGUI::Window | [inline]
getMouseCursor(bool useDefault=true) const | CEGUI::Window |
getName(void) const | CEGUI::Window | [inline]
getParent(void) const | CEGUI::Window | [inline]
getParentHeight(void) const | CEGUI::Window | [protected]
getParentSize(void) const | CEGUI::Window | [protected]
getParentWidth(void) const | CEGUI::Window | [protected]
getPixelRect(void) const | CEGUI::Window | [virtual]
getPosition(void) const | CEGUI::Window |
getPosition(MetricsMode mode) const | CEGUI::Window |
getProperty(const String &name) const | CEGUI::PropertySet |
getPropertyDefault(const String &name) const | CEGUI::PropertySet |
getPropertyHelp(const String &name) const | CEGUI::PropertySet |
getRect(void) const | CEGUI::Window |
getRect(MetricsMode mode) const | CEGUI::Window |
getRelativeHeight(void) const | CEGUI::Window | [inline]
getRelativePosition(void) const | CEGUI::Window | [inline]
getRelativeRect(void) const | CEGUI::Window | [inline]
getRelativeSize(void) const | CEGUI::Window | [inline]
getRelativeWidth(void) const | CEGUI::Window | [inline]
getRelativeXPosition(void) const | CEGUI::Window | [inline]
getRelativeYPosition(void) const | CEGUI::Window | [inline]
getRenderCache() | CEGUI::Window | [inline]
getSize(void) const | CEGUI::Window |
getSize(MetricsMode mode) const | CEGUI::Window |
getText(void) const | CEGUI::Window | [inline]
getTooltip(void) const | CEGUI::Window |
getTooltipText(void) const | CEGUI::Window |
getTooltipType(void) const | CEGUI::Window |
getType(void) const | CEGUI::Window |
getUnclippedInnerRect(void) const | CEGUI::Window | [virtual]
getUnclippedPixelRect(void) const | CEGUI::Window |
getUserData(void) const | CEGUI::Window | [inline]
getUserString(const String &name) const | CEGUI::Window |
getVerticalAlignment() const | CEGUI::Window | [inline]
getWidth(void) const | CEGUI::Window |
getWidth(MetricsMode mode) const | CEGUI::Window |
getWindowArea() const | CEGUI::Window |
getWindowHeight() const | CEGUI::Window |
getWindowMaxSize() const | CEGUI::Window |
getWindowMinSize() const | CEGUI::Window |
getWindowPosition() const | CEGUI::Window |
getWindowSize() const | CEGUI::Window |
getWindowSize_impl(const Window *window) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
getWindowWidth() const | CEGUI::Window |
getWindowXPosition() const | CEGUI::Window |
getWindowYPosition() const | CEGUI::Window |
getXPosition(void) const | CEGUI::Window |
getXPosition(MetricsMode mode) const | CEGUI::Window |
getYPosition(void) const | CEGUI::Window |
getYPosition(MetricsMode mode) const | CEGUI::Window |
hide(void) | CEGUI::Window | [inline]
inheritsAlpha(void) const | CEGUI::Window | [inline]
inheritsTooltipText(void) const | CEGUI::Window |
initialise(void) | CEGUI::Window | [inline, virtual]
isActive(void) const | CEGUI::Window |
isAlwaysOnTop(void) const | CEGUI::Window | [inline]
isAncestor(const String &name) const | CEGUI::Window |
isAncestor(uint ID) const | CEGUI::Window |
isAncestor(const Window *window) const | CEGUI::Window |
isCapturedByAncestor(void) const | CEGUI::Window | [inline]
isCapturedByChild(void) const | CEGUI::Window | [inline]
isCapturedByThis(void) const | CEGUI::Window | [inline]
isChild(const String &name) const | CEGUI::Window |
isChild(uint ID) const | CEGUI::Window |
isChild(const Window *window) const | CEGUI::Window |
isClippedByParent(void) const | CEGUI::Window | [inline]
isDestroyedByParent(void) const | CEGUI::Window | [inline]
isDisabled(bool localOnly=false) const | CEGUI::Window |
isEventPresent(const String &name) | CEGUI::EventSet |
isHit(const Point &position) const | CEGUI::Window | [virtual]
isMouseAutoRepeatEnabled(void) const | CEGUI::Window |
isMuted(void) const | CEGUI::EventSet |
isPropertyDefault(const String &name) const | CEGUI::PropertySet |
isPropertyPresent(const String &name) const | CEGUI::PropertySet |
isRiseOnClickEnabled(void) const | CEGUI::Window | [inline]
isUserStringDefined(const String &name) const | CEGUI::Window |
isUsingDefaultTooltip(void) const | CEGUI::Window |
isVisible(bool localOnly=false) const | CEGUI::Window |
isZOrderingEnabled(void) const | CEGUI::Window |
moveToBack() | CEGUI::Window |
moveToFront() | CEGUI::Window |
moveToFront_impl(bool wasClicked) | CEGUI::Window | [protected, virtual]
notifyDragDropItemDropped(DragContainer *item) | CEGUI::Window |
notifyDragDropItemEnters(DragContainer *item) | CEGUI::Window |
notifyDragDropItemLeaves(DragContainer *item) | CEGUI::Window |
onActivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onAlwaysOnTopChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureGained(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCaptureLost(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onCharacter(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildAdded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onChildRemoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onClippingChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDeactivated(ActivationEventArgs &e) | CEGUI::Window | [protected, virtual]
onDestructionStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDisabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemDropped(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemEnters(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onDragDropItemLeaves(DragDropEventArgs &e) | CEGUI::Window | [protected, virtual]
onEnabled(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onFontChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHidden(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onHorizontalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onIDChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onInheritsAlphaChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyDown(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onKeyUp(KeyEventArgs &e) | CEGUI::Window | [protected, virtual]
onMetricsChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonDown(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseButtonUp(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseDoubleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseEnters(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseLeaves(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseMove(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseTripleClicked(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMouseWheel(MouseEventArgs &e) | CEGUI::Window | [protected, virtual]
onMoved(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentDestroyChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onParentSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingEnded(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onRenderingStarted(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onShown(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onSized(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onTextChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onVerticalAlignmentChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
onZChange_impl(void) | CEGUI::Window | [protected, virtual]
onZChanged(WindowEventArgs &e) | CEGUI::Window | [protected, virtual]
operator=(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
operator=(EventSet &e) (defined in CEGUI::EventSet) | CEGUI::EventSet | [inline, protected]
performChildWindowLayout() | CEGUI::Window | [virtual]
populateRenderCache() | CEGUI::Window | [inline, protected, virtual]
PropertyIterator typedef (defined in CEGUI::PropertySet) | CEGUI::PropertySet |
PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline]
PropertySet(void) | CEGUI::PropertySet | [inline]
relativeToAbsolute(const Point &pt) const | CEGUI::Window |
relativeToAbsolute(const Size &sze) const | CEGUI::Window |
relativeToAbsolute(const Rect &rect) const | CEGUI::Window |
relativeToAbsolute_impl(const Window *window, const Rect &rect) const | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Size &sz) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsolute_impl(const Window *window, const Point &pt) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteX(float val) const | CEGUI::Window |
relativeToAbsoluteX_impl(const Window *window, float x) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
relativeToAbsoluteY(float val) const | CEGUI::Window |
relativeToAbsoluteY_impl(const Window *window, float y) const (defined in CEGUI::Window) | CEGUI::Window | [protected]
releaseInput(void) | CEGUI::Window |
removeAllEvents(void) | CEGUI::EventSet |
removeChild_impl(Window *wnd) | CEGUI::Window | [protected, virtual]
removeChildWindow(const String &name) | CEGUI::Window |
removeChildWindow(Window *window) | CEGUI::Window |
removeChildWindow(uint ID) | CEGUI::Window |
removeEvent(const String &name) | CEGUI::EventSet |
removeProperty(const String &name) | CEGUI::PropertySet |
removeWindowFromDrawList(const Window &wnd) | CEGUI::Window | [protected]
rename(const String &new_name) | CEGUI::Window |
render(void) | CEGUI::Window |
requestRedraw(void) const | CEGUI::Window |
restoresOldCapture(void) const | CEGUI::Window | [inline]
screenToWindow(const Point &pt) const | CEGUI::Window |
screenToWindow(const Size &sze) const | CEGUI::Window |
screenToWindow(const Rect &rect) const | CEGUI::Window |
screenToWindow(const UVector2 &vec) const | CEGUI::Window |
screenToWindow(const URect &rect) const | CEGUI::Window |
screenToWindowX(float x) const | CEGUI::Window |
screenToWindowX(const UDim &x) const | CEGUI::Window |
screenToWindowY(float y) const | CEGUI::Window |
screenToWindowY(const UDim &y) const | CEGUI::Window |
setAlpha(float alpha) | CEGUI::Window |
setAlwaysOnTop(bool setting) | CEGUI::Window |
setAreaRect(const Rect &area) | CEGUI::Window |
setAutoRepeatDelay(float delay) | CEGUI::Window |
setAutoRepeatRate(float rate) | CEGUI::Window |
setClippedByParent(bool setting) | CEGUI::Window |
setDestroyedByParent(bool setting) | CEGUI::Window |
setDistributesCapturedInputs(bool setting) | CEGUI::Window |
setEnabled(bool setting) | CEGUI::Window |
setFont(const Font *font) | CEGUI::Window |
setFont(const String &name) | CEGUI::Window |
setHeight(float height) | CEGUI::Window |
setHeight(MetricsMode mode, float height) | CEGUI::Window |
setHorizontalAlignment(const HorizontalAlignment alignment) | CEGUI::Window |
setID(uint ID) | CEGUI::Window |
setInheritsAlpha(bool setting) | CEGUI::Window |
setInheritsTooltipText(bool setting) | CEGUI::Window |
setLookNFeel(const String &falagardType, const String &look) | CEGUI::Window |
setMaximumSize(const Size &sz) | CEGUI::Window |
setMetricsMode(MetricsMode mode) | CEGUI::Window |
setMinimumSize(const Size &sz) | CEGUI::Window |
setModalState(bool state) | CEGUI::Window |
setMouseAutoRepeatEnabled(bool setting) | CEGUI::Window |
setMouseCursor(const Image *image) | CEGUI::Window | [inline]
setMouseCursor(MouseCursorImage image) | CEGUI::Window | [inline]
setMouseCursor(const String &imageset, const String &image_name) | CEGUI::Window |
setMutedState(bool setting) | CEGUI::EventSet |
setParent(Window *parent) | CEGUI::Window | [protected]
setPosition(const Point &position) | CEGUI::Window |
setPosition(MetricsMode mode, const Point &position) | CEGUI::Window |
setProperty(const String &name, const String &value) | CEGUI::PropertySet |
setRect(MetricsMode mode, const Rect &area) | CEGUI::Window |
setRestoreCapture(bool setting) | CEGUI::Window |
setRiseOnClickEnabled(bool setting) | CEGUI::Window | [inline]
setSize(const Size &size) | CEGUI::Window |
setSize(MetricsMode mode, const Size &size) | CEGUI::Window |
setText(const String &text) | CEGUI::Window |
setTooltip(Tooltip *tooltip) | CEGUI::Window |
setTooltipText(const String &tip) | CEGUI::Window |
setTooltipType(const String &tooltipType) | CEGUI::Window |
setUserData(void *user_data) | CEGUI::Window | [inline]
setUserString(const String &name, const String &value) | CEGUI::Window |
setVerticalAlignment(const VerticalAlignment alignment) | CEGUI::Window |
setVisible(bool setting) | CEGUI::Window |
setWantsMultiClickEvents(bool setting) | CEGUI::Window |
setWidth(float width) | CEGUI::Window |
setWidth(MetricsMode mode, float width) | CEGUI::Window |
setWindowArea(const UDim &xpos, const UDim &ypos, const UDim &width, const UDim &height) | CEGUI::Window |
setWindowArea(const UVector2 &pos, const UVector2 &size) | CEGUI::Window |
setWindowArea(const URect &area) | CEGUI::Window |
setWindowArea_impl(const UVector2 &pos, const UVector2 &size, bool topLeftSizing=false, bool fireEvents=true) | CEGUI::Window | [protected]
setWindowHeight(const UDim &height) | CEGUI::Window |
setWindowMaxSize(const UVector2 &size) | CEGUI::Window |
setWindowMinSize(const UVector2 &size) | CEGUI::Window |
setWindowPosition(const UVector2 &pos) | CEGUI::Window |
setWindowSize(const UVector2 &size) | CEGUI::Window |
setWindowWidth(const UDim &width) | CEGUI::Window |
setWindowXPosition(const UDim &x) | CEGUI::Window |
setWindowYPosition(const UDim &y) | CEGUI::Window |
setXPosition(float x) | CEGUI::Window |
setXPosition(MetricsMode mode, float x) | CEGUI::Window |
setYPosition(float y) | CEGUI::Window |
setYPosition(MetricsMode mode, float y) | CEGUI::Window |
setZOrderingEnabled(bool setting) | CEGUI::Window |
show(void) | CEGUI::Window | [inline]
subscribeEvent(const String &name, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeEvent(const String &name, Event::Group group, Event::Subscriber subscriber) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, const String &subscriber_name) | CEGUI::EventSet | [virtual]
subscribeScriptedEvent(const String &name, Event::Group group, const String &subscriber_name) | CEGUI::EventSet | [virtual]
System (defined in CEGUI::Window) | CEGUI::Window | [friend]
testClassName(const String &class_name) const | CEGUI::Window | [inline]
testClassName_impl(const String &class_name) const | CEGUI::Window | [inline, protected, virtual]
unifiedToAbsolute(const UVector2 &val) const | CEGUI::Window |
unifiedToAbsolute(const URect &val) const | CEGUI::Window |
unifiedToAbsoluteX(const UDim &val) const | CEGUI::Window |
unifiedToAbsoluteY(const UDim &val) const | CEGUI::Window |
unifiedToRelative(const UVector2 &val) const | CEGUI::Window |
unifiedToRelative(const URect &val) const | CEGUI::Window |
unifiedToRelativeX(const UDim &val) const | CEGUI::Window |
unifiedToRelativeY(const UDim &val) const | CEGUI::Window |
update(float elapsed) | CEGUI::Window |
updateSelf(float elapsed) | CEGUI::Window | [protected, virtual]
UserStringMap typedef (defined in CEGUI::Window) | CEGUI::Window | [protected]
wantsMultiClickEvents(void) const | CEGUI::Window |
Window(const String &type, const String &name) | CEGUI::Window |
Window(const Window &wnd) (defined in CEGUI::Window) | CEGUI::Window | [inline, protected]
windowToScreen(const Point &pt) const | CEGUI::Window |
windowToScreen(const Size &sze) const | CEGUI::Window |
windowToScreen(const Rect &rect) const | CEGUI::Window |
windowToScreen(const UVector2 &vec) const | CEGUI::Window |
windowToScreen(const URect &rect) const | CEGUI::Window |
windowToScreenX(float x) const | CEGUI::Window |
windowToScreenX(const UDim &x) const | CEGUI::Window |
windowToScreenY(float y) const | CEGUI::Window |
windowToScreenY(const UDim &y) const | CEGUI::Window |
writeChildWindowsXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writePropertiesXML(OutStream &out_stream) const (defined in CEGUI::Window) | CEGUI::Window | [protected, virtual]
writeXMLToStream(OutStream &out_stream) const | CEGUI::Window | [virtual]
~EventSet(void) | CEGUI::EventSet | [virtual]
~PropertyReceiver() (defined in CEGUI::PropertyReceiver) | CEGUI::PropertyReceiver | [inline, virtual]
~PropertySet(void) | CEGUI::PropertySet | [inline, virtual]
~Window(void) | CEGUI::Window | [virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowEventArgs Member List

This is the complete list of members for CEGUI::WindowEventArgs, including all inherited members.

EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline]
handled | CEGUI::EventArgs |
window | CEGUI::WindowEventArgs |
WindowEventArgs(Window *wnd) (defined in CEGUI::WindowEventArgs) | CEGUI::WindowEventArgs | [inline]
~EventArgs(void) (defined in CEGUI::EventArgs) | CEGUI::EventArgs | [inline, virtual]

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowFactory Member List

This is the complete list of members for CEGUI::WindowFactory, including all inherited members.

createWindow(const String &name)=0 | CEGUI::WindowFactory | [pure virtual]
d_type | CEGUI::WindowFactory | [protected]
destroyWindow(Window *window)=0 | CEGUI::WindowFactory | [pure virtual]
getTypeName(void) const | CEGUI::WindowFactory | [inline]
WindowFactory(const String &type) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, protected]
~WindowFactory(void) (defined in CEGUI::WindowFactory) | CEGUI::WindowFactory | [inline, virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowFactoryManager Member List

This is the complete list of members for CEGUI::WindowFactoryManager, including all inherited members.

addFactory(WindowFactory *factory) | CEGUI::WindowFactoryManager |
addFalagardWindowMapping(const String &newType, const String &targetType, const String &lookName) | CEGUI::WindowFactoryManager |
addWindowTypeAlias(const String &aliasName, const String &targetType) | CEGUI::WindowFactoryManager |
FalagardMappingIterator typedef (defined in CEGUI::WindowFactoryManager) | CEGUI::WindowFactoryManager |
getAliasIterator(void) const | CEGUI::WindowFactoryManager |
getDereferencedAliasType(const String &type) const | CEGUI::WindowFactoryManager |
getFactory(const String &type) const | CEGUI::WindowFactoryManager |
getFalagardMappingIterator() const | CEGUI::WindowFactoryManager |
getIterator(void) const | CEGUI::WindowFactoryManager |
getMappedLookForType(const String &type) const | CEGUI::WindowFactoryManager |
getSingleton(void) | CEGUI::WindowFactoryManager | [static]
getSingletonPtr(void) | CEGUI::WindowFactoryManager | [static]
isFactoryPresent(const String &name) const | CEGUI::WindowFactoryManager |
isFalagardMappedType(const String &type) const | CEGUI::WindowFactoryManager |
removeAllFactories(void) | CEGUI::WindowFactoryManager | [inline]
removeFactory(const String &name) | CEGUI::WindowFactoryManager |
removeFactory(WindowFactory *factory) | CEGUI::WindowFactoryManager |
removeFalagardWindowMapping(const String &type) | CEGUI::WindowFactoryManager |
removeWindowTypeAlias(const String &aliasName, const String &targetType) | CEGUI::WindowFactoryManager |
TypeAliasIterator typedef (defined in CEGUI::WindowFactoryManager) | CEGUI::WindowFactoryManager |
WindowFactoryIterator typedef (defined in CEGUI::WindowFactoryManager) | CEGUI::WindowFactoryManager |
WindowFactoryManager(void) | CEGUI::WindowFactoryManager | [inline]
~WindowFactoryManager(void) | CEGUI::WindowFactoryManager | [inline]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowFactoryManager::AliasTargetStack Member List

This is the complete list of members for CEGUI::WindowFactoryManager::AliasTargetStack, including all inherited members.

AliasTargetStack(void) | CEGUI::WindowFactoryManager::AliasTargetStack | [inline]
getActiveTarget(void) const | CEGUI::WindowFactoryManager::AliasTargetStack |
getStackedTargetCount(void) const | CEGUI::WindowFactoryManager::AliasTargetStack |
WindowFactoryManager (defined in CEGUI::WindowFactoryManager::AliasTargetStack) | CEGUI::WindowFactoryManager::AliasTargetStack | [friend]
~AliasTargetStack(void) | CEGUI::WindowFactoryManager::AliasTargetStack | [inline]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowManager Member List

This is the complete list of members for CEGUI::WindowManager, including all inherited members.

cleanDeadPool(void) | CEGUI::WindowManager |
createWindow(const String &type, const String &name="") | CEGUI::WindowManager |
destroyAllWindows(void) | CEGUI::WindowManager |
destroyWindow(Window *window) | CEGUI::WindowManager |
destroyWindow(const String &window) | CEGUI::WindowManager |
GeneratedWindowNameBase | CEGUI::WindowManager | [static]
getIterator(void) const | CEGUI::WindowManager |
getSingleton(void) | CEGUI::WindowManager | [static]
getSingletonPtr(void) | CEGUI::WindowManager | [static]
getWindow(const String &name) const | CEGUI::WindowManager |
isDeadPoolEmpty(void) const | CEGUI::WindowManager |
isWindowPresent(const String &name) const | CEGUI::WindowManager |
loadWindowLayout(const String &filename, const String &name_prefix="", const String &resourceGroup="", PropertyCallback *callback=NULL, void *userdata=NULL) | CEGUI::WindowManager |
PropertyCallback typedef | CEGUI::WindowManager |
renameWindow(const String &window, const String &new_name) | CEGUI::WindowManager |
renameWindow(Window *window, const String &new_name) | CEGUI::WindowManager |
WindowIterator typedef (defined in CEGUI::WindowManager) | CEGUI::WindowManager |
WindowManager(void) | CEGUI::WindowManager |
writeWindowLayoutToStream(const Window &window, OutStream &out_stream, bool writeParent=false) const | CEGUI::WindowManager |
writeWindowLayoutToStream(const String &window, OutStream &out_stream, bool writeParent=false) const | CEGUI::WindowManager |
~WindowManager(void) | CEGUI::WindowManager |

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteHeight Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteHeight, including all inherited members.

AbsoluteHeight() (defined in CEGUI::WindowProperties::AbsoluteHeight) | CEGUI::WindowProperties::AbsoluteHeight | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteHeight | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteHeight | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteMaxSize Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteMaxSize, including all inherited members.

AbsoluteMaxSize() (defined in CEGUI::WindowProperties::AbsoluteMaxSize) | CEGUI::WindowProperties::AbsoluteMaxSize | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteMaxSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteMaxSize | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteMaxSize | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteMaxSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteMinSize Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteMinSize, including all inherited members.

AbsoluteMinSize() (defined in CEGUI::WindowProperties::AbsoluteMinSize) | CEGUI::WindowProperties::AbsoluteMinSize | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteMinSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteMinSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsolutePosition Member List

This is the complete list of members for CEGUI::WindowProperties::AbsolutePosition, including all inherited members.

AbsolutePosition() (defined in CEGUI::WindowProperties::AbsolutePosition) | CEGUI::WindowProperties::AbsolutePosition | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsolutePosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsolutePosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteRect Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteRect, including all inherited members.

AbsoluteRect() (defined in CEGUI::WindowProperties::AbsoluteRect) | CEGUI::WindowProperties::AbsoluteRect | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteRect | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteRect | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteSize Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteSize, including all inherited members.

AbsoluteSize() (defined in CEGUI::WindowProperties::AbsoluteSize) | CEGUI::WindowProperties::AbsoluteSize | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteWidth Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteWidth, including all inherited members.

AbsoluteWidth() (defined in CEGUI::WindowProperties::AbsoluteWidth) | CEGUI::WindowProperties::AbsoluteWidth | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteWidth | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteWidth | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteXPosition Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteXPosition, including all inherited members.

AbsoluteXPosition() (defined in CEGUI::WindowProperties::AbsoluteXPosition) | CEGUI::WindowProperties::AbsoluteXPosition | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteXPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteXPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AbsoluteYPosition Member List

This is the complete list of members for CEGUI::WindowProperties::AbsoluteYPosition, including all inherited members.

AbsoluteYPosition() (defined in CEGUI::WindowProperties::AbsoluteYPosition) | CEGUI::WindowProperties::AbsoluteYPosition | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AbsoluteYPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AbsoluteYPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Alpha Member List

This is the complete list of members for CEGUI::WindowProperties::Alpha, including all inherited members.

Alpha() (defined in CEGUI::WindowProperties::Alpha) | CEGUI::WindowProperties::Alpha | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Alpha | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Alpha | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AlwaysOnTop Member List

This is the complete list of members for CEGUI::WindowProperties::AlwaysOnTop, including all inherited members.

AlwaysOnTop() (defined in CEGUI::WindowProperties::AlwaysOnTop) | CEGUI::WindowProperties::AlwaysOnTop | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AlwaysOnTop | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AlwaysOnTop | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AutoRepeatDelay Member List

This is the complete list of members for CEGUI::WindowProperties::AutoRepeatDelay, including all inherited members.

AutoRepeatDelay() (defined in CEGUI::WindowProperties::AutoRepeatDelay) | CEGUI::WindowProperties::AutoRepeatDelay | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AutoRepeatDelay | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AutoRepeatDelay | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::AutoRepeatRate Member List

This is the complete list of members for CEGUI::WindowProperties::AutoRepeatRate, including all inherited members.

AutoRepeatRate() (defined in CEGUI::WindowProperties::AutoRepeatRate) | CEGUI::WindowProperties::AutoRepeatRate | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::AutoRepeatRate | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::AutoRepeatRate | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::ClippedByParent Member List

This is the complete list of members for CEGUI::WindowProperties::ClippedByParent, including all inherited members.

ClippedByParent() (defined in CEGUI::WindowProperties::ClippedByParent) | CEGUI::WindowProperties::ClippedByParent | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::ClippedByParent | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::ClippedByParent | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::CustomTooltipType Member List

This is the complete list of members for CEGUI::WindowProperties::CustomTooltipType, including all inherited members.

CustomTooltipType() (defined in CEGUI::WindowProperties::CustomTooltipType) | CEGUI::WindowProperties::CustomTooltipType | [inline]
d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::CustomTooltipType | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::CustomTooltipType | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::DestroyedByParent Member List

This is the complete list of members for CEGUI::WindowProperties::DestroyedByParent, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DestroyedByParent() (defined in CEGUI::WindowProperties::DestroyedByParent) | CEGUI::WindowProperties::DestroyedByParent | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::DestroyedByParent | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::DestroyedByParent | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Disabled Member List

This is the complete list of members for CEGUI::WindowProperties::Disabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
Disabled() (defined in CEGUI::WindowProperties::Disabled) | CEGUI::WindowProperties::Disabled | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Disabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Disabled | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Disabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::DistributeCapturedInputs Member List

This is the complete list of members for CEGUI::WindowProperties::DistributeCapturedInputs, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
DistributeCapturedInputs() (defined in CEGUI::WindowProperties::DistributeCapturedInputs) | CEGUI::WindowProperties::DistributeCapturedInputs | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::DistributeCapturedInputs | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::DistributeCapturedInputs | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Font Member List

This is the complete list of members for CEGUI::WindowProperties::Font, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
Font() (defined in CEGUI::WindowProperties::Font) | CEGUI::WindowProperties::Font | [inline]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Font | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Font | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Font | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Height Member List

This is the complete list of members for CEGUI::WindowProperties::Height, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Height | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
Height() (defined in CEGUI::WindowProperties::Height) | CEGUI::WindowProperties::Height | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Height | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::HorizontalAlignment Member List

This is the complete list of members for CEGUI::WindowProperties::HorizontalAlignment, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::HorizontalAlignment | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
HorizontalAlignment() (defined in CEGUI::WindowProperties::HorizontalAlignment) | CEGUI::WindowProperties::HorizontalAlignment | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::HorizontalAlignment | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::ID Member List

This is the complete list of members for CEGUI::WindowProperties::ID, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::ID | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
ID() (defined in CEGUI::WindowProperties::ID) | CEGUI::WindowProperties::ID | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::ID | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::InheritsAlpha Member List

This is the complete list of members for CEGUI::WindowProperties::InheritsAlpha, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::InheritsAlpha | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
InheritsAlpha() (defined in CEGUI::WindowProperties::InheritsAlpha) | CEGUI::WindowProperties::InheritsAlpha | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::InheritsAlpha | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::InheritsTooltipText Member List

This is the complete list of members for CEGUI::WindowProperties::InheritsTooltipText, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::InheritsTooltipText | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
InheritsTooltipText() (defined in CEGUI::WindowProperties::InheritsTooltipText) | CEGUI::WindowProperties::InheritsTooltipText | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::InheritsTooltipText | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::MetricsMode Member List

This is the complete list of members for CEGUI::WindowProperties::MetricsMode, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::MetricsMode | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MetricsMode() (defined in CEGUI::WindowProperties::MetricsMode) | CEGUI::WindowProperties::MetricsMode | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::MetricsMode | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::MouseButtonDownAutoRepeat Member List

This is the complete list of members for CEGUI::WindowProperties::MouseButtonDownAutoRepeat, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::MouseButtonDownAutoRepeat | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
MouseButtonDownAutoRepeat() (defined in CEGUI::WindowProperties::MouseButtonDownAutoRepeat) | CEGUI::WindowProperties::MouseButtonDownAutoRepeat | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::MouseButtonDownAutoRepeat | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::MouseCursorImage Member List

This is the complete list of members for CEGUI::WindowProperties::MouseCursorImage, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::MouseCursorImage | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::MouseCursorImage | [virtual]
MouseCursorImage() (defined in CEGUI::WindowProperties::MouseCursorImage) | CEGUI::WindowProperties::MouseCursorImage | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::MouseCursorImage | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Position Member List

This is the complete list of members for CEGUI::WindowProperties::Position, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Position | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Position() (defined in CEGUI::WindowProperties::Position) | CEGUI::WindowProperties::Position | [inline]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Position | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Rect Member List

This is the complete list of members for CEGUI::WindowProperties::Rect, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Rect | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
Rect() (defined in CEGUI::WindowProperties::Rect) | CEGUI::WindowProperties::Rect | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Rect | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeHeight Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeHeight, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeHeight | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeHeight() (defined in CEGUI::WindowProperties::RelativeHeight) | CEGUI::WindowProperties::RelativeHeight | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeHeight | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeMaxSize Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeMaxSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeMaxSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeMaxSize() (defined in CEGUI::WindowProperties::RelativeMaxSize) | CEGUI::WindowProperties::RelativeMaxSize | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeMaxSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeMinSize Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeMinSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeMinSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeMinSize() (defined in CEGUI::WindowProperties::RelativeMinSize) | CEGUI::WindowProperties::RelativeMinSize | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeMinSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:18 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativePosition Member List

This is the complete list of members for CEGUI::WindowProperties::RelativePosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativePosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativePosition() (defined in CEGUI::WindowProperties::RelativePosition) | CEGUI::WindowProperties::RelativePosition | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativePosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeRect Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeRect, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeRect | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeRect() (defined in CEGUI::WindowProperties::RelativeRect) | CEGUI::WindowProperties::RelativeRect | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeRect | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeSize Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeSize, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeSize | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeSize() (defined in CEGUI::WindowProperties::RelativeSize) | CEGUI::WindowProperties::RelativeSize | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeSize | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeWidth Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeWidth, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeWidth | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeWidth() (defined in CEGUI::WindowProperties::RelativeWidth) | CEGUI::WindowProperties::RelativeWidth | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeWidth | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeXPosition Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeXPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeXPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeXPosition() (defined in CEGUI::WindowProperties::RelativeXPosition) | CEGUI::WindowProperties::RelativeXPosition | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeXPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RelativeYPosition Member List

This is the complete list of members for CEGUI::WindowProperties::RelativeYPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RelativeYPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RelativeYPosition() (defined in CEGUI::WindowProperties::RelativeYPosition) | CEGUI::WindowProperties::RelativeYPosition | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RelativeYPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RestoreOldCapture Member List

This is the complete list of members for CEGUI::WindowProperties::RestoreOldCapture, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RestoreOldCapture | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RestoreOldCapture() (defined in CEGUI::WindowProperties::RestoreOldCapture) | CEGUI::WindowProperties::RestoreOldCapture | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RestoreOldCapture | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::RiseOnClick Member List

This is the complete list of members for CEGUI::WindowProperties::RiseOnClick, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::RiseOnClick | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
RiseOnClick() (defined in CEGUI::WindowProperties::RiseOnClick) | CEGUI::WindowProperties::RiseOnClick | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::RiseOnClick | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Size Member List

This is the complete list of members for CEGUI::WindowProperties::Size, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Size | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Size | [virtual]
Size() (defined in CEGUI::WindowProperties::Size) | CEGUI::WindowProperties::Size | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Text Member List

This is the complete list of members for CEGUI::WindowProperties::Text, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Text | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Text | [virtual]
Text() (defined in CEGUI::WindowProperties::Text) | CEGUI::WindowProperties::Text | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Tooltip Member List

This is the complete list of members for CEGUI::WindowProperties::Tooltip, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Tooltip | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Tooltip | [virtual]
Tooltip() (defined in CEGUI::WindowProperties::Tooltip) | CEGUI::WindowProperties::Tooltip | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::VerticalAlignment Member List

This is the complete list of members for CEGUI::WindowProperties::VerticalAlignment, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::VerticalAlignment | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::VerticalAlignment | [virtual]
VerticalAlignment() (defined in CEGUI::WindowProperties::VerticalAlignment) | CEGUI::WindowProperties::VerticalAlignment | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Visible Member List

This is the complete list of members for CEGUI::WindowProperties::Visible, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Visible | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Visible | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Visible | [virtual]
Visible() (defined in CEGUI::WindowProperties::Visible) | CEGUI::WindowProperties::Visible | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::WantsMultiClickEvents Member List

This is the complete list of members for CEGUI::WindowProperties::WantsMultiClickEvents, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::WantsMultiClickEvents | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::WantsMultiClickEvents | [virtual]
WantsMultiClickEvents() (defined in CEGUI::WindowProperties::WantsMultiClickEvents) | CEGUI::WindowProperties::WantsMultiClickEvents | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::Width Member List

This is the complete list of members for CEGUI::WindowProperties::Width, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::Width | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::Width | [virtual]
Width() (defined in CEGUI::WindowProperties::Width) | CEGUI::WindowProperties::Width | [inline]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::XPosition Member List

This is the complete list of members for CEGUI::WindowProperties::XPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::XPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::XPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
XPosition() (defined in CEGUI::WindowProperties::XPosition) | CEGUI::WindowProperties::XPosition | [inline]
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:19 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::YPosition Member List

This is the complete list of members for CEGUI::WindowProperties::YPosition, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::YPosition | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::YPosition | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
YPosition() (defined in CEGUI::WindowProperties::YPosition) | CEGUI::WindowProperties::YPosition | [inline]
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowProperties::ZOrderChangeEnabled Member List

This is the complete list of members for CEGUI::WindowProperties::ZOrderChangeEnabled, including all inherited members.

d_default | CEGUI::Property | [protected]
d_help | CEGUI::Property | [protected]
d_name | CEGUI::Property | [protected]
d_writeXML | CEGUI::Property | [protected]
get(const PropertyReceiver *receiver) const | CEGUI::WindowProperties::ZOrderChangeEnabled | [virtual]
getDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
getHelp(void) const | CEGUI::Property | [inline]
getName(void) const | CEGUI::Property | [inline]
isDefault(const PropertyReceiver *receiver) const | CEGUI::Property | [virtual]
Property(const String &name, const String &help, const String &defaultValue="", bool writesXML=true) | CEGUI::Property | [inline]
set(PropertyReceiver *receiver, const String &value) | CEGUI::WindowProperties::ZOrderChangeEnabled | [virtual]
writeXMLToStream(const PropertyReceiver *receiver, OutStream &out_stream) const | CEGUI::Property |
ZOrderChangeEnabled() (defined in CEGUI::WindowProperties::ZOrderChangeEnabled) | CEGUI::WindowProperties::ZOrderChangeEnabled | [inline]
~Property(void) | CEGUI::Property | [inline, virtual]

Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::XercesParser Member List

This is the complete list of members for CEGUI::XercesParser, including all inherited members.

cleanup(void) | CEGUI::XMLParser |
cleanupImpl(void) | CEGUI::XercesParser | [protected, virtual]
createReader(XERCES_CPP_NAMESPACE::DefaultHandler &handler) (defined in CEGUI::XercesParser) | CEGUI::XercesParser | [protected, static]
d_identifierString | CEGUI::XMLParser | [protected]
doParse(XERCES_CPP_NAMESPACE::SAX2XMLReader *parser, const String &xmlFilename, const String &resourceGroup) (defined in CEGUI::XercesParser) | CEGUI::XercesParser | [protected, static]
getIdentifierString() const | CEGUI::XMLParser |
initialise(void) | CEGUI::XMLParser |
initialiseImpl(void) | CEGUI::XercesParser | [protected, virtual]
initialiseSchema(XERCES_CPP_NAMESPACE::SAX2XMLReader *reader, const String &schemaName, const String &xmlFilename, const String &resourceGroup) (defined in CEGUI::XercesParser) | CEGUI::XercesParser | [protected, static]
parseXMLFile(XMLHandler &handler, const String &filename, const String &schemaName, const String &resourceGroup) | CEGUI::XercesParser | [virtual]
populateAttributesBlock(const XERCES_CPP_NAMESPACE::Attributes &src, XMLAttributes &dest) | CEGUI::XercesParser | [static]
transcodeXmlCharToString(const XMLCh *const xmlch_str) | CEGUI::XercesParser | [static]
XercesParser(void) (defined in CEGUI::XercesParser) | CEGUI::XercesParser |
XMLParser(void) | CEGUI::XMLParser |
~XercesParser(void) (defined in CEGUI::XercesParser) | CEGUI::XercesParser |
~XMLParser(void) | CEGUI::XMLParser | [virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::XMLAttributes Member List

This is the complete list of members for CEGUI::XMLAttributes, including all inherited members.

add(const String &attrName, const String &attrValue) | CEGUI::XMLAttributes |
AttributeMap typedef (defined in CEGUI::XMLAttributes) | CEGUI::XMLAttributes | [protected]
d_attrs (defined in CEGUI::XMLAttributes) | CEGUI::XMLAttributes | [protected]
exists(const String &attrName) const | CEGUI::XMLAttributes |
getCount(void) const | CEGUI::XMLAttributes |
getName(size_t index) const | CEGUI::XMLAttributes |
getValue(size_t index) const | CEGUI::XMLAttributes |
getValue(const String &attrName) const | CEGUI::XMLAttributes |
getValueAsBool(const String &attrName, bool def=false) const | CEGUI::XMLAttributes |
getValueAsFloat(const String &attrName, float def=0.0f) const | CEGUI::XMLAttributes |
getValueAsInteger(const String &attrName, int def=0) const | CEGUI::XMLAttributes |
getValueAsString(const String &attrName, const String &def="") const | CEGUI::XMLAttributes |
remove(const String &attrName) | CEGUI::XMLAttributes |
XMLAttributes(void) | CEGUI::XMLAttributes |
~XMLAttributes(void) | CEGUI::XMLAttributes | [virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::XMLParser Member List

This is the complete list of members for CEGUI::XMLParser, including all inherited members.

cleanup(void) | CEGUI::XMLParser |
cleanupImpl(void)=0 | CEGUI::XMLParser | [protected, pure virtual]
d_identifierString | CEGUI::XMLParser | [protected]
getIdentifierString() const | CEGUI::XMLParser |
initialise(void) | CEGUI::XMLParser |
initialiseImpl(void)=0 | CEGUI::XMLParser | [protected, pure virtual]
parseXMLFile(XMLHandler &handler, const String &filename, const String &schemaName, const String &resourceGroup)=0 | CEGUI::XMLParser | [pure virtual]
XMLParser(void) | CEGUI::XMLParser |
~XMLParser(void) | CEGUI::XMLParser | [virtual]

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Alphabetical List

Crazy Eddies GUI System Class Index

A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | R | S | T | U | V | W | X | Y | Z | _

A
DragCursorImage (CEGUI::DragContainerProperties) InvalidRequestException (CEGUI) Rect (CEGUI) TabTextPadding (CEGUI::TabControlProperties)
AbsoluteDim (CEGUI) DragDropEventArgs (CEGUI) IrrlichtRenderer (CEGUI) Rect (CEGUI::WindowProperties) Text (CEGUI::WindowProperties)
AbsoluteHeight (CEGUI::WindowProperties) | DraggingEnabled (CEGUI::TitlebarProperties) | ItemEntry (CEGUI) | RegexValidator (CEGUI) | TextColour (CEGUI::TextItemProperties)
AbsoluteMaxSize (CEGUI::WindowProperties) | DraggingEnabled (CEGUI::DragContainerProperties) | ItemListBase (CEGUI) | RelativeHeight (CEGUI::WindowProperties) | TextColours (CEGUI::StaticTextProperties)
AbsoluteMinSize (CEGUI::WindowProperties) | DragMovingEnabled (CEGUI::FrameWindowProperties) | ItemSpacing (CEGUI::MenuBaseProperties) | RelativeMaxSize (CEGUI::WindowProperties) | TextComponent (CEGUI)
AbsolutePosition (CEGUI::WindowProperties) | DragThreshold (CEGUI::DragContainerProperties) | ItemTooltips (CEGUI::ListboxProperties) | RelativeMinSize (CEGUI::WindowProperties) | TextFormatting (CEGUI::TextItemProperties)
AbsoluteRect (CEGUI::WindowProperties)
E
K
RelativePosition (CEGUI::WindowProperties) TextInputMode (CEGUI::SpinnerProperties)
AbsoluteSize (CEGUI::WindowProperties) Editbox (CEGUI) Key (CEGUI) RelativeRect (CEGUI::WindowProperties) TextItem (CEGUI)
AbsoluteTabHeight (CEGUI::TabControlProperties) EditSelectionLength (CEGUI::ComboboxProperties) KeyEventArgs (CEGUI) RelativeSize (CEGUI::WindowProperties) Texture (CEGUI)
AbsoluteTabTextPadding (CEGUI::TabControlProperties) EditSelectionStart (CEGUI::ComboboxProperties)
L
RelativeTabHeight (CEGUI::TabControlProperties) TextUtils (CEGUI)
AbsoluteWidth (CEGUI::WindowProperties) | Event (CEGUI) | LayerSpecification (CEGUI) | RelativeTabTextPadding (CEGUI::TabControlProperties) | TextXOffset (CEGUI::TextItemProperties)
AbsoluteXPosition (CEGUI::WindowProperties) Event::ConnectionInterface (CEGUI) LeftFrameImage (CEGUI::StaticProperties) RelativeWidth (CEGUI::WindowProperties) TextXOffset (CEGUI::PushButtonProperties)
AbsoluteYPosition (CEGUI::WindowProperties) Event::ScopedConnection (CEGUI) Listbox (CEGUI) RelativeXPosition (CEGUI::WindowProperties) Thumb (CEGUI)
ActivationEventArgs (CEGUI) EventArgs (CEGUI) ListboxItem (CEGUI) RelativeYPosition (CEGUI::WindowProperties) TinyXMLParser (CEGUI)
ActiveEditSelectionColour (CEGUI::ComboboxProperties) EventSet (CEGUI) ListboxTextItem (CEGUI) RenderableFrame (CEGUI) Titlebar (CEGUI)
ActiveSelectionColour (CEGUI::EditboxProperties) EWSizingCursorImage (CEGUI::FrameWindowProperties) ListHeader (CEGUI) RenderableImage (CEGUI) TitlebarEnabled (CEGUI::FrameWindowProperties)
ActiveSelectionColour (CEGUI::MultiLineEditboxProperties) Exception (CEGUI) ListHeaderSegment (CEGUI) RenderCache (CEGUI) TitlebarFont (CEGUI::FrameWindowProperties)
AllowMultiplePopups (CEGUI::MenuBaseProperties)
F
Logger (CEGUI) Renderer (CEGUI) TiXmlAttribute
Alpha (CEGUI::WindowProperties) FactoryModule (CEGUI)
M
RendererException (CEGUI) TiXmlBase
AlreadyExistsException (CEGUI) | FadeInTime (CEGUI::PopupMenuProperties) | MaskCodepoint (CEGUI::EditboxProperties) | ResourceProvider (CEGUI) | TiXmlComment
AlwaysOnTop (CEGUI::WindowProperties) | FadeOutTime (CEGUI::PopupMenuProperties) | MaskText (CEGUI::EditboxProperties) | RestoreOldCapture (CEGUI::WindowProperties) | TiXmlDeclaration
AutoRepeatDelay (CEGUI::WindowProperties) FadeTime (CEGUI::TooltipProperties) MaxEditTextLength (CEGUI::ComboboxProperties) RightFrameImage (CEGUI::StaticProperties) TiXmlDocument
AutoRepeatRate (CEGUI::WindowProperties) | Falagard_xmlHandler (CEGUI) | MaximumValue (CEGUI::SpinnerProperties) | RiseOnClick (CEGUI::WindowProperties) | TiXmlElement
AutoResizeEnabled (CEGUI::ItemListBaseProperties) | FalagardComponentBase (CEGUI) | MaximumValue (CEGUI::SliderProperties) | RollUpEnabled (CEGUI::FrameWindowProperties) | TiXmlHandle
B
FalagardXMLHelper (CEGUI) MaxTextLength (CEGUI::EditboxProperties) RollUpState (CEGUI::FrameWindowProperties) TiXmlNode
BackgroundColours (CEGUI::MenuBaseProperties) | FileIOException (CEGUI) | MaxTextLength (CEGUI::MultiLineEditboxProperties) | RowCount (CEGUI::MultiColumnListProperties) | TiXmlText
BackgroundColours (CEGUI::StaticProperties) Font (CEGUI) MCLGridRef (CEGUI)
S
TiXmlUnknown
BackgroundEnabled (CEGUI::StaticProperties) Font (CEGUI::WindowProperties) MemoryException (CEGUI) Scheme (CEGUI) Tooltip (CEGUI)
BackgroundImage (CEGUI::StaticProperties) Font_xmlHandler (CEGUI) Menubar (CEGUI) Scheme_xmlHandler (CEGUI) Tooltip (CEGUI::WindowProperties)
BaseDim (CEGUI) FontDim (CEGUI) MenuBase (CEGUI) SchemeManager (CEGUI) TopFrameImage (CEGUI::StaticProperties)
BorderWidth (CEGUI::MenuBaseProperties) | FontManager (CEGUI) | MenuItem (CEGUI) | ScriptFunctor (CEGUI) | TopLeftFrameImage (CEGUI::StaticProperties)
BottomFrameImage (CEGUI::StaticProperties) ForceHorzScrollbar (CEGUI::ListboxProperties) MetricsMode (CEGUI::WindowProperties) ScriptModule (CEGUI) TopRightFrameImage (CEGUI::StaticProperties)
BottomLeftFrameImage (CEGUI::StaticProperties) ForceHorzScrollbar (CEGUI::ComboboxProperties) MinimumValue (CEGUI::SpinnerProperties) ScrollablePane (CEGUI)
U
BottomRightFrameImage (CEGUI::StaticProperties) ForceHorzScrollbar (CEGUI::ScrollablePaneProperties) MouseButtonDownAutoRepeat (CEGUI::WindowProperties) Scrollbar (CEGUI) UDim (CEGUI)
ButtonBase (CEGUI) ForceHorzScrollbar (CEGUI::MultiColumnListProperties) MouseClickTracker (CEGUI) ScrolledContainer (CEGUI) UnifiedDim (CEGUI)
C
ForceVertScrollbar (CEGUI::ListboxProperties) MouseCursor (CEGUI) ScrolledContainerFactory (CEGUI) UnknownObjectException (CEGUI)
CaptionColour (CEGUI::FrameWindowProperties) ForceVertScrollbar (CEGUI::ComboboxProperties) MouseCursorEventArgs (CEGUI) ScrollPosition (CEGUI::ScrollbarProperties) URect (CEGUI)
CaptionColour (CEGUI::TitlebarProperties) ForceVertScrollbar (CEGUI::ScrollablePaneProperties) MouseCursorImage (CEGUI::WindowProperties) SectionSpecification (CEGUI) UseStandardImagery (CEGUI::PushButtonProperties)
CaratIndex (CEGUI::EditboxProperties) ForceVertScrollbar (CEGUI::MultiColumnListProperties) MouseEventArgs (CEGUI) Selected (CEGUI::CheckboxProperties) UVector2 (CEGUI)
CaratIndex (CEGUI::ComboboxProperties) FrameColours (CEGUI::StaticProperties) MultiColumnList (CEGUI) Selected (CEGUI::RadioButtonProperties)
V
CaratIndex (CEGUI::MultiLineEditboxProperties) FrameComponent (CEGUI) MultiColumnList::ListRow (CEGUI) SelectedEditTextColour (CEGUI::ComboboxProperties) ValidationString (CEGUI::ComboboxProperties)
Checkbox (CEGUI) FrameEnabled (CEGUI::FrameWindowProperties) MultiLineEditbox (CEGUI) SelectedTextColour (CEGUI::EditboxProperties) ValidationString (CEGUI::EditboxProperties)
ChildExtentsArea (CEGUI::ScrolledContainerProperties) FrameEnabled (CEGUI::StaticProperties) MultiLineEditbox::LineInfo (CEGUI) SelectedTextColour (CEGUI::MultiLineEditboxProperties) Vector2 (CEGUI)
Clickable (CEGUI::ListHeaderSegmentProperties) FrameWindow (CEGUI) MultiSelect (CEGUI::ListboxProperties) SelectionLength (CEGUI::EditboxProperties) Vector3 (CEGUI)
ClickStepSize (CEGUI::SliderProperties)
G
N
SelectionLength (CEGUI::MultiLineEditboxProperties) VertFormatting (CEGUI::StaticTextProperties)
ClippedByParent (CEGUI::WindowProperties) GenericException (CEGUI) NamedArea (CEGUI) SelectionMode (CEGUI::MultiColumnListProperties) VertFormatting (CEGUI::StaticImageProperties)
CloseButtonEnabled (CEGUI::FrameWindowProperties) GlobalEventSet (CEGUI) NESWSizingCursorImage (CEGUI::FrameWindowProperties) SelectionStart (CEGUI::MultiLineEditboxProperties) VertFree (CEGUI::ThumbProperties)
colour (CEGUI) GroupID (CEGUI::RadioButtonProperties) NominatedSelectionColumnID (CEGUI::MultiColumnListProperties) SelectionStart (CEGUI::EditboxProperties) VerticalAlignment (CEGUI::WindowProperties)
ColourRect (CEGUI) GUILayout_xmlHandler (CEGUI) NominatedSelectionRow (CEGUI::MultiColumnListProperties) SimpleTimer (CEGUI) VertOverlapSize (CEGUI::ScrollablePaneProperties)
ColumnHeader (CEGUI::MultiColumnListProperties) | GUISheet (CEGUI) | NormalEditTextColour (CEGUI::ComboboxProperties) | SingleClickMode (CEGUI::ComboboxProperties) | VertPadding (CEGUI::MenuBaseProperties)
ColumnsMovable (CEGUI::ListHeaderProperties) GUISheetFactory (CEGUI) NormalImage (CEGUI::PushButtonProperties) Sizable (CEGUI::ListHeaderSegmentProperties) VertRange (CEGUI::ThumbProperties)
ColumnsMovable (CEGUI::MultiColumnListProperties)
H
NormalTextColour (CEGUI::EditboxProperties) Size (CEGUI::WindowProperties) VertScrollbar (CEGUI::StaticTextProperties)
ColumnsSizable (CEGUI::ListHeaderProperties) HeaderSequenceEventArgs (CEGUI) NormalTextColour (CEGUI::ButtonBaseProperties) Size (CEGUI) VertScrollPosition (CEGUI::ScrollablePaneProperties)
ColumnsSizable (CEGUI::MultiColumnListProperties) Height (CEGUI::WindowProperties) NormalTextColour (CEGUI::MultiLineEditboxProperties) SizingBorderThickness (CEGUI::FrameWindowProperties) VertStepSize (CEGUI::ScrollablePaneProperties)
Combobox (CEGUI) | HorizontalAlignment (CEGUI::WindowProperties) | NormalTextColour (CEGUI::MenuItemProperties) | SizingEnabled (CEGUI::FrameWindowProperties) | Visible (CEGUI::WindowProperties)
ComboDropList (CEGUI) HorzFormatting (CEGUI::StaticTextProperties) NSSizingCursorImage (CEGUI::FrameWindowProperties) Slider (CEGUI)
W
ComponentArea (CEGUI) HorzFormatting (CEGUI::StaticImageProperties) NullObjectException (CEGUI) Sort (CEGUI::ListboxProperties) WantsMultiClickEvents (CEGUI::WindowProperties)
Config_xmlHandler (CEGUI) HorzFree (CEGUI::ThumbProperties) NWSESizingCursorImage (CEGUI::FrameWindowProperties) SortColumnID (CEGUI::MultiColumnListProperties) WidgetComponent (CEGUI)
ConstBaseIterator (CEGUI) HorzOverlapSize (CEGUI::ScrollablePaneProperties)
O
SortColumnID (CEGUI::ListHeaderProperties) WidgetDim (CEGUI)
ContentArea (CEGUI::ScrolledContainerProperties) | HorzPadding (CEGUI::MenuBaseProperties) | ObjectInUseException (CEGUI) | SortDirection (CEGUI::ListHeaderSegmentProperties) | WidgetLookFeel (CEGUI)
ContentArea (CEGUI::ScrollablePaneProperties) | HorzRange (CEGUI::ThumbProperties) | OpenedColour (CEGUI::MenuItemProperties) | SortDirection (CEGUI::ListHeaderProperties) | WidgetLookManager (CEGUI)
ContentPaneAutoSized (CEGUI::ScrolledContainerProperties) HorzScrollbar (CEGUI::StaticTextProperties) OpenGLRenderer (CEGUI) SortDirection (CEGUI::MultiColumnListProperties) Width (CEGUI::WindowProperties)
ContentPaneAutoSized (CEGUI::ScrollablePaneProperties) HorzScrollPosition (CEGUI::ScrollablePaneProperties) OpenGLTexture (CEGUI) SortList (CEGUI::ComboboxProperties) Window (CEGUI)
CurrentProgress (CEGUI::ProgressBarProperties) HorzStepSize (CEGUI::ScrollablePaneProperties) OverlapSize (CEGUI::ScrollbarProperties) SortSettingEnabled (CEGUI::MultiColumnListProperties) WindowEventArgs (CEGUI)
CurrentValue (CEGUI::SpinnerProperties) HotTracked (CEGUI::ThumbProperties)
P
SortSettingEnabled (CEGUI::ListHeaderProperties) WindowFactory (CEGUI)
CurrentValue (CEGUI::SliderProperties) | HoverColour (CEGUI::MenuItemProperties) | PageSize (CEGUI::ScrollbarProperties) | Spinner (CEGUI) | WindowFactoryManager (CEGUI)
CustomTooltipType (CEGUI::WindowProperties) HoverImage (CEGUI::PushButtonProperties) PopupMenu (CEGUI) StateImagery (CEGUI) WindowFactoryManager::AliasTargetStack (CEGUI)
D
HoverTextColour (CEGUI::ButtonBaseProperties) Position (CEGUI::WindowProperties) Static (CEGUI) WindowFactoryManager::FalagardWindowMapping (CEGUI)
DestroyedByParent (CEGUI::WindowProperties) HoverTime (CEGUI::TooltipProperties) ProgressBar (CEGUI) StaticImage (CEGUI) WindowManager (CEGUI)
Dimension (CEGUI)
I
Property (CEGUI) StaticText (CEGUI) WordWrap (CEGUI::MultiLineEditboxProperties)
DirectX81Renderer (CEGUI) ID (CEGUI::WindowProperties) PropertyDefinition (CEGUI) StepSize (CEGUI::ProgressBarProperties)
X
DirectX81Texture (CEGUI) Image (CEGUI::StaticImageProperties) PropertyDim (CEGUI) StepSize (CEGUI::ScrollbarProperties) XercesParser (CEGUI)
DirectX9Renderer (CEGUI) | Image (CEGUI) | PropertyHelper (CEGUI) | StepSize (CEGUI::SpinnerProperties) | XMLAttributes (CEGUI)
DirectX9Texture (CEGUI) ImageColours (CEGUI::StaticImageProperties) PropertyInitialiser (CEGUI) String (CEGUI) XMLParser (CEGUI)
Disabled (CEGUI::WindowProperties) ImageDim (CEGUI) PropertyReceiver (CEGUI) String::const_iterator (CEGUI) XPosition (CEGUI::WindowProperties)
DisabledImage (CEGUI::PushButtonProperties) ImageryComponent (CEGUI) PropertySet (CEGUI) String::iterator (CEGUI)
Y
DisabledTextColour (CEGUI::ButtonBaseProperties) ImagerySection (CEGUI) PushButton (CEGUI) SubscriberInterface (CEGUI) YPosition (CEGUI::WindowProperties)
DisabledTextColour (CEGUI::MenuItemProperties) Imageset (CEGUI) PushedColour (CEGUI::MenuItemProperties) SubscriberTemplate (CEGUI)
Z
DisplayTime (CEGUI::TooltipProperties) Imageset_xmlHandler (CEGUI) PushedImage (CEGUI::PushButtonProperties) System (CEGUI) ZOrderChangeEnabled (CEGUI::WindowProperties)
DistributeCapturedInputs (CEGUI::WindowProperties) ImagesetManager (CEGUI) PushedTextColour (CEGUI::ButtonBaseProperties)
T
_
DocumentSize (CEGUI::ScrollbarProperties) InactiveEditSelectionColour (CEGUI::ComboboxProperties)
R
TabButton (CEGUI) _freeBinder (CEGUI)
Dragable (CEGUI::ListHeaderSegmentProperties) InactiveSelectionColour (CEGUI::EditboxProperties) RadioButton (CEGUI) TabControl (CEGUI) _functorBinder (CEGUI)
DragAlpha (CEGUI::DragContainerProperties) | InactiveSelectionColour (CEGUI::MultiLineEditboxProperties) | ReadOnly (CEGUI::EditboxProperties) | TabHeight (CEGUI::TabControlProperties) | _memberBinder (CEGUI)
DragContainer (CEGUI) InheritsAlpha (CEGUI::WindowProperties) ReadOnly (CEGUI::MultiLineEditboxProperties) TabPane (CEGUI) _refBinder (CEGUI)
DragContainerFactory (CEGUI) InheritsTooltipText (CEGUI::WindowProperties) ReadOnly (CEGUI::ComboboxProperties)

A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | R | S | T | U | V | W | X | Y | Z | _

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlAttribute Member List

This is the complete list of members for TiXmlAttribute, including all inherited members.

Column() const | TiXmlBase | [inline]
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
DoubleValue() const | TiXmlAttribute |
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
IntValue() const | TiXmlAttribute |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
location (defined in TiXmlBase) | TiXmlBase | [protected]
Name() const | TiXmlAttribute | [inline]
Next() const | TiXmlAttribute |
Next() (defined in TiXmlAttribute) | TiXmlAttribute |
operator<(const TiXmlAttribute &rhs) const (defined in TiXmlAttribute) | TiXmlAttribute | [inline]
operator==(const TiXmlAttribute &rhs) const (defined in TiXmlAttribute) | TiXmlAttribute | [inline]
operator>(const TiXmlAttribute &rhs) const (defined in TiXmlAttribute) | TiXmlAttribute | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding) (defined in TiXmlAttribute) | TiXmlAttribute | [virtual]
Previous() const | TiXmlAttribute |
Previous() (defined in TiXmlAttribute) | TiXmlAttribute |
Print(FILE *cfile, int depth) const | TiXmlAttribute | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
QueryDoubleValue(double *value) const | TiXmlAttribute |
QueryIntValue(int *value) const | TiXmlAttribute |
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetDocument(TiXmlDocument *doc) (defined in TiXmlAttribute) | TiXmlAttribute | [inline]
SetDoubleValue(double value) | TiXmlAttribute |
SetIntValue(int value) | TiXmlAttribute |
SetName(const char *_name) | TiXmlAttribute | [inline]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlAttribute | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlAttribute) | TiXmlAttribute | [virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlAttribute() | TiXmlAttribute | [inline]
TiXmlAttribute(const char *_name, const char *_value) | TiXmlAttribute | [inline]
TiXmlAttributeSet (defined in TiXmlAttribute) | TiXmlAttribute | [friend]
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
Value() const | TiXmlAttribute | [inline]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlBase Member List

This is the complete list of members for TiXmlBase, including all inherited members.

Column() const | TiXmlBase | [inline]
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
location (defined in TiXmlBase) | TiXmlBase | [protected]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)=0 (defined in TiXmlBase) | TiXmlBase | [pure virtual]
Print(FILE *cfile, int depth) const =0 | TiXmlBase | [pure virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *) const =0 (defined in TiXmlBase) | TiXmlBase | [protected, pure virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlDocument (defined in TiXmlBase) | TiXmlBase | [friend]
TiXmlElement (defined in TiXmlBase) | TiXmlBase | [friend]
TiXmlNode (defined in TiXmlBase) | TiXmlBase | [friend]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlComment Member List

This is the complete list of members for TiXmlComment, including all inherited members.

Clear() | TiXmlNode |
Clone() const | TiXmlComment | [virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlComment *target) const (defined in TiXmlComment) | TiXmlComment | [protected]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
operator=(const TiXmlComment &base) (defined in TiXmlComment) | TiXmlComment |
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding) (defined in TiXmlComment) | TiXmlComment | [virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print(FILE *cfile, int depth) const | TiXmlComment | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlComment) | TiXmlComment | [protected, virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlComment() | TiXmlComment | [inline]
TiXmlComment(const TiXmlComment &) (defined in TiXmlComment) | TiXmlComment |
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
type (defined in TiXmlNode) | TiXmlNode | [protected]
Type() const | TiXmlNode | [inline, virtual]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
value (defined in TiXmlNode) | TiXmlNode | [protected]
Value() const | TiXmlNode | [inline]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlComment() (defined in TiXmlComment) | TiXmlComment | [inline, virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlDeclaration Member List

This is the complete list of members for TiXmlDeclaration, including all inherited members.

Clear() | TiXmlNode |
Clone() const | TiXmlDeclaration | [virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlDeclaration *target) const (defined in TiXmlDeclaration) | TiXmlDeclaration | [protected]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
Encoding() const | TiXmlDeclaration | [inline]
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
operator=(const TiXmlDeclaration &copy) (defined in TiXmlDeclaration) | TiXmlDeclaration |
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding) (defined in TiXmlDeclaration) | TiXmlDeclaration | [virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print(FILE *cfile, int depth) const | TiXmlDeclaration | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
Standalone() const | TiXmlDeclaration | [inline]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlDeclaration) | TiXmlDeclaration | [protected, virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlDeclaration() | TiXmlDeclaration | [inline]
TiXmlDeclaration(const char *_version, const char *_encoding, const char *_standalone) | TiXmlDeclaration |
TiXmlDeclaration(const TiXmlDeclaration &copy) (defined in TiXmlDeclaration) | TiXmlDeclaration |
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
Type() const | TiXmlNode | [inline, virtual]
type (defined in TiXmlNode) | TiXmlNode | [protected]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
Value() const | TiXmlNode | [inline]
value (defined in TiXmlNode) | TiXmlNode | [protected]
Version() const | TiXmlDeclaration | [inline]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlDeclaration() (defined in TiXmlDeclaration) | TiXmlDeclaration | [inline, virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlDocument Member List

This is the complete list of members for TiXmlDocument, including all inherited members.

Clear() | TiXmlNode |
ClearError() | TiXmlDocument | [inline]
Clone() const | TiXmlDocument | [protected, virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
Error() const | TiXmlDocument | [inline]
ErrorCol() | TiXmlDocument | [inline]
ErrorDesc() const | TiXmlDocument | [inline]
ErrorId() const | TiXmlDocument | [inline]
ErrorRow() | TiXmlDocument | [inline]
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
LoadFile(TiXmlEncoding encoding=TIXML_DEFAULT_ENCODING) | TiXmlDocument |
LoadFile(const char *filename, TiXmlEncoding encoding=TIXML_DEFAULT_ENCODING) | TiXmlDocument |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
operator=(const TiXmlDocument &copy) (defined in TiXmlDocument) | TiXmlDocument |
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data=0, TiXmlEncoding encoding=TIXML_DEFAULT_ENCODING) | TiXmlDocument | [virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print() const | TiXmlDocument | [inline]
Print(FILE *cfile, int depth=0) const | TiXmlDocument | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
RootElement() const | TiXmlDocument | [inline]
RootElement() (defined in TiXmlDocument) | TiXmlDocument | [inline]
Row() const | TiXmlBase | [inline]
SaveFile() const | TiXmlDocument |
SaveFile(const char *filename) const | TiXmlDocument |
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetError(int err, const char *errorLocation, TiXmlParsingData *prevData, TiXmlEncoding encoding) (defined in TiXmlDocument) | TiXmlDocument |
SetTabSize(int _tabsize) | TiXmlDocument | [inline]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlDocument) | TiXmlDocument | [protected, virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TabSize() const (defined in TiXmlDocument) | TiXmlDocument | [inline]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlDocument() | TiXmlDocument |
TiXmlDocument(const char *documentName) | TiXmlDocument |
TiXmlDocument(const TiXmlDocument &copy) (defined in TiXmlDocument) | TiXmlDocument |
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
Type() const | TiXmlNode | [inline, virtual]
type (defined in TiXmlNode) | TiXmlNode | [protected]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
Value() const | TiXmlNode | [inline]
value (defined in TiXmlNode) | TiXmlNode | [protected]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlDocument() (defined in TiXmlDocument) | TiXmlDocument | [inline, virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlElement Member List

This is the complete list of members for TiXmlElement, including all inherited members.

Attribute(const char *name) const | TiXmlElement |
Attribute(const char *name, int *i) const | TiXmlElement |
Attribute(const char *name, double *d) const | TiXmlElement |
Clear() | TiXmlNode |
ClearThis() (defined in TiXmlElement) | TiXmlElement | [protected]
Clone() const | TiXmlElement | [virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlElement *target) const (defined in TiXmlElement) | TiXmlElement | [protected]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
FirstAttribute() const | TiXmlElement | [inline]
FirstAttribute() (defined in TiXmlElement) | TiXmlElement | [inline]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
LastAttribute() const | TiXmlElement | [inline]
LastAttribute() (defined in TiXmlElement) | TiXmlElement | [inline]
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
operator=(const TiXmlElement &base) (defined in TiXmlElement) | TiXmlElement |
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding) (defined in TiXmlElement) | TiXmlElement | [virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print(FILE *cfile, int depth) const | TiXmlElement | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
QueryDoubleAttribute(const char *name, double *value) const | TiXmlElement |
QueryDoubleAttribute(const char *name, float *value) const | TiXmlElement | [inline]
QueryIntAttribute(const char *name, int *value) const | TiXmlElement |
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadValue(const char *in, TiXmlParsingData *prevData, TiXmlEncoding encoding) (defined in TiXmlElement) | TiXmlElement | [protected]
RemoveAttribute(const char *name) | TiXmlElement |
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
Row() const | TiXmlBase | [inline]
SetAttribute(const char *name, const char *value) | TiXmlElement |
SetAttribute(const char *name, int value) | TiXmlElement |
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetDoubleAttribute(const char *name, double value) | TiXmlElement |
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlElement) | TiXmlElement | [protected, virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlElement(const char *in_value) | TiXmlElement |
TiXmlElement(const TiXmlElement &) (defined in TiXmlElement) | TiXmlElement |
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
Type() const | TiXmlNode | [inline, virtual]
type (defined in TiXmlNode) | TiXmlNode | [protected]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
value (defined in TiXmlNode) | TiXmlNode | [protected]
Value() const | TiXmlNode | [inline]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlElement() (defined in TiXmlElement) | TiXmlElement | [virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlHandle Member List

This is the complete list of members for TiXmlHandle, including all inherited members.

Child(const char *value, int index) const | TiXmlHandle |
Child(int index) const | TiXmlHandle |
ChildElement(const char *value, int index) const | TiXmlHandle |
ChildElement(int index) const | TiXmlHandle |
Element() const | TiXmlHandle | [inline]
FirstChild() const | TiXmlHandle |
FirstChild(const char *value) const | TiXmlHandle |
FirstChildElement() const | TiXmlHandle |
FirstChildElement(const char *value) const | TiXmlHandle |
Node() const | TiXmlHandle | [inline]
operator=(const TiXmlHandle &ref) (defined in TiXmlHandle) | TiXmlHandle | [inline]
Text() const | TiXmlHandle | [inline]
TiXmlHandle(TiXmlNode *node) | TiXmlHandle | [inline]
TiXmlHandle(const TiXmlHandle &ref) | TiXmlHandle | [inline]
Unknown() const | TiXmlHandle | [inline]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlNode Member List

This is the complete list of members for TiXmlNode, including all inherited members.

Clear() | TiXmlNode |
Clone() const =0 | TiXmlNode | [pure virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding)=0 (defined in TiXmlBase) | TiXmlBase | [pure virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print(FILE *cfile, int depth) const =0 | TiXmlBase | [pure virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *) const =0 (defined in TiXmlBase) | TiXmlBase | [protected, pure virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlDocument (defined in TiXmlNode) | TiXmlNode | [friend]
TiXmlElement (defined in TiXmlNode) | TiXmlNode | [friend]
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
Type() const | TiXmlNode | [inline, virtual]
type (defined in TiXmlNode) | TiXmlNode | [protected]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
Value() const | TiXmlNode | [inline]
value (defined in TiXmlNode) | TiXmlNode | [protected]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlText Member List

This is the complete list of members for TiXmlText, including all inherited members.

Blank() const (defined in TiXmlText) | TiXmlText | [protected]
Clear() | TiXmlNode |
Clone() const | TiXmlText | [protected, virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlText *target) const (defined in TiXmlText) | TiXmlText | [protected]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
operator=(const TiXmlText &base) (defined in TiXmlText) | TiXmlText | [inline]
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding) (defined in TiXmlText) | TiXmlText | [virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print(FILE *cfile, int depth) const | TiXmlText | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlText) | TiXmlText | [protected, virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlElement (defined in TiXmlText) | TiXmlText | [friend]
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
TiXmlText(const char *initValue) | TiXmlText | [inline]
TiXmlText(const TiXmlText &copy) (defined in TiXmlText) | TiXmlText | [inline]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
type (defined in TiXmlNode) | TiXmlNode | [protected]
Type() const | TiXmlNode | [inline, virtual]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
Value() const | TiXmlNode | [inline]
value (defined in TiXmlNode) | TiXmlNode | [protected]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]
~TiXmlText() (defined in TiXmlText) | TiXmlText | [inline, virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

TiXmlUnknown Member List

This is the complete list of members for TiXmlUnknown, including all inherited members.

Clear() | TiXmlNode |
Clone() const | TiXmlUnknown | [virtual]
Column() const | TiXmlBase | [inline]
COMMENT enum value (defined in TiXmlNode) | TiXmlNode |
ConvertUTF32ToUTF8(unsigned long input, char *output, int *length) (defined in TiXmlBase) | TiXmlBase | [protected, static]
CopyTo(TiXmlUnknown *target) const (defined in TiXmlUnknown) | TiXmlUnknown | [protected]
CopyTo(TiXmlNode *target) const (defined in TiXmlNode) | TiXmlNode | [protected]
DECLARATION enum value (defined in TiXmlNode) | TiXmlNode |
DOCUMENT enum value (defined in TiXmlNode) | TiXmlNode |
ELEMENT enum value (defined in TiXmlNode) | TiXmlNode |
errorString (defined in TiXmlBase) | TiXmlBase | [protected, static]
firstChild (defined in TiXmlNode) | TiXmlNode | [protected]
FirstChild() const | TiXmlNode | [inline]
FirstChild() (defined in TiXmlNode) | TiXmlNode | [inline]
FirstChild(const char *value) const | TiXmlNode |
FirstChild(const char *value) | TiXmlNode |
FirstChildElement() const | TiXmlNode |
FirstChildElement() (defined in TiXmlNode) | TiXmlNode |
FirstChildElement(const char *value) const | TiXmlNode |
FirstChildElement(const char *value) (defined in TiXmlNode) | TiXmlNode |
GetChar(const char *p, char *_value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
GetDocument() const | TiXmlNode |
GetDocument() (defined in TiXmlNode) | TiXmlNode |
GetEntity(const char *in, char *value, int *length, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
GetUserData() (defined in TiXmlBase) | TiXmlBase | [inline]
Identify(const char *start, TiXmlEncoding encoding) (defined in TiXmlNode) | TiXmlNode | [protected]
InsertAfterChild(TiXmlNode *afterThis, const TiXmlNode &addThis) | TiXmlNode |
InsertBeforeChild(TiXmlNode *beforeThis, const TiXmlNode &addThis) | TiXmlNode |
InsertEndChild(const TiXmlNode &addThis) | TiXmlNode |
IsAlpha(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsAlphaNum(unsigned char anyByte, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
IsWhiteSpace(char c) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
IsWhiteSpaceCondensed() | TiXmlBase | [inline, static]
IterateChildren(TiXmlNode *previous) const | TiXmlNode |
IterateChildren(TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) const | TiXmlNode |
IterateChildren(const char *value, TiXmlNode *previous) (defined in TiXmlNode) | TiXmlNode |
LastChild() const (defined in TiXmlNode) | TiXmlNode | [inline]
LastChild() | TiXmlNode | [inline]
LastChild(const char *value) const (defined in TiXmlNode) | TiXmlNode |
LastChild(const char *value) | TiXmlNode |
lastChild (defined in TiXmlNode) | TiXmlNode | [protected]
LinkEndChild(TiXmlNode *addThis) | TiXmlNode |
location (defined in TiXmlBase) | TiXmlBase | [protected]
next (defined in TiXmlNode) | TiXmlNode | [protected]
NextSibling() const | TiXmlNode | [inline]
NextSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
NextSibling(const char *) const | TiXmlNode |
NextSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement() const | TiXmlNode |
NextSiblingElement() (defined in TiXmlNode) | TiXmlNode |
NextSiblingElement(const char *) const | TiXmlNode |
NextSiblingElement(const char *) (defined in TiXmlNode) | TiXmlNode |
NoChildren() const | TiXmlNode | [inline]
NodeType enum name | TiXmlNode |
operator<< (defined in TiXmlNode) | TiXmlNode | [friend]
operator=(const TiXmlUnknown &copy) (defined in TiXmlUnknown) | TiXmlUnknown | [inline]
parent (defined in TiXmlNode) | TiXmlNode | [protected]
Parent() | TiXmlNode | [inline]
Parent() const (defined in TiXmlNode) | TiXmlNode | [inline]
Parse(const char *p, TiXmlParsingData *data, TiXmlEncoding encoding) (defined in TiXmlUnknown) | TiXmlUnknown | [virtual]
prev (defined in TiXmlNode) | TiXmlNode | [protected]
PreviousSibling() const | TiXmlNode | [inline]
PreviousSibling() (defined in TiXmlNode) | TiXmlNode | [inline]
PreviousSibling(const char *) const | TiXmlNode |
PreviousSibling(const char *) (defined in TiXmlNode) | TiXmlNode |
Print(FILE *cfile, int depth) const | TiXmlUnknown | [virtual]
PutString(const TIXML_STRING &str, TIXML_OSTREAM *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
PutString(const TIXML_STRING &str, TIXML_STRING *out) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadName(const char *p, TIXML_STRING *name, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
ReadText(const char *in, TIXML_STRING *text, bool ignoreWhiteSpace, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
RemoveChild(TiXmlNode *removeThis) | TiXmlNode |
ReplaceChild(TiXmlNode *replaceThis, const TiXmlNode &withThis) | TiXmlNode |
Row() const | TiXmlBase | [inline]
SetCondenseWhiteSpace(bool condense) | TiXmlBase | [inline, static]
SetUserData(void *user) (defined in TiXmlBase) | TiXmlBase | [inline]
SetValue(const char *_value) | TiXmlNode | [inline]
SkipWhiteSpace(const char *, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
StreamOut(TIXML_OSTREAM *out) const (defined in TiXmlUnknown) | TiXmlUnknown | [protected, virtual]
StringEqual(const char *p, const char *endTag, bool ignoreCase, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [protected, static]
SValue() const (defined in TiXmlNode) | TiXmlNode | [inline, protected]
TEXT enum value (defined in TiXmlNode) | TiXmlNode |
TIXML_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_DOCUMENT_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_EMBEDDED_NULL enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OPENING_FILE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_OUT_OF_MEMORY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_COMMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_DECLARATION enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_ELEMENT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_EMPTY enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_PARSING_UNKNOWN enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ATTRIBUTES enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_ELEMENT_VALUE enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_READING_END_TAG enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_ERROR_STRING_COUNT enum value (defined in TiXmlBase) | TiXmlBase |
TIXML_NO_ERROR enum value (defined in TiXmlBase) | TiXmlBase |
TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline]
TiXmlNode(NodeType _type) (defined in TiXmlNode) | TiXmlNode | [protected]
TiXmlUnknown() (defined in TiXmlUnknown) | TiXmlUnknown | [inline]
TiXmlUnknown(const TiXmlUnknown &copy) (defined in TiXmlUnknown) | TiXmlUnknown | [inline]
ToComment() const | TiXmlNode | [inline]
ToComment() | TiXmlNode | [inline]
ToDeclaration() const | TiXmlNode | [inline]
ToDeclaration() | TiXmlNode | [inline]
ToDocument() const | TiXmlNode | [inline]
ToDocument() | TiXmlNode | [inline]
ToElement() const | TiXmlNode | [inline]
ToElement() | TiXmlNode | [inline]
ToLower(int v, TiXmlEncoding encoding) (defined in TiXmlBase) | TiXmlBase | [inline, protected, static]
ToText() const | TiXmlNode | [inline]
ToText() | TiXmlNode | [inline]
ToUnknown() const | TiXmlNode | [inline]
ToUnknown() | TiXmlNode | [inline]
Type() const | TiXmlNode | [inline, virtual]
type (defined in TiXmlNode) | TiXmlNode | [protected]
TYPECOUNT enum value (defined in TiXmlNode) | TiXmlNode |
UNKNOWN enum value (defined in TiXmlNode) | TiXmlNode |
userData | TiXmlBase | [protected]
utf8ByteTable (defined in TiXmlBase) | TiXmlBase | [static]
Value() const | TiXmlNode | [inline]
value (defined in TiXmlNode) | TiXmlNode | [protected]
~TiXmlBase() (defined in TiXmlBase) | TiXmlBase | [inline, virtual]
~TiXmlNode() (defined in TiXmlNode) | TiXmlNode | [virtual]
~TiXmlUnknown() (defined in TiXmlUnknown) | TiXmlUnknown | [inline, virtual]

Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: d3d9renderer.h Source File

include » renderers » directx9GUIRenderer

d3d9renderer.h

00001 /************************************************************************
00002         filename:       d3d9renderer.h
00003         created:        17/7/2004
00004         author:         Paul D Turner with D3D 9 Updates by Magnus Österlind
00005
00006         purpose:        Interface for DirectX 9.0 Renderer class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 /*************************************************************************
00027         This file contains code that is specific to Win32 and DirectX
00028 *************************************************************************/
00029 #ifndef _d3d9renderer_h_
00030 #define _d3d9renderer_h_
00031
00032 #include "CEGUIBase.h"
00033 #include "CEGUIRenderer.h"
00034 #include "CEGUITexture.h"
00035 #include <d3d9.h>
00036 #include <list>
00037 #include <set>
00038
00039 #ifdef DIRECTX9_GUIRENDERER_EXPORTS
00040 #define DIRECTX9_GUIRENDERER_API __declspec(dllexport)
00041 #else
00042 #define DIRECTX9_GUIRENDERER_API __declspec(dllimport)
00043 #endif
00044
00045
00046 #if defined(_MSC_VER)
00047 #       pragma warning(push)
00048 #       pragma warning(disable : 4251)
00049 #endif
00050
00051
00052 // Start of CEGUI namespace section
00053 namespace CEGUI
00054 {
00055 /*************************************************************************
00056         Forward refs
00057 *************************************************************************/
00058 class DirectX9Texture;
00059
00064 class DIRECTX9_GUIRENDERER_API DirectX9Renderer : public Renderer
00065 {
00066 public:
00077         DirectX9Renderer(LPDIRECT3DDEVICE9 device, uint max_quads);
00078
00083         virtual ~DirectX9Renderer(void);
00084
00085         // add's a quad to the list to be rendered
00086         virtual void    addQuad(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00087
00088         // perform final rendering for all queued renderable quads.
00089         virtual void    doRender(void);
00090
00091         // clear the queue
00092         virtual void    clearRenderList(void);
00093
00094
00110         virtual void    setQueueingEnabled(bool setting)                {d_queueing = setting;}
00111
00112
00113         // create an empty texture
00114         virtual Texture*        createTexture(void);
00115
00116         // create a texture and load it with the specified file.
00117         virtual Texture*        createTexture(const String& filename, const String& resourceGroup);
00118
00119         // create a texture and set it to the specified size
00120         virtual Texture*        createTexture(float size);
00121
00122         // destroy the given texture
00123         virtual void            destroyTexture(Texture* texture);
00124
00125         // destroy all textures still active
00126         virtual void            destroyAllTextures(void);
00127
00128         // return ptr to device
00129         LPDIRECT3DDEVICE9       getDevice(void) const           {return d_device;}
00130
00131
00139         virtual bool    isQueueingEnabled(void) const   {return d_queueing;}
00140
00141
00149         virtual float   getWidth(void) const            {return d_display_area.getWidth();}
00150
00151
00159         virtual float   getHeight(void) const           {return d_display_area.getHeight();}
00160
00161
00169         virtual Size    getSize(void) const                     {return d_display_area.getSize();}
00170
00171
00180         virtual Rect    getRect(void) const                     {return d_display_area;}
00181
00182
00190         virtual uint    getMaxTextureSize(void) const           {return d_maxTextureSize;}
00191
00192
00200         virtual uint    getHorzScreenDPI(void) const    {return 96;}
00201
00202
00210         virtual uint    getVertScreenDPI(void) const    {return 96;}
00211
00212
00219         virtual void    preD3DReset(void);
00220
00221
00228         virtual void    postD3DReset(void);
00229
00230
00248         void    setDisplaySize(const Size& sz);
00249
00250
00251 private:
00252         /************************************************************************
00253                 Implementation Constants
00254         ************************************************************************/
00255         static const int                        VERTEX_PER_QUAD;
00256         static const int                        VERTEX_PER_TRIANGLE;
00257         static const int                        VERTEXBUFFER_CAPACITY;
00258         static const ulong                      VERTEX_FVF;
00259
00260         /*************************************************************************
00261             Implementation Structs & classes
00262         *************************************************************************/
00267         struct QuadVertex {
00268                 FLOAT x, y, z, rhw;
00269                 DWORD diffuse;
00270                 float tu1, tv1;
00271         };
00272
00277         struct QuadInfo
00278         {
00279                 LPDIRECT3DTEXTURE9      texture;
00280                 Rect                            position;
00281                 float                           z;
00282                 Rect                            texPosition;
00283                 ulong                           topLeftCol;
00284                 ulong                           topRightCol;
00285                 ulong                           bottomLeftCol;
00286                 ulong                           bottomRightCol;
00287
00288         QuadSplitMode       splitMode;
00289
00290                 bool operator<(const QuadInfo& other) const
00291                 {
00292                         // this is intentionally reversed.
00293                         return z > other.z;
00294                 }
00295         };
00296
00297
00298         /*************************************************************************
00299             Implementation Methods
00300         *************************************************************************/
00301         // setup states etc
00302         void    initPerFrameStates(void);
00303
00304         // renders whatever is in the vertex buffer
00305         void    renderVBuffer(void);
00306
00307         // sort quads list according to texture
00308         void    sortQuads(void);
00309
00310         // render a quad directly to the display
00311         void    renderQuadDirect(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00312
00313         // return size of device view port (if possible)
00314         Size    getViewportSize(void);
00315
00316         // method to do work of constructor
00317         void    constructor_impl(LPDIRECT3DDEVICE9 device, const Size& display_size);
00318
00319
00320         /*************************************************************************
00321             Implementation Data
00322         *************************************************************************/
00323         Rect                            d_display_area;
00324
00325         typedef std::multiset<QuadInfo>         QuadList;
00326         QuadList d_quadlist;
00327         bool    d_queueing;
00328
00329         LPDIRECT3DDEVICE9               d_device;
00330         LPDIRECT3DTEXTURE9              d_currTexture;
00331         LPDIRECT3DVERTEXBUFFER9 d_buffer;
00332         int                                             d_bufferPos;
00333
00334         std::list<DirectX9Texture*>     d_texturelist;
00335
00336         uint    d_maxTextureSize;
00337 };
00338
00339 } // End of  CEGUI namespace section
00340
00341 #if defined(_MSC_VER)
00342 #       pragma warning(pop)
00343 #endif
00344
00345 #endif  // end of guard _d3d9renderer_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: d3d9texture.h Source File

include » renderers » directx9GUIRenderer

d3d9texture.h

00001 /************************************************************************
00002         filename:       d3d9texture.h
00003         created:        17/7/2004
00004         author:         Paul D Turner with D3D 9 Updates by Magnus Österlind
00005
00006         purpose:        Defines concrete texture class for D3D9.0
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _d3d9texture_h_
00027 #define _d3d9texture_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIRenderer.h"
00031 #include "CEGUITexture.h"
00032 #include "d3d9renderer.h"
00033 #include <d3d9.h>
00034 #include <list>
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00039
00044 class DIRECTX9_GUIRENDERER_API DirectX9Texture : public Texture
00045 {
00046 private:
00047         /*************************************************************************
00048                 Friends (to allow construction and destruction)
00049         *************************************************************************/
00050         friend  Texture* DirectX9Renderer::createTexture(void);
00051         friend  Texture* DirectX9Renderer::createTexture(const String& filename, const String& resourceGroup);
00052         friend  Texture* DirectX9Renderer::createTexture(float size);
00053         friend  void     DirectX9Renderer::destroyTexture(Texture* texture);
00054
00055
00056         /*************************************************************************
00057                 Construction & Destruction (by Renderer object only)
00058         *************************************************************************/
00059         DirectX9Texture(Renderer* owner);
00060         virtual ~DirectX9Texture(void);
00061
00062 public:
00070         virtual ushort  getWidth(void) const            {return d_width;}
00071
00072
00080         virtual ushort  getHeight(void) const           {return d_height;}
00081
00082
00096         virtual void    loadFromFile(const String& filename, const String& resourceGroup);
00097
00098
00115         virtual void    loadFromMemory(const void* buffPtr, uint buffWidth, uint buffHeight);
00116
00117
00125         LPDIRECT3DTEXTURE9      getD3DTexture(void) const               {return d_d3dtexture;}
00126
00127
00128         //
00139         void    setD3DTextureSize(uint size);
00140
00141
00153         virtual void    preD3DReset(void);
00154
00155
00167         virtual void    postD3DReset(void);
00168
00169
00170 private:
00171         /*************************************************************************
00172                 Implementation Functions
00173         *************************************************************************/
00174         // safely free direc3d texture (can be called multiple times with no ill effect)
00175         void    freeD3DTexture(void);
00176
00177
00178         /*************************************************************************
00179                 Implementation Data
00180         *************************************************************************/
00181         LPDIRECT3DTEXTURE9              d_d3dtexture;
00182         String                                  d_filename;
00183     String                  d_resourceGroup;
00184         bool                                    d_isMemoryTexture;
00185
00186         ushort                                  d_width;
00187         ushort                                  d_height;
00188 };
00189
00190 } // End of  CEGUI namespace section
00191
00192
00193 #endif  // end of guard _d3d9texture_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LastAttribute() : TiXmlElement
  • LastChild() : TiXmlNode
  • LayerSpecification() : CEGUI::LayerSpecification
  • layoutChildWidgets() : CEGUI::WidgetLookFeel
  • layoutItemWidgets() : CEGUI::PopupMenu, CEGUI::Menubar, CEGUI::ItemListBase
  • layoutSegments() : CEGUI::ListHeader
  • LeftAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • length() : CEGUI::String
  • LineList : CEGUI::MultiLineEditbox
  • LinkEndChild() : TiXmlNode
  • Listbox() : CEGUI::Listbox
  • ListboxItem() : CEGUI::ListboxItem
  • ListboxTextItem() : CEGUI::ListboxTextItem
  • ListHeader() : CEGUI::ListHeader
  • ListHeaderSegment() : CEGUI::ListHeaderSegment
  • load() : CEGUI::Imageset
  • LoadFile() : TiXmlDocument
  • loadFromFile() : CEGUI::OpenGLTexture, CEGUI::DirectX9Texture, CEGUI::DirectX81Texture, CEGUI::Texture
  • loadFromMemory() : CEGUI::OpenGLTexture, CEGUI::DirectX9Texture, CEGUI::DirectX81Texture, CEGUI::Texture
  • loadRawDataContainer() : CEGUI::ResourceProvider
  • loadResources() : CEGUI::Scheme
  • loadScheme() : CEGUI::SchemeManager
  • loadWindowLayout() : CEGUI::WindowManager
  • logEvent() : CEGUI::Logger
  • Logger() : CEGUI::Logger
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • makeButtonName() : CEGUI::TabControl
  • max_size() : CEGUI::String
  • Menubar() : CEGUI::Menubar
  • MenuBase() : CEGUI::MenuBase
  • MenuItem() : CEGUI::MenuItem
  • MinimumSegmentPixelWidth : CEGUI::ListHeader
  • modulateAlpha() : CEGUI::ColourRect
  • mouseCursor : CEGUI::MouseCursorEventArgs
  • MouseCursor() : CEGUI::MouseCursor
  • moveBottomEdge() : CEGUI::FrameWindow
  • moveColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • moveColumn_impl() : CEGUI::MultiColumnList
  • moveColumnWithID() : CEGUI::MultiColumnList
  • moveDelta : CEGUI::MouseEventArgs
  • moveLeftEdge() : CEGUI::FrameWindow
  • moveRightEdge() : CEGUI::FrameWindow
  • moveSegment() : CEGUI::ListHeader
  • moveToBack() : CEGUI::Window
  • moveToFront() : CEGUI::Window
  • moveToFront_impl() : CEGUI::Window
  • moveTopEdge() : CEGUI::FrameWindow
  • MultiColumnList() : CEGUI::MultiColumnList
  • MultiLineEditbox() : CEGUI::MultiLineEditbox
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name() : TiXmlAttribute
  • Next() : TiXmlAttribute
  • NextSibling() : TiXmlNode
  • NextSiblingElement() : TiXmlNode
  • NoChildren() : TiXmlNode
  • Node() : TiXmlHandle
  • NodeType : TiXmlNode
  • None : CEGUI::ListHeaderSegment
  • notifyDragDropItemDropped() : CEGUI::Window
  • notifyDragDropItemEnters() : CEGUI::Window
  • notifyDragDropItemLeaves() : CEGUI::Window
  • notifyScreenResolution() : CEGUI::ImagesetManager, CEGUI::Imageset, CEGUI::FontManager, CEGUI::Font
  • notifyWindowDestroyed() : CEGUI::System
  • npos : CEGUI::String
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • Octal : CEGUI::Spinner
  • OctalValidator : CEGUI::Spinner
  • offset() : CEGUI::Rect
  • offsetPixelPosition() : CEGUI::FrameWindow
  • offsetPosition() : CEGUI::MouseCursor
  • onActivated() : CEGUI::Spinner, CEGUI::FrameWindow, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::Window
  • onAlphaChanged() : CEGUI::StaticImage, CEGUI::Static, CEGUI::PopupMenu, CEGUI::DragContainer, CEGUI::Window
  • onAlwaysOnTopChanged() : CEGUI::Window
  • onAutoSizeSettingChanged() : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • onCaptureGained() : CEGUI::Window
  • onCaptureLost() : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::ButtonBase, CEGUI::Window
  • onCaratMoved() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onCharacter() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Window
  • onChildAdded() : CEGUI::ScrolledContainer, CEGUI::Window
  • onChildRemoved() : CEGUI::ScrolledContainer, CEGUI::Window
  • onClickableSettingChanged() : CEGUI::ListHeaderSegment
  • onClicked() : CEGUI::TabButton, CEGUI::PushButton, CEGUI::MenuItem
  • onClippingChanged() : CEGUI::DragContainer, CEGUI::Window
  • onCloseClicked() : CEGUI::FrameWindow
  • onContentChanged() : CEGUI::ScrolledContainer
  • onContentPaneChanged() : CEGUI::ScrollablePane
  • onContentPaneScrolled() : CEGUI::ScrollablePane
  • onDeactivated() : CEGUI::FrameWindow, CEGUI::Window
  • onDestructionStarted() : CEGUI::Window
  • onDisabled() : CEGUI::Window
  • onDisplayTimeChanged() : CEGUI::Tooltip
  • onDragAlphaChanged() : CEGUI::DragContainer
  • onDragDropItemDropped() : CEGUI::Window
  • onDragDropItemEnters() : CEGUI::Window
  • onDragDropItemLeaves() : CEGUI::Window
  • onDragDropTargetChanged() : CEGUI::DragContainer
  • onDragEnabledChanged() : CEGUI::DragContainer
  • onDragEnded() : CEGUI::DragContainer
  • onDraggingModeChanged() : CEGUI::Titlebar
  • onDragMouseCursorChanged() : CEGUI::DragContainer
  • onDragMoveSettingChanged() : CEGUI::ListHeader
  • onDragPositionChanged() : CEGUI::DragContainer
  • onDragSizeSettingChanged() : CEGUI::ListHeader
  • onDragStarted() : CEGUI::DragContainer
  • onDragThresholdChanged() : CEGUI::DragContainer
  • onDropListDisplayed() : CEGUI::Combobox
  • onDroplistRemoved() : CEGUI::Combobox
  • onEditboxFullEvent() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onEnabled() : CEGUI::Window
  • OnEvent() : CEGUI::IrrlichtRenderer
  • onFadeTimeChanged() : CEGUI::Tooltip
  • onFontChanged() : CEGUI::Titlebar, CEGUI::TabControl, CEGUI::StaticText, CEGUI::Spinner, CEGUI::Combobox, CEGUI::Window
  • onHidden() : CEGUI::Window
  • onHorizontalAlignmentChanged() : CEGUI::Window
  • onHorzScrollbarModeChanged() : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • onHoverTimeChanged() : CEGUI::Tooltip
  • onIDChanged() : CEGUI::Window
  • onImageChanged() : CEGUI::MouseCursor
  • onInheritsAlphaChanged() : CEGUI::Window
  • onInvalidEntryAttempted() : CEGUI::Editbox, CEGUI::Combobox
  • onKeyDown() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Window
  • onKeyUp() : CEGUI::Window
  • onListColumnMoved() : CEGUI::MultiColumnList
  • onListColumnSized() : CEGUI::MultiColumnList
  • onListContentsChanged() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • onListSelectionAccepted() : CEGUI::ComboDropList, CEGUI::Combobox
  • onListSelectionChanged() : CEGUI::Combobox
  • onMaskCodePointChanged() : CEGUI::Editbox
  • onMaskedRenderingModeChanged() : CEGUI::Editbox
  • onMaximumTextLengthChanged() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onMaximumValueChanged() : CEGUI::Spinner
  • onMetricsChanged() : CEGUI::Window
  • onMinimumValueChanged() : CEGUI::Spinner
  • onMouseButtonDown() : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::Listbox, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::ButtonBase, CEGUI::Window
  • onMouseButtonUp() : CEGUI::Titlebar, CEGUI::TabButton, CEGUI::RadioButton, CEGUI::PushButton, CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::Checkbox, CEGUI::ButtonBase, CEGUI::Window
  • onMouseClicked() : CEGUI::Window
  • onMouseDoubleClicked() : CEGUI::Titlebar, CEGUI::MultiLineEditbox, CEGUI::ListHeaderSegment, CEGUI::Editbox, CEGUI::Window
  • onMouseEnters() : CEGUI::Tooltip, CEGUI::Window
  • onMouseLeaves() : CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::ButtonBase, CEGUI::Window
  • onMouseMove() : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::Listbox, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::ButtonBase, CEGUI::Window
  • onMouseTripleClicked() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Window
  • onMouseWheel() : CEGUI::StaticText, CEGUI::Slider, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Window
  • onMovableSettingChanged() : CEGUI::ListHeaderSegment
  • onMoved() : CEGUI::Window
  • onMultiselectModeChanged() : CEGUI::Listbox
  • onNominatedSelectColumnChanged() : CEGUI::MultiColumnList
  • onNominatedSelectRowChanged() : CEGUI::MultiColumnList
  • onParentDestroyChanged() : CEGUI::Window
  • onParentSized() : CEGUI::ScrolledContainer, CEGUI::Window
  • onPopupClosed() : CEGUI::MenuBase
  • onPopupOpened() : CEGUI::MenuBase
  • onProgressChanged() : CEGUI::ProgressBar
  • onProgressDone() : CEGUI::ProgressBar
  • onReadOnlyChanged() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onRenderingEnded() : CEGUI::Window
  • onRenderingStarted() : CEGUI::Window
  • onRollupToggled() : CEGUI::FrameWindow
  • onScrollConfigChanged() : CEGUI::Scrollbar
  • onScrollPositionChanged() : CEGUI::Scrollbar
  • onSegmentAdded() : CEGUI::ListHeader
  • onSegmentClicked() : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onSegmentDragPositionChanged() : CEGUI::ListHeaderSegment
  • onSegmentDragStart() : CEGUI::ListHeaderSegment
  • onSegmentDragStop() : CEGUI::ListHeaderSegment
  • onSegmentOffsetChanged() : CEGUI::ListHeader
  • onSegmentRemoved() : CEGUI::ListHeader
  • onSegmentSequenceChanged() : CEGUI::ListHeader
  • onSegmentSized() : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onSelectionChanged() : CEGUI::TabControl, CEGUI::MultiColumnList, CEGUI::Listbox
  • onSelectionModeChanged() : CEGUI::MultiColumnList
  • onSelectStateChange() : CEGUI::Checkbox
  • onSelectStateChanged() : CEGUI::RadioButton
  • onShown() : CEGUI::Window
  • onSized() : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::ScrollablePane, CEGUI::PushButton, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Window
  • onSizingSettingChanged() : CEGUI::ListHeaderSegment
  • onSortColumnChanged() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • onSortDirectionChanged() : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onSortModeChanged() : CEGUI::Listbox, CEGUI::Combobox
  • onSortSettingChanged() : CEGUI::ListHeader
  • onSplitterDoubleClicked() : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onStaticFrameChanged() : CEGUI::StaticImage, CEGUI::Static
  • onStepChanged() : CEGUI::Spinner
  • onTextAcceptedEvent() : CEGUI::Editbox, CEGUI::Combobox
  • onTextChanged() : CEGUI::Tooltip, CEGUI::TextItem, CEGUI::StaticText, CEGUI::Spinner, CEGUI::MultiLineEditbox, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::Combobox, CEGUI::Window
  • onTextInputModeChanged() : CEGUI::Spinner
  • onTextInvalidatedEvent() : CEGUI::Editbox, CEGUI::Combobox
  • onTextSelectionChanged() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onThumbPositionChanged() : CEGUI::Thumb
  • onThumbTrackEnded() : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • onThumbTrackStarted() : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • onTooltipActive() : CEGUI::Tooltip
  • onTooltipInactive() : CEGUI::Tooltip
  • onValidationStringChanged() : CEGUI::Editbox, CEGUI::Combobox
  • onValueChanged() : CEGUI::Spinner, CEGUI::Slider
  • onVerticalAlignmentChanged() : CEGUI::Window
  • onVertScrollbarModeChanged() : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • onWordWrapModeChanged() : CEGUI::MultiLineEditbox
  • onZChange_impl() : CEGUI::Window
  • onZChanged() : CEGUI::Window
  • OpenGLRenderer() : CEGUI::OpenGLRenderer
  • openPopupMenu() : CEGUI::PopupMenu, CEGUI::MenuItem
  • operator *() : CEGUI::ConstBaseIterator< T >
  • operator *=() : CEGUI::ColourRect
  • operator!=() : CEGUI::ConstBaseIterator< T >
  • operator++() : CEGUI::ConstBaseIterator< T >
  • operator+=() : CEGUI::String
  • operator--() : CEGUI::ConstBaseIterator< T >
  • operator<() : CEGUI::ListboxItem, CEGUI::SubscriberTemplate< Ret, Args >
  • operator=() : CEGUI::Dimension, CEGUI::String, CEGUI::ConstBaseIterator< T >
  • operator==() : CEGUI::ConstBaseIterator< T >
  • operator>() : CEGUI::ListboxItem
  • operator[]() : CEGUI::String
  • otherWindow : CEGUI::ActivationEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~AliasTargetStack() : CEGUI::WindowFactoryManager::AliasTargetStack
  • ~ButtonBase() : CEGUI::ButtonBase
  • ~Checkbox() : CEGUI::Checkbox
  • ~Combobox() : CEGUI::Combobox
  • ~ComboDropList() : CEGUI::ComboDropList
  • ~Config_xmlHandler() : CEGUI::Config_xmlHandler
  • ~ConstBaseIterator() : CEGUI::ConstBaseIterator< T >
  • ~Dimension() : CEGUI::Dimension
  • ~DirectX81Renderer() : CEGUI::DirectX81Renderer
  • ~DirectX9Renderer() : CEGUI::DirectX9Renderer
  • ~DragContainer() : CEGUI::DragContainer
  • ~Editbox() : CEGUI::Editbox
  • ~Event() : CEGUI::Event
  • ~EventSet() : CEGUI::EventSet
  • ~FactoryModule() : CEGUI::FactoryModule
  • ~Falagard_xmlHandler() : CEGUI::Falagard_xmlHandler
  • ~FalagardComponentBase() : CEGUI::FalagardComponentBase
  • ~Font() : CEGUI::Font
  • ~Font_xmlHandler() : CEGUI::Font_xmlHandler
  • ~FontManager() : CEGUI::FontManager
  • ~FrameWindow() : CEGUI::FrameWindow
  • ~GUILayout_xmlHandler() : CEGUI::GUILayout_xmlHandler
  • ~GUISheet() : CEGUI::GUISheet
  • ~Image() : CEGUI::Image
  • ~Imageset() : CEGUI::Imageset
  • ~Imageset_xmlHandler() : CEGUI::Imageset_xmlHandler
  • ~ImagesetManager() : CEGUI::ImagesetManager
  • ~IrrlichtRenderer() : CEGUI::IrrlichtRenderer
  • ~ItemEntry() : CEGUI::ItemEntry
  • ~ItemListBase() : CEGUI::ItemListBase
  • ~Listbox() : CEGUI::Listbox
  • ~ListboxItem() : CEGUI::ListboxItem
  • ~ListboxTextItem() : CEGUI::ListboxTextItem
  • ~ListHeader() : CEGUI::ListHeader
  • ~ListHeaderSegment() : CEGUI::ListHeaderSegment
  • ~Logger() : CEGUI::Logger
  • ~Menubar() : CEGUI::Menubar
  • ~MenuBase() : CEGUI::MenuBase
  • ~MenuItem() : CEGUI::MenuItem
  • ~MouseCursor() : CEGUI::MouseCursor
  • ~MultiColumnList() : CEGUI::MultiColumnList
  • ~MultiLineEditbox() : CEGUI::MultiLineEditbox
  • ~OpenGLRenderer() : CEGUI::OpenGLRenderer
  • ~PopupMenu() : CEGUI::PopupMenu
  • ~ProgressBar() : CEGUI::ProgressBar
  • ~Property() : CEGUI::Property
  • ~PropertySet() : CEGUI::PropertySet
  • ~PushButton() : CEGUI::PushButton
  • ~RenderableFrame() : CEGUI::RenderableFrame
  • ~RenderableImage() : CEGUI::RenderableImage
  • ~RenderCache() : CEGUI::RenderCache
  • ~ResourceProvider() : CEGUI::ResourceProvider
  • ~Scheme() : CEGUI::Scheme
  • ~Scheme_xmlHandler() : CEGUI::Scheme_xmlHandler
  • ~SchemeManager() : CEGUI::SchemeManager
  • ~ScriptModule() : CEGUI::ScriptModule
  • ~ScrollablePane() : CEGUI::ScrollablePane
  • ~Scrollbar() : CEGUI::Scrollbar
  • ~ScrolledContainer() : CEGUI::ScrolledContainer
  • ~Slider() : CEGUI::Slider
  • ~Spinner() : CEGUI::Spinner
  • ~Static() : CEGUI::Static
  • ~StaticImage() : CEGUI::StaticImage
  • ~StaticText() : CEGUI::StaticText
  • ~String() : CEGUI::String
  • ~System() : CEGUI::System
  • ~TabButton() : CEGUI::TabButton
  • ~TabControl() : CEGUI::TabControl
  • ~TabPane() : CEGUI::TabPane
  • ~TextItem() : CEGUI::TextItem
  • ~Texture() : CEGUI::Texture
  • ~Thumb() : CEGUI::Thumb
  • ~Titlebar() : CEGUI::Titlebar
  • ~Tooltip() : CEGUI::Tooltip
  • ~WidgetLookManager() : CEGUI::WidgetLookManager
  • ~Window() : CEGUI::Window
  • ~WindowFactoryManager() : CEGUI::WindowFactoryManager
  • ~WindowManager() : CEGUI::WindowManager
  • ~XMLAttributes() : CEGUI::XMLAttributes
  • ~XMLParser() : CEGUI::XMLParser
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • begin() : CEGUI::String
  • BottomAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • button : CEGUI::MouseEventArgs
  • button_PressHandler() : CEGUI::Combobox
  • ButtonBase() : CEGUI::ButtonBase
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • c_str() : CEGUI::String
  • cacheCaratImagery() : CEGUI::MultiLineEditbox
  • cacheEditboxBaseImagery() : CEGUI::MultiLineEditbox
  • cacheImage() : CEGUI::RenderCache
  • cacheListboxBaseImagery() : CEGUI::MultiColumnList, CEGUI::Listbox
  • cacheText() : CEGUI::RenderCache
  • cacheTextLines() : CEGUI::MultiLineEditbox
  • calculateModulatedAlphaColour() : CEGUI::Static, CEGUI::ListboxItem
  • calculateTabButtonSizePosition() : CEGUI::TabControl
  • capacity() : CEGUI::String
  • captureInput() : CEGUI::Window
  • changePopupMenuItem() : CEGUI::MenuBase
  • Checkbox() : CEGUI::Checkbox
  • Child() : TiXmlHandle
  • ChildElement() : TiXmlHandle
  • cleanDeadPool() : CEGUI::WindowManager
  • cleanup() : CEGUI::XMLParser
  • cleanupChildren() : CEGUI::Window
  • cleanupImpl() : CEGUI::XMLParser, CEGUI::XercesParser, CEGUI::TinyXMLParser
  • cleanupLoadedWindows() : CEGUI::GUILayout_xmlHandler
  • Clear() : TiXmlNode
  • clear() : CEGUI::String
  • clearAllSelections() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • clearAllSelections_impl() : CEGUI::MultiColumnList, CEGUI::Listbox
  • clearCachedImagery() : CEGUI::RenderCache
  • ClearError() : TiXmlDocument
  • clearFrameComponents() : CEGUI::ImagerySection
  • clearImageryComponents() : CEGUI::ImagerySection
  • clearImagerySections() : CEGUI::WidgetLookFeel
  • clearLayers() : CEGUI::StateImagery
  • clearNamedAreas() : CEGUI::WidgetLookFeel
  • clearProperties() : CEGUI::PropertySet
  • clearPropertyDefinitions() : CEGUI::WidgetLookFeel
  • clearPropertyInitialisers() : CEGUI::WidgetLookFeel
  • clearRenderList() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • clearSectionSpecifications() : CEGUI::LayerSpecification
  • clearSelection() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • clearStateSpecifications() : CEGUI::WidgetLookFeel
  • clearTextComponents() : CEGUI::ImagerySection
  • clearWidgetComponents() : CEGUI::WidgetLookFeel
  • clickCount : CEGUI::MouseEventArgs
  • clone() : CEGUI::BaseDim
  • Clone() : TiXmlDocument, TiXmlUnknown, TiXmlDeclaration, TiXmlText, TiXmlComment, TiXmlElement, TiXmlNode
  • clone_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • closeAllMenuItemPopups() : CEGUI::MenuItem
  • closeClickHandler() : CEGUI::FrameWindow
  • closePopupMenu() : CEGUI::PopupMenu, CEGUI::MenuItem
  • codepoint : CEGUI::KeyEventArgs
  • ColourRect() : CEGUI::ColourRect
  • Column() : TiXmlBase
  • column : CEGUI::MCLGridRef
  • Combobox() : CEGUI::Combobox
  • ComboDropList() : CEGUI::ComboDropList
  • compare() : CEGUI::String
  • Config_xmlHandler() : CEGUI::Config_xmlHandler
  • configureScrollbars() : CEGUI::StaticText, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • const_pointer : CEGUI::String
  • const_reference : CEGUI::String
  • const_reverse_iterator : CEGUI::String
  • ConstBaseIterator() : CEGUI::ConstBaseIterator< T >
  • constrainSize() : CEGUI::Rect
  • constrainSizeMax() : CEGUI::Rect
  • constrainSizeMin() : CEGUI::Rect
  • copy() : CEGUI::String
  • create() : CEGUI::WidgetComponent
  • createBindings() : CEGUI::ScriptModule
  • createCloseButton() : CEGUI::FrameWindow
  • createDecreaseButton() : CEGUI::Spinner, CEGUI::Scrollbar
  • createDropList() : CEGUI::Combobox
  • createEditbox() : CEGUI::Spinner, CEGUI::Combobox
  • createFont() : CEGUI::FontManager
  • createHorizontalScrollbar() : CEGUI::ScrollablePane
  • createHorzScrollbar() : CEGUI::StaticText, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • createImageset() : CEGUI::ImagesetManager
  • createImagesetFromImageFile() : CEGUI::ImagesetManager
  • createIncreaseButton() : CEGUI::Spinner, CEGUI::Scrollbar
  • createInitialisedSegment() : CEGUI::ListHeader
  • createListHeader() : CEGUI::MultiColumnList
  • createNewSegment() : CEGUI::ListHeader
  • createPushButton() : CEGUI::Combobox
  • createResourceProvider() : CEGUI::IrrlichtRenderer
  • createTabButton() : CEGUI::TabControl
  • createTabButtonPane() : CEGUI::TabControl
  • createTabContentPane() : CEGUI::TabControl
  • createTexture() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • createThumb() : CEGUI::Slider, CEGUI::Scrollbar
  • createTitlebar() : CEGUI::FrameWindow
  • createVerticalScrollbar() : CEGUI::ScrollablePane
  • createVertScrollbar() : CEGUI::StaticText, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • createWindow() : CEGUI::ScrolledContainerFactory, CEGUI::GUISheetFactory, CEGUI::DragContainerFactory, CEGUI::WindowManager, CEGUI::WindowFactory
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • d_abs_tabHeight : CEGUI::TabControl
  • d_abs_tabPadding : CEGUI::TabControl
  • d_active : CEGUI::Window
  • d_allowClicks : CEGUI::ListHeaderSegment
  • d_allowMultiplePopups : CEGUI::MenuBase
  • d_alpha : CEGUI::Window
  • d_alwaysOnTop : CEGUI::Window
  • d_area : CEGUI::FalagardComponentBase, CEGUI::Window
  • d_armed : CEGUI::ComboDropList
  • d_autoArm : CEGUI::ComboDropList
  • d_autoDelete : CEGUI::ListboxItem
  • d_autoRepeat : CEGUI::Window
  • d_autoScale : CEGUI::Imageset
  • d_autoscaleImages : CEGUI::PushButton
  • d_autosizePane : CEGUI::ScrolledContainer
  • d_background : CEGUI::Static
  • d_backgroundColours : CEGUI::MenuBase
  • d_backgroundCols : CEGUI::Static
  • d_backgroundEnabled : CEGUI::Static
  • d_beingDragged : CEGUI::Thumb
  • d_beingSized : CEGUI::FrameWindow
  • d_borderSize : CEGUI::FrameWindow
  • d_borderWidth : CEGUI::MenuBase
  • d_bottom : CEGUI::RenderableFrame
  • d_bottom_height : CEGUI::Static
  • d_bottom_or_height : CEGUI::ComponentArea
  • d_bottomleft : CEGUI::RenderableFrame
  • d_bottomright : CEGUI::RenderableFrame
  • d_button : CEGUI::Combobox
  • d_cache : CEGUI::Logger
  • d_caching : CEGUI::Logger
  • d_captionColour : CEGUI::Titlebar
  • d_captureWindow : CEGUI::Window
  • d_caratPos : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_children : CEGUI::Window
  • d_click_area : CEGUI::MouseClickTracker
  • d_click_count : CEGUI::MouseClickTracker
  • d_clippedByParent : CEGUI::Window
  • d_closeButton : CEGUI::FrameWindow
  • d_colourPropertyName : CEGUI::FalagardComponentBase
  • d_colourProperyIsRect : CEGUI::FalagardComponentBase
  • d_colours : CEGUI::FalagardComponentBase
  • d_container : CEGUI::ScrollablePane
  • d_contentArea : CEGUI::ScrolledContainer
  • d_contentRect : CEGUI::ScrollablePane
  • d_currentValue : CEGUI::Spinner
  • d_customTip : CEGUI::Window
  • d_decrease : CEGUI::Scrollbar
  • d_decreaseButton : CEGUI::Spinner
  • d_default : CEGUI::Property
  • d_defaultResourceGroup : CEGUI::ResourceProvider
  • d_destroyedByParent : CEGUI::Window
  • d_disabled : CEGUI::ListboxItem
  • d_disabledColour : CEGUI::ButtonBase
  • d_disabledImage : CEGUI::PushButton
  • d_disabledTextColour : CEGUI::MenuItem
  • d_displayTime : CEGUI::Tooltip
  • d_distCapturedInputs : CEGUI::Window
  • d_documentSize : CEGUI::Scrollbar
  • d_dragAlpha : CEGUI::DragContainer
  • d_dragAnchorIdx : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_dragCursorImage : CEGUI::DragContainer
  • d_dragEnabled : CEGUI::Titlebar
  • d_dragging : CEGUI::Titlebar, CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::DragContainer
  • d_draggingEnabled : CEGUI::DragContainer
  • d_dragMovable : CEGUI::FrameWindow
  • d_dragMoving : CEGUI::ListHeaderSegment
  • d_dragPoint : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::ListHeaderSegment, CEGUI::FrameWindow, CEGUI::DragContainer
  • d_dragPosition : CEGUI::ListHeaderSegment
  • d_dragSizing : CEGUI::ListHeaderSegment
  • d_dragThreshold : CEGUI::DragContainer
  • d_drawList : CEGUI::Window
  • d_droplist : CEGUI::Combobox
  • d_dropTarget : CEGUI::DragContainer
  • d_editbox : CEGUI::Spinner, CEGUI::Combobox
  • d_elapsed : CEGUI::Tooltip
  • d_enabled : CEGUI::Window
  • d_enableHorzScrollbar : CEGUI::StaticText
  • d_enableVertScrollbar : CEGUI::StaticText
  • d_eventConnections : CEGUI::ScrolledContainer
  • d_ewSizingCursor : CEGUI::FrameWindow
  • d_extent : CEGUI::MultiLineEditbox::LineInfo
  • d_fadeElapsed : CEGUI::PopupMenu
  • d_fadeInTime : CEGUI::PopupMenu
  • d_fadeOutTime : CEGUI::PopupMenu
  • d_fadeTime : CEGUI::Tooltip
  • d_fading : CEGUI::PopupMenu
  • d_fadingOut : CEGUI::PopupMenu
  • d_falagardType : CEGUI::Window
  • d_font : CEGUI::ListboxTextItem, CEGUI::Window
  • d_forceHorzScroll : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_forceVertScroll : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_frame : CEGUI::Static
  • d_frameCols : CEGUI::Static
  • d_frameEnabled : CEGUI::Static, CEGUI::FrameWindow
  • d_frameImages : CEGUI::FrameComponent
  • d_fullColSelect : CEGUI::MultiColumnList
  • d_fullRowSelect : CEGUI::MultiColumnList
  • d_grid : CEGUI::MultiColumnList
  • d_header : CEGUI::MultiColumnList
  • d_help : CEGUI::Property
  • d_horzAlign : CEGUI::Window
  • d_horzFormat : CEGUI::RenderableImage
  • d_horzFormatPropertyName : CEGUI::FalagardComponentBase
  • d_horzFormatting : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticText
  • d_horzFree : CEGUI::Thumb
  • d_horzMax : CEGUI::Thumb
  • d_horzOverlap : CEGUI::ScrollablePane
  • d_horzPadding : CEGUI::MenuBase
  • d_horzScaling : CEGUI::Imageset
  • d_horzScrollbar : CEGUI::StaticText, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_horzStep : CEGUI::ScrollablePane
  • d_hotTrack : CEGUI::Thumb
  • d_hoverColour : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_hoverImage : CEGUI::PushButton
  • d_hovering : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_hoverTime : CEGUI::Tooltip
  • d_ID : CEGUI::Window
  • d_identifierString : CEGUI::XMLParser, CEGUI::ScriptModule, CEGUI::Renderer
  • d_image : CEGUI::ImageryComponent, CEGUI::StaticImage, CEGUI::RenderableImage
  • d_imageCols : CEGUI::StaticImage
  • d_imagePropertyName : CEGUI::ImageryComponent
  • d_images : CEGUI::Imageset
  • d_inactiveSelectBrushColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_increase : CEGUI::Scrollbar
  • d_increaseButton : CEGUI::Spinner
  • d_inheritsAlpha : CEGUI::Window
  • d_inheritsTipText : CEGUI::Window
  • d_inputMode : CEGUI::Spinner
  • d_itemData : CEGUI::ListboxItem
  • d_itemID : CEGUI::ListboxItem
  • d_itemSpacing : CEGUI::MenuBase
  • d_itemText : CEGUI::ListboxItem
  • d_itemTooltips : CEGUI::Listbox
  • d_lastSelected : CEGUI::MultiColumnList, CEGUI::Listbox
  • d_left : CEGUI::ComponentArea, CEGUI::RenderableFrame
  • d_left_width : CEGUI::Static
  • d_leftMouseDown : CEGUI::DragContainer
  • d_length : CEGUI::MultiLineEditbox::LineInfo
  • d_level : CEGUI::Logger
  • d_lineBreakChars : CEGUI::MultiLineEditbox
  • d_lines : CEGUI::MultiLineEditbox
  • d_listItems : CEGUI::Listbox, CEGUI::ItemListBase
  • d_lookName : CEGUI::Window
  • d_maskCodePoint : CEGUI::Editbox
  • d_maskText : CEGUI::Editbox
  • d_maxSize : CEGUI::Window
  • d_maxTextLen : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_maxValue : CEGUI::Spinner, CEGUI::Slider
  • d_metricsMode : CEGUI::Window
  • d_minSize : CEGUI::Window
  • d_minValue : CEGUI::Spinner
  • d_mouseCursor : CEGUI::Window
  • d_movingEnabled : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • d_movingMouseCursor : CEGUI::ListHeaderSegment
  • d_multiselect : CEGUI::Listbox
  • d_multiSelect : CEGUI::MultiColumnList
  • d_muted : CEGUI::EventSet
  • d_name : CEGUI::Window, CEGUI::Property, CEGUI::Imageset
  • d_nativeHorzRes : CEGUI::Imageset
  • d_nativeVertRes : CEGUI::Imageset
  • d_needsRedraw : CEGUI::Window
  • d_neswSizingCursor : CEGUI::FrameWindow
  • d_newIdx : CEGUI::HeaderSequenceEventArgs
  • d_nextTabIndex : CEGUI::TabControl
  • d_nominatedSelectCol : CEGUI::MultiColumnList
  • d_nominatedSelectRow : CEGUI::MultiColumnList
  • d_normalColour : CEGUI::ButtonBase
  • d_normalImage : CEGUI::PushButton
  • d_normalTextColour : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox
  • d_nsSizingCursor : CEGUI::FrameWindow
  • d_nwseSizingCursor : CEGUI::FrameWindow
  • d_oldCapture : CEGUI::Window
  • d_oldCursorArea : CEGUI::Titlebar
  • d_oldIdx : CEGUI::HeaderSequenceEventArgs
  • d_opened : CEGUI::MenuItem
  • d_openedColour : CEGUI::MenuItem
  • d_origAlpha : CEGUI::PopupMenu
  • d_ostream : CEGUI::Logger
  • d_overlapSize : CEGUI::Scrollbar
  • d_owner : CEGUI::ListboxItem
  • d_pageSize : CEGUI::Scrollbar
  • d_parent : CEGUI::Window
  • d_pixelSize : CEGUI::Window
  • d_popup : CEGUI::MenuItem, CEGUI::MenuBase
  • d_popupWasClosed : CEGUI::MenuItem
  • d_position : CEGUI::Scrollbar
  • d_progress : CEGUI::ProgressBar
  • d_pushed : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_pushedColour : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_pushedImage : CEGUI::PushButton
  • d_quadSplitMode : CEGUI::RenderableImage
  • d_readOnly : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_rel_tabHeight : CEGUI::TabControl
  • d_rel_tabPadding : CEGUI::TabControl
  • d_renderCache : CEGUI::Window
  • d_repeatButton : CEGUI::Window
  • d_repeatDelay : CEGUI::Window
  • d_repeatElapsed : CEGUI::Window
  • d_repeating : CEGUI::Window
  • d_repeatRate : CEGUI::Window
  • d_resourceProvider : CEGUI::Renderer
  • d_restoreOldCapture : CEGUI::Window
  • d_right : CEGUI::RenderableFrame
  • d_right_or_width : CEGUI::ComponentArea
  • d_right_width : CEGUI::Static
  • d_rightOfSelected : CEGUI::TabButton
  • d_riseOnClick : CEGUI::Window
  • d_rolledup : CEGUI::FrameWindow
  • d_rollupEnabled : CEGUI::FrameWindow
  • d_segmentHover : CEGUI::ListHeaderSegment
  • d_segmentOffset : CEGUI::ListHeader
  • d_segmentPushed : CEGUI::ListHeaderSegment
  • d_segments : CEGUI::ListHeader
  • d_selectBrush : CEGUI::ListboxItem
  • d_selectBrushColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_selectCols : CEGUI::ListboxItem
  • d_selected : CEGUI::TabButton, CEGUI::ListboxItem, CEGUI::Checkbox
  • d_selectionBrush : CEGUI::MultiLineEditbox
  • d_selectionEnd : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_selectionStart : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_selectMode : CEGUI::MultiColumnList
  • d_selectTextColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_singleClickOperation : CEGUI::Combobox
  • d_sizingEnabled : CEGUI::ListHeaderSegment, CEGUI::ListHeader, CEGUI::FrameWindow
  • d_sizingMouseCursor : CEGUI::ListHeaderSegment
  • d_sortDir : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • d_sorted : CEGUI::Listbox
  • d_sortingEnabled : CEGUI::ListHeader
  • d_sortSegment : CEGUI::ListHeader
  • d_splitterHover : CEGUI::ListHeaderSegment
  • d_splitterSize : CEGUI::ListHeaderSegment
  • d_startIdx : CEGUI::MultiLineEditbox::LineInfo
  • d_startPosition : CEGUI::DragContainer
  • d_state : CEGUI::Tooltip
  • d_step : CEGUI::Slider, CEGUI::ProgressBar
  • d_stepSize : CEGUI::Spinner, CEGUI::Scrollbar
  • d_storedAlpha : CEGUI::DragContainer
  • d_storedClipState : CEGUI::DragContainer
  • d_tabButtonIndexMap : CEGUI::TabControl
  • d_tabButtonPane : CEGUI::TabControl
  • d_tabContentPane : CEGUI::TabControl
  • d_tabIndex : CEGUI::TabButton
  • d_target : CEGUI::Tooltip
  • d_target_window : CEGUI::MouseClickTracker
  • d_targetWindow : CEGUI::TabButton
  • d_text : CEGUI::Window
  • d_textColour : CEGUI::TextItem
  • d_textCols : CEGUI::StaticText, CEGUI::ListboxTextItem
  • d_textFormatting : CEGUI::TextItem
  • d_texture : CEGUI::Imageset
  • d_textureFilename : CEGUI::Imageset
  • d_textXOffset : CEGUI::TextItem, CEGUI::PushButton
  • d_thumb : CEGUI::Slider, CEGUI::Scrollbar
  • d_timer : CEGUI::MouseClickTracker
  • d_titlebar : CEGUI::FrameWindow
  • d_tooltipText : CEGUI::ListboxItem, CEGUI::Window
  • d_top : CEGUI::ComponentArea, CEGUI::RenderableFrame
  • d_top_height : CEGUI::Static
  • d_topleft : CEGUI::RenderableFrame
  • d_topright : CEGUI::RenderableFrame
  • d_type : CEGUI::WindowFactory, CEGUI::Window
  • d_uniqueIDNumber : CEGUI::ListHeader
  • d_useDisabledImage : CEGUI::PushButton
  • d_useHoverImage : CEGUI::PushButton
  • d_useNominatedCol : CEGUI::MultiColumnList
  • d_useNominatedRow : CEGUI::MultiColumnList
  • d_useNormalImage : CEGUI::PushButton
  • d_usePushedImage : CEGUI::PushButton
  • d_userData : CEGUI::Window
  • d_userStrings : CEGUI::Window
  • d_useStandardImagery : CEGUI::PushButton
  • d_validationString : CEGUI::Editbox
  • d_validator : CEGUI::Editbox
  • d_value : CEGUI::Slider
  • d_vertAlign : CEGUI::Window
  • d_vertFormat : CEGUI::RenderableImage
  • d_vertFormatPropertyName : CEGUI::FalagardComponentBase
  • d_vertFormatting : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticText
  • d_vertFree : CEGUI::Thumb
  • d_vertMax : CEGUI::Thumb
  • d_vertOverlap : CEGUI::ScrollablePane
  • d_vertPadding : CEGUI::MenuBase
  • d_vertScaling : CEGUI::Imageset
  • d_vertScrollbar : CEGUI::StaticText, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_vertStep : CEGUI::ScrollablePane
  • d_visible : CEGUI::Window
  • d_wantsMultiClicks : CEGUI::Window
  • d_weOwnTip : CEGUI::Window
  • d_widestExtent : CEGUI::MultiLineEditbox
  • d_wordWrap : CEGUI::MultiLineEditbox
  • d_workstream : CEGUI::Logger
  • d_writeXML : CEGUI::Property
  • d_zOrderingEnabled : CEGUI::Window
  • data() : CEGUI::String
  • deactivate() : CEGUI::Window
  • DefaultAlphanumerical : CEGUI::TextUtils
  • DefaultBackgroundColour : CEGUI::MenuBase
  • DefaultColour : CEGUI::Font
  • DefaultDisabledLabelColour : CEGUI::ButtonBase
  • DefaultDisabledTextColour : CEGUI::MenuItem
  • DefaultHoverColour : CEGUI::MenuItem
  • DefaultHoverLabelColour : CEGUI::ButtonBase
  • DefaultInactiveSelectionColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • DefaultMultiClickAreaSize : CEGUI::System
  • DefaultMultiClickTimeout : CEGUI::System
  • DefaultNormalLabelColour : CEGUI::ButtonBase
  • DefaultNormalSelectionColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • DefaultNormalTextColour : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox
  • DefaultOpenedColour : CEGUI::MenuItem
  • DefaultPushedColour : CEGUI::MenuItem
  • DefaultPushedLabelColour : CEGUI::ButtonBase
  • DefaultSelectedTextColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • DefaultSelectionColour : CEGUI::ListboxItem
  • DefaultSingleClickTimeout : CEGUI::System
  • DefaultSizingArea : CEGUI::ListHeaderSegment
  • DefaultSizingBorderSize : CEGUI::FrameWindow
  • DefaultTextColour : CEGUI::TextItem, CEGUI::ListboxTextItem
  • DefaultWhitespace : CEGUI::TextUtils
  • DefaultWrapDelimiters : CEGUI::TextUtils
  • defineFontGlyphs() : CEGUI::Font
  • defineImage() : CEGUI::Imageset
  • Descending : CEGUI::ListHeaderSegment
  • deselectOtherButtonsInGroup() : CEGUI::RadioButton
  • destroy() : CEGUI::Window
  • destroyAllFonts() : CEGUI::FontManager
  • destroyAllImagesets() : CEGUI::ImagesetManager
  • destroyAllTextures() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • destroyAllWindows() : CEGUI::WindowManager
  • destroyBindings() : CEGUI::ScriptModule
  • destroyFont() : CEGUI::FontManager
  • destroyImageset() : CEGUI::ImagesetManager
  • destroyListSegment() : CEGUI::ListHeader
  • destroyTexture() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • destroyWindow() : CEGUI::ScrolledContainerFactory, CEGUI::GUISheetFactory, CEGUI::DragContainerFactory, CEGUI::WindowManager, CEGUI::WindowFactory
  • difference_type : CEGUI::String
  • Dimension() : CEGUI::Dimension
  • DirectX81Renderer() : CEGUI::DirectX81Renderer
  • DirectX9Renderer() : CEGUI::DirectX9Renderer
  • disable() : CEGUI::Window
  • distributesCapturedInputs() : CEGUI::Window
  • doDragging() : CEGUI::DragContainer
  • doDragMoving() : CEGUI::ListHeaderSegment
  • doDragSizing() : CEGUI::ListHeaderSegment
  • doRender() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • doRiseOnClick() : CEGUI::Window
  • DoubleValue() : TiXmlAttribute
  • DragContainer() : CEGUI::DragContainer
  • draw() : CEGUI::ListboxTextItem, CEGUI::ListboxItem, CEGUI::MouseCursor, CEGUI::Imageset, CEGUI::Image
  • draw_impl() : CEGUI::RenderableImage, CEGUI::RenderableFrame
  • drawDisabled() : CEGUI::ButtonBase
  • drawHover() : CEGUI::ButtonBase
  • drawNormal() : CEGUI::ButtonBase
  • drawPushed() : CEGUI::ButtonBase
  • drawSelf() : CEGUI::TabControl, CEGUI::TabButton, CEGUI::ScrolledContainer, CEGUI::GUISheet, CEGUI::DragContainer, CEGUI::ButtonBase, CEGUI::Window
  • drawText() : CEGUI::Font
  • droplist_HiddenHandler() : CEGUI::Combobox
  • droplist_SelectionAcceptedHandler() : CEGUI::Combobox
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • Editbox() : CEGUI::Editbox
  • editbox_MouseDownHandler() : CEGUI::Combobox
  • Element() : TiXmlHandle
  • elementStart() : CEGUI::Scheme_xmlHandler, CEGUI::Imageset_xmlHandler, CEGUI::GUILayout_xmlHandler, CEGUI::Font_xmlHandler, CEGUI::Config_xmlHandler
  • empty() : CEGUI::String
  • enable() : CEGUI::Window
  • Encoding() : TiXmlDeclaration
  • end() : CEGUI::String
  • ensureCaratIsVisible() : CEGUI::MultiLineEditbox
  • ensureItemIsVisible() : CEGUI::Listbox
  • erase() : CEGUI::String
  • eraseSelectedText() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • eraseWidgetLook() : CEGUI::WidgetLookManager
  • Error() : TiXmlDocument
  • ErrorCol() : TiXmlDocument
  • ErrorDesc() : TiXmlDocument
  • ErrorId() : TiXmlDocument
  • ErrorRow() : TiXmlDocument
  • Event() : CEGUI::Event
  • EventActivated : CEGUI::Window
  • EventAlphaChanged : CEGUI::Window
  • EventAlwaysOnTopChanged : CEGUI::Window
  • EventAutoSizeSettingChanged : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • EventCaratMoved : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventCharacterKey : CEGUI::Window
  • EventCheckStateChanged : CEGUI::Checkbox
  • EventChildAdded : CEGUI::Window
  • EventChildRemoved : CEGUI::Window
  • EventClickableSettingChanged : CEGUI::ListHeaderSegment
  • EventClicked : CEGUI::TabButton, CEGUI::PushButton, CEGUI::MenuItem
  • EventClippedByParentChanged : CEGUI::Window
  • EventCloseClicked : CEGUI::FrameWindow
  • EventContentChanged : CEGUI::ScrolledContainer
  • EventContentPaneChanged : CEGUI::ScrollablePane
  • EventContentPaneScrolled : CEGUI::ScrollablePane
  • EventDeactivated : CEGUI::Window
  • EventDefaultFontChanged : CEGUI::System
  • EventDefaultMouseCursorChanged : CEGUI::System
  • EventDestroyedByParentChanged : CEGUI::Window
  • EventDestructionStarted : CEGUI::Window
  • EventDisabled : CEGUI::Window
  • EventDisplaySizeChanged : CEGUI::Renderer
  • EventDisplayTimeChanged : CEGUI::Tooltip
  • EventDragAlphaChanged : CEGUI::DragContainer
  • EventDragDropItemDropped : CEGUI::Window
  • EventDragDropItemEnters : CEGUI::Window
  • EventDragDropItemLeaves : CEGUI::Window
  • EventDragDropTargetChanged : CEGUI::DragContainer
  • EventDragEnabledChanged : CEGUI::DragContainer
  • EventDragEnded : CEGUI::DragContainer
  • EventDragMouseCursorChanged : CEGUI::DragContainer
  • EventDragMoveSettingChanged : CEGUI::ListHeader
  • EventDragPositionChanged : CEGUI::DragContainer
  • EventDragSizeSettingChanged : CEGUI::ListHeader
  • EventDragStarted : CEGUI::DragContainer
  • EventDragThresholdChanged : CEGUI::DragContainer
  • EventDropListDisplayed : CEGUI::Combobox
  • EventDropListRemoved : CEGUI::Combobox
  • EventEditboxFull : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventEnabled : CEGUI::Window
  • EventFadeTimeChanged : CEGUI::Tooltip
  • EventFontChanged : CEGUI::Window
  • EventGUISheetChanged : CEGUI::System
  • EventHidden : CEGUI::Window
  • EventHorizontalAlignmentChanged : CEGUI::Window
  • EventHorzScrollbarModeChanged : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • EventHoverTimeChanged : CEGUI::Tooltip
  • EventIDChanged : CEGUI::Window
  • EventImageChanged : CEGUI::MouseCursor
  • EventInheritsAlphaChanged : CEGUI::Window
  • EventInputCaptureGained : CEGUI::Window
  • EventInputCaptureLost : CEGUI::Window
  • EventInvalidEntryAttempted : CEGUI::Editbox, CEGUI::Combobox
  • EventKeyDown : CEGUI::Window
  • EventKeyUp : CEGUI::Window
  • EventListColumnMoved : CEGUI::MultiColumnList
  • EventListColumnSized : CEGUI::MultiColumnList
  • EventListContentsChanged : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • EventListSelectionAccepted : CEGUI::ComboDropList, CEGUI::Combobox
  • EventListSelectionChanged : CEGUI::Combobox
  • EventMaskCodePointChanged : CEGUI::Editbox
  • EventMaskedRenderingModeChanged : CEGUI::Editbox
  • EventMaximumTextLengthChanged : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventMaximumValueChanged : CEGUI::Spinner
  • EventMetricsModeChanged : CEGUI::Window
  • EventMinimumValueChanged : CEGUI::Spinner
  • EventMouseButtonDown : CEGUI::Window
  • EventMouseButtonUp : CEGUI::Window
  • EventMouseClick : CEGUI::Window
  • EventMouseDoubleClick : CEGUI::Window
  • EventMouseEnters : CEGUI::Window
  • EventMouseLeaves : CEGUI::Window
  • EventMouseMove : CEGUI::Window
  • EventMouseMoveScalingChanged : CEGUI::System
  • EventMouseTripleClick : CEGUI::Window
  • EventMouseWheel : CEGUI::Window
  • EventMovableSettingChanged : CEGUI::ListHeaderSegment
  • EventMoved : CEGUI::Window
  • EventMultiClickAreaSizeChanged : CEGUI::System
  • EventMultiClickTimeoutChanged : CEGUI::System
  • EventMultiselectModeChanged : CEGUI::Listbox
  • EventNamespace : CEGUI::Tooltip, CEGUI::Titlebar, CEGUI::Thumb, CEGUI::TabControl, CEGUI::TabButton, CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::Spinner, CEGUI::Slider, CEGUI::ScrolledContainer, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::RadioButton, CEGUI::PushButton, CEGUI::ProgressBar, CEGUI::PopupMenu, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::MenuItem, CEGUI::MenuBase, CEGUI::Menubar, CEGUI::ListHeaderSegment, CEGUI::ListHeader, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::Checkbox, CEGUI::Window, CEGUI::System, CEGUI::Renderer, CEGUI::MouseCursor
  • EventNominatedSelectColumnChanged : CEGUI::MultiColumnList
  • EventNominatedSelectRowChanged : CEGUI::MultiColumnList
  • EventParentSized : CEGUI::Window
  • EventPopupClosed : CEGUI::MenuBase
  • EventPopupOpened : CEGUI::MenuBase
  • EventProgressChanged : CEGUI::ProgressBar
  • EventProgressDone : CEGUI::ProgressBar
  • EventReadOnlyModeChanged : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventRenderingEnded : CEGUI::Window
  • EventRenderingStarted : CEGUI::Window
  • EventRollupToggled : CEGUI::FrameWindow
  • EventScrollConfigChanged : CEGUI::Scrollbar
  • EventScrollPositionChanged : CEGUI::Scrollbar
  • EventSegmentAdded : CEGUI::ListHeader
  • EventSegmentClicked : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventSegmentDragPositionChanged : CEGUI::ListHeaderSegment
  • EventSegmentDragStart : CEGUI::ListHeaderSegment
  • EventSegmentDragStop : CEGUI::ListHeaderSegment
  • EventSegmentRemoved : CEGUI::ListHeader
  • EventSegmentRenderOffsetChanged : CEGUI::ListHeader
  • EventSegmentSequenceChanged : CEGUI::ListHeader
  • EventSegmentSized : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventSelectionChanged : CEGUI::TabControl, CEGUI::MultiColumnList, CEGUI::Listbox
  • EventSelectionModeChanged : CEGUI::MultiColumnList
  • EventSelectStateChanged : CEGUI::RadioButton
  • EventSet() : CEGUI::EventSet
  • EventShown : CEGUI::Window
  • EventSingleClickTimeoutChanged : CEGUI::System
  • EventSized : CEGUI::Window
  • EventSizingSettingChanged : CEGUI::ListHeaderSegment
  • EventSortColumnChanged : CEGUI::MultiColumnList, CEGUI::ListHeader
  • EventSortDirectionChanged : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventSortModeChanged : CEGUI::Listbox, CEGUI::Combobox
  • EventSortSettingChanged : CEGUI::ListHeader
  • EventSplitterDoubleClicked : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventStepChanged : CEGUI::Spinner
  • EventTextAccepted : CEGUI::Editbox, CEGUI::Combobox
  • EventTextChanged : CEGUI::Window
  • EventTextInputModeChanged : CEGUI::Spinner
  • EventTextInvalidated : CEGUI::Editbox, CEGUI::Combobox
  • EventTextSelectionChanged : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventThumbPositionChanged : CEGUI::Thumb
  • EventThumbTrackEnded : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • EventThumbTrackStarted : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • EventTooltipActive : CEGUI::Tooltip
  • EventTooltipInactive : CEGUI::Tooltip
  • EventValidationStringChanged : CEGUI::Editbox, CEGUI::Combobox
  • EventValueChanged : CEGUI::Spinner, CEGUI::Slider
  • EventVerticalAlignmentChanged : CEGUI::Window
  • EventVertScrollbarModeChanged : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • EventWordWrapModeChanged : CEGUI::MultiLineEditbox
  • EventZOrderChanged : CEGUI::Window
  • executeScriptedEventHandler() : CEGUI::ScriptModule
  • executeScriptFile() : CEGUI::System, CEGUI::ScriptModule
  • executeScriptGlobal() : CEGUI::System, CEGUI::ScriptModule
  • executeScriptString() : CEGUI::System
  • executeString() : CEGUI::ScriptModule
  • exists() : CEGUI::XMLAttributes
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FactoryModule() : CEGUI::FactoryModule
  • FadeIn : CEGUI::Tooltip
  • FadeOut : CEGUI::Tooltip
  • Falagard_xmlHandler() : CEGUI::Falagard_xmlHandler
  • FalagardComponentBase() : CEGUI::FalagardComponentBase
  • find() : CEGUI::String
  • find_first_not_of() : CEGUI::String
  • find_first_of() : CEGUI::String
  • find_last_not_of() : CEGUI::String
  • find_last_of() : CEGUI::String
  • findColumnItemWithText() : CEGUI::MultiColumnList
  • findItemWithText() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • findListItemWithText() : CEGUI::MultiColumnList
  • findRowItemWithText() : CEGUI::MultiColumnList
  • fireEvent() : CEGUI::GlobalEventSet, CEGUI::EventSet
  • FirstAttribute() : TiXmlElement
  • FirstChild() : TiXmlHandle, TiXmlNode
  • FirstChildElement() : TiXmlHandle, TiXmlNode
  • FloatingPoint : CEGUI::Spinner
  • FloatValidator : CEGUI::Spinner
  • Font_xmlHandler() : CEGUI::Font_xmlHandler
  • FontDim() : CEGUI::FontDim
  • FontManager() : CEGUI::FontManager
  • formatText() : CEGUI::MultiLineEditbox
  • FrameComponent() : CEGUI::FrameComponent
  • FrameWindow() : CEGUI::FrameWindow
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • generateAutoRepeatEvent() : CEGUI::Window
  • GeneratedWindowNameBase : CEGUI::WindowManager
  • get() : CEGUI::PropertyDefinition, CEGUI::TooltipProperties::FadeTime, CEGUI::TooltipProperties::DisplayTime, CEGUI::TooltipProperties::HoverTime, CEGUI::TitlebarProperties::CaptionColour, CEGUI::TitlebarProperties::DraggingEnabled, CEGUI::ThumbProperties::HorzRange, CEGUI::ThumbProperties::VertRange, CEGUI::ThumbProperties::HorzFree, CEGUI::ThumbProperties::VertFree, CEGUI::ThumbProperties::HotTracked, CEGUI::TextItemProperties::TextFormatting, CEGUI::TextItemProperties::TextColour, CEGUI::TextItemProperties::TextXOffset, CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::AbsoluteTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::RelativeTabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::StaticTextProperties::HorzScrollbar, CEGUI::StaticTextProperties::VertScrollbar, CEGUI::StaticTextProperties::VertFormatting, CEGUI::StaticTextProperties::HorzFormatting, CEGUI::StaticTextProperties::TextColours, CEGUI::StaticProperties::BottomFrameImage, CEGUI::StaticProperties::TopFrameImage, CEGUI::StaticProperties::RightFrameImage, CEGUI::StaticProperties::LeftFrameImage, CEGUI::StaticProperties::BottomRightFrameImage, CEGUI::StaticProperties::BottomLeftFrameImage, CEGUI::StaticProperties::TopRightFrameImage, CEGUI::StaticProperties::TopLeftFrameImage, CEGUI::StaticProperties::BackgroundImage, CEGUI::StaticProperties::BackgroundColours, CEGUI::StaticProperties::FrameColours, CEGUI::StaticProperties::BackgroundEnabled, CEGUI::StaticProperties::FrameEnabled, CEGUI::StaticImageProperties::VertFormatting, CEGUI::StaticImageProperties::HorzFormatting, CEGUI::StaticImageProperties::ImageColours, CEGUI::StaticImageProperties::Image, CEGUI::SpinnerProperties::TextInputMode, CEGUI::SpinnerProperties::MaximumValue, CEGUI::SpinnerProperties::MinimumValue, CEGUI::SpinnerProperties::StepSize, CEGUI::SpinnerProperties::CurrentValue, CEGUI::SliderProperties::ClickStepSize, CEGUI::SliderProperties::MaximumValue, CEGUI::SliderProperties::CurrentValue, CEGUI::ScrolledContainerProperties::ChildExtentsArea, CEGUI::ScrolledContainerProperties::ContentArea, CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, CEGUI::ScrollbarProperties::ScrollPosition, CEGUI::ScrollbarProperties::OverlapSize, CEGUI::ScrollbarProperties::StepSize, CEGUI::ScrollbarProperties::PageSize, CEGUI::ScrollbarProperties::DocumentSize, CEGUI::ScrollablePaneProperties::VertScrollPosition, CEGUI::ScrollablePaneProperties::VertOverlapSize, CEGUI::ScrollablePaneProperties::VertStepSize, CEGUI::ScrollablePaneProperties::HorzScrollPosition, CEGUI::ScrollablePaneProperties::HorzOverlapSize, CEGUI::ScrollablePaneProperties::HorzStepSize, CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, CEGUI::ScrollablePaneProperties::ForceVertScrollbar, CEGUI::ScrollablePaneProperties::ContentArea, CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, CEGUI::RadioButtonProperties::GroupID, CEGUI::RadioButtonProperties::Selected, CEGUI::PushButtonProperties::TextXOffset, CEGUI::PushButtonProperties::UseStandardImagery, CEGUI::PushButtonProperties::DisabledImage, CEGUI::PushButtonProperties::HoverImage, CEGUI::PushButtonProperties::PushedImage, CEGUI::PushButtonProperties::NormalImage, CEGUI::ProgressBarProperties::StepSize, CEGUI::ProgressBarProperties::CurrentProgress, CEGUI::PopupMenuProperties::FadeOutTime, CEGUI::PopupMenuProperties::FadeInTime, CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, CEGUI::MultiLineEditboxProperties::SelectedTextColour, CEGUI::MultiLineEditboxProperties::NormalTextColour, CEGUI::MultiLineEditboxProperties::MaxTextLength, CEGUI::MultiLineEditboxProperties::SelectionLength, CEGUI::MultiLineEditboxProperties::SelectionStart, CEGUI::MultiLineEditboxProperties::CaratIndex, CEGUI::MultiLineEditboxProperties::WordWrap, CEGUI::MultiLineEditboxProperties::ReadOnly, CEGUI::MultiColumnListProperties::RowCount, CEGUI::MultiColumnListProperties::ColumnHeader, CEGUI::MultiColumnListProperties::SelectionMode, CEGUI::MultiColumnListProperties::ForceHorzScrollbar, CEGUI::MultiColumnListProperties::ForceVertScrollbar, CEGUI::MultiColumnListProperties::NominatedSelectionRow, CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, CEGUI::MultiColumnListProperties::SortColumnID, CEGUI::MultiColumnListProperties::SortDirection, CEGUI::MultiColumnListProperties::SortSettingEnabled, CEGUI::MultiColumnListProperties::ColumnsMovable, CEGUI::MultiColumnListProperties::ColumnsSizable, CEGUI::MenuItemProperties::DisabledTextColour, CEGUI::MenuItemProperties::NormalTextColour, CEGUI::MenuItemProperties::OpenedColour, CEGUI::MenuItemProperties::PushedColour, CEGUI::MenuItemProperties::HoverColour, CEGUI::MenuBaseProperties::AllowMultiplePopups, CEGUI::MenuBaseProperties::BackgroundColours, CEGUI::MenuBaseProperties::BorderWidth, CEGUI::MenuBaseProperties::VertPadding, CEGUI::MenuBaseProperties::HorzPadding, CEGUI::MenuBaseProperties::ItemSpacing, CEGUI::ListHeaderSegmentProperties::SortDirection, CEGUI::ListHeaderSegmentProperties::Dragable, CEGUI::ListHeaderSegmentProperties::Clickable, CEGUI::ListHeaderSegmentProperties::Sizable, CEGUI::ListHeaderProperties::SortColumnID, CEGUI::ListHeaderProperties::SortDirection, CEGUI::ListHeaderProperties::SortSettingEnabled, CEGUI::ListHeaderProperties::ColumnsMovable, CEGUI::ListHeaderProperties::ColumnsSizable, CEGUI::ListboxProperties::ItemTooltips, CEGUI::ListboxProperties::ForceHorzScrollbar, CEGUI::ListboxProperties::ForceVertScrollbar, CEGUI::ListboxProperties::MultiSelect, CEGUI::ListboxProperties::Sort, CEGUI::ItemListBaseProperties::AutoResizeEnabled, CEGUI::FrameWindowProperties::NESWSizingCursorImage, CEGUI::FrameWindowProperties::NWSESizingCursorImage, CEGUI::FrameWindowProperties::EWSizingCursorImage, CEGUI::FrameWindowProperties::NSSizingCursorImage, CEGUI::FrameWindowProperties::CaptionColour, CEGUI::FrameWindowProperties::TitlebarFont, CEGUI::FrameWindowProperties::SizingBorderThickness, CEGUI::FrameWindowProperties::DragMovingEnabled, CEGUI::FrameWindowProperties::RollUpState, CEGUI::FrameWindowProperties::RollUpEnabled, CEGUI::FrameWindowProperties::CloseButtonEnabled, CEGUI::FrameWindowProperties::TitlebarEnabled, CEGUI::FrameWindowProperties::FrameEnabled, CEGUI::FrameWindowProperties::SizingEnabled, CEGUI::EditboxProperties::InactiveSelectionColour, CEGUI::EditboxProperties::ActiveSelectionColour, CEGUI::EditboxProperties::SelectedTextColour, CEGUI::EditboxProperties::NormalTextColour, CEGUI::EditboxProperties::MaxTextLength, CEGUI::EditboxProperties::SelectionLength, CEGUI::EditboxProperties::SelectionStart, CEGUI::EditboxProperties::CaratIndex, CEGUI::EditboxProperties::ValidationString, CEGUI::EditboxProperties::MaskCodepoint, CEGUI::EditboxProperties::MaskText, CEGUI::EditboxProperties::ReadOnly, CEGUI::DragContainerProperties::DragCursorImage, CEGUI::DragContainerProperties::DragThreshold, CEGUI::DragContainerProperties::DragAlpha, CEGUI::DragContainerProperties::DraggingEnabled, CEGUI::ComboboxProperties::SingleClickMode, CEGUI::ComboboxProperties::ForceHorzScrollbar, CEGUI::ComboboxProperties::ForceVertScrollbar, CEGUI::ComboboxProperties::SortList, CEGUI::ComboboxProperties::InactiveEditSelectionColour, CEGUI::ComboboxProperties::ActiveEditSelectionColour, CEGUI::ComboboxProperties::SelectedEditTextColour, CEGUI::ComboboxProperties::NormalEditTextColour, CEGUI::ComboboxProperties::MaxEditTextLength, CEGUI::ComboboxProperties::EditSelectionLength, CEGUI::ComboboxProperties::EditSelectionStart, CEGUI::ComboboxProperties::CaratIndex, CEGUI::ComboboxProperties::ValidationString, CEGUI::ComboboxProperties::ReadOnly, CEGUI::CheckboxProperties::Selected, CEGUI::ButtonBaseProperties::DisabledTextColour, CEGUI::ButtonBaseProperties::PushedTextColour, CEGUI::ButtonBaseProperties::HoverTextColour, CEGUI::ButtonBaseProperties::NormalTextColour, CEGUI::WindowProperties::HorizontalAlignment, CEGUI::WindowProperties::VerticalAlignment, CEGUI::WindowProperties::RiseOnClick, CEGUI::WindowProperties::InheritsTooltipText, CEGUI::WindowProperties::Tooltip, CEGUI::WindowProperties::CustomTooltipType, CEGUI::WindowProperties::DistributeCapturedInputs, CEGUI::WindowProperties::AutoRepeatRate, CEGUI::WindowProperties::AutoRepeatDelay, CEGUI::WindowProperties::MouseButtonDownAutoRepeat, CEGUI::WindowProperties::WantsMultiClickEvents, CEGUI::WindowProperties::ZOrderChangeEnabled, CEGUI::WindowProperties::AbsoluteRect, CEGUI::WindowProperties::RelativeRect, CEGUI::WindowProperties::Rect, CEGUI::WindowProperties::AbsolutePosition, CEGUI::WindowProperties::RelativePosition, CEGUI::WindowProperties::Position, CEGUI::WindowProperties::AbsoluteYPosition, CEGUI::WindowProperties::RelativeYPosition, CEGUI::WindowProperties::YPosition, CEGUI::WindowProperties::AbsoluteXPosition, CEGUI::WindowProperties::RelativeXPosition, CEGUI::WindowProperties::XPosition, CEGUI::WindowProperties::AbsoluteSize, CEGUI::WindowProperties::RelativeSize, CEGUI::WindowProperties::Size, CEGUI::WindowProperties::AbsoluteHeight, CEGUI::WindowProperties::RelativeHeight, CEGUI::WindowProperties::Height, CEGUI::WindowProperties::AbsoluteWidth, CEGUI::WindowProperties::RelativeWidth, CEGUI::WindowProperties::Width, CEGUI::WindowProperties::DestroyedByParent, CEGUI::WindowProperties::RestoreOldCapture, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::AlwaysOnTop, CEGUI::WindowProperties::InheritsAlpha, CEGUI::WindowProperties::ClippedByParent, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Text, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::Alpha, CEGUI::WindowProperties::ID, CEGUI::WindowProperties::MetricsMode, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::AbsoluteMinSize, CEGUI::WindowProperties::RelativeMaxSize, CEGUI::WindowProperties::RelativeMinSize, CEGUI::Property
  • getAbsoluteHeight() : CEGUI::Window
  • getAbsolutePosition() : CEGUI::Window
  • getAbsoluteRect() : CEGUI::Window
  • getAbsoluteSize() : CEGUI::Window
  • getAbsoluteTabHeight() : CEGUI::TabControl
  • getAbsoluteTabTextPadding() : CEGUI::TabControl
  • getAbsoluteWidth() : CEGUI::Window
  • getAbsoluteXPosition() : CEGUI::Window
  • getAbsoluteYPosition() : CEGUI::Window
  • getActiveChild() : CEGUI::Window
  • getActiveSibling() : CEGUI::Window
  • getActiveTarget() : CEGUI::WindowFactoryManager::AliasTargetStack
  • getAdjustDirectionFromPoint() : CEGUI::Slider, CEGUI::Scrollbar
  • getAliasIterator() : CEGUI::WindowFactoryManager
  • getAlpha() : CEGUI::Window
  • getArea() : CEGUI::NamedArea
  • getAreaPropertySource() : CEGUI::ComponentArea
  • getAutoRepeatDelay() : CEGUI::Window
  • getAutoRepeatRate() : CEGUI::Window
  • getAvailableGlyphs() : CEGUI::Font
  • getBackgroundColours() : CEGUI::Static, CEGUI::MenuBase
  • getBackgroundHorizontalFormatting() : CEGUI::FrameComponent
  • getBackgroundImage() : CEGUI::Static
  • getBackgroundVerticalFormatting() : CEGUI::FrameComponent
  • getBaseDimension() : CEGUI::Dimension
  • getBaseline() : CEGUI::Font
  • getBaseXCoord() : CEGUI::RenderableImage
  • getBaseYCoord() : CEGUI::RenderableImage
  • getBorderWidth() : CEGUI::MenuBase
  • getBoundingRect() : CEGUI::ImagerySection
  • getButtonForTabContents() : CEGUI::TabControl
  • getCaptionColour() : CEGUI::Titlebar, CEGUI::FrameWindow
  • getCaptureWindow() : CEGUI::Window
  • getCaratIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getCharAtPixel() : CEGUI::Font
  • getChild() : CEGUI::Window
  • getChildAtIdx() : CEGUI::Window
  • getChildAtPosition() : CEGUI::Window
  • getChildCount() : CEGUI::Window
  • getChildExtentsArea() : CEGUI::ScrolledContainer
  • getClickStep() : CEGUI::Slider
  • getColourAtPoint() : CEGUI::ColourRect
  • getColours() : CEGUI::FalagardComponentBase
  • getColumnCount() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • getColumnFromID() : CEGUI::ListHeader
  • getColumnFromSegment() : CEGUI::ListHeader
  • getColumnHeaderWidth() : CEGUI::MultiColumnList
  • getColumnID() : CEGUI::MultiColumnList
  • getColumnPixelWidth() : CEGUI::ListHeader
  • getColumnWithHeaderText() : CEGUI::MultiColumnList
  • getColumnWithID() : CEGUI::MultiColumnList
  • getColumnWithText() : CEGUI::ListHeader
  • getComponentArea() : CEGUI::FalagardComponentBase
  • getConstraintArea() : CEGUI::MouseCursor
  • getContentArea() : CEGUI::ScrolledContainer
  • getContentPane() : CEGUI::ScrollablePane
  • getContentPaneArea() : CEGUI::ScrollablePane
  • getContentSize() : CEGUI::PopupMenu, CEGUI::Menubar, CEGUI::ItemListBase
  • getCount() : CEGUI::XMLAttributes
  • getCurrentDropTarget() : CEGUI::DragContainer
  • getCurrentKey() : CEGUI::ConstBaseIterator< T >
  • getCurrentValue() : CEGUI::Spinner, CEGUI::Slider, CEGUI::ConstBaseIterator< T >
  • getCurrentZ() : CEGUI::Renderer
  • getD3DTexture() : CEGUI::DirectX9Texture, CEGUI::DirectX81Texture
  • getDefault() : CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::Property
  • getDefaultFont() : CEGUI::System
  • getDefaultFontName() : CEGUI::Config_xmlHandler
  • getDefaultMouseCursor() : CEGUI::System
  • getDefaultResourceGroup() : CEGUI::ResourceProvider, CEGUI::Config_xmlHandler
  • getDefaultTooltip() : CEGUI::System
  • getDereferencedAliasType() : CEGUI::WindowFactoryManager
  • getDestinationSize() : CEGUI::RenderableImage
  • getDimensionOperator() : CEGUI::BaseDim
  • getDimensionType() : CEGUI::Dimension
  • getDisabledImage() : CEGUI::PushButton
  • getDisabledTextColour() : CEGUI::MenuItem, CEGUI::ButtonBase
  • getDisplayIndependantPosition() : CEGUI::MouseCursor
  • getDisplayTime() : CEGUI::Tooltip
  • GetDocument() : TiXmlNode
  • getDocumentSize() : CEGUI::Scrollbar
  • getDragAlpha() : CEGUI::DragContainer
  • getDragCursorImage() : CEGUI::DragContainer
  • getDragMoveOffset() : CEGUI::ListHeaderSegment
  • getEffectiveAlpha() : CEGUI::Window
  • getEWSizingCursorImage() : CEGUI::FrameWindow
  • getFactory() : CEGUI::WindowFactoryManager
  • getFadeInTime() : CEGUI::PopupMenu
  • getFadeOutTime() : CEGUI::PopupMenu
  • getFadeTime() : CEGUI::Tooltip
  • getFalagardMappingIterator() : CEGUI::WindowFactoryManager
  • getFirstSelectedItem() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getFont() : CEGUI::TextComponent, CEGUI::ListboxTextItem, CEGUI::Window, CEGUI::FontManager
  • getFontHeight() : CEGUI::Font
  • getFormattedLineCount() : CEGUI::Font
  • getFormattedTextExtent() : CEGUI::Font
  • getFrameColours() : CEGUI::Static
  • getGroupID() : CEGUI::RadioButton
  • getGUISheet() : CEGUI::System
  • getHeaderSegmentForColumn() : CEGUI::MultiColumnList
  • getHeight() : CEGUI::OpenGLTexture, CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Texture, CEGUI::Renderer, CEGUI::Rect, CEGUI::Image
  • getHelp() : CEGUI::Property
  • getHighestRowItemHeight() : CEGUI::MultiColumnList
  • getHorizontalAlignment() : CEGUI::Window
  • getHorizontalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • getHorizontalOverlapSize() : CEGUI::ScrollablePane
  • getHorizontalScrollPosition() : CEGUI::ScrollablePane
  • getHorizontalStepSize() : CEGUI::ScrollablePane
  • getHorzFormatting() : CEGUI::RenderableImage
  • getHorzPadding() : CEGUI::MenuBase
  • getHorzRange() : CEGUI::Thumb
  • getHorzScreenDPI() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • getHorzTileCount() : CEGUI::RenderableImage
  • getHoverColour() : CEGUI::MenuItem
  • getHoverImage() : CEGUI::PushButton
  • getHoverTextColour() : CEGUI::ButtonBase
  • getHoverTime() : CEGUI::Tooltip
  • getID() : CEGUI::ListboxItem, CEGUI::Window
  • getIdentifierString() : CEGUI::XMLParser, CEGUI::ScriptModule, CEGUI::Renderer
  • getImage() : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticImage, CEGUI::RenderableImage, CEGUI::MouseCursor, CEGUI::Imageset
  • getImageColours() : CEGUI::StaticImage
  • getImageCount() : CEGUI::Imageset
  • getImageForFrameLocation() : CEGUI::Static
  • getImageForLocation() : CEGUI::RenderableFrame
  • getImageHeight() : CEGUI::Imageset
  • getImageOffset() : CEGUI::Imageset
  • getImageOffsetX() : CEGUI::Imageset
  • getImageOffsetY() : CEGUI::Imageset
  • getImagePropertySource() : CEGUI::ImageryComponent
  • getImagerySection() : CEGUI::WidgetLookFeel
  • getImageset() : CEGUI::ImagesetManager
  • getImagesetName() : CEGUI::Image
  • getImageSize() : CEGUI::Imageset
  • getImageWidth() : CEGUI::Imageset
  • getInactiveSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getInheritedMetricsMode() : CEGUI::Window
  • getInitialiserValue() : CEGUI::PropertyInitialiser
  • getInitScriptFilename() : CEGUI::Config_xmlHandler
  • getInnerRect() : CEGUI::Window
  • getIntersection() : CEGUI::Rect
  • getItemAtGridReference() : CEGUI::MultiColumnList
  • getItemAtPoint() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getItemColumnIndex() : CEGUI::MultiColumnList
  • getItemCount() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • getItemFromIndex() : CEGUI::ItemListBase
  • getItemGridReference() : CEGUI::MultiColumnList
  • getItemIndex() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • getItemPixelSize() : CEGUI::TextItem, CEGUI::ItemEntry
  • getItemRenderArea() : CEGUI::ItemListBase
  • getItemRowIndex() : CEGUI::MultiColumnList
  • getItemSpacing() : CEGUI::MenuBase
  • getIterator() : CEGUI::WindowManager, CEGUI::WindowFactoryManager, CEGUI::SchemeManager, CEGUI::PropertySet, CEGUI::ImagesetManager, CEGUI::Imageset, CEGUI::FontManager, CEGUI::EventSet
  • getLayerPriority() : CEGUI::LayerSpecification
  • getLayoutFilename() : CEGUI::Config_xmlHandler
  • getLayoutRootWindow() : CEGUI::GUILayout_xmlHandler
  • getLineNumberFromIndex() : CEGUI::MultiLineEditbox
  • getLineSpacing() : CEGUI::Font
  • getListboxItemFromIndex() : CEGUI::Listbox, CEGUI::Combobox
  • getListRenderArea() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getLogFilename() : CEGUI::Config_xmlHandler
  • getLoggingLevel() : CEGUI::Logger, CEGUI::Config_xmlHandler
  • getLookNFeel() : CEGUI::Window
  • getMappedLookForType() : CEGUI::WindowFactoryManager
  • getMaskCodePoint() : CEGUI::Editbox
  • getMasterColours() : CEGUI::ImagerySection
  • getMaximumSize() : CEGUI::Window
  • getMaximumValue() : CEGUI::Spinner
  • getMaxTextLength() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getMaxTextureSize() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • getMaxValue() : CEGUI::Slider
  • getMessage() : CEGUI::Exception
  • getMetricsMode() : CEGUI::Window
  • getMinimumSize() : CEGUI::Window
  • getMinimumValue() : CEGUI::Spinner
  • getModalState() : CEGUI::Window
  • getModalTarget() : CEGUI::System
  • getModulateAlphaColourRect() : CEGUI::ListboxItem
  • getMouseCursor() : CEGUI::Window
  • getMouseMoveScaling() : CEGUI::System
  • getMultiClickTimeout() : CEGUI::System
  • getMultiClickToleranceAreaSize() : CEGUI::System
  • getName() : CEGUI::WidgetLookFeel, CEGUI::StateImagery, CEGUI::NamedArea, CEGUI::ImagerySection, CEGUI::XMLAttributes, CEGUI::Window, CEGUI::Scheme, CEGUI::Property, CEGUI::Imageset, CEGUI::Image, CEGUI::Font, CEGUI::Event
  • getNamedArea() : CEGUI::WidgetLookFeel
  • getNativeResolution() : CEGUI::Imageset, CEGUI::Font
  • getNESWSizingCursorImage() : CEGUI::FrameWindow
  • getNextSelected() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getNextTokenLength() : CEGUI::MultiLineEditbox
  • getNextWord() : CEGUI::TextUtils
  • getNextWordStartIdx() : CEGUI::TextUtils
  • getNominatedSelectionColumn() : CEGUI::MultiColumnList
  • getNominatedSelectionColumnID() : CEGUI::MultiColumnList
  • getNominatedSelectionRow() : CEGUI::MultiColumnList
  • getNormalImage() : CEGUI::PushButton
  • getNormalSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getNormalTextColour() : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox, CEGUI::Combobox, CEGUI::ButtonBase
  • getNSSizingCursorImage() : CEGUI::FrameWindow
  • getNWSESizingCursorImage() : CEGUI::FrameWindow
  • getOffsets() : CEGUI::Image
  • getOffsetX() : CEGUI::Image
  • getOffsetY() : CEGUI::Image
  • getOGLTexid() : CEGUI::OpenGLTexture
  • getOpenedColour() : CEGUI::MenuItem
  • getOperand() : CEGUI::BaseDim
  • getOverlapSize() : CEGUI::Scrollbar
  • getOverrideColours() : CEGUI::SectionSpecification
  • getOwnerWidgetLookFeel() : CEGUI::SectionSpecification
  • getOwnerWindow() : CEGUI::ListboxItem
  • getPageSize() : CEGUI::Scrollbar
  • getParent() : CEGUI::Window
  • getParentHeight() : CEGUI::Window
  • getParentSize() : CEGUI::Window
  • getParentWidth() : CEGUI::Window
  • getPixelDragThreshold() : CEGUI::DragContainer
  • getPixelOffsetToColumn() : CEGUI::ListHeader
  • getPixelOffsetToSegment() : CEGUI::ListHeader
  • getPixelRect() : CEGUI::ComponentArea, CEGUI::Window
  • getPixelSize() : CEGUI::ListboxTextItem, CEGUI::ListboxItem
  • getPointSize() : CEGUI::Font
  • getPopupMenu() : CEGUI::MenuItem
  • getPopupMenuItem() : CEGUI::MenuBase
  • getPosition() : CEGUI::Window, CEGUI::Rect, CEGUI::MouseCursor
  • getProgress() : CEGUI::ProgressBar
  • getProperty() : CEGUI::PropertySet
  • getPropertyDefault() : CEGUI::PropertySet
  • getPropertyHelp() : CEGUI::PropertySet
  • getPushedColour() : CEGUI::MenuItem
  • getPushedImage() : CEGUI::PushButton
  • getPushedTextColour() : CEGUI::ButtonBase
  • getQuadSplitMode() : CEGUI::RenderableImage
  • getRect() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Renderer
  • getRelativeHeight() : CEGUI::Window
  • getRelativePosition() : CEGUI::Window
  • getRelativeRect() : CEGUI::Window
  • getRelativeSize() : CEGUI::Window
  • getRelativeTabHeight() : CEGUI::TabControl
  • getRelativeTabTextPadding() : CEGUI::TabControl
  • getRelativeWidth() : CEGUI::Window
  • getRelativeXPosition() : CEGUI::Window
  • getRelativeYPosition() : CEGUI::Window
  • getRenderCache() : CEGUI::Window
  • getRenderer() : CEGUI::Texture, CEGUI::System
  • getResourceProvider() : CEGUI::System
  • getRowCount() : CEGUI::MultiColumnList
  • getRowID() : CEGUI::MultiColumnList
  • getRowWithID() : CEGUI::MultiColumnList
  • getScheme() : CEGUI::SchemeManager
  • getSchemeFilename() : CEGUI::Config_xmlHandler
  • getScriptingModule() : CEGUI::System
  • getScrollPosition() : CEGUI::Scrollbar
  • getSectionName() : CEGUI::SectionSpecification
  • getSegmentFromColumn() : CEGUI::ListHeader
  • getSegmentFromID() : CEGUI::ListHeader
  • getSegmentOffset() : CEGUI::ListHeader
  • getSelectedButtonInGroup() : CEGUI::RadioButton
  • getSelectedCount() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getSelectedItem() : CEGUI::Combobox
  • getSelectedTabIndex() : CEGUI::TabControl
  • getSelectedTextColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSelectionBrushImage() : CEGUI::ListboxItem
  • getSelectionColours() : CEGUI::ListboxItem
  • getSelectionEndIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSelectionLength() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSelectionMode() : CEGUI::MultiColumnList
  • getSelectionStartIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSingleClickEnabled() : CEGUI::Combobox
  • getSingleClickTimeout() : CEGUI::System
  • getSingleton() : CEGUI::WidgetLookManager, CEGUI::WindowManager, CEGUI::WindowFactoryManager, CEGUI::System, CEGUI::SchemeManager, CEGUI::MouseCursor, CEGUI::Logger, CEGUI::ImagesetManager, CEGUI::GlobalEventSet, CEGUI::FontManager
  • getSingletonPtr() : CEGUI::WidgetLookManager, CEGUI::WindowManager, CEGUI::WindowFactoryManager, CEGUI::System, CEGUI::SchemeManager, CEGUI::MouseCursor, CEGUI::ImagesetManager, CEGUI::GlobalEventSet, CEGUI::FontManager
  • getSize() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Renderer, CEGUI::Rect, CEGUI::Image
  • getSizingBorderAtPoint() : CEGUI::FrameWindow
  • getSizingBorderThickness() : CEGUI::FrameWindow
  • getSizingRect() : CEGUI::FrameWindow
  • getSortColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • getSortDirection() : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • getSortSegment() : CEGUI::ListHeader
  • getSourceTextureArea() : CEGUI::Image
  • getStackedTargetCount() : CEGUI::WindowFactoryManager::AliasTargetStack
  • getStateImagery() : CEGUI::WidgetLookFeel
  • getStep() : CEGUI::ProgressBar
  • getStepSize() : CEGUI::Spinner, CEGUI::Scrollbar
  • getSubRectangle() : CEGUI::ColourRect
  • getSystemKeys() : CEGUI::System
  • getTabContents() : CEGUI::TabControl
  • getTabContentsAtIndex() : CEGUI::TabControl
  • getTabCount() : CEGUI::TabControl
  • getTabHeight() : CEGUI::TabControl
  • getTabIndex() : CEGUI::TabButton
  • getTabTextPadding() : CEGUI::TabControl
  • getTargetPropertyName() : CEGUI::PropertyInitialiser
  • getTargetWindow() : CEGUI::Tooltip, CEGUI::TabButton
  • getTermScriptFilename() : CEGUI::Config_xmlHandler
  • getText() : CEGUI::TextComponent, CEGUI::ListboxItem, CEGUI::Window
  • getTextColour() : CEGUI::TextItem
  • getTextColours() : CEGUI::StaticText, CEGUI::ListboxTextItem
  • getTextExtent() : CEGUI::Font
  • getTextFormatting() : CEGUI::TextItem
  • getTextFromValue() : CEGUI::Spinner
  • getTextIndexFromPosition() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • getTextInputMode() : CEGUI::Spinner
  • getTextRenderArea() : CEGUI::StaticText, CEGUI::MultiLineEditbox
  • getTextSize() : CEGUI::Tooltip
  • getTexture() : CEGUI::Imageset
  • getTextXOffset() : CEGUI::TextItem, CEGUI::PushButton
  • getTitlebarFont() : CEGUI::FrameWindow
  • getTooltip() : CEGUI::Window
  • getTooltipText() : CEGUI::Window
  • getTooltipType() : CEGUI::Window
  • getTotalColumnHeadersWidth() : CEGUI::MultiColumnList
  • getTotalItemsHeight() : CEGUI::Listbox
  • getTotalRowsHeight() : CEGUI::MultiColumnList
  • getTotalSegmentsPixelExtent() : CEGUI::ListHeader
  • getType() : CEGUI::Window
  • getTypeName() : CEGUI::WindowFactory
  • getUnclippedInnerRect() : CEGUI::StaticText, CEGUI::Static, CEGUI::ScrolledContainer, CEGUI::Window
  • getUnclippedPixelRect() : CEGUI::Window
  • getUnifiedConstraintArea() : CEGUI::MouseCursor
  • getUserData() : CEGUI::ListboxItem, CEGUI::Window
  • getUserString() : CEGUI::Window
  • getValidationString() : CEGUI::Editbox, CEGUI::Combobox
  • getValue() : CEGUI::BaseDim, CEGUI::XMLAttributes
  • getValue_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • getValueAsBool() : CEGUI::XMLAttributes
  • getValueAsFloat() : CEGUI::XMLAttributes
  • getValueAsInteger() : CEGUI::XMLAttributes
  • getValueAsString() : CEGUI::XMLAttributes
  • getValueFromText() : CEGUI::Spinner
  • getValueFromThumb() : CEGUI::Slider, CEGUI::Scrollbar
  • getVertFormatting() : CEGUI::RenderableImage
  • getVerticalAlignment() : CEGUI::Window
  • getVerticalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • getVerticalOverlapSize() : CEGUI::ScrollablePane
  • getVerticalScrollPosition() : CEGUI::ScrollablePane
  • getVerticalStepSize() : CEGUI::ScrollablePane
  • getVertPadding() : CEGUI::MenuBase
  • getVertRange() : CEGUI::Thumb
  • getVertScreenDPI() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • getVertTileCount() : CEGUI::RenderableImage
  • getViewableArea() : CEGUI::ScrollablePane
  • getWidestColumnItemWidth() : CEGUI::MultiColumnList
  • getWidestItemWidth() : CEGUI::Listbox
  • getWidgetLook() : CEGUI::WidgetLookManager
  • getWidth() : CEGUI::OpenGLTexture, CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Texture, CEGUI::Renderer, CEGUI::Rect, CEGUI::Image
  • getWindow() : CEGUI::WindowManager
  • getWindowArea() : CEGUI::Window
  • getWindowContainingMouse() : CEGUI::System
  • getWindowHeight() : CEGUI::Window
  • getWindowMaxSize() : CEGUI::Window
  • getWindowMinSize() : CEGUI::Window
  • getWindowPosition() : CEGUI::Window
  • getWindowSize() : CEGUI::Window
  • getWindowWidth() : CEGUI::Window
  • getWindowXPosition() : CEGUI::Window
  • getWindowYPosition() : CEGUI::Window
  • getWordStartIdx() : CEGUI::TextUtils
  • getXMLParser() : CEGUI::System
  • getXPosition() : CEGUI::Window
  • getYPosition() : CEGUI::Window
  • getZLayer() : CEGUI::Renderer
  • grabTexture() : CEGUI::OpenGLTexture
  • grabTextures() : CEGUI::OpenGLRenderer
  • GUILayout_xmlHandler() : CEGUI::GUILayout_xmlHandler
  • GUISheet() : CEGUI::GUISheet
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • handle_scrollChange() : CEGUI::MultiLineEditbox, CEGUI::Listbox
  • handleAutoSizePaneChanged() : CEGUI::ScrollablePane
  • handleBackspace() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleCharLeft() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleCharRight() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleChildMoved() : CEGUI::ScrolledContainer
  • handleChildSized() : CEGUI::ScrolledContainer
  • handleContentAreaChange() : CEGUI::ScrollablePane
  • handled : CEGUI::EventArgs
  • handleDecreaseClicked() : CEGUI::Scrollbar
  • handleDelete() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleDocEnd() : CEGUI::MultiLineEditbox
  • handleDocHome() : CEGUI::MultiLineEditbox
  • handleEnd() : CEGUI::Editbox
  • handleHome() : CEGUI::Editbox
  • handleIncreaseClicked() : CEGUI::Scrollbar
  • handleLineDown() : CEGUI::MultiLineEditbox
  • handleLineEnd() : CEGUI::MultiLineEditbox
  • handleLineHome() : CEGUI::MultiLineEditbox
  • handleLineUp() : CEGUI::MultiLineEditbox
  • handleNewLine() : CEGUI::MultiLineEditbox
  • handleScrollChange() : CEGUI::ScrollablePane
  • handleThumbMoved() : CEGUI::Slider, CEGUI::Scrollbar
  • handleThumbTrackEnded() : CEGUI::Slider, CEGUI::Scrollbar
  • handleThumbTrackStarted() : CEGUI::Slider, CEGUI::Scrollbar
  • handleUpdatedItemData() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase
  • handleUpdatedListItemData() : CEGUI::Combobox
  • handleWordLeft() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleWordRight() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • hasCachedImagery() : CEGUI::RenderCache
  • hasInputFocus() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • Hexadecimal : CEGUI::Spinner
  • HexValidator : CEGUI::Spinner
  • hide() : CEGUI::Window, CEGUI::MouseCursor
  • hideDropList() : CEGUI::Combobox
  • HorzCentred : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • HorzFormatting : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • HorzJustified : CEGUI::StaticText
  • HorzStretched : CEGUI::StaticImage, CEGUI::RenderableImage
  • HorzTiled : CEGUI::StaticImage, CEGUI::RenderableImage
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • image : CEGUI::MouseCursorEventArgs
  • Image() : CEGUI::Image
  • ImageDim() : CEGUI::ImageDim
  • ImageIterator : CEGUI::Imageset
  • ImageryComponent() : CEGUI::ImageryComponent
  • ImagerySection() : CEGUI::ImagerySection
  • Imageset_xmlHandler() : CEGUI::Imageset_xmlHandler
  • ImagesetManager() : CEGUI::ImagesetManager
  • ImagesetSchemaName : CEGUI::Imageset
  • Inactive : CEGUI::Tooltip
  • inheritsAlpha() : CEGUI::Window
  • inheritsTooltipText() : CEGUI::Window
  • initColourRectForOverride() : CEGUI::SectionSpecification
  • initColoursRect() : CEGUI::FalagardComponentBase
  • initDragMoving() : CEGUI::ListHeaderSegment
  • initialise() : CEGUI::TabControl, CEGUI::StaticText, CEGUI::Spinner, CEGUI::Slider, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::GUISheet, CEGUI::FrameWindow, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::XMLParser, CEGUI::Window
  • initialiseDragging() : CEGUI::DragContainer
  • initialiseImpl() : CEGUI::XMLParser, CEGUI::XercesParser, CEGUI::TinyXMLParser
  • initialiseWidget() : CEGUI::WidgetLookFeel
  • initMasterColourRect() : CEGUI::ImagerySection
  • initSegmentHoverState() : CEGUI::ListHeaderSegment
  • initSizingHoverState() : CEGUI::ListHeaderSegment
  • injectChar() : CEGUI::System
  • injectKeyDown() : CEGUI::System
  • injectKeyUp() : CEGUI::System
  • injectMouseButtonDown() : CEGUI::System
  • injectMouseButtonUp() : CEGUI::System
  • injectMouseLeaves() : CEGUI::System
  • injectMouseMove() : CEGUI::System
  • injectMousePosition() : CEGUI::System
  • injectMouseWheelChange() : CEGUI::System
  • injectTimePulse() : CEGUI::System
  • insert() : CEGUI::String
  • InsertAfterChild() : TiXmlNode
  • InsertBeforeChild() : TiXmlNode
  • insertColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • InsertEndChild() : TiXmlNode
  • insertItem() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • insertRow() : CEGUI::MultiColumnList
  • Integer : CEGUI::Spinner
  • IntegerValidator : CEGUI::Spinner
  • IntValue() : TiXmlAttribute
  • IrrlichtRenderer() : CEGUI::IrrlichtRenderer
  • isActive() : CEGUI::Window
  • isAlwaysOnTop() : CEGUI::Window
  • isAncestor() : CEGUI::Window
  • isAntiAliased() : CEGUI::Font
  • isAreaFetchedFromProperty() : CEGUI::ComponentArea
  • isArmed() : CEGUI::ComboDropList
  • isAtEnd() : CEGUI::ConstBaseIterator< T >
  • isAtStart() : CEGUI::ConstBaseIterator< T >
  • isAutoArmEnabled() : CEGUI::ComboDropList
  • isAutoDeleted() : CEGUI::ListboxItem
  • isAutoResizeEnabled() : CEGUI::ItemListBase
  • isAutoScaled() : CEGUI::Imageset, CEGUI::Font
  • isBackgroundEnabled() : CEGUI::Static
  • isBeingDragged() : CEGUI::DragContainer
  • isBottomSizingLocation() : CEGUI::FrameWindow
  • isCapturedByAncestor() : CEGUI::Window
  • isCapturedByChild() : CEGUI::Window
  • isCapturedByThis() : CEGUI::Window
  • isChild() : CEGUI::Window
  • isClickable() : CEGUI::ListHeaderSegment
  • isClippedByParent() : CEGUI::Window
  • isClippedToDisplay() : CEGUI::StateImagery
  • isCloseButtonEnabled() : CEGUI::FrameWindow
  • isCodepointAvailable() : CEGUI::Font
  • isColumnDraggingEnabled() : CEGUI::ListHeader
  • isColumnSizingEnabled() : CEGUI::ListHeader
  • isContentPaneAutoSized() : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • isCustomImageryAutoSized() : CEGUI::PushButton
  • isDeadPoolEmpty() : CEGUI::WindowManager
  • isDefault() : CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::Property
  • isDestroyedByParent() : CEGUI::Window
  • isDisabled() : CEGUI::ListboxItem, CEGUI::Window
  • isDraggingEnabled() : CEGUI::Titlebar, CEGUI::DragContainer
  • isDraggingThresholdExceeded() : CEGUI::DragContainer
  • isDragMoveThresholdExceeded() : CEGUI::ListHeaderSegment
  • isDragMovingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • isDropDownListVisible() : CEGUI::Combobox
  • isEventPresent() : CEGUI::EventSet
  • isFactoryPresent() : CEGUI::WindowFactoryManager
  • isFalagardMappedType() : CEGUI::WindowFactoryManager
  • isFontPresent() : CEGUI::FontManager
  • isFrameEnabled() : CEGUI::Static, CEGUI::FrameWindow
  • isHit() : CEGUI::FrameWindow, CEGUI::Combobox, CEGUI::Window
  • isHorizontalScrollbarEnabled() : CEGUI::StaticText
  • isHorzFree() : CEGUI::Thumb
  • isHorzScrollbarAlwaysShown() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isHorzScrollbarNeeded() : CEGUI::ScrollablePane
  • isHotTracked() : CEGUI::Thumb
  • isHovering() : CEGUI::MenuItem, CEGUI::ButtonBase
  • isImageDefined() : CEGUI::Imageset
  • isImageFetchedFromProperty() : CEGUI::ImageryComponent
  • isImagesetPresent() : CEGUI::ImagesetManager
  • isItemInList() : CEGUI::ItemListBase
  • isItemSelected() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isLeftSizingLocation() : CEGUI::FrameWindow
  • isListboxItemInColumn() : CEGUI::MultiColumnList
  • isListboxItemInList() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isListboxItemInRow() : CEGUI::MultiColumnList
  • isMonochromatic() : CEGUI::ColourRect
  • isMouseAutoRepeatEnabled() : CEGUI::Window
  • isMultiplePopupsAllowed() : CEGUI::MenuBase
  • isMultiselectEnabled() : CEGUI::Listbox
  • isMuted() : CEGUI::EventSet
  • isNamedAreaDefined() : CEGUI::WidgetLookFeel
  • isPointInRect() : CEGUI::Rect
  • isPropertyDefault() : CEGUI::PropertySet
  • isPropertyPresent() : CEGUI::PropertySet
  • isPushed() : CEGUI::MenuItem, CEGUI::ButtonBase
  • isQueueingEnabled() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • isReadOnly() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • isRedrawRequested() : CEGUI::System
  • isRightSizingLocation() : CEGUI::FrameWindow
  • isRiseOnClickEnabled() : CEGUI::Window
  • isRolledup() : CEGUI::FrameWindow
  • isRollupEnabled() : CEGUI::FrameWindow
  • isSchemePresent() : CEGUI::SchemeManager
  • isSelected() : CEGUI::TabButton, CEGUI::RadioButton, CEGUI::ListboxItem, CEGUI::Checkbox
  • isSizingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • isSortEnabled() : CEGUI::Listbox, CEGUI::Combobox
  • isSortingEnabled() : CEGUI::ListHeader
  • isStandardImageryEnabled() : CEGUI::PushButton
  • isStateImageryPresent() : CEGUI::WidgetLookFeel
  • isStringValid() : CEGUI::Editbox
  • isTabContentsSelected() : CEGUI::TabControl
  • isTextMasked() : CEGUI::Editbox
  • isTextValid() : CEGUI::Editbox, CEGUI::Combobox
  • isTitleBarEnabled() : CEGUI::FrameWindow
  • isTopSizingLocation() : CEGUI::FrameWindow
  • isUserColumnDraggingEnabled() : CEGUI::MultiColumnList
  • isUserColumnSizingEnabled() : CEGUI::MultiColumnList
  • isUserSortControlEnabled() : CEGUI::MultiColumnList
  • isUserStringDefined() : CEGUI::Window
  • isUsingDefaultTooltip() : CEGUI::Window
  • isUsingOverrideColours() : CEGUI::SectionSpecification
  • isVertFree() : CEGUI::Thumb
  • isVerticalScrollbarEnabled() : CEGUI::StaticText
  • isVertScrollbarAlwaysShown() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isVertScrollbarNeeded() : CEGUI::ScrollablePane
  • isVisible() : CEGUI::Window, CEGUI::MouseCursor
  • IsWhiteSpaceCondensed() : TiXmlBase
  • isWidgetLookAvailable() : CEGUI::WidgetLookManager
  • isWindowPresent() : CEGUI::WindowManager
  • isWordWrapped() : CEGUI::MultiLineEditbox
  • isZOrderingEnabled() : CEGUI::Window
  • ItemEntry() : CEGUI::ItemEntry
  • ItemListBase() : CEGUI::ItemListBase
  • IterateChildren() : TiXmlNode
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Parent() : TiXmlNode
  • Parse() : TiXmlDocument
  • parseLookNFeelSpecification() : CEGUI::WidgetLookManager
  • parseXMLFile() : CEGUI::XMLParser, CEGUI::XercesParser, CEGUI::TinyXMLParser
  • performChildWindowLayout() : CEGUI::TabControl, CEGUI::Window
  • pointer : CEGUI::String
  • populateAttributesBlock() : CEGUI::XercesParser
  • populateRenderCache() : CEGUI::TextItem, CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Window
  • populateRenderCahce() : CEGUI::ItemEntry
  • PopupMenu() : CEGUI::PopupMenu
  • position : CEGUI::MouseEventArgs
  • positionSelf() : CEGUI::Tooltip
  • postD3DReset() : CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer
  • preD3DReset() : CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer
  • pred_descend() : CEGUI::MultiColumnList
  • Previous() : TiXmlAttribute
  • PreviousSibling() : TiXmlNode
  • Print() : TiXmlDocument, TiXmlUnknown, TiXmlDeclaration, TiXmlText, TiXmlComment, TiXmlElement, TiXmlAttribute, TiXmlBase
  • ProgressBar() : CEGUI::ProgressBar
  • Property() : CEGUI::Property
  • PropertyCallback : CEGUI::WindowManager
  • PropertyDim() : CEGUI::PropertyDim
  • PropertyInitialiser() : CEGUI::PropertyInitialiser
  • PropertySet() : CEGUI::PropertySet
  • push_back() : CEGUI::String
  • PushButton() : CEGUI::PushButton
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueryDoubleAttribute() : TiXmlElement
  • QueryDoubleValue() : TiXmlAttribute
  • QueryIntAttribute() : TiXmlElement
  • QueryIntValue() : TiXmlAttribute
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • rbegin() : CEGUI::String
  • Rect() : CEGUI::Rect
  • reference : CEGUI::String
  • registerAllFactories() : CEGUI::FactoryModule
  • registerFactory() : CEGUI::FactoryModule
  • relativeToAbsolute() : CEGUI::Window
  • relativeToAbsolute_impl() : CEGUI::Window
  • relativeToAbsoluteX() : CEGUI::Window
  • relativeToAbsoluteY() : CEGUI::Window
  • release() : CEGUI::SubscriberTemplate< Ret, Args >
  • releaseInput() : CEGUI::Window
  • remove() : CEGUI::XMLAttributes
  • removeAllEvents() : CEGUI::EventSet
  • removeAllFactories() : CEGUI::WindowFactoryManager
  • RemoveAttribute() : TiXmlElement
  • removeButtonForTabContent() : CEGUI::TabControl
  • RemoveChild() : TiXmlNode
  • removeChild_impl() : CEGUI::TabControl, CEGUI::ScrollablePane, CEGUI::Window
  • removeChildWindow() : CEGUI::Window
  • removeColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • removeColumnWithID() : CEGUI::MultiColumnList
  • removeEvent() : CEGUI::EventSet
  • removeFactory() : CEGUI::WindowFactoryManager
  • removeFalagardWindowMapping() : CEGUI::WindowFactoryManager
  • removeItem() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • removeProperty() : CEGUI::PropertySet
  • removeRow() : CEGUI::MultiColumnList
  • removeSegment() : CEGUI::ListHeader
  • removeTab() : CEGUI::TabControl
  • removeWindowFromDrawList() : CEGUI::Window
  • removeWindowTypeAlias() : CEGUI::WindowFactoryManager
  • rename() : CEGUI::Window
  • renameChildren() : CEGUI::WidgetLookFeel
  • renameWindow() : CEGUI::WindowManager
  • rend() : CEGUI::String
  • render() : CEGUI::StateImagery, CEGUI::SectionSpecification, CEGUI::LayerSpecification, CEGUI::ImagerySection, CEGUI::FalagardComponentBase, CEGUI::Window, CEGUI::RenderCache
  • render_impl() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::FalagardComponentBase
  • RenderableFrame() : CEGUI::RenderableFrame
  • RenderableImage() : CEGUI::RenderableImage
  • RenderCache() : CEGUI::RenderCache
  • renderGUI() : CEGUI::System
  • replace() : CEGUI::String
  • ReplaceChild() : TiXmlNode
  • requestRedraw() : CEGUI::Window
  • reserve() : CEGUI::String
  • resetList() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • resetList_impl() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase
  • resetTimer() : CEGUI::Tooltip
  • resetZValue() : CEGUI::Renderer
  • resize() : CEGUI::String
  • ResourceProvider() : CEGUI::ResourceProvider
  • resourcesLoaded() : CEGUI::Scheme
  • restoresOldCapture() : CEGUI::Window
  • restoreTexture() : CEGUI::OpenGLTexture
  • restoreTextures() : CEGUI::OpenGLRenderer
  • reverse_iterator : CEGUI::String
  • rfind() : CEGUI::String
  • RightAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • RootElement() : TiXmlDocument
  • row : CEGUI::MCLGridRef
  • Row() : TiXmlBase
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SaveFile() : TiXmlDocument
  • scancode : CEGUI::KeyEventArgs
  • Scheme_xmlHandler() : CEGUI::Scheme_xmlHandler
  • SchemeManager() : CEGUI::SchemeManager
  • screenToWindow() : CEGUI::Window
  • screenToWindowX() : CEGUI::Window
  • screenToWindowY() : CEGUI::Window
  • ScriptModule() : CEGUI::ScriptModule
  • ScrollablePane() : CEGUI::ScrollablePane
  • Scrollbar() : CEGUI::Scrollbar
  • ScrolledContainer() : CEGUI::ScrolledContainer
  • ScrollSpeed : CEGUI::ListHeader
  • SectionSpecification() : CEGUI::SectionSpecification
  • SegmentMoveThreshold : CEGUI::ListHeaderSegment
  • SelectionMode : CEGUI::MultiColumnList
  • selectRange() : CEGUI::MultiColumnList, CEGUI::Listbox
  • selectTab_impl() : CEGUI::TabControl
  • set() : CEGUI::PropertyDefinition, CEGUI::TooltipProperties::FadeTime, CEGUI::TooltipProperties::DisplayTime, CEGUI::TooltipProperties::HoverTime, CEGUI::TitlebarProperties::CaptionColour, CEGUI::TitlebarProperties::DraggingEnabled, CEGUI::ThumbProperties::HorzRange, CEGUI::ThumbProperties::VertRange, CEGUI::ThumbProperties::HorzFree, CEGUI::ThumbProperties::VertFree, CEGUI::ThumbProperties::HotTracked, CEGUI::TextItemProperties::TextFormatting, CEGUI::TextItemProperties::TextColour, CEGUI::TextItemProperties::TextXOffset, CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::AbsoluteTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::RelativeTabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::StaticTextProperties::HorzScrollbar, CEGUI::StaticTextProperties::VertScrollbar, CEGUI::StaticTextProperties::VertFormatting, CEGUI::StaticTextProperties::HorzFormatting, CEGUI::StaticTextProperties::TextColours, CEGUI::StaticProperties::BottomFrameImage, CEGUI::StaticProperties::TopFrameImage, CEGUI::StaticProperties::RightFrameImage, CEGUI::StaticProperties::LeftFrameImage, CEGUI::StaticProperties::BottomRightFrameImage, CEGUI::StaticProperties::BottomLeftFrameImage, CEGUI::StaticProperties::TopRightFrameImage, CEGUI::StaticProperties::TopLeftFrameImage, CEGUI::StaticProperties::BackgroundImage, CEGUI::StaticProperties::BackgroundColours, CEGUI::StaticProperties::FrameColours, CEGUI::StaticProperties::BackgroundEnabled, CEGUI::StaticProperties::FrameEnabled, CEGUI::StaticImageProperties::VertFormatting, CEGUI::StaticImageProperties::HorzFormatting, CEGUI::StaticImageProperties::ImageColours, CEGUI::StaticImageProperties::Image, CEGUI::SpinnerProperties::TextInputMode, CEGUI::SpinnerProperties::MaximumValue, CEGUI::SpinnerProperties::MinimumValue, CEGUI::SpinnerProperties::StepSize, CEGUI::SpinnerProperties::CurrentValue, CEGUI::SliderProperties::ClickStepSize, CEGUI::SliderProperties::MaximumValue, CEGUI::SliderProperties::CurrentValue, CEGUI::ScrolledContainerProperties::ChildExtentsArea, CEGUI::ScrolledContainerProperties::ContentArea, CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, CEGUI::ScrollbarProperties::ScrollPosition, CEGUI::ScrollbarProperties::OverlapSize, CEGUI::ScrollbarProperties::StepSize, CEGUI::ScrollbarProperties::PageSize, CEGUI::ScrollbarProperties::DocumentSize, CEGUI::ScrollablePaneProperties::VertScrollPosition, CEGUI::ScrollablePaneProperties::VertOverlapSize, CEGUI::ScrollablePaneProperties::VertStepSize, CEGUI::ScrollablePaneProperties::HorzScrollPosition, CEGUI::ScrollablePaneProperties::HorzOverlapSize, CEGUI::ScrollablePaneProperties::HorzStepSize, CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, CEGUI::ScrollablePaneProperties::ForceVertScrollbar, CEGUI::ScrollablePaneProperties::ContentArea, CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, CEGUI::RadioButtonProperties::GroupID, CEGUI::RadioButtonProperties::Selected, CEGUI::PushButtonProperties::TextXOffset, CEGUI::PushButtonProperties::UseStandardImagery, CEGUI::PushButtonProperties::DisabledImage, CEGUI::PushButtonProperties::HoverImage, CEGUI::PushButtonProperties::PushedImage, CEGUI::PushButtonProperties::NormalImage, CEGUI::ProgressBarProperties::StepSize, CEGUI::ProgressBarProperties::CurrentProgress, CEGUI::PopupMenuProperties::FadeOutTime, CEGUI::PopupMenuProperties::FadeInTime, CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, CEGUI::MultiLineEditboxProperties::SelectedTextColour, CEGUI::MultiLineEditboxProperties::NormalTextColour, CEGUI::MultiLineEditboxProperties::MaxTextLength, CEGUI::MultiLineEditboxProperties::SelectionLength, CEGUI::MultiLineEditboxProperties::SelectionStart, CEGUI::MultiLineEditboxProperties::CaratIndex, CEGUI::MultiLineEditboxProperties::WordWrap, CEGUI::MultiLineEditboxProperties::ReadOnly, CEGUI::MultiColumnListProperties::RowCount, CEGUI::MultiColumnListProperties::ColumnHeader, CEGUI::MultiColumnListProperties::SelectionMode, CEGUI::MultiColumnListProperties::ForceHorzScrollbar, CEGUI::MultiColumnListProperties::ForceVertScrollbar, CEGUI::MultiColumnListProperties::NominatedSelectionRow, CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, CEGUI::MultiColumnListProperties::SortColumnID, CEGUI::MultiColumnListProperties::SortDirection, CEGUI::MultiColumnListProperties::SortSettingEnabled, CEGUI::MultiColumnListProperties::ColumnsMovable, CEGUI::MultiColumnListProperties::ColumnsSizable, CEGUI::MenuItemProperties::DisabledTextColour, CEGUI::MenuItemProperties::NormalTextColour, CEGUI::MenuItemProperties::OpenedColour, CEGUI::MenuItemProperties::PushedColour, CEGUI::MenuItemProperties::HoverColour, CEGUI::MenuBaseProperties::AllowMultiplePopups, CEGUI::MenuBaseProperties::BackgroundColours, CEGUI::MenuBaseProperties::BorderWidth, CEGUI::MenuBaseProperties::VertPadding, CEGUI::MenuBaseProperties::HorzPadding, CEGUI::MenuBaseProperties::ItemSpacing, CEGUI::ListHeaderSegmentProperties::SortDirection, CEGUI::ListHeaderSegmentProperties::Dragable, CEGUI::ListHeaderSegmentProperties::Clickable, CEGUI::ListHeaderSegmentProperties::Sizable, CEGUI::ListHeaderProperties::SortColumnID, CEGUI::ListHeaderProperties::SortDirection, CEGUI::ListHeaderProperties::SortSettingEnabled, CEGUI::ListHeaderProperties::ColumnsMovable, CEGUI::ListHeaderProperties::ColumnsSizable, CEGUI::ListboxProperties::ItemTooltips, CEGUI::ListboxProperties::ForceHorzScrollbar, CEGUI::ListboxProperties::ForceVertScrollbar, CEGUI::ListboxProperties::MultiSelect, CEGUI::ListboxProperties::Sort, CEGUI::ItemListBaseProperties::AutoResizeEnabled, CEGUI::FrameWindowProperties::NESWSizingCursorImage, CEGUI::FrameWindowProperties::NWSESizingCursorImage, CEGUI::FrameWindowProperties::EWSizingCursorImage, CEGUI::FrameWindowProperties::NSSizingCursorImage, CEGUI::FrameWindowProperties::CaptionColour, CEGUI::FrameWindowProperties::TitlebarFont, CEGUI::FrameWindowProperties::SizingBorderThickness, CEGUI::FrameWindowProperties::DragMovingEnabled, CEGUI::FrameWindowProperties::RollUpState, CEGUI::FrameWindowProperties::RollUpEnabled, CEGUI::FrameWindowProperties::CloseButtonEnabled, CEGUI::FrameWindowProperties::TitlebarEnabled, CEGUI::FrameWindowProperties::FrameEnabled, CEGUI::FrameWindowProperties::SizingEnabled, CEGUI::EditboxProperties::InactiveSelectionColour, CEGUI::EditboxProperties::ActiveSelectionColour, CEGUI::EditboxProperties::SelectedTextColour, CEGUI::EditboxProperties::NormalTextColour, CEGUI::EditboxProperties::MaxTextLength, CEGUI::EditboxProperties::SelectionLength, CEGUI::EditboxProperties::SelectionStart, CEGUI::EditboxProperties::CaratIndex, CEGUI::EditboxProperties::ValidationString, CEGUI::EditboxProperties::MaskCodepoint, CEGUI::EditboxProperties::MaskText, CEGUI::EditboxProperties::ReadOnly, CEGUI::DragContainerProperties::DragCursorImage, CEGUI::DragContainerProperties::DragThreshold, CEGUI::DragContainerProperties::DragAlpha, CEGUI::DragContainerProperties::DraggingEnabled, CEGUI::ComboboxProperties::SingleClickMode, CEGUI::ComboboxProperties::ForceHorzScrollbar, CEGUI::ComboboxProperties::ForceVertScrollbar, CEGUI::ComboboxProperties::SortList, CEGUI::ComboboxProperties::InactiveEditSelectionColour, CEGUI::ComboboxProperties::ActiveEditSelectionColour, CEGUI::ComboboxProperties::SelectedEditTextColour, CEGUI::ComboboxProperties::NormalEditTextColour, CEGUI::ComboboxProperties::MaxEditTextLength, CEGUI::ComboboxProperties::EditSelectionLength, CEGUI::ComboboxProperties::EditSelectionStart, CEGUI::ComboboxProperties::CaratIndex, CEGUI::ComboboxProperties::ValidationString, CEGUI::ComboboxProperties::ReadOnly, CEGUI::CheckboxProperties::Selected, CEGUI::ButtonBaseProperties::DisabledTextColour, CEGUI::ButtonBaseProperties::PushedTextColour, CEGUI::ButtonBaseProperties::HoverTextColour, CEGUI::ButtonBaseProperties::NormalTextColour, CEGUI::WindowProperties::HorizontalAlignment, CEGUI::WindowProperties::VerticalAlignment, CEGUI::WindowProperties::RiseOnClick, CEGUI::WindowProperties::InheritsTooltipText, CEGUI::WindowProperties::Tooltip, CEGUI::WindowProperties::CustomTooltipType, CEGUI::WindowProperties::DistributeCapturedInputs, CEGUI::WindowProperties::AutoRepeatRate, CEGUI::WindowProperties::AutoRepeatDelay, CEGUI::WindowProperties::MouseButtonDownAutoRepeat, CEGUI::WindowProperties::WantsMultiClickEvents, CEGUI::WindowProperties::ZOrderChangeEnabled, CEGUI::WindowProperties::AbsoluteRect, CEGUI::WindowProperties::RelativeRect, CEGUI::WindowProperties::Rect, CEGUI::WindowProperties::AbsolutePosition, CEGUI::WindowProperties::RelativePosition, CEGUI::WindowProperties::Position, CEGUI::WindowProperties::AbsoluteYPosition, CEGUI::WindowProperties::RelativeYPosition, CEGUI::WindowProperties::YPosition, CEGUI::WindowProperties::AbsoluteXPosition, CEGUI::WindowProperties::RelativeXPosition, CEGUI::WindowProperties::XPosition, CEGUI::WindowProperties::AbsoluteSize, CEGUI::WindowProperties::RelativeSize, CEGUI::WindowProperties::Size, CEGUI::WindowProperties::AbsoluteHeight, CEGUI::WindowProperties::RelativeHeight, CEGUI::WindowProperties::Height, CEGUI::WindowProperties::AbsoluteWidth, CEGUI::WindowProperties::RelativeWidth, CEGUI::WindowProperties::Width, CEGUI::WindowProperties::DestroyedByParent, CEGUI::WindowProperties::RestoreOldCapture, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::AlwaysOnTop, CEGUI::WindowProperties::InheritsAlpha, CEGUI::WindowProperties::ClippedByParent, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Text, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::Alpha, CEGUI::WindowProperties::ID, CEGUI::WindowProperties::MetricsMode, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::AbsoluteMinSize, CEGUI::WindowProperties::RelativeMaxSize, CEGUI::WindowProperties::RelativeMinSize, CEGUI::Property
  • setAbsoluteTabHeight() : CEGUI::TabControl
  • setAbsoluteTabTextPadding() : CEGUI::TabControl
  • setAllowMultiplePopups() : CEGUI::MenuBase
  • setAlpha() : CEGUI::Window, CEGUI::ColourRect
  • setAlwaysOnTop() : CEGUI::Window
  • setAntiAliased() : CEGUI::Font
  • setArea() : CEGUI::NamedArea
  • setAreaPropertySource() : CEGUI::ComponentArea
  • setAreaRect() : CEGUI::Window
  • setArmed() : CEGUI::ComboDropList
  • SetAttribute() : TiXmlElement
  • setAutoArmEnabled() : CEGUI::ComboDropList
  • setAutoDeleted() : CEGUI::ListboxItem
  • setAutoRepeatDelay() : CEGUI::Window
  • setAutoRepeatRate() : CEGUI::Window
  • setAutoResizeEnabled() : CEGUI::ItemListBase
  • setAutoScalingEnabled() : CEGUI::Imageset, CEGUI::Font
  • setBackgroundColours() : CEGUI::Static, CEGUI::MenuBase
  • setBackgroundEnabled() : CEGUI::Static
  • setBackgroundHorizontalFormatting() : CEGUI::FrameComponent
  • setBackgroundImage() : CEGUI::Static
  • setBackgroundVerticalFormatting() : CEGUI::FrameComponent
  • setBaseDimension() : CEGUI::Dimension
  • setBorderWidth() : CEGUI::MenuBase
  • setBottomAlpha() : CEGUI::ColourRect
  • setCaptionColour() : CEGUI::Titlebar, CEGUI::FrameWindow
  • setCaratIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setClickable() : CEGUI::ListHeaderSegment
  • setClickStep() : CEGUI::Slider
  • setClippedByParent() : CEGUI::Window
  • setClippedToDisplay() : CEGUI::StateImagery
  • setCloseButtonEnabled() : CEGUI::FrameWindow
  • setColours() : CEGUI::FalagardComponentBase, CEGUI::ColourRect
  • setColoursPropertyIsColourRect() : CEGUI::FalagardComponentBase
  • setColoursPropertySource() : CEGUI::FalagardComponentBase
  • setColumnDraggingEnabled() : CEGUI::ListHeader
  • setColumnHeaderWidth() : CEGUI::MultiColumnList
  • setColumnPixelWidth() : CEGUI::ListHeader
  • setColumnSizingEnabled() : CEGUI::ListHeader
  • setComponentArea() : CEGUI::FalagardComponentBase
  • SetCondenseWhiteSpace() : TiXmlBase
  • setConstraintArea() : CEGUI::MouseCursor
  • setContentArea() : CEGUI::ScrolledContainer
  • setContentPaneArea() : CEGUI::ScrollablePane
  • setContentPaneAutoSized() : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • setCurrentValue() : CEGUI::Spinner, CEGUI::Slider
  • setCursorForPoint() : CEGUI::FrameWindow
  • setCustomImageryAutoSized() : CEGUI::PushButton
  • setD3DTextureSize() : CEGUI::DirectX9Texture, CEGUI::DirectX81Texture
  • setDefaultFont() : CEGUI::System
  • setDefaultMouseCursor() : CEGUI::System
  • setDefaultResourceGroup() : CEGUI::ResourceProvider
  • setDestroyedByParent() : CEGUI::Window
  • setDimensionOperator() : CEGUI::BaseDim
  • setDimensionType() : CEGUI::Dimension
  • setDisabled() : CEGUI::ListboxItem
  • setDisabledImage() : CEGUI::PushButton
  • setDisabledTextColour() : CEGUI::MenuItem, CEGUI::ButtonBase
  • setDisplaySize() : CEGUI::OpenGLRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer
  • setDisplayTime() : CEGUI::Tooltip
  • setDistributesCapturedInputs() : CEGUI::Window
  • setDocumentSize() : CEGUI::Scrollbar
  • SetDoubleAttribute() : TiXmlElement
  • SetDoubleValue() : TiXmlAttribute
  • setDragAlpha() : CEGUI::DragContainer
  • setDragCursorImage() : CEGUI::DragContainer
  • setDraggingEnabled() : CEGUI::Titlebar, CEGUI::DragContainer
  • setDragMovingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • setEnabled() : CEGUI::Window
  • setEWSizingCursorImage() : CEGUI::FrameWindow
  • setFadeInTime() : CEGUI::PopupMenu
  • setFadeOutTime() : CEGUI::PopupMenu
  • setFadeTime() : CEGUI::Tooltip
  • setFont() : CEGUI::TextComponent, CEGUI::ListboxTextItem, CEGUI::Window
  • setFormatting() : CEGUI::StaticText, CEGUI::StaticImage
  • setFrameColours() : CEGUI::Static
  • setFrameEnabled() : CEGUI::Static, CEGUI::FrameWindow
  • setFrameImages() : CEGUI::Static
  • setGroupID() : CEGUI::RadioButton
  • setGUISheet() : CEGUI::System
  • setHeight() : CEGUI::Window, CEGUI::Rect
  • setHorizontalAlignment() : CEGUI::Window
  • setHorizontalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • setHorizontalOverlapSize() : CEGUI::ScrollablePane
  • setHorizontalScrollbarEnabled() : CEGUI::StaticText
  • setHorizontalScrollPosition() : CEGUI::ScrollablePane
  • setHorizontalStepSize() : CEGUI::ScrollablePane
  • setHorzFormatting() : CEGUI::RenderableImage
  • setHorzFormattingPropertySource() : CEGUI::FalagardComponentBase
  • setHorzFree() : CEGUI::Thumb
  • setHorzPadding() : CEGUI::MenuBase
  • setHorzRange() : CEGUI::Thumb
  • setHotTracked() : CEGUI::Thumb
  • setHoverColour() : CEGUI::MenuItem
  • setHoverImage() : CEGUI::PushButton
  • setHoverTextColour() : CEGUI::ButtonBase
  • setHoverTime() : CEGUI::Tooltip
  • setID() : CEGUI::ListboxItem, CEGUI::Window
  • setImage() : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticImage, CEGUI::RenderableImage, CEGUI::MouseCursor
  • setImageColours() : CEGUI::StaticImage
  • setImageForFrameLocation() : CEGUI::Static
  • setImageForLocation() : CEGUI::RenderableFrame
  • setImagePropertySource() : CEGUI::ImageryComponent
  • setImages() : CEGUI::RenderableFrame
  • setInactiveSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setInheritsAlpha() : CEGUI::Window
  • setInheritsTooltipText() : CEGUI::Window
  • SetIntValue() : TiXmlAttribute
  • setItem() : CEGUI::MultiColumnList
  • setItemSelectState() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • setItemSelectState_impl() : CEGUI::MultiColumnList
  • setItemSpacing() : CEGUI::MenuBase
  • setLeftAlpha() : CEGUI::ColourRect
  • setLogFilename() : CEGUI::Logger
  • setLoggingLevel() : CEGUI::Logger
  • setLookNFeel() : CEGUI::Window
  • setMaskCodePoint() : CEGUI::Editbox
  • setMasterColours() : CEGUI::ImagerySection
  • setMasterColoursPropertyIsColourRect() : CEGUI::ImagerySection
  • setMasterColoursPropertySource() : CEGUI::ImagerySection
  • setMaximumSize() : CEGUI::Window
  • setMaximumValue() : CEGUI::Spinner
  • setMaxTextLength() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setMaxValue() : CEGUI::Slider
  • setMetricsMode() : CEGUI::Window
  • setMinimumSize() : CEGUI::Window
  • setMinimumValue() : CEGUI::Spinner
  • setModalState() : CEGUI::Window
  • setModalTarget() : CEGUI::System
  • setMouseAutoRepeatEnabled() : CEGUI::Window
  • setMouseCursor() : CEGUI::Window
  • setMouseMoveScaling() : CEGUI::System
  • setMultiClickTimeout() : CEGUI::System
  • setMultiClickToleranceAreaSize() : CEGUI::System
  • setMultiselectEnabled() : CEGUI::Listbox
  • setMutedState() : CEGUI::EventSet
  • SetName() : TiXmlAttribute
  • setNativeResolution() : CEGUI::Imageset, CEGUI::Font
  • setNESWSizingCursorImage() : CEGUI::FrameWindow
  • setNominatedSelectionColumn() : CEGUI::MultiColumnList
  • setNominatedSelectionColumnID() : CEGUI::MultiColumnList
  • setNominatedSelectionRow() : CEGUI::MultiColumnList
  • setNormalImage() : CEGUI::PushButton
  • setNormalSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setNormalTextColour() : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox, CEGUI::Combobox, CEGUI::ButtonBase
  • setNSSizingCursorImage() : CEGUI::FrameWindow
  • setNWSESizingCursorImage() : CEGUI::FrameWindow
  • setOGLTextureSize() : CEGUI::OpenGLTexture
  • setOpenedColour() : CEGUI::MenuItem
  • setOperand() : CEGUI::BaseDim
  • setOverlapSize() : CEGUI::Scrollbar
  • setOverrideColours() : CEGUI::SectionSpecification
  • setOverrideColoursPropertyIsColourRect() : CEGUI::SectionSpecification
  • setOverrideColoursPropertySource() : CEGUI::SectionSpecification
  • setOwnerWindow() : CEGUI::ListboxItem
  • setPageSize() : CEGUI::Scrollbar
  • setParent() : CEGUI::Window
  • setPixelDragThreshold() : CEGUI::DragContainer
  • setPopupMenu() : CEGUI::MenuItem
  • setPosition() : CEGUI::Window, CEGUI::Rect, CEGUI::MouseCursor
  • setProgress() : CEGUI::ProgressBar
  • setProperty() : CEGUI::PropertySet
  • setPushedColour() : CEGUI::MenuItem
  • setPushedImage() : CEGUI::PushButton
  • setPushedTextColour() : CEGUI::ButtonBase
  • setQuadSplitMode() : CEGUI::RenderableImage
  • setQueueingEnabled() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • setReadOnly() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setRect() : CEGUI::Window
  • setRelativeTabHeight() : CEGUI::TabControl
  • setRelativeTabTextPadding() : CEGUI::TabControl
  • setRestoreCapture() : CEGUI::Window
  • setRightAlpha() : CEGUI::ColourRect
  • setRightOfSelected() : CEGUI::TabButton
  • setRiseOnClickEnabled() : CEGUI::Window
  • setRollupEnabled() : CEGUI::FrameWindow
  • setRowID() : CEGUI::MultiColumnList
  • setScrollPosition() : CEGUI::Scrollbar
  • setSegmentOffset() : CEGUI::ListHeader
  • setSelected() : CEGUI::TabButton, CEGUI::RadioButton, CEGUI::ListboxItem, CEGUI::Checkbox
  • setSelectedTab() : CEGUI::TabControl
  • setSelectedTabAtIndex() : CEGUI::TabControl
  • setSelectedTextColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setSelectForItemsInColumn() : CEGUI::MultiColumnList
  • setSelectForItemsInRow() : CEGUI::MultiColumnList
  • setSelection() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setSelectionBrushImage() : CEGUI::ListboxItem
  • setSelectionColours() : CEGUI::ListboxItem
  • setSelectionMode() : CEGUI::MultiColumnList
  • setShowHorzScrollbar() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • setShowVertScrollbar() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • setSingleClickEnabled() : CEGUI::Combobox
  • setSingleClickTimeout() : CEGUI::System
  • setSize() : CEGUI::Window, CEGUI::Rect
  • setSizingBorderThickness() : CEGUI::FrameWindow
  • setSizingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • setSortColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • setSortColumnByID() : CEGUI::MultiColumnList
  • setSortColumnFromID() : CEGUI::ListHeader
  • setSortDirection() : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • setSortingEnabled() : CEGUI::ListHeader, CEGUI::Listbox, CEGUI::Combobox
  • setSortSegment() : CEGUI::ListHeader
  • setSourceDimension() : CEGUI::WidgetDim, CEGUI::ImageDim
  • setSourceImage() : CEGUI::ImageDim
  • setStandardImageryEnabled() : CEGUI::PushButton
  • setStepSize() : CEGUI::Spinner, CEGUI::Scrollbar, CEGUI::ProgressBar
  • setTabHeight() : CEGUI::TabControl
  • setTabIndex() : CEGUI::TabButton
  • SetTabSize() : TiXmlDocument
  • setTabTextPadding() : CEGUI::TabControl
  • setTargetWindow() : CEGUI::Tooltip, CEGUI::TabButton
  • setText() : CEGUI::TextComponent, CEGUI::ListboxItem, CEGUI::Window
  • setTextColour() : CEGUI::TextItem
  • setTextColours() : CEGUI::StaticText, CEGUI::ListboxTextItem
  • setTextFormatting() : CEGUI::TextItem
  • setTextInputMode() : CEGUI::Spinner
  • setTextMasked() : CEGUI::Editbox
  • setTexture() : CEGUI::Imageset
  • setTextXOffset() : CEGUI::TextItem, CEGUI::PushButton
  • setTitleBarEnabled() : CEGUI::FrameWindow
  • setTitlebarFont() : CEGUI::FrameWindow
  • setTooltip() : CEGUI::Window, CEGUI::System
  • setTooltipText() : CEGUI::Window
  • setTooltipType() : CEGUI::Window
  • setTopAlpha() : CEGUI::ColourRect
  • setUnifiedConstraintArea() : CEGUI::MouseCursor
  • setUserColumnDraggingEnabled() : CEGUI::MultiColumnList
  • setUserColumnSizingEnabled() : CEGUI::MultiColumnList
  • setUserData() : CEGUI::ListboxItem, CEGUI::Window
  • setUserSortControlEnabled() : CEGUI::MultiColumnList
  • setUserString() : CEGUI::Window
  • setUsingOverrideColours() : CEGUI::SectionSpecification
  • setValidationString() : CEGUI::Editbox, CEGUI::Combobox
  • SetValue() : TiXmlAttribute, TiXmlNode
  • setValue() : CEGUI::AbsoluteDim
  • setVertFormatting() : CEGUI::RenderableImage
  • setVertFormattingPropertySource() : CEGUI::FalagardComponentBase
  • setVertFree() : CEGUI::Thumb
  • setVerticalAlignment() : CEGUI::Window
  • setVerticalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • setVerticalOverlapSize() : CEGUI::ScrollablePane
  • setVerticalScrollbarEnabled() : CEGUI::StaticText
  • setVerticalScrollPosition() : CEGUI::ScrollablePane
  • setVerticalStepSize() : CEGUI::ScrollablePane
  • setVertPadding() : CEGUI::MenuBase
  • setVertRange() : CEGUI::Thumb
  • setVisible() : CEGUI::Window
  • setWantsMultiClickEvents() : CEGUI::Window
  • setWidgetName() : CEGUI::WidgetDim
  • setWidth() : CEGUI::Window, CEGUI::Rect
  • setWindowArea() : CEGUI::Window
  • setWindowArea_impl() : CEGUI::Window
  • setWindowHeight() : CEGUI::Window
  • setWindowMaxSize() : CEGUI::Window
  • setWindowMinSize() : CEGUI::Window
  • setWindowPosition() : CEGUI::Window
  • setWindowSize() : CEGUI::Window
  • setWindowWidth() : CEGUI::Window
  • setWindowXPosition() : CEGUI::Window
  • setWindowYPosition() : CEGUI::Window
  • setWordWrapping() : CEGUI::MultiLineEditbox
  • setXPosition() : CEGUI::Window
  • setYPosition() : CEGUI::Window
  • setZOrderingEnabled() : CEGUI::Window
  • show() : CEGUI::Window, CEGUI::MouseCursor
  • showDropList() : CEGUI::Combobox
  • signalRedraw() : CEGUI::System
  • size() : CEGUI::String
  • size_type : CEGUI::String
  • sizeToContent() : CEGUI::ItemListBase
  • sizeToContent_impl() : CEGUI::ItemListBase
  • SizingBottom : CEGUI::FrameWindow
  • SizingBottomLeft : CEGUI::FrameWindow
  • SizingBottomRight : CEGUI::FrameWindow
  • SizingLeft : CEGUI::FrameWindow
  • SizingLocation : CEGUI::FrameWindow
  • SizingNone : CEGUI::FrameWindow
  • SizingRight : CEGUI::FrameWindow
  • SizingTop : CEGUI::FrameWindow
  • SizingTopLeft : CEGUI::FrameWindow
  • SizingTopRight : CEGUI::FrameWindow
  • Slider() : CEGUI::Slider
  • SortDirection : CEGUI::ListHeaderSegment
  • Spinner() : CEGUI::Spinner
  • Standalone() : TiXmlDeclaration
  • StateImagery() : CEGUI::StateImagery
  • Static() : CEGUI::Static
  • StaticImage() : CEGUI::StaticImage
  • StaticText() : CEGUI::StaticText
  • step() : CEGUI::ProgressBar
  • String() : CEGUI::String
  • subscribe() : CEGUI::Event
  • subscribeEvent() : CEGUI::GlobalEventSet, CEGUI::EventSet
  • SubscriberTemplate() : CEGUI::SubscriberTemplate< Ret, Args >
  • subscribeScriptedEvent() : CEGUI::EventSet
  • substr() : CEGUI::String
  • swap() : CEGUI::String
  • sysKeys : CEGUI::KeyEventArgs, CEGUI::MouseEventArgs
  • System() : CEGUI::System
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TabButton() : CEGUI::TabButton
  • TabControl() : CEGUI::TabControl
  • TabPane() : CEGUI::TabPane
  • testClassName() : CEGUI::Window
  • testClassName_impl() : CEGUI::Tooltip, CEGUI::Titlebar, CEGUI::Thumb, CEGUI::TextItem, CEGUI::TabPane, CEGUI::TabControl, CEGUI::TabButton, CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::Spinner, CEGUI::Slider, CEGUI::ScrolledContainer, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::RadioButton, CEGUI::PushButton, CEGUI::ProgressBar, CEGUI::PopupMenu, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::MenuItem, CEGUI::MenuBase, CEGUI::Menubar, CEGUI::ListHeaderSegment, CEGUI::ListHeader, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::ItemEntry, CEGUI::GUISheet, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::Checkbox, CEGUI::ButtonBase, CEGUI::Window
  • Text() : TiXmlHandle
  • TextComponent() : CEGUI::TextComponent
  • TextInputMode : CEGUI::Spinner
  • TextItem() : CEGUI::TextItem
  • Texture() : CEGUI::Texture
  • Thumb() : CEGUI::Thumb
  • TipState : CEGUI::Tooltip
  • Titlebar() : CEGUI::Titlebar
  • TiXmlAttribute() : TiXmlAttribute
  • TiXmlComment() : TiXmlComment
  • TiXmlDeclaration() : TiXmlDeclaration
  • TiXmlDocument() : TiXmlDocument
  • TiXmlElement() : TiXmlElement
  • TiXmlHandle() : TiXmlHandle
  • TiXmlText() : TiXmlText
  • ToComment() : TiXmlNode
  • ToDeclaration() : TiXmlNode
  • ToDocument() : TiXmlNode
  • ToElement() : TiXmlNode
  • toEnd() : CEGUI::ConstBaseIterator< T >
  • togglePopupMenu() : CEGUI::MenuItem
  • toggleRollup() : CEGUI::FrameWindow
  • Tooltip() : CEGUI::Tooltip
  • TopAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • toStart() : CEGUI::ConstBaseIterator< T >
  • ToText() : TiXmlNode
  • ToUnknown() : TiXmlNode
  • transcodeXmlCharToString() : CEGUI::XercesParser
  • trimLeadingChars() : CEGUI::TextUtils
  • trimTrailingChars() : CEGUI::TextUtils
  • Type() : TiXmlNode
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • undefineAllImages() : CEGUI::Imageset
  • undefineImage() : CEGUI::Imageset
  • UnifiedDim() : CEGUI::UnifiedDim
  • unifiedToAbsolute() : CEGUI::Window
  • unifiedToAbsoluteX() : CEGUI::Window
  • unifiedToAbsoluteY() : CEGUI::Window
  • unifiedToRelative() : CEGUI::Window
  • unifiedToRelativeX() : CEGUI::Window
  • unifiedToRelativeY() : CEGUI::Window
  • Unknown() : TiXmlHandle
  • unload() : CEGUI::Imageset
  • unloadAllSchemes() : CEGUI::SchemeManager
  • unloadRawDataContainer() : CEGUI::ResourceProvider
  • unloadResources() : CEGUI::Scheme
  • unloadScheme() : CEGUI::SchemeManager
  • update() : CEGUI::Window
  • updateActiveMouseCursor() : CEGUI::DragContainer
  • updateContainerPosition() : CEGUI::ScrollablePane
  • updateImageScalingFactors() : CEGUI::Imageset
  • updateInternalState() : CEGUI::MenuItem, CEGUI::ButtonBase
  • updateRenderableFrameColours() : CEGUI::Static
  • updateRenderableImageColours() : CEGUI::StaticImage
  • updateSelf() : CEGUI::Tooltip, CEGUI::PopupMenu, CEGUI::Window
  • updateThumb() : CEGUI::Slider, CEGUI::Scrollbar
  • userData : TiXmlBase
  • utf8_stream_len() : CEGUI::String
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Value() : TiXmlAttribute, TiXmlNode
  • value_type : CEGUI::String
  • Version() : TiXmlDeclaration
  • VertCentred : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • VertFormatting : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • VertStretched : CEGUI::StaticImage, CEGUI::RenderableImage
  • VertTiled : CEGUI::StaticImage, CEGUI::RenderableImage
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • wantsMultiClickEvents() : CEGUI::Window
  • wheelChange : CEGUI::MouseEventArgs
  • WidgetDim() : CEGUI::WidgetDim
  • WidgetLookManager() : CEGUI::WidgetLookManager
  • WidgetTypeName : CEGUI::ScrolledContainer, CEGUI::GUISheet, CEGUI::DragContainer
  • Window() : CEGUI::Window
  • window : CEGUI::WindowEventArgs
  • WindowFactoryManager() : CEGUI::WindowFactoryManager
  • WindowManager() : CEGUI::WindowManager
  • windowToScreen() : CEGUI::Window
  • windowToScreenX() : CEGUI::Window
  • windowToScreenY() : CEGUI::Window
  • WordWrapCentred : CEGUI::StaticText
  • WordWrapJustified : CEGUI::StaticText
  • WordWrapLeftAligned : CEGUI::StaticText
  • WordWrapRightAligned : CEGUI::StaticText
  • writeColoursXML() : CEGUI::FalagardComponentBase
  • writeFalagardXMLHeadToStream() : CEGUI::WidgetLookManager
  • writeFalagardXMLTailToStream() : CEGUI::WidgetLookManager
  • writeFontToStream() : CEGUI::FontManager
  • writeHorzFormatXML() : CEGUI::FalagardComponentBase
  • writeImagesetToStream() : CEGUI::ImagesetManager
  • writeVertFormatXML() : CEGUI::FalagardComponentBase
  • writeWidgetLookSeriesToStream() : CEGUI::WidgetLookManager
  • writeWidgetLookToStream() : CEGUI::WidgetLookManager
  • writeWindowLayoutToStream() : CEGUI::WindowManager
  • writeXMLElementAttributes_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • writeXMLElementName_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • writeXMLToStream() : CEGUI::WidgetLookFeel, CEGUI::WidgetComponent, CEGUI::TextComponent, CEGUI::StateImagery, CEGUI::SectionSpecification, CEGUI::PropertyInitialiser, CEGUI::PropertyDefinition, CEGUI::NamedArea, CEGUI::LayerSpecification, CEGUI::ImagerySection, CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::ComponentArea, CEGUI::Dimension, CEGUI::BaseDim, CEGUI::Window, CEGUI::Property, CEGUI::Imageset, CEGUI::Image
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • XMLAttributes() : CEGUI::XMLAttributes
  • XMLParser() : CEGUI::XMLParser
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • HorzFormatting : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • NodeType : TiXmlNode
  • SelectionMode : CEGUI::MultiColumnList
  • SizingLocation : CEGUI::FrameWindow
  • SortDirection : CEGUI::ListHeaderSegment
  • TextInputMode : CEGUI::Spinner
  • TipState : CEGUI::Tooltip
  • VertFormatting : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • f
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
  • v
  • w

- a -

  • Active : CEGUI::Tooltip
  • Ascending : CEGUI::ListHeaderSegment

- b -

  • BottomAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage

- d -

  • Descending : CEGUI::ListHeaderSegment

- f -

  • FadeIn : CEGUI::Tooltip
  • FadeOut : CEGUI::Tooltip
  • FloatingPoint : CEGUI::Spinner

- h -

  • Hexadecimal : CEGUI::Spinner
  • HorzCentred : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • HorzJustified : CEGUI::StaticText
  • HorzStretched : CEGUI::StaticImage, CEGUI::RenderableImage
  • HorzTiled : CEGUI::StaticImage, CEGUI::RenderableImage

- i -

  • Inactive : CEGUI::Tooltip
  • Integer : CEGUI::Spinner

- l -

  • LeftAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage

- n -

  • None : CEGUI::ListHeaderSegment

- o -

  • Octal : CEGUI::Spinner

- r -

  • RightAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage

- s -

  • SizingBottom : CEGUI::FrameWindow
  • SizingBottomLeft : CEGUI::FrameWindow
  • SizingBottomRight : CEGUI::FrameWindow
  • SizingLeft : CEGUI::FrameWindow
  • SizingNone : CEGUI::FrameWindow
  • SizingRight : CEGUI::FrameWindow
  • SizingTop : CEGUI::FrameWindow
  • SizingTopLeft : CEGUI::FrameWindow
  • SizingTopRight : CEGUI::FrameWindow

- t -

  • TopAligned : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage

- v -

  • VertCentred : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::RenderableImage
  • VertStretched : CEGUI::StaticImage, CEGUI::RenderableImage
  • VertTiled : CEGUI::StaticImage, CEGUI::RenderableImage

- w -

  • WordWrapCentred : CEGUI::StaticText
  • WordWrapJustified : CEGUI::StaticText
  • WordWrapLeftAligned : CEGUI::StaticText
  • WordWrapRightAligned : CEGUI::StaticText
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- a -

  • AbsoluteDim() : CEGUI::AbsoluteDim
  • absoluteToRelative() : CEGUI::Window
  • absoluteToRelative_impl() : CEGUI::Window
  • absoluteToRelativeX() : CEGUI::Window
  • absoluteToRelativeY() : CEGUI::Window
  • activate() : CEGUI::Window
  • activateEditbox() : CEGUI::Combobox
  • add() : CEGUI::XMLAttributes
  • addButtonForTabContent() : CEGUI::TabControl
  • addCheckboxEvents() : CEGUI::Checkbox
  • addChild_impl() : CEGUI::TabControl, CEGUI::ScrollablePane, CEGUI::Window
  • addChildWindow() : CEGUI::Window
  • addColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • addComboboxEvents() : CEGUI::Combobox
  • addComboDropListEvents() : CEGUI::ComboDropList
  • addDragContainerEvents() : CEGUI::DragContainer
  • addEditboxEvents() : CEGUI::Editbox
  • addEvent() : CEGUI::EventSet
  • addFactory() : CEGUI::WindowFactoryManager
  • addFalagardWindowMapping() : CEGUI::WindowFactoryManager
  • addFrameComponent() : CEGUI::ImagerySection
  • addFrameWindowEvents() : CEGUI::FrameWindow
  • addHeaderSegmentEvents() : CEGUI::ListHeaderSegment
  • addImageryComponent() : CEGUI::ImagerySection
  • addImagerySection() : CEGUI::WidgetLookFeel
  • addItem() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • addItemEntryEvents() : CEGUI::ItemEntry
  • addItemListBaseEvents() : CEGUI::ItemListBase
  • addLayer() : CEGUI::StateImagery
  • addListboxEvents() : CEGUI::Listbox
  • addListHeaderEvents() : CEGUI::ListHeader
  • addMenuBaseEvents() : CEGUI::MenuBase
  • addMenuItemEvents() : CEGUI::MenuItem
  • addMouseCursorEvents() : CEGUI::MouseCursor
  • addMultiColumnListboxEvents() : CEGUI::MultiColumnList
  • addMultiLineEditboxEvents() : CEGUI::MultiLineEditbox
  • addNamedArea() : CEGUI::WidgetLookFeel
  • addProgressBarEvents() : CEGUI::ProgressBar
  • addProperty() : CEGUI::PropertySet
  • addPropertyDefinition() : CEGUI::WidgetLookFeel
  • addPropertyInitialiser() : CEGUI::WidgetLookFeel
  • addPushButtonEvents() : CEGUI::PushButton
  • addQuad() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • addRadioButtonEvents() : CEGUI::RadioButton
  • addRow() : CEGUI::MultiColumnList
  • addScrollablePaneEvents() : CEGUI::ScrollablePane
  • addScrollbarEvents() : CEGUI::Scrollbar
  • addScrolledContainerEvents() : CEGUI::ScrolledContainer
  • addSectionSpecification() : CEGUI::LayerSpecification
  • addSliderEvents() : CEGUI::Slider
  • addSpinnerEvents() : CEGUI::Spinner
  • addStandardEvents() : CEGUI::Window
  • addStandardProperties() : CEGUI::Window
  • addStateSpecification() : CEGUI::WidgetLookFeel
  • addTab() : CEGUI::TabControl
  • addTabButtonEvents() : CEGUI::TabButton
  • addTabControlEvents() : CEGUI::TabControl
  • addTextComponent() : CEGUI::ImagerySection
  • addThumbEvents() : CEGUI::Thumb
  • addTooltipEvents() : CEGUI::Tooltip
  • addWidgetComponent() : CEGUI::WidgetLookFeel
  • addWidgetLook() : CEGUI::WidgetLookManager
  • addWindowToDrawList() : CEGUI::Window
  • addWindowTypeAlias() : CEGUI::WindowFactoryManager
  • adjustProgress() : CEGUI::ProgressBar
  • advanceZValue() : CEGUI::Renderer
  • AliasTargetStack() : CEGUI::WindowFactoryManager::AliasTargetStack
  • append() : CEGUI::String
  • apply() : CEGUI::PropertyInitialiser
  • assign() : CEGUI::String
  • at() : CEGUI::String
  • Attribute() : TiXmlElement
  • autoSizeColumnHeader() : CEGUI::MultiColumnList
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- l -

  • LastAttribute() : TiXmlElement
  • LastChild() : TiXmlNode
  • LayerSpecification() : CEGUI::LayerSpecification
  • layoutChildWidgets() : CEGUI::WidgetLookFeel
  • layoutItemWidgets() : CEGUI::PopupMenu, CEGUI::Menubar, CEGUI::ItemListBase
  • layoutSegments() : CEGUI::ListHeader
  • length() : CEGUI::String
  • LinkEndChild() : TiXmlNode
  • Listbox() : CEGUI::Listbox
  • ListboxItem() : CEGUI::ListboxItem
  • ListboxTextItem() : CEGUI::ListboxTextItem
  • ListHeader() : CEGUI::ListHeader
  • ListHeaderSegment() : CEGUI::ListHeaderSegment
  • load() : CEGUI::Imageset
  • LoadFile() : TiXmlDocument
  • loadFromFile() : CEGUI::OpenGLTexture, CEGUI::DirectX9Texture, CEGUI::DirectX81Texture, CEGUI::Texture
  • loadFromMemory() : CEGUI::OpenGLTexture, CEGUI::DirectX9Texture, CEGUI::DirectX81Texture, CEGUI::Texture
  • loadRawDataContainer() : CEGUI::ResourceProvider
  • loadResources() : CEGUI::Scheme
  • loadScheme() : CEGUI::SchemeManager
  • loadWindowLayout() : CEGUI::WindowManager
  • logEvent() : CEGUI::Logger
  • Logger() : CEGUI::Logger
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- m -

  • makeButtonName() : CEGUI::TabControl
  • max_size() : CEGUI::String
  • Menubar() : CEGUI::Menubar
  • MenuBase() : CEGUI::MenuBase
  • MenuItem() : CEGUI::MenuItem
  • modulateAlpha() : CEGUI::ColourRect
  • MouseCursor() : CEGUI::MouseCursor
  • moveBottomEdge() : CEGUI::FrameWindow
  • moveColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • moveColumn_impl() : CEGUI::MultiColumnList
  • moveColumnWithID() : CEGUI::MultiColumnList
  • moveLeftEdge() : CEGUI::FrameWindow
  • moveRightEdge() : CEGUI::FrameWindow
  • moveSegment() : CEGUI::ListHeader
  • moveToBack() : CEGUI::Window
  • moveToFront() : CEGUI::Window
  • moveToFront_impl() : CEGUI::Window
  • moveTopEdge() : CEGUI::FrameWindow
  • MultiColumnList() : CEGUI::MultiColumnList
  • MultiLineEditbox() : CEGUI::MultiLineEditbox
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- n -

  • Name() : TiXmlAttribute
  • Next() : TiXmlAttribute
  • NextSibling() : TiXmlNode
  • NextSiblingElement() : TiXmlNode
  • NoChildren() : TiXmlNode
  • Node() : TiXmlHandle
  • notifyDragDropItemDropped() : CEGUI::Window
  • notifyDragDropItemEnters() : CEGUI::Window
  • notifyDragDropItemLeaves() : CEGUI::Window
  • notifyScreenResolution() : CEGUI::ImagesetManager, CEGUI::Imageset, CEGUI::FontManager, CEGUI::Font
  • notifyWindowDestroyed() : CEGUI::System
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- o -

  • offset() : CEGUI::Rect
  • offsetPixelPosition() : CEGUI::FrameWindow
  • offsetPosition() : CEGUI::MouseCursor
  • onActivated() : CEGUI::Spinner, CEGUI::FrameWindow, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::Window
  • onAlphaChanged() : CEGUI::StaticImage, CEGUI::Static, CEGUI::PopupMenu, CEGUI::DragContainer, CEGUI::Window
  • onAlwaysOnTopChanged() : CEGUI::Window
  • onAutoSizeSettingChanged() : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • onCaptureGained() : CEGUI::Window
  • onCaptureLost() : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::ButtonBase, CEGUI::Window
  • onCaratMoved() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onCharacter() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Window
  • onChildAdded() : CEGUI::ScrolledContainer, CEGUI::Window
  • onChildRemoved() : CEGUI::ScrolledContainer, CEGUI::Window
  • onClickableSettingChanged() : CEGUI::ListHeaderSegment
  • onClicked() : CEGUI::TabButton, CEGUI::PushButton, CEGUI::MenuItem
  • onClippingChanged() : CEGUI::DragContainer, CEGUI::Window
  • onCloseClicked() : CEGUI::FrameWindow
  • onContentChanged() : CEGUI::ScrolledContainer
  • onContentPaneChanged() : CEGUI::ScrollablePane
  • onContentPaneScrolled() : CEGUI::ScrollablePane
  • onDeactivated() : CEGUI::FrameWindow, CEGUI::Window
  • onDestructionStarted() : CEGUI::Window
  • onDisabled() : CEGUI::Window
  • onDisplayTimeChanged() : CEGUI::Tooltip
  • onDragAlphaChanged() : CEGUI::DragContainer
  • onDragDropItemDropped() : CEGUI::Window
  • onDragDropItemEnters() : CEGUI::Window
  • onDragDropItemLeaves() : CEGUI::Window
  • onDragDropTargetChanged() : CEGUI::DragContainer
  • onDragEnabledChanged() : CEGUI::DragContainer
  • onDragEnded() : CEGUI::DragContainer
  • onDraggingModeChanged() : CEGUI::Titlebar
  • onDragMouseCursorChanged() : CEGUI::DragContainer
  • onDragMoveSettingChanged() : CEGUI::ListHeader
  • onDragPositionChanged() : CEGUI::DragContainer
  • onDragSizeSettingChanged() : CEGUI::ListHeader
  • onDragStarted() : CEGUI::DragContainer
  • onDragThresholdChanged() : CEGUI::DragContainer
  • onDropListDisplayed() : CEGUI::Combobox
  • onDroplistRemoved() : CEGUI::Combobox
  • onEditboxFullEvent() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onEnabled() : CEGUI::Window
  • OnEvent() : CEGUI::IrrlichtRenderer
  • onFadeTimeChanged() : CEGUI::Tooltip
  • onFontChanged() : CEGUI::Titlebar, CEGUI::TabControl, CEGUI::StaticText, CEGUI::Spinner, CEGUI::Combobox, CEGUI::Window
  • onHidden() : CEGUI::Window
  • onHorizontalAlignmentChanged() : CEGUI::Window
  • onHorzScrollbarModeChanged() : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • onHoverTimeChanged() : CEGUI::Tooltip
  • onIDChanged() : CEGUI::Window
  • onImageChanged() : CEGUI::MouseCursor
  • onInheritsAlphaChanged() : CEGUI::Window
  • onInvalidEntryAttempted() : CEGUI::Editbox, CEGUI::Combobox
  • onKeyDown() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Window
  • onKeyUp() : CEGUI::Window
  • onListColumnMoved() : CEGUI::MultiColumnList
  • onListColumnSized() : CEGUI::MultiColumnList
  • onListContentsChanged() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • onListSelectionAccepted() : CEGUI::ComboDropList, CEGUI::Combobox
  • onListSelectionChanged() : CEGUI::Combobox
  • onMaskCodePointChanged() : CEGUI::Editbox
  • onMaskedRenderingModeChanged() : CEGUI::Editbox
  • onMaximumTextLengthChanged() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onMaximumValueChanged() : CEGUI::Spinner
  • onMetricsChanged() : CEGUI::Window
  • onMinimumValueChanged() : CEGUI::Spinner
  • onMouseButtonDown() : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::Listbox, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::ButtonBase, CEGUI::Window
  • onMouseButtonUp() : CEGUI::Titlebar, CEGUI::TabButton, CEGUI::RadioButton, CEGUI::PushButton, CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::Checkbox, CEGUI::ButtonBase, CEGUI::Window
  • onMouseClicked() : CEGUI::Window
  • onMouseDoubleClicked() : CEGUI::Titlebar, CEGUI::MultiLineEditbox, CEGUI::ListHeaderSegment, CEGUI::Editbox, CEGUI::Window
  • onMouseEnters() : CEGUI::Tooltip, CEGUI::Window
  • onMouseLeaves() : CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::ButtonBase, CEGUI::Window
  • onMouseMove() : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::ListHeaderSegment, CEGUI::Listbox, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::ButtonBase, CEGUI::Window
  • onMouseTripleClicked() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Window
  • onMouseWheel() : CEGUI::StaticText, CEGUI::Slider, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Window
  • onMovableSettingChanged() : CEGUI::ListHeaderSegment
  • onMoved() : CEGUI::Window
  • onMultiselectModeChanged() : CEGUI::Listbox
  • onNominatedSelectColumnChanged() : CEGUI::MultiColumnList
  • onNominatedSelectRowChanged() : CEGUI::MultiColumnList
  • onParentDestroyChanged() : CEGUI::Window
  • onParentSized() : CEGUI::ScrolledContainer, CEGUI::Window
  • onPopupClosed() : CEGUI::MenuBase
  • onPopupOpened() : CEGUI::MenuBase
  • onProgressChanged() : CEGUI::ProgressBar
  • onProgressDone() : CEGUI::ProgressBar
  • onReadOnlyChanged() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onRenderingEnded() : CEGUI::Window
  • onRenderingStarted() : CEGUI::Window
  • onRollupToggled() : CEGUI::FrameWindow
  • onScrollConfigChanged() : CEGUI::Scrollbar
  • onScrollPositionChanged() : CEGUI::Scrollbar
  • onSegmentAdded() : CEGUI::ListHeader
  • onSegmentClicked() : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onSegmentDragPositionChanged() : CEGUI::ListHeaderSegment
  • onSegmentDragStart() : CEGUI::ListHeaderSegment
  • onSegmentDragStop() : CEGUI::ListHeaderSegment
  • onSegmentOffsetChanged() : CEGUI::ListHeader
  • onSegmentRemoved() : CEGUI::ListHeader
  • onSegmentSequenceChanged() : CEGUI::ListHeader
  • onSegmentSized() : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onSelectionChanged() : CEGUI::TabControl, CEGUI::MultiColumnList, CEGUI::Listbox
  • onSelectionModeChanged() : CEGUI::MultiColumnList
  • onSelectStateChange() : CEGUI::Checkbox
  • onSelectStateChanged() : CEGUI::RadioButton
  • onShown() : CEGUI::Window
  • onSized() : CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::ScrollablePane, CEGUI::PushButton, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Window
  • onSizingSettingChanged() : CEGUI::ListHeaderSegment
  • onSortColumnChanged() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • onSortDirectionChanged() : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onSortModeChanged() : CEGUI::Listbox, CEGUI::Combobox
  • onSortSettingChanged() : CEGUI::ListHeader
  • onSplitterDoubleClicked() : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • onStaticFrameChanged() : CEGUI::StaticImage, CEGUI::Static
  • onStepChanged() : CEGUI::Spinner
  • onTextAcceptedEvent() : CEGUI::Editbox, CEGUI::Combobox
  • onTextChanged() : CEGUI::Tooltip, CEGUI::TextItem, CEGUI::StaticText, CEGUI::Spinner, CEGUI::MultiLineEditbox, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::Combobox, CEGUI::Window
  • onTextInputModeChanged() : CEGUI::Spinner
  • onTextInvalidatedEvent() : CEGUI::Editbox, CEGUI::Combobox
  • onTextSelectionChanged() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • onThumbPositionChanged() : CEGUI::Thumb
  • onThumbTrackEnded() : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • onThumbTrackStarted() : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • onTooltipActive() : CEGUI::Tooltip
  • onTooltipInactive() : CEGUI::Tooltip
  • onValidationStringChanged() : CEGUI::Editbox, CEGUI::Combobox
  • onValueChanged() : CEGUI::Spinner, CEGUI::Slider
  • onVerticalAlignmentChanged() : CEGUI::Window
  • onVertScrollbarModeChanged() : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • onWordWrapModeChanged() : CEGUI::MultiLineEditbox
  • onZChange_impl() : CEGUI::Window
  • onZChanged() : CEGUI::Window
  • OpenGLRenderer() : CEGUI::OpenGLRenderer
  • openPopupMenu() : CEGUI::PopupMenu, CEGUI::MenuItem
  • operator *() : CEGUI::ConstBaseIterator< T >
  • operator *=() : CEGUI::ColourRect
  • operator!=() : CEGUI::ConstBaseIterator< T >
  • operator++() : CEGUI::ConstBaseIterator< T >
  • operator+=() : CEGUI::String
  • operator--() : CEGUI::ConstBaseIterator< T >
  • operator<() : CEGUI::ListboxItem, CEGUI::SubscriberTemplate< Ret, Args >
  • operator=() : CEGUI::Dimension, CEGUI::String, CEGUI::ConstBaseIterator< T >
  • operator==() : CEGUI::ConstBaseIterator< T >
  • operator>() : CEGUI::ListboxItem
  • operator[]() : CEGUI::String
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- ~ -

  • ~AliasTargetStack() : CEGUI::WindowFactoryManager::AliasTargetStack
  • ~ButtonBase() : CEGUI::ButtonBase
  • ~Checkbox() : CEGUI::Checkbox
  • ~Combobox() : CEGUI::Combobox
  • ~ComboDropList() : CEGUI::ComboDropList
  • ~Config_xmlHandler() : CEGUI::Config_xmlHandler
  • ~ConstBaseIterator() : CEGUI::ConstBaseIterator< T >
  • ~Dimension() : CEGUI::Dimension
  • ~DirectX81Renderer() : CEGUI::DirectX81Renderer
  • ~DirectX9Renderer() : CEGUI::DirectX9Renderer
  • ~DragContainer() : CEGUI::DragContainer
  • ~Editbox() : CEGUI::Editbox
  • ~Event() : CEGUI::Event
  • ~EventSet() : CEGUI::EventSet
  • ~FactoryModule() : CEGUI::FactoryModule
  • ~Falagard_xmlHandler() : CEGUI::Falagard_xmlHandler
  • ~FalagardComponentBase() : CEGUI::FalagardComponentBase
  • ~Font() : CEGUI::Font
  • ~Font_xmlHandler() : CEGUI::Font_xmlHandler
  • ~FontManager() : CEGUI::FontManager
  • ~FrameWindow() : CEGUI::FrameWindow
  • ~GUILayout_xmlHandler() : CEGUI::GUILayout_xmlHandler
  • ~GUISheet() : CEGUI::GUISheet
  • ~Image() : CEGUI::Image
  • ~Imageset() : CEGUI::Imageset
  • ~Imageset_xmlHandler() : CEGUI::Imageset_xmlHandler
  • ~ImagesetManager() : CEGUI::ImagesetManager
  • ~IrrlichtRenderer() : CEGUI::IrrlichtRenderer
  • ~ItemEntry() : CEGUI::ItemEntry
  • ~ItemListBase() : CEGUI::ItemListBase
  • ~Listbox() : CEGUI::Listbox
  • ~ListboxItem() : CEGUI::ListboxItem
  • ~ListboxTextItem() : CEGUI::ListboxTextItem
  • ~ListHeader() : CEGUI::ListHeader
  • ~ListHeaderSegment() : CEGUI::ListHeaderSegment
  • ~Logger() : CEGUI::Logger
  • ~Menubar() : CEGUI::Menubar
  • ~MenuBase() : CEGUI::MenuBase
  • ~MenuItem() : CEGUI::MenuItem
  • ~MouseCursor() : CEGUI::MouseCursor
  • ~MultiColumnList() : CEGUI::MultiColumnList
  • ~MultiLineEditbox() : CEGUI::MultiLineEditbox
  • ~OpenGLRenderer() : CEGUI::OpenGLRenderer
  • ~PopupMenu() : CEGUI::PopupMenu
  • ~ProgressBar() : CEGUI::ProgressBar
  • ~Property() : CEGUI::Property
  • ~PropertySet() : CEGUI::PropertySet
  • ~PushButton() : CEGUI::PushButton
  • ~RenderableFrame() : CEGUI::RenderableFrame
  • ~RenderableImage() : CEGUI::RenderableImage
  • ~RenderCache() : CEGUI::RenderCache
  • ~ResourceProvider() : CEGUI::ResourceProvider
  • ~Scheme() : CEGUI::Scheme
  • ~Scheme_xmlHandler() : CEGUI::Scheme_xmlHandler
  • ~SchemeManager() : CEGUI::SchemeManager
  • ~ScriptModule() : CEGUI::ScriptModule
  • ~ScrollablePane() : CEGUI::ScrollablePane
  • ~Scrollbar() : CEGUI::Scrollbar
  • ~ScrolledContainer() : CEGUI::ScrolledContainer
  • ~Slider() : CEGUI::Slider
  • ~Spinner() : CEGUI::Spinner
  • ~Static() : CEGUI::Static
  • ~StaticImage() : CEGUI::StaticImage
  • ~StaticText() : CEGUI::StaticText
  • ~String() : CEGUI::String
  • ~System() : CEGUI::System
  • ~TabButton() : CEGUI::TabButton
  • ~TabControl() : CEGUI::TabControl
  • ~TabPane() : CEGUI::TabPane
  • ~TextItem() : CEGUI::TextItem
  • ~Texture() : CEGUI::Texture
  • ~Thumb() : CEGUI::Thumb
  • ~Titlebar() : CEGUI::Titlebar
  • ~Tooltip() : CEGUI::Tooltip
  • ~WidgetLookManager() : CEGUI::WidgetLookManager
  • ~Window() : CEGUI::Window
  • ~WindowFactoryManager() : CEGUI::WindowFactoryManager
  • ~WindowManager() : CEGUI::WindowManager
  • ~XMLAttributes() : CEGUI::XMLAttributes
  • ~XMLParser() : CEGUI::XMLParser
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- b -

  • begin() : CEGUI::String
  • button_PressHandler() : CEGUI::Combobox
  • ButtonBase() : CEGUI::ButtonBase
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- c -

  • c_str() : CEGUI::String
  • cacheCaratImagery() : CEGUI::MultiLineEditbox
  • cacheEditboxBaseImagery() : CEGUI::MultiLineEditbox
  • cacheImage() : CEGUI::RenderCache
  • cacheListboxBaseImagery() : CEGUI::MultiColumnList, CEGUI::Listbox
  • cacheText() : CEGUI::RenderCache
  • cacheTextLines() : CEGUI::MultiLineEditbox
  • calculateModulatedAlphaColour() : CEGUI::Static, CEGUI::ListboxItem
  • calculateTabButtonSizePosition() : CEGUI::TabControl
  • capacity() : CEGUI::String
  • captureInput() : CEGUI::Window
  • changePopupMenuItem() : CEGUI::MenuBase
  • Checkbox() : CEGUI::Checkbox
  • Child() : TiXmlHandle
  • ChildElement() : TiXmlHandle
  • cleanDeadPool() : CEGUI::WindowManager
  • cleanup() : CEGUI::XMLParser
  • cleanupChildren() : CEGUI::Window
  • cleanupImpl() : CEGUI::XMLParser, CEGUI::XercesParser, CEGUI::TinyXMLParser
  • cleanupLoadedWindows() : CEGUI::GUILayout_xmlHandler
  • Clear() : TiXmlNode
  • clear() : CEGUI::String
  • clearAllSelections() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • clearAllSelections_impl() : CEGUI::MultiColumnList, CEGUI::Listbox
  • clearCachedImagery() : CEGUI::RenderCache
  • ClearError() : TiXmlDocument
  • clearFrameComponents() : CEGUI::ImagerySection
  • clearImageryComponents() : CEGUI::ImagerySection
  • clearImagerySections() : CEGUI::WidgetLookFeel
  • clearLayers() : CEGUI::StateImagery
  • clearNamedAreas() : CEGUI::WidgetLookFeel
  • clearProperties() : CEGUI::PropertySet
  • clearPropertyDefinitions() : CEGUI::WidgetLookFeel
  • clearPropertyInitialisers() : CEGUI::WidgetLookFeel
  • clearRenderList() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • clearSectionSpecifications() : CEGUI::LayerSpecification
  • clearSelection() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • clearStateSpecifications() : CEGUI::WidgetLookFeel
  • clearTextComponents() : CEGUI::ImagerySection
  • clearWidgetComponents() : CEGUI::WidgetLookFeel
  • clone() : CEGUI::BaseDim
  • Clone() : TiXmlDocument, TiXmlUnknown, TiXmlDeclaration, TiXmlText, TiXmlComment, TiXmlElement, TiXmlNode
  • clone_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • closeAllMenuItemPopups() : CEGUI::MenuItem
  • closeClickHandler() : CEGUI::FrameWindow
  • closePopupMenu() : CEGUI::PopupMenu, CEGUI::MenuItem
  • ColourRect() : CEGUI::ColourRect
  • Column() : TiXmlBase
  • Combobox() : CEGUI::Combobox
  • ComboDropList() : CEGUI::ComboDropList
  • compare() : CEGUI::String
  • Config_xmlHandler() : CEGUI::Config_xmlHandler
  • configureScrollbars() : CEGUI::StaticText, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • ConstBaseIterator() : CEGUI::ConstBaseIterator< T >
  • constrainSize() : CEGUI::Rect
  • constrainSizeMax() : CEGUI::Rect
  • constrainSizeMin() : CEGUI::Rect
  • copy() : CEGUI::String
  • create() : CEGUI::WidgetComponent
  • createBindings() : CEGUI::ScriptModule
  • createCloseButton() : CEGUI::FrameWindow
  • createDecreaseButton() : CEGUI::Spinner, CEGUI::Scrollbar
  • createDropList() : CEGUI::Combobox
  • createEditbox() : CEGUI::Spinner, CEGUI::Combobox
  • createFont() : CEGUI::FontManager
  • createHorizontalScrollbar() : CEGUI::ScrollablePane
  • createHorzScrollbar() : CEGUI::StaticText, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • createImageset() : CEGUI::ImagesetManager
  • createImagesetFromImageFile() : CEGUI::ImagesetManager
  • createIncreaseButton() : CEGUI::Spinner, CEGUI::Scrollbar
  • createInitialisedSegment() : CEGUI::ListHeader
  • createListHeader() : CEGUI::MultiColumnList
  • createNewSegment() : CEGUI::ListHeader
  • createPushButton() : CEGUI::Combobox
  • createResourceProvider() : CEGUI::IrrlichtRenderer
  • createTabButton() : CEGUI::TabControl
  • createTabButtonPane() : CEGUI::TabControl
  • createTabContentPane() : CEGUI::TabControl
  • createTexture() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • createThumb() : CEGUI::Slider, CEGUI::Scrollbar
  • createTitlebar() : CEGUI::FrameWindow
  • createVerticalScrollbar() : CEGUI::ScrollablePane
  • createVertScrollbar() : CEGUI::StaticText, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • createWindow() : CEGUI::ScrolledContainerFactory, CEGUI::GUISheetFactory, CEGUI::DragContainerFactory, CEGUI::WindowManager, CEGUI::WindowFactory
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- d -

  • data() : CEGUI::String
  • deactivate() : CEGUI::Window
  • defineFontGlyphs() : CEGUI::Font
  • defineImage() : CEGUI::Imageset
  • deselectOtherButtonsInGroup() : CEGUI::RadioButton
  • destroy() : CEGUI::Window
  • destroyAllFonts() : CEGUI::FontManager
  • destroyAllImagesets() : CEGUI::ImagesetManager
  • destroyAllTextures() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • destroyAllWindows() : CEGUI::WindowManager
  • destroyBindings() : CEGUI::ScriptModule
  • destroyFont() : CEGUI::FontManager
  • destroyImageset() : CEGUI::ImagesetManager
  • destroyListSegment() : CEGUI::ListHeader
  • destroyTexture() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • destroyWindow() : CEGUI::ScrolledContainerFactory, CEGUI::GUISheetFactory, CEGUI::DragContainerFactory, CEGUI::WindowManager, CEGUI::WindowFactory
  • Dimension() : CEGUI::Dimension
  • DirectX81Renderer() : CEGUI::DirectX81Renderer
  • DirectX9Renderer() : CEGUI::DirectX9Renderer
  • disable() : CEGUI::Window
  • distributesCapturedInputs() : CEGUI::Window
  • doDragging() : CEGUI::DragContainer
  • doDragMoving() : CEGUI::ListHeaderSegment
  • doDragSizing() : CEGUI::ListHeaderSegment
  • doRender() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • doRiseOnClick() : CEGUI::Window
  • DoubleValue() : TiXmlAttribute
  • DragContainer() : CEGUI::DragContainer
  • draw() : CEGUI::ListboxTextItem, CEGUI::ListboxItem, CEGUI::MouseCursor, CEGUI::Imageset, CEGUI::Image
  • draw_impl() : CEGUI::RenderableImage, CEGUI::RenderableFrame
  • drawDisabled() : CEGUI::ButtonBase
  • drawHover() : CEGUI::ButtonBase
  • drawNormal() : CEGUI::ButtonBase
  • drawPushed() : CEGUI::ButtonBase
  • drawSelf() : CEGUI::TabControl, CEGUI::TabButton, CEGUI::ScrolledContainer, CEGUI::GUISheet, CEGUI::DragContainer, CEGUI::ButtonBase, CEGUI::Window
  • drawText() : CEGUI::Font
  • droplist_HiddenHandler() : CEGUI::Combobox
  • droplist_SelectionAcceptedHandler() : CEGUI::Combobox
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- e -

  • Editbox() : CEGUI::Editbox
  • editbox_MouseDownHandler() : CEGUI::Combobox
  • Element() : TiXmlHandle
  • elementStart() : CEGUI::Scheme_xmlHandler, CEGUI::Imageset_xmlHandler, CEGUI::GUILayout_xmlHandler, CEGUI::Font_xmlHandler, CEGUI::Config_xmlHandler
  • empty() : CEGUI::String
  • enable() : CEGUI::Window
  • Encoding() : TiXmlDeclaration
  • end() : CEGUI::String
  • ensureCaratIsVisible() : CEGUI::MultiLineEditbox
  • ensureItemIsVisible() : CEGUI::Listbox
  • erase() : CEGUI::String
  • eraseSelectedText() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • eraseWidgetLook() : CEGUI::WidgetLookManager
  • Error() : TiXmlDocument
  • ErrorCol() : TiXmlDocument
  • ErrorDesc() : TiXmlDocument
  • ErrorId() : TiXmlDocument
  • ErrorRow() : TiXmlDocument
  • Event() : CEGUI::Event
  • EventSet() : CEGUI::EventSet
  • executeScriptedEventHandler() : CEGUI::ScriptModule
  • executeScriptFile() : CEGUI::System, CEGUI::ScriptModule
  • executeScriptGlobal() : CEGUI::System, CEGUI::ScriptModule
  • executeScriptString() : CEGUI::System
  • executeString() : CEGUI::ScriptModule
  • exists() : CEGUI::XMLAttributes
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- f -

  • FactoryModule() : CEGUI::FactoryModule
  • Falagard_xmlHandler() : CEGUI::Falagard_xmlHandler
  • FalagardComponentBase() : CEGUI::FalagardComponentBase
  • find() : CEGUI::String
  • find_first_not_of() : CEGUI::String
  • find_first_of() : CEGUI::String
  • find_last_not_of() : CEGUI::String
  • find_last_of() : CEGUI::String
  • findColumnItemWithText() : CEGUI::MultiColumnList
  • findItemWithText() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • findListItemWithText() : CEGUI::MultiColumnList
  • findRowItemWithText() : CEGUI::MultiColumnList
  • fireEvent() : CEGUI::GlobalEventSet, CEGUI::EventSet
  • FirstAttribute() : TiXmlElement
  • FirstChild() : TiXmlHandle, TiXmlNode
  • FirstChildElement() : TiXmlHandle, TiXmlNode
  • Font_xmlHandler() : CEGUI::Font_xmlHandler
  • FontDim() : CEGUI::FontDim
  • FontManager() : CEGUI::FontManager
  • formatText() : CEGUI::MultiLineEditbox
  • FrameComponent() : CEGUI::FrameComponent
  • FrameWindow() : CEGUI::FrameWindow
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- g -

  • generateAutoRepeatEvent() : CEGUI::Window
  • get() : CEGUI::PropertyDefinition, CEGUI::TooltipProperties::FadeTime, CEGUI::TooltipProperties::DisplayTime, CEGUI::TooltipProperties::HoverTime, CEGUI::TitlebarProperties::CaptionColour, CEGUI::TitlebarProperties::DraggingEnabled, CEGUI::ThumbProperties::HorzRange, CEGUI::ThumbProperties::VertRange, CEGUI::ThumbProperties::HorzFree, CEGUI::ThumbProperties::VertFree, CEGUI::ThumbProperties::HotTracked, CEGUI::TextItemProperties::TextFormatting, CEGUI::TextItemProperties::TextColour, CEGUI::TextItemProperties::TextXOffset, CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::AbsoluteTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::RelativeTabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::StaticTextProperties::HorzScrollbar, CEGUI::StaticTextProperties::VertScrollbar, CEGUI::StaticTextProperties::VertFormatting, CEGUI::StaticTextProperties::HorzFormatting, CEGUI::StaticTextProperties::TextColours, CEGUI::StaticProperties::BottomFrameImage, CEGUI::StaticProperties::TopFrameImage, CEGUI::StaticProperties::RightFrameImage, CEGUI::StaticProperties::LeftFrameImage, CEGUI::StaticProperties::BottomRightFrameImage, CEGUI::StaticProperties::BottomLeftFrameImage, CEGUI::StaticProperties::TopRightFrameImage, CEGUI::StaticProperties::TopLeftFrameImage, CEGUI::StaticProperties::BackgroundImage, CEGUI::StaticProperties::BackgroundColours, CEGUI::StaticProperties::FrameColours, CEGUI::StaticProperties::BackgroundEnabled, CEGUI::StaticProperties::FrameEnabled, CEGUI::StaticImageProperties::VertFormatting, CEGUI::StaticImageProperties::HorzFormatting, CEGUI::StaticImageProperties::ImageColours, CEGUI::StaticImageProperties::Image, CEGUI::SpinnerProperties::TextInputMode, CEGUI::SpinnerProperties::MaximumValue, CEGUI::SpinnerProperties::MinimumValue, CEGUI::SpinnerProperties::StepSize, CEGUI::SpinnerProperties::CurrentValue, CEGUI::SliderProperties::ClickStepSize, CEGUI::SliderProperties::MaximumValue, CEGUI::SliderProperties::CurrentValue, CEGUI::ScrolledContainerProperties::ChildExtentsArea, CEGUI::ScrolledContainerProperties::ContentArea, CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, CEGUI::ScrollbarProperties::ScrollPosition, CEGUI::ScrollbarProperties::OverlapSize, CEGUI::ScrollbarProperties::StepSize, CEGUI::ScrollbarProperties::PageSize, CEGUI::ScrollbarProperties::DocumentSize, CEGUI::ScrollablePaneProperties::VertScrollPosition, CEGUI::ScrollablePaneProperties::VertOverlapSize, CEGUI::ScrollablePaneProperties::VertStepSize, CEGUI::ScrollablePaneProperties::HorzScrollPosition, CEGUI::ScrollablePaneProperties::HorzOverlapSize, CEGUI::ScrollablePaneProperties::HorzStepSize, CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, CEGUI::ScrollablePaneProperties::ForceVertScrollbar, CEGUI::ScrollablePaneProperties::ContentArea, CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, CEGUI::RadioButtonProperties::GroupID, CEGUI::RadioButtonProperties::Selected, CEGUI::PushButtonProperties::TextXOffset, CEGUI::PushButtonProperties::UseStandardImagery, CEGUI::PushButtonProperties::DisabledImage, CEGUI::PushButtonProperties::HoverImage, CEGUI::PushButtonProperties::PushedImage, CEGUI::PushButtonProperties::NormalImage, CEGUI::ProgressBarProperties::StepSize, CEGUI::ProgressBarProperties::CurrentProgress, CEGUI::PopupMenuProperties::FadeOutTime, CEGUI::PopupMenuProperties::FadeInTime, CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, CEGUI::MultiLineEditboxProperties::SelectedTextColour, CEGUI::MultiLineEditboxProperties::NormalTextColour, CEGUI::MultiLineEditboxProperties::MaxTextLength, CEGUI::MultiLineEditboxProperties::SelectionLength, CEGUI::MultiLineEditboxProperties::SelectionStart, CEGUI::MultiLineEditboxProperties::CaratIndex, CEGUI::MultiLineEditboxProperties::WordWrap, CEGUI::MultiLineEditboxProperties::ReadOnly, CEGUI::MultiColumnListProperties::RowCount, CEGUI::MultiColumnListProperties::ColumnHeader, CEGUI::MultiColumnListProperties::SelectionMode, CEGUI::MultiColumnListProperties::ForceHorzScrollbar, CEGUI::MultiColumnListProperties::ForceVertScrollbar, CEGUI::MultiColumnListProperties::NominatedSelectionRow, CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, CEGUI::MultiColumnListProperties::SortColumnID, CEGUI::MultiColumnListProperties::SortDirection, CEGUI::MultiColumnListProperties::SortSettingEnabled, CEGUI::MultiColumnListProperties::ColumnsMovable, CEGUI::MultiColumnListProperties::ColumnsSizable, CEGUI::MenuItemProperties::DisabledTextColour, CEGUI::MenuItemProperties::NormalTextColour, CEGUI::MenuItemProperties::OpenedColour, CEGUI::MenuItemProperties::PushedColour, CEGUI::MenuItemProperties::HoverColour, CEGUI::MenuBaseProperties::AllowMultiplePopups, CEGUI::MenuBaseProperties::BackgroundColours, CEGUI::MenuBaseProperties::BorderWidth, CEGUI::MenuBaseProperties::VertPadding, CEGUI::MenuBaseProperties::HorzPadding, CEGUI::MenuBaseProperties::ItemSpacing, CEGUI::ListHeaderSegmentProperties::SortDirection, CEGUI::ListHeaderSegmentProperties::Dragable, CEGUI::ListHeaderSegmentProperties::Clickable, CEGUI::ListHeaderSegmentProperties::Sizable, CEGUI::ListHeaderProperties::SortColumnID, CEGUI::ListHeaderProperties::SortDirection, CEGUI::ListHeaderProperties::SortSettingEnabled, CEGUI::ListHeaderProperties::ColumnsMovable, CEGUI::ListHeaderProperties::ColumnsSizable, CEGUI::ListboxProperties::ItemTooltips, CEGUI::ListboxProperties::ForceHorzScrollbar, CEGUI::ListboxProperties::ForceVertScrollbar, CEGUI::ListboxProperties::MultiSelect, CEGUI::ListboxProperties::Sort, CEGUI::ItemListBaseProperties::AutoResizeEnabled, CEGUI::FrameWindowProperties::NESWSizingCursorImage, CEGUI::FrameWindowProperties::NWSESizingCursorImage, CEGUI::FrameWindowProperties::EWSizingCursorImage, CEGUI::FrameWindowProperties::NSSizingCursorImage, CEGUI::FrameWindowProperties::CaptionColour, CEGUI::FrameWindowProperties::TitlebarFont, CEGUI::FrameWindowProperties::SizingBorderThickness, CEGUI::FrameWindowProperties::DragMovingEnabled, CEGUI::FrameWindowProperties::RollUpState, CEGUI::FrameWindowProperties::RollUpEnabled, CEGUI::FrameWindowProperties::CloseButtonEnabled, CEGUI::FrameWindowProperties::TitlebarEnabled, CEGUI::FrameWindowProperties::FrameEnabled, CEGUI::FrameWindowProperties::SizingEnabled, CEGUI::EditboxProperties::InactiveSelectionColour, CEGUI::EditboxProperties::ActiveSelectionColour, CEGUI::EditboxProperties::SelectedTextColour, CEGUI::EditboxProperties::NormalTextColour, CEGUI::EditboxProperties::MaxTextLength, CEGUI::EditboxProperties::SelectionLength, CEGUI::EditboxProperties::SelectionStart, CEGUI::EditboxProperties::CaratIndex, CEGUI::EditboxProperties::ValidationString, CEGUI::EditboxProperties::MaskCodepoint, CEGUI::EditboxProperties::MaskText, CEGUI::EditboxProperties::ReadOnly, CEGUI::DragContainerProperties::DragCursorImage, CEGUI::DragContainerProperties::DragThreshold, CEGUI::DragContainerProperties::DragAlpha, CEGUI::DragContainerProperties::DraggingEnabled, CEGUI::ComboboxProperties::SingleClickMode, CEGUI::ComboboxProperties::ForceHorzScrollbar, CEGUI::ComboboxProperties::ForceVertScrollbar, CEGUI::ComboboxProperties::SortList, CEGUI::ComboboxProperties::InactiveEditSelectionColour, CEGUI::ComboboxProperties::ActiveEditSelectionColour, CEGUI::ComboboxProperties::SelectedEditTextColour, CEGUI::ComboboxProperties::NormalEditTextColour, CEGUI::ComboboxProperties::MaxEditTextLength, CEGUI::ComboboxProperties::EditSelectionLength, CEGUI::ComboboxProperties::EditSelectionStart, CEGUI::ComboboxProperties::CaratIndex, CEGUI::ComboboxProperties::ValidationString, CEGUI::ComboboxProperties::ReadOnly, CEGUI::CheckboxProperties::Selected, CEGUI::ButtonBaseProperties::DisabledTextColour, CEGUI::ButtonBaseProperties::PushedTextColour, CEGUI::ButtonBaseProperties::HoverTextColour, CEGUI::ButtonBaseProperties::NormalTextColour, CEGUI::WindowProperties::HorizontalAlignment, CEGUI::WindowProperties::VerticalAlignment, CEGUI::WindowProperties::RiseOnClick, CEGUI::WindowProperties::InheritsTooltipText, CEGUI::WindowProperties::Tooltip, CEGUI::WindowProperties::CustomTooltipType, CEGUI::WindowProperties::DistributeCapturedInputs, CEGUI::WindowProperties::AutoRepeatRate, CEGUI::WindowProperties::AutoRepeatDelay, CEGUI::WindowProperties::MouseButtonDownAutoRepeat, CEGUI::WindowProperties::WantsMultiClickEvents, CEGUI::WindowProperties::ZOrderChangeEnabled, CEGUI::WindowProperties::AbsoluteRect, CEGUI::WindowProperties::RelativeRect, CEGUI::WindowProperties::Rect, CEGUI::WindowProperties::AbsolutePosition, CEGUI::WindowProperties::RelativePosition, CEGUI::WindowProperties::Position, CEGUI::WindowProperties::AbsoluteYPosition, CEGUI::WindowProperties::RelativeYPosition, CEGUI::WindowProperties::YPosition, CEGUI::WindowProperties::AbsoluteXPosition, CEGUI::WindowProperties::RelativeXPosition, CEGUI::WindowProperties::XPosition, CEGUI::WindowProperties::AbsoluteSize, CEGUI::WindowProperties::RelativeSize, CEGUI::WindowProperties::Size, CEGUI::WindowProperties::AbsoluteHeight, CEGUI::WindowProperties::RelativeHeight, CEGUI::WindowProperties::Height, CEGUI::WindowProperties::AbsoluteWidth, CEGUI::WindowProperties::RelativeWidth, CEGUI::WindowProperties::Width, CEGUI::WindowProperties::DestroyedByParent, CEGUI::WindowProperties::RestoreOldCapture, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::AlwaysOnTop, CEGUI::WindowProperties::InheritsAlpha, CEGUI::WindowProperties::ClippedByParent, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Text, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::Alpha, CEGUI::WindowProperties::ID, CEGUI::WindowProperties::MetricsMode, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::AbsoluteMinSize, CEGUI::WindowProperties::RelativeMaxSize, CEGUI::WindowProperties::RelativeMinSize, CEGUI::Property
  • getAbsoluteHeight() : CEGUI::Window
  • getAbsolutePosition() : CEGUI::Window
  • getAbsoluteRect() : CEGUI::Window
  • getAbsoluteSize() : CEGUI::Window
  • getAbsoluteTabHeight() : CEGUI::TabControl
  • getAbsoluteTabTextPadding() : CEGUI::TabControl
  • getAbsoluteWidth() : CEGUI::Window
  • getAbsoluteXPosition() : CEGUI::Window
  • getAbsoluteYPosition() : CEGUI::Window
  • getActiveChild() : CEGUI::Window
  • getActiveSibling() : CEGUI::Window
  • getActiveTarget() : CEGUI::WindowFactoryManager::AliasTargetStack
  • getAdjustDirectionFromPoint() : CEGUI::Slider, CEGUI::Scrollbar
  • getAliasIterator() : CEGUI::WindowFactoryManager
  • getAlpha() : CEGUI::Window
  • getArea() : CEGUI::NamedArea
  • getAreaPropertySource() : CEGUI::ComponentArea
  • getAutoRepeatDelay() : CEGUI::Window
  • getAutoRepeatRate() : CEGUI::Window
  • getAvailableGlyphs() : CEGUI::Font
  • getBackgroundColours() : CEGUI::Static, CEGUI::MenuBase
  • getBackgroundHorizontalFormatting() : CEGUI::FrameComponent
  • getBackgroundImage() : CEGUI::Static
  • getBackgroundVerticalFormatting() : CEGUI::FrameComponent
  • getBaseDimension() : CEGUI::Dimension
  • getBaseline() : CEGUI::Font
  • getBaseXCoord() : CEGUI::RenderableImage
  • getBaseYCoord() : CEGUI::RenderableImage
  • getBorderWidth() : CEGUI::MenuBase
  • getBoundingRect() : CEGUI::ImagerySection
  • getButtonForTabContents() : CEGUI::TabControl
  • getCaptionColour() : CEGUI::Titlebar, CEGUI::FrameWindow
  • getCaptureWindow() : CEGUI::Window
  • getCaratIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getCharAtPixel() : CEGUI::Font
  • getChild() : CEGUI::Window
  • getChildAtIdx() : CEGUI::Window
  • getChildAtPosition() : CEGUI::Window
  • getChildCount() : CEGUI::Window
  • getChildExtentsArea() : CEGUI::ScrolledContainer
  • getClickStep() : CEGUI::Slider
  • getColourAtPoint() : CEGUI::ColourRect
  • getColours() : CEGUI::FalagardComponentBase
  • getColumnCount() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • getColumnFromID() : CEGUI::ListHeader
  • getColumnFromSegment() : CEGUI::ListHeader
  • getColumnHeaderWidth() : CEGUI::MultiColumnList
  • getColumnID() : CEGUI::MultiColumnList
  • getColumnPixelWidth() : CEGUI::ListHeader
  • getColumnWithHeaderText() : CEGUI::MultiColumnList
  • getColumnWithID() : CEGUI::MultiColumnList
  • getColumnWithText() : CEGUI::ListHeader
  • getComponentArea() : CEGUI::FalagardComponentBase
  • getConstraintArea() : CEGUI::MouseCursor
  • getContentArea() : CEGUI::ScrolledContainer
  • getContentPane() : CEGUI::ScrollablePane
  • getContentPaneArea() : CEGUI::ScrollablePane
  • getContentSize() : CEGUI::PopupMenu, CEGUI::Menubar, CEGUI::ItemListBase
  • getCount() : CEGUI::XMLAttributes
  • getCurrentDropTarget() : CEGUI::DragContainer
  • getCurrentKey() : CEGUI::ConstBaseIterator< T >
  • getCurrentValue() : CEGUI::Spinner, CEGUI::Slider, CEGUI::ConstBaseIterator< T >
  • getCurrentZ() : CEGUI::Renderer
  • getD3DTexture() : CEGUI::DirectX9Texture, CEGUI::DirectX81Texture
  • getDefault() : CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::Property
  • getDefaultFont() : CEGUI::System
  • getDefaultFontName() : CEGUI::Config_xmlHandler
  • getDefaultMouseCursor() : CEGUI::System
  • getDefaultResourceGroup() : CEGUI::ResourceProvider, CEGUI::Config_xmlHandler
  • getDefaultTooltip() : CEGUI::System
  • getDereferencedAliasType() : CEGUI::WindowFactoryManager
  • getDestinationSize() : CEGUI::RenderableImage
  • getDimensionOperator() : CEGUI::BaseDim
  • getDimensionType() : CEGUI::Dimension
  • getDisabledImage() : CEGUI::PushButton
  • getDisabledTextColour() : CEGUI::MenuItem, CEGUI::ButtonBase
  • getDisplayIndependantPosition() : CEGUI::MouseCursor
  • getDisplayTime() : CEGUI::Tooltip
  • GetDocument() : TiXmlNode
  • getDocumentSize() : CEGUI::Scrollbar
  • getDragAlpha() : CEGUI::DragContainer
  • getDragCursorImage() : CEGUI::DragContainer
  • getDragMoveOffset() : CEGUI::ListHeaderSegment
  • getEffectiveAlpha() : CEGUI::Window
  • getEWSizingCursorImage() : CEGUI::FrameWindow
  • getFactory() : CEGUI::WindowFactoryManager
  • getFadeInTime() : CEGUI::PopupMenu
  • getFadeOutTime() : CEGUI::PopupMenu
  • getFadeTime() : CEGUI::Tooltip
  • getFalagardMappingIterator() : CEGUI::WindowFactoryManager
  • getFirstSelectedItem() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getFont() : CEGUI::TextComponent, CEGUI::ListboxTextItem, CEGUI::Window, CEGUI::FontManager
  • getFontHeight() : CEGUI::Font
  • getFormattedLineCount() : CEGUI::Font
  • getFormattedTextExtent() : CEGUI::Font
  • getFrameColours() : CEGUI::Static
  • getGroupID() : CEGUI::RadioButton
  • getGUISheet() : CEGUI::System
  • getHeaderSegmentForColumn() : CEGUI::MultiColumnList
  • getHeight() : CEGUI::OpenGLTexture, CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Texture, CEGUI::Renderer, CEGUI::Rect, CEGUI::Image
  • getHelp() : CEGUI::Property
  • getHighestRowItemHeight() : CEGUI::MultiColumnList
  • getHorizontalAlignment() : CEGUI::Window
  • getHorizontalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • getHorizontalOverlapSize() : CEGUI::ScrollablePane
  • getHorizontalScrollPosition() : CEGUI::ScrollablePane
  • getHorizontalStepSize() : CEGUI::ScrollablePane
  • getHorzFormatting() : CEGUI::RenderableImage
  • getHorzPadding() : CEGUI::MenuBase
  • getHorzRange() : CEGUI::Thumb
  • getHorzScreenDPI() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • getHorzTileCount() : CEGUI::RenderableImage
  • getHoverColour() : CEGUI::MenuItem
  • getHoverImage() : CEGUI::PushButton
  • getHoverTextColour() : CEGUI::ButtonBase
  • getHoverTime() : CEGUI::Tooltip
  • getID() : CEGUI::ListboxItem, CEGUI::Window
  • getIdentifierString() : CEGUI::XMLParser, CEGUI::ScriptModule, CEGUI::Renderer
  • getImage() : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticImage, CEGUI::RenderableImage, CEGUI::MouseCursor, CEGUI::Imageset
  • getImageColours() : CEGUI::StaticImage
  • getImageCount() : CEGUI::Imageset
  • getImageForFrameLocation() : CEGUI::Static
  • getImageForLocation() : CEGUI::RenderableFrame
  • getImageHeight() : CEGUI::Imageset
  • getImageOffset() : CEGUI::Imageset
  • getImageOffsetX() : CEGUI::Imageset
  • getImageOffsetY() : CEGUI::Imageset
  • getImagePropertySource() : CEGUI::ImageryComponent
  • getImagerySection() : CEGUI::WidgetLookFeel
  • getImageset() : CEGUI::ImagesetManager
  • getImagesetName() : CEGUI::Image
  • getImageSize() : CEGUI::Imageset
  • getImageWidth() : CEGUI::Imageset
  • getInactiveSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getInheritedMetricsMode() : CEGUI::Window
  • getInitialiserValue() : CEGUI::PropertyInitialiser
  • getInitScriptFilename() : CEGUI::Config_xmlHandler
  • getInnerRect() : CEGUI::Window
  • getIntersection() : CEGUI::Rect
  • getItemAtGridReference() : CEGUI::MultiColumnList
  • getItemAtPoint() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getItemColumnIndex() : CEGUI::MultiColumnList
  • getItemCount() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • getItemFromIndex() : CEGUI::ItemListBase
  • getItemGridReference() : CEGUI::MultiColumnList
  • getItemIndex() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • getItemPixelSize() : CEGUI::TextItem, CEGUI::ItemEntry
  • getItemRenderArea() : CEGUI::ItemListBase
  • getItemRowIndex() : CEGUI::MultiColumnList
  • getItemSpacing() : CEGUI::MenuBase
  • getIterator() : CEGUI::WindowManager, CEGUI::WindowFactoryManager, CEGUI::SchemeManager, CEGUI::PropertySet, CEGUI::ImagesetManager, CEGUI::Imageset, CEGUI::FontManager, CEGUI::EventSet
  • getLayerPriority() : CEGUI::LayerSpecification
  • getLayoutFilename() : CEGUI::Config_xmlHandler
  • getLayoutRootWindow() : CEGUI::GUILayout_xmlHandler
  • getLineNumberFromIndex() : CEGUI::MultiLineEditbox
  • getLineSpacing() : CEGUI::Font
  • getListboxItemFromIndex() : CEGUI::Listbox, CEGUI::Combobox
  • getListRenderArea() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getLogFilename() : CEGUI::Config_xmlHandler
  • getLoggingLevel() : CEGUI::Logger, CEGUI::Config_xmlHandler
  • getLookNFeel() : CEGUI::Window
  • getMappedLookForType() : CEGUI::WindowFactoryManager
  • getMaskCodePoint() : CEGUI::Editbox
  • getMasterColours() : CEGUI::ImagerySection
  • getMaximumSize() : CEGUI::Window
  • getMaximumValue() : CEGUI::Spinner
  • getMaxTextLength() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getMaxTextureSize() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • getMaxValue() : CEGUI::Slider
  • getMessage() : CEGUI::Exception
  • getMetricsMode() : CEGUI::Window
  • getMinimumSize() : CEGUI::Window
  • getMinimumValue() : CEGUI::Spinner
  • getModalState() : CEGUI::Window
  • getModalTarget() : CEGUI::System
  • getModulateAlphaColourRect() : CEGUI::ListboxItem
  • getMouseCursor() : CEGUI::Window
  • getMouseMoveScaling() : CEGUI::System
  • getMultiClickTimeout() : CEGUI::System
  • getMultiClickToleranceAreaSize() : CEGUI::System
  • getName() : CEGUI::WidgetLookFeel, CEGUI::StateImagery, CEGUI::NamedArea, CEGUI::ImagerySection, CEGUI::XMLAttributes, CEGUI::Window, CEGUI::Scheme, CEGUI::Property, CEGUI::Imageset, CEGUI::Image, CEGUI::Font, CEGUI::Event
  • getNamedArea() : CEGUI::WidgetLookFeel
  • getNativeResolution() : CEGUI::Imageset, CEGUI::Font
  • getNESWSizingCursorImage() : CEGUI::FrameWindow
  • getNextSelected() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getNextTokenLength() : CEGUI::MultiLineEditbox
  • getNextWord() : CEGUI::TextUtils
  • getNextWordStartIdx() : CEGUI::TextUtils
  • getNominatedSelectionColumn() : CEGUI::MultiColumnList
  • getNominatedSelectionColumnID() : CEGUI::MultiColumnList
  • getNominatedSelectionRow() : CEGUI::MultiColumnList
  • getNormalImage() : CEGUI::PushButton
  • getNormalSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getNormalTextColour() : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox, CEGUI::Combobox, CEGUI::ButtonBase
  • getNSSizingCursorImage() : CEGUI::FrameWindow
  • getNWSESizingCursorImage() : CEGUI::FrameWindow
  • getOffsets() : CEGUI::Image
  • getOffsetX() : CEGUI::Image
  • getOffsetY() : CEGUI::Image
  • getOGLTexid() : CEGUI::OpenGLTexture
  • getOpenedColour() : CEGUI::MenuItem
  • getOperand() : CEGUI::BaseDim
  • getOverlapSize() : CEGUI::Scrollbar
  • getOverrideColours() : CEGUI::SectionSpecification
  • getOwnerWidgetLookFeel() : CEGUI::SectionSpecification
  • getOwnerWindow() : CEGUI::ListboxItem
  • getPageSize() : CEGUI::Scrollbar
  • getParent() : CEGUI::Window
  • getParentHeight() : CEGUI::Window
  • getParentSize() : CEGUI::Window
  • getParentWidth() : CEGUI::Window
  • getPixelDragThreshold() : CEGUI::DragContainer
  • getPixelOffsetToColumn() : CEGUI::ListHeader
  • getPixelOffsetToSegment() : CEGUI::ListHeader
  • getPixelRect() : CEGUI::ComponentArea, CEGUI::Window
  • getPixelSize() : CEGUI::ListboxTextItem, CEGUI::ListboxItem
  • getPointSize() : CEGUI::Font
  • getPopupMenu() : CEGUI::MenuItem
  • getPopupMenuItem() : CEGUI::MenuBase
  • getPosition() : CEGUI::Window, CEGUI::Rect, CEGUI::MouseCursor
  • getProgress() : CEGUI::ProgressBar
  • getProperty() : CEGUI::PropertySet
  • getPropertyDefault() : CEGUI::PropertySet
  • getPropertyHelp() : CEGUI::PropertySet
  • getPushedColour() : CEGUI::MenuItem
  • getPushedImage() : CEGUI::PushButton
  • getPushedTextColour() : CEGUI::ButtonBase
  • getQuadSplitMode() : CEGUI::RenderableImage
  • getRect() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Renderer
  • getRelativeHeight() : CEGUI::Window
  • getRelativePosition() : CEGUI::Window
  • getRelativeRect() : CEGUI::Window
  • getRelativeSize() : CEGUI::Window
  • getRelativeTabHeight() : CEGUI::TabControl
  • getRelativeTabTextPadding() : CEGUI::TabControl
  • getRelativeWidth() : CEGUI::Window
  • getRelativeXPosition() : CEGUI::Window
  • getRelativeYPosition() : CEGUI::Window
  • getRenderCache() : CEGUI::Window
  • getRenderer() : CEGUI::Texture, CEGUI::System
  • getResourceProvider() : CEGUI::System
  • getRowCount() : CEGUI::MultiColumnList
  • getRowID() : CEGUI::MultiColumnList
  • getRowWithID() : CEGUI::MultiColumnList
  • getScheme() : CEGUI::SchemeManager
  • getSchemeFilename() : CEGUI::Config_xmlHandler
  • getScriptingModule() : CEGUI::System
  • getScrollPosition() : CEGUI::Scrollbar
  • getSectionName() : CEGUI::SectionSpecification
  • getSegmentFromColumn() : CEGUI::ListHeader
  • getSegmentFromID() : CEGUI::ListHeader
  • getSegmentOffset() : CEGUI::ListHeader
  • getSelectedButtonInGroup() : CEGUI::RadioButton
  • getSelectedCount() : CEGUI::MultiColumnList, CEGUI::Listbox
  • getSelectedItem() : CEGUI::Combobox
  • getSelectedTabIndex() : CEGUI::TabControl
  • getSelectedTextColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSelectionBrushImage() : CEGUI::ListboxItem
  • getSelectionColours() : CEGUI::ListboxItem
  • getSelectionEndIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSelectionLength() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSelectionMode() : CEGUI::MultiColumnList
  • getSelectionStartIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • getSingleClickEnabled() : CEGUI::Combobox
  • getSingleClickTimeout() : CEGUI::System
  • getSingleton() : CEGUI::WidgetLookManager, CEGUI::WindowManager, CEGUI::WindowFactoryManager, CEGUI::System, CEGUI::SchemeManager, CEGUI::MouseCursor, CEGUI::Logger, CEGUI::ImagesetManager, CEGUI::GlobalEventSet, CEGUI::FontManager
  • getSingletonPtr() : CEGUI::WidgetLookManager, CEGUI::WindowManager, CEGUI::WindowFactoryManager, CEGUI::System, CEGUI::SchemeManager, CEGUI::MouseCursor, CEGUI::ImagesetManager, CEGUI::GlobalEventSet, CEGUI::FontManager
  • getSize() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Renderer, CEGUI::Rect, CEGUI::Image
  • getSizingBorderAtPoint() : CEGUI::FrameWindow
  • getSizingBorderThickness() : CEGUI::FrameWindow
  • getSizingRect() : CEGUI::FrameWindow
  • getSortColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • getSortDirection() : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • getSortSegment() : CEGUI::ListHeader
  • getSourceTextureArea() : CEGUI::Image
  • getStackedTargetCount() : CEGUI::WindowFactoryManager::AliasTargetStack
  • getStateImagery() : CEGUI::WidgetLookFeel
  • getStep() : CEGUI::ProgressBar
  • getStepSize() : CEGUI::Spinner, CEGUI::Scrollbar
  • getSubRectangle() : CEGUI::ColourRect
  • getSystemKeys() : CEGUI::System
  • getTabContents() : CEGUI::TabControl
  • getTabContentsAtIndex() : CEGUI::TabControl
  • getTabCount() : CEGUI::TabControl
  • getTabHeight() : CEGUI::TabControl
  • getTabIndex() : CEGUI::TabButton
  • getTabTextPadding() : CEGUI::TabControl
  • getTargetPropertyName() : CEGUI::PropertyInitialiser
  • getTargetWindow() : CEGUI::Tooltip, CEGUI::TabButton
  • getTermScriptFilename() : CEGUI::Config_xmlHandler
  • getText() : CEGUI::TextComponent, CEGUI::ListboxItem, CEGUI::Window
  • getTextColour() : CEGUI::TextItem
  • getTextColours() : CEGUI::StaticText, CEGUI::ListboxTextItem
  • getTextExtent() : CEGUI::Font
  • getTextFormatting() : CEGUI::TextItem
  • getTextFromValue() : CEGUI::Spinner
  • getTextIndexFromPosition() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • getTextInputMode() : CEGUI::Spinner
  • getTextRenderArea() : CEGUI::StaticText, CEGUI::MultiLineEditbox
  • getTextSize() : CEGUI::Tooltip
  • getTexture() : CEGUI::Imageset
  • getTextXOffset() : CEGUI::TextItem, CEGUI::PushButton
  • getTitlebarFont() : CEGUI::FrameWindow
  • getTooltip() : CEGUI::Window
  • getTooltipText() : CEGUI::Window
  • getTooltipType() : CEGUI::Window
  • getTotalColumnHeadersWidth() : CEGUI::MultiColumnList
  • getTotalItemsHeight() : CEGUI::Listbox
  • getTotalRowsHeight() : CEGUI::MultiColumnList
  • getTotalSegmentsPixelExtent() : CEGUI::ListHeader
  • getType() : CEGUI::Window
  • getTypeName() : CEGUI::WindowFactory
  • getUnclippedInnerRect() : CEGUI::StaticText, CEGUI::Static, CEGUI::ScrolledContainer, CEGUI::Window
  • getUnclippedPixelRect() : CEGUI::Window
  • getUnifiedConstraintArea() : CEGUI::MouseCursor
  • getUserData() : CEGUI::ListboxItem, CEGUI::Window
  • getUserString() : CEGUI::Window
  • getValidationString() : CEGUI::Editbox, CEGUI::Combobox
  • getValue() : CEGUI::BaseDim, CEGUI::XMLAttributes
  • getValue_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • getValueAsBool() : CEGUI::XMLAttributes
  • getValueAsFloat() : CEGUI::XMLAttributes
  • getValueAsInteger() : CEGUI::XMLAttributes
  • getValueAsString() : CEGUI::XMLAttributes
  • getValueFromText() : CEGUI::Spinner
  • getValueFromThumb() : CEGUI::Slider, CEGUI::Scrollbar
  • getVertFormatting() : CEGUI::RenderableImage
  • getVerticalAlignment() : CEGUI::Window
  • getVerticalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • getVerticalOverlapSize() : CEGUI::ScrollablePane
  • getVerticalScrollPosition() : CEGUI::ScrollablePane
  • getVerticalStepSize() : CEGUI::ScrollablePane
  • getVertPadding() : CEGUI::MenuBase
  • getVertRange() : CEGUI::Thumb
  • getVertScreenDPI() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • getVertTileCount() : CEGUI::RenderableImage
  • getViewableArea() : CEGUI::ScrollablePane
  • getWidestColumnItemWidth() : CEGUI::MultiColumnList
  • getWidestItemWidth() : CEGUI::Listbox
  • getWidgetLook() : CEGUI::WidgetLookManager
  • getWidth() : CEGUI::OpenGLTexture, CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer, CEGUI::Window, CEGUI::Texture, CEGUI::Renderer, CEGUI::Rect, CEGUI::Image
  • getWindow() : CEGUI::WindowManager
  • getWindowArea() : CEGUI::Window
  • getWindowContainingMouse() : CEGUI::System
  • getWindowHeight() : CEGUI::Window
  • getWindowMaxSize() : CEGUI::Window
  • getWindowMinSize() : CEGUI::Window
  • getWindowPosition() : CEGUI::Window
  • getWindowSize() : CEGUI::Window
  • getWindowWidth() : CEGUI::Window
  • getWindowXPosition() : CEGUI::Window
  • getWindowYPosition() : CEGUI::Window
  • getWordStartIdx() : CEGUI::TextUtils
  • getXMLParser() : CEGUI::System
  • getXPosition() : CEGUI::Window
  • getYPosition() : CEGUI::Window
  • getZLayer() : CEGUI::Renderer
  • grabTexture() : CEGUI::OpenGLTexture
  • grabTextures() : CEGUI::OpenGLRenderer
  • GUILayout_xmlHandler() : CEGUI::GUILayout_xmlHandler
  • GUISheet() : CEGUI::GUISheet
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- h -

  • handle_scrollChange() : CEGUI::MultiLineEditbox, CEGUI::Listbox
  • handleAutoSizePaneChanged() : CEGUI::ScrollablePane
  • handleBackspace() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleCharLeft() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleCharRight() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleChildMoved() : CEGUI::ScrolledContainer
  • handleChildSized() : CEGUI::ScrolledContainer
  • handleContentAreaChange() : CEGUI::ScrollablePane
  • handleDecreaseClicked() : CEGUI::Scrollbar
  • handleDelete() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleDocEnd() : CEGUI::MultiLineEditbox
  • handleDocHome() : CEGUI::MultiLineEditbox
  • handleEnd() : CEGUI::Editbox
  • handleHome() : CEGUI::Editbox
  • handleIncreaseClicked() : CEGUI::Scrollbar
  • handleLineDown() : CEGUI::MultiLineEditbox
  • handleLineEnd() : CEGUI::MultiLineEditbox
  • handleLineHome() : CEGUI::MultiLineEditbox
  • handleLineUp() : CEGUI::MultiLineEditbox
  • handleNewLine() : CEGUI::MultiLineEditbox
  • handleScrollChange() : CEGUI::ScrollablePane
  • handleThumbMoved() : CEGUI::Slider, CEGUI::Scrollbar
  • handleThumbTrackEnded() : CEGUI::Slider, CEGUI::Scrollbar
  • handleThumbTrackStarted() : CEGUI::Slider, CEGUI::Scrollbar
  • handleUpdatedItemData() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase
  • handleUpdatedListItemData() : CEGUI::Combobox
  • handleWordLeft() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • handleWordRight() : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • hasCachedImagery() : CEGUI::RenderCache
  • hasInputFocus() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • hide() : CEGUI::Window, CEGUI::MouseCursor
  • hideDropList() : CEGUI::Combobox
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- i -

  • Image() : CEGUI::Image
  • ImageDim() : CEGUI::ImageDim
  • ImageryComponent() : CEGUI::ImageryComponent
  • ImagerySection() : CEGUI::ImagerySection
  • Imageset_xmlHandler() : CEGUI::Imageset_xmlHandler
  • ImagesetManager() : CEGUI::ImagesetManager
  • inheritsAlpha() : CEGUI::Window
  • inheritsTooltipText() : CEGUI::Window
  • initColourRectForOverride() : CEGUI::SectionSpecification
  • initColoursRect() : CEGUI::FalagardComponentBase
  • initDragMoving() : CEGUI::ListHeaderSegment
  • initialise() : CEGUI::TabControl, CEGUI::StaticText, CEGUI::Spinner, CEGUI::Slider, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::GUISheet, CEGUI::FrameWindow, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::XMLParser, CEGUI::Window
  • initialiseDragging() : CEGUI::DragContainer
  • initialiseImpl() : CEGUI::XMLParser, CEGUI::XercesParser, CEGUI::TinyXMLParser
  • initialiseWidget() : CEGUI::WidgetLookFeel
  • initMasterColourRect() : CEGUI::ImagerySection
  • initSegmentHoverState() : CEGUI::ListHeaderSegment
  • initSizingHoverState() : CEGUI::ListHeaderSegment
  • injectChar() : CEGUI::System
  • injectKeyDown() : CEGUI::System
  • injectKeyUp() : CEGUI::System
  • injectMouseButtonDown() : CEGUI::System
  • injectMouseButtonUp() : CEGUI::System
  • injectMouseLeaves() : CEGUI::System
  • injectMouseMove() : CEGUI::System
  • injectMousePosition() : CEGUI::System
  • injectMouseWheelChange() : CEGUI::System
  • injectTimePulse() : CEGUI::System
  • insert() : CEGUI::String
  • InsertAfterChild() : TiXmlNode
  • InsertBeforeChild() : TiXmlNode
  • insertColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • InsertEndChild() : TiXmlNode
  • insertItem() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • insertRow() : CEGUI::MultiColumnList
  • IntValue() : TiXmlAttribute
  • IrrlichtRenderer() : CEGUI::IrrlichtRenderer
  • isActive() : CEGUI::Window
  • isAlwaysOnTop() : CEGUI::Window
  • isAncestor() : CEGUI::Window
  • isAntiAliased() : CEGUI::Font
  • isAreaFetchedFromProperty() : CEGUI::ComponentArea
  • isArmed() : CEGUI::ComboDropList
  • isAtEnd() : CEGUI::ConstBaseIterator< T >
  • isAtStart() : CEGUI::ConstBaseIterator< T >
  • isAutoArmEnabled() : CEGUI::ComboDropList
  • isAutoDeleted() : CEGUI::ListboxItem
  • isAutoResizeEnabled() : CEGUI::ItemListBase
  • isAutoScaled() : CEGUI::Imageset, CEGUI::Font
  • isBackgroundEnabled() : CEGUI::Static
  • isBeingDragged() : CEGUI::DragContainer
  • isBottomSizingLocation() : CEGUI::FrameWindow
  • isCapturedByAncestor() : CEGUI::Window
  • isCapturedByChild() : CEGUI::Window
  • isCapturedByThis() : CEGUI::Window
  • isChild() : CEGUI::Window
  • isClickable() : CEGUI::ListHeaderSegment
  • isClippedByParent() : CEGUI::Window
  • isClippedToDisplay() : CEGUI::StateImagery
  • isCloseButtonEnabled() : CEGUI::FrameWindow
  • isCodepointAvailable() : CEGUI::Font
  • isColumnDraggingEnabled() : CEGUI::ListHeader
  • isColumnSizingEnabled() : CEGUI::ListHeader
  • isContentPaneAutoSized() : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • isCustomImageryAutoSized() : CEGUI::PushButton
  • isDeadPoolEmpty() : CEGUI::WindowManager
  • isDefault() : CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::Property
  • isDestroyedByParent() : CEGUI::Window
  • isDisabled() : CEGUI::ListboxItem, CEGUI::Window
  • isDraggingEnabled() : CEGUI::Titlebar, CEGUI::DragContainer
  • isDraggingThresholdExceeded() : CEGUI::DragContainer
  • isDragMoveThresholdExceeded() : CEGUI::ListHeaderSegment
  • isDragMovingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • isDropDownListVisible() : CEGUI::Combobox
  • isEventPresent() : CEGUI::EventSet
  • isFactoryPresent() : CEGUI::WindowFactoryManager
  • isFalagardMappedType() : CEGUI::WindowFactoryManager
  • isFontPresent() : CEGUI::FontManager
  • isFrameEnabled() : CEGUI::Static, CEGUI::FrameWindow
  • isHit() : CEGUI::FrameWindow, CEGUI::Combobox, CEGUI::Window
  • isHorizontalScrollbarEnabled() : CEGUI::StaticText
  • isHorzFree() : CEGUI::Thumb
  • isHorzScrollbarAlwaysShown() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isHorzScrollbarNeeded() : CEGUI::ScrollablePane
  • isHotTracked() : CEGUI::Thumb
  • isHovering() : CEGUI::MenuItem, CEGUI::ButtonBase
  • isImageDefined() : CEGUI::Imageset
  • isImageFetchedFromProperty() : CEGUI::ImageryComponent
  • isImagesetPresent() : CEGUI::ImagesetManager
  • isItemInList() : CEGUI::ItemListBase
  • isItemSelected() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isLeftSizingLocation() : CEGUI::FrameWindow
  • isListboxItemInColumn() : CEGUI::MultiColumnList
  • isListboxItemInList() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isListboxItemInRow() : CEGUI::MultiColumnList
  • isMonochromatic() : CEGUI::ColourRect
  • isMouseAutoRepeatEnabled() : CEGUI::Window
  • isMultiplePopupsAllowed() : CEGUI::MenuBase
  • isMultiselectEnabled() : CEGUI::Listbox
  • isMuted() : CEGUI::EventSet
  • isNamedAreaDefined() : CEGUI::WidgetLookFeel
  • isPointInRect() : CEGUI::Rect
  • isPropertyDefault() : CEGUI::PropertySet
  • isPropertyPresent() : CEGUI::PropertySet
  • isPushed() : CEGUI::MenuItem, CEGUI::ButtonBase
  • isQueueingEnabled() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • isReadOnly() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • isRedrawRequested() : CEGUI::System
  • isRightSizingLocation() : CEGUI::FrameWindow
  • isRiseOnClickEnabled() : CEGUI::Window
  • isRolledup() : CEGUI::FrameWindow
  • isRollupEnabled() : CEGUI::FrameWindow
  • isSchemePresent() : CEGUI::SchemeManager
  • isSelected() : CEGUI::TabButton, CEGUI::RadioButton, CEGUI::ListboxItem, CEGUI::Checkbox
  • isSizingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • isSortEnabled() : CEGUI::Listbox, CEGUI::Combobox
  • isSortingEnabled() : CEGUI::ListHeader
  • isStandardImageryEnabled() : CEGUI::PushButton
  • isStateImageryPresent() : CEGUI::WidgetLookFeel
  • isStringValid() : CEGUI::Editbox
  • isTabContentsSelected() : CEGUI::TabControl
  • isTextMasked() : CEGUI::Editbox
  • isTextValid() : CEGUI::Editbox, CEGUI::Combobox
  • isTitleBarEnabled() : CEGUI::FrameWindow
  • isTopSizingLocation() : CEGUI::FrameWindow
  • isUserColumnDraggingEnabled() : CEGUI::MultiColumnList
  • isUserColumnSizingEnabled() : CEGUI::MultiColumnList
  • isUserSortControlEnabled() : CEGUI::MultiColumnList
  • isUserStringDefined() : CEGUI::Window
  • isUsingDefaultTooltip() : CEGUI::Window
  • isUsingOverrideColours() : CEGUI::SectionSpecification
  • isVertFree() : CEGUI::Thumb
  • isVerticalScrollbarEnabled() : CEGUI::StaticText
  • isVertScrollbarAlwaysShown() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • isVertScrollbarNeeded() : CEGUI::ScrollablePane
  • isVisible() : CEGUI::Window, CEGUI::MouseCursor
  • IsWhiteSpaceCondensed() : TiXmlBase
  • isWidgetLookAvailable() : CEGUI::WidgetLookManager
  • isWindowPresent() : CEGUI::WindowManager
  • isWordWrapped() : CEGUI::MultiLineEditbox
  • isZOrderingEnabled() : CEGUI::Window
  • ItemEntry() : CEGUI::ItemEntry
  • ItemListBase() : CEGUI::ItemListBase
  • IterateChildren() : TiXmlNode
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- p -

  • Parent() : TiXmlNode
  • Parse() : TiXmlDocument
  • parseLookNFeelSpecification() : CEGUI::WidgetLookManager
  • parseXMLFile() : CEGUI::XMLParser, CEGUI::XercesParser, CEGUI::TinyXMLParser
  • performChildWindowLayout() : CEGUI::TabControl, CEGUI::Window
  • populateAttributesBlock() : CEGUI::XercesParser
  • populateRenderCache() : CEGUI::TextItem, CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Window
  • populateRenderCahce() : CEGUI::ItemEntry
  • PopupMenu() : CEGUI::PopupMenu
  • positionSelf() : CEGUI::Tooltip
  • postD3DReset() : CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer
  • preD3DReset() : CEGUI::DirectX9Texture, CEGUI::DirectX9Renderer, CEGUI::DirectX81Texture, CEGUI::DirectX81Renderer
  • pred_descend() : CEGUI::MultiColumnList
  • Previous() : TiXmlAttribute
  • PreviousSibling() : TiXmlNode
  • Print() : TiXmlDocument, TiXmlUnknown, TiXmlDeclaration, TiXmlText, TiXmlComment, TiXmlElement, TiXmlAttribute, TiXmlBase
  • ProgressBar() : CEGUI::ProgressBar
  • Property() : CEGUI::Property
  • PropertyDim() : CEGUI::PropertyDim
  • PropertyInitialiser() : CEGUI::PropertyInitialiser
  • PropertySet() : CEGUI::PropertySet
  • push_back() : CEGUI::String
  • PushButton() : CEGUI::PushButton
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- q -

  • QueryDoubleAttribute() : TiXmlElement
  • QueryDoubleValue() : TiXmlAttribute
  • QueryIntAttribute() : TiXmlElement
  • QueryIntValue() : TiXmlAttribute
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- r -

  • rbegin() : CEGUI::String
  • Rect() : CEGUI::Rect
  • registerAllFactories() : CEGUI::FactoryModule
  • registerFactory() : CEGUI::FactoryModule
  • relativeToAbsolute() : CEGUI::Window
  • relativeToAbsolute_impl() : CEGUI::Window
  • relativeToAbsoluteX() : CEGUI::Window
  • relativeToAbsoluteY() : CEGUI::Window
  • release() : CEGUI::SubscriberTemplate< Ret, Args >
  • releaseInput() : CEGUI::Window
  • remove() : CEGUI::XMLAttributes
  • removeAllEvents() : CEGUI::EventSet
  • removeAllFactories() : CEGUI::WindowFactoryManager
  • RemoveAttribute() : TiXmlElement
  • removeButtonForTabContent() : CEGUI::TabControl
  • RemoveChild() : TiXmlNode
  • removeChild_impl() : CEGUI::TabControl, CEGUI::ScrollablePane, CEGUI::Window
  • removeChildWindow() : CEGUI::Window
  • removeColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • removeColumnWithID() : CEGUI::MultiColumnList
  • removeEvent() : CEGUI::EventSet
  • removeFactory() : CEGUI::WindowFactoryManager
  • removeFalagardWindowMapping() : CEGUI::WindowFactoryManager
  • removeItem() : CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • removeProperty() : CEGUI::PropertySet
  • removeRow() : CEGUI::MultiColumnList
  • removeSegment() : CEGUI::ListHeader
  • removeTab() : CEGUI::TabControl
  • removeWindowFromDrawList() : CEGUI::Window
  • removeWindowTypeAlias() : CEGUI::WindowFactoryManager
  • rename() : CEGUI::Window
  • renameChildren() : CEGUI::WidgetLookFeel
  • renameWindow() : CEGUI::WindowManager
  • rend() : CEGUI::String
  • render() : CEGUI::StateImagery, CEGUI::SectionSpecification, CEGUI::LayerSpecification, CEGUI::ImagerySection, CEGUI::FalagardComponentBase, CEGUI::Window, CEGUI::RenderCache
  • render_impl() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::FalagardComponentBase
  • RenderableFrame() : CEGUI::RenderableFrame
  • RenderableImage() : CEGUI::RenderableImage
  • RenderCache() : CEGUI::RenderCache
  • renderGUI() : CEGUI::System
  • replace() : CEGUI::String
  • ReplaceChild() : TiXmlNode
  • requestRedraw() : CEGUI::Window
  • reserve() : CEGUI::String
  • resetList() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • resetList_impl() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase
  • resetTimer() : CEGUI::Tooltip
  • resetZValue() : CEGUI::Renderer
  • resize() : CEGUI::String
  • ResourceProvider() : CEGUI::ResourceProvider
  • resourcesLoaded() : CEGUI::Scheme
  • restoresOldCapture() : CEGUI::Window
  • restoreTexture() : CEGUI::OpenGLTexture
  • restoreTextures() : CEGUI::OpenGLRenderer
  • rfind() : CEGUI::String
  • RootElement() : TiXmlDocument
  • Row() : TiXmlBase
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- s -

  • SaveFile() : TiXmlDocument
  • Scheme_xmlHandler() : CEGUI::Scheme_xmlHandler
  • SchemeManager() : CEGUI::SchemeManager
  • screenToWindow() : CEGUI::Window
  • screenToWindowX() : CEGUI::Window
  • screenToWindowY() : CEGUI::Window
  • ScriptModule() : CEGUI::ScriptModule
  • ScrollablePane() : CEGUI::ScrollablePane
  • Scrollbar() : CEGUI::Scrollbar
  • ScrolledContainer() : CEGUI::ScrolledContainer
  • SectionSpecification() : CEGUI::SectionSpecification
  • selectRange() : CEGUI::MultiColumnList, CEGUI::Listbox
  • selectTab_impl() : CEGUI::TabControl
  • set() : CEGUI::PropertyDefinition, CEGUI::TooltipProperties::FadeTime, CEGUI::TooltipProperties::DisplayTime, CEGUI::TooltipProperties::HoverTime, CEGUI::TitlebarProperties::CaptionColour, CEGUI::TitlebarProperties::DraggingEnabled, CEGUI::ThumbProperties::HorzRange, CEGUI::ThumbProperties::VertRange, CEGUI::ThumbProperties::HorzFree, CEGUI::ThumbProperties::VertFree, CEGUI::ThumbProperties::HotTracked, CEGUI::TextItemProperties::TextFormatting, CEGUI::TextItemProperties::TextColour, CEGUI::TextItemProperties::TextXOffset, CEGUI::TabControlProperties::RelativeTabTextPadding, CEGUI::TabControlProperties::AbsoluteTabTextPadding, CEGUI::TabControlProperties::TabTextPadding, CEGUI::TabControlProperties::RelativeTabHeight, CEGUI::TabControlProperties::AbsoluteTabHeight, CEGUI::TabControlProperties::TabHeight, CEGUI::StaticTextProperties::HorzScrollbar, CEGUI::StaticTextProperties::VertScrollbar, CEGUI::StaticTextProperties::VertFormatting, CEGUI::StaticTextProperties::HorzFormatting, CEGUI::StaticTextProperties::TextColours, CEGUI::StaticProperties::BottomFrameImage, CEGUI::StaticProperties::TopFrameImage, CEGUI::StaticProperties::RightFrameImage, CEGUI::StaticProperties::LeftFrameImage, CEGUI::StaticProperties::BottomRightFrameImage, CEGUI::StaticProperties::BottomLeftFrameImage, CEGUI::StaticProperties::TopRightFrameImage, CEGUI::StaticProperties::TopLeftFrameImage, CEGUI::StaticProperties::BackgroundImage, CEGUI::StaticProperties::BackgroundColours, CEGUI::StaticProperties::FrameColours, CEGUI::StaticProperties::BackgroundEnabled, CEGUI::StaticProperties::FrameEnabled, CEGUI::StaticImageProperties::VertFormatting, CEGUI::StaticImageProperties::HorzFormatting, CEGUI::StaticImageProperties::ImageColours, CEGUI::StaticImageProperties::Image, CEGUI::SpinnerProperties::TextInputMode, CEGUI::SpinnerProperties::MaximumValue, CEGUI::SpinnerProperties::MinimumValue, CEGUI::SpinnerProperties::StepSize, CEGUI::SpinnerProperties::CurrentValue, CEGUI::SliderProperties::ClickStepSize, CEGUI::SliderProperties::MaximumValue, CEGUI::SliderProperties::CurrentValue, CEGUI::ScrolledContainerProperties::ChildExtentsArea, CEGUI::ScrolledContainerProperties::ContentArea, CEGUI::ScrolledContainerProperties::ContentPaneAutoSized, CEGUI::ScrollbarProperties::ScrollPosition, CEGUI::ScrollbarProperties::OverlapSize, CEGUI::ScrollbarProperties::StepSize, CEGUI::ScrollbarProperties::PageSize, CEGUI::ScrollbarProperties::DocumentSize, CEGUI::ScrollablePaneProperties::VertScrollPosition, CEGUI::ScrollablePaneProperties::VertOverlapSize, CEGUI::ScrollablePaneProperties::VertStepSize, CEGUI::ScrollablePaneProperties::HorzScrollPosition, CEGUI::ScrollablePaneProperties::HorzOverlapSize, CEGUI::ScrollablePaneProperties::HorzStepSize, CEGUI::ScrollablePaneProperties::ForceHorzScrollbar, CEGUI::ScrollablePaneProperties::ForceVertScrollbar, CEGUI::ScrollablePaneProperties::ContentArea, CEGUI::ScrollablePaneProperties::ContentPaneAutoSized, CEGUI::RadioButtonProperties::GroupID, CEGUI::RadioButtonProperties::Selected, CEGUI::PushButtonProperties::TextXOffset, CEGUI::PushButtonProperties::UseStandardImagery, CEGUI::PushButtonProperties::DisabledImage, CEGUI::PushButtonProperties::HoverImage, CEGUI::PushButtonProperties::PushedImage, CEGUI::PushButtonProperties::NormalImage, CEGUI::ProgressBarProperties::StepSize, CEGUI::ProgressBarProperties::CurrentProgress, CEGUI::PopupMenuProperties::FadeOutTime, CEGUI::PopupMenuProperties::FadeInTime, CEGUI::MultiLineEditboxProperties::InactiveSelectionColour, CEGUI::MultiLineEditboxProperties::ActiveSelectionColour, CEGUI::MultiLineEditboxProperties::SelectedTextColour, CEGUI::MultiLineEditboxProperties::NormalTextColour, CEGUI::MultiLineEditboxProperties::MaxTextLength, CEGUI::MultiLineEditboxProperties::SelectionLength, CEGUI::MultiLineEditboxProperties::SelectionStart, CEGUI::MultiLineEditboxProperties::CaratIndex, CEGUI::MultiLineEditboxProperties::WordWrap, CEGUI::MultiLineEditboxProperties::ReadOnly, CEGUI::MultiColumnListProperties::RowCount, CEGUI::MultiColumnListProperties::ColumnHeader, CEGUI::MultiColumnListProperties::SelectionMode, CEGUI::MultiColumnListProperties::ForceHorzScrollbar, CEGUI::MultiColumnListProperties::ForceVertScrollbar, CEGUI::MultiColumnListProperties::NominatedSelectionRow, CEGUI::MultiColumnListProperties::NominatedSelectionColumnID, CEGUI::MultiColumnListProperties::SortColumnID, CEGUI::MultiColumnListProperties::SortDirection, CEGUI::MultiColumnListProperties::SortSettingEnabled, CEGUI::MultiColumnListProperties::ColumnsMovable, CEGUI::MultiColumnListProperties::ColumnsSizable, CEGUI::MenuItemProperties::DisabledTextColour, CEGUI::MenuItemProperties::NormalTextColour, CEGUI::MenuItemProperties::OpenedColour, CEGUI::MenuItemProperties::PushedColour, CEGUI::MenuItemProperties::HoverColour, CEGUI::MenuBaseProperties::AllowMultiplePopups, CEGUI::MenuBaseProperties::BackgroundColours, CEGUI::MenuBaseProperties::BorderWidth, CEGUI::MenuBaseProperties::VertPadding, CEGUI::MenuBaseProperties::HorzPadding, CEGUI::MenuBaseProperties::ItemSpacing, CEGUI::ListHeaderSegmentProperties::SortDirection, CEGUI::ListHeaderSegmentProperties::Dragable, CEGUI::ListHeaderSegmentProperties::Clickable, CEGUI::ListHeaderSegmentProperties::Sizable, CEGUI::ListHeaderProperties::SortColumnID, CEGUI::ListHeaderProperties::SortDirection, CEGUI::ListHeaderProperties::SortSettingEnabled, CEGUI::ListHeaderProperties::ColumnsMovable, CEGUI::ListHeaderProperties::ColumnsSizable, CEGUI::ListboxProperties::ItemTooltips, CEGUI::ListboxProperties::ForceHorzScrollbar, CEGUI::ListboxProperties::ForceVertScrollbar, CEGUI::ListboxProperties::MultiSelect, CEGUI::ListboxProperties::Sort, CEGUI::ItemListBaseProperties::AutoResizeEnabled, CEGUI::FrameWindowProperties::NESWSizingCursorImage, CEGUI::FrameWindowProperties::NWSESizingCursorImage, CEGUI::FrameWindowProperties::EWSizingCursorImage, CEGUI::FrameWindowProperties::NSSizingCursorImage, CEGUI::FrameWindowProperties::CaptionColour, CEGUI::FrameWindowProperties::TitlebarFont, CEGUI::FrameWindowProperties::SizingBorderThickness, CEGUI::FrameWindowProperties::DragMovingEnabled, CEGUI::FrameWindowProperties::RollUpState, CEGUI::FrameWindowProperties::RollUpEnabled, CEGUI::FrameWindowProperties::CloseButtonEnabled, CEGUI::FrameWindowProperties::TitlebarEnabled, CEGUI::FrameWindowProperties::FrameEnabled, CEGUI::FrameWindowProperties::SizingEnabled, CEGUI::EditboxProperties::InactiveSelectionColour, CEGUI::EditboxProperties::ActiveSelectionColour, CEGUI::EditboxProperties::SelectedTextColour, CEGUI::EditboxProperties::NormalTextColour, CEGUI::EditboxProperties::MaxTextLength, CEGUI::EditboxProperties::SelectionLength, CEGUI::EditboxProperties::SelectionStart, CEGUI::EditboxProperties::CaratIndex, CEGUI::EditboxProperties::ValidationString, CEGUI::EditboxProperties::MaskCodepoint, CEGUI::EditboxProperties::MaskText, CEGUI::EditboxProperties::ReadOnly, CEGUI::DragContainerProperties::DragCursorImage, CEGUI::DragContainerProperties::DragThreshold, CEGUI::DragContainerProperties::DragAlpha, CEGUI::DragContainerProperties::DraggingEnabled, CEGUI::ComboboxProperties::SingleClickMode, CEGUI::ComboboxProperties::ForceHorzScrollbar, CEGUI::ComboboxProperties::ForceVertScrollbar, CEGUI::ComboboxProperties::SortList, CEGUI::ComboboxProperties::InactiveEditSelectionColour, CEGUI::ComboboxProperties::ActiveEditSelectionColour, CEGUI::ComboboxProperties::SelectedEditTextColour, CEGUI::ComboboxProperties::NormalEditTextColour, CEGUI::ComboboxProperties::MaxEditTextLength, CEGUI::ComboboxProperties::EditSelectionLength, CEGUI::ComboboxProperties::EditSelectionStart, CEGUI::ComboboxProperties::CaratIndex, CEGUI::ComboboxProperties::ValidationString, CEGUI::ComboboxProperties::ReadOnly, CEGUI::CheckboxProperties::Selected, CEGUI::ButtonBaseProperties::DisabledTextColour, CEGUI::ButtonBaseProperties::PushedTextColour, CEGUI::ButtonBaseProperties::HoverTextColour, CEGUI::ButtonBaseProperties::NormalTextColour, CEGUI::WindowProperties::HorizontalAlignment, CEGUI::WindowProperties::VerticalAlignment, CEGUI::WindowProperties::RiseOnClick, CEGUI::WindowProperties::InheritsTooltipText, CEGUI::WindowProperties::Tooltip, CEGUI::WindowProperties::CustomTooltipType, CEGUI::WindowProperties::DistributeCapturedInputs, CEGUI::WindowProperties::AutoRepeatRate, CEGUI::WindowProperties::AutoRepeatDelay, CEGUI::WindowProperties::MouseButtonDownAutoRepeat, CEGUI::WindowProperties::WantsMultiClickEvents, CEGUI::WindowProperties::ZOrderChangeEnabled, CEGUI::WindowProperties::AbsoluteRect, CEGUI::WindowProperties::RelativeRect, CEGUI::WindowProperties::Rect, CEGUI::WindowProperties::AbsolutePosition, CEGUI::WindowProperties::RelativePosition, CEGUI::WindowProperties::Position, CEGUI::WindowProperties::AbsoluteYPosition, CEGUI::WindowProperties::RelativeYPosition, CEGUI::WindowProperties::YPosition, CEGUI::WindowProperties::AbsoluteXPosition, CEGUI::WindowProperties::RelativeXPosition, CEGUI::WindowProperties::XPosition, CEGUI::WindowProperties::AbsoluteSize, CEGUI::WindowProperties::RelativeSize, CEGUI::WindowProperties::Size, CEGUI::WindowProperties::AbsoluteHeight, CEGUI::WindowProperties::RelativeHeight, CEGUI::WindowProperties::Height, CEGUI::WindowProperties::AbsoluteWidth, CEGUI::WindowProperties::RelativeWidth, CEGUI::WindowProperties::Width, CEGUI::WindowProperties::DestroyedByParent, CEGUI::WindowProperties::RestoreOldCapture, CEGUI::WindowProperties::Visible, CEGUI::WindowProperties::Disabled, CEGUI::WindowProperties::AlwaysOnTop, CEGUI::WindowProperties::InheritsAlpha, CEGUI::WindowProperties::ClippedByParent, CEGUI::WindowProperties::MouseCursorImage, CEGUI::WindowProperties::Text, CEGUI::WindowProperties::Font, CEGUI::WindowProperties::Alpha, CEGUI::WindowProperties::ID, CEGUI::WindowProperties::MetricsMode, CEGUI::WindowProperties::AbsoluteMaxSize, CEGUI::WindowProperties::AbsoluteMinSize, CEGUI::WindowProperties::RelativeMaxSize, CEGUI::WindowProperties::RelativeMinSize, CEGUI::Property
  • setAbsoluteTabHeight() : CEGUI::TabControl
  • setAbsoluteTabTextPadding() : CEGUI::TabControl
  • setAllowMultiplePopups() : CEGUI::MenuBase
  • setAlpha() : CEGUI::Window, CEGUI::ColourRect
  • setAlwaysOnTop() : CEGUI::Window
  • setAntiAliased() : CEGUI::Font
  • setArea() : CEGUI::NamedArea
  • setAreaPropertySource() : CEGUI::ComponentArea
  • setAreaRect() : CEGUI::Window
  • setArmed() : CEGUI::ComboDropList
  • SetAttribute() : TiXmlElement
  • setAutoArmEnabled() : CEGUI::ComboDropList
  • setAutoDeleted() : CEGUI::ListboxItem
  • setAutoRepeatDelay() : CEGUI::Window
  • setAutoRepeatRate() : CEGUI::Window
  • setAutoResizeEnabled() : CEGUI::ItemListBase
  • setAutoScalingEnabled() : CEGUI::Imageset, CEGUI::Font
  • setBackgroundColours() : CEGUI::Static, CEGUI::MenuBase
  • setBackgroundEnabled() : CEGUI::Static
  • setBackgroundHorizontalFormatting() : CEGUI::FrameComponent
  • setBackgroundImage() : CEGUI::Static
  • setBackgroundVerticalFormatting() : CEGUI::FrameComponent
  • setBaseDimension() : CEGUI::Dimension
  • setBorderWidth() : CEGUI::MenuBase
  • setBottomAlpha() : CEGUI::ColourRect
  • setCaptionColour() : CEGUI::Titlebar, CEGUI::FrameWindow
  • setCaratIndex() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setClickable() : CEGUI::ListHeaderSegment
  • setClickStep() : CEGUI::Slider
  • setClippedByParent() : CEGUI::Window
  • setClippedToDisplay() : CEGUI::StateImagery
  • setCloseButtonEnabled() : CEGUI::FrameWindow
  • setColours() : CEGUI::FalagardComponentBase, CEGUI::ColourRect
  • setColoursPropertyIsColourRect() : CEGUI::FalagardComponentBase
  • setColoursPropertySource() : CEGUI::FalagardComponentBase
  • setColumnDraggingEnabled() : CEGUI::ListHeader
  • setColumnHeaderWidth() : CEGUI::MultiColumnList
  • setColumnPixelWidth() : CEGUI::ListHeader
  • setColumnSizingEnabled() : CEGUI::ListHeader
  • setComponentArea() : CEGUI::FalagardComponentBase
  • SetCondenseWhiteSpace() : TiXmlBase
  • setConstraintArea() : CEGUI::MouseCursor
  • setContentArea() : CEGUI::ScrolledContainer
  • setContentPaneArea() : CEGUI::ScrollablePane
  • setContentPaneAutoSized() : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • setCurrentValue() : CEGUI::Spinner, CEGUI::Slider
  • setCursorForPoint() : CEGUI::FrameWindow
  • setCustomImageryAutoSized() : CEGUI::PushButton
  • setD3DTextureSize() : CEGUI::DirectX9Texture, CEGUI::DirectX81Texture
  • setDefaultFont() : CEGUI::System
  • setDefaultMouseCursor() : CEGUI::System
  • setDefaultResourceGroup() : CEGUI::ResourceProvider
  • setDestroyedByParent() : CEGUI::Window
  • setDimensionOperator() : CEGUI::BaseDim
  • setDimensionType() : CEGUI::Dimension
  • setDisabled() : CEGUI::ListboxItem
  • setDisabledImage() : CEGUI::PushButton
  • setDisabledTextColour() : CEGUI::MenuItem, CEGUI::ButtonBase
  • setDisplaySize() : CEGUI::OpenGLRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer
  • setDisplayTime() : CEGUI::Tooltip
  • setDistributesCapturedInputs() : CEGUI::Window
  • setDocumentSize() : CEGUI::Scrollbar
  • SetDoubleAttribute() : TiXmlElement
  • SetDoubleValue() : TiXmlAttribute
  • setDragAlpha() : CEGUI::DragContainer
  • setDragCursorImage() : CEGUI::DragContainer
  • setDraggingEnabled() : CEGUI::Titlebar, CEGUI::DragContainer
  • setDragMovingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • setEnabled() : CEGUI::Window
  • setEWSizingCursorImage() : CEGUI::FrameWindow
  • setFadeInTime() : CEGUI::PopupMenu
  • setFadeOutTime() : CEGUI::PopupMenu
  • setFadeTime() : CEGUI::Tooltip
  • setFont() : CEGUI::TextComponent, CEGUI::ListboxTextItem, CEGUI::Window
  • setFormatting() : CEGUI::StaticText, CEGUI::StaticImage
  • setFrameColours() : CEGUI::Static
  • setFrameEnabled() : CEGUI::Static, CEGUI::FrameWindow
  • setFrameImages() : CEGUI::Static
  • setGroupID() : CEGUI::RadioButton
  • setGUISheet() : CEGUI::System
  • setHeight() : CEGUI::Window, CEGUI::Rect
  • setHorizontalAlignment() : CEGUI::Window
  • setHorizontalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • setHorizontalOverlapSize() : CEGUI::ScrollablePane
  • setHorizontalScrollbarEnabled() : CEGUI::StaticText
  • setHorizontalScrollPosition() : CEGUI::ScrollablePane
  • setHorizontalStepSize() : CEGUI::ScrollablePane
  • setHorzFormatting() : CEGUI::RenderableImage
  • setHorzFormattingPropertySource() : CEGUI::FalagardComponentBase
  • setHorzFree() : CEGUI::Thumb
  • setHorzPadding() : CEGUI::MenuBase
  • setHorzRange() : CEGUI::Thumb
  • setHotTracked() : CEGUI::Thumb
  • setHoverColour() : CEGUI::MenuItem
  • setHoverImage() : CEGUI::PushButton
  • setHoverTextColour() : CEGUI::ButtonBase
  • setHoverTime() : CEGUI::Tooltip
  • setID() : CEGUI::ListboxItem, CEGUI::Window
  • setImage() : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticImage, CEGUI::RenderableImage, CEGUI::MouseCursor
  • setImageColours() : CEGUI::StaticImage
  • setImageForFrameLocation() : CEGUI::Static
  • setImageForLocation() : CEGUI::RenderableFrame
  • setImagePropertySource() : CEGUI::ImageryComponent
  • setImages() : CEGUI::RenderableFrame
  • setInactiveSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setInheritsAlpha() : CEGUI::Window
  • setInheritsTooltipText() : CEGUI::Window
  • SetIntValue() : TiXmlAttribute
  • setItem() : CEGUI::MultiColumnList
  • setItemSelectState() : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • setItemSelectState_impl() : CEGUI::MultiColumnList
  • setItemSpacing() : CEGUI::MenuBase
  • setLeftAlpha() : CEGUI::ColourRect
  • setLogFilename() : CEGUI::Logger
  • setLoggingLevel() : CEGUI::Logger
  • setLookNFeel() : CEGUI::Window
  • setMaskCodePoint() : CEGUI::Editbox
  • setMasterColours() : CEGUI::ImagerySection
  • setMasterColoursPropertyIsColourRect() : CEGUI::ImagerySection
  • setMasterColoursPropertySource() : CEGUI::ImagerySection
  • setMaximumSize() : CEGUI::Window
  • setMaximumValue() : CEGUI::Spinner
  • setMaxTextLength() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setMaxValue() : CEGUI::Slider
  • setMetricsMode() : CEGUI::Window
  • setMinimumSize() : CEGUI::Window
  • setMinimumValue() : CEGUI::Spinner
  • setModalState() : CEGUI::Window
  • setModalTarget() : CEGUI::System
  • setMouseAutoRepeatEnabled() : CEGUI::Window
  • setMouseCursor() : CEGUI::Window
  • setMouseMoveScaling() : CEGUI::System
  • setMultiClickTimeout() : CEGUI::System
  • setMultiClickToleranceAreaSize() : CEGUI::System
  • setMultiselectEnabled() : CEGUI::Listbox
  • setMutedState() : CEGUI::EventSet
  • SetName() : TiXmlAttribute
  • setNativeResolution() : CEGUI::Imageset, CEGUI::Font
  • setNESWSizingCursorImage() : CEGUI::FrameWindow
  • setNominatedSelectionColumn() : CEGUI::MultiColumnList
  • setNominatedSelectionColumnID() : CEGUI::MultiColumnList
  • setNominatedSelectionRow() : CEGUI::MultiColumnList
  • setNormalImage() : CEGUI::PushButton
  • setNormalSelectBrushColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setNormalTextColour() : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox, CEGUI::Combobox, CEGUI::ButtonBase
  • setNSSizingCursorImage() : CEGUI::FrameWindow
  • setNWSESizingCursorImage() : CEGUI::FrameWindow
  • setOGLTextureSize() : CEGUI::OpenGLTexture
  • setOpenedColour() : CEGUI::MenuItem
  • setOperand() : CEGUI::BaseDim
  • setOverlapSize() : CEGUI::Scrollbar
  • setOverrideColours() : CEGUI::SectionSpecification
  • setOverrideColoursPropertyIsColourRect() : CEGUI::SectionSpecification
  • setOverrideColoursPropertySource() : CEGUI::SectionSpecification
  • setOwnerWindow() : CEGUI::ListboxItem
  • setPageSize() : CEGUI::Scrollbar
  • setParent() : CEGUI::Window
  • setPixelDragThreshold() : CEGUI::DragContainer
  • setPopupMenu() : CEGUI::MenuItem
  • setPosition() : CEGUI::Window, CEGUI::Rect, CEGUI::MouseCursor
  • setProgress() : CEGUI::ProgressBar
  • setProperty() : CEGUI::PropertySet
  • setPushedColour() : CEGUI::MenuItem
  • setPushedImage() : CEGUI::PushButton
  • setPushedTextColour() : CEGUI::ButtonBase
  • setQuadSplitMode() : CEGUI::RenderableImage
  • setQueueingEnabled() : CEGUI::OpenGLRenderer, CEGUI::IrrlichtRenderer, CEGUI::DirectX9Renderer, CEGUI::DirectX81Renderer, CEGUI::Renderer
  • setReadOnly() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setRect() : CEGUI::Window
  • setRelativeTabHeight() : CEGUI::TabControl
  • setRelativeTabTextPadding() : CEGUI::TabControl
  • setRestoreCapture() : CEGUI::Window
  • setRightAlpha() : CEGUI::ColourRect
  • setRightOfSelected() : CEGUI::TabButton
  • setRiseOnClickEnabled() : CEGUI::Window
  • setRollupEnabled() : CEGUI::FrameWindow
  • setRowID() : CEGUI::MultiColumnList
  • setScrollPosition() : CEGUI::Scrollbar
  • setSegmentOffset() : CEGUI::ListHeader
  • setSelected() : CEGUI::TabButton, CEGUI::RadioButton, CEGUI::ListboxItem, CEGUI::Checkbox
  • setSelectedTab() : CEGUI::TabControl
  • setSelectedTabAtIndex() : CEGUI::TabControl
  • setSelectedTextColour() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setSelectForItemsInColumn() : CEGUI::MultiColumnList
  • setSelectForItemsInRow() : CEGUI::MultiColumnList
  • setSelection() : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • setSelectionBrushImage() : CEGUI::ListboxItem
  • setSelectionColours() : CEGUI::ListboxItem
  • setSelectionMode() : CEGUI::MultiColumnList
  • setShowHorzScrollbar() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • setShowVertScrollbar() : CEGUI::ScrollablePane, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • setSingleClickEnabled() : CEGUI::Combobox
  • setSingleClickTimeout() : CEGUI::System
  • setSize() : CEGUI::Window, CEGUI::Rect
  • setSizingBorderThickness() : CEGUI::FrameWindow
  • setSizingEnabled() : CEGUI::ListHeaderSegment, CEGUI::FrameWindow
  • setSortColumn() : CEGUI::MultiColumnList, CEGUI::ListHeader
  • setSortColumnByID() : CEGUI::MultiColumnList
  • setSortColumnFromID() : CEGUI::ListHeader
  • setSortDirection() : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • setSortingEnabled() : CEGUI::ListHeader, CEGUI::Listbox, CEGUI::Combobox
  • setSortSegment() : CEGUI::ListHeader
  • setSourceDimension() : CEGUI::WidgetDim, CEGUI::ImageDim
  • setSourceImage() : CEGUI::ImageDim
  • setStandardImageryEnabled() : CEGUI::PushButton
  • setStepSize() : CEGUI::Spinner, CEGUI::Scrollbar, CEGUI::ProgressBar
  • setTabHeight() : CEGUI::TabControl
  • setTabIndex() : CEGUI::TabButton
  • SetTabSize() : TiXmlDocument
  • setTabTextPadding() : CEGUI::TabControl
  • setTargetWindow() : CEGUI::Tooltip, CEGUI::TabButton
  • setText() : CEGUI::TextComponent, CEGUI::ListboxItem, CEGUI::Window
  • setTextColour() : CEGUI::TextItem
  • setTextColours() : CEGUI::StaticText, CEGUI::ListboxTextItem
  • setTextFormatting() : CEGUI::TextItem
  • setTextInputMode() : CEGUI::Spinner
  • setTextMasked() : CEGUI::Editbox
  • setTexture() : CEGUI::Imageset
  • setTextXOffset() : CEGUI::TextItem, CEGUI::PushButton
  • setTitleBarEnabled() : CEGUI::FrameWindow
  • setTitlebarFont() : CEGUI::FrameWindow
  • setTooltip() : CEGUI::Window, CEGUI::System
  • setTooltipText() : CEGUI::Window
  • setTooltipType() : CEGUI::Window
  • setTopAlpha() : CEGUI::ColourRect
  • setUnifiedConstraintArea() : CEGUI::MouseCursor
  • setUserColumnDraggingEnabled() : CEGUI::MultiColumnList
  • setUserColumnSizingEnabled() : CEGUI::MultiColumnList
  • setUserData() : CEGUI::ListboxItem, CEGUI::Window
  • setUserSortControlEnabled() : CEGUI::MultiColumnList
  • setUserString() : CEGUI::Window
  • setUsingOverrideColours() : CEGUI::SectionSpecification
  • setValidationString() : CEGUI::Editbox, CEGUI::Combobox
  • SetValue() : TiXmlAttribute, TiXmlNode
  • setValue() : CEGUI::AbsoluteDim
  • setVertFormatting() : CEGUI::RenderableImage
  • setVertFormattingPropertySource() : CEGUI::FalagardComponentBase
  • setVertFree() : CEGUI::Thumb
  • setVerticalAlignment() : CEGUI::Window
  • setVerticalFormatting() : CEGUI::TextComponent, CEGUI::ImageryComponent, CEGUI::StaticText, CEGUI::StaticImage
  • setVerticalOverlapSize() : CEGUI::ScrollablePane
  • setVerticalScrollbarEnabled() : CEGUI::StaticText
  • setVerticalScrollPosition() : CEGUI::ScrollablePane
  • setVerticalStepSize() : CEGUI::ScrollablePane
  • setVertPadding() : CEGUI::MenuBase
  • setVertRange() : CEGUI::Thumb
  • setVisible() : CEGUI::Window
  • setWantsMultiClickEvents() : CEGUI::Window
  • setWidgetName() : CEGUI::WidgetDim
  • setWidth() : CEGUI::Window, CEGUI::Rect
  • setWindowArea() : CEGUI::Window
  • setWindowArea_impl() : CEGUI::Window
  • setWindowHeight() : CEGUI::Window
  • setWindowMaxSize() : CEGUI::Window
  • setWindowMinSize() : CEGUI::Window
  • setWindowPosition() : CEGUI::Window
  • setWindowSize() : CEGUI::Window
  • setWindowWidth() : CEGUI::Window
  • setWindowXPosition() : CEGUI::Window
  • setWindowYPosition() : CEGUI::Window
  • setWordWrapping() : CEGUI::MultiLineEditbox
  • setXPosition() : CEGUI::Window
  • setYPosition() : CEGUI::Window
  • setZOrderingEnabled() : CEGUI::Window
  • show() : CEGUI::Window, CEGUI::MouseCursor
  • showDropList() : CEGUI::Combobox
  • signalRedraw() : CEGUI::System
  • size() : CEGUI::String
  • sizeToContent() : CEGUI::ItemListBase
  • sizeToContent_impl() : CEGUI::ItemListBase
  • Slider() : CEGUI::Slider
  • Spinner() : CEGUI::Spinner
  • Standalone() : TiXmlDeclaration
  • StateImagery() : CEGUI::StateImagery
  • Static() : CEGUI::Static
  • StaticImage() : CEGUI::StaticImage
  • StaticText() : CEGUI::StaticText
  • step() : CEGUI::ProgressBar
  • String() : CEGUI::String
  • subscribe() : CEGUI::Event
  • subscribeEvent() : CEGUI::GlobalEventSet, CEGUI::EventSet
  • SubscriberTemplate() : CEGUI::SubscriberTemplate< Ret, Args >
  • subscribeScriptedEvent() : CEGUI::EventSet
  • substr() : CEGUI::String
  • swap() : CEGUI::String
  • System() : CEGUI::System
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- t -

  • TabButton() : CEGUI::TabButton
  • TabControl() : CEGUI::TabControl
  • TabPane() : CEGUI::TabPane
  • testClassName() : CEGUI::Window
  • testClassName_impl() : CEGUI::Tooltip, CEGUI::Titlebar, CEGUI::Thumb, CEGUI::TextItem, CEGUI::TabPane, CEGUI::TabControl, CEGUI::TabButton, CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::Spinner, CEGUI::Slider, CEGUI::ScrolledContainer, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::RadioButton, CEGUI::PushButton, CEGUI::ProgressBar, CEGUI::PopupMenu, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::MenuItem, CEGUI::MenuBase, CEGUI::Menubar, CEGUI::ListHeaderSegment, CEGUI::ListHeader, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::ItemEntry, CEGUI::GUISheet, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::Checkbox, CEGUI::ButtonBase, CEGUI::Window
  • Text() : TiXmlHandle
  • TextComponent() : CEGUI::TextComponent
  • TextItem() : CEGUI::TextItem
  • Texture() : CEGUI::Texture
  • Thumb() : CEGUI::Thumb
  • Titlebar() : CEGUI::Titlebar
  • TiXmlAttribute() : TiXmlAttribute
  • TiXmlComment() : TiXmlComment
  • TiXmlDeclaration() : TiXmlDeclaration
  • TiXmlDocument() : TiXmlDocument
  • TiXmlElement() : TiXmlElement
  • TiXmlHandle() : TiXmlHandle
  • TiXmlText() : TiXmlText
  • ToComment() : TiXmlNode
  • ToDeclaration() : TiXmlNode
  • ToDocument() : TiXmlNode
  • ToElement() : TiXmlNode
  • toEnd() : CEGUI::ConstBaseIterator< T >
  • togglePopupMenu() : CEGUI::MenuItem
  • toggleRollup() : CEGUI::FrameWindow
  • Tooltip() : CEGUI::Tooltip
  • toStart() : CEGUI::ConstBaseIterator< T >
  • ToText() : TiXmlNode
  • ToUnknown() : TiXmlNode
  • transcodeXmlCharToString() : CEGUI::XercesParser
  • trimLeadingChars() : CEGUI::TextUtils
  • trimTrailingChars() : CEGUI::TextUtils
  • Type() : TiXmlNode
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- u -

  • undefineAllImages() : CEGUI::Imageset
  • undefineImage() : CEGUI::Imageset
  • UnifiedDim() : CEGUI::UnifiedDim
  • unifiedToAbsolute() : CEGUI::Window
  • unifiedToAbsoluteX() : CEGUI::Window
  • unifiedToAbsoluteY() : CEGUI::Window
  • unifiedToRelative() : CEGUI::Window
  • unifiedToRelativeX() : CEGUI::Window
  • unifiedToRelativeY() : CEGUI::Window
  • Unknown() : TiXmlHandle
  • unload() : CEGUI::Imageset
  • unloadAllSchemes() : CEGUI::SchemeManager
  • unloadRawDataContainer() : CEGUI::ResourceProvider
  • unloadResources() : CEGUI::Scheme
  • unloadScheme() : CEGUI::SchemeManager
  • update() : CEGUI::Window
  • updateActiveMouseCursor() : CEGUI::DragContainer
  • updateContainerPosition() : CEGUI::ScrollablePane
  • updateImageScalingFactors() : CEGUI::Imageset
  • updateInternalState() : CEGUI::MenuItem, CEGUI::ButtonBase
  • updateRenderableFrameColours() : CEGUI::Static
  • updateRenderableImageColours() : CEGUI::StaticImage
  • updateSelf() : CEGUI::Tooltip, CEGUI::PopupMenu, CEGUI::Window
  • updateThumb() : CEGUI::Slider, CEGUI::Scrollbar
  • utf8_stream_len() : CEGUI::String
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- v -

  • Value() : TiXmlAttribute, TiXmlNode
  • Version() : TiXmlDeclaration
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- w -

  • wantsMultiClickEvents() : CEGUI::Window
  • WidgetDim() : CEGUI::WidgetDim
  • WidgetLookManager() : CEGUI::WidgetLookManager
  • Window() : CEGUI::Window
  • WindowFactoryManager() : CEGUI::WindowFactoryManager
  • WindowManager() : CEGUI::WindowManager
  • windowToScreen() : CEGUI::Window
  • windowToScreenX() : CEGUI::Window
  • windowToScreenY() : CEGUI::Window
  • writeColoursXML() : CEGUI::FalagardComponentBase
  • writeFalagardXMLHeadToStream() : CEGUI::WidgetLookManager
  • writeFalagardXMLTailToStream() : CEGUI::WidgetLookManager
  • writeFontToStream() : CEGUI::FontManager
  • writeHorzFormatXML() : CEGUI::FalagardComponentBase
  • writeImagesetToStream() : CEGUI::ImagesetManager
  • writeVertFormatXML() : CEGUI::FalagardComponentBase
  • writeWidgetLookSeriesToStream() : CEGUI::WidgetLookManager
  • writeWidgetLookToStream() : CEGUI::WidgetLookManager
  • writeWindowLayoutToStream() : CEGUI::WindowManager
  • writeXMLElementAttributes_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • writeXMLElementName_impl() : CEGUI::PropertyDim, CEGUI::FontDim, CEGUI::UnifiedDim, CEGUI::WidgetDim, CEGUI::ImageDim, CEGUI::AbsoluteDim, CEGUI::BaseDim
  • writeXMLToStream() : CEGUI::WidgetLookFeel, CEGUI::WidgetComponent, CEGUI::TextComponent, CEGUI::StateImagery, CEGUI::SectionSpecification, CEGUI::PropertyInitialiser, CEGUI::PropertyDefinition, CEGUI::NamedArea, CEGUI::LayerSpecification, CEGUI::ImagerySection, CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::ComponentArea, CEGUI::Dimension, CEGUI::BaseDim, CEGUI::Window, CEGUI::Property, CEGUI::Imageset, CEGUI::Image
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~

- x -

  • XMLAttributes() : CEGUI::XMLAttributes
  • XMLParser() : CEGUI::XMLParser
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • const_pointer : CEGUI::String
  • const_reference : CEGUI::String
  • const_reverse_iterator : CEGUI::String
  • difference_type : CEGUI::String
  • ImageIterator : CEGUI::Imageset
  • LineList : CEGUI::MultiLineEditbox
  • pointer : CEGUI::String
  • PropertyCallback : CEGUI::WindowManager
  • reference : CEGUI::String
  • reverse_iterator : CEGUI::String
  • size_type : CEGUI::String
  • value_type : CEGUI::String
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- b -

  • button : CEGUI::MouseEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- m -

  • MinimumSegmentPixelWidth : CEGUI::ListHeader
  • mouseCursor : CEGUI::MouseCursorEventArgs
  • moveDelta : CEGUI::MouseEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- n -

  • npos : CEGUI::String
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- o -

  • OctalValidator : CEGUI::Spinner
  • otherWindow : CEGUI::ActivationEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- c -

  • clickCount : CEGUI::MouseEventArgs
  • codepoint : CEGUI::KeyEventArgs
  • column : CEGUI::MCLGridRef
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- d -

  • d_abs_tabHeight : CEGUI::TabControl
  • d_abs_tabPadding : CEGUI::TabControl
  • d_active : CEGUI::Window
  • d_allowClicks : CEGUI::ListHeaderSegment
  • d_allowMultiplePopups : CEGUI::MenuBase
  • d_alpha : CEGUI::Window
  • d_alwaysOnTop : CEGUI::Window
  • d_area : CEGUI::FalagardComponentBase, CEGUI::Window
  • d_armed : CEGUI::ComboDropList
  • d_autoArm : CEGUI::ComboDropList
  • d_autoDelete : CEGUI::ListboxItem
  • d_autoRepeat : CEGUI::Window
  • d_autoScale : CEGUI::Imageset
  • d_autoscaleImages : CEGUI::PushButton
  • d_autosizePane : CEGUI::ScrolledContainer
  • d_background : CEGUI::Static
  • d_backgroundColours : CEGUI::MenuBase
  • d_backgroundCols : CEGUI::Static
  • d_backgroundEnabled : CEGUI::Static
  • d_beingDragged : CEGUI::Thumb
  • d_beingSized : CEGUI::FrameWindow
  • d_borderSize : CEGUI::FrameWindow
  • d_borderWidth : CEGUI::MenuBase
  • d_bottom : CEGUI::RenderableFrame
  • d_bottom_height : CEGUI::Static
  • d_bottom_or_height : CEGUI::ComponentArea
  • d_bottomleft : CEGUI::RenderableFrame
  • d_bottomright : CEGUI::RenderableFrame
  • d_button : CEGUI::Combobox
  • d_cache : CEGUI::Logger
  • d_caching : CEGUI::Logger
  • d_captionColour : CEGUI::Titlebar
  • d_captureWindow : CEGUI::Window
  • d_caratPos : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_children : CEGUI::Window
  • d_click_area : CEGUI::MouseClickTracker
  • d_click_count : CEGUI::MouseClickTracker
  • d_clippedByParent : CEGUI::Window
  • d_closeButton : CEGUI::FrameWindow
  • d_colourPropertyName : CEGUI::FalagardComponentBase
  • d_colourProperyIsRect : CEGUI::FalagardComponentBase
  • d_colours : CEGUI::FalagardComponentBase
  • d_container : CEGUI::ScrollablePane
  • d_contentArea : CEGUI::ScrolledContainer
  • d_contentRect : CEGUI::ScrollablePane
  • d_currentValue : CEGUI::Spinner
  • d_customTip : CEGUI::Window
  • d_decrease : CEGUI::Scrollbar
  • d_decreaseButton : CEGUI::Spinner
  • d_default : CEGUI::Property
  • d_defaultResourceGroup : CEGUI::ResourceProvider
  • d_destroyedByParent : CEGUI::Window
  • d_disabled : CEGUI::ListboxItem
  • d_disabledColour : CEGUI::ButtonBase
  • d_disabledImage : CEGUI::PushButton
  • d_disabledTextColour : CEGUI::MenuItem
  • d_displayTime : CEGUI::Tooltip
  • d_distCapturedInputs : CEGUI::Window
  • d_documentSize : CEGUI::Scrollbar
  • d_dragAlpha : CEGUI::DragContainer
  • d_dragAnchorIdx : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_dragCursorImage : CEGUI::DragContainer
  • d_dragEnabled : CEGUI::Titlebar
  • d_dragging : CEGUI::Titlebar, CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::DragContainer
  • d_draggingEnabled : CEGUI::DragContainer
  • d_dragMovable : CEGUI::FrameWindow
  • d_dragMoving : CEGUI::ListHeaderSegment
  • d_dragPoint : CEGUI::Titlebar, CEGUI::Thumb, CEGUI::ListHeaderSegment, CEGUI::FrameWindow, CEGUI::DragContainer
  • d_dragPosition : CEGUI::ListHeaderSegment
  • d_dragSizing : CEGUI::ListHeaderSegment
  • d_dragThreshold : CEGUI::DragContainer
  • d_drawList : CEGUI::Window
  • d_droplist : CEGUI::Combobox
  • d_dropTarget : CEGUI::DragContainer
  • d_editbox : CEGUI::Spinner, CEGUI::Combobox
  • d_elapsed : CEGUI::Tooltip
  • d_enabled : CEGUI::Window
  • d_enableHorzScrollbar : CEGUI::StaticText
  • d_enableVertScrollbar : CEGUI::StaticText
  • d_eventConnections : CEGUI::ScrolledContainer
  • d_ewSizingCursor : CEGUI::FrameWindow
  • d_extent : CEGUI::MultiLineEditbox::LineInfo
  • d_fadeElapsed : CEGUI::PopupMenu
  • d_fadeInTime : CEGUI::PopupMenu
  • d_fadeOutTime : CEGUI::PopupMenu
  • d_fadeTime : CEGUI::Tooltip
  • d_fading : CEGUI::PopupMenu
  • d_fadingOut : CEGUI::PopupMenu
  • d_falagardType : CEGUI::Window
  • d_font : CEGUI::ListboxTextItem, CEGUI::Window
  • d_forceHorzScroll : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_forceVertScroll : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_frame : CEGUI::Static
  • d_frameCols : CEGUI::Static
  • d_frameEnabled : CEGUI::Static, CEGUI::FrameWindow
  • d_frameImages : CEGUI::FrameComponent
  • d_fullColSelect : CEGUI::MultiColumnList
  • d_fullRowSelect : CEGUI::MultiColumnList
  • d_grid : CEGUI::MultiColumnList
  • d_header : CEGUI::MultiColumnList
  • d_help : CEGUI::Property
  • d_horzAlign : CEGUI::Window
  • d_horzFormat : CEGUI::RenderableImage
  • d_horzFormatPropertyName : CEGUI::FalagardComponentBase
  • d_horzFormatting : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticText
  • d_horzFree : CEGUI::Thumb
  • d_horzMax : CEGUI::Thumb
  • d_horzOverlap : CEGUI::ScrollablePane
  • d_horzPadding : CEGUI::MenuBase
  • d_horzScaling : CEGUI::Imageset
  • d_horzScrollbar : CEGUI::StaticText, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_horzStep : CEGUI::ScrollablePane
  • d_hotTrack : CEGUI::Thumb
  • d_hoverColour : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_hoverImage : CEGUI::PushButton
  • d_hovering : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_hoverTime : CEGUI::Tooltip
  • d_ID : CEGUI::Window
  • d_identifierString : CEGUI::XMLParser, CEGUI::ScriptModule, CEGUI::Renderer
  • d_image : CEGUI::ImageryComponent, CEGUI::StaticImage, CEGUI::RenderableImage
  • d_imageCols : CEGUI::StaticImage
  • d_imagePropertyName : CEGUI::ImageryComponent
  • d_images : CEGUI::Imageset
  • d_inactiveSelectBrushColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_increase : CEGUI::Scrollbar
  • d_increaseButton : CEGUI::Spinner
  • d_inheritsAlpha : CEGUI::Window
  • d_inheritsTipText : CEGUI::Window
  • d_inputMode : CEGUI::Spinner
  • d_itemData : CEGUI::ListboxItem
  • d_itemID : CEGUI::ListboxItem
  • d_itemSpacing : CEGUI::MenuBase
  • d_itemText : CEGUI::ListboxItem
  • d_itemTooltips : CEGUI::Listbox
  • d_lastSelected : CEGUI::MultiColumnList, CEGUI::Listbox
  • d_left : CEGUI::ComponentArea, CEGUI::RenderableFrame
  • d_left_width : CEGUI::Static
  • d_leftMouseDown : CEGUI::DragContainer
  • d_length : CEGUI::MultiLineEditbox::LineInfo
  • d_level : CEGUI::Logger
  • d_lineBreakChars : CEGUI::MultiLineEditbox
  • d_lines : CEGUI::MultiLineEditbox
  • d_listItems : CEGUI::Listbox, CEGUI::ItemListBase
  • d_lookName : CEGUI::Window
  • d_maskCodePoint : CEGUI::Editbox
  • d_maskText : CEGUI::Editbox
  • d_maxSize : CEGUI::Window
  • d_maxTextLen : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_maxValue : CEGUI::Spinner, CEGUI::Slider
  • d_metricsMode : CEGUI::Window
  • d_minSize : CEGUI::Window
  • d_minValue : CEGUI::Spinner
  • d_mouseCursor : CEGUI::Window
  • d_movingEnabled : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • d_movingMouseCursor : CEGUI::ListHeaderSegment
  • d_multiselect : CEGUI::Listbox
  • d_multiSelect : CEGUI::MultiColumnList
  • d_muted : CEGUI::EventSet
  • d_name : CEGUI::Window, CEGUI::Property, CEGUI::Imageset
  • d_nativeHorzRes : CEGUI::Imageset
  • d_nativeVertRes : CEGUI::Imageset
  • d_needsRedraw : CEGUI::Window
  • d_neswSizingCursor : CEGUI::FrameWindow
  • d_newIdx : CEGUI::HeaderSequenceEventArgs
  • d_nextTabIndex : CEGUI::TabControl
  • d_nominatedSelectCol : CEGUI::MultiColumnList
  • d_nominatedSelectRow : CEGUI::MultiColumnList
  • d_normalColour : CEGUI::ButtonBase
  • d_normalImage : CEGUI::PushButton
  • d_normalTextColour : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox
  • d_nsSizingCursor : CEGUI::FrameWindow
  • d_nwseSizingCursor : CEGUI::FrameWindow
  • d_oldCapture : CEGUI::Window
  • d_oldCursorArea : CEGUI::Titlebar
  • d_oldIdx : CEGUI::HeaderSequenceEventArgs
  • d_opened : CEGUI::MenuItem
  • d_openedColour : CEGUI::MenuItem
  • d_origAlpha : CEGUI::PopupMenu
  • d_ostream : CEGUI::Logger
  • d_overlapSize : CEGUI::Scrollbar
  • d_owner : CEGUI::ListboxItem
  • d_pageSize : CEGUI::Scrollbar
  • d_parent : CEGUI::Window
  • d_pixelSize : CEGUI::Window
  • d_popup : CEGUI::MenuItem, CEGUI::MenuBase
  • d_popupWasClosed : CEGUI::MenuItem
  • d_position : CEGUI::Scrollbar
  • d_progress : CEGUI::ProgressBar
  • d_pushed : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_pushedColour : CEGUI::MenuItem, CEGUI::ButtonBase
  • d_pushedImage : CEGUI::PushButton
  • d_quadSplitMode : CEGUI::RenderableImage
  • d_readOnly : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_rel_tabHeight : CEGUI::TabControl
  • d_rel_tabPadding : CEGUI::TabControl
  • d_renderCache : CEGUI::Window
  • d_repeatButton : CEGUI::Window
  • d_repeatDelay : CEGUI::Window
  • d_repeatElapsed : CEGUI::Window
  • d_repeating : CEGUI::Window
  • d_repeatRate : CEGUI::Window
  • d_resourceProvider : CEGUI::Renderer
  • d_restoreOldCapture : CEGUI::Window
  • d_right : CEGUI::RenderableFrame
  • d_right_or_width : CEGUI::ComponentArea
  • d_right_width : CEGUI::Static
  • d_rightOfSelected : CEGUI::TabButton
  • d_riseOnClick : CEGUI::Window
  • d_rolledup : CEGUI::FrameWindow
  • d_rollupEnabled : CEGUI::FrameWindow
  • d_segmentHover : CEGUI::ListHeaderSegment
  • d_segmentOffset : CEGUI::ListHeader
  • d_segmentPushed : CEGUI::ListHeaderSegment
  • d_segments : CEGUI::ListHeader
  • d_selectBrush : CEGUI::ListboxItem
  • d_selectBrushColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_selectCols : CEGUI::ListboxItem
  • d_selected : CEGUI::TabButton, CEGUI::ListboxItem, CEGUI::Checkbox
  • d_selectionBrush : CEGUI::MultiLineEditbox
  • d_selectionEnd : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_selectionStart : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_selectMode : CEGUI::MultiColumnList
  • d_selectTextColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • d_singleClickOperation : CEGUI::Combobox
  • d_sizingEnabled : CEGUI::ListHeaderSegment, CEGUI::ListHeader, CEGUI::FrameWindow
  • d_sizingMouseCursor : CEGUI::ListHeaderSegment
  • d_sortDir : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • d_sorted : CEGUI::Listbox
  • d_sortingEnabled : CEGUI::ListHeader
  • d_sortSegment : CEGUI::ListHeader
  • d_splitterHover : CEGUI::ListHeaderSegment
  • d_splitterSize : CEGUI::ListHeaderSegment
  • d_startIdx : CEGUI::MultiLineEditbox::LineInfo
  • d_startPosition : CEGUI::DragContainer
  • d_state : CEGUI::Tooltip
  • d_step : CEGUI::Slider, CEGUI::ProgressBar
  • d_stepSize : CEGUI::Spinner, CEGUI::Scrollbar
  • d_storedAlpha : CEGUI::DragContainer
  • d_storedClipState : CEGUI::DragContainer
  • d_tabButtonIndexMap : CEGUI::TabControl
  • d_tabButtonPane : CEGUI::TabControl
  • d_tabContentPane : CEGUI::TabControl
  • d_tabIndex : CEGUI::TabButton
  • d_target : CEGUI::Tooltip
  • d_target_window : CEGUI::MouseClickTracker
  • d_targetWindow : CEGUI::TabButton
  • d_text : CEGUI::Window
  • d_textColour : CEGUI::TextItem
  • d_textCols : CEGUI::StaticText, CEGUI::ListboxTextItem
  • d_textFormatting : CEGUI::TextItem
  • d_texture : CEGUI::Imageset
  • d_textureFilename : CEGUI::Imageset
  • d_textXOffset : CEGUI::TextItem, CEGUI::PushButton
  • d_thumb : CEGUI::Slider, CEGUI::Scrollbar
  • d_timer : CEGUI::MouseClickTracker
  • d_titlebar : CEGUI::FrameWindow
  • d_tooltipText : CEGUI::ListboxItem, CEGUI::Window
  • d_top : CEGUI::ComponentArea, CEGUI::RenderableFrame
  • d_top_height : CEGUI::Static
  • d_topleft : CEGUI::RenderableFrame
  • d_topright : CEGUI::RenderableFrame
  • d_type : CEGUI::WindowFactory, CEGUI::Window
  • d_uniqueIDNumber : CEGUI::ListHeader
  • d_useDisabledImage : CEGUI::PushButton
  • d_useHoverImage : CEGUI::PushButton
  • d_useNominatedCol : CEGUI::MultiColumnList
  • d_useNominatedRow : CEGUI::MultiColumnList
  • d_useNormalImage : CEGUI::PushButton
  • d_usePushedImage : CEGUI::PushButton
  • d_userData : CEGUI::Window
  • d_userStrings : CEGUI::Window
  • d_useStandardImagery : CEGUI::PushButton
  • d_validationString : CEGUI::Editbox
  • d_validator : CEGUI::Editbox
  • d_value : CEGUI::Slider
  • d_vertAlign : CEGUI::Window
  • d_vertFormat : CEGUI::RenderableImage
  • d_vertFormatPropertyName : CEGUI::FalagardComponentBase
  • d_vertFormatting : CEGUI::ImageryComponent, CEGUI::FrameComponent, CEGUI::StaticText
  • d_vertFree : CEGUI::Thumb
  • d_vertMax : CEGUI::Thumb
  • d_vertOverlap : CEGUI::ScrollablePane
  • d_vertPadding : CEGUI::MenuBase
  • d_vertScaling : CEGUI::Imageset
  • d_vertScrollbar : CEGUI::StaticText, CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox
  • d_vertStep : CEGUI::ScrollablePane
  • d_visible : CEGUI::Window
  • d_wantsMultiClicks : CEGUI::Window
  • d_weOwnTip : CEGUI::Window
  • d_widestExtent : CEGUI::MultiLineEditbox
  • d_wordWrap : CEGUI::MultiLineEditbox
  • d_workstream : CEGUI::Logger
  • d_writeXML : CEGUI::Property
  • d_zOrderingEnabled : CEGUI::Window
  • DefaultAlphanumerical : CEGUI::TextUtils
  • DefaultBackgroundColour : CEGUI::MenuBase
  • DefaultColour : CEGUI::Font
  • DefaultDisabledLabelColour : CEGUI::ButtonBase
  • DefaultDisabledTextColour : CEGUI::MenuItem
  • DefaultHoverColour : CEGUI::MenuItem
  • DefaultHoverLabelColour : CEGUI::ButtonBase
  • DefaultInactiveSelectionColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • DefaultMultiClickAreaSize : CEGUI::System
  • DefaultMultiClickTimeout : CEGUI::System
  • DefaultNormalLabelColour : CEGUI::ButtonBase
  • DefaultNormalSelectionColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • DefaultNormalTextColour : CEGUI::MultiLineEditbox, CEGUI::MenuItem, CEGUI::Editbox
  • DefaultOpenedColour : CEGUI::MenuItem
  • DefaultPushedColour : CEGUI::MenuItem
  • DefaultPushedLabelColour : CEGUI::ButtonBase
  • DefaultSelectedTextColour : CEGUI::MultiLineEditbox, CEGUI::Editbox
  • DefaultSelectionColour : CEGUI::ListboxItem
  • DefaultSingleClickTimeout : CEGUI::System
  • DefaultSizingArea : CEGUI::ListHeaderSegment
  • DefaultSizingBorderSize : CEGUI::FrameWindow
  • DefaultTextColour : CEGUI::TextItem, CEGUI::ListboxTextItem
  • DefaultWhitespace : CEGUI::TextUtils
  • DefaultWrapDelimiters : CEGUI::TextUtils
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- e -

  • EventActivated : CEGUI::Window
  • EventAlphaChanged : CEGUI::Window
  • EventAlwaysOnTopChanged : CEGUI::Window
  • EventAutoSizeSettingChanged : CEGUI::ScrolledContainer, CEGUI::ScrollablePane
  • EventCaratMoved : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventCharacterKey : CEGUI::Window
  • EventCheckStateChanged : CEGUI::Checkbox
  • EventChildAdded : CEGUI::Window
  • EventChildRemoved : CEGUI::Window
  • EventClickableSettingChanged : CEGUI::ListHeaderSegment
  • EventClicked : CEGUI::TabButton, CEGUI::PushButton, CEGUI::MenuItem
  • EventClippedByParentChanged : CEGUI::Window
  • EventCloseClicked : CEGUI::FrameWindow
  • EventContentChanged : CEGUI::ScrolledContainer
  • EventContentPaneChanged : CEGUI::ScrollablePane
  • EventContentPaneScrolled : CEGUI::ScrollablePane
  • EventDeactivated : CEGUI::Window
  • EventDefaultFontChanged : CEGUI::System
  • EventDefaultMouseCursorChanged : CEGUI::System
  • EventDestroyedByParentChanged : CEGUI::Window
  • EventDestructionStarted : CEGUI::Window
  • EventDisabled : CEGUI::Window
  • EventDisplaySizeChanged : CEGUI::Renderer
  • EventDisplayTimeChanged : CEGUI::Tooltip
  • EventDragAlphaChanged : CEGUI::DragContainer
  • EventDragDropItemDropped : CEGUI::Window
  • EventDragDropItemEnters : CEGUI::Window
  • EventDragDropItemLeaves : CEGUI::Window
  • EventDragDropTargetChanged : CEGUI::DragContainer
  • EventDragEnabledChanged : CEGUI::DragContainer
  • EventDragEnded : CEGUI::DragContainer
  • EventDragMouseCursorChanged : CEGUI::DragContainer
  • EventDragMoveSettingChanged : CEGUI::ListHeader
  • EventDragPositionChanged : CEGUI::DragContainer
  • EventDragSizeSettingChanged : CEGUI::ListHeader
  • EventDragStarted : CEGUI::DragContainer
  • EventDragThresholdChanged : CEGUI::DragContainer
  • EventDropListDisplayed : CEGUI::Combobox
  • EventDropListRemoved : CEGUI::Combobox
  • EventEditboxFull : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventEnabled : CEGUI::Window
  • EventFadeTimeChanged : CEGUI::Tooltip
  • EventFontChanged : CEGUI::Window
  • EventGUISheetChanged : CEGUI::System
  • EventHidden : CEGUI::Window
  • EventHorizontalAlignmentChanged : CEGUI::Window
  • EventHorzScrollbarModeChanged : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • EventHoverTimeChanged : CEGUI::Tooltip
  • EventIDChanged : CEGUI::Window
  • EventImageChanged : CEGUI::MouseCursor
  • EventInheritsAlphaChanged : CEGUI::Window
  • EventInputCaptureGained : CEGUI::Window
  • EventInputCaptureLost : CEGUI::Window
  • EventInvalidEntryAttempted : CEGUI::Editbox, CEGUI::Combobox
  • EventKeyDown : CEGUI::Window
  • EventKeyUp : CEGUI::Window
  • EventListColumnMoved : CEGUI::MultiColumnList
  • EventListColumnSized : CEGUI::MultiColumnList
  • EventListContentsChanged : CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::Combobox
  • EventListSelectionAccepted : CEGUI::ComboDropList, CEGUI::Combobox
  • EventListSelectionChanged : CEGUI::Combobox
  • EventMaskCodePointChanged : CEGUI::Editbox
  • EventMaskedRenderingModeChanged : CEGUI::Editbox
  • EventMaximumTextLengthChanged : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventMaximumValueChanged : CEGUI::Spinner
  • EventMetricsModeChanged : CEGUI::Window
  • EventMinimumValueChanged : CEGUI::Spinner
  • EventMouseButtonDown : CEGUI::Window
  • EventMouseButtonUp : CEGUI::Window
  • EventMouseClick : CEGUI::Window
  • EventMouseDoubleClick : CEGUI::Window
  • EventMouseEnters : CEGUI::Window
  • EventMouseLeaves : CEGUI::Window
  • EventMouseMove : CEGUI::Window
  • EventMouseMoveScalingChanged : CEGUI::System
  • EventMouseTripleClick : CEGUI::Window
  • EventMouseWheel : CEGUI::Window
  • EventMovableSettingChanged : CEGUI::ListHeaderSegment
  • EventMoved : CEGUI::Window
  • EventMultiClickAreaSizeChanged : CEGUI::System
  • EventMultiClickTimeoutChanged : CEGUI::System
  • EventMultiselectModeChanged : CEGUI::Listbox
  • EventNamespace : CEGUI::Tooltip, CEGUI::Titlebar, CEGUI::Thumb, CEGUI::TabControl, CEGUI::TabButton, CEGUI::StaticText, CEGUI::StaticImage, CEGUI::Static, CEGUI::Spinner, CEGUI::Slider, CEGUI::ScrolledContainer, CEGUI::Scrollbar, CEGUI::ScrollablePane, CEGUI::RadioButton, CEGUI::PushButton, CEGUI::ProgressBar, CEGUI::PopupMenu, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::MenuItem, CEGUI::MenuBase, CEGUI::Menubar, CEGUI::ListHeaderSegment, CEGUI::ListHeader, CEGUI::Listbox, CEGUI::ItemListBase, CEGUI::FrameWindow, CEGUI::Editbox, CEGUI::DragContainer, CEGUI::ComboDropList, CEGUI::Combobox, CEGUI::Checkbox, CEGUI::Window, CEGUI::System, CEGUI::Renderer, CEGUI::MouseCursor
  • EventNominatedSelectColumnChanged : CEGUI::MultiColumnList
  • EventNominatedSelectRowChanged : CEGUI::MultiColumnList
  • EventParentSized : CEGUI::Window
  • EventPopupClosed : CEGUI::MenuBase
  • EventPopupOpened : CEGUI::MenuBase
  • EventProgressChanged : CEGUI::ProgressBar
  • EventProgressDone : CEGUI::ProgressBar
  • EventReadOnlyModeChanged : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventRenderingEnded : CEGUI::Window
  • EventRenderingStarted : CEGUI::Window
  • EventRollupToggled : CEGUI::FrameWindow
  • EventScrollConfigChanged : CEGUI::Scrollbar
  • EventScrollPositionChanged : CEGUI::Scrollbar
  • EventSegmentAdded : CEGUI::ListHeader
  • EventSegmentClicked : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventSegmentDragPositionChanged : CEGUI::ListHeaderSegment
  • EventSegmentDragStart : CEGUI::ListHeaderSegment
  • EventSegmentDragStop : CEGUI::ListHeaderSegment
  • EventSegmentRemoved : CEGUI::ListHeader
  • EventSegmentRenderOffsetChanged : CEGUI::ListHeader
  • EventSegmentSequenceChanged : CEGUI::ListHeader
  • EventSegmentSized : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventSelectionChanged : CEGUI::TabControl, CEGUI::MultiColumnList, CEGUI::Listbox
  • EventSelectionModeChanged : CEGUI::MultiColumnList
  • EventSelectStateChanged : CEGUI::RadioButton
  • EventShown : CEGUI::Window
  • EventSingleClickTimeoutChanged : CEGUI::System
  • EventSized : CEGUI::Window
  • EventSizingSettingChanged : CEGUI::ListHeaderSegment
  • EventSortColumnChanged : CEGUI::MultiColumnList, CEGUI::ListHeader
  • EventSortDirectionChanged : CEGUI::MultiColumnList, CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventSortModeChanged : CEGUI::Listbox, CEGUI::Combobox
  • EventSortSettingChanged : CEGUI::ListHeader
  • EventSplitterDoubleClicked : CEGUI::ListHeaderSegment, CEGUI::ListHeader
  • EventStepChanged : CEGUI::Spinner
  • EventTextAccepted : CEGUI::Editbox, CEGUI::Combobox
  • EventTextChanged : CEGUI::Window
  • EventTextInputModeChanged : CEGUI::Spinner
  • EventTextInvalidated : CEGUI::Editbox, CEGUI::Combobox
  • EventTextSelectionChanged : CEGUI::MultiLineEditbox, CEGUI::Editbox, CEGUI::Combobox
  • EventThumbPositionChanged : CEGUI::Thumb
  • EventThumbTrackEnded : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • EventThumbTrackStarted : CEGUI::Thumb, CEGUI::Slider, CEGUI::Scrollbar
  • EventTooltipActive : CEGUI::Tooltip
  • EventTooltipInactive : CEGUI::Tooltip
  • EventValidationStringChanged : CEGUI::Editbox, CEGUI::Combobox
  • EventValueChanged : CEGUI::Spinner, CEGUI::Slider
  • EventVerticalAlignmentChanged : CEGUI::Window
  • EventVertScrollbarModeChanged : CEGUI::ScrollablePane, CEGUI::MultiLineEditbox, CEGUI::MultiColumnList, CEGUI::Listbox, CEGUI::Combobox
  • EventWordWrapModeChanged : CEGUI::MultiLineEditbox
  • EventZOrderChanged : CEGUI::Window
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- f -

  • FloatValidator : CEGUI::Spinner
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- g -

  • GeneratedWindowNameBase : CEGUI::WindowManager
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- h -

  • handled : CEGUI::EventArgs
  • HexValidator : CEGUI::Spinner
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- i -

  • image : CEGUI::MouseCursorEventArgs
  • ImagesetSchemaName : CEGUI::Imageset
  • IntegerValidator : CEGUI::Spinner
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- p -

  • position : CEGUI::MouseEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- r -

  • row : CEGUI::MCLGridRef
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- s -

  • scancode : CEGUI::KeyEventArgs
  • ScrollSpeed : CEGUI::ListHeader
  • SegmentMoveThreshold : CEGUI::ListHeaderSegment
  • sysKeys : CEGUI::KeyEventArgs, CEGUI::MouseEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- u -

  • userData : TiXmlBase
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- w -

  • wheelChange : CEGUI::MouseEventArgs
  • WidgetTypeName : CEGUI::ScrolledContainer, CEGUI::GUISheet, CEGUI::DragContainer
  • window : CEGUI::WindowEventArgs
Generated on Sat Nov 26 10:09:56 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Sat Nov 26 10:10:21 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Main Page

Crazy Eddies GUI System Documentation

1

Generated on Sat Nov 26 10:09:54 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: internal.h Source File

src » pcre

internal.h

00001 /*************************************************
00002 *      Perl-Compatible Regular Expressions       *
00003 *************************************************/
00004
00005
00006 /* This is a library of functions to support regular expressions whose syntax
00007 and semantics are as close as possible to those of the Perl 5 language. See
00008 the file doc/Tech.Notes for some information on the internals.
00009
00010 Written by: Philip Hazel <ph10@cam.ac.uk>
00011
00012            Copyright (c) 1997-2004 University of Cambridge
00013
00014 -----------------------------------------------------------------------------
00015 Redistribution and use in source and binary forms, with or without
00016 modification, are permitted provided that the following conditions are met:
00017
00018     * Redistributions of source code must retain the above copyright notice,
00019       this list of conditions and the following disclaimer.
00020
00021     * Redistributions in binary form must reproduce the above copyright
00022       notice, this list of conditions and the following disclaimer in the
00023       documentation and/or other materials provided with the distribution.
00024
00025     * Neither the name of the University of Cambridge nor the names of its
00026       contributors may be used to endorse or promote products derived from
00027       this software without specific prior written permission.
00028
00029 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00030 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00031 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
00032 ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
00033 LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
00034 CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
00035 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
00036 INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
00037 CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
00038 ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
00039 POSSIBILITY OF SUCH DAMAGE.
00040 -----------------------------------------------------------------------------
00041 */
00042
00043 /* This header contains definitions that are shared between the different
00044 modules, but which are not relevant to the outside. */
00045
00046 /* Get the definitions provided by running "configure" */
00047
00048 #include "pcreconfig.h"
00049
00050 /* Standard C headers plus the external interface definition. The only time
00051 setjmp and stdarg are used is when NO_RECURSE is set. */
00052
00053 #include <ctype.h>
00054 #include <limits.h>
00055 #include <setjmp.h>
00056 #include <stdarg.h>
00057 #include <stddef.h>
00058 #include <stdio.h>
00059 #include <stdlib.h>
00060 #include <string.h>
00061
00062 #ifndef PCRE_SPY
00063 #define PCRE_DEFINITION       /* Win32 __declspec(export) trigger for .dll */
00064 #endif
00065
00066 /* We need to have types that specify unsigned 16-bit and 32-bit integers. We
00067 cannot determine these outside the compilation (e.g. by running a program as
00068 part of "configure") because PCRE is often cross-compiled for use on other
00069 systems. Instead we make use of the maximum sizes that are available at
00070 preprocessor time in standard C environments. */
00071
00072 #if USHRT_MAX == 65535
00073   typedef unsigned short pcre_uint16;
00074 #elif UINT_MAX == 65535
00075   typedef unsigned int pcre_uint16;
00076 #else
00077   #error Cannot determine a type for 16-bit unsigned integers
00078 #endif
00079
00080 #if UINT_MAX == 4294967295
00081   typedef unsigned int pcre_uint32;
00082 #elif ULONG_MAX == 4294967295
00083   typedef unsigned long int pcre_uint32;
00084 #else
00085   #error Cannot determine a type for 32-bit unsigned integers
00086 #endif
00087
00088 /* All character handling must be done as unsigned characters. Otherwise there
00089 are problems with top-bit-set characters and functions such as isspace().
00090 However, we leave the interface to the outside world as char *, because that
00091 should make things easier for callers. We define a short type for unsigned char
00092 to save lots of typing. I tried "uchar", but it causes problems on Digital
00093 Unix, where it is defined in sys/types, so use "uschar" instead. */
00094
00095 typedef unsigned char uschar;
00096
00097 /* Include the public PCRE header */
00098
00099 #include "pcre.h"
00100
00101 /* When compiling for use with the Virtual Pascal compiler, these functions
00102 need to have their names changed. PCRE must be compiled with the -DVPCOMPAT
00103 option on the command line. */
00104
00105 #ifdef VPCOMPAT
00106 #define strncmp(s1,s2,m) _strncmp(s1,s2,m)
00107 #define memcpy(d,s,n)    _memcpy(d,s,n)
00108 #define memmove(d,s,n)   _memmove(d,s,n)
00109 #define memset(s,c,n)    _memset(s,c,n)
00110 #else  /* VPCOMPAT */
00111
00112 /* To cope with SunOS4 and other systems that lack memmove() but have bcopy(),
00113 define a macro for memmove() if HAVE_MEMMOVE is false, provided that HAVE_BCOPY
00114 is set. Otherwise, include an emulating function for those systems that have
00115 neither (there some non-Unix environments where this is the case). This assumes
00116 that all calls to memmove are moving strings upwards in store, which is the
00117 case in PCRE. */
00118
00119 #if ! HAVE_MEMMOVE
00120 #undef  memmove        /* some systems may have a macro */
00121 #if HAVE_BCOPY
00122 #define memmove(a, b, c) bcopy(b, a, c)
00123 #else  /* HAVE_BCOPY */
00124 void *
00125 pcre_memmove(unsigned char *dest, const unsigned char *src, size_t n)
00126 {
00127 int i;
00128 dest += n;
00129 src += n;
00130 for (i = 0; i < n; ++i) *(--dest) =  *(--src);
00131 return dest;
00132 }
00133 #define memmove(a, b, c) pcre_memmove(a, b, c)
00134 #endif   /* not HAVE_BCOPY */
00135 #endif   /* not HAVE_MEMMOVE */
00136 #endif   /* not VPCOMPAT */
00137
00138
00139 /* PCRE keeps offsets in its compiled code as 2-byte quantities (always stored
00140 in big-endian order) by default. These are used, for example, to link from the
00141 start of a subpattern to its alternatives and its end. The use of 2 bytes per
00142 offset limits the size of the compiled regex to around 64K, which is big enough
00143 for almost everybody. However, I received a request for an even bigger limit.
00144 For this reason, and also to make the code easier to maintain, the storing and
00145 loading of offsets from the byte string is now handled by the macros that are
00146 defined here.
00147
00148 The macros are controlled by the value of LINK_SIZE. This defaults to 2 in
00149 the config.h file, but can be overridden by using -D on the command line. This
00150 is automated on Unix systems via the "configure" command. */
00151
00152 #if LINK_SIZE == 2
00153
00154 #define PUT(a,n,d)   \
00155   (a[n] = (d) >> 8), \
00156   (a[(n)+1] = (d) & 255)
00157
00158 #define GET(a,n) \
00159   (((a)[n] << 8) | (a)[(n)+1])
00160
00161 #define MAX_PATTERN_SIZE (1 << 16)
00162
00163
00164 #elif LINK_SIZE == 3
00165
00166 #define PUT(a,n,d)       \
00167   (a[n] = (d) >> 16),    \
00168   (a[(n)+1] = (d) >> 8), \
00169   (a[(n)+2] = (d) & 255)
00170
00171 #define GET(a,n) \
00172   (((a)[n] << 16) | ((a)[(n)+1] << 8) | (a)[(n)+2])
00173
00174 #define MAX_PATTERN_SIZE (1 << 24)
00175
00176
00177 #elif LINK_SIZE == 4
00178
00179 #define PUT(a,n,d)        \
00180   (a[n] = (d) >> 24),     \
00181   (a[(n)+1] = (d) >> 16), \
00182   (a[(n)+2] = (d) >> 8),  \
00183   (a[(n)+3] = (d) & 255)
00184
00185 #define GET(a,n) \
00186   (((a)[n] << 24) | ((a)[(n)+1] << 16) | ((a)[(n)+2] << 8) | (a)[(n)+3])
00187
00188 #define MAX_PATTERN_SIZE (1 << 30)   /* Keep it positive */
00189
00190
00191 #else
00192 #error LINK_SIZE must be either 2, 3, or 4
00193 #endif
00194
00195
00196 /* Convenience macro defined in terms of the others */
00197
00198 #define PUTINC(a,n,d)   PUT(a,n,d), a += LINK_SIZE
00199
00200
00201 /* PCRE uses some other 2-byte quantities that do not change when the size of
00202 offsets changes. There are used for repeat counts and for other things such as
00203 capturing parenthesis numbers in back references. */
00204
00205 #define PUT2(a,n,d)   \
00206   a[n] = (d) >> 8; \
00207   a[(n)+1] = (d) & 255
00208
00209 #define GET2(a,n) \
00210   (((a)[n] << 8) | (a)[(n)+1])
00211
00212 #define PUT2INC(a,n,d)  PUT2(a,n,d), a += 2
00213
00214
00215 /* In case there is no definition of offsetof() provided - though any proper
00216 Standard C system should have one. */
00217
00218 #ifndef offsetof
00219 #define offsetof(p_type,field) ((size_t)&(((p_type *)0)->field))
00220 #endif
00221
00222
00223 /* These are the public options that can change during matching. */
00224
00225 #define PCRE_IMS (PCRE_CASELESS|PCRE_MULTILINE|PCRE_DOTALL)
00226
00227 /* Private options flags start at the most significant end of the four bytes,
00228 but skip the top bit so we can use ints for convenience without getting tangled
00229 with negative values. The public options defined in pcre.h start at the least
00230 significant end. Make sure they don't overlap, though now that we have expanded
00231 to four bytes, there is plenty of space. */
00232
00233 #define PCRE_FIRSTSET      0x40000000  /* first_byte is set */
00234 #define PCRE_REQCHSET      0x20000000  /* req_byte is set */
00235 #define PCRE_STARTLINE     0x10000000  /* start after \n for multiline */
00236 #define PCRE_ICHANGED      0x08000000  /* i option changes within regex */
00237 #define PCRE_NOPARTIAL     0x04000000  /* can't use partial with this regex */
00238
00239 /* Options for the "extra" block produced by pcre_study(). */
00240
00241 #define PCRE_STUDY_MAPPED   0x01     /* a map of starting chars exists */
00242
00243 /* Masks for identifying the public options which are permitted at compile
00244 time, run time or study time, respectively. */
00245
00246 #define PUBLIC_OPTIONS \
00247   (PCRE_CASELESS|PCRE_EXTENDED|PCRE_ANCHORED|PCRE_MULTILINE| \
00248    PCRE_DOTALL|PCRE_DOLLAR_ENDONLY|PCRE_EXTRA|PCRE_UNGREEDY|PCRE_UTF8| \
00249    PCRE_NO_AUTO_CAPTURE|PCRE_NO_UTF8_CHECK|PCRE_AUTO_CALLOUT)
00250
00251 #define PUBLIC_EXEC_OPTIONS \
00252   (PCRE_ANCHORED|PCRE_NOTBOL|PCRE_NOTEOL|PCRE_NOTEMPTY|PCRE_NO_UTF8_CHECK| \
00253    PCRE_PARTIAL)
00254
00255 #define PUBLIC_STUDY_OPTIONS 0   /* None defined */
00256
00257 /* Magic number to provide a small check against being handed junk. */
00258
00259 #define MAGIC_NUMBER  0x50435245UL   /* 'PCRE' */
00260
00261 /* Negative values for the firstchar and reqchar variables */
00262
00263 #define REQ_UNSET (-2)
00264 #define REQ_NONE  (-1)
00265
00266 /* Flags added to firstbyte or reqbyte; a "non-literal" item is either a
00267 variable-length repeat, or a anything other than literal characters. */
00268
00269 #define REQ_CASELESS 0x0100    /* indicates caselessness */
00270 #define REQ_VARY     0x0200    /* reqbyte followed non-literal item */
00271
00272 /* Miscellaneous definitions */
00273
00274 typedef int BOOL;
00275
00276 #define FALSE   0
00277 #define TRUE    1
00278
00279 /* Escape items that are just an encoding of a particular data value. Note that
00280 ESC_n is defined as yet another macro, which is set in config.h to either \n
00281 (the default) or \r (which some people want). */
00282
00283 #ifndef ESC_e
00284 #define ESC_e 27
00285 #endif
00286
00287 #ifndef ESC_f
00288 #define ESC_f '\f'
00289 #endif
00290
00291 #ifndef ESC_n
00292 #define ESC_n NEWLINE
00293 #endif
00294
00295 #ifndef ESC_r
00296 #define ESC_r '\r'
00297 #endif
00298
00299 /* We can't officially use ESC_t because it is a POSIX reserved identifier
00300 (presumably because of all the others like size_t). */
00301
00302 #ifndef ESC_tee
00303 #define ESC_tee '\t'
00304 #endif
00305
00306 /* These are escaped items that aren't just an encoding of a particular data
00307 value such as \n. They must have non-zero values, as check_escape() returns
00308 their negation. Also, they must appear in the same order as in the opcode
00309 definitions below, up to ESC_z. There's a dummy for OP_ANY because it
00310 corresponds to "." rather than an escape sequence. The final one must be
00311 ESC_REF as subsequent values are used for \1, \2, \3, etc. There is are two
00312 tests in the code for an escape greater than ESC_b and less than ESC_Z to
00313 detect the types that may be repeated. These are the types that consume
00314 characters. If any new escapes are put in between that don't consume a
00315 character, that code will have to change. */
00316
00317 enum { ESC_A = 1, ESC_G, ESC_B, ESC_b, ESC_D, ESC_d, ESC_S, ESC_s, ESC_W,
00318        ESC_w, ESC_dum1, ESC_C, ESC_P, ESC_p, ESC_X, ESC_Z, ESC_z, ESC_E,
00319        ESC_Q, ESC_REF };
00320
00321 /* Flag bits and data types for the extended class (OP_XCLASS) for classes that
00322 contain UTF-8 characters with values greater than 255. */
00323
00324 #define XCL_NOT    0x01    /* Flag: this is a negative class */
00325 #define XCL_MAP    0x02    /* Flag: a 32-byte map is present */
00326
00327 #define XCL_END       0    /* Marks end of individual items */
00328 #define XCL_SINGLE    1    /* Single item (one multibyte char) follows */
00329 #define XCL_RANGE     2    /* A range (two multibyte chars) follows */
00330 #define XCL_PROP      3    /* Unicode property (one property code) follows */
00331 #define XCL_NOTPROP   4    /* Unicode inverted property (ditto) */
00332
00333
00334 /* Opcode table: OP_BRA must be last, as all values >= it are used for brackets
00335 that extract substrings. Starting from 1 (i.e. after OP_END), the values up to
00336 OP_EOD must correspond in order to the list of escapes immediately above.
00337 Note that whenever this list is updated, the two macro definitions that follow
00338 must also be updated to match. */
00339
00340 enum {
00341   OP_END,            /* 0 End of pattern */
00342
00343   /* Values corresponding to backslashed metacharacters */
00344
00345   OP_SOD,            /* 1 Start of data: \A */
00346   OP_SOM,            /* 2 Start of match (subject + offset): \G */
00347   OP_NOT_WORD_BOUNDARY,  /*  3 \B */
00348   OP_WORD_BOUNDARY,      /*  4 \b */
00349   OP_NOT_DIGIT,          /*  5 \D */
00350   OP_DIGIT,              /*  6 \d */
00351   OP_NOT_WHITESPACE,     /*  7 \S */
00352   OP_WHITESPACE,         /*  8 \s */
00353   OP_NOT_WORDCHAR,       /*  9 \W */
00354   OP_WORDCHAR,           /* 10 \w */
00355   OP_ANY,            /* 11 Match any character */
00356   OP_ANYBYTE,        /* 12 Match any byte (\C); different to OP_ANY for UTF-8 */
00357   OP_NOTPROP,        /* 13 \P (not Unicode property) */
00358   OP_PROP,           /* 14 \p (Unicode property) */
00359   OP_EXTUNI,         /* 15 \X (extended Unicode sequence */
00360   OP_EODN,           /* 16 End of data or \n at end of data: \Z. */
00361   OP_EOD,            /* 17 End of data: \z */
00362
00363   OP_OPT,            /* 18 Set runtime options */
00364   OP_CIRC,           /* 19 Start of line - varies with multiline switch */
00365   OP_DOLL,           /* 20 End of line - varies with multiline switch */
00366   OP_CHAR,           /* 21 Match one character, casefully */
00367   OP_CHARNC,         /* 22 Match one character, caselessly */
00368   OP_NOT,            /* 23 Match anything but the following char */
00369
00370   OP_STAR,           /* 24 The maximizing and minimizing versions of */
00371   OP_MINSTAR,        /* 25 all these opcodes must come in pairs, with */
00372   OP_PLUS,           /* 26 the minimizing one second. */
00373   OP_MINPLUS,        /* 27 This first set applies to single characters */
00374   OP_QUERY,          /* 28 */
00375   OP_MINQUERY,       /* 29 */
00376   OP_UPTO,           /* 30 From 0 to n matches */
00377   OP_MINUPTO,        /* 31 */
00378   OP_EXACT,          /* 32 Exactly n matches */
00379
00380   OP_NOTSTAR,        /* 33 The maximizing and minimizing versions of */
00381   OP_NOTMINSTAR,     /* 34 all these opcodes must come in pairs, with */
00382   OP_NOTPLUS,        /* 35 the minimizing one second. */
00383   OP_NOTMINPLUS,     /* 36 This set applies to "not" single characters */
00384   OP_NOTQUERY,       /* 37 */
00385   OP_NOTMINQUERY,    /* 38 */
00386   OP_NOTUPTO,        /* 39 From 0 to n matches */
00387   OP_NOTMINUPTO,     /* 40 */
00388   OP_NOTEXACT,       /* 41 Exactly n matches */
00389
00390   OP_TYPESTAR,       /* 42 The maximizing and minimizing versions of */
00391   OP_TYPEMINSTAR,    /* 43 all these opcodes must come in pairs, with */
00392   OP_TYPEPLUS,       /* 44 the minimizing one second. These codes must */
00393   OP_TYPEMINPLUS,    /* 45 be in exactly the same order as those above. */
00394   OP_TYPEQUERY,      /* 46 This set applies to character types such as \d */
00395   OP_TYPEMINQUERY,   /* 47 */
00396   OP_TYPEUPTO,       /* 48 From 0 to n matches */
00397   OP_TYPEMINUPTO,    /* 49 */
00398   OP_TYPEEXACT,      /* 50 Exactly n matches */
00399
00400   OP_CRSTAR,         /* 51 The maximizing and minimizing versions of */
00401   OP_CRMINSTAR,      /* 52 all these opcodes must come in pairs, with */
00402   OP_CRPLUS,         /* 53 the minimizing one second. These codes must */
00403   OP_CRMINPLUS,      /* 54 be in exactly the same order as those above. */
00404   OP_CRQUERY,        /* 55 These are for character classes and back refs */
00405   OP_CRMINQUERY,     /* 56 */
00406   OP_CRRANGE,        /* 57 These are different to the three sets above. */
00407   OP_CRMINRANGE,     /* 58 */
00408
00409   OP_CLASS,          /* 59 Match a character class, chars < 256 only */
00410   OP_NCLASS,         /* 60 Same, but the bitmap was created from a negative
00411                            class - the difference is relevant only when a UTF-8
00412                            character > 255 is encountered. */
00413
00414   OP_XCLASS,         /* 61 Extended class for handling UTF-8 chars within the
00415                            class. This does both positive and negative. */
00416
00417   OP_REF,            /* 62 Match a back reference */
00418   OP_RECURSE,        /* 63 Match a numbered subpattern (possibly recursive) */
00419   OP_CALLOUT,        /* 64 Call out to external function if provided */
00420
00421   OP_ALT,            /* 65 Start of alternation */
00422   OP_KET,            /* 66 End of group that doesn't have an unbounded repeat */
00423   OP_KETRMAX,        /* 67 These two must remain together and in this */
00424   OP_KETRMIN,        /* 68 order. They are for groups the repeat for ever. */
00425
00426   /* The assertions must come before ONCE and COND */
00427
00428   OP_ASSERT,         /* 69 Positive lookahead */
00429   OP_ASSERT_NOT,     /* 70 Negative lookahead */
00430   OP_ASSERTBACK,     /* 71 Positive lookbehind */
00431   OP_ASSERTBACK_NOT, /* 72 Negative lookbehind */
00432   OP_REVERSE,        /* 73 Move pointer back - used in lookbehind assertions */
00433
00434   /* ONCE and COND must come after the assertions, with ONCE first, as there's
00435   a test for >= ONCE for a subpattern that isn't an assertion. */
00436
00437   OP_ONCE,           /* 74 Once matched, don't back up into the subpattern */
00438   OP_COND,           /* 75 Conditional group */
00439   OP_CREF,           /* 76 Used to hold an extraction string number (cond ref) */
00440
00441   OP_BRAZERO,        /* 77 These two must remain together and in this */
00442   OP_BRAMINZERO,     /* 78 order. */
00443
00444   OP_BRANUMBER,      /* 79 Used for extracting brackets whose number is greater
00445                            than can fit into an opcode. */
00446
00447   OP_BRA             /* 80 This and greater values are used for brackets that
00448                            extract substrings up to EXTRACT_BASIC_MAX. After
00449                            that, use is made of OP_BRANUMBER. */
00450 };
00451
00452 /* WARNING WARNING WARNING: There is an implicit assumption in pcre.c and
00453 study.c that all opcodes are less than 128 in value. This makes handling UTF-8
00454 character sequences easier. */
00455
00456 /* The highest extraction number before we have to start using additional
00457 bytes. (Originally PCRE didn't have support for extraction counts highter than
00458 this number.) The value is limited by the number of opcodes left after OP_BRA,
00459 i.e. 255 - OP_BRA. We actually set it a bit lower to leave room for additional
00460 opcodes. */
00461
00462 #define EXTRACT_BASIC_MAX  100
00463
00464
00465 /* This macro defines textual names for all the opcodes. There are used only
00466 for debugging, in pcre.c when DEBUG is defined, and also in pcretest.c. The
00467 macro is referenced only in printint.c. */
00468
00469 #define OP_NAME_LIST \
00470   "End", "\\A", "\\G", "\\B", "\\b", "\\D", "\\d",                \
00471   "\\S", "\\s", "\\W", "\\w", "Any", "Anybyte",                   \
00472   "notprop", "prop", "extuni",                                    \
00473   "\\Z", "\\z",                                                   \
00474   "Opt", "^", "$", "char", "charnc", "not",                       \
00475   "*", "*?", "+", "+?", "?", "??", "{", "{", "{",                 \
00476   "*", "*?", "+", "+?", "?", "??", "{", "{", "{",                 \
00477   "*", "*?", "+", "+?", "?", "??", "{", "{", "{",                 \
00478   "*", "*?", "+", "+?", "?", "??", "{", "{",                      \
00479   "class", "nclass", "xclass", "Ref", "Recurse", "Callout",       \
00480   "Alt", "Ket", "KetRmax", "KetRmin", "Assert", "Assert not",     \
00481   "AssertB", "AssertB not", "Reverse", "Once", "Cond", "Cond ref",\
00482   "Brazero", "Braminzero", "Branumber", "Bra"
00483
00484
00485 /* This macro defines the length of fixed length operations in the compiled
00486 regex. The lengths are used when searching for specific things, and also in the
00487 debugging printing of a compiled regex. We use a macro so that it can be
00488 incorporated both into pcre.c and pcretest.c without being publicly exposed.
00489
00490 As things have been extended, some of these are no longer fixed lenths, but are
00491 minima instead. For example, the length of a single-character repeat may vary
00492 in UTF-8 mode. The code that uses this table must know about such things. */
00493
00494 #define OP_LENGTHS \
00495   1,                             /* End                                    */ \
00496   1, 1, 1, 1, 1, 1, 1, 1, 1, 1,  /* \A, \G, \B, \B, \D, \d, \S, \s, \W, \w */ \
00497   1, 1,                          /* Any, Anybyte                           */ \
00498   2, 2, 1,                       /* NOTPROP, PROP, EXTUNI                  */ \
00499   1, 1, 2, 1, 1,                 /* \Z, \z, Opt, ^, $                      */ \
00500   2,                             /* Char  - the minimum length             */ \
00501   2,                             /* Charnc  - the minimum length           */ \
00502   2,                             /* not                                    */ \
00503   /* Positive single-char repeats                            ** These are  */ \
00504   2, 2, 2, 2, 2, 2,              /* *, *?, +, +?, ?, ??      ** minima in  */ \
00505   4, 4, 4,                       /* upto, minupto, exact     ** UTF-8 mode */ \
00506   /* Negative single-char repeats - only for chars < 256                   */ \
00507   2, 2, 2, 2, 2, 2,              /* NOT *, *?, +, +?, ?, ??                */ \
00508   4, 4, 4,                       /* NOT upto, minupto, exact               */ \
00509   /* Positive type repeats                                                 */ \
00510   2, 2, 2, 2, 2, 2,              /* Type *, *?, +, +?, ?, ??               */ \
00511   4, 4, 4,                       /* Type upto, minupto, exact              */ \
00512   /* Character class & ref repeats                                         */ \
00513   1, 1, 1, 1, 1, 1,              /* *, *?, +, +?, ?, ??                    */ \
00514   5, 5,                          /* CRRANGE, CRMINRANGE                    */ \
00515  33,                             /* CLASS                                  */ \
00516  33,                             /* NCLASS                                 */ \
00517   0,                             /* XCLASS - variable length               */ \
00518   3,                             /* REF                                    */ \
00519   1+LINK_SIZE,                   /* RECURSE                                */ \
00520   2+2*LINK_SIZE,                 /* CALLOUT                                */ \
00521   1+LINK_SIZE,                   /* Alt                                    */ \
00522   1+LINK_SIZE,                   /* Ket                                    */ \
00523   1+LINK_SIZE,                   /* KetRmax                                */ \
00524   1+LINK_SIZE,                   /* KetRmin                                */ \
00525   1+LINK_SIZE,                   /* Assert                                 */ \
00526   1+LINK_SIZE,                   /* Assert not                             */ \
00527   1+LINK_SIZE,                   /* Assert behind                          */ \
00528   1+LINK_SIZE,                   /* Assert behind not                      */ \
00529   1+LINK_SIZE,                   /* Reverse                                */ \
00530   1+LINK_SIZE,                   /* Once                                   */ \
00531   1+LINK_SIZE,                   /* COND                                   */ \
00532   3,                             /* CREF                                   */ \
00533   1, 1,                          /* BRAZERO, BRAMINZERO                    */ \
00534   3,                             /* BRANUMBER                              */ \
00535   1+LINK_SIZE                    /* BRA                                    */ \
00536
00537
00538 /* A magic value for OP_CREF to indicate the "in recursion" condition. */
00539
00540 #define CREF_RECURSE  0xffff
00541
00542 /* The texts of compile-time error messages are defined as macros here so that
00543 they can be accessed by the POSIX wrapper and converted into error codes.  Yes,
00544 I could have used error codes in the first place, but didn't feel like changing
00545 just to accommodate the POSIX wrapper. */
00546
00547 #define ERR1  "\\ at end of pattern"
00548 #define ERR2  "\\c at end of pattern"
00549 #define ERR3  "unrecognized character follows \\"
00550 #define ERR4  "numbers out of order in {} quantifier"
00551 #define ERR5  "number too big in {} quantifier"
00552 #define ERR6  "missing terminating ] for character class"
00553 #define ERR7  "invalid escape sequence in character class"
00554 #define ERR8  "range out of order in character class"
00555 #define ERR9  "nothing to repeat"
00556 #define ERR10 "operand of unlimited repeat could match the empty string"
00557 #define ERR11 "internal error: unexpected repeat"
00558 #define ERR12 "unrecognized character after (?"
00559 #define ERR13 "POSIX named classes are supported only within a class"
00560 #define ERR14 "missing )"
00561 #define ERR15 "reference to non-existent subpattern"
00562 #define ERR16 "erroffset passed as NULL"
00563 #define ERR17 "unknown option bit(s) set"
00564 #define ERR18 "missing ) after comment"
00565 #define ERR19 "parentheses nested too deeply"
00566 #define ERR20 "regular expression too large"
00567 #define ERR21 "failed to get memory"
00568 #define ERR22 "unmatched parentheses"
00569 #define ERR23 "internal error: code overflow"
00570 #define ERR24 "unrecognized character after (?<"
00571 #define ERR25 "lookbehind assertion is not fixed length"
00572 #define ERR26 "malformed number after (?("
00573 #define ERR27 "conditional group contains more than two branches"
00574 #define ERR28 "assertion expected after (?("
00575 #define ERR29 "(?R or (?digits must be followed by )"
00576 #define ERR30 "unknown POSIX class name"
00577 #define ERR31 "POSIX collating elements are not supported"
00578 #define ERR32 "this version of PCRE is not compiled with PCRE_UTF8 support"
00579 #define ERR33 "spare error"
00580 #define ERR34 "character value in \\x{...} sequence is too large"
00581 #define ERR35 "invalid condition (?(0)"
00582 #define ERR36 "\\C not allowed in lookbehind assertion"
00583 #define ERR37 "PCRE does not support \\L, \\l, \\N, \\U, or \\u"
00584 #define ERR38 "number after (?C is > 255"
00585 #define ERR39 "closing ) for (?C expected"
00586 #define ERR40 "recursive call could loop indefinitely"
00587 #define ERR41 "unrecognized character after (?P"
00588 #define ERR42 "syntax error after (?P"
00589 #define ERR43 "two named groups have the same name"
00590 #define ERR44 "invalid UTF-8 string"
00591 #define ERR45 "support for \\P, \\p, and \\X has not been compiled"
00592 #define ERR46 "malformed \\P or \\p sequence"
00593 #define ERR47 "unknown property name after \\P or \\p"
00594
00595 /* The real format of the start of the pcre block; the index of names and the
00596 code vector run on as long as necessary after the end. We store an explicit
00597 offset to the name table so that if a regex is compiled on one host, saved, and
00598 then run on another where the size of pointers is different, all might still
00599 be well. For the case of compiled-on-4 and run-on-8, we include an extra
00600 pointer that is always NULL. For future-proofing, we also include a few dummy
00601 fields - even though you can never get this planning right!
00602
00603 NOTE NOTE NOTE:
00604 Because people can now save and re-use compiled patterns, any additions to this
00605 structure should be made at the end, and something earlier (e.g. a new
00606 flag in the options or one of the dummy fields) should indicate that the new
00607 fields are present. Currently PCRE always sets the dummy fields to zero.
00608 NOTE NOTE NOTE:
00609 */
00610
00611 typedef struct real_pcre {
00612   pcre_uint32 magic_number;
00613   pcre_uint32 size;               /* Total that was malloced */
00614   pcre_uint32 options;
00615   pcre_uint32 dummy1;             /* For future use, maybe */
00616
00617   pcre_uint16 top_bracket;
00618   pcre_uint16 top_backref;
00619   pcre_uint16 first_byte;
00620   pcre_uint16 req_byte;
00621   pcre_uint16 name_table_offset;  /* Offset to name table that follows */
00622   pcre_uint16 name_entry_size;    /* Size of any name items */
00623   pcre_uint16 name_count;         /* Number of name items */
00624   pcre_uint16 dummy2;             /* For future use, maybe */
00625
00626   const unsigned char *tables;    /* Pointer to tables or NULL for std */
00627   const unsigned char *nullpad;   /* NULL padding */
00628 } real_pcre;
00629
00630 /* The format of the block used to store data from pcre_study(). The same
00631 remark (see NOTE above) about extending this structure applies. */
00632
00633 typedef struct pcre_study_data {
00634   pcre_uint32 size;               /* Total that was malloced */
00635   pcre_uint32 options;
00636   uschar start_bits[32];
00637 } pcre_study_data;
00638
00639 /* Structure for passing "static" information around between the functions
00640 doing the compiling, so that they are thread-safe. */
00641
00642 typedef struct compile_data {
00643   const uschar *lcc;            /* Points to lower casing table */
00644   const uschar *fcc;            /* Points to case-flipping table */
00645   const uschar *cbits;          /* Points to character type table */
00646   const uschar *ctypes;         /* Points to table of type maps */
00647   const uschar *start_code;     /* The start of the compiled code */
00648   const uschar *start_pattern;  /* The start of the pattern */
00649   uschar *name_table;           /* The name/number table */
00650   int  names_found;             /* Number of entries so far */
00651   int  name_entry_size;         /* Size of each entry */
00652   int  top_backref;             /* Maximum back reference */
00653   unsigned int backref_map;     /* Bitmap of low back refs */
00654   int  req_varyopt;             /* "After variable item" flag for reqbyte */
00655   BOOL nopartial;               /* Set TRUE if partial won't work */
00656 } compile_data;
00657
00658 /* Structure for maintaining a chain of pointers to the currently incomplete
00659 branches, for testing for left recursion. */
00660
00661 typedef struct branch_chain {
00662   struct branch_chain *outer;
00663   uschar *current;
00664 } branch_chain;
00665
00666 /* Structure for items in a linked list that represents an explicit recursive
00667 call within the pattern. */
00668
00669 typedef struct recursion_info {
00670   struct recursion_info *prevrec; /* Previous recursion record (or NULL) */
00671   int group_num;                /* Number of group that was called */
00672   const uschar *after_call;     /* "Return value": points after the call in the expr */
00673   const uschar *save_start;     /* Old value of md->start_match */
00674   int *offset_save;             /* Pointer to start of saved offsets */
00675   int saved_max;                /* Number of saved offsets */
00676 } recursion_info;
00677
00678 /* When compiling in a mode that doesn't use recursive calls to match(),
00679 a structure is used to remember local variables on the heap. It is defined in
00680 pcre.c, close to the match() function, so that it is easy to keep it in step
00681 with any changes of local variable. However, the pointer to the current frame
00682 must be saved in some "static" place over a longjmp(). We declare the
00683 structure here so that we can put a pointer in the match_data structure.
00684 NOTE: This isn't used for a "normal" compilation of pcre. */
00685
00686 struct heapframe;
00687
00688 /* Structure for passing "static" information around between the functions
00689 doing the matching, so that they are thread-safe. */
00690
00691 typedef struct match_data {
00692   unsigned long int match_call_count; /* As it says */
00693   unsigned long int match_limit;/* As it says */
00694   int   *offset_vector;         /* Offset vector */
00695   int    offset_end;            /* One past the end */
00696   int    offset_max;            /* The maximum usable for return data */
00697   const uschar *lcc;            /* Points to lower casing table */
00698   const uschar *ctypes;         /* Points to table of type maps */
00699   BOOL   offset_overflow;       /* Set if too many extractions */
00700   BOOL   notbol;                /* NOTBOL flag */
00701   BOOL   noteol;                /* NOTEOL flag */
00702   BOOL   utf8;                  /* UTF8 flag */
00703   BOOL   endonly;               /* Dollar not before final \n */
00704   BOOL   notempty;              /* Empty string match not wanted */
00705   BOOL   partial;               /* PARTIAL flag */
00706   BOOL   hitend;                /* Hit the end of the subject at some point */
00707   const uschar *start_code;     /* For use when recursing */
00708   const uschar *start_subject;  /* Start of the subject string */
00709   const uschar *end_subject;    /* End of the subject string */
00710   const uschar *start_match;    /* Start of this match attempt */
00711   const uschar *end_match_ptr;  /* Subject position at end match */
00712   int    end_offset_top;        /* Highwater mark at end of match */
00713   int    capture_last;          /* Most recent capture number */
00714   int    start_offset;          /* The start offset value */
00715   recursion_info *recursive;    /* Linked list of recursion data */
00716   void  *callout_data;          /* To pass back to callouts */
00717   struct heapframe *thisframe;  /* Used only when compiling for no recursion */
00718 } match_data;
00719
00720 /* Bit definitions for entries in the pcre_ctypes table. */
00721
00722 #define ctype_space   0x01
00723 #define ctype_letter  0x02
00724 #define ctype_digit   0x04
00725 #define ctype_xdigit  0x08
00726 #define ctype_word    0x10   /* alphameric or '_' */
00727 #define ctype_meta    0x80   /* regexp meta char or zero (end pattern) */
00728
00729 /* Offsets for the bitmap tables in pcre_cbits. Each table contains a set
00730 of bits for a class map. Some classes are built by combining these tables. */
00731
00732 #define cbit_space     0      /* [:space:] or \s */
00733 #define cbit_xdigit   32      /* [:xdigit:] */
00734 #define cbit_digit    64      /* [:digit:] or \d */
00735 #define cbit_upper    96      /* [:upper:] */
00736 #define cbit_lower   128      /* [:lower:] */
00737 #define cbit_word    160      /* [:word:] or \w */
00738 #define cbit_graph   192      /* [:graph:] */
00739 #define cbit_print   224      /* [:print:] */
00740 #define cbit_punct   256      /* [:punct:] */
00741 #define cbit_cntrl   288      /* [:cntrl:] */
00742 #define cbit_length  320      /* Length of the cbits table */
00743
00744 /* Offsets of the various tables from the base tables pointer, and
00745 total length. */
00746
00747 #define lcc_offset      0
00748 #define fcc_offset    256
00749 #define cbits_offset  512
00750 #define ctypes_offset (cbits_offset + cbit_length)
00751 #define tables_length (ctypes_offset + 256)
00752
00753 /* End of internal.h */
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: IrrlichtEventPusher.h Source File

src » renderers » IrrlichtRenderer

IrrlichtEventPusher.h

00001 /************************************************************************
00002 filename:       IrrlichtEventPusher.h
00003 created:        12/22/2004
00004 author:         Thomas Suter
00005 *************************************************************************/
00006 /*************************************************************************
00007 Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008 Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010 This library is free software; you can redistribute it and/or
00011 modify it under the terms of the GNU Lesser General Public
00012 License as published by the Free Software Foundation; either
00013 version 2.1 of the License, or (at your option) any later version.
00014
00015 This library is distributed in the hope that it will be useful,
00016 but WITHOUT ANY WARRANTY; without even the implied warranty of
00017 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018 Lesser General Public License for more details.
00019
00020 You should have received a copy of the GNU Lesser General Public
00021 License along with this library; if not, write to the Free Software
00022 Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef CCEGUIEVENTPUSHER_H_INCLUDED
00025 #define CCEGUIEVENTPUSHER_H_INCLUDED
00026
00027 #include <CEGUI.h>
00028 #include <irrlicht.h>
00029
00030 namespace CEGUI
00031 {
00032         using namespace irr;
00033
00034         class EventPusher
00035         {
00036                 gui::ICursorControl* cursorctrl;
00037
00038                 core::position2d<s32> pos;
00039                 core::position2d<s32> dpos;
00040
00041         public :
00042
00043                 EventPusher(irr::gui::ICursorControl* ctrl)
00044                         :cursorctrl(ctrl)
00045                 {
00046                         cursorctrl->setPosition(0.5f,0.5f);
00047                         pos=cursorctrl->getPosition();
00048                         dpos.X=0;
00049                         dpos.Y=0;
00050                         initCodes();
00051                 };
00052
00053                 virtual ~EventPusher(){};
00054
00055                 bool OnEvent(SEvent& event)
00056                 {
00057                         switch(event.EventType)
00058                         {
00059                         case EET_KEY_INPUT_EVENT :
00060                                 if(event.KeyInput.PressedDown)
00061                                         return OnKeyDown(event.KeyInput.Key,event.KeyInput.Char,event.KeyInput.Control,event.KeyInput.Shift);
00062                                 else
00063                                         return OnKeyUp(event.KeyInput.Key,event.KeyInput.Char,event.KeyInput.Control,event.KeyInput.Shift);
00064                                 break;
00065
00066                         case EET_MOUSE_INPUT_EVENT :
00067                                 return OnMouse(event.MouseInput.X,event.MouseInput.Y,event.MouseInput.Wheel,event.MouseInput.Event);
00068                                 break;
00069
00070                         default:
00071                                 break;
00072                         }
00073                         return false;
00074                 }
00075
00076                 bool OnKeyDown(EKEY_CODE key, wchar_t wch, bool ctrl, bool shift)
00077                 {
00078                         bool handled=false;
00079                         CEGUI::System& cegui = CEGUI::System::getSingleton();
00080                         handled = cegui.injectKeyDown(getKeyCode(key));
00081                         handled = cegui.injectChar(wch) || handled;
00082                         return handled;
00083                 }
00084
00085                 bool OnKeyUp(EKEY_CODE key, wchar_t wch, bool ctrl, bool shift)
00086                 {
00087                         bool handled=false;
00088                         CEGUI::System& cegui = CEGUI::System::getSingleton();
00089                         handled=cegui.injectKeyUp(getKeyCode(key));
00090                         return handled;
00091                 }
00092
00093                 bool OnMouse(s32 x, s32 y, f32 w, EMOUSE_INPUT_EVENT e)
00094                 {
00095                         using namespace irr;
00096                         bool handled=false;
00097
00098                         switch(e)
00099                         {
00101                         case EMIE_LMOUSE_PRESSED_DOWN:
00102                                 handled=CEGUI::System::getSingleton().injectMouseButtonDown(CEGUI::LeftButton);
00104                         case EMIE_RMOUSE_PRESSED_DOWN:
00105                                 handled=CEGUI::System::getSingleton().injectMouseButtonDown(CEGUI::RightButton);
00106                                 break;
00108                         case EMIE_MMOUSE_PRESSED_DOWN:
00109                                 handled=CEGUI::System::getSingleton().injectMouseButtonDown(CEGUI::MiddleButton);
00110                                 break;
00112                         case EMIE_LMOUSE_LEFT_UP:
00113                                 handled=CEGUI::System::getSingleton().injectMouseButtonUp(CEGUI::LeftButton);
00114                                 break;
00116                         case EMIE_RMOUSE_LEFT_UP:
00117                                 handled=CEGUI::System::getSingleton().injectMouseButtonUp(CEGUI::RightButton);
00118                                 break;
00120                         case EMIE_MMOUSE_LEFT_UP:
00121                                 handled=CEGUI::System::getSingleton().injectMouseButtonUp(CEGUI::MiddleButton);
00122                                 break;
00124                         case EMIE_MOUSE_MOVED:
00125                                 dpos.X=x-pos.X;
00126                                 dpos.Y=y-pos.Y;
00127                                 pos.X=x;
00128                                 pos.Y=y;
00129                                 CEGUI::MouseCursor::getSingleton().setPosition(CEGUI::Point(float(pos.X),float(pos.Y)));
00130                                 handled=CEGUI::System::getSingleton().injectMouseMove(0.0f, 0.0f);
00131                                 //handled=CEGUI::System::getSingleton().injectMouseMove(float(dpos.X), float(dpos.Y));
00132                                 break;
00135                         case EMIE_MOUSE_WHEEL:
00136                                 handled=CEGUI::System::getSingleton().injectMouseWheelChange(w);
00137                                 break;
00138                         default:
00139                                 break;
00140
00141                         }
00142                         return handled;
00143
00144                 }
00145
00146                 protected:
00147
00148                         unsigned char irr2ceCODE[irr::KEY_KEY_CODES_COUNT];
00149
00150                         void initCodes()
00151                         {
00152                                 using namespace irr;
00153                                 memset(irr2ceCODE,0,KEY_KEY_CODES_COUNT);
00154
00155                                 irr2ceCODE[KEY_LBUTTON          ] = 0;  // Left mouse button
00156                                 irr2ceCODE[KEY_RBUTTON          ] = 0;  // Right mouse button
00157                                 irr2ceCODE[KEY_CANCEL           ] = 0;  // Control-break processing
00158                                 irr2ceCODE[KEY_MBUTTON          ] = 0;  // Middle mouse button (three-button mouse)
00159                                 irr2ceCODE[KEY_XBUTTON1         ] = 0;  // Windows 2000/XP: X1 mouse button
00160                                 irr2ceCODE[KEY_XBUTTON2         ] = 0;  // Windows 2000/XP: X2 mouse button
00161                                 irr2ceCODE[KEY_BACK             ] = Key::Backspace; //0x08;  // BACKSPACE key
00162                                 irr2ceCODE[KEY_TAB              ] = Key::Tab; //0x09;  // TAB key
00163                                 irr2ceCODE[KEY_CLEAR            ] = 0;  // CLEAR key
00164                                 irr2ceCODE[KEY_RETURN           ] = Key::Return; //0x0D;  // ENTER key
00165                                 irr2ceCODE[KEY_SHIFT            ] = Key::LeftShift;  // SHIFT key
00166                                 irr2ceCODE[KEY_CONTROL          ] = Key::LeftControl;   // CTRL key
00167                                 irr2ceCODE[KEY_MENU             ] = Key::LeftAlt;  // ALT key
00168                                 irr2ceCODE[KEY_PAUSE            ] = Key::Pause;   // PAUSE key
00169                                 irr2ceCODE[KEY_CAPITAL          ] = Key::Capital;  // CAPS LOCK key
00170                                 irr2ceCODE[KEY_KANA             ] = Key::Kana;  // IME Kana mode
00171                                 irr2ceCODE[KEY_HANGUEL          ] = KEY_HANGUEL;  // IME Hanguel mode
00172                                 irr2ceCODE[KEY_HANGUL           ] = KEY_HANGUL;  // IME Hangul mode
00173                                 irr2ceCODE[KEY_JUNJA            ] = 0;  // IME Junja mode
00174                                 irr2ceCODE[KEY_FINAL            ] = 0;  // IME final mode
00175                                 irr2ceCODE[KEY_HANJA            ] = 0;  // IME Hanja mode
00176                                 irr2ceCODE[KEY_KANJI            ] = 0;  // IME Kanji mode
00177                                 irr2ceCODE[KEY_ESCAPE           ] = Key::Escape;  // ESC key
00178                                 irr2ceCODE[KEY_CONVERT          ] = Key::Convert;  // IME convert
00179                                 irr2ceCODE[KEY_NONCONVERT       ] = Key::NoConvert;  // IME nonconvert
00180                                 irr2ceCODE[KEY_ACCEPT           ] = 0;  // IME accept
00181                                 irr2ceCODE[KEY_MODECHANGE       ] = 0;  // IME mode change request
00182                                 irr2ceCODE[KEY_SPACE            ] = Key::Space;  // SPACEBAR
00183                                 irr2ceCODE[KEY_PRIOR            ] = Key::PageUp;  // PAGE UP key
00184                                 irr2ceCODE[KEY_NEXT             ] = Key::PageDown;  // PAGE DOWN key
00185                                 irr2ceCODE[KEY_END              ] = Key::End;  // END key
00186                                 irr2ceCODE[KEY_HOME             ] = Key::Home;  // HOME key
00187                                 irr2ceCODE[KEY_LEFT             ] = Key::ArrowLeft;  // LEFT ARROW key
00188                                 irr2ceCODE[KEY_UP               ] = Key::ArrowUp;  // UP ARROW key
00189                                 irr2ceCODE[KEY_RIGHT            ] = Key::ArrowRight;  // RIGHT ARROW key
00190                                 irr2ceCODE[KEY_DOWN             ] = Key::ArrowDown;  // DOWN ARROW key
00191                                 irr2ceCODE[KEY_SELECT           ] = 0;  // SELECT key
00192                                 irr2ceCODE[KEY_PRINT            ] = Key::SysRq;  // PRINT key
00193                                 irr2ceCODE[KEY_EXECUT           ] = 0;  // EXECUTE key
00194                                 irr2ceCODE[KEY_SNAPSHOT         ] = 0;  // PRINT SCREEN key
00195                                 irr2ceCODE[KEY_INSERT           ] = Key::Insert;//0x2D;  // INS key
00196                                 irr2ceCODE[KEY_DELETE           ] = Key::Delete;//0x2E;  // DEL key
00197                                 irr2ceCODE[KEY_HELP             ] = 0;  // HELP key
00198                                 irr2ceCODE[KEY_KEY_0            ] = Key::Zero;   // 0 key
00199                                 irr2ceCODE[KEY_KEY_1            ] = Key::One;    // 1 key
00200                                 irr2ceCODE[KEY_KEY_2            ] = Key::Two;    // 2 key
00201                                 irr2ceCODE[KEY_KEY_3            ] = Key::Three;  // 3 key
00202                                 irr2ceCODE[KEY_KEY_4            ] = Key::Four;   // 4 key
00203                                 irr2ceCODE[KEY_KEY_5            ] = Key::Five;   // 5 key
00204                                 irr2ceCODE[KEY_KEY_6            ] = Key::Six;    // 6 key
00205                                 irr2ceCODE[KEY_KEY_7            ] = Key::Seven;  // 7 key
00206                                 irr2ceCODE[KEY_KEY_8            ] = Key::Eight;  // 8 key
00207                                 irr2ceCODE[KEY_KEY_9            ] = Key::Nine;   // 9 key
00208                                 irr2ceCODE[KEY_KEY_A            ] = Key::A;  // A key
00209                                 irr2ceCODE[KEY_KEY_B            ] = Key::B;  // B key
00210                                 irr2ceCODE[KEY_KEY_C            ] = Key::C;  // C key
00211                                 irr2ceCODE[KEY_KEY_D            ] = Key::D;  // D key
00212                                 irr2ceCODE[KEY_KEY_E            ] = Key::E;  // E key
00213                                 irr2ceCODE[KEY_KEY_F            ] = Key::F;  // F key
00214                                 irr2ceCODE[KEY_KEY_G            ] = Key::G;  // G key
00215                                 irr2ceCODE[KEY_KEY_H            ] = Key::H;  // H key
00216                                 irr2ceCODE[KEY_KEY_I            ] = Key::I;  // I key
00217                                 irr2ceCODE[KEY_KEY_J            ] = Key::J;  // J key
00218                                 irr2ceCODE[KEY_KEY_K            ] = Key::K;  // K key
00219                                 irr2ceCODE[KEY_KEY_L            ] = Key::L;  // L key
00220                                 irr2ceCODE[KEY_KEY_M            ] = Key::M;  // M key
00221                                 irr2ceCODE[KEY_KEY_N            ] = Key::N;  // N key
00222                                 irr2ceCODE[KEY_KEY_O            ] = Key::O;  // O key
00223                                 irr2ceCODE[KEY_KEY_P            ] = Key::P;  // P key
00224                                 irr2ceCODE[KEY_KEY_Q            ] = Key::Q;  // Q key
00225                                 irr2ceCODE[KEY_KEY_R            ] = Key::R;  // R key
00226                                 irr2ceCODE[KEY_KEY_S            ] = Key::S;  // S key
00227                                 irr2ceCODE[KEY_KEY_T            ] = Key::T;  // T key
00228                                 irr2ceCODE[KEY_KEY_U            ] = Key::U;  // U key
00229                                 irr2ceCODE[KEY_KEY_V            ] = Key::V;  // V key
00230                                 irr2ceCODE[KEY_KEY_W            ] = Key::W;  // W key
00231                                 irr2ceCODE[KEY_KEY_X            ] = Key::X;  // X key
00232                                 irr2ceCODE[KEY_KEY_Y            ] = Key::Y;  // Y key
00233                                 irr2ceCODE[KEY_KEY_Z            ] = Key::Z;  // Z key
00234                                 irr2ceCODE[KEY_LWIN             ] = Key::LeftWindows;  // Left Windows key (Microsoft® Natural® keyboard)
00235                                 irr2ceCODE[KEY_RWIN             ] = Key::RightWindow;  // Right Windows key (Natural keyboard)
00236                                 irr2ceCODE[KEY_APPS             ] = Key::AppMenu;  //Applications key (Natural keyboard)
00237                                 irr2ceCODE[KEY_SLEEP            ] = Key::Sleep;  // Computer Sleep key
00238                                 irr2ceCODE[KEY_NUMPAD0          ] = Key::Numpad0;  // Numeric keypad 0 key
00239                                 irr2ceCODE[KEY_NUMPAD1          ] = Key::Numpad1;  // Numeric keypad 1 key
00240                                 irr2ceCODE[KEY_NUMPAD2          ] = Key::Numpad2;  // Numeric keypad 2 key
00241                                 irr2ceCODE[KEY_NUMPAD3          ] = Key::Numpad3;  // Numeric keypad 3 key
00242                                 irr2ceCODE[KEY_NUMPAD4          ] = Key::Numpad4;  // Numeric keypad 4 key
00243                                 irr2ceCODE[KEY_NUMPAD5          ] = Key::Numpad5;  // Numeric keypad 5 key
00244                                 irr2ceCODE[KEY_NUMPAD6          ] = Key::Numpad6;  // Numeric keypad 6 key
00245                                 irr2ceCODE[KEY_NUMPAD7          ] = Key::Numpad7;  // Numeric keypad 7 key
00246                                 irr2ceCODE[KEY_NUMPAD8          ] = Key::Numpad8;  // Numeric keypad 8 key
00247                                 irr2ceCODE[KEY_NUMPAD9          ] = Key::Numpad9;  // Numeric keypad 9 key
00248                                 irr2ceCODE[KEY_MULTIPLY         ] = Key::Multiply;  // Multiply key
00249                                 irr2ceCODE[KEY_ADD              ] = Key::Add;  // Add key
00250                                 irr2ceCODE[KEY_SEPARATOR        ] = 0;  // Separator key
00251                                 irr2ceCODE[KEY_SUBTRACT         ] = Key::Subtract;  // Subtract key
00252                                 irr2ceCODE[KEY_DECIMAL          ] = Key::Decimal;  // Decimal key
00253                                 irr2ceCODE[KEY_DIVIDE           ] = Key::Divide;  // Divide key
00254                                 irr2ceCODE[KEY_F1               ] = Key::F1;   // F1 key
00255                                 irr2ceCODE[KEY_F2               ] = Key::F2;   // F2 key
00256                                 irr2ceCODE[KEY_F3               ] = Key::F3;   // F3 key
00257                                 irr2ceCODE[KEY_F4               ] = Key::F4;   // F4 key
00258                                 irr2ceCODE[KEY_F5               ] = Key::F5;   // F5 key
00259                                 irr2ceCODE[KEY_F6               ] = Key::F6;   // F6 key
00260                                 irr2ceCODE[KEY_F7               ] = Key::F7;   // F7 key
00261                                 irr2ceCODE[KEY_F8               ] = Key::F8;   // F8 key
00262                                 irr2ceCODE[KEY_F9               ] = Key::F9;   // F9 key
00263                                 irr2ceCODE[KEY_F10              ] = Key::F10;  // F10 key
00264                                 irr2ceCODE[KEY_F11              ] = Key::F11;  // F11 key
00265                                 irr2ceCODE[KEY_F12              ] = Key::F12;  // F12 key
00266                                 irr2ceCODE[KEY_F13              ] = Key::F13;  // F13 key
00267                                 irr2ceCODE[KEY_F14              ] = Key::F14;  // F14 key
00268                                 irr2ceCODE[KEY_F15              ] = Key::F15;  // F15 key
00269                                 irr2ceCODE[KEY_F16              ] = 0;  // F16 key
00270                                 irr2ceCODE[KEY_F17              ] = 0;  // F17 key
00271                                 irr2ceCODE[KEY_F18              ] = 0;  // F18 key
00272                                 irr2ceCODE[KEY_F19              ] = 0;  // F19 key
00273                                 irr2ceCODE[KEY_F20              ] = 0;  // F20 key
00274                                 irr2ceCODE[KEY_F21              ] = 0;  // F21 key
00275                                 irr2ceCODE[KEY_F22              ] = 0;  // F22 key
00276                                 irr2ceCODE[KEY_F23              ] = 0;  // F23 key
00277                                 irr2ceCODE[KEY_F24              ] = 0;  // F24 key
00278                                 irr2ceCODE[KEY_NUMLOCK          ] = Key::NumLock;  // NUM LOCK key
00279                                 irr2ceCODE[KEY_SCROLL           ] = Key::ScrollLock;  // SCROLL LOCK key
00280                                 irr2ceCODE[KEY_LSHIFT           ] = Key::LeftShift;  // Left SHIFT key
00281                                 irr2ceCODE[KEY_RSHIFT           ] = Key::RightShift;  // Right SHIFT key
00282                                 irr2ceCODE[KEY_LCONTROL         ] = Key::LeftControl;  // Left CONTROL key
00283                                 irr2ceCODE[KEY_RCONTROL         ] = Key::RightControl;  // Right CONTROL key
00284                                 irr2ceCODE[KEY_LMENU            ] = Key::LeftAlt;  // Left MENU key
00285                                 irr2ceCODE[KEY_RMENU            ] = Key::RightAlt;  // Right MENU key
00286                                 irr2ceCODE[KEY_COMMA            ] = Key::Comma;//0xBC;  // Comma Key  (;)
00287                                 irr2ceCODE[KEY_PLUS             ] = Key::Add;  // Plus Key   (+)
00288                                 irr2ceCODE[KEY_MINUS            ] = Key::Minus;  // Minus Key  (-)
00289                                 irr2ceCODE[KEY_PERIOD           ] = Key::Period;//0xBE;  // Period Key (.)
00290                                 irr2ceCODE[KEY_ATTN             ] = 0;  // Attn key
00291                                 irr2ceCODE[KEY_CRSEL            ] = 0;  // CrSel key
00292                                 irr2ceCODE[KEY_EXSEL            ] = 0;  // ExSel key
00293                                 irr2ceCODE[KEY_EREOF            ] = 0;  // Erase EOF key
00294                                 irr2ceCODE[KEY_PLAY             ] = 0;  // Play key
00295                                 irr2ceCODE[KEY_ZOOM             ] = 0;  // Zoom key
00296                                 irr2ceCODE[KEY_PA1              ] = 0;  // PA1 key
00297                                 irr2ceCODE[KEY_OEM_CLEAR        ] = 0;  // Clear key
00298                         }
00299
00307                         uchar getKeyCode(irr::EKEY_CODE kc)
00308                         {
00309                                 return irr2ceCODE[kc];
00310                         }
00311
00312
00313         };
00314
00315 }
00316
00317
00318 #endif
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: irrlichtrenderer.h Source File

include » renderers » IrrlichtRenderer

irrlichtrenderer.h

00001 /************************************************************************
00002         filename:       irrlichtrenderer.h
00003         created:        20/7/2004
00004         author:         Thomas Suter
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef _CEGUI_IrrlichtRenderer_h_
00025 #define _CEGUI_IrrlichtRenderer_h_
00026
00027 #include "IrrlichtRendererDef.h"
00028 #include "irrlichttexture.h"
00029 #include "IrrlichtResourceProvider.h"
00030
00031 #include "CEGUIRenderer.h"
00032 #include "CEGUIInputEvent.h"
00033
00034 #include <irrlicht.h>
00035
00036 #include <vector>
00037 #include <algorithm>
00038
00039 #if defined(_MSC_VER)
00040 #       pragma warning(push)
00041 #       pragma warning(disable : 4251)
00042 #endif
00043
00044 namespace CEGUI
00045 {
00046
00047         class EventPusher;
00048
00054         class IRRLICHT_GUIRENDERER_API IrrlichtRenderer: public Renderer
00055         {
00056         public:
00057
00068                 IrrlichtRenderer(irr::IrrlichtDevice* dev,bool bWithIrrlichtResourceProvicer=false);
00069
00071                 virtual ~IrrlichtRenderer();
00072
00073
00077                 virtual ResourceProvider* createResourceProvider(void);
00078
00080                 bool OnEvent(irr::SEvent& event);
00081
00082
00083                 /*************************************************************************
00084                 Abstract interface methods
00085                 *************************************************************************/
00111                 virtual void    addQuad(const Rect& dest_rect, float z, const Texture* tex,
00112                         const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00113
00114
00124                 virtual void    doRender(void);
00125
00126
00134                 virtual void    clearRenderList(void);
00135
00136
00152                 virtual void    setQueueingEnabled(bool setting);
00153
00154
00163                 virtual Texture*        createTexture(void);
00164
00165
00185                 virtual Texture*        createTexture(const String& filename, const String& resourceGroup);
00186
00187
00203                 virtual Texture*        createTexture(float size);
00204
00205
00216                 virtual void            destroyTexture(Texture* texture);
00217
00218
00226                 virtual void            destroyAllTextures(void);
00227
00228
00236                 virtual bool    isQueueingEnabled(void) const;
00237
00238
00246                 virtual float   getWidth(void) const;
00247
00248
00256                 virtual float   getHeight(void) const;
00257
00258
00266                 virtual Size    getSize(void) const;
00267
00268
00277                 virtual Rect    getRect(void) const;
00278
00279
00287                 virtual uint    getMaxTextureSize(void) const;
00288
00289
00297                 virtual uint    getHorzScreenDPI(void) const;
00298
00299
00307                 virtual uint    getVertScreenDPI(void) const;
00308
00309                 private:
00310
00311                         // the irrlicht device
00312                         irr::IrrlichtDevice* device;
00313                         // video driver
00314                         irr::video::IVideoDriver* driver;
00315                         // window width,height
00316                         irr::core::dimension2d<irr::s32> resolution;
00317                         // screen resolution
00318                         irr::core::dimension2d<irr::s32> screensize;
00319
00320                         // is queueing enabled
00321                         bool bQueuingEnabled;
00322                         // is quad queue sorted
00323                         bool bSorted;
00324                         // enable irrlicht resource provider
00325                         bool bWithIrrlichtResourceProvicer;
00326
00327                         // quad structure used for rendering the gui
00328                         struct RenderQuad
00329                         {
00330                                 RenderQuad(){};
00331
00332                                 RenderQuad(float zVal,
00333                                         const irr::core::rect<irr::s32>& target,
00334                                         const irr::core::rect<irr::s32>& source,
00335                                         ColourRect col,const Texture*t)
00336                                         :z(zVal),dst(target),src(source),colours(col){
00337                                                 tex=(IrrlichtTexture*)t;
00338                                         };
00339
00340                                 float z;
00341                                 irr::core::rect<irr::s32> dst;
00342                                 irr::core::rect<irr::s32> src;
00343                                 ColourRect colours;
00344                                 IrrlichtTexture* tex;
00345                         };
00346
00347                         RenderQuad dummyQuad;
00348
00349                         // std sorting RenderQuad class
00350                         struct quadsorter
00351                                 : public std::binary_function<RenderQuad*, RenderQuad*, bool>
00352                         {
00353                                 bool operator()(const RenderQuad& _Left, const RenderQuad& _Right) const
00354                                 {return (_Left.z > _Right.z);}
00355                         };
00356
00357                         // list ot quads we want to render
00358                         std::vector<RenderQuad> renderlist;
00359
00360                         // list of textures used for rendering
00361                         std::vector<IrrlichtTexture*> textures;
00362
00363                         // sort the quads in the renderlist
00364                         void sortQuads();
00365
00366                         // render the quad
00367                         void doRender(RenderQuad& quad);
00368
00369                         // print some debug output
00370                         void print(RenderQuad& quad);
00371
00372                         // convert cegui colour to irrlicht scolor
00373                         inline irr::video::SColor toIrrlichtColor(CEGUI::ulong cecolor);
00374                         irr::video::SColor colors[4];
00375
00376
00377
00378                         EventPusher* eventpusher;
00379
00380         };
00381
00382 } // End of  CEGUI namespace section
00383
00384 #if defined(_MSC_VER)
00385 #       pragma warning(pop)
00386 #endif
00387
00388 #endif
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: IrrlichtRendererDef.h Source File

include » renderers » IrrlichtRenderer

IrrlichtRendererDef.h

00001 /************************************************************************
00002 filename:       IrrlichtRendererDef.h
00003 created:        20/7/2004
00004 author:         Thomas Suter
00005
00006 changes:
00007 - Irrlicht patching not needed anymore
00008 - using the irrlicht filesystem to load config files etc.
00009 *************************************************************************/
00010
00011 /*************************************************************************
00012 Crazy Eddie's GUI System (http://www.cegui.org.uk)
00013 Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00014
00015 This library is free software; you can redistribute it and/or
00016 modify it under the terms of the GNU Lesser General Public
00017 License as published by the Free Software Foundation; either
00018 version 2.1 of the License, or (at your option) any later version.
00019
00020 This library is distributed in the hope that it will be useful,
00021 but WITHOUT ANY WARRANTY; without even the implied warranty of
00022 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00023 Lesser General Public License for more details.
00024
00025 You should have received a copy of the GNU Lesser General Public
00026 License along with this library; if not, write to the Free Software
00027 Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00028 *************************************************************************/
00029
00030 /*
00031         Beginning from version 0.7 Irrlicht does NOT need any changes for the GUI-renderer.
00032         Thanks to Nikolaus Gebhardt for including the missing methods in the renderer.
00033 */
00034
00035 #ifndef IRRLICHTRENDERERDEF_H_INCLUDED
00036 #define IRRLICHTRENDERERDEF_H_INCLUDED
00037
00038 #if defined( __WIN32__ ) || defined( _WIN32 ) || defined (WIN32)
00039 #   ifdef IRRRENDERER_EXPORTS
00040 #       define IRRLICHT_GUIRENDERER_API __declspec(dllexport)
00041 #   else
00042 #       define IRRLICHT_GUIRENDERER_API __declspec(dllimport)
00043 #   endif
00044 #else
00045 #   define IRRLICHT_GUIRENDERER_API
00046 #endif
00047
00048 #endif
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: IrrlichtResourceProvider.h Source File

include » renderers » IrrlichtRenderer

IrrlichtResourceProvider.h

00001 /************************************************************************
00002 filename:       IrrlichtResourceProvider.h
00003 created:        12/22/2004
00004 author:         Thomas Suter
00005
00006 purpose:        DImplements the Resource Provider common functionality
00007 *************************************************************************/
00008 /*************************************************************************
00009 Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010 Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012 This library is free software; you can redistribute it and/or
00013 modify it under the terms of the GNU Lesser General Public
00014 License as published by the Free Software Foundation; either
00015 version 2.1 of the License, or (at your option) any later version.
00016
00017 This library is distributed in the hope that it will be useful,
00018 but WITHOUT ANY WARRANTY; without even the implied warranty of
00019 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020 Lesser General Public License for more details.
00021
00022 You should have received a copy of the GNU Lesser General Public
00023 License along with this library; if not, write to the Free Software
00024 Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _CEGUIIrrlichtResourceProvider_h_
00027 #define _CEGUIIrrlichtResourceProvider_h_
00028
00029 #include "IrrlichtRendererDef.h"
00030 #include "CEGUIResourceProvider.h"
00031 #include <IFileSystem.h>
00032 // Start of CEGUI namespace section
00033 namespace CEGUI
00034 {
00035         class IRRLICHT_GUIRENDERER_API IrrlichtResourceProvider : public ResourceProvider
00036         {
00037         protected:
00038                 irr::io::IFileSystem* fsys;
00039         public:
00040                 /*************************************************************************
00041                 Construction and Destruction
00042                 *************************************************************************/
00043                 IrrlichtResourceProvider(irr::io::IFileSystem* fsys_);
00044
00045                 ~IrrlichtResourceProvider(void) ;
00046
00047                 void loadRawDataContainer(const String& filename, RawDataContainer& output, const String& resourceGroup);
00048         void unloadRawDataContainer(RawDataContainer& data);
00049         };
00050
00051 } // End of  CEGUI namespace section
00052
00053 #endif  // end of guard _CEGUIIrrlichtResourceProvider_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: irrlichttexture.h Source File

include » renderers » IrrlichtRenderer

irrlichttexture.h

00001 /************************************************************************
00002         filename:       irrlichttexture.h
00003         created:        20/7/2004
00004         author:         Thomas Suter
00005 *************************************************************************/
00006 /*************************************************************************
00007     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00008     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00009
00010     This library is free software; you can redistribute it and/or
00011     modify it under the terms of the GNU Lesser General Public
00012     License as published by the Free Software Foundation; either
00013     version 2.1 of the License, or (at your option) any later version.
00014
00015     This library is distributed in the hope that it will be useful,
00016     but WITHOUT ANY WARRANTY; without even the implied warranty of
00017     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00018     Lesser General Public License for more details.
00019
00020     You should have received a copy of the GNU Lesser General Public
00021     License along with this library; if not, write to the Free Software
00022     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00023 *************************************************************************/
00024 #ifndef IRRLICHTTEXTURE_H_INCLUDED
00025 #define IRRLICHTTEXTURE_H_INCLUDED
00026
00027 #include "IrrlichtRendererDef.h"
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIRenderer.h"
00031 #include "CEGUITexture.h"
00032
00033 #include <irrlicht.h>
00034
00035 namespace CEGUI
00036 {
00037         class IRRLICHT_GUIRENDERER_API IrrlichtTexture : public Texture
00038         {
00039         public:
00040
00041                 // constructor
00042                 IrrlichtTexture(Renderer* r, irr::IrrlichtDevice* device);
00043
00044                 // destructor
00045                 virtual ~IrrlichtTexture();
00046
00047                 // returns the irrlich texture
00048                 irr::video::ITexture* getTexture();
00049
00050                 // set the irrlicht texture
00051                 void setTexture(irr::video::ITexture* texture);
00052
00053
00061                 virtual ushort  getWidth(void) const;
00062
00063
00071                 virtual ushort  getHeight(void) const;
00072
00073
00087                 virtual void    loadFromFile(const String& filename, const String& resourceGroup);
00088
00089
00106                 virtual void    loadFromMemory(const void* buffPtr, uint buffWidth, uint buffHeight);
00107
00108         private:
00109
00110                 // counter for unique texture names
00111                 static int iTextureNumber;
00112
00113                 // generate a unique name
00114                 static irr::core::stringc getUniqueName(void);
00115
00116                 // remove the texture from irrlicht textures
00117                 void freeTexture();
00118
00119                 // the current texture for rendering
00120                 irr::video::ITexture* tex;
00121
00122                 // the irrlicht video driver
00123                 irr::video::IVideoDriver* driver;
00124
00125                 // the irrlicht device
00126                 irr::IrrlichtDevice* device;
00127
00128         };
00129 }
00130 #endif
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: macPlugins.h Source File

src » implementations » mac

macPlugins.h

00001 /*
00002 -----------------------------------------------------------------------------
00003 This source file is part of CrazyEddiesGUI
00004     (but borrowed from OGRE, see http://www.ogre3d.org/)
00005
00006 Copyright � 2000-2002 The OGRE Team
00007 Also see acknowledgements in Readme.html
00008
00009 This program is free software; you can redistribute it and/or modify it under
00010 the terms of the GNU Lesser General  License as published by the Free Software
00011 Foundation; either version 2 of the License, or (at your option) any later
00012 version.
00013
00014 This program is distributed in the hope that it will be useful, but WITHOUT
00015 ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
00016 FOR A PARTICULAR PURPOSE. See the GNU Lesser General  License for more details.
00017
00018 You should have received a copy of the GNU Lesser General  License along with
00019 this program; if not, write to the Free Software Foundation, Inc., 59 Temple
00020 Place - Suite 330, Boston, MA 02111-1307, USA, or go to
00021 http://www.gnu.org/copyleft/lesser.txt.
00022 -----------------------------------------------------------------------------
00023 */
00024
00025 #include <CoreFoundation/CoreFoundation.h>
00026
00027 namespace CEGUI {
00028
00029      CFBundleRef mac_loadExeBundle(const char *path);
00030      void * mac_getBundleSym(CFBundleRef bundle, const char *name);
00031      bool mac_unloadExeBundle(CFBundleRef bundle);
00032      const char *mac_errorBundle();
00033 }
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • DimensionOperator : CEGUI
  • DimensionType : CEGUI
  • FontFlag : CEGUI
  • FontMetricType : CEGUI
  • FrameImageComponent : CEGUI
  • FrameLocation : CEGUI
  • HorizontalAlignment : CEGUI
  • HorizontalFormatting : CEGUI
  • HorizontalTextFormatting : CEGUI
  • LoggingLevel : CEGUI
  • MetricsMode : CEGUI
  • MouseButton : CEGUI
  • MouseCursorImage : CEGUI
  • OrientationFlags : CEGUI
  • QuadSplitMode : CEGUI
  • SystemKey : CEGUI
  • TextFormatting : CEGUI
  • VerticalAlignment : CEGUI
  • VerticalFormatting : CEGUI
  • VerticalTextFormatting : CEGUI
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • n
  • r
  • s
  • t
  • v
  • w
  • x

- a -

  • Absolute : CEGUI
  • Alt : CEGUI

- b -

  • BlankMouseCursor : CEGUI
  • BottomLeftToTopRight : CEGUI

- c -

  • Centred : CEGUI
  • Control : CEGUI

- d -

  • Default : CEGUI
  • DefaultMouseCursor : CEGUI
  • DOP_ADD : CEGUI
  • DOP_DIVIDE : CEGUI
  • DOP_MULTIPLY : CEGUI
  • DOP_NOOP : CEGUI
  • DOP_SUBTRACT : CEGUI
  • DT_BOTTOM_EDGE : CEGUI
  • DT_HEIGHT : CEGUI
  • DT_INVALID : CEGUI
  • DT_LEFT_EDGE : CEGUI
  • DT_RIGHT_EDGE : CEGUI
  • DT_TOP_EDGE : CEGUI
  • DT_WIDTH : CEGUI
  • DT_X_OFFSET : CEGUI
  • DT_X_POSITION : CEGUI
  • DT_Y_OFFSET : CEGUI
  • DT_Y_POSITION : CEGUI

- e -

  • Errors : CEGUI

- f -

  • FIC_BACKGROUND : CEGUI
  • FIC_BOTTOM_EDGE : CEGUI
  • FIC_BOTTOM_LEFT_CORNER : CEGUI
  • FIC_BOTTOM_RIGHT_CORNER : CEGUI
  • FIC_FRAME_IMAGE_COUNT : CEGUI
  • FIC_LEFT_EDGE : CEGUI
  • FIC_RIGHT_EDGE : CEGUI
  • FIC_TOP_EDGE : CEGUI
  • FIC_TOP_LEFT_CORNER : CEGUI
  • FIC_TOP_RIGHT_CORNER : CEGUI
  • FlipHorizontal : CEGUI
  • FlipVertical : CEGUI
  • FMT_BASELINE : CEGUI
  • FMT_HORZ_EXTENT : CEGUI
  • FMT_LINE_SPACING : CEGUI

- h -

  • HA_CENTRE : CEGUI
  • HA_LEFT : CEGUI
  • HA_RIGHT : CEGUI
  • HF_CENTRE_ALIGNED : CEGUI
  • HF_LEFT_ALIGNED : CEGUI
  • HF_RIGHT_ALIGNED : CEGUI
  • HF_STRETCHED : CEGUI
  • HF_TILED : CEGUI
  • HTF_CENTRE_ALIGNED : CEGUI
  • HTF_JUSTIFIED : CEGUI
  • HTF_LEFT_ALIGNED : CEGUI
  • HTF_RIGHT_ALIGNED : CEGUI
  • HTF_WORDWRAP_CENTRE_ALIGNED : CEGUI
  • HTF_WORDWRAP_JUSTIFIED : CEGUI
  • HTF_WORDWRAP_LEFT_ALIGNED : CEGUI
  • HTF_WORDWRAP_RIGHT_ALIGNED : CEGUI

- i -

  • Informative : CEGUI
  • Inherited : CEGUI
  • Insane : CEGUI

- j -

  • Justified : CEGUI

- l -

  • LeftAligned : CEGUI
  • LeftMouse : CEGUI

- m -

  • MiddleMouse : CEGUI

- n -

  • NoAntiAlias : CEGUI
  • NoButton : CEGUI

- r -

  • Relative : CEGUI
  • RightAligned : CEGUI
  • RightMouse : CEGUI
  • RotateRightAngle : CEGUI

- s -

  • Shift : CEGUI
  • Standard : CEGUI

- t -

  • TopLeftToBottomRight : CEGUI

- v -

  • VA_BOTTOM : CEGUI
  • VA_CENTRE : CEGUI
  • VA_TOP : CEGUI
  • VF_BOTTOM_ALIGNED : CEGUI
  • VF_CENTRE_ALIGNED : CEGUI
  • VF_STRETCHED : CEGUI
  • VF_TILED : CEGUI
  • VF_TOP_ALIGNED : CEGUI
  • VTF_BOTTOM_ALIGNED : CEGUI
  • VTF_CENTRE_ALIGNED : CEGUI
  • VTF_TOP_ALIGNED : CEGUI

- w -

  • WordWrapCentred : CEGUI
  • WordWrapJustified : CEGUI
  • WordWrapLeftAligned : CEGUI
  • WordWrapRightAligned : CEGUI

- x -

  • X1Mouse : CEGUI
  • X2Mouse : CEGUI
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • lbi_greater() : CEGUI
  • lbi_less() : CEGUI
  • operator!=() : CEGUI
  • operator+() : CEGUI
  • operator<() : CEGUI
  • operator<=() : CEGUI
  • operator==() : CEGUI
  • operator>() : CEGUI
  • operator>=() : CEGUI
  • SubscriberRef() : CEGUI
  • swap() : CEGUI
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • argb_t : CEGUI
  • DefaultWindow : CEGUI
  • OutStream : CEGUI
  • Point : CEGUI
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator

  • DefaultNativeHorzRes : CEGUI
  • DefaultNativeVertRes : CEGUI
Generated on Sat Nov 26 10:10:20 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: openglrenderer.h Source File

include » renderers » OpenGLGUIRenderer

openglrenderer.h

00001 /************************************************************************
00002         filename:       openglrenderer.h
00003         created:        9/4/2004
00004         author:         Mark Strom
00005                                 mwstrom@gmail.com
00006
00007         purpose:        Interface to Renderer implemented via Opengl
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _openglrenderer_h_
00028 #define _openglrenderer_h_
00029
00030 #include "CEGUIBase.h"
00031
00032 #if defined( __WIN32__ ) || defined( _WIN32 )
00033 #   ifdef OPENGL_GUIRENDERER_EXPORTS
00034 #       define OPENGL_GUIRENDERER_API __declspec(dllexport)
00035 #   else
00036 #       define OPENGL_GUIRENDERER_API __declspec(dllimport)
00037 #   endif
00038 #else
00039 #   define OPENGL_GUIRENDERER_API
00040 #endif
00041
00042
00043 #if defined(_WIN32)//  All this taken from glut.h
00044 #  ifndef APIENTRY
00045 #   define GLUT_APIENTRY_DEFINED
00046 #   if (_MSC_VER >= 800) || defined(_STDCALL_SUPPORTED) || defined(__BORLANDC__) || defined(__LCC__)
00047 #    define APIENTRY    __stdcall
00048 #   else
00049 #    define APIENTRY
00050 #   endif
00051 #  endif
00052 /* XXX This is from Win32's <winnt.h> */
00053 #  ifndef CALLBACK
00054 #   if (defined(_M_MRX000) || defined(_M_IX86) || defined(_M_ALPHA) || defined(_M_PPC)) && !defined(MIDL_PASS) || defined(__LCC__)
00055 #    define CALLBACK __stdcall
00056 #   else
00057 #    define CALLBACK
00058 #   endif
00059 #  endif
00060 /* XXX Hack for lcc compiler.  It doesn't support __declspec(dllimport), just __stdcall. */
00061 #  if defined( __LCC__ )
00062 #   undef WINGDIAPI
00063 #   define WINGDIAPI __stdcall
00064 #  else
00065 /* XXX This is from Win32's <wingdi.h> and <winnt.h> */
00066 #   ifndef WINGDIAPI
00067 #    define GLUT_WINGDIAPI_DEFINED
00068 #    define WINGDIAPI __declspec(dllimport)
00069 #   endif
00070 #  endif
00071 /* XXX This is from Win32's <ctype.h> */
00072 #  ifndef _WCHAR_T_DEFINED
00073 typedef unsigned short wchar_t;
00074 #   define _WCHAR_T_DEFINED
00075 #  endif
00076 # endif //win32 end glut.h stuff
00077
00078 /* XXX Hack for finding headers in Apple's OpenGL framework. */
00079 #if defined( __APPLE__ )
00080 #include <OpenGL/gl.h>
00081 #include <OpenGL/glu.h>
00082 #else /* __APPLE__ */
00083 #include <GL/gl.h>
00084 #include <GL/glu.h>
00085 #endif /* __APPLE__ */
00086 #include <list>
00087 #include <set>
00088
00089 #include "CEGUIRenderer.h"
00090 #include "CEGUITexture.h"
00091
00092
00093 #if defined(_WIN32)
00094 #  if defined(_DEBUG)
00095 #     pragma comment(lib, "CEGUIBase_d.lib")
00096 #  else
00097 #     pragma comment(lib, "CEGUIBase.lib")
00098 #  endif
00099 #endif
00100
00101 #if defined(_MSC_VER)
00102 #       pragma warning(push)
00103 #       pragma warning(disable : 4251)
00104 #endif
00105
00106 #define OGLRENDERER_VBUFF_CAPACITY      4096
00107
00108
00109 // Start of CEGUI namespace section
00110 namespace CEGUI
00111 {
00112 /*************************************************************************
00113         Forward refs
00114 *************************************************************************/
00115 class OpenGLTexture;
00116
00121 class OPENGL_GUIRENDERER_API OpenGLRenderer : public Renderer
00122 {
00123 public:
00131     OpenGLRenderer(uint max_quads);
00132         OpenGLRenderer(uint max_quads,int width, int height);
00133
00134
00139     virtual ~OpenGLRenderer(void);
00140
00141     // add's a quad to the list to be rendered
00142     virtual     void    addQuad(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00143
00144     // perform final rendering for all queued renderable quads.
00145     virtual     void    doRender(void);
00146
00147     // clear the queue
00148     virtual     void    clearRenderList(void);
00149
00150
00166     virtual void        setQueueingEnabled(bool setting)                {d_queueing = setting;}
00167
00168
00169     // create an empty texture
00170     virtual     Texture*        createTexture(void);
00171
00172     // create a texture and load it with the specified file.
00173     virtual     Texture*        createTexture(const String& filename, const String& resourceGroup);
00174
00175     // create a texture and set it to the specified size
00176     virtual     Texture*        createTexture(float size);
00177
00178     // destroy the given texture
00179     virtual     void            destroyTexture(Texture* texture);
00180
00181     // destroy all textures still active
00182     virtual void                destroyAllTextures(void);
00183
00191     virtual bool        isQueueingEnabled(void) const   {return d_queueing;}
00192
00193
00201     virtual float       getWidth(void) const            {return d_display_area.getWidth();}
00202
00203
00211     virtual float       getHeight(void) const           {return d_display_area.getHeight();}
00212
00213
00221     virtual Size        getSize(void) const                     {return d_display_area.getSize();}
00222
00223
00232     virtual Rect        getRect(void) const                     {return d_display_area;}
00233
00234
00242     virtual     uint    getMaxTextureSize(void) const           {return d_maxTextureSize;}
00243
00244
00252     virtual     uint    getHorzScreenDPI(void) const    {return 96;}
00253
00254
00262     virtual     uint    getVertScreenDPI(void) const    {return 96;}
00263
00264
00282         void    setDisplaySize(const Size& sz);
00283
00284
00291     void grabTextures(void);
00292
00293
00298     void restoreTextures(void);
00299
00300
00301 private:
00302     /************************************************************************
00303                 Implementation Constants
00304     ************************************************************************/
00305     static const int                    VERTEX_PER_QUAD;
00306     static const int                    VERTEX_PER_TRIANGLE;
00307     static const int                    VERTEXBUFFER_CAPACITY;
00308
00309     /*************************************************************************
00310                 Implementation Structs & classes
00311     *************************************************************************/
00312     struct MyQuad
00313     {
00314         float tex[2];
00315         long color;
00316         float vertex[3];
00317     };
00318
00323     struct QuadInfo
00324     {
00325         GLuint          texid;
00326         Rect            position;
00327         float           z;
00328         Rect            texPosition;
00329                 long            topLeftCol;
00330                 long            topRightCol;
00331                 long            bottomLeftCol;
00332                 long            bottomRightCol;
00333
00334         QuadSplitMode   splitMode;
00335
00336                 bool operator<(const QuadInfo& other) const
00337                 {
00338                         // this is intentionally reversed.
00339                         return z > other.z;
00340                 }
00341
00342     };
00343
00344
00345     /*************************************************************************
00346                 Implementation Methods
00347     *************************************************************************/
00348     // setup states etc
00349     void        initPerFrameStates(void);
00350
00351     // restore states
00352     void  exitPerFrameStates(void);
00353
00354     // render whatever is in the vertex buffer
00355     void        renderVBuffer(void);
00356
00357     // sort quads list according to texture
00358     void        sortQuads(void);
00359
00360     // render a quad directly to the display
00361     void        renderQuadDirect(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00362
00363         // convert colour value to whatever the OpenGL system is expecting.
00364         long    colourToOGL(const colour& col) const;
00365
00366         // set the module ID string
00367         void setModuleIdentifierString();
00368
00369
00370     /*************************************************************************
00371             Implementation Data
00372     *************************************************************************/
00373         typedef std::multiset<QuadInfo>         QuadList;
00374         QuadList d_quadlist;
00375
00376         Rect            d_display_area;
00377
00378         MyQuad          myBuff[OGLRENDERER_VBUFF_CAPACITY];
00379
00380         bool            d_queueing;
00381         uint            d_currTexture;
00382         int                     d_bufferPos;
00383         bool            d_sorted;
00384
00385         std::list<OpenGLTexture*>       d_texturelist;
00386         GLint       d_maxTextureSize;
00387 };
00388
00389 } // End of  CEGUI namespace section
00390
00391 #if defined(_MSC_VER)
00392 #       pragma warning(pop)
00393 #endif
00394
00395 #endif  // end of guard _openglrenderer_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: opengltexture.h Source File

include » renderers » OpenGLGUIRenderer

opengltexture.h

00001 /************************************************************************
00002         filename:       opengltexture.h
00003         created:        9/4/2004
00004         author:         Mark Strom
00005                                 mwstrom@gmail.com
00006
00007         purpose:        Interface to Texture implemented via Opengl
00008 *************************************************************************/
00009 /*************************************************************************
00010     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00011     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00012
00013     This library is free software; you can redistribute it and/or
00014     modify it under the terms of the GNU Lesser General Public
00015     License as published by the Free Software Foundation; either
00016     version 2.1 of the License, or (at your option) any later version.
00017
00018     This library is distributed in the hope that it will be useful,
00019     but WITHOUT ANY WARRANTY; without even the implied warranty of
00020     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00021     Lesser General Public License for more details.
00022
00023     You should have received a copy of the GNU Lesser General Public
00024     License along with this library; if not, write to the Free Software
00025     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00026 *************************************************************************/
00027 #ifndef _opengltexture_h_
00028 #define _opengltexture_h_
00029
00030 #include "CEGUIBase.h"
00031 #include "CEGUIRenderer.h"
00032 #include "CEGUITexture.h"
00033 #include "renderers/OpenGLGUIRenderer/openglrenderer.h"
00034
00035 #include <list>
00036
00037
00038 // Start of CEGUI namespace section
00039 namespace CEGUI
00040 {
00041
00046 class OPENGL_GUIRENDERER_API OpenGLTexture : public Texture
00047 {
00048 private:
00049     /*************************************************************************
00050             Friends (to allow construction and destruction)
00051     *************************************************************************/
00052     friend      Texture* OpenGLRenderer::createTexture(void);
00053     friend      Texture* OpenGLRenderer::createTexture(const String& filename, const String& resourceGroup);
00054     friend      Texture* OpenGLRenderer::createTexture(float size);
00055     friend      void     OpenGLRenderer::destroyTexture(Texture* texture);
00056
00057
00058     /*************************************************************************
00059                 Construction & Destruction (by Renderer object only)
00060     *************************************************************************/
00061     OpenGLTexture(Renderer* owner);
00062     virtual ~OpenGLTexture(void);
00063
00064 public:
00072     virtual     ushort  getWidth(void) const            {return d_width;}
00073
00074
00082     virtual     ushort  getHeight(void) const           {return d_height;}
00083
00084
00098     virtual void        loadFromFile(const String& filename, const String& resourceGroup);
00099
00100
00117     virtual void        loadFromMemory(const void* buffPtr, uint buffWidth, uint buffHeight);
00118
00119
00127     GLuint      getOGLTexid(void) const {return d_ogltexture;}
00128
00129
00140     void        setOGLTextureSize(uint size);
00141
00142
00143     /************************************************************************
00144         Grab/restore
00145     *************************************************************************/
00151     void grabTexture(void);
00152
00153
00158     void restoreTexture(void);
00159
00160
00161 private:
00162 #ifndef USE_DEVIL_LIBRARY
00163 // These defines are used to tell us about the type of TARGA file it is
00164 #       define TGA_RGB           2              // This tells us it's a normal RGB (really BGR) file
00165 #       define TGA_A             3              // This tells us it's a ALPHA file
00166 #       define TGA_RLE          10              // This tells us that the targa is Run-Length Encoded (RLE)
00167
00168         /*************************************************************************
00169                 Implementation Struct
00170         *************************************************************************/
00171         // This is our image structure for our targa data
00172         struct tImageTGA
00173         {
00174                 int channels;                   // The channels in the image (3 = RGB : 4 = RGBA)
00175                 int sizeX;                              // The width of the image in pixels
00176                 int sizeY;                              // The height of the image in pixels
00177                 unsigned char *data;    // The image pixel data
00178         };
00179
00180
00181         // flips data for tImageTGA 'img'
00182         static void flipImageTGA(tImageTGA* img);
00183
00184
00185         // Took this code from http://www.gametutorials.com still ne
00186     // tImageTGA *LoadTGA(const char *filename)
00187     //
00188     // This is our cool function that loads the targa (TGA) file, then returns it's data.
00189     // This tutorial supports 16, 24 and 32 bit images, along with RLE compression.
00190     //
00191     //
00192     // Ben Humphrey (DigiBen)
00193     // Game Programmer
00194     // DigiBen@GameTutorials.com
00195     // Co-Web Host of www.GameTutorials.com
00196     //
00197         //
00198         // Modified by Paul D Turner to accept a raw data buffer & it's length
00199         // as input.
00200         //
00201     tImageTGA* OpenGLTexture::LoadTGA(const unsigned char* buffer, size_t buffer_size);
00202
00203 #endif
00204         /*************************************************************************
00205                 Implementation Data
00206         *************************************************************************/
00207     GLuint              d_ogltexture;
00208     ushort              d_width;
00209     ushort              d_height;
00210     uint8*      d_grabBuffer;
00211 };
00212
00213 } // End of  CEGUI namespace section
00214
00215
00216 #endif  // end of guard _opengltexture_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: pcre.h Source File

src » pcre

pcre.h

00001 #ifndef _PCRE_H
00002 #define _PCRE_H
00003
00004 /* The file pcre.h is build by "configure". Do not edit it; instead
00005 make changes to pcre.in. */
00006
00007 #define PCRE_MAJOR      5
00008 #define PCRE_MINOR      0
00009 #define PCRE_DATE       13-Sep-2004
00010
00011
00012 /* Win32 uses DLL by default */
00013 /*
00014 #ifdef _WIN32
00015 #  ifdef PCRE_DEFINITION
00016 #    ifdef DLL_EXPORT
00017 #      define PCRE_DATA_SCOPE __declspec(dllexport)
00018 #    endif
00019 #  else
00020 #    ifndef PCRE_STATIC
00021 #      define PCRE_DATA_SCOPE extern __declspec(dllimport)
00022 #    endif
00023 #  endif
00024 #endif
00025 */
00026
00027 #ifndef PCRE_DATA_SCOPE
00028 #  define PCRE_DATA_SCOPE     extern
00029 #endif
00030
00031 /* Have to include stdlib.h in order to ensure that size_t is defined;
00032 it is needed here for malloc. */
00033
00034 #include <stdlib.h>
00035
00036 /* Allow for C++ users */
00037
00038 #ifdef __cplusplus
00039 extern "C" {
00040 #endif
00041
00042 /* Options */
00043
00044 #define PCRE_CASELESS           0x0001
00045 #define PCRE_MULTILINE          0x0002
00046 #define PCRE_DOTALL             0x0004
00047 #define PCRE_EXTENDED           0x0008
00048 #define PCRE_ANCHORED           0x0010
00049 #define PCRE_DOLLAR_ENDONLY     0x0020
00050 #define PCRE_EXTRA              0x0040
00051 #define PCRE_NOTBOL             0x0080
00052 #define PCRE_NOTEOL             0x0100
00053 #define PCRE_UNGREEDY           0x0200
00054 #define PCRE_NOTEMPTY           0x0400
00055 #define PCRE_UTF8               0x0800
00056 #define PCRE_NO_AUTO_CAPTURE    0x1000
00057 #define PCRE_NO_UTF8_CHECK      0x2000
00058 #define PCRE_AUTO_CALLOUT       0x4000
00059 #define PCRE_PARTIAL            0x8000
00060
00061 /* Exec-time and get/set-time error codes */
00062
00063 #define PCRE_ERROR_NOMATCH         (-1)
00064 #define PCRE_ERROR_NULL            (-2)
00065 #define PCRE_ERROR_BADOPTION       (-3)
00066 #define PCRE_ERROR_BADMAGIC        (-4)
00067 #define PCRE_ERROR_UNKNOWN_NODE    (-5)
00068 #define PCRE_ERROR_NOMEMORY        (-6)
00069 #define PCRE_ERROR_NOSUBSTRING     (-7)
00070 #define PCRE_ERROR_MATCHLIMIT      (-8)
00071 #define PCRE_ERROR_CALLOUT         (-9)  /* Never used by PCRE itself */
00072 #define PCRE_ERROR_BADUTF8        (-10)
00073 #define PCRE_ERROR_BADUTF8_OFFSET (-11)
00074 #define PCRE_ERROR_PARTIAL        (-12)
00075 #define PCRE_ERROR_BADPARTIAL     (-13)
00076 #define PCRE_ERROR_INTERNAL       (-14)
00077 #define PCRE_ERROR_BADCOUNT       (-15)
00078
00079 /* Request types for pcre_fullinfo() */
00080
00081 #define PCRE_INFO_OPTIONS            0
00082 #define PCRE_INFO_SIZE               1
00083 #define PCRE_INFO_CAPTURECOUNT       2
00084 #define PCRE_INFO_BACKREFMAX         3
00085 #define PCRE_INFO_FIRSTBYTE          4
00086 #define PCRE_INFO_FIRSTCHAR          4  /* For backwards compatibility */
00087 #define PCRE_INFO_FIRSTTABLE         5
00088 #define PCRE_INFO_LASTLITERAL        6
00089 #define PCRE_INFO_NAMEENTRYSIZE      7
00090 #define PCRE_INFO_NAMECOUNT          8
00091 #define PCRE_INFO_NAMETABLE          9
00092 #define PCRE_INFO_STUDYSIZE         10
00093 #define PCRE_INFO_DEFAULT_TABLES    11
00094
00095 /* Request types for pcre_config() */
00096
00097 #define PCRE_CONFIG_UTF8                    0
00098 #define PCRE_CONFIG_NEWLINE                 1
00099 #define PCRE_CONFIG_LINK_SIZE               2
00100 #define PCRE_CONFIG_POSIX_MALLOC_THRESHOLD  3
00101 #define PCRE_CONFIG_MATCH_LIMIT             4
00102 #define PCRE_CONFIG_STACKRECURSE            5
00103 #define PCRE_CONFIG_UNICODE_PROPERTIES      6
00104
00105 /* Bit flags for the pcre_extra structure */
00106
00107 #define PCRE_EXTRA_STUDY_DATA          0x0001
00108 #define PCRE_EXTRA_MATCH_LIMIT         0x0002
00109 #define PCRE_EXTRA_CALLOUT_DATA        0x0004
00110 #define PCRE_EXTRA_TABLES              0x0008
00111
00112 /* Types */
00113
00114 struct real_pcre;                 /* declaration; the definition is private  */
00115 typedef struct real_pcre pcre;
00116
00117 /* The structure for passing additional data to pcre_exec(). This is defined in
00118 such as way as to be extensible. Always add new fields at the end, in order to
00119 remain compatible. */
00120
00121 typedef struct pcre_extra {
00122   unsigned long int flags;        /* Bits for which fields are set */
00123   void *study_data;               /* Opaque data from pcre_study() */
00124   unsigned long int match_limit;  /* Maximum number of calls to match() */
00125   void *callout_data;             /* Data passed back in callouts */
00126   const unsigned char *tables;    /* Pointer to character tables */
00127 } pcre_extra;
00128
00129 /* The structure for passing out data via the pcre_callout_function. We use a
00130 structure so that new fields can be added on the end in future versions,
00131 without changing the API of the function, thereby allowing old clients to work
00132 without modification. */
00133
00134 typedef struct pcre_callout_block {
00135   int          version;           /* Identifies version of block */
00136   /* ------------------------ Version 0 ------------------------------- */
00137   int          callout_number;    /* Number compiled into pattern */
00138   int         *offset_vector;     /* The offset vector */
00139   const char  *subject;           /* The subject being matched */
00140   int          subject_length;    /* The length of the subject */
00141   int          start_match;       /* Offset to start of this match attempt */
00142   int          current_position;  /* Where we currently are in the subject */
00143   int          capture_top;       /* Max current capture */
00144   int          capture_last;      /* Most recently closed capture */
00145   void        *callout_data;      /* Data passed in with the call */
00146   /* ------------------- Added for Version 1 -------------------------- */
00147   int          pattern_position;  /* Offset to next item in the pattern */
00148   int          next_item_length;  /* Length of next item in the pattern */
00149   /* ------------------------------------------------------------------ */
00150 } pcre_callout_block;
00151
00152 /* Indirection for store get and free functions. These can be set to
00153 alternative malloc/free functions if required. Special ones are used in the
00154 non-recursive case for "frames". There is also an optional callout function
00155 that is triggered by the (?) regex item. Some magic is required for Win32 DLL;
00156 it is null on other OS. For Virtual Pascal, these have to be different again.
00157 */
00158
00159 #ifndef VPCOMPAT
00160 PCRE_DATA_SCOPE void *(*pcre_malloc)(size_t);
00161 PCRE_DATA_SCOPE void  (*pcre_free)(void *);
00162 PCRE_DATA_SCOPE void *(*pcre_stack_malloc)(size_t);
00163 PCRE_DATA_SCOPE void  (*pcre_stack_free)(void *);
00164 PCRE_DATA_SCOPE int   (*pcre_callout)(pcre_callout_block *);
00165 #else   /* VPCOMPAT */
00166 extern void *pcre_malloc(size_t);
00167 extern void  pcre_free(void *);
00168 extern void *pcre_stack_malloc(size_t);
00169 extern void  pcre_stack_free(void *);
00170 extern int   pcre_callout(pcre_callout_block *);
00171 #endif  /* VPCOMPAT */
00172
00173 /* Exported PCRE functions */
00174
00175 extern pcre *pcre_compile(const char *, int, const char **,
00176               int *, const unsigned char *);
00177 extern int  pcre_config(int, void *);
00178 extern int  pcre_copy_named_substring(const pcre *, const char *,
00179               int *, int, const char *, char *, int);
00180 extern int  pcre_copy_substring(const char *, int *, int, int,
00181               char *, int);
00182 extern int  pcre_exec(const pcre *, const pcre_extra *,
00183               const char *, int, int, int, int *, int);
00184 extern void pcre_free_substring(const char *);
00185 extern void pcre_free_substring_list(const char **);
00186 extern int  pcre_fullinfo(const pcre *, const pcre_extra *, int,
00187               void *);
00188 extern int  pcre_get_named_substring(const pcre *, const char *,
00189               int *, int,  const char *, const char **);
00190 extern int  pcre_get_stringnumber(const pcre *, const char *);
00191 extern int  pcre_get_substring(const char *, int *, int, int,
00192               const char **);
00193 extern int  pcre_get_substring_list(const char *, int *, int,
00194               const char ***);
00195 extern int  pcre_info(const pcre *, int *, int *);
00196 extern const unsigned char *pcre_maketables(void);
00197 extern pcre_extra *pcre_study(const pcre *, int, const char **);
00198 extern const char *pcre_version(void);
00199
00200 #ifdef __cplusplus
00201 }  /* extern "C" */
00202 #endif
00203
00204 #endif /* End of pcre.h */
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: pcreconfig.h Source File

src » pcre

pcreconfig.h

00001 /* On Unix systems config.in is converted by configure into config.h. PCRE is
00002 written in Standard C, but there are a few non-standard things it can cope
00003 with, allowing it to run on SunOS4 and other "close to standard" systems.
00004
00005 On a non-Unix system you should just copy this file into config.h, and set up
00006 the macros the way you need them. You should normally change the definitions of
00007 HAVE_STRERROR and HAVE_MEMMOVE to 1. Unfortunately, because of the way autoconf
00008 works, these cannot be made the defaults. If your system has bcopy() and not
00009 memmove(), change the definition of HAVE_BCOPY instead of HAVE_MEMMOVE. If your
00010 system has neither bcopy() nor memmove(), leave them both as 0; an emulation
00011 function will be used. */
00012
00013 /* CEGUI::String uses utf8, so allow regex support for this. */
00014 #define SUPPORT_UTF8 1
00015
00016 /* If you are compiling for a system that uses EBCDIC instead of ASCII
00017 character codes, define this macro as 1. On systems that can use "configure",
00018 this can be done via --enable-ebcdic. */
00019
00020 #ifndef EBCDIC
00021 #define EBCDIC 0
00022 #endif
00023
00024 /* If you are compiling for a system that needs some magic to be inserted
00025 before the definition of an exported function, define this macro to contain the
00026 relevant magic. It apears at the start of every exported function. */
00027
00028 #define EXPORT
00029
00030 /* Define to empty if the "const" keyword does not work. */
00031
00032 #undef const
00033
00034 /* Define to "unsigned" if <stddef.h> doesn't define size_t. */
00035
00036 #undef size_t
00037
00038 /* The following two definitions are mainly for the benefit of SunOS4, which
00039 doesn't have the strerror() or memmove() functions that should be present in
00040 all Standard C libraries. The macros HAVE_STRERROR and HAVE_MEMMOVE should
00041 normally be defined with the value 1 for other systems, but unfortunately we
00042 can't make this the default because "configure" files generated by autoconf
00043 will only change 0 to 1; they won't change 1 to 0 if the functions are not
00044 found. */
00045
00046 #define HAVE_STRERROR 1
00047 #define HAVE_MEMMOVE  1
00048
00049 /* There are some non-Unix systems that don't even have bcopy(). If this macro
00050 is false, an emulation is used. If HAVE_MEMMOVE is set to 1, the value of
00051 HAVE_BCOPY is not relevant. */
00052
00053 #define HAVE_BCOPY    0
00054
00055 /* The value of NEWLINE determines the newline character. The default is to
00056 leave it up to the compiler, but some sites want to force a particular value.
00057 On Unix systems, "configure" can be used to override this default. */
00058
00059 #ifndef NEWLINE
00060 #define NEWLINE '\n'
00061 #endif
00062
00063 /* The value of LINK_SIZE determines the number of bytes used to store
00064 links as offsets within the compiled regex. The default is 2, which allows for
00065 compiled patterns up to 64K long. This covers the vast majority of cases.
00066 However, PCRE can also be compiled to use 3 or 4 bytes instead. This allows for
00067 longer patterns in extreme cases. On Unix systems, "configure" can be used to
00068 override this default. */
00069
00070 #ifndef LINK_SIZE
00071 #define LINK_SIZE   2
00072 #endif
00073
00074 /* The value of MATCH_LIMIT determines the default number of times the match()
00075 function can be called during a single execution of pcre_exec(). (There is a
00076 runtime method of setting a different limit.) The limit exists in order to
00077 catch runaway regular expressions that take for ever to determine that they do
00078 not match. The default is set very large so that it does not accidentally catch
00079 legitimate cases. On Unix systems, "configure" can be used to override this
00080 default default. */
00081
00082 #ifndef MATCH_LIMIT
00083 #define MATCH_LIMIT 10000000
00084 #endif
00085
00086 /* When calling PCRE via the POSIX interface, additional working storage is
00087 required for holding the pointers to capturing substrings because PCRE requires
00088 three integers per substring, whereas the POSIX interface provides only two. If
00089 the number of expected substrings is small, the wrapper function uses space on
00090 the stack, because this is faster than using malloc() for each call. The
00091 threshold above which the stack is no longer use is defined by POSIX_MALLOC_
00092 THRESHOLD. On Unix systems, "configure" can be used to override this default.
00093 */
00094
00095 #ifndef POSIX_MALLOC_THRESHOLD
00096 #define POSIX_MALLOC_THRESHOLD 10
00097 #endif
00098
00099 /* PCRE uses recursive function calls to handle backtracking while matching.
00100 This can sometimes be a problem on systems that have stacks of limited size.
00101 Define NO_RECURSE to get a version that doesn't use recursion in the match()
00102 function; instead it creates its own stack by steam using pcre_recurse_malloc
00103 to get memory. For more detail, see comments and other stuff just above the
00104 match() function. On Unix systems, "configure" can be used to set this in the
00105 Makefile (use --disable-stack-for-recursion). */
00106
00107 /* #define NO_RECURSE */
00108
00109 /* End */
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: pcreposix.h Source File

src » pcre

pcreposix.h

00001 /*************************************************
00002 *       Perl-Compatible Regular Expressions      *
00003 *************************************************/
00004
00005 #ifndef _PCREPOSIX_H
00006 #define _PCREPOSIX_H
00007
00008 /* This is the header for the POSIX wrapper interface to the PCRE Perl-
00009 Compatible Regular Expression library. It defines the things POSIX says should
00010 be there. I hope.
00011
00012             Copyright (c) 1997-2004 University of Cambridge
00013
00014 -----------------------------------------------------------------------------
00015 Redistribution and use in source and binary forms, with or without
00016 modification, are permitted provided that the following conditions are met:
00017
00018     * Redistributions of source code must retain the above copyright notice,
00019       this list of conditions and the following disclaimer.
00020
00021     * Redistributions in binary form must reproduce the above copyright
00022       notice, this list of conditions and the following disclaimer in the
00023       documentation and/or other materials provided with the distribution.
00024
00025     * Neither the name of the University of Cambridge nor the names of its
00026       contributors may be used to endorse or promote products derived from
00027       this software without specific prior written permission.
00028
00029 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00030 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00031 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
00032 ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
00033 LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
00034 CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
00035 SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
00036 INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
00037 CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
00038 ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
00039 POSSIBILITY OF SUCH DAMAGE.
00040 -----------------------------------------------------------------------------
00041 */
00042
00043 /* Have to include stdlib.h in order to ensure that size_t is defined. */
00044
00045 #include <stdlib.h>
00046
00047 /* Allow for C++ users */
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00053 /* Options defined by POSIX. */
00054
00055 #define REG_ICASE     0x01
00056 #define REG_NEWLINE   0x02
00057 #define REG_NOTBOL    0x04
00058 #define REG_NOTEOL    0x08
00059
00060 /* These are not used by PCRE, but by defining them we make it easier
00061 to slot PCRE into existing programs that make POSIX calls. */
00062
00063 #define REG_EXTENDED  0
00064 #define REG_NOSUB     0
00065
00066 /* Error values. Not all these are relevant or used by the wrapper. */
00067
00068 enum {
00069   REG_ASSERT = 1,  /* internal error ? */
00070   REG_BADBR,       /* invalid repeat counts in {} */
00071   REG_BADPAT,      /* pattern error */
00072   REG_BADRPT,      /* ? * + invalid */
00073   REG_EBRACE,      /* unbalanced {} */
00074   REG_EBRACK,      /* unbalanced [] */
00075   REG_ECOLLATE,    /* collation error - not relevant */
00076   REG_ECTYPE,      /* bad class */
00077   REG_EESCAPE,     /* bad escape sequence */
00078   REG_EMPTY,       /* empty expression */
00079   REG_EPAREN,      /* unbalanced () */
00080   REG_ERANGE,      /* bad range inside [] */
00081   REG_ESIZE,       /* expression too big */
00082   REG_ESPACE,      /* failed to get memory */
00083   REG_ESUBREG,     /* bad back reference */
00084   REG_INVARG,      /* bad argument */
00085   REG_NOMATCH      /* match failed */
00086 };
00087
00088
00089 /* The structure representing a compiled regular expression. */
00090
00091 typedef struct {
00092   void *re_pcre;
00093   size_t re_nsub;
00094   size_t re_erroffset;
00095 } regex_t;
00096
00097 /* The structure in which a captured offset is returned. */
00098
00099 typedef int regoff_t;
00100
00101 typedef struct {
00102   regoff_t rm_so;
00103   regoff_t rm_eo;
00104 } regmatch_t;
00105
00106 /* The functions */
00107
00108 extern int regcomp(regex_t *, const char *, int);
00109 extern int regexec(const regex_t *, const char *, size_t, regmatch_t *, int);
00110 extern size_t regerror(int, const regex_t *, char *, size_t);
00111 extern void regfree(regex_t *);
00112
00113 #ifdef __cplusplus
00114 }   /* extern "C" */
00115 #endif
00116
00117 #endif /* End of pcreposix.h */
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: renderer.h Source File

include » renderers » directx81GUIRenderer

renderer.h

00001 /************************************************************************
00002         filename:       renderer.h
00003         created:        15/3/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Interface for DirectX 8.1 Renderer class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 /*************************************************************************
00027         This file contains code that is specific to Win32 and DirectX
00028 *************************************************************************/
00029 #ifndef _DirectX81GUIRenderer_h_
00030 #define _DirectX81GUIRenderer_h_
00031
00032 #ifdef DIRECTX81_GUIRENDERER_EXPORTS
00033 #define DIRECTX81_GUIRENDERER_API __declspec(dllexport)
00034 #else
00035 #define DIRECTX81_GUIRENDERER_API __declspec(dllimport)
00036 #endif
00037
00038 #include "CEGUIBase.h"
00039 #include "CEGUIRenderer.h"
00040 #include "CEGUITexture.h"
00041 #include <d3d8.h>
00042 #include <list>
00043 #include <set>
00044
00045
00046 #if defined(_MSC_VER)
00047 #       pragma warning(push)
00048 #       pragma warning(disable : 4251)
00049 #endif
00050
00051
00052 // Start of CEGUI namespace section
00053 namespace CEGUI
00054 {
00055 /*************************************************************************
00056         Forward refs
00057 *************************************************************************/
00058 class DirectX81Texture;
00059
00064 class DIRECTX81_GUIRENDERER_API DirectX81Renderer : public Renderer
00065 {
00066 public:
00077         DirectX81Renderer(LPDIRECT3DDEVICE8 device, uint max_quads = 0);
00078
00079
00090         DirectX81Renderer(LPDIRECT3DDEVICE8 device, const Size& sz);
00091
00092
00097         virtual ~DirectX81Renderer(void);
00098
00099         // add's a quad to the list to be rendered
00100         virtual void    addQuad(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00101
00102         // perform final rendering for all queued renderable quads.
00103         virtual void    doRender(void);
00104
00105         // clear the queue
00106         virtual void    clearRenderList(void);
00107
00108
00124         virtual void    setQueueingEnabled(bool setting)                {d_queueing = setting;}
00125
00126
00127         // create an empty texture
00128         virtual Texture*        createTexture(void);
00129
00130         // create a texture and load it with the specified file.
00131         virtual Texture*        createTexture(const String& filename, const String& resourceGroup);
00132
00133         // create a texture and set it to the specified size
00134         virtual Texture*        createTexture(float size);
00135
00136         // destroy the given texture
00137         virtual void            destroyTexture(Texture* texture);
00138
00139         // destroy all textures still active
00140         virtual void            destroyAllTextures(void);
00141
00142         // return ptr to device
00143         LPDIRECT3DDEVICE8       getDevice(void) const           {return d_device;}
00144
00145
00153         virtual bool    isQueueingEnabled(void) const   {return d_queueing;}
00154
00155
00163         virtual float   getWidth(void) const            {return d_display_area.getWidth();}
00164
00165
00173         virtual float   getHeight(void) const           {return d_display_area.getHeight();}
00174
00175
00183         virtual Size    getSize(void) const                     {return d_display_area.getSize();}
00184
00185
00194         virtual Rect    getRect(void) const                     {return d_display_area;}
00195
00196
00204         virtual uint    getMaxTextureSize(void) const           {return d_maxTextureSize;}
00205
00206
00214         virtual uint    getHorzScreenDPI(void) const    {return 96;}
00215
00216
00224         virtual uint    getVertScreenDPI(void) const    {return 96;}
00225
00226
00233         virtual void    preD3DReset(void);
00234
00235
00242         virtual void    postD3DReset(void);
00243
00244
00263         void    setDisplaySize(const Size& sz);
00264
00265
00266 private:
00267         /************************************************************************
00268                 Implementation Constants
00269         ************************************************************************/
00270         static const int                        VERTEX_PER_QUAD;
00271         static const int                        VERTEX_PER_TRIANGLE;
00272         static const int                        VERTEXBUFFER_CAPACITY;
00273         static const ulong                      VERTEX_FVF;
00274
00275         /*************************************************************************
00276             Implementation Structs & classes
00277         *************************************************************************/
00282         struct QuadVertex {
00283                 FLOAT x, y, z, rhw;
00284                 DWORD diffuse;
00285                 float tu1, tv1;
00286         };
00287
00292         struct QuadInfo
00293         {
00294                 LPDIRECT3DTEXTURE8      texture;
00295                 Rect                            position;
00296                 float                           z;
00297                 Rect                            texPosition;
00298                 ulong                           topLeftCol;
00299                 ulong                           topRightCol;
00300                 ulong                           bottomLeftCol;
00301                 ulong                           bottomRightCol;
00302
00303         QuadSplitMode       splitMode;
00304
00305                 bool operator<(const QuadInfo& other) const
00306                 {
00307                         // this is intentionally reversed.
00308                         return z > other.z;
00309                 }
00310         };
00311
00312
00313         /*************************************************************************
00314             Implementation Methods
00315         *************************************************************************/
00316         // setup states etc
00317         void    initPerFrameStates(void);
00318
00319         // renders whatever is in the vertex buffer
00320         void    renderVBuffer(void);
00321
00322         // sort quads list according to texture
00323         void    sortQuads(void);
00324
00325         // render a quad directly to the display
00326         void    renderQuadDirect(const Rect& dest_rect, float z, const Texture* tex, const Rect& texture_rect, const ColourRect& colours, QuadSplitMode quad_split_mode);
00327
00328         // return size of device view port (if possible)
00329         Size    getViewportSize(void);
00330
00331         // method to do work of constructor
00332         void    constructor_impl(LPDIRECT3DDEVICE8 device, const Size& display_size);
00333
00334
00335         /*************************************************************************
00336             Implementation Data
00337         *************************************************************************/
00338         Rect                            d_display_area;
00339
00340         typedef std::multiset<QuadInfo>         QuadList;
00341         QuadList d_quadlist;
00342         bool    d_queueing;
00343
00344         LPDIRECT3DDEVICE8               d_device;
00345         LPDIRECT3DTEXTURE8              d_currTexture;
00346         LPDIRECT3DVERTEXBUFFER8 d_buffer;
00347         int                                             d_bufferPos;
00348
00349         std::list<DirectX81Texture*>    d_texturelist;
00350
00351         uint    d_maxTextureSize;
00352         bool    d_canGetVPSize;
00353 };
00354
00355 } // End of  CEGUI namespace section
00356
00357
00358 #if defined(_MSC_VER)
00359 #       pragma warning(pop)
00360 #endif
00361
00362 #endif  // end of guard _DirectX81GUIRenderer_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::Key Member List

This is the complete list of members for CEGUI::Key, including all inherited members.

A enum value (defined in CEGUI::Key) | CEGUI::Key
ABNT_C1 enum value (defined in CEGUI::Key) | CEGUI::Key
ABNT_C2 enum value (defined in CEGUI::Key) | CEGUI::Key
Add enum value (defined in CEGUI::Key) | CEGUI::Key
Apostrophe enum value (defined in CEGUI::Key) | CEGUI::Key
AppMenu enum value (defined in CEGUI::Key) | CEGUI::Key
ArrowDown enum value (defined in CEGUI::Key) | CEGUI::Key
ArrowLeft enum value (defined in CEGUI::Key) | CEGUI::Key
ArrowRight enum value (defined in CEGUI::Key) | CEGUI::Key
ArrowUp enum value (defined in CEGUI::Key) | CEGUI::Key
At enum value (defined in CEGUI::Key) | CEGUI::Key
AX enum value (defined in CEGUI::Key) | CEGUI::Key
B enum value (defined in CEGUI::Key) | CEGUI::Key
Backslash enum value (defined in CEGUI::Key) | CEGUI::Key
Backspace enum value (defined in CEGUI::Key) | CEGUI::Key
C enum value (defined in CEGUI::Key) | CEGUI::Key
Calculator enum value (defined in CEGUI::Key) | CEGUI::Key
Capital enum value (defined in CEGUI::Key) | CEGUI::Key
Colon enum value (defined in CEGUI::Key) | CEGUI::Key
Comma enum value (defined in CEGUI::Key) | CEGUI::Key
Convert enum value (defined in CEGUI::Key) | CEGUI::Key
D enum value (defined in CEGUI::Key) | CEGUI::Key
Decimal enum value (defined in CEGUI::Key) | CEGUI::Key
Delete enum value (defined in CEGUI::Key) | CEGUI::Key
Divide enum value (defined in CEGUI::Key) | CEGUI::Key
E enum value (defined in CEGUI::Key) | CEGUI::Key
Eight enum value (defined in CEGUI::Key) | CEGUI::Key
End enum value (defined in CEGUI::Key) | CEGUI::Key
Equals enum value (defined in CEGUI::Key) | CEGUI::Key
Escape enum value (defined in CEGUI::Key) | CEGUI::Key
F enum value (defined in CEGUI::Key) | CEGUI::Key
F1 enum value (defined in CEGUI::Key) | CEGUI::Key
F10 enum value (defined in CEGUI::Key) | CEGUI::Key
F11 enum value (defined in CEGUI::Key) | CEGUI::Key
F12 enum value (defined in CEGUI::Key) | CEGUI::Key
F13 enum value (defined in CEGUI::Key) | CEGUI::Key
F14 enum value (defined in CEGUI::Key) | CEGUI::Key
F15 enum value (defined in CEGUI::Key) | CEGUI::Key
F2 enum value (defined in CEGUI::Key) | CEGUI::Key
F3 enum value (defined in CEGUI::Key) | CEGUI::Key
F4 enum value (defined in CEGUI::Key) | CEGUI::Key
F5 enum value (defined in CEGUI::Key) | CEGUI::Key
F6 enum value (defined in CEGUI::Key) | CEGUI::Key
F7 enum value (defined in CEGUI::Key) | CEGUI::Key
F8 enum value (defined in CEGUI::Key) | CEGUI::Key
F9 enum value (defined in CEGUI::Key) | CEGUI::Key
Five enum value (defined in CEGUI::Key) | CEGUI::Key
Four enum value (defined in CEGUI::Key) | CEGUI::Key
G enum value (defined in CEGUI::Key) | CEGUI::Key
Grave enum value (defined in CEGUI::Key) | CEGUI::Key
H enum value (defined in CEGUI::Key) | CEGUI::Key
Home enum value (defined in CEGUI::Key) | CEGUI::Key
I enum value (defined in CEGUI::Key) | CEGUI::Key
Insert enum value (defined in CEGUI::Key) | CEGUI::Key
J enum value (defined in CEGUI::Key) | CEGUI::Key
K enum value (defined in CEGUI::Key) | CEGUI::Key
Kana enum value (defined in CEGUI::Key) | CEGUI::Key
Kanji enum value (defined in CEGUI::Key) | CEGUI::Key
L enum value (defined in CEGUI::Key) | CEGUI::Key
LeftAlt enum value (defined in CEGUI::Key) | CEGUI::Key
LeftBracket enum value (defined in CEGUI::Key) | CEGUI::Key
LeftControl enum value (defined in CEGUI::Key) | CEGUI::Key
LeftShift enum value (defined in CEGUI::Key) | CEGUI::Key
LeftWindows enum value (defined in CEGUI::Key) | CEGUI::Key
M enum value (defined in CEGUI::Key) | CEGUI::Key
Mail enum value (defined in CEGUI::Key) | CEGUI::Key
MediaSelect enum value (defined in CEGUI::Key) | CEGUI::Key
MediaStop enum value (defined in CEGUI::Key) | CEGUI::Key
Minus enum value (defined in CEGUI::Key) | CEGUI::Key
Multiply enum value (defined in CEGUI::Key) | CEGUI::Key
Mute enum value (defined in CEGUI::Key) | CEGUI::Key
MyComputer enum value (defined in CEGUI::Key) | CEGUI::Key
N enum value (defined in CEGUI::Key) | CEGUI::Key
NextTrack enum value (defined in CEGUI::Key) | CEGUI::Key
Nine enum value (defined in CEGUI::Key) | CEGUI::Key
NoConvert enum value (defined in CEGUI::Key) | CEGUI::Key
NumLock enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad0 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad1 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad2 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad3 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad4 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad5 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad6 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad7 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad8 enum value (defined in CEGUI::Key) | CEGUI::Key
Numpad9 enum value (defined in CEGUI::Key) | CEGUI::Key
NumpadComma enum value (defined in CEGUI::Key) | CEGUI::Key
NumpadEnter enum value (defined in CEGUI::Key) | CEGUI::Key
NumpadEquals enum value (defined in CEGUI::Key) | CEGUI::Key
O enum value (defined in CEGUI::Key) | CEGUI::Key
OEM_102 enum value (defined in CEGUI::Key) | CEGUI::Key
One enum value (defined in CEGUI::Key) | CEGUI::Key
P enum value (defined in CEGUI::Key) | CEGUI::Key
PageDown enum value (defined in CEGUI::Key) | CEGUI::Key
PageUp enum value (defined in CEGUI::Key) | CEGUI::Key
Pause enum value (defined in CEGUI::Key) | CEGUI::Key
Period enum value (defined in CEGUI::Key) | CEGUI::Key
PlayPause enum value (defined in CEGUI::Key) | CEGUI::Key
Power enum value (defined in CEGUI::Key) | CEGUI::Key
PrevTrack enum value (defined in CEGUI::Key) | CEGUI::Key
Q enum value (defined in CEGUI::Key) | CEGUI::Key
R enum value (defined in CEGUI::Key) | CEGUI::Key
Return enum value (defined in CEGUI::Key) | CEGUI::Key
RightAlt enum value (defined in CEGUI::Key) | CEGUI::Key
RightBracket enum value (defined in CEGUI::Key) | CEGUI::Key
RightControl enum value (defined in CEGUI::Key) | CEGUI::Key
RightShift enum value (defined in CEGUI::Key) | CEGUI::Key
RightWindow enum value (defined in CEGUI::Key) | CEGUI::Key
RightWindows enum value (defined in CEGUI::Key) | CEGUI::Key
S enum value (defined in CEGUI::Key) | CEGUI::Key
Scan enum name (defined in CEGUI::Key) | CEGUI::Key
ScrollLock enum value (defined in CEGUI::Key) | CEGUI::Key
Semicolon enum value (defined in CEGUI::Key) | CEGUI::Key
Seven enum value (defined in CEGUI::Key) | CEGUI::Key
Six enum value (defined in CEGUI::Key) | CEGUI::Key
Slash enum value (defined in CEGUI::Key) | CEGUI::Key
Sleep enum value (defined in CEGUI::Key) | CEGUI::Key
Space enum value (defined in CEGUI::Key) | CEGUI::Key
Stop enum value (defined in CEGUI::Key) | CEGUI::Key
Subtract enum value (defined in CEGUI::Key) | CEGUI::Key
SysRq enum value (defined in CEGUI::Key) | CEGUI::Key
T enum value (defined in CEGUI::Key) | CEGUI::Key
Tab enum value (defined in CEGUI::Key) | CEGUI::Key
Three enum value (defined in CEGUI::Key) | CEGUI::Key
Two enum value (defined in CEGUI::Key) | CEGUI::Key
U enum value (defined in CEGUI::Key) | CEGUI::Key
Underline enum value (defined in CEGUI::Key) | CEGUI::Key
Unlabeled enum value (defined in CEGUI::Key) | CEGUI::Key
V enum value (defined in CEGUI::Key) | CEGUI::Key
VolumeDown enum value (defined in CEGUI::Key) | CEGUI::Key
VolumeUp enum value (defined in CEGUI::Key) | CEGUI::Key
W enum value (defined in CEGUI::Key) | CEGUI::Key
Wake enum value (defined in CEGUI::Key) | CEGUI::Key
WebBack enum value (defined in CEGUI::Key) | CEGUI::Key
WebFavorites enum value (defined in CEGUI::Key) | CEGUI::Key
WebForward enum value (defined in CEGUI::Key) | CEGUI::Key
WebHome enum value (defined in CEGUI::Key) | CEGUI::Key
WebRefresh enum value (defined in CEGUI::Key) | CEGUI::Key
WebSearch enum value (defined in CEGUI::Key) | CEGUI::Key
WebStop enum value (defined in CEGUI::Key) | CEGUI::Key
X enum value (defined in CEGUI::Key) | CEGUI::Key
Y enum value (defined in CEGUI::Key) | CEGUI::Key
Yen enum value (defined in CEGUI::Key) | CEGUI::Key
Z enum value (defined in CEGUI::Key) | CEGUI::Key
Zero enum value (defined in CEGUI::Key) | CEGUI::Key

Generated on Sat Nov 26 10:10:00 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MCLGridRef Member List

This is the complete list of members for CEGUI::MCLGridRef, including all inherited members.

column | CEGUI::MCLGridRef |
MCLGridRef(uint r, uint c) (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef | [inline]
operator!=(const MCLGridRef &rhs) const (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
operator<(const MCLGridRef &rhs) const (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
operator<=(const MCLGridRef &rhs) const (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
operator=(const MCLGridRef &rhs) (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
operator==(const MCLGridRef &rhs) const (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
operator>(const MCLGridRef &rhs) const (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
operator>=(const MCLGridRef &rhs) const (defined in CEGUI::MCLGridRef) | CEGUI::MCLGridRef |
row | CEGUI::MCLGridRef |

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MouseClickTracker Member List

This is the complete list of members for CEGUI::MouseClickTracker, including all inherited members.

d_click_area | CEGUI::MouseClickTracker |
d_click_count | CEGUI::MouseClickTracker |
d_target_window | CEGUI::MouseClickTracker |
d_timer | CEGUI::MouseClickTracker |
MouseClickTracker(void) (defined in CEGUI::MouseClickTracker) | CEGUI::MouseClickTracker | [inline]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiColumnList::ListRow Member List

This is the complete list of members for CEGUI::MultiColumnList::ListRow, including all inherited members.

d_items (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow |
d_rowID (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow |
d_sortColumn (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow |
operator<(const ListRow &rhs) const (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow |
operator>(const ListRow &rhs) const (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow |
operator[](uint idx) const (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow | [inline]
operator[](uint idx) (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow | [inline]
RowItems typedef (defined in CEGUI::MultiColumnList::ListRow) | CEGUI::MultiColumnList::ListRow |

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::MultiLineEditbox::LineInfo Member List

This is the complete list of members for CEGUI::MultiLineEditbox::LineInfo, including all inherited members.

d_extent | CEGUI::MultiLineEditbox::LineInfo
d_length | CEGUI::MultiLineEditbox::LineInfo
d_startIdx | CEGUI::MultiLineEditbox::LineInfo

Generated on Sat Nov 26 10:10:06 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::RegexValidator Member List

This is the complete list of members for CEGUI::RegexValidator, including all inherited members.

d_regex (defined in CEGUI::RegexValidator) | CEGUI::RegexValidator |
RegexValidator(void) (defined in CEGUI::RegexValidator) | CEGUI::RegexValidator | [inline]
release() (defined in CEGUI::RegexValidator) | CEGUI::RegexValidator | [inline]
~RegexValidator(void) (defined in CEGUI::RegexValidator) | CEGUI::RegexValidator | [inline]

Generated on Sat Nov 26 10:10:11 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: Member List

CEGUI::WindowFactoryManager::FalagardWindowMapping Member List

This is the complete list of members for CEGUI::WindowFactoryManager::FalagardWindowMapping, including all inherited members.

d_baseType (defined in CEGUI::WindowFactoryManager::FalagardWindowMapping) | CEGUI::WindowFactoryManager::FalagardWindowMapping
d_lookName (defined in CEGUI::WindowFactoryManager::FalagardWindowMapping) | CEGUI::WindowFactoryManager::FalagardWindowMapping
d_windowType (defined in CEGUI::WindowFactoryManager::FalagardWindowMapping) | CEGUI::WindowFactoryManager::FalagardWindowMapping

Generated on Sat Nov 26 10:10:03 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: texture.h Source File

include » renderers » directx81GUIRenderer

texture.h

00001 /************************************************************************
00002         filename:       texture.h
00003         created:        10/4/2004
00004         author:         Paul D Turner
00005
00006         purpose:        Defines concrete texture class
00007 *************************************************************************/
00008 /*************************************************************************
00009     Crazy Eddie's GUI System (http://www.cegui.org.uk)
00010     Copyright (C)2004 - 2005 Paul D Turner (paul@cegui.org.uk)
00011
00012     This library is free software; you can redistribute it and/or
00013     modify it under the terms of the GNU Lesser General Public
00014     License as published by the Free Software Foundation; either
00015     version 2.1 of the License, or (at your option) any later version.
00016
00017     This library is distributed in the hope that it will be useful,
00018     but WITHOUT ANY WARRANTY; without even the implied warranty of
00019     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00020     Lesser General Public License for more details.
00021
00022     You should have received a copy of the GNU Lesser General Public
00023     License along with this library; if not, write to the Free Software
00024     Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
00025 *************************************************************************/
00026 #ifndef _texture_h_
00027 #define _texture_h_
00028
00029 #include "CEGUIBase.h"
00030 #include "CEGUIRenderer.h"
00031 #include "CEGUITexture.h"
00032 #include "renderer.h"
00033 #include <d3d8.h>
00034 #include <list>
00035
00036 // Start of CEGUI namespace section
00037 namespace CEGUI
00038 {
00039
00044 class DIRECTX81_GUIRENDERER_API DirectX81Texture : public Texture
00045 {
00046 private:
00047         /*************************************************************************
00048                 Friends (to allow construction and destruction)
00049         *************************************************************************/
00050         friend  Texture* DirectX81Renderer::createTexture(void);
00051         friend  Texture* DirectX81Renderer::createTexture(const String& filename, const String& resourceGroup);
00052         friend  Texture* DirectX81Renderer::createTexture(float size);
00053         friend  void     DirectX81Renderer::destroyTexture(Texture* texture);
00054
00055
00056         /*************************************************************************
00057                 Construction & Destruction (by Renderer object only)
00058         *************************************************************************/
00059         DirectX81Texture(Renderer* owner);
00060         virtual ~DirectX81Texture(void);
00061
00062 public:
00070         virtual ushort  getWidth(void) const            {return d_width;}
00071
00072
00080         virtual ushort  getHeight(void) const           {return d_height;}
00081
00082
00096         virtual void    loadFromFile(const String& filename, const String& resourceGroup);
00097
00098
00115         virtual void    loadFromMemory(const void* buffPtr, uint buffWidth, uint buffHeight);
00116
00117
00125         LPDIRECT3DTEXTURE8      getD3DTexture(void) const               {return d_d3dtexture;}
00126
00127
00128         //
00139         void    setD3DTextureSize(uint size);
00140
00141
00153         virtual void    preD3DReset(void);
00154
00155
00167         virtual void    postD3DReset(void);
00168
00169
00170 private:
00171         /*************************************************************************
00172                 Implementation Functions
00173         *************************************************************************/
00174         // safely free direc3d texture (can be called multiple times with no ill effect)
00175         void    freeD3DTexture(void);
00176
00177
00178         /*************************************************************************
00179                 Implementation Data
00180         *************************************************************************/
00181         LPDIRECT3DTEXTURE8              d_d3dtexture;
00182         String                                  d_filename;
00183     String                  d_resourceGroup;
00184     bool                                        d_isMemoryTexture;
00185
00186         ushort                                  d_width;
00187         ushort                                  d_height;
00188 };
00189
00190 } // End of  CEGUI namespace section
00191
00192
00193 #endif  // end of guard _texture_h_
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: tinystr.h Source File

src » tinyxml

tinystr.h

00001 /*
00002 www.sourceforge.net/projects/tinyxml
00003 Original file by Yves Berquin.
00004
00005 This software is provided 'as-is', without any express or implied
00006 warranty. In no event will the authors be held liable for any
00007 damages arising from the use of this software.
00008
00009 Permission is granted to anyone to use this software for any
00010 purpose, including commercial applications, and to alter it and
00011 redistribute it freely, subject to the following restrictions:
00012
00013 1. The origin of this software must not be misrepresented; you must
00014 not claim that you wrote the original software. If you use this
00015 software in a product, an acknowledgment in the product documentation
00016 would be appreciated but is not required.
00017
00018 2. Altered source versions must be plainly marked as such, and
00019 must not be misrepresented as being the original software.
00020
00021 3. This notice may not be removed or altered from any source
00022 distribution.
00023 */
00024
00025 #include "tinyxml.h"
00026
00027
00028 #ifndef TIXML_USE_STL
00029
00030 #ifndef TIXML_STRING_INCLUDED
00031 #define TIXML_STRING_INCLUDED
00032
00033 #ifdef _MSC_VER
00034 #pragma warning( disable : 4786 )       // Debugger truncating names.
00035 #endif
00036
00037 #include <assert.h>
00038
00039 /*
00040    TiXmlString is an emulation of the std::string template.
00041    Its purpose is to allow compiling TinyXML on compilers with no or poor STL support.
00042    Only the member functions relevant to the TinyXML project have been implemented.
00043    The buffer allocation is made by a simplistic power of 2 like mechanism : if we increase
00044    a string and there's no more room, we allocate a buffer twice as big as we need.
00045 */
00046 class TiXmlString
00047 {
00048   public :
00049     // TiXmlString constructor, based on a string
00050     TiXmlString (const char * instring);
00051
00052     // TiXmlString empty constructor
00053     TiXmlString ()
00054     {
00055         allocated = 0;
00056         cstring = NULL;
00057         current_length = 0;
00058     }
00059
00060     // TiXmlString copy constructor
00061     TiXmlString (const TiXmlString& copy);
00062
00063     // TiXmlString destructor
00064     ~ TiXmlString ()
00065     {
00066         empty_it ();
00067     }
00068
00069     // Convert a TiXmlString into a classical char *
00070     const char * c_str () const
00071     {
00072         if (allocated)
00073             return cstring;
00074         return "";
00075     }
00076
00077     // Return the length of a TiXmlString
00078     unsigned length () const
00079         {
00080                 return ( allocated ) ? current_length : 0;
00081         }
00082
00083     // TiXmlString = operator
00084     void operator = (const char * content);
00085
00086     // = operator
00087     void operator = (const TiXmlString & copy);
00088
00089     // += operator. Maps to append
00090     TiXmlString& operator += (const char * suffix)
00091     {
00092         append (suffix);
00093                 return *this;
00094     }
00095
00096     // += operator. Maps to append
00097     TiXmlString& operator += (char single)
00098     {
00099         append (single);
00100                 return *this;
00101     }
00102
00103     // += operator. Maps to append
00104     TiXmlString& operator += (TiXmlString & suffix)
00105     {
00106         append (suffix);
00107                 return *this;
00108     }
00109     bool operator == (const TiXmlString & compare) const;
00110     bool operator == (const char* compare) const;
00111     bool operator < (const TiXmlString & compare) const;
00112     bool operator > (const TiXmlString & compare) const;
00113
00114     // Checks if a TiXmlString is empty
00115     bool empty () const
00116     {
00117         return length () ? false : true;
00118     }
00119
00120     // single char extraction
00121     const char& at (unsigned index) const
00122     {
00123         assert( index < length ());
00124         return cstring [index];
00125     }
00126
00127     // find a char in a string. Return TiXmlString::notfound if not found
00128     unsigned find (char lookup) const
00129     {
00130         return find (lookup, 0);
00131     }
00132
00133     // find a char in a string from an offset. Return TiXmlString::notfound if not found
00134     unsigned find (char tofind, unsigned offset) const;
00135
00136     /*  Function to reserve a big amount of data when we know we'll need it. Be aware that this
00137                 function clears the content of the TiXmlString if any exists.
00138     */
00139     void reserve (unsigned size)
00140     {
00141         empty_it ();
00142         if (size)
00143         {
00144             allocated = size;
00145             cstring = new char [size];
00146             cstring [0] = 0;
00147             current_length = 0;
00148         }
00149     }
00150
00151     // [] operator
00152     char& operator [] (unsigned index) const
00153     {
00154         assert( index < length ());
00155         return cstring [index];
00156     }
00157
00158     // Error value for find primitive
00159     enum {      notfound = 0xffffffff,
00160             npos = notfound };
00161
00162     void append (const char *str, int len );
00163
00164   protected :
00165
00166     // The base string
00167     char * cstring;
00168     // Number of chars allocated
00169     unsigned allocated;
00170     // Current string size
00171     unsigned current_length;
00172
00173     // New size computation. It is simplistic right now : it returns twice the amount
00174     // we need
00175     unsigned assign_new_size (unsigned minimum_to_allocate)
00176     {
00177         return minimum_to_allocate * 2;
00178     }
00179
00180     // Internal function that clears the content of a TiXmlString
00181     void empty_it ()
00182     {
00183         if (cstring)
00184             delete [] cstring;
00185         cstring = NULL;
00186         allocated = 0;
00187         current_length = 0;
00188     }
00189
00190     void append (const char *suffix );
00191
00192     // append function for another TiXmlString
00193     void append (const TiXmlString & suffix)
00194     {
00195         append (suffix . c_str ());
00196     }
00197
00198     // append for a single char.
00199     void append (char single)
00200     {
00201         if ( cstring && current_length < (allocated-1) )
00202                 {
00203                         cstring[ current_length ] = single;
00204                         ++current_length;
00205                         cstring[ current_length ] = 0;
00206                 }
00207                 else
00208                 {
00209                         char smallstr [2];
00210                         smallstr [0] = single;
00211                         smallstr [1] = 0;
00212                         append (smallstr);
00213                 }
00214     }
00215
00216 } ;
00217
00218 inline bool TiXmlString::operator == (const char* compare) const
00219 {
00220         if ( allocated )
00221         {
00222                 assert( cstring );
00223                 return ( strcmp( cstring, compare ) == 0 );
00224         }
00225         return false;
00226 }
00227
00228 /*
00229    TiXmlOutStream is an emulation of std::ostream. It is based on TiXmlString.
00230    Only the operators that we need for TinyXML have been developped.
00231 */
00232 class TiXmlOutStream : public TiXmlString
00233 {
00234 public :
00235     TiXmlOutStream () : TiXmlString () {}
00236
00237     // TiXmlOutStream << operator. Maps to TiXmlString::append
00238     TiXmlOutStream & operator << (const char * in)
00239     {
00240         append (in);
00241         return (* this);
00242     }
00243
00244     // TiXmlOutStream << operator. Maps to TiXmlString::append
00245     TiXmlOutStream & operator << (const TiXmlString & in)
00246     {
00247         append (in . c_str ());
00248         return (* this);
00249     }
00250 } ;
00251
00252 #endif  // TIXML_STRING_INCLUDED
00253 #endif  // TIXML_USE_STL
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: tinyxml.h Source File

src » tinyxml

tinyxml.h

00001 /*
00002 www.sourceforge.net/projects/tinyxml
00003 Original code (2.0 and earlier )copyright (c) 2000-2002 Lee Thomason (www.grinninglizard.com)
00004
00005 This software is provided 'as-is', without any express or implied
00006 warranty. In no event will the authors be held liable for any
00007 damages arising from the use of this software.
00008
00009 Permission is granted to anyone to use this software for any
00010 purpose, including commercial applications, and to alter it and
00011 redistribute it freely, subject to the following restrictions:
00012
00013 1. The origin of this software must not be misrepresented; you must
00014 not claim that you wrote the original software. If you use this
00015 software in a product, an acknowledgment in the product documentation
00016 would be appreciated but is not required.
00017
00018 2. Altered source versions must be plainly marked as such, and
00019 must not be misrepresented as being the original software.
00020
00021 3. This notice may not be removed or altered from any source
00022 distribution.
00023 */
00024
00025
00026 #ifndef TINYXML_INCLUDED
00027 #define TINYXML_INCLUDED
00028
00029 #ifdef _MSC_VER
00030 #pragma warning( disable : 4530 )
00031 #pragma warning( disable : 4786 )
00032 #endif
00033
00034 #include <ctype.h>
00035 #include <stdio.h>
00036 #include <stdlib.h>
00037 #include <string.h>
00038 #include <assert.h>
00039
00040 // Help out windows:
00041 #if defined( _DEBUG ) && !defined( DEBUG )
00042 #define DEBUG
00043 #endif
00044
00045 #if defined( DEBUG ) && defined( _MSC_VER )
00046 #include <windows.h>
00047 #define TIXML_LOG OutputDebugString
00048 #else
00049 #define TIXML_LOG printf
00050 #endif
00051
00052 #ifdef TIXML_USE_STL
00053         #include <string>
00054         #include <iostream>
00055         #define TIXML_STRING    std::string
00056         #define TIXML_ISTREAM   std::istream
00057         #define TIXML_OSTREAM   std::ostream
00058         #define TIXML_CAST_STRING std::string
00059 #else
00060         #include "tinystr.h"
00061         #define TIXML_STRING    TiXmlString
00062         #define TIXML_OSTREAM   TiXmlOutStream
00063         #define TIXML_CAST_STRING
00064 #endif
00065
00066 class TiXmlDocument;
00067 class TiXmlElement;
00068 class TiXmlComment;
00069 class TiXmlUnknown;
00070 class TiXmlAttribute;
00071 class TiXmlText;
00072 class TiXmlDeclaration;
00073 class TiXmlParsingData;
00074
00075 const int TIXML_MAJOR_VERSION = 2;
00076 const int TIXML_MINOR_VERSION = 3;
00077 const int TIXML_PATCH_VERSION = 3;
00078
00079 /*      Internal structure for tracking location of items
00080         in the XML file.
00081 */
00082 struct TiXmlCursor
00083 {
00084         TiXmlCursor()           { Clear(); }
00085         void Clear()            { row = col = -1; }
00086
00087         int row;        // 0 based.
00088         int col;        // 0 based.
00089 };
00090
00091
00092 // Only used by Attribute::Query functions
00093 enum
00094 {
00095         TIXML_SUCCESS,
00096         TIXML_NO_ATTRIBUTE,
00097         TIXML_WRONG_TYPE
00098 };
00099
00100
00101 // Used by the parsing routines.
00102 enum TiXmlEncoding
00103 {
00104         TIXML_ENCODING_UNKNOWN,
00105         TIXML_ENCODING_UTF8,
00106         TIXML_ENCODING_LEGACY
00107 };
00108
00109 const TiXmlEncoding TIXML_DEFAULT_ENCODING = TIXML_ENCODING_UNKNOWN;
00110
00133 class TiXmlBase
00134 {
00135         friend class TiXmlNode;
00136         friend class TiXmlElement;
00137         friend class TiXmlDocument;
00138
00139 public:
00140         TiXmlBase()     :       userData(0) {}
00141         virtual ~TiXmlBase()                                    {}
00142
00148         virtual void Print( FILE* cfile, int depth ) const = 0;
00149
00156         static void SetCondenseWhiteSpace( bool condense )              { condenseWhiteSpace = condense; }
00157
00159         static bool IsWhiteSpaceCondensed()                                             { return condenseWhiteSpace; }
00160
00179         int Row() const                 { return location.row + 1; }
00180         int Column() const              { return location.col + 1; }
00181
00182         void  SetUserData( void* user )                 { userData = user; }
00183         void* GetUserData()                                             { return userData; }
00184
00185         // Table that returs, for a given lead byte, the total number of bytes
00186         // in the UTF-8 sequence.
00187         static const int utf8ByteTable[256];
00188
00189         virtual const char* Parse(      const char* p,
00190                                                                 TiXmlParsingData* data,
00191                                                                 TiXmlEncoding encoding /*= TIXML_ENCODING_UNKNOWN */ ) = 0;
00192
00193         enum
00194         {
00195                 TIXML_NO_ERROR = 0,
00196                 TIXML_ERROR,
00197                 TIXML_ERROR_OPENING_FILE,
00198                 TIXML_ERROR_OUT_OF_MEMORY,
00199                 TIXML_ERROR_PARSING_ELEMENT,
00200                 TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME,
00201                 TIXML_ERROR_READING_ELEMENT_VALUE,
00202                 TIXML_ERROR_READING_ATTRIBUTES,
00203                 TIXML_ERROR_PARSING_EMPTY,
00204                 TIXML_ERROR_READING_END_TAG,
00205                 TIXML_ERROR_PARSING_UNKNOWN,
00206                 TIXML_ERROR_PARSING_COMMENT,
00207                 TIXML_ERROR_PARSING_DECLARATION,
00208                 TIXML_ERROR_DOCUMENT_EMPTY,
00209                 TIXML_ERROR_EMBEDDED_NULL,
00210
00211                 TIXML_ERROR_STRING_COUNT
00212         };
00213
00214 protected:
00215
00216         // See STL_STRING_BUG
00217         // Utility class to overcome a bug.
00218         class StringToBuffer
00219         {
00220           public:
00221                 StringToBuffer( const TIXML_STRING& str );
00222                 ~StringToBuffer();
00223                 char* buffer;
00224         };
00225
00226         static const char*      SkipWhiteSpace( const char*, TiXmlEncoding encoding );
00227         inline static bool      IsWhiteSpace( char c )
00228         {
00229                 return ( isspace( (unsigned char) c ) || c == '\n' || c == '\r' );
00230         }
00231
00232         virtual void StreamOut (TIXML_OSTREAM *) const = 0;
00233
00234         #ifdef TIXML_USE_STL
00235             static bool StreamWhiteSpace( TIXML_ISTREAM * in, TIXML_STRING * tag );
00236             static bool StreamTo( TIXML_ISTREAM * in, int character, TIXML_STRING * tag );
00237         #endif
00238
00239         /*      Reads an XML name into the string provided. Returns
00240                 a pointer just past the last character of the name,
00241                 or 0 if the function has an error.
00242         */
00243         static const char* ReadName( const char* p, TIXML_STRING* name, TiXmlEncoding encoding );
00244
00245         /*      Reads text. Returns a pointer past the given end tag.
00246                 Wickedly complex options, but it keeps the (sensitive) code in one place.
00247         */
00248         static const char* ReadText(    const char* in,                         // where to start
00249                                                                         TIXML_STRING* text,                     // the string read
00250                                                                         bool ignoreWhiteSpace,          // whether to keep the white space
00251                                                                         const char* endTag,                     // what ends this text
00252                                                                         bool ignoreCase,                        // whether to ignore case in the end tag
00253                                                                         TiXmlEncoding encoding );       // the current encoding
00254
00255         // If an entity has been found, transform it into a character.
00256         static const char* GetEntity( const char* in, char* value, int* length, TiXmlEncoding encoding );
00257
00258         // Get a character, while interpreting entities.
00259         // The length can be from 0 to 4 bytes.
00260         inline static const char* GetChar( const char* p, char* _value, int* length, TiXmlEncoding encoding )
00261         {
00262                 assert( p );
00263                 if ( encoding == TIXML_ENCODING_UTF8 )
00264                 {
00265                         *length = utf8ByteTable[ *((unsigned char*)p) ];
00266                         assert( *length >= 0 && *length < 5 );
00267                 }
00268                 else
00269                 {
00270                         *length = 1;
00271                 }
00272
00273                 if ( *length == 1 )
00274                 {
00275                         if ( *p == '&' )
00276                                 return GetEntity( p, _value, length, encoding );
00277                         *_value = *p;
00278                         return p+1;
00279                 }
00280                 else if ( *length )
00281                 {
00282                         strncpy( _value, p, *length );
00283                         return p + (*length);
00284                 }
00285                 else
00286                 {
00287                         // Not valid text.
00288                         return 0;
00289                 }
00290         }
00291
00292         // Puts a string to a stream, expanding entities as it goes.
00293         // Note this should not contian the '<', '>', etc, or they will be transformed into entities!
00294         static void PutString( const TIXML_STRING& str, TIXML_OSTREAM* out );
00295
00296         static void PutString( const TIXML_STRING& str, TIXML_STRING* out );
00297
00298         // Return true if the next characters in the stream are any of the endTag sequences.
00299         // Ignore case only works for english, and should only be relied on when comparing
00300         // to Engilish words: StringEqual( p, "version", true ) is fine.
00301         static bool StringEqual(        const char* p,
00302                                                                 const char* endTag,
00303                                                                 bool ignoreCase,
00304                                                                 TiXmlEncoding encoding );
00305
00306         static const char* errorString[ TIXML_ERROR_STRING_COUNT ];
00307
00308         TiXmlCursor location;
00309
00311         void*                   userData;
00312
00313         // None of these methods are reliable for any language except English.
00314         // Good for approximation, not great for accuracy.
00315         static int IsAlpha( unsigned char anyByte, TiXmlEncoding encoding );
00316         static int IsAlphaNum( unsigned char anyByte, TiXmlEncoding encoding );
00317         inline static int ToLower( int v, TiXmlEncoding encoding )
00318         {
00319                 if ( encoding == TIXML_ENCODING_UTF8 )
00320                 {
00321                         if ( v < 128 ) return tolower( v );
00322                         return v;
00323                 }
00324                 else
00325                 {
00326                         return tolower( v );
00327                 }
00328         }
00329         static void ConvertUTF32ToUTF8( unsigned long input, char* output, int* length );
00330
00331 private:
00332         TiXmlBase( const TiXmlBase& );                          // not implemented.
00333         void operator=( const TiXmlBase& base );        // not allowed.
00334
00335         struct Entity
00336         {
00337                 const char*     str;
00338                 unsigned int    strLength;
00339                 char                chr;
00340         };
00341         enum
00342         {
00343                 NUM_ENTITY = 5,
00344                 MAX_ENTITY_LENGTH = 6
00345
00346         };
00347         static Entity entity[ NUM_ENTITY ];
00348         static bool condenseWhiteSpace;
00349 };
00350
00351
00358 class TiXmlNode : public TiXmlBase
00359 {
00360         friend class TiXmlDocument;
00361         friend class TiXmlElement;
00362
00363 public:
00364         #ifdef TIXML_USE_STL
00365
00369             friend std::istream& operator >> (std::istream& in, TiXmlNode& base);
00370
00387             friend std::ostream& operator<< (std::ostream& out, const TiXmlNode& base);
00388
00390                 friend std::string& operator<< (std::string& out, const TiXmlNode& base );
00391
00392         #else
00393             // Used internally, not part of the public API.
00394             friend TIXML_OSTREAM& operator<< (TIXML_OSTREAM& out, const TiXmlNode& base);
00395         #endif
00396
00400         enum NodeType
00401         {
00402                 DOCUMENT,
00403                 ELEMENT,
00404                 COMMENT,
00405                 UNKNOWN,
00406                 TEXT,
00407                 DECLARATION,
00408                 TYPECOUNT
00409         };
00410
00411         virtual ~TiXmlNode();
00412
00425         const char * Value() const { return value.c_str (); }
00426
00436         void SetValue(const char * _value) { value = _value;}
00437
00438     #ifdef TIXML_USE_STL
00439
00440         void SetValue( const std::string& _value )
00441         {
00442                 StringToBuffer buf( _value );
00443                 SetValue( buf.buffer ? buf.buffer : "" );
00444         }
00445         #endif
00446
00448         void Clear();
00449
00451         TiXmlNode* Parent()                                                     { return parent; }
00452         const TiXmlNode* Parent() const                         { return parent; }
00453
00454         const TiXmlNode* FirstChild()   const   { return firstChild; }
00455         TiXmlNode* FirstChild()                                 { return firstChild; }
00456         const TiXmlNode* FirstChild( const char * value ) const;
00457         TiXmlNode* FirstChild( const char * value );
00458
00459         const TiXmlNode* LastChild() const      { return lastChild; }
00460         TiXmlNode* LastChild()  { return lastChild; }
00461         const TiXmlNode* LastChild( const char * value ) const;
00462         TiXmlNode* LastChild( const char * value );
00463
00464     #ifdef TIXML_USE_STL
00465         const TiXmlNode* FirstChild( const std::string& _value ) const  {       return FirstChild (_value.c_str ());    }
00466         TiXmlNode* FirstChild( const std::string& _value )                              {       return FirstChild (_value.c_str ());    }
00467         const TiXmlNode* LastChild( const std::string& _value ) const   {       return LastChild (_value.c_str ());     }
00468         TiXmlNode* LastChild( const std::string& _value )                               {       return LastChild (_value.c_str ());     }
00469         #endif
00470
00487         const TiXmlNode* IterateChildren( TiXmlNode* previous ) const;
00488         TiXmlNode* IterateChildren( TiXmlNode* previous );
00489
00491         const TiXmlNode* IterateChildren( const char * value, TiXmlNode* previous ) const;
00492         TiXmlNode* IterateChildren( const char * value, TiXmlNode* previous );
00493
00494     #ifdef TIXML_USE_STL
00495         const TiXmlNode* IterateChildren( const std::string& _value, TiXmlNode* previous ) const        {       return IterateChildren (_value.c_str (), previous);     }
00496         TiXmlNode* IterateChildren( const std::string& _value, TiXmlNode* previous ) {  return IterateChildren (_value.c_str (), previous);     }
00497         #endif
00498
00502         TiXmlNode* InsertEndChild( const TiXmlNode& addThis );
00503
00504
00514         TiXmlNode* LinkEndChild( TiXmlNode* addThis );
00515
00519         TiXmlNode* InsertBeforeChild( TiXmlNode* beforeThis, const TiXmlNode& addThis );
00520
00524         TiXmlNode* InsertAfterChild(  TiXmlNode* afterThis, const TiXmlNode& addThis );
00525
00529         TiXmlNode* ReplaceChild( TiXmlNode* replaceThis, const TiXmlNode& withThis );
00530
00532         bool RemoveChild( TiXmlNode* removeThis );
00533
00535         const TiXmlNode* PreviousSibling() const                        { return prev; }
00536         TiXmlNode* PreviousSibling()                                            { return prev; }
00537
00539         const TiXmlNode* PreviousSibling( const char * ) const;
00540         TiXmlNode* PreviousSibling( const char * );
00541
00542     #ifdef TIXML_USE_STL
00543         const TiXmlNode* PreviousSibling( const std::string& _value ) const     {       return PreviousSibling (_value.c_str ());       }
00544         TiXmlNode* PreviousSibling( const std::string& _value )                         {       return PreviousSibling (_value.c_str ());       }
00545         const TiXmlNode* NextSibling( const std::string& _value) const          {       return NextSibling (_value.c_str ());   }
00546         TiXmlNode* NextSibling( const std::string& _value)                                      {       return NextSibling (_value.c_str ());   }
00547         #endif
00548
00550         const TiXmlNode* NextSibling() const                            { return next; }
00551         TiXmlNode* NextSibling()                                                        { return next; }
00552
00554         const TiXmlNode* NextSibling( const char * ) const;
00555         TiXmlNode* NextSibling( const char * );
00556
00561         const TiXmlElement* NextSiblingElement() const;
00562         TiXmlElement* NextSiblingElement();
00563
00568         const TiXmlElement* NextSiblingElement( const char * ) const;
00569         TiXmlElement* NextSiblingElement( const char * );
00570
00571     #ifdef TIXML_USE_STL
00572         const TiXmlElement* NextSiblingElement( const std::string& _value) const        {       return NextSiblingElement (_value.c_str ());    }
00573         TiXmlElement* NextSiblingElement( const std::string& _value)                            {       return NextSiblingElement (_value.c_str ());    }
00574         #endif
00575
00577         const TiXmlElement* FirstChildElement() const;
00578         TiXmlElement* FirstChildElement();
00579
00581         const TiXmlElement* FirstChildElement( const char * value ) const;
00582         TiXmlElement* FirstChildElement( const char * value );
00583
00584     #ifdef TIXML_USE_STL
00585         const TiXmlElement* FirstChildElement( const std::string& _value ) const        {       return FirstChildElement (_value.c_str ());     }
00586         TiXmlElement* FirstChildElement( const std::string& _value )                            {       return FirstChildElement (_value.c_str ());     }
00587         #endif
00588
00593         virtual int Type() const        { return type; }
00594
00598         const TiXmlDocument* GetDocument() const;
00599         TiXmlDocument* GetDocument();
00600
00602         bool NoChildren() const                                         { return !firstChild; }
00603
00604         const TiXmlDocument* ToDocument()       const           { return ( this && type == DOCUMENT ) ? (const TiXmlDocument*) this : 0; }
00605         const TiXmlElement*  ToElement() const                  { return ( this && type == ELEMENT  ) ? (const TiXmlElement*)  this : 0; }
00606         const TiXmlComment*  ToComment() const                  { return ( this && type == COMMENT  ) ? (const TiXmlComment*)  this : 0; }
00607         const TiXmlUnknown*  ToUnknown() const                  { return ( this && type == UNKNOWN  ) ? (const TiXmlUnknown*)  this : 0; }
00608         const TiXmlText*           ToText()    const            { return ( this && type == TEXT     ) ? (const TiXmlText*)     this : 0; }
00609         const TiXmlDeclaration* ToDeclaration() const   { return ( this && type == DECLARATION ) ? (const TiXmlDeclaration*) this : 0; }
00610
00611         TiXmlDocument* ToDocument()                     { return ( this && type == DOCUMENT ) ? (TiXmlDocument*) this : 0; }
00612         TiXmlElement*  ToElement()                      { return ( this && type == ELEMENT  ) ? (TiXmlElement*)  this : 0; }
00613         TiXmlComment*  ToComment()                      { return ( this && type == COMMENT  ) ? (TiXmlComment*)  this : 0; }
00614         TiXmlUnknown*  ToUnknown()                      { return ( this && type == UNKNOWN  ) ? (TiXmlUnknown*)  this : 0; }
00615         TiXmlText*         ToText()                     { return ( this && type == TEXT     ) ? (TiXmlText*)     this : 0; }
00616         TiXmlDeclaration* ToDeclaration()       { return ( this && type == DECLARATION ) ? (TiXmlDeclaration*) this : 0; }
00617
00621         virtual TiXmlNode* Clone() const = 0;
00622
00623 protected:
00624         TiXmlNode( NodeType _type );
00625
00626         // Copy to the allocated object. Shared functionality between Clone, Copy constructor,
00627         // and the assignment operator.
00628         void CopyTo( TiXmlNode* target ) const;
00629
00630         #ifdef TIXML_USE_STL
00631             // The real work of the input operator.
00632             virtual void StreamIn( TIXML_ISTREAM* in, TIXML_STRING* tag ) = 0;
00633         #endif
00634
00635         // Figure out what is at *p, and parse it. Returns null if it is not an xml node.
00636         TiXmlNode* Identify( const char* start, TiXmlEncoding encoding );
00637
00638         // Internal Value function returning a TIXML_STRING
00639         const TIXML_STRING& SValue() const      { return value ; }
00640
00641         TiXmlNode*              parent;
00642         NodeType                type;
00643
00644         TiXmlNode*              firstChild;
00645         TiXmlNode*              lastChild;
00646
00647         TIXML_STRING    value;
00648
00649         TiXmlNode*              prev;
00650         TiXmlNode*              next;
00651
00652 private:
00653         TiXmlNode( const TiXmlNode& );                          // not implemented.
00654         void operator=( const TiXmlNode& base );        // not allowed.
00655 };
00656
00657
00665 class TiXmlAttribute : public TiXmlBase
00666 {
00667         friend class TiXmlAttributeSet;
00668
00669 public:
00671         TiXmlAttribute() : TiXmlBase()
00672         {
00673                 document = 0;
00674                 prev = next = 0;
00675         }
00676
00677         #ifdef TIXML_USE_STL
00678
00679         TiXmlAttribute( const std::string& _name, const std::string& _value )
00680         {
00681                 name = _name;
00682                 value = _value;
00683                 document = 0;
00684                 prev = next = 0;
00685         }
00686         #endif
00687
00689         TiXmlAttribute( const char * _name, const char * _value )
00690         {
00691                 name = _name;
00692                 value = _value;
00693                 document = 0;
00694                 prev = next = 0;
00695         }
00696
00697         const char*             Name()  const           { return name.c_str (); }
00698         const char*             Value() const           { return value.c_str (); }
00699         const int       IntValue() const;
00700         const double    DoubleValue() const;
00701
00711         int QueryIntValue( int* value ) const;
00713         int QueryDoubleValue( double* value ) const;
00714
00715         void SetName( const char* _name )       { name = _name; }
00716         void SetValue( const char* _value )     { value = _value; }
00717
00718         void SetIntValue( int value );
00719         void SetDoubleValue( double value );
00720
00721     #ifdef TIXML_USE_STL
00722
00723         void SetName( const std::string& _name )
00724         {
00725                 StringToBuffer buf( _name );
00726                 SetName ( buf.buffer ? buf.buffer : "error" );
00727         }
00729         void SetValue( const std::string& _value )
00730         {
00731                 StringToBuffer buf( _value );
00732                 SetValue( buf.buffer ? buf.buffer : "error" );
00733         }
00734         #endif
00735
00737         const TiXmlAttribute* Next() const;
00738         TiXmlAttribute* Next();
00740         const TiXmlAttribute* Previous() const;
00741         TiXmlAttribute* Previous();
00742
00743         bool operator==( const TiXmlAttribute& rhs ) const { return rhs.name == name; }
00744         bool operator<( const TiXmlAttribute& rhs )      const { return name < rhs.name; }
00745         bool operator>( const TiXmlAttribute& rhs )  const { return name > rhs.name; }
00746
00747         /*      Attribute parsing starts: first letter of the name
00748                                                  returns: the next char after the value end quote
00749         */
00750         virtual const char* Parse( const char* p, TiXmlParsingData* data, TiXmlEncoding encoding );
00751
00752         // Prints this Attribute to a FILE stream.
00753         virtual void Print( FILE* cfile, int depth ) const;
00754
00755         virtual void StreamOut( TIXML_OSTREAM * out ) const;
00756         // [internal use]
00757         // Set the document pointer so the attribute can report errors.
00758         void SetDocument( TiXmlDocument* doc )  { document = doc; }
00759
00760 private:
00761         TiXmlAttribute( const TiXmlAttribute& );                                // not implemented.
00762         void operator=( const TiXmlAttribute& base );   // not allowed.
00763
00764         TiXmlDocument*  document;       // A pointer back to a document, for error reporting.
00765         TIXML_STRING name;
00766         TIXML_STRING value;
00767         TiXmlAttribute* prev;
00768         TiXmlAttribute* next;
00769 };
00770
00771
00772 /*      A class used to manage a group of attributes.
00773         It is only used internally, both by the ELEMENT and the DECLARATION.
00774
00775         The set can be changed transparent to the Element and Declaration
00776         classes that use it, but NOT transparent to the Attribute
00777         which has to implement a next() and previous() method. Which makes
00778         it a bit problematic and prevents the use of STL.
00779
00780         This version is implemented with circular lists because:
00781                 - I like circular lists
00782                 - it demonstrates some independence from the (typical) doubly linked list.
00783 */
00784 class TiXmlAttributeSet
00785 {
00786 public:
00787         TiXmlAttributeSet();
00788         ~TiXmlAttributeSet();
00789
00790         void Add( TiXmlAttribute* attribute );
00791         void Remove( TiXmlAttribute* attribute );
00792
00793         const TiXmlAttribute* First()   const   { return ( sentinel.next == &sentinel ) ? 0 : sentinel.next; }
00794         TiXmlAttribute* First()                                 { return ( sentinel.next == &sentinel ) ? 0 : sentinel.next; }
00795         const TiXmlAttribute* Last() const              { return ( sentinel.prev == &sentinel ) ? 0 : sentinel.prev; }
00796         TiXmlAttribute* Last()                                  { return ( sentinel.prev == &sentinel ) ? 0 : sentinel.prev; }
00797
00798         const TiXmlAttribute*   Find( const char * name ) const;
00799         TiXmlAttribute* Find( const char * name );
00800
00801 private:
00802         //*ME:  Because of hidden/disabled copy-construktor in TiXmlAttribute (sentinel-element),
00803         //*ME:  this class must be also use a hidden/disabled copy-constructor !!!
00804         TiXmlAttributeSet( const TiXmlAttributeSet& );  // not allowed
00805         void operator=( const TiXmlAttributeSet& );     // not allowed (as TiXmlAttribute)
00806
00807         TiXmlAttribute sentinel;
00808 };
00809
00810
00815 class TiXmlElement : public TiXmlNode
00816 {
00817 public:
00819         TiXmlElement (const char * in_value);
00820
00821         #ifdef TIXML_USE_STL
00822
00823         TiXmlElement( const std::string& _value );
00824         #endif
00825
00826         TiXmlElement( const TiXmlElement& );
00827
00828         void operator=( const TiXmlElement& base );
00829
00830         virtual ~TiXmlElement();
00831
00835         const char* Attribute( const char* name ) const;
00836
00843         const char* Attribute( const char* name, int* i ) const;
00844
00851         const char* Attribute( const char* name, double* d ) const;
00852
00860         int QueryIntAttribute( const char* name, int* value ) const;
00862         int QueryDoubleAttribute( const char* name, double* value ) const;
00864         int QueryDoubleAttribute( const char* name, float* value ) const {
00865                 double d;
00866                 int result = QueryDoubleAttribute( name, &d );
00867                 *value = (float)d;
00868                 return result;
00869         }
00870
00874         void SetAttribute( const char* name, const char * value );
00875
00876     #ifdef TIXML_USE_STL
00877         const char* Attribute( const std::string& name ) const                          { return Attribute( name.c_str() ); }
00878         const char* Attribute( const std::string& name, int* i ) const          { return Attribute( name.c_str(), i ); }
00879         const char* Attribute( const std::string& name, double* d ) const       { return Attribute( name.c_str(), d ); }
00880         int QueryIntAttribute( const std::string& name, int* value ) const      { return QueryIntAttribute( name.c_str(), value ); }
00881         int QueryDoubleAttribute( const std::string& name, double* value ) const { return QueryDoubleAttribute( name.c_str(), value ); }
00882
00884         void SetAttribute( const std::string& name, const std::string& _value )
00885         {
00886                 StringToBuffer n( name );
00887                 StringToBuffer v( _value );
00888                 if ( n.buffer && v.buffer )
00889                         SetAttribute (n.buffer, v.buffer );
00890         }
00892         void SetAttribute( const std::string& name, int _value )
00893         {
00894                 StringToBuffer n( name );
00895                 if ( n.buffer )
00896                         SetAttribute (n.buffer, _value);
00897         }
00898         #endif
00899
00903         void SetAttribute( const char * name, int value );
00904
00908         void SetDoubleAttribute( const char * name, double value );
00909
00912         void RemoveAttribute( const char * name );
00913     #ifdef TIXML_USE_STL
00914         void RemoveAttribute( const std::string& name ) {       RemoveAttribute (name.c_str ());        }
00915         #endif
00916
00917         const TiXmlAttribute* FirstAttribute() const    { return attributeSet.First(); }
00918         TiXmlAttribute* FirstAttribute()                                { return attributeSet.First(); }
00919         const TiXmlAttribute* LastAttribute()   const   { return attributeSet.Last(); }
00920         TiXmlAttribute* LastAttribute()                                 { return attributeSet.Last(); }
00921
00923         virtual TiXmlNode* Clone() const;
00924         // Print the Element to a FILE stream.
00925         virtual void Print( FILE* cfile, int depth ) const;
00926
00927         /*      Attribtue parsing starts: next char past '<'
00928                                                  returns: next char past '>'
00929         */
00930         virtual const char* Parse( const char* p, TiXmlParsingData* data, TiXmlEncoding encoding );
00931
00932 protected:
00933
00934         void CopyTo( TiXmlElement* target ) const;
00935         void ClearThis();       // like clear, but initializes 'this' object as well
00936
00937         // Used to be public [internal use]
00938         #ifdef TIXML_USE_STL
00939             virtual void StreamIn( TIXML_ISTREAM * in, TIXML_STRING * tag );
00940         #endif
00941         virtual void StreamOut( TIXML_OSTREAM * out ) const;
00942
00943         /*      [internal use]
00944                 Reads the "value" of the element -- another element, or text.
00945                 This should terminate with the current end tag.
00946         */
00947         const char* ReadValue( const char* in, TiXmlParsingData* prevData, TiXmlEncoding encoding );
00948
00949 private:
00950
00951         TiXmlAttributeSet attributeSet;
00952 };
00953
00954
00957 class TiXmlComment : public TiXmlNode
00958 {
00959 public:
00961         TiXmlComment() : TiXmlNode( TiXmlNode::COMMENT ) {}
00962         TiXmlComment( const TiXmlComment& );
00963         void operator=( const TiXmlComment& base );
00964
00965         virtual ~TiXmlComment() {}
00966
00968         virtual TiXmlNode* Clone() const;
00970         virtual void Print( FILE* cfile, int depth ) const;
00971
00972         /*      Attribtue parsing starts: at the ! of the !--
00973                                                  returns: next char past '>'
00974         */
00975         virtual const char* Parse( const char* p, TiXmlParsingData* data, TiXmlEncoding encoding );
00976
00977 protected:
00978         void CopyTo( TiXmlComment* target ) const;
00979
00980         // used to be public
00981         #ifdef TIXML_USE_STL
00982             virtual void StreamIn( TIXML_ISTREAM * in, TIXML_STRING * tag );
00983         #endif
00984         virtual void StreamOut( TIXML_OSTREAM * out ) const;
00985
00986 private:
00987
00988 };
00989
00990
00993 class TiXmlText : public TiXmlNode
00994 {
00995         friend class TiXmlElement;
00996 public:
00998         TiXmlText (const char * initValue) : TiXmlNode (TiXmlNode::TEXT)
00999         {
01000                 SetValue( initValue );
01001         }
01002         virtual ~TiXmlText() {}
01003
01004         #ifdef TIXML_USE_STL
01005
01006         TiXmlText( const std::string& initValue ) : TiXmlNode (TiXmlNode::TEXT)
01007         {
01008                 SetValue( initValue );
01009         }
01010         #endif
01011
01012         TiXmlText( const TiXmlText& copy ) : TiXmlNode( TiXmlNode::TEXT )       { copy.CopyTo( this ); }
01013         void operator=( const TiXmlText& base )                                                         { base.CopyTo( this ); }
01014
01016         virtual void Print( FILE* cfile, int depth ) const;
01017
01018         virtual const char* Parse( const char* p, TiXmlParsingData* data, TiXmlEncoding encoding );
01019
01020 protected :
01022         virtual TiXmlNode* Clone() const;
01023         void CopyTo( TiXmlText* target ) const;
01024
01025         virtual void StreamOut ( TIXML_OSTREAM * out ) const;
01026         bool Blank() const;     // returns true if all white space and new lines
01027         // [internal use]
01028         #ifdef TIXML_USE_STL
01029             virtual void StreamIn( TIXML_ISTREAM * in, TIXML_STRING * tag );
01030         #endif
01031
01032 private:
01033 };
01034
01035
01049 class TiXmlDeclaration : public TiXmlNode
01050 {
01051 public:
01053         TiXmlDeclaration()   : TiXmlNode( TiXmlNode::DECLARATION ) {}
01054
01055 #ifdef TIXML_USE_STL
01056
01057         TiXmlDeclaration(       const std::string& _version,
01058                                                 const std::string& _encoding,
01059                                                 const std::string& _standalone );
01060 #endif
01061
01063         TiXmlDeclaration(       const char* _version,
01064                                                 const char* _encoding,
01065                                                 const char* _standalone );
01066
01067         TiXmlDeclaration( const TiXmlDeclaration& copy );
01068         void operator=( const TiXmlDeclaration& copy );
01069
01070         virtual ~TiXmlDeclaration()     {}
01071
01073         const char *Version() const                     { return version.c_str (); }
01075         const char *Encoding() const            { return encoding.c_str (); }
01077         const char *Standalone() const          { return standalone.c_str (); }
01078
01080         virtual TiXmlNode* Clone() const;
01082         virtual void Print( FILE* cfile, int depth ) const;
01083
01084         virtual const char* Parse( const char* p, TiXmlParsingData* data, TiXmlEncoding encoding );
01085
01086 protected:
01087         void CopyTo( TiXmlDeclaration* target ) const;
01088         // used to be public
01089         #ifdef TIXML_USE_STL
01090             virtual void StreamIn( TIXML_ISTREAM * in, TIXML_STRING * tag );
01091         #endif
01092         virtual void StreamOut ( TIXML_OSTREAM * out) const;
01093
01094 private:
01095
01096         TIXML_STRING version;
01097         TIXML_STRING encoding;
01098         TIXML_STRING standalone;
01099 };
01100
01101
01109 class TiXmlUnknown : public TiXmlNode
01110 {
01111 public:
01112         TiXmlUnknown() : TiXmlNode( TiXmlNode::UNKNOWN )        {}
01113         virtual ~TiXmlUnknown() {}
01114
01115         TiXmlUnknown( const TiXmlUnknown& copy ) : TiXmlNode( TiXmlNode::UNKNOWN )              { copy.CopyTo( this ); }
01116         void operator=( const TiXmlUnknown& copy )                                                                              { copy.CopyTo( this ); }
01117
01119         virtual TiXmlNode* Clone() const;
01121         virtual void Print( FILE* cfile, int depth ) const;
01122
01123         virtual const char* Parse( const char* p, TiXmlParsingData* data, TiXmlEncoding encoding );
01124
01125 protected:
01126         void CopyTo( TiXmlUnknown* target ) const;
01127
01128         #ifdef TIXML_USE_STL
01129             virtual void StreamIn( TIXML_ISTREAM * in, TIXML_STRING * tag );
01130         #endif
01131         virtual void StreamOut ( TIXML_OSTREAM * out ) const;
01132
01133 private:
01134
01135 };
01136
01137
01142 class TiXmlDocument : public TiXmlNode
01143 {
01144 public:
01146         TiXmlDocument();
01148         TiXmlDocument( const char * documentName );
01149
01150         #ifdef TIXML_USE_STL
01151
01152         TiXmlDocument( const std::string& documentName );
01153         #endif
01154
01155         TiXmlDocument( const TiXmlDocument& copy );
01156         void operator=( const TiXmlDocument& copy );
01157
01158         virtual ~TiXmlDocument() {}
01159
01164         bool LoadFile( TiXmlEncoding encoding = TIXML_DEFAULT_ENCODING );
01166         bool SaveFile() const;
01168         bool LoadFile( const char * filename, TiXmlEncoding encoding = TIXML_DEFAULT_ENCODING );
01170         bool SaveFile( const char * filename ) const;
01171
01172         #ifdef TIXML_USE_STL
01173         bool LoadFile( const std::string& filename, TiXmlEncoding encoding = TIXML_DEFAULT_ENCODING )
01174         {
01175                 StringToBuffer f( filename );
01176                 return ( f.buffer && LoadFile( f.buffer, encoding ));
01177         }
01178         bool SaveFile( const std::string& filename ) const
01179         {
01180                 StringToBuffer f( filename );
01181                 return ( f.buffer && SaveFile( f.buffer ));
01182         }
01183         #endif
01184
01189         virtual const char* Parse( const char* p, TiXmlParsingData* data = 0, TiXmlEncoding encoding = TIXML_DEFAULT_ENCODING );
01190
01195         const TiXmlElement* RootElement() const         { return FirstChildElement(); }
01196         TiXmlElement* RootElement()                                     { return FirstChildElement(); }
01197
01203         bool Error() const                                              { return error; }
01204
01206         const char * ErrorDesc() const  { return errorDesc.c_str (); }
01207
01211         const int ErrorId()     const                           { return errorId; }
01212
01220         int ErrorRow()  { return errorLocation.row+1; }
01221         int ErrorCol()  { return errorLocation.col+1; }
01222
01243         void SetTabSize( int _tabsize )         { tabsize = _tabsize; }
01244
01245         int TabSize() const     { return tabsize; }
01246
01250         void ClearError()                                               {       error = false;
01251                                                                                                 errorId = 0;
01252                                                                                                 errorDesc = "";
01253                                                                                                 errorLocation.row = errorLocation.col = 0;
01254                                                                                                 //errorLocation.last = 0;
01255                                                                                         }
01256
01258         void Print() const                                              { Print( stdout, 0 ); }
01259
01261         virtual void Print( FILE* cfile, int depth = 0 ) const;
01262         // [internal use]
01263         void SetError( int err, const char* errorLocation, TiXmlParsingData* prevData, TiXmlEncoding encoding );
01264
01265 protected :
01266         virtual void StreamOut ( TIXML_OSTREAM * out) const;
01267         // [internal use]
01268         virtual TiXmlNode* Clone() const;
01269         #ifdef TIXML_USE_STL
01270             virtual void StreamIn( TIXML_ISTREAM * in, TIXML_STRING * tag );
01271         #endif
01272
01273 private:
01274         void CopyTo( TiXmlDocument* target ) const;
01275
01276         bool error;
01277         int  errorId;
01278         TIXML_STRING errorDesc;
01279         int tabsize;
01280         TiXmlCursor errorLocation;
01281 };
01282
01283
01364 class TiXmlHandle
01365 {
01366 public:
01368         TiXmlHandle( TiXmlNode* node )                                  { this->node = node; }
01370         TiXmlHandle( const TiXmlHandle& ref )                   { this->node = ref.node; }
01371         TiXmlHandle operator=( const TiXmlHandle& ref ) { this->node = ref.node; return *this; }
01372
01374         TiXmlHandle FirstChild() const;
01376         TiXmlHandle FirstChild( const char * value ) const;
01378         TiXmlHandle FirstChildElement() const;
01380         TiXmlHandle FirstChildElement( const char * value ) const;
01381
01385         TiXmlHandle Child( const char* value, int index ) const;
01389         TiXmlHandle Child( int index ) const;
01394         TiXmlHandle ChildElement( const char* value, int index ) const;
01399         TiXmlHandle ChildElement( int index ) const;
01400
01401         #ifdef TIXML_USE_STL
01402         TiXmlHandle FirstChild( const std::string& _value ) const                               { return FirstChild( _value.c_str() ); }
01403         TiXmlHandle FirstChildElement( const std::string& _value ) const                { return FirstChildElement( _value.c_str() ); }
01404
01405         TiXmlHandle Child( const std::string& _value, int index ) const                 { return Child( _value.c_str(), index ); }
01406         TiXmlHandle ChildElement( const std::string& _value, int index ) const  { return ChildElement( _value.c_str(), index ); }
01407         #endif
01408
01410         TiXmlNode* Node() const                 { return node; }
01412         TiXmlElement* Element() const   { return ( ( node && node->ToElement() ) ? node->ToElement() : 0 ); }
01414         TiXmlText* Text() const                 { return ( ( node && node->ToText() ) ? node->ToText() : 0 ); }
01416         TiXmlUnknown* Unknown() const                   { return ( ( node && node->ToUnknown() ) ? node->ToUnknown() : 0 ); }
01417
01418 private:
01419         TiXmlNode* node;
01420 };
01421
01422
01423 #endif
01424
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: ucp.h Source File

src » pcre

ucp.h

00001 /*************************************************
00002 *     libucp - Unicode Property Table handler    *
00003 *************************************************/
00004
00005 /* These are the character categories that are returned by ucp_findchar */
00006
00007 enum {
00008   ucp_C,     /* Other */
00009   ucp_L,     /* Letter */
00010   ucp_M,     /* Mark */
00011   ucp_N,     /* Number */
00012   ucp_P,     /* Punctuation */
00013   ucp_S,     /* Symbol */
00014   ucp_Z      /* Separator */
00015 };
00016
00017 /* These are the detailed character types that are returned by ucp_findchar */
00018
00019 enum {
00020   ucp_Cc,    /* Control */
00021   ucp_Cf,    /* Format */
00022   ucp_Cn,    /* Unassigned */
00023   ucp_Co,    /* Private use */
00024   ucp_Cs,    /* Surrogate */
00025   ucp_Ll,    /* Lower case letter */
00026   ucp_Lm,    /* Modifier letter */
00027   ucp_Lo,    /* Other letter */
00028   ucp_Lt,    /* Title case letter */
00029   ucp_Lu,    /* Upper case letter */
00030   ucp_Mc,    /* Spacing mark */
00031   ucp_Me,    /* Enclosing mark */
00032   ucp_Mn,    /* Non-spacing mark */
00033   ucp_Nd,    /* Decimal number */
00034   ucp_Nl,    /* Letter number */
00035   ucp_No,    /* Other number */
00036   ucp_Pc,    /* Connector punctuation */
00037   ucp_Pd,    /* Dash punctuation */
00038   ucp_Pe,    /* Close punctuation */
00039   ucp_Pf,    /* Final punctuation */
00040   ucp_Pi,    /* Initial punctuation */
00041   ucp_Po,    /* Other punctuation */
00042   ucp_Ps,    /* Open punctuation */
00043   ucp_Sc,    /* Currency symbol */
00044   ucp_Sk,    /* Modifier symbol */
00045   ucp_Sm,    /* Mathematical symbol */
00046   ucp_So,    /* Other symbol */
00047   ucp_Zl,    /* Line separator */
00048   ucp_Zp,    /* Paragraph separator */
00049   ucp_Zs     /* Space separator */
00050 };
00051
00052 /* For use in PCRE we make this function static so that there is no conflict if
00053 PCRE is linked with an application that makes use of an external version -
00054 assuming an external version is ever released... */
00055
00056 static int ucp_findchar(const int, int *, int *);
00057
00058 /* End of ucp.h */
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5


Crazy Eddies GUI System: ucpinternal.h Source File

src » pcre

ucpinternal.h

00001 /*************************************************
00002 *     libucp - Unicode Property Table handler    *
00003 *************************************************/
00004
00005 /* Internal header file defining the layout of compact nodes in the tree. */
00006
00007 typedef struct cnode {
00008   unsigned short int f0;
00009   unsigned short int f1;
00010   unsigned short int f2;
00011 } cnode;
00012
00013 /* Things for the f0 field */
00014
00015 #define f0_leftexists   0x8000    /* Left child exists */
00016 #define f0_typemask     0x3f00    /* Type bits */
00017 #define f0_typeshift         8    /* Type shift */
00018 #define f0_chhmask      0x00ff    /* Character high bits */
00019
00020 /* Things for the f2 field */
00021
00022 #define f2_rightmask    0xf000    /* Mask for right offset bits */
00023 #define f2_rightshift       12    /* Shift for right offset */
00024 #define f2_casemask     0x0fff    /* Mask for case offset */
00025
00026 /* The tree consists of a vector of structures of type cnode, with the root
00027 node as the first element. The three short ints (16-bits) are used as follows:
00028
00029 (f0) (1) The 0x8000 bit of f0 is set if a left child exists. The child's node
00030          is the next node in the vector.
00031      (2) The 0x4000 bits of f0 is spare.
00032      (3) The 0x3f00 bits of f0 contain the character type; this is a number
00033          defined by the enumeration in ucp.h (e.g. ucp_Lu).
00034      (4) The bottom 8 bits of f0 contain the most significant byte of the
00035          character's 24-bit codepoint.
00036
00037 (f1) (1) The f1 field contains the two least significant bytes of the
00038          codepoint.
00039
00040 (f2) (1) The 0xf000 bits of f2 contain zero if there is no right child of this
00041          node. Otherwise, they contain one plus the exponent of the power of
00042          two of the offset to the right node (e.g. a value of 3 means 8). The
00043          units of the offset are node items.
00044
00045      (2) The 0x0fff bits of f2 contain the signed offset from this character to
00046          its alternate cased value. They are zero if there is no such
00047          character.
00048
00049
00050 -----------------------------------------------------------------------------
00051 ||.|.| type (6) | ms char (8) ||  ls char (16)  ||....|  case offset (12)  ||
00052 -----------------------------------------------------------------------------
00053   | |                                              |
00054   | |-> spare                                      |
00055   |                                        exponent of right
00056   |-> left child exists                       child offset
00057
00058
00059 The upper/lower casing information is set only for characters that come in
00060 pairs. There are (at present) four non-one-to-one mappings in the Unicode data.
00061 These are ignored. They are:
00062
00063   1FBE Greek Prosgegrammeni (lower, with upper -> capital iota)
00064   2126 Ohm
00065   212A Kelvin
00066   212B Angstrom
00067
00068 Certainly for the last three, having an alternate case would seem to be a
00069 mistake. I don't know any Greek, so cannot comment on the first one.
00070
00071
00072 When searching the tree, proceed as follows:
00073
00074 (1) Start at the first node.
00075
00076 (2) Extract the character value from f1 and the bottom 8 bits of f0;
00077
00078 (3) Compare with the character being sought. If equal, we are done.
00079
00080 (4) If the test character is smaller, inspect the f0_leftexists flag. If it is
00081     not set, the character is not in the tree. If it is set, move to the next
00082     node, and go to (2).
00083
00084 (5) If the test character is bigger, extract the f2_rightmask bits from f2, and
00085     shift them right by f2_rightshift. If the result is zero, the character is
00086     not in the tree. Otherwise, calculate the number of nodes to skip by
00087     shifting the value 1 left by this number minus one. Go to (2).
00088 */
00089
00090
00091 /* End of internal.h */
Generated on Sat Nov 26 10:09:55 2005 for Crazy Eddies GUI System by doxygen 1.4.5